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Version 6.03 Release Notes 
For CaptionMaker  

 
 

Installation Instructions  

 CaptionMaker Installation and Activation Instructions: 

http://www.telestream.net/pdfs/quick-starts/MacCaption-and-CaptionMaker-Quickstart.pdf 

 

Installing CaptionMaker over an Older Version 

If you have an older version of CaptionMaker software on your computer, you may need to 
uninstall the software first before installing a new version.  Clean uninstall instructions are 
available in our Knowledgebase.  

If you are captioning the old fashioned way using a hardware encoder & external time 
code interface, before uninstalling the software, make a note of your default configuration: 

 Caption/subtitle device (e.g., Link PDR-885) 

 Comm. or serial port for the above device (e.g., Comm. 1, 1200, N, 8, 1) 

 Time code device (e.g. ACE PCI-TC) 

 Address or serial port for TC device (e.g., 1100) 

Then uninstall the old version and install the new version. Run the new version and reset the 
devices with the old settings.  

 
New Features in Version 6.03 

 CaptionMaker Installer 

A new dialog was added to ask the user whether to install the HASP USB dongle driver 

or not. This driver is not required for Demo mode or software keys (serial numbers). This 

driver is only required if you have a CaptionMaker USB dongle.  If you’re not sure, 

selecting “Yes” is the safest option for most users. 

 Windows 8.1 support 

The CaptionMaker installer now installs the latest version of the HASP USB dongle 

driver (V6.60), which was updated to support Windows 8.1. 

 Word Substitution 

This new feature allows you to search and replace a list of words. Select the "Tools" 

menu "Configure Word Substitution" to define the list of words you want replaced and 

their replacements. Then when you select the "Edit" menu "Word Substitution", 

CaptionMaker will perform a "search and replace all" operation for each word in the list. 

 Paste Options 

A new "Paste Options" item was added to the "Edit" menu that pops up a "Paste 

Options" dialog with a check box to configure CaptionMaker to "always break up pasted 

text into multiple cells". 

http://www.telestream.net/pdfs/quick-starts/MacCaption-and-CaptionMaker-Quickstart.pdf
http://www.telestream.net/telestream-support/captioning/knowledgebase/
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This new feature allows you to change how CaptionMaker handles inserting text pasted 

into a Caption/Subtitle cell. Normally, if the inserted text is 4 lines or less then all the text 

is pasted into the selected cell, and if the inserted text is more than 4 lines then the text 

is broken up into multiple cells. The new option, when checked, forces CaptionMaker to 

always treat the pasted text as if it were more than 4 lines long. 

 SMPTE-TT/MAGIC-TT Import/Export 16x9 Mode 

A new option was added to select 4x3 or 16x9 mode for SMPTE-TT/MAGIC-TT 

import/export. Not all TTML players treat aspect ratio the same way.  When exporting, 

this option defines whether to pad (pillar box) the exported subtitles for a 16x9 screen. 

When importing, this option defines whether the subtitles being imported were formatted 

for a 4x3 or 16x9 screen.  If you want to keep the default behavior of previous versions 

of CaptionMaker, select the 4x3 option. 

 Command Line 

The following new parameters were added: 

o /SmpteTt16x9=N 

o /Semicolon=N 

o /ImportStartTimeCode=timecode 

 Batch Mode 

A new export configuration item was added to the Batch Mode dialog to allow you to 

specify the colon or semicolon format for the exported time code values when exporting 

CC/SCC files. 

 QCC Multi-format Import 

This import function was enhanced to support importing DVD-style captions from MPEG-

2 elementary, program, and transport streams. 

 MXF Export 
A change was made to use unique file names for all temp files used during the MXF 
export process - to prevent conflicts when running multiple instances of CaptionMaker in 
command line mode. 
 

 Sonic Producer Text Export 
The export dialog to select colon or semicolon time code formatting was enabled for the 
Sonic Producer Text export. 

Fixed in Version 6.03 

 Optimizations to improve UI responsiveness 
Several editing functions were optimized to reduce “lag” and improve the 
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responsiveness of the UI under certain conditions. 
 

 Time Code Column Widths 
The widths of the time code columns are now user adjustable, to improve compatibility 
when Windows is configured to use large fonts (high DPI mode). 
 

 Batch Convert Mode 
A bug was corrected in the Batch Mode dialog that was accidentally limiting the number 
of input files you could select at the same time. 
 

 Web Exports 

A bug was corrected that was causing some Web Exports with ".fraction" formatted time 

code values to be incorrectly exported with ":frames" format. The problem was in the 

following exports: 

o SubRip 

o Google/YouTube 

o WebVTT 

o DFXP XML 

Also, a bug was corrected in the calculations for real-time time code values that was 

occasionally causing some invalid time code values such as 1000ms to be exported.  

 Web Imports 

A bug was corrected that was causing some web files with CRLF line terminators to not 

import correctly. 

 PAC File Import 

A bug was corrected with importing PAC files with PAL or FILM time code values 

(CaptionMaker was accidentally always defaulting to NTSC drop frame). 

 Print Preview 
A bug was corrected that would sometimes cause CaptionMaker to crash when selecting 
Print Preview. 
 

 Quick Start Guide 
A bug was corrected that was causing the Help menu "Quick Start Guide" item to not 
work for some users. 

New Features in Version 6.02 

 Command Line Interface (CLI) 

The following import types are now enabled on CLI: 

o MacCaption MCC (*.mcc) 
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o PAC Subtitle File (*.pac) 

o EBU-STL (*.stl) 

A new CLI parameter was added: /NoDemo=1.  This causes CaptionMaker to quit 
instead of starting in Demo mode, if a license (dongle/serial) was not found. 

 Online Licensing 

A change was implemented to save one serial number for all users of the computer 

(previously the serial number was saved separately for each user). Note that saving the 

serial number now requires administrator permission and causes the Windows User 

Access Control dialog to appear.  Each user still must activate the license on their 

account.   

 

Additionally, this version now supports temporary serial numbers for evaluations. 

 Flash XML and Mijo XML DFXP Exports 

An improvement in the horizontal positioning was made to these exports: they now 

"snap" to left/right.  

 Auto Time Stamp 
Some additional WMA audio codecs were added. 

 New Export: MPEG-2 Userdata 608/708 Captions 
This export is similar to the “ATSC DTV 608/708 MPEG-2” export, but in many cases is 
faster and it supports more file types.  Please see our knowledgebase for more info. 

 
Fixed in Version 6.02 

 Web/Mobile Imports/Exports - Timing correction 

For all web/mobile Imports and Exports (all file types that use "real time" time values 

instead of SMPTE video time codes), a correction was applied to properly convert 

between caption SMPTE Non-drop frame or SMPTE 24.0 video time codes to “real time” 

time values. 

o SMPTE-TT 

o MAGIC-TT 

o WebVTT 

o Google/YouTube 

o SubRip 

o Windows Media Player 

o PBS COVE 

o Flash XML in Timed Text Authoring Format DFXP 

o Mijo XML 

http://www.telestream.net/telestream-support/captioning/knowledgebase/
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o QuickTime text 

o RealPlayer 

Note that the video frame rate value defaults to 29.97 fps when drop frame or non-drop 

frame time code is selected, 23.98 fps when film time code is selected, and 25 fps when 

PAL time code is selected. If a video file is loaded into CaptionMaker then the video 

frame rate value instead defaults to the "Video File Frame Rate" setting in the "Video 

Settings" dialog. 

For most cases the default value is correct and requires no attention by the user. But 

there are several cases when the default value will be incorrect and must be corrected 

by the user. For example, if the associated video file is 24.0fps (not 23.976 or 23.98 fps), 

and the video file is not loaded into CaptionMaker, then the video frame rate must 

manually be set to 24.0 fps in the import/export options dialog. 

 DFXP Style File on CLI 

A bug was corrected that could cause an error if multiple CaptionMaker CLI instances 

tried to access the same DFXP style file simultaneously. 

 

New Features in Version 6.0 

 Online License Purchasing 

Support was added for online licensing. You may now purchase a serial number online 

or use a HASP protection device to activate CaptionMaker. A new "Manage 

CaptionMaker License" item was added to the Help menu to facilitate purchasing, 

activating, and deactivating serial numbers. 

 Open Movie 

A new "Open Movie" item was added to the File menu that opens the Video Properties 

dialog. 

 Import/Export Groups Reorganized 

The grouping of the import and export file types has been reorganized. The new import 

groups are: 

o Text Documents (formerly "Word Processor")  

o TV Caption files (formerly "Caption Formatted")  

o Subtitle Files (formerly "DVD/DV2000 Subtitle")  

o Web Caption Files (formerly "Webcast")  

o Extract From Video (formerly "DV", "NLE", and "HD")  

The new export groups are: 

o Text Documents (formerly "Word Processor")  

o TV Caption files (formerly "Caption Formatted")  
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o Subtitles (formerly "DVD/DV2000 Subtitle")  

o Web Caption Files (formerly "Webcast")  

o Embed Into Video (formerly "DV", "NLE", and "HD")  

 Drag and Drop 
More file types are now recognized when dropped onto the editing grid. The extensions 
that were added are .mcc, .pac, .vtt, .mxf, .mov, .mp4, .mpg, .ts, .m2t, .mpeg, and .m2v. 

 Main Toolbar 

Copies of the "Top" and "Bottom" buttons were added to the main toolbar. 

 Caption Center TDS file Import 

This import was improved to handle all types of line termination (CR, LF, or CRLF). 

Previously, TDS files with LF line terminators would not import properly. 

 Customize Keystrokes 

The file containing the keystroke settings (CapKeyMap.dat) has been relocated. It is now 

stored in each user's "Documents" folder. The old location was in the "Program Files" 

folder with the CaptionMaker executable (CapMaker.exe). 

Now each user of the computer has their own keystroke settings file. The old keystroke 

settings file location forced all users of the computer to share one keystroke settings file. 

This change also solves the security problems associated with storing the keystroke 

settings file in the "Program Files" folder (which some users are not allowed to access). 

 Auto Time Stamp 

Auto Time Stamp is now available in all CaptionMaker versions. 

 
Fixed in Version 6.0 

 MXF File Export 

A bug was corrected that, for particular MXF files, was causing the caption data KLV to 

be inserted after the first audio track KLV instead of after the last audio track KLV. 

 PAC File Import 

A bug was corrected that was sometimes causing some text to be lost during the import 

operation. 

 SCC Export 

A bug was corrected that was, under certain circumstances, causing the last letter of a 

caption line to be lost. 

 QCC Multi-Format Input 
Fixed a line 21 decode issue with uncompressed 10-bit video. 
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 H.264 SEI 608/708 Export 
Fixed a bug when using an mp4 source file and the video track is not the first track. 
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Documentation and Support  

 MacCaption and CaptionMaker Quick Start Guide: 

http://www.telestream.net/pdfs/quick-starts/MacCaption-and-CaptionMaker-Quickstart.pdf 

 MacCaption and CaptionMaker Product Feature Comparison web page: 

http://www.telestream.net/captioning/compare.htm 

 Captioning Products Brochure (for MacCaption and CaptionMaker): 

http://www.telestream.net/pdfs/brochures/bro-captioning.pdf  

 Knowledge Base: 
Telestream has a number of new documents for troubleshooting and also for the latest 

features at http://www.telestream.net/telestream-support/captioning/knowledgebase/  

 

System Requirements 

Minimum Requirements 

 Intel Pentium or AMD Athlon or equivalent processor 

 1GB RAM (Windows XP), 2GB RAM (Windows Vista/7/8) 

 5GB free Hard Disk space 

 One free USB port (if using a dongle) 

 Supported Operating Systems: 

 Windows XP SP3 Home/Professional edition (32-bit only) 

 Windows Vista SP1 (32/64-bit) 

 Windows 7 (32/64-bit) 

 Windows 8 (32/64-bit) 

 Internet access required for some online features 

 Auto Time Stamp requires 2GB RAM and Java Version 6 (JRE 1.6) or higher 
 

Recommended System 

 Dual core processor (Intel Core series or AMD Athlon X2 series or later) 

 1.8GHz or faster Processor Speed 

 2GB RAM or higher 

 10GB free Hard Disk space 

 
 

http://www.telestream.net/pdfs/quick-starts/MacCaption-and-CaptionMaker-Quickstart.pdf
http://www.telestream.net/captioning/compare.htm
http://www.telestream.net/pdfs/brochures/bro-captioning.pdf
http://www.telestream.net/telestream-support/captioning/knowledgebase/
http://cpcweb.com/ats/
http://www.java.com/en/download/

