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Limited Warranty and Disclaimers
Telestream, LLC. warrants to you, as the original licensee only, that the software you licensed will perform
as stated below for a period of one (1) year from the date of purchase of the software by you:
The software will operate in substantial conformance with its specifications as set forth in the applicable
product user's guide/published specifications/product description. Telestream's sole liability under this
Limited Warranty shall be to use reasonable commercial efforts to bring the Software's performance into
substantial conformance with the specifications in the applicable product user's guide/ published
specifications/product description.
FlipFactory and Vantage in their various editions have been designed for professionals skilled in the art of
digital media transformation and workflow automation, to facilitate the automation of complex media
operations and workflow that require a multitude of input and output media formats, delivery to numerous
types of media devices and file systems, and notification of media systems.
The FlipFactory and Vantage architectures and user interfaces are designed to provide maximum flexibility
in the setup and configuration of these complex media transformations and workflow. In providing this
high degree of flexibility, it is possible for media transformation and workflow processes to be configured
that are impractical, likely to result in unexpected or unintended results, or beyond the limits of FlipFactory
or Vantage to perform satisfactorily. Additionally, FlipFactory or Vantage may be executed on a platform
that lacks the performance or capacity to perform the media transformations and workflow you've
configured, which is your responsibility to specify. Telestream has chosen to implement FlipFactory and
Vantage to provide the greatest flexibility without limiting its functionality to only those transformations
and workflow that are known with certainty to be within its performance capabilities, including those
limits imposed by the platform upon which you have installed FlipFactory or Vantage.
Therefore, you acknowledge that you may create transformations and workflow that are impractical or
beyond your product installation's limits, and Telestream does not warrant that each transformation or
workflow you specify or use will complete without error.
Limitations of Warranties. EXCEPT AS EXPRESSLY SET FORTH IN SECTION 1 ABOVE, NO
OTHER WARRANTY, EXPRESS OR IMPLIED, IS MADE WITH RESPECT TO THE SOFTWARE,
INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTY OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT OF THIRD PARTY RIGHTS
AND THOSE ARISING FROM A COURSE OF DEALING OR USAGE OF TRADE. NO WARRANTY
IS MADE THAT USE OF THE SOFTWARE WILL BE ERROR FREE OR UNINTERRUPTED, THAT
ANY ERRORS OR DEFECTS IN THE LICENSED MATERIALS WILL BE CORRECTED, OR THAT
THE SOFTWARE'S FUNCTIONALITY WILL MEET YOUR REQUIREMENTS.
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Preface

SUPPORT AND INFORMATION
For assistance or information about Telestream or its products, please
contact us via any of these methods:

Internet

Web Site. www.telestream.net
Technical Support. support@telestream.net
Licensing. license@telestream.net
Sales and Marketing. info@telestream.net

USA Telephone

Main. (530) 470-1300
Support Services. (877) 257-6245 from 6 am to 6 pm weekdays,
excluding U. S. holidays. Terms and times of support services vary, based
on the terms of your current service contract with Telestream.

Mail

Telestream, LLC.
848 Gold Flat Road-Suite 1
Nevada City, CA. USA 95959

International

See our Web site for your regional authorized Telestream distributor.

WE'D LIKE TO HEAR FROM YOU!
If you have comments or suggestions about improving this document, or
other Telestream documents – or if you've discovered an error or
omission, please email us at techwriter@telestream.net.
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HOW TO USE THIS GUIDE
This guide provides installation instructions for GraphicsFactory®, helps
you get up and running quickly, and gain a high-level understanding of
how GraphicsFactory works with FlipFactory and Vantage.
You may view or print this guide with Adobe Acrobat Reader.
You can also access this guide by selecting Start > Programs > Telestream
> GraphicsFactory > GraphicsFactory User’s Guide.
This guide contains the following chapters:
Chapter 1, Introduction to GraphicsFactory
This chapter describes GraphicsFactory and how to get up and running
quickly.
Chapter 2, Installing GraphicsFactory Tools
This chapter describes how to download and install the GraphicsFactory
Template Creator and Submit tool. It also describes how to obtain and
install your license to use GraphicsFactory.
Chapter 3, Guided Tours
This chapter offers guided tours of GraphicsFactory. In the first tour, you
learn about the architecture and components of GraphicsFactory – how it
is organized and how it works.
In tour 2, you’ll launch GraphicsFactory Template Creator and explore
the components of a GraphicsFactory template.
In tour 3, you’ll learn how to build your own template to produce a media
file with overlay graphics. You’ll also learn about different
GraphicsFactory workflows and advanced features.
Chapter 4, Using GraphicsFactory in FlipFactory
This chapter describes how to use FlipFactory’s GraphicsFactory Process/
Analyze filter and GraphicsFactory product filter, and describes various
workflows and the factory configurations to support GraphicsFactory
transcoding.
Chapter 5, Using GraphicsFactory in Vantage
This chapter describes using the GraphicsFactory filter in Vantage, and
describes workflow configurations that apply GraphicsFactory templates.

About-2

February 2016

178729

NOTATIONAL CONVENTIONS
The guide uses certain conventions used to make the guide more readable.

Notes, Tips &
Cautions

Three special paragraphs are set in particular type with an icon to gain
your attention in special circumstances:

Note
Notes highlight important information about the topic you’re
studying. Be sure to read this information before continuing.

Tip
Tips are bits of information you might not be aware of, or that make
using GraphicsFactory easier.

Caution
A caution paragraph indicates an action that may cause
potential loss of data, or other permanent changes to
GraphicsFactory or your media assets.

TYPOGRAPHICAL CONVENTIONS
Certain typographical conventions are used as visual clues in this guide.
Sample information, or information that should be entered in a specific
format or pattern, is shown in italics. For example:
Type your domain (mydomain.com) in the Web Site Address field,
without using the http:// prefix.
Specific text strings or commands that must be entered exactly as shown,
are displays in a keyboard or courier-style font. For example:
At command prompt, type import FileName where FileName is
the fully-qualified path of the file in drive-letter format, including the
name of the file including the suffix.
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Introduction to
GraphicsFactory

WELCOME TO GRAPHICSFACTORY!
GraphicsFactory® is a template-based graphics and audio overlay system
that you can use to quickly and efficiently create video with text, image,
movie, and sound overlays automatically during transcoding jobs.
GraphicsFactory is available for use with both Vantage and FlipFactory.
With GraphicsFactory, you can:
1.

Create a GraphicsFactory template using the GraphicsFactory
Template Creator

2.

Design factories in FlipFactory or workflows in Vantage that use
the GraphicsFactory template, dynamically applying graphics or
audio as desired to your media

3.

Submit media files or SDK jobs to automatically process content.

Both Vantage and FlipFactory require a GraphicsFactory license in order
to use GraphicsFactory.

UP AND RUNNING
To install GraphicsFactory tools and get up and running quickly,
Telestream recommends the following steps:

February 2016

Step 1

Use “Installing GraphicsFactory Tools” on page 2–1 to install
GraphicsFactory tools on your workstations, and obtain GraphicsFactory
licenses from Telestream and install them.

Step 2

Take the guided tours in Chapter 3 “Guided Tours” on page 3–1. In about
an hour, you’ll learn how GraphicsFactory works and its components.
You’ll also learn how to use the GraphicsFactory Template Creator to
create templates

1-1
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Step 3
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Use Chapter 4 “Using GraphicsFactory in FlipFactory Workflows” on
page 4–1 or Chapter 5 “Using GraphicsFactory in Vantage” on page 5–1
as a reference when building FlipFactory factories or Vantage workflows
for transcoding your video with overlays, and submitting jobs for
GraphicsFactory processing.
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Installing GraphicsFactory
Tools
Use this chapter to download the GraphicsFactory® Tools installer which
installs the GraphicsFactory Template Creator and the GraphicsFactory
Submit tool. This chapter also describes how to obtain and update your
FlipFactory or Vantage server license to enable GraphicsFactory.

Topics



Platform Requirements (page 2-1)



Downloading the GraphicsFactory Tools Installer (page 2-1)



Installing GraphicsFactory Tools (page 2-2)



Obtaining and Installing the GraphicsFactory License (page 2-3)

PLATFORM REQUIREMENTS
GraphicsFactory tools are compatible with these operating systems:
 Windows 7
 Windows 2003 Server and 2008 Server

DOWNLOADING THE GRAPHICSFACTORY TOOLS INSTALLER
To obtain the installer from the Telestream Web site, follow these steps:
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Step 1

Using your Web browser, go to www.telestream.net. Click Downloads,
and under Enterprise Products > FlipFactory or Enterprise Products >
Vantage, and click the Download link.

Step 2

If you’re not registered, click Create an Account. Complete the form and
click Create Account to display the GraphicsFactory Download page.
(Telestream will email you a confirmation email.)

Step 3

Log in using your authorized user name and password, then click Log In.

2-1
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On the Download page, click the current GraphicsFactory link to run (or
save and run locally) the GraphicsFactory installer.

INSTALLING GRAPHICSFACTORY TOOLS
When you run the GraphicsFactory installer, it performs the following:


Creates a Telestream/GraphicsFactory directory
 Installs the GraphicsFactory Template Creator, Submit tool, and
related files (DLLs, PDFs, etc.), along with samples
 Creates Telestream > GraphicsFactory > GraphicsFactory Template
Creator and Submit Tool entries in the Start > Programs list.

Upgrading
GraphicsFactory Tools
Step 1

Make sure that Template Creator and Job Submit tool are not running.

Step 2

Click Start > Control Panel > Add or Remove Programs and select
GraphicsFactory Creator.

Step 3

Click Remove to uninstall the GraphicsFactory tools. This action does not
remove your templates or any media.

Installing
GraphicsFactory Tools

2-2

If you are using previous versions of GraphicsFactory tools, uninstall the
them before installing the current version:

To install the GraphicsFactory tools, follow these steps:

Step 1

Run the GraphicsFactory installer (locally or from a server) and follow
the steps in the installer:

Step 2

The installer runs and displays the Welcome window:

Step 3

Welcome Window. In the Welcome window, click Next to display the
License panel.

Step 4

License Terms. Click Yes if you agree to license terms. Click Next to
continue.

Step 5

Customer Information. Enter your user name and organization
information, check Anyone or Only Me for using this application and
click Next.

Step 6

Destination Folder. Accept the default folder or click Change to select an
alternate folder. Click Next to install the tools.

Step 7

Installation Wizard Completed. Click Finish to exit the wizard.
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OBTAINING AND INSTALLING THE GRAPHICSFACTORY LICENSE
Before you can begin using GraphicsFactory in FlipFactory or Vantage,
or take the tours in the GraphicsFactory User’s Guide, you must obtain
and install a GraphicsFactory license from Telestream.

Note
You can download and install GraphicsFactory tools without a
license. However, you cannot perform GraphicsFactory
processing or use the Template Creator without a license.
To use GraphicsFactory for evaluation, please send the
licensing group an email request (see Support and Information
in About This Guide).

Obtain the License

If you are evaluating GraphicsFactory, your license enables all of
GraphicsFactory’s features, and expires on the date shown in the feature
section at the bottom of the email (usually 15 days from its start date).
When you register with Telestream to download GraphicsFactory,
Telestream verifies your customer information and emails you a no-cost
demo license file, usually within one business day of registering. Demo
licenses cause a watermark to be burned in output media during
transcoding.
If you are a current Telestream customer, log on to the Telestream Web
site download page at http://dynamic.telestream.net/downloads/
downloads.asp and click Obtain License to request a license file for
GraphicsFactory for use with FlipFactory or Vantage.
If you are using GraphicsFactory with FlipFactory or Vantage, you’ll
receive a license.dat file that enables GraphicsFactory Template Creator.
Installation varies, depending on where you install the GraphicsFactory
Template Creator (see below).

Note
If you are using GraphicsFactory with Vantage, you’ll also
receive a GraphicsFactory option license that you’ll use to
update your Vantage server. For details, see the Vantage User’s
Guide.

February 2016
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Installing the
License on a
Workstation

If you installed GraphicsFactory tools on a computer that is not hosting
FlipFactory, follow these instructions to install the license:
(If you installed GraphicsFactory tools directly on a FlipFactory server,
proceed to Install or Update a FlipFactory Server License.)

Step 1

Place the attached license.dat file in the GraphicsFactory License folder
(default C:\Program Files\Telestream\GraphicsFactory\License).

Step 2

Run the GraphicsFactory Template Creator to validate that your license is
correct and is stored in the correct folder. If the Template Creator can’t
locate the license file or it is not a valid GraphicsFactory license,
Template Creator displays a dialog to notify you of the problem.

Install or Update a
FlipFactory Server
License
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If you installed GraphicsFactory tools on a FlipFactory server, you need
to install or update the license in the FlipFactory license folder.
When you receive the GraphicsFactory License File email, follow the
steps in the email to install or update the license on each FlipFactory
server you’ve licensed for GraphicsFactory:

Step 1

Place the attached license.dat file in the FlipFactory license folder
(default C:\Program Files\Telestream\FlipFactory\License).

Step 2

Restart your server before processing any jobs.
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Guided Tours

GraphicsFactory is a template-driven, file-based graphics workflow
automation and assembly system. GraphicsFactory allows you to
assemble layers of images, QuickTime movies, text, audio files, and other
elements, apply timeline effects, and merge the resulting graphics and
audio into your video files during job processing.
The tours in this chapter will help you understand the concepts and
features of GraphicsFactory.
Tour 1 describes GraphicsFactory components, how GraphicsFactory
works. In Tours 2 and 3, you'll explore how to use the tools to create and
apply graphics and how to submit GraphicsFactory jobs for processing.

Tours



[Tour 1] GraphicsFactory Introduction (page 3-2)



[Tour 2] Exploring a GraphicsFactory Template (page 3-6)



[Tour 3] Creating a GraphicsFactory Template (page 3-15)

Note
The file references in these tours assume you’ve installed
GraphicsFactory in the default directory and your
GraphicsFactory tools are on the GraphicsFactory server.

February 2016
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[TOUR 1] GRAPHICSFACTORY INTRODUCTION
In this tour, you’ll become familiar with the concepts of GraphicsFactory
and its design tool – Template Creator.

Concepts

GraphicsFactory enables editors to quickly and easily configure and
assemble text, drop shadows, images, audio overlays, and QuickTime
movies in a template.
GraphicsFactory is integrated directly into Vantage and FlipFactory's
transcode engine which automates media file transfer and exchange in a
wide variety of workflows and formats.
These templates permit spatial positioning on the video frame and
temporal placement on a timeline. Templates can be produced for a single
job to produce video with graphics overlays. Or, you can mark properties
of video or audio layers as dynamic, or “fill in the blank”, and submit
several jobs – each with different values (images or text, for example) on
different baseline video files.
After a template is built, it can be submitted to Vantage or FlipFactory by
various methods, along with the video to transcode the sources into an
overlay video to meet your format and specifications.
Three key concepts are fundamental to understanding GraphicsFactory:
layers, timeline effects, and variables. These concepts are demonstrated in
the remaining tours.
Layers
A layer in GraphicsFactory is a single video or audio overlay element
element, such as an image, text, audio overlay, QuickTime movie, etc.
You can have multiple layers in a GraphicsFactory template. Each layer
has its own properties – for example, text has properties including font,
color, position, and the actual value of the text – the specific words that
display on the output.
Layers are ordered, meaning that, similar to a stack of slide
transparencies, each layer can be positioned either on top of or below
other layers. Each visual layer also has varying opacity – it can be
completely opaque (hiding everything underneath its element) –
completely clear (rendering its element invisible) or anywhere in
between. You also can control each audio layers loudness, from 0%
(silent) to 400% (4 times louder than the original).
Timeline Effects
GraphicsFactory allows you to apply timeline-based (temporal) effects to
layers, such as, “Fade in an image at this time”. Each effect is associated
with a point in time. Effects include the ability to fade layers in and out, or

3-2
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(for QuickTime and audio layers) the ability to start and stop the layer’s
media at specific times. Effect times can be relative to each other, such as,
“Fade in this image two seconds before fading in this text”.
Variables
Almost all properties of layers or effects can be controlled through the use
of variables. A variable is a changeable (or dynamic) property of a layer
or effect whose value is provided while the template is being applied. Said
differently, if you mark a layer property as a variable, this allows you to
"fill in the blank" for each job when the job is submitted for processing.

Note
Almost all layer properties can be controlled through the use of
variables. For example, you can use variables to control the text
to display, image positions, fade-in and fade-out times, etc.
For example, a template might specify the font, color, and position of text
you want to display, but the template uses a variable to identify a holder
for the actual text. By filling in the value of this text variable each time
you submit a job for processing, the same template can be re-used on
different videos, with a different overlay for each video.
Variables allow you to generalize a template. Variables allow you to reuse the same template for more than one job, without having to re-build
the entire template. This reduces design labor and makes templates
broadly applicable to a workflow. You don't need to use variables, but
they are a powerful way to avoid doing everything “by hand” for each
input file. For an example of how to use variables, see Tour 3.
Variables can be mixed with actual numbers and time code values in a
formula, using + and - arithmetic operators. For example, you can specify
a timeline effect by specifying $starttime + 00:00:03:00@29.97 $end_of_movie - $credit_length.
You can also specify the X or Y location of elements. For example, for
property value $bottom - 20 allows the position of elements to change
with each file.
Finally, you can use variable arithmetic when supplying filenames for
overlays. For example: “C:\images\” + $OVERLAY_FNAME + “.jpg”.
Be sure to use arithmetic with proper types. In integer fields, only perform
arithmetic on integers; in timecode fields, just use timecode values. For
filenames, be sure to wrap any non-variable parts of the filename with
quotes. For example: “C:\Documents and Settings\”+$FILENAME. If
you are not using variables, you don’t need quotes.

February 2016
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GraphicsFactory includes a a template design tool – Template Creator –
for use with both FlipFactory and Vantage.
Template Creator is a Windows application that allows you to design and
create graphics templates used to control how the video is generated. You
can install the Template Creator directly on your FlipFactory or Vantage
server, or you can install it on another Windows computer – an editor’s
workstation, for example – on the same network.
Figure 3–1. Use the Template Creator to create templates

GraphicsFactory templates are XML documents that contain the
specifications for how video and audio layers are overlaid on your output
video, as specified using this creation tool.
You use the Template Creator to add graphics and audio elements and
determine where they display on the video, plus other attributes (size,
transparency, loudness). You also specify when they are visible or audible
and when they disappear or become silent. Some graphic elements are
files – raster images, for example. Others are just specifications of
elements including text and darken regions, that are to be rendered when
your job is processed.
You don’t specify the original input media in the Template Creator. The
underlying media file is specified at job submission time. By keeping the
underlying video and audio separate from the template, you can re-use the
template in various workflows, with any media that you want.

GraphicsFactory
Workflow

3-4

In order to process GraphicsFactory jobs, first you create a factory in
FlipFactory or create a workflow in Vantage. In either case, you specify
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one or more output formats, and optionally, one or more GraphicsFactory
templates, depending on your workflow requirements.
Each job you submit for processing has several components:


The GraphicsFactory template, which specifies layers and effects



Optionally, GraphicsFactory variables which the operator (or in
Vantage, the workflow itself) uses to “fill in the blanks” of the
template. In Vantage, these may be linked directly to Vantage
variables.



Optionally, links to one or more images, audio, and movies which
form the composite layers



The baseline video file upon which the elements are applied

These components may be provided in various ways. You’ll learn more
about building templates with Template Creator in Tours 2 and 3.
All elements in a template – typically movies and images – must be
accessible by the FlipFactory or Vantage server that is actually
performing the transcode. If you are working directly on the transcoding
server (localhost) to create a template and submit the job, then this
typically isn't an issue. However, if you are working on a LAN then you
must make sure that all necessary files are network-accessible, and that
GraphicsFactory has sufficient permissions to access those files. Details
about how to attach network-accessible images and movies are provided
in “File Paths and Authentication” on page 3–11.
The baseline media is the underlying foundation upon which
GraphicsFactory elements are rendered. Your transcoding server can
ingest and decode over a hundred different video formats. There is no
specific requirement as to which format you use for your input baseline
media.
In FlipFactory, factories are configured by you to determine where video
files should be imported from, how they should be processed, what output
formats are required, and how the outputs should be delivered. You can
find more information about setting up Factories in your FlipFactory
User’s Guide. Aspects of factory settings which are specific to
GraphicsFactory are discussed in “Using GraphicsFactory in FlipFactory
Workflows” on page 4–1.
In Vantage, workflows are configured by you to determine where video
files should be imported from, make decisions about what to do with
them, generate variables automatically, what output formats are required,
and where they should be delivered.
You can find more information about building workflows in the Vantage
User's Guide. Aspects of workflow design which are specific to Vantage
are discussed in “Using GraphicsFactory in Vantage” on page 5–1.
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[TOUR 2] EXPLORING A GRAPHICSFACTORY TEMPLATE
This tour takes about twenty minutes, and acquaints you with the
Template Creator, using a sample GraphicsFactory template.

Note
Before you can participate in this tour, you should have installed
the GraphicsFactory Template Creator.

Start the Template
Creator

To begin, run the GraphicsFactory Template Creator.
Click start > programs > Telestream > GraphicsFactory >
GraphicsFactory Template Creator.
When Template Creator starts, it displays the main window:
Figure 3–2. Main Window of GraphicsFactory Template Creator

Recall from Tour 1 that the Template Creator’s main window
(<HT_Blue>Figure 3–2) has a menu bar at the top, and a toolbar of
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frequently-used commands. There are other windows as well; you’ll view
these later in the tour.

Note
Online help for GraphicsFactory Template Creator provides
specific details about each window, menu, and feature. To
access online help click Help > Contents.
Directly below the toolbar on the left is the layer list (which is currently
empty except for the master audio layer, because you just opened it). For
each layer you create, an entry is made in this list. The list is displayed
ordinally, with the highest element in the layer stack at the top of the list.
You can re-order layers in the list.
To the right is the timeline, which provides both an ordinal and temporal
view of element layers and their effects. The timeline displays tick marks
horizontally, and layers you’ve created vertically.

Open a Template

Next, open an example template we’ve already built for you.
Click File > Open Template to display the Open Template dialog.
Figure 3–3. Open template in Template Creator

Browse to C:\Program Files\Telestream\GraphicsFactory\Tour Examples,
and open Tour2_GF_Template.xml.

Explore the Main
Window

February 2016

With the template open in the main window, the element layers are
displayed on the left, and the timeline is displayed on the right. For this
tour, don’t make any changes to settings in the template (except for
updating relative file paths, as instructed below).
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Figure 3–4. Main window with open template

To start, click on each menu in the menubar: File, Layer, Timeline,
Windows, and Help. Use the File menu to create, open, and save
templates. The Layer menu allows you to add new layers and re-order
them. Use the Timeline menu to set a frame rate for this template.
The Windows menu enables you to display the other windows in
Template Creator: Variable Editor, Template Preview window, and the
Layer Effects Editor.
Below the toolbar on the left, each element in this template is displayed –
one per layer. Each element has a name and type, plus a Visible and
Locked checkbox.
Figure 3–5. Layer list entries

When selected, a layer displays as depressed. You can re-order the
selected layer by repeatedly selecting Layer > Move Up or Move Down
(or clicking the Move Up or Move Down icons in the toolbar).
To delete a layer, select it and select Layer > Delete (or click the red X in
the toolbar).
Next, display a layer properties dialog to learn about some of these
settings and configurations. Double-click the top layer (Text - Up next),
which is a text layer.
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Figure 3–6. Layer properties vary by type

DaNow, explore the other layer types – don’t check any boxes or make
other changes though. For example, open the Image layer and the QT
Movie layer property dialogs and review the various properties, then
close them by clicking the Cancel button.

Layer Types

The Template Creator provides the following layers:
Image Layer
An image layer is a raster image in JPG, PNG, BMP, TIF or TARGA
format, plus size and position information, and opacity.
QuickTime Layer
A QuickTime layer is a reference to a QuickTime-compatible movie file
(AVI, MOV, etc.), plus information about the image size, position and
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opacity, and looping. QuickTime movies allow you to create dynamic
graphics (snipes) and movie insets as graphics.

Note
The QuickTime layer only overlays the video, not the audio,
from the QuickTime file. You can use an Audio Layer to overlay
the audio from a QuickTime file; if you want both video and
audio, each is in a separate layer, allowing you to control them
individually.
Text Layer
A text layer is a specific text string (or a variable that resolves to a
specific string when the job is submitted) to be rendered on the output
media. In addition, you can set attributes including extensive font,
character, and paragraph control, plus drop shadows.
Darken Region Layer
A darken region layer is a rectangular region at a specific location and
size, plus opacity, that effectively reduces the luminance of all the lower
layers, including the baseline video.
You can use Darken Region layers to darken a rectangular area on the
image where you plan to display text or a QuickTime movie.
Audio Layer
An audio layer specifies a sound file in WAV, QuickTime, or MP3 format,
plus the ability to map audio channels to output channels. You can add
fade-in and fade-out effects to control volume on a layer basis.
Master Audio Layer
A master audio layer is automatically inserted in each template. You can
use it to control the volume level of the baseline audio, by adding fade-in
and fade-out effects, and adjusting their duration and target intensity.

Note
The Master Audio layer controls the levels of only the original
baseline audio from your source media, and does not affect any
other audio layers. For example, you might use the Master
Audio layer to fade out the original audio, while fading in a new
Audio layer containing a voice-over.
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GraphicsFactory uses file-based resources including templates (in XML
format), plus raster image files including BMP, PNG, etc. and QuickTime
movie files as graphic element resources. Additionally, you can specify
audio files in MP3, WAV, or QuickTime. Baseline video (in any supported
format) is also specified as a file.
Each of these files must be accessible to the transcoding server that is
processing the job.
If your reference files (in Template Creator as well as Submit tool) are on
the transcoding server, use fully-qualified Windows paths to the files. If
your reference files are on shares accessed by the GraphicsFactory server
or if you’re using a FlipFactory Array or Vantage Array, you should
reference the various files as fully-qualified UNC paths, because these
references must be resolved from the perspective of the network-based
transcoding server. Relative and drive-letter paths won’t be correctly
specified from the transcoding server’s location if the template is being
designed on another computer.
Server-based files must be in a share that is accessible to the transcoding
server as well as the Template Creator. They should also be specified as
full UNC paths (\\imageshare\image\logo.png, for example), instead of
using mapped drives: S:\logo.png.

Note
When submitting GraphicsFactory jobs to a transcoding server
on the LAN, file references should be fully-qualified UNC paths,
starting with a Windows server name (\\SierraServer, for
example).

Update the Paths

Before continuing, you need to update two file references in the template
which have specifically been entered as relative, so that they work in all
installations. You need to update them to local, fully-qualified paths on
your computer.
In the Template Creator, double-click the Telestream logo image layer to
display its property dialog.
Click the Browse button to locate and select the tel_logo_stack.png file in
(default installation path) C:\Program Files\Telestream\GraphicsFactory
\Tour Examples\tel_logo_stack.png and click Open.
Click OK to save the settings with the fully-qualified path to this logo.

Note
This path will only work if you are working in a single-server
environment, directly on the server performing the transcoding).

February 2016

3-11

Guided Tours

178729

Next, double-click the Lower 3rd bkg movie QuickTime layer to display
its property dialog.
Click the Browse button to locate and select the NT Telestream Blue
Lower 3rd CIRCLES.mov file in (default installation path) C:\Program
Files\Telestream\GraphicsFactory
\Tour Examples\NT Telestream Blue Lower 3rd CIRCLES.mov and click
Open.
Click OK to save the settings with the fully-qualified path to this movie.
Click File > Save Template to save the changes and continue.

Previewing a
Template

Now that you’re familiar with the main window and the building blocks
of a template, select Windows > Template Preview window.
Figure 3–7. Template Preview window

The Preview window provides you a visual overview of all graphic
elements without the baseline video so that you can get a visual sense of
how it will look when rendered.
First, click the View menu and select several backgrounds, and also
display the Video/Text Safe guide and the Rule of Thirds guide to get a
quick sense of how each feature works.
Next, click the Size menu and select various preview sizes. You can set
the preview window to display in NTSC, PAL, and HD 720 and 1080
formats. Also, you can set your own preview size.
These sizes do not control the output. Rather, the output is set in Product
area of the GraphicsFactory factory you set up, and you should set the
Preview size to the size of output you’re planning. A GraphicsFactory
template is generally designed to fit a particular frame size (e.g.: 720x480
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for NTSC). In the Size menu, you can also preview the template at fullsize (100%), half-size (50%) or quarter-size (25%).
In the Template Preview window, you can see the spatial positioning of
the elements, and you can also preview the template timeline.

Note
You can also display Layer properties dialogs directly from the
Template Preview window. Double click any object to display its
property dialog. If an element (such as a QuickTime movie)
completely fills the window, then clicking anywhere in the
window will select that element unless another element is on top
of it. So, consider putting full-screen elements at the bottom of
the layer stack if possible.

Play the Template

Finally, click Preview > Play and watch the template step through the
visual effects to get a sense of how the elements will play out. You can
also display time codes (Preview > Show Timecode During Play).
When you click Play, you can see the template fade the text in and out.
This allows you to see how the template will appear when applied to a
video. (To stop playing the preview at any time, just click directly in the
Preview window.) But how do you know when elements should fade in
and out? For that, you use the Timeline in the main window.

Using the Timeline

The timeline is where effects, such as “fade in” or “stop QuickTime
movie” are applied to the layers. The timeline is located to the right of the
layers list in the Template Creator’s main window.
Figure 3–8. Timeline in main window

You can navigate the timeline in several ways:
— Use the scroll bar at the bottom of the screen
— Use the mouse scroll wheel to zoom in and out
— Left-click and drag on the timeline to move the timeline
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Events on the timeline are driven by timecodes, such as
“00:00:01:00@29.97”. More detail is provided about creating effects in
Tour 3, but its important to place the frame rate at the end of the timecode.
Even though two timecodes with different frame rates can mean the same
time – 00:00:10:00@29.97 and 00:00:10:00@25 are the same – it's useful
to change the tick frequency in the timeline display. To change the
duration, click the Timeline menu, and select NTSC (29.97 fps), PAL (25
fps), or define your own custom frame rate. This setting is used to
determine the appropriate timeline basis when you click to add effects on
the timeline.
Before proceeding to other tours, be sure to save the template with your
updated file paths, and continue. You can quit the Template Creator
program if you choose to.

Conclusion
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Now that you’ve reviewed a template and learned the basics of how to use
the GraphicsFactory Template Creator, you’re ready to build a Graphics
template from scratch.
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[TOUR 3] CREATING A GRAPHICSFACTORY TEMPLATE
This tour takes about 15 to 20 minutes. In this tour, you’ll create a
template from scratch, duplicating the template from Tour 2.
In the process, you’ll have an opportunity to use most of the features in
the Template Creator.

Note
The instructions in this tour assume that you have taken Tour 1
and Tour 2, and have learned the menu items and toolbar, how
to display dialogs and the other windows in Template Creator. If
you need help using the user interface, display Online Help.

Create a Template

To create the Coming Next template, follow these steps:

Step 1

Start the Template Creator if you don’t already have it open. (If it is, select
File > New, and close any open templates.) When you start the Template
Creator, a new template is created for you automatically.

Step 2

Save the new, blank template in Program Files > GraphicsFactory > Tour
Examples as MyUpNextTemplate.xml.

Step 3

Display the Template Preview Window (select Windows > Template
Preview Window) so you can lay the elements out. Drag it to one side if
necessary so you don’t obscure the main window. Display the Rule of
Thirds and Video/Text Safe guides (via View menu).

Step 4

Now, return to the main window and begin adding layers to the template.

Step 5

First, add a QuickTime layer: click Add QuickTime Layer and doubleclick the layer to view properties.
Set up the following properties:
Name the layer Telestream movie.
Click Browse (the button with the ellipses on it...) and navigate to
C:\Program Files\Telestream\
GraphicsFactory\Tour Examples and select NT Telestream Blue Lower
3rd CIRCLES.mov.
Check Looping, so the movie repeats as long as the baseline video runs.
Click Adjust Preview Frame and select the frame you’d like to view in the
Preview window. (Note the Preview button here, too). Click OK.
In the Template Preview window, move the movie rectangle to the bottom
left of the window. You move the rectangle by grabbing the grab button (a
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small black square in the center of the object) and dragging the rectangle
to its target location.
Next, adjust the size of the rectangle to fill the window by dragging the
right and top edges. This effectively sets the X and Y point to 0,0, and the
size to 720 by 480 – close and open the QT Movie property dialog again
to refresh the settings and verify the values, adjusting them as necessary.
(You can also just edit the values in the dialog, of course.) Close the Edit
QuickTime Layer dialog and continue.

Note
When you’re done setting up a specific element, it’s a good idea
to lock it (click Locked in the layer). When an element is locked,
you can’t make changes, and it doesn’t prevent you from
selecting elements below it in the Template Preview window.
You can also use the Visible checkbox to hide and show
elements during your design work.
Step 6

Add a text layer for “Up Next”. Click Layer > Add Text Layer or use the
toolbar icon.

Step 7

Click to select the layer and move it to the top of the layer stack (click
Layer > Move Up or click the Move Up icon in the toolbar).

Step 8

Open the properties dialog and name the layer “Up Next”, add the value
“Up Next:”, select a font (Arial is suggested), set the color to white (or
other color you choose - click in the color box to display the color picker)
and click OK.
In the Template Preview window, drag the Up Next rectangle to the
bottom left just inside the yellow guide line and just below the swoosh (at
about 35, 360. Now, lock the layer. (When a layer is locked, you can’t
open the property dialog.) Save your template changes.

Step 9

Add a text layer for the name of the next TV show. Click Layer > Add
Text Layer, then move it to the top of the stack.

Step 10

Double-click to display the new text layer’s property dialog.
Name the layer “Show Name”. But instead of specifying the value “more
cycling fun...”, make the template general purpose by adding a variable so
it can be used repeatedly. Enter $ShowName in the text field. By putting
the symbol $in front of ShowName, you have created a new variable
called “ShowName:. (When you enter a new variable, it creates it
automatically. You’ll supply the actual text to render on this layer, when
you submit the job.) Select the font, set the color to white, text size to 48.
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Step 11

To create a shadow for the Up Next text, check Draw Outline / Drop
shadow. Set the pixel width to 4, and the X and Y offsets to 5. Select black
as the color.

Step 12

Next, review the text and drop shadow in the preview window and make
adjustments to suit your taste. When you’re satisfied with the look, click
OK to close the Edit Text Layer window and save the settings.

Step 13

Now, add default text to the variable. Click Window > Variable Editor to
display the Variable Editor window.

Note
You should always provide default values and data entry
instructions for each variable you create. If you don’t, the
rectangle doesn’t display in the Template Preview window, and it
makes it more difficult for data entry during job submission.
The Variable Editor window displays a list of all variables you’ve created
in this template. Select $ShowName and enter ShowName in the Default
Value text field. Enter Type the name of the next show in the Data Entry
Instructions field. Then, close the window.
In the Template Preview window, drag the $ShowName rectangle just
below the Up Next element. Save changes and lock the layer.
Step 14

The final element to add is the Telestream logo. Add an image layer,
move it up above the QT Movie layer (so it displays correctly and you can
move it around in the Template Preview window) and display the
properties dialog.
Name the layer Logo, then select the Telestream logo (C:\Program
Files\Telestream\GraphicsFactory\Tour Examples\tel_logo_stack.png).
Set the size to 115 wide, 76 high. (You need to know the size of images
and QuickTime movies and set them manually.)
In the Template Preview window, move the logo rectangle to the lower
right corner, just inside the red rectangle corner.
Save the template.
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Adding Timeline
Events
Step 15

Now that you’ve added the elements and have them set spatially, you’ll
adjust the temporal settings so that they fade in and out at the appropriate
times.
To set up times for each element, open the Layer Effects Editor window
(Windows > Layer Effects Editor).
Select the Up Next layer, and click Add in the Layer Effects Editor
window. Set the Fade In time to 00:00:01:00@29.97 (1 second).
Click Add again and set the effect type to Fade Out. Set the Fade Out time
to 00:00:10:00@29.97 (10 seconds).

Step 16

Select the Show Name layer, add a Fade In and a Fade Out, and set the
times to 00:00:03:00@29.97 and 00:00:10:00@29.97, respectively.

Step 17

The logo should display during the entire run of the video, so you don’t
need to add any effects. By default, elements are visible unless effects are
applied.

Tip
You can use the timeline as a visual guide – a layer that is visible
displays a thick grey bar above the layer timeline and, if it is a
Quicktime or Audio layer, the media is playable, the black layer
timeline bar is thicker during play time, thin when stopped.
Step 18

Select the Telestream movie layer, add a QuickTime Movie Start at
00:00:00:00@29.97 and add a QuickTime Movie End at
00:00:12:00@29.97.

Step 19

Also add a Fade In at 00:00:00:00@29.97 and add a Fade Out at
00:00:12:00@29.97.

Step 20

Save the template and play the preview (Preview > Play) to see how the
effects play out. If you’ve made any errors, correct them now and re-play
the preview.

Conclusion

You’ve just created your first GraphicsFactory template and in the
process, gained some first-hand experience with the GraphicsFactory
Template Creator.
Now you’re ready to try it using this template in FlipFactory (Chapter 4,
Using GraphicsFactory in FlipFactory) or Vantage (Chapter 5, Using
GraphicsFactory in Vantage).
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Using GraphicsFactory in
FlipFactory
This chapter describes how to set up and configure FlipFactory to use
GraphicsFactory templates to process media.

Topics
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Using Variables in GraphicsFactory Factories (page 4-2)



GraphicsFactory PA Tool and Filter (page 4-3)



GraphicsFactory PA Tool (page 4-3)



Media Expansion PA Tool (page 4-6)



GraphicsFactory Template Filter (page 4-9)



GraphicsFactory Submit Tool Job Submission Workflow (page 4-11)



FlipFactory Monitor/Manual Submission Workflow (page 4-14)



Monitor/Manual Submission With Data Entry Workflow (page 4-15)



Automatic Slate Generation Workflow (page 4-20)



Workflow Variations (page 4-21)
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USING VARIABLES IN GRAPHICSFACTORY FACTORIES
There are several methods you can use to “fill in the blanks” for variables.
You can provide specific values for each variable in the following ways:

4-2



Use the GraphicsFactory Submit Tool, which allows you to perform
data entry for variables before sending the job to a GraphicsFactory
server. Details are provided in Tour 2.



Set up your GraphicsFactory factory with a monitor, to maintain a
queue of pending GraphicsFactory jobs. Then, have an operator open
each job and “fill in the blanks” using the GraphicsFactory Resubmit/
Forward workflow. This workflow is described in Monitor/Manual
Submission With Data Entry Workflow on page 4–14.



Use automatically updated GraphicsFactory variables, such as
$DURATION or $FILENAME, or spot label variables ($ISCI or
$AGENCY, for example) so that the entire workflow is completely
automated.



Through an SDK integration, variables can be populated
automatically from a database. Contact Telestream for more
information about the GraphicsFactory SDK.

February 2016

178729

Using GraphicsFactory in FlipFactory

GRAPHICSFACTORY PA TOOL AND FILTER
GraphicsFactory implements a GraphicsFactory Process/Analyze tool
(commonly called a PA tool) and a GraphicsFactory Template filter. This
PA tool and filter are unique to FlipFactory servers with GraphicsFactory
licenses, and each provides functionality to enable various workflows.
It is important to understand how PA tools and filters work, in order to
correctly configure factories to process GraphicsFactory jobs.
FlipFactory’s PA tools operate at the factory level. That is, they operate
on input, not output, and are enabled in a factory at the top level. PA tools
do not operate at the product level, as product filters do.
Product filters, on the other hand, operate on output, not input, and are
added at the product level in a factory: each factory can have multiple
products. Therefore, for each product you add to a factory, you can add a
product filter and configure it to meet your needs.

Note
In addition to specific PA tools and filters created especially for
GraphicsFactory, you can utilize any other PA tools and filters
you need to create your media.

GraphicsFactory
PA Tool

The GraphicsFactory PA tool permits you to submit GraphicsFactory jobs
with the FlipFactory Job Submit window or by adding media files to
folders or shares being tracked by FlipFactory monitors.
Use the GraphicsFactory PA tool only when you have variables in the
template and you're creating a two-stage workflow (by creating a
Duplicate Original product). This enables an operator to view the job,
input values for each variable, and resubmit the job for final output.
Alternatively, this workflow allows the automatic population of special
GraphicsFactory variables such as $DURATION and $FILENAME.
When processing spots – media with a spot label – GraphicsFactory also
provides GraphicsFactory variables for all the metadata in the label.
In a two-stage factory, the stage one factory processes manually submitted
jobs or jobs that have been generated by a monitor. The stage one factory
is configured with a Duplicate Original product (for Resubmit/Forward
operation and to provide the same input media to stage two) and to
display variables from the template in the Resubmit/Forward window.
The operator supplies values for each variable, and resubmits the job to
the stage two factory for product encoding.
If there are timecode variables or automatic variables or if you want your
operator to view a proxy of the media file while performing variable data
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entry, then you should also create a QuickTime preview/trim proxy
product in the stage one factory.
The GraphicsFactory PA tool should be enabled in a factory when:


You’re submitting jobs via monitors or Manual Submit window and...



The template has variables and specific values must be calculated and
entered by an operator (or filled in manually) during job processing,
then forwarded to another factory for media transcoding and final
output and...



Your workflow has two factories: a stage-one factory for processing
the template and “filling in the blanks” either by an operator or
automatically, before submitting to the stage-two factory for
producing the overlay media using the template with image, audio,
and movie files, variable values, and baseline video.

Note
If you are using templates without variables, you should enable
the GraphicsFactory filter directly in the product: you do not
need to use the GraphicsFactory PA tool.

Enabling the
GraphicsFactory
Process/Analyze Tool
Step 1

To enable the GraphicsFactory PA tool, log into the account using the
FlipFactory console, follow these steps:
Open the factory you’re working on.
Figure 4–1. Enabling the GraphicsFactory PA tool

Step 2
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Click the Process/Analyze icon to display the list of tools.
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Step 3

Configuring the
GraphicsFactory PA
Tool
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Click the GraphicsFactory tab, and check Enabled.
To configure the GraphicsFactory PA tool, Click the Process/Analyze >
GraphicsFactory icon to display the editor and follow these steps:
Figure 4–2. Configuring the GraphicsFactory PA tool

Step 1

If your template is on the same computer as the GraphicsFactory server,
select Select GraphicsFactory Template from Local Drive. If it is on a
network server, select GraphicsFactory Template from Network Drive in
the dropdown at the top of the editor panel and then enter the domain or
workgroup you’re in, in the Domain/Workgroup Name field.

Step 2

Next, click Browse to locate and select the GraphicsFactory template that
you want to use for jobs submitted to this factory.

Step 3

Optionally, check Populate $DURATION Variable. Check this option
when you are using $DURATION in the template to provide
GraphicsFactory the length of the video, so you can apply effects based
on the total length of the output.
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For example, you may want to apply a fade-out for 4 seconds prior to the
end of the clip. Check this option to pass the value in the template through
with the job ticket without requiring operator data entry.

Note
Using the $DURATION variable requires that your stage one
factory produce a QuickTime product as a proxy, or uses the
Analysis encoder. If you use a Quicktime proxy, a small one
using the MPEG4 encoder (60 x 80, for example) is acceptable.
Using the Analysis product or the Quicktime proxy enables
correct frame-accurate calculations of the baseline duration.
Step 4

Optionally, check Populate $FILENAME variable. Check this option
when you want to use the $FILENAME variable (which is the base
filename of the input media without path or suffix text), as part of a text or
image overlay. Check this option to pass the value in the template through
with the job ticket without requiring operator data entry.
For example, you are using C:\inputmedia\sierrasunset.mpg as input
media. $FILENAME is set to sierrasunset. You can use $FILENAME in
a text overlay. You can also use it as the filename for an image overlay, by
prepending it; modify the GraphicsFactory template to add a directory
and extension. For example, place “C:\inputmedia\images\” +
$FILENAME + “.tif” as the filename for the image.

Step 5

Media Expansion
PA Tool

Whenever you make changes to a factory, be sure to save it so that
changes in the configuration are applied to the next job submitted.
The Media Expansion PA tool is a FlipFactory PA tool which allows you
to add black frames to the beginning or end of your baseline video, or in
the middle, as a segment. You can use this additional black baseline video
to add introductory graphics, QuickTime movies, or an audio bed
throughout your video.
When adding black video to expand your baseline video, be sure to
compensate for the new values when designing your template.
The Media Expansion pa tool should be enabled in a factory when you
want to add black time as a leader, trailer, or internal segment to increase
the overall length of your media.

Note
You can add a bumper, trailer, and one intermediate segment to
your video using the Media Expansion PA tool’s editor panel. If
you need to add multiple intermediate segments, use the
FlipFactory SDK. Contact Telestream for details.
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Enabling the Media
Expansion PA Tool
Step 1

To enable the Media Expansion PA tool, log into the account using the
FlipFactory console, follow these steps:
Open the factory you’re working on.
Figure 4–3. Enabling the Media Expansion PA tool

Step 2

Click the Process/Analyze icon to display the list of tools.

Step 3

Click the Media Expansion tab, and check Enabled.

Configuring the Media
Expansion PA Tool

February 2016

To configure the Media Expansion PA tool, Click the Process/Analyze >
Media Expansion icon to display the editor and follow these steps:
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Figure 4–4. Configuring Media Expansion to add leader/trailer

Step 1

On the Leader/Trailer Media Expansion tab, check Enabled, and then
check Lead in Duration and/or Trailer Duration and specify the amount of
time in timecode format that you want to add to your baseline video
before applying elements from your template.
Figure 4–5. Configuring Media Expansion to add a segment

Step 2

4-8

On the Segment Media Expansion tab, check Enabled, and then check
Segment Insertion and specify the position in the original input media
where you want to add a black segment, and enter the amount of time in
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timecode format that you want to add to your baseline video before
applying elements from your template.
Be sure to select the correct fps value to match your baseline video.
The position value should be calculated from the original baseline video,
not taking into account any leader black time you’ve added.
Step 3

GraphicsFactory
Template Filter

Whenever you make changes to a factory, be sure to save it so that
changes in the configuration are applied to the next job submitted.
Product filters (often called just filters) are always applied directly to
output media: a product in FlipFactory terms, and you can produce one or
many products in a single factory.
The purpose of the GraphicsFactory Template filter is to allow you to use
different GraphicsFactory templates for each product in a factory.
The GraphicsFactory Template filter is almost always used; especially
when:


You’re submitting jobs via monitors or Manual Submit window and...



You have multiple products per factory, and each product requires a
separate template or...



You’ve enabled the GraphicsFactory PA tool (requires a Duplicate
Original) and unchecked Attach specified template in the stage one
factory.

In this case, the product filter should be enabled and the template selected
in each product in the stage one (product encoding) factory. The one case
when you don't need the GraphicsFactory Template filter is when you are
submitting a file through the GraphicsFactory submit tool.

Enabling the
GraphicsFactory
Template Filter
Step 1
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To enable the GraphicsFactory Template filter, when logged into an
account in the FlipFactory console, follow these steps:
Open the factory you’re working on.
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Figure 4–6. Enabling the GraphicsFactory Template filter

Step 2

Open the product that you want to specify a specific template for.

Step 3

Open the format icon, then click the Filters icon to display the list of tools.

Step 4

Click the GraphicsFactory Template tab, and check Enabled.

Configuring the
GraphicsFactory
Template Filter

To configure the GraphicsFactory Template filter, Click the Filters >
GraphicsFactory Template icon to display the editor; follow these steps:
Figure 4–7. Configuring the GraphicsFactory Template filter

Click Browse to locate and select the GraphicsFactory template that you
want to use for this product.
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GRAPHICSFACTORY SUBMIT TOOL JOB SUBMISSION WORKFLOW
In this workflow, GraphicsFactory jobs are submitted using only the
GraphicsFactory Submit tool. Templates may or may not have variables.

Note
The GraphicsFactory Submit tool is different from the
FlipFactory Submit Job window, which also allows you to submit
jobs manually. See FlipFactory Monitor/Manual Submission
Workflow on page 4–14 to learn how to set up factories and use
the FlipFactory Job Submit window to submit GraphicsFactory
jobs.
This simple workflow is designed for testing, and for low-volume,
manual job submission. This method is not recommended for highvolume workflows.
Figure 4–8. GraphicsFactory Submit tool job submission workflow

GraphicsFactory Submit Tool
The Submit tool is a Windows application. The Submit tool allows you to
select a template and source video, then submit a FlipFactory job to the
selected factory.
You can install the Submit tool directly on your FlipFactory server or on
another Windows computer on the same network.
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Figure 4–9. Use the Submit tool to set up and submit a job

If your template uses variables (rather than specifically naming each
value), the Submit tool allows you to override the default values for each
variable – a show name, time, or other text, or a numeric value for
graphics locations on the display, or timecodes, for example, as you
submit your job.

Factory Configuration

The factory which processes the job may have one or more products, and
the factory should not have the GraphicsFactory PA tool enabled. It is not
needed because the GraphicsFactory Submit tool displays the variables (if
present) for the operator to add values before submitting the job.
Additionally, there is no GraphicsFactory Template filter enabled on any
of the products in this factory, because the template is selected by you,
and passed in by the GraphicsFactory Submit tool. Thus, this factory has
no special configuration that is different from any other factory.
Make sure that the frame size on each product you produce in this factory
matches the appropriate frame size for the template that you're using.
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For this workflow, you submit a job by running the GraphicsFactory
Submit tool. Connect to the target GraphicsFactory server, and log in to
the account that owns the factory you want to submit a job to.
Figure 4–10. GraphicsFactory Submit tool job submission workflow
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FLIPFACTORY MONITOR/MANUAL SUBMISSION WORKFLOW
In this workflow, GraphicsFactory jobs are submitted via FlipFactory
monitors, or manually using the Manual Submit window in FlipFactory.
The factory which processes the job may have one or more products.
Variables are optional in templates. If a template has variables, the default
values are used in the job – there is no data entry opportunity for operators
before encoding the media. (See Monitor/Manual Submission With Data
Entry Workflow on page 4–15 for a workflow with manual data entry.)
This automated workflow is designed for high-volume, automatic job
submission via monitors (or manual submission when necessary), when
variable values (if any) are pre-set and do not require operator
intervention or automatic calculation.
Figure 4–11. Workflow for monitor/manual jobs & no data entry

Factory Configuration

The GraphicsFactory PA tool in this factory isn’t enabled, because the
default values are used and no operator intervention is involved.
The GraphicsFactory template filter must be enabled on each product
(and template specified) because it isn’t specified during automatic
submission, or manually via the FlipFactory Job Submit window.
You can use different templates for each product; for example, a small
mobile video might have a different template applied than an HD product
within the same factory.

Job Submission

You submit a job to this workflow by adding your source media to the
target monitor for the factory producing your media. Alternatively, submit
a job manually using the FlipFactory Job Submit window.
The GraphicsFactory filter ingests the template, and variables (if any),
with default values specified, are passed in via the template specified in
the filter.
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MONITOR/MANUAL SUBMISSION WITH DATA ENTRY WORKFLOW
In this workflow, GraphicsFactory jobs are submitted via FlipFactory
monitors or manually, using the Manual Submit window. This workflow
is designed for high-volume, automatic job submission via monitors.
These templates have variables, and specific values are entered by an
operator or automatically calculated before encoding the media.
The workflow has two factories, and the stage two (encoding) factory
may have one or more products.
Figure 4–12. Workflow for monitor/manual jobs with data entry

Factory Configuration

The stage one factory has at least one product: Duplicate Original, which
is passed through to the stage two factory for product encoding.
If manual data entry is required, this workflow enables operator
intervention to edit metadata (and add variable values) and then enables
the operator to resubmit or forward the job.
Enable the GraphicsFactory PA tool in the stage one factory and select a
template so it can be passed to the stage two factory. If the stage one
factory is used to automatically populate variables such as $FILENAME
or $DURATION, populate these in the GraphicsFactory PA tool.
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The stage two factory should have the GraphicsFactory Template filter
specified in its product. This filter picks up the variables provided by the
PA tool in stage 1, and uses them when applying graphics.
If you use $DURATION, a QuickTime product (for use as a proxy) must
be added. If you want to review the proxy, create a QuickTime product. If
it's automatic only, you only need to use the Analysis encoder. A small
MPEG4 video (60 x 80, for example) is acceptable, unless you have other
timecode variables which you want to supply values for by scrubbing the
proxy. In this case, set the size to 320 x 480 for better viewing.
The QuickTime proxy enables correct frame-accurate calculations of the
baseline duration. The optional second product in this factory is also
enables the operator to preview the movie and identify significant times
easily, if there are timecode variables in the template.
Alternatively, if all variables are automatically populated, then the stage
one factory should just use a Forward Notify to pass the complete job to
the stage two factory.

Job Submission

You submit a job to the stage one factory by adding your source media to
the monitor for the factory producing your media. Alternatively, submit a
job manually, using the FlipFactory Job Submit window. The
GraphicsFactory PA tool ingests the template, and variables are passed in.
When the stage one factory job completes, either a proxy is produced or
the file is analyzed automatically and the original file is duplicated.
Display the Job Status window, and double-click the job to view the
Message Viewer.
Figure 4–13. Use Message Viewer to view job results.
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Click Resubmit to display the Resubmit/Forward window.
Figure 4–14. Use Resubmit/Forward to update variable values

Update the variables in the Metadata group at the bottom, including
timecodes if any, using the QuickTime proxy playback editor (click
GraphicsFactory Editor).
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Figure 4–15. Playback editor – mark timecodes & trim header/trailer

Scrub through the video and mark selected variable timecodes. Click the
Save icon (disk) and close the window.
Also, you can use the buttons above the video to go to start, then scrub
through leader/header or video you just don’t want, and clip it. Then, you
can go to end and scrub back, to trim trailer or video you don’t want, all in
a single step. The header/foot trim marks automatically adjust other trim
marks you make.

Note
If you intend to trim the video using the mark-in/mark-out points
you’ve made in the playback editor, go to the stage two factory
in your workflow and enable the Media Processing PA tool so it
will enable trimming.
Also, Be sure to check Adjust Variables for Trim Points in the
GraphicsFactory filter in the same factory.
Return to the Resubmit/Forward window:
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Figure 4–16. Submit the job to the stage two factory

Note that the timecode variables you set in the playback/trim editor are
updated, and update variables if you didn’t already do so.
Select the stage two factory you’re using to encode media, and click
Submit to submit the job to the stage two factory, where the actual
product encoding takes place.
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AUTOMATIC SLATE GENERATION WORKFLOW
You can use spot label GraphicsFactory variables to expose all the values
you need to automatically produce slates. In this workflow,
GraphicsFactory jobs are submitted via FlipFactory monitors or manually,
using the Manual Submit window in FlipFactory.
When an ad or spot includes a spot label, GraphicsFactory automatically
populates the following GraphicsFactory variables with metadata values:


$ISCI



$TITLE



$CLIENT



$AGENCY



$PRODUCT



$SPOT_DURATION



$SPOT_DESCRIPTION



$SPOT_TYPE

When creating your slate template using the Template Creator, you can
use these GraphicsFactory variables to place values on the within text
layers of the template, and burn them into the video when it runs the job
in GraphicsFactory.

Note
Unlike the two-stage workflows involving $DURATION and
$FILENAME, these variables are always immediately available
to a transcode that is applying a GraphicsFactory template,
provided that the incoming media has a spot label. As a result,
only one factory (one stage) is required.
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WORKFLOW VARIATIONS
You can vary factory settings in several ways to accommodate your
workflow requirements.

One to Many
Workflow

In a one-to-many workflow, you can implement a single stage one factory
with a template. After data entry, this job can be submitted to multiple
templates in a stage two factory for product encoding. This is useful when
you have multiple, different templates all using the same variables.
You enable the GraphicsFactory PA tool and specify a GraphicsFactory
template which has the prototype variables that are common to all the
GraphicsFactory templates in this group.
In the stage two factories (one for HD, one for mobile, one for SD, for
example), you enable the GraphicsFactory Template Filter, and attach the
specific template for this product, making sure that each template shares
common variables.

Note
If you are submitting jobs with variables in a two-stage workflow
that require multiple templates, they must have the same set of
variables. You can enable the GraphicsFactory Template Filter
in each product, and specify a unique template in the set.

February 2016

4-21

Using GraphicsFactory in FlipFactory

4-22

178729

February 2016

C

H

A

P

T

E

5

R

Using GraphicsFactory in
Vantage
This chapter describes how to set up and configure Vantage to use
GraphicsFactory templates.

Topics
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GraphicsFactory Filters in Vantage (page 5-2)



Adding a GraphicsFactory Template to a Workflow (page 5-2)



Vantage Variables and GraphicsFactory (page 5-2)



Workflow Portal Submission to GraphicsFactory Workflows (page
5-3)
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GRAPHICSFACTORY FILTERS IN VANTAGE
Vantage provides a GraphicsFactory video filter and a GraphicsFactory
audio filter, which can be applied during transcoding. The video filter
applies the video portions of a GraphicsFactory template; the audio filter
applies the audio portions. If you require both video and audio in your
transcoded output, you should use both the audio and video filters.
Figure 5–1. Enabling the GraphicsFactory PA tool

Adding a
GraphicsFactory
Template to a
Workflow

Use the following steps to apply a GraphicsFactory template in a
workflow:

Step 1

Open your Encode action inspector.

Step 2

Select the video stream.

Step 3

Enable the GraphicsFactory video filter, and select it.

Step 4

Find the Template File parameter, and browse to select your
GraphicsFactory template.

Vantage Variables and
GraphicsFactory

When you select a GraphicsFactory template to be applied, all of the
GraphicsFactory variables display in the inspector as Vantage parameters.
These parameters may be set to fixed values (if you want every file
transcoded to use the same values), or they may be bound directly by
Vantage variables (if you want every file to dynamically change the
GraphicsFactory template).
The latter approach allows you to use any information available to the
workflow in Vantage directly in the GraphicsFactory template.

5-2
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Common uses of variable binding include:

Workflow Portal
Submission to
GraphicsFactory
Workflows



Allowing operators to enter variables via Vantage Workflow Portal,
and then providing that information directly into the GraphicsFactory
template



Building a GraphicsFactory template that is relative to the duration of
the media, and then using the Identify analysis capability to determine
the media duration and provide it into the template



Using Associate to match an overlay image with the incoming media
file, then use the Path variable location of that overlay image as a
variable within the GraphicsFactory template



Using the Slate/Spot detection filter to detect the start and end of a
slate, and using this information to overlay a new slate on top of the
old one



Use the Vantage SDK to provide variables to Vantage, which are then
passed into GraphicsFactory during a transcode.

Vantage Workflow Portal provides a way for operators to view a proxy of
a media asset, and provide metadata. Using this feature, you can create a
workflow where operators can enter GraphicsFactory variables directly,
as follows:

Step 1

In the Vantage Management Console, create a metadata label that
represents the variables that you want the operator to enter.

Step 2

Create a pre-processing ingest workflow in Vantage to create a proxy and
a thumbnail of the media files submitted, and register a binder in the
catalog.

Step 3

Create a Workflow Portal configuration which presents the catalog to the
operator, and which allows them to enter the metadata label you created.

Step 4

Create a post-processing workflow that:
a. Uses the Populate action to convert parameters within the label into
individual variables
b. Contains an Encode action that uses a GraphicsFactory video and/
or audio filter, and which binds the variables into the GraphicsFactory
template.
See the Vantage Management Console User's Guide for more information
about configuring a Vantage Workflow Portal.
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Figure 5–2. Typical operator-driven workflow
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