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Troubleshooting Info 

Gather Info  
Workflow/System info 
Identify the workflow and get system information 
 

Detailed description of the problem: 
o What, when, how, where 
o Describe the system configuration - Pipeline, network, host computer details, media 

storage locations (local, network, type of drives, RAID, etc….) 
o Include any error messages that are generated 

 Screen shots are great it possible 
 
Pipeline hardware info: 
Pipeline Firmware revision 

o Locate this information on the Configure panel of the Pipeline Direct browser UI 
o App  
o Loader 

 
Network topography 

o Pipeline IP Address 
o Default, Static or DHCP 

o Connected direct or through a switch 
o Full description of the network that the Pipeline is connected to 
o If through a switch, is the route through more than one? 

 If dual NIC cards are present and connected make sure the route to the 
Pipeline is correct 

o Any managed switches between the Pipeline and the target system? 
o 100Mb/s or 1000Mb/s 
o Is the LAN used for general data traffic as well or dedicated to Pipeline traffic 

only (recommended) 
o Are there Firewall or security obstacles preventing reliable Pipeline communications? 

 
Mac OS X system information (if applicable): 
Obtain the OS X host system profile 

o Provide a copy of the Console log 
 Open the Console utility from the Applications/Utilities folder 

• If the log list is hidden select Show Log List  
 Select Console Messages then File->Save Copy, save the log and send to 

support 
 Select System.log then File->Save Copy, save the log and send to support 

o Provide a copy of the System Profiler log 
o Launch the System Profiler, which is located at: /Applications/Utilities/System 

Profiler 
o Select Save As... from the File menu. 
o Select Rich Text Format (RTF) from the Format popup menu. 
o Save the file to the Desktop and send to support 

 
Pipeline software information: 
Get the Pipeline for Mac OS X software revisions 

o Pipeline scheduler revision can be found at Pipeline->About Pipeline 
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o Pipeline Porter revision can be found at Pipeline->About Pipeline Porter 
o Encoding spec 

o What Pipeline(s) codec is being used (DV, DVCPro, IMX30/40/50, MPEG-2, 
ProRes 422) 

o Which file wrapper is used QuickTime or TIFO 
o If using the Pipeline scheduler send a copy of the schedule file (has a file 

extension of ‘pipelineschedule’) 
 

FlipFactory 6.x system information (if applicable): 
 Get information directly from FlipFactory 

o From the FlipFactory main app select System Settings 
o Click on the Email Technical Support button 
o Choose “Copy file to……….”, then click OK 

 
o Wait while all of the information is gathered. This can take several minutes. 
o When the process is complete, all information needed to debug FlipFactory issues 

will reside in at  
 

“..\Program Files\Telestream\FlipFactory\SupportInfo” 
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General Questions and Issues 
Issue. I am evaluating Pipeline with my existing FlipFactory and am have problems getting them to 
work together. 
Resolutions.  

 Pipeline require FlipFactory v6.0 with Service Pack 4  
 Pipeline EDL monitor requires an additional license key. This license key can be obtained from 

Telestream free of charge. Contact license@telestream.net 
 If your existing FlipFactory license only contains “DEMO” keys some Pipeline workflows will not 

work and will require “limited” production keys. Workflow that perform DV direct convert, IMX and 
MXF direct convert, and MPEG-2 direct convert. 

 
Issue. I have a Mac and want to create other formats, such as MPEG-2 4:2:0 long GOP or WMV, 
from my Pipeline. How can I do this? 
Resolutions. To create other types of files from your Pipeline utilize Telestream’s Episode 4.4 craft 
encoding application. You will need to first create a source file from Pipeline using one of its available 
codec (DV25, DVCPro25, IMX(30/40/50) and MPEG-2 50I-Frame), then pass this file to Episode.  
 
Follow these steps: 

1. Create a TIFO (Telestream Intermediary Format) source file direct from the Pipeline Direct 
browser UI. (See the ‘Chapter 3 – Using Pipeline Direct’ in the Pipeline User Guide for details 
on how to create TIFO files directly from the Pipeline Direct browser UI.) 

2. Use the TIFO file as source media in Episode 4.4 to create one (or more) new files using 
Episode’s wide selection of available media formats.   

 
Issue. I cannot play Pipeline created QuickTime files containing IMX or MPEG-2 on my Mac 
PowerPC. 
Resolutions. The Telestream IMX QuickTime components are compatible with Intel based Mac systems. 
Telestream does not supply MPEG QuickTime components for PowerPC or Intel Macs. 
 
Issue. What are the general hardware requirements for a Pipeline capture system? 
Resolutions. Minimum hardware requirements for a dedicated Pipeline capture system 

Network and Hard Disk Performance Requirements (per stream) 

CODEC Disk read/write (MB/s) 
Network throughput 

(Mb/s) 

SD Codecs     

Photo Motion JPEG 0.75 8 

DV/DVCPro  4.4 35 

IMX30 5.3 43 

IMX40 7 56 

IMX50 8.3 67 

ProRes 422 7.3 58 

Uncompressed 8bit 422 22 175 

mailto:license@telestream.net�
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HD Codecs (range based on codec and bit rate)     

DVCPro HD  16.5 135 

ProRes 422 HQ 10-36 62-240 

DNxHD 10-36 62-240 

Recommended Hardware Systems* 
Standard Definition** (ingest only)  

Single channel system 
Intel Dual Core 2.0Ghz CPU, 2GB RAM, SATA 1.5GBs 7200 RPM media storage drive (separate 
from OS drive) 
Two channel system 
Intel Dual Core 2.0Ghz CPU, 2GB RAM, minimum 2 drive RAID-0 SATA 1.5GBs 7200 RPM 
media storage partition (separate from OS drive) 
Four channel system 
Intel Quad Core (4 cores) 2.33 GHz CPU, 4GB RAM, minimum 3 drive RAID-0 SATA 1.5GBs 
7200 RPM media storage partition (separate from OS drive) 
Eight channel system 
Intel Dual Quad Core (8 cores) 2.33 GHz CPU, 6GB RAM, minimum 4 drive RAID-0 SATA 3GBs 
7200 RPM media storage partition (separate from OS drive) 
 

High Definition** – DVCPro HD  (ingest only)  
Single channel system*** 
Intel Dual Core 2.53Ghz CPU, 2GB RAM, minimum 2 drive RAID-0 SATA 7200 RPM media 
storage drive (separate from OS drive) 
Two channel system*** 
Intel Quad Core 2.8 GHz CPU, 6GB RAM, minimum 4 drive RAID-0 SATA 1.5GBs 7200 RPM 
media storage partition (separate from OS drive) 
Three/Four channel system*** 
Dual Intel Quad Core (8 cores) 2.8 GHz CPU, 6GB RAM, minimum 6 drive RAID-0 SATA 1.5GBs 
7200 RPM media storage partition (separate from OS drive) 
Five channel system*** 
Dual Intel Quad Core (8 cores) 3.0 GHz CPU, 8GB RAM, minimum 8 drive RAID-0 SATA 1.5GBs 
7200 RPM media storage partition (separate from OS drive) 

 
High Definition** - DNxHD 220/Pro Res 422 HQ (ingest only)  

Single channel system*** 
Intel Dual Core 2.53Ghz CPU, 2GB RAM, minimum 4 drive RAID-0 SATA 7200 RPM media 
storage drive (separate from OS drive) 
Two channel system*** 
Dual Intel Quad Core (8 cores) 2.8 GHz CPU, 6GB RAM, minimum 6 drive RAID-0 SATA 1.5GBs 
7200 RPM media storage partition (separate from OS drive) 
Three channel system*** 
Dual Intel Quad Core (8 cores) 3.0 GHz CPU, 8GB RAM, minimum 8 drive RAID-0 SATA 1.5GBs 
7200 RPM media storage partition (separate from OS drive) 
 
*All systems assume media storage local (internal or direct attached) to the host system with 
adequate storage to support 24 hours of content at the chosen format, and drive array is less 
than 80% full without serious fragmentation. 
 
**Edit while ingest and transcode while ingest workflows require increased disk I/O performance 
to support the additional read processes, and may require disk buffer cache drive system (see 
Pipeline User Guide disk buffering details). 
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***Viewing HD preview stream(s) can consumes high levels of CPU which may cause dropped 
frames. It is recommended that preview be turned off during capture. 
 
**** To insure quality of service when writing to a NAS, share storage location or network share 
your Pipeline system must support disk buffering and have it enabled.  

 
Issue. My media goes offline when I navigate away from Final Cut Pro? 
Resolutions. When you switch out of FCP and back in, the app scans to see if any of the files have 
changed "behind its back". Since Pipeline ‘Open’ QuickTime files are changing as the capture progresses 
this causes the offline message. Even if automatically reconnect is set, FCP closes the viewer item when 
reconnecting (because that is what is going on... updating the clip to match the new file) because the clip 
in the viewer may be going through dramatic changes. You can use the Update Media File apple event, 
but the viewer will still close. This is normal procedure for Final Cut Pro. 
 
Issue. I am receiving a Video or Audio buffer overflow errors when capturing? 
Resolutions. Video buffer overflow errors indicate that real-time media data cannot be written to disk fast 
enough to prevent the RAM buffer from overflowing. Verify that the disk being written to (either directly 
without disk buffering or the disk buffering disk) is fast enough to support your workflow. See the Chapter 
3 - Typical Pipeline Systems and Considerations section in the Pipeline User Guide). 
 
Issue. I am receiving an Incomplete Frame error when capturing? 
Resolutions. Incomplete Frame errors indicate that real-time media stream data coming over the 
Ethernet connection cannot be consumed by the Pipeline software fast enough to prevent frames from 
being lost. This is generally caused when the Pipeline host system is overloaded with additional 
processes such as Pipeline video preview or other CPU intensive tasks or when the network’s bandwidth 
is exceeded. Disable all unnecessary tasks and try the capture again. Also verify that the network 
connection to the Pipeline(s) is configured in a way to provide adequate bandwidth. See the Chapter 3 - 
Typical Pipeline Systems and Considerations section in the Pipeline User Guide). 
 
Issue. I am receiving a “Not Implement” error from the Pipeline Control for Windows application? 
Resolutions. This is a general error indicating that the combination of Wrapper, Video and Audio you 
have selected is not compatible with the input signal currently attached to the Pipeline hardware. This 
error takes into account capabilities of the Pipeline device firmware in respect to the SDI input signal 
connected to the hardware. For example this error would be generated if the input signal connected is 
NTSC and your Pipeline Control for Windows application has DV selected as a wrapper and 576i 
selected (PAL) as the video frame size. 
 

Networking 
Issue. How can I find the IP address that my Pipeline is set to? 
Resolutions. 
The default Pipeline IP address, set at the factory, is located on the 
bottom of your Pipeline device. You can also find the Pipeline MAC 
address and serial number there. 
 
If you have modified the IP address by selecting Static or DHCP, your 
address can be found by opening the Pipeline Direct browser interface. 
 

1. Select the Pipeline device from a Bonjour list or by going 
entering the Pipeline URL (http://telestream-plxxxx.local where 
xxxx is the last 4 digits of the Pipeline serial number) on the 
browser address box. 

2. Where the Pipeline Direct connects to your Pipeline the IP address will appear in the browsers 
address box. 

http://telestream-plxxxx.local/�
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Issue. I’ve attached the Pipeline to the LAN via Ethernet, but I can’t ping it using the IP address. 
Resolutions. 
Make sure the Pipeline is on. Plug it in with the supplied power adapter (there is no power switch). On 
the front panel, verify that the Power LED is lit. Also, verify that the link LED (left LED on Ethernet port) is 
lit. 
 
Make sure that you’re using an operational, straight-through Ethernet cable. If you’re using a cross-
over cable on a LAN connection (instead of the conventional straight-through cable), make sure your 
switch is auto sensing. 
 
Make sure your computer is on same LAN & subnet. Determine that your computer is connected to 
the same LAN and subnet and that you can ping other devices. 
 
Make sure you’re pinging the correct IP address. By default, Pipeline uses the IP address printed on 
the label affixed to the bottom of the device. If you’ve forgotten the IP address, you can also ping the 
Pipeline using its host name, in the format telestream-pl<serial number>.local, where the serial number is 
printed on the bottom of the device. For example, telestream-pl3009.local. 
 
Is your router/switch VLAN enabled? Routers with VLAN enabled may block link-local traffic. Pipelines 
by default use a link-local IP address in the range 169.254.1.0 to 169.254.254.255. If your Pipeline is 
using its default IP address and the router has VLAN enabled, change the IP address (DHCP or static) or 
disable VLAN and try again. 
 
Eliminate routers from the route. Routers, when used in conjunction with a self-assigned IP address, 
limit traffic to the local network. Pipeline traffic in this situation will not pass through a router. If you are 
using DHCP or a static IP address, traffic may pass through a router, although this is not supported 
because you can’t predict associated latencies or out of order packets, both of which cause problems for 
transmitting media via RTP sessions. 
 
In rare circumstances, Pipeline encounters an IP address conflict and must use another IP 
address. Make sure you’re pinging with the correct IP address. If you suspect this is the case, 
disconnect the Pipeline and ping the address again to verify that another device is already using the 
default address assigned to the Pipeline. Resolve the situation by: 
 

A) changing the second device’s IP address so it does not conflict with the Pipeline’s default 
address  
B) Using Bonjour so that you can access and connect to Pipeline without knowing its IP address 
C) Connect the Pipeline directly to a computer and ping it to verify that the IP address printed on 
the bottom panel is being utilized, and change the settings to use DHCP or a static IP address  

 
Disable or don’t use switches with Spanning Tree Enabled. A switch with the spanning tree feature 
enabled reconfigures itself each time a new device is plugged in. During the reboot cycle, clients will not 
be able to communicate with the Pipeline (usually for several seconds after it is rebooted). This may 
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interrupt sessions, destroy a media stream, and could limit your ability to perform a firmware rescue. The 
work-around is to perform firmware rescue directly connected to the computer. 
 
Verify that the correct IP address is in the routing table. Each Windows computer maintains a routing 
table so that it knows what gateway is required to contact devices that are not on your subnet. The default 
link local IP address range is the class B subnet 169.254.0.0. So that the computer knows that it doesn’t 
need to use a gateway to access devices on this subnet you need a 169.254.0.0 route entry in the routing 
table. This route is typically set by default in Windows XP in the registry. To view the route table and verify 
that the class B subnet for your Pipeline is in the routing table, open a command window (start > run, 
enter cmd and press Enter) execute: 
 

route –p print 
 
If for some reason 169.254.0.0 is not in the routing table, add it back into the table with this DOS 
command: 
 

route –p add 169.254.0.0 mask 255.255.0.0 999.999.999.999 
 

where 999.999.999.999 is the IP address of your computer, and retry the ping command. 
 
Issue. My system has more than one network adaptor (NIC) connected.  
Resolution.  
Make sure that the route table (see above) contains a specific route to the Pipeline device(s) using the 
correct NIC. This table listing directs all traffic to your Pipeline through the appropriate NIC, thus insuring 
all communications to the Pipeline(s) always uses the correct network interface. 
 
Route command syntax: 
 

route –p ADD [Pipeline IP] MASK [mask IP] [gateway IP] [METRIC metric] [IF interface] 
 
Issue. I am using Pipeline Direct – Internet Explorer continues to display a message indicating 
that it can’t communicate with the Pipeline. 
Resolution.  
You may have changed the IP address, and have not reconnected using the new address. Close the Web 
browser, and restart it. Next, log on using either Bonjour or the Pipeline’s new IP address. 
 
Issue. I can ping the Pipeline and/or see the Pipeline in Bonjour panels, but I still can’t connect 
using my Web browser or via the Pipeline Plugin for Final Cut Pro. 
Resolution. Have your IT administrator check the NAT/firewall settings in the switch (or switches) you’re 
connecting through (at most, you should use a single switch). Pipeline uses TCP and UDP ports 
7000/7002 (video), 7004/7006 (audio), 7008/7010 (status), 554 (RTSP), and 80 (http). These ports must 
not be blocked. 
Resolution. Two IP addresses may be set to the same NIC card. When using Pipeline Direct, don’t use 
two IP addresses. 
 
Issue. I am losing packets – lost packets display in the Counter panel. 
Resolution. It is possible that the connection speed is 10Mbps. Typical causes include a damaged or 
extremely long, or poor quality Ethernet cable (Telestream recommends cat-5 or cat-6 cables), some 
device on an intervening switch or hub running at 10 MB/S and causing all traffic to drop to 10 MB/S, or 
an older, 10 MB/S switch/hub itself. Correct the problem before continuing. 
 
Issue. FlipFactory Pipeline Control editor intermittently say that the selected Pipeline is ‘Already 
In use’ when I know it is not? 
Resolution. Windows Firewall can intermittently affect the Bonjour service causing it to report wrong 
Pipeline states.  We recommend that the Windows Firewall be enabled and turned off via the Windows 
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Security control Panel; if this is not possible then UDP port 5353 must be added as an exception for 
Bonjour to work reliably. 
 
Issue. FlipFactory Pipeline will occasionally fail a jobs reporting “No frames from Pipeline 
received” or “Failed due to inactivity time out”. 
Resolution. Windows Firewall can intermittently affect the Bonjour service causing it to report wrong 
Pipeline states.  We recommend that the Windows Firewall be enabled and turned off via the Windows 
Security control Panel; if this is not possible then UDP port 5353 must be added as an exception for 
Bonjour to work reliably. 
 

Pipeline Direct 
Issue. I am having problems running Pipeline Direct in my Web browser. I can’t download files 
during crash record, and similar problems. 
Resolution. Make sure that Internet Explorer security settings are set to Low as follows (enable similar 
functionality in Safari and Firefox so that you run signed Active-X controls and download files (for EDL 
and TIFO files): 
 
• Add Pipelines to your Trusted Intranet sites. Click Tools > Internet Options. On the Security tab, click 
Trusted Sites, and add http://telestream-pl<9999>.local (where 9999 is the serial number) for each 
Pipeline. 
• Click Custom Level and Select Low. 
This setting permits (among other things) the following required functionality, which may be set 
individually: 
• Active-X Controls and plug-ins: Allow previously unused Active-X controls to run without prompting 
(Enable) 
• Downloads: automatic prompting for file downloads (Enable) & File download (Enable) 
• Scripting: Scripting of Java applets (Enable) 
 
Issue. When I open the Live panel occasionally the embedded QuickTime player does not start. 
Resolution. Simply click the pause then the play button on the unopened player control. This will restart 
the player. 
 
Issue. I am creating TIFO files with Pipeline Direct in Internet Explorer and cannot make any files 
larger than 4GB. 
 Resolution. This is a limitation of Internet Explorer. All “downloaded” files are restricted to 4GB. Try 
using Firefox for Windows, which uses a download manager capable for “downloading” files larger than 
4GB.  
 

Pipeline schedule software 

Issue. If I delete the scheduled event on the schedule (by highlighting the colored area and pressing the 
X button or delete) does that delete the media file?”  

Resolution. No. If you delete an event from the schedule, the associated clip file tied to that event will 
remain in its stored location. More about this below.  

Issue. If I rename an event and capture again what happens to the original captured file? 
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Resolution. When you rename a scheduled event from the event dialog sheet the associated clip file is 
also renamed. After a rename when the schedule is restarted the existing clip, which was renamed, is 
then overwritten.  

 To avoid having captured file overwritten follow these procedures  

Stopping a schedule early  

 Here is the process for ending a scheduled event early:  

1. After the schedule document has been stopped delete the current event from the schedule.    
2. If you wish to immediately begin recording again using this schedule document, add a new event 

with a new name to the schedule.  
3. Start the schedule by clicking on the record button.  

This process will insure that the files that were previously recorded are maintained and that new clip files 
are created without overwriting the previously recorded material.    

If a schedule unexpectedly stops  

 If a schedule stops unexpectedly due to a Pipeline or network outage, a computer crash, software crash 
or any other reason, be aware that a schedule restart will overwrite the current schedule event’s last 
captured file. To prevent this from happening you can do one of two things.  

1. Follow the procedure from “Stopping a schedule early” above. It is best to do this when an edit 
session has the existing file open.  

2. Rename the clip file at its storage location, then restart the schedule. Do this if no edit session is 
currently opened to this file.  

Issue. When opening a QuickTime file (that is currently being captured by Pipeline) for editing from a 
shared folder location on by Mac OS X system, I only can see video data up to the point in time of when I 
opened the file. It does not grow as time progresses and I cannot edit it while it is being captured. 

Resolution. Due to the nature of file sharing under AFP (Apple File Protocol), QuickTime files being 
created by Pipeline that are written to a shared folder on Mac OS X need to be shared and connected to 
using SMB. See the work around procedure below: 

• From System Preferences->File Sharing select ‘Share files and the folder using SMB’ in the 
Options dialog, on all folders that Pipeline will be writing to.  

• From the Final Cut Pro edit workstations connect to the shared media folders using SMB. Open 
Finder and select Go->Connect to Sever from the Finder menu. Connect the media folder as 
smb://<server name or IP Address> 

• When importing the Pipeline files into Final Cut Pro select them from ‘DEVICES’ and not 
‘SHARED’ 

 

Pipeline hardware 
Issue. The Out or In LED on the front is lighted yellow. 
Resolution. You’re losing either video or audio packets, and your encoded media is not going to be the 
quality you planned. This is probably due to connecting through a 10/100 switch, or a hub that is not able 
to handle the traffic. To verify, connect to the Pipeline with Pipeline Direct and click Live. Review the 
AudioStream, StatusStream, and VideoQueue values to determine if they are higher than zero, indicating 
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lost data. Also, you may have a damaged or inferior cable introducing noise that corrupts traffic. You 
should either direct connect to your Windows computer or Macintosh, or go through a Gigabit Ethernet 
switch, especially if you have multiple Pipelines installed and encoding or decoding media 
simultaneously. 
 
Issue. The Ethernet port right LED is not lit. 
Resolution. This indicates that the port is operating at 10 MB/S, which is not adequate for real time 
media traffic. Typical causes include a damaged or extremely long, or poor quality Ethernet cable 
(Telestream recommends cat-5 or cat-6 cables), some device on an intervening switch or hub running at 
10 MB/S and causing all traffic to drop to 10 MB/S, or an older, 10 MB/S switch/hub itself. Correct the 
problem before continuing. 
 
Issue.  When a sync reference signal is connected to the Pipeline Quad the output SDI signal 
quality looks poor? 
Resolution. The sync reference signal needs to be a high quality SDI signal.  SDI signals reference 
signals derived from low quality input signals can cause the export signal not to be able to lock securely 
to the reference clock. 
 

 

** The following should only be done with the assistance of Telestream support 
staff ** 

Issue. My Pipeline’s LEDs are all blinking green rapidly one after another. 
Resolution. Your Pipeline has lost it’s serial number from non-volatile memory and will have to have it 
reprogrammed. Contact Pipeline support for instructions of reprogramming a Pipeline serial number. 
 

Re-programming a Pipeline’s serial number and resetting system defaults: 
 Re-program serial number 

 Find the Pipeline’s Serial Number and MAC address

 Open a CMD dialog 

 located on the bottom label of your 
Pipeline device. 

 Enter “telnet 169.254.1.1” 
 At the prompt “New serial number:” enter the last four (4) digits of the Serial Number

 At the prompt “Confirm that serial number <your serial number> is to be set into non-volatile 
(Y):”, enter “Y” and press “Enter”. 

 located 
on the bottom of your Pipeline device. 

 At the prompt “Confirm that MAC address generation overrides are to be set (Y/N):”, enter “N” 
and press “Enter”. 

 At the prompt “Confirm that NV configuration data should be erased (Y):”, enter “N” and press 
“Enter”. 

 Cycle the power to the Pipeline and wait for it to restart (about one [1] minute) 
 Reset Pipeline defaults settings (see Below)  

 
Issue. How can I upgrade or restore the default settings in my Pipeline if I have forgotten its IP 
Address or it has becomes unreachable? 
 
Resolution.  
Before you reset the Pipeline, you must obtain the MAC address of the Pipeline hardware. It can be found 
on the bottom of the Pipeline device. 

 
To prepare the computer to use the IP address that you desire the Pipeline hardware to use, a static ARP 
entry must be added to the computer’s ARP table. Follow these instructions: 
 

1. Unplug the Pipeline device. 
2. Open a command console on your Windows PC or a Mac. 
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3. Issue the following command to clear the ARP register. 
 

arp –d 
 

4. Issue the following command to link a new IP Address to the Pipeline’s MAC address 
 

arp -s 169.254.1.1 xx-xx-xx-xx-xx-xx (on a Windows PC) 
 
- or - 

  
arp -s 169.254.1.1 xx:xx:xx:xx:xx:xx (On Mac OS X) 

 
where xx-xx-xx-xx-xx-xx is your Pipeline’s MAC address. 

 
5. Next, prepare to interrupt the Pipeline during its boot cycle. First, enter http://169.254.1.1 in the 

URL window of your Web browser, but DO NOT press Enter.  
6. Now, re-insert the power into the Pipeline. When the Pipeline first powers up you’ll see all three 

LEDs (IN, OUT and PWR) glow green. When IN and OUT go out, press Enter to establish your 
browser’s connection to the Pipeline.  

 

 
 
7. If the interruption and connection is successful, your browser will display the Pipeline Direct Web 

Upgrade panel. Proceed to the next step. If not, repeat these steps from step 1. 
 

8. The Web Upgrade panel provides three options to choose from: 
 

 
 
 
 
Upgrade the Firmware 
By selecting a new firmware file, the 
Pipeline firmware can be updated. Normally 
this firmware file is a new application adding 
functionality or providing bug fixes. The 
firmware file can also be a new Application 
Loader. Note, by upgrading the Application 
Loader, it is possible to leave the Pipeline in 
an inoperable state if an upgrade to the 
Application Loader does not complete 
properly. Never remove power from a 
Pipeline while firmware is being loaded. 
 
Reset to the Default Settings 
This option allows the Pipeline to be reset to its default settings. If a user has assigned a static IP 
address to the device and subsequently forgotten it, this option allows the unit to reenter the self-
assigned, default, linklocal IP address mode. You can now connect to the device again using the 
default IP address printed on the bottom of the unit. 
 
Reboot the Pipeline 
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Once the Pipeline has been interrupted, the only way to operate the Pipeline in its normal mode 
again is to reboot the device. On reboot, the device will restart, which may be interrupted again or 
may be allowed to load the Pipeline Direct application. 

 
Issue.  I’m trying to fix my Pipeline with but can’t TELNET to 169.254.1.1? 
Resolution. Clear the ARP registry with an “arp –d” command and try again. 
 
Issue. The output LED on channel 4 of my Quad is flashing orange with a period of 1 second. 
Resolution. Integral to the quad is a network switch which aggregates the four pipeline channels.  If the 
external network is connected but one of the internal channels is not then the LED will flash.  This usually 
indicated a failure of one of the input channels.  You may also see this if you reboot one of the other 
channels while channel 4 is active. If after rebooting the issue does not clear itself contact Telestream 
technical support. 
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Issue.  How does my Pipeline know which time code source to use as its primary reference? 
Resolution. You can set Pipeline into an Auto select mode or specifically select which time code to use.  
 
In Auto mode the Pipeline selects the time code source according to the tables below (Note: Auto 
selection can be overwritten by selected Pipeline software applications) 
 

Available Time Code sources 

Auto time code - Pipeline single channel device 

  

Primary 
reference 

SDI Input time 
code available 

RS422 time code 
available 

SNTP time code 
available   

 

Time code 
Reference used 

by Pipeline 

- Available - 
  

RS422 

Available Not available - 
  

Input SDI VBI 

Not available Not available Available
  

SNTP Server 

Not available Not available Not available 
  

Zero based upon 
connection 

 
 

Quad 
option 

Auto time code - Pipeline Quad channel device 

 
Available Time Code sources 

 

Primary 
reference 

"Input SDI signal 
for Timecode" 

option 
 

SDI Input time 
code available 

RS422 time code 
available 

Ext Sync Ref 
 time code 
available* 

SNTP time code 
available 

 

Time code 
Reference used 

by Pipeline 

Checked  
 
Available - - - 

 
Input SDI VBI 

Checked  
 

Not available - - Available
 

SNTP Server 

Not Checked 
 

- Available - - 
 

RS422 

Not Checked 
 

- Not available Available - 
 

Ext Sync SDI VBI 

Not Checked 
 
Available Not available Not available - 

 
Input SDI VBI 

Not Checked 
 

Not available Not available Not available Available
 

SNTP Server 

Not Checked 
 

Not available Not available Not available Not available 
 

Zero based upon 
connection 
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To specifically select the time code source to use, open the Configure panel on the Pipeline Direct 
browser interface then select the Options tab and select the time code source you wish to use. Select 
Save Changes to save your selection. 
 

 

VTR deck control 
Issue. The VTR controls are gray or don’t respond. 
Resolution. Make sure your VTR is in remote mode. There is usually a physical switch on the front panel 
for operating in local or remote mode. When using Pipeline Direct, view the status bar directly above the 
video preview on the Live panel to see if it indicates local or remote. (If there is NO indication, the VTR is 
off or disconnected.) 
Resolution. Make sure the RS422 cable is connected properly and is not damaged, then try again. 

FlipFactory 
Issue. In FlipFactory v6.0 I get an error trying to open the Pipeline Control applet from Submit. 
What should I do? 
Resolution. The Pipeline Control applet uses a QuickTime for Java embedded media player. If 
QuickTime was installed before Java Run Time Environment v1.5 it will not properly install the required 
components supporting QuickTime for Java. To remedy this simply reinstalled QuickTime. 
 
Issue. Using FlipFactory v6.0 I get an internal error trying to choose a Pipeline device from the Pipeline 
EDL monitor setup or on the Select tab of the Pipeline Capture Editor. What should I do? 
 

 
 
Resolution. FlipFactory v6.0 installs all the necessary components for using Pipeline. One of these 
components is Apple’s Bonjour, a zero-configuration device discovery service that enables FlipFactory to 
find and display all Pipeline devices currently on your network. When Bonjour is installed by the 
FlipFactory installer, it is set in a disabled state. In order to enable it go to Control Panel-
>Administrative Tools->Services, right click the Bonjour Service and select Properties from the 
context menu. From the Bonjour Service Properties dialog select Automatic from the Startup type 
drop down menu, and then click Apply. Now click on Start and then OK. The Bonjour Service is now 
started and will start automatically each time the server is restarted. 
 
Resolution. If this error occurs on a system other than the one FlipFactory resides on you’ll need to 
install the Bonjour service. The Bonjour installer can be found on the Pipeline CD, the Pipeline support 
web page (http://www.telestream.net/support/support_pipeline_ff.htm) or on Apple’s web site at 
http://www.apple.com/support/downloads/bonjourforwindows.html.  

http://www.telestream.net/support/support_pipeline_ff.htm�
http://www.apple.com/support/downloads/bonjourforwindows.html�
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Issue. Our IT group policies do not allow the Bonjour service to run on our FlipFactory server. Can 
we use Pipeline without it? 
Resolution. Yes. You’ll need to add your Pipeline(s) to the system registry to allow FlipFactory to 
discover and communication to them. This option requires FlipFactory Pipeline update pack (XXXXXX) 

Add the following registry key: 
HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs\net\telestream\flip\engine\bonjour 

Add a string value here for all Pipeline devices  and add a comma delimited list e.g. 
btpipeline,169.254.12.236 

Any non IP addresses listed will need to be resolved on the client and the server by either a hosts file 
entry 169.254.12.235 btpipeline or by a DNS server 
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