Vantage
App Note

Using the Vantage®
Database Deployment Utility

This App Note
applies to
Vantage
Version 8.1

Note: This guide is written for video professionals who are familiar with using Vantage. To
implement applications in Vantage, you should know how to create workflows and submit jobs. If
you aren’t familiar with Vantage, we suggest that you review the Vantage User’s Guide and Vantage
Domain Management Guide as needed.
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Overview

Overview

The Vantage Database Deployment Utility allows you to upgrade or install a Vantage
database into an existing SQL 2012, 2014, 2016, or 2019 database instance. The utility auto-
discovers SQL database instances on your network and allows you to select the one you
wish to install the Vantage database into.

Because this utility installs a Vantage domain database into an existing SQL instance, it
allows you to use the existing database name and password. This allows you to create
Vantage systems using custom instance names other than VANTAGE.

Software Requirements

» The Vantage Database Deployment Utility works with Vantage version 8.1. Use the
utility version that matches the Vantage version you plan to use or upgrade to.

e SQL Server Express or Standard, 2012, 2014, 2016, or 2019

» SQL Server Management Studio (free download)

Licensing

The Vantage Database Deployment Utility works with any Vantage 8.1 license level.

Features

« Installs a Vantage database into an existing Microsoft SQL instance. This allows
custom database instance names and passwords. Users who need to distinguish
among multiple domain databases by different instance names and passwords can
do so.

» Upgrades existing Vantage database instances, making upgrades of standard,
mirrored, and clustered databases much faster and easier.

» Re-installs a clean version of a Vantage database into an existing database.

Limitations

« If you plan to use Windows authentication when deploying a database using the
Database Deployment Utility, you must also set the SQL Server service Log On to
the same Windows account that you use for database authentication. To change
the SQL Server service log on, select Start > Administrative Tools > Services > SQL
Server > Properties > Log On > This account.

e These instructions do not cover the installation of SQL or the creation of the
instance. Please refer to SQL documentation and contact Telestream for assistance
if your Vantage installation includes a mirrored or clustered database configuration.
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Overview

Prerequisites for Instance Installation

It is assumed you have already created a SQL database instance into which a Vantage
database instance can be deployed. The database instance must meet certain
prerequisites before you can use the Vantage utility to deploy a Vantage database
instance:

e The SQL instance must be deployed as a named instance.

e The SQL instance mustinclude a SQL or active directory user account. The user can
be sa or another account, and any password may be used.

» The user account installing the Vantage database must have the sysadmin role
assigned. The following steps explain how to assign a role.

» The user account running the Vantage database after it is installed can have the
db_owner and dbcreator roles assigned instead of sysadmin, if you prefer the user to
have lower privileges.

Configuring the Administrator Role

1. In the SQL Server Management Studio > Object Explorer panel, expand Security,
and expand Logins.

2. Right-click the sa user or another user that you want to use as the administrator
login, and select Properties.

3. Goto Server Roles and enable sysadmin. Click OK. This gives the user system
administrator privileges for the database instance.

|3 Login Properties - TELESTREAM\chuckp =B
Selectapage ' - i
Script ~ H
2 General S5 13 Help
£y
42 User Mapping Server role is used to grant serverwide security privileges to a user.
47 Securables
A2 Status
Server roles:
[7] bulkadmin
[ dbereator
[F] diskadmin
[C] processadmin
] public
[ securityadmin
[] serveradmin
[] setupadmin
[¥] sysadmin
Connection
Server:
W-LHUCKF\DBUTILTEST
Connection:
sa
S View connection properies
Progress
Ready
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Configuring the Vantage User Role

1. Right-click the current Windows user and select Properties.

2. Click User Mapping. Check master or Vantage (if present) in the database column,
and check db_owner. Click OK.

5 Login Properties - TELESTREAM\chuckp (= i

g‘ Server Roles

g" User Mapping Users mapped to this login:

ﬁz Securables M Database User Default Schema

' Status TELESTREAM\chuckp =

[} msdb
[[]  tempdb
Vartage
Database role membership for: master
Conneclion
("] db_accessadmin
Server:
WCHUCKPADBUTILTEST % SE_:;‘::::?EIN
Comnecton: [] db_datawrer
TELESTREAM‘chuckp [] db_ddlzdmin
) ) [ db_denydatarzader
_‘!j View connection properties :| db_derydatawriter
Hoower
Progress [] db_securityadmin
[¥] public
Ready
i OK i Cancel

3. Right-click the Windows user and select Properties again.

4, Click Server Roles and check dbcreator to enable it. Click OK. This gives the current
Windows user sufficient privileges to run the Vantage database instance after
installation.

5 Lagin Properties - NT AUTHORITY\SYSTEM [E=REEn

Seleclapage l -

14 General ; o m FE3

ﬁ Server Foles

147 User Mapping Server role s used to gmnt server-wide security privileges to a user.

% Securables
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Server roles:
[ bulkadmin
[ diskadmin
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Overview

5. In the SSMS left panel, right-click the server name, and select Properties. Select
Memory and set Maximum server memory (in MB) to 75% of the host system’s
memory. For example, if the system's memory is 8 GB (8192 MB), then the
maximum server memory for SQL should be set to 6 GB (6144 MB, or in round
numbers 6,000,000,000 bytes).

6. Click OK and select File > Exit to close the Microsoft SQL Server Management
Studio.
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Using the Database Deployment Utility

Following the steps provided in this section, you can use the Database Deployment
Utility to perform these tasks:

» Upgrade an existing Vantage database to the current (8.1) structure while retaining
existing contents.

 Attach an existing (detached) Vantage database to a SQL instance and upgrade the
database to the current (8.1) structure while retaining existing contents.

« Install (or replace) a clean, new Vantage 8.1 database into a SQL instance. If replacing
an existing database, this option deletes all existing contents.

Note: The word “detached”is defined here as follows: When Vantage 7.1 (or earlier) is
uninstalled, the Vantage database files physically remain where they were installed in a
standard or custom location, but the database can become disassociated or “detached”
from the SQL instance. You can use the Database Deployment Utility to browse and select
the folder containing the database, which you can then reattach and upgrade. For
Vantage 7.2, 8.0, and 8.1, the Vantage database no longer becomes detached when
Vantage is uninstalled.

1. Launch the DatabaseDeploymentUtility.exe file.
The license agreement opens.

Vantage Database Deployment Utility

Vantage Domain Database 8.1.0

VANTAGE™ SOFTWARE
LICENSE TERMS AND CONDITIONS

PLEASE READ THIS CAREFULLY BEFORE INSTALLING
THIS SOFTWARE.

THIS AGREEMENT STATES THE TERMS AND
CONDITIONS UPON WHICH TELESTREAM, LLC
(“TELESTREAM™) OFFERS TO LICENSE TO YOU
(*YOU™ OR “YOUR") THE RIGHT TO USE A LIMITED
NUMBER OF COPIES OF ITS VANTAGE SOFTWARE AS
SPECIFIED IN THE APPLICABLE TELESTREAM
INVOICE. AMONG OTHER THINGS, THIS AGREEMENT
CONTAINS WARRANTY DISCLAIMERS. BY CLICKING
THE ‘1 ACCEPT" BUTTON YOU ARE AGREEING TO
BECOME BOUND BY THE TERMS OF THIS
AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS
OF THIS AGREEMENT, DO NOT CLICK ON ‘I ACCEPT;
AND CONTACT TELESTREAM FOR A FULL REFUND.

THIS AGREEMENT APPLIES TO ALL VANTAGE

| accept the license agreement

2. Check the I accept the license agreement check box, and click Next.

A list of available SQL database instances opens.
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Using the Database Deployment Utility

3. Select a Host and Instance in the left panel.

Vantage Database Deployment Utility

Choose the SQL instance where the database will be deployed
Host Instance = Host: I0A-C6100-5-1
QA-C6100-5-1 VANTAGE
ATS-RUNNER-1B VANTAGE
ATS-RUNNER-2 VANTAGE Authentication: ‘@ Windows Authentication
ATS-RUNNER-3 VANTAGE Sql Server Authentication
ATS-RUNNER-4 VANTAGE
ATS-RUNNER-5 VANTAGE
ATS-RUNNER-6 VANTAGE
ATS-RUNNER-7 VANTAGE
ATS-STAGING VANTAGE
BMO-RESULTS VANTAGE
CML-SECONDARY  VANTAGE
ENG-LIVE-2 VANTAGE

Instance: VANTAGE

Refresh Previous " Connect

4. In the right panel, choose an Authentication method for logging into SQL Server,
either Windows or SQL Server.

No matter which authentication method you choose, you must have the sysadmin
role assigned to install a Vantage database instance.

IMPORTANT: If you use Windows authentication, you must set the SQL Server
service Log On to the same Windows account that you use for database
authentication. Otherwise, you will receive a logon error message.

To change the SQL Server service Log On, select Start > Administrative Tools >
Services > SQL Server > Properties > Log On > This account.

5. Enter the authentication User name and Password, if required, and click Connect.

6. The utility searches for SQL instances with Vantage databases and reports on its
findings. Depending on the dialog displayed, you may select one of the following
deployments:

- Attached Vantage Database Found—Upgrade or Replace

Finds a SQL Server instance with an attached, upgradeable Vantage database. In
the dialog, notice that the Database location field is filled in and the Browse
button is disabled. In this instance, you can choose Upgrade to upgrade the
attached Vantage database, or you can choose Replace existing database in which
case all existing data will be lost.
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Using the Database Deployment Utility
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Vantage Database Deployment Utility

This SQL instance contains an existing Vantage Database.

Host name: QA-CH100-5-1
Instance name: VANTAGE
Database version: 8.1.0

Database location:

What would you like to do?
Upgrade

Replace existing database

Upgrade—Select this if you want to retain the domain database contents but
upgrade to the current Vantage database structure. If you select Upgrade and
then select Install, the database is upgraded to 8.1 and the installation complete
message appears.

Note: You cannot downgrade a database; upgrading moves a database forward
from previous versions to the current version.

Replace existing database—Select this if you want to completely overwrite the
current database contents. If you select Replace existing database and then click

Install, a warning message opens as shown to advise you that your database will
be completely erased and replaced if you continue. Click OK to continue.

Are you really really sure?

You are about to replace the existing Vantage

ﬂ Domain Database with a new blank database. This

process cannot be undone. Are you sure you want to
do this?

Warning: If you select Replace existing database, all Vantage database contents
WILL BE ERASED and replaced. If you want to keep the current database
contents, back up your database prior to using the database deployment utility
by using the Vantage Management Console. Backing up the current database
before upgrading is strongly recommended, but it is not required. For

Vantage
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Using the Database Deployment Utility

information regarding how to backup an existing database, refer to Backing up
the Existing Database, in the Vantage Database Setup application note.

- No Vantage Database Found—Select and Upgrade an Existing Detached
Database

Finds no attached Vantage database, but allows you to browse to a folder with an
existing Vantage database for reattachment then upgrade to 8.1. Enter your
existing database location.

Vantage Database Deployment Utility

No Vantage Database is attached or could be found in the default location.

To attach an existing database, please use the Browse dialog below to select the Folder
containing the MDF file.

Otherwise, A new Vantage Domain Database will be deployed to the Database location
below.

Host name: LS3-TECHPUBS
Instance name: VANTAGE

Database version:

Database location: C:\Program Files (x86)\Telestream\Vantage\Database Browse...

Cancel Previous Install

If you enter or browse to a database location and a database is found in that
location, the Reattach and Upgrade dialog is immediately displayed. If the
Vantage database is detached, the utility attaches it to SQL and upgrades it.
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Vantage Database Deployment Utility

A detached Vantage Database was found at the Database Location below.

Host name: LS3-TECHPUBS
Instance name: VANTAGE
Database version:

Database location:

What would you like to do?

@' Reattach and Upgrade

Cancel Previous

Note: In the dialog the Browse button is unavailable, as well as the Replace existing
database option. The Database location field is auto populated with the location of the
database that you specified in the previous dialog.

Select Reattach and Upgrade then Install. After reattachment, the database is
upgraded to 8.1 and the installation complete message appears.

- No Vantage Database Found—Install a new Database

Enter a database location or Browse to a folder where you want the database to
reside. Click Install. The utility will recognize that this folder has no database, and
will deploy a new Vantage database in this location.
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Installing Vantage

7. Awindow opens to show progress and advises you when the installation or,
depending on your selection, when the upgrade is complete.

Vantage Database Deployment Utility

Upgrade complete

Host name: LS3-TECHPUBS

Instance name: VANTAGE

Finish

Click Finish when the progress window indicates that the installation or the
upgrade has completed.

Installing Vantage

Now that you have a new or upgraded Vantage database, you are ready to install or
upgrade all of the Vantage clients and components. For detailed instructions for a new
Vantage installation, see the Installing Vantage chapter of the Vantage Domain
Management Guide. For detailed instructions for upgrading Vantage, see the
Upgrading and Modifying Vantage chapter in the Vantage Domain Management
Guide.
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Copyright and Trademark Notice

Copyright © 2022 Telestream, LLC and its Affiliates. All rights reserved. No part of this
publication may be reproduced, transmitted, transcribed, altered, or translated into any
languages without written permission of Telestream, LLC. Information and
specifications in this document are subject to change without notice and do not
represent a commitment on the part of Telestream. Specifications subject to change
without notice.

Telestream, CaptionMaker, Cerify, DIVA, Episode, Flip4Mac, FlipFactory, Flip Player,
GraphicsFactory, Kumulate, Lightspeed, MetaFlip, Post Producer, ScreenFlow, Switch,
Tempo, TrafficManager, Vantage, VOD Producer, and Wirecast are registered trademarks
and Aurora, ContentAgent, Cricket, e-Captioning, Inspector, iQ, iVMS, iVMS ASM,
MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port, CaptureVU, FlexVU, PRISM,
Sentry, Stay Genlock, Aurora, and Vidchecker are trademarks of Telestream, LLC and its
Affiliates. All other trademarks are the property of their respective owners.

All other brand, product, and company names are the property of their respective
owners and are used only for identification purposes.
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