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Overview

The Vantage Database Deployment Utility allows you to upgrade or install a Vantage database into
an existing SQL 2012, 2014, or 2016 database instance. The utility auto-discovers SQL database
instances on your network and allows you to select the one you wish to install the Vantage database
into.

Because this utility installs a Vantage domain database into an existing SQL instance, it allows you to
use the existing database name and password. This allows you to create Vantage systems using
custom instance names other than VANTAGE.

Software Requirements

» The Vantage Database Deployment Utility works with Vantage version 7.2. Use the utility
version that matches the Vantage version you plan to use or upgrade to.

» SQL Server Express or Standard, 2012, 2014, or 2016

» SQL Server Management Studio (free download)

Licensing

» The Vantage Database Deployment Utility is available for use with any Vantage license level.

Features

« Installs a Vantage database into an existing Microsoft SQL instance. This allows custom
database instance names and passwords. Customers who need to distinguish among mul-
tiple domain databases by different instance names and passwords can do so.

» Upgrades existing Vantage database instances, making upgrades of standard, mirrored,
and clustered databases much faster and easier.

» Re-installs a clean version of a Vantage database into an existing database.

Limitations

« If you plan to use Windows authentication when deploying a database using the Database
Deployment Utility, you must also set the SQL Server service Log On to the same Windows
account that you will use for database authentication. To change the SQL Server service log on,
select Start > Administrative Tools > Services > SQL Server > Properties > Log On > This account.

» These instructions do not cover the installation of SQL or the creation of the instance.
Please refer to SQL documentation and contact Telestream for assistance if your Vantage
installation includes a mirrored or clustered database configuration.
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Prerequisites for Instance Installation

It is assumed you have already created a SQL database instance into which a Vantage database
instance can be deployed. The database instance must meet certain prerequisites before you
can use the Vantage utility to deploy a Vantage database instance:

The SQL instance must be deployed as a named instance.

The SQL instance must include a SQL or active directory user account. The user can be sa or
another account, and any password may be used.

The user account installing the Vantage database must have the sysadmin role assigned.
The steps below explain how to assign a role.

The user account running the Vantage database after it is installed can have the db_owner
and dbcreator roles assigned instead of sysadmin, if you prefer the user to have lower privi-
leges.

Configuring the Administrator Role

1.

In the SQL Server Management Studio > Object Explorer panel, expand Security, and
expand Logins.

. Right-click the sa user or another user that you want to use as the administrator login, and

select Properties.

. Go to Server Roles and enable sysadmin. Click OK. This gives the user system administrator

privileges for the database instance.

[ Login Properties - TELESTREAM\chuckp =Ny X
Selecta page , = v I
1P General ; Script I3 Help
il Server Roles
44 |ser Mapping Server role is used to grant server-wide security privileges to a user.
# Securables
1 Status
Server roles:
[T bulkadmin
[] dbereator
[] diskadmin
[ processadmin
[¥] public
[T securityadmin
[] serveradmin
[] setupadmin
[¥] sysadmin
Connection

Server:
W-CHUCKPA\DBUTILTEST

Connection:
sa

3 View connection properties

Progress
Ready

oK | [ Cancel
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Configuring the Vantage User Role

1. Right-click the current Windows user and select Properties.
2. Click User Mapping. Check master or Vantage (if present) in the database column, and check

db_owner. Click OK.

db_denydatarsader
3 View connection properties % db_denydatawriter

Progress [] db_securityadmin
[¥] public
Ready

Boower

5 Login Properties - TELESTREAM\chuckp (= i
Select apage I . -
. S - Hell
_’@Geneml ; =5 Lj z
1 Server Roles
_4": User Mapping Users mapped to this login:
g Securables Database User Default Schema
B Status master TELESTREAM\chuckp =
mode
[} msdb
[[]  tempdb
Vartage
Database role membership for: master
‘Connection
("] db_accessadmin
Server: [ db_backupoperator
WLHUCKPA\DBUTILTEST 7] db_datareader
Cennection: [ db_datawrter
TELESTREAM \chuckp [C] db_ddizdmin

3. Right-click the Windows user and select Properties again.
4, Click Server Roles and check dbcreator to enable it. Click OK. This gives the current Windows

user sufficient privileges to run the Vantage database instance after installation.

5 Lagin Properties - NT AUTHORITY\SYSTEM [E=REEn
Seleclapage l i v
14 General ; £ Lj =
f Server Foles
_»%N UUser Mapping Server role s used to grant server-wide security privileges to a user.
% Securables
& Stahs
Server roles:
[ bulkadmin
[ diskadmin
|| processadmin
[¥] public
[ securityadmin
[ eerveradmin
[ setupacmin
[ sysadmin

5. In the SSMS left panel, right-click the server name, and select Properties. Select Memory and
set Maximum server memory (in MB) to 75% of the host system’s memory. For example, if the
system's memory is 8 GB (8192 MB), then the maximum server memory for SQL should be
set to 6 GB (6144 MB, or in round numbers 6,000,000,000 bytes).

6. Click OK and select File > Exit to close the Microsoft SQL Server Management Studio.
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Using the Database Deployment Utility

Following the steps below, you can use the Database Deployment Utility to perform these tasks:

a. Upgrade an existing Vantage database to the current (7.2) structure while retaining

existing contents.
b. Attach an existing (detached) Vantage database to a SQL instance and upgrade the database

to the current (7.2) structure while retaining existing contents.

c. Install (or replace) a clean, new Vantage 7.2 database into a SQL instance. If replacing an
existing database, this option deletes all existing contents.

Note: The word “detached” can be defined as follows. When Vantage 7.1 (or earlier) is

uninstalled, the Vantage database files physically remain where they were installed in a standard

or custom location, but the database can become disassociated or “detached” from the SQL

instance. You can use the Database Deployment Utility to browse and select the folder containing
the database, which you can then reattach and upgrade. For Vantage 7.2 and later, the Vantage

database no longer becomes detached when Vantage is uninstalled.

1. Launch the DatabaseDeploymentUtility.exe file.

The license agreement opens.

Vantage Database Deployment Utility

2. Check the I accept the license agreement checkbox, and click Next.
A list of available SQL database instances opens.
3. Select a Host and Instance in the left panel.

Vantage Domain Database 7.2.0

VANTAGE™ SOFTWARE
LICENSE TERMS AND CONDITIONS

PLEASE READ THIS CAREFULLY BEFORE INSTALLING
THIS SOFTWARE.

THIS AGREEMENT STATES THE TERMS AND
CONDITIONS UPON WHICH TELESTREAM, LLC
(“TELESTREAM”) OFFERS TO LICENSE TO YOU
{(“YOU” OR “YOUR") THE RIGHT TO USE A LIMITED
NUMBER OF COPIES OF ITS VANTAGE SOFTWARE AS
SPECIFIED IN THE APPLICABLE TELESTREAM
INVOICE. AMONG OTHER THINGS, THIS AGREEMENT
CONTAINS WARRANTY DISCLAIMERS. BY CLICKING
THE ‘I ACCEPT' BUTTON YOU ARE AGREEING TO
BECOME BOUND BY THE TERMS OF THIS
AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS
‘OF THIS AGREEMENT, DO NOT CLICK ON ‘I ACCEPT,
AND CONTACT TELESTREAM FOR A FULL REFUND.

THIS AGREEMENT APPLIES TO ALL VANTAGE

| accept the license agreement

Vantage Database Deployment Utility

Choose the SQL instance where the database will be deployed

Host
LS3-TECHPUBS
BUILDTEST3
BUILDTESTE
DAVIDR_VAN2012
ESS-COREYC

Instance % hocp LS3-TECHPUBS
VANTAGE

VANTAGE Instance: VANTAGE

VANTAGE Authentication: Windows Authentication

VANTAGE ® Sgl Server Authentication

VANTAGE
VANTAGE
VANTAGE
VANTAGE

QA-BROOKEM-TEST VANTAGE
WIN-S8ITNNUOOQFF  VANTAGE
WIN-ECO3TD2GEOL  VANTAGE

C1758 VANTAGE

Using the Database Deployment Utility

Previous | Connect
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4. In the right panel, choose an Authentication method for logging into SQL Server, either
Windows or SQL Server.

No matter which authentication method you choose, the user must have the sysadmin role
assigned to install a Vantage database instance.

IMPORTANT: If you use Windows authentication, you must also set the SQL Server service
Log On to the same Windows account that you will use for database authentication. Other-
wise, you will receive a logon error message.

To change the SQL Server service Log On, select Start > Administrative Tools > Services >
SQL Server > Properties > Log On > This account.

5. Enter the authentication User name and Password, if required, and click Connect.
The utility searches for SQL instances with Vantage databases and reports on its findings:
a. Finds a SQL Server instance with an attached, upgradeable Vantage database... or
b. Finds an upgradeable Vantage database that is detached from the SQL instance... or

c. Finds no Vantage database, but allows you to browse to a Vantage database if one exists.
If you browse to an existing database, the utility will attach and update it in the next step.
Otherwise, the utility deploys a new Vantage database.

Attached Vantage DB Found Detached Vantage Database Found

Vantage Database Deployment Utility

[ Vantage Database Deployment Utility

A detached Vantage Database was found at the Database Location below.

This SQL instance contains an existing Vantage Database

Host name: LS3-TECHPUBS. Host name: LS3-TECHPUBS

Instance name: VANTAGE Instance name: VANTAGE

Datab, sion:
Database version: 7.2.0 atabase version:

Database location: | C

What would you like to da?
What would you like to do?
Upgrade

® Reattach and Upgrade
Replace existing database

Cancel Previous

Cancel Previous

No Vantage DB Found

| Vantage Database Deployment Utitity

No Vantage Database is attached or could be found in the default location,

To attach an existing database, please use the Browse dialog below to select the Folder
containing the MDF file.

Otherwise, A new Vantage Domain Database will be deployed to the Database location
below.

Host name: LS3-TECHPUBS
Instance name: VANTAGE
Database version:

Database location: C:\Program Files (x86)\Telestream\Vantage\Database Browse...

Cancel Previous | Ipstall |

. oge r—\
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6. Select the type of deployment you want to do, either a or b:

a. Upgrade—Select this if you want to retain the domain database contents but upgrade
to the current Vantage database structure. If the Vantage database is detached, the utility
will attach it to SQL and upgrade it.

Note: You cannot downgrade a database; upgrading will only move a database forward
from previous versions to the current version.

b. Replace existing database—Select this if you want to completely erase the database
contents and install a new, clean Vantage database or create one where none exists.

Warning: If you select Replace, all Vantage database contents WILL BE ERASED and
replaced. Back up your database first using the Vantage Management Console if you
want to keep the contents. Backing up before upgrading is also wise but not required.

7. Click Install.

8. If you selected Replace existing database, a warning message opens to advise you that your
database will be completely erased and replaced if you continue.

Are you really really sure?

You are about to replace the existing Vantage
ﬂ Domain Database with a new blank database. This

process cannot be undone. Are you sure you want to
do this?

[ ok || Cancel |

9. Click OK to install the upgraded or new database.
10. A window opens to show progress and advises you when the installation is complete.

Vantage Database Deployment Utility

Upgrade complete

Host name: LS3-TECHPUBS

Instance name: VANTAGE

11. Click Finish when the progress window indicates Installation/Upgrade Complete.

The database has now been converted/upgraded to a current Vantage database. If you
chose Upgrade, the Vantage domain database contents remain intact, but the database
structure is upgraded. If you chose Replace, a clean Vantage domain database is installed.
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Installing Vantage

Now that you have an available, new or upgraded Vantage database, you are ready to install all
of the Vantage clients and components. The following instructions are abbreviated. For
detailed instructions, see the Installation chapter of the Vantage Domain Management Guide.

1. Run the Vantage_Setup.exe installer to install or upgrade Vantage:

a. New Vantage Installations: If you are installing a new Vantage instance, when you run
the Vantage_Setup.exe installer, select Array (Multi-Node) Installation, select Custom
Install, and select the components you want installed but do NOT select Database.
Vantage and the selected components will be installed, but the database is not altered.

b. Upgrading Vantage: If you are upgrading an existing Vantage instance, first use the
Control Panel Programs and Features to remove only Vantage but leave MS SQL and the
domain database in place. Then run the Vantage_Setup.exe installer, select Array (Multi-
Node) Installation, select Custom Install, and select the components you want installed,
but do NOT select Database. Vantage and the selected components will be installed, but
the database is not altered.

2. If necessary, use the Vantage Management Console > File > Change Vantage Domain
(shown below) to connect your new or upgraded Vantage installation to the deployed
database.

Click Search to search for and select a Vantage domain, or for a custom database, click Spec-
ify Vantage Domain name/IP address, and enter the server name, the custom database
name, expand the Connection settings, and enter the custom Login and Password. When
you click OK, the Vantage Management Console should connect to the database and begin
normal operation.

Select Vantage Domain Select Vantage Domain

Select a Vantage Domain:

Select a Vantage Domain: 3RDPARTY

W-MICHELLEI3

¥ Connection Settings W-TECHPUBSTEST

Enter name or IP address of your Vantage Domain server:

W-CHUCKP

Specify Vantage Domain name/IP address | | Cancel

Enter the Vantage instance name:

DBUTILTEST

~ Connection Settings

Specify the connection settings for accessing the Vantage SQL Server
database. Normally you will use the default values, unless your Vantage
administrator has specified otherwise.

Login: sa

Password: sessssssss

[ oK | Cancel

REMINDER: If you use Windows authentication, you must also set the SQL Server service
Log On to the same Windows account that you will use for database authentication. To
change the SQL Server service Log On, select Start > Administrative Tools > Services > SQL
Server > Properties > Log On > This account.

/_-\
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3. If necessary (for a new installation), install Vantage licenses using the Vantage Management
Console > Licenses panel and configure Vantage as described in the Vantage Domain
Management Guide.

T
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Copyright and Trademark Notice

Copyright © 2019 Telestream, LLC. All rights reserved. No part of this publication may be
reproduced, transmitted, transcribed, altered, or translated into any languages without written
permission of Telestream. Information and specifications in this document are subject to
change without notice and do not represent a commitment on the part of Telestream.

Telestream, CaptionMaker, Episode, Flip4Mac, FlipFactory, Flip Player, Lightspeed, ScreenFlow,
Switch, Vantage, Wirecast, Gameshow, GraphicsFactory, MetaFlip, and Split-and-Stitch are
registered trademarks and MacCaption, e-Captioning, Pipeline, Post Producer, Tempo,
TrafficManager, VidChecker, and VOD Producer are trademarks of Telestream, LLC. All other
trademarks are the property of their respective owners.
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