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Preface
SUPPORT AND INFORMATION

For assistance or information about Telestream or its products, please 
contact us via any of these methods:

Internet Web Site. www.telestream.net

Technical Support. support@telestream.net

Licensing. license@telestream.net

Sales and Marketing. info@telestream.net

USA Telephone Main. (530) 470-1300

Support Services. (877) 257-6245 from 6 am to 6 pm weekdays, 
excluding U. S. holidays. Terms and times of support services vary, based 
on the terms of your current service contract with Telestream.

Mail Telestream, Inc. 
848 Gold Flat Road-Suite 1
Nevada City, CA. USA 95959

International See our Web site for your regional authorized Telestream distributor.

HOW TO USE THIS GUIDE

This guide provides installation instructions for GraphicsFactory®, helps 
you get up and running quickly, and gain a high level understanding of 
how GraphicsFactory works. You may view or print this guide with 
Adobe Acrobat Reader. The guide is also available by selecting start > 
Programs > Telestream > GraphicsFactory > GraphicsFactory User’s 
Guide. Appendices contain specification and capabilities information.
About-1
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In addition to a table of contents, figures, and an index, this guide 
contains the following sections:

Chapter 1, Introduction to GraphicsFactory

This chapter describes the family of FlipFactory products. It also 
describes how to get started with FlipFactory.

Chapter 2, Installing GraphicsFactory Tools

This chapter describes how to download and install the GraphicsFactory 
Template Creator and Submit tool, and how to obtain and update your 
license in FlipFactory to enable GraphicsFactory features and capabilities. 

Chapter 3, Guided Tours

This chapter offers guided tours of GraphicsFactory. In the first tour, you 
learn about the architecture and components of GraphicsFactory – how it 
is organized and how it works.

In the second tour, you’ll launch GraphicsFactory Template Creator and 
preview a GraphicsFactory template, submit it with the Job Submission 
Tool and play the output video.

In the third tour, you’ll build your own template to produce a Windows 
media file with graphics incorporated and play it. In the final tour, you’ll 
learn about different GraphicsFactory workflows and advanced features. 
You can take all the tours in about an hour.

Chapter 4, GraphicsFactory Workflows

This chapter describes the GraphicsFactory Process/Analyze filter and the 
GraphicsFactory product filter, and describes various automation 
workflows and factory configurations to support them.
About-2 July 2008
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NOTATIONAL CONVENTIONS

The guide uses certain conventions used to make the guide more readable.

Notes, Tips & 
Cautions

Three special paragraphs are set in particular type with an icon to gain 
your attention in special circumstances: 

TYPOGRAPHICAL CONVENTIONS

Certain typographical conventions are used as visual clues in this guide. 
Sample information, or a specific format to be used when entering 
information, is shown in italics, or in a courier-style font. For example: 

Type your domain (mydomain.com) in the domain field.

Type import FileName where FileName is the fully-qualified path.

WE'D LIKE TO HEAR FROM YOU!

If you have comments or suggestions about improving this document, 
other Telestream documents, or our Web site – or if you've discovered an 
error or omission, please email us at support@telestream.net.

Note
Notes highlight important information about the topic you’re 
studying. Be sure to read this information before continuing.

Tip
Tips are bits of information you might not be aware of, or that make 
using GraphicsFactory easier.

Caution
A caution paragraph indicates an action that may cause 
potential loss of data, or other permanent changes to 
GraphicsFactory or your media assets.
July 2008 About-3
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Introduction to
GraphicsFactory
WELCOME TO GRAPHICSFACTORY!

GraphicsFactory® is a specialized, licensed version of FlipFactory you 
can use to quickly and efficiently create video with text, image, movie, 
and sound overlays.

UP AND RUNNING 

To install GraphicsFactory tools and get up and running quickly, 
Telestream recommends the following steps:

Step 1 Use “Installing GraphicsFactory Tools” on page 2–1 to install 
GraphicsFactory tools on your workstations, update FlipFactory servers 
for processing GraphicsFactory jobs, and obtain GraphicsFactory licenses 
from Telestream and install them.

Step 2 Take the guided tours in Chapter 3 “Guided Tours” on page 3–1. In about 
an hour, you’ll learn how GraphicsFactory works and its components. 
You’ll also learn how to use the GraphicsFactory Template Creator to 
create templates and how to use the Job Submit application to submit 
GraphicsFactory jobs and monitor their progress.

Step 3 Use Chapter 4 “GraphicsFactory Workflows” on page 4–1 and as a 
reference when building GraphicsFactory factories for transcoding your 
video with various overlays, and submitting jobs for GraphicsFactory 
processing.
July 2008 1-1
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Installing GraphicsFactory
Tools
Use this chapter to download the GraphicsFactory® Tools installer which 
installs the GraphicsFactory Template Creator and the GraphicsFactory 
Submit tool. This chapter also describes how to obtain and update your 
FlipFactory server license to enable GraphicsFactory features.

Topics Platform Requirements (page 2-1)
Downloading the GraphicsFactory Tools Installer (page 2-1)
Installing GraphicsFactory Tools (page 2-2)
Obtaining and Installing the GraphicsFactory License (page 2-3) 

PLATFORM REQUIREMENTS

GraphicsFactory tools can be used on the FlipFactory server, or on 
computers other than the FlipFactory server itself. GraphicsFactory tools 
are compatible with these operating systems:

Windows XP or XP Pro
Windows 2003 Server

DOWNLOADING THE GRAPHICSFACTORY TOOLS INSTALLER

To obtain the installer from the Telestream Web site, follow these steps:

Step 1 Use your Web browser to go to http://www.telestream.net/flipfactory.

Step 2 If you’re not registered, click to display the Register page. Complete the 
form and click Download FlipFactory. You can use your user name and 
password immediately. Telestream will email you a confirmation email.

Step 3 Enter your authorized user name and password, then click Log In.

Step 4 On the FlipFactory & GraphicsFactory Download page, click the current 
Version 6.1 link to display the FlipFactory Family Downloads page.
July 2008 2-1
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Step 5 Click GraphicsFactory download link to display the GraphicsFactory 
Download page.

Step 6 Click the GraphicsFactory installer for FlipFactory 6.1 to download and 
save the installer package.

INSTALLING GRAPHICSFACTORY TOOLS

When you run the GraphicsFactory installer, it performs the following:

Creates a Telestream/GraphicsFactory directory
Installs the GraphicsFactory Template Creator, Submit tool, and 
related files (DLLs, PDFs, etc.), along with samples.
Creates Telestream > GraphicsFactory > GraphicsFactory Template 
Creator and Submit Tool entries in the Start > Programs list

Upgrading 
GraphicsFactory Tools

If you are using previous versions of GraphicsFactory tools, uninstall the 
them before installing the current version:

Step 1 Make sure that you have exited both GraphicsFactory tools: Template 
Creator and Job Submit tool.

Step 2 Click Start > Control Panel > Add or Remove Programs and select 
GraphicsFactory Creator.

Step 3 Click Remove to uninstall the GraphicsFactory tools.

This action does not remove your templates or any media.

Installing 
GraphicsFactory Tools

To install the GraphicsFactory tools, follow these steps:

Step 1 Run the GraphicsFactory installer (locally or from a server) and follow 
the steps in the installer:

Step 2 The installer runs and displays the Welcome window:

Step 3 Welcome Window. In the Welcome window, click Next to display the 
license agreement.

Step 4 License Terms. Click Yes if you agree to the license terms. Click Next to 
continue.

Step 5 Customer Information. Enter your user name and organization 
information, check Anyone or Only Me for using this application 
(Anyone is recommended) and click Next. 

Step 6 Destination Folder. Accept the default folder or click Change to select 
an alternate folder. Click Next to install the tools.

Step 7 Installation Wizard Completed. Click Finish to exit the wizard.
2-2 July 2008
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OBTAINING AND INSTALLING THE GRAPHICSFACTORY LICENSE

Before you can begin using GraphicsFactory or take the tours in the 
GraphicsFactory User’s Guide, you must obtain and install a 
GraphicsFactory license from Telestream. 

Obtain the License If you are evaluating GraphicsFactory, your license enables all of 
GraphicsFactory’s features, and expires on the date shown in the feature 
section at the bottom of the email (usually 15 days from its start date). 

If you registered with Telestream to download GraphicsFactory tools, 
Telestream verifies your customer information and emails you a no-cost 
demo license file, usually within one business day of registering. Demo 
licenses cause a watermark to be branded in your media.

If you are a current Telestream customer, log on to the Telestream Web 
site at http://www.telestream.net/flipfactory and click Obtain License to 
request a license file for GraphicsFactory.

Installing the 
License on a 
Workstation

If you installed GraphicsFactory tools on the GraphicsFactory server, 
proceed to Install or Update the FlipFactory License, below.

If you installed GraphicsFactory tools on a different computer than the 
GraphicsFactory server, follow these instructions to install the license for 
the GraphicsFactory tools:

Step 1 Place the attached license.dat file in the GraphicsFactory License folder 
(default C:\Program Files\Telestream\GraphicsFactory\License).

Step 2 Run the GraphicsFactory Template Creator to validate that your license is 
correct and is stored in the correct folder. If the Template Creator can’t 
locate the license file or it is not a valid GraphicsFactory license, 
Template Creator displays a dialog to notify you of the problem.

Install or Update 
the FlipFactory 
Server License

If you installed GraphicsFactory tools on your FlipFactory server, you 
only need to install or update the license in the FlipFactory license folder.

Note
You can download and install GraphicsFactory tools without a 
license. However, you cannot perform GraphicsFactory 
processing or use the Template Creator without a license.
To use GraphicsFactory for evaluation, please send the 
licensing group an email request (see Support and Information 
in About This Guide).
July 2008 2-3
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When you receive the GraphicsFactory License File email, follow the 
steps in the email to install or update the license on each FlipFactory 
server you’ve licensed for GraphicsFactory:

Step 1 Place the attached license.dat file in the FlipFactory license folder 
(default C:\Program Files\Telestream\FlipFactory\License).

Step 2 Restart your server before processing any jobs.
2-4 July 2008
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Guided Tours
GraphicsFactory is a template-driven, file-based graphics workflow 
automation and assembly system. GraphicsFactory allows you to 
assemble layers of images, QuickTime movies, text, audio files, and other 
elements, apply timeline effects, and merge the resulting graphics and 
audio into your video files during job processing.

The tours in this chapter will help you understand the concepts and 
features of GraphicsFactory.

Tour 1 describes GraphicsFactory components, how GraphicsFactory 
works. In Tours 2 and 3, you'll explore how to use the tools to create and 
apply graphics and how to submit GraphicsFactory jobs for processing.

Tours [Tour 1] GraphicsFactory Introduction (page 3-2)
[Tour 2] Flip Your First GraphicsFactory Video (page 3-8)
[Tour 3] Creating a GraphicsFactory Template (page 3-21)

Note
These tours build on your understanding of FlipFactory in 
general. If you’re not already familiar with FlipFactory, you 
should take the tours in the FlipFactory User’s Guide, Chapter 3, 
Guided Tours.
The file references in these tours assume you’ve installed 
GraphicsFactory in the default directory and your 
GraphicsFactory tools are on the GraphicsFactory server, which 
is referred to as localhost. If you’ve set up your system 
differently, make adjustments accordingly.
July 2008 3-1
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[TOUR 1] GRAPHICSFACTORY INTRODUCTION

In this tour, you’ll become familiar with the concepts of GraphicsFactory 
and its design tool – Template Creator – plus the GraphicsFactory Submit 
tool, which you can use to submit GraphicsFactory jobs.

Concepts GraphicsFactory enables editors to quickly and easily configure and 
assemble text, drop shadows, images, audio overlays, and QuickTime 
movies in a template.

These templates permit spatial positioning on the video frame and 
temporal placement on a timeline. Templates can be produced for a single 
job to produce video with graphics overlays. Or, you can mark properties 
of video or audio layers as dynamic, or “fill in the blank”, and submit 
several jobs – each with different values (images or text, for example) on 
different baseline video files.

GraphicsFactory is built on FlipFactory's transcode engine which 
automates media file transfer and exchange in a wide variety of 
workflows and formats.

After a template is built, it can be submitted to GraphicsFactory by 
various methods, along with the video to transcode the sources into an 
overlay video to meet your format and specifications.

Three key concepts are fundamental to understanding GraphicsFactory: 
layers, timeline effects, and variables. These concepts are demonstrated in 
the remaining tours.

Layers
A layer in GraphicsFactory is a single video or audio overlay element 
element, such as an image, text, audio overlay, QuickTime movie, etc. 
You can have multiple layers in a GraphicsFactory template. Each layer 
has its own properties – for example, text has properties including font, 
color, position, and the actual value of the text – the specific words that 
display on the output. 

Layers are ordered, meaning that, similar to a stack of slide 
transparencies, each layer can be positioned either on top of or below 
other layers. Each visual layer also has varying opacity – it can be 
completely opaque (hiding everything underneath its element) – 
completely clear (rendering its element invisible) or anywhere in 
between. You also can control each audio layers loudness, from 0% 
(silent) to 400% (4 times louder than the original).

Timeline Effects
GraphicsFactory allows you to apply timeline-based (temporal) effects to 
layers, such as, “Fade in an image at this time”. Each effect is associated 
3-2 July 2008
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with a point in time. Effects include the ability to fade layers in and out, or 
(for QuickTime and audio layers) the ability to start and stop the layer’s 
media at specific times. Effect times can be relative to each other, such as, 
“Fade in this image two seconds before fading in this text”.

Variables
Almost all properties of layers or effects can be controlled through the use 
of variables. A variable is a changeable (or dynamic) property of a layer 
or effect whose value is provided while the template is being applied. 
Said differently, if you mark a layer property as a variable, this allows you 
to "fill in the blank" for each job when the job is submitted for processing.

For example, a template might specify the font, color, and position of text 
you want to display, but the template uses a variable to identify a holder 
for the actual text. By filling in the value of this text variable each time 
you submit a job for processing, the same template can be re-used on 
different videos, with a different overlay for each video.

Variables allow you to generalize a template. Variables allow you to re-
use the same template for more than one job, without having to re-build 
the entire template. This reduces design labor and makes templates 
broadly applicable to a workflow. You don't need to use variables, but 
they are a powerful way to avoid doing everything “by hand” for each 
input file. For an example of how to use variables, see Tour 3.

Variables can be mixed with actual numbers and time code values in a 
formula, using + and - arithmetic operators. For example, you can specify 
a timeline effect by specifying $starttime + 00:00:03:00@29.97 - 
$end_of_movie - $credit_length.

You can also specify the X or Y location of elements. For example, for 
property value $bottom - 20 allows the position of elements to change 
with each file. 

Finally, you can use variable arithmetic when supplying filenames for 
overlays. For example: “C:\images\” + $OVERLAY_FNAME + “.jpg”.

Be sure to use arithmetic with proper types. In integer fields, only perform 
arithmetic on integers; in timecode fields, just use timecode values. For 
filenames, be sure to wrap any non-variable parts of the filename with 
quotes. For example: “C:\Documents and Settings\”+$FILENAME. If 
you are not using variables, you don’t need quotes.

Note
Almost all layer properties can be controlled through the use of 
variables. For example, you can use variables to control the text 
to display, image positions, fade-in and fade-out times, etc.
July 2008 3-3
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Components GraphicsFactory consists of a specially-licensed FlipFactory that enables 
a sophisticated file-based graphics assembly and rendering engine, plus 
two additional tools – a template design tool (Template Creator) and a job 
submission tool (GraphicsFactory Submit Tool). You use all three to 
design and produce video with graphics overlays.

GraphicsFactory
GraphicsFactory is a specially-licensed FlipFactory, which enables the 
processing of GraphicsFactory templates, images, text, audio overlays, 
QuickTime movies and other graphic objects to merge them with baseline 
video and audio both spatially and temporally.

You can process, transcode, and produce your overlay video and audio 
products using the formats and codecs that you have licensed.

Template Creator
The GraphicsFactory Template Creator is a Windows application that 
allows you to design and create graphics templates used to control how 
the video is generated. You can install the Template Creator directly on 
your FlipFactory server, or you can install it on another Windows 
computer – an editor’s workstation, for example – on the same network.

Figure 3–1.  Use the Template Creator to create templates

GraphicsFactory templates are XML documents that contain the 
specifications for how video and audio layers are overlaid on your output 
video, as specified using this creation tool.
3-4 July 2008
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You use the Template Creator to add graphics and audio elements and 
determine where they display on the video, plus other attributes (size, 
transparency, loudness). You also specify when they are visible or audible 
and when they disappear or become silent. Some graphic elements are 
files – raster images, for example. Others are just specifications of 
elements including text and darken regions, that are to be rendered when 
your job is processed.

You don’t specify the original input media in the Template Creator. The 
underlying media file is specified at job submission time. By keeping the 
underlying video and audio separate from the template, you can re-use the 
template in various workflows, with any media that you want.

GraphicsFactory Submit Tool
The Submit tool is also a Windows application. The Submit tool allows 
you to select a template and source video, then submit a FlipFactory job 
to the selected factory.

You can also install the Submit tool directly on your FlipFactory server or 
on another Windows computer on the same network.

Figure 3–2.  Use the Submit tool to set up and submit a job
July 2008 3-5
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If your template uses variables (rather than specifically naming each 
value), the Submit tool allows you to override the default values for each 
variable – a show name, time, or other text, or a numeric value for 
graphics locations on the display, or timecodes, for example, as you 
submit your job.

GraphicsFactory 
Workflow

In order to process GraphicsFactory jobs, first you create a factory on 
your GraphicsFactory server. In this factory, you specify one or more 
output formats, and optionally, a GraphicsFactory template, depending on 
your workflow requirements.

Each job you submit to GraphicsFactory has several components:

The GraphicsFactory template, which specifies layers and effects
Optionally, GraphicsFactory variables which the operator uses to “fill 
in the blanks” of the template
Optionally, links to one or more images, audio, and movies which 
form the composite layers
The baseline video file upon which the elements are applied

These components may be provided in various ways. You’ll learn more 
about building templates with Template Creator in Tours 2 and 3.

There are several methods you can use to “fill in the blanks” for variables. 
You can provide specific values for each variable in the following ways:

Use the GraphicsFactory Submit Tool, which allows you to do data 
entry for variables before sending the job to a GraphicsFactory server. 
Details are provided in Tour 2.
Set up your GraphicsFactory factory with a monitor, to maintain a 
queue of pending GraphicsFactory jobs. Then, have an operator open 
each job and “fill in the blanks” using the GraphicsFactory Resubmit/
Forward workflow. This workflow is described in “Monitor/Manual 
Submission With Data Entry Workflow” on page 4–14.
Use automatically updated variables, such as $DURATION or 
$FILENAME, so that the entire workflow is completely automated.
Through an SDK integration, variables can be populated 
automatically from a database. Contact Telestream for more 
information about the GraphicsFactory SDK.

All elements in a template – typically movies and images – must be 
accessible by the GraphicsFactory server. If you are using your own 
GraphicsFactory server (localhost) to create a template and submit the 
job, then this typically isn't an issue. However, if you are working on a 
LAN then you must make sure that all necessary files are network-
accessible, and that GraphicsFactory has sufficient permissions to access 
those files. Details about how to attach network-accessible images and 
movies are provided in “File Paths and Authentication” on page 3–13.
3-6 July 2008
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The baseline media is the underlying foundation upon which 
GraphicsFactory elements are rendered. Your GraphicsFactory server can 
read over a hundred different video formats. There is no specific 
requirement as to which format you use for your input baseline media. 
You can choose the video to submit using either the GraphicsFactory 
Submit tool (Tour 2), or via a typical FlipFactory/GraphicsFactory 
workflow (“GraphicsFactory Workflows” on page 4–1).

Factories are configured by you to determine where video files should be 
imported from, how they should be processed, what output format(s) are 
required, and how the outputs should be delivered. You can find more 
information about setting up Factories in your FlipFactory User’s Guide. 
Aspects of factory settings which are specific to GraphicsFactory are 
discussed in “GraphicsFactory Workflows” on page 4–1.
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[TOUR 2] FLIP YOUR FIRST GRAPHICSFACTORY VIDEO

This tour takes about half an hour, and acquaints you with the Template 
Creator and the Submit tool, using a sample GraphicsFactory template. In 
this tour, you’ll also make a simple GraphicsFactory factory to process 
the template and video, and view the media in Windows Media Player.

Start the Template 
Creator

To begin, run the GraphicsFactory Template Creator.

Click start > programs > Telestream > GraphicsFactory > 
GraphicsFactory Template Creator.

When Template Creator starts, it displays the main window:

Figure 3–3.  Main Window of GraphicsFactory Template Creator

Note
This tour is designed for you to select example files and submit 
a local job. Before you can participate in this tour, you should 
have GraphicsFactory and the GraphicsFactory Template 
Creator and Submit tool installed on a single server.
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Recall from Tour 1 that the Template Creator’s main window (Figure 3–
3) has a menubar at the top, and a toolbar of frequently-used commands. 
There are other windows as well; you’ll view these later in the tour.

Directly below the toolbar on the left is the layer list (which is currently 
empty except for the master audio layer, because you just opened it). For 
each layer you create, an entry is made in this list. The list is displayed 
ordinally, with the highest element in the layer stack at the top of the list. 
You can re-order layers in the list.

To the right is the timeline, which provides both an ordinal and temporal 
view of element layers and their effects. The timeline displays tick marks 
horizontally, and layers you’ve created vertically.

Open a Template Next, open an example template we’ve already built for you.

Click File > Open Template to display the Open Template dialog.

Figure 3–4.  Open template in Template Creator

Browse to C:\Program Files\Telestream\GraphicsFactory\Tour Examples, 
and open Tour2_GF_Template.xml.

Explore the Main 
Window

With the template open in the main window, the element layers are 
displayed on the left, and the timeline is displayed on the right. For this 

Note
Online help for GraphicsFactory Template Creator provides 
specific details about each window, menu, and feature. To 
access online help click Help > Contents.
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tour, don’t make any changes to settings in the template (except for 
updating relative file paths, as instructed below). 

Figure 3–5.  Main window with open template

When you’re done browsing around, you’ll create a factory and submit 
this template for processing and view your new media.

To start, click on each menu in the menubar: File, Layer, Timeline, 
Windows, and Help. Use the File menu to create, open, and save 
templates. The Layer menu allows you to add new layers and re-order 
them. Use the Timeline menu to set a frame rate for this template.

The Windows menu enables you to display the other windows in 
Template Creator: Variable Editor, Template Preview window, and the 
Layer Effects Editor.

Below the toolbar on the left, each element in this template is displayed – 
one per layer. Each element has a name and type, plus a Visible and 
Locked checkbox. 

Figure 3–6.  Layer list entries

When selected, a layer displays as depressed. You can re-order the 
selected layer by repeatedly selecting Layer > Move Up or Move Down 
(or clicking the Move Up or Move Down icons in the toolbar).

To delete a layer, select it and select Layer > Delete (or click the red X in 
the toolbar).
3-10 July 2008



74-0072-02 Guided Tours
Next, display a layer properties dialog to learn about some of these 
settings and configurations. Double-click the top layer (Text - Up next), 
which is a text layer.

Figure 3–7.  Layer properties vary by type

Each type of layer has some unique properties. In general, you can 
provide the value of the layer (or the file name), its XY coordinate 
location on the image, plus size, transparency and other attributes.

Now, explore the other layer types – don’t check any boxes or make other 
changes though. For example, open the Image layer and the QT Movie 
layer property dialogs and review the various properties, then close them 
by clicking the Cancel button.

Layer Types The Template Creator provides the following layers:

Image Layer
An image layer is a raster image in JPG, PNG, BMP, TIF or TARGA 
format, plus size and position information, and opacity.

QuickTime Layer
A QuickTime layer is a reference to a QuickTime-compatible movie file 
(AVI, MOV, etc.), plus information about the image size, position and 
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opacity, and looping. QuickTime movies allow you to create dynamic 
graphics (snipes) and movie insets as graphics. 

Text Layer
A text layer is a specific text string (or a variable that resolves to a 
specific string when the job is submitted) to be rendered on the output 
media. In addition, you can set attributes including extensive font, 
character, and paragraph control, plus drop shadows.

Darken Region Layer
A darken region layer is a rectangular region at a specific location and 
size, plus opacity, that effectively reduces the luminance of all the lower 
layers, including the baseline video.

You can use Darken Region layers to darken a rectangular area on the 
image where you plan to display text or a QuickTime movie.

Audio Layer
An audio layer specifies a sound file in WAV, QuickTime, or MP3 
format, plus the ability to map audio channels to output channels. You can 
add fade-in and fade-out effects to control volume on a layer basis.

Master Audio Layer
A master audio layer is automatically inserted in each template. You can 
use it to control the volume level of the baseline audio, by adding fade-in 
and fade-out effects, and adjusting their duration and target intensity. 

Note
The QuickTime layer only overlays the video, not the audio, 
from the QuickTime file. You can use an Audio Layer to overlay 
the audio from a QuickTime file; if you want both video and 
audio, each is in a separate layer, allowing you to control them 
individually.

Note
The Master Audio layer controls the levels of only the original 
baseline audio from your source media, and does not affect any 
other audio layers. For example, you might use the Master 
Audio layer to fade out the original audio, while fading in a new 
Audio layer containing a voice-over.
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File Paths and 
Authentication

GraphicsFactory uses file-based resources including templates (in XML 
format), plus raster image files including BMP, PNG, etc. and QuickTime 
movie files as graphic element resources. Additionally, you can specify 
audio files in MP3, WAV, or QuickTime. Baseline video (in any 
FlipFactory-supported format) is also specified as a file. 

Each of these files must be accessible to the GraphicsFactory server that 
is processing the job.

If your reference files (in Template Creator as well as Submit tool) are on 
the GraphicsFactory server, use fully-qualified Windows paths to the 
files. If your reference files are on shares accessed by the 
GraphicsFactory server or if you’re using a FlipFactory Array or Load-
Balance group, you should reference the various files as fully-qualified 
UNC paths, because these references must be resolved from the 
perspective of the network-based GraphicsFactory server. Relative and 
drive-letter paths won’t be correctly specified from the GraphicsFactory 
server’s location if the template is being designed on another computer.

Server-based files must be in a share that is accessible to GraphicsFactory 
as well as the Template Creator and Submit tool. They should also be 
specified as full UNC paths (\\imageshare\image\logo.png, for example), 
instead of using mapped drives: S:\logo.png.

Update the Paths Before continuing, you need to update two file references in the template 
which have specifically been entered as relative, so that they work in all 
installations. You need to update them to local, fully-qualified paths on 
your computer.

In the Template Creator, double-click the Telestream logo image layer to 
display its property dialog.

Click the Browse button to locate and select the tel_logo_stack.png file in 
(default installation path) C:\Program Files\Telestream\GraphicsFactory
\Tour Examples\tel_logo_stack.png and click Open.

Click OK to save the settings with the fully-qualified path to this logo.

Next, double-click the Lower 3rd bkg movie QuickTime layer to display 
its property dialog.

Click the Browse button to locate and select the NT Telestream Blue 
Lower 3rd CIRCLES.mov file in (default installation path) C:\Program 
Files\Telestream\GraphicsFactory

Note
When submitting GraphicsFactory jobs to a FlipFactory on the 
LAN, file references should be fully-qualified UNC paths, 
starting with a Windows server name (\\SierraServer, for 
example).
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\Tour Examples\NT Telestream Blue Lower 3rd CIRCLES.mov and click 
Open.

Click OK to save the settings with the fully-qualified path to this movie.

Click File > Save Template to save the changes and continue.

Previewing a 
Template

Now that you’re familiar with the main window and the building blocks 
of a template, select Windows > Template Preview window.

Figure 3–8.  Template Preview window

The Preview window provides you a visual overview of all graphic 
elements without the baseline video so that you can get a visual sense of 
how it will look when rendered.

First, click the View menu and select several backgrounds, and also 
display the Video/Text Safe guide and the Rule of Thirds guide to get a 
quick sense of how each feature works.

Next, click the Size menu and select various preview sizes. You can set 
the preview window to display in NTSC, PAL, and HD 720 and 1080 
formats. Also, you can set your own preview size.

These sizes do not control the output. Rather, the output is set in Product 
area of the GraphicsFactory factory you set up, and you should set the 
Preview size to the size of output you’re planning. A GraphicsFactory 
template is generally designed to fit a particular frame size (e.g.: 720x480 
for NTSC). In the Size menu, you can also preview the template at full-
size (100%), half-size (50%) or quarter-size (25%).
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In the Template Preview window, you can see the spatial positioning of 
the elements, and you can also preview the template timeline. 

Play the Template Finally, click Preview > Play and watch the template step through the 
visual effects to get a sense of how the elements will play out. You can 
also display time codes (Preview > Show timecode during Play).

When you click Play, you can see the template fade the text in and out. 
This allows you to see how the template will appear when applied to a 
video. (To stop playing the preview at any time, just click directly in the 
Preview window.) But how do you know when elements should fade in 
and out? For that, you use the Timeline in the main window.

Using the Timeline The timeline is where effects, such as “fade in” or “stop QuickTime 
movie” are applied to the layers. The timeline is located to the right of the 
layers list in the Template Creator’s main window.

Figure 3–9.  Timeline in main window

You can navigate the timeline in several ways:

— Use the scroll bar at the bottom of the screen
— Use the mouse scroll wheel to zoom in and out
— Left-click and drag on the timeline to move the timeline

Events on the timeline are driven by timecodes, such as 
“00:00:01:00@29.97”. More detail is provide about creating effects in 
Tour 3, but its important to place the frame rate at the end of the timecode.

Note
You can also display Layer properties dialogs directly from the 
Template Preview window. Double click any object to display its 
property dialog. If an element (such as a QuickTime movie) 
completely fills the window, then clicking anywhere in the 
window will select that element unless another element is on top 
of it. So, consider putting full-screen elements at the bottom of 
the layer stack if possible.
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Even though two timecodes with different frame rates can mean the same 
time – 00:00:10:00@29.97 and 00:00:10:00@25 are the same – it's useful 
to change the tick frequency in the timeline display. To change the 
duration, click the Timeline menu, and select NTSC (29.97 fps), PAL (25 
fps), or define your own custom frame rate. This setting is used to 
determine the appropriate timeline basis when you click to add effects on 
the timeline.

Before building your first GraphicsFactory factory, be sure to save the 
template with your updated file paths, and continue. You can quit the 
Template Creator program if you choose to.

Build a 
GraphicsFactory 
Factory

Before you can submit a GraphicsFactory job, you need to build a factory. 
Here are the specifications for your factory:

Product: Windows Media – (name: WMV720X480) Single Rate 
CBR, 720 x 480, 2 MB/sec @ 29.97 FPS.
Destination: Local Folder (suggested path: C:\Program 
Files\GraphicsFactory\Tour Examples).

Open the FlipFactory console, log in to the Demo account and create a 
new factory (called WMV_GFTours). Add the product and destination 
and save the factory.

Submit a Job Now that you’ve updated the template and created the factory, you’re 
ready to run Submit Tool, review the Submit Job window and its 
important input fields, and submit your first job. The factory you created 
doesn’t have a monitor, so you’ll submit the job manually, using the 
GraphicsFactory Submit tool.

Run the GraphicsFactory Submit Tool: double-click the shortcut on your 
desktop, or select start > Program Files > Telestream > GraphicsFactory > 
GraphicsFactory Submit Tool.

When it starts, the Submit Tool displays the connection dialog:

Figure 3–10.  Connect to FlipFactory in Submit tool

Note
For complete details about building and configuring factories in 
FlipFactory, see the FlipFactory User’s Guide.
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The GraphicsFactory defaults to localhost, which is correct for this tour. 
(You can type the name of any FlipFactory server in your environment.) 
Click Connect to connect to the GraphicsFactory running on your server. 

When the Account list populates and the Log In button activates, you’ve 
successfully connected.

Figure 3–11.  Log in to the demo account

Select demo from the FlipFactory account menu and click Log In.

When you’ve successfully logged into an account on the connected 
FlipFactory server, the Submit tool displays this window.

Figure 3–12.  Submit tool (sample, shown completed)

In the main window, select WMV_GFTours from list of factories (this is 
the factory you just created on the GraphicsFactory server.)

Next, click the Video Filename Browse button and select your baseline 
video (C:\Program Files\GraphicsFactory\Source Footage\
Source_Video.wmv), a 30-second clip.

Finally, click the Template Filename Browse button and select the 
Tour2_GF_Template XML template file (C:\Program 
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Files\GraphicsFactory\> Tour Examples\Tour2_GF_Template.xml) 
you’ve been exploring.

Click Submit Job to send the template and the file reference to the 
baseline video you selected to the WMV_GFTours factory on your local 
FlipFactory server, then close the Submit tool by clicking Exit.

View Job Status To view the Status of the job you just submitted, run the FlipFactory 
console again (if its not already running) and log on to the demo account.

Click the Job Status icon (located in the User panel). FlipFactory displays 
the Job Status window.

Figure 3–13.  Job Status window

The Job Status window displays jobs that are in progress in the upper 
(Active Jobs) panel, and jobs that have been completed in the lower (All 
Jobs) panel. You click a job to select and manage it, or double-click it to 
view job details in the Message Viewer window.

Note
Click Help to view Online Help for GraphicsFactory Submit Tool.
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Play Your New Clip When the job is complete the media has been transcoded to Windows 
Media, and you can view your new clip. Double-click the job in the Job 
Status window All Jobs panel to display the Message Viewer window. 

Figure 3–14.  Message Viewer window

The Message Viewer window displays details about each product (new 
media file) in the job. The new media was delivered to the Local Folder 
destination you specified.

Open the destination folder (C:\Program 
Files\Telestream\GraphicsFactory\Tour Examples) and open the media 
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file Source_VideoWMV720x480.wmv in Windows Media Player by 
double-clicking it.

Figure 3–15.  Windows Media Player plays the media you flipped

Conclusion Now that you’ve reviewed a template, learned the basics of how to use 
GraphicsFactory Template Creator, and learned how to submit and 
monitor jobs, you’re ready to build a Graphics template from scratch and 
process another GraphicsFactory job.
3-20 July 2008



74-0072-02 Guided Tours
[TOUR 3] CREATING A GRAPHICSFACTORY TEMPLATE

This tour takes about 15 to 20 minutes. In this tour, you’ll create a 
template from scratch, duplicating the template from Tour 2. You’ll use 
the same factory to process the template and video, and view the output 
media in Windows Media Player.

In this tour, you'll learn how to create the “Coming Next” template from 
scratch. In the process, you’ll have an opportunity to use most of the 
features in the Template Creator.

Create a Template To create the Coming Next template, follow these steps:

Step 1 Start the Template Creator if you don’t already have it open. (If it is, select 
File > New, and close any open templates.) When you start the Template 
Creator, a new template is created for you automatically.

Step 2 Save the new, blank template in Program Files > GraphicsFactory > Tour 
Examples as MyUpNextTemplate.xml.

Step 3 Display the Template Preview Window (select Windows > Template 
Preview Window) so you can lay the elements out. Drag it to one side if 
necessary so you don’t obscure the main window. Display the Rule of 
Thirds and Video/Text Safe guides (via View menu).

Step 4 Now, return to the main window and begin adding layers to the template.

Step 5 First, add a QuickTime layer: click Add QuickTime Layer and double-
click the layer to view properties. 

Set up the following properties:

Name the layer Telestream movie.

Click Browse (the button with the ellipses on it...) and navigate to 
C:\Program Files\Telestream\
GraphicsFactory\Tour Examples and select NT Telestream Blue Lower 
3rd CIRCLES.mov.

Check Looping, so the movie repeats as long as the baseline video runs. 
Click Adjust Preview Frame and select the frame you’d like to view in the 
Preview window. (Note the Preview button here, too). Click OK.

Note
The instructions in this tour assume that you have taken Tour 1 
and Tour 2, and have learned the menu items and toolbar, how 
to display dialogs and the other windows in Template Creator. If 
you need help using the user interface, display Online Help.
July 2008 3-21



Guided Tours 74-0072-02
In the Template Preview window, move the movie rectangle to the bottom 
left of the window. You move the rectangle by grabbing the grab button (a 
small black square in the center of the object) and dragging the rectangle 
to its target location. 

Next, adjust the size of the rectangle to fill the window by dragging the 
right and top edges. This effectively sets the X and Y point to 0,0, and the 
size to 720 by 480 – close and open the QT Movie property dialog again 
to refresh the settings and verify the values, adjusting them as necessary. 
(You can also just edit the values in the dialog, of course.) Close the Edit 
QuickTime Layer dialog and continue.

Step 6 Add a text layer for “Up Next”. Click Layer > Add Text Layer or use the 
toolbar icon.

Step 7 Click to select the layer and move it to the top of the layer stack (click 
Layer > Move Up or click the Move Up icon in the toolbar).

Step 8 Open the properties dialog and name the layer “Up Next”, add the value 
“Up Next:”, select a font (Arial is suggested), set the color to white (or 
other color you choose - click in the color box to display the color picker) 
and click OK.

In the Template Preview window, drag the Up Next rectangle to the 
bottom left just inside the yellow guide line and just below the swoosh (at 
about 35, 360. Now, lock the layer. (When a layer is locked, you can’t 
open the property dialog.) Save your template changes.

Step 9 Add a text layer for the name of the next TV show. Click Layer > Add 
Text Layer, then move it to the top of the stack.

Step 10 Double-click to display the new text layer’s property dialog.

Name the layer “Show Name”. But instead of specifying the value “more 
cycling fun...”, make the template general purpose by adding a variable so 
it can be used repeatedly. Enter $ShowName in the text field. By putting 
the symbol $in front of ShowName, you have created a new variable 
called “ShowName:. (When you enter a new variable, it creates it 
automatically. You’ll supply the actual text to render on this layer, when 
you submit the job.) Select the font, set the color to white, text size to 48.

Note
When you’re done setting up a specific element, it’s a good idea 
to lock it (click Locked in the layer). When an element is locked, 
you can’t make changes, and it doesn’t prevent you from 
selecting elements below it in the Template Preview window.
You can also use the Visible checkbox to hide and show 
elements during your design work.
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Step 11 To create a shadow for the Up Next text, check Draw Outline / Drop 
shadow. Set the pixel width to 4, and the X and Y offsets to 5. Select 
black as the color.

Step 12 Next, review the text and drop shadow in the preview window and make 
adjustments to suit your taste. When you’re satisfied with the look, click 
OK to close the Edit Text Layer window and save the settings.

Step 13 Now, add default text to the variable. Click Window > Variable Editor to 
display the Variable Editor window. 

The Variable Editor window displays a list of all variables you’ve created 
in this template. Select $ShowName and enter ShowName in the Default 
Value text field. Enter Type the name of the next show in the Data Entry 
Instructions field. Then, close the window.

In the Template Preview window, drag the $ShowName rectangle just 
below the Up Next element. Save changes and lock the layer.

Step 14 The final element to add is the Telestream logo. Add an image layer, 
move it up above the QT Movie layer (so it displays correctly and you can 
move it around in the Template Preview window) and display the 
properties dialog. 

Name the layer Logo, then select the Telestream logo (C:\Program 
Files\Telestream\GraphicsFactory\Tour Examples\tel_logo_stack.png).

Set the size to 115 wide, 76 high. (You need to know the size of images 
and QuickTime movies and set them manually.)

In the Template Preview window, move the logo rectangle to the lower 
right corner, just inside the red rectangle corner.

Save the template.

Note
You should always provide default values and data entry 
instructions for each variable you create. If you don’t, the 
rectangle doesn’t display in the Template Preview window, and it 
makes it more difficult for data entry during job submission.
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Adding Timeline 
Events

Now that you’ve added the elements and have them set spatially, you’ll 
adjust the temporal settings so that they fade in and out at the appropriate 
times.

Step 15 To set up times for each element, open the Layer Effects Editor window 
(Windows > Layer Effects Editor).

Select the Up Next layer, and click Add in the Layer Effects Editor 
window. Set the Fade In time to 00:00:01:00@29.97 (1 second). 

Click Add again and set the effect type to Fade Out. Set the Fade Out time 
to 00:00:10:00@29.97 (10 seconds). 

Step 16 Select the Show Name layer, add a Fade In and a Fade Out, and set the 
times to 00:00:03:00@29.97 and 00:00:10:00@29.97, respectively.

Step 17 The logo should display during the entire run of the video, so you don’t 
need to add any effects. By default, elements are visible unless effects are 
applied.

Step 18 Select the Telestream movie layer, add a QuickTime Movie Start at 
00:00:00:00@29.97 and add a QuickTime Movie End at 
00:00:12:00@29.97.

Also add a Fade In at 00:00:00:00@29.97 and add a Fade Out at 
00:00:12:00@29.97.

Step 19 Save the template and play the preview (Preview > Play) to see how the 
effects play out. If you’ve made any errors, correct them now and re-play 
the preview.

Submit a Job Now you’re ready to submit the job. You’ll use the GraphicsFactory 
Submit tool to submit the job to the same factory you created in Tour 2.

Step 20 Launch the Submit tool and connect to your GraphicsFactory server using 
localhost. 

Step 21 When you connect, select demo from the FlipFactory account menu and 
click Log In.

The Submit tool displays its window.

Step 22 In the main window, select WMV_GFTours from list of factories (this is 
the factory you created in Tour 2.)

Tip
You can use the timeline as a visual guide – a layer that is visible 
displays a thick grey bar above the layer timeline and, if it is a 
Quicktime or Audio layer, the media is playable, the black layer 
timeline bar is thicker during play time, thin when stopped.
3-24 July 2008



74-0072-02 Guided Tours
Step 23 Next, click Browse and select the same baseline video (C:\Program 
Files\GraphicsFactory\Source Footage\Source_Video.wmv).

Step 24 Click Browse and select the MyUpNextTemplate file (C:\Program 
Files\GraphicsFactory\Tour Examples\MyUpNextTemplate.xml) you just 
created.

Step 25 Click Submit Job to send the template and references to the baseline video 
to the WMV_GFTours factory on your local FlipFactory server, then 
close the Submit tool by clicking Exit.

View Job Status To view the Status of the job you just submitted, click Job Status (located 
in the User panel). FlipFactory displays the Job Status window.

Play Your New 
Clip

When the job is complete the media has been transcoded to Windows 
Media, and you can view your new clip. Double-click the job in the All 
Jobs panel of the Job Status window to display the Message Viewer 
window and details about each product (new media file) in the job. 

The new media was delivered to the local folder destination you 
specified, and you can click the Play icon (right arrow) to play the clip in 
Windows Media Player.

Conclusion You’ve just created your first GraphicsFactory template and in the 
process, gained some first-hand experience with the GraphicsFactory 
Template Creator. Now you’re ready to try it on your own.
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C     H     A     P     T     E     R 4

GraphicsFactory Workflows
This chapter describes how to set up and configure GraphicsFactory to 
facilitate various workflow requirements.

Topics GraphicsFactory PA Tools and Filters (page 4-2)

GraphicsFactory PA Tool (page 4-2)
Media Expansion PA Tool (page 4-5)
GraphicsFactory Template Filter (page 4-8)
GraphicsFactory Submit Tool Job Submission Workflow (page 4-10)
FlipFactory Monitor/Manual Submission Workflow (page 4-12)
Monitor/Manual Submission With Data Entry Workflow (page 4-14)
Workflow Variations (page 4-19)
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GRAPHICSFACTORY PA TOOLS AND FILTERS

GraphicsFactory implements a GraphicsFactory Process/Analyze tool 
(commonly called just PA tool) and a GraphicsFactory Template filter. 
This PA tool and filter are unique to FlipFactory servers with 
GraphicsFactory licenses, and each provides functionality to enable 
various workflows.

It is important to understand how PA tools and filters work, in order to 
correctly configure factories to process GraphicsFactory jobs.

FlipFactory’s PA tools operate at the factory level. That is, they operate 
on input, not output, and are enabled in a factory at the top level. PA tools 
do not operate at the product level, as product filters do.

Product filters, on the other hand, operate on output, not input, and are 
added at the product level in a factory: each factory can have multiple 
products. Therefore, for each product you add to a factory, you can add a 
product filter and configure it to meet your needs.

GraphicsFactory 
PA Tool

The GraphicsFactory PA tool permits you to submit GraphicsFactory jobs 
with the FlipFactory Job Submit window or by adding media files to 
folders or shares being tracked by FlipFactory monitors.

Use the GraphicsFactory PA tool only when you have variables in the 
template and you're creating a two-stage workflow (by creating a 
Duplicate Original product). This enables an operator to view the job, 
input values for each variable, and resubmit the job for final output.

Alternatively, this workflow allows the automatic population of special 
variables such as $DURATION and $FILENAME.

In a two-stage factory, the stage one factory processes manually submitted 
jobs or jobs that have been generated by a monitor. The stage one factory 
is configured with a Duplicate Original product (for Resubmit/Forward 
operation and to provide the same input media to stage two) and to 
display variables from the template in the Resubmit/Forward window. 
The operator supplies values for each variable, and resubmits the job to 
the stage two factory for product encoding.

If there are timecode variables or automatic variables, you should also 
create a QuickTime Proxy product in the stage one factory. This triggers 

Note
In addition to specific PA tools and filters created especially for 
GraphicsFactory, you can utilize any other PA tools and filters 
you need to create your media.
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the population of variables, and also allows an operator to view the proxy 
and easily select points in the movie as timecode values using the slider.

The GraphicsFactory PA tool should be enabled in a factory when:

You’re submitting jobs via monitors or Manual Submit window and...
The template has variables and specific values must be calculated and 
entered by an operator (or filled in manually) during job processing, 
then forwarded to another factory for media transcoding and final 
output and...
Your workflow has two factories: a stage-one factory for processing 
the template and “filling in the blanks” either by an operator or 
automatically, before submitting to the stage-two factory for 
producing the overlay media using the template with image, audio, 
and movie files, variable values, and baseline video.

Enabling the 
GraphicsFactory 
Process/Analyze Tool

To enable the GraphicsFactory PA tool, log into the account using the 
FlipFactory console, follow these steps:

Step 1 Open the factory you’re working on.

Figure 4–1.  Enabling the GraphicsFactory PA tool

Note
If you are submitting jobs without variables, or you are 
submitting jobs using the GraphicsFactory Submit tool, you 
should enable the GraphicsFactory filter directly in the product: 
you do not need to use the GraphicsFactory PA tool.
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Step 2 Click the Process/Analyze icon to display the list of tools.

Step 3 Click the GraphicsFactory tab, and check Enabled.

Configuring the 
GraphicsFactory PA 
Tool

To configure the GraphicsFactory PA tool, Click the Process/Analyze > 
GraphicsFactory icon to display the editor and follow these steps:

Figure 4–2.  Configuring the GraphicsFactory PA tool

Step 1 If your template is on the same computer as the GraphicsFactory server, 
select Select GraphicsFactory Template from Local Drive. If it is on a 
network server, select GraphicsFactory Template from Network Drive in 
the dropdown at the top of the editor panel and then enter the domain or 
workgroup you’re in, in the Domain/Workgroup Name field.

Step 2 Next, click Browse to locate and select the GraphicsFactory template that 
you want to use for jobs submitted to this factory.

Step 3 Optionally, check Populate $DURATION Variable. Check this option 
when you are using $DURATION in the template to provide 
GraphicsFactory the length of the video, so you can apply effects based 
on the total length of the output. 
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For example, you may want to apply a fade-out for 4 seconds prior to the 
end of the clip. Check this option to pass the value in the template through 
with the job ticket without requiring operator data entry.

Step 4 Optionally, check Populate $FILENAME Variable. Check this option 
when you want to use the $FILENAME variable (which is the base 
filename of the input media without path or suffix text), as part of a text or 
image overlay. Check this option to pass the value in the template through 
with the job ticket without requiring operator data entry.

For example, you are using C:\inputmedia\sierrasunset.mpg as input 
media. $FILENAME is set to sierrasunset. You can use $FILENAME in 
a text overlay. You can also use it as the filename for an image overlay, 
by prepending it; modify the GraphicsFactory template to add a directory 
and extension. For example, place “C:\inputmedia\images\” + 
$FILENAME + “.tif” as the filename for the image.

Step 5 Whenever you make changes to a factory, be sure to save it so that 
changes in the configuration are applied to the next job submitted.

Media Expansion 
PA Tool

The Media Expansion PA tool is a FlipFactory PA tool which allows you 
to add black frames to the beginning or end of your baseline video, or in 
the middle, as a segment. You can use this additional black baseline video 
to add introductory graphics, QuickTime movies, an audio bed 
throughout your video. 

When adding black video to expand your baseline video, be sure to 
compensate for the new values when designing your template.

The Media Expansion pa tool should be enabled in a factory when you 
want to add black time as a leader, trailer, or internal segment to increase 
the overall length of your media. 

Note
Using the $DURATION variable requires that your stage one 
factory produce a QuickTime product as a proxy, or uses the 
Analysis encoder. If you use a Quicktime proxy, a small one 
using the MPEG4 encoder (60 x 80, for example) is acceptable. 
Using the Analysis product or the Quicktime proxy enables 
correct frame-accurate calculations of the baseline duration.

Note
You can add a bumper, trailer, and one intermediate segment to 
your video using the Media Expansion PA tool’s editor panel. If 
you need to add multiple intermediate segments, use the 
FlipFactory SDK. Contact Telestream for details.
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Enabling the Media 
Expansion PA Tool

To enable the Media Expansion PA tool, log into the account using the 
FlipFactory console, follow these steps:

Step 1 Open the factory you’re working on.

Figure 4–3.  Enabling the Media Expansion PA tool

Step 2 Click the Process/Analyze icon to display the list of tools.

Step 3 Click the Media Expansion tab, and check Enabled.

Configuring the Media 
Expansion PA Tool

To configure the Media Expansion PA tool, Click the Process/Analyze > 
Media Expansion icon to display the editor and follow these steps:
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Figure 4–4.  Configuring Media Expansion to add leader/trailer

Step 1 On the Leader/Trailer Media Expansion tab, check Enabled, and then 
check Lead in Duration and/or Trailer Duration and specify the amount of 
time in timecode format that you want to add to your baseline video 
before applying elements from your template.

Figure 4–5.  Configuring Media Expansion to add a segment

Step 2 On the Segment Media Expansion tab, check Enabled, and then check 
Segment Insertion and specify the position in the original input media 
where you want to add a black segment, and enter the amount of time in 
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timecode format that you want to add to your baseline video before 
applying elements from your template.

Be sure to select the correct fps value to match your baseline video.

The position value should be calculated from the original baseline video, 
not taking into account any leader black time you’ve added.

Step 3 Whenever you make changes to a factory, be sure to save it so that 
changes in the configuration are applied to the next job submitted. 

GraphicsFactory 
Template Filter

Product filters (often called just filters) are always applied directly to 
output media: a product in FlipFactory terms, and you can produce one or 
many products in a single factory.

The purpose of the GraphicsFactory Template filter is to allow you to use 
different GraphicsFactory templates for each product in a factory. 

The GraphicsFactory Template filter is almost always used; especially 
when:

You’re submitting jobs via monitors or Manual Submit window and...
You have multiple products per factory, and each product requires a 
separate template or...
You’ve enabled the GraphicsFactory PA tool (requires a Duplicate 
Original) and unchecked Attach specified template in the stage one 
factory. 

In this case, the product filter should be enabled and the template selected 
in each product in the stage one (product encoding) factory. The one case 
when you don't need the GraphicsFactory Template filter is when you are 
submitting a file through the GraphicsFactory submit tool.

Enabling the 
GraphicsFactory 
Template Filter

To enable the GraphicsFactory Template filter, when logged into an 
account in the FlipFactory console, follow these steps:

Step 1 Open the factory you’re working on.
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Figure 4–6.  Enabling the GraphicsFactory Template Filter

Step 2 Open the product that you want to specify a specific template for.

Step 3 Open the format icon, then click the Filters icon to display the list of tools.

Step 4 Click the GraphicsFactory Template tab, and check Enabled.

Configuring the 
GraphicsFactory 
Template Filter

To configure the GraphicsFactory Template filter, Click the Filters > 
GraphicsFactory Template icon to display the editor; follow these steps:

Figure 4–7.  Configuring the GraphicsFactory Template Filter

Click Browse to locate and select the GraphicsFactory template that you 
want to use for this product.
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GRAPHICSFACTORY SUBMIT TOOL JOB SUBMISSION WORKFLOW

In this workflow, GraphicsFactory jobs are submitted using only the 
GraphicsFactory Submit tool. Templates may or may not have variables.

This simple workflow is designed for testing, and for low-volume, 
manual job submission. This method is not recommended for high-
volume workflows. 

Figure 4–8.  GraphicsFactory Submit tool job submission workflow

Factory Configuration The factory which processes the job may have one or more products, and 
the factory should not have the GraphicsFactory PA tool enabled. It is not 
needed because the GraphicsFactory Submit tool displays the variables (if 
present) for the operator to add values before submitting the job.

Additionally, there is no GraphicsFactory Template filter enabled on any 
of the products in this factory, because the template is selected by you, 
and passed in by the GraphicsFactory Submit tool. Thus, this factory has 
no special configuration that is different from any other factory.

Make sure that the frame size on each product you produce in this factory 
matches the appropriate frame size for the template that you're using.

Note
The GraphicsFactory Submit tool is different from the 
FlipFactory Submit Job window, which also allows you to submit 
jobs manually. See “FlipFactory Monitor/Manual Submission 
Workflow” on page 4–12 to learn how to set up factories and 
use the FlipFactory Job Submit window to submit 
GraphicsFactory jobs.
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Job Submission For this workflow, you submit a job by running the GraphicsFactory 
Submit tool. Connect to the target GraphicsFactory server, and log in to 
the account that owns the factory you want to submit a job to.

Figure 4–9.  GraphicsFactory Submit tool job submission workflow

In the main window, select the factory name from the drop-down menu. 
Next, Select the video source, and the template. If there are variables to 
supply values for, enter them now. Finally, click Submit Job.
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FLIPFACTORY MONITOR/MANUAL SUBMISSION WORKFLOW

In this workflow, GraphicsFactory jobs are submitted via FlipFactory 
monitors, or manually using the Manual Submit window in FlipFactory.

Templates may or may not have variables. If the template has variables, 
the default values are used in this workflow – there is no data entry 
opportunity for operators before encoding the final video overlay media. 
(See “Monitor/Manual Submission With Data Entry Workflow” on page 
4–14 for a workflow with manual data entry.)

This automated workflow is designed for high-volume, automatic job 
submission via monitors (or manual submission when necessary), when 
variable values (if any) are pre-set and do not require operator 
intervention or automatic calculation.

The factory which processes the job may have one or more products.

Figure 4–10.  Workflow for monitor/manual jobs & no data entry

Factory Configuration The factory in this workflow does not have the GraphicsFactory PA tool 
enabled, because the default values are acceptable, and you want a no-
operator intervention workflow.

In this workflow, the GraphicsFactory template filter must be enabled on 
each product, because is not specified during automatic submission via 
the monitor or manually, via the FlipFactory Job Submit window. 
Therefore, each product must have the GraphicsFactory Template filter 
enabled, and the template must be specified.

You can use different templates for each product; for example, a small 
mobile video might have a different template applied than an HD product 
within the same factory.

Job Submission For this workflow, you submit a job by adding your source media to the 
target monitor for the factory producing your media. Alternatively, submit 
a job manually, using the FlipFactory Job Submit window. The 
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GraphicsFactory filter ingests the template, and variables (if any), with 
default values specified, are passed in via the template specified in the 
filter.
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MONITOR/MANUAL SUBMISSION WITH DATA ENTRY WORKFLOW

In this workflow, GraphicsFactory jobs are submitted via FlipFactory 
monitors or manually, using the Manual Submit window in FlipFactory.

Templates have variables, and specific values are entered by an operator 
or automatically calculated, before encoding the final video overlay 
media.

This automated workflow is designed for high-volume, automatic job 
submission via monitors.

The factory which processes the job has two factories, and the stage two 
(encoding) factory may have one or more products.

Figure 4–11.  Workflow for monitor/manual jobs with data entry

Factory Configuration There are two factories in this workflow. The stage one factory has at 
least one product: Duplicate Original, which is passed through to the 
stage two factory for product encoding.

If manual data entry is required, this workflow enables operator 
intervention to edit metadata (in this case, add variable values) and then 
Resubmit/Forward.
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Additionally, if the stage one factory is used to automatically populate 
variables such as $FILENAME or $DURATION. If you’re using 
$DURATION, then a QuickTime product (for use as a proxy) must be 
added and configured. If you want to review the video with a proxy, you 
should create a QuickTime proxy If it's automatic only, you only need to 
use the Analysis encoder. A small video using the MPEG4 encoder (at 60 
x 80, for example) is acceptable, unless you have other arbitrary timecode 
variables which you want to supply values for by scrubbing the proxy. In 
this case, set the size to 320 x 480 for better viewing.

The QuickTime proxy enables correct frame-accurate calculations of the 
baseline duration. The optional second product in this factory is a 
QuickTime also enables the operator to preview the movie and identify 
significant times easily, if there are timecode variables in the template.

Alternatively, if all variables are automatically populated, then the stage 
one factory should just use a Forward Notify to pass the complete job to 
the stage two factory.

The stage one factory must have the GraphicsFactory PA tool enabled, 
the template selected, so it can be passed through to the stage two factory. 
If you’re automatically calculating variables, such as $DURATION, this 
can be configured within the GraphicsFactory PA tool. The stage two 
factory should have the GraphicsFactory Template filter specified in its 
product. This filter picks up the variables provided by the PA tool in 
Stage 1, and uses them when applying graphics.

Job Submission For this workflow, you submit a job to the stage one factory by adding 
your source media to the target monitor for the factory producing your 
media. Alternatively, submit a job manually, using the FlipFactory Job 
Submit window. The GraphicsFactory PA tool ingests the template, and 
variables are passed in.

When the stage one factory job completes, either a proxy is produced or 
the file is analyzed automatically, and the original file is duplicated. 
Display the Job Status window, and double-clicks the job to view the 
Message Viewer.
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Figure 4–12.  Use Message Viewer to view job results

Click Resubmit to display the Resubmit/Forward window.
4-16 July 2008



74-0072-02 GraphicsFactory Workflows
Figure 4–13.  Use Resubmit/Forward to update variable values

Update the variables in the Metadata group at the bottom, including 
timecodes if any, using the QuickTime proxy playback editor (click 
GraphicsFactory Editor). 
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Figure 4–14.  Use the Playback editor to mark timecodes and trim 
the header and trailer

Scrub through the video and mark selected variable timecodes. Click the 
Save icon (disk) and close the window.

Also, you can use the buttons above the video to go to start, then scrub 
through leader/header or video you just don’t want, and clip it. Then, you 
can go to end and scrub back, to trim trailer or video you don’t want, all in 
a single step. The header/foot trim marks automatically adjust other trim 
marks you make.

Return to the Resubmit/Forward window:
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Figure 4–15.  Submit the job to the stage two factory

Note that the timecode variables you set in the playback/trim editor are 
updated, and update variables if you didn’t already do so.

Select the stage two factory you’re using to encode media, and click 
Submit to submit the job to the stage two factory, where the actual 
product encoding takes place.

WORKFLOW VARIATIONS

You can vary factory settings in several ways to accommodate your 
workflow requirements.

One to Many 
Workflow

In a one-to-many workflow, you can implement a single stage one factory 
with a template. After data entry, this job can be submitted to multiple 
templates in a stage two factory for product encoding. This is useful when 
you have multiple, different templates all using the same variables.
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You enable the GraphicsFactory PA tool and specify a GraphicsFactory 
template which has the prototype variables that are common to all the 
GraphicsFactory templates in this group.

In the stage two factories (one for HD, one for mobile, one for SD, for 
example), you enable the GraphicsFactory Template Filter, and attach the 
specific template for this product, making sure that each template shares 
common variables.

Note
If you are submitting jobs with variables in a two-stage workflow 
that require multiple templates, they must have the same set of 
variables. You can enable the GraphicsFactory Template Filter 
in each product, and specify a unique template in the set.
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