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Copyrights and Trademark Notices
Copyright © 2014 Telestream, Inc. All rights reserved worldwide. No part of this 
publication may be reproduced, transmitted, transcribed, altered, or translated into any 
languages without the written permission of Telestream. Information and 
specifications in this document are subject to change without notice and do not 
represent a commitment on the part of Telestream.

Telestream, Flip4Mac, FlipFactory, Episode, Telestream MAP, MetaFlip, GraphicsFactory, 
MotionResolve, ScreenFlow, and Split-and-Stitch are registered trademarks and 
Pipeline, Launch, Wirecast, Videocue, Drive-in, and Vantage are trademarks of 
Telestream, Inc.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour 
logo, and the Bonjour symbol are trademarks of Apple, Inc.

Microsoft, Windows Media Technologies and Silverlight are trademarks of Microsoft 
Corporation.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.

AudioRestore, iZotope®; ©2011 iZotope, Inc. All Rights Reserved.

Sparkle, copyright (c) 2006 Andy Matuschak.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the "Software"), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, merge, 
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons 
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or 
substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL 
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR 
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
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ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 
OTHER DEALINGS IN THE SOFTWARE.

RSS reader class, copyright (c) 2002, Brent Simmons. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of ranchero.com or Brent Simmons nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS 
IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This project uses software developed by the OpenSSL Project for use in the OpenSSL 
Toolkit (http://www.openssl.org). This toolkit is licensed as follows:

Copyright (c) 1998-2005 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the 
following acknowledgment: "This product includes software developed by the 
OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or 
promote products derived from this software without prior written permission. For 
written permission, please contact: openssl-core@openssl.org.
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5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" 
appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment: 
"This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN 
NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, 
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young 
(eay@cryptsoft.com). This product includes software written by Tim Hudson 
(tjh@cryptsoft.com).

ShortcutRecorder, copyright 2006-2007 Contributors. All rights reserved.

License: BSD

Jesper, waffle software, <wootest+shortcutrecorder@gmail.com>

David Dauer, <david@daviddauer.de>

Jamie Kirkpatrick, Kirk Consulting Ltd, <jkp@kirkconsulting.co.uk> 

CTGradient, v 1.5, copyright (c) 2006 Cotingent.

Created by Chad Weider on 12/3/05.

Some rights reserved: http://creativecommons.org/licenses/by/2.5/
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Limited Warranty and Disclaimers
Telestream, Inc. (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), is free from defects in materials and workmanship under normal 
operating conditions and use.

Software—If software is supplied as part of the product, the software will operate in 
substantial conformance with specifications set forth in its product user's guide. The 
Company does not warrant that the software will operate uninterrupted or error-free, 
will meet your requirements, or that software errors will be corrected.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality.

Software—If software is supplied as part of the product and it fails to substantially 
confirm to its specifications as stated in the product user's guide, the Company shall, at 
its own expense, use its best efforts to correct (with due allowance made for the nature 
and complexity of the problem) such defect, error or nonconformity.

Software Updates—If software is supplied as part of the product, the Company will 
supply the registered purchaser/licensee with maintenance releases of the Company’s 
proprietary Software Version Release in manufacture at the time of license for a period 
of one year from the date of license or until such time as the Company issues a new 
Version Release of the Software, whichever first occurs. To clarify the difference 
between a Software Version Release and a maintenance release, a maintenance release 
generally corrects minor operational deficiencies (previously non-implemented 
features and software errors) contained in the Software, whereas a Software Version 
Release adds new features and functionality. The Company shall have no obligation to 
supply you with any new Software Version Release of Telestream software or third party 
software during the warranty period, other than maintenance releases.
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Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, INC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product.

Damages
TELESTREAM, INC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, Inc.
848 Gold Flat Road
Nevada City, CA 95959

You can call Telestream, Inc. via telephone at (530) 470-1300.

Part Number: 127975

Publication Date: April, 2014
ScreenFlow User Guide
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Telestream Contact
Information
To obtain product information, technical support, or to provide comments on this 
guide, contact us using our Web site, email, or phone number as listed in Table 1.

Table 1. Telestream Contact Information

Resource Contact Information

Telestream Technical 
Support

Web Site: http://www.telestream.net/telestream-support

Support Web Mail. www.telestream.net/telestream-support/
screen-flow/contact-support.htm

ScreenFlow Technical 
Support, FAQs, 
Forums, & Upgrades

Web Site: http://www.telestream.net/telestream-support/
screen-flow/support.htm

Telestream, Inc. Web Site: http://www.telestream.net/purchase/store.htm

Online Web Store: info@telestream.net

Sales and Marketing Email: info@telestream.net

Telestream, Inc. 
848 Gold Flat Road
Nevada City, CA. USA 95959

International 
Distributor Support

Web Site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net

If you have comments or suggestions about improving this 
document, or other Telestream documents—or if you've 
discovered an error or omission, please email us.

mailto:info@telestream.net
http://www.telestream.net/telestream-support/overview.htm
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
http://www.telestream.net/purchase/store.htm
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
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About ScreenFlow
This guide is designed to help you understand how to use ScreenFlow to record, edit, 
and create high-quality screencasts and encode them as MPEG-4 files, or publish them 
directly to video sites such as YouTube, for your audience to enjoy.

This guide also provides hints, tricks, and other information to help you make the best 
screencasts possible.

 Record. Edit. Share.

 Using ScreenFlow in Trial Mode (Telestream Web Store Only)

 What’s New in ScreenFlow

 Making Movies in ScreenFlow

 Making Slide Shows in ScreenFlow

Note: If you haven’t installed ScreenFlow yet and would like to now, proceed to 
Installing ScreenFlow.
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Record. Edit. Share.
Telestream’s ScreenFlow is a powerful, easy-to-use screen recording and video editing 
software for Mac.

With ScreenFlow, you can easily create screencasts—recording your entire display 
while simultaneously capturing your video camera, microphone, and your computer 
audio. ScreenFlow is ideal for creating screencasts for software demos, tutorials, 
application previews, training, and business presentations.

The easy-to-use editing interface lets you creatively edit your video, and add additional 
images, voice-overs, text, and music beds, with callouts and transitions for a truly 
professional-looking video. The finished result is an MP4 movie, ready for publishing to 
your Web site, blog or directly to YouTube or Vimeo.

Or, use ScreenFlow simply as an intuitive video editor to edit and create your own best 
picture nominee.

Using ScreenFlow in Trial Mode
(Telestream Web Store Only)

Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Until you unlock ScreenFlow by purchasing a license and activating it, ScreenFlow 
operates in trial mode. In trial mode, all of ScreenFlow’s features are available, but your 
movies are watermarked when you export or publish them.

To unlock ScreenFlow, go to Unlocking ScreenFlow via Telestream Web Store. 

What’s New in ScreenFlow
This version of ScreenFlow has many new features that improve its capabilities and user 
experience.

• New publishing options added: Google Drive, Facebook & Dropbox.

• Asynchronous uploads for faster workflows

• Enhanced Transition Inspector

• Additional Transition Packs available for sale
ScreenFlow User Guide
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Making Movies in ScreenFlow
With full support for 64-bit architecture, ColorSync, Retina displays and built on Cocoa, 
not only is ScreenFlow a powerful, intuitive and responsive application for creating 
screencasts, it doubles down as a snappy movie maker. 

With its essential nonlinear editor features like the canvas and timeline, making movies 
using your own clips is a snap. Import your own movie clips into the media library, and 
drop them right into the timeline. With its magnetic properties, you can join and sync 
clips without overlaps or clicks in a single drop, then add transition effects, and voice 
overs and music beds.

Using ScreenFlow’s essential features, making your own movies is easy. You don’t have 
to wade through a cluttered jumble of things you’ll never use, just to get your movie 
built. ScreenFlow helps you do what you want—make great movies for friends and 
customers. It doesn’t force you to become a professional editor just to get the job done.

Everything you need is at your fingertips: clip nesting and grouping, video and sound 
effects, tracks and canvas, video clipping, transitions, and support for external camera 
and mic recording.

Use ScreenFlow’s integrated rendering in MEPG-4, QuickTime, and Windows Media 
(Telestream Web Store edition only), and you’ll be premiering your movie in no time.

Making Slide Shows in ScreenFlow
Slide shows have never been easier to make either. You can use images in leading 
formats including PNG, TIFF, and JPEG and many others. You can adjust each image to 
display just the right length of time. And, you can make great transitions, create text 
overlays and graphics, and add your own voice-overs and add music beds, trimmed just 
right. Just like movies, you can use integrated publishing directly in ScreenFlow to 
render your movie for publication or distribution.
ScreenFlow User Guide
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Getting Started
These tours are designed to introduce you to the capabilities and significant features of 
ScreenFlow.

We encourage you to take these tours before beginning a screencast or other 
ScreenFlow project. They help you to gain a basic understanding of how ScreenFlow 
works and help to familiarize yourself with the program.

The creation of a ScreenFlow screencast is a three step process: first you record your 
video, next you edit your screencast project, and finally you export your screencast to a 
video file or publish it directly to an Internet video service such as YouTube and others.

For video tutorials, please visit our ScreenFlow demos page.

 Tour 1—Recording With ScreenFlow

 Tour 2– Editing Your Screencast

 Tour 3—Publishing Your Screencast

http://www.telestream.net/screen-flow/demos.htm
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Tour 1—Recording With ScreenFlow
This first tour focuses on creating a high quality recording for editing and publishing. 
When creating a screencast, it is important to prepare your recording properly while 
considering how you intend to use this screencast.

We recommend that you record a few sample screencasts to familiarize yourself with 
ScreenFlow and its options, before creating a screencast for publication.

To record a screencast with ScreenFlow, follow these basic steps:

1. Open your Applications folder.

2. Drag ScreenFlow onto your dock bar.

3. Double-click the ScreenFlow icon to launch the application.

When you launch ScreenFlow, it displays a Configure Recording window.

Figure 1. Screenflow Recording Window

If you’re ready to start recording, you check the options you want enabled, and click the 
red Record button.

Before you create your first screencast, take a moment to consider ways of approaching 
the process.

Configuring Your Recording
Use the Configure Recording window to specify your recording sources. This 
automatically opens when you launch the application, but it can also be accessed from 
ScreenFlow Helper > Configure Recording… or File > New Recording.

Record Desktop from. This option records your computer display. This source records 
by default and cannot be deselected. If you have multiple displays connected, you can 
choose between them. ScreenFlow cannot record multiple displays simultaneously.

Record Video from. This option records video from any camera connected to your 
computer. Use the popup menu to choose from multiple cameras. Upon selecting a 
source, a preview image displays below.

Record Audio from. This option records from any microphone connected to your 
computer. Use the popup menu to choose from multiple microphones. Upon selecting 
the source, the volume level is displayed below.
ScreenFlow User Guide
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Record Computer Audio. Choose this option to record all sounds played through your 
computer. The ScreenFlow audio driver must be installed to use this setting. If the 
driver is not installed, you are prompted to install it.

Beginning Your Recording
When you are ready, click the Record button. ScreenFlow enters a countdown mode 
before recording. You can change the length of this countdown (see Using the 
Countdown Window). 

Create a short presentation then stop your recording: press Shift-Command-2 or select 
Stop Record from the ScreenFlow Helper menu in the upper-right corner of your 
display. 

When you stop recording, ScreenFlow opens your recording in the ScreenFlow editing 
window with all of your recorded sources placed on the timeline.

Display video and computer audio are combined into one clip; camera video and 
microphone audio are combined in another clip, to maintain video/audio sync. Video 
and audio can be separated by selecting the clip and choosing Edit > Detach Audio.
ScreenFlow User Guide
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Tour 2– Editing Your Screencast
The purpose of this tour is to familiarize you with the basic editing features of 
ScreenFlow. This tour describes some of the most common and basic editing 
techniques.

For a comprehensive description of editing features, see Editing ScreenFlow Projects.

When you finish your recording, ScreenFlow creates a new document and recorded 
media is placed at the beginning of the timeline. The media elements on the timeline 
reference your project’s stored media. Changes made on the timeline or on the canvas 
do not alter your original recording.

The Editing Window
The space used for editing is the editing window, which consists of three main parts: 
Canvas Control, Playback Controls, and Timeline area.

Figure 2. Editing Window

Canvas Controls

The large, central area of the editing window is called the canvas. This offers a preview 
of all visual elements in your project. The gray space around the preview is for elements 
that will not be present in your exported video. This is used to display off-screen 

Canvas

Timeline areaCanvas controls Playback controls

Properties
ScreenFlow User Guide
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elements present in scaling and panning effects. The elements displayed on the canvas 
reflect the position of the scrubber on the timeline.

You can set the canvas size and background color using the canvas controls (see 
Configuring the Canvas).

Timeline Area

The wide area at the bottom of the screen is the timeline. This is a visual representation 
of the temporal length of your screencast. The scale at the top of the timeline 
represents measurements of time.

The red vertical line on the timeline is called the scrubber. This represents the current 
temporal position of the preview currently displayed on the canvas.

The timeline is divided into tracks to manage different clips overlapping at the same 
time. If the clip is visual (i.e. video, image, or text), the upper most track is displayed over 
the lower tracks.

Between the canvas and the timeline are playback controls which enable you to play 
your screencast and jump to the beginning or end of your video.

Properties

On the upper-right side of the editing window are the Properties tabs. These are the 
main editing controls of ScreenFlow and allow you to configure each clip in your 
screencast. It also includes the media library which stores all recorded and imported 
media in an unaltered state.

For more information, see the Properties topics in Editing ScreenFlow Projects.

ScreenFlow provides two different types of cropping.

Figure 3. Canvas Controls
ScreenFlow User Guide
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Canvas Cropping
Canvas cropping is used to change the resolution or aspect ratio of the workspace you 
have to edit in. This can be useful if you want to constrain your screencast to only a 
portion of the total recording (i.e. a foreground window).

Canvas cropping is accessible through the canvas control button. This is set by 
numerically entering the width and height values or dragging the edge of the canvas 
with your mouse cursor.

The canvas cannot be set to a value larger than the original recording. Remember, the 
canvas size represents your total usable display space, which converts to the frame size 
of your video when you export or publish it.

Image Cropping
To crop an image, select the video or still image on the canvas. Hold the Control key 
and drag the edge or handles of the image to crop it. Use the shift key to constrain the 
cropping action to the original ratio of the image.

Actions
Actions are property changes used to transition the media from one state to another. 
Actions are added to a clip by selecting the clip, opening the property that you want to 
alter, then clicking the Add Action button at the bottom of the properties pane. The 
action is placed in relation to the position of the scrubber, but can be moved on the 
clip. The duration of the action is changed by dragging the edge of the action to 
lengthen or shorten the action.

Figure 4. Video Properties Action

Place the scrubber before or after the action to make changes to the property relative 
to the action. When the scrubber is placed before the action, this sets the properties of 
the clip before the action. When the scrubber is placed after the action, this sets the 
properties of the clip after the action.

Video Properties
Video properties can be used to make changes to any recorded or imported video, 
video action, or image file. This includes both screen and camera recordings.

This tour focuses on the most common features. For more details, see Configuring Video 
Properties.
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Figure 5. Video Properties

Scale. Use this option to change the size of a video or image relative to the size of the 
canvas. This can be used for highlighting a particular portion of the screen or with a 
video action to create a zoom effect.

Use the slider or enter a percentage value to change the image scale.

Position. Position represents the location of your video or image on the canvas. The 
position is based on the exact placement of the center of your image. Values in the 
position field are represented in pixels.

You can reposition the image by dragging the image on the canvas, nudging the image 
with the arrow keys, or entering a numerical value in the position fields.

Opacity. This is the degree to which the image is translucent. The greater the value, the 
more opaque the image. If the value is set to zero, the image is invisible.

This is used with a video action to fade an image in or out. It is particularly useful if you 
would like to periodically display your camera recording.
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Screen Recording Properties
Screen recording properties are effects specific to demonstrations using the mouse and 
keyboard. They can only be applied to screen recording clips.

This tour focuses on the most common features. For more details, see Configuring 
Screen Recording Properties.

Figure 6. Screen Recording Properties

Pointer Zoom. Often it can be difficult to see the mouse in a screencast, particularly if 
the video has been significantly resized. Increasing the pointer zoom value makes the 
mouse cursor larger and easier for the viewer to follow.

Click Effect. This feature can be used to make a visual effect when you click your 
mouse. Select Radar to screencast a red circle with each click or Invert to change the 
cursor from black to white with each click.

Sound on Click. Select this option to generate a click sound when the mouse button is 
pressed.

Show Keys Pressed. Select this option to display the text as you were typing it while 
recording.

Show Modifier Keys Pressed. Select this option to display modifiers used in hotkey 
commands, F1 through F12, and the arrow keys.

Callout Properties
Callout Properties are used to highlight a specific portion of the screen. They can be 
applied to screen recordings, images, or video clips. Unlike the other properties, Callout 
Properties must be used with an action.
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This tour focuses on the most common features. For more details, see Configuring 
Callout Properties.

Figure 7. Callout Properties

Highlight. Callouts are capable of highlighting an area in three different ways. Mouse 
cursor highlights a circular space around the mouse cursor. Foreground Window 
highlights any window which is currently active. Freehand allows you to draw the area 
you want to highlight.

Opacity. The opacity slider controls the opacity of the space outside the callout. A low 
value makes the surrounding area more visible, while a high value makes the 
surrounding area less visible.

Zoom Up. This option magnifies the area inside the callout to make it more prominent.

Border. This option increases the range of the callout area to draw attention to a larger 
space. This feature is not available with freehand callouts.

Media Library
The media library stores all recorded and imported media in an unaltered state. This 
media may be dragged from the media library to your timeline or canvas for inclusion 
in the project. You can drag this media into your project multiple times to replicate the 
same file. 

For more information, see Using the Media Library.
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Tour 3—Publishing Your Screencast
The purpose of this tour is to familiarize you with publishing your screencast. 
ScreenFlow screencasts are not video files—they are saved as ScreenFlow documents 
(with a .screenflow extension), which can only be opened and used by ScreenFlow.

There are two ways to publish your screencasts—by exporting them to a standard 
video file format or publishing them directly to an Internet video service, like YouTube 
or Vimeo.

Determining the correct export settings for your screencast depends on the complexity 
of your screencast and the intended use of the video after it has been produced.

This tour explores the basics of ScreenFlow’s export options. For a comprehensive 
description, see Publishing Your ScreenFlow Project.

Select File > Export or press Command-E to export your presentation:

Figure 8. Export Settings Window

Save As. Choose a name for your exported video (default: ScreenFlow.mp4).

Where. Choose a location to export your video.

Preset. ScreenFlow has several export presets for your convenience. This tour focuses 
on the most commonly used presets.

• Web-High. This is the default export option which encodes using the H.264 codec. 
It was chosen as the default codec based on both image quality and file size.

• Web-Low. This is an export option similar to Web-High, but formatted for a low 
bandwidth. It plays more smoothly on slow Internet connections but the image 
quality is not as good as Web-High.

• Lossless. This is an uncompressed export format ideal for additional editing. This 
format has the highest quality image but also the largest file size. When exported at 
100%, the image quality is identical to the original recording.
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iPad / iPhone / Apple TV / iPod. These export options are formatted based on the 
recommended video specifications for these devices. They cannot be altered.

Windows Media. This option exports a video in the WMV format (Telestream Web 
Store edition only). This is a popular format for Windows users. This option uses a 
QuickTime plugin called Flip4Mac which must be licensed separately.

Note: Flip4Mac needs to be installed for this option to appear in the export menu.

Dimensions

These options are used to set the dimensions of your video export. You should not set a 
size larger that your canvas size. This does not improve image quality.

Scale by. Use this option to scale your screencast by a percentage value. This is an easy 
way to shrink your screencast while maintaining the aspect ratio.

Scale to custom size. Use this option to set the exact width and height of your 
exported video. Click the Letterbox Content box to add letterboxing to your export.

Publishing
In addition to encoding a video file, ScreenFlow can also publish screencasts directly to 
YouTube, Vimeo, Google Drive, Facebook, and Flash. These options are accessible from 
the File menu. For more information, see Publishing Your ScreenFlow Project.
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Recording Media in
ScreenFlow
Creating a screencast or other project that involves video is typically a three step 
process: recording your media, editing the project, and exporting (or publishing) your 
screencast as a video file. This chapter focuses on the first step—recording video and 
audio directly in ScreenFlow.

Note: ScreenFlow automatically stops recording when you have less than 100 
megabytes free on your system disk volume.

 How ScreenFlow Records and Saves Media

 Setting Recording Preferences

 Configuring Recording Options

 Recording Media in ScreenFlow

 Recording Tips
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How ScreenFlow Records and Saves Media
ScreenFlow is actually comprised of two separate applications which work together 
seamlessly to provide you a wide variety of options and flexibility as you record media, 
edit, and export your screencasts. 

In addition to ScreenFlow—the desktop application that stars up when you double-
click the ScreenFlow icon—there is also a utility, called ScreenFlow Helper. It is 
ScreenFlow Helper that actually performs the task of audio and video recording. The 
ScreenFlow application enables you to compose and edit your screencast projects and 
export them, but it uses ScreenFlow Helper to perform audio and video recording.

ScreenFlow Helper can be configured to start when you log in to your computer or only 
when you start ScreenFlow (in the ScreenFlow Preferences General Pane). When this 
option is disabled, ScreenFlow Helper always starts when you log in and stays running 
whether ScreenFlow is running or not.

ScreenFlow Helper always runs in the background so that you can start and stop 
recording without changing the state of your system. When ScreenFlow Helper is 
running, it displays a menu identified by a camera icon , in the Finder menu bar.

Note: ScreenFlow can record the computer screen as video, as well as record camera-
based video (iSight, for example). Throughout this guide, the computer screen is 
referred to as the display—as in display video—in keeping with Apple’s terminology.

When you finish recording a clip in ScreenFlow, display video is combined with 
computer audio, and added to your screencast project and saved as a .scc file. Camera-
based video (iSight, for example) and microphone-based audio is also combined, and 
added to a screencast file. Screencast files are stored in a ScreenFlow-controlled 
location, and clips are added to the project’s the media library.

ScreenFlow clips (sometimes called screen recordings or screencast files)—unlike clips 
recorded outside ScreenFlow in QuickTime or other video formats—contain spatial and 
temporal information about mouse tracking and key presses that enables powerful 
special effects to enhance your screencast.

Note: Clips recorded by ScreenFlow are saved in a proprietary ScreenFlow format, 
with a .scc extension, and referred to as screencast files. Screencast files can only be 
utilized by ScreenFlow. Because screencast files are automatically and transparently 
managed by ScreenFlow, you rarely ever encounter them or have to deal with them.
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Setting Recording Preferences
ScreenFlow provides several options for recording. To view and change these 
preferences, select ScreenFlow > Preferences. The recording options are displayed on 
the General tab and the Advanced tab. 

For details, see Setting Preferences.

Configuring Recording Options
In ScreenFlow, you don't need to define a capture region in order to record a clip of 
your display for your screencast. ScreenFlow records your entire computer display with 
an advanced algorithm that produces the highest quality recording and small file 
size—giving you the flexibility to make changes to your frame size in post-production.

You can set up ScreenFlow to record video and audio from various cameras and 
microphones, depending on your project, and you can change these settings any time 
you need to.

To configure your recording options, choose from these options:

• Click on the ScreenFlow Helper  menu and select Configure Recording to display 
the ScreenFlow window

• In ScreenFlow, select File > New Recording to display the ScreenFlow window

• In ScreenFlow, select File > Add Additional Recording to display the Add Additional 
Recording window. Additional Recording allows you to not record the screen, 
whereas Configure Recording always records the screen.

Note: You can also add recording from the Media Library (see Using the Media Library).

The recording options are identical in both windows. However, the Add Additional 
Recording window also allows you to close ScreenFlow automatically before recording. 

 Configuring Recording in the ScreenFlow Recording Window

 Configuring Recording in the Add Additional Recording Window
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Configuring Recording in the ScreenFlow Recording 
Window

You use the ScreenFlow window to select recording options and record media. You can 
record multiple audio and video sources simultaneously: For example, you can record 
your display (with optional computer audio), and at the same time, record yourself 
using the iSight camera, and providing voice-over commentary.

Note: You can only record one screen (even if you have more than one) and one 
camera source, and only one computer audio, and one audio source at a time. For 
example, if you plug in three cameras, you can only choose one at a time to record.

You can display the ScreenFlow window depicted in (Figure 9) in both ScreenFlow and 
ScreenFlow Helper:

• Click on ScreenFlow Helper  menu and select Configure Recording

• In ScreenFlow, select File > New Recording

Figure 9. Configure Recording Window—2 Panes

The ScreenFlow window is a two-pane window—use the arrow at the bottom right to 
display the other pane. 

You can also configure ScreenFlow to record your display unattended. For example, you 
might want to record a half-hour webinar and you don’t want to sit through it to stop 
the recording. Use the Stop Recording option on the second panel to specify the 
elapsed time to stop the recording, and click Set Timer, then start recording. Elapsed 
time recording is a one-off event—you need to set it every time you want to use it.

Recording options are described in Table 2.
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Table 2. ScreenFlow Record Dialog Controls

Control Description

Record Desktop from 
your Color LCD

Note: If you have 
more than one 
monitor, ScreenFlow 
displays a list—select 
which monitor you 
want to record. 

When configuring recording using the ScreenFlow window, 
ScreenFlow automatically records your computer display. This 
option can not be disabled.

When recording using the ScreenFlow Add Additional 
Recording window, you can check or uncheck Record 
Desktop from your Color LCD.

The frame size is determined by the display’s resolution. If you 
have multiple displays, you can choose between them, but 
you can’t record multiple displays simultaneously.

Record Video from Check to record video from a camera.

Use the popup menu to choose the camera you want to use. 
ScreenFlow displays live video below.

Record Audio from Check to record audio from a microphone.

Use the popup menu to choose the microphone you want to 
use. The volume level is displayed below.

Record Computer 
Audio

Check to record sound played through your computer.

The ScreenFlow audio driver must be installed to record 
sounds played through your computer. If the driver isn’t 
installed, you’re prompted to install it (see Installing 
Telestream Audio).

Stop Recording After Specify when ScreenFlow should automatically stop this 
recording session. Click Set Timer to activate one time.

Record Click the red button—the Record icon—to display the 
countdown window (if enabled—see the Countdown option 
in the General Pane) and begin recording.
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Configuring Recording in the Add Additional Recording 
Window

You can also use the Add Additional Recording window to select recording options, 
and record media to add to an open project document. To display the Add Additional 
Recording window in ScreenFlow, select File > Add Additional Recording (Figure 10) or 
click the Add Recording button in the media library, which is described in detail in Using 
the Media Library.

Figure 10. Add Additional Recording

 

Note: When you are recording using Add Additional Recording, you can select only 
those sources you want to record. You can disable display recording—by unchecking 
Record Desktop from your Color LCD—which you can’t do in the ScreenFlow 
recording window.

You can also close the ScreenFlow application automatically, before recording—check 
the Close ScreenFlow before recording checkbox. Typically, you use this option when you 
don’t want the ScreenFlow application or its windows displayed on the desktop or the 
ScreenFlow icon displayed in the dock when you’re recording. 

Note: Make sure that all open ScreenFlow documents have been saved prior to 
starting recording or it won’t close on command.

The recording options are described above, in Table 2.
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Recording Media in ScreenFlow
Depending on how you plan to use your clip, choose these recording options:

 Stopping, Pausing & Resuming Your Recording

 Using the Countdown Window

 Recording When you Start ScreenFlow

 Creating a Document Without Recording

 Adding Recordings to a ScreenFlow Project

 Recording Clips Generally

 Setting the Recording Timer

Stopping, Pausing & Resuming Your Recording
Before you start recording, it’s nice to know how to stop. To stop recording in 
ScreenFlow, click the ScreenFlow Helper  menu and select Stop Record or press 
Shift-Command-2, the default shortcut to stop recording.

To pause your recording, click the ScreenFlow Helper  menu and select Pause. When 
you pause recording, the solid black recording dot changes to a blinking paused dot. To 
start recording again, select Resume from the ScreenFlow Helper menu.

Using the Countdown Window
By default, each time you start recording (unless you’ve disabled it in Preferences), 
ScreenFlow displays the countdown window as shown below in Figure 11, providing a 
delay to allow you to prepare for recording.

Figure 11. Using the Countdown Window

By default, the countdown is set to 5 seconds. To change the countdown option (or to 
enable or disable the countdown window), select > Preferences > General. For details, 
see General Pane. You can set the countdown delay for up to ten seconds.
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To skip a countdown in progress, simply click on the countdown window and 
ScreenFlow begins recording immediately.

Recording When you Start ScreenFlow
To record a clip for a new screencast project, just start ScreenFlow. The ScreenFlow 
recording window displays and you can click the red Record button to start recording 
your first clip. (If you don’t want to record right now, just close the window.) During 
recording, the camera icon of the ScreenFlow Helper menu displays a black dot.

When you stop recording, ScreenFlow displays a window that lets you add your 
recording to a new document, add to an existing document, or discard the document.

Creating a Document Without Recording
To create a ScreenFlow document without recording, start ScreenFlow. When the 
ScreenFlow recording window displays (Figure 12), click the Close button on the upper 
left corner. Now, select File > New Empty Document or press Shift-Command-N.

ScreenFlow displays a dialog which allows you to set your canvas size to any dimension, 
regardless of your display size. 

Figure 12. Using the Recording Complete Dialog

Select a preset canvas size from the Preset popup menu or enter a custom canvas size 
in the Width and Height fields.

Now, you can record video or work on your project using other media, as you want.

Adding Recordings to a ScreenFlow Project
To record a clip and add it to an open project, make sure the project window is open 
and selected. Then, select File > Add Additional Recording (Shift-Command-R) or press 
the Add Recording button in the media library. Verify your settings and click Record.

Depending on your preferences, the countdown window displays, and then 
ScreenFlow begins recording. During recording, the camera icon of the ScreenFlow 
Helper menu displays a black dot. When you stop recording, ScreenFlow adds the clip 
you just recorded to the project.

For details, see Configuring Recording in the Add Additional Recording Window.
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Recording Clips Generally
To record a clip without deciding which project to add it to first, click on the ScreenFlow 
Helper  menu and select Record or select File > New Recording. Depending on your 
preferences, the countdown window displays, and then ScreenFlow begins recording. 
During recording, the camera icon of the ScreenFlow Helper menu displays a black dot.

When you stop recording, ScreenFlow displays a Recording Complete window 
(Figure 13) so that you can create a new document with our recording, or add your 
recording to any open document.

Figure 13. Using the Recording Complete Dialog

To verify your settings first, click on the ScreenFlow Helper  menu and select 
Configure Recording. When you’re ready, click the Record button. Depending on your 
preferences, the countdown window displays, and then ScreenFlow begins recording. 

When you stop recording, ScreenFlow displays the Recording Complete window, as 
shown above, so that you can add your recording to an open project, start a new one, 
or discard your recording.

Setting the Recording Timer
You can also configure ScreenFlow to record your display unattended. For example, you 
might want to record a half-hour webinar and you don’t want to sit through it to stop 
the recording. 

To set up ScreenFlow to stop recording after a certain time, click on the ScreenFlow 
Helper  menu and select Configure Recording. Use the Stop Recording option on 
the second panel to specify the elapsed time to stop the recording, and click Set Timer, 
then start recording. Elapsed time recording is a one-off event—you need to set it 
every time you want to use it.
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Recording Tips
Before you begin your recording, it’s useful to consider how you (and your users) intend 
to use your screencast, how you want to organize your media, and how best to present 
your screencast on screen.

 Setting Your Display Resolution

 Using Text in a Screencast

 Considerations for Narrative Screencasts

Setting Your Display Resolution
Two important factors to consider before you begin recording is the resolution of your 
display and the intended export resolution of your screencast. Since you usually do not 
intend to export your screencast at the same resolution that you recorded at, it is 
important to consider that your final video will be at a lower resolution than it is on 
your screen—especially if you are recording a large resolution display or a Retina 
display (maximum 2880 x 1800). This is especially important when you have text which 
must be legible. Digital video was not designed to capture text, so it can often be 
difficult to capture clearly.

Telestream recommends that you check your display resolution before recording 
(select System Preferences > Displays). Lower your display resolution as much as 
possible without impairing your ability to view your screencast clearly. Do not lower the 
resolution below your intended export resolution or you will lose quality.

Using Text in a Screencast
Digital video was designed primarily for capturing real world images, so it is often 
difficult to capture the thin lines of text legibly. Here are a few tips to consider when 
you are using text in your video:

• Use larger point sizes (e.g., at least 25 points or more). Larger characters always ren-
der better than small ones.

• Do not use serif fonts (e.g,. Times Roman). Always use sans-serif fonts (e.g., Arial or 
Helvetica).

• Use boldface fonts, since they render better, especially at smaller sizes.

• Do not use odd values for the output movie's frame height or width. Always use 
even numbers. Also, input sources having odd height or width values can result in 
illegible titles.

• Always generate non-interlaced video (the Lossless preset is the only format that 
you can specify as interlaced). Interlaced video is much more prone to poor quality 
text rendering because it may introduce flickering.
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Considerations for Narrative Screencasts
When creating narrative screencasts, you might consider two different approaches. For 
simple demonstrations, you may be able to narrate the demo as you perform it. For 
more complex demos, you may have a problem narrating in real time, as you perform 
the task using the keyboard and mouse.

 Record Everything at Once

 Record Your Display—Then Add Narration

Record Everything at Once
Using this method, you record each recording source in a single session—
simultaneously recording the display, camera video, microphone audio, and computer 
audio. When you are done recording, you can use the editing tools to finalize your 
screencast project.

For example, you might start a screencast project by recording your display, then cut to 
a Picture-in-Picture of a camera recording, as you demonstrate the application. Later, 
you fade out your video, leaving only the audio to narrate the remaining moments of 
the screencast.

This method is considered a single-pass production. It works well when your subject 
matter is simple, straightforward, or short. For longer or more complex screencast 
projects, you may find the second approach more comfortable.

Record Your Display—Then Add Narration
Using this method, you first record the display (optionally, without computer audio), 
demonstrating your application or subject matter without any video or voice-over.

When you have finished your demonstration, you can record your camera and 
microphone sources while playing the video preview of your demonstration in 
ScreenFlow. This can be done in a single long recording or several short recordings.

You can then edit your recordings to align your narration with your demonstration or 
fade your camera recording in and out when appropriate.

This workflow is effective when the screencast involves a series of complex mouse or 
keyboard operations, or you have several comprehensive steps or tasks to achieve, 
each of which take some effort to produce.
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Editing ScreenFlow
Projects
You use the editor window to create your screencast or other ScreenFlow project, add 
media, and add text, actions, and other effects for clarity, emphasis, and visual appeal.

You also use the editor window to arrange elements spatially and temporally in your 
project, and configure elements to behave or display just the way you want, and to 
preview your project and then go back and adjust your results.

 Editor Window Overview

 Adding Media to Your Project

 Using the Editor Window’s Toolbar

 Editing Your Project on the Canvas

 Editing your Project on the Timeline

 Using Nested Clips

 Creating Closed Captions

 Configuring Video Properties

 Configuring Audio Properties

 Configuring Screen Recording Properties

 Configuring Callout Properties

 Configuring Annotations Properties

 Configuring Text Properties

 Using Audio and Video Filters

 Using the Chroma Key Filter

 Using the Media Library

Editor Window Overview
You use the editor window (Figure 14) to create screencast or other ScreenFlow 
projects, and then edit your projects. This includes adding media, and adding text, 
actions, and other visual and audio effects for clarity, emphasis, and visual appeal.
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The editor window also allows you to arrange your project’s elements both spatially 
and temporally, and configure each element’s properties to behave or display just the 
way you want, and to preview your project and then go back and adjust your results.

Figure 14. Editor Window Overview

The editor window is a document window for ScreenFlow documents. Each editor 
window displays a single ScreenFlow project. Each ScreenFlow project is stored in a 
ScreenFlow document, including the media library. You can open several ScreenFlow 
documents and work on these projects simultaneously.

Note: To create a new, untitled ScreenFlow document for a new project, see Creating 
a Document Without Recording.

The editor window consists of three panes: canvas, properties, and timeline.

You can resize the canvas and timeline panes by clicking and dragging the toolbar up 
or down. Click anywhere in the region of the toolbar directly below the toolbar icons 
(and above the timeline) and drag the toolbar up or down to resize the panes.

The upper-left pane of the editor window is the canvas. The canvas is a spatial 
representation of the visual clips of your project (and their properties, actions, etc.), 
based on the position of the scrubber on the timeline. At any given point in time, 
elements in a project may be entirely or partially visible in the frame, or off-screen 
entirely. You use the canvas to arrange, resize and configure these elements. For details, 
see Editing Your Project on the Canvas.

Preview pane

Timeline pane

Canvas button

Playback
controls

Properties 
panes

Audio meters

Timeline 
magnification 
slider

Resize canvas 
and timeline 
panes by 
dragging the 
borders.

Timecode Toolbar

Scrubber
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The bottom pane (directly below the playback controls) is the timeline—a temporal 
representation of your project, with a time scale at the top. The timeline enables you to 
arrange the clips in your project in play order, and add fades and other effects. The 
elements on the timeline reference media in your project’s media library. Changes 
made on the timeline or on the canvas do not alter your original media clips in the 
media library. For details, see Editing your Project on the Timeline.

The upper-right pane displays the properties panes and media library. There are six 
properties panes: video, audio, screen recording, callouts, annotations, and text. For 
details, see Configuring Video Properties. The media library (Using the Media Library) 
stores all recorded and imported media in its original format and state. 

All three panes work together to help you create, edit, and preview your project.

Adding Media to Your Project
Media files are added as clips in ScreenFlow. And clips are the building blocks of every 
ScreenFlow project. Before you can accomplish any editing or composition, you need 
to add clips to your project. A clip in ScreenFlow is not the media itself—the media is 
the file that the clip represents (or points to). A clip not only points to a media file, it also 
contains all of the other information need to play and render the clip the way you’ve 
configured it. This may include start and stop times, fades and other actions, and other 
properties that you assign.

As mentioned before in Recording Media in ScreenFlow, you can record your display 
directly in ScreenFlow, and you can also record directly in ScreenFlow using a camera 
and microphone. When you do, these recordings are automatically managed by 
ScreenFlow, and clips are added to your project under your control.

You can also add media that has been recorded outside of ScreenFlow, and you can use 
still images as clips as well. ScreenFlow supports video and audio file formats that 
QuickTime Player can play in Mac OS X10.6.x and higher. ScreenFlow also supports 
many image formats, including PNG, JPEG, GIF, and TIFF images—if Preview can display 
a file, you can use it in ScreenFlow.

The media library is an integral part of ScreenFlow—it’s a central repository for media 
you’re using in a project, and knowing how it works will help you take advantage of it.

Adding media to a project always involves adding a clip to the media library—even if it 
happens automatically. You either drag media from the file system onto the timeline 
and ScreenFlow adds its clip to the media library automatically—or you add media 
directly to the media library (creating a clip), and then you drag the clip onto to the 
canvas or timeline whenever you want to—creating a copy of the original clip. 

You might think that dragging a clip onto the timeline merely places it there, but in fact 
it’s a copy. You can edit it without changing the properties of the original clip. And, you 
can drag the original clip onto the timeline over and over, as many times as you like.

These topics focuses on the practical issue of getting clips into your project, ignoring 
the finer details of media library management for the moment. For those details, see 
Managing Media in your Media Library.
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 Adding Clips

 Deleting Clips

Adding Clips
To add clips to your project use these methods:

• Drag a clip from the media library directly onto the canvas. This allows you to locate 
the media’s frame spatially on the canvas. The clip is automatically placed in a new, 
top track on the timeline at the point of the scrubber.
If this clip is a display recording and the canvas is the same size, you can just drag it 
onto the timeline—the clip is automatically positioned to fill the canvas correctly.

• Drag a clip from the media library directly onto the timeline. This allows you to 
place the clip on the track(s) you want, and at the location on the timeline you 
want. You can select one or more clips using lasso selection—click and drag across 
some portion of each clip to select it.

• Double-click a clip in the media library to add it to the timeline at the point of the 
scrubber.

• Drag a clip from the file system (Desktop or Finder window) directly onto the time-
line. This allows you to place the clip on the track you want, at the point on the 
timeline you want. The clip is automatically added to the media library.

Note: You can also copy and paste clips in the same project, and you can copy and 
paste clips between open ScreenFlow document windows.

The default name of a clip is obtained from the media file it references. To change the 
name of a clip, double-click on the text or click the gear icon  on the clip, and select 
Rename Clip. The new name does not change the name of the source file.

Deleting Clips
To delete clips from your project use these methods:

• Select a clip on the canvas or timeline and press Delete or select Edit > Delete. This 
removes the clip from the canvas/timeline, but the original clip remains in the 
media library.

• Select a clip in the media library and press Delete or select Edit > Delete. This 
removes the clip from the timeline and deletes the clip from the media library. If the 
media is on the timeline, ScreenFlow displays a Delete dialog—click Delete to con-
tinue. (This action does not delete the referenced media file—just the clip.)
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Using the Editor Window’s Toolbar
Below the canvas is a toolbar. It displays several tools you’ll use to configure your 
canvas, preview your video, and monitor your audio, as described below, in Table 3.

Editing Your Project on the Canvas
The canvas (Figure 15) is a real-time video preview pane—a spatial representation of 
the visual elements of your project—which allows you to size and position the visual 
elements of your project. How (and where) the elements display at any point in time is 
controlled by the position of the scrubber on the timeline.

Table 3. Using the Editor Window Toolbar

Control Description

Canvas Button Click the canvas button (far left) to display the canvas 
controls—click it again to hide them. You can use these 
controls to view and adjust canvas properties: the canvas size 
(and resulting frame size of your exported video) and 
background color.
For details, see Configuring the Canvas.

Playback Controls Use the playback controls (center) to play your project as well 
as jump to the beginning or end of your project. 

You can also use the traditional video editor’s JKL keystrokes 
for Rewind, Stop, and Playback. Press J or L repeatedly to 
speed up rewind/playback respectively.

The timecode of the project is displayed directly to the right 
of the playback controls. (You can set timecode to SMPTE or 
ScreenFlow—see Timeline Pane.)

Audio Meter The audio meter (far right) displays audio volume. The top 
meter represents the left channel; the bottom, the right 
channel.
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Figure 15. Using the Canvas Pane

The center rectangle (which may be obscured by a clip, as shown above) represents the 
video frame of your project. Its dimension (which is set by clicking the Canvas button 
and using the canvas controls) determines the frame size of your video when you 
export or publish it. 

The gray space around the video frame rectangle is workspace; space that isn’t 
included in exported video. You can use this space for off- or partially off-screen visual 
elements for scaling or pan effects.

 Zooming and Panning the Canvas

 Configuring the Canvas

 Arranging and Adjusting Clips on the Canvas

Zooming and Panning the Canvas
You can zoom in and out on the canvas to view details or see the big picture. 

To zoom in or out on the canvas, use the scroll wheel or use these commands:

• Zoom in—select View > Zoom In (Command-=)

• Zoom out—select View > Zoom Out (Command--)

• Zoom to full pixel size—select View > Zoom to 100% (Alt-Command-0 (zero))

• Zoom to fill the pane at its current size and shape—select View > Zoom to Fit (Alt-
Command-0 (zero)).

When the canvas is larger than the panel, scroll bars appear so that you can pan in any 
direction to view hidden portions of the canvas.

Canvas work
area

Canvas button

Playback controls

Output frame 
rectangle

Timecode

Canvas 
properties
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Configuring the Canvas
Before you start working on a project, it’s a good idea to configure your canvas—
determine the frame size of your published project, pick a background color, etc.

Click the Canvas button  to view and configure your canvas properties (Figure 16).

Figure 16. Empty Canvas Pane Without Any Elements

When canvas controls are displayed, you can’t use the canvas. Click the button again to 
hide the controls. Click Apply to save the settings before closing the control bar. 

Canvas 
properties

Canvas button

Table 4. Canvas Properties

Control Description

Canvas (Width and 
Height)

Enter the width and height values on the Canvas X and Y 
fields to change the video frame size. (When canvas controls 
are hidden, you can also click and drag any corner of the 
rectangle to change its size.) The size cannot be set to a value 
larger than the original recording.
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Arranging and Adjusting Clips on the Canvas
After you add clips to your project, you can quickly and easily arrange them spatially on 
the canvas, and you can crop, resize, rotate, add filters, etc.

Figure 17. Arranging and Adjusting Clips on the Canvas Pane

To operate on a clip, click to select it. ScreenFlow highlights the clip (both on the canvas 
and the timeline). When you select a clip on the canvas, it also selects it on the timeline.

Background Color Click the Background Color button  (to the right of the 
Canvas height and width fields) to choose the background 
color of the canvas (default: black.) If your visual elements 
don’t obscure the background, it displays as part of the video.

Snap to Front 
Window

Check to highlight a foreground window in your recording 
and want to crop the area outside of that window. This helps 
you to crop the canvas around the foreground window. 

When you start your recording, no window is selected. So 
during your recording you need to click on the window you 
want to highlight. After the recording, you need to move the 
scrubber to where you clicked to highlight. Now you can click 
on the canvas button, move the sides and they will snap to 
your highlighted (focused) window.

Reset | Cancel | Apply Use these buttons to reset the settings to the default values, 
cancel changes you’ve made, or apply the changes you’ve 
made, before hiding these controls.

Table 4. Canvas Properties

Control Description

Click a media clip to highlight it.

Grab a resize handle to resize 
the rectangle.

Grab the center handle to 
rotate the clip at any angle.

Notice the highlighted clip on 
the timeline, and the scrubber 
bar’s position.
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Note: You can select a clip on the canvas or timeline when you want to view or 
change its properties, which is done using the properties panes to the right of the 
canvas.

 Placing a Clip Spatially

 Resizing/Scaling a Clip

 Cropping a Clip

 Rotating a Clip

Placing a Clip Spatially
To place a clip anywhere on the canvas, click and drag it to the location you want, and 
then release the mouse. When dragging a clip on the canvas, as you near the center 
vertically or horizontally, yellow guidelines appear to help you locate the clip along 
those lines, if you want.

The location of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click its Video Properties tab. The location is identified in the Position field, 
as X and Y values (in pixels). 

Resizing/Scaling a Clip
To resize (or scale) a clip up or down, select the clip and then select any resize handle 
and drag your mouse. Hold the Shift key while scaling to preserve its aspect ratio. You 
can also use the scroll wheel plus the Command key to resize the selected clip.

The scale of a clip is also specified as part of its properties. To adjust it in the video 
properties panel, select the clip and click the Video Properties tab. Use the Scale slider 
or manually enter a percent to resize the clip.

Cropping a Clip
To crop a clip, press and hold the Control key and drag any resize handle inward. Hold 
the Shift key while scaling to preserve the aspect ratio.

The cropping of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click the Video Properties tab. Click the Details icon and use the left, right, 
top and bottom sliders or manually enter a pixel value to crop the clip.

Rotating a Clip
Click and drag the center handle of the clip and rotate it.

The rotation of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click the Video Properties tab. Use the X, Y, and Z thumbwheels or manually 
enter a degree value to rotate the clip in any direction.
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Editing your Project on the Timeline
The timeline (Figure 18) is a temporal representation of your project. The timeline 
displays all of the clips in your project and represents the start and end time each for 
the clips. You can use the timeline to arrange clips in the order you want them played. 
You can also layer them, and crop them. You can also use the timeline to add actions 
(such as fade) to your clips.

Figure 18. The Timeline Displays Media Clips

The timeline is divided vertically into tracks to allow you to arrange clips that overlap at 
certain points on the timeline. 

 Using the Scrubber

 Using the Scale

 Zooming In and Out on the Timeline

 Using Tracks

 Trimming Clips

 Creating and Closing Gaps in a Single Track

 Creating and Closing Gaps Across All Tracks

 Using In and Out Points

 Changing a Clip’s Play Speed

 Grouping Clips

 Locking Clips

 Creating a Freeze Frame

 Using Markers to Identify Points on the Timeline

 Creating Transitions

 Using Actions

Using the Scrubber
The red vertical bar with a handle (red flag) at the bottom is the scrubber. The scrubber 
identifies the current temporal position of the view displayed on the canvas, and its 
timecode displays in the toolbar. 
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You can scrub (move) through your project by using the mouse to grab the top handle 
(in the time scale) and moving it right or left. Notice that as you use the scrubber to 
scrub your project, the canvas updates in real time. 

You press the Home key (or select Mark > Go to > Project Start) to jump the scrubber to 
the beginning of the timeline, and the End key (or select Mark > Go to > Project End) to 
jump to the end. You can also use the left and right arrow keys to move the scrubber a 
frame at a time—or select Mark > Go to > Previous Frame or Next Frame.

Use the red handle (red flag) at the bottom to insert time across all layers on the 
timeline, splitting clips if they fall under the scrubber.

Using the Scale
At the top of the timeline is the scale. The scale is a precise measure of the total length 
of time in the project, and you can determine the start and stop time of each clip (or 
action in the clip) in the project by moving the scrubber to the start or stop of the clip.

Zooming In and Out on the Timeline
If you need to zoom in on an area of the timeline to make minor adjustments—or zoom 
out to see the big picture—use the timeline magnification slider (Figure 19). 

Note: Apple Magic Trackpad and MacBook Pro users can use pinch gestures to zoom 
in/out on the timeline.

Figure 19. Timeline Magnification Slider

To change the scale magnification, use the slider in the lower left corner of the window. 
At maximum magnification, each line on the scale represents a single frame of video.

Note: You can also click repeatedly on the small and large magnifier icons to 
incrementally zoom in or out.

You can also use the View > Zoom Timeline to Fit (Control-T) | Zoom Timeline In (=) | 
Zoom Timeline Out (-) menu items to adjust magnification.

Using Tracks
You can place multiple clips sequentially in a single track or you can place clips 
separately on individual tracks, and use as many tracks as you need. 

Tracks allow you to organize your clips by layer. For visual elements at the same point 
on the timeline, vertical arrangement of tracks determines how they display in relation 
to other tracks. The further down the stack they are on the timeline, the further back 
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they display in the video. Thus, if a track is below another track, its elements will be 
obscured by the track or tracks on top. Visual elements in the top track always display 
frontmost and can’t be obscured; those in the bottom track always displays farthest 
back and will be obscured by the elements in all other tracks above (in front) of it.

For example, a text box placed on a track above a video overlays the text on top of the 
video. If the text box were placed on the track below the screen recording, it would be 
behind the recording and not visible.

Adding and Deleting Tracks
You never need to add a track explicitly; ScreenFlow adds a track every time you drag a 
clip down into the timeline below the existing tracks.

To delete a track, use one of these methods:

• Right-click in the track controller to display the context menu and select Delete

• Click in the track controller and drag it out of the window and drop it when the 
cloud displays.

Using the Track Controller
Use the controls (Figure 20) in the track controller at the far left of the timeline on each 
track to adjust the track height and re-arrange their order.

Figure 20. Using Track Controls to Adjust Track Height and Position

To adjust the height of a track, use the arrow buttons on the track. Click the down arrow 
to decrease the track height; click the up arrow to increase track height. This can make 
it easier to manage clips and other elements in your timeline. 

To re-arrange a track’s position, select the track position handle and drag the track up 
or down in relation to the other tracks on the timeline and drop it in the new position. 
This allows you to move all of the clips, rather than moving one clip at a time.

You can click and drag a clip left or right in a timeline to adjust its start time relative to 
the other clips. You can also click and drag clips to other tracks, or down to a new track.

Trimming Clips
ScreenFlow provides a few simple commands for quick editing of clips in your timeline.

 Splitting a Clip

Track height

Track position
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 Trimming a Clip

Splitting a Clip
To split your clip into two smaller clips, position the scrubber over the moment where 
you want the split to occur, then press the T key or select Edit > Split. This splits the 
selected clip at the scrubber into two separate clips. By default, the newly-created clip 
to the left is selected after the split. 

Note: Press Shift-T to split the clip and have the clip on the right selected.

Trimming a Clip
Reducing the Clip Length—To trim the front of the selected clip, position the scrubber 
at the time you want the clip to begin, then press the W key or select Edit > Trim Front 
to Scrubber. This trims the clip up to the scrubber, thus changing the start time—but it 
does not alter the referenced media.

To trim the end of the clip, position the scrubber at the time where you want the clip to 
end, then press the E key or select Edit > Trim End to Scrubber. This trims the clip (not 
the media) after the scrubber.

You can also grab either end of the clip and drag it inward to trim it. 

Lengthening a Previously Trimmed Clip—On a previously-trimmed clip, you can pull 
either edge out from the clip to restore trimmed media.

Note: Trimming changes the amount of time the clip plays; it does not modify the 
referenced media file.

Creating and Closing Gaps in a Single Track
To create a gap in a track between existing clips, drag to shift the clips to the left or right 
as necessary. 

To close a gap in a track, click in the gap—ScreenFlow highlights the gap in purple with 
diagonal gray stripes. Press the Delete key, or control-click and select Close Gap.

Creating and Closing Gaps Across All Tracks
To create a gap in the entire timeline (across all tracks) to place a new clip, position the 
scrubber where you want the gap to occur. Then, grab the handle (red flag) at the 
bottom of the scrubber and move it to the right. 
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Figure 21. Using the Scrubber to Create a Gap on the Timeline

As the gap is created and widened, all clips to the right of the scrubber (in every track) 
move to the right to create the timeline gap. If the scrubber is positioned over any clip, 
it splits it in two.

To close a gap, position the scrubber at the beginning of the gap you want to close. 
Then, drag the bottom scrubber handle (red flag) to the left. This doesn’t join clips 
which have been split; it just butts them together. If clips overlap, this forms a 
transition.

Using In and Out Points
You can create in and out points on your timeline, and use them in the following ways:

• To delete the selected (marked) section of the timeline and close the gap, select 
Edit > Ripple Delete (Command-Backspace). All clips between the in and out points 
on all tracks are trimmed, and each clip completely encompassing the in and out 
points is split into two clips. All clips on the right are shifted left. After performing in 
and out point operations, in and out points are automatically removed.

• To delete the selected (marked) section of the timeline, without closing the gap, 
select Edit > Delete. All clips between the in and out points on all tracks are 
trimmed, and each clip completely encompassing the in and out points is split into 
two clips, leaving a gap on the timeline. After performing in and out point opera-
tions, the in and out points are automatically removed.

• To publish the range bounded by the points (instead of exporting the entire proj-
ect), select File > Publish Selected Range to < YouTube | Vimeo | Google Drive | 
Dropbox | Facebook | Flash>. ScreenFlow displays the selected Publish dialog. Pro-
ceed as appropriate for the publisher. See Publishing Your ScreenFlow Project for 
details.

• To export the range bounded by the points (instead of exporting the entire proj-
ect), select File > Export Selected Range. (See Exporting Your Video).

Position the scrubber, then 
drag the handle (red flag) to 
create a gap on the timeline.
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The time between mark in and out points is highlighted in purple (Figure 22). 

Figure 22. Marking In and Out Points on Timeline

To set in and out points, position the scrubber and select Mark > Mark In Point (or press 
I). ScreenFlow highlights the timeline in blue to the end of the timeline. Then move the 
scrubber to the out point and select Mark > Mark Out Point (O) to set the out point.

You can reverse this process as well: Position the scrubber and set the out point. 
ScreenFlow highlights the timeline in blue to the beginning of the timeline. Then move 
the scrubber and set the in point.

To set in and out points relative to the position of the scrubber, shift-click on the 
timeline scale. If you shift-click to the left of the scrubber, you create the in point, using 
the scrubber location as the out point; if you shift-click to the right of the scrubber, you 
create the out point using the scrubber as the in point.

When you create an in point without an out point, ScreenFlow automatically sets the 
out point to the end of the last clip. When you create an out point without an in point, 
ScreenFlow sets the in point to the beginning of the timeline.

Changing a Clip’s Play Speed
You can change the play speed of individual clips on the timeline (Figure 23). This 
option is useful for quickly moving past a process that doesn’t need to be shown in 
detail or slowing down a quick process which should be viewed in greater detail.

To change a clip’s play speed, use one of these two methods:

• Press and hold the Option key and move your cursor to the edge of the clip. The 
cursor displays a clock icon indicating that you are changing the clip speed. Move 
the edge of the clip inward to speed the clip up and outward to slow the clip down. 

• Click on the gear icon and select Show Clip Inspector (Figure 23).

Figure 23. Speed Change Icons

To adjust the speed, use the slider or manually enter a percentage value, as shown 
below in Figure 24. You can also change the duration to change the speed. Short is 
faster, longer is slower.

Gear icon with clip commands. 
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Figure 24. Using the Clip Inspector

You can also lock a clip to prevent editing.

The clip is marked with a speed badge—a turtle or rabbit icon—to indicate that the clip 
speed was decreased or increased.

Grouping Clips
You can group a set of clips together to link them to one another temporally, which 
enables you to move them as a group in a single operation. This is useful when you 
have a sequence of clips arranged, and you want to preserve their relationship to one 
another.

It’s also useful when you have a screencast clip and a corresponding iSight clip with 
video and/or voice-over. Because the iSight clip is on the same timecode, grouping the 
two makes it easy to keep them in synch with one another.

To group a set of clips together, select the clips you want to group, and select Edit > 
Group or press Command-G.

To ungroup them again, select the group, then select Edit > Ungroup or press 
Command-U. 

Note: ScreenFlow also supports nesting of clips—hiding nested clips in one master 
nest clip, to reduce timeline complexity and increase the ease of editing. For details, 
see Using Nested Clips.

Locking Clips
You can lock a clip so that it can’t be altered in any way. This is useful when you have a 
clip placed or configured exactly the way you want and do not want to alter them. 
Figure 25 depicts a clip which is locked—it displays dimmed and cannot be modified or 
moved.

To lock a clip, select it and use one of these methods:

• Select Edit > Lock Clip.

• Click the gear icon  on the clip and select Show Clip Inspector, then check Locked 
or select Lock Clip (Alt-Command-L).
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Figure 25. Locking and Unlocking Clips

To unlock the clip, select it and select Edit > Unlock Clip or display the gear menu and 
select Show Clip Inspector or select Unlock Clip (Alt-Command-L).

Creating a Freeze Frame
If you want to pause on a single frame of video while editing, select the clip and move 
the scrubber to the frame where you want to freeze. Select Edit > Add Freeze Frame to 
create a still image of the current frame of video, as shown below in Figure 26. 

Figure 26. Creating a Freeze Frame

This command splits the video into two clips, and adds a two second freeze frame clip 
(essentially an image) in between the two split clips. The duration of the freeze frame 
can be modified by expanding or contracting the clip (see Trimming Clips).

Using Markers to Identify Points on the Timeline
You can place markers on your timeline to identify a particular milestone on your 
project that you want to refer to often. Markers are particularly useful in a long or 
complex project during editing.

 Adding Markers

 Jumping to a Marker

 Deleting Markers

Note: You can also export marker locations as chapters in supported formats. For 
more information, see the Add Chapter Track from Markers control, described in 
Exporting Your Video.

Adding Markers
To add a marker, select from these choices:

• Move the scrubber to the desired location and select Mark > Markers > Add

Locked clips display as dimmed.
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• Control (right)-click in the time scale (scrubber jumps) and select Add Marker

• Select Window > Markers, then move the scrubber to the desired location and in the  
Markers window, click the plus (+) icon at the bottom left.

ScreenFlow displays a dialog so you can name the marker.

Figure 27. Creating a Marker

After entering the name of the marker, click OK. 

Note: Markers display as orange ticks on the time scale are named, but display in blue 
if blank or unnamed. You can select them to rename them, or drag them to re-arrange 
them.

Jumping to a Marker
To jump to a given marker, these choices:

• Select Window > Markers

ScreenFlow displays the marker list window, as shown here in Figure 28.

Figure 28. Selecting a Marker From the Marker List

Click the arrow to the left of a marker to quickly move to that time in the project. 

• Control (right)-click in the time scale—select the marker that you want to jump to.

Deleting Markers
To delete markers, choose from the following:
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• Control (right)-click the orange or blue marker in the time scale and select Delete

• In the Markers window, select the marker and press Delete or click the minus (-) 
icon at the bottom left.

Creating Transitions
Transitions are applied to a clip to create a smooth progression into, out of, and 
between clips. Transitions can only be added to clips in the same track.

The default duration of a transition is one second. You can expand or contract the 
duration by moving the thin vertical line separating the transition from the main part of 
the clip. You may need to zoom in on the timeline to make it easier. As you adjust its 
duration, the time value displays in real time.

Note: You can also change the default duration of transitions in the ScreenFlow > 
Preferences >Timeline pane (Timeline Pane).

• Adding Transitions

• Configuring Video Transitions

• Configuring Audio Transitions

Adding Transitions
To add a transition, select a clip and choose from the following:

• Select Edit > Add Starting Transition to add a transition to the front of the clip

• Select Edit > Add Ending Transition to add a transition to the end of the clip

• Select Edit > Add Starting & Ending Transition to add a transition to both ends

• These commands are also displayed on the clip’s context menu (which displays 
when you control (right)-click the clip).

You can also create transitions between two clips by dragging one clip over an adjacent 
clip. The section where the two clips overlap is the transition.

Configuring Video Transitions
To configure a transition, double-click the Transition icon in the clip (Figure 29).

Figure 29. Transition Icon in Timeline Window

Transition icon.
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ScreenFlow displays the Transitions Inspector (Figure 30). 

Figure 30. Transitions Inspector Window

Click a transition icon to choose one of the transition types. (A notice will display for 
transitions that are not configurable). Click on a transition icon to see a demonstration 
of the transition action. (The transition keeps performing until your move the mouse 
off the icon.) Configure the transition properties (width, height, color, angle, opacity, 
etc.) using the controls displayed on the right side of the Transition Inspector window. 

Click the Preview button to preview the transition in your clip on the canvas. You can 
also set the transition duration value in seconds in the duration field at the bottom of 
the Transition Inspector window.

Show the Transition Groups area by clicking the arrow in the bottom left corner of the 
window.(click it again to hide them). Click All to display all available transitions.

When you hover over a transition a star appears. Click that star to add the transition to 
the list of favorites. To remove a transition from your list of favorites, click the star again. 
Click Favorites to display a list of your most used transitions. 

Click Built-in OS X to display transitions that are built into the operating system.

Purchasing Transition Packs
Additional transition packs can be purchased by clicking the Buy More button which 
takes you to the Telestream online store. (You can also get to the Telestream store by 
selecting ScreenFlow > Store.) 

Favorites 

Buy More button
Transition groups button

Preview button

Transition ControlsTransition icons

Duration field
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Figure 31. Telestream Store Access

Once in the Telestream Online Store, the transition packs are available for purchase. 
Select the transition packs you want and completed your order. You will be given a link 
to download the transition pack installer. This link is provided in the store and in an 
email sent to you. You will also be given a license key.

Figure 32. Transition Pack Purchase Email

Click Store Click Buy More

Installer link

License key
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Click the installer link to download the installer.

Figure 33. Transition Pack Installer Download

Open the downloaded zip file and run the installer. The installer is a custom application 
that walks you through installation and license activation of your purchased transition 
pack. Click Continue when the Welcome screen displays.

Figure 34. Installer Welcome Screen

Click to 
download 
installer

Click Continue
ScreenFlow User Guide



Editing ScreenFlow Projects
Editing your Project on the Timeline

67
Enter your Mac Name and Password, then click Install Helper.

Figure 35. Password Screen

 To complete the installation, enter the license key you received via email and click 
Continue. The license key will be validated.

Figure 36. License Key Validation

Enter Name and Password

Click Install Helper

Enter License Key

Click Continue
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Click Finish to complete the installation.

Figure 37. Successful Installation

Once the license key has been successfully activated, the installer updates the /Library/
Application Support/Telestream/Transitions.plist file. When ScreenFlow detects this key 
file, it will enable the new transition pack. To verify that your transition pack has been 
installed and activated, select ScreenFlow > About ScreenFlow and observe the 
verification message displayed.

Figure 38. Transition Pack Verification Message

Once the transition pack is installed, ScreenFlow will validate the transition pack license 
key every time the application is opened. 

Note: The MAS version will not perform this validation because it does not use the 
same licensing verification functionality. However, transition packs purchased for the 
Mac App Store version of ScreenFlow will work.

 Contents of transition pack Wipe Pack 1:

• Bands Radial Wipe

• Boxes Wipe

Click Quit

Verification message
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• Circle Wipe 

• Clock Wipe 

• Color Drop Wipe

• Cross Blur Wipe

• Cross Hair Wipe

• Doors Wipe

• Flip Over Wipe

• Grid Wipe

• Grid Zoom Wipe

• Jaws Wipe 

• Lava Wipe

• RGB Split

• Radial Wipe

• Slat Wipe 

• Square Reveal Wipe

• Vacuum Wipe

• Wave Wipe 

• Windshield Wipe 

Configuring Audio Transitions
Audio transitions are applied to audio clips in the same manner as video transitions. 
However, since there is no visual media in an audio clip, there is one transition—a 
volume transition, which is automatically applied. 

Audio transitions have no user-settable properties. Starting and ending audio 
transitions fade in and fade out. Overlapping transitions fade from one clip to the 
succeeding clip simultaneously.

Using Actions
Actions are property changes used to transition the media from one state to another. 
ScreenFlow provides the following types of actions:

• Video

• Audio

• Screen Recording

• Callout.

Certain actions only can be added to specific types of clips. For example, screen 
recording actions can only be added to screen recording clips.
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When you add an action to a clip, it displays as a bright yellow rectangle.

Sometimes, you may want to set a pair of actions—one at the beginning and one at the 
end of a clip. You can also set any number of actions in between.

 Adding an Action

 Configuring Actions

Adding an Action
To add an action, select the clip and set the scrubber to the time you want the action to 
start (Figure 39). 

Then, choose from these options:

• Display the property pane (top-right) of the type that you want to add, then click 
the Add Action button at the bottom of the property pane. 

• Select Actions > Add Video Action | Add Audio Action | Add Screen Recording 
Action | Add Callout

The action is placed in relation to the position of the scrubber, but can be moved to any 
location on the clip. 

Figure 39. Video Properties Action

The duration of the action is changed by dragging the edge of the action to lengthen 
or shorten it.

Configuring Actions
Place the scrubber at the start or end of the action to make changes to the property 
relative to the action. If the scrubber is placed at the start of the action, this sets the 
properties of the clip before the action. If the scrubber is placed at the end the action, 
this sets the properties of the clip after the action.

For details on configuring actions, see the following topics:

 Configuring Video Properties

 Configuring Audio Properties

 Configuring Screen Recording Properties

 Configuring Callout Properties

Using Nested Clips
At some point in the editing process, you may find that your project—after adding 
more and more clips—is becoming unmanageable. The solution: create nested clips.
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Figure 40. Screencast with Nested Clips

You can select multiple, related clips and merge them into a single, nested clip—this 
reduces the visual complexity of the high-level timeline by displaying a single nested 
clip—which may represent dozens of clips gathered inside it. 

Each nested clip can be expanded and displayed on its own tab (Figure 40), so that you 
can edit it on its own independent view of the timeline. Nested clips also make it easy 
to re-use complex sequences in other places or other projects. But more importantly, 
you can edit a whole group of clips by placing edits on the nest, which affect all of the 
clips inside the nest. 

 Creating Nested Clips

 Viewing and Editing Nested Clips

Creating Nested Clips
To nest a set of clips, select the clips you want in the set and choose:

• Select Edit > Nest Clips. 

• Click the gear icon  on one of the clips and select Nest Clips (Alt-Control-N).

• Control (right)-click one of the clips and select Nest Clips (Alt-Command-N).

ScreenFlow replaces the set of nested clips with a single clip the length of the now-
nested clips on the timeline.

To un-nest a clip, select it and select Edit > Unnest Clips.

You can also nest clips recursively. That is, you can create a nest of clips, then open that 
nested clip and select some clips inside it and nest them, and so on. You can also go the 
other direction and nest two nests together, or create a nest from a nest and a clip. 
Although the depth of nesting is limited to ten, two or three levels is usually sufficient.
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Viewing and Editing Nested Clips
To display the clips inside of a nested clip, double-click the nested clip in the high-level 
timeline (or in the Default tab when tabs are displayed). 

To display the tab bar, select View > Show Tab Bar. (Uncheck it to hide it again). The tab 
bar displays the default tab at the far left. The default tab displays the entire view of the 
timeline, including nested clips in relation to all other clips.

Additional tabs display the name of each nested clip in the default tab. To change it, 
double-click on the name in the clip and rename it. The name on the tab automatically 
updates when you change the master clip’s name.

To display the clips inside a given nested clip, select the tab for that clip. ScreenFlow 
hides the default tab contents, and uses the entire window to display all of the clips 
that comprise the nested clip. ScreenFlow opens the nested clip and displays all of its 
contents on the timeline.

To view the big picture of your timeline, you can click the default tab at any time.

Nesting also provides another benefit: You can apply video filters and actions such as  
color correction or effect filtering to a nested clip. These changes apply to all clips 
inside the nested clip.

You can organize tabs to suit the needs of your project. To move a tab around, click and 
drag it to its new location. For example, you might want clip tabs to be displayed 
ordinally, just as the clips are arranged on the timeline. Or, you may want them 
displayed alphabetically.

When you delete a nested clip, all clips inside are deleted, and its tab is automatically 
removed from the timeline as well.

Creating Closed Captions
You can use ScreenFlow's caption editor to add, edit, and publish ADA-compliant soft 
subtitles as caption tracks to a project (Figure 41). Closed captions are not included by 
default when you create a new project—you need to enable them if you need them.

You can include captions in the screencast when you export the project as an MPEG-4 
movie (suitable for playback in iPhone & iPad, for example) and when you publish 
YouTube videos. Caption tracks can be created in multiple languages. You can also 
export captions as an SRT subtitle file.

Note: To view closed captions in a movie player, you must enable closed caption 
viewing. Enabling closed caption viewing in players is beyond the scope of this guide.
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Figure 41. Screencast with Closed Captions

Closed caption text is rendered on-screen in white, sans-serif type, centered at the 
bottom of the screen.

 Displaying and Previewing Closed Captions

 Adjusting Video to Accommodate Caption Text

 Adding and Configuring Closed Captions

 Generating Closed Captions

 Exporting Closed Captions as SRT Subtitles

Displaying and Previewing Closed Captions
To display closed captions on the canvas, select View > Show Captions. As you scrub or 
preview the project, closed captions display on the canvas along with all other visual 
elements in the project.

Adjusting Video to Accommodate Caption Text
To provide a suitable background on which to display caption text clearly, use black or 
another dark background color, and consider using one of these techniques:

• Shorten the computer video frame upward (Figure 42) to create an empty rectan-
gle at the bottom. (This creates a minor distortion in the image.) 

Captions are rendered on the 
frame from the text you enter 
in caption clips.
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Figure 42. Shortening Video Frame Up for Captions

• Crop the computer video frame upward (Figure 43)—preserving the application 
window, but hiding the dock bar at the bottom. (This doesn’t distort the image.)

Figure 43. Cropping Video Frame for Captions

• Reduce the frame proportionally (Figure 44), positioning it at the top center of the 
canvas to achieve the same goal. Leave the canvas as-is—with pillars on each side 
of the frame—or shorten the canvas horizontally to eliminate the pillars (remem-
bering that this adjusts the frame size of your video).

Shorten video frame 
upward to create space for 
closed caption text.

Crop bottom of video 
frame to create space for 
closed caption text.
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Figure 44. Shrinking Video Frame for Captions

Adding and Configuring Closed Captions
To add and configure closed captions, first select View > Show Captions Track 
(Figure 45). ScreenFlow displays the caption track at the top of the timeline. Each clip 
on the timeline with an audio track displays a corresponding caption clip. Only one 
caption track can be shown at a time. 

Figure 45. Using the Caption Editor on the Canvas Pane

If there is more than one audio clip in the project at the same time (for example, a 
voice-over and a music bed), the audio clip on top (highest layer on the timeline) has 
it's caption track displayed.

Reduce video frame to 
create space for closed 
caption text.

Leave pillars or reduce 
canvas size horizontally to 
remove them.

Closed caption editor pane

Caption playback controls:
     Previous Box | Play Clip | Next Box

Caption text field

Caption track

Caption boxes in a caption clip

Audio clip that corresponds to the caption clips above.
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Caption clips are permanently joined to their parent clip, and are always the same time 
length. They can not be moved independently. When you move (or duplicate or delete) 
the clip that ScreenFlow created the caption clip for, the caption clip moves along the 
timeline with it.

Caption clips are comprised of one or more caption boxes—which contain the text to 
display—in 3 second increments, which you can adjust. The number of boxes depends 
on the total length of the clip. You click each caption box independently to add text.

To add text to a clip’s caption box (or to edit it), click the target box. ScreenFlow displays 
the caption editor, where you can enter text and test it for appropriate time length, 
adjusting the length as necessary. You can add carriage returns to closed captions to 
display closed caption text on multiple lines.

To change the caption’s language, control-click on the caption box and select Set 
Language, or Edit>Captions>Set Language. Select the language you want to display 
captions in.

To move between caption boxes, use the left and right arrows in the caption playback 
controls. Or, press the tab key to advance to the next box and use Shift-tab to go to the 
previous box. The scrubber automatically jumps to the beginning of the next (or 
previous) box, and displays that box’s text, so you can add or edit it.

To lengthen the display time of a caption box, press Command-up arrow. To reduce the 
display time, press Command-down arrow. You an also change the time in the caption 
editor.

To delete all of the text in all captions, control-click and select Clear All Captions, or Edit 
> Captions > Clear All Captions.

Generating Closed Captions
You can generate closed captions when exporting or publishing in these formats:

• Export the project as an MP4 (H.264 video) file. Select the Web-High or Web-Low 
preset or any Apple device preset, or a customized derivative. You’ll need to check 
Add Captions Track on the export window. For details, see Exporting Your Video.

• Publish the project to YouTube. You’ll need to check Add Captions Track on the 
export window. For details, see Publishing to YouTube.

Exporting Closed Captions as SRT Subtitles
To export your closed captions and save them in an SRT subtitle file, control-click on the 
timeline and select Export to SRT or Edit > Captions > Export to SRT. ScreenFlow displays a 
Save As dialog, where you can name the file, select a location, and save the file.
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Configuring Video Properties
You can configure video properties to make visual changes to screen recordings, 
camera-based video, and other imported video clips, as well as image clips in a project.

You can also add video actions (transitional properties—those which change over 
time) to a clip and apply video properties only to the action. Actions display as yellow 
rectangles inside the clip—they are time-limited sections of a clip which enable you to 
apply properties to that time-bound section of the clip. Video actions can be added to 
both the start and end of a clip to create a transition. For details, see Using Actions.

Select a video, screen recording, or image clip, or place the scrubber at the start or end 
of a video action in a clip before applying properties. To display the Screen Recording 
Properties pane, click the Screen Recording Properties icon, as shown in Figure 46.

Figure 46. Video Properties
Click to display the Video Properties tab.

Click to add a video action.

Gear icon.
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To reset all properties in the selected clip to default values, click the gear icon  at the 
top-right corner of the panel and select Reset to Defaults.

Video properties are described in Table 5.
Table 5. Video Properties Pane

Control Description

Scale Use the slider or enter a value (0-400%) to change the scale of 
your image. This is useful for highlighting a particular portion 
of the screen, or in a video action to create a zoom effect. 

Position Enter X and Y coordinates to specify the location (in pixels) of 
your video or image on the canvas, based on the center of the 
image. You can also reposition the image by dragging the 
image on the canvas, or nudging the selected image with the 
arrow keys.

X/Y/Z Rotation Use the rotation options to rotate (in degrees: -180 to180) the 
image in a virtual, three-dimensional space. X rotates the 
image along a horizontal axis. Y rotates the image along a 
vertical axis. Z spins the image along a depth axis. Or, use the 
thumb wheels to rotate the image in real time.

Opacity Use the slider to set the opacity value or enter it manually (0 
to 100%). The greater the value, the more opaque the image. 
When set to zero, the image is transparent—invisible. This can 
be used with a video action to fade an image in or out, or if 
you have a video voice-over, and would like to periodically 
display your entire camera recording frame.

Cropping Click the disclosure triangle down to display cropping 
options. Set the crop margins (by pixel) for left, right, bottom, 
and top. 

Reflection Check to implement reflection. Use the slider to set the value 
or enter it manually (0 to 100%).

Reflection creates a mirror image of the selected clip below 
the clip itself. The greater the value, the more opaque the 
reflection. When set to zero, the reflection is invisible. 

Shadow Check to create a shadow effect behind a still image. If the 
image uses a transparency, the shadow only reflects the non-
transparent part of your image.

Use the thumb wheel (or enter the value manually) to set the 
angle of the shadow relative to the image in degrees (-180 to 
80 degrees). The default is -45 degrees.

When checked, configure these options:
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Configuring Audio Properties
Display the Audio properties tab to modify the selected audio clips in your timeline. 
You can apply audio properties to any clip which contains audio, including clips with 
both video and audio.

You can also add audio actions (transitional properties—those which change over 
time) to a clip and apply properties to them. Audio actions can be added to both the 
start and end of a clip to create a transition. For details, see Using Actions.

Color Click the color field to select the shadow color from the color 
picker. Default: black.

Offset Use the slider to set the value (in pixels) or enter it manually (0 
to 150 pixels) to specify the distance between the shadow 
and the clip. Default: 40.

Opacity Use the arrows to set the value or enter it manually (0 to 
100%). The greater the value, the more opaque the shadow. If 
the value is set to zero, the shadow is invisible. Default: 75%. 

Blur Size Use the arrows to set the value or enter it manually. Blur is a 
gradual loss in opacity as the shadow spreads from the center. 
Default: 4. Range: 0 to 100 pixels.

Color Controls Click the disclosure triangle down to display color options. 

Saturation Use the slider to set the value or enter it manually (0 to 400%). 
Saturation is the intensity of a color relative to its brightness, 
represented as a percentage. Default: 100%. 

Brightness Use the slider to set the value or enter it manually (0 to 400%). 
Brightness is the degree of luminosity present in the image, 
represented as a percentage. Default: 100%. 

Contrast Use the slider to set the value or enter it manually (0 to 400%). 
Contrast is the relative intensity of the black and white values 
in an image. A high contrast has a greater intensity of black 
and white values. This value is represented as a percentage. 
Default: 100%. 

Video Filters Click the disclosure triangle down to display the video filters.
Click the plus icon to add filters to the selected clip. For details 
see Using Audio and Video Filters.

Add Video Action Click to add a video action at the moment indicated by the 
scrubber in the selected clip. You can also click the gear icon 

 at the top-right of the panel and select Add Video Action.

Table 5. Video Properties Pane

Control Description
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Select a video clip with audio, audio clip, screen recording clip with audio, or place the 
scrubber at the start or end of an audio action in the clip before applying properties. To 
display the Audio Properties pane, click the Audio Properties icon, as shown in 
Figure 47.

Figure 47. Audio Properties

To reset all audio properties in the selected clip to default values, click the gear icon  
at the top-right corner of the pan and select Reset to Defaults.

Each clip with audio displays with a waveform. This waveform provides a visual 
representation which reflects volume changes. Figure 48 depicts an audio clip with an 
audio action set to increase volume. Notice how the waveform display is enlarged to 
the right, due to the added action (shown in purple).

Figure 48. Audio Clip in Timeline

Click to display the Audio Properties tab.

Click to add an audio action.

Gear icon
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Audio properties are described in Table 6.
Table 6. Audio Properties Controls

Control Description

Volume Use the slider or enter a percentage value (0 to 190%) to 
change the audio on a clip. This can be used with an action to 
gradually change the audio level as shown in the image 
above.

Ducking Check to apply audio ducking and automatically adjust 
volume levels on clips with audio on lower layers. When 
applied to a clip, all audio on lower level clips is decreased to 
draw attention to the audio in this clip. Use the slider (or 
manually enter a value) to specify the percent of reduction to 
apply. It is a reverse scale where, for example, 5% means that 
the clips below will allowed 5% of their volume (reduced by 
95%). Ducking must be applied to the main (or top) clip that 
you want to hear, and not the lower level clips where you 
want to the volume decreased. Ducking is particularly useful 
when using background music with narration.

Meter Depicts relative volume of each channel in the selected clip.

Mute Audio Check to mute the selected clip with audio.

Processing

Smooth Volume 
Levels

Select to normalize and smooth out volume peaks while 
increasing quieter clips so that the audio has a more 
consistent volume.

Mix Input to Mono  If you record one-channel audio, checking this box will make 
that one channel output to stereo.

Effect Check to apply the selected audio effect (from the Effect 
popup menu) to the audio clip. Use the slider or manually 
enter the percent of effect to apply.

Filter: Remove 
Background Noise

Check to reduce the audio volume of incidental background 
noise, which typically results in a clearer audio track. Use the 
slider or manually enter the percent of sensitivity to apply.

Audio Filters Click the disclosure triangle down to display the audio filters.
Click the plus icon to add filters to the selected clip. For details 
see Using Audio and Video Filters.

Add Audio Action 
Button

Click to add an audio action at the moment indicated by the 
scrubber in the selected clip. You can also click the gear icon 

 at the top-right of the panel and select Add Audio Action. 
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Configuring Screen Recording Properties
A screen recording (sometimes called a screencast, ScreenFlow clip or screen capture)—
as compared to a video clip or video file—is a proprietary format video clip that has 
been recorded directly in ScreenFlow, and is saved with a .scc extension. Screencast 
files can not be opened by other applications. Because screencast files are 
automatically and transparently managed by ScreenFlow, you rarely ever encounter 
them or have to deal with them.

Screen recording properties can only be applied to screen recording clips. If you try to 
apply properties to recording actions, they will be applied to the whole clip. Screen 
recording properties cannot be applied to clips recorded by other applications.

Select a screen recording or select the start or end of a screen recording action in the 
clip before applying properties. 

When you add a screen recording action, it displays in yellow.

To display the Screen Recording Properties pane, click the Screen Recording Properties 
icon, as shown in Figure 49.

Figure 49. Screen Recording Properties

To reset all properties in the selected clip to default values, click the gear icon  at the 
top-right corner of the pan and select Reset to Defaults.

Click to display the Screen Recording Properties tab.

Click to add a screen 
recording action.

Gear icon
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Video properties are described in Table 7.
Table 7. Screen Recording Properties Controls

Control Description

Show Mouse Pointer Displays the mouse as it moves on the display.

Pointer Zoom When Show Mouse Pointer is checked, use the slider to 
specify the size of the mouse icon in the screen recording.

Use the slider or manually enter the value to specify the 
percent of increase to apply.

Often it can be difficult to distinguish or track the mouse in a 
screencast, particularly if the video has been significantly 
resized. Increasing the pointer zoom value increases the size 
of the mouse icon, making it easier to follow.

Click Effect Select None | Radar | Invert from the popup menu to create a 
visual effect when you click the mouse. Radar displays an 
animated red circle with each click. Invert changes the cursor 
from black to white and back with each click.

Pointer Select Default | Circle - Light | Circle - Dark | Square | Choose 
Image from the popup menu to change the pointer image.

The Circle - Dark option is particularly good for iOS 
screencasts.

When you select Choose Image, ScreenFlow displays an Open 
dialog, so you can navigate and select an image file. When 
selecting a custom image, you also specify the cursor hotspot 
position.

Opacity Specifies the degree of pointer translucency.

Use the slider to set the value or enter it manually (0 to 100%).

The greater the value, the more opaque the pointer. If the 
value is set to zero, the pointer is invisible. Default: 100%.

This can be used in a screen recording action to fade the 
pointer in or out.

Sound on Click Check to generate a sound when the mouse button is 
pressed.

Click the disclosure triangle to display Sound on Click details. 

Volume Specify the volume level of the mouse click sound (from 0 to 
5,000%). Use the arrows to set the value or enter it manually.

Click Sound Click Choose to display an Open dialog, and navigate to and 
select any custom sound file, to play a unique sound file every 
time the mouse is clicked.
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Configuring Callout Properties
Callouts are transitional properties—those which change over time—and are used to 
highlight a specific portion of the screen. Mouse cursor and foreground windows 
callouts can only be added to screen recording clips. Freehand callouts can be added to 
video clips, image clips, and screen recording clips.

Callout properties cannot be applied at a clip level, only to a specific callout within a 
clip.

Note: You must add and/or select a callout before configuring its settings.

To display the Callout Properties pane, click the Callout Properties icon in the Properties 
pane, as shown in Figure 50 below.

Show Keystrokes Check to display the characters (one at a time) of keyboard 
characters typed during the recording.

Show All Keys Check to display all keystrokes typed during the recording, 
including the modifier keys.

Show Only Modifier 
Keys

Check to display modifiers used in hotkey commands, 
function keys, and the arrow keys that were pressed during 
the recording.

Height and Position Specify the height and position of the font.

Font Button Click to display the font settings and specify all font 
information for the characters shown in the keyboard 
characters display.

Add Screen 
Recording Action 
Button

Click to add a screen recording action at the moment 
indicated by the scrubber in the selected clip. You can also 
click the gear icon  at the top-right of the panel and select 
Add Screen Recording Action. 

Table 7. Screen Recording Properties Controls

Control Description
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Figure 50. Callout Properties

To reset all properties in the selected callout to default values, click the gear icon  at 
the top-right corner of the pan and select Reset to Defaults.

To use all properties (as currently specified) as default values for new callouts added to 
a clip, click the gear icon  and select Make Settings Default for new Callouts.

Callout properties are described in Table 8. 
Table 8. Callout Properties

Control Description

Highlight Select how to highlight an area of the recording: Mouse 
Cursor highlights a circular space around the mouse cursor. 
Foreground Window highlights the window which is in the 
screen recording. Mouse and foreground highlights can only 
be added to screen recording clips.

Freehand callouts can be added to video clips, image clips, 
and screen recording clips.

See Adding Freehand Callouts to Images.

Opacity Use the slider to control the percent of opacity of the space 
outside the callout. A value of 0 makes the surrounding area 
entirely visible; a 100% value makes the surrounding area 
invisible.

Blur Use the slider or manually enter the pixel value to blur the 
callout area (range: 0-16).

Click to display the Callout Properties tab.

Click to add a callout.

Gear icon
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Adding Freehand Callouts to Images
You can highlight freehand areas directly on images, using either a circular paint brush 
or a rectangle tool. You can use freehand callouts to blur out sensitive data or create a 
highlighted box around the content you are discussing, for example.

To create a freehand callout, follow these steps:

1. Set the location of the scrubber.

2. Select an image on your canvas.

3. Click the Callout Properties pane.

4. Click Add Callout—because you’re working on an image, Freehand is the only 
callout option. ScreenFlow displays the tool palette (Figure 51) in the upper right 
corner of the canvas.

Blur Background Check to blur the area outside of the callout.

Zoom Up Use the slider or manually enter the percentage value to 
magnify the area inside the callout (range: 0 to 500%).

Border Use the slider or manually enter the value to create a gradual 
loss in opacity as the shadow spreads from the center (range: 
0-300). This feature does not apply to freehand callouts. This 
is not a zoom control, but instead it adds more area to the 
callout.

Outline Enter the value (in pixels) to create an outline around the 
callout area (range: 0 to 59.) Click the color box to change the 
color of the outline.

Shadow Check to add a shadow behind the callout. Use the slider or 
manually enter the value to create a gradual change in size as 
the shadow spreads from the center (range: 0-80).

Feather Specify the blend value (in pixels) to apply to the callout 
border to create a smooth transition between the callout area 
and the surrounding space (range: 0-20).

Round Applies to foreground window callouts only. Specify the 
round-off value (in pixels) of the callout edge to create a more 
gentle appearance (range: 0-59).

Build Specify the transition time of the callout, in seconds, up to 2 
decimal places, and from 0 to 4 seconds. Duration In 
determines the amount of build-in time to reach the full 
effect of the callout. Duration Out determines the amount of 
build-out time to return to normal.

Table 8. Callout Properties

Control Description
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Figure 51. Freehand Callout Tool Palette

5. Select either the brush or the rectangle tool. If you select the brush, you can set the 
size of the brush.

6. Draw the highlighted region on your selected image.

7. Use the callout properties to adjust the look of your callout.

Figure 52 depicts an example of a callout blurring an application’s serial number.

Figure 52. Freehand Callout Tool Palette

Configuring Annotations Properties
Annotations are used for displaying simple shapes in your project. Annotations are clips 
you can add to your timeline, and behave like image clips. You can apply several video 
properties (scaling, position, x/y/z rotation, and opacity) and video actions to 
annotations clips.

To display the Annotations Properties pane, click the Annotations Properties icon in the 
Properties pane, as shown in Figure 53 below.

Figure 53. Annotations Properties
Click to display the Annotations Properties tab.

Tool palette

Click to add an 
annotations clip.

Gear icon
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Adding an Annotation Clip
To add an annotation clip, set the scrubber in the location where you want the clip to 
start, and click Add Annotations or click the gear icon  and select Add Annotations 
Clip or select Insert > Annotations Clip. ScreenFlow adds a 5 second annotation clip in a 
new, top track (which you can move anywhere on the timeline you want).

When you create an annotation clip, you must immediately add at least one object to 
the clip, or ScreenFlow will automatically delete it. As a matter of fact, if you later 
remove all annotations, ScreenFlow deletes the annotation clip automatically.

Figure 54 depicts a sample callout on the canvas (left), and its corresponding clip on 
the timeline (on the right).

Figure 54. Sample Annotations Clip on Canvas (left) and Timeline (right)

Adding and Configuring Annotation Items
To add annotation items to an annotation clip, select it. Then, select the item from the 
tool palette and begin drawing in the video frame rectangle on the canvas. While 
selected, you can adjust the item’s properties as described below in Table 9. 

Note: Notice that as you are drawing, the timeline loses focus and darkens. Drawing is 
a modal operation: When you’re done drawing and configuring objects, you must click 
on the timeline to continue working on the canvas or timeline. 
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To save these settings for new annotations clips you may add in the future, click the 
gear icon  and select Make Settings Default. 

Configuring Text Properties
Text boxes are clips which display blocks of text in your project. Text clips behave like 
image clips—they are static images which display for the length of time you specify. 
You can also apply video properties and transitions to text clips.

To display the Text Properties pane, click the Text Properties icon in the Properties pane, 
as shown in Figure 55 below.

Table 9. Annotations Properties Controls

Control Description

Shapes Choose from the types of annotations in the tool bar: 

• Line (arrow)

• Line

• Square (filled)

• Square

• Circle

Color Click to select the color of the annotation.

Opacity Use the slider (or enter the percentage value manually) to set 
the opacity of the selected object.

Thickness Use the slider or manually enter the value to specify the 
thickness (in pixels) of annotation lines (range: 2 to 350). 
Default: 55.

Shadow Check to create a shadow on objects in the annotation. Use 
the slider or manually enter the value (in pixels) to specify the 
opacity of the shadow (range: 1 to 60). Default: 25. The value 
creates a gradual loss in opacity as the shadow spreads from 
the center.

Outline Check to create an outline around objects in the annotation. 
Use the slider to specify the thickness of the outline.

Color Click to select the color of the outline.

Endpoints Select a shape to affix to the end of a line segment. The first 
and second field represent the starting and finishing point of 
the line segment, respectively.
ScreenFlow User Guide



Editing ScreenFlow Projects
Configuring Text Properties

90
Figure 55. Text Properties

 Adding and Configuring a Text Clip

 Using Dictation to Add Text

Adding and Configuring a Text Clip
To add a text clip, set the scrubber in the location where you want the clip to start, and 
click Add Text Box or click the gear icon  on the Text Properties pane and select Add 
Text Box or Insert > Add Text Box. ScreenFlow adds a 5 second text clip in a new, top track 
(which you can move anywhere on the timeline you want).

Note: Go to ScreenFlow > Preferences > Timeline to change the default duration of 
your Text clip.

When you create a text clip, it has the default word Text in it. Select the text to edit it. 
You must have at least one character in the clip, or ScreenFlow automatically deletes it. 
As a matter of fact, if you later remove all text, ScreenFlow deletes the clip 
automatically.

Note: If you’re running on Mac OS Mountain Lion (v10.8), you can also use dictation. 
See Using Dictation to Add Text. However, ScreenFlow 4.5 only requires Lion 10.7 or 
greater.

Figure 56 depicts a sample text clip on the canvas (left), and its corresponding clip on 
the timeline (on the right).

Click to display the Text Properties tab.

Click to add a text clip.

Gear icon
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Figure 56. Sample Text Clip on Canvas (left) and Timeline (right)

While the text is selected, you can adjust the text properties as described below in 
Table 10.

Click the gear icon  and select Reset to Defaults to reset all properties in this pane to 
default values. When you select Reset to Defaults, the settings applied by this 
command are the settings in place when Make Settings Default for New Text Clips was 
executed.

To save these settings for new text clips you may add in the future, click the gear icon 
 and select Make Settings Default. 

Table 10. Text Properties Controls

Menu Item Description

Font Select this menu to choose a font face from the list of fonts 
provided by your system. The font is applied to the entire text 
box (if none or all text is selected) or a range of selected 
characters.

Size Select this menu to choose the size of your text in pixels 
(range: 9 to 288). The size is applied to the entire text box (if 
none or all text is selected) or a range of selected characters. 
Select Font > Show Fonts to enter a custom size.

Alignment Select paragraph alignment: Align Left | Align Right | Center. 
This property affects the selected paragraph, if more than 
one.

Fill Check to choose Solid Color | Image | Gradient from the 
popup menu. For solid color, select a color from the color 
wheel. The color is applied to the entire text box (if none or all 
text is selected) or a range of selected characters. For Image, 
ScreenFlow displays an Open dialog, so you can navigate to 
and select any custom image file. Deselect the checkbox to 
remove the file. This can be used with Outline to create 
characters which are transparent. Applying an image uses the 
color patterns represented in the image to fill the text. These 
properties are applied to the entire text box (if none or all text 
is selected) or a range of selected characters.

Color The Fill color field allows you to choose the color used in your 
text. For gradient, click in the top half and select a color, then 
click in the bottom half and select the second color.
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Using Dictation to Add Text
As an alternative to typing in text, you can dictate it (Mac OS Mountain Lion 10.8 only).

To use dictation, follow these steps:

1. Add a text box to your project.

2. Delete the text from the box, leaving the cursor in place in the empty box.

3. Select Edit > Start Dictation (or press the function key twice in rapid succession).

4. Mac OS X displays the microphone—after the bing, start talking into your 
microphone (Do not click the done button).

5. When done talking, click the Done button

Mac OS X converts the speech to text and ScreenFlow inserts it into the text box.

Outline Check to outline the text.The outline is applied to the entire 
text box (if none or all text is selected) or a range of selected 
characters. Use the slider to set the width of the outline (in 
pixels) range: 0 to 15.

Color Click to select the color of the outline. Select the color, 
brightness, and opacity. Brightness is only available on the 
Color Sliders pane of the Show Colors tool.

Backdrop Check to add a background and choose Solid Color | Image 
Fill.

Color For Solid Color only, click to select the color of the backdrop. 
Specify the color, brightness, and opacity. Brightness is only 
available on the Color Sliders pane of the Show Colors tool.

Round Use the arrows or manually specify the value in pixels to 
smooth the edge of the text box (range: 0 to 100). Default: 20.

Image For Image Fill only, click Choose display an Open dialog and 
select an image to insert into the background. Use the popup 
menu below Image Fill to choose how the image fills the 
background space: Scale To Fit | Scale To Fill | Tile | Original 
Size | Stretch.

Margin Use the slider or manually enter the size (in pixels) of the 
backdrop (range: 0 to 300). Default: 25.

Table 10. Text Properties Controls

Menu Item Description
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Using Audio and Video Filters
ScreenFlow provides a vast array of audio and video filters to add effects to videos, 
audio tracks, and images. Audio effects include EQ, multiband compression, peak 
limiting, delay and many more. Video effects include advanced color adjustments, 
distortion effects, blurring, color effects, alpha mask, and many more as well. Multiple 
filters can be applied to a single clip. Filters can also be applied to nested clips.

Note: You can also purchase 3rd party Core Audio or Video filters and install them for 
use in ScreenFlow.

Each filter has parameters that can be configured and adjusted for optional features 
and fine-tuning its effects.

 Adding a Filter

 Removing a Filter

 Re-ordering Filters

 Configuring a Filter

Adding a Filter
To add a filter to a clip (or clips), follow these steps:

1. Select the clip that you want to add the filter to.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video or Audio Filters plus (+) icon to display the filter list (Figure 57).

Figure 57. Adding a Filter to a Clip

Click the plus icon to 
display the list of filters. 

Scroll through the filter list, 
opening categories as 
appropriate. Select the 
filter you want to add and 
click Add. 

Enter filter name to search 
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4. Scroll through the list of filters, opening and closing filter groups as appropriate. Or, 
you may search for a filter by entering a filter name into the Search box and 
pressing the Enter key.

5. Click Add to add it to the filter list for the selected clip.

Note: If a manufacturer's Audio Unit plug-in does not work in a sandboxed 
environment, it will not work in the Mac App Store version of ScreenFlow.

Removing a Filter
To remove a filter that has been added to a clip, follow these steps:

1. Select the clip that you want to remove the filter from.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters Figure 58.

Figure 58. Deleting a Filter from a Clip

4. Scroll through the filters until you find the one you want to delete. 

5. Click the X icon to delete it from the clip.

Note: You can disable a filter temporarily, by unchecking its name.

Re-ordering Filters
The application of a filter has different effects, depending on where it is stacked with 
the other filters, if present. Filters are applied based on their order in the list, from top to 
bottom. 

To layer (or order) filters in the order you want them applied, follow these steps:

1. Select the clip that has the filters you want to re-order.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters Figure 59.

Click the X icon to 
delete the filter. 
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Figure 59. Re-ordering the Filter List

4. Scroll through the filters to identify the one you want to re-arrange.

5. Click on the grab icon just to the left of the checkbox by its name.

6. Drag the filter up or down the list to re-order its application in relation to other 
filters in the list.

Configuring a Filter
Video filters that have a visual position coordinate display a cross-hairs button, which 
allows you to adjust the position on the canvas. The label of the parameter you are 
editing also appears on the canvas when adjusting the position.

When multiple clips are selected, ScreenFlow attempts to display the list of filters in the 
Video Properties pane where the filters have similar settings. For example, if two clips 
have two identical filters in the same order, ScreenFlow will display the two filters 
regardless of whether any of the individual parameters are the same. However, if the 
two clips have the same filters but in different order, ScreenFlow displays a Multiple 
Filters message.

Filter processing is CPU-intensive. Depending on the number of filters enabled, expect 
export and publishing times to increase.

After you configure a filter, you can test it out by playing the video.

To configure a filter, follow these steps:

1. Select the clip that has the filter you want to configure.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters (Figure 60).

Click the grab icon to drag the 
filter up or down the list.
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Figure 60. Sample Filter

4. Scroll through the filters to locate the one you want to configure.

5. Adjust the controls as necessary.

Using the Chroma Key Filter
The Chroma Key filter creates transparency in the selected clip, using a unique color. In 
effect, this creates a keyhole in the clip, by converting all pixels in each frame that are 
similar to the chroma color, so that they are transparent. This permits the pixels in the 
same location in the clip (in layers below) or background behind to display through. 
This is the effect used to depict the classic weatherman standing in front of a weather 
map. The weatherman actually stands in front of a green (or blue) screen, and his image 
is then chroma-keyed onto the weather map to complete the illusion.

In the progressive sequence portrayed in images (below, in Figure 61), an announcer is 
filmed in front of a green screen. The clip (the first image on the left) is added to the 
project, and the Chroma Key filter is added and adjusted to make the background 
pixels transparent, permitting the black background to show through (second image). 
In the final step, a still image clip (third image) is added to the track below the 
announcer clip, which depicts the announcer—in the far right image—as standing in 
the meadow in front of the mountain.

Figure 61. Typical Chroma Key Filter Application

A chromatic background is a background with color in it. Black and white are not colors 
in this sense. Green and blue are the best colors to use, but the Chroma Key filter also 
works with orange or red or purple, just not as well. 

Effective use of a chroma key requires video where the background is a bright, evenly-
lit uniform (or nearly so) color. The persons or objects you place in front of the backdrop 

Original clip Green color keyed out Background - 2nd track Final composite clip
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shouldn’t match the color in the backdrop (unless they have regions that you also want 
to make transparent).

An important aspect of implementing an effective chroma key is to ensure you have a 
uniform chroma key source (green screen). And the best way to do this is to provide an 
even, well-lit chroma background. The better the input, the better the output.

 Implementing a Chroma Keyed Clip

 Applying the Chroma Key Filter

 Refining the Chroma Key Filter Settings

Implementing a Chroma Keyed Clip
To chroma key a clip, do the following:

1. Shoot your target clip (of persons or objects) against a green screen—a well lit, 
even blue or green surface, for example. This color should not be in the foreground 
object (a person’s tie, for example, shouldn’t be green when using a green screen).

2. Shoot your background image or clip.

3. Add the target clip to your project.

4. Select a background color on the canvas for chroma key testing.

5. Add the Chroma Key filter and set it up. See Applying the Chroma Key Filter.

6. Test your clip by previewing it, and adjust chroma key settings as necessary. See 
Refining the Chroma Key Filter Settings

7. If necessary, split your clips, add the chroma key filter and adjust it.

8. When you’re satisfied with the chroma key, add your background image or clip to 
the project in the track immediately below the target clip.

Applying the Chroma Key Filter
You can apply the Chroma Key filter (Figure 62) to any clip shot against a green screen—
for the purpose of replacing the transparent regions with another image or 
background. 

Figure 62. Chroma Key Filter Settings Editor

You can also apply the filter to clips shot against other uniform-colored backgrounds 
such as a sky, or a wall, although your results may vary, based on the uniformity and 
contrast with the foreground objects. (For details on adding filters, see Using Audio and 
Video Filters).
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Adjust the Chroma Key settings as needed. For details, see Selecting a Chroma Key Color.

Selecting a Chroma Key Color
It is important to choose the correct color for the chroma key. The color should match 
or closely match the background. The color displayed in the box is selected 
automatically by analyzing the current frame. Sometimes this is not the best color.

An effective method for chroma key color selection is to select the correct color by 
clicking in the original image where a cross-hair appears (to select a specific color/
pixel), then use the Refine Key image to further refine the key as required. It's often best 
to click next to the edge of an object that is not going to be removed. Usually, the color 
near the object is the most effective chroma key color.

To select a more effective color, click the Color button to open the Refine Key window in 
the upper right corner of the canvas pane, as shown here in Figure 63.

Figure 63. Refining the Chroma Key Color

Table 11. Chroma Key Filter Settings

Menu Item Description

Color Click to refine the key (to specify the color to be converted to 
transparency.

White Clip Use the slider to adjust the whiteness tolerance to reduce 
white pixel transparency. Adjust the gray scale value (0 to 
255) to the right, until the entire background is transparent.

In a source with lots of very bright white, the background may 
bleed through the white part of the image. To avoid this, 
adjust the White Clip value.

Tolerance Use the slider to specify how far from the chroma key color is 
considered background. Adjust to remove more or less of the 
background color without affecting the foreground image. 

Angle Use the slider to specify the angle around the chosen color. 

The amount of color varies, depending on how far from the 
center of the colorspace the selected color is. 
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When the Refine Key window is open you can click anywhere in the clip image on the 
canvas to select a new color to use. 

You can also click directly in the Refine Key window to adjust the selected color. The 
Refine Key color range displays the colors that are near (in value) to the currently 
selected color. (The Refine Key window does not display all colors in the image.)

Refining the Chroma Key Filter Settings
The most effective chroma key settings are found by an iterative process of adjusting all 
three parameters, viewing results over time, and adjusting them again, until you are 
satisfied with the overall performance. Here’s a suggested pattern of refinement.

Temporarily move your background or image clip out of the way, so that the canvas 
color can be used as a backdrop against your foreground image.

Next, adjust the White Key value by dragging the slider from left to right. As the opaque 
area reduces, pay close attention to the edges of the foreground image. If background 
starts showing through, creating a shadow effect from the black (or other) background, 
adjust the Tolerance level to the left to eliminate the shadows around the edge.

Then, return to the White Key parameter and completely eliminate the opaque areas so 
that the entire background is fully transparent.

Work back and forth between the White Key and Tolerance sliders (with a little fudge 
factor in each) to strike a perfect balance as you scrub your clip.

Finally, reduce the Angle slider value to zero, then move it to the right again until the 
background is completely transparent, then increase it a bit more for fudge factor.

Scrub the clip often, to make sure the chroma key works well across the entire clip.

Note: Sometimes a video will slightly vary color over time. Thus, you might need 
different keys. To add different chroma keys to a clip, you can split the source clip into 
several clips and then apply a slightly different key color to each one.

Using the Media Library
The media library is a directory of sorts, but it is not a file system folder. You use the 
media library to collect all your clips for a given project into a single collection, and to 
provide easy access directly in your project. Screen recording files are stored in a 
ScreenFlow-controlled location (the Media folder in the package contents of each 
ScreenFlow document). Other files you add (video and audio files and images) remain 
in the directory where you placed them, but are also auto-saved in the same location.

When you add (import) a file into ScreenFlow, ScreenFlow creates a media object for it, 
and displays its thumbnail image in the media library, which points to the original 
media file. When you adjust properties of a clip or image or add actions, these 
properties are stored with the media object—the original file is never altered. You can 
drag these media objects onto your canvas or timeline to add them to the project.
ScreenFlow User Guide



Editing ScreenFlow Projects
Using the Media Library

100
Note: In the Telestream Web Store version of ScreenFlow, you can edit media files and 
images outside of ScreenFlow and save them—ScreenFlow advises you and allows 
you to reload the updated file. ScreenFlow also adds a refresh icon to the media file in 
the Media Library, which you can select. This feature is not present in the Mac App 
Store version.

To display the media library (Figure 64), click the media library tab in the Properties 
pane.

Figure 64. Using the Media Library

You can view media with thumbnails, or you can view as a list of media. Click the 
thumbnail (or list) icon in the media library toolbar, as shown in the figure above. In 
thumbnail view, you can zoom in and out—and scroll the thumbnails (or list)—as 
necessary.

 Managing Media in your Media Library

 Adding Media to the Timeline

 Using the Media Library Context Menu

 Using the Media Library Controls

Managing Media in your Media Library
To add media to your media library, use one of these methods:

• Record media in ScreenFlow. When the recording is added to the canvas and time-
line of an open project window, it is also added to the project’s media library.

Click to search the media library.

Click to display as thumbnails or list.

Click to import media files.

Click to select sort/group media, and display duration.
Click to zoom in and out.

Click to record media.

Click to display media library.
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• Drag the media file from the Finder into the media library

• Drag the media file from the Finder onto the timeline. ScreenFlow automatically 
adds it to the media library.

• In the media library pane, click Add Media. ScreenFlow displays a File System dia-
log, where you can navigate and select the media to add to the media library.

Note: Videos, images, and audio files imported into the media library remain linked 
to their original source. If a source file is modified, ScreenFlow will advise you, and 
offer to reload the modified file. When ScreenFlow reloads a file, it automatically 
updates the library, timeline, and canvas. This makes it easy to edit your video, audio, 
and images—and automatically update them in your ScreenFlow projects.

To duplicate media to the file system, drag the media file out to your desktop, target 
folder or server. Mac OS X duplicates the source media file in the new location.

To delete media from your media library, select the media object and click Delete. If this 
media is referenced by a clip on the timeline, ScreenFlow displays a dialog alerting you 
that the clip or clips will be deleted as well. Click Delete to continue.

To rename media files in the library, highlight the media, then click on the name to edit 
it. This renames all clips on the timeline that reference this media, unless they have 
already been given a custom name (double-click the clip on the timeline to provide a 
custom name—this does not rename the referenced clip in the media library).

Using the Media Library Controls
Use the buttons and other controls at the bottom of the media library to perform the 
following tasks, as described in Table 12.
Table 12. Media Library Controls

Control Description

Zoom Use the slider to change the display size of the media 
thumbnails.

Display and Arrange 
Options menu

Click  to choose the following options:

Show Duration 
Overlays

When checked, displays a time button on each thumbnail in 
thumbnail view, indicating the clip length.

Arrange By Select sort option: Name | Added When | Duration | Type.

Group By Select grouping option: None | Type.
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Adding Media to the Timeline
To add media to your timeline once it’s in the media library, either drag it to the canvas 
or the timeline which will place it wherever the scrubber is on the timeline. You can also 
double click on the media object to add to the timeline at the scrubber location. You 
can select one or more clips using lasso selection—click and drag across some portion 
of each clip to select it.

For complete details on these and other ways to add media to your project, see Adding 
Media to Your Project.

Using the Media Library Context Menu
Control-click (right-click) on a media file in the media library to display the context 
menu and perform the following tasks, as described in Table 13.

View Button Click  to select thumbnail or list view.

Add Media Click to browse local drives or network servers for media to 
import into your project. This may include video files, audio 
files, and still images.

Add Recording Click to create a new recording. For details, see Configuring 
Recording in the Add Additional Recording Window.

Table 12. Media Library Controls

Control Description

Table 13. Media Library’s Media Menu

Menu Item Description

Preview Source Select to play (or view) media files in the media library. Or, 
hover your mouse over a media file until the Play button 
displays, then click it. ScreenFlow displays the image, plays 
the audio, or displays the video with playback controls at the 
base of the window.

Add to Timeline at 
Scrubber

Select to add your media to the timeline at the current 
scrubber position.

Select Clips in 
Timeline

Select to select the clip or clips to show where this clip is 
being used on the timeline.

Delete Media Select to remove the media from your project. If the media 
has been placed on the timeline, it is removed following a 
confirmation prompt. Media files that are recorded outside of 
ScreenFlow (files that are not .scc files) are not deleted.
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Publishing Your
ScreenFlow Project

When you’re done editing your screencast or other project, the final task is to convert it 
to a standard video format (encode it) for publication and distribution. Before 
generating your project for playback in a specific program, check the program 
specifications to see which formats it supports.

ScreenFlow provides two methods of converting projects to video. You can export a 
standard video file, then distribute or publish it yourself. You can also publish your 
video directly to an online video service such as YouTube, Vimeo, Google Drive, 
Dropbox, Facebook, or Flash—converting the project to the appropriate video format 
as part of the publication process.

 Exporting Your Video

 Publishing to YouTube

 Publishing to Vimeo

 Publishing to Google Drive

 Publishing to Dropbox

 Publishing to Facebook

 Publishing to Flash

 Publishing Your Video to Your Web Server

 Upload Manager Interface
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Exporting Your Video
Select File > Export to produce a video file, using a preset codec you select.

Note: If you have in and out points set in your project, the menu item displays Export 
Selected Range and the exported media is the media between the in and out points.

 Using the Export Window

 Customizing Codec Settings

 Managing your Export Presets

 Configuring Export Dimensions

 Configuring Other Options

 Video File Size Considerations

Using the Export Window
After configuring your export options, click Export to begin encoding the project into a 
video file. ScreenFlow displays a progress dialog so you can monitor its progress.

Note: If you purchased ScreenFlow from the Mac App Store, the Where popup menu 
does not display. Instead, ScreenFlow displays the File Save dialog after you click 
Export, so you can navigate and select your folder for the exported file.

ScreenFlow displays the Export Settings window, shown in Figure 65.

Figure 65. Export Settings Window

In the Mac App Store version, this 
popup menu does not display. 
Instead, the File Save dialog 
displays after you click Export. 
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These settings are described in Table 14.
Table 14. Video Export Options

Control Description

Save As Enter the name of your screencast. The default name is the 
name of your project file. The file extension is applied 
automatically based on your choice of preset.

Where Navigate and select the location of your exported video file.

Preset Export presets are designed for both general and specific use, 
based on the most common applications. 

Select a preset from the popup menu:

Web-High Default export option, which encodes video in H.264 format 
using the x264 codec, with AAC audio, balancing the 
demands of image quality and file size, producing an MP4 file.

Web-Low Encodes video in H.264 using the x264 codec, with AAC 
audio, for low bandwidth, producing an MP4 file. It plays 
more smoothly on slow Internet connections but with 
reduced image quality when compared to Web-High.

Windows Media 
Format

Telestream Web Store Only: This option exports video in 
WMV format, a popular Microsoft format for Windows. This 
option utilizes Flip4Mac, a QuickTime plugin by Telestream 
(Windows Media Format Customization) to encode the media, 
which must be licensed separately. 

Note: This control only appears if Flip4Mac is installed.

Lossless Encodes video using Apple’s Animation codec and raw PCM 
audio, an export format ideal for additional editing, as a 
QuickTime file. This format has the highest quality image and 
the largest file size. When exported at 100%, the image 
quality is identical to the original source recording.

Lossless - ProRes 
with Alpha

Encodes a lossless QuickTime file in ProRes 4444, including a 
clear alpha channel and stereo audio. Suitable for usage in 
applications such as Motion and After Effects.

To view transparent portions of the canvas, select View > 
Show Checkerboard.

Lossless - Audio 
Only

Encodes an uncompressed audio-only AIFF format ideal for 
additional editing.

iPad / iPhone / 
Apple TV / iPod

These export options are configured based on the 
recommended video specifications for these devices. They 
cannot be altered.
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Customizing Codec Settings
After selecting the Web-High, Web-Low, Lossless, or WMV preset (or a derivative), click 
the Customize button to modify these codec settings.

 H.264/AAC (MPEG-4) Customization

 QuickTime Customization

 Windows Media Format Customization

Make Settings 
Default

Select to use the current settings as the default export 
settings.

Customize When enabled, click to make changes to your video and 
audio encoding options. Some presets cannot be customized. 
See Customizing Codec Settings. 
You can use QuickTime (see QuickTime Customization) or 
WMV compression via Flip4Mac (see Windows Media Format 
Customization).

Manage Click to modify the preset encoding settings. See Managing 
your Export Presets.

 Dimensions Use these controls to specify scaling, set a specific frame size, 
and enable letterbox formatting. Available choices depend 
on the preset you’ve selected. See Configuring Export 
Dimensions

 Options Use these controls to specify motion blur, add chapter tracks, 
and add captions, depending on your encoding options. See 
Configuring Other Options.

Table 14. Video Export Options

Control Description
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H.264/AAC (MPEG-4) Customization
When you customize Web-High and Web-Low presets, ScreenFlow displays the H.264/
AAC compression settings dialog (Figure 66).

Figure 66. H.264/AAC Settings Window

Set these options, as described below in Table 15. When you’re done, click OK.
Table 15. H.264/AAC (MPEG-4) Settings

Option Description

H.264 Video Uncheck when you do not want your exported file to contain 
video tracks.

Frame rate Enter the frame rate in frames per second, or select preset 
values from the popup menu.

Data rate Enter the data rate in kbits per second.

NOTE: The data rate you enter is a target value. Therefore, the 
actual data rate may be higher or lower than entered.

Profile Select the codec profile (which establishes parameter ranges 
for a given application) from the popup menu:

Automatic The codec determines which profile to use, based on the size 
of the input video.

Main This profile results in longer encoding; it was designed 
primarily for SD digital TV broadcasts. It is well-suited for 
playback on desktop computers.

Baseline This profile is used for faster, simpler encoding, and improved 
data loss robustness, particularly for playback in mobile 
applications.
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AAC Audio Uncheck when you do not want your exported file to contain 
audio tracks.

Sample Rate Select to signify the number of samples taken from the source 
per second (in kHz) and added to the audio track being 
generated.
Select the sample rate from the popup menu. Web-High and 
Web-Low, defaults to CD quality ( 44.1 kHz). 

Data rate Enter the data rate in kbits per second. Web-High, defaults to 
256kbits/sec. Web-Low, defaults to 96kbits/sec.

Table 15. H.264/AAC (MPEG-4) Settings

Option Description
ScreenFlow User Guide



Publishing Your ScreenFlow Project
Exporting Your Video

109
QuickTime Customization
When you customize a Lossless preset, ScreenFlow displays the Movie Settings dialog 
(Figure 67), the standard dialog for all programs which use QuickTime to compress 
video.

Figure 67. QuickTime Movie Settings Window (Typical)

Set these options, as described in Table 16. When you’re done, click OK.
Table 16. QuickTime Video Settings

Option Description

Video Uncheck when you do not want your exported file to contain 
a video track.

Settings Click to change the video codec and its settings: frame rate, 
bit rate, quality, etc.

Filter Check to add effects such as Sharpen, Sepia, Gamma (Adjust) 
and others. Filters increase encoding time.

Sound Uncheck when you do not want your exported file to contain 
audio tracks.

Settings Click to change the audio codec and its settings. Each codec 
has its own set of options: sample rate, sample size, etc.

Prepare for Internet 
Streaming

Check Prepare for Internet Streaming to export your movie 
for use on the Internet.
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Fast Start Select to allow your movie to begin playing before the movie 
has finished downloading. This is the default option. 

Fast-Start with 
Compressed Header

Select to also compress the file header. Some older versions 
of QuickTime don’t support this option. Therefore, some users 
may not be able to view video compressed using this option. 

Hinted Streaming Use when this video will be hosted on a QuickTime Streaming 
Server (QTSS). This option adds hint tracks, which allow QTSS 
to stream the movie. 

Table 16. QuickTime Video Settings

Option Description
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Windows Media Format Customization

Note: You can only export media in Windows Media format in ScreenFlow purchased 
from the Telestream Web Store. If you purchased ScreenFlow in the Mac App Store, 
you can’t export media in WMV format.
For details on exporting WMV media in Flip4Mac, refer to the Flip4Mac User’s Guide.

When you customize a WMV preset, ScreenFlow displays the Flip4Mac WMV Export 
Settings window, shown in Figure 68. 

Figure 68. Flip4Mac Compression Window

To export your project in Windows Media (WMV) format, a popular Microsoft format for 
Windows users, ScreenFlow uses Flip4Mac WMV Components for QuickTime. Flip4Mac 
must be installed and licensed separately. 

To export a full length Windows Media file requires a Flip4Mac WMV Studio license. If 
Flip4Mac is not licensed, it outputs 30 seconds of video, and watermarks the output.

For more information and to download the installer, go to the Telestream Flip4Mac Web 
page.
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Managing your Export Presets
Click the Manage button on the Export window to display the Manage Presets windows 
where you create and configure custom export presets. 

ScreenFlow displays the window shown in Figure 69.

Figure 69. Manage Presets Window (Custom Presets Vary)

Check the check box to the left of the preset to show it in the Preset list. Uncheck it to 
hide it.

Click the Copy button to the right of the preset to generate a copy of the preset so that 
you can modify it.

Custom presets are displayed in the list at the bottom of the window. To change the 
custom preset name, double-click the name. Click the Edit button to customize your 
preset. See Customizing Codec Settings for details.
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Configuring Export Dimensions
Use the dimensions options (Figure 70) to set the frame size of your exported video. 
You should not set a size larger than your canvas size—it does not improve image 
quality.

Figure 70. Export Settings Dimension Options

Set these options, as described in Table 17. When you’re done, click OK. 
Table 17. Dimensions Settings

Control Description

Scale by Select to scale your video by a percentage. This shrinks the 
frame proportionally, preserving the aspect ratio.

Scale to custom size Select to specify the width and height of your exported video.

Letterbox Content Check to process for letter boxing. Letter boxing preserves 
the aspect ratio of the original canvas size by placing black 
bars at the top and bottom (or the sides), where there would 
be blank areas created by a custom size with a different 
aspect ratio
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Configuring Other Options
Use these options (Figure 71) to specify motion blur, add a chapter track, and add 
captions, depending on the video format you’re creating.

Figure 71. Export Settings Export Options

These settings are described in Table 18. 

Note: *QuickTime X and VLC require a chapter marker on the first frame of your 
project or it will move the chapter markers from their intended locations. Be sure to 
set a chapter marker at the very beginning of your project to prevent this.

Table 18. Dimensions Settings

Control Description

Use Motion Blur Check to apply a blurring algorithm to blend movement 
smoothly into the video. This is useful if you are using video 
properties effects to move clips on the canvas. This option 
increases encoding time so it should only be used if objects 
are not moving smoothly in your exported video.

Add Chapter Track 
from Markers*

When encoding with some codecs in QuickTime, check to add 
chapter markers to your movie based on the location and 
names of the markers in your project. These markers provide 
quick navigation and require named markers to be present in 
the project.

Add Captions Track Check to include your caption track. Available on all presets 
except the lossless presets.
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Video File Size Considerations
Video files often become very large, making them difficult to send to others, download, 
or post to servers via the Internet.

The frame size of video clips in your project is typically much larger than the screen size 
of the video file you are exporting. For example, if your original screen size is 1280 x 800 
pixels, you probably do not want to create a video of the same frame size. This is 
essentially HD video, and is about four times larger than a 640 x 400 video.

Reducing Video File Size
To preserve the aspect ratio of your project, use the Scale by Dimensions option as 
opposed to Scale to a custom size. For general purposes, you may want to scale by 50%.

Reducing the Frame Rate
The NTSC video standard frame rate is 30 FPS. This is the standard for videos produced 
in North America. However, this standard is based on creating a smooth representation 
of video motion captured in the real world and may not be necessary for your project.

For example, if you specify 30 frames per second, the output will be smooth, but the file 
will be about twice as large as a 15 fps video file. You may find that a 10 fps or 15 fps 
encoding is very acceptable for your audience. Reducing the frame rate can drastically 
reduce the size of the video file.

You should experiment with codec settings to get a sense for what size and frame rate 
works best for you. 
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Publishing to YouTube
If you have a YouTube account, ScreenFlow enables you to encode and publish your 
projects directly to YouTube. Select File > Publish to > YouTube, select Video Encoding 
and Options, then click Next. 

Figure 72. YouTube Account Login Window

When the Google Sign In window displays, enter your email and password, then click 
Sign In.

Figure 73. YouTube Account Login Window

Select Video Encoding

Select Options

Click Next

Enter email and password

Click Sign In
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When you sign in, Google displays the ScreenFlow Verification dialog. Click Accept to 
complete log in.

Figure 74. ScreenFlow Verification Dialog

Click Accept
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When the Publish To YouTube window displays, select a Category, and enter a Title and 
Description. The Title is a required field and will manifest itself as the primary filename. 
Enter your tags. The Tags are required to activate the Publish button. Select a Privacy 
level to restrict who can view the content. Click Publish when finished. The URL for 
uploads will be returned when the upload has completed. 

Table 19. YouTube Publishing Details

Control Description

Category Select the category of your project from the options in the 
popup menu.

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When YouTube users 
search for these words, your video is included in the search 
results.

Privacy Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only YouTube users that you authorize can view this 
video

Enter Title, 
Description 
and Tags

Click Publish

Set Privacy level

Select a Category
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“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your YouTube account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Table 19. YouTube Publishing Details

Control Description
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Publishing to Vimeo
If you have a Vimeo account, ScreenFlow enables you to encode and publish your 
projects directly to Vimeo. Select File > Publish to > Vimeo then select Video Encoding 
and Options. Click Sign In when finished:

When the Log In window displays, enter your email and password then click Log In. 

When the Publish To Vimeo window displays, enter a Title and Description. The Tags are 
not required to activate the Publish button. The Privacy settings can be adjusted to 
restrict who can view the content. The Account Default Privacy setting uses the defaults 

Select Video Encoding

Select Options

Click Sign In
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set up through the Vimeo Web interface. Click Publish when finished. The URL for 
uploads will be returned when the upload has completed. 

.
Table 20. Vimeo Settings

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When Vimeo users 
search for these words, your video is included in the search 
results.

Privacy Select the level of privacy required. Account Default uses the 
defaults set up through the Vimeo Web interface.

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Vimeo account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Enter Title, 
Description 
and Tags

Click Publish

Set Privacy level
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Publishing to Google Drive
Google Drive is a generic file storage system that allows you to place uploaded files into 
a specific folder. Additional folders can be created under the Folder pop up menu.

If you have a Google account, ScreenFlow enables you to encode and publish your 
projects directly to Google Drive. Select File > Publish to > Google Drive then select a 
Preset. Optionally, you can customize or manage your preset by clicking Customize or 
Manage. Set Dimensions and select Options as needed. Click Next when finished.

When the Google Sign In window displays, enter your email and password, then click 
Sign In.

Figure 75. Google Account Login Window

Click Next

Select Preset

Optionally click Customize 
or Manage

Select Options

Set Dimensions

Enter email and password

Click Sigh In
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When you sign in, Google displays the ScreenFlow Verification dialog. Click Accept to 
complete log in.

Figure 76. ScreenFlow Verification Dialog

When the Publish To Google Drive window displays, select a folder in the list or click 
Create New Folder to create a new folder in your Google Drive account. ( My Drive is the 
root folder, consistent with how Google Drive behaves through their Web interface.) 
Enter a Title and Description. The Title is a required field and will manifest itself as the 
primary filename. The star icon (to the right of Title) allows you to mark the upload as a 
favorite. This follows the way Google Drive Web interface behaves. Select also a Sharing 
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level to restrict who can view the content. The URL for uploads will be returned when 
the upload has completed. Click Publish when finished.

.
Table 21. Google Drive Publishing Details

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When users search 
for these words, your video is included in the search results.

Sharing Check Public | Unlisted | Private:

Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only Google Drive users that you authorize can view 
this video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Google account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Enter Title and 
Description

Click Publish

Set Privacy level

Select a Folder

Click star to mark as favorite
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Publishing to Dropbox
Dropbox is similar to a virtually hosted file system and therefore has a simple set of 
publishing options. 

If you have a Dropbox account, ScreenFlow enables you to encode and publish your 
projects directly to Dropbox. Select File > Publish to > Dropbox then select a Preset. 
Optionally, you can customize or manage your preset by clicking Customize or Manage. 
Set Dimensions and select Options as needed. Click Sign In when finished.

Click Sign In

Select Preset

Optionally click Customize 
or Manage

Select Options

Set Dimensions
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After the Dropbox Authorization window (Figure 77) and the Sign In window 
(Figure 78) both display, enter your email and password, then click Sign In.

Figure 77. Dropbox Authorization Dialog

Figure 78. ScreenFlow Sign In Dialog

Note: Once you are finished working with your Dropbox account, it is recommended 
that you log out of the service through your Web browser.

Enter email and password

Click Sign In
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When you have successfully signed in the window will display a Success! message Click 
Show ScreenFlow to continue.

Figure 79. ScreenFlow Success Dialog

When the Publish To Dropbox window displays, select a filename (required) and set 
privacy level. Click Publish when finished. The URL for uploads will be returned when 
the upload has completed. 

Figure 80. Dropbox Account Login Window

The Dropbox upload places all the files into a ScreenFlow folder inside the Apps folder at 
the root of the user’s Dropbox. This cannot be changed because it is the only way for 
third-party applications to upload to Dropbox directly.
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Table 22. Dropbox Publishing Details

Control Description

Filename Enter a filename to use for your publication. 
NOTE: The Apps folder at the root of the user’s Dropbox 
cannot be changed because it is the only way for third-party 
applications to upload to Dropbox directly.

Privacy Public: Anyone can view this video

Private: Only users that you authorize can view this video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Dropbox account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.
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Publishing to Facebook
The Facebook upload will post your exported video (with an optional title and 
description) directly to your Facebook home page or any Page or Group you have 
access to. The publishing service will cause Facebook to populate the Post To field with 
all of your accessible information. If there is no title or description added, the video will 
be posted without accompanying text. There are privacy options available, but only 
when posting directly to your Facebook home page. These options are not relevant 
when posting to a Page or Group (since these are public). The URL for the upload will be 
returned once the publish/upload process has completed. 

If you have a Facebook account, ScreenFlow enables you to encode and publish your 
projects directly to Facebook. Select File > Publish to > Facebook to display the Facebook 
Sign In window. Select video encoding and options, then click Sign In.

When the Facebook window displays, enter your email (or phone number) and 
password, then click Log In.

Select Video Encoding

Select Options

Click Sign In
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When the Publish To Facebook window displays, enter a Title and Description, then set 
the Privacy level. Click Publish when finished. The URL for uploads will be returned 
when the upload has completed.

Figure 81. Facebook Account Login Window

.

Publishing to Flash
When you publish your project to Flash, ScreenFlow saves it in F4V Flash format, a 
highly-compressed format suitable for Internet publication. Publishing to Flash 

Table 23. Facebook Publishing Details

Control Description

Post To Select the category of your project from the options in the 
popup menu.

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Privacy Public: Anyone can view this video

Friends Only: Only people with a link can view this video

Me Only: Only you can view this video 

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Facebook account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Enter Title and 
Description

Click Publish

Set Privacy level

Select Post To
ScreenFlow User Guide



Publishing Your ScreenFlow Project
Publishing to Flash

131
produces a Flash video plus the necessary components for hosting the video on your 
Web site.

Select File > Publish to > Flash to display the Flash Settings dialog, as shown here in 
Figure 82.

Figure 82. Flash Settings Window

The settings are described below, in Table 24. 
Table 24. Flash Settings

Control Description

Player Use the left and right arrows to scroll and select one of the 
Flash player skins to determine how the video controls are 
presented on your Web site.

Encoding: Automatic 
for Web

Uses the automatic Flash presets. This formats the video as 
320 x 240, 30 FPS, and 900 KPBPS.

Encoding: Custom Select to configure your own settings.

Width Enter the width of your video in pixels.

Height Enter the height of your video in pixels.

Frame Rate Select the number of frames per second. The North American 
NTSC standard is 29.97 (often rounded up to 30). The 
European PAL standard is 25. Range: 1-100.

Data Rate Enter the volume of bits that define the video per second. 
Setting a low data rate is ideal for streaming with slow 
Internet connections, but a low data rate may impair video 
quality. An acceptable data rate depends on the complexity 
of the video and user preference. Range:10-10,000.
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Depending on the operating system, the File Save method varies. This example is from 
Mac OS X 10.7, Lion. For details, see Save Commands.

Figure 83. Flash Settings Window

Click Save to export your project in Flash format. 

ScreenFlow publishes a Flash folder consisting of:

• index.html, an HTML page containing a player showing <yourmovie>.f4v. Edit 
this file to suit your requirements, or use it as a template for incorporating the video 
in other Web pages.

•  <yourmovie>.f4v, the project published in Flash

•  player.swf, the Flash player

•  a /com directory containing the skin for the player

•  a readme file.

Publishing Your Video to Your Web Server
If you are running the Mac OS X Web server (Preferences > Sharing > Web Sharing), you 
can place the output directory in (a subdirectory of ) /Library/WebServer/
Documents/ and have your video immediately accessible to the world.

Example: If you have placed your output in /Library/WebServer/Documents/
myvideo/ on mywebserver.com, opening http://mywebserver.com/myvideo/ in 
a Web browser will display your video.

Upload Manager Interface
Once the publishing settings have been selected and the Publish button is clicked, the 
exporting begins. 
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When the export has completed, the upload will occur in the background through the 
Upload Manager. The Upload Manager button displays in the main document window 
and displays progress via its blue progress bar.

Click the Upload Manager button to display details of the upload. (ScreenFlow supports 
multiple concurrent uploads.)

When the upload finishes, you can click the arrow icon to open the URL in a browser. 
Click Clear to close the Upload Manager and clear out completed uploads from the list. 
If there are no remaining uploads in progress, the Upload Manager button is hidden 
until a new upload occurs. (This is similar to how the Safari download manager works.)

Upload Manager button

Click the Upload 
Manager button

Click ClearClick Arrow to view upload
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If an error occurs when uploading, it is displayed in the Upload Manager window. Click 
the yellow warning triangle to display more information about the error.

Error message

Click Yellow triangle
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Setting Preferences
You use ScreenFlow Preferences to set your options and customize ScreenFlow to suit 
your specific needs. To display Preferences, select ScreenFlow > Preferences or press 
Command-comma.

Note: If you purchased ScreenFlow through the Mac App Store, the License tab does 
not display. The Mac App Store has its own licensing and updating processes.

 General Pane

 Timeline Pane

 Advanced Pane

 Licenses (Telestream Web Store Only)
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General Pane
The General pane provides startup, display, recording, and auto-update options.

Figure 84. Preferences General Pane

These controls are described in Table 25.
Table 25. Preferences General Pane Options

Control Description

Show ScreenFlow 
options in menu bar

Check to toggle the ScreenFlow Helper menu on and off in 
the status menu.

Countdown for [x] 
secs before recording

Check to use the Countdown window, and set the countdown 
time (in seconds). Range: 0 - 10. Default: 5.

Launch ScreenFlow 
Helper at user login

Check to launch ScreenFlow Helper when you log in so that 
you can record without first launching ScreenFlow.

Check for ScreenFlow 
updates at launch

Check to automatically check for updates each time you start 
ScreenFlow, so you can update ScreenFlow immediately. 

Note: This option is not available if you purchased 
ScreenFlow from the Mac App Store. The App Store has its 
own update procedure.

Recording Hotkey Click the button to change the recording hotkey command 
(default: Shift-Command-2), then press the key combination 
you want to use.

Note: Be sure to choose a hotkey which is not used by the 
application you are recording.

Pause Hotkey Click the button to set or change the pause hotkey command, 
then press the key combination you want to use.

Note: Be sure to choose a hotkey which is not used by the 
application you are recording.

These do not display if 
ScreenFlow was purchased 
from the Mac App Store.
ScreenFlow User Guide



Setting Preferences
Timeline Pane

137
Timeline Pane
Use the Timeline pane to set timeline preferences.

Figure 85. Preferences Timeline Pane

These controls are described in Table 26.
Table 26. Preferences Timeline Pane Options

Control Description

Use SMPTE timecode Check to display the scale as SMPTE timecode 
(HH:MM:SS:FF—Hours:Minutes:Seconds:Frames). 
If unchecked, the scale displays the scale informally. For 
example: 1h2m30s.

Hide Action Menu 
Overlay in Clips

Check to hide the action gear menu in clips.

Show Stereo Audio 
Waveforms

Check to display two audio waveforms (left and right) in the 
editor window toolbar, instead of a single, combined 
waveform.
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Default Transitions Select the default effect to use when generating a transition. 
Default: Bars Swipe.

Default Track Height Select the default track height of timeline tracks: small, 
Regular, or Large. If your project has many tracks, you can set 
this to Small to view more tracks in your window without 
scrolling. Default: Regular.

Default Durations Select the duration field of the item you want to change. 
These are default time values for actions, transitions, still 
images, callouts, and annotaions. Enter the value (in seconds) 
of the default length of the item when added to the timeline. 
Range: one-tenth of a second (typically 3 frames) up to (but 
not including) 30 seconds.

Table 26. Preferences Timeline Pane Options

Control Description
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Advanced Pane
The Advanced pane (Figure 86) provides ScreenFlow settings for video magnification, 
compression, and managing your audio driver and scratch disk.

Figure 86. Preferences Advanced Pane

These preferences are described in Table 27.
Table 27. Preferences Advanced Options

Preference Description

Video Magnification Select Smooth | Sharp to set the compression algorithm used 
when computing a scale effect or zoomed callout. Smooth 
blurs color values to create a smoother transition. Sharp does 
not blur color values. Default: Smooth.

Screen Recording 
Compression

Select Adaptive | Lossless to specify the method of 
compression used. Adaptive is compressed, which minimizes 
file size, but the loss in video quality is not noticeable to most 
users. Lossless is uncompressed which captures all pixels, 
thereby resulting in a larger file size. Default: Adaptive.

Computer Audio Click to install or uninstall ScreenFlow’s computer audio 
driver, which is required for recording computer audio. 
Note: If you purchased ScreenFlow through the App Store, 
the computer audio driver is installed automatically.

Capture Scratch Disk Click Change to specify a directory where ScreenFlow can 
temporarily save media as it is being recorded. By default, this 
is set to a private system location. Specifying a custom scratch 
disk allows you to locate your recording in the event that it 
was interrupted before completion.
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Licenses (Telestream Web Store Only)
The Licenses pane displays your serial number and allows you to manage your licenses. 

Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

ScreenFlow must be licensed to fully enable the export capabilities. If ScreenFlow is not 
licensed, all exported files are watermarked.

License functions are locked, and require administrator access to prevent guests from 
removing your license. Click the lock at the bottom of the window to make changes, 
then click the lock again, when you’re done.

Licensing ScreenFlow
If ScreenFlow is not currently licensed, the Licenses pane displays the buttons as 
depicted in the figure below (Figure 87).

Figure 87. Preferences Licenses Pane (Unlicensed)

These preferences are described in Table 28.
Table 28. Preferences License Options

Button Description

Purchase License Click to purchase a ScreenFlow license from the Telestream 
Web site. The license is automatically installed upon 
completion of your purchase.

Enter Serial Number Click to enter a serial number which has already been issued. 
This field is case sensitive. All letters must be capitalized and 
hyphens must be included.

Deactivate Serial 
Number

When ScreenFlow is unlicensed, this option is disabled.
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Upgrading, Changing and Deactivating a Serial Number
When ScreenFlow is licensed, the Licenses pane enables you to upgrade, change serial 
numbers, and deactivate serial numbers, as depicted in Figure 88.

Figure 88. Preferences Licenses Pane (Licensed)

Table 29. Preferences License Options

Button Description

Upgrade License If an upgrade is available, click to upgrade your ScreenFlow 
license from a previous version, enabling access to the 
features of the current ScreenFlow version. The upgrade fee 
depends on which license you currently have installed.

Change Serial 
Number

Click to enter a different serial number that you have already 
purchased for use with ScreenFlow.

Deactivate Serial 
Number

Click to deactivate your ScreenFlow license. This allows you to 
use your license on a different computer. Please allow up to 
15 minutes to process the deactivation before re-activating 
this serial number.
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Using ScreenFlow
Menus
This chapter describes each of ScreenFlow’s menu commands.

 ScreenFlow Helper Menu

 ScreenFlow Menu

 File Menu

 Edit Menu

 Mark Menu

 Insert Menu

 Font Menu

 Actions Menu

 View Menu

 Window Menu

 Purchase Menu (Telestream Web Store Only)

 Help Menu

ScreenFlow Helper Menu
The ScreenFlow Helper menu is identified by the camera icon  in the status menu.

Click camera icon
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ScreenFlow Menu
This topic describes each item in the ScreenFlow menu, as described in Table 31.

Table 30. ScreenFlow Helper Menu Items

Menu Item Description

Record/Stop Record
(Shift-Command-2)

Begins recording using the selected sources (display, 
camera, microphone, and/or computer audio). The menu 
icon changes from  to , advising you that 
ScreenFlow is recording.

Select Stop Record or press Shift-Command-2 to stop 
recording. 

Pause/Resume Pauses recording. The menu icon changes to a blinking 
dot, advising you that ScreenFlow has been paused. 
Select Resume to continue recording.

To modify the hotkey for these commands, see General 
Pane. 

Configure Recording Displays the Configuring Recording in the ScreenFlow 
Recording Window for setting recording parameters.

Hide Desktop Icons/Show 
Desktop Icons

Hides all icons on your desktop if you prefer a less 
cluttered background. Select Show Desktop to show them 
again. 

Quit ScreenFlow Closes the ScreenFlow and ScreenFlow Helper 
applications. 

Table 31. ScreenFlow Menu Items

Menu Item Description

About ScreenFlow Displays a dialog indicating the version of ScreenFlow you are 
running.

Check For Updates Note: This option is not available to users who purchased 
from the Mac App Store. The App Store has its own update 
procedure.

Checks Telestream’s Online Store to determine if there is a 
more recent version of ScreenFlow available. If so, you can 
download it. To check for ScreenFlow updates automatically, 
check the Check for Updates option in the General Pane.

Preferences
(Command-,)

Displays the Setting Preferences window so that you can view 
and change ScreenFlow preferences. If the Preferences 
window is already open, it is brought to the front.
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File Menu
This topic describes each menu item in the File menu, as described in Table 32. File save 
commands vary by operating system and are described separately, in Save Commands.

Store Takes you to the Telestream on-line store where you can 
purchase upgrades and Transition packs.

Services Displays Macintosh Services—none are implemented in 
ScreenFlow.

Hide ScreenFlow
(Command-H)

Hides all ScreenFlow windows.

Hide others
(Alt-Command-H)

Hides all other application windows (every window which is 
not a ScreenFlow window).

Show All Shows all previously hidden windows.

Quit ScreenFlow
(Command-Q)

Closes all open documents and then quits.

If a document has not been saved, ScreenFlow displays a Save 
dialog, so you can save the document before quitting.

If Launch ScreenFlow Helper at user login is checked in the 
Preferences General Pane, ScreenFlow Helper stays running 
when you quit ScreenFlow.

Table 31. ScreenFlow Menu Items

Menu Item Description

Table 32. File Menu Items

Menu Item Description

New Recording
(Command-N)

Displays the Configure Recording window (see Configuring 
Recording in the ScreenFlow Recording Window), which allows 
you to select recording options and record a new clip.

When complete, the clip can be added to a new (untitled) 
ScreenFlow document, or can be added to any existing 
document, or can be discarded entirely.

New Empty Document
(Shift-Command-N)

Displays a dialog use to set the video frame size by selecting a 
preset or entering a custom width and height, then click 
Create to display a new, untitled ScreenFlow document.

Open
(Command-O)

Displays the Open dialog, so you can navigate and open a 
ScreenFlow document that was saved earlier. 

Open Recent Click to select from up to 15 recently accessed documents. 

Every time you open or save a document, it is added to the 
list. Select Open Recent > Clear Menu to reset the list.
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Add Additional 
Recording
(Shift-Command-R)

Displays the Add Additional Recording dialog. After recording 
is complete, displays the Recording Complete dialog so you 
can add the recording to a new document or to a currently-
open document. See Configuring Recording in the Add 
Additional Recording Window.

Close
(Command-W)

Closes the active ScreenFlow document.

If the document has not been previously saved, ScreenFlow 
displays a Save As dialog, so that you can name the document 
and save it before closing it.

Close Tab
(Command-W)

Closes the active tab on the timeline.

Save Save varies by operating system. (See Save Commands)

Duplicate Creates an untitled copy of your ScreenFlow project

Rename Enables you to rename your ScreenFlow project by turning 
the title of your project (at the top of the ScreenFlow window) 
into an editable field.

Move To Opens a dialog box that enables you to navigate to a new 
location. After selecting a location, click Move to move your 
project.

Revert to Saved Greyed out. This feature is not available.

Save Frame Select to save the video frame of the canvas (as rendered by 
the location of the scrubber) as a PNG file.

Publish to...
     YouTube
     Vimeo
     Google Drive
     Dropbox
     Facebook

Displays the Publish dialog, enabling you to log in, encode 
your project (or the selected range, when in and out points 
are present) and publish your video.

     Flash Displays the Publish to Flash dialog, so you can encode your 
project (or the selected range, when in and out points are 
present) in Flash (F4V) format and save the file.

Export | Publish 
Export Range
(Command-E)

Displays the Export dialog (see Exporting Your Video), so you 
can select your encoding options, encode your project (or the 
selected range, when in and out points are present) and 
export the file.

Table 32. File Menu Items

Menu Item Description
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Save Commands
ScreenFlow save features are different depending on which operating system is used. 

 OS X Mountain Lion Save Commands

 OS X Lion Save Commands

OS X Mountain Lion Save Commands
These save options are specific to OS X Mountain Lion (10.8)—see Table 33.
Table 33. Mac OS Mountain Lion File Menu Save Commands

Menu Item Description

Save
(Command-S)

Saves the document with recent changes. 

If the document has not been previously saved, ScreenFlow 
displays the Save As dialog, so that you can name the 
document and save it before closing it.

Duplicate Saves a new version of the document without overwriting the 
previous version.

This allows you to save the ScreenFlow project with a new 
name and/or location.

Rename Highlights the document title so that you can change the file 
name without using the file system dialog.

Move To Displays a file system dialog so that you can move (not copy) 
the file to a different folder.

Revert to Saved Restores the document to the state it was in when last saved.

This reverses any action taken since the last save.
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OS X Lion Save Commands
These save options are specific to OS X Lion (10.7)—see Table 34.
Table 34. Mac OS Lion File Menu Save Commands

Menu Item Description

Save
(Command-S)

Saves the document with recent changes. 

If the document has not been previously saved, ScreenFlow 
displays the Save As dialog, so that you can name the 
document and save it before closing it.

Duplicate Saves a new version of the document without overwriting the 
previous version.

This allows you to save the ScreenFlow project with a new 
name and/or location.

Revert to Saved Restores the document to the state it was in when last saved.

This reverses any action taken since the last save.
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Edit Menu
This topic describes each item in the Edit menu, as described in Table 35 through 
Table 40.

Note: Most of these commands are also on the gear  menu, directly on the clip. 

Table 35. Edit Menu Items

Menu Item Description

Undo
(Command-Z)

Reverses your last change.

ScreenFlow permits an unlimited number of undo/redo 
actions (limited only by memory constraints). However, undo 
information is stored on a per-window basis. If you close a 
window and then reopen it, its undo list is lost.

Redo
(Shift-Command-Z)

Reverses your last Undo action.

Cut
(Command-X)

Removes the selected object or objects, and place them on 
the clipboard.

Copy
(Command-C)

Copies the selected object or objects onto the clipboard.

Note: Clips in the media library cannot be copied, but they 
can be added to the timeline multiple times.

Paste
(Command-V)

Adds objects on the clipboard to your document.

Copied text is added to the text box at the cursor position. 
Inserted text adopts the text formatting of the character 
immediately preceding the insertion point.

If the scrubber is at the start of the timeline or anywhere on a 
clip, the clip is added one layer up, at the scrubber position.

If the scrubber is at the end of a clip, the pasted clip is added 
on the same layer.

Paste Properties Updates the properties of the selected clip on the timeline 
with the properties of the clip on the clipboard.
Paste Properties has these sub menu items:

Video
(Alt-Command-I)

Pastes video properties into a video clip.

Audio
(Alt-Command-A)

Pastes audio properties into an audio clip.

Screen Recording
(Alt-Command-S)

Pastes the screen recording properties into a clip.
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Note: You can paste properties to multiple clips simultaneously; however, If you copy 
multiple clips with different properties and paste adjustments to another clip, which 
properties will be pasted is not predictable.

Figure 89. Mark In and out points on your timeline

Select Delete to remove all assets from the timeline between the in and out points:

Figure 90. Delete the assets between the in and out points

Callout
(Alt-Command-C)

Pastes callout properties into a callout action.

Video Filters
(Alt-Command-V)

Pastes video filter properties into a clip.

Callout
(Alt-Command-U)

Pastes audio filter properties into a clip.

Table 36. Edit Menu Items (continued)

Menu Item Description

Paste and Match Style
(Alt-Shift-Command-V)

Adds text on the clipboard to your text box. Inserted text 
adopts the text formatting of the character immediately 
preceding the insertion point. 

Delete (Delete) Permanently removes the selected items. If you have marked 
in and out points, the segment between the in and out point 
is deleted for all clips, as shown in Figure 89 and Figure 90.

Table 35. Edit Menu Items

Menu Item Description
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Note: To shift clips left to fill the hole created by the deletion, use Ripple Delete 
(Command-backspace), the scrubber handle, or right-click (Control-click) in the empty 
space and select Close Gap.

Figure 91. Timeline before splitting a clip

Figure 92. Timeline after splitting a clip

When splitting a clip, the previous clip name is retained on both clips. By default, each 
segment of a clip uses the name of the original media located in the Media Library.

These segments can be renamed for convenience and clarity.

Table 37. Edit Menu Items (continued)

Menu Item Description

Ripple Delete
(Command-
Backspace or Delete)

Delete the elements (or portions of elements) between the in 
and out points on all tracks of the timeline and shift all clips 
left to close the gap on the timeline.

Select All
(Command-A)

Highlights all clips on the timeline.

Deselect All
(Shift-Command-A)

Deselects all clips on the timeline. This can also be done by 
clicking in an empty area of the canvas or timeline.

Split
(Command-T | 
Command-Shift-T | T)

Converts each selected clip into two separate clips, splitting 
them at the current scrubber point, so that you can adjust the 
parts of the clip independently, as shown in Figure 91 and 
Figure 92.

Table 38. Edit Menu Items (continued)

Menu Item Description

Detach Audio Removes the audio stream from the selected clip (visible as a 
green waveform through the center of the clip unless View > 
Show Audio Waveforms is unchecked), and creates a new 
audio clip at the same point on the timeline, as shown in 
Figure 93 and Figure 94. 
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Figure 93. Timeline Prior to Performing the Detach Audio Command

ScreenFlow adds the audio to a new audio clip on the timeline:

Figure 94. Timeline After Detaching Audio from a Clip

After detaching audio from a clip, the new audio clip—containing the audio from the 
selected video clip—is added to the timeline. The original clip is now video only.

Figure 95. Timeline Prior to Performing the Add Freeze Frame Command

Table 39. Edit Menu Items (continued)

Menu Item Description

Add Freeze Frame
(Shift-Command-F)

Inserts a freeze frame in the middle of a selected clip.

First, the clip is split at the scrubber, then a two second freeze 
frame is inserted between the clips. The duration of the freeze 
frame can be set by dragging the edge of the clip, much like 
any other still image clip. The second half of the clip is moved 
to the right to adjust for the added clip, as shown in Figure 95 
and Figure 96.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of freeze frames.
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ScreenFlow adds two new clips to the timeline:

Figure 96. Timeline After Detaching Audio From a Clip

This is useful for pausing your video while demonstrating or narrating.
Table 40. Edit Menu Items (continued)

Menu Item Description

Trim Front to 
Scrubber
(W)

Trims the front of the selected clips from the start of the clip 
up to the scrubber position.

Alternatively, you can adjust the left side of the clip by 
clicking the mouse just near the left edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the right to trim the amount you want off of the front 
of the clip. This method is functionally equivalent to using the 
Trim Front to Scrubber command.

Trim End to Scrubber
(E)

Trims the back of the selected clips from the end of the clip 
up to the scrubber mark.

Alternatively, you can adjust the right side of the clip by 
clicking the mouse just near the right edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the left to trim the amount you want off of the back of 
the clip. This method is functionally equivalent to using the 
Trim End to Scrubber command.

Lock Clip | Unlock Clip
(Alt-Command-L)

Locks selected clips to their positions on the timeline and 
cannot be moved. When clips are locked, you cannot move 
other clips onto them to make transitions. Select again to 
unlock selected clips you have previously locked.

Nest Clips
(Alt-Command-N)

Nests selected clips into a group for treating the group as a 
whole when operating on them. See Using Nested Clips for 
details.

Unnest Clips Unnests a previously nested clip.

Group
(Command-G)

Ties selected clips together on the timeline, so that moving 
one clip moves all grouped clips. Ideal for synchronizing 
voice-overs, music beds, etc., to a camera clip so that their 
timing remains synchronized as you move them around in 
your project.
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Ungroup
(Command-U)

Returns selected clips to be independent of other clips.

Add Starting 
Transition | Remove 
Starting Transition
(Alt-Command-,)

Adds a transition to the beginning of the selected clip(s). 
Apply again to remove the transition.

Add Ending 
Transition | Remove 
Ending Transition
(Alt-Command-.)

Adds a transition to the ending of the selected clip(s). Apply 
again to remove the transition.

Add Starting & 
Ending Transitions | 
Remove Starting & 
Ending Transitions
(Alt-Command-.)

Adds transitions to the beginning and ending of the selected 
clip(s). Apply again to remove the transitions.

Captions

Set Current 
Language

Specifies the language you want to display captions in.

Export to SRT Exports the closed caption text in this project to a file.

Clear All Captions Removes caption text from all caption clips in this project.

Start Dictation
(Mac OS 10.8 
Mountain Lion only)

Displays the Mac OS dictation system, so that you can add 
text to a text box clip using your voice (Using Dictation to Add 
Text).

Special Character Displays the Characters window so that you can enter special 
characters in text fields.

Table 40. Edit Menu Items (continued)

Menu Item Description
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Mark Menu
This topic describes each item in the Mark menu, as described in Table 41.
Table 41. Mark Menu Items

Menu Item Description

Mark In Point
(I)

Sets the in point of a range on the timeline at the current 
point of the scrubber.

When you create an in point without an out point, 
ScreenFlow automatically sets the out point to the end of the 
last clip on the timeline, and highlights the range in blue. In 
and out points can be used to delete entire sections of your 
timeline using the Ripple Delete command.

Select the in point (click on the line directly over the timeline 
scale) and drag it right or left to adjust its point on the 
timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Mark Out Point
(O)

Sets the out point of a range on the timeline at the current 
point of the scrubber.

When you create an out point without an in point, 
ScreenFlow automatically sets the in point to the beginning 
of the timeline, and highlights the range in blue. In and out 
points can be used to delete entire sections of your timeline 
using the Ripple Delete command.

Select the out point (click on the line directly over the 
timeline scale) and drag it right or left to adjust its point on 
the timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Clear In & Out Points
(Alt-Z)

Removes the in and out points you created previously.

Markers

Add

(back single 
quote mark, left 
of the “1” key)

Adds a marker to the timeline at the scrubber location.

If you export a ScreenFlow document as a QuickTime movie, 
chapter markers are placed at each named marker position in 
the movie when Add Chapter Track from Markers is checked.

Delete
(Shift-~)

Deletes the selected marker.

Delete All Deletes all markers on the timeline.
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Goto Next
(Shift-Up Arrow)

Moves the scrubber to the next marker to the right on the 
timeline.

Goto Previous
(Shift-Down 
Arrow)

Moves the scrubber to the previous marker to the left on the 
timeline. You can also use the mouse to drag markers and 
adjust their position.

Go To

Project Start Moves the scrubber to the start of the project timeline.

Project End Moves the scrubber to the end of the project timeline.

Previous Frame Moves the scrubber to the previous frame on the timeline.

Next Frame Moves the scrubber to the next frame on the timeline.

Table 41. Mark Menu Items

Menu Item Description
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Insert Menu
This topic describes each item in the Insert menu, as described in Table 42.
Table 42. Insert Menu Items

Menu Item Description

Text Box Inserts a text clip into the project at the current scrubber 
position. Text box duration is 5 seconds, but can be adjusted 
by dragging the edge of the clip on the timeline.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of text boxes.

Annotations Clip
(Alt-Command-T)

Inserts simple graphic effects to visual clips including 
recordings, videos, and image files. Annotation shapes 
include circle, square, line, and arrow.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of annotation clips.

Speech Clip... Displays a sheet where you enter text, select a voice, then 
click Insert to create an audio clip in your project by 
converting text to speech using one of six automated voice 
programs. Text can be typed directly into the field or pasted 
from another document.

Choose...
(Shift-Command-V)

Imports media files into your project at the current scrubber 
position. ScreenFlow displays the Open dialog, so that you 
can browse your file system or network server and select the 
media file to add to the project’s media library and timeline.
ScreenFlow User Guide



Using ScreenFlow Menus
Font Menu

158
Font Menu
This topic describes each menu item in the Font menu, as described in Table 43. Font 
options apply only to text in text clips.
Table 43. Font Menu Items

Menu Item Description

Show Fonts
(Command-T)

Displays the System Font pane. Select a font to apply to 
highlighted text, or all text if none is selected.

Bold
(Command-B)

Makes the selected text bold.

Italic
(Command-I)

Makes the selected text italic.

Underline
(Shift-Command-U)

Underlines the selected text.

Bigger Increases the font size by one point.

Smaller Decreases the font size by one point.

Kern Adjusts the distance between characters to make them look 
better balanced. 
For example, tucking the letter A under V in the phrase AV. 
Kerning applies to all selected text. If no characters are 
selected it kerns the pair of characters on each side of the 
cursor.

The Kern menu item has these submenu items:

Use Default Use the default kerning built into the font.

Use None Disable all kerning.

Tighten Decrease the distance between characters.

Loosen Increase the distance between characters.

Ligature A ligature is a character that combines two or more other 
characters into a single character. Not all fonts contain all 
ligature characters, but their use is enabled by default.

The Ligature menu item has these submenu items:

Use Default Use ligatures if the font uses them.

Use None Never use ligatures.

Use All Always use ligatures.
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Copy Style Copies the style of the selected text, except background.

Paste Style Applies the previously copied text style to the selected text.

Make Text Properties 
Default

Saves the current text properties for the selected text box clip 
and makes them the default. When you create a new text box, 
the default text properties are used.

Table 43. Font Menu Items

Menu Item Description
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Actions Menu
Actions are time-based changes to clips used to create gradual temporal or temporary 
effects. Actions are applied mid-point, where the change takes place.

This topic describes each menu item in the Actions menu, as described in Table 44.
Table 44. Actions Menu Items

Menu Item Description

Add Video Action
(Command-K)

Adds a Video Action to the selected clip at the location of the 
scrubber. A Video Action allows you to apply effects like 
Zoom, Pan, and Rotate to your video clip.

Add Audio Action Adds an Audio Action to the selected clip. An Audio Action 
allows you to apply various effects on the audio of the 
selected clip, such as ducking, or adjusting the volume.

Add Screen 
Recording Action
(Command-R)

Adds a Screen Recording Action to the selected screen 
recording clip. Screen Recording actions enable you to 
modify the size of the Mouse Pointer, add click effects, or 
show keys pressed, for example.

Add Callout
(Command-L)

Adds a Callout to the selected screen recording clip. A callout 
lets you focus attention on a section of your project. For 
example, you can highlight the mouse pointer by dimming 
everything but the area just around the mouse pointer or 
highlight and magnify the foreground window.

Goto Next Action Within a clip, selects the next action.

Goto Previous Action Within a clip, selects the previous action.

Curve Type By default, actions are applied to the clip in a linear manner. 
For example, when applying a scaling action, the image size 
changes by equal amounts from start to finish. This may be 
perceived as too abrupt, so you can modify the rate with 
which an action is applied.

The Curve Type menu item has these submenu items:

Default Linear transition.

Ease-In Starting slow, speeding up towards the end.

Ease-Out Starting fast, slowing down towards the end.

Ease-In & Out Starting and ending slowly, faster in the middle.

None Applies action immediately.

The duration of the action is ignored if this option is applied.
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View Menu
This topic describes each menu item in the View menu, as described in Table 45. View 
options determine how the media is presented both on the canvas and on the timeline.

These options only change how your project is displayed on the canvas—they do not 
alter the media.
Table 45. View Menu Items

Menu Item Description

Enter Full Screen
(Command-F)

Displays the editor window in full screen mode to reduce on-
screen clutter.

Enter Preview
(Alt-Command-F)

Displays the project in full screen mode for playback only. 
Press Escape to exit preview.

Zoom In
(Command-=)

Magnifies the display of the canvas. 

Zoom Out
(Command--)

Reduces the display of the canvas. 

Zoom to 100%
(Alt-Command-0)

Displays the canvas area at its direct pixel size.

Zoom to Fit
(Control-Command-0)

When the canvas is obscured, adjusts the display size so that 
it is completely visible in the window.

Show Checkerboard Displays transparent portions of the background as 
checkerboard to distinguish them from opaque portions that 
are the same color as the background. To export video with 
an alpha channel, use the Lossless - ProRes with Alpha preset 
or a custom derivative (see Exporting Your Video).

Show Captions Displays closed caption text on the canvas.

Zoom Timeline to Fit
(Control-T)

Scales the timeline downward to display it entirely in the 
window. 

Zoom Timeline In
(=)

Expands the timeline.

Zoom Timeline Out
(-)

Contracts the timeline.

Switch to Inspector
(Command-0 - 7)

Displays the selected Property pane: Video, Audio, Screen 
Recording, Callout, Annotations, Text, and Media (library).

Select Focus Timeline to return keyboard events back to the 
timeline. For example, when you are editing a text box on the 
timeline, you can select Focus Timeline, then use shortcuts.
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Snapping
(Control-N)

Toggles snapping for both the canvas and timeline.

When snapping is on, the mouse snaps to various guide-lines. 
For example, on the canvas, the mouse snaps your objects to 
the center and edges of your canvas. It also snaps to other 
objects, if you have any. On the timeline, the mouse snaps to 
the beginnings and endings of actions and clips. Checked/On 
by default.

You can temporarily toggle snapping by holding down the 
Command key. 

Scrub Live Audio
(Shift-S)

When activated, you can hear the audio track while dragging 
the scrubber. Checked/On by default.

Show Audio 
Waveforms

When activated, clips that contain audio have the audio 
waveform shown along the center of the clip. Checked/On by 
default. 

Show Thumbnail 
Icons

When activated, each clip displays a thumbnail icon 
displaying either the first frame (for video or image files) or a 
format icon for audio or text clips. Checked/On by default.

Show Tab Bar Displays the tab bar on the timeline, pushing the timeline and 
all tracks down in the window, to accommodate it. When you 
create nested clips, each clip nest is identified by a tab.

Show Caption Track Displays the caption track on the timeline—the caption track 
is the highest track on the timeline. 

Table 45. View Menu Items

Menu Item Description
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Window Menu
This topic describes each menu item in the Window menu, as described in Table 46 and 
Table 47.

Figure 97. Markers window

Table 46. Window Menu Items

Menu Item Description

Minimize
(Command-M)

Minimizes the foreground window.

Zoom Scales the foreground window to the full size of the screen.

Select Previous Tab
(Shift-Command-[)

When the tab bar is visible in the timeline (as when editing 
nested clips), this navigates to the previous timeline tab.

Select Next Tab
(Shift-Command-])

Navigates to the next timeline tab.

Markers Opens a window listing the markers in the current document.

You can add, delete, and rename markers, and jump to 
markers in this window, as shown below in Figure 97. 

Table 47. Window Menu Items (continued)

Menu Item Description

Bring All to Front Puts all ScreenFlow windows in front of any other 
application's windows on the desktop.

documents List of all open document windows, listed sequentially in the 
order they were opened.
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Purchase Menu (Telestream Web Store Only)
Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Use these menu commands for purchasing from the Telestream Web Store and 
activating your ScreenFlow license, as described in table Table 48.

Note: If your ScreenFlow license is already activated, this menu does not display.

Table 48. Purchase Menu Items

Menu Item Description

Purchase ScreenFlow 
Online

Displays the Telestream online Web store.

Unlock ScreenFlow Displays the Licenses pane of ScreenFlow Preferences to 
enter a license. Requires admin authentication first. See 
Unlocking ScreenFlow via Telestream Web Store.
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Help Menu
This topic describes each menu item in the Help menu, as described in Table 49.
Table 49. Help Menu Items

Menu Item Description

Search Searches the User’s Guide (this document).

ScreenFlow Help Displays the ScreenFlow Help page, where you can access the 
ScreenFlow User’s Guide, view screencasts of ScreenFlow 
topics, and access other helpful resources.

Visit ScreenFlow Web 
site

Displays the Web page for general ScreenFlow information.

Visit Support Page Displays the Web page for ScreenFlow support information.

Open Temporary 
Folder in Finder

To display this menu item, press Shift then click the Help 
menu. Opens a Finder window to display the contents of 
ScreenFlow's temporary folder, where temporary files are 
stored.  

Gather Support 
Diagnostics

To display this menu item, press Shift then click the Help 
menu. 
Select Gather Support Diagnostics to collect debugging logs, 
crash reports, a system profile, and a snapshot of the current 
state of ScreenFlow including open documents. 

Click Gather to generate an archive of these files, and save it 
on your desktop. This process takes a couple of minutes—the 
file is named ScreenFlowDiagnostics_<User 
Name><ComputerModel>.zip.

Send this file to Customer Service as requested.
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Troubleshooting
This section describes common questions with ScreenFlow. If your issue is not listed or 
the recommended procedure does not work, please contact technical support.

How do I provide Customer Service with diagnostic information about a 
problem I’m having with ScreenFlow?

You select Help > Gather Support Diagnostics. To display this menu item, press Shift 
then click the Help menu. Select Gather Support Diagnostics to collect debugging logs, 
crash reports, a system profile, and a snapshot of the current state of ScreenFlow 
including open documents. 

Click Gather to generate an archive of these files, and save it on your desktop.

Send it to Telestream Customer Service as requested.

Why doesn’t ScreenFlow play a movie file I imported?

ScreenFlow supports video and audio file formats and codecs that QuickTime Player 
can play in Mac OS X10.7.x and higher. If ScreenFlow cannot play a movie file you’ve 
imported, attempt to open the media in QuickTime Player. If QuickTime Player cannot 
open the file, your system may not have the required codec. If QuickTime Player can 
play the clip and the clip does not play in ScreenFlow, please contact technical support.

I exported my video, but it looks fuzzy or blurry. What can I do to make it look 
better?

When using ScreenFlow, it can be difficult to record your entire display at full resolution 
then compress that data into a low-resolution video while still retaining your necessary 
level of image clarity. Here are a few things you can do:

• Export using the Lossless uncompressed video format. As long as you do not lower 
the resolution, it is identical to the original recording, but results in a large file size. 
This is ideal if you require additional editing or reformatting outside of ScreenFlow 
before publishing it. 

• Reduce your display resolution before recording (System Preferences/Displays). By 
reducing your display resolution before recording, you require less compression 
later. We recommend that you decide what size you want your video to be in 
advance. Then, lower your display resolution as close to that as possible, but no 

http://www.telestream.net/telestream-support/screen-flow/support.htm
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smaller. If you record at a smaller resolution than your intended output, you will 
lose image clarity. 

• Use the scale and zoom functions in ScreenFlow. If you do not want to reduce your 
display resolution or export to a large, uncompressed format, your best option is to 
use Video Properties > Scale or Callout Action > Zoom. These functions allow you 
to increase the visibility on a specific portion of the recording which can be valu-
able for maintaining clarity in a heavily compressed video. 

• Text is the hardest item to reproduce clearly in digital video. Digital video was not 
designed to recreate detailed figures like text. It was designed to map color spaces, 
so the thin lines of text can be particularly difficult to recreate. If you have text in 
your screencast, it is best to use the Scale feature or to increase the text size.

How do you designate a display recording area?

Although many screen capture programs function by designating a specific recording 
area, ScreenFlow does not. ScreenFlow captures the entire display. This enables you to 
make use of the entire display during editing in post-production. 

When using a program which designates a recording space, you may unexpectedly 
move outside of this space due to a menu option or pop-up. If your recording space is 
preset, there is no way to recover this lost information. With ScreenFlow's reliance on 
post-production editing, you can move outside your area of focus when necessary.

If you plan on recording only a small region of the display, you may be concerned that a 
full-screen recording will take up unnecessary disk space. ScreenFlow's adaptive 
recording method captures minimal information on parts of the screen where there is 
no action, so this has very little effect on file size, while preserving your post-
production options. 

Does ScreenFlow work with Parallels or VMware?

Since ScreenFlow captures everything on your display, both Parallels and VMware are 
supported (including Computer Audio output). However, ScreenFlow cannot use the 
Callout features, as these are dependent upon information provided by Mac OS X. 

Telestream has tested ScreenFlow with Parallels in all modes (Coherence, Window, and 
Full Screen) without issue. In fact, when using Parallels/VMware, some users have 
reported that ScreenFlow produces smoother, higher-quality output while using less 
CPU resources than native Windows screen capture programs.

What kind of graphics card should I use?

ScreenFlow requires a Quartz Extreme-capable graphics card. If you are unsure if your 
graphics card is supported, please download an evaluation version; ScreenFlow will 
notify you if it is not supported. You can expect most Mac hardware made in the last 
five years to fully support Quartz Extreme graphics cards. 

ScreenFlow uses video RAM (or VRAM) during the recording process, so it is important 
to have a graphics card with at least 64 MB of VRAM, but we recommend 128 MB. The 
amount of VRAM necessary to record smooth video depends on your display resolution 
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and whether or not other applications are simultaneously using VRAM. If you have 
insufficient VRAM, the recording will drop frames and the video skips during playback.

Does ScreenFlow support audio interface or mixing devices?

ScreenFlow does not support audio interface or mixing devices. However many of 
these devices will work with ScreenFlow if the audio is routed properly. If you are 
having trouble with your mixer, we recommend posting your issue on our forum. 

Does ScreenFlow support closed captioning?

ScreenFlow does support closed captioning. For details, see Creating Closed Captions. 

How do I use ScreenFlow to record my iPod/iPhone/iPad?

ScreenFlow cannot record these devices directly, but can record demonstrations using 
the XCODE simulator on Mac OS X.

My USB microphone and iSight camera are out of sync. What should I do?

If the audio and video are out of sync, try using the audio input on the computer (not 
the USB input) as there can be a latency problem between USB input and the iSight 
camera. This is particularly evident when recording a talking head. Use a microphone 
that utilizes the audio input into the computer. 

I can’t find my media files. Where is the media library?

Each project in ScreenFlow has a media library once the first media file has been 
recorded or the first file has been added. The media library is actually a folder inside the 
project itself. The media folder’s contents include .scc files and copies of externally-
added media files, and are controlled by the media library as you record clips in 
ScreenFlow, and add and delete files. 

To view the media folder, control-click (right-click) the project file in Finder and select 
Show Package Contents. Open the Media folder to view the files in the media library for 
this project.

CAUTION: Unless directed by customer service, you should not delete or rename files 
in this directory or it may corrupt your project.

Every file you add to the library is saved (or duplicated) in that folder. ScreenFlow 
recordings are media files with a .scc extension and can’t be opened by other video 
applications. 
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Installing ScreenFlow
This chapter specifies the platform requirements for ScreenFlow, and describes how to 
install, upgrade, and uninstall ScreenFlow and related subsystems.

Note: These topics apply only to purchases of ScreenFlow from the Telestream Web 
Store. If you purchased ScreenFlow from the Mac App Store, refer to their installation 
and upgrade instructions.

Note: To export screencasts in Windows Media format, ScreenFlow uses Flip4Mac  
Components for QuickTime. Flip4Mac must be installed and licensed for full 
functionality. If Flip4Mac is not licensed, it functions in demo mode to provide a 
sample of its capabilities. 
To export a full length Windows Media file, Flip4Mac requires a Flip4Mac Studio 
license. Customization beyond the preset profiles requires a Flip4Mac Studio Pro 
license. For more information, or to download the installer, go to the Telestream 
Flip4Mac Web page.

 Platform Requirements

 Installing ScreenFlow via Telestream Web Store

 Unlocking ScreenFlow via Telestream Web Store

 Activating Your Telestream Web Store License

 Installing Telestream Audio

 Deactivating Your ScreenFlow License

 Removing ScreenFlow from Your Computer

Be sure to review the platform requirements before installing ScreenFlow.

http://www.telestream.net/flip4mac-wmv/overview.htm
http://www.telestream.net/flip4mac-wmv/overview.htm
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Platform Requirements
ScreenFlow runs as a 64-bit application under OS X 10.7 Lion or later, which improves 
overall performance, memory usage, export speed, and scalability. Mac OS Mountain 
Lion 10.8 improves performance and has faster screen recording.

ScreenFlow runs on these platforms:

 Mac OS Lion 10.7.3 or later for Mac App Store

 Mac OS Lion 10.7 or later

 Mac OS Mountain Lion 10.8 or later

 Intel-based CPU required—Core 2 Duo recommended

 A Quartz Extreme graphics (GPU) card is required for certain effects & functionality.

Note: Cameras using an HDV codec are not supported.
ScreenFlow User Guide
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Installing ScreenFlow via Telestream Web Store
ScreenFlow is available from www.telestream.net as a disk image (dmg) file, as well as 
from the Mac App Store. This topic is for users who have downloaded ScreenFlow from 
the Telestream Web site.

Note: This installation procedure does not apply to users who purchased ScreenFlow 
from the Mac App Store. Instead, follow their installation and licensing procedures.

When you download or open the .dmg file in Safari, Mac OS X automatically mounts the 
disk image and runs the installer. When you download a .dmg file using another Web 
browser, double-click on the .dmg file to run the ScreenFlow installer.

Note: You are prompted for an administrator name and password during installation. 
If you don’t have an administrative account, obtain one to continue.
The installer attempts to close applications including QuickTime, Final Cut Pro, 
Episode Desktop, and Pipeline Control before installation. If the installer can’t close 
these applications, installation will fail after about a minute.

When the installer runs, it displays the window depicted below, in Figure 98.

Figure 98. Installing ScreenFlow

Drag the ScreenFlow icon onto the Applications folder to install ScreenFlow.

If a previous version of ScreenFlow is in the Applications folder, the Finder displays a 
dialog, confirming that you want to replace the previous version of ScreenFlow. Click 
Replace to complete installation.

Enter an administrative user’s name and password to continue. When installation is 
complete, Close the installer—ScreenFlow is installed and ready for you to use.
ScreenFlow User Guide
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Unlocking ScreenFlow via Telestream Web Store
You must upgrade your ScreenFlow 3.0 (or earlier) license or purchase a new 
ScreenFlow license in order to export movies without watermarking them. 

Note: This topic does not apply to users who purchased from the Mac App Store. The 
App Store has its own installation and licensing procedure.
Your user must be an administrator. If your user is not an administrative account, you’ll 
need to create one (or log on with one) in order to continue.

To activate your ScreenFlow license, follow these steps: 

1. Start ScreenFlow.

2. Select Purchase > Unlock ScreenFlow or select ScreenFlow > Preferences and click the 
Licenses tab, as shown in Figure 99.

Figure 99. Preferences Licenses Pane (Unlicensed)

3. Click the Lock icon at the bottom of the pane, and enter the password to your 
administrative account to allow ScreenFlow to make changes to your license.

4. Upgrade—If you have a ScreenFlow 3.0 or earlier license you want to upgrade, click 
Upgrade License. 
No License—If you don’t have a license, click Purchase License. This redirects you to 
the Telestream online store where you can purchase or upgrade your license.

When the purchase is complete, the ScreenFlow license installs automatically.

Note: If ScreenFlow doesn’t display an Upgrade or Purchase License button, then you 
have already registered ScreenFlow and it’s been activated and unlocked.
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Activating Your Telestream Web Store License
If you have already purchased a license through the Telestream Web Store, Telestream 
sent you an email receipt containing your license key.

Note: If your Macintosh is not connected to the Internet, follow the instructions in the 
Manual Activation Guide (www.telestream.net/pdfs/user-guides/
Manual_Activation_Guide.pdf) to activate your license and unlock ScreenFlow.

The easiest way to register the license key and activate ScreenFlow is to click on the link 
provided in your email receipt. If the link doesn’t work, register ScreenFlow as follows:

1. Launch ScreenFlow.

2. Select Purchase > Unlock ScreenFlow or select ScreenFlow > Preferences and click 
the Licenses tab.

Note: If ScreenFlow doesn’t display a Purchase menu, then you have already 
registered and unlocked ScreenFlow.

3. Click the Lock icon at the bottom of the pane, and enter your password to allow 
ScreenFlow to make changes to your license.

Note: Your user must be an administrator. If your username is not an administrative 
account, you’ll need to create one in order to continue.

4. Click Enter Serial Number and enter the license key into the license key field, as 
shown here in Figure 100.

Figure 100. Enter Your Serial Number To Unlock Screenflow

5. Click Activate to activate your serial number and unlock ScreenFlow.

Note: If the Activate button is dimmed, it means that the license is invalid. Double-
check your license from the e-mail. Make sure that all letters are capitalized, dashes are 
included, and all 0’s are zeros, not the capital letter O. It may also help to copy and 
paste your serial number from your e-mail, but be careful not to copy any additional 
text such as a space. If you are still having problems, please contact technical support.

Now your serial number is activated and ScreenFlow is unlocked. Close the Preferences 
window to continue.
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Installing Telestream Audio
To capture computer audio, ScreenFlow must install the Telestream Audio driver.

Note: Your user must be an administrator. If your username is not an administrative 
account, you’ll need to create (or log on with) one in order to continue.

The installation process begins automatically if you attempt to record computer audio 
without the driver installed.

Note: If you purchased ScreenFlow from the Mac App Store, you will be directed to 
the Telestream Web site to download and install the driver.

To install the Telestream Audio driver manually, follow these steps:

1. In ScreenFlow, select ScreenFlow > Preferences > Advanced.

2. Click the Install Driver button to display the Install Telestream Audio dialog using 
the Installer application.

3. Click Continue to proceed. The installer displays a space requirement message. 

4. Click Install to continue.

5. Enter your password to install the driver and click OK to continue.

6. The installer installs the Telestream Audio driver. Upon completion, click Close to 
close the Installation Complete dialog.

Uninstalling Telestream Audio
To uninstall the Telestream Audio driver, select ScreenFlow > Preferences > Advanced. 
Click the Uninstall Driver button and enter the password to uninstall the driver.

Deactivating Your ScreenFlow License
If you want to use your ScreenFlow license on another computer, you must deactivate it 
first. Then, you can activate the license in ScreenFlow running on another computer

Note: This topic does not apply to users who purchased from the Mac App Store. The 
App Store has its own installation and licensing procedure.
Your user must be an administrator. If your user is not an administrative account, you’ll 
need to create one (or log on with one) in order to continue.

To deactivate your ScreenFlow license, follow these steps: 

1. Start ScreenFlow.

2. Select ScreenFlow > Preferences and click the Licenses tab, as shown in Figure 101.
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Figure 101. Preferences Licenses Pane

3. Click the Lock icon at the bottom of the pane, and enter the password to your 
administrative account to allow ScreenFlow to make changes to your license.

4.  Click Deactivate to deactivate the license on this computer. Now, you can use the 
same license in ScreenFlow running on another computer. Please allow 15 minutes 
before trying to reactivate your license. 
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Removing ScreenFlow from Your Computer
To uninstall ScreenFlow, open the Applications folder and drag the ScreenFlow 
application to the trash. (The ScreenFlow license is stored separately, so you do not 
need to re-activate your license if you reinstall ScreenFlow.)

The files that you remove depend on the versions of ScreenFlow you have had on your 
computer. 

 Removing ScreenFlow Files Upgraded from Version 2.0

 Removing ScreenFlow Files Upgraded from Version 3.0

 Removing ScreenFlow Files from Version 4.0

Removing ScreenFlow Files Upgraded from Version 2.0
To completely remove ScreenFlow that has been upgraded from version 2.0, move 
these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow.plist

• ~/Library/Preferences/com.vara.screenflow.LSSharedFileList.plist

• ~/Library/Preferences/com.vara.screenflow.plist

• ~/Library/Preferences/com.vara.screenflowhelper.plist

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files Upgraded from Version 3.0
To completely remove ScreenFlow that has been upgraded from version 3.0, move 
these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/net.telestream.screenflowhelper.plist
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Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files from Version 4.0
To completely remove ScreenFlow that was installed (not upgraded from a previous 
version), move these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow.plist

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/WSG985FR47.net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.
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Index
Symbols
.scc file extension, for screencast files 34
.scc files, in project’s media folder 169

A
AAC audio 105
AAC, exporting 107
actions

adding 70
audio, configuring 79
configuring 70
curve type for 160
generally 69
screen recording, adding 82
screen recording, configuring 82

Actions menu 160
activating a license 140
activation

changing license 141
deactivation 141

Add Additional Recording window 35
Add Additional window, using for recording 38
add chapter track from markers 114
adding clips, methods 48
annotations properties 87
AppleTV, exporting video for 105
audio

enable/disable waveform 162
audio driver 176

uninstalling 176
audio filters 93
audio interface 169
audio meter 49

audio properties 79
smooth volume levels 81

audio recording, enabling 37
audio, muting 81
audio-only, exporting 105
axis rotation 78

B
background color 52
background, setting for closed captions 73

C
callout properties 84
callouts 84
canvas 49

arranging clips on 52
color 52
configuring 51
panning and zooming 50
snap to front window 52

canvas controls 51
caption clips 76
changing clip speed 59
changing license 141
chapters 114
chroma key filter, applying to video 96
clip

creating freeze frame from 61
cropping 53
trimming 57

clip speed, changing 59
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clips
adding to your project 47
adding, methods for 48
arranging on canvas 52
deleting 48

closed captioning 169
closed captions

exporting 76
generally 72
generating 76

codecs, configuring 106
compressing video 115
computer sound recording, enabling 37
configuring

actions 69
annotations properties 87
recording options 35
the canvas 51

copyright notice 3
countdown 136
countdown window 39
create or close timeline gap 57
creating 61, 63
creating or close gap 57
cropping 78

clip 53
image 53

curve type 160

D
deactivating license 141
delete media 102
deleting clips 48
diagnostic information, providing to Customer

Service 167
dictation, using to generate text 92
disk space required for recording 33
display recording, disabling 38
document, creating a new 40
drawing shapes 87
Dropbox, publishing to 125

E
Edit menu 149
edit window, toolbar for 49

editing
audio properties 79
callout properties 84
canvas 49
changing clip speed 59
create or close gap 57
create or close timeline gap 57
drawing shapes 87
freeze frame 61
group 60
image cropping 53
in and out points 58
lock clip 60
media library 99
positioning 78
scaling 53, 78
screen recording properties 82
split clip 57
text boxes 89
text properties 89
timeline 54
tour 24
tracks 55
transitions inspector 63
trim 57
video properties 77
window 45

editing ScreenFlow projects, generally 45
editing window

canvas 49
timeline 54
tracks 55

editor window 45
Elapsed time recording, setting up 36, 41
export

chapters 114
dimensions 113, 114
frame size 113, 114
manage 112
motion blur 114
presets

creating your own 112
resolution 113, 114
scale by 113
tour 30
video file size 115

export presets 105
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export settings 104
export settings, customizing 106
exporting

for iPad, iPhone, AppleTV, iPod devices 105
Lossless preset 105
lossless ProRes with Alpha 105
lossless, audio-only 105
MPEG-4 107
Web - High preset 105
Web - Low preset 105
WMV format 105
WMV with Flip4Mac 111

exporting a project, generally 103

F
Facebook, publishing to 129
Fast Start, setting for export 110
features, new 18
file formats, supported in ScreenFlow 47
File menu 145

save 147, 148
filters, using on audio and video media 93
Flash format, publishing in 130
Flip4Mac, using to export WMV 111
Font menu 158
freehand callouts, adding 86
freeze frame, creating 61

G
gap, creating or closing 57
GIF 47
Google Drive, publishing to 122
group 60

H
H.264 codec, exporting with 30, 76
H.264, exporting 107
Help menu 165

ScreenFlow Help 165
search 165
visit ScreenFlow support 165
visit ScreenFlow website 165

hide desktop icons 144

I
image

cropping 53, 78
opacity 78
reflection 78
scaling 53, 78
setting default duration 138
shadow 78

image formats, supported in ScreenFlow 47
importing media 99
in and out points 58
in points 58
Insert menu 157
installing 173
iPad, iPhone, iPod, AppleTV, exporting video

for 105
iPod, iPad, iPhone, recording not supported 169
iSight camera recording, enabling 37

J
JKL keystrokes, used in playback controls 49
JPEG 47

K
kerning 158
keys strokes, showing 84

L
licensing 140

change serial number 141
deactivation 141
upgrade 141, 174, 176

ligatures, creating 158
lock clip 60
Lossless format, exporting 105
Lossless ProRes with Alpha, exporting 105

M
Magic Trackpad 55
manual 165
markers 61

window 163
maximum frame size 42
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media library 99
add media 102
add recording 102
contact menu 101, 102
delete 102
preview 102
rename 101
zoom 101

media management 99
media, adding to your project 47
menu

Actions 160
Edit 149
File 145
Font 158
Help 165
Insert 157
Purchase 164
ScreenFlow 144
View 161
Window 163

motion blur 114
mouse pointer, showing 83
movies, making in ScreenFlow 19
MP4 105
MPEG-4, exporting 107
muting audio 81

N
narration 43
narrative screencasts, generally 43
nested clips 70
new features 18
normalize 81
notices, legal, generally 3

O
online Web store 15
opacity 78
out points 58

P
panning, on canvas 50
pausing recording 39
platform requirements 172
playback controls 49

PNG 47
position 78
preferences

capture scratch disk 139
countdown 136
general 136
installing/uninstalling audio driver 176
opening 144

Preferences panes, displaying 35
preset export settings 105
presets, customizing 106
preview media 102
properties

actions 69
annotations 87
audio 79
callout 84
screen recording 82
text 89
video 77

ProRes lossless with Alpha, exporting 105
publish

Dropbox 125
Facebook 129
Flash 130
Google Drive 122
to your Mac Web server 132
Vimeo 120
YouTube 116

publishing a project, generally 103
Purchase menu 164
purchasing 164

Q
QuickTime, configuring 107, 109
QuickTime, Flip4Mac plugin for 105
quit 145

R
Record Desktop from your Color LCD, disabling 38
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recording
adding to a project 40
automatically when you start ScreenFlow 40
capturing text 42
closing ScreenFlow before 38
configuring options 35
countdown window 39
generally 39
maximum frame size 42
pause hotkey 136
Preferences panes 35
start/stop hotkey 136
stopping, starting, resuming 39
stops when less than 100MB disk space 33
tips 42
tour 22
with Add Additional window 38
with ScreenFlow window 36
your computer display (screen/monitor) 36

recovering lost recordings 139
reflection 78
removing ScreenFlow 178
rename media 101
repositioning 78
Retina display, support for 42
rotation 78

S
Safari, using to download installer 173
save 147, 148
scaling

image 53, 78
scaling, clip 53
scratch disk 139
screen recording properties 82
screencast file, .scc extension 34
ScreenFlow

closing before recording 38
new features in 18
supported file formats 47
using in trial mode 18

ScreenFlow Helper 34, 39
disable 136
hide desktop icons 144
launch at user login 136

ScreenFlow menu 144
check for updates 144

ScreenFlow window, using for recording 36
scrub live audio 162
Set Timer button 36, 41
setting display resolution 42
shapes 87
slide shows, making in ScreenFlow 19
smooth volume levels 81
snapping 162
splitting a clip 57
starting recording 39
stopping recording 39
support 15, 165
supported file formats 47
system requirements 172

T
technical specifications 172
technical support 15, 165
Telestream

contacting 7
online Web store 15
sales and marketing 15
technical support 15
Web site 15

Telestream Audio 176
uninstalling 176

Telestream, contacting 15
text boxes 89
text properties 89
thumbnail icons 162
TIFF 47
timeline 54

changing clip speed 59
create or close gap 57
freeze frame 61
group 60
in and out points 58
lock clip 60
markers 61
scale 55
SMPTE timecode, displaying 137
split clip 57
tracks 55
trim 57
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timeline, zooming on 55
Timer button, setting 36, 41
tracks 55

setting default height 138
track controls 56

trademark notice 3
trademark notices 3
transitions 63

audio 69
setting default 138

transitions inspector 63
transparency 78
trial mode 18
trimming a clip 57
troubleshooting

audio interface 169
closed captioning 169
export video quality 167
graphics card 168
importing files 167
out of sync 169
Parallels 168
recording area 168
VMWare 168

U
uninstalling ScreenFlow 178
update 144
upgrade license 174, 176

V
version number, finding 144
video filters 93
video properties 77

cropping 78
opacity 78
position 78
reflection 78
scale 78
shadow 78
x rotation 78
y rotation 78
z rotation 78

video recording, enabling 37

View menu 161
scrub live audio 162
show audio waveform 162
show thumbnail icon 162
snapping 162

Vimeo, publishing to 120

W
Warranty and Disclaimers 6
Web - High export preset 105
Web - Low preset, exporting 105
Web server (Mac), publishing to 132
Web store, online Telestream 15
website 165
Window menu 163

markers 163
WMV format, exporting 105

X
x rotation 78
x264 codec, using to export MPEG-4 105

Y
y rotation 78
YouTube, publishing to 116

Z
z rotation 78
zooming, on canvas 50
zooming, on timeline 55
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