User’s Guide
Copyrights and Trademark Notices

Copyright © 2012 Telestream, Inc. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, altered, or translated into any languages without the written permission of Telestream. Information and specifications in this document are subject to change without notice and do not represent a commitment on the part of Telestream.

Telestream, Flip4Mac, FlipFactory, Episode, Telestream MAP, MetaFlip, GraphicsFactory, MotionResolve, ScreenFlow, and Split-and-Stitch are registered trademarks and Pipeline, Launch, Wirecast, Videocue, Drive-in, and Vantage are trademarks of Telestream, Inc.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. Copyright 2004 MainConcept Multimedia Technologies.


This product is manufactured by Telestream under license from Avid to pending patent applications.

This product is manufactured by Telestream under license from VoiceAge Corporation Dolby and the double-D symbol are registered trademarks of Dolby Laboratories.

SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Other brands, product names, and company names are trademarks of their respective holders, and are used for identification purpose only.

**MPEG Disclaimers**

**MPEGLA MPEG2 Patent**

ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM MPEG LA, LLC, 6312 S. Fiddlers Green circle, Suite 400E, Greenwood Village, Colorado 80111 U.S.A.

**MPEGLA MPEG4 VISUAL**

THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE HTTP://WWW.MPEGLA.COM.

**MPEGLA AVC**

THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM.

**MPEG4 SYSTEMS**

THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers

Telestream, Inc. (the Company) warrants to the original registered end user that the product will perform as stated below for a period of one (1) year from the date of shipment from factory:

**Hardware and Media.** The Product hardware components, if any, including equipment supplied but not manufactured by the Company but NOT including any third party equipment that has been substituted by the Distributor for such equipment (the “Hardware”), is free from defects in materials and workmanship under normal operating conditions and use.

**Software.** If software is supplied as part of the product, the software will operate in substantial conformance with specifications set forth in its product user’s guide. The Company does not warrant that the software will operate uninterrupted or error-free, will meet your requirements, or that software errors will be corrected.

Warranty Remedies

Your sole remedies under this limited warranty are as follows:

**Hardware and Media.** The Company will either repair or replace (at its option) any defective Hardware component or part, or Software Media, with new or like new Hardware components or Software Media. Components may not be necessarily the same, but will be of equivalent operation and quality.

**Software.** If software is supplied as part of the product and it fails to substantially conform to its specifications as stated in the product user’s guide, the Company shall, at its own expense, use its best efforts to correct (with due allowance made for the nature and complexity of the problem) such defect, error or nonconformity.

**Software Updates.** If software is supplied as part of the product, the Company will supply the registered purchaser/licensee with maintenance releases of the Company’s proprietary Software Version Release in manufacture at the time of license for a period of one year from the date of license or until such time as the Company issues a new Version Release of the Software, whichever first occurs. To clarify the difference between a Software Version Release and a maintenance release, a maintenance release generally corrects minor operational deficiencies (previously non-implemented features and software errors) contained in the Software, whereas a Software Version Release adds new features and functionality. The Company shall have no obligation to supply you with any new Software Version Release of Telestream software or third party software during the warranty period, other than maintenance releases.
Restrictions and Conditions of Limited Warranty

This Limited Warranty will be void and of no force and effect if (i) Product Hardware or Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, neglect, or shipping, or as a result of service or modification by a party other than the Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties

THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral or written information or advice given by the Company, its distributors, dealers or agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty. This limited warranty is valid only within the country in which the Product is purchased/licensed.

Limitations on Remedies. YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF TELESTREAM, INC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any Limited Warranty by the Company shall be the recovery of reasonable damages which, in the aggregate, shall not exceed the total amount of the combined license fee and purchase price paid by you for the Product.

Damages

TELESTREAM, INC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, Inc.
848 Gold Flat Road, Suite 1
Nevada City, CA 95959
You can call Telestream, Inc. via telephone at (530) 470-1300.
Contents

Preface 1
Obtaining Support | Information | Assistance 1
ScreenFlow FAQs, Forums & Upgrades 1
Company and Product Information 1
Mail 1
International Telestream Distributors 1
We’d Like to Hear From You! 1

About ScreenFlow 17
Record. Edit. Share. 17
Using ScreenFlow in Trial Mode 17
What’s New in ScreenFlow 18
Unlocking ScreenFlow (Telestream Web Store Only) 20
  • Purchasing ScreenFlow Directly in the Application 20
  • Activating Your License 21

Getting Started 17
Tour 1 – Recording With ScreenFlow 18
  • Configuring Your Recording 18
  • Beginning Your Recording 18
Tour 2– Editing Your Screencast 20
  • The Editing Window 20
  • Cropping 21
    • Canvas Cropping 22
    • Image Cropping 22
  • Actions 22
  • Video Properties 22
  • Screen Recording Properties 23
  • Callout Properties 24
  • Media Library 25
Tour 3– Exporting Your Screencast 26
  • Publish to YouTube/Vimeo/Flash 27
Recording Presentations 17

Configuring ScreenFlow Helper Recording Options 17
   Using the Configure Recording Window 17
   Using the Countdown Window 18
Using ScreenFlow Helper 19
   ScreenFlow Helper Menu 19
Adding A Recording 21
   Add Additional Recording (Shift-Command-R) 21
Preference Options for Recording 22
   General 22
   Advanced 22
Recording Tips 23
   Set Your Display Resolution 23
   Using Text 23
   Considerations for Narrative Demonstrations 23
      Record Everything at Once 24
      First Record Your Monitor, Then Add Narration 24

Editing ScreenCasts 17

Editing Window Overview 18
   Canvas Panel 18
   Timeline Panel 19
   Properties Panel 19
Using the Canvas Panel 19
   Configuring the Canvas 21
   Configuring Clips in your Screencast 21
      Scaling a Clip 22
      Cropping a Clip 22
      Rotating a Clip 22
Using the Timeline Panel 22
   Scale 23
   Tracks 23
      Using Track Controls 23
   Trimming Clips 24
      Splitting a Clip 24
      Trimming a Clip 24
Creating and Closing Gaps in a Track 24
Creating and Closing Gaps in the Timeline 25
Creating and Using In and Out Points 25
Changing a Clip’s Play Speed 26
Grouping a Set of Clips 26
Locking a Clip 26
Creating a Freeze Frame 26
Adding Markers 27
Transitions 27
   Adding Transitions 27
Contents

Transitions Inspector  27
Audio Transitions  28
Actions  28
  Adding an Action  28
Video Properties  29
Audio Properties  32
Screen Recording Properties  34
Callout Properties  36
Annotations Properties  38
Text Properties  39
Media Library  42

Publishing Your Screencast  17

Exporting Your Video  17
  Exported Video File Size Considerations  20
    Reducing your Video File Size  20
    Reducing the Frame Rate  20
Customizing Codec Settings  21
  QuickTime Customization  21
  Flip4Mac Customization  22
Publishing to YouTube  24
  Logging In  24
  Settings  25
Publishing to Vimeo  25
  Setting up your account  26
  Verify account  28
  Vimeo Settings  29
Publishing to Flash  29
  How to Publish Your video to a Local Web Server  31

Preferences  17

General Pane  17
Timeline Pane  18
Advanced Pane  19
Licenses (Telestream Web Store Only)  20
  Licensing ScreenFlow  20
  Changing and Deactivating a Serial Number  21

Using ScreenFlow Menus  17

ScreenFlow Menu  17
  About ScreenFlow  17
  Check For Updates  17
  Preferences (Command-)  18
  Services  18
  Hide ScreenFlow (Command-H)  18
Contents

Hide others (Alt-Command-H) 18
Show All 18
Quit ScreenFlow (Command-Q) 18

File Menu 18
New Recording (Command-N) 18
New Empty Document (Shift-Command-N) 18
Open (Command-O) 18
Open Recent 19
Add Additional Recording (Shift-Command-R) 19
Close (Command-W) 19

OS X Lion Save Commands 19
Save a Version (Command-S) 19
Duplicate 19
Revert to Saved 19

OS X Snow Leopard Save Commands 19
Save (Command-S) 19
Save As (Shift-Command-S) 20
Publish to YouTube 20
Publish to Vimeo 20
Publish to Flash 20
Export (Command-E) 20

Edit Menu 20
Undo (Command-Z) 20
Redo (Shift-Command-Z) 20
Cut (Command-X) 20
Copy (Command-C) 21
Paste (Command-V) 21
Paste Properties 21
Paste and Match Style (Alt-Shift-Command-V) 22
Select All (Command-A) 22
Deselect All (Shift-Command-A) 22
Split Clip (T) 23
Detach Audio 23
Add Freeze Frame (Shift-Command-F) 24
Trim Front to Scrubber (W) 24
Trim End to Scrubber (E) 24
Lock Clip/Unlock Clip (Alt-Command-L) 25
Add Starting Transition/Remove Starting Transition 25
Add Ending Transition/Remove Ending Transition 25
Ripple Delete (Command-Backspace) 25
Mark In Point (I) 25
Mark Out Point (O) 25
Clear In & Out Points 25
Markers 26
Special Characters (Alt-Command-T) 26

Insert Menu 26
Text Box 26
Speech Clip 26
Choose (Shift-Command-V) 27

Font Menu 27
  Show Fonts (Command-T) 27
  Bold (Command-B) 27
  Italic (Command-I) 27
  Underline (Command-U) 27
  Bigger 27
  Smaller 27
  Kern 27
  Ligature 28
  Copy Style 28
  Paste Style (Alt-Command-V) 28
  Make Text Properties Default 28

Actions Menu 28
  Add Video Action (Command-K) 28
  Add Audio Action (Alt-Command-U) 29
  Add Screen Recording Action (Command-R) 29
  Add Callout (Command-L) 29
  Add Annotations (Alt-Command-T) 29
  Goto Next Action 29
  Goto Previous Action 29
  Curve Type 29

View Menu 30
  Enter Full Screen (Command-F) 30
  Enter Preview (Alt-Command-F) 30
  Zoom In (Command-=) 30
  Zoom Out (Command-- ) 30
  Zoom to 100% (Alt-Command-0) 30
  Zoom to Fit 30
  Zoom Timeline to Fit (Control-T) 30
  Zoom Timeline In (=) 30
  Zoom Timeline Out (-) 30
  Snapping (Control-N) 31
  Scrub Live Audio (Shift-S) 31
  Show Audio Waveform 31
  Show Thumbnail Icons 31

Window Menu 31
  Minimize (Command-M) 31
  Zoom 31
  Markers 31
  Bring All to Front 32
  Documents 32

Purchase Menu (Telestream Web Store Only) 32
  Purchase ScreenFlow Online 32
  Unlock ScreenFlow 32

Help Menu 32
  Search 32
  ScreenFlow Help (Command-?) 33
Troubleshooting 17

Installing ScreenFlow 17

System Requirements 17
Installing ScreenFlow 18
Upgrading ScreenFlow 19
Installing Telestream Audio 19
  Uninstalling Telestream Audio 19
Removing ScreenFlow from Your Computer 20
Figures

About ScreenFlow 17
Figure 1  Preferences Licenses Pane (Unlicensed)  20
Figure 2  Enter Your Serial Number To Unlock Screenflow  21

Getting Started 17
Figure 3  Screenflow Recording Window  18
Figure 4  Editing Window  20
Figure 5  Canvas Controls  21
Figure 6  Video Properties Action  22
Figure 7  Video Properties  23
Figure 8  Screen Recording Properties  24
Figure 9  Callout Properties  25
Figure 10  Export Settings Window  26

Recording Presentations 17
Figure 11  Configure Recording Window  18
Figure 12  Countdown Window  19
Figure 13  Use the Recording Complete Dialog to Save your Clip  21
Figure 14  Add Additional Recording Window  21

Editing ScreenCasts 17
Figure 15  Editing Window  18
Figure 16  Canvas Controls  20
Figure 17  Canvas Panel Without any Content in Project.  21
Figure 18  Arranging and Adjusting Clips in the Canvas Panel  22
Figure 19  Timeline Displays Project Length and all Media Clips  23
Figure 20  Timeline Magnification Slider  23
Figure 21  Use Track Controls to Adjust Track Height  24
Figure 22  Mark In and Out Points on Timeline  25
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>23</td>
<td>Speed Change Icons</td>
<td>26</td>
</tr>
<tr>
<td>24</td>
<td>Locked and Unlocked Clips</td>
<td>26</td>
</tr>
<tr>
<td>25</td>
<td>Creating a Freeze Frame</td>
<td>27</td>
</tr>
<tr>
<td>26</td>
<td>Transitions Inspector Window</td>
<td>28</td>
</tr>
<tr>
<td>27</td>
<td>Video Properties Action</td>
<td>29</td>
</tr>
<tr>
<td>28</td>
<td>Video Properties</td>
<td>30</td>
</tr>
<tr>
<td>29</td>
<td>Audio Properties</td>
<td>32</td>
</tr>
<tr>
<td>30</td>
<td>Audio Clip in Timeline</td>
<td>33</td>
</tr>
<tr>
<td>31</td>
<td>Screen Recording Properties</td>
<td>34</td>
</tr>
<tr>
<td>32</td>
<td>Callout Properties</td>
<td>36</td>
</tr>
<tr>
<td>33</td>
<td>Annotations Properties</td>
<td>38</td>
</tr>
<tr>
<td>34</td>
<td>Text Box on Canvas</td>
<td>39</td>
</tr>
<tr>
<td>35</td>
<td>Text Clip on Timeline</td>
<td>39</td>
</tr>
<tr>
<td>36</td>
<td>Text properties</td>
<td>40</td>
</tr>
<tr>
<td>37</td>
<td>Media Library</td>
<td>42</td>
</tr>
</tbody>
</table>

**Publishing Your Screencast** 17

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>38</td>
<td>Export Settings Window</td>
<td>18</td>
</tr>
<tr>
<td>39</td>
<td>Manage Presets Window</td>
<td>19</td>
</tr>
<tr>
<td>40</td>
<td>Dimensions: Scale to Custom Size Settings</td>
<td>19</td>
</tr>
<tr>
<td>41</td>
<td>QuickTime Compression Window</td>
<td>21</td>
</tr>
<tr>
<td>42</td>
<td>Flip4Mac Compression Window</td>
<td>23</td>
</tr>
<tr>
<td>43</td>
<td>YouTube Account Login Window</td>
<td>24</td>
</tr>
<tr>
<td>44</td>
<td>YouTube Details Window</td>
<td>25</td>
</tr>
<tr>
<td>45</td>
<td>Vimeo Log In Window</td>
<td>26</td>
</tr>
<tr>
<td>46</td>
<td>Vimeo Account Window</td>
<td>26</td>
</tr>
<tr>
<td>47</td>
<td>Join Vimeo Window</td>
<td>27</td>
</tr>
<tr>
<td>48</td>
<td>Vimeo Authorization Window</td>
<td>28</td>
</tr>
<tr>
<td>49</td>
<td>Vimeo Account Verification Window</td>
<td>28</td>
</tr>
<tr>
<td>50</td>
<td>Vimeo Settings Window</td>
<td>29</td>
</tr>
<tr>
<td>51</td>
<td>Flash Settings Window</td>
<td>30</td>
</tr>
</tbody>
</table>

**Preferences** 17

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>52</td>
<td>Preferences General Pane</td>
<td>17</td>
</tr>
<tr>
<td>53</td>
<td>Preferences Timeline Pane</td>
<td>18</td>
</tr>
<tr>
<td>54</td>
<td>Preferences Advanced Pane</td>
<td>19</td>
</tr>
<tr>
<td>55</td>
<td>Preferences Licenses pane (unlicensed)</td>
<td>21</td>
</tr>
<tr>
<td>56</td>
<td>Preferences Licenses Pane (Licensed)</td>
<td>21</td>
</tr>
</tbody>
</table>

**Using ScreenFlow Menus** 17

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>57</td>
<td>Timeline just prior to a clip paste operation</td>
<td>21</td>
</tr>
<tr>
<td>58</td>
<td>Timeline after pasting a clip from the clipboard</td>
<td>21</td>
</tr>
</tbody>
</table>
Figure 59  Mark In and out points on your timeline  22
Figure 60  Delete the assets between the in and out points  22
Figure 61  Timeline before splitting a clip  23
Figure 62  Timeline after splitting a clip  23
Figure 63  Timeline just prior to a clip Detach Audio operation  23
Figure 64  Timeline after detaching audio from a clip  23
Figure 65  Timeline just prior to a Add Freeze Frame operation  24
Figure 66  Timeline after detaching audio from a clip  24
Figure 67  Markers window  32
Figure 68  Clip contact menu  33
Figure 69  Clip Inspector  34

Installing ScreenFlow 17
Figure 70  Installing ScreenFlow  18
Obtaining Support | Information | Assistance
Web Site: http://www.telestream.net/telestream-support/screen-flow/support.htm
Support Email: desktopsupport@telestream.net

ScreenFlow FAQs, Forums & Upgrades
Web Site: http://www.telestream.net/telestream-support/screen-flow/support.htm

Company and Product Information
For information about Telestream or its products, please contact us via:
Web Site: www.telestream.net
Online Store: www.telestream.net/purchase/store.htm
Sales and Marketing Email: info@telestream.net

Mail
Telestream, Inc.
848 Gold Flat Road
Nevada City, CA. USA 95959

International Telestream Distributors
See the Telestream Web site at www.telestream.net for your regional authorized Telestream distributor.

We'd Like to Hear From You!
If you have comments or suggestions about improving this document, or other Telestream documents – or if you’ve discovered an error or omission, please email us at techwriter@telestream.net.
About ScreenFlow

This guide is designed to help you understand how to use each feature in ScreenFlow, and also to provide hints, tricks, and other information to help you make the best presentations possible.

Record. Edit. Share.

Telestream ScreenFlow is powerful, easy-to-use screencasting software for Mac users. With ScreenFlow, you can record the contents of your entire monitor while also capturing your video camera, microphone, and your computer audio.

After capturing your video and audio, you can use ScreenFlow’s video editing tools to edit and publish your presentation. You can publish your presentation as a QuickTime or Windows Media movie as well as publish directly to YouTube or Vimeo.

Using ScreenFlow in Trial Mode

Until you unlock ScreenFlow by purchasing a license and activating it, ScreenFlow operates in trial mode. In trial mode, all of ScreenFlow’s features are available, but your presentations are water-marked. To unlock ScreenFlow, go to Unlocking ScreenFlow (Telestream Web Store Only).

Topics
- Record. Edit. Share.
- Using ScreenFlow in Trial Mode
- What’s New in ScreenFlow
- Unlocking ScreenFlow (Telestream Web Store Only)
What’s New in ScreenFlow

This version of ScreenFlow has added many new features to improve upon the capabilities and user experience of the program. New features include:

- **New Document**
  - You can open a new, untitled ScreenFlow document without starting a recording
- **Full-screen preview mode**
- **Freehand Callouts**
  - Draw directly onto your screen recordings to call out specific regions of the screen with a paint brush tool
  - Blur the content you are calling out
  - Add shadow options to your callouts
  - Build callout in and out
  - Callouts can have a default style set (through the Action Gear menu)
- **Video Annotations**
  - Draw circles, squares, lines and arrows over your video content
  - Adjust the size, color, position, shadow and thickness
  - Save default annotation styles
- **Improved Timeline features**
  - Timeline preferences including default timeline height, default duration of still image, and use of SMPTE timecode
  - Reorder tracks
  - Resize height of tracks
  - Easily delete tracks
  - Insert space or gaps in the timeline
  - Select gaps between clips and remove them
  - Set duration of transitions durations through the inspector
  - Preview and customize transitions
  - Group and ungroup clips
  - Jump to marker in timeline from the Markers window
  - Added ability to select all clips on a track by double-clicking track sidebar or clip context menu
- **Media Library improvements**
  - Preview video and audio in your media library
  - Resize library items in the media library
• Audio improvements
  – View audio waveforms and clipped audio peaks directly in the timeline and see effects & volume changes directly.
  – Smooth volume levels (combines limiting, compression and more) throughout your clips
  – Convert your text to synthesized speech

• Export improvements
  – Create and save your own export presets
  – See estimated time remaining in export
  – Export to iPad with iPad preset
  – Export high performance lossless audio only with preset
  – Save your files to Recent Places from the Export Window
  – Publish directly to Vimeo
  – Choose letterbox option in the YouTube publishing window
  – 720p and 1080p support for YouTube publishing
  – Full integration with the Elgato Turbo H.264 device

• Video canvas improvements
  – Use cursor keys to move video clips around the canvas
  – Set exact position for a clip by entering the coordinates in the inspector
  – Change background color of your canvas
Unlocking ScreenFlow (Telestream Web Store Only)

Note: If you purchased ScreenFlow through the Mac App Store, the License tab does not display. The Mac App Store has its own licensing and updating processes.

To unlock ScreenFlow and activate its features, you must purchase and install a license.

Purchasing ScreenFlow Directly in the Application

The easiest way to purchase and activate ScreenFlow is to directly in the application:

Step 1 Launch ScreenFlow.
Step 2 Select Purchase > Purchase ScreenFlow Online to display the License pane.

Figure 1. Preferences Licenses Pane (Unlicensed)

Note: If ScreenFlow doesn’t display a Purchase License button, then you have already registered ScreenFlow.

Step 3 Click the Lock icon at the bottom of the panel, and enter your password to allow ScreenFlow to make changes to your license.

Note: Your user must be an administrator. If your username is not an administrative account, you’ll need to create one in order to continue.

Step 4 Click the Purchase License button to go to the Telestream online store and purchase a license.
Step 5 When the purchase is complete, the ScreenFlow license installs automatically.
Activating Your License

If you have already purchased a license through the Telestream Web Store, Telestream sent you an email receipt containing your license key.

**Note:** If your Macintosh is not connected to the Internet, follow the instructions in the Manual Activation Guide (www.telestream.net/pdfs/user-guides/Manual_Activation_Guide.pdf) to activate your license and unlock ScreenFlow.

The easiest way to register and activate ScreenFlow is to click on the link provided in your email receipt. If this link doesn’t work, register ScreenFlow as follows:

**Step 1** Launch ScreenFlow.

**Step 2** Select Purchase > Unlock ScreenFlow to display the License pane.

**Note:** If ScreenFlow doesn’t display a Purchase menu, then you have already registered and unlocked ScreenFlow.

**Step 3** Click the Lock icon at the bottom of the panel, and enter your password to allow ScreenFlow to make changes to your license.

**Note:** Your user must be an administrator. If your username is not an administrative account, you’ll need to create one in order to continue.

**Step 4** Click Enter Serial Number and enter the license key into the license key field:

**Figure 2.** Enter Your Serial Number To Unlock Screenflow

**Step 5** Click Activate to activate your serial number and unlock ScreenFlow.

**Note:** If the Activate button is dimmed, it means that the license is invalid. Double-check your license from the e-mail. Make sure that all letters are capitalized, dashes are included, and all 0’s are zeros, not the letter O. It may also help to copy and paste your serial number from your e-mail, but be careful not to copy any additional text such as a space. If you are still having problems, please contact technical support.

**Step 6** Now your serial number is activated and ScreenFlow is unlocked. Close the Preferences window to continue.
About ScreenFlow
Unlocking ScreenFlow (Telestream Web Store Only)
Getting Started

These tours are designed to introduce you to the features and capabilities of ScreenFlow.

We encourage you to take these tours before beginning a project. They help you to gain a basic understanding of how ScreenFlow works and help to familiarize yourself with the program.

Every ScreenFlow project is a three step process: first you record your presentation, next you edit your screencast, and finally you export your screencast to a video file or publish it directly to an Internet video service such as YouTube and others.

For video tutorials, please visit our ScreenFlow demos page.

**Tours**

- Tour 1 – Recording With ScreenFlow
- Tour 2 – Editing Your Screencast
- Tour 3 – Exporting Your Screencast
Tour 1 – Recording With ScreenFlow

When launching the program, ScreenFlow displays a Configure Recording window.

Figure 3. Screenflow Recording Window

Before you create your first screencast, take a moment to consider ways of approaching the process.

This first tour focuses on creating a high quality recording for editing and publishing. When creating a screencast, it is important to prepare your recording properly while considering how you intend to use this screencast later in your workflow.

We recommend that you create at least one sample recording to familiarize yourself with the program before creating your intended screencast.

Configuring Your Recording

Use the Configure Recording window to specify your recording sources. This automatically opens when you launch the application, but it can also be accessed from ScreenFlow Helper > Configure Recording… or File > New Recording.

Record Desktop from. This option records your computer display. This source records by default and cannot be deselected. If you have multiple displays connected, you can choose between them. ScreenFlow cannot record multiple displays simultaneously.

Record Video from. This option records video from any camera connected to your computer. Use the dropdown menu to choose from multiple cameras. Upon selecting a source, a preview image displays below.

Record Audio from. This option records from any microphone connected to your computer. Use the dropdown menu to choose from multiple microphones. Upon selecting the source, the volume level is displayed below.

Record Computer Audio. Choose this option to record all sounds played through your computer. The ScreenFlow audio driver must be installed to use this setting. If the driver is not installed, you are prompted to install it.

Beginning Your Recording

When you are ready, click the Record button. ScreenFlow enters a countdown mode before recording. You can change the length of this countdown (see Using the Countdown Window).
Create a short presentation then stop your recording: press Shift-Command-2 or select Stop Record from the ScreenFlow Helper menu in the upper-right corner of your monitor. For more details, see Using ScreenFlow Helper.

When you stop recording, ScreenFlow opens your recording in the ScreenFlow editing window with all of your recorded sources placed in the timeline.

Monitor video and computer audio are combined into one clip; camera video and microphone audio are combined in another clip, to maintain video/audio sync. Video and audio can be separated by selecting the clip and choosing Edit > Detach Audio.
Tour 2– Editing Your Screencast

The purpose of this tour is to familiarize you with the basic editing features of ScreenFlow. This tour describes some of the most common and basic editing techniques.

For a comprehensive description of editing features, see Editing ScreenCasts.

When you finish your recording, ScreenFlow creates a new document and recorded material is placed at the beginning of the timeline. All media in the timeline is referenced to your project’s stored media. Changes made in the timeline or on the canvas do not alter your original recording.

The Editing Window

The space used for editing is the editing window, which consists of three main panels.

**Figure 4.** Editing Window

Canvas

The large, central area of the editing window is called the canvas. This offers a preview of all content in your screencast. The gray space around the preview is for content that will not be present in your exported video. This is used to display off-screen content present in scaling or pan effects. The content displayed on the canvas reflects the position of the scrubber on the timeline.
You can set the canvas size and background color using the canvas controls (see Configuring the Canvas).

**Timeline**

The wide area at the bottom of the screen is the timeline. This is a visual representation of the temporal length of your screencast. The scale at the top of the timeline represents measurements of time.

The red vertical line on the timeline is called the *scrubber*. This represents the current temporal position of the preview currently displayed on the canvas.

The timeline is divided into tracks to manage different clips overlapping at the same time. If the clip is visual (i.e. video, image, or text), the upper most track is displayed over the lower tracks.

Between the canvas and the timeline are playback controls to play your screencast as well as jump to the beginning or end of your screencast.

**Properties**

On the upper-right side of the editing window are the Properties tabs. These are the main editing controls of ScreenFlow and allow you to configure each clip in your screencast. It also includes the media library which stores all recorded and imported media in an unaltered state.

For more information, see the Properties topics in Editing ScreenCasts.

**Cropping**

ScreenFlow provides two different types of cropping.

*Figure 5. Canvas Controls*
Canvas Cropping

Canvas cropping is used to change the resolution or aspect ratio of the workspace you have to edit in. This can be useful if you want to constrain your screencast to only a portion of the total recording (i.e. a foreground window).

Canvas cropping is accessible through the canvas control button. This is set by numerically entering the width and height values or dragging the edge of the canvas with your mouse cursor.

The canvas cannot be set to a value larger than the original recording. Remember, the canvas size represents your total usable display space, which converts to the frame size of your video when you export or publish it.

Image Cropping

Image cropping is useful for removing content from the edge of a visual clip. Unlike canvas cropping, image cropping does not limit your workspace but simply alters the content of video or image material.

To crop an image, select the video or still image presented on your canvas. This highlights the image and place handles on the sides. Hold the Control key and drag the edge of the image to crop it.

Actions

Actions are property changes used to transition the media from one state to another. Actions are added to a clip by selecting the clip, opening the property that you want to alter, then clicking the Add Action button at the bottom of the properties pane. The action is placed in relation to the position of the scrubber, but can be moved on the clip. The duration of the action is changed by dragging the edge of the action to lengthen or shorten the action.

Figure 6. Video Properties Action

Place the scrubber before or after the action to make changes to the property relative to the action. When the scrubber is placed before the action, this sets the properties of the clip before the action. When the scrubber is placed after the action, this sets the properties of the clip after the action.

Video Properties

Video properties can be used to make changes to any recorded or imported video or image file. This includes both screen and camera recordings.

This tour focuses on the most common features. For more details, see Video Properties.
Figure 7. Video Properties

**Scale.** Use this option to change the size of a video or image relative to the size of the canvas. This can be used for highlighting a particular portion of the screen or with a video action to create a zoom effect.

Use the slider or enter a percentage value to change the image scale.

**Position.** Position represents the location of your video or image on the canvas. The position is based on the exact placement of the center of your image. Values in the position field are represented in pixels.

You can reposition the image by dragging the image on the canvas, nudging the image with the arrow keys, or entering a numerical value in the position fields.

**Opacity.** This is the degree to which the image is translucent. The greater the value, the more opaque the image. If the value is set to zero, the image is invisible.

This is used with a video action to fade an image in or out. It is particularly useful if you would like to periodically display your camera recording.

**Screen Recording Properties**

Screen recording properties are effects specific to demonstrations using the mouse and keyboard. They can only be applied to screen recording clips.

This tour focuses on the most common features. For more details, see Screen Recording Properties.
Figure 8. Screen Recording Properties

**Pointer Zoom.** Often it can be difficult to see the mouse in a screencast, particularly if the video has been significantly resized. Increasing the pointer zoom value makes the mouse cursor larger and easier for the viewer to follow.

**Click Effect.** This feature can be used to make a visual effect when you click your mouse. Select Radar to project a red circle with each click or Invert to change the cursor from black to white with each click.

**Sound on Click.** Select this option to generate a click sound when the mouse button is pressed.

**Show Keys Pressed.** Select this option to display the text as you were typing it while recording.

**Show Modifier Keys Pressed.** Select this option to display modifiers used in hotkey commands, F1 through F12, and the arrow keys.

**Callout Properties**

Callout Properties are used to highlight a specific portion of the screen. They can only be applied to screen recordings. Unlike the other properties, Callout Properties must be used with an action.

This tour focuses on the most common features. For more details, see Callout Properties.
Figure 9. Callout Properties

Highlight. Callouts are capable of highlighting an area in three different ways. Mouse cursor highlights a circular space around the mouse cursor. Foreground Window highlights any window which is currently active. Freehand allows you to draw the area you want to highlight.

Opacity. The opacity slider controls the opacity of the space outside the callout. A low value makes the surrounding area opaque while a high value makes the surrounding area invisible.

Zoom Up. This option magnifies the area inside the callout to make it more prominent.

Border. This option increases the range of the callout area to draw attention to a larger space. This feature is not available with freehand callouts.

Media Library

The media library stores all recorded and imported media in an unaltered state. This material may be dragged to your timeline or canvas for editing. You may drag this content into your project multiple times to copy the same material.

For more information, see Media Library.
Tour 3– Exporting Your Screencast

The purpose of this tour is to familiarize you with exporting your screencast. Screencast projects are not video files – they are saved as Screenflow documents (with a screenflow extension), which can only be opened and used by ScreenFlow.

There are two ways to publish your screencasts – by exporting them to a standard video file format (QuickTime or Windows Media) or publishing them directly to an Internet video service, like YouTube.

Determining the correct export settings for your screencast depends on the complexity of your screencast and the intended use of the video after it has been produced.

This tour explores the basics of ScreenFlow’s export options. For a comprehensive description, see Publishing Your Screencast.

Select File > Export or press Command-E to export your presentation:

Figure 10. Export Settings Window

Save As. Choose a name for your exported video (default: ScreenFlow.mov).

Where. Choose a location to export your video.

Preset. ScreenFlow has several export presets for your convenience. This tour focuses on the most commonly used presets. For more information, see Preset.

- **Web - High.** This is the default export option which encodes using the H.264 codec. It was chosen as the default codec based on both image quality and file size.
- **Web - Low.** This is an export option similar to Web - High, but formatted for a low bandwidth. It plays more smoothly on slow internet connections but the image quality is not as good as Web - High.
- **Lossless.** This is an uncompressed export format ideal for additional editing. This format has the highest quality image but also the largest file size. When exported at 100%, the image quality is identical to the original recording.

iPad / iPhone / Apple TV / iPod. These export options are formatted based on the recommended video specifications for these devices. They cannot be altered.
**Windows Media.** This option exports a video in the WMV format. This is a popular format for Windows users. This option uses a QuickTime plugin called Flip4Mac which must be licensed separately.

**Dimensions**

These options are used to set the dimensions of your video export. You should not set a size larger that your canvas size. This does not improve image quality.

*Scale by.* Use this option to scale your project by a percentage value. This is an easy way to shrink your screencast while maintaining the aspect ratio.

*Scale to custom size.* Use this option to set the exact width and height of your exported video. Click the Letterbox Content box to add letterboxing to your export.

**Publish to YouTube/Vimeo/Flash**

In addition to encoding a video file, ScreenFlow can also publish screencasts directly to YouTube, Vimeo, and Flash. These options are accessible from the File menu.

For more information, see [Publishing to YouTube](#), [Publishing to Vimeo](#), and [Publishing to Flash](#).
Recording Presentations

The first step in creating a screencast is to record your media. This topic guides you through the process of recording, and describes your recording options.

**Note:** ScreenFlow automatically stops recording when you have less than 100 megabytes free on your system disk volume.

**Topics**
- Configuring ScreenFlow Helper Recording Options
- Using ScreenFlow Helper
- Adding A Recording
- Preference Options for Recording
- Recording Tips

**Configuring ScreenFlow Helper Recording Options**

Each time you start ScreenFlow, ScreenFlow also launches ScreenFlow Helper (the menu is displayed in the automatically displays the Configure Recording window to help you begin recording media for your screencast. You can also display the Configure Recording window from ScreenFlow Helper > Configure Recording or select File > New Recording.

When you stop recording, you can add these new clips to a new document, or you can add them to one of the topmost ScreenFlow documents that are already open. If this is the first recording session, ScreenFlow starts a new recording project and displays a new, untitled ScreenFlow document. (To add subsequent recordings, see Adding A Recording.)

**Using the Configure Recording Window**

Use the Configure Recording window to select recording options and start recording media.
Recording Presentations
Configuring ScreenFlow Helper Recording Options

**Figure 11.** Configure Recording Window

![Configure Recording Window](image)

**Record Desktop from.** Check this option to record your computer monitor. This source records by default and cannot be deselected. If you have multiple displays connected, you can choose between them. ScreenFlow cannot record multiple monitors simultaneously.

Desktop video and audio is combined into a single clip, and added to your project as a ScreenFlow file.

**Record Video from.** Check this option to record video from any camera connected to your computer. Use the dropdown menu to choose from multiple cameras. Upon selecting a source, a preview image is displayed below.

**Record Audio from.** Check this option to record audio from any microphone connected to your computer. Use the dropdown menu to choose from multiple microphones. Upon selecting the source, the volume level is displayed below.

Desktop video and audio is combined into a single clip, and added to your project as a QuickTime movie file.

**Record Computer Audio.** Choose this option to record all sounds played through your computer. The ScreenFlow audio driver must be installed to use this setting. If the driver is not installed, you are prompted to install it (see Installing Telestream Audio).

**Record.** Click the red button - the Record icon – to display the countdown window and begin recording.

When you have finished recording, video and audio sources are combined to maintain video/audio sync. Desktop video is combined with computer audio and camera video is combined with microphone audio. You can separate these clips using the Edit > Detach Audio command.

**Using the Countdown Window**

Each time you start recording, ScreenFlow displays the countdown panel, providing a delay to allow you to prepare yourself for recording:
By default, the countdown is set to 5 seconds. To change the countdown option (or enable or disable it), select > Preferences > General. You can set the countdown delay for up to ten seconds.

To skip the countdown, simply click on the countdown window and ScreenFlow begins recording immediately.

Using ScreenFlow Helper

ScreenFlow utilizes a background application – ScreenFlow Helper – to manage various aspects of your recording. The ScreenFlow Helper menu is located on the right side of the menu bar at the top of the display. To monitor the status of your recording, select the ScreenFlow Helper menu located on the right side of the menu bar.

ScreenFlow Helper Menu

The ScreenFlow Helper menu contains the following items:

**Record/Stop Record (Shift-Command-2)**. Select to begin recording using the most recently selected sources (display, camera, microphone, and/or computer audio). The menu icon changes from

![Record Icon]

To

![Stop Record Icon]

To advise you that ScreenFlow is recording.

Select Stop Record or press Shift-Command-2 again, to stop the recording.

**Pause/Resume**. Select Pause to pause the recording. Resume recording by selecting Resume.

(You can modify the hotkey for these commands **(General Pane)**.
Configure Recording… Displays the Configuring ScreenFlow Helper Recording Options window for setting recording parameters.

Hide Desktop Icons/Show Desktop Icons. You can hide all icons on your Desktop if you prefer to have a less cluttered background to your screen recording. You can show them again when you need to interact with your Desktop.

Quit ScreenFlow. Select to close the ScreenFlow and ScreenFlow Helper applications.
Adding A Recording

When you have finished your recording, the clips that you have recorded are automatically opened in a new document. If you already have a document open, you are given the option of creating a new document or adding your recording to an existing document.

Figure 13. Use the Recording Complete Dialog to Save your Clip

If you have accidentally created a new document when you intended to add the recording to an existing document, just drag your recording into the previous document's canvas, timeline, or Media Library. This duplicates the recording in the other document’s project folder.

Add Additional Recording (Shift-Command-R)

To add a recording to your document, you may simply create a new recording, in which case you receive notification (as illustrated above) or you may choose Add Additional Recording. This may be selected from the File menu or the Media Library.

The Add Additional Recording dialog has options similar to the Configuring ScreenFlow Helper Recording Options window.

Figure 14. Add Additional Recording Window

The differences are the option to deselect desktop recording and close ScreenFlow before recording.
Preference Options for Recording

Several options relate to ScreenFlow recording. To view and change ScreenFlow preferences, select ScreenFlow > Preferences.

General

Show ScreenFlow options in Menu Bar. Check to enable the ScreenFlow Helper menu (the video camera icon) in the Finder menu. By default, this option is checked.

Countdown for [x] secs before recording. Check to enable the Countdown window, and set the delay (1 to 10 seconds) between when you press record and when ScreenFlow begins recording. This is used to prepare yourself for your demonstration. By default, the countdown is set to 5 seconds. You can set the countdown delay for up to ten seconds.

Launch ScreenFlow Helper at user login. Select this option to have ScreenFlow Helper available when you log on to your user account. By default, this option is off.

Recording Hotkey. This is a shortcut command used for both starting and stopping your recording. By default, this option is set to Shift-Command-2. When setting a custom hotkey, it is important to choose a command which is not in use by other programs.

Pause Hotkey. This is a shortcut command used for both pausing and resuming your recording. By default, this option is not set. When setting a custom hotkey, it is important to choose a command which is not in use by other programs.

Advanced

Screen Recording Compression. This option is used to choose between a compressed and uncompressed recording. By default, it is set to Adaptive which is a compressed method. This is used to minimize file size, but the difference in quality is not be noticeable to most users.

Computer Audio. This button is used to install or uninstall the ScreenFlow audio driver. The driver must be installed to record computer audio.

Capture Scratch Disk. This option is used to set the temporary storage location while you recording is being generated. By default, this is set to a private system location. Setting a custom Capture Scratch Disk allows you to more easily locate your recording in the event that your recording is interrupted before completion.
Recording Tips

Before you begin your recording, it can be useful to consider what you intend to do with your screencast, how you would like to organize your media, and how best to present the content on screen.

Set Your Display Resolution

Two important factors to consider before you begin recording is the resolution of your display and the intended export resolution of your screencast. Since you usually do not intend to export your screencast at the same resolution that you recorded at, it is important to consider that your final video will be at a lower resolution than it is on your screen. This is especially important when you have text which must be legible. Digital video was not designed to capture text, so it can often be difficult to capture legibly.

Telestream recommends that you check your display resolution before recording (select System Preferences > Displays). Lower your display resolution as much as possible without impairing your ability to demonstrate your screencast. Do not lower the resolution below your intended export resolution or you will lose quality.

Using Text

Digital video was designed primarily for capturing real world images, so it is often difficult to capture the thin lines of text legibly. Here are a few tips if you are using text in your video:

- Use larger point sizes (e.g., at least 25 points or more). Larger characters always render better than small ones.
- Do not use serif fonts (e.g., Times Roman). Always use sans-serif fonts (e.g., Arial or Helvetica).
- Use boldface fonts, since they render better, especially at smaller sizes.
- Do not use odd values for the output movie’s frame height or width. Always use even numbers. Also, input sources having odd height or width values can result in illegible titles.
- Always generate non-interlaced video. Interlaced video is much more prone to poor quality text rendering because it may introduce flickering.

Considerations for Narrative Demonstrations

When creating narrative demonstrations, you might consider two different approaches. For simple demonstrations, you may be able to narrate the demo as you perform it. For more complex demos, you may have a problem narrating in real time, as you perform the task using the keyboard and mouse.
**Record Everything at Once**

Using this method, you record each recording source in a single session – simultaneously recording the display, camera video, microphone audio, and computer audio. When you are done recording, you can use the editing tools to finalize your screencast.

For example, you might start a presentation recording your display, then cut to a Picture-in-Picture of your camera recording, as you demonstrate the application. Later, you fade out your video, leaving only the audio to narrate the remaining moments of the screencast.

This method is considered a single-pass production. It works well when your subject matter is simple, straightforward, or short. For longer or more complex project, you may find the second approach more comfortable.

**First Record Your Monitor, Then Add Narration**

Using this method, you first record the display (with or without computer audio), demonstrating your application or subject matter without any video or voice-over. When you have finished your demonstration, you can record your camera and microphone sources while playing the video preview of your demonstration in ScreenFlow. This can be done in a single long recording or several short recordings. You can then edit your recordings to align your narration with your demonstration or fade your camera recording in and out when appropriate.

This workflow is effective when the screencast involves a series of complex mouse or keyboard operations, or you have several comprehensive steps or tasks to achieve, each of which take some effort to produce.
Editing ScreenCasts

When you have completed your first recording, your recorded media is placed in a new, untitled ScreenFlow document for editing, and displayed in the editor window. You use the Editor window to configure your screencast, add more media, and add text, actions, and other effects for clarity, emphasis, and presentation.

Topics
- Editing Window Overview
- Using the Canvas Panel
- Using the Timeline Panel
- Video Properties
- Audio Properties
- Screen Recording Properties
- Callout Properties
- Annotations Properties
- Text Properties
- Media Library
Editing Window Overview

The editing window is the main window for each screencast project you have open. (You can open several ScreenFlow documents and work on multiple projects simultaneously.) The editing window consists of three panels, as described below.

**Figure 15. Editing Window**

You can resize the canvas and timeline panels as necessary, by clicking and dragging the boundary up or down. The panel boundary is the upper border of the timeline labels, as shown in the figure above.

Canvas Panel

The upper-left panel of the editing window is the canvas. The canvas displays a preview of all content in your screencast, based on the position of the scrubber in the project. You can adjust the canvas size (and resulting frame size of your exported video) and background color using the Canvas button. You use the canvas to arrange, resize and configure all of the media in the project.

**Canvas Button.** Just below the canvas on the far left is the canvas button, which you click to view and adjust canvas properties.
Playback Controls. Below the canvas and centered, are playback controls to play your screencast as well as jump to the beginning or end of your screencast.

Audio Meters. To the right of the playback controls are the audio meters. The top meter represents the left channel; the bottom represents the right channel.

Timeline Panel

The bottom panel (directly below the player controls is the timeline – a visual representation of the temporal length of your screencast. The scale at the top displays the time scale for this project.

The timeline is divided vertically into tracks to manage different clips which may overlap at the same time.

The red vertical line on the timeline is the scrubber. The scrubber identifies the current position of the view displayed on the canvas. You can scrub through your project by using the mouse to grab the top handle (in the time scale) and moving it right or left. Notice that as you use the scrubber to scrub your project, the canvas update the video in real time.

All of the media in the timeline is referenced to your project’s media library. Changes made in the timeline or on the canvas do not alter your original recording.

Properties Panel

The upper-right panel displays the properties panel. The properties panel organizes the properties by tab: video, audio, screen recording, callouts, annotations, text and media files – the media library which stores all recorded and imported media in its original format and state.

Using the Canvas Panel

The canvas panel is a video preview panel – spacial representation of the visual clips in your ScreenFlow project – which allows you to play your project, and size and organize the visual clips of your project.
Figure 16. Canvas Controls

The center black frame (which may be obscured by the frame of a video clip) in the canvas panel is the output frame rectangle that controls the size of your video when you export it. The gray space around the black frame is for placing content that will not be present (or fully present) in your exported video. Use this space to display off-screen content present in scaling or pan effects. The content displayed on the canvas reflects the position of the scrubber on the timeline.

If the clip is visual (video, image, and text), the upper track is displayed over the lower tracks.

The figure below depicts how the canvas looks before any recording has been performed to obscure the output frame rectangle:
Configuring the Canvas

The canvas size represents your total usable display space (as measured in pixels) of your output video.

Click the Canvas button to highlight the canvas rectangle and display canvas controls. Click the button again to hide the controls. Clicking the button to hide the controls without first clicking Apply cancels any changes you have made.

**Canvas Size:** To change the maximum canvas size, click and drag any corner of the highlighted rectangle, or enter the width and height values in the Canvas X and Y fields. The canvas size cannot be set to a value larger than the original recording.

**Background Color.** Click the Background Color button (to the right of the Canvas X and Y fields) to choose the background color of the canvas. (Default: black.)

**Snap to Front Window.** Check to highlight a foreground window in your recording and want to crop the area outside of that window. This helps you to crop the canvas around the foreground window.

**Reset | Cancel | Apply.** Use these buttons to reset the settings to the default values, cancel changes you've made, or apply the changes you've made.

Configuring Clips in your Screencast

There are several operations you can perform on visual clips you've added. You can quickly and easily arrange them spatially on the canvas, and you can crop, resize, and rotate them.
Figure 18. Arranging and Adjusting Clips in the Canvas Panel
Click a media clip to highlight it.

Click on a clip to select it. ScreenFlow highlights the clip both in the canvas and the timeline.

Scaling a Clip
To scale a clip, select any resize handle and drag your mouse. Hold the Shift key while scaling to preserve the aspect ratio.

Cropping a Clip
To crop a clip, press and hold the Control key and drag any resize handle inward. Hold the Shift key while scaling to preserve the aspect ratio.

Rotating a Clip
Click and drag the center handle of the clip and rotate it.

Using the Timeline Panel
The timeline is a visual representation of the total length of time in your ScreenFlow project. The timeline displays all clips, media, and actions in your timeline and represents the start and end time for these clips.

The timeline also provides a scrubber so you can view any portion of your screencast by dragging the scrubber to the point you want to view.
Scale

At the top of the timeline is the scale. The scale is a precise measure of the total length of time in the project, and you can determine the start and stop time of each clip in the project by moving the scrubber to the start or stop of the clip. When you begin your project, the scale automatically adapts to the length of your first recorded media.

To change the scale magnification, use the slider in the lower left corner of the window. At maximum magnification, each line on the scale represents a single frame of video.

Figure 20. Timeline Magnification Slider

Move to any point in the timeline – or pan the timeline – by dragging the handle on the vertical red line, called the scrub bar. You can also use the left and right arrow keys to move the scrubber by a single frame.

Tracks

Clips in the timeline are placed sequentially in a single track, or separately on individual tracks, which allows you to overlap clips. Visual media placed on a track should be placed in relation to clips above or below it.

Once a clip is placed in a track, you can drag the clip to adjust its start and stop times relative to the other clips.

Tracks are organize by layer, with the topmost layer being the front layer, and succeeding tracks down in the timeline represent incrementally receding layers in the video.

For example, a text box placed on a track above a video overlays the text on top of the video. If the text box is placed on the track below the screen recording, it is behind the recording and not visible.

Using Track Controls

To make track adjustments, use the controls at the far left of the timeline on each track.
Figure 21. Use Track Controls to Adjust Track Height

To adjust the height of the track, use the arrow buttons on the track. Click the down arrow to decrease the track height; click the up arrow to increase track height. This can make it easier to manage content in your timeline.

To re-arrange a track’s position, select the track position handle and drag your track up or down in relation to the other tracks in the timeline.

Trimming Clips

ScreenFlow uses a few simple commands for quick editing of clips in your timeline.

Splitting a Clip

To split your clip into two smaller clips, position the scrubber over the moment where you want the split to occur, then press the T key. This splits the selected clip at the scrubber into two separate clips.

Trimming a Clip

To trim content off the front of selected clip, position the scrubber at the time you want the clip to begin, then press the W key. This trims all content from the front of the clip up to the scrubber.

To trim the end of the clip, position the scrubber at the time where you want the clip to end, then press the E key. This trims all content from the end of the clip back to the scrubber.

You can also grab either end of the clip and pull it inward to trim it. If the edge of the clip has already been trimmed, you can pull the edge out from the clip to restore trimmed content.

These actions change the amount of time the clip plays; it does not modify the underlying file (for images, video, and audio).

Creating and Closing Gaps in a Track

To create a gap in a track between existing clips, simply shift the clips to the left or right as necessary. You can also split a clip into two smaller clips: Position the scrubber over the moment where you want the split to occur, then press the T key. This splits the selected clip at the scrubber into two separate clips.

Now, you can shift the two new clips left and right as necessary to create the gap.
To close a gap in a track, click in the cap – ScreenFlow highlights the gap as blue with diagonal gray stripes. Press the Delete key, or control-click and select Close Gap.

Creating and Closing Gaps in the Timeline

To create a gap in the entire timeline to place a new clip, position the scrubber where you want the gap to occur. Then, grab the handle at the bottom of the scrubber and move it to the right. As the gap is created and widened, all clips to the right of the scrubber (in every track) move to the right to create the timeline gap. If the scrubber is positioned over any clip, it splits it in two.

To close a gap, position the scrubber at the beginning of the gap you want to close. Then, drag the bottom scrubber handle to the left. This does not join clips which have been split; it just butts them together. If clips overlap while closing the gap, this forms a transition.

Creating and Using In and Out Points

You create in and out points and then use them to delete entire sections of your timeline, using Ripple Delete (Command-Backspace). You can also export the range bounded by the in and out points, instead of exporting your entire project.

You can also select a range across tracks to take action specific to this part of the timeline. This range is set by applying an in point and an out point.

**Figure 22.** Mark In and Out Points on Timeline

Position the scrubber and press the I key to set an in point. ScreenFlow highlights the timeline in blue to the end of the timeline. Then move the scrubber to the out point and press the O-key to set an out point.

You can reverse this process as well: Position the scrubber and press the O key to set the out point. ScreenFlow highlights the timeline in blue to the beginning of the timeline. Then move the scrubber to the in point and press the I key to set the in point.

You can also shift-click on the timeline scale to set in and out points relative to the position of the scrubber. If you click to the left of the scrubber, you shift-click to create the in point, using the scrubber location as the out point; if you click to the right of the scrubber, you create the out point, using the scrubber as the in point.

When you create an in point without an out point, ScreenFlow automatically sets the out point to the end of the last clip in the timeline. When you create an out point without an in point, ScreenFlow automatically sets the in point to the beginning of the timeline.

With the timeline selected between the in point and out point, you can delete clips or portions of between the selected points and you can also export everything between
the selected points. Deleting the selected clips or portions does not shorten the timeline - close the gap. It only deletes the selected clips or portions thereof.

**Changing a Clip’s Play Speed**

Press and hold the Option key and move your cursor to the edge of the clip. The cursor displays a clock icon indicating that you are about to change the speed of the clip. Move the edge of the clip inward to speed the clip and outward to slow the clip. This clip is marked with a turtle or rabbit icon to indicate whether the clip speed was decreased or increased.

*Figure 23. Speed Change Icons*

This option is useful for quickly moving past a process that does not need to be shown in detail or slowing a quick processes which should be viewed in greater detail.

**Grouping a Set of Clips**

Select multiple clips and select Edit > Group to link them to one another. This allows you to move them as a group, which is useful when you have a sequence of clips arranged, and you don’t want to alter. To ungroup it, select the group, then select Edit > Ungroup.

**Locking a Clip**

Select a clip and select Edit > Lock Clip to lock the clip on the timeline. This clip is dimmed and cannot be altered in any way, or moved. This is useful when you have a clip or clips placed exactly where you want and do not want to alter them. To unlock the clip, select it and then select Edit > Unlock Clip.

*Figure 24. Locked and Unlocked Clips*

**Creating a Freeze Frame**

If you want to pause on a single frame of video while editing, select the clip and move the scrubber to the frame that you want to pause. Select Edit > Add Freeze Frame to create a still image of the current frame of video. This splits the video and adds a two
second freeze frame clip (essentially an image) within the split. The duration of the freeze frame can be modified by expanding or contracting the clip.

**Figure 25. Creating a Freeze Frame**

---

**Adding Markers**

You can place markers on your timeline to identify a particular time mark on your screencast. Markers are particularly useful in a long or complex screencast during editing.

You can export marker locations as chapters in supported formats. For more information, see the Add Chapter Track from Markers control, described in Exporting Your Video.

Move the scrubber to the desired location then select Edit > Markers > Add to create the marker. ScreenFlow displays a dialog so you can name the marker.

To display the marker list, Select Window > Markers. Click a marker to quickly move to that time in the project.

---

**Transitions**

Transitions are applied to a clip to create a smooth progression into, out of, and between clips. Transitions can only be added to clips in the same track.

The default duration of a transition is one second. You can expand or contract the duration by moving the thin line on the inside portion of the transition.

**Adding Transitions**

Select a clip and select Edit > Add Starting Transition to add a transition to the front of the clip or Edit > Add Ending Transition to add a transition to the end of the clip.

Create transitions between two clips by dragging one clip over an adjacent clip. The section where the two clips overlap is the transition.

**Transitions Inspector**

Double-click the Transition Icon to Display the Transitions Inspector:
Choose from sixteen different transition types and set the transition duration value in seconds.

**Figure 26. Transitions Inspector Window**

You can also select a transition effect and click the Properties button to alter properties (width, height, color, angle, opacity, etc.) specific to the selected transition effect, as appropriate.

**Audio Transitions**

Transitions are applied to audio clips in the same manner as images. However, since there is no visual content in an audio clip, the transition is a volume transition. Starting and ending audio transitions fade in/fade out; overlapping transitions fade from one clip to the other simultaneously.

**Actions**

Actions are property changes used to transition the media from one state to another. You can use video, audio, screen recording, and callout actions.

**Adding an Action**

To add an action, select the clip, display the property that you want to modify, then click the Add Action button at the bottom of the property panel. The action is placed in relation to the position of the scrubber, but can be moved to any location on the clip. The duration of the action is changed by dragging the edge of the action to lengthen or shorten it.
Figure 27. Video Properties Action

Place the scrubber before or after the action to make changes to the property relative to the action. If the scrubber is placed before the action, this sets the properties of the clip before the action. If the scrubber is placed after the action, this sets the properties of the clip after the action.

Video Properties

Video properties can be used to make visual changes to any screen recording, camera-based video, other imported video clips, and text image clips in a screencast.

You can also apply video properties to video actions you’ve added to a clip. When applying properties to an action, only value-based properties (those that have a numeric value) are transitional – these can be applied to both the start and end of an action to create a transition.

For example, you have a 30-second video clip, and you add a video action to the start of the clip, and another video action to the end of the clip – each 4 seconds long. Next, using the scrubber, you set the start of the beginning video action to 0% brightness, and the end of the beginning video action to 100% brightness. Next, you set the beginning of the ending video action to 100% brightness, and the end of the ending video action to 0% brightness, to create a fade-in and a fade-out effect.

Select a video, screen recording, or text clip, or select the start or end of a video action in the video or screen recording clip before applying properties.
Audio Properties Dropdown Menu

**Add Video Action.** Select to add a video action at the moment indicated by the scrubber in the selected clip.

**Reset to Defaults.** Select to reset all properties in this panel to default values.

**Audio Properties**

**Scale.** Scale is used to change the size of a video or image. This is useful for highlighting a particular portion of the screen or with a video action to create a zoom effect.

Use the slider or enter a percentage value to change the scale of your image.

**Position.** Position represents the location of your video or image on the canvas. The location is based on the position of the center of your image. Values in the position field are represented in pixels.

You can reposition the image by dragging the image on the canvas, nudging the image with the arrow keys, or entering a numerical value in the position fields.

**X/Y/Z Rotation.** Use the rotation options to rotate a two dimensional image in a virtual three dimensional space. Values in the rotation field represent degrees.

X Rotation rotates the image along a fixed horizontal axis. Y Rotation rotates the image along a fixed vertical axis. Z Rotation spins the image along a fixed depth axis.

Use the thumb wheels to rotate the image in real time or manually enter the values (0 to 360 degrees) in the text fields.
**Opacity.** Opacity is the degree of image translucency. The greater the value, the more opaque the image. If the value is set to zero, the image is invisible. This may be used with a video action to fade an image in or out. It is particularly useful if you would like to periodically display your camera recording. Use the slider to set the value or enter it manually (0 to 100%).

**Reflection.** Reflection creates a mirror image of the selected clip below the clip itself. Check to implement reflection. The greater the value, the more opaque the reflection. If the value is set to zero, the reflection is invisible. Use the slider to set the value or enter it manually (0 to 100%).

**Shadow.** Check to create a shadow effect behind a still image. If you image uses a transparency, the shadow only reflects the non-transparent part of your image.

**Angle.** Use the thumb wheel to set the angle of the shadow relative to the image in degrees. The default is -45 degrees.

**Color.** Click the color field to select the shadow color from the color picker. Default: black.

**Offset.** Specify the distance between the shadow and the clip, in pixels. Default: 40. Use the slider to set the value or enter it manually (0 to 100%).

**Opacity.** Opacity is the degree of shadow translucency. The greater the value, the more opaque the shadow. If the value is set to zero, the shadow is invisible. Default: 75%. Use the arrows to set the value or enter it manually (0 to 100%).

**Blur.** Blur is a gradual loss in opacity as the shadow spreads from the center. Default: 4. Use the arrows to set the value or enter it manually.

**Saturation.** Saturation is the intensity of a color relative to its brightness, represented as a percentage. Default: 100%. Use the slider to set the value or enter it manually (0 to 400%).

**Brightness.** Brightness is the degree of luminosity present in the image, represented as a percentage. Default: 100%. Use the slider to set the value or enter it manually (0 to 400%).

**Contrast.** Contrast is the relative intensity of the black and white values in an image. A high contrast has a greater intensity of black and white values. This value is represented as a percentage. Default: 100%. Use the slider to set the value or enter it manually (0 to 400%).

**Add Video Action.** Click to add a video action at the moment indicated by the scrubber in the selected clip.
Audio Properties

Display the Audio properties tab to modify the selected audio clips in your timeline. You can apply audio properties to any clip which contains audio, including clips with both video and audio.

You can also apply audio properties to audio actions you’ve added to a clip. When applying properties to an action within a clip, only value-based properties (those that have a numeric value) are transitional – these can be applied to both the start and end of an action to create a transition.

For example, you have a 30-second video clip, and you add a video action to the start of the clip, and another video action to the end of the clip – each 4 seconds long. Next, using the scrubber, you set the start of the beginning video action to 0% brightness, and the end of the beginning video action to 100% brightness. Next, you set the beginning of the ending video action to 100% brightness, and the end of the ending video action to 0% brightness, to create a fade-in and a fade-out effect.

Select a video, screen recording, or text clip, or select the start or end of a video action in the video or screen recording clip before applying properties.

Figure 29. Audio Properties

Any clip which uses audio content displays with a waveform. This waveform adjusts to reflect any volume changes.

The following image depicts an audio clip with an audio action set to increase volume. Notice how the waveform display is enlarged to the right, due to the action.
Audio Properties Dropdown Menu

**Add Audio Action.** Select to add an audio action at the moment indicated by the scrubber in the selected clip.

**Reset to Defaults.** Select to reset all properties in this panel to default values.

**Audio Properties**

**Volume.** Use the slider or enter a percentage value to change the audio on a clip. This can be used with an action to gradually change the audio level as shown in the image above.

**Ducking.** Check to apply audio ducking and automatically adjust volume levels on overlapping audio clips. When applied to a clip, all overlapping audio is muted to draw attention to the audio in this clip.

Use the slider or manually enter the value to specify the percent of reduction to apply. This is particularly useful when using background music with narration.

**Meter:** Depicts relative volume of each channel in the selected clip.

**Mute Audio.** Check to mute the selected audio clip.

**Processing**

**Smooth Volume Levels.** Select this option to normalize and smooth out volume peaks while increasing quieter clips so that the audio has a more consistent volume.

**Mix Input to Mono.** Check to mix multichannel audio into a single mono channel.

**Effect.** Check to apply the selected audio effect (from the dropdown menu) to the audio clip. Use the slider or manually enter the percent of effect to apply.

**Filter: Remove Background Noise.** Check to reduce the audio volume of incidental background noise, which typically results in a clearer audio track. Use the slider or manually enter the percent of sensitivity to apply.

**Add Audio Action Button.** Click to add an audio action at the moment indicated by the scrubber in the selected clip.
Screen Recording Properties

Screen recording properties can only be applied to ScreenFlow screen recording clips. They cannot be applied to video or other clips. ScreenFlow files (unlike other QuickTime movies and other video formats) contain proprietary spatial and temporal information about mouse tracking and key presses that enables powerful special effects to enhance your screencast.

**Note:** Media created by ScreenFlow is saved in a file in ScreenFlow format, with an `.scc` extension. This is a proprietary format which can only be utilized by ScreenFlow.

---

**Figure 31.** Screen Recording Properties

![Screen Recording Properties Dropdown Menu](image)

**Screen Recording Properties Dropdown Menu**

**Add Screen Recording Action.** Select to add a screen recording action at the moment indicated by the scrubber in the selected clip.

**Reset to Defaults.** Select to reset all properties in this panel to default values.

**Screen Recording Properties Controls**

**Pointer Zoom.** Check to increase the size of the mouse pointer in the screen recording. Often it can be difficult to easily distinguish or track the mouse in a screencast, particularly if the video has been significantly resized. Increasing the pointer zoom value increases the size of the mouse cursor, making it easier for the viewer to follow. Use the slider or manually enter the value to specify the percent of increase to apply.

**Click Effect.** Select None | Radar | Invert from the dropdown menu to create a visual effect when you click the mouse. Radar projects a red circle with each click. Invert changes the cursor from black to white and back with each click.

**Pointer.** Select Default | Circle | Square | Choose Image from the dropdown menu to change the pointer image. Select Choose Image to display an Open dialog, and
navigate to and select any custom image file. When selecting a custom image, specify the cursor hotspot position.

**Opacity.** Opacity is the degree of pointer translucency. The greater the value, the more opaque the pointer. If the value is set to zero, the pointer is invisible. Default: 75%. Use the slider to set the value or enter it manually (0 to 100%). This may be used with an action to fade the pointer in or out.

**Sound on Click.** Click the down arrow to display Sound on Click details. Check to generate a sound when the mouse button is pressed.

**Volume.** Sets the volume level of the mouse click sound (from 0 to 5,000%). Use the arrows to set the value or enter it manually.

**Click Sound.** Click Choose to display an Open dialog, and navigate to and select any custom sound file, to play a unique sound file every time the mouse is clicked.

**Show Keys Pressed.** Check to display the text of keyboard characters typed during the recording.

**Show Modifier Keys Pressed.** Check to display modifiers used in hotkey commands, function keys, and the arrow keys that were pressed during the recording.
Callout Properties

Callout properties are used to highlight a specific portion of the screen. Callout properties can only be applied to callout actions in screen recording clips. Callout properties cannot be applied at a clip level, and can only be applied to screen recording clips, not other video clips.

**Note:** Be sure to add or select an action on a screen recording clip, before using this property tab.

**Figure 32. Callout Properties**

![Callout Properties Dropdown Menu](image)

**Callout Properties Dropdown Menu**

**Add Callout Action.** Select to add a callout action at the moment indicated by the scrubber in the selected clip.

**Reset to Defaults.** Select to reset all properties in this panel to default values. When you select Reset to Defaults, the settings applied by this command are the settings in place when Make Settings Default for New Callouts was executed.

**Make Settings Default for new Callouts.** Select to set all properties as they currently exist, as default values for any new callout clips added to this project.

**Callout Properties Controls**

**Highlight.** Select how to highlight an area of the recording in three different ways. Mouse Cursor highlights a circular space around the mouse cursor. Foreground Window highlights any window which is currently active. Freehand allows you to draw the area you want to highlight.
**Opacity.** Use the slider to control the percent of opacity of the space outside the callout. A value of 0 makes the surrounding area opaque; a 100% value makes the surrounding area invisible.

**Blur.** Use the slider or manually enter the pixel value to blur the content in a callout area (range: 0-16).

**Blur Background.** Check to blur the area outside of the callout.

**Zoom Up.** Use the slider or manually enter the percentage value to magnify the area inside the callout (range: 0 to 100%).

**Border.** Use the slider or manually enter the value to create a gradual loss in opacity as the shadow spreads from the center (range: 0-60). This feature is does not apply to freehand callouts.

**Outline.** Enter the value (in pixels) to create an outline around the callout area (range: 0 to 200.)

Click the color box to change the color of the outline.

**Shadow.** Check to add a shadow behind the callout.

Use the slider or manually enter the value to create a gradual loss in opacity as the shadow spreads from the center (range: 0-60).

**Feather.** Specify the blend value (in pixels) to apply to the callout border to create a smooth transition between the callout area and the surrounding space (range: 0-20).

**Round.** Applies to Foreground callouts only. Specify the round-off value (in pixels) of the callout edge to create a more gentle appearance (range: 0-200).

**Build.** Specify the transition time of the callout, in seconds, up to 2 decimal places. Duration In determines the amount of build-in time to reach the full effect of the callout. Duration Out determines the amount of build-out time to return to normal.
Annotations Properties

Annotations are used for drawing simple shapes in your screencast. Annotations are a clip you can add to your timeline, and behave like image clips on the canvas. You can apply video properties and transitions to annotations clips.

When you create an annotation clip, you can optionally draw on the canvas. You can draw multiple shapes in the same annotation clip and format these shapes individually. However, any action applied to this clip apply to all shapes within the clip.

**Figure 33. Annotations Properties**

![Annotations Properties](image)

Annotations Properties Dropdown Menu

**Add Annotations Clip.** Select to add an annotations clip at the moment indicated by the scrubber.

**Make Settings Default.** Select to set all properties in this panel to default values.

Annotations Properties Controls

**Shapes.** Choose from the four types of annotations indicated in the icon bar: Circle | Square | Line | Arrow.

**Color.** Click to select the color of the annotation. Select the color, brightness, and opacity of objects in the annotation.

**Thickness.** Use the slider or manually enter the value to specify the thickness (in pixels) of annotation lines (range: 2 to 300). Default: 50.

**Shadow.** Check to create a shadow on objects in the annotation. Use the slider or manually enter the value (in pixels) to specify the opacity of the shadow (range: 1 to 60). Default: 25. The value creates a gradual loss in opacity as the shadow spreads from the center.

**Outline.** Check to create an outline around objects in the annotation. Use the slider or manually enter the value (in pixels) to specify the thickness of the outline (range: 1 to 60). Default: 25.
**Color.** Click to select the color of the outline. Select the color, brightness, and opacity of objects in the annotation.

**Endpoints.** Select a shape to affix to the end of a line segment. The first and second field represent the starting and finishing point of the line segment, respectively.

---

**Text Properties**

Use Text Properties to create text clips which display blocks of text on your screencast. Text clips behave like image clips on the canvas. You can apply video properties and transitions to text clips.

**Figure 34.** Text Box on Canvas

![Text Box on Canvas](image)

Click the Add Text Box button to add a text clip to your timeline at the moment of the scrubber. Text clips are placed in the top track of your timeline, with a duration of five seconds and the word *Text* in the box. If there is no room in the top track for this clip (that is, the scrubber is in a clip on the top track), an empty track is added to the top of your timeline, and the text clip is placed in the new, empty track.

**Figure 35.** Text Clip on Timeline

![Text Clip on Timeline](image)

Click the text box to change the text in the text box. The name of the clip is changed in the timeline to reflect this content.
Text Properties

Add Text Clip. Select to add a text clip at the moment indicated by the scrubber.

Reset to Defaults. Select to reset all properties in this panel to default values. When you select Reset to Defaults, the settings applied by this command are the settings in place when Make Settings Default for New Text Clips was executed.

Make Settings Default for New Text Clips. Select to set all properties in this panel to default values for future text clips.

Text Properties Controls

Font. Select this menu to choose a font face from the list of fonts provided by your system. The font is applied to the entire text box (if none or all text is selected) or a range of selected characters.

Size. Select this menu to choose the size of your text in pixels (range: 9 to 288). The size is applied to the entire text box (if none or all text is selected) or a range of selected characters.

Select Font Panel option to enter a custom size.

Alignment. Select paragraph alignment: Align Left | Align Right | Center. This property affects the selected paragraph, if more than one.

Fill. Check to choose Solid Color | Image | Gradient from the dropdown menu. For fill, select a color from the color wheel. The color is applied to the entire text box (if none or all text is selected) or a range of selected characters.

For Image, ScreenFlow displays an Open dialog, so you can navigate to and select any custom image file. Deselect the checkbox to remove the file. This can be used with Outline to create characters which are transparent. Applying an image uses the color patterns represented in the image to fill the text.
These properties are applied to the entire text box (if none or all text is selected) or a range of selected characters.

**Color.** The color field below allows you to choose the color used in your text. For gradient, click in the top half and select a color, then click in the bottom half and select the second color.

**Outline.** Check to outline the text. The outline is applied to the entire text box (if none or all text is selected) or a range of selected characters.

Use the slider to set the width of the outline (in pixels) range: 0 to 15.

**Color.** Click to select the color of the outline. Select the color, brightness, and opacity.

**Backdrop.** Check to add a background and choose Solid Color | Image Fill.

**Color.** For Solid Color only, click to select the color of the backdrop. Specify the color, brightness, and opacity.

**Round.** Use the arrows or manually specify the value in pixels to smooth the edge of the text box (range: 0 to 100). Default: 20.

**Image.** For Image Fill only, click Choose display an Open dialog and select an image to insert into the background. Use the dropdown menu below to choose how the image fills the background space: Scale To Fit | Scale To Fill | Tile | Original Size | Stretch.

**Margin.** Use the slider or manually enter the size (in pixels) of the margin (range: 0 to 300). Default: 25.
Media Library

The media library stores all recorded and imported media in an unaltered state. This material may be dragged to your timeline or canvas to add it to your project. Dragging the content to the canvas or timeline more than once duplicates the content.

Media created by ScreenFlow is saved in a file in ScreenFlow format, with an scc extension. This is a proprietary format which can only be utilized by ScreenFlow.

You can import media by dragging the media from the Finder to your media library, and export media by dragging the media out to your desktop, target folder or server.

You can rename media files in your library by highlighting the media, then clicking on the name below. This also renames all associated clips on the timeline unless they have already been given a custom name.

Figure 37. Media Library

Media Dropdown Menu

Right-click (Control-click) your media to display the dropdown menu.

Preview Source. Select to preview video, audio, or still image clips stored in the media library. Or, move your mouse near the center and wait a moment until the Play button displays over the thumbnail; then click the Play button. ScreenFlow displays the video in a preview window, with player controls superimposed at the base of the window.

Add to Timeline at Playhead. Select to add your media to the timeline beginning at the current scrubber position.

Delete Media. Select to remove the media from your project. If the media has been placed on the timeline, it is removed following a confirmation prompt. Media files are not deleted from the file system.

Media Controls

Zoom. Use the slider to change the display size of the media thumbnail.

Add Media. Click to browse local drives or network servers for media to import into your ScreenFlow project. This may include video files, audio files, and still images.

Add Recording. Click to create a new recording. For details, see Adding A Recording.
Publishing Your Screencast

When you are done editing your screencast, the final task is to convert it to a standard video format for publication and distribution or use in other video programs. If you intend to use your screencast in another application, check the application documents to see which formats it supports.

ScreenFlow has two primary means of converting projects to video. You can use the Export options to create standard video files or use the Publish options for publishing your videos directly to an online video service such as YouTube.

Topics
- Exporting Your Video
- Customizing Codec Settings
- Publishing to YouTube
- Publishing to Vimeo
- Publishing to Flash

Exporting Your Video

Select File > Export to produce a standard video file for distribution or use in other video applications.

**Note:** If you have in and out points set in your project, the menu item displays as Export Selected Range.

When you are done configuring your export options, click Export to begin encoding the screencast into a video file. ScreenFlow displays a progress dialog so you can monitor its progress.
Publishing Your Screencast

Exporting Your Video

Figure 38. Export Settings Window

**Save As.** Enter the name of your screencast. The default name is your project name. The file extension is applied automatically based on your choice of preset.

**Where.** Select to determine the location of your video upon completion of export.

**Preset.** Export presets are settings designed for both general and specific use. These settings are designed based on the most common needs of the user.

- **Web - High | Web - High (Multi-pass)**
  This is the default export option, which encodes using the H.264 codec, which balances the demands of image quality and file size.

- **Web - Low | Web - Low (Multi-pass)**
  This is an export option similar to Web - High, but formatted for a low bandwidth. It plays more smoothly on slow Internet connections but the image quality is not as good as Web - High.

**Note:** Multi-pass is a compression method that determines how best to format the video based on predictive scanning of the source content. This increases encoding time, but may improve image quality and decrease file size.

- **Windows Media**
  This option exports video in the WMV format, a popular Microsoft format for Windows users. This option utilizes Flip4Mac, a QuickTime plugin by Telestream (Flip4Mac Customization) to encode the media, which must be licensed separately.

- **Lossless**
  This is an uncompressed export format ideal for additional editing. This format has the highest quality image but also the largest file size. When exported at 100%, the image quality is identical to the original recording.

- **Lossless - Audio Only**
  This is an uncompressed audio-only export format ideal for additional editing.
• iPad / iPhone / Apple TV / iPod
These export options are formatted based on the recommended video specifications for these devices. They cannot be altered.

**Make Settings Default.** Select to set your current setting as the default export setting.

**Customize.** Click to make changes to your video and audio encoding options. You can use either QuickTime or Windows Media video compression (via Flip4Mac).

**Manage.** Click to manage your available export presets.

**Figure 39.** Manage Presets Window

Click the check box to the left of the preset to hide it. Click the Copy button to the right of the preset to generate a custom preset copy.

Custom presets are displayed below. To change the custom preset name, double-click the name field. Click the Edit button to customize your preset.

**Dimensions.** These options are used to set the dimensions of your video export. You should not set a size larger than your canvas size. This does not improve image quality.

**Figure 40.** Dimensions: Scale to Custom Size Settings
**Scale by.** Select to scale your project by a percentage value. This is an easy way to shrink your screencast while maintaining the aspect ratio.

**Scale to custom size.** Select to set the exact width and height of your exported video. Click the Letterbox Content box to add letterboxing to your export.

**Use Motion Blur.** Check to apply a blurring algorithm to blend movement smoothly into the video. This is useful if you are using video properties effects to move clips on the canvas.

This option increases encoding time so it should only be used if objects are not moving smoothly in your exported video.

**Add Chapter Track from Markers.** Check to add chapter markers to your exported video based on the location and names of the markers in your screencast.

Presets which do not support chapter markers include iPad, iPhone, Apple TV, iPod, and Windows Media.

---

**Note:** QuickTime X and VLC require a chapter marker on the first frame of your project or it will move the chapter markers from their intended locations. Be sure to set a chapter marker at the very beginning of your project to prevent this.

---

**Exported Video File Size Considerations.**

Video files often become very large, making them difficult to send to others, download, or post to servers via the Internet.

The frame size of video clips in your screencast is typically much larger than the screen size of the video file you are exporting. For example, if your original screen size is 1280 x 800 pixels, you probably do not want to create a video of the same frame size. This is essentially HD video, and may be four times larger than a 640 x 400 video. If you were to post it on a Web site, many users wouldn’t be able to view it.

**Reducing your Video File Size**

To preserve the aspect ratio of your screencast, use the Dimensions options. For general purposes, you may want to reduce the dimensions by 50%.

**Reducing the Frame Rate**

The NTSC video standard frame rate is 30 FPS. This is the standard for videos produced in North America. However, this standard is based on creating a smooth representation of video motion captured in the real world and may not be necessary for your screencast.

If you specify 30 frames per second, the output will be smooth, but the file will be about twice as a 15 FPS video file. You may find that a 10 FPS or 15 FPS recording is very acceptable for your audience. Reducing the frame rate can drastically reduce the size of the video file.

You should experiment with codec settings to get a sense for what frame size and frame rate works best for you.
Customizing Codec Settings

After selecting a preset, click the Customize button to modify these codec settings. ScreenFlow displays the QuickTime compression settings dialog, the standard dialog for all programs which use QuickTime to compress video.

If you are customizing the Windows Media preset, ScreenFlow displays the Flip4Mac compression settings window.

You can also access this window by creating a custom preset using Manage > Edit.

QuickTime Customization

When you are editing QuickTime-based presets, ScreenFlow displays the standard QuickTime compression settings dialog.

Figure 41. QuickTime Compression Window

Video. Uncheck when you do not want your exported file to contain video content. When unchecked, the file will only contain audio content.

Settings. Click to change the video codec and its settings. Each codec has its own set of options controlling frame rate, bit rate, quality, etc.

Filter. Check to add effects such as Sharpen, Sepia, Gamma (Adjust) and others. Using filters increases the time it takes for ScreenFlow to render the video file.

Size. Check to specify the frame size directly in the codec.

Although you can configure the size directly in the codec, Telestream recommends that you retain the default setting (Current). Instead, specify the frame size during the Export process to modify the resulting file size.

Resizing increases the time it takes for ScreenFlow to render the video file.
**Sound.** Uncheck when you do not want your exported video file to contain audio content. When unchecked, the file will only contain video content.

**Settings.** Click to change the audio codec and its various settings. Each codec has its own set of options, controlling frame rate, bit rate, quality, etc.

**Prepare for Internet Streaming.** Check to export your movie for use on the Internet:

- **Fast Start** Allows your movie to begin playing before the movie has finished downloading. This is the default option.
- **Fast Start—Compressed Header** Same as the Fast Start option, but compresses the header of the file.

Some older versions of QuickTime do not support this option. Therefore, some users may not be able to view video compressed using this format.

**Hinted Streaming** Use when this video will be hosted on a QuickTime Streaming Server (QTSS). This option adds hint tracks, which allow QTSS to stream the movie.

**Flip4Mac Customization**

Flip4Mac customization is described in the Flip4Mac User's Guide.

To export your screencast in Windows Media format, ScreenFlow uses Flip4Mac WMV Components for QuickTime. This plugin must be installed and licensed separately for full functionality. If Flip4Mac is not licensed, it functions in demo mode to provide a sample of its capabilities.

To export a full length Windows Media file, Flip4Mac requires a Flip4Mac WMV Studio license. Customization beyond the preset profiles requires a Flip4Mac WMV Studio Pro license.

For more information and to download the installer, go to the Telestream Flip4Mac Web page.
**Figure 42.** Flip4Mac Compression Window

Profiles. Select from a list of preset encoding options for Windows Media.

Video. Display the video tab to customize the video content in your export.

**Export Using.** Choose between WMV 9 Standard or Advanced (VC-1)

**Coding Method.** Choose between one-pass or two-pass encoding and constant bit rate or variable bit rate. Two-pass encoding requires Flip4Mac WMV Studio Pro HD.

**Quality.** Move the slider to set the quality value of the encoded video as it relates to smoothness versus sharpness.

**Bit Rate.** Set to determine the average bit rate of your video. This applies a baseline for the amount of data to be processed per second while playing your video. A high bit rate allows more complex information which may increase quality while a low bit rate limits the amount of data, which reduces file size and plays more smoothly on a low bandwidth selection.

**Peak bit rate** Set to determine the maximum bit rate when using the VBR Constrained option.

**Size.** Set to determine the resolution of your encoding. Available frame sizes are dependent on your Flip4Mac license.

Although you can configure the size directly in the codec, Telestream recommends that you retain the default setting (Current). Instead, specify the size using the Dimensions control in the Export window to modify the resulting size of the movie.

If you set a frame size which is not supported by your Flip4Mac license, the plugin defaults to the closest available frame size.
For more information, see Flip4Mac technical specifications on the Telestream Flip4Mac Web page.

**Rate.** Choose to select the frame rate of your video. Frame rate standards are 30 (NTSC) and 25 (PAL), however for screencasts, you may be able to use an exceptionally low frame rate without noticing a loss of quality.

**Advanced.** This section features advanced encoding techniques including complexity, profile, key frame distance, B-frame distance, buffer delay, and interlacing options.

**Audio.** Display the audio tab to customize the audio content in your export.

**Export Using.** Choose between WMV 9 Standard, Professional, or Lossless

**Coding Method.** Choose between one-pass or two-pass encoding, constant bit rate or variable bit rate, mono or stereo, and various sample rates.

**Advanced.** Set buffer delay.

**Content.** This tab is used to set the metadata on your Windows Media file including title, author, description, copyright, and rating.

**Silverlight.** This tab is for encoding your Windows Media file for use with Microsoft’s Silverlight Player. Here you may select from various player skins to customize your video presentation.

### Publishing to YouTube

If you have a YouTube account, ScreenFlow enables you to publish your screencasts directly to YouTube.

#### Logging In

Select File > Publish to YouTube to access the YouTube login window.

**Figure 43.** YouTube Account Login Window

Enter your YouTube Name and Password to access your account. Select the check box to retain your login information for future uploads.

Click the Sign In button. When you have successfully signed in, ScreenFlow displays a dialog for you to enter details about your screencast:
Settings

Figure 44. YouTube Details Window

![YouTube Details Window]

**Note:** All fields must be completed to activate the Publish button.

**Category.** Select the category of your screencast from the options in the dropdown menu.

**Title.** Enter the title for your screencast. By default, this field uses your project name.

**Description.** Enter a description for your screencast.

**Tags.** Enter keywords to describe your screencast. When YouTube users search for these words, your video is included in the search results.

**Access.** Check to mark your screencast as personal. Personal content can only be viewed from your account and by other YouTube users that you authorize.

**Quality.** Select this option to publish your screencast in HD. YouTube supports both 720p and 1080p for upload. If this option is not checked, the resolution of the video is set to 360p.

**Publish.** Click Publish to export and upload your screencast.

ScreenFlow displays a progress bar to indicate encoding and upload progress. Click Cancel at any time to abort the encode/upload process.

**Publishing to Vimeo**

Select File > Publish to Vimeo to publish your video directly to the Vimeo video hosting site. If you don’t have a Vimeo account, you are prompted to create one.
Figure 45. Vimeo Log In Window

Setting up your account

Click the Join Vimeo button to create a Vimeo account. Choose Basic or Plus to determine the type of Vimeo account you want to set up.

Figure 46. Vimeo Account Window
After you have chosen your account preference, enter your first and last name, e-mail, and password to create your account.

**Figure 47. Join Vimeo Window**

After your account has been created, you must authorize ScreenFlow to publish directly to your account.

After accessing your account, Vimeo prompts you to authorize the application to upload directly to your Vimeo account. Click Yes, authorize ScreenFlow! to enable Vimeo uploads.
Verify account

**Figure 48.** Vimeo Authorization Window

![Vimeo Authorization Window]

**Figure 49.** Vimeo Account Verification Window

![Vimeo Account Verification Window]

**Vimeo Account.** This displays your currently accessed Vimeo account.

**Remember login in my keychain.** Select this option to retain your account information when uploading to Vimeo.

**Change Account.** Click this button to access a different Vimeo account.
Vimeo Settings

Figure 50. Vimeo Settings Window

Publish your screencast to Vimeo

Title: Entered
Description: Entry
Tags: Entry
Access: Check to mark your screencast personal
Quality: Select this option to publish your screencast in HD

Publish. Click Publish to export and upload your screencast. ScreenFlow displays a progress bar to indicate encoding and upload progress. Click Cancel at any time to abort the encode/upload process.

Publishing to Flash

This feature enables the user to save their screencast in the F4V Flash format. This is a highly compressed format most suitable for internet publication.

This feature produces both a Flash video and the necessary components for hosting the video on your website.

After selecting the Publish to Flash option, you are presented with a settings dialog.
Figure 51. Flash Settings Window

- **Save As.** Enter the name of your screencast here. The default name is the same as your project name. The file extension is applied automatically based on your choice of preset.

- **Where.** Select to determine the location of your video after encoding.

- **Player.** Choose between three standard Flash player skins to determine how the video controls are presented on your website.

- **Encoding: Automatic for Web.** Select to use the automatic Flash presets. This formats the video as 320 x 240, 30 FPS, and 900 KPBPS.

- **Encoding: Custom.** Select to configure your own settings.

- **Width.** This field determines the width of your video in pixels.

- **Height.** This field determines the height of your video in pixels.

- **Frame Rate.** This field determines the number of frames in your video per second. The North American NTSC standard is 29.97 (often rounded up to 30) while the European PAL standard is 25. The range for this field is 1-100.

- **Data Rate.** Data rate sets the amount of information required to process the video per second. Setting a low data rate is ideal for streaming with slow internet connections, but a low data rate may impair image quality. An acceptable data rate depends on the content of the video and user preference. The range for this field is 10 to 10,000.

- **Contents of Flash folder.** This feature produces a Flash folder consisting of:
  - index.html, an HTML page containing a player showing movie.f4v. You may edit this file to suit your design requirements, or use it as a template for incorporating the video in a different Web page.
  - movie.f4v, the screencast published in Flash
  - player.swf, the player itself
• a /com directory containing the skin for the player
• README.txt.

How to Publish Your video to a Local Web Server

If you have a Web server on the same computer as ScreenFlow, you can place the output directory in (a subdirectory of) /Library/WebServer/Documents/ and have your video immediately accessible to the world.

Example: If you have placed your output in /Library/WebServer/Documents/prettyvideo/ on webserver.comp.com, opening http://webserver.comp.com/prettyvideo/ in a Web browser will show your video.
Preferences

You use ScreenFlow Preferences to set your options and customize ScreenFlow to suit your specific needs. To display Preferences, select ScreenFlow > Preferences.

**Note:** If you purchased ScreenFlow through the Mac App Store, the License tab does not display. The Mac App Store has its own licensing and updating processes.

**Topics**
- General Pane
- Timeline Pane
- Advanced Pane
- Licenses (Telestream Web Store Only)

**General Pane**

The General pane provides various startup, display, recording, and auto-update options.

**Figure 52.** Preferences General Pane

[Image of Preferences General Pane]

These controls do not display when ScreenFlow has been purchased from the Mac App Store.
Preferences

Settings
Show ScreenFlow options in menu bar. Check to toggle the ScreenFlow Helper menu on or off.

Countdown for [x] secs before recording. Check to display the Countdown window prior to recording, and set the countdown time (in seconds) between 0 - 10. Default: 5.

Startup
Launch ScreenFlow Helper at user login. Check to launch ScreenFlow Helper when you log into your computer. This allows you to conduct recording prior to launching ScreenFlow.

Auto Update
Check for ScreenFlow updates at launch. Check to periodically check for ScreenFlow updates when the application is launched. If a new version is available, you can update ScreenFlow immediately.

Note: This option is not available if you purchased ScreenFlow from the Mac App Store. The App Store has its own updating procedure.

Recording Hotkey. Click the button to set a recording hotkey command, then press the key combination you want to use. Default: Shift-Command-2. Be sure to choose a hotkey which is not already in use by the application you are demonstrating.

Pause Hotkey. Click the button to set a pause hotkey command, then press the key combination you want to use. Be careful to choose a hotkey which is not already in use by the application you are demonstrating.

Timeline Pane

Use the Timeline pane to set timeline preferences.

Figure 53. Preferences Timeline Pane
Display

Use SMPTE timecode. Check to display the timeline scale as SMPTE timecode (HH:MM:SS:FF – Hours:Minutes:Seconds:Frames). If unchecked, the scale uses an informal method of displaying time markers (for example, 1h2m30s).

Show current time when scrubbing. Check to display exact time when moving the scrubber around in the timeline.

Default Transition. Select the default effect to use when generating a transition. Default: Bars Swipe.

Default Track Height. Select the default track height of timeline tracks. If you typically use many tracks, you may want to set this to Small, so that you can see more tracks in your window without scrolling. Default: Regular.

Default duration of still images. Use the arrows or manually enter the value (in seconds) of the default length of an image clip on the timeline. Range: one-tenth of a second (3 frames) to 50 seconds. Default: 5 seconds.

Advanced Pane

The Advanced pane provides advanced ScreenFlow settings.

Figure 54. Preferences Advanced Pane

- Video Magnification. Select Smooth | Sharp to set the compression algorithm used when computing a scale effect or zoom callout. Smooth blurs color values to create a smoother transition. Sharp does not blur color values. Default: Smooth.

- Screen Recording Compression. Select Adaptive | Lossless to specify the method of compression used in recording the video. Adaptive uses a compression method which recognizes clips of the display which do not change thereby resulting in a smaller file size. Lossless uses an uncompressed recording method which does not record content based on changes thereby resulting in a larger file size.
Preferences

Licenses (Telestream Web Store Only)

Default: Adaptive. This setting is recommended because the Lossless setting rarely results in better quality, but always results in a larger file size.

Computer Audio. Click to install or uninstall ScreenFlow’s computer audio driver. This driver is required for recording system audio.

Note: If you purchased ScreenFlow through the App Store, this setting is not available. The computer audio driver installs automatically.

Capture Scratch Disk. Click Change to specify your capture scratch disk volume and directory. ScreenFlow saves recording files in this directory as they are being created. If your recording is interrupted for any reason, you can find it in the capture scratch disk directory.

Licenses (Telestream Web Store Only)

The Licenses pane displays your serial number and allows you to manage your licenses.

Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. The App Store has its own installation and licensing procedure.

ScreenFlow must be licensed to fully enable the export capabilities. If ScreenFlow is not licensed, all exported and published files are watermarked.

License functions are locked, and require administrator access to prevent guests from removing your license. Click the lock at the bottom of the window to make changes, then click the lock again, when you’re done.

Licensing ScreenFlow

If ScreenFlow is not currently licensed, the Licenses pane displays the buttons as depicted in the following figure:
Figure 55. Preferences Licenses pane (unlicensed)

**Purchase License.** Click to purchase a ScreenFlow license from the Telestream Web site. The license is automatically installed upon completion of your purchase.

**Enter Serial Number.** Click this button to enter a serial number which has already been issued. This field is case sensitive. All letters must be capitalized and hyphens must be included.

**Deactivate Serial Number.** This option is disabled.

**Changing and Deactivating a Serial Number**

When ScreenFlow is licensed, the Licenses pane displays the buttons as depicted in the following figure:

Figure 56. Preferences Licenses Pane (Licensed)
Upgrade License. Click to upgrade your ScreenFlow license from a previous version, thereby enabling full access to the features of the current ScreenFlow version. The upgrade fee depends on which license you have installed.

Change Serial Number. Click to enter a different serial number that you have already purchased for use with ScreenFlow.

Deactivate Serial Number. Click to deactivate your ScreenFlow license. This allows you to use your license on a different computer. Please allow up to 15 minutes to process the deactivation before re-activating this serial number.
This topic describes ScreenFlow’s menus.

Topics
- ScreenFlow Menu
- File Menu
- Edit Menu
- Insert Menu
- Font Menu
- Actions Menu
- View Menu
- Window Menu
- Purchase Menu (Telestream Web Store Only)
- Help Menu

ScreenFlow Menu
This topic describes each item in the ScreenFlow menu.

About ScreenFlow
Displays a dialog indicating the version of ScreenFlow you are running.

Check For Updates
Note: This option is not available to users who purchased from the Mac App Store. The App Store has its own update procedure.
Checks Telestream’s Online Store to determine if there is a more recent version of ScreenFlow available. If so, you can download it.
To check for ScreenFlow updates automatically, check the Check for Updates option in the General Pane.
Preferences (Command-,)
Displays the Preferences window so that you can view and change ScreenFlow preferences. If the Preferences window is already open, it is brought to the front.

Services
Displays Macintosh Services – none are implemented in ScreenFlow.

Hide ScreenFlow (Command-H)
Hides all ScreenFlow windows.

Hide others (Alt-Command-H)
Hides all other application windows (every window which is not a ScreenFlow window).

Show All
Shows all previously hidden windows.

Quit ScreenFlow (Command-Q)
ScreenFlow closes all open documents and then quits. If a document has not been saved, ScreenFlow displays a Save dialog, so you can save the document before quitting.
If Launch ScreenFlow Helper at user login in is checked in the Preferences General Pane, ScreenFlow Helper stays running when you quit ScreenFlow.

File Menu
This topic describes each item in the File menu.

New Recording (Command-N)
Displays the Configure Recording window (see Using the Configure Recording Window), which allows you to select recording options and record a new clip. When complete, the clip is added to a new, untitled document if no document is open, or if one or more documents are open, you can choose to create a new document or add it to an open document.

New Empty Document (Shift-Command-N)
Displays a new, untitled ScreenFlow document.

Open (Command-O)
Displays the Open dialog, so you can navigate and open a ScreenFlow document that was saved earlier.
Open Recent
Click to select from up to 15 recently accessed documents.
Every time you open or save a document, it is entered into the Open Recent list. You can select “Clear Menu” from the “Open Recent” menu to reset the list.

Add Additional Recording (Shift-Command-R)
Configures a new recording to be added to a currently open document. (See Adding A Recording.)

Close (Command-W)
Closes the active ScreenFlow document. If the document has never been previously saved, ScreenFlow displays a Save As dialog, so you can name the document, then save the document in the desired folder before closing it.

OS X Lion Save Commands
Due to the introduction of new file save features in OS X 10.7 Lion, ScreenFlow save features are different depending on which operating system is used. The following save options are specific to OS X Lion.

Save a Version (Command-S)
Saves the document with recent changes. If the document has never been previously saved, ScreenFlow displays a Save As dialog, so you can name the document, then save the document in the desired folder.

Duplicate
Saves a new version of the document without overwriting the previous version. This allows you to save the project with a new name and/or location.

Revert to Saved
Restores the document to the state it was in when last saved. This will undo any action taken since the last save.

OS X Snow Leopard Save Commands
Mac OS X 10.6 Snow Leopard does not have the same save functionality as OS X 10.7 Lion. The following save commands are specific to OS X Snow Leopard.

Save (Command-S)
Saves the document with recent changes. If the document has never been previously saved, ScreenFlow displays a Save As dialog, so you can name the document, then save the document in the desired folder.
Save As (Shift-Command-S)
ScreenFlow displays a Save As dialog, so that you can rename the document with a new name, then save the document in the desired folder. If you have previously saved your document, this duplicates the document and does not alter the original.

Publish to YouTube
Displays the Publishing to YouTube dialog, so you can log in to your YouTube account, encode your screencast and publish your video.

Publish to Vimeo
Displays the Publishing to Vimeo dialog, so you can log in to your Vimeo account, encode your screencast and publish your video.

Publish to Flash
Displays the Publishing to Flash dialog, which you use to encode your screencast in Flash (F4V) format and save the file.

Export (Command-E)
Displays the Export dialog (see Exporting Your Video), which you use to select your encoding options, encode your screencast and save the file.
When you have in and out points set on your timeline, this menu item displays as Export Selected Range.

Edit Menu
This topic describes each item in the Edit menu.

Undo (Command-Z)
Reverts your last change. ScreenFlow offers an unlimited number of undo/redo actions (limited only by memory constraints). However, undo information is stored on a per-window basis. If you close a window and then reopen it, your undo information for that window is lost.

Redo (Shift-Command-Z)
Reverts your last Undo action.

Cut (Command-X)
Select Cut to remove these selected clips:
• Removes selected text in a text box, and places it on the clipboard.
• Removes the selected clips from the project and places them on the clipboard.
Copy (Command-C)
Select Copy to duplicate these selected clips:
• Duplicates selected clips in the timeline and places a copy onto the clipboard.
• Duplicates selected text in a text box, and places the text onto the clipboard for pasting later.

Note: Clips in the media library cannot be copied, but can be imported into the timeline multiple times.

Paste (Command-V)
Select Paste to add clips and text from the clipboard to your document:
• Pastes copied text into the text box at the cursor position. When you paste text, it retains its formatting (see Paste and Match Style (Alt-Shift-Command-V)).
• Pastes the copied clip onto the timeline starting from the scrubber, in the same track as the original clip, as shown below:

Figure 57. Timeline just prior to a clip paste operation

Select Paste to add the clip on the clipboard to the timeline:

Figure 58. Timeline after pasting a clip from the clipboard

If the clip is pasted again, a new track is created for each new copy.

Paste Properties
Select Paste Properties to update the properties of the selected clip in the timeline with the properties of the current clip on the clipboard.
Paste Properties has the following sub menu items:
Video (Alt-Command-I). Pastes video properties into a video clip.
Audio (Alt-Command-A). Pastes audio properties into an audio clip.
Screen Recording (Alt-Command-S). Pastes screen recording properties into a screen recording clip.
Callout (Alt-Command-C). Pastes callout properties into a callout action.
Paste and Match Style (Alt-Shift-Command-V)
Select Paste and Match Style to add text on the clipboard to your text box. Inserted text adopts the text formatting of the character immediately preceding the insertion point.

Delete (Backspace)
Select Delete to permanently remove the currently selected items. Delete does not place the item on the clipboard.
If you have marked in and out points, the segment between the in and out point is deleted for all clips, as shown below:

Figure 59. Mark In and out points on your timeline

Select Delete to remove all assets from the timeline between the in and out points:

Figure 60. Delete the assets between the in and out points

Note: To shift clips left to fill the hole created by the deletion, use Ripple Delete (Command-backspace), the scrubber handle, or right-click (Control-click) in the empty space and select Close Gap.

Select All (Command-A)
Choose Select All to highlight all clips in the timeline.

Deselect All (Shift-Command-A)
Choose Deselect All to deselect all clips in the timeline. This can also be done by clicking in an empty area of the canvas or timeline.
Split Clip (T)
Select Split Clip to convert each selected clip into two separate clips, splitting them at the current scrubber point, so that you can adjust the parts of the clip independently.

Figure 61. Timeline before splitting a clip

Figure 62. Timeline after splitting a clip

When splitting a clip, the previous clip name is retained on both clips. By default, each segment of a clip uses the name of the original media located in the Media Library. These segments can be renamed for convenience and clarity. This action is applied with Command-T, Command-Shift-T, or simply T.

Detach Audio
Select Detach Audio to remove the audio stream from the selected clip (visible as a green waveform through the center of the clip unless View > Show Audio Waveforms is unchecked), and create a new audio clip, creating an independent audio clip at the same point in the timeline.

Figure 63. Timeline just prior to a clip Detach Audio operation

ScreenFlow adds the audio to a new audio clip in the timeline:

Figure 64. Timeline after detaching audio from a clip
After the operation, a new audio clip, which contains the audio from the selected video clip, is added to the timeline. The previous video/audio clip is now video only.

**Add Freeze Frame (Shift-Command-F)**

Select Add Freeze Frame to insert a freeze frame in the middle of a selected clip. First, the clip is split at the scrubber, then a two second freeze frame is inserted between the clips. The duration of the freeze frame can be set by dragging the edge of the clip, much like any other still image clip. The second half of the clip is moved to the right to adjust for the added clip.

**Figure 65.** Timeline just prior to a Add Freeze Frame operation

![Timeline just prior to a Add Freeze Frame operation](image)

ScreenFlow adds two new clips to the timeline:

**Figure 66.** Timeline after detaching audio from a clip

![Timeline after detaching audio from a clip](image)

This is useful for pausing your video while demonstrating or narrating.

**Trim Front to Scrubber (W)**

Select Trim Front to Scrubber to trim the front of the selected clips from the start of the clip up to the scrubber position.

Alternatively, you can adjust the left side of the clip by clicking the mouse just near the left edge of the clip (the mouse pointer changes to the drag cursor [left]) to indicate that you can resize the clip. Click and drag the edge of the clip to the right to trim the amount you want off of the front of the clip. This method is functionally equivalent to using the Trim Front to Scrubber command.

**Trim End to Scrubber (E)**

Select Trim End to Scrubber to trim the back of the selected clips from the end of the clip up to the scrubber mark.

Alternatively, you can adjust the right side of the clip by clicking the mouse just near the right edge of the clip (the mouse pointer changes to the drag cursor [left]) to indicate that you can resize the clip. Click and drag the edge of the clip to the left to trim the amount you want off of the back of the clip. This method is functionally equivalent to using the Trim End to Scrubber command.
Lock Clip/Unlock Clip (Alt-Command-L)
Select Lock Clip to lock selected clips to their positions in the timeline and cannot be moved. (When clips are locked, you cannot move other clips onto them to make transitions. Select again to unlock selected clips you have previously locked.

Add Starting Transition/Remove Starting Transition
Select Add Starting Transition/Remove Starting Transition to add transitions to the beginning of the selected clips. Apply again to remove the transition.

Add Ending Transition/Remove Ending Transition
Select Add Ending Transition/Remove Ending Transition to add transitions to the ending of the selected clips. Apply again to remove the transition.

Ripple Delete (Command-Backspace)
Select Ripple Delete to delete the content between the in and out points on all tracks of the timeline and shift all clips left to close the gap in the timeline.

Mark In Point (I)
Select Mark In Point to set the in point of a range in the timeline at the current point of the scrubber. When you create an in point without an out point, ScreenFlow automatically sets the out point to the end of the last clip in the timeline, and highlights the range in blue. In and out points can be used to delete entire sections of your timeline using the Ripple Delete command.
Select the in point (click on the line directly over the timeline scale) and drag it right or left to adjust its point on the timeline.
Shift-click on the timeline scale to set in and out points relative to the position of the scrubber.

Mark Out Point (O)
Select Mark Out Point to set the out point of a range in the timeline at the current point of the scrubber. When you create an out point without an in point, ScreenFlow automatically sets the in point to the beginning of the timeline, and highlights the range in blue. In and out points can be used to delete entire sections of your timeline using the Ripple Delete command.
Select the out point (click on the line directly over the timeline scale) and drag it right or left to adjust its point on the timeline.
Shift-click on the timeline scale to set in and out points relative to the position of the scrubber.

Clear In & Out Points
Select Clear In & Out Points to remove the in and out points you created previously.
Markers
The Markers menu item has the following submenu options:

Add (‘)
Select to add a marker to the timeline at the scrubber location.
If you export a ScreenFlow document as a QuickTime movie, chapter markers are placed at each named marker position in the movie when Add Chapter Track from Markers is checked.

Delete (Shift-~)
Select to delete the selected marker.

Delete All
Select to delete all markers in the timeline.

Goto Next (Shift-Up Arrow)
Select to move the scrubber to the next marker to the right on the timeline.

Goto Previous (Shift-Down Arrow)
Select to move the scrubber to the previous marker to the left in the timeline. You can also use the mouse to drag markers and adjust their position.

Special Characters (Alt-Command-T)
Displays the Characters window so that you can enter special characters in text fields.

Insert Menu
This topic describes each item in the Insert menu.

Text Box
Select Text Box to insert a text clip into the project at the current scrubber position. Text box duration is five second, but can be adjusted by dragging the edge of the clip in the timeline.

Speech Clip
Select Speech Clip to display s sheet where you enter text, select a voice, then click Insert to create an audio clip in your project by converting text to speech using one of six automated voice programs. Text can be typed directly into the field or pasted from another document.
Choose (Shift-Command-V)
Select Choose to import media files into your screencast at the current scrubber position. ScreenFlow displays the Open dialog, so that you can browse your file system or network server and select the media file to add. The selected media file is added to the Media Library as well as the project.

Font Menu
This topic describes each item in the Font menu. Font options apply only to text clips in your project.

Show Fonts (Command-T)
Displays the System Font Panel. Select a font to apply to highlighted text, or all text if none is selected.

Bold (Command-B)
Makes the current text selection bold.

Italic (Command-I)
Makes the current text selection italic.

Underline (Command-U)
Underlines the current text selection.

Bigger
Increases by one point the font size of the current text selection.

Smaller
Decreases by one point the font size of the current text selection.

Kern
Kerning adjusts the distance between glyphs (characters) in text to make it look better balanced. For example, tucking in the A under the V in the phrase AV. Kern applies to all selected text in a text box. If no characters are selected but the insertion cursor is placed between two characters, Kern applies to that pair.
The Kern menu item has the following submenu options:

Use Default
Use the default kerning built into the font.

Use None
Disable all kerning.
**Tighten**
Decrease the distance between characters.

**Loosen**
Increase the distance between characters.

**Ligature**
A ligature is a character that combines two or more other characters. For example the ligature ? combines f and i. Not all fonts contain all ligature characters, but their use is turned on by default in ScreenFlow.
The Ligature menu item has the following submenu options:

**Use Default**
Use ligatures if the font uses them.

**Use None**
Do not use ligatures.

**Use All**
Use ligatures.

**Copy Style**
Copies the Text style of the selected text. This does not copy the background of the text as the background is for the whole Text Box.

**Paste Style (Alt-Command-V)**
Applies the previously copied Text Style to the currently selected text. This does not paste the background of the text as the background is for the whole Text Box.

**Make Text Properties Default**
Saves all the current text properties for the selected Text Box clip and make them the default. When you create a new Text Box, the default text properties are used.

**Actions Menu**
This topic describes each item in the Actions menu. Actions are time-based changes to clip clips used to create gradual or temporary effects. A clip must be selected for the items in this menu to be active. Actions are often applied to a clip in pairs: one at the beginning, and the other at the end.

**Add Video Action (Command-K)**
Adds a Video Action to the selected clip at the location of the scrubber. A Video Action allows you to apply effects like Zoom, Pan, and Rotate to your video clip.
Add Audio Action (Alt-Command-U)
Adds an Audio Action to the selected clip. An Audio Action allows you to apply various effects on the audio of the selected clip, such as muting, ducking, or adjusting the volume.

Add Screen Recording Action (Command-R)
Adds a Screen Recording Action to the selected screen recording clip. Screen Recording actions enable you to modify the size of the Mouse Pointer, add click effects, or show keys pressed, for example.

Add Callout (Command-L)
Adds a Callout to the selected screen recording clip. A callout lets you focus attention on a section of your screencast. For example, you can highlight the Mouse Pointer by dimming everything but the area just around the Mouse Pointer or highlight and magnify the foreground window.

Add Annotations (Alt-Command-T)
Adds simple graphic effects to visual clips including recordings, videos, and image files. Annotation shapes include circle, square, line, and arrow.

Goto Next Action
Within a clip, selects the next action.

Goto Previous Action
Within a clip, selects the previous action.

Curve Type
By default, actions are applied to the clip in a linear manner. For example, when applying a scaling action, the image size changes by equal amounts from start to finish. This may be perceived as too abrupt, so you can modify the rate with which an action is applied.

The Curve Type menu item has the following submenu options:

Default
Linear transition.

Ease-In
Starting slow, speeding up towards the end.

Ease-Out
Starting fast, slowing down towards the end.
Ease-In & Out
Starting and ending slowly, faster in the middle.

None
Apply action immediately. The duration of the action is ignored if this option is applied.

View Menu

This topic describes each item in the View menu. View options determine how the media is presented both on the Canvas and in the Timeline.

Enter Full Screen (Command-F)
Only available in OSX 10.7 Lion. Displays the editing window in full screen mode to reduce on-screen clutter.

Enter Preview (Alt-Command-F)
Displays the screencast in full screen mode for playback only. Press Escape to exit preview.

Zoom In (Command-=)
Magnify the canvas area of ScreenFlow.

Zoom Out (Command--)
Reduce the canvas area of ScreenFlow.

Zoom to 100% (Alt-Command-0)
Display the canvas area at its direct pixel size.

Zoom to Fit
Magnify the canvas of ScreenFlow so that all contents are visible in the window with a bit of margins on the sides. These options only change how your screencast is displayed on the canvas. They do not alter the media.

Zoom Timeline to Fit (Control-T)
Scales the timeline to fit all content in your window.

Zoom Timeline In (=)
Expands the timeline.

Zoom Timeline Out (-)
Contracts the timeline.
Snapping (Control-N)
Toggles snapping for both the canvas and timeline.
When snapping is on, the mouse snaps to various guide-lines. For example, in the canvas, the mouse snaps your objects to the center and edges of your canvas. It also snaps to other objects, if you have any. In the timeline, the mouse snaps to the beginnings and endings of actions and clips.
You can temporarily toggle snapping by holding down the Command key.

Scrub Live Audio (Shift-S)
When activated, you can hear the audio track while dragging the scrubber.

Show Audio Waveform
When activated, clips that contain audio have the audio waveform shown along the center of the clip.

Show Thumbnail Icons
When activated, each clip displays a thumbnail icon displaying either the first frame of content (for video or image files) or a format icon for audio or text clips.

Window Menu
This topic describes each item in the Window menu.

Minimize (Command-M)
Minimizes the foreground window.

Zoom
Scales the foreground window to the full size of the screen.

Markers
Opens a window listing the markers in the front-most document. You can add, delete, rename, and jump to markers in this window.
Using ScreenFlow Menus

Purchase Menu (Telestream Web Store Only)

This menu is for purchasing from the Telestream Web Store and activating your ScreenFlow license.

Purchase ScreenFlow Online
Displays the Licenses pane of ScreenFlow Preferences to purchase a license. For details, see Unlocking ScreenFlow (Telestream Web Store Only).

Unlock ScreenFlow
Directs the user to the Licenses pane of ScreenFlow Preferences to enter a license. Unlocking ScreenFlow (Telestream Web Store Only).

Help Menu
This topic describes each item in the Help menu.

Search
Searches this documentation.
**ScreenFlow Help (Command-?)**
Opens the ScreenFlow Help page, where you can access the ScreenFlow User’s Guide in HTML format, view screencasts of ScreenFlow topics, and access other helpful resources.

**Visit ScreenFlow Web site**
Opens the Web page for general ScreenFlow information.

**Visit Support Page**
Opens the Web page for ScreenFlow support information.

**Provide ScreenFlow Feedback**
Opens the Web page for contacting technical support.

**Clip Contact Menu**
Right-click (or Control-click) on a clip in the timeline to show the clip contact menu.

![Figure 68. Clip contact menu](image)

This menu represents numerous menu options detailed in the Edit Menu (83). Described below are menu items only available in this menu.

**Show Clip Inspector**
Select to open the Clip Inspector window.
Here you can change the duration or speed of a clip as well as lock it from further editing.

**Rename Clip**
Select to rename the clip in the timeline. The new name only effects this specific clip and does not change the name of the source in the media library. You can also change the name by double-clicking the name of the clip on the clip itself.

**Track Selection**
Use the All Clips option to select all clips on this track. Use the All Clips after current Clip option to select all clips following the selected clip on this track.
Troubleshooting

This section describes common questions with ScreenFlow which may be addressed by the user. If your issue is not listed or the recommended procedure does not work, please contact technical support.

Why doesn’t ScreenFlow play a movie file I imported?
If ScreenFlow cannot play a movie file you’ve imported, attempt to open the media in QuickTime Player. If QuickTime Player cannot open the file, most likely the codec is not installed. If QuickTime Player can play the clip and the clip does not play in ScreenFlow, please contact technical support.

I exported my video, but it looks fuzzy or blurry. What can I do to make it look better?
When using ScreenFlow, it can be difficult to record your entire display at full resolution then compress that data into a low-resolution video while still retaining your necessary level of image clarity. Here are a few things you can do:

- Export using the Lossless uncompressed video format. As long as you do not lower the resolution, it is identical to the original recording, but results in a large file size. This is ideal if you require additional editing or reformatting outside of ScreenFlow before publishing it.
- Reduce your display resolution before recording (System Preferences/Displays). By reducing your display resolution before recording, you require less compression later. We recommend that you decide what size you want your video to be in advance. Then, lower your display resolution as close to that as possible, but no smaller. If you use a smaller resolution than your output, you will lose image clarity.
- Use the scale and zoom functions in ScreenFlow. If you do not want to reduce your display resolution or export to a large, uncompressed format, your best option is to use Video Properties > Scale or Callout Action > Zoom. These functions allow you to increase the visibility on a specific portion of the recording which can be valuable for maintaining clarity in a heavily compressed video.
- Text is the hardest item to reproduce clearly in digital video. Digital video was not designed to recreate detailed figures like text. It was designed to map color spaces,
so the thin lines of text can be particularly difficult to recreate. If you have text in your project, it is best to use the Scale feature or to increase the text size.

How do you designate a recording area?
Although many screen capture programs function by designating a recording area, ScreenFlow does not. ScreenFlow captures the entire monitor and all of its contents. This enables you to make use of the entire monitor during editing in post-production. When using a program which designates a recording space, you may unexpectedly move outside of this space due to a menu option or pop-up. If your recording space is preset, there is no way to recover this lost information. With ScreenFlow's reliance on post-production editing, you can move outside your area of focus when necessary. If you are recording a small video area, you may be concerned that a full-screen recording will take up unnecessary disk space. ScreenFlow's adaptive recording method captures minimal information on parts of the screen where there is no action, so this has very little effect on file size.

Does ScreenFlow work with Parallels or VMware?
Since ScreenFlow captures everything on your monitor, both Parallels and VMware are supported (including Computer Audio output). However, ScreenFlow cannot use the Callout features, as these are dependent upon information provided by Mac OS X. Telestream has tested ScreenFlow with Parallels in all modes (Coherence, Window, and Full Screen) without issue. In fact, when using Parallels/VMware, some users have reported that ScreenFlow produces smoother, higher-quality output while using less CPU resources than native Windows screen capture programs.

What kind of graphics card should I use?
ScreenFlow requires a Quartz Extreme-capable graphics card. If you are unsure if your graphics card is supported, please download an evaluation version; ScreenFlow will notify you if it is not supported. You can expect most Mac hardware made in the last five years to fully support Quartz Extreme graphics cards. ScreenFlow uses video RAM (or VRAM) during the recording process, so it is important to have a graphics card with at least 64 MB of VRAM, but we recommend 128 MB. The amount of VRAM necessary to record smooth video depends on your display resolution and whether or not other applications are simultaneously using VRAM. If you have insufficient VRAM, the recording will drop frames and the video skips during playback.

Does ScreenFlow support audio interface or mixing devices?
ScreenFlow does not support audio interface or mixing devices. However many of these devices will work with ScreenFlow if the audio is routed properly. If you are having trouble with your mixer, we recommend posting your issue on our forum.

Does ScreenFlow support closed captioning?
ScreenFlow does not support closed captioning. This process is performed following video production in a separate application specifically designed for closed captioning.
**How do I use ScreenFlow to record my iPod/iPhone/iPad?**

ScreenFlow cannot record these devices directly, but can record demonstrations using the XCODE simulator on Mac OS X.

**My USB microphone and iSight camera are out of sync. What should I do?**

If the audio and video are out of sync, try using the audio input on the computer (not the USB input) as there can be a latency problem between USB input and the iSight camera. This is particularly evident when recording a “talking head.” Use a microphone that utilizes the audio input into the computer.
Installing ScreenFlow

This topic specifies the system requirements for ScreenFlow, and describes how to install, upgrade, or uninstall ScreenFlow and related subsystems.

To export your screencast in Windows Media format, ScreenFlow uses Flip4Mac WMV Components for QuickTime. Flip4Mac WMV must be installed and licensed separately for full functionality. If Flip4Mac is not licensed, it functions in demo mode to provide a sample of its capabilities.

To export a full length Windows Media file, Flip4Mac requires a Flip4Mac WMV Studio license. Customization beyond the preset profiles requires a Flip4Mac WMV Studio Pro license.

For more information and to download the installer, go to the Telestream Flip4Mac Web page.

Topics
- System Requirements
- Installing ScreenFlow
- Upgrading ScreenFlow
- Installing Telestream Audio
- Removing ScreenFlow from Your Computer

Note: Be sure to review your platform requirements before installing ScreenFlow.

System Requirements
- Mac OS X Snow Leopard 10.6.7 or later
- Intel-based CPU required. Core 2 Duo recommended.
- A supported programmable GPU required for certain effects & functionality

Note: Cameras using an HDV codec are not supported.
Installing ScreenFlow

**Note:** This installation process does not apply to users who purchased from the Mac App Store. The App Store has its own installation and licensing procedure.

ScreenFlow is available from [www.telestream.net](http://www.telestream.net) as a disk image file (dmg).

When you download or open the dmg file in Safari, Mac OS X automatically mounts the disk image and runs the installer. When you download a dmg file using another Web browser, you should mount the file yourself. Then, double-click it to run the installer.

**Note:** You are prompted for an administrator name and password during installation. If you don't have an administrative account, you need to obtain one to continue.

The installer attempts to close QuickTime, Final Cut Pro, Episode Desktop, and Pipeline Control before installation. If any of these applications can't be closed (for example, because they have an open document that hasn't been saved) installation will fail after about a minute (unless you click Save or Discard during this time to close the application).

When the installer runs, it displays the following window:

**Figure 70. Installing ScreenFlow**

Drag the ScreenFlow icon onto your Applications folder to install ScreenFlow. If a previous version is in the Applications folder, the Finder displays a Copy dialog, asking you to confirm that you want to replace the ScreenFlow file. Click Replace to complete installation.

Close the installer – ScreenFlow is installed and ready for you to use.
Upgrading ScreenFlow

Note: This topic does not apply to users who purchased from the Mac App Store. The App Store has its own installation and licensing procedure.

If you currently have a license for ScreenFlow 1.0 or 2.0, this license will not work in 3.0 and you will be required to upgrade your license in order to activate ScreenFlow 3.0.

1. To upgrade your license, in ScreenFlow, select ScreenFlow > Preferences > Licenses.
2. Click the Lock icon at the bottom of the panel, and enter your password to allow ScreenFlow to make changes to your license.

Note: Your user must be an administrator. If your username is not an administrative account, you’ll need to create one in order to continue.

3. Click Upgrade License. This redirects you to the Telestream online store where you will receive an upgraded license at a discount price.
4. Upon completing your purchase, the new license is automatically installed and activated.

Installing Telestream Audio

To capture computer audio, ScreenFlow must install the Telestream Audio driver. The installation process begins automatically if you attempt to record computer audio without the driver installed.

1. In ScreenFlow, select ScreenFlow > Preferences > Advanced.
2. Click the Install Driver button to display the Install Telestream Audio dialog using the Installer application.
3. Click Continue to proceed. The installer displays a space requirement message.
4. Click Install to continue.
5. Enter your password to install the driver and click OK to continue.

Note: Your user must be an administrator. If your username is not an administrative account, you’ll need to create one in order to continue.

6. The installer installs the Telestream Audio driver. Upon completion, click Close to close the Installation Complete dialog.

Uninstalling Telestream Audio

To uninstall the audio driver, in ScreenFlow, select ScreenFlow > Preferences > Advanced. Click the Uninstall Driver button and enter an administrator username and password to uninstall the driver.
Removing ScreenFlow from Your Computer

To uninstall ScreenFlow, simply move the ScreenFlow application to the trash. (The ScreenFlow license is stored separately, so you do not need to re-activate your license if you reinstall ScreenFlow.)

To completely remove ScreenFlow from your computer, move the following files to your trash:

- /Applications/ScreenFlow
- /System/Library/Extensions/TelestreamAudio.kext
- /Library/Preferences/net.telestream.screenflow.plist
- ~/Library/Preferences/com.vara.screenflow.plist
- ~/Library/Preferences/com.vara.screenflowhelper.plist
- ~/Library/Preferences/net.telestream.screenflowapp.plist
- ~/Library/Preferences/net.telestream.screenflowapp.plist
- ~/Library/Preferences/net.telestream.screenflowhelper.plist

**Note:** Some of these files may not be present, because the associated feature was not used.
Index

A
actions 28
    curve type 29
Actions menu 28
activating your serial number 20
activation 20
    changing license 22
deactivation 22
add chapter track from markers 20
adding a recording 21
annotations properties 38
    color 38, 39, 41
dot endpoints 39
    outline 38
shadow 38
shapes 38
thickness 38
arrows 38
audio
    detach from video 23
ducking 33
    effects 33
    enable/disable waveform 31
audio driver 19
    un installing 19
audio interface 18
audio properties 32
    d upt aking 33
effect 33
    mix input to mono 33
mute audio 33
    smooth volume levels 33
    volume 33
auto update 18
automated voice 26
axis rotation 30
B
background color 21
background noise 33
blur 37
brightness 31
C
callout properties 36
    blur 37
der_emit  background 37
d border 37
build 37
feather 37
highlight 36
opacity 37
outline 37
round 37
shadow 37
zoom up 37
callouts 36
canvas 19
color 21
crop 21
    snap to front window 21
    zoom 30
censor 37
change license 22
changing speed 26
chapters 20
clip contact menu 33
clip inspector 33
closed captioning 18
compressing video 20
configure recording 17
contrast 31
copy 21
copyright notice i
countdown 18
create empty document 18
create or close gap 24
create or close timeline gap 25
cropping
canvas 21
image 22
curve type 29
cut 20
D
deactivating license 22
delete media 42
detach audio 23
drawing shapes 38
ducking 33
E
Edit menu 20
add freeze frame 24
copy 21
cut 20
detach audio 23
lock/unlock clip 25
mark in point 25
mark out point 25
markers 26
paste 21
redo 20
ripple delete 25
special characters 26
split clip 23
trim to end 24
trim to front 24
undo 20
editing
actions 28
curve type 29
annotations properties 38
audio properties 32
blur 37
brightness 31
callout properties 36
canvas 19
changing speed 26
clip contact menu 33
clip inspector 33
contrast 31
create or close gap 24
create or close timeline gap 25
drawing shapes 38
freeze frame 26, 24
group 26
highlight 36
image cropping 22
in and out points 25
lock clip 26
markers 27, 26
media library 42
positioning 30
rename clip 34
ripple delete 25
saturation 31
scaling 22, 30
screen recording properties 34
split clip 24, 23
text boxes 39
text properties 39
timeline 22
tour 20
track selection 34
tracks 23
transitions 27
transitions inspector 27
trim 24
video properties 29
volume 33
window 18
editing window 18
canvas 19
timeline 22
tracks 23
election 34
export 17
chapters 20
customize 21
  Flip4Mac (Windows Media) 22
  QuickTime 21
dimensions 19
frame size 19
manage 19
  Flip4Mac (Windows Media) 22
  QuickTime 21
motion blur 20
presets
  Apple TV 19
 creating your own 19
customize 21
  iPad 19
  iPhone 19
  iPod 19
Lossless 18
make settings default 19
Web - High 18
Web - Low 18
Windows Media 18
resolution 19
tour 26
video file size 20

F
features
  new 18
feedback 33
File menu 18
  open 18
  save 19
Flash 29
  contents 30
  how to publish 31
font 40
  size 40
Font menu 27
  copy style 28
  kern 27
  ligature 28
  make text properties default 28
  paste style 28
freeze frame 26, 24
full screen 30

G
group 26

H
Help menu 32
  ScreenFlow Help 33
  search 32
  visit ScreenFlow support 33
  visit ScreenFlow website 33
Helper 19
hide desktop icons 20
highlight 36

I
image
  cropping 22
  opacity 31
  reflection 31
  scaling 22, 30
  setting default duration 19
  shadow 31
importing media 42
in and out points 25
  clear 25
  mark in 25
  mark out 25
in points 25
Insert menu 26
  choose 27
  media 27
  speech clip 26
  Text box 26
installing 18

K
kern 27

L
licensing 20
  change serial number 22
  deactivation 22
  upgrade 22, 19
  ligature 28
  lock clip 26
M
magnify 37
  setting smoothness 19
manual 33
markers 27, 26
  window 31
media library 42
  add media 42
  add recording 42
  contact menu 42
  delete 42
  preview 42
  rename 42
  zoom 42
media management 42
menu
  Actions 28
  Edit 20
  File 18
  Font 27
  Help 32
  Insert 26
  Purchase 32
  ScreenFlow 17
  View 30
  Window 31
mix input to mono 33
motion blur 20
MPEG disclaimers ii
mute 33
N
narration 23
new features 18
noise 33
normalize 33
notices, legal, generally i
O
opacity 31
open 18
out points 25
P
paste 21
paste properties 21
pointer
  click effect 34
  enlarge 34
  image 34
  opacity 35
  sound 35
  zoom 34
position 30
preferences
  auto update 18
  capture scratch disk 20
  countdown 18
  general 17
  installing/uninstalling audio driver 20, 19
  opening 18
  preview 30
preview media 42
properties
  actions 28
  annotations 38
  audio 32
  callout 36
  paste 21
  screen recording 34
  text 39
  video 29
publish
  Flash 29
  Vimeo 25
  YouTube 24
Purchase menu 32
purchasing 20, 32
Q
quit 18
Index

R
recording
  add 21
  capturing text 23
  compression 19
  configure recording 17
  countdown 18
  pause hotkey 18
  preferences 22
  start/stop hotkey 18
  tips 23
  tour 18
recovering lost recordings 20
redo 20
reflection 31
removing ScreenFlow 20
rename clip 34
rename media 42
repositioning 30
ripple delete 25
rotation 30

S
Safari, using to download installer 18
saturation 31
save 19
scaling 22
  image 22, 30
  setting smoothness 19
scratch disk 20
screen recording properties 34
  click effect 34
  opacity 35
  pointer 34
  pointer zoom 34
  show keys pressed 35
  show modifier keys pressed 35
  sound on click 35
ScreenFlow
  FAQ and Forum 1
tech support email 1
unlocking 20
website for 1

ScreenFlow Helper 19
  disable 18
  hide desktop icons 20
  launch at user login 18
ScreenFlow menu 17
  check for updates 17
  provide ScreenFlow feedback 33
scrub live audio 31
serial number, entering 20
setting display resolution 23
shapes 38
show clip inspector 33
show keys pressed 35
show modifier keys 35
smooth volume levels 33
snapping 31
special characters 26
speech clip 26
split clip 23
support 1, 33
system requirements 17

T
tech specs 17
technical specifications 17
technical support 1, 33
  email address 1
  website 1
Telestream
  address 1
  contacting iv, 1
  information about 1
  International 1
  mailing address 1
  sales and marketing 1
  ScreenFlow email support site 1
  ScreenFlow FAQ and Forum 1
  ScreenFlow support site 1
  technical support 1
  Web site 1
Telestream Audio 19
uninstalling 19
Index

Text
kern 27
ligature 28
paste and match style 22
special characters 26
text boxes 39
backdrop 41
copy style 28
paste style 28
special characters 26
text properties 39
alignment 40
backdrop 41
fill 40
font 40
outline 41
paste and match style 22
set default 28
size 40
thumbnail icons 31
timeline 22
changing speed 26
clip contact menu 33
clip inspector 33
create or close gap 24, 25
freeze frame 26, 24
group 26
in and out points 25
lock clip 26
markers 27, 26
rename clip 34
scale 23
enable SMPTE timecode 19
split clip 24, 23
track selection 34
tracks 23
trim 24
track selection 34
tracks 23
setting default height 19
track controls 23
trademark notice i
trademark notices i
transitions 27
audio 28
setting default 19
transitions inspector 27
transparency 31
trim 24
end 24
front 24
troubleshooting
audio interface 18
closed captioning 18
export video quality 17
graphics card 18
importing files 17
iPad 19
iPhone 19
iPod 19
out of sync 19
Parallels 18
recording area 18
VMWare 18

U
undo 20
uninstalling ScreenFlow 20
unlocking ScreenFlow 20
update 17
automatic 18
upgrade license 19

V
version number, finding 17
video properties 29
brightness 31
contrast 31
opacity 31
position 30
reflection 31
saturation 31
scale 30
setting smoothness 19
shadow 31
x rotation 30
y rotation 30
z rotation 30
View menu 30
  enter full screen 30
eenter preview 30
scrub live audio 31
show audio waveform 31
show thumbnail icon 31
snapping 31
zoom 30
Vimeo 25
  setting up your account 26
  settings 29
  verify account 28
volume 33

W
  warranty iii
Warranty and Disclaimers iii
  website 1, 33
Window menu 31
  markers 31

X
  x rotation 30

Y
  y rotation 30
YouTube 24
  logging in 24
  settings 25

Z
  z rotation 30