Copyrights and Trademark Notices

Copyright © 2019 Telestream, LLC. All rights reserved. No part of this publication may be reproduced, transmitted, transcribed, altered, or translated into any languages without the written permission of Telestream. Information and specifications in this document are subject to change without notice and do not represent a commitment on the part of Telestream.

Telestream, CaptionMaker, Episode, Flip4Mac, FlipFactory, Flip Player, Lightspeed, ScreenFlow, Switch, Vantage, Wirecast, Gameshow, GraphicsFactory, MetaFlip, and Split-and-Stitch are registered trademarks and MacCaption, e-Captioning, Pipeline, Post Producer, Tempo, TrafficManager, and VOD Producer are trademarks of Telestream, LLC. All other trademarks are the property of their respective owners.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. Copyright 2004 MainConcept Multimedia Technologies.


Dolby and the double-D symbol are registered trademarks of Dolby Laboratories.

Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Other brands, product names, and company names are trademarks of their respective holders, and are used for identification purpose only.

**MPEG Disclaimers**

**MPEGLA MPEG2 Patent**

ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM MPEGLA, LLC, 6312 S. Fiddlers Green circle, Suite 400E, Greenwood Village, Colorado 80111 U.S.A.

**MPEGLA MPEG4 VISUAL**

THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEGLA, LLC. SEE HTTP://WWW.MPEGLA.COM.

**MPEGLA AVC**

THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEGLA, LLC. SEE HTTP://WWW.MPEGLA.COM.
MPEG4 SYSTEMS

THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers

Telestream, LLC. (the Company) warrants to the original registered end user that the product will perform as stated below for a period of one (1) year from the date of shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment supplied but not manufactured by the Company but NOT including any third party equipment that has been substituted by the Distributor for such equipment (the "Hardware"), is free from defects in materials and workmanship under normal operating conditions and use.

Software—if software is supplied as part of the product, the software will operate in substantial conformance with specifications set forth in its product user's guide. The Company does not warrant that the software will operate uninterrupted or error-free, will meet your requirements, or that software errors will be corrected.

Warranty Remedies

Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any defective Hardware component or part, or Software Media, with new or like new Hardware components or Software Media. Components may not be necessarily the same, but will be of equivalent operation and quality.

Software—if software is supplied as part of the product and it fails to substantially confirm to its specifications as stated in the product user's guide, the Company shall, at its own expense, use its best efforts to correct (with due allowance made for the nature and complexity of the problem) such defect, error or nonconformity.

Software Updates—if software is supplied as part of the product, the Company will supply the registered purchaser/licensee with maintenance releases of the Company's proprietary Software Version Release in manufacture at the time of license for a period of one year from the date of license or until such time as the Company issues a new Version Release of the Software, whichever first occurs.

To clarify the difference between a Software Version Release and a maintenance release, a maintenance release generally corrects minor operational deficiencies.
(previously non-implemented features and software errors) contained in the Software, whereas a Software Version Release adds new features and functionality. The Company shall have no obligation to supply you with any new Software Version Release of Telestream software or third party software during the warranty period, other than maintenance releases.

Restrictions and Conditions of Limited Warranty

This Limited Warranty will be void and of no force and effect if (i) Product Hardware or Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, neglect, or shipping, or as a result of service or modification by a party other than the Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties

THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral or written information or advice given by the Company, its distributors, dealers or agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF TELESTREAM, LLC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any Limited Warranty by the Company shall be the recovery of reasonable damages which, in the aggregate, shall not exceed the total amount of the combined license fee and purchase price paid by you for the Product.

Damages

TELESTREAM, LLC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS ESSENTIAL PURPOSE.
Further information regarding this limited warranty may be obtained by writing:

Telestream, LLC.
848 Gold Flat Road
Nevada City, CA 95959

You can call Telestream via telephone at (530) 470-1300.

**Telestream Contact Information**

To obtain product information, technical support, or provide comments on this guide, contact us using our web site, email, or phone number.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Contact Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Telestream Technical Support</td>
<td>Web site: <a href="http://www.telestream.net/telestream-support">www.telestream.net/telestream-support</a></td>
</tr>
<tr>
<td></td>
<td>Support Email: <a href="mailto:desktopsupport@telestream.net">desktopsupport@telestream.net</a></td>
</tr>
<tr>
<td>Telestream, LLC.</td>
<td>Web site: <a href="http://www.telestream.net">www.telestream.net</a></td>
</tr>
<tr>
<td></td>
<td>Sales and Marketing Email: <a href="mailto:info@telestream.net">info@telestream.net</a></td>
</tr>
<tr>
<td></td>
<td>Telestream, LLC.</td>
</tr>
<tr>
<td></td>
<td>848 Gold Flat Road</td>
</tr>
<tr>
<td></td>
<td>Nevada City, CA. USA 95959</td>
</tr>
<tr>
<td>International Distributor Support</td>
<td>Web site: <a href="http://www.telestream.net">www.telestream.net</a></td>
</tr>
<tr>
<td></td>
<td>See the Telestream Web site for your regional authorized</td>
</tr>
<tr>
<td></td>
<td>Telestream distributor.</td>
</tr>
<tr>
<td>Telestream Technical Writers</td>
<td>Email: <a href="mailto:techwriters@telestream.net">techwriters@telestream.net</a></td>
</tr>
<tr>
<td></td>
<td>If you have comments or suggestions about improving</td>
</tr>
<tr>
<td></td>
<td>this document, or other Telestream documents—or if</td>
</tr>
<tr>
<td></td>
<td>you've discovered an error or omission, please email us.</td>
</tr>
</tbody>
</table>

---

*Switch User Guide*
## Contents

### Preface 3
- Copyrights and Trademark Notices 3
- Telestream Contact Information 7

### Overview 13
- Introduction 13
- Switch Demo Restrictions 14
- Switch Player Features 14
- Switch Plus Features 14
- Switch Pro Features 14
- System Requirements 18
- Summary of License Features 18

### Installing Switch 21
- Introduction 21
- Installing Switch 21
  - Windows Error Messages 21
- Uninstalling Switch 22
- Updating/Activating/Deactivating Switch 22
- Opening Switch 22

### Opening Files 25
- Introduction 25
- Opening Files 25
- Opening Secondary Files 25
- Opening Flags 26
- Opening Recent Files 26
- Closing Files 26
**Media Playback 27**
Introduction 27
Play Bar 27
Control Menu 29
Timeline 31
  - GOP Mode 31
  - Datarate Mode 32
  - Flags Mode 32
Audio Control 33

**Inspecting Media 35**
Introduction 35
Media Inspector 35
  - Inspect/Edit Mode Switch 36
Container Tab 37
  - File Controls 37
  - Metadata and Secondary Audio/Subtitles 38
Video Tab 39
Audio Tab 40
Subtitle Tab 42
Time Tab 43
Flags Tab 43

**Editing Media 45**
Introduction 45
Media Inspector 45
  - Inspect/Edit Mode Switch 46
Container Tab 46
  - File Controls 47
  - Metadata and Secondary Audio/Subtitles 48
Video Tab 49
Audio Tab 53
Subtitle Tab 56
Time Tab 57
Flags Tab 59

**Exporting Media 61**
Introduction 61
Exporting Media 61
Exporting Movies 62
Exporting iTunes Packages 62
Exporting an iTunes Asset Only .itmsp Package 64
Exporting Video Frames 65
Exporting Flags 65
Exporting Inspector Info 66

Getting Help 67
Introduction 67
Getting Help 67
User Guides 67
Purchasing Switch 68
Customer Support 68

Preferences and Updates 71
Introduction 71
Setting Preferences 71
General 71
Update 72
License 73
Activating a Serial Number 73
Deactivating a Serial Number 74
Display 75
Audio 75
Check for Updates 75

Switch Menus 77
File Menu 77
Edit Menu 78
Inspect Menu 78
Control Menu 79
Audio Menu 80
View Menu 81
Export Menu 88
Window Menu 88
Help Menu 89

View and Window Controls 91
Introduction 91
View Control 91
Window Controls 99

Reference 101
Supported Codecs, Formats, & Protocols 101
Playback Format Support 101
Containers 101
Video Codecs (decode only) 102
<table>
<thead>
<tr>
<th>Contents</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio Codecs (decode only)</td>
<td>103</td>
</tr>
<tr>
<td>Caption</td>
<td>103</td>
</tr>
<tr>
<td>Encode Format Support</td>
<td>103</td>
</tr>
<tr>
<td>Containers</td>
<td>103</td>
</tr>
<tr>
<td>Video Codecs</td>
<td>103</td>
</tr>
<tr>
<td>Audio Codecs</td>
<td>104</td>
</tr>
<tr>
<td>iTunes Package Export</td>
<td>104</td>
</tr>
<tr>
<td>DPP/AMWA Certified Player</td>
<td>104</td>
</tr>
</tbody>
</table>

**Acknowledgments 105**

Acknowledgments 105
Introduction

Switch is a professional media player that plays files and allows you to inspect and edit them. Switch opens and plays virtually any media file, displays detailed information about that file, and lets users make changes to the file - saving time and ensuring higher accuracy in media inspection.

The built-in inspector displays information about your media such as audio channels, speaker labels, aspect ratio, clean aperture, bitrate, metadata, encoding formats and more. Edit mode enables modifications including trim, resize, and crop; changing aspect ratio; rearranging audio tracks; editing speaker assignments. You can also attach secondary audio to your video when exporting.

When Switch is unlicensed (the free Player version), it watermarks the video by placing the Switch logo in the upper right portion of the display. The audio is also watermarked with an occasional message. To remove the watermarks during playback, you must purchase and enter a valid Switch license serial number and activate it. There are three licensing levels: Player, Plus and Pro. (See Summary of License Features for a list of features included in each level.)

**Note:** Switch will watermark your media when in *transcode* mode and will truncate it when in *pass-through* mode.

Topics

- Switch Demo Restrictions
- Switch Player Features
- Switch Plus Features
- Switch Pro Features
- System Requirements
- Summary of License Features
Switch Demo Restrictions

The Switch Free Trial (unlicensed version) includes all features of Switch Pro but also watermarks all of these features.

Switch Player Features

The Switch Player license supports WMV files without restrictions and is capable of exporting to the MP4 container.

Playback Restrictions:
- Video watermark overlay for DNxHD, DNxHR, JPEG-2000 and HEVC on both Mac and Windows
- Audio watermark heard for AC-3 audio

Application Restrictions:
- Cannot add secondary subtitle files
- Cannot enable caption decoding
- Cannot display advanced metadata

Export Restrictions:
- If audio and video are in transcode mode, a watermark is added to the export.
- If either audio or video (or both) are in pass-through mode, export will be truncated to thirty seconds, or half the duration (if the source is less than thirty seconds).
- If audio and video are in transcode mode, and the source has AC-3 audio, export will have the audio watermark added.

Switch Plus Features

The Switch Plus license removes watermarking on all features except iTunes exporting. It also enables Caption and Subtitle playback of all supported formats, enables the Audio Meters feature, and enables viewing of Collaboration Markers on the timeline.

Switch Pro Features

The Switch Pro license enables all the features of the Plus license along with iTunes exporting. It also enables playback through external preview devices such as SDI monitors, enables comparison of alternate media, and allows a timeline view of the GOP structure and data rate. Additionally, the Pro license adds Loudness Meters and deep data inspection.
The table below lists the features of Switch for Playback, Inspection, and Export.

**Table 1. Switch Pro Features**

<table>
<thead>
<tr>
<th>Features</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Playback</strong></td>
<td></td>
</tr>
</tbody>
</table>
| Containers | AAC  
AC3  
AIFF  
AVI (open DML)  
AVC (AVC Elementary Stream)  
DV  
Flash  
GXF  
HEVC (HEVC Elementary Stream)  
LXF  
MOV  
M1V (MPEG-1 Video Elementary Stream)  
M2V (MPEG-2 Video Elementary Stream)  
MP3 (MPEG Layer 1,2,3 Audio Elementary Stream)  
MP4 (ISO Base Media Format)  
MPG (MPEG-1 System Stream)  
MPS (MPEG-2 Program Stream)  
MTS (MPEG-2 Transport Stream)  
MXF (OP-1a; AS02, AS03)  
MXF (OP-Atom)  
MXF (OP-1a proxy)  
MXF (OP-1b)  
SCC4  
TIFO  
WAV  
WMV, WMA, AVI, ASF |
### Table 1. Switch Pro Features

<table>
<thead>
<tr>
<th>Features</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Video Codecs</strong></td>
<td>Apple ProRes</td>
</tr>
<tr>
<td></td>
<td>Avid Meridian MJPEG Playback</td>
</tr>
<tr>
<td></td>
<td>DV in MXF OP-Atom Playback</td>
</tr>
<tr>
<td></td>
<td>DV 25</td>
</tr>
<tr>
<td></td>
<td>DVCP 25</td>
</tr>
<tr>
<td></td>
<td>DVCP 50</td>
</tr>
<tr>
<td></td>
<td>DVCP 100</td>
</tr>
<tr>
<td></td>
<td>DVCP Pro HD</td>
</tr>
<tr>
<td></td>
<td>DNxHDX</td>
</tr>
<tr>
<td></td>
<td>DNxHR</td>
</tr>
<tr>
<td></td>
<td>Google VP9</td>
</tr>
<tr>
<td></td>
<td>H.263</td>
</tr>
<tr>
<td></td>
<td>H.264</td>
</tr>
<tr>
<td></td>
<td>H.265</td>
</tr>
<tr>
<td></td>
<td>JPEG</td>
</tr>
<tr>
<td></td>
<td>MPEG-1</td>
</tr>
<tr>
<td></td>
<td>MPEG-2</td>
</tr>
<tr>
<td></td>
<td>MPEG-4</td>
</tr>
<tr>
<td></td>
<td>MPEG-4 Simple Studio Profile (SStP)</td>
</tr>
<tr>
<td></td>
<td>Uncompressed YUV</td>
</tr>
<tr>
<td></td>
<td>Uncompressed R10k</td>
</tr>
<tr>
<td></td>
<td>Uncompressed R10g</td>
</tr>
<tr>
<td><strong>Audio Codecs</strong></td>
<td>AAC</td>
</tr>
<tr>
<td></td>
<td>AC-3</td>
</tr>
<tr>
<td></td>
<td>MPEG Audio Layer 1,2,3</td>
</tr>
<tr>
<td></td>
<td>Microsoft ADPCM</td>
</tr>
<tr>
<td></td>
<td>G.711 aLaw</td>
</tr>
<tr>
<td></td>
<td>G.711 uLaw</td>
</tr>
<tr>
<td></td>
<td>G.726</td>
</tr>
<tr>
<td></td>
<td>PCM3</td>
</tr>
</tbody>
</table>
### Table 1. Switch Pro Features

<table>
<thead>
<tr>
<th>Features</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Captions/Subtitles</td>
<td>CEA-608 &amp; CEA-708 captions, Teletext (OP-42 and OP-47), Lambda .CAP, SCC, MCC, DVB, TTML (iTT and SMPTE-TT) and WebVTT*, SRT and STL subtitle files.</td>
</tr>
<tr>
<td></td>
<td>* Web VTT captions do not display in vertical columns on Windows 7</td>
</tr>
<tr>
<td>Navigation</td>
<td>Step, skip or jump forward/reverse navigation, JKL playback, command/period stepping, slow motion playback. Loop, instant replay navigation</td>
</tr>
<tr>
<td>Position display</td>
<td>Frame number / timecode</td>
</tr>
<tr>
<td>Inspection</td>
<td>Video and audio formats, bitrates, subsampling, Color Space, language, duration, frame rate, encoded size, Clean Aperture, aspect ratio, display size, metadata, audio tracks and channels, audio sample rates, secondary audio files, secondary subtitle files</td>
</tr>
<tr>
<td>Property pass-through</td>
<td>HEVC pass-through into MP4</td>
</tr>
<tr>
<td></td>
<td>DNxHR pass-through to MXF Op1a</td>
</tr>
<tr>
<td>Export</td>
<td></td>
</tr>
<tr>
<td>Editable properties</td>
<td>Crop, resize, change clean aperture, change pixel aspect ratio, change colorimetry, down-mix (audio)</td>
</tr>
<tr>
<td>Video Encoding Format</td>
<td>Apple ProRes</td>
</tr>
<tr>
<td>support</td>
<td></td>
</tr>
<tr>
<td>iTunes Asset Preparation</td>
<td>Built-in packaging presets for iTunes store package: Music Video (NTSC)</td>
</tr>
<tr>
<td></td>
<td>Music Video (PAL)</td>
</tr>
<tr>
<td></td>
<td>Music Video (HD)</td>
</tr>
<tr>
<td></td>
<td>Television (NTSC)</td>
</tr>
<tr>
<td></td>
<td>Television (PAL)</td>
</tr>
<tr>
<td></td>
<td>Television (HD)</td>
</tr>
<tr>
<td></td>
<td>Film (NTSC)</td>
</tr>
<tr>
<td></td>
<td>Film (PAL)</td>
</tr>
<tr>
<td></td>
<td>Film (HD)</td>
</tr>
</tbody>
</table>
System Requirements

OS Version: Windows 7 SP1 and later.

Platform Update for Windows 7.

CPU: 2.4 Ghz Core 2 Duo or faster. Any Core i3, i5, or i7

RAM: 4 GB (minimum)

Display: 1280 x 768 or larger, 50 Hz or faster

Graphics:

- Correct DirectX 10.0 -> 10.1
- Intel GMA X4500 or higher -> Intel HD Graphics 3000 or higher.
- Any discrete graphics card with support for DirectX 11 or better (hardware level DirectX 10.1 at minimum). Note: For Windows 7 users, Switch requires a card that supports DirectX 10.1 hardware feature level 10.1 or better. For more information, view the Switch product Knowledgebase.

Summary of License Features
## Overview

### Summary of License Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Switch Player</th>
<th>Switch Plus</th>
<th>Switch Pro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Loudness monitoring panel displaying average momentary loudness, average short-term loudness, integrated loudness and loudness range</td>
<td></td>
<td></td>
<td>✔️</td>
</tr>
<tr>
<td>Preview to external monitors via Blackmagic Design or AJA devices, includes VANC data display</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Advanced inspection of application-specific metadata such as AS11 with UK DPP metadata, AS03, and others</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Compare/Alternate Media: Load multiple versions of your media to compare frame by frame</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Timeline feature displaying video GOP structure and data rate information</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td><strong>FIX IT</strong></td>
<td>$9.99*</td>
<td>$199*</td>
<td>$499*</td>
</tr>
<tr>
<td>Pass through export</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Export (See full export format support)</td>
<td>✔️</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>iTunes package preset including media content, secondary subtitle or audio files, chapter information and an XML file</td>
<td></td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td><strong>PREMIUM SUPPORT</strong></td>
<td>Not available</td>
<td>$39/year*</td>
<td>$99/year*</td>
</tr>
<tr>
<td>Priority response, telephone support, free software upgrades, Remote Access services</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*1st year Premium Support included in the purchase of Switch Plus and Switch Pro.
Installing Switch

Introduction

This section will demonstrate how to install, remove, update, and customize Switch.

Note: Switch installers are available at: www.telestream.net

Topics

- Installing Switch
- Uninstalling Switch
- Updating/Activating/Deactivating Switch
- Opening Switch

Installing Switch

To install Switch, follow these steps:

1. Download the installer from the Website at:
   http://www.telestream.net/switch/overview.htm

Note: If you have a previous version of Switch installed on your computer, you must first uninstall it before installing the new version of Switch.

2. Run the installer program and follow the instructions provided.

Windows Error Messages

Here are some possible installation error messages that you might encounter:

- .NET Framework is not installed Switch requires the .NET Framework 4.0 runtime. Try installing it before installing Switch.
Installing Switch

Uninstalling Switch

• Attempting to install 64-bit version on 32-bit OS: Switch requires a 64-bit operating system. You can not install Switch on this version of Windows.

• Media foundation not installer (Windows N or Server without Desktop Experience): Switch requires Windows Media Foundation. Try installing the Windows Media Feature Pack before installing Switch.

Uninstalling Switch

To uninstall Switch:

1. Select Switch on the list of programs in Control Panel>All Control Panel Items>Programs and Features, then click Uninstall at the top of the window.

2. The installer asks if you want to repair or remove the existing version. Select Remove to uninstall the existing version of Switch.

Updating/Activating/Deactivating Switch

To check for software updates, see Update in the Preferences and Updates section.

To activate a serial number for Switch, see Activating a Serial Number in the Preferences and Updates section.

To deactivate a serial number for Switch, see Deactivating a Serial Number in the Preferences and Updates section.

Opening Switch

After you have installed Switch (See Installing Switch), you can open Switch by double-clicking the Switch shortcut icon located on the desktop.

When Switch opens it displays a Welcome screen. You can watch an introduction video, browse the user guide, visit the Telestream Website, or open a media file. To open a media file, select a recently opened file and click Open. If you do not have any recent files, or if you want to open another file, click Open Other to navigate to a media file.
Click **Clear** to clear the list of recent files. Optionally, check **Show Welcome Screen** to force its display when all media files have been closed.
If you click *Open Other*, a navigation window displays. Navigate to the location of your file and click *Open*. 

![Navigation Window](image.png)

- **Navigate to file location**
- **Click Open**
Introduction

This section presents how to open media files as primary or secondary files (audio and subtitle files), and how to open recently accessed files. It also describes how to associate and close media files.

Topics

- Opening Files
- Opening Secondary Files
- Opening Flags
- Opening Recent Files
- Closing Files

Opening Files

Select File > Open File, to open a media file in Switch. When the Open dialog box displays, navigate to the file you want to open, and click Open. Click Cancel if you decide to not open any media files.

Opening Secondary Files

You can open a Secondary audio file by selecting File > Open Secondary Audio File, or a Secondary Subtitle file by selecting File > Open Secondary Subtitle File. When the Open dialog box displays, navigate to the secondary file you want to open, and click Open. Click Cancel if you decide to not open a secondary file.

Secondary audio and subtitle files play along with the primary media file you have open. These are useful for supplying background audio for a video that has no embedded audio, or for supplying subtitles for a video that has no embedded subtitles.
Opening Flags

Select File > Open Flags, to open a Flags file in Switch. When the Open dialog box displays, navigate to the file you want to open, and click Open. Click Cancel if you decide to not open any media files.

Opening Recent Files

You can re-open previously opened media files by selecting File > Open Recent. This displays a list of your most recently accessed media files. Every time a file is opened or exported it is entered into the list. You may also (optionally) clear the menu list by selecting Clear Menu.

Closing Files

To close a file, first select (make active) the media window displaying it, then select File > Close.
Media Playback

Introduction

This section presents how to playback media files using Switch. Playback is controlled using a Play Bar. A complete set of controls are provided through the Control menu.

Topics

- Play Bar
- Control Menu
- Timeline
- Audio Control

Play Bar

The easiest way to control the playback of your media is through the Switch Play Bar. The features of the Play Bar are described below.
Play/Pause  Click the play/pause button to play the video; click again to pause it.

**Note:** In addition to clicking Play/Pause on the Play Bar, you can also play and pause by pressing the Spacebar. It acts as a toggle between play and pause modes.

**Elapsed Time** Displays how long the video has been playing. Click the time display to change display mode: Time, Frame Counter, or Timecode. You can also enter a time value and click Go to go to that time in the video.

**Note:** Switch appends a plus sign (+) to the end of the current frame count (if the Time Display mode is set to Frame Count) whenever playback has exceeded the length of the video. This usually happens because the audio is longer than the video. During this time, Switch will display black frames.

**Scrubber/Playhead** Click and slide to change the location in the video you are viewing. You can also click on any position in the scrubber timeline to jump the playhead to that location.

**Time Remaining** Displays time remaining for the video to play. Display is shown in either seconds or frames depending on the Elapsed Time display mode (Time, Frame Counter, or Timecode).

**Volume Control** Click the speaker icon to mute or un-mute the audio. Click and slide the bars icon to increase or decrease the volume.
Control Menu

Switch also provides a complete set of playback controls through the Control menu. The Control menu includes play, rewind, fast and slow motion, jump, skip, and loop controls.

**Play** Starts playing your selected media. When a media is playing the *Play* menu item changes to *Pause*. To pause a media, select *Pause*. Select *Play* again to restart it.

**Play All** Starts playing all open media files.

**Play Forward** Plays your selected media forward at normal or increased speed. Pressing the “L” key also plays your media forward. Repeated “L” key presses increases the play speed up to 16x.

**Stop** Stops forward or backward playing of your media. Pressing the “K” key also stops media playing. If your media is playing at increased speed when Stop is selected (or the “K” key is pressed), any new playing of media will be at normal speed (the increased speed is not remembered).

**Play Backward** Plays your selected media backward at normal or increased speed. Pressing the “J” key also plays your media backward. Repeated “J” key presses increases the play speed up to 16x.

When a media is playing at increased speed, the speed is displayed in the upper left corner of the window.

**Slow Motion Forward** enables you to forward play video at one-half of normal speed. You can also press the Ctrl + L keys. If your media is playing in slow motion, when Stop is selected (or the “K” key is pressed), any new playing of media will be at normal speed (the slow motion is not remembered).

**Slow Motion Backward** enables you to backward play video at one-half of normal speed. You can also press the Ctrl + J keys. If your media is playing in slow motion, when Stop is selected (or the “K” key is pressed), any new playing of media will be at normal speed (the slow motion is not remembered).
**Step Forward** Steps forward in the video, one frame at a time. You can also press the right arrow key to step forward. The L, K, and J keys (Backward, Stop, and Forward) remain active.

**Step Backward** Steps Backward in the video, one frame at a time. You can also press the left arrow key to step backward. The L, K, and J keys (Backward, Stop, and Forward) remain active.

**Skip Forward (1 sec)** Moves the video one second ahead. You can also press the Alt + Shift + Right Arrow keys.

**Skip Backward (1 sec)** Moves the video one second backward. You can also press the Alt + Shift + Left Arrow keys.

**Skip Forward (10 sec)** Moves the video ten seconds ahead. You can also press the Alt + Right Arrow keys.

**Skip Backward (10 sec)** Moves the video ten seconds backward. You can also press the Alt + Left Arrow keys.

**Next Chapter** Enables you to jump to the next chapter location.

**Previous Chapter** Enables you to jump to the previous chapter location.

**Chapters** Enables you to jump to a location by selecting a chapter title from a list.

---

**Note:** The Chapter menu items (Next Chapter, Previous Chapter, and Chapter) are only enabled if the video has chapter markers embedded in it. If no chapter markers are present, the menu items are grayed out. Chapter markers are sometimes embedded in longer movie clips to divide sections of the media topically or by edit points.

---

**Loop** When selected, your video plays repeatedly and the movie will play again from the beginning whenever it reaches the end. You can select from two loop modes: *Entire Duration* or *Trimmed Segment.*
Timeline

The timeline enables you to view the frame types or the data rate of your video. It also allows you to view any flags you have set. To open the timeline, select View > Show Timeline. After the timeline opens, the menu changes to Hide Timeline. You can also press Ctrl+T to show or hide the timeline.

GOP Mode

Select GOP (Group of Pictures) mode to display the video frame types. Each bar represents a frame, which can be selected by clicking it. Purple bars represent P-frames, which are predictive frames that only contain the changes from the previous frame. Blue bars represent B-frames, which are bi-predictive frames that contain both the changes between the previous and the next frame. White bars represent I-frames, which are intra-coded frames that contain the entire picture being displayed. You can also zoom the timeline display by sliding the Zoom slider.
Datarate Mode

Select *Datarate* mode to display the datarate for each video frame, showing the overall data of the video charted across the timeline in the form of peaks and valleys. You can also zoom the timeline display by sliding the Zoom slider.

Flags Mode

Select *Flags* mode to display all flags on the timeline. Click the left flag icon to add a new *start* flag. Click the right flag icon to add a new *end* flag. Select a flag and click the minus (-) button to remove a flag.
The flag settings for this timeline are set in the Inspector using the Flags Tab. Click the plus (+) button to add a new flag. Select a flag and click the minus (-) button to remove a flag. Click on the flag icon to change its color to any of five: Green, Blue, Yellow, Orange, or red. (See Flags Tab)

Audio Control

The Audio menu enables you to control playback volume.

Select Increase Volume or Decrease Volume to change the audio volume level, or select Mute to silence it entirely. You can also mute all non-active media windows by selecting Mute Inactive Windows. Additionally, you can mute all audio, or just the audio of selected files, tracks or channels by selecting Mute Files, Mute Tracks, or Mute Channels. Select Solo Files, Solo Tracks or Solo Channels to mute all but the selected file, track or channel.
Inspecting Media

Introduction

Switch allows you to either inspect or edit your media files through a Media Inspector window. This section presents how to use Switch to inspect media files. (See Editing Media on how to edit media files).

Topics

- Media Inspector
- Container Tab
- Video Tab
- Audio Tab
- Subtitle Tab
- Time Tab
- Flags Tab

Media Inspector

The Media Inspector window enables you to inspect or edit your media files. To open the Media Inspector window, select Window > Show Inspector.

Note: If Hide Inspector is displayed as a menu item, it means that the Media Inspector is already open.
The Media Inspector window can also be opened by selecting one of its six tabs from the Edit menu.

The media Inspector window has six Media Inspector tabs: Container, Video, Audio, Subtitles, Time, and Flags. There is also a switch that enables you to select either Inspect or Edit mode.

Common to all six tabs is an Export menu at the bottom of the inspector window. You can export your video at any time by selecting one of the menu items: Movie, iTunes Store Package, or Current Video Frame. You can also export your flags or the inspector info. This is the same as the Export menu at the top of the Switch media window.

**Inspect/Edit Mode Switch**

The Inspect/Edit mode switch enables you to select either Inspect or Edit mode. When the switch is in Inspect mode, settings cannot be edited -- they can only be inspected (viewed). When the switch is in Edit mode, settings can be edited. You can export your media in either mode. See *Exporting Media* for details on how to export media files.
Container Tab

The Container tab provides a way to inspect the container for your media (name, location, size, type, etc.). To access the Container tab, open the Media Inspector by selecting Window > Show Inspector, then click the Container tab. You can also display the Container tab by selecting Inspect > Container.

File Controls

Name Displays the filename of your media. To change the file name, consult the Editing Media section.

Directory Select a location (directory) for your media file from the list displayed in the drop-down menu.

Size Displays the size of the media file (when known).

Type Displays the container type. To change the container type, consult the Editing Media section.

Duration Displays the duration of the media file (when known).

Created Displays the date when your media file was created.

Modified Displays the date when your media file was last modified.
Metadata and Secondary Audio/Subtitles

Metadata and Secondary Audio/Subtitles are displayed along with information about them. To add metadata, secondary audio, or secondary subtitles, see Metadata and Secondary Audio/Subtitles in the Editing Media section.

To view an embedded DPP file content, select the file name from the list at the bottom of the Metadata window, then click the gear icon and select Show XML Metadata Content from the drop-down menu.

The metadata content displays in a window:

```
<Program xmlns="http://www.digitalproductionpartnership.co.uk/ns/as11/2012">
  <Editorial/>
  <ProgramTitle/>
  <EpisodeTitleNumber/>
  <ProductionNumber/>
  <Synopsis/>
  This is 10076 DPP test material
  <Originator/>
  <CopyrightYear/>
  2014
```

This XML file does not appear to have any style information associated with it. The document tree is shown below.
Video Tab

The Video tab provides inspection of the video portion of your media (video format, size, rate, etc.). To access the Video tab, open the Media Inspector by selecting Window > Show Inspector, then click the Video tab. You can also select Inspect > Video.

You can also access the Video tab by selecting Edit > Video.

- **Format** Displays the video format of your media file. To change the format, consult the Editing Media section.
- **Bit Rate** Displays the video bit rate (when available).
- **Bit Depth** Displays the video bit depth (when available).
- **Subsampling** Displays the subsampling ratio.
- **Color Space** Displays the Color Space. To change the Color Space, consult the Editing Media section.
- **Range** Displays the range value.
- **Alpha Channel** Displays the alpha channel.
- **Language** Displays the language used in metadata. To change the language, consult the Editing Media section.
- **Duration** Displays the time duration of the video.
- **Rate** Displays the video rate in FPS (frames per second). To change the rate, consult the Editing Media section.
**Encoded Size** Displays the encoded media file and whether it is HD, UHD, SD, etc.

**Clean Aperture** Displays the Clean Aperture setting. To change Clean Aperture, consult the *Editing Media* section.

**Aspect Ratio** Displays the aspect ratio. To change the Aspect Ratio, consult the *Editing Media* section.

**Display Size** Displays the size (resolution) of the video after crop, resize, etc. are applied.

**Video Properties** Displays video metadata.

### Audio Tab

The Audio tab enables you to inspect the audio portion of your media. This includes channel, format, bitrate, duration, etc. To access the Audio tab, open the Media Inspector by selecting *Window > Show Inspect*, then click the Audio tab. You can also select *Inspect > Audio*.

**Program** Click the down arrow on the right to display channel settings. For some channel selections, you can also change the speaker name. To do this, click on the current speaker name and then select a new name from the displayed list. You can also...
check Mute or Solo for each channel. Mute removes the sound for that channel. Solo turns off the sound for all other channels.

Format Displays audio codec used.

Bit Rate Displays the audio bit rate.

Sample Rate Displays the sample audio rate (32, 44.1 or 48 Khz).

Language Displays the language to use in metadata.

Duration Displays the time duration of the audio.

Note: The order of audio tracks in the list reflect the order of the tracks in the source file when in inspect mode, and the order of the tracks in any export files when in edit mode.
Subtitle Tab

The Subtitle tab enables you to inspect the subtitling in your media.

Subtitle files are added by opening them from the File > Open Secondary Subtitle File menu. Once opened it is associated with the currently open primary video file. When the subtitle file displays in the subtitle tab list, select it to display its controls.

To access the Subtitle tab, open the Media Inspector by selecting Window > Show Inspector, then click the Subtitle tab. You can also select Inspect > Subtitles.

- **Format** Displays the type of subtitling used in your media.
- **Language** Displays which language the subtitles are written in.
- **Timecode Format** Displays the timecode format used.
- **Start** Displays the start time of SCC subtitles. This field allows you to re-synchronize the subtitles with the video by adjusting the start timecode. It is available with many, but not all, secondary subtitle formats.
- **Duration** Displays the time duration of the subtitles.
- **Other** Displays metadata.
**Time Tab**

The Time tab enables you to inspect the timing portion of your media (In, Out, Length, and chapter controls). To access the Time tab, open the Media Inspector by selecting *Window > Show Inspector*, then click the Time tab. You can also select *Inspect > Time*.

The Time tab displays entry points (chapters) in your media that you have created in Switch. To change the chapters, consult the *Editing Media* section.

**Note:** You can only view the chapter markers you have created in Switch. Chapter markers resident in the file when opened in Switch will not be visible -- even if they were previously created using Switch.

**Flags Tab**

The Flags tab enables you to inspect the flags placed in your media. To access the Flags tab, open the Media Inspector by selecting *Window > Show Inspector*, then click the Flags tab. You can also select *Inspect > Flags*.
The Flags tab displays flagged sections in your media. To set, remove, or change the flags, consult the *Editing Media* section.
Editing Media

Introduction

Switch allows you to either inspect or edit your media files through a Media Inspector window. This section presents how to use Switch to edit media files. (See Inspecting Media on how to inspect media files).

Topics

- Media Inspector
- Container Tab
- Video Tab
- Audio Tab
- Subtitle Tab
- Time Tab
- Flags Tab

Media Inspector

The Media Inspector window enables you to inspect or edit your media files. To open the Media Inspector window, select Window > Show Inspector.

Note: If Hide Inspector is displayed as a menu item, it means that the Media Inspector is already open.
The Media Inspector window can also be opened by selecting one of its six tabs from the Edit menu.

The media Inspector window has six Media Inspector tabs: Container, Video, Audio, Subtitles, Time, and Flags. There is also a switch that enables you to select either Inspect or Edit mode.

Common to all six tabs is an Export menu at the bottom of the inspector window. You can export your video at any time by selecting one of the menu items: Movie, iTunes Store Package, or Current Video Frame. You can also export your flags or the inspector info. This is the same as the Export menu at the top of the Switch media window.

**Inspect/Edit Mode Switch**

The Inspect/Edit mode switch enables you to select either Inspect or Edit mode. When the switch is in Inspect mode, settings cannot be edited -- they can only be inspected (viewed). When the switch is in Edit mode, settings can be edited. You can export your media in either mode. See *Exporting Media* for details on how to export media files.

**Container Tab**

The Container tab provides a way to inspect and edit the container for your media including information such as: name, location, size, type. To access the Container tab,
open the Media Inspector by selecting **Window > Show Inspector**, then click the Container tab. You can also display the Container tab by selecting **Inspect > Container**.

### Container tab

**Name** Displays the filename of your media. (You can change the name of the file when exporting.)

**Directory** Select a location (directory) for your media file from the list displayed.

**Size** Displays the size of the media file (when known).

**Type** Select the container type by clicking on the double arrow and selecting a type from the menu: MXF, MOV, MP4, TS, MPEG, and WMV.

For WMV, the following codecs are supported:

**Windows Media Video**

<table>
<thead>
<tr>
<th>Codec</th>
<th>Four-character Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Media Video 9 Standard</td>
<td>'WMV3', 'wmv3'</td>
</tr>
<tr>
<td>Windows Media Video 9 Advanced (a.k.a. VC-1)</td>
<td>'WMVA', 'wmva'</td>
</tr>
</tbody>
</table>
**Editing Media**

**Container Tab**

- **Switch User Guide**

**Windows Media Audio**

<table>
<thead>
<tr>
<th>Codec</th>
<th>Four-character Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Media Audio 9 Standard</td>
<td>WMA2, 'wma2', 'wma'</td>
</tr>
<tr>
<td>Windows Media Audio 9 Professional</td>
<td>'WMAP', 'wmap', 'WMA3', 'wma3'</td>
</tr>
<tr>
<td>Windows Media Audio 9 Lossless</td>
<td>'WMAL', 'wmal'</td>
</tr>
<tr>
<td>Windows Media Audio 10 Professional</td>
<td>'WMAP', 'wmap'</td>
</tr>
</tbody>
</table>

**Duration** Displays the duration of the media file (when known).

**Created** Displays the date when your media file was created.

**Modified** Displays the date when your media file was last modified.

**Metadata and Secondary Audio/Subtitles**

To add metadata, click the associated plus (+) icon and add available metadata (Album, Artist, Director, Year, etc). To add secondary audio and subtitle files, click the associated plus (+) icon and navigate to the file you want to add. To remove an added file, select it and click the minus (-) icon. Click the gear icon to make additional settings.

Click the Metadata gear icon to open the metadata URL or to display the metadata in HTML or XML format. Click the Secondary (Audio or Subtitle) gear icon, to copy the URL of the audio or subtitle file, or to show its location.

![Image showing metadata and secondary audio/subtitles](image-url)
Video Tab

The Video tab provides controls for the video portion of your media. This includes video format, size, rate, etc. To access the Video tab, open the Media Inspector by selecting Window > Show Inspector, then click the Video tab. You can also access the Video tab by selecting Inspect > Video.

**Video Transcode/Video Pass-Through** You can select Video Transcode (use transcoder) or Video Pass-Through (do not use transcoder), or you can Omit the Video. Use the pull-down menu to make a selection. Pass-through preserves the existing encoding of the video.

**Format** Displays the current video format used. When in transcode mode you can change the format by making a selection from the drop-down menu: H.264, H.262, WMV and ProRes.

Click the down arrow to the right of the Format menu, then select the quality and enter any needed command line settings.
**Bit Rate** Displays the video bit rate (when available).

**Bit Depth** Displays the video bit depth (when available).

**Subsampling** Displays the sub-sampling ratio.

**Color Space** Select the Color Space from the drop-down menu. Then click the arrow to open the Color Space controls. Your selection of Color Space automatically populates Color Primaries, Matrix Coefficients, and Transfer Characteristics. However, you can set these manually using pull-down menus.

**Note:** If you change any of the control settings so that they do not match a known Color Space, the Color Space display will change to “Unknown”.

**Range** Displays the range value.

**Alpha Channel** Displays the alpha channel.

**Language** Select a language to use in metadata from the drop-down menu.

**Duration** Displays the time duration of the video.

**Rate** Displays the video rate in FPS (frames per second).

**Note:** Frame rate changes (beyond those supported as part of deinterlacing) should be made outside of Switch.

**Original Size** Displays the original size (resolution) of the video.
**Crop** The crop tool enables you to use just a selected portion of the visible picture. This is useful in making the picture frame smaller to fit in a Web window application. It is also useful for fitting in a 4:3 or 16:9 aspect ratio that is sized smaller than the existing frame geometry.

To open the cropping controls, click the down arrow. You can crop the visible area of your media by entering the pixel size you want, or by entering the number of pixels to crop in each direction of the image (left, right, top, bottom).

**Resize** You can resize the picture (and optionally change the aspect ratio) for devices or applications. Resize the video by clicking the down arrow to display the control panel and entering size (resolution) values.

You can set constraints on resizing. Select *Maintain Aspect Ratio* or *Fit To Screen* from the Constraints menu to determine how aspect ratio changes as you resize your video. Select *None* to remove all constraints on cropping.

If you have selected *Maintain Aspect Ratio*, select (from the aspect ratio menu) the aspect ratio to be used.

Select a display mode from the Mode menu. Your choices are: Center, Letterbox, Fill, and Stretch.
Center: When increasing the dimensions, the video remains the same size and black is added on all sides as needed to fill in. When decreasing the dimensions, the video is cropped.

Letterbox: The video is resized both vertically and horizontally so that each axis is less than or equal to the target dimensions. If one dimension is less than the target dimension, black is added to fill in.

Fill: Fills the dimensions with video by scaling the video up or down, by cropping the video, or by adding black as needed to fill.

Stretch: The video is resized to fit the target dimensions, ignoring the aspect ratio. This may distort the video.

Clean Aperture To set Clean Aperture, click the down arrow on the Clean Aperture menu. Enter the desired size, left, right, top, and bottom aperture settings.

Aspect Ratio Click the down arrow to open the Aspect Ratio control panel. Select the aspect ratio type (PAR or DAR) from the Type menu. Select also an aspect ratio from the Aspect Ratio menu list.

Display Size Displays the size (resolution) of the video after crop, resize, etc. are applied.
Audio Tab

The Audio tab enables you to inspect and edit the audio portion of your media. This includes channel, format, bitrate, duration, etc. To access the Audio tab, open the Media Inspector by selecting Window > Show Inspector, then click the Audio tab. You can also select Inspect > Audio.

Audio Transcode/Audio Pass-Through You can select Audio Transcode (use transcoder) or Audio Pass-Through (do not use transcoder) by selecting one of these from the pull-down menu.

Note: When exporting to an iTunes Store Package, If you have selected Feature for the Asset Type, secondary audio files are included in the exported iTunes package. But if Preview is selected as the Asset Type, the audio files are not included in the exported iTunes package.

Click the plus icon to add a track. (Click minus icon to delete a selected track.)
Click the gear icon to display the settings menu.

**Revert** Reverts audio settings to their original values. This action cannot be undone.

**Move Up/Down** After selecting an audio track, you can move it up or down in the list.

**Note:** The order of audio tracks in the list reflect the order of the tracks in the source file when in inspect mode, and the order of the tracks in any export files when in edit mode.

**Split/Join** Selecting **Split** will divide a multi-channel track into multiple audio tracks, each containing a single channel of audio. Highlighting multiple tracks, then selecting **Join**, will merge them into a single track containing all of the selected channels.

**Note:** When creating a Feature iTunes package using Audio Pass-Through, the secondary audio files will be added separately from the primary asset. When creating a Preview iTunes package, secondary audio files will be ignored when using Audio Pass-Through mode.

Click a track to edit its settings.
**Program** Select a type of audio configuration from the Program pull-down menu (Stereo, 5.1 Audio, etc.). Click also the down arrow on the right to display channel settings. For some channel selections, you can also change the speaker name. To do this, click on the current speaker name and then select a new name from the displayed list.

Format Select an audio codec from the pull-down menu: LPCM, AAC-LC, MPEG Layer 2, or WMA.

Click the down arrow on the right of the drop-down menu, and select the format type. Also select Big or Small Endian.

**Bit Rate** Displays the audio bit rate.

**Sample Rate** Select a sample audio rate from the Sample Rate menu: 44.1Khz or 48Khz.

**Language** Select the language to use in metadata.

**Duration** Displays the time duration of the audio.
Subtitle Tab

The Subtitle tab enables you to inspect and edit the subtitling in your media.

Subtitle files are added by opening them from the File > Open Secondary Subtitle File menu. Once opened it is associated with the currently open primary video file. When the subtitle file displays in the subtitle tab list, select it to display its controls.

To access the Subtitle tab, open the Media Inspector by selecting Window > Show Inspector, then click the Subtitle tab. You can also select Inspect > Subtitles.

**Format** Displays the type of subtitling used in your media.

**Language** Select which language the subtitles are written in from the Language drop-down menu.

**Timecode Format** Select a timecode format from the drop-down menu.
**Start** Displays the start time of SCC subtitles. This field allows you to re-synchronize the subtitles with the video by adjusting the start timecode. It is available with many, but not all, secondary subtitle formats.

**Duration** Displays the time duration of the subtitles.

**Other** Displays metadata.

---

**Time Tab**

The Time tab provides controls for setting the trimming and chapter markers. This includes timing controls (In, Out, and Length) and chapter controls. To access the Time tab, open the Media Inspector by selecting *Window > Show Inspector*, then click the Time tab. You can also select *Inspect > Time*.

Click a plus (+) icon to add a trim or chapters to your video.

---

**Trim** Lets you choose where a video clip begins and ends by setting trim points. The time format is: hours, minutes, seconds, fractional seconds (hh:mm:ss:fs).
You can set in and out markers by sliding them in the edit bar below the video. You can also select a video clip by moving the Play Head to a location in the video and pressing the “I” key to set the Mark In point, or “O” key to set the Mark Out point. The dark area between the two markers indicates the selected portion.

**Note:** Cut, Copy, Paste, Delete, and Select All can be used to edit fields in Edit Boxes.

Click the plus icon to create a trim. (Remove a trim by selecting it and clicking the minus icon.) Click a Go button to move the Play Head to the In or Out point.

**Chapters** Enables you to create entry points (chapters) in your media. Click the plus icon to add a chapter. The chapter entry point is created with a picture of the starting video frame and the timecode location. Click Go to go to that location in your video. To remove a chapter point, select the chapter point and click the minus icon.
To create a chapter thumbnail which is not the first frame of the chapter, move the playhead to the frame you want to use, click the plus (+) button to create the chapter, then adjust the time value to the intended start of the chapter.

**Note:** Chapters can only be created in files exported as iTunes packages, not in movie (.mov) files.

## Flags Tab

The Flags tab enables you to edit the flags placed in your media. To access the Flags tab, open the Media Inspector by selecting *Window > Show Inspector*, then click the Flags tab. You can also select *Inspect > Flags*. Set the switch to *Edit*.

Click a plus (+) icon to add a flag to your video. Click on the flag to change its color: yellow, orange, or red. To remove a flag, select it by clicking its screen shot image, then click the minus (-) icon.

**Flags** Lets you choose where a flagged section of your video by setting start and end points. The time format is: hours, minutes, seconds, fractional seconds (hh:mm:ss:fs). To set the start or end point of the flagged section of your video, enter the time and click the Go button. You can also title your flag by entering a title into the Title field.
Exporting Media

Introduction
This section shows you how to export media from Switch. Media can be exported as a movie or as an iTunes package. You can also export selected video frames as single pictures.

Topics
- Exporting Media
- Exporting Movies
- Exporting iTunes Packages
- Exporting Video Frames
- Exporting Flags
- Exporting Inspector Info

Exporting Media
A powerful feature of Switch is the ability to re-encode video and export a new movie clip for use by other applications and many popular devices (iPhone, iPod etc.). Switch is also a file transcoding tool. While not having the powerful features of Telestream Episode or Vantage, Switch is handy for reading most formats supported by QuickTime, and exporting to a very small subset.

To export media from Switch, select Export, then select the type of export you want: Movie, iTunes Store Package, or Current Video Frame. You can also export your flags and the inspector info.

Note: You can re-encode from most QuickTime supported formats, but you cannot export to all QuickTime supported formats.
Exporting Movies

To export your media as a movie, select Export > Movie. When the dialog box opens, it displays the Container, Video, and Audio setup information. You can change any of these by clicking one of the Edit buttons. Once the settings are correct, click Export.

When the Save dialog box displays, enter a filename for your movie and navigate to the location where you want to save your movie. Click Save when finished.

Exporting iTunes Packages

To export your media as an iTunes Store Package, select Export > iTunes Store Package. You can export the following iTunes packages:

- Music Video (NTSC)
- Music Video (PAL)
- Music Video (HD)
- Television (NTSC)
- Television (PAL)
- Television (HD)
- Film (NTSC)
- Film (PAL)
- Film (HD)

Note: If the video codec used is not Apple ProRes 422 (HQ), or if you are in Video Pass-Through mode, an error message will display. You will also get an error message if the audio codec is not Linear PCM, or if the audio track is not 16 or 24 bit.
When the dialog box opens, it displays the Container, Video, and Audio setup information. You can change any of these by clicking one of the Edit buttons. Once the settings are correct, click Export.

When the dialog box displays, select Asset Type: Feature or Preview. The Feature asset type embeds the secondary audio into the package, whereas Preview does not. If you select Preview, select also a Preview Territory. (Preview Territory will remain grayed-out until Preview is selected.)

Enter your provider name. (The Continue button will remain grayed-out until a provider name is entered.) Select also a language and locale for Metadata, Spoken language, and Primary Assets. Click Continue to continue.

If Switch is not licensed, a warning that the export will be watermarked is displayed. Click Continue to continue.

When the Save dialog box displays, enter a filename for your movie and navigate to the location where you want to save your movie. Click Save when finished.
Exporting an iTunes Asset Only .itmsp Package

Switch creates an asset-only .itmsp package, but you still need to enter additional information via iTunes Connect to complete the .itmsp package.

If you do not have an iTunes Connect Account, you have two options:

1. Take iTunes package created by Switch to an iTunes authorized aggregator for delivery (https://itunesconnect.apple.com/WebObjects/iTunesConnect.woa/wa/displayAggregators?ccTypeId=7)

Assets must meet iTunes Video Specification:

- iTunes requires film to be delivered as ProRes 422 (HQ) at their native frame-rate: the frame-rate originally captured by the camera’s image sensor.
- Movies are usually either 23.976, 24 or 25 fps. This is often different form the frame-rate that is found on tape, archived storage, NLE (Non-Linear Editor) projects or masters for broadcast which are 29.97i (NTSC or 25i (PAL). Consult with iTunes if the native frame rate is neither 23.976, 24 or 25 fps.

Subtitles must be provided as an iTunes Timed Text (.itt) formatted file.

The following settings are required for iTunes delivery:

- ProRes 422 (HQ)
- 4:2:2: color space
- 1920 x 1080 1:1 (square) pixel aspect ratio for HD

Other requirements:

- Must begin and end with at least one black frame
- 5.1 audio when available in-addition to the stereo track
- Audio source in Linear PCM 16 or 24 bit at 48Khz
- Closed Caption or English ITT Subtitle required for distribution in U.S. iTunes Store
- SD Assets: User must select the correct Aspect Ratio when SD assets are selected.
- Chapters: The first chapter stop must be at 00:00:00. If using a frame-accurate time-code format, the first chapter stop must be at 00:00:00:00.
- Accessibility XML: User must review the XML and make necessary edits to following asset and accessibility tags. Please refer to the “Vendor Tool Guide” for additional information.
Exporting Video Frames

To export a single frame of your media, pause your media and select Export >Current Video Frame. When the Save dialog box displays, enter a filename for your video frame then navigate to the location where you want to save your video frame as a picture. Click Save when finished.

Exporting Flags

You can save and open all of your flags in a file. This enables you to transfer your flags between different Switch environment settings. To save your flags, select Export >Flags. When the Save dialog box displays, enter a filename for your flags file then navigate to the location where you want to save your flags. Click Save when finished. You can also open a flags file by selecting File > Open Flags File, navigating to the location of your flags file, selecting it, and then clicking Open.

Note: Please keep in mind that Flags files save a media path relative to the machine they were created on. If you want to open a Flags file on another machine, open the media first, and then the file. This will associate the two and in turn an updated Flags file may be exported.

Switch exports flag files with a single root element <Switch> which maximizes compatibility with other applications, particularly Vantage. Here is a sample file:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<Switch>
  <Media>/Users/telestream/Desktop/DVwithCaptions.mov</Media>
  <Flags>
    <Flag Title="Bad frame" UUID="838C2FF0-F84C-4B56-A35A-C7B6B43C53AA" Start="1001001" End="1001001" Level="Error"/>
    <Flag Title="Make it look like this." UUID="F15599F6-1A65-4527-A862-29B1E158642" Start="61061061" End="61061061" Level="Good"/>
    <Flag Title="Slate" UUID="899C0852-9E14-4E69-A14D-3D799782927D" Start="140140140" End="141808475" Level="Neutral"/>
    <Flag Title="Start of captions" UUID="C0B1066D-FFB8-4D27-AFE0-3FC7530DB86D" Start="153153153" End="153153153" Level="Info"/>
    <Flag Title="Check audio here." UUID="E5107F72-1C60-4197-AF5B-0C426DB8F93C" Start="508508509" End="508508509" Level="Warning"/>
  </Flags>
</Switch>
```
Exporting Inspector Info

You can save your inspector information in a text file in a file. To save your inspector information, select Export > Inspector Info. The two formats that may be exported are: TXT or JSON. When the Save dialog box displays, enter a filename for your file then navigate to the location where you want to save your it. Click Save when finished. You can also view your inspector info by opening your newly saved file in a text editor. This file will typically look like this:
Getting Help

Introduction
This section presents how to get help using Switch. This includes online help, PDF help documents, and obtaining customer service support.

Topics
- Getting Help
- User Guides
- Purchasing Switch
- Customer Support

Getting Help
To get help using Switch, select the Help menu. This menu enables you to search for help by topic, open the user guide, purchase Switch, or get customer support help.

User Guides
Select Switch Help to open the online help version of the Switch User Guide, or select Switch User Guide to open the PDF version of the User Guide.
Purchasing Switch

Click *Buy* to open a browser window of the Telestream product purchasing Web page. When the Telestream store Web page displays, enter quantity and click *Add To Cart* to make your purchase. You will receive a serial number in a confirmation email.

1. The Switch Preferences window is also opened so that you can activate your new purchase. Once you have obtained your product serial number, enter it into the Serial Number field in the Preferences window, then click *Activate*.

Customer Support

To report a problem with Switch, first select the window displaying the media file you want to report, then select *Report Problem File* in the Help menu. When the reporting dialog window opens, click the *Report* button to send a technical report of your file to the Telestream support team. Click *Cancel* to abort this reporting action.
If your report is successfully sent, a confirming browser window will display. Click *Submit Feedback* to open a new support case.

Select *Gather Support Information* from the Help menu to collect and send information about Switch when you encounter problems. When the process finishes collecting information, enter your support case number and click *Reveal*.

Support information is gathered and saved in a file to your Windows desktop. A unique filename is generated. Sending this file to Telestream enables the support team to diagnose any problems you have reported.

Select *Contact Support* to open the Switch Support page on the Telestream Website. Select *Visit Switch Website* to open the Switch Product page on the Telestream Website. Select *Acknowledgments* to open the Acknowledgments page on the Telestream Website.
Preferences and Updates

Introduction
This section describes how to set preferences in Switch, how to check for updates, and how to set services preferences.

Topics
- Setting Preferences
  - General
  - Update
  - License
  - Display
  - Audio
- Check for Updates

Setting Preferences
To set preferences in Switch, select File > Preferences. The preferences window enables you to change the update interval and activate/deactivate licenses.

General
To use Switch Preferences to change general settings, follow these steps:
1. Select File > Preferences, then click General.
2. Select the Default Export Directory: Same as Source or Last Used. If Last Used is selected, the export directory will be the last directory that was used in an export. If the last used directory option is chosen, and that directory no longer exists,
source directory will be used. You can also (optionally) check *Watch for growing files* to cause Switch to watch for files that are still being created.

**Note:** Many media containers, such as MPEG-2 Transport Streams, do not provide information about the duration of the media inside. When Switch first opens the file, it must guess at the duration. Once indexing is complete and Switch knows about every frame of video and every portion of audio, accurate durations can be calculated. But until indexing is complete, Switch shows estimates for the video, audio, subtitle, and container durations in the inspector and player windows. Once indexing is complete, these durations are updated to reflect the more accurate values. Therefore, you can not rely on these initial durations being accurate. If you notice durations are not what they should be, and you are not using growing files, make sure the *Watch for growing files* preference is unchecked. Relaunch Switch if you change this setting.

**Update**

To use Switch Preferences to check for software updates (manually or at scheduled intervals) follow these steps:

1. Select *File > Preferences*, then click *Update*.
2. To change the interval at which Switch checks for updates, choose Daily, Weekly, Monthly or Never from the *Check For Updates* menu.
3. To check for updates manually, click *Check Now*.
License

During unlicensed playback, DNxHD and HEVC/H.265 are watermarked placing a transparent Switch logo in the upper right portion of the display. No other video codecs are watermarked during playback. Additionally, an audio watermark in 15 second intervals will be added to all media using Dolby AC-3 audio.

To remove the watermark during playback, you must purchase and enter a valid serial number and activate it.

All unlicensed video exports are watermarked in transcode mode. Exports are truncated when either audio and/or video are in pass-through mode. Licensed exports have no watermark or truncation. Truncation is set at 30 seconds, or half the duration of the media if less than 30 seconds long.

Activating or deactivating a license while a video is open will cause the video display to change accordingly and immediately.

Activating a Serial Number

If your computer is connected to the Internet and you purchased an upgrade via the Telestream Store online, use the email receipt (which contains your serial number) to manually activate Switch. Manual activation is also used for activating a serial number in Switch on another PC. To purchase a license for Switch, click the Buy button.

To enable the upgraded features, or activate additional copies of Switch, you must have access to the Internet. Your serial number must be manually entered to activate the features purchased.

**Note:** If your computer does not have Internet access, do not use this process. Instead, use a separate computer with Internet access to open the Manual Activation Guide on the Telestream Web site (www.telestream.net/pdfs/user-guides/Manual_Activation_Guide.pdf). This is a step-by-step guide to manually activate Switch.

1. Select *File > Preferences*, click *License*, enter your serial number, then click *Activate*. (When the serial number is entered correctly, the Activate button is enabled.)

Enter the serial number exactly as it exists in your email receipt. It is best to copy and paste the serial number to avoid typing mistakes. When typing it in, be sure to enter only zeros (no letter O’s), capitalize all letters, and include all hyphens. The Telestream Store is contacted and the serial number for your computer is activated.
Preferences and Updates
Setting Preferences

Note: If you experience problems activating, contact Telestream Customer Support at: desktopsupport@telestream.net or 877-681-2088.

Deactivating a Serial Number

A Switch serial number can only be active on one computer at a time. But, you can enter it on multiple computers (see Activating a Serial Number), making it available on all of them. Before activating Switch on a different computer, you must deactivate wherever it is currently activated. In other words, you can deactivate it and then activate it elsewhere as needed. This makes the use of the serial number more flexible, and avoids unnecessarily purchasing extra licenses.

To deactivate a Switch serial number, Select File > Preferences, click License, then click Deactivate.

When you deactivate your serial number on your computer, it must have Internet access. Deactivation enables you to activate this same serial number on another computer. You can also change licensing by clicking Change and entering a different serial number.
Preferences and Updates

Check for Updates

Display

Select File > Preferences, then click Display to open the Display Settings window. Switch provides three options concerning the display.

Check Enable hardware rendering to use hardware (rather than software GPU drivers) to render the video.

Check Improve playback performance to abandon searching for Captions if they are not found in the first few samples. This improves performance since the application will be doing one less thing (scanning the entire file for Captions) while playing back video.

Optionally, check Disable desktop display whenever you are using an external monitor.

Check for Updates

To check for the latest Switch updates, select File > Preferences, then click Check Now. (See Update in the Setting Preferences section for details.)

Audio

Select File > Preferences, then click Audio to open the Audio Settings window. Select a mode: Custom Analog, Custom Digital, Line Out, or RF. Adjust Cut and Boost by moving the sliders.

Check options

Click Display

Click Audio

Select Mode

Adjust Cut and Boost
Switch Menus

Introduction

Switch has nine menus that provide access to all its controls and features. This section describes the functionality of each menu item in Switch.

Topics

- File Menu
- Edit Menu
- Inspect Menu
- Control Menu
- Audio Menu
- View Menu
- Export Menu
- Window Menu
- Help Menu

File Menu

**Open** Displays the Open dialog window for opening a media file.

**Open Secondary Audio File** Opens a Secondary Audio files that plays along with the currently open primary media file.

**Open Secondary Subtitle File** Opens a Secondary Subtitle files that plays along with the currently open primary media file.

**Open Flags** Opens a Flags file that was saved using the *Export > Flags* menu selection.
**Compare Alternate Media** Opens additional media files to be compared with your primary media file. Up to sixteen alternate media files can be opened. Once opened, all of the files are listed on the View > Alternate Media File menu where they can be selected or cycled through sequentially.

**Open Recent** Displays the most recently accessed media files. Every time a file is opened or saved it is entered into this list.

**Close Window** Closes the currently active media file window.

**Preferences** Opens the Switch Preferences window.

**Exit** Exits Switch.

---

**Edit Menu**

**Undo** Reverses your last change in Switch. Switch offers an unlimited number of undo actions (within computer memory limitations). Undo information is stored on a per-window basis. Also, if you close window then reopen it, your undo information is lost. Undo does not undo edit actions.

**Redo** Reverses your last undo action. Switch offers an unlimited number of redo actions (within computer memory limitations). Redo information is stored on a per-window basis. Also, if you close window then reopen it, your redo information is lost. Redo does not re-do edit actions.

**Cut** Copies (and removes) the selection and stores it on the clipboard allowing you to paste it into a selected target.

**Copy** Copies (but does not remove) the selection and stores it on the clipboard allowing you to paste it into a selected target.

**Paste** Duplicates the content in the clipboard into the currently selected location.

**Select All** Selects all items in the currently active window.

**Set Mark In** Sets the Mark In location in your media file.

**Set Mark Out** Sets the Mark Out location in your media file.

**Add Flag** Adds a new flag with the start time at the current location in the video.

**Set Flag Out** Sets the end time of a selected flag to the current location in the video.

---

**Inspect Menu**

**Container** Opens the Media Inspector window and selects the Container tab. You can also press the Alt + 1 keys.

**Video** Opens the Media Inspector window and selects the Video tab. You can also press the Alt + 2 keys.

**Audio** Opens the Media Inspector window and selects the Audio tab. You can also press the Alt + 3 keys.
**Subtitles** Opens the Media Inspector window and selects the Subtitles tab. You can also press the Alt + 4 keys.

**Time** Opens the Media Inspector window and selects the Time tab. You can also press the Alt + 5 keys.

**Flags** Opens the Media Inspector window and selects the Flags tab. You can also press the Alt + 6 keys.

**Allow Editing** Toggles between edit and inspect mode each time selected. You can also press the Alt + 7 keys.

---

**Control Menu**

**Play/Pause** Plays the selected media file. When playing, the word *Pause* is displayed and when selected causes the media to stop playing. When paused, the word *Play* is displayed.

**Play All** Plays all open media files.

**Play Forward** Causes the selected media to progressively (each time selection is made) play faster in forward direction.

**Stop** Causes the selected media to stop playing.

**Play Backward** Causes the selected media to progressively (each time selection is made) play faster in backward direction.

**Note:** *Play Backward, Stop, and Play Forward* are controlled by keyboard shortcuts J, K, and L (key presses), respectively.

**Slow Motion Forward** Places the currently playing media into forward slow motion mode. Slow motion can also be started while paused.

**Slow Motion Backward** Places the currently playing media into backward slow motion mode. Slow motion can also be started while paused.

**Step Forward** Moves selected media forward one frame.

**Step Backward** Moves selected media backward one frame.

**Skip Forward (1 or 10 sec)** Moves selected media forward one or ten seconds.

**Skip Backward (1 or 10 sec)** Moves selected media backward one or ten seconds.

**Next Chapter** Moves media to the next chapter.

**Previous Chapter** Moves media to the previous chapter.

**Chapters** Displays list of chapters. Moves media to selected chapter.

**Next Flag** Move media to the next flag start location.

**Previous Flag** Moves media to the previous flag end location.
Flags Displays a list of flags. Select a flag in the list to go to its start location.

Jump To End Moves current location in media to last frame. If the media is playing, it will continue playing. If it is paused, it will continue to be paused.

Jump To Start Moves current location in media to first frame. If the media is playing, it will continue playing. If it is paused, it will continue to be paused.

Jump To Moves current location in media to location set in dialog box. Enter new time location value and click Go. If the media is playing, it will continue playing. If it is paused, it will continue to be paused.

Loop When checked (selected), media loops back to start when end is reached. You can choose to loop on the entire duration of the media or just a trimmed section as set by Edit > Set Mark In and Edit > Set Mark Out (or using the I and O keys).

Audio Menu

Increase Volume Turns the media volume up.

Decrease Volume Turns the media volume down.

Mute Mutes the media audio.

Mute Inactive Windows Mutes all inactive windows (active window remains unmuted).

Mute Files Mutes all audio tracks in the selected file.

Mute Tracks Displays a list of tracks. Select a track to mute.

Mute Channels Displays a list of channels. Select a channel to mute.

Solo Files Solos all audio tracks in the selected file.

Solo Tracks Displays a list of tracks. Select a track to solo (all others are muted).

Solo Channels Displays a list of channels. Select a channel to solo (all others are muted).

Loudness Type Selects the loudness type: Gated or Ungated.

Peak Hold Select Infinite Hold or 4s Hold. Infinite hold, holds the audio peaks for an unlimited amount of time. This allows you to view the highest audio peak reached. 4s Hold, holds the audio peaks for only 4 seconds, and then resets the meter.
Switch Menus

**View Menu**

**Play Through External Preview Device** Select to play audio through the selected External Preview device. Audio will only be played through the external preview device when external preview is enabled. Also, the video must match a standard broadcast format, otherwise audio will be played through the default system audio device.

**Enter Full Screen** Cause the active media window to display full screen. To return to original window size, press the Escape key.

**Half Size** Changes the size of the selected media to half of its actual size.

**Actual Size** Changes the size of the selected media to its actual size.

**Double Size** Changes the size of the selected media to twice its actual size.

**Fit to Screen** Changes the size of the selected media to the max size of the screen.

**Increase Size** Increases the size of the selected media.

**Decrease Size** Decreases the size of the selected media.

**Show Playback Statistics** Displays playback statistics such as playback frame rate, queue fill percentages, number of dropped frames, and AFD (Active Format Description) codes.

**Show Frame Metadata** Displays a list of metadata attached to the currently displayed frame, including various types of timecode or captions.

**Note:** Some attached metadata may not be supported by Switch, and therefore will not be displayed.

**Show Timeline** Displays and hides the switch timeline feature. (Requires a Switch Pro license.)
**Time Display** Changes the time display on the selected media: Time, Frame Count, or Timecode.

You can also click on the timecode display to show the settings window. Enter new time data and click Go.

If you select *Frame Count*, enter a new frame count value and click Go.

If you select *Timecode*, enter a new timecode value and click Go. You can also select a timecode source from the drop-down menu (Switch, QuickTime, etc.).
**Safe Areas** Enables you to show/Hide the boundaries of any of three safe areas: Action, Title, Caption, All or None. The Caption boundary is defined by a dotted line. The Title boundary is defined by a dashed line. The Action boundary is defined by a solid line.

![Caption boundary](image)

![Title boundary](image)

![Action boundary](image)

You can also select an alternate aspect ratio (16:9 or 4:3) to define safe areas.

Selected above is *Pillarbox 4:3, Horizontally Centered*. This results in a display of a green rectangle defining the safe area.
The color of the safe area boundary can also be selected: Light or Dark. If you select *Light*, the Action, Title, and Caption boundaries will be displayed in white (else in black is *Dark* is selected). For the Alternate safe area boundary lines, *Light* displays them in green and *Dark* displays them in purple.

**Show Subtitles / Closed Captions** Displays or hides Subtitles / Closed Captioning. (Requires a Switch Plus license.)

**Subtitle / Closed Captions Source** Choose the source of the Subtitles or Closed Captions. These may be embedded in the video or a secondary subtitle file.

**Subtitle / Closed Captions Channel** Choose from multiple channels within a source if present. For example, a video or secondary subtitle file may contain both 608 and 708 Captions. Channels include CEA-608 CC1 through CC4, CEA-708 Service 1 through Service 6, or Teletext Pages.

**V-Chip & Extended Data Services** When selected, if V-Chip and/or other XDS data is present on the selected caption source and channel, it will be rendered in the top right corner of the video.

**Enable/Disable External Preview** Enables or disables the selected External Preview device. When enabled, the menu item changes to *Disable*.

**External Preview Device** Selects an External Preview device. Switch currently supports the following external preview devices: Blackmagic, AJA T-TAP, AJA ioXT, AJA io4K, AJA Kona 3G, AJA Kona 4. Other AJA devices may work as well. The source video must match a format that is supported by the external preview device that you have selected or external preview will not occur. Users can refer to the device manufacturer's
specifications for a list of supported formats for each device. External preview currently only works in Preview mode, not in Edit mode.

**Note:** External Preview requires a Switch Pro license.

**Output VANC Data** Enables and disables the output of VANC data to the selected External Preview device. Enabled when checked. When you output via SDI, you have the option to output ancillary data along with the audio and video signal. This is metadata that pertains to the video being output. For example, Captions are one form of metadata that you may want to output in conjunction with your video. Like SDI out, this feature will remain on when enabled, and will output continuously whenever audio or video is being played back.

**Show Alternate Media** Shows or hides Alternate Media comparison.

**Alternate Media File** Select Alternate Media file from the list. Files are added by selecting *File > Compare Alternate Media*. Cycle Previous and Next enables you to sequentially cycle through the Alternate media files listed.

**Alternate Media Display** Enables you to choose how the selected alternate media file is compared.

- *Full View* displays the media file fully in the media window, enabling you to compare by sequencing through all the media files by selecting *View > Alternate Media Display > Cycle Next*, or by pressing the Alt + Shift + S keys.
• *Split View* displays the selected alternate media file in a split, overlapping window. You can slide the middle divider left or right by clicking and dragging the move (<> ) icon.

• *Difference View* displays the pixel difference between your primary media and the selected alternate media file. The videos are composited into a single black and white signal. Differences between the two videos will appear as highlights on a black backdrop.
**Interlacing** Determines how to display interlaced video frames on your progressive computer monitor. Select which method to use: Weave Fields (default), Blend Fields, Split Fields, Field 1, or Field 2. The Cycle Next menu item chooses the next method in the list.

**Note:** Switch disables the Split Fields option when you enable the Show Gutters option.

**Show/Hide Gutters** Displays or hides (toggle action) the gutters on the active media window.

**Pixel Aspect Ratio** When checked, uses the Aspect Ratio selected on the video tab in the Media Inspector window. Otherwise the aspect ratio is 1:1.

**Alpha Channel** Shows/Hides checked transparency background.

With Alpha Channel on, a transparent image may be very hard to see due to the checkered background:
With Alpha Channel off, the same image is easily viewed:

![Image](image-url)

**Export Menu**

- **Movie** Exports media file as a movie.
- **iTunes Store Package** Exports media file as an iTunes package.
- **Current Video Frame** Exports currently selected frame as a picture.
- **Flags** Exports your flags to a file that can be saved and reopened as needed.
- **Inspector Info** Exports your inspector info in TXT or JSON formats.

**Window Menu**

- **Show/Hide Inspector** Shows and hides the Media Inspector window.
- **Show/Hide Audio Meters** Displays the Audio Meters with a scale and levels. If you have a Pro license, Loudness is also displayed by clicking the arrow. There are four loudness level displays: Momentary, Short-term, Integrated, and Loudness Range.

When the audio meters are shown, you can click the mute headphones (monitor) icon, or mute audio icon, at the bottom of each track. You can also click the Solo or Mute buttons at the bottom of each level bar to solo (turn on) or mute (turn off) any or all level bars in that track. When a level bar solo button is first selected, all other levels are muted. But then you can add any or all other level bars by clicking the solo button of each. This works the same way for the Mute buttons, except the action is muting rather than soloing (turning off rather than on). When a level bar is muted, its peak meter...
display is dimmed but it continues to update with the value it would have were it audible.

**Show/Hide Progress Window** Displays the Export Progress window. Close the Export Progress window by clicking the X in the upper left corner of the window.

**Show/Hide Welcome Screen** Displays or hides the Switch Welcome screen.

---

**Help Menu**

**Switch Help** Opens the online help version of the Switch User Guide.

**Switch User Guide** Opens the PDF version of the Switch User Guide.

**Buy** Enables you to purchase Switch online.

**Report Problem File** Opens a reporting dialog window. Click *Report* to send a report of your file to the Telestream support team. Click *Cancel* to abort.
Gather Support Information Gathers support information and enables you to save a file with this information to your PC desktop. A unique filename is generated. Sending this file to Telestream enables the support team to diagnose any problems you have reported. Click Reveal when finished.

Contact Support Opens the Switch Support page on the Telestream Website.

View Switch Website Opens the Switch Product page on the Telestream Website.

Acknowledgments Opens the Acknowledgments page on the Telestream Website.

About Displays the Switch About window.
View and Window Controls

Introduction

This section presents how to control how Switch is displayed (viewed) and how to manage Switch windows.

Topics

- View Control
- Window Controls

View Control

Enter Full Screen Cause the active media window to display full screen. To return to original window size, press the Escape key.

Half Size Changes the size of the selected media to half of its actual size.

Actual Size Changes the size of the selected media to its actual size.

Double Size Changes the size of the selected media to twice its actual size.

Fit to Screen Changes the size of the selected media to the max size of the screen.

Increase Size Increases the size of the selected media.

Decrease Size Decreases the size of the selected media.
Show Playback Statistics: Displays playback statistics such as playback frame rate, queue fill percentages, number of dropped frames, and AFD (Active Format Description) codes.

![Frame Rate: 0 fps
Queue: Audio -- 100%
Dropped Frames: 0](image)

Frame Metadata:
- SMPTE ST2016-1 Active Format Descriptor (2 - Box 16:9 Top),
- ATSC A/55 Active Format Description,
- ATSC A/53 CEA-708 Closed Captions,
- Tifo Atom,
- Tifo Time Code,
- SMPTE ST12 Time Code,
- SMPTE ST251 Ancillary Data,
- CEA-708 Closed Captions,
- CEA-608 Closed Captions (Field 1)

Show Frame Metadata: Displays a list of metadata attached to the currently displayed frame, including various types of timecode or captions.

**Note:** Some attached metadata may not be supported by Switch, and therefore will not be displayed.

Show Timeline: Displays and hides the switch timeline feature. (Requires a Switch Pro license.)

Time Display: Changes the time display on the selected media: Time, Frame Count, or Timecode.

You can also click on the timecode display to show the settings window. Enter new time data and click Go.
If you select **Frame Count**, enter a new frame count value and click **Go**.

If you select **Timecode**, enter a new timecode value and click **Go**. You can also select a timecode source from the drop-down menu (Switch, QuickTime, etc.).

**Safe Areas**: Enables you to show/Hide the boundaries of any of three safe areas: Action, Title, Caption, All or None. The Caption boundary is defined by a dotted line. The Title boundary is defined by a dashed line. The Action boundary is defined by a solid line.

You can also select an alternate aspect ratio (16:9 or 4:3) to define safe areas.
Selected above is *Pillarbox 4:3, Horizontally Centered*. This results in a display of a green rectangle defining the safe area.

The color of the safe area boundary can also be selected: Light or Dark. If you select *Light*, the Action, Title, and Caption boundaries will be displayed in white (else in black is *Dark* is selected). For the Alternate safe area boundary lines, *Light* displays them in green and *Dark* displays them in purple.

**Show Subtitles / Closed Captions** Displays or hides Subtitles / Closed Captioning. (Requires a Switch Plus license.)

**Subtitle / Closed Captions Source** Choose the source of the Subtitles or Closed Captions. These may be embedded in the video or a secondary subtitle file.

**Subtitle / Closed Captions Channel** Choose from multiple channels within a source if present. For example, a video or secondary subtitle file may contain both 608 and 708
Captions. Channels include CEA-608 CC1 through CC4, CEA-708 Service 1 through Service 6, or Teletext Pages.

V-Chip & Extended Data Services When selected, if V-Chip and/or other XDS data is present on the selected caption source and channel, it will be rendered in the top right corner of the video.

Enable/Disable External Preview Enables or disables the selected External Preview device. When enabled, the menu item changes to Disable.

External Preview Device Selects an External Preview device. Switch currently supports the following external preview devices: Blackmagic, AJA T-TAP, AJA ioXT, AJA io4K, AJA Kona 3G, AJA Kona 4. Other AJA devices may work as well. The source video must match a format that is supported by the external preview device that you have selected or external preview will not occur. Users can refer to the device manufacturer’s specifications for a list of supported formats for each device. External preview currently only works in Preview mode, not in Edit mode.

Note: External Preview requires a Switch Pro license.
**Output VANC Data** Enables and disables the output of VANC data to the selected External Preview device. Enabled when checked. When you output via SDI, you have the option to output ancillary data along with the audio and video signal. This is metadata that pertains to the video being output. For example, Captions are one form of metadata that a you may want to output in conjunction with your video. Like SDI out, this feature will remain on when enabled, and will output continuously whenever audio or video is being played back.

**Show Alternate Media** Shows or hides Alternate Media comparison.

**Alternate Media File** Select Alternate Media file from the list. Files are added by selecting File > Compare Alternate Media. Cycle Previous and Next enables you to sequentially cycle through the Alternate media files listed.

**Alternate Media Display** Enables you to choose how the selected alternate media file is compared.

- **Full View** displays the media file fully in the media window, enabling you to compare by sequencing through all the media files by selecting View > Alternate Media Display > Cycle Next, or by pressing the Alt + Shift + S keys.
- **Split View** displays the selected alternate media file in a split, overlapping window. You can slide the middle divider left or right by clicking and dragging the move (<> ) icon.

- **Difference View** displays the pixel difference between your primary media and the selected alternate media file. The videos are composited into a single black and
white signal. Differences between the two videos will appear as highlights on a black backdrop.

**Interlacing** Determines how to display interlaced video frames on your progressive computer monitor. Select which method to use: Weave Fields (default), Blend Fields, Split Fields, Field 1, or Field 2. The Cycle Next menu item chooses the next method in the list.

**Note:** Switch disables the Split Fields option when you enable the Show Gutters option.

**Show/Hide Gutters** Displays or hides (toggle action) the gutters on the active media window.
**Pixel Aspect Ratio** When checked, uses the Aspect Ratio selected on the video tab in the Media Inspector window. Otherwise the aspect ratio is 1:1.

**Alpha Channel** Shows/Hides checked transparency background.

With Alpha Channel on, a transparent image may be very hard to see due to the checkered background:

With Alpha Channel off, the same image is easily viewed:
Window Controls

To access various window controls, select the Switch Window menu.

**Show/Hide Inspector** Shows and hides the Media Inspector window.

**Show/Hide Audio Meters** Displays the Audio Meters with a scale and levels. If you have a Pro license, Loudness is also displayed by clicking the arrow. There are four loudness level displays: Momentary, Short-term, Integrated, and Loudness Range.

When the audio meters are shown, you can click the mute headphones (monitor) icon, or mute audio icon, at the bottom of each track. You can also click the Solo or Mute buttons at the bottom of each level bar to solo (turn on) or mute (turn off) any or all level bars in that track. When a level bar solo button is first selected, all other levels are muted. But then you can add any or all other level bars by clicking the solo button of each. This works the same way for the Mute buttons, except the action is muting rather than soloing (turning off rather than on). When a level bar is muted, its peak meter display is dimmed but it continues to update with the value it would have were it audible.

**Show/Hide Progress Window** Displays the Export Progress window. Close the Export Progress window by clicking the X in the upper left corner of the window.

**Show/Hide Welcome Screen** Displays or hides the Switch Welcome screen.
Reference

Introduction

This section provides important reference information including supported codecs and formats, and network protocols.

Topics

- Supported Codecs, Formats, & Protocols

Supported Codecs, Formats, & Protocols

The following audio and video codecs and general file formats can be processed in Switch.

Note: Switch can play all codecs, formats, and protocols provided by QuickTime including uncompressed 4:2:2 10-bit (v210) and Apple ProRes 4444 XQ. Switch for Windows exports Apple ProRes 422 (HQ) within iTunes Store Package only.

Playback Format Support

Containers

AAC
AC3
AIFF
ASF
AVC (AVC Elementary Stream)
AVI (OpenDML)
DV
GXF
HEVC (HEVC Elementary Stream)
Supported Codecs, Formats, & Protocols

- IMF
- LXF
- M1V (MPEG-1 Video Elementary Stream)
- M2V (MPEG-2 Video Elementary Stream)
- MOV
- MP3 (MPEG Layer 1, 2, 3 Audio Elementary Stream)
- MP4 (ISO Base Media Format)
- MPG (MPEG-1 System Stream)
- MPS (MPEG-2 Program Stream)
- MTS (MPEG-2 Transport Stream)
- MXF (AS-11^3 with UK DPP metadata)
- MXF (OP-1a; AS-02, AS-03^3, AS-11^5)
- MXF (OP-1a Proxy)
- MXF (OP-1b)
- MXF (OP-Atom)
- SCC^4
- WAV

**Video Codecs (decode only)**

- Apple QuickTime Animation RLE^5
- Apple ProRes
- DNxHD^1
- DNxHR^1
- DV 25
- DVCPro 25
- DVCPro 50
- DVCPro 100
- DVCPro HD
- H.263
- H.264
- H.265^1
- JPEG
- JPEG2000^1
- MPEG-1
- MPEG-2^6
- MPEG-4
- Uncompressed YUV
- VP9
- WMV
**Audio Codecs (decode only)**

AAC
AC3
G.711 aLaw
G.711 uLaw
G.726
Microsoft ADPCM
MPEG Audio Layer 1, 2, 3
PCM
WMA

**Caption**

Extraction and playback: CEA-608, CEA-708
DVB files
SCC\(^3\) files
SRT files
STL files
TTML/ITT/SMPTE-TT files
WebVTT (HTML5) files

---

1 Not supported in Switch Player.
2 HEVC support of 8-bit 4:2:0 profiles in Elementary Streams, MPEG-2 Transport Stream or MP4 files.
3 Advanced inspection of application-specific metadata included in Switch Pro.
4 Currently supports export of .scc files as part of an iTunes asset-only package.
5 Currently supports 24-bit and 32-bit only.
6 Not supported in Switch Player for Windows.

---

**Encode Format Support**

**Containers**

ASF
MOV
MPEG-2 TS/PS
MPEG-4
MXF (OP-1a, OP-Atom)

**Video Codecs**

Apple ProRes
MPEG-2 Video
Supported Codecs, Formats, & Protocols

WMV
x264

Audio Codecs
AAC
MPEG Layer 2
PCM
WMA

1 Export is available for Plus and Pro only.
2 ProRes export on Windows only possible in iTunes packages using Switch Pro.

iTunes Package Export

Creates an asset-only iTunes package file (an .itmsp file) which includes media content, secondary subtitle (.iTT or .scc files) or audio files, chapter information and an XML file. iTunes packages can only be created using the ProRes 422 HQ profile.

DPP/AMWA Certified Player

Switch can visually QC DPP files on the desktop, playing back the files as well as displaying DPP AS-11 MXF metadata.
Acknowledgments

Portions of this software may utilize the following copyrighted material, the use of which is hereby acknowledged:

**x264** The product is manufactured by Telestream, LLC under license from x.264 LLC

**Main Concept** © 2013 Rovi Corporation. All rights reserved. MainConcept is a subsidiary of Rovi Corporation.

**Apple** QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

**Matt Gemmell** Includes MAAttachedWindow code by Matt Gemmell.

**MIT License**

Copyright (c) 2018 Telestream, LLC

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.