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Contacting Telestream
To obtain product information, technical support, or provide comments on this guide,
contact us using our web site, email, or phone number as listed below.
Resource

Contact Information

Wirecast Technical
Support

Support Website: http://www.telestream.net/telestreamsupport/wire-cast/support.htm
Support Email: support@telestream.net
Enterprise Telephone Support:
U. S. Toll Free: (877) 257-6245
U. S. from outside U.S.: (530) 470-2036
Europe | Middle East | Africa | Asia | Pacific:
+49 228 280 9141
Terms and times of support services vary, per the terms of
your current service contract with Telestream.

Telestream, LLC

Web Site: www.telestream.net
Marketing Email: info@telestream.net
Sales Email: sales@telestream.net
Sales Website: http://www.telestream.net/purchase/
store.htm
Telestream, LLC
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International
Distributor Support

Web Site: www.telestream.net

Telestream Technical
Writers

Email: techwriter@telestream.net

See the Telestream Web site for your regional authorized
Telestream distributor.
Share comments about this or other Telestream documents.

Copyrights and Trademark Notices
Copyright © 2022 Telestream, LLC and its Affiliates. All rights reserved. No part of this
publication may be reproduced, transmitted, transcribed, altered, or translated into any
languages without written permission of Telestream, LLC. Information and
specifications in this document are subject to change without notice and do not
represent a commitment on the part of Telestream. Specifications subject to change
without notice.
Telestream, CaptionMaker, Cerify, DIVA, Episode, Flip4Mac, FlipFactory, Flip Player,
GraphicsFactory, Kumulate, Lightspeed, MetaFlip, Post Producer, ScreenFlow, Switch,
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Tempo, TrafficManager, Vantage, VOD Producer, and Wirecast are registered trademarks
and Aurora, ContentAgent, Cricket, e-Captioning, Inspector, iQ, iVMS, iVMS ASM,
MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port, CaptureVU, FlexVU, PRISM,
Sentry, Stay Genlock, Aurora, and Vidchecker are trademarks of Telestream, LLC and its
Affiliates. All other trademarks are the property of their respective owners.
Adobe. Adobe® HTTP Dynamic Streaming Copyright © 2014 Adobe Systems. All rights
reserved.
Apple. QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the
Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.
Avid. Portions of this product Copyright 2012 Avid Technology, Inc.
CoreOS. Developers of ETCD.
Dolby. Dolby and the double-D symbol are registered trademarks of Dolby
Laboratories Licensing Corporation.
Fraunhofer IIS and Thomson Multimedia. MPEG Layer-3 audio coding technology
licensed from Fraunhofer IIS and Thomson Multimedia.
Google. VP6 and VP8 Copyright Google Inc. 2014 All rights reserved.
MainConcept. MainConcept is a registered trademark of MainConcept LLC and
MainConcept AG. Copyright 2004 MainConcept Multimedia Technologies.
Manzanita. Manzanita is a registered trademark of Manzanita Systems, Inc.
MCW. HEVC Decoding software licensed from MCW.
MediaInfo. Copyright © 2002-2013 MediaArea.net SARL. All rights reserved.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Microsoft. Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008
|Server 2012|Server 2016|Server 2019, Windows 7, Windows 8, Windows 10, Media
Player, Media Encoder, .Net, Internet Explorer, SQL Server 2005|2008|2012|2016|2019,
and Windows Media Technologies are trademarks of Microsoft Corporation.
NLOG, MIT, Apache, Google. NLog open source code used in this product under MIT
License and Apache License is copyright © 2014-2016 by Google, Inc., © 2016 by Stabzs,
© 2015 by Hiro, Sjoerd Tieleman, © 2016 by Denis Pushkarev, © 2015 by Dash Industry
Forum. All rights reserved.
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SharpSSH2. SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer:
Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or other materials
provided with the distribution.
Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors
may be used to endorse or promote products derived from this software without
specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Swagger. Licensed from SmartBear.
Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.
VoiceAge. This product is manufactured by Telestream under license from VoiceAge Corporation.
x264 LLC. The product is manufactured by Telestream under license from x264 LLC.
Xceed. The Software is Copyright ©1994-2012 Xceed Software Inc., all rights reserved.
ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.

Other brands, product names, and company names are trademarks of their respective
holders, and are used for identification purpose only.
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MPEG Disclaimers
MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM
MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 80237 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE.
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C.
SEE HTTP://WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA,
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.
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Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the
product will perform as stated below for a period of one (1) year from the date of
shipment from factory:
Hardware and Media—The Product hardware components, if any, including equipment
supplied but not manufactured by the Company but NOT including any third party
equipment that has been substituted by the Distributor for such equipment (the
“Hardware”), will be free from defects in materials and workmanship under normal
operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:
Hardware and Media—The Company will either repair or replace (at its option) any
defective Hardware component or part, or Software Media, with new or like new
Hardware components or Software Media. Components may not be necessarily the
same, but will be of equivalent operation and quality.

Software Updates
Except as may be provided in a separate agreement between Telestream and You, if
any, Telestream is under no obligation to maintain or support the Software and
Telestream has no obligation to furnish you with any further assistance, technical
support, documentation, software, update, upgrades, or information of any nature or
kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration,
neglect, or shipping, or as a result of service or modification by a party other than the
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral
or written information or advice given by the Company, its distributors, dealers or
agents, shall increase the scope of this Limited Warranty or create any new warranties.
Geographical Limitation of Warranty—This limited warranty is valid only within the
country in which the Product is purchased/licensed.
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Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF
TELESTREAM, LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any
Limited Warranty by the Company shall be the recovery of reasonable damages which,
in the aggregate, shall not exceed the total amount of the combined license fee and
purchase price paid by you for the Product.

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS
ESSENTIAL PURPOSE.
Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA
You can call Telestream during U. S. business hours via telephone at (530) 470-1300.

Regulatory Compliance
Electromagnetic Emissions: FCC Class A, EN 55022 Class A, EN 61000-3-2/-3-3, CISPR 22
Class A
Electromagnetic Immunity: EN 55024/CISPR 24, (EN 61000-4-2, EN 61000-4-3, EN
61000-4-4, EN 61000-4-5, EN 61000-4-6, EN 61000-4-8, EN 61000-4-11)
Safety: CSA/EN/IEC/UL 60950-1 Compliant, UL or CSA Listed (USA and Canada), CE
Marking (Europe)
California Best Management Practices Regulations for Perchlorate Materials:
This Perchlorate warning applies only to products containing CR (Manganese Dioxide)
Lithium coin cells. Perchlorate Material-special handling may apply. See
www.dtsc.ca.gov/hazardouswaste/perchlorate.
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Introducing Wirecast

Introduction
Wirecast is professional-grade software for live streaming video production.

Topics
■Introducing Wirecast 16
■Wirecast Workflow 17
■Wirecast Resources 18
■Two Ways to Use this Application 19

Introducing Wirecast
Wirecast provides the tools you need for every step of a broadcast, from audio-video
capture to live production to streaming.
Note: We use the word, “broadcast” throughout this guide to mean a one-to-many
transmission of an audio-video stream, and related data, over the Internet.
Wirecast is available in two versions: Studio and Pro.
Wirecast Studio supports the following:

• Unlimited Capture
– Unlimited inputs
– Two remote guests via Wirecast

• Rendezvous conferencing
• Enhanced Production
– 4096 x 3072 maximum project and encoding resolution
– Five Main Mixing layers
– Built-in, animated lower thirds title library
– Integrated text, Chroma Key and built-in transitions
– Custom transitions, playlists
– Advanced audio mixer
– Social media comment moderation
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• Unlimited Destination Outputs
– Unlimited output destinations + multiple simultaneous record-to-disks
– Virtual camera and microphone output
– 1-4 slot multi-viewer output unlimited
Wirecast Pro includes all the features of Wirecast Studio and also supports the
following:

• Advanced Unlimited Capture
– Seven remote guests via Wirecast Rendezvous conferencing

• Advanced Production
– PTZ Camera Control
– Pro Audio FX
– Sports Production (instant replay, scoreboards)
– Virtual Sets and backgrounds

• Advanced Unlimited Destination Outputs
Adds baseband SDI/HDMI output, NDI program output, and Secondary Display output
– 1-17 slot multi-viewer output
– ISO recording of individual sources
– Multi-track audio recording
Features that pertain specifically to Wirecast Pro are indicated by this Pro icon:
PRO

Note: Both Studio and Pro licenses include one year of Insider Access Support
providing free software updates, access to built-in Stock Media library, on-demand
video training, access to Knowledgebase and Community Forum, and email support
with an eight-business-hour response time target.
This guide explains how Wirecast works, and provides tips for producing the best
broadcasts possible.

Wirecast Workflow
Because of its versatility in handling a variety of inputs and outputs, Wirecast typically
fits in the middle of your broadcasting workflow. Wirecast can take the place of
traditional T-bar hardware switchers, graphics generators, and title generators.
However, you can also use Wirecast simply as the back-end encoder for large switching
systems.
Wirecast productions generally follow a four-step workflow:
1. Plug in your live input devices such as video cameras, iOS cameras, computer
desktop, and web feeds.
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2. Capture your content.
3. Produce your program using the full range of Wirecast production features.
4. Stream your program live to the web or to a LAN, or record it to a local drive.
Figure 1. The Wirecast Workflow

Wirecast Resources
For up-to-date information about Wirecast, visit the following Telestream resources.

Tutorials, Webinars, and Demos
To learn Wirecast basics quickly, work through the tutorials in the Tutorials section of
the Wirecast User Guide. The tutorial environment built into Wirecast corresponds with
these tutorials. Together, the three tutorials take about thirty minutes.
Telestream provides tutorials, webinars, and product demos on the Wirecast Training
Resources page:
http://www.telestream.net/telestream-support/wire-cast/training.htm
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Finally, Telestream provides tutorials, webinars, and product demos on Vimeo at these
locations:
Wirecast Webinars
Wirecast Tutorial Series: Part I
Wirecast Tutorial Series: Part II
Also, see Making Great Broadcasts. This topic provides practical tips for improving the
quality of your presentations.

Telestream User Forum
Join the active community of Wirecast users in posting Wirecast questions, answers,
and feature requests. Also, one click takes you from the forum to the knowledge base of
Wirecast technical articles.
Telestream User Forums:
https://telestreamforum.forumbee.com/

Wirecast Literature, Documentation, and Knowledge Base
Find current versions of Wirecast literature, user guides, and customer case studies on
the Wirecast Literature and Documentation page. Find Wirecast technical articles on
the Wirecast Knowledge Base.
Wirecast Literature and Documentation:
http://www.telestream.net/wirecast/resources.htm#docs
Wirecast Knowledge Base:
Wirecast Knowledge Base

Navigate the User Interface.
For descriptions of the various Wirecast menu items, tools and windows, see Windows,
Controls, and Menus.

Two Ways to Use this Application
There are two different ways you can use Wirecast:

• Presenter Is Operator The person conducting the presentation also operates Wirecast.

• Presenter Plus Operator The presenter concentrates on the content and someone
else operates Wirecast. In this mode, the presenter never needs to know in detail
how Wirecast works.
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Presenter Is Operator
In this mode of operation, the person conducting the presentation simultaneously
operates Wirecast.
Here are some suggestions for using Wirecast when you are both the presenter and
operator:

• Keep it simple Set up Wirecast to make it easy for you to be the operator and the
presenter. Set up your logo and titles so that you need to make very few changes
during your presentation. Use a minimum number of shots so it’s easy for you to
see which shot to choose.

• Keep the AutoLive feature on This enables you to present your shots with just one
click. Though this limits your ability to perform complex presentations, it is the best
way when the presenter is also the operator. To turn AutoLive on or off, select it
under the Switch menu.

• Pre-configure your shots Make sure that all the shots are created prior to your
presentation. Do not try to create or modify shots while broadcasting them.

• Use hot-keys for switching shots Wirecast provides a hotkey editor that enables
you to easily assign hotkeys to your shots.

Presenter Plus Operator
In this mode of operation, an engineer (or operator) is responsible for using Wirecast,
and the presenter concentrates on the content of the presentation.
Here are some suggestions for using Wirecast when you have both an operator and a
presenter:

• Keep the AutoLive feature off This enables you to make several changes at one

time before taking the changes live. However, to quickly make a shot live, press the
Shift+Ctrl keys and click the shot. The AutoLive control is located under the Switch
menu

• Open the Preview Area The operator should use Preview mode to examine everything before it becomes live. The Preview display control is located under the Layout menu.

• Use the Layer Windows to make more shots available To open layer windows so
you can quickly flip between shots on several layers, select Window > New Layer
Window.
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Installation
You can install Wirecast on any Mac or Windows computer that meets the minimum
system requirements.

Topics
■General System Requirements 22
■Installation and Uninstallation 25
■Purchasing, Activating, and Deactivating Wirecast 25
■Support Subscriptions and Upgrades 27
■Checking for Wirecast Updates 27
■Demonstration Mode 27
■Installing a Hardware Controller 28
■Preventing Screen Tearing with Vertical Sync 28
■Preventing Dropped Frames from Short Latency 29
■The Wirecast Capture Folder 29

General System Requirements
Operating System
• Minimum: Windows 10 version 1809 or higher; or Windows 11 21H2
• Recommended: Windows 10 21H2

Processor
Note: How to check the generation of your Intel processor.

• Minimum: Intel 6th generation (May be insufficient for 1080p+ or 60 fps workflows)
or later; or AMD Ryzen™ 1000 Series or later

• Recommended: Intel 7th generation or later; or AMD Ryzen™ 3000 Series or later
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Memory
• Minimum: 8GB RAM
• Recommended: 16+ GB RAM

Hard Drive
• Minimum: 7200 RPM Hard Drive (HDD) for record to disk
• Recommended: Solid State Drive (SSD)

Graphics Card
• Minimum: Intel HD (insufficient for advanced Multi-Viewer workflows), 2 GB video
memory, DirectX 11 capable

• Recommended: Dedicated Nvidia GeForce 4+ GB video memory, DirectX 12 capable

Internet Bandwidth
Recommended: Total bitrate needed x 2 = Required upload bandwidth

Network Ports
You may want to check that the following ports are open for traffic on your network:

•
•
•
•
•
•
•
•
•
•

80 (HTTP/HTTPS)
443 (SSL)
1935 (RTMP)
2935 (RTMPS)
3478 (STUN/Rendezvous)
5349 (STUN/Rendezvous)
5353 (mDNS for NDI sources)
5960-59xx NDI port range (One port for each NDI source in use)
7272 (Remote Desktop Presenter)
49152-65535 (WebRTC Media/Rendezvous, selected at random)

If you are behind a firewall, check with your streaming destination for any sites you may
need to whitelist.
Note: We recommend running Wirecast on the Windows Aero theme, which includes
a hardware-accelerated window manager. Running Wirecast on the Windows Classic
theme can cause performance issues.
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Rendezvous Requirements
Wirecast Rendezvous uses WebRTC technology that can be very resource intensive. For
the best Rendezvous experience, we recommend the following hardware:
Studio (2 guests + 1 host)

Pro (7 guests + 1 host)

Bandwidth1

Add 4 Mbps

Add 5+ Mbps2

Processor1

i5 quad-core3

i7 quad-core3

1. Based on a single simultaneous stream of 720p30 x264 @ 4.0Mbps.
2. Bandwidth per guest will scale downwards as more are added to maintain
reliability.
3. Minimum recommended processor with example stream4. More demanding
workflows may require a more capable CPU.

ISO Recording Requirements
• Solid State Drive or fast RAID array recommended for ISO Recording and Replay
functionality.

• Actual data rates will vary depending on quality level selected for ProRes (Mac) or
MJPEG recording (Windows), as well as the resolution and frame rate selected.

• For Mac ProRes recording please refer to Apple’s ProRes data rate specifications.
• Total expected data rate should be compared to available disk write speed to
ensure adequate disk throughput.

Note: Failure to ensure the available disk write speed is greater than the highest
expected total data rate may result in frames being dropped from recordings (ISO,
Replay, and Record-to-Disk).

Recommended Hardware
• Intel Core i5 CPU @ 2.5 Ghz or higher recommended for 720p streaming with x264
@ 30 fps.

• Intel Core i7 CPU @ 3.0Ghz or higher recommended for 1080p streaming with x264
@ 30fps.

Note: 60 FPS streaming will result in increased CPU usage and a high bit rate (4Mbps
or higher) for good quality.

• Minimum 4GB RAM, 2GB free hard disk space. Additional hard disk space required
for recording to disk.
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Hardware Accelerated Encoding Requirements
• Intel Quick Sync Video encoding requires an Intel CPU with an Intel® QuickSync
Video core.

• NVIDIA NVENC encoding requires an NVidia GPU with Kepler architecture or newer.

Installation and Uninstallation
You can install Wirecast on any computer that meets the Wirecast basic system
requirements.

Installing Wirecast
To install Wirecast, follow these steps:
1. Download the installer from the Telestream website:
https://dynamic.telestream.net/downloads/download-wirecast.asp?prodid=wirecast.
2. Run the installer (.exe) program and follow the instructions provided.
Note: The Wirecast installer asks whether you want to install the Virtual Microphone
feature. If you do (recommended), check the box for this feature and continue the
installation. You must have administrative rights to install Virtual Microphone.
3. If you have an older version of Wirecast already installed on your computer, the
installer upgrades to the newer version.
See also Install and Activate Wirecast for Windows.

Uninstalling Wirecast
To uninstall Wirecast, do the following:
1. Run the Wirecast installer (.exe) program.
The installer asks if you want to repair or remove the existing version.
2. Select Remove to uninstall the existing version of Wirecast.

Purchasing, Activating, and Deactivating Wirecast
You can purchase and activate Wirecast on a computer that is either online or offline.

Purchasing and Activating Wirecast Online
To purchase and activate Wirecast, do the following:
1. Launch Wirecast.
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2. Select File > Preferences > Licenses, and click Purchase. Purchase Wirecast. Enter your
license key into the License Key field. If you previously purchased a copy of Wirecast
and want to use that serial number, enter that serial number.
3. Click Activate.
Wirecast validates the serial number and unlocks Wirecast.
4. Close the Preferences window.
Telestream activates your Wirecast program.
Note: You can also purchase a serial number at www.telestream.net.
See Preferences.

Activating Wirecast Offline
If the computer where Wirecast is installed is not on the Internet, you can use another
computer that is online to activate your license and unlock Wirecast.
To activate your license from another computer, follow the steps in the Offline
Activation Guide at:
http://www.telestream.net/telestream-support/wire-cast/training.htm.

Deactivating Wirecast
Deactivating a serial number on one computer allows you to re-activate it on another
computer. Without an activated license, Wirecast adds water-marking to the video and
audio whenever licensed features are used.
Note: You can always reactivate a serial number by re-entering it into the License Key
field and clicking Activate.
To deactivate Wirecast, do the following:
1. Select File > Preferences > Licenses.
2. Click Deactivate.
Wirecast deactivates the serial number and removes it from the License Key field.
Note: You can access the License Reset Tool at:
https://www.telestream.net/telestream-support/deactivate-software.htm
See Preferences.
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Support Subscriptions and Upgrades
With each purchase of Wirecast – whether it is an upgrade purchase or full license – you
receive an Insider Access Support subscription for one year from the date of purchase.
You can renew this subscription annually.
You can choose to upgrade from an Insider Access Support subscription to a Premium
Access Support subscription at any time, for an additional fee. You can also renew
Premium Access Support subscriptions annually.
Your support subscription is tied to your Wirecast license. As long as your license is
entered into the software and your Premium Access Support or Insider Access Support
subscription is active, you can upgrade to the latest unlocked version of Wirecast for
free. To do this, download and install the latest version of Wirecast. You will
automatically have access to all the new features (depending on your license level).
If your support subscription is expired, or you have not entered your license into the
software, you will not be able to upgrade to an unlocked version and the software will
revert to demonstration mode. However, you may continue to use the last valid version
of the software released during your support subscription coverage.
If your support subscription is about to expire (12 months from the date of purchase),
Wirecast will prompt you to renew it. If you do not renew it before it expires, you may
re-subscribe at any time for an additional fee.
See also Support Subscriptions and Upgrades.

Checking for Wirecast Updates
To check for Wirecast software updates, do the following:
1. Select File> Preferences > Software Update.
2. Click Check Now.
Wirecast checks for updates, but does not transmit personal information to
Telestream during this action.
See Preferences.

Demonstration Mode
With no active serial number, Wirecast enters demonstration mode. In demonstration
mode, Wirecast watermarks all outputs (both to disk and network). The video watermark is a periodic overlay of the Wirecast logo. The audio watermark is a periodic voiceover. If you have a Wirecast serial number and are using a Wirecast Pro feature without a
Pro license, Wirecast also watermarks that output.
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Installing a Hardware Controller
You can control many Wirecast functionalities with some external hardware controllers,
or Human Interface Devices. Wirecast provides control of three MIDI controllers: APC
MINI, APC40mk2, Launchpad MK2, and one X-keys controller: XKeys 128.
To install a hardware controller for Wirecast, do the following:
1. Select File > Preferences > Controllers.
2. Select a controller from the drop-down menu.
3. To close the Preferences dialog box, click the “x.”
See Preferences.

Preventing Screen Tearing with Vertical Sync
Wirecast usually synchronizes its video display with the refresh rate of your display.
However, this degrades performance when the Wirecast program window is not visible
(due to the screen being locked, Wirecast minimized, or the Wirecast covered by
another application).
When your system can’t draw a complete frame by the time another one comes along
you'll notice “tearing” artifacts in your video. There is a Vertical Synchronization option
that is disabled by default. Unchecking this box will enable vertical synchronization.
This prevents the video card from drawing another frame until after the monitor
finishes its current refresh cycle. However, when vertical synchronization is used, the
frame rate of the rendering engine gets limited to the video-signal frame rate. That
feature improves video quality but involves trade-offs in some cases. For example this
could introduce input lag, which can interfere with the interactive nature of games,
particularly games that require precise timing or fast reaction times. You can prevent
Wirecast from dropping frames, and optimize Wirecast performance by disabling
vertical sync.
See also Screen Tearing.
Note: Disabling vertical sync can interfere with the smooth display of video in the
Wirecast user interface. This does not, however, decrease the broadcast video quality.
In order to avoid dropping frames, do the following:
1. Select File > Preferences > Advanced.
2. Check Disable Vertical Sync.
3. To close the Preferences dialog box, click the “x.”
See Preferences.
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Preventing Dropped Frames from Short Latency
You can prevent Wirecast from dropping frames, and optimize Wirecast performance
by lengthening latency.
Wirecast adds latency to all incoming sources. Latency is the brief period between
receiving live video and displaying it or processing it. Adding latency gives Wirecast
time to store the incoming data properly. The Application Source Latency preference lets
you specify the length of the latency. The lower this value, the less time Wirecast takes
between receiving data and using it. If the connection is not fast enough, or the latency
is too brief, this may result in dropped video frames (less noticeable) and audio blips
(very noticeable). The higher this value, the more time Wirecast has to store data before
displaying or processing it. You can set the value for Application Source Latency, from
50ms at a minimum to 330ms at a maximum. The default is 300 ms.
In order to avoid dropping frames from short latency, do the following:
1. Select File > Preferences > Advanced.
2. Enter a value, in milliseconds, into the Application Source Latency field.
3. To close the Preferences dialog box, click the “x.”
See Preferences.

The Wirecast Capture Folder
The first time you launch Wirecast, Wirecast detects any media capture drive present in
your computer, and creates the folder, Wirecast Recordings, on the media capture drive.
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Customization
You can customize Wirecast to your needs by selecting Wirecast preferences. You can
select most preferences directly from a Wirecast document or from the Shot Editor. You
can also manage your licenses, update your software, and select advanced video
preferences through the Preferences window.

Topics
■Launching Wirecast 30
■The Wirecast Layout 31
■Customizing Wirecast with Preferences 31
■Document Hotkeys and Application Shortcuts 31
■Setting the Primary Device for Audio Monitoring 34
■Choosing a Video Adapter 34
■Disabling Sleep Mode 34
■Assigning CPU Usage 34
■Keeping the Wirecast Window on Top 35
■Customizing the Playlist Countdown Timer 35
■Selecting and Customizing Encoder Presets 35
■External Display Outputs 35
■Adding VST Plugins to the Available Audio Plugins 36

Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop
during installation.
Note: You can determine whether Wirecast displays the landing page, and whether
Wirecast opens the last document you worked on, at startup.
See Show landing page on startup and Open last document on startup.
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The Wirecast Layout
Before customizing the Wirecast layout, familiarize yourself with the default layout, and
with the main Wirecast windows, controls, and menus.
See The Default Layout.

Customizing Wirecast with Preferences
You can customize Wirecast to meet your particular production needs, and types of
equipment, by choosing preferences.
See The Preferences Dialog Box.
To customize Wirecast, do the following:
1. Select FilePreferences.
2. In the Preferences dialog, click one of these headings to view and change its
associated preferences:
– General
– Canvas
– Shot Display
– Licenses
– Update
– Shortcuts
– Controllers
– Advanced
Wirecast applies your preferences immediately, and saves them automatically, every
time you change a preference.

Resetting Preferences
To reset your preferences, use Support Assistant.
See Send Support Information and Preferences.

Document Hotkeys and Application Shortcuts
You can control most of the standard Wirecast commands with pre-set application
keyboard shortcuts. Also, you can create document hotkeys for document commands
you use often.

Creating a Keyboard Shortcut Set
You can create new keyboard shortcut sets, including both application keyboard
shortcuts and document hotkeys, through the Shortcuts tab on the Preferences dialog.
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You create a new keyboard shortcut set by copying an existing keyboard shortcut set
and modifying it.
To create a keyboard shortcut set, do the following:
1. Select File > Preferences > Shortcuts.
2. Select the keyboard shortcut set you want to copy from the Keyboard Shortcut Set
drop-down menu.
3. Click Configure > Duplicate Set.
Wirecast copies the selected keyboard shortcut set and adds it to the Keyboard
Shortcut Set drop-down menu.
4. Select the new keyboard shortcut set from the Keyboard Shortcut Set drop-down
menu.
5. Click Configure > Rename.
Wirecast opens a renaming dialog box.
6. Enter a name for the keyboard shortcut set in the field under Please enter a new
name for the Set, and click OK.
Wirecast renames the keyboard shortcut set, and closes the Preferences dialog box.
See also Shortcuts Preferences.

Changing a Keyboard Shortcut
You can’t change any of the default application shortcuts in the Default keyboard
shortcut set. However, you can copy the Default keyboard shortcut set, and edit the
application shortcuts in the copied keyboard shortcut set. Also, you can change the
document hotkeys.
To change a keyboard shortcut (either an application shortcut or a document hotkey),
do the following:
1. Create a keyboard shortcut set by copying the Default keyboard shortcut set.
See Creating a Keyboard Shortcut Set.
2. Select the keyboard shortcut you want to change.
See Finding an Application Shortcut and Finding a Document Hotkey.
Wirecast opens the Click to record shortcut field towards the bottom of the Preferences dialog.
3. Enter the key desired in the Click to record shortcut field.
Wirecast saves the new keyboard shortcut.

Creating a Document Hotkey
To create a document hotkey, do the following:
1. Select File > Preferences > Shortcuts > Document Hotkeys.
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2. Select a hotkey in the list.
Wirecast opens the Click to record shortcut field.
3. Enter a key in the Click to record shortcut field.
Wirecast binds the key to the command.
4. (Optional) To make your hotkey active even when the Wirecast window is not in
focus, check Global. If Global is not checked, you must select the Wirecast window
for the document hotkey to work.
See also Shortcuts Preferences.
Note: If your hotkey combination already is assigned to a command, Wirecast
displays a warning icon in the Conflict column. The Conflicted subtab of the Application
Shortcuts tab displays conflicted application shortcuts.

Creating a Document Hotkey for a Shot
On a shot in the layers pane, click the gear icon, select Assign Hotkey, and select a
hotkey from the menu.
Wirecast assigns the hotkey to the shot, and displays the keyboard shortcut in the
shot icon.
See Layers, Creating a Document Hotkey, and Shortcuts Preferences.

Creating a Document Hotkey for Multiple Shots
You can assign the same document hotkey to multiple shots. This is useful when you
want to activate different shots on different layers at the same time, using a single
hotkey. To create a document hotkey for multiple shots, do the following:
1. Assign a keyboard shortcut to one shot.
See Creating a Document Hotkey for a Shot.
2. Assign the same keyboard shortcut to a second shot on another layer.
Wirecast displays the keyboard shortcut in both shot icons.
See also Shortcuts Preferences.

Displaying Either Hotkey Name or Key Combination on
Shots
To determine whether Wirecast displays the hotkey name or the key combination itself
on shots, do the following:
1. Open Preferences, and select the Shot Display tab.
See Customizing Wirecast with Preferences.
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2. Click the arrows for the Display hotkeys using drop-down menu.
Wirecast displays the options Key Combination and Hotkey Name.
3. Select the type of hotkey display desired.
See also Shot Display Preferences and Shortcuts Preferences.

Setting the Primary Device for Audio Monitoring
To select the device Wirecast uses for audio monitoring, do the following:
1. In Windows, right-click the speaker icon in the task bar. Then, select Open Sound
settings > Sound.
2. Under Choose your output device select the desired default audio-monitoring device
from the drop-down menu.
Wirecast uses the device chosen as the device for audio-monitoring. You can select a
different device through the Audio Playback preference.
See Audio Playback.

Choosing a Video Adapter
If your computer has multiple video adapters, such as NVIDIA, AMD, or Intel graphics
cards, you can determine which video adapter Wirecast uses. Generally, use this option
only for troubleshooting.
To select a video adapter, do the following:
1. Select FileWirecast > Preferences > Advanced.
2. From the Video Adapter drop-down menu, select the video adapter desired. Choose
Select a video adapter.
3. To close the Preferences dialog box, click the “x.”
See PreferencesPreferences.

Disabling Sleep Mode
Wirecast does not prevent your computer from entering sleep mode. To ensure
uninterrupted streaming, disable sleep mode on your computer while using Wirecast.

Assigning CPU Usage
To avoid a decrease in video quality, don’t set Wirecast CPU usage above 80%. See the
Telestream Website for suggested configurations.
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Keeping the Wirecast Window on Top
To keep the Wirecast window active as the topmost open window on your system,
select File > Always On Top.
See File Menu.

Customizing the Playlist Countdown Timer
The countdown timer in the Live Broadcast Area displays either the times for the current
shot, or the times for both the current shot and for the playlist containing the current
shot. To choose the mode of the playlist countdown timer, do the following:
1. With a playlist displayed in the Live Broadcast Area, click the gear icon in the Live
Broadcast Area.
Wirecast displays a drop-down menu
2. Choose one of the following:
– To display the times for only the current shot, choose the first item in the dropdown menu. The first item is the name of the current shot.
– To display the times for both the current shot and for the whole playlist, choose
the second item in the drop-down menu, New Playlist - Completion.
See Playlist Countdown Timer Display.

Selecting and Customizing Encoder Presets
To select one of the default encoder presets, or to customize encoder presets for your
outputs, do the following:
1. Select Window > Encoder Presets.
2. Select an encoder preset from the Encoder Preset drop-down menu, and click Close.
3. (Optional) Alternatively, check Video Encoding, Audio Encoding, or both. Choose the
video and audio settings desired. Click Save As, give the custom preset a name, and
click OK.
See The Encoder Presets Window.

External Display Outputs
You can use either the Secondary Display Monitor output or the Multiviewer output for
external output. Secondary Display lets you send a frame-accurate program feed out
via the software. You can feed this into a recorder or use it as a source for another
program, such as Zoom. There is 1/4-second of latency in the Secondary Display
output. This latency improves A/V sync and reduces dropped frames.
The Multiviewer output, on the other hand, lets you monitor up to 17 sources or
windows, including your Preview window, Live window, or any source you have in your
document. Because the Multiviewer output is meant for monitoring rather than frame-
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accurate recording, Multiviewer has no intrinsic latency. Multiviewer outputs usually
have less latency than Secondary Display outputs.
See Multi-Viewer Output and Secondary Display Live Output.

Adding VST Plugins to the Available Audio Plugins
To add VST plugins to the plugins available to the Wirecast audio mixer, do the
following:
1. Select Window > Audio Plugin Explorer.
See Window Menu.
Wirecast opens the Audio Plugin Explorer dialog box, listing the Telestream plugins
installed by default.
2. Click the “+” button.
Wirecast opens a file browser.
3. Browse to a folder of VST plugins, select a VST file, and click Open.
Wirecast adds the VST plugin to the list of audio plugins.
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Document Creation and
Input Configuration
Wirecast enables you to work with media created outside of Wirecast, as well as with
live camera and live microphone sources. Wirecast supports media in a variety of
platforms such as AVFoundation, a variety of file types such as MOV and AVI, and a
variety of codecs such as AVC or H.264. This section introduces some common media
types you can use with Wirecast. You can add media by selecting Import Media from the
File menu.

Topics
■Creating a Document 39
■Configuring the Wirecast Layout 39
■Application Shortcuts and Document Hotkeys 39
■Shots 40
■Playlist Shots 45
■Replay Shots 47
■Social Media Shots 48
■Adding NDI™ Sources 52
■PTZ Cameras and Controls 53
■Rendezvous 55
■Resizing a Layer 61
■Setting Transition Speed 61
■Specifying the Transitions for the Transition Buttons 61
■Importing Stinger Transitions 61
■Deleting Stinger Transitions 62
■Executing a Stinger Transition 62
■Images/Opacity 62
■The Preview Area 63
■Adding and Modifying Template Placeholders 64
■Reassigning Media 67
■Supported Codecs 67

Wirecast User Guide

38

39

Document Creation and Input Configuration
Creating a Document

Creating a Document
In Wirecast, you keep all the resources for a particular broadcast in a Wirecast
document. You can save the audio, video, file, and controller sources, as well as the
output settings, for a broadcast in a document file. Wirecast Document files have the
file extension, “wcst.”
Once you’ve created a document, you add shots to the document. Then, you add
sources to the shots. The document then contains the shots and sources for a particular
broadcast.
To create a new document, do the following:
1. Select File > New.
Wirecast opens a new document.
2. To save the document, select File > Save.
3. Enter a file name for the document, and click Save.
Note: Consider establishing a file-naming method for naming documents. For
example, you could name documents for specific broadcasts, or for specific types of
broadcasts.

Configuring the Wirecast Layout
To optimize the user interface for each document, you can configure the Wirecast
layout. Wirecast saves the layout settings in the document file.
See The Default Layout.
To configure the Wirecast layout, do the following:
1. Select Layout.
See Layout Menu.
2. Choose a desired option from the menu.
Wirecast configures the layout accordingly, and closes the Layout menu.
3. To select whether Wirecast displays the Preview Area, the Live Program Area, or both,
choose the appropriate Mode Selection button.
See Layers.

Application Shortcuts and Document Hotkeys
You can use keyboard commands to execute most of the menu commands in Wirecast.
These keyboard shortcuts are called application shortcuts. You can also execute many
Wirecast document commands with keyboard shortcuts you create. These are called
document hotkeys.
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Note: You can view complete lists of application shortcuts and document hotkeys on
the Shortcuts tab of the Preferences dialog.

Finding an Application Shortcut
You can find existing application shortcuts through the Shortcuts tab on the Settings
dialog.
To find an application shortcut, do the following:
1. Select File > Preferences > Shortcuts.
2. Select the desired keyboard shortcut set from the Keyboard Shortcut Set drop-down
menu.
3. Click the Application Shortcuts tab.
4. (Optional) To filter the shortcuts Wirecast lists, click the All, Customized, or Conflicted
subtab.
5. To expand a menu item in the list, click the “+” next to the name of the menu item.
6. Do one of the following:
– Scroll down to the desired menu item to find its assigned application shortcut.
– Enter the name of the menu item into the Search field.
Wirecast filters the list of menu items, displaying only those containing your search
term.
See also Shortcuts Preferences.

Finding a Document Hotkey
You can find existing hotkeys for controlling documents through the Shortcuts tab on
the Settings dialog.
To find a document hotkey, do the following:
1. Select File > Preferences > Shortcuts.
2. Select the desired keyboard shortcut set from the Keyboard Shortcut Set drop-down
menu.
3. Click the Document Hotkeys tab.
4. Scroll down to the desired hotkey.
See also Shortcuts Preferences.

Shots
You can create and edit shots for your broadcasts before you begin broadcasting.
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Creating a Shot
1. To create a shot, click the “+” in any of the layers.
See Layers in The Default Layout.
Wirecast opens the Add Shot dialog box.
2. Select options for the shot as desired.
See Add Shot Window.

Adding Media Files from a Local Drive to a Shot
1. To add media files from a local drive to a shot, click the “+” in any of the layers.
See Layers in The Default Layout.
Wirecast opens the Add Shot dialog box.
2. Click Media Files.
3. To select a media file from a local drive, double-click Browse Disk.... Select a file and
click Open.
4. Click Add.
See Add Shot Window.

Adding Media Files from the Stock Media Library to a Shot
1. To add media files from the Stock Media Library to a shot, click the “+” in any of the
layers.
See Layers in The Default Layout.
Wirecast opens the Add Shot dialog box.
2. Click Media Files.
3. Double-click Stock Media Library.
4. The first time you open a Stock Media Library file, Wirecast displays Terms and
Conditions. Read the Terms and Conditions, check the I Agree checkbox, and click
Proceed.
Wirecast opens the Stock Media Library.
See the screenshot of the Stock Media Library in Stock Media Library.
5. Use Source Type and Left/Right buttons to navigate to a media file, then click
Download to include it as a shot.
6. Click Add.
See Add Shot Window.
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Adding Video Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.
See Layers in The Default Layout.
Wirecast opens the Add Shot dialog box.
2. Click Video Capture. Select video sources for the shot as desired.
3. Click Add.
See Add Shot Window.

Adding Audio Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.
See Layers in The Default Layout.
Wirecast opens the Add Shot dialog box.
2. Click Audio Capture. Select audio sources for the shot as desired.
3. Click Add.
See Add Shot Window.

Creating a Consolidated Shot
1. Select multiple sources in the Shot Layers tab of the Shot Editor.
See The Shot Editor Window.
2. Select Edit > Copy.
3. Select Edit > Paste as new Consolidated Shot to create a new shot in the selected
layer.
See Edit Menu.

Adding a Title to a Shot
To add a title to a shot, do the following:
1. In a layer, click the Add Shot “+” button.
See Layers in The Default Layout.
2. Select Overlays > Title.
3. To add the title to your document, click the Add button.
See Title.

Adding a Virtual Set to a Shot
To add a virtual set to a shot, do the following:
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1. In a layer, click the Add Shot “+” button.
See Layers in The Default Layout.
2. Select Templates > Shot Template.
3. In the Shot Template dialog box, navigate to one of the built-in virtual sets, and
select it.
4. Customize the set as desired.
See Virtual Set Properties.

Opening a Shot for Editing
To open a shot in the Shot Editor window, do one of the following:

• In a layer, double-click the shot desired
• Single-click the shot to select it. Then click the double-arrow on the left of the
default layout to open the Shot Editor window.

See The Default Layout and The Shot Editor Window.

Adding, Deleting, or Rearranging Layers in a Shot
You can add, delete, or rearrange layers in a shot with the controls on the Shot Layers
tab of the Shot Editor.
See Shot Layers Tab.
To add, delete, or rearrange layers in a shot, do the following:
1. Select a shot in a layer. Then select Edit > Edit Shot.
2. Edit the shot in one or more of the following ways, as desired:

• Add a layer by clicking the plus (+) button
• Delete a layer by select selecting it and clicking the minus (-) button.
• Reorder the layers by selecting a source and clicking the up arrow or down arrow to
move it.

• To move a layer forward or back, replace a source in a layer with another source,

add a layer to a shot, remove a layer from a shot, or display the original location of a
media file, click the gear icon.

• Toggle, on or off, the visibility of a video source by clicking the eye icon.
• Toggle, on or off, the visibility of an audio source by clicking the speaker icon.
See Shot Layers Tab.

Resizing or Rotating a Shot
To resize or rotate a shot, do the following:
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1. Click a shot in a layer. Then, click the shot in the Preview Area.
Wirecast places a control frame around the shot in the Preview Area. The control
frame includes handles for resizing and rotation.
2. Click and drag any of these handles to resize or rotate your image.
See Preview Area.

Positioning an Image Within a Shot
You can also snap an image in the Preview Area to various alignments: Snap to Center,
Snap to Edge, Snap to Corner, or Snap to an Image. The yellow guide lines appear when
the image is ready to snap into place.
See Preview Area.

Moving a Shot to Another Layer
You can move a selected shot to another layer by selecting Move to Layer from the Edit
menu, then selecting the target layer from the drop-down menu. You can also click and
drag the shot icon to a different layer.
When shots are created, they are assigned to a specific layer. They exist on that layer
until they are moved or deleted. (See Layers.)
To temporarily disable the snap action, hold down the Alt key while moving an image
into place (the yellow snap lines will not appear). Additionally, after selecting an image,
the arrows keys can be used to nudge it into placement.
Figure 2. Snap Actions

Snap to Center

Snap to Edge
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Playlist Shots
You can create and broadcast shots containing multiple preselected clips. First, create
and edit the playlist shots.

Creating a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source
from the list.
To create a new Playlist, click the “+” in one of the layers, and select Shots.
Select New Playlist Shot. Then click Add.
The playlist shot displays a playlist badge and the playlist duration.
Figure 3. Playlist Shot
Playlist badge
Playlist duration

Adding Clips to a Playlist Shot
To add clips to an existing playlist, do one of the following:

• Click and drag the desired clip from any layer onto the playlist shot.
• Click and drag the desired shot onto the playlist shot (you must click the bottom
part of the shot icon to drag it).

Adding Clips to a Playlist from the Shots Menu
To add clips to an existing playlist shot from the Shots menu, do the following:
1. In a layer, double-click the desired playlist shot.
Wirecast opens the Playlist tab.
2. Select Shots > New Shot, and select the clips desired.
Wirecast adds the selected clips to the playlist.

Editing Playlist Shots
To edit a shot in a playlist, do one of the following:
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• Double-click the shot in the playlist.
• Right-click the shot and select an item from the Shot Menu.
See The Shot Menu.
Note: Do not delete shots from a playlist while the playlist is running.

Setting Playlist Shot Attributes
You can determine how Wirecast plays playlists. To select playlist options, do the
following:
1. In the Main Shot List tab in the Layers window, select a playlist shot, and click the
button for the Source Properties tab.
See the Source Properties tab on The Shot Editor Window.
Wirecast opens the Playlist Properties tab.
2. In the Playlist Properties tab, set the options for the playlist as desired.
See Playlist Properties Tab.

Changing the Duration of a Playlist Shot
The Change Shot menu for playlist shots has a Modify Duration option. By default, live
sources have an infinite duration (since they are not clips). For clips, you must assign a
duration time.
To set or change the duration of a playlist shot, do the following:
1. Right-click the shot and select Modify Duration from the Shot Menu.
See The Shot Menu.
Wirecast displays the Shot Duration window.
2. Enter a new duration time value.
3. (Optional) Check Apply to All if you want this duration applied to all items in the
playlist.
4. (Optional) Reset the duration to its original value by clicking Reset.
5. Click OK when finished.

Adding a Live Source to a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source
from the list.
Note: Wirecast does not support nested playlists: playlists within playlists).

Wirecast User Guide

46

47

Document Creation and Input Configuration
Replay Shots

Replay Shots
You can create replay shots that you can broadcast at any time.
See Configuring Replay + ISO.

Creating a Replay Shot from a Selected Clip
To create a Replay shot, do the following:
1. Make sure you have activated Replay.
See Activating Replay.
2. To play a clip, select the clip and click the Go button.
3. Select Replay + ISO > Program Replay > Start.
Wirecast displays the Replay controls.
4. Click the Create Replay Shot button.
Since the default replay duration is set at 30 seconds, Wirecast creates a Replay shot
that starts 30 seconds before you clicked Create Replay Shot. Wirecast places the
new Replay Shot in Layer 1 and displays the Replay controls next to the transition
controls and Go button.
See The Default Layout.

Creating a Replay Shot from a Layer
To create a replay shot from a layer, do the following:
1. In a layer, click the plus icon (+). In the Add Shot dialog box, select Shots > Replay
Shot. Click Add.
2. In the Shot Layers tab of the Shot Editor, add additional graphics, titles or other
sources to the shot as needed.
3. Select Replay+ISO > Configure, then select Replay Settings. Select the Replay
template from the Replay Shot Template drop-down menu, check Program Replay,
and click OK.
4. Enable the Replay system by selecting Replay+ ISO > Start All.
Wirecast displays the Replay controls.
5. Click the Create/Update Replay Shot button to create a Replay shot using the
template.
See the Create/Update Replay Shot button on the screenshot in Replay Controls.
See Add Shot Window, The Shot Editor Window, Shot Layers Tab, and Replay Layer.

Trimming a Replay Shot
To trim a Replay shot from its start, do the following:
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1. Select a Replay shot in a layer.
The Replay shot appears in the Preview Area.
2. Trim the shot by moving the In Point indicator and Out Point indicator to the
desired start and end frames.
See In Point and Out Point in Media Files.
3. Play the Replay shot to the frame you want to end the shot.
4. Click the Create Replay Shot button.
Your Replay Shot now contains only the content you wanted.

Looping, Holding, or Removing a Clip After Playback
You can determine what Wirecast does when it is finished playing a live clip. To set what
Wirecast does when finished, do the following:
1. Select a shot in the Shot Layers pane.
2. Click the three-dot button to open the Source Properties tab.
See the Source Properties tab on the screenshot of The Shot Editor Window.
3. Select the desired options for the clip on the Source Properties tab.
See Source Properties Tab.

Social Media Shots
Wirecast lets you incorporate social-media feeds into your broadcasts. With the Social
Comments feature, you can display Tweets from Twitter, and posts from Facebook or
YouTube Live in overlays. Also, you can conduct and display Facebook polls.
The Social Comments feature lets you bring your audience's comments into your
broadcast. You can bring in comments from Twitter (whether you're broadcasting to
Twitter or not), as well as from Facebook Live (Profile, Page, Group) and YouTube Live
broadcasts.
Setting up comment display is a two-step process:
1. Authenticate with the platforms from which you want to pull comments.
2. You can pull comments from Facebook and YouTube only if you are also streaming
live to those platforms.
3. Choose a social media title where Wirecast displays the comments.
Once you start streaming, you can moderate your incoming comments manually or set
them to automatically rotate into your broadcast.
See The Comment Moderation Window, Social Media Title, and Moderating Social Media
Comments.
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Configuring Twitter Comments
To display posts from a Twitter feed in your broadcast. first, configure Wirecast for
Twitter.
To configure your account with Twitter, do the following:
1. Select Social > Twitter > Settings. Then click the Authenticate button.
Alternatively, open the Comment Moderation window (Social > Comments), click the
Twitter logo and authorize your account on Twitter.
2. Enter the user name and password for your Twitter account.
Wirecast displays a PIN.
3. Copy the PIN and enter it into the PIN field.
4. Press Enter or Authorize app.
5. Select a feed type.
If you select Search, the Search String field becomes active., and Wirecast displays
Twitter feeds that contain a search string.
See Moderating Social Media Comments and Moderating Facebook or YouTube Comments
for a Streaming Computer or RTMP Server.

Configuring Facebook Live or YouTube Live Comments
To display posts from a Facebook Live or YouTube Live feed in your broadcast, first
configure Wirecast for Facebook Live or YouTube Live.
To configure Facebook Live or YouTube Live social comments, do one of the following:

• (Facebook only) Set your Facebook stream to “public” so that Wirecast can display
Facebook comments in the Comment Moderation window.

• Click Output > Output Settings, and set up a streaming destination.
See Adding a Destination and The Output Settings Window.

• Click Social > Comments, and click either the Facebook or the YouTube logo.
Wirecast opens the Output Settings window, where you set up your streaming destination.
See also Configuring Wirecast to Show Facebook User Name and Photo, Moderating Social
Media Comments, and Moderating Facebook or YouTube Comments for a Streaming
Computer or RTMP Server.

Configuring Wirecast to Show Facebook User Name and
Photo
By default, Wirecast displays a generic Facebook User graphic to identify the source of a
Facebook Live comment. To enable Wirecast to display the actual Facebook user name
and photo, ask the Facebook user to grant permission to Wirecast. Do the following:
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1. Make sure Wirecast is configured to show Facebook Comments.
See Configuring Facebook Live or YouTube Live Comments.
2. Let your viewers know you want to include their names and photos for their
comments. Request their permission to let Wirecast access their name and picture.
Tell them they may grant permission through this website:
https://www.telestream.net/facebook/permission.htm
3. Tell your users that, to grant permission, they should click the button, Let Wirecast
display your Facebook Live comments.

Choosing a Social Media Title for Displaying Comments
To choose a title for displaying social media comments, do the following:
1. Click the “+” in one of the layers to create a new shot.
2. Click Overlays > Social Media Title.
Alternatively, from the Comment Moderation window, click the Create Title Shot button in the lower left.
3. Specify what each of the types of title displays.
4. Add your title shot to one of the layers in your document.
See Adding a Title to a Shot.
Note: You can adjust the settings for each social media title in the Title Properties
panel.
Wirecast displays comments from Facebook and YouTube in the Comment Moderation
window once you start your live stream.
Wirecast starts displaying comments or Tweets from Twitter immediately after you
authorize Twitter.
See The Comment Moderation Window.

Creating a Facebook Poll
You can create and display Facebook polls in your broadcast. First, configure Wirecast
for Facebook.
Note: Wirecast displays Facebook polls in the Facebook user interface only when a
Facebook video is playing, and is fully open.
Note: Wirecast can use only Facebook Polls created within the Wirecast application
itself. You can’t import Facebook polls created within the Facebook Live user interface.
To create a Facebook poll, do the following:
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1. Select Social > Facebook > Create New Poll.
Wirecast opens a dialog box for specifying the poll options.
2. Enter a question.
3. Select whether there are two, three, or four answers, and enter each answer. Be sure
to enter an answer for every option selected.
4. Check the boxes for any of the implementation options desired.
5. Click OK.
Once you’ve created the poll, Wirecast lists the poll in the Social > Facebook menu.
See Facebook.

Selecting a Facebook Poll
To select an existing Facebook poll, do the following:
1. Select Social > Facebook.
2. Select a previously-created poll from the drop-down menu.
Note: Wirecast saves Facebook polls, like Wirecast preferences, with the Wirecast
application, not with a specific document.
See Facebook.

Editing or Deleting a Facebook Poll
To edit or delete an existing Facebook poll, do the following:
1. Select Social > Facebook.
2. Select a previously-created poll from the drop-down menu.
3. Do one of the following:

• To edit the poll, select Edit.
• To delete the poll, select Delete.
Note: Facebook does not allow you to edit a poll that is being shown, so this option is
not enabled while streaming to Facebook and using a poll.
See Facebook.

Showing or Hiding a Poll or Results when Streaming to
Facebook
The options to Show Poll, Show Results, and Hide are available when streaming to
Facebook. Once the poll has been activated, you may show a poll or show its results at
any time while streaming to Facebook. When you start streaming, the Show Poll option
is enabled, but by default, it is not selected.
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There is a lag of 5 to 15 seconds between selecting a poll and having it shown in your
stream. When a poll is actually shown in your stream, a check mark is added to its menu
item and Wirecast enables the Show Results and Hide options.
To show or hide a Facebook poll or Facebook poll results, do one of the following:

• To show a Facebook poll, select Social > Facebook > Show Poll.
• To show the results for the Facebook poll, select Social > Facebook > Show Results.
Note: Showing a Facebook poll closes the poll to further responses.
Note: On Facebook, polls are not automatically shown. The viewer must click on the
video to see or vote on a poll.
To hide the Facebook poll and results, select Social > Facebook > Hide.
Note: You may hide a poll only if it is the active poll. Showing a different poll, or
showing the results for a different poll, hides any other polls being shown. This allows
you to show a poll, or show the results of the poll, and then hide it.

Adding NDI™ Sources
Wirecast lists any NewTek NDI source on your local network under the Network option
in the Add Source Menu. To add an NDI source to a shot, do the following:
1. In a layer, click the “+” icon.
Wirecast opens the Add Shot dialog box.
2. Select Network.
3. Select the NDI source from the list of sources in the right-side pane, and click Add.
Wirecast creates a shot for the NDI source selected.
Note: You can also check GPU Decoding for NDI sources. When checked, incoming
sources will use your GPU to process the incoming source (potentially saving you
some CPU processing power).
Select video source, audio source and audio output. You can also make a copy of the
URL to send to participants by clicking Copy.
See NDI Devices in the Shot Layer Properties Tab.
See also How to setup a NDI Discovery Server to resolve NDI connectivity issues in
Wirecast.
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PTZ Cameras and Controls
You can control cameras that allow remote control of pan, tilt, and zoom (PTZ)
functions. First, configure Wirecast to support your PTZ cameras.

Setting Up PTZOptics Camera with a Dynamic IP Address
PTZOptics cameras ship with a Static IP address set to 192.168.100.88. To communicate
with your cameras on your network, you will need to change this to be in range of your
existing network.
To set up your PTZOptics camera IP address, follow these steps:
1. To obtain a usable IP address for your camera, ensure you can access the video feed
of your camera over HDMI or SDI (not IP). Since the IP address will be changing, you
need to use HDMI or SDI to access the video feed. Connect the HDMI port of the
camera to a TV, or if you are already using a capture card with Wirecast simply add
the source to your document and queue it up in Preview.
2. To set your Camera to DHCP (Automatic) and make it addressable by your PC, enter
“# * 4” (sequentially) using the camera remote control. (Do not press the buttons
simultaneously.) The camera will display a message in the video feed that says
“DHCP OPEN”, and then the camera will automatically reboot.
Note: If your camera did not display DHCP OPEN and restart automatically, you may
need to contact PTZOptics for assistance unless you are proficient in manual IP
assignment procedures not covered below.
3. When the video feed displays, enter “# * 4” (sequentially) using the remote control
to view the new DHCP address. The camera will now always request a new IP
address, whenever it is plugged into a new network.
Note: This means the IP address can change, which is generally not desirable in a live
environment.

Setting Up PTZOptics Camera with a Static IP Address
If you prefer to set a static IP address for a permanent installation, follow these steps:
1. Open a web browser, and enter the IP address obtained in the previous steps. You
can view that IP address by entering “# * 4” (sequentially) using the remote control
2. Enter admin for both the username and password.
3. Select Network in the navigation options, located at the top-left part of the web
page.
4. Find the DHCP/STATIC setting.
5. Set IP Configuration Type to Fixed IP Address.
6. When the confirmation dialog window displays, click Apply, then click OK.
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7. Recycle to power on the camera to reboot it.
Note: If you are have trouble setting the IP address on your camera, contact
PTZOptics for assistance.

Configuring The PTZ Controller
1. Get the IP address of your camera.
See Setting Up PTZOptics Camera with a Dynamic IP Address and Setting Up PTZOptics
Camera with a Static IP Address
2. To display the PTZ Controller panel, select Window > PTZ Controller.
3. Select the video ingestion method from the Camera menu. This will be an HDMI or
SDI capture device, or NDI if your device supports it.
4. Enter the IP address for your camera.
5. Port and VISCA Address are set automatically to the default values for PTZOptics
camera. You do not need to change these.
6. Click the Connection button to the far right of Status. Wirecast displays connected
when a connection is made.

Setting Up a PTZ Camera Shot
To setup a Wirecast shot using a camera setup, follow these steps:
1. To display the PTZ Controller panel, select Window > PTZ Controller.
2. Select D-Pad from the Pan/Tilt menu and move the camera to a desired position.
(Pan the camera by clicking the left and right arrows, and tilt the camera by clicking
the up and down arrows.)
3. Enter a preset number (0 to 255) and click the Save button to save this camera
position.
4. To create a camera shot, click a “+” in one of the Wirecast layers.
Wirecast opens the Add Shot dialog box.
5. Select Video Capture, select your camera from the device pane, and click the Add
button.
Wirecast places your PTZ camera shot in the layer.
6. To open the Shot Editor, double-click your camera shot from its layer. Click the Shot
Layer Properties tab.
7. Click the PTZ triangle to display the PTZ controls. Check the Preset check box, enter
a preset number and click the Go arrow.
You are now able to move your camera by changing shots.
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Opening the PTZ Controller Panel
To open the PTZ Controller panel, select Window > PTZ Controller.
See The PTZ Controller Panel.

Enabling Preset Recall for a PTZ Camera
Once you have configured a shot layer with a PTZ Preset, sending that shot to preview
recalls the preset for the camera. If multiple shots share the same video source with
different PTZ Presets configured, the shot which is currently live takes precedence over
subsequent PTZ Preset recall actions, until you drop the shot from the live feed.
To enable preset recall, do the following:
1. In the Shot Editor, select the Shot Layer Properties tab. Click the PTZ triangle towards
the bottom of Shot Layer Properties.
2. Check the Enable box. To select a preset, enter a preset number or click the up/
down arrow buttons. Click the Go button (right pointing arrow) to cause the
associated PTZ camera to go live with the recalled preset.
When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel.
See Shot Layers Properties Tab and The PTZ Controller Panel.

Rendezvous
Creating a Rendezvous Session
Rendezvous provides an easy way to organize a video conference with up to two
guests in Wirecast Studio, and up to seven guests in Wirecast Pro. You can bring in live
video feeds from a computer or smart device running a supported web browser, or
from iOS devices running the Wirecast Go app.
To create a Rendezvous session, do the following:
1. In a layer, click the Add Shot (+) icon. Then, select Network > Create Rendezvous
Session > Add.
In the Creating Session window, optionally select Enable chat for session, Share chat
history, or both. Then click Create Session.
2. In the Created Session window click the Click to Copy button to copy the
Rendezvous URL to the clipboard. Send this URL to the participants that you want
to invite to the broadcast.
3. Click OK when finished.
Wirecast opens the Wirecast Rendezvous Dashboard.
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Note: You can also select the Live Broadcast Area as your Rendezvous display (instead
of your local camera). To do this, click the camera icon and select Live Output. You can
add live output audio by clicking the mic icon.
Note: From the Rendezvous Dashboard in Wirecast, you can mute audio or hide the
camera of your local sources (or of those who have joined). To do this click the camera
or mic icon of the source to mute. You can also disconnect at any time by clicking the
Disconnect button.
You can also select your local camera and mic as an integrated Webcam shot on
another layer and add it to the Preview Area by selecting it.
See also Rendezvous Essentials.

Joining a Rendezvous Session
To join a Rendezvous session on a remote computer (or smart device), do the following:
1. To initiate a connection with Wirecast, paste the obtained URL into a browser and
press Enter.
Wirecast opens the Rendezvous window.
Note: The only browsers supported by Wirecast for joining a Rendezvous session are
Chrome, Safari, and Firefox.
2. Click the Settings (gear) icon.
Wirecast opens the Camera-Microphone-Options dialog.
3. Select a video source.
If you select Share Screen, Wirecast opens the Choose what to share dialog.
4. Select the screen you want to share and click Share.
5. In the Camera-Microphone-Options dialog, select a microphone.
6. (Optional) To flip the video horizontally, in the Camera-Microphone-Options dialog,
check Flip Video Horizontally.
7. (Optional) Mute the camera or mic by clicking the camera icon, the microphone
icon, or both.
8. Enter an identification in the Your name field and click Join.
Note: Wirecast Go, running on iOS devices, can join a Rendezvous session by opening
the URL. Android devices can join a session by opening a Session URL (sent to them) in
the Chrome browser.
The Rendezvous window displays a Waiting to join message until the Wirecast host has
added you as a participant.
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Improving Rendezvous Audio with Music Mode
Only Rendezvous guests can turn on Music Mode. This greatly improves the audio
quality for musical instruments played over Rendezvous.
Rendezvous guests can turn on Music Mode in the Rendezvous web app. This does the
following:

• Changes the audio channel from the default monaural to stereo
• Increases the audio bit-rate from the default 32kbps to 256kbps, 128kbps for each
stereo track.

Note: Wirecast Music Mode improves audio quality only for Rendezvous guests
sending audio to Wirecast. To conserve bandwidth, Wirecast doesn’t send the higher
quality audio to other guests in a session.

• Disables audio processing (echo cancellation and noise reduction)
Note: Disabling audio processing for speech through normal microphones can result
in poor quality audio. Disable audio processing only for music.

Adding a Participant Shot to Rendezvous
When a participant is waiting to join the Rendezvous session, Wirecast displays a
participant icon in both the Wirecast default layout and in the Rendezvous Dashboard.
To add a participant to a Rendezvous session, do the following:
1. Click the icon and select a participant to add to the session.
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Figure 4. Participant Shot in Rendezvous

Local camera

Participant
camera

“P” icon (see
Note below)
Click on icon

Select participant

Note: If at any time Wirecast displays a “P” icon to the right of a user’s name, it
indicates that the connection is “proxied” through the Wirecast TURN infrastructure,
and traffic is flowing through Wirecast proxy servers. In most cases, Rendezvous traffic
does not flow through Wirecast proxy servers. Data flows through Wirecast servers
only if the user’s server cannot be connected directly. This happens, typically, in the
case of restrictive firewalls. Otherwise, the traffic flows peer-to-peer, and there is no
need to worry about Wirecast server capacity.
See also Wirecast Network Ports and Proxy Servers.
2. In a layer, click the Add Shot (+) icon.
3. In the Add Shot dialog, select Network.
4. Under Rendezvous Session, select the name of the participant to add.
Wirecast displays your new Rendezvous shot on the shot level from which it was
selected.
5. Select the shot to display it in the Preview Area where you can place it and size it as
needed.

Enabling Rendezvous Chat
There are times in a live interview where you need to communicate privately with your
guests. That is the purpose of the Rendezvous Chat feature in Wirecast.
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When you initiate a Rendezvous session, you will be asked to choose the chat settings
for that session.
The Enable chat for session option enables a chat dialog between you and your guests.
If you select Share chat history with new session participants, any new guests that arrive
at any time in the session will see the full chat history. If you don't select this option,
new guests will only see chat messages that occur after they have joined the session.
When you select Create session, your Rendezvous Session will be created, and you can
copy/send the link to your guests.
Click OK and your Rendezvous Dashboard will appear. There will be a panel on the right
side of your Dashboard that, when clicked, will slide-out to reveal the Rendezvous Live
Chat panel.
You can open and close that panel at any time by clicking on the “>>” icon to the left of
the Live Chat panel.
You will receive a notification if a guest types a message, even if you have the Live Chat
panel closed or the Rendezvous Dashboard is not in focus.
Host and guests can type into the message window to communicate. This chat panel
will not be seen on the live broadcast, so you can type private messages you might not
want to say over the live stream.
Each guest's name will appear above any messages they send. If you have several
guests, each guest will have a different color assigned to their chat bubble windows, for
easy identification.
You, as the host, can select Clear Chat in the top right corner of your Live Chat panel, at
any time, and all the messages will be cleared from your, and your guests', Live Chat
panel.
Your guests connecting through a browser, like Chrome, will also see a Live Chat panel
in their browser.
They can close their Live Chat panel by clicking on the X in the top of their panel.
If a message arrives for a guest when they have their Chat panel closed, they will get a
green dot on the chat icon, which they can press to re-open their chat panel.
If a guest disconnects and reconnects to the same session, they will still be able to see
the chat history (as long as you selected to enable chat history).
However, if you disconnect your session and force Guests to disconnect, then your chat
history will be deleted.
See also Wirecast: Rendezvous Chat Guide.

Ending a Rendezvous Session
When you are ready to close your session, click Stop Session.
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When you disconnect from a Rendezvous session, your camera is removed in the
participant’s browser and the participant’s camera is removed from your local session
window. To reconnect to the previous session click Reconnect to previous session. When
you do this, everything is restored as long as the remote browsers are still open. If a
remote browser has been closed, it can still reconnect by re-joining, using the same
URL that was used previously. You can also start a new session by clicking Start Session,
but you will have to copy and send a new URL to all potential participants.

Sharing Screen, Camera, or Both as Rendezvous Guest
Rendezvous guests can share their screens and cameras during a broadcast.
Note: Only one person can share screen and camera at any one time. However,
multiple people at the same time can share screens with their cameras disabled.
As a Rendezvous guest, to share your desktop, camera, or both, do the following:
1. Select Window > Rendezvous Dashboard.
Wirecast opens the Rendezvous Dashboard with a Share Screen button in the topright corner.
2. Click the Share Screen button.
Wirecast opens a drop-down menu.
3. Select one of the following options, as desired:
– Share screen & camera
If no-one else is sharing screen and camera, Wirecast asks which screen or window to share. Choose one.
– Share screen (disable camera)
Note: The camera-share and screen-share buttons indicate whether camera- or
screen-sharing are active.
If you (as guest) choose Share screen & camera, Wirecast displays only the Share
Screen button for the Wirecast host.
When you (as guest) select Share screen (disable camera), the Wirecast host sees
your shared guest screen.
When you (as guest) select Share screen & camera, the host sees two separate feeds
in the Rendezvous Dashboard: one for the camera and one for the shared screen.
The Wirecast host then can add one or both of these feeds, as separate shots, into
the broadcast. Alternatively, the host can display the guest camera and the guest
screen picture-in-picture.
Note: You (as guest) might need to enable security or privacy permissions in your
browser to allow screen sharing
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4. (Optional) To stop sharing, you (as guest) can either re-press the Share Screen
button at the top of the Rendezvous window, or press the Stop Sharing button
displayed as a notification at the bottom of the screen.
Note: If a second guest selects Share screen & camera while another guest already is
sharing both, Wirecast notifies the second guest that only one guest can share both
screen and camera at a time. Wirecast offers the second guest the Share screen (disable
camera) option.

Resizing a Layer
To change the height of any layer, and the size of the shot icons on the layer, do the
following:
1. Click the lower edge of the layer desired.
2. To increase the layer height, drag the lower edge downward. To increase the height,
drag it upward.
See the screenshot of the Layers window in the topic Layers.

Setting Transition Speed
The transition speed is set by selecting Switch > Transition Speed. There are five settings:
Slowest, Slow, Normal, Faster, and Fastest.

Specifying the Transitions for the Transition
Buttons
To assign a type of transition to a transition button, do the following:
1. Click the down-arrow on the right side of the transition button
2. From the drop-down menu, select a new transition to assign to that button.
See Final Mix Audio Panel, and Selecting and Customizing Encoder Presets.

Importing Stinger Transitions
Stinger transitions are custom transitions that employ transparent backgrounds. These
transitions are typically created using applications such as Adobe After Effects, Apple
Motion or Telestream ScreenFlow.
To import a stinger transition, do the following:
1. Select Switch > Manage Stinger Transitions.
Wirecast displays the Stinger Transition Manager.
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2. To import a transition file, click the plus (+) button, navigate to the desired file, and
select it.
Once the transition file is imported, you can preview the transition from shot A to
shot B by clicking the play button.
3. To set the location where the shot will change from A to B, slide the scrubber to a
location in the transition, then click the A/B button.
Note: Stinger transitions are stored in the preferences (including the path to the
media file). This allows the you to re-use transitions in other Wirecast documents.
When Wirecast cannot find a media file associated with a stinger transition (file
deleted or moved), Wirecast removes the transition from the transition bank list and
highlights the name in red in the Stinger Transition Manager.
See the screenshot of the Stinger Transition Manager in Manage Stinger Transitions.

Deleting Stinger Transitions
To delete a stinger transition, do the following:
1. Select Switch > Manage Stinger Transitions.
Wirecast displays the Stinger Transition Manager.
2. To delete a transition, select it and click the minus (-) button.
3. Click the help (?) button to display help instructions (this portion of the user guide).
4. (Optional) Check the Keep all video frames in memory check box. When checked,
CPU spiking (which can cause streaming problems) is prevented, but more memory
is used.
5. Click Close to exit the Stinger Transition Manager.
See the screenshot of the Stinger Transition Manager in Manage Stinger Transitions.

Executing a Stinger Transition
To execute a stinger transition, do the following:
1. To execute a stinger transition, open a transition menu and select a stinger
transition.
2. Click the Go button to execute the stinger transition.
See the screenshot of the Stinger Transition Manager in Manage Stinger Transitions.

Images/Opacity
Wirecast supports a wide variety of still images types (TIFF, GIF, JPEG, PNG, etc.). Some
of these formats offer some form of opacity (or transparency). This is often called an
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Alpha Channel. Wirecast works seamlessly with these formats making them the
preferred methods for using graphics and logos which have transparency.

GIF and Transparency
GIF files are a special case because they only offer transparency and not a true Alpha
Channel. The GIF format enables you to define part of the image as transparent
(completely invisible), but does not enable you to define it as partially transparent.
Some GIF images use transparency for much of the image. However, near the edges of
the visible data, transparency cannot be used. This happens quite often when there is a
shadow near the edges of the visible data. The author of the GIF often assumes a
certain background color (white, for example) and that color becomes embedded in
the actual image.
When Wirecast displays these types of images, the edges of the visible data shows the
background that was saved in the GIF. This is not a defect in Wirecast and, therefore,
Wirecast can only present the data as it exists in the GIF. The solution is to obtain the
original image and re-save the image as either TIFF or PNG. Both of these formats offer
full Opacity.

The Preview Area
You can preview media files in the Preview Area.
See Preview Area.

Viewing the Preview Area
To display the Preview Area, select Layout > Show Live and Preview, or Layout > Show
Preview Only.
See Preview Area.

Viewing a Shot in the Preview Area
To view a shot in the Preview Area, click a shot in a layer.
Wirecast displays the shot in the Preview Area.
See The Default Layout, Viewing the Preview Area, and Preview Area.

Magnifying the Preview Area
Another control available at the bottom of the Preview Area is the Magnification control.
Click the magnifier icon (spyglass) to display a magnification slider. Slide the slider to
the left for lower magnification of the In and Out controls, and to the right for greater
magnification.
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Figure 5. Magnifying Preview Area
Magnifier icon

In and Out point
controls

Magnifier slider

For example, if you move the slider to the right, the In and Out controls move farther
apart, increasing the magnification, so that you can more easily adjust the location of
the In and Out controls. This is very helpful when you have long-duration shots.
However, the slider will quit sliding when you have reached the maximum size of the
shot.

Setting the Speed of Preview
One more control is available at the bottom of the Preview Area. It is the speed control.
You can set the playback speed of the shot by clicking the speed icon (“1x”) and
selecting a speed from the pull-down menu. Your choices are 1x (normal speed), 2x
(double speed),.5x (half speed), and .25x (one-fourth speed). The audio is muted for any
speed other than normal.

Adding and Modifying Template Placeholders
There are nine default placeholders (labeled A through I). If you need more, you can
create your own. All existing placeholder letters will appear in the list of available
placeholders, and the current assignment of each placeholder will display next to the
letter.
1. Select New Placeholder and click Add to generate a new placeholder.
Wirecast displays the new placeholder shot in the shot editor, and displays its
Placeholder [#] in the list of placeholders.
Note: Wirecast saves new placeholders in the document. These placeholders don’t
appear in newly created documents. You can’t assign media to a placeholder with New
Placeholder > Add. You can add an existing placeholder to a shot, or add a new
placeholder.

Assigning Media to Placeholders
To assign media to a placeholder, do one of the following:

• Select Media > Assign Placeholder. Any placeholders that have been added to shots
will appear in the drop-down of the Assign Placeholder menu item. Clicking on one
of the available placeholders opens the Add Source dialog box, where you can
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assign a source to that placeholder. When you assign a source to a placeholder, that
source will be assigned to the placeholder in every shot in which that placeholder is
used.

• In the Shot Layers tab, click on the Gear menu of any placeholder and select Assign
Placeholder. This will bring up a drop-down menu where you can choose a source
to be assigned to your placeholder.

• Right-Click on a placeholder in the Preview Area.
• This will bring up a similar Assign Placeholder drop-down menu where you can
select a source to replace your placeholder.

Note: You can assign media that isn’t yet used in the document to a placeholder.
However, you can’t assign Rendezvous guests to a placeholder until they have joined
the broadcast.

Resetting Placeholders
Select Media > Reset Placeholder, then select a placeholder to remove any media
assignments.

Indicating Media is Assigned to a Placeholder
There are two places to see what source/media is assigned to any particular
Placeholder:
1. In the Add Source Dialog box you can see a list of available Placeholders and see
what they're currently assigned to.
2. Select Media > Assign Placeholder. Then select a current placeholders and its
assignment.

Adding placeholders to shots or templates
You can add a Placeholder to any shot in the same way you can currently add a source.
Click the Add Source menu, select Templates and choose a Placeholder.

Creating customized Shot Templates
You can configure any shot with a Placeholder and save it as a Template Shot. Click the
Shot Gear menu then select Save as a Template.
When the dialog box displays, enter a template name and click OK.
Once saved as a Template shot, it will appear in the Add Source > Template Dialog box,
as a Custom Template.
Custom Templates are saved in Global Preferences so that you can access your Custom
Template across different documents.

Wirecast User Guide

Document Creation and Input Configuration
Adding and Modifying Template Placeholders

Note: Any Placeholders that are in your Custom Template will revert to an unassigned
Placeholder, (even if that Placeholder was assigned to a Source when you saved the
Custom Template)

Deleting Custom Templates
To delete a Custom Template select Add Source > Templates > Shot Template to open the
Custom Templates window. Select the template to delete, then click Delete Template.
This will delete it from your Global Preferences, so that Custom Template will no longer
appear in the Shot Templates window. However, shots in any documents using this
Shot Template will not be deleted, they will simply no longer be a Template shot.

Shots
New Shot
Creates a new shot. Select and click the Add button.
New Playlist Shot
Creates a new Playlist shot. Select and click the Add button.
New Shots From Clipboard
Creates a new shot that has been copied to the clipboard. This is how you duplicate a
shot. Select and click the Add button.
Favorites
Displays a list of shots that have been marked as a Favorite by clicking on the star on
the right side of each shot in the Add Shot Menu.
All
Displays all sources in one list.
Add Media File
Creates a Media File shot (video clip or picture). When selected, a navigation widow
displays. Navigate to a media file location, select a media file, and click Open.
See Templates.

Deleting a Placeholder
To delete a placeholder from a shot, do the following:
1. In a layer, click a shot that contains a placeholder.
Wirecast opens the shot in the Shot Layers tab.
2. Select the placeholder in the Shot Layers tab.
3. Click the delete button (-).
Wirecast asks you to confirm, and then deletes the placeholder from the shot.

Wirecast User Guide

66

67

Document Creation and Input Configuration
Reassigning Media

Reassigning Media
The Asset Manager is used to change the sources of media in your document. It is
accessed by selecting Media > Show Asset Manager.
Wirecast stores a path to your media in the Wirecast document. If you relocate your
media, Wirecast no longer is able to find them. In this case, use the Asset Manager to
reassign the new media locations. However, Wirecast does keep track of the relative
path to your media. If you move both the document and media to a new position,
Wirecast still finds the media.
To reassign media, follow these steps:
1. To open the Asset Manager, select Show Asset Manager from the Wirecast Media
menu.
2. Select the media you want to assign to another source.
3. Some media assets (i.e. cameras) enable you to set the aspect ratio by displaying a
Device Aspect Ratio menu. You can select an aspect ratio from this menu.
4. Select the desired media file from the Assign To menu; or click Browse and locate the
desired media file, and then select the desired media file.
Note: When Remote Desktop Presenter is selected as the source, you can enter the IP
address for the RDP. This enables you to build a Wirecast presentation with placeholders and then reconfigure at a later date to accommodate a new presenter with a
new Remote Desktop Presenter as a source. Click Apply, then click the corresponding
icon in the Shot Selection.
5. Click Apply to replace the existing media, then close the Reassign Media window.
Note: You can also select an item from the list and click Delete to remove it. Or, you
can click Delete All to clear the list.

Supported Codecs
Shown below is a list of supported video and audio codecs.
Table 1. Supported Codecs
Video Codec
AVC
H264
DVC25
DVCPRO50
DVCPRO100

MOV
(M4V)
YES
YES
YES
YES
YES

MP3 MPEG-4 WAV AIFF
ISO (MP4)
(AIFF, AIF)
NO YES
NO NO
NO YES
NO NO
NO NO
NO NO
NO NO
NO NO
NO NO
NO NO

ASF
(WMV)
NO
NO
NO
NO
NO

WEBM

NO
NO
NO
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MJPEG
ProRes

YES
NO
YES
NO
(mac only)
YES
NO

NO
NO

NO
NO

NO
NO

NO
NO

NO
NO

QuickTime
Animation
VP8
NO
VP9
NO
Windows Media NO
Video

NO

NO

NO

NO

NO

NO
NO
NO

NO
NO
NO

NO
NO
NO

NO
NO
NO

NO
NO
YES
(windows)

YES
YES
NO

Audio Codecs
AAC
MP3
Opus
PCM
Vorbis
Windows Media
Audio

NO
YES
NO
NO
NO
NO

YES
NO
NO
NO
NO
NO

NO
NO
NO
YES
NO
NO

NO
NO
NO
YES
NO
NO

NO
NO
NO
NO
NO
YES
(windows)

NO
NO
YES
NO
YES
NO
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Output Configuration
Before you can broadcast with Wirecast, you must configure your output settings.
Wirecast enables you to specify many output settings for your presentation. You can
configure Wirecast to broadcast multiple data rates simultaneously, broadcast with
different encoders at the same time, or use Windows Media Encoder to record your
broadcast to disk.

Topics
■Destinations 70
■Encoder Presets 84
■Mapping Audio Tracks to Output Audio Channels 89
■Streaming 89
■Configuring Replay + ISO 92
■Recording To Disk 97

Destinations
To broadcast with Wirecast, you define at least one destination. A destination can be a
broadcast server, content distribution network, or local disk recording.
See The Output Settings Window.

Destination Settings
Wirecast offers several default presets. The first choice you need to make is whether
you'll be using RTMP Server, SRT (Secure Reliable Transport), Windows Media, or some
combination as the broadcast technology. This decision depends on what you expect
your viewers to use. Given enough bandwidth, you can stream to combinations of
RTMP Server, and Windows Media by adding new destinations to the output settings.
Note: To use Push To Server, you must have a good local Internet connection and
access to a Windows Media Server. Pushing your broadcast to a Windows Media Server
moves the bandwidth strain from your local machine to the external server.
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Multicast and Unicast Destination Settings
You can select Multicast or Unicast from the Destination drop-down menu. Multicast
lets you broadcast to multiple computers simultaneously. Unicast lets you broadcast to
a specific computer.
You need to create an SDP File, and you must do so every time you change any option
on this page (including the encoder preset). To create an SDP file click the gear icon to
the right of the Destination field. Select Save SDP File, navigate to the desired location,
and click Save in the Save File dialog window. The SDP file must be given to the user to
place on the computer that receives your broadcast.
During multicast, your broadcasting computer sends data across your local network,
identifying it as a broadcast that it has no specific destination. Since many applications
could be doing the same thing, the broadcasting computer must have a unique way of
defining the data that is being multicast. This enables clients to choose between the
available multicast streams.
The multicast protocol uses unique addresses, one for video and one for audio.
Although these unique addresses look like TCP/IP addresses, they are not. Instead, they
provide a way to define uniqueness among all multicast data flowing over the network.
Once the broadcasting computer is streaming this data through the local network, any
computer on the network can receive it.
The SDP file becomes the glue between your broadcast computer and the viewer
computers. The SDP file contains multicast addresses, encoding format, and other
important information.

Selecting a Destination
To select a destination for a broadcast, do the following:
1. Select Output > Output Settings. Select a destination from the Destination dropdown menu.
Wirecast displays the Output Settings dialog with presets for the destination you
selected. Each Output Settings dialog has a unique set of controls and a way to
authenticate your connection.
2. (Optional) To view more destinations in the Destination drop-down menu, click
More in the Select an Output Destination dialog. Check the box for each destination
you want to include in the destination menu list. Uncheck the box for any
destination you want removed from the list of destinations for the broadcast.
3. Click OK.
See The Output Settings Window.

Adding a Destination
To add a destination for a broadcast, do the following:
1. Select Output > Output Settings.
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2. In the left-side pane, click Add.
Wirecast displays the Select an Output Destination dialog.
3. Choose a destination from the Destination drop-down menu.
4. (Optional) To view more destinations in the Destination drop-down menu, click
More in the Select an Output Destination dialog. Check the box for each destination
you want to include in the destination menu list.
5. Click OK.
Note: You can add as many destinations as you need, but keep in mind that each
additional destination requires additional system resources.
See The Output Settings Window.

Removing a Destination
To remove a destination from a broadcast, do the following:
1. Select Output > Output Settings. Select a destination from the Destination dropdown menu, and click OK.
Wirecast displays the Output Settings dialog with presets for the destination you
selected.
2. In the left-side pane, select the destination you want to remove.
3. Click Remove.
4. Click OK.
See The Output Settings Window.

Modifying Windows Media Server Destination Settings
Windows Media can be used to broadcast WMV8, WMV9 and WMV9 Advanced.

Push To Server
To access the Windows Media Push To Server window, select the Windows Media
Streaming destination. In the Output Settings dialog, check the box for Push to Server.
Address Enter the Internet address of the Windows Media Server you use to broadcast.
Publish Point Enter the name of the file that is put on the server, and that is used as
part of the URL that your users use. Wirecast cannot know the resulting URL that your
users use, as this may vary depending on the installation of the Windows Media Server.
Contact your Windows Media Server administrator to understand how to build a
proper URL for your viewers, based on the Publish Point.
Auto Remove Check Auto Remove to remove the file used as the publish point when
the broadcast is over.
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Username/Password Enter the user name and password for the Windows Media
Server. Contact your Windows Media Server administrator to obtain these. If there is no
user name or password required, leave these fields empty.

Pull From Server
To access the Windows Media Pull From Server window, select any of the WindowsMedia-based presets from the Encoding drop-down menu. Check the box for Pull From
Server.
To use the Pull from Server option, set the port number that your users use to connect
to your computer. Connect by using the Open URL option in Windows Media Player,
and enter a URL. For example, if your computer IP address is 10.0.5.55 and your port is
1755, use mms://10.0.5.55:1755.
Port Number Enter the port on your computer to use as the broadcast port. This can
be, effectively, any port number as long as it doesn't conflict with any existing ports on
your computer. Be aware that if you have any firewall software installed, you need to
enable the port entered here.
See also Wirecast Network Ports and Proxy Servers.
Maximum Connections The maximum number of connections your server accepts is
50 users. Your CPU is affected by the number of users you have connected, therefore
you may need to limit the number of connections.
This option turns your local computer into a mini Windows Media Server, enabling you
to broadcast immediately. There are, however, some limitations:

• User Requirement You cannot have more than 50 users connected at any one
time.

• Bandwidth Requirement You must have enough bandwidth on your Wirecast
computer to supply all of your viewers.

• CPU Requirement Since the Wirecast computer is acting as a server the CPU must
be fast enough to handle all of the user connections.

The greatest issue with this method is bandwidth. If, for example, all of your viewers are
on a local network (a business or school), then you should be able to use this method.
However, if you have a DSL connection to the Internet and you want to broadcast a
200k stream to 20 viewers, you may not have enough upload bandwidth to
accommodate this.
Note: Be aware that when you use Wirecast with an Internet connection what matters
is your upload bandwidth. Most ISP businesses offer packages that have a higher
download than upload bandwidth (e.g., a 512k DSL package is often only 256k
upload).
See The Output Settings Window.
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Modifying RTMP Server Destination Settings
Wirecast can stream to an RTMP/H.264-compatible streaming server such as RTMP
Server Media Server or Wowza Media Server.
To configure RTMP Server Streaming, follow these steps:
1. Select Destination > RTMP Server.
2. Select an encoder.
3. Enter the Address to the RTMP server. The default RTMP port is 1935, but you may
need to configure your firewall to allow connections on this port.
4. Wirecast can import a RTMP Server Encoder configuration file (XML file). Click Open
FMLE XML File, and navigate to the configuration file and select either version 2.5 or
version 3.0.
Wirecast reads the Address and Stream information from that file. Many online
streaming services offer FMLE configuration files which Wirecast can use.
Note: Only the Address and Stream information from the XML configuration file is
used. No Encoding information is imported.
5. Click OK to save your settings:

Modifying SRT (Secure Reliable Transport) Destination
Settings
Wirecast can stream to SRT (Secure Reliable Transport), an open-source video transport
protocol that enables the delivery of high-quality and secure, low-latency video across
the public Internet. SRT Supports x264 and Apple H.264 encoding methods.
To configure SRT Streaming, follow these steps:
1. Select Destination > SRT:Secure Reliable Transport.
2. Select an encoder.
3. Enter the Address, Port, and Passphrase to the SRT.
4. Click OK to save your settings.

Modifying CDN Partners Destination Settings
Listed below are the Content Distribution Network (CDN) partner destinations available
in Wirecast. Most destinations share a common user interface and only require a user
name and password. Destinations that do not conform to this paradigm, or require
additional parameters, are presented separately.
Note: The list of CDN partners in Wirecast is subject to change at any time.
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Most Common CDN Configurations
To stream to one of these CDN partners, do the following:
1. Select Output > Output Settings.
Wirecast opens the Output Settings dialog box.
2. Select a CDN partner from the Destination drop-down menu.
3. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
4. Enter your username or email.
5. Click Authenticate to enter your password and generate the RTMP URL. You only
need to do this one time because Wirecast stores the channel information for
future streams. The default RTMP port is 1935. You may need to configure your
firewall to enable connections on this port.
Note: If you do not have a username and password, you can sign up with a CDN
partner by clicking Sign Up.
6. Select your channel.
7. Optionally, you can refresh your connection by clicking Refresh.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
9. Click OK when finished.

Modifying Azure Media Services and Sermon.net
Destination Settings
To stream to one of these CDN partners, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select a CDN partner from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this is provided by the CDN partner).
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Note: If you do not have a stream name and password, you can sign up with the CDN
partner by clicking Learn More.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
8. Click OK when finished.

Modifying Brightcove and Limelight Destination Settings
To stream to one of these CDN partners, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select a CDN partner from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this is provided by the CDN partner).
7. Click Set Credentials to enter your Username and Password.
Note: If you do not have a stream name and password, you can sign up with the CDN
partner by clicking Learn More.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
9. Click OK when finished.

Modifying Akamai Destination Settings
To stream to Akamai, follow these steps:
1. Optionally, enter a Name for your destination.
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2. Select Akamai from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your Akamai Stream ID and Event Name.
6. Enter your Akamai Angle and Video Rate.
7. Enter your user name and click Authenticate to enter your log in information.
Note: If you do not have a username and password, you can sign up with Akamai by
clicking the Akamai icon, or by clicking Sign Up.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
9. Click OK.

Modifying LinkedIn Live Destination Settings
To stream to LinkedIn Live, follow these steps:
1. Enter a Name for your destination.
2. Select LinkedIn Live from the Destination menu.
3. Select an Encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Select On Behalf of Organization or Member and click Login.
6. When the login window displays, enter email/phone and password information,
then click Sign In.
Note: If you do not have a username and password, you can sign up with LinkedIn
Live by clicking Join Now.
7. Select an Organization.
8. Select a Ingest Region.
9. Enter your Post information.
10. (Skip ahead to step 11 to create a targeted audience.)
To create an event, check Event, enter a URL, and click Verify URL.
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11. (Skip ahead to step 14 if you created an event.)
To create a targeted audience, check Audience Targeting and Click Setup.
12. When the Setup window displays, select multiple regions.
13. Select Languages and click OK.
Note: Your target audience must include at least 300 members.
14. Check Draft (optionally) if you want your post to be just a draft, and click Create
Broadcast.
15. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
16. Click OK.

Modifying LiveArena Destination Settings
To stream to LiveArena, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select LiveArena from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your LiveArena Account ID, User Name, and Password.
6. Click Apply.
Note: If you do not have a username and password, you can sign up with LiveArena
by clicking the LiveArena icon, or by clicking Sign Up.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
8. Click OK.
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Modifying Twitter Broadcast Destination Settings
To stream to Twitter follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Twitter from the Destination menu.
3. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
4. Click Plus (+) to enter your username and password.
5. Copy the Authorization Code and click on the URL below it.
6. When the Authorization Code window displays, paste in the code and click
Authorize.
Note: If Wirecast does not display the Authorization Code window, or if Wirecast
displays an error window, clear your browser history or try using a different browser.
Then, sign in again.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the length of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
8. Click OK.
See also Wirecast: Streaming to Twitter using RTMP Output Destination.

Modifying Twitch Destination Settings
To stream to Twitch, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Twitch from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your Twitch username.
6. Click Authenticate to open the Twitch Log In window.
Note: If you do not have a username and password, you can sign up with Twitch by
clicking the Twitch icon or by clicking Sign Up.
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7. When the Twitch Login window displays, enter your username and password and
click Log In.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
9. Click OK when finished.

Modifying Vimeo Destination Settings
To stream to Vimeo, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Vimeo from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Click Authenticate to enter your username and password.
Note: If you do not have a username and password, you can sign up with Vimeo by
clicking Sign Up.
6. When the Authorization window displays, click Allow.
7. Click the plus (+) icon to add a new event.
8. Enter your email and password, then press Enter.
9. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
10. Click OK when finished.

Modifying Wowza Streaming Engine Destination Settings
To stream to Wowza Streaming Engine, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Wowza from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this may be provided by the CDN
partner).
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7. Click Import Wowza Config to import a Wowza configuration to use.
8. Select User Agent. Default is Wirecast/FM1.0.
9. Click Set Credentials to enter your Username and Password.
Note: If you do not have a stream name and password, you can sign up Wowza.
10. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
11. Click OK when finished.

Modifying Zixi Destination Settings
To stream to Zixi, follow these steps:
1. Download and install Zixi Feeder.
For instructions on downloading and installing Zixi Feeder, see Zixi Documentation
Center.
2. Optionally, enter a Name for your destination.
3. Select Zixi from the Destination menu.
4. Select an encoder.
5. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
6. Enter Zixi connection information.
7. Enter your Zixi channel name and password.
8. Click Apply to generate the RTMP URL. You only need to do this one time because
Wirecast stores the channel information for future streams. The default RTMP port
is 1935. You may need to configure your firewall to enable connections on this port.
Note: If you do not have a username and password, you can sign up with Zixi by
clicking the Zixi icon, or by clicking Sign Up.
9. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds.
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10. Click OK.
See also Setting up a Zixi Output Destination in Wirecast.

Modifying Facebook Live Destination Settings
To stream to Facebook, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Facebook Live from the Destination menu (if not already selected).
3. Select an encoder from the Encoding menu.
4. Choose the audio track to be used by selecting it from the Audio Track Selection
menu.
5. (Optional) Map the audio tracks to the desired output audio channels.
See Mapping Audio Tracks to Output Audio Channels.
Note: If you change the encoding settings while streaming to Facebook, an error will
occur. The encoder settings are set by Facebook.
6. To log into Facebook, do one of the following:
– To log into Facebook with a user account, click Authenticate and log into
Facebook. If you already are logged into Facebook, you can click the Change
button to log into a different Facebook account.
Note: If you do not have a username and password, you can sign up with Facebook
by clicking the Facebook icon, or by clicking Sign Up.
– To log into Facebook with a one-time stream key instead of a user account, click
Pair Device. Wirecast opens a dialog. Follow the instructions given in the dialog.
7. Select Go Live Now or Schedule for Later from the Post To menu.
8. If you selected Schedule for Later, select also a start date and a time.
9. Select Pages, Profile, or Groups from the Post To destination menu. Click Refresh to
refresh the page list. If planning to use co-branded content, check the Show verified
pages only checkbox to filter out all non-verified pages. Enter a Title and a
Description. Click Create to refresh after changing any settings.
10. If you selected Go Live Now, select also Pages, Profile, or Groups and enter a Title and
Description (as described in step 9 above). Optionally, click Advanced Options.
If you select Pages, you can also select Crosspost, if desired.
11. If you selected to post to a Profile, select also a level of Privacy: Public, Friends, or
Only Me.
12. Click Create to start an event on Facebook. You can, optionally, optimize your
connection by clicking Optimize Connection. When you do a progress bar is
displayed while optimization is performed. Click Cancel Speed Test at any time to
cancel your optimization request.
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13. Click OK when finished.

Modifying Microsoft Stream Destination Settings
In order to broadcast using Microsoft Stream, you must first configure your streaming
using Office 365. For a detailed procedure on how to do this visit the Telestream
website at: Publish to Microsoft Stream
1. When Wirecast displays the Output Settings window, select Microsoft Stream as your
Destination, and click OK.
2. When Wirecast displays the Output window, select an Encoder and Audio Track for
the stream. Paste in the address copied from Office 365 where streaming was
initiated.
3. (Optional) Enter a Stream Delay if needed. Click Ok when finished.
4. (Optional) Click the Map button to open the Muti-Track Input Mapper. For each
channel, select (by checking the box) one or more inputs.
Click OK when finished.

Modifying YouTube Destination Settings
Note: Custom encoders cannot be used to stream to YouTube. They may only be used
to encode a recording to disk.
To stream to YouTube, follow these steps:
1. Log into your YouTube account using your browser.
2. Optionally, enter a Name for your destination.
3. Select YouTube from the Destination menu.
4. Select an encoder.
5. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
6. Check Use Backup Server if you get an error when authenticating, or the application
tries to connect and then crashes.
Note: At times the primary streaming servers at YouTube go down for maintenance
or other reasons. When Wirecast users attempt to connect to these servers, especially
when using YouTube's “Stream Now” feature, they are unable to connect.
7. Click the plus (+) icon to add a new event.
Note: If you do not have a YouTube account, click Sign Up (or go to
www.youtube.com).
8. Enter all of your event information and click Save.
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Note: Click the Details button to get more information from Google.
9. Click Authenticate, enter your login information, and wait for your event to appear
in the Event menu box. Click the minus icon (-) to remove a selected event.
Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. Click OK when finished.
Note: If you are not already signed in, Wirecast launches a window enabling you to
sign into your YouTube account. Enter your account information and click Sign In.

Encoder Presets
Without compression, the bandwidth of audio-video data can be too large to
successfully broadcast across a network. An encoder is a program that compresses
audio, video, or both, for broadcast. Wirecast supports a wide variety of encoders, also
known as codecs.
The settings for encoders range from simple to very complex. Wirecast offers presets of
the most common settings for encoders. This provides a starting point, reduces
complexity, and enables you to experiment and adjust settings as you test your
broadcast.
Note: Encoder Presets can be edited from the Output Settings window. To do this
select Output > Output Settings, click the gear icon, then choose View Details from the
drop-down menu.
See The Encoder Presets Window.

Selecting an Encoder Preset
To use an encoder other than the default, select an encoder from the Encoding dropdown menu in the Output Settings dialog.
Note: Click More next to the Destination field to display a list of all available
destinations. Check the box for each destination you want to include in the
destination menu list.
Note: Click Filter from the Gear menu next to the Encoding field to display a check list
of encoder presets. Check the presets you want to display in the Encoder Presets menu.
Click Save when finished.
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Creating an Encoder Preset
The default encoder presets cannot be changed. However, you can make a copy of any
preset, modify it as needed, and save it under a new name. You can refer back to the
default presets at any time since they are never modified.
To edit an encoder preset, do the following:
1. Select Window > Encoder Presets.
2. Select a preset to edit from the Encoder Preset drop-down menu.
3. Change the settings as desired.
4. Click Save As. Enter a name for the edited preset.
5. Click OK.
Note: Click New Preset from the Gear menu next to the Encoding field to create a new
encoder preset. Enter a name for your new preset and click OK.
Note: Click View Details from the Gear menu next to the Encoding field to modify an
encoder preset. One important option is Strict Constant Bitrate. When checked, the
bitrate is strictly held at the bitrate entered in Average bit rate.

Modifying the MainConcept H.264 Preset
To modify a MainConcept H.264 preset, follow these steps:
1. Select Window > Encoder Presets.
2. Select the MainConcept H.264 encoder preset from the Encoder drop-down menu.
3. To encode video, check the Video Encoding checkbox.
When checked, the video for your broadcast is encoded. When Video Encoding is
unchecked, the output contains a blank video screen.
Note: To create an audio-only broadcast, uncheck Video Encoding and check Audio
Encoding (AAC). To create a video-only broadcast, check Video Encoding and uncheck
Audio Encoding (AAC).
4. Enter the desired width, in pixels, into the Width field.
5. Enter the desired height, in pixels, into the Height field.
6. Select the desired framerate, into the Frames per second field. This value is a target
value for the encoder. The exact value of the output is not guaranteed.
7. Enter the average bit rate in Kbits (1000 bits) per second into the Average bit rate
field. This is the target bit rate of your video. Higher numbers provide better quality.
The connection speed of your audience is a significant factor in determining your
target bit rate. The encoder compresses the video to approximate this target.
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However, at different times during your broadcast the bit rate may be higher or
lower than the target rate.
8. Select an encoder profile from the Profile menu. Three profiles are provided:
Baseline, Main, and High. The Baseline profile is commonly used in mobile
applications. It is also used in other applications which operate with limited
processing power, storage capacity, and/or bandwidth. The Main profile is
appropriate for general-purpose applications of broadcast media, such as highbandwidth Internet broadcasting. The High profile provides the highest broadcast
quality encoding.
9. (Optional) Key frame every allows you to enter the number of frames. A movie is a
sequence of images and each image is called a frame. To compress video data,
most encoders take a frame and make it a reference (also known as a key). This
keyframe is sent as part of the broadcast, and all of the data after that keyframe is
relative to it. The benefit of this is that the compressor only needs to send what has
changed since the last keyframe. The main drawback of this is that over time it
becomes harder for the encoder to distinguish the frame-difference information,
especially if there is a lot of motion in the video. Another drawback is if your
viewer’s computer misses a keyframe, the video is distorted until the next keyframe
is sent. However, you can control how often the encoder makes a new keyframe by
setting the number of frames. The more keyframes you broadcast, the more
bandwidth required and less compression, but results in better quality video.
10. (Optional) Check the Timecode Every checkbox and enter the number of frames
between timecodes. Wirecast can generate timecodes embedded in the flash
stream. If a frames value of zero is entered, the timecode is never sent. Wirecast
sends metadata along with the frames. This data looks like an ONFi call. Various
timecodes and timestamps are also sent with the stream.
11. (Optional) Check Strict Constant Bitrate. When checked, it forces the Average bit rate
(see item 8 above) to maintain the exact bit rate entered. CBR pads the data (when
necessary) to meet exact bitrate specified. Disabling CBR can result in slightly
improved quality and decrease file size, but at the cost of greater bitrate
fluctuations which could prove troublesome for certain streaming destinations.
Selecting this option for recording is not recommended because it can result in
decreased quality and larger files, with no real benefit.
12. (Optional) Check Keyframe Aligned. When checked, it facilitates adaptive bitrate
streaming by ensuring that keyframes from multiple streams are in sync, along with
the keyframes timestamp, DTS and PTS values. But this is true only if those other
streams also have the option turned on and have the same keyframe interval. To
accomplish this, Wirecast disables scene detection and manually inserts the
keyframe at the exact keyframe interval specified. Therefore, to ensure quality and
smooth switching in the player, the keyframe interval should be in the 1 to 4
second range. When Keyframe Aligned is enabled, absolute timestamp is also
enabled.
13. (Optional) Check the Audio Encoding (AAC) checkbox.
When checked, the audio for your broadcast is encoded. When Audio Encoding
(AAC) is unchecked, the output contains no audio track.
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14. Select the type of audio channels: Mono or Stereo. Mono uses less bandwidth than
stereo.
15. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate
menu. This is the target bit rate of your audio. Higher numbers provide better
quality. The connection speed of your audience is a significant factor in
determining your target bit rate. The encoder compresses the audio to
approximate this target. However, at different times during your broadcast the bit
rate may be higher lower than the target rate. The total broadcast bit rate is a
function of video bit rate plus audio bit rate.
16. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample rate
menu. This value specifies how many thousands of times per second to sample the
audio in the broadcast. Higher values provide better quality sound, but at greater
bandwidth.
17. Click Save to save your settings.
See The Encoder Presets Window.

Modifying the x264 Preset
Note: The x264 implementation of the H.264 standard results in better quality and
lower CPU usage for any given bitrate, but at the cost of higher memory usage. The
default implementation is based on the MainConcept codec and uses less memory.
To modify an x264 preset, follow these steps:
1. Select Window > Encoder Presets.
2. Select an x264 from the Encoder menu.
Note: See The Encoder Presets Window.
3. Check the Video Encoding checkbox. When checked, the video for your broadcast is
encoded. When unchecked, a blank video screen is provided. This is the preferred
method of producing audio-only broadcasts.
4. Enter the Width of your broadcast video.
5. Enter the Height of your broadcast video.
6. Select the desired frames per second (fps) of your broadcast. This value is a target
value for the encoder and the exact value is not guaranteed.
7. Enter the average bit rate in Kbits (1000 bits) per second. This is the target bit rate of
your video. Higher numbers provide better quality. The connection speed of your
audience is a significant factor in determining your target bit rate. The encoder
compresses the video to approximate this target. However, at different times
during your broadcast the bit rate may be higher or lower than the target rate.
8. Select encoding quality (Ultra fast to Very slow encoding). Slower encoding results
in better quality.
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9. In the x264 command line options edit box, enter any command line options you
want included.
10. Select an encoder profile from the Profile menu. Three profiles are provided:
Baseline, Main, and High. The Baseline profile is commonly used in mobile
applications. It is also used in other applications which operate with limited
processing power, storage capacity, and/or bandwidth. The Main profile is
appropriate for general-purpose applications of broadcast media, such as highbandwidth Internet broadcasting. The High profile provides the highest broadcast
quality encoding.
See Profile.
11. Key Frame (optionally) allows you to enter the number of frames. A movie is a
sequence of images and each image is called a frame. To compress video data,
most encoders take a frame and make it a reference (also known as a key). This
keyframe is sent as part of the broadcast, and all of the data after that keyframe is
relative to it. The benefit of this is that the compressor only needs to send what has
changed since the last keyframe. The main drawback of this is that over time it
becomes harder for the encoder to distinguish the frame-difference information,
especially if there is a lot of motion in the video. Another drawback is if your
viewer’s computer misses a keyframe, the video is distorted until the next keyframe
is sent. However, you can control how often the encoder makes a new keyframe by
setting the number of frames. The more keyframes you broadcast, the more
bandwidth required. The result is less compression but better quality video.
12. Check (optionally) Strict Constant Bitrate. When checked, it forces the Average bit
rate (see above) to maintain the exact bit rate entered. CBR pads the data (when
necessary) to meet exact bitrate specified. Disabling CBR can result in slightly
improved quality and decrease file size, but at the cost of greater bitrate
fluctuations which could prove troublesome for certain streaming destinations.
Selecting this option for recording is not recommended because it can result in
decreased quality and larger files, with no real benefit.
13. Check (optionally) Keyframe aligned. When checked, it facilitates adaptive bitrate
streaming by ensuring that keyframes from multiple streams are in sync, along with
the keyframes timestamp, DTS and PTS values. But this is true only if those other
streams also have the option turned on and have the same keyframe interval. To
accomplish this, Wirecast disables scene detection and manually inserts the
keyframe at the exact keyframe interval specified. Therefore, to ensure quality and
smooth switching in the player, the keyframe interval should be in the 1 to 4
second range. When Keyframe Aligned is enabled, absolute timestamp is also
enabled.
14. Check (optionally) the Timecode Every checkbox and enter the number of frames
between timecodes. Wirecast can generate timecodes embedded in the flash
stream. If a frames value of zero is entered, the timecode is never sent. Wirecast
sends metadata along with the frames. This data looks like an ONFi call. Various
timecodes and timestamps are also sent with the stream.
15. Check (optionally) the Audio Encoding (AAC) checkbox. When checked, the audio
for your broadcast is included. When unchecked, audio is absent. This is the
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preferred method of producing video-only broadcasts because the presence of
silent audio uses bandwidth.
16. Select the number of channels: Mono or Stereo. Mono uses less bandwidth than
stereo, but stereo is more pleasing to the listener.
17. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate
menu. This is the target bit rate of your audio. Higher numbers provide better
quality. The connection speed of your audience is a significant factor in
determining your target bit rate. The encoder compresses the audio to
approximate this target. However, at different times during your broadcast the bit
rate may be higher or lower than the target rate. The total broadcast bit rate is a
function of video bit rate plus audio bit rate.
18. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample Rate
menu. This value specifies how many thousands of times per second to sample the
audio in the broadcast. Higher values provide better quality sound, but at greater
bandwidth.
19. To save your settings, click Save.
See The Encoder Presets Window.

Mapping Audio Tracks to Output Audio Channels
You can determine the output audio destination channels for each of the audio tracks
available in a Wirecast document. To map audio tracks to output audio channels, do the
following:
1. Click Output > Output Settings.
Wirecast opens the Output Settings dialog.
2. Click the Map button.
See Map Button.
Wirecast opens the Multi-Track Input Mapper window.
See The Multi-Track Input Mapper.
3. In each Channel row, click the checkbox for each track you want to send to that
output audio channel.
4. To close the Multi-Track Input Mapper window, click the “x.”

Streaming
To start steaming, do the following:
1. Click the Stream button.
See the Stream button on the screenshot in Control/Status Bar.
The Stream button blinks green until a connection is made. Once you are connected,
the Stream icon turns unblinking green. If you can’t connect, Wirecast displays an error
message.
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If you are streaming to Facebook, Wirecast displays additional statuses on the right side
of the status bar.
Figure 6. The Status Bar

Various
reactions

Number of
viewers

See Streaming Status Colors.
1. (Optional) To record your broadcast click Record.
2. To stop streaming, click Stream again.

Streaming Status Colors
Wirecast indicates connectivity strength by the number of bars displayed in the Stream
icon. Fewer bars indicate lower speed or connection reliability issues. If packets aren't
reaching the destination server, Wirecast buffers the packets. When this happens, the
green streaming indicator turns yellow and Wirecast continues sending those packets
in an attempt to reach the destination server.
If packets continue to fail to reach the server, Wirecast drops packets, and the streaming
indicator turns red. When Wirecast stops attempting to send packets, Wirecast displays
the red Failed icon.
Red Failed icon

When the connection is recovered, Wirecast replaces the red Failed icon with green
bars.

Buffer Utilization
When streaming over RTMP, there is a buffer for the packets called the flash queue.
The buffer is utilized to handle scenarios where the Internet uplink to the RTMP
endpoint (CDN) temporarily is unable to deliver at a fast enough rate. Any of the
following can cause a slow-down:

•
•
•
•
•
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Colors
• Green will be shown when the flash queue is able to be emptied just as fast or
faster than it is able to be filled.

• Yellow will be shown when the flash queue has grown, but is not yet approaching
overload.

• Red will be shown when the flash queue is just about to be full, in which packets
will be lost.

Example 1
• Encoding is set to 7Mbps

• ISP upload speed is 7Mbps
• Video content was fairly still, but a scene change or shot switch occurs that is fast
motion.

• The encoder bursts to handle the more complex content, and momentarily requires
8Mbps to properly deliver the content.

• The flash queue is only able to output at 7Mbps, so it grows with more frames/
packets backed up.

• The Icon color turns Yellow, to alert this state.
• The encoder catches up, and settles back down to 5Mbps after the scene change.
• The Icon returns to green.
Example 2
• Encoding is set to 5Mbps

• ISP upload speed is 7Mbps
• Video content is running fine, with green Icon.
• Someone else on the network begins uploading at 4Mbps, perhaps an Aspera
transfer if you remember those taking down Telestream's network...

• The available bandwidth to the stream is 3Mbps during this usage.
• The icon will turn yellow, then turn red.
• If the queue stays red for long enough, the stream disconnects.
Example 3
• Encoding is set to 5Mbps

• ISP upload speed is 7Mbps
• Video content is running fine, with green Icon.
• The ISP oversold their network, and some neighboring business or residents all
hopped on the Internet at the same time.

• The available upload speed drops to 5Mbps
• The icon drops to yellow, then to red.
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• The icon stays red, and the stream continues.
• Viewers are still seeing the stream despite the icon being red.
• The flash queue is able to unload the packets during downward bitrate fluctua-

tions, and builds more packets in buffer during upward bitrate fluctuations, just
enough that the queue stays in this almost-full-but-hasn't-burst state.

Troubleshooting Connectivity for Streaming
You can test for server-side issues by running a test stream to another server. If you get
a continuous green streaming indicator to the new destination, contact the CDN host
and report the destination server problem.
To test for Internet ISP problems, run a speed test. Note upload speed and packet loss.
Your combined encoder settings to all destinations should total no more than half the
tested upload speed. Streaming requires this headroom because both the sending data
rate and the ISP upload bandwidth can vary from moment to moment. Actual upload
speed often varies from the speed claimed by an ISP.
Keep packet loss at 0%. Any other number indicates packet loss. If you are losing
packets, have the ISP run tests to your point-of-origin broadband connection.
While streaming from Wirecast, keep CPU use under 60% for optimal performance. If
CPU usage exceeds 80% a variety of problems might occur, including disconnection.

Limiting Reconnection Attempts
When Wirecast loses an Internet connection, Wirecast attempts to reconnect. Each time
Wirecast attempts reconnection, the stream icon blinks.
To limit the number of reconnection tries, do the following:
1. Select File > Preferences > General.
2. Enter a value into the field, Maximum Reconnect Attempts.
3. To close the Preferences dialog box, click the “x.”

Configuring Replay + ISO
PRO

Replay enables you to repeatedly play a clip, or even a portion of a clip, any number of
times or endlessly. You can also replay playlists (see Playing Playlists). This makes the
combination of Playlist and Replay a very powerful production tool.
ISO (or Isolated Output) allows users to create recordings for system devices (cameras,
capture cards, or mics) that are currently not being displayed in the Live canvas window.
This enables you to be outputting one device while broadcasting with another. ISOs
can also be setup as a replay source. This enables you to have all the Replay
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functionality (keyboard shortcuts, Mark-in, and Mark-out) in your ISO source but
without it being displayed in the Live canvas window.
Replay and ISO share the same menu because ISOs have the ability to be setup to use
replay functionality. This functionality is toggled in the ISO Settings window. If an ISO is
set to use Replay then it will use all the replay settings that have been configured in the
Replay+ISO window.
Note: Multiple Replay clips captured during the same replay session will not render
correctly when played at the same time on different Main Layers or different shot
layers.
To use Replay you need to set it up the way you want it to perform. To do this select
Replay+ISO > Configure. Check the Program Replay box, make your desired settings, and
click OK when finished.
Capture Audio in the Replay Check the Audio box to capture audio in the Replay you
are creating. If unchecked all audio is ignored.
Video Quality Set the video quality for Standard or High. Depending on what quality
you choose, an estimate of the write rate will be displayed.
Folder Click Browse and navigate to the location where you want to store your Replay
shots.
Create Replay Keyboard Shortcut Select a keyboard shortcut from the drop-down
menu that will activate the Create Replay function.
Update Replay Keyboard Shortcut Select a keyboard shortcut from the drop-down
menu that will activate the Update Replay function.
Mark Replay Keyboard Shortcut Select a keyboard shortcut from the drop-down
menu that will activate the Mark Replay function.
Manage Opens the Preferences > Shortcuts window so you can add, delete or change
your application shortcuts and document hotkeys. The Global check box must be
checked if you want that hotkey to be available in the drop-down menus above.
See Replay + ISO Menu and Replay Shots.

Activating Replay
Note: When Replay is activated, CPU usage increases.
To activate Replay, select Replay > Start All.
The Start All menu item becomes Stop All and Wirecast adds buttons to the Wirecast
default layout: Set Replay Mark In and Update Replay Shot.
Once Replay has been activated it keeps all shot activity (playing of clips or capturing of
live sources) in the Replay buffer on disk. The amount that is saved when the Create
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Replay Shot button is pressed depends on the value entered into the Default Replay
duration setting.
See Replay Shots.

Configuring ISO Recording
ISO (or Isolated Output) is a Wirecast Pro feature that allows you to create clean
recordings of your system devices (cameras, capture cards, or mics) even when they are
not being displayed in the Live canvas window. This is often helpful when you want to
edit together a video-on-demand version of your live show. You can have recordings of
all your cameras even when they weren't live in your broadcast.
There are two ways to ISO record:
1. The Capture Source ISO capability allows you to choose one source (such as your
webcam, or a microphone). This is truly an isolated source recording, so it doesn't
enable you to combine a separate audio and video raw sources into one ISO
recording. However if your source includes audio, you can capture that as part of
your Capture Source ISO.
2. The Shot ISO capability lets you record any shot that is on your Main Shot Display.
This lets you mix two or more sources into a single shot and record that. It also lets
you ISO record sources that are not available in the Capture Source ISO option such
as WebRTC sources (Rendezvous and Wirecast Go), NDI, Webstream, or Elgato
capture sources.
3. Select Configure from the Replay+ISO main navigation.
4. Click Add ISO.
You have two choices for Recording type: Capture Source ISO or Shot ISO.

Capture Source ISO
Capture Source ISO lets you ISO record an individual camera or audio source, (e.g. your
Facetime Camera, or a camera plugged in via a capture card.
Note: Certain sources, such as Rendezvous guests, Web Stream sources, IP Cameras
sources, Web Page plugin sources, or Wirecast Go sources will not show up as available
Capture Source sources. To record these, you should use Shot ISO.
If your chosen source produces both video and audio, you will have the option to
include which media tracks are included from your single source.
If you want to record audio that is coming from a separate source (like from a separate
micro-phone), you can either set up another Capture Source ISO for that audio
separately, OR you can place your chosen video and audio sources into a single shot on
the Main Shot Display and use Shot ISO to record that shot.

Wirecast User Guide

94

95

Output Configuration
Configuring Replay + ISO

Note: Documents created prior to Wirecast version 14.1 that had ISO configured that
included video and audio from two different sources will be split into two separate
source recordings (one for Audio, one for Video).

Shot ISO
Shot ISO lets you ISO record any shot on the Main Shot Display. The advantage of this is
that you can combine any audio and video sources into a shot. You can also record
shots that contain sources that aren't available in Capture Source ISO, like Rendezvous
guests and IP camera sources.
If your chosen shot has both video and audio, you will have the option to include which
media tracks are included from the shot.
Shot ISO recordings will produce video at the canvas resolution and frame rate. This can
be adjusted in Preferences > Canvas. Audio will match the Wirecast internal mixer which
is stereo, 32-bit float, 48 kHz.
Note: Any animated graphic or media file contained in your shot will not play as part
of a Shot ISO recording. So, if you don't want a static image where your media is, you
should place that source in a different shot on a different layer.
Audio-Only Recordings You can make audio-only ISO recordings, using either Capture
Source (if your source is audio) or Shot ISO (if your shot includes only audio).
The ISO configuration dialog displays the selected source's current video resolution
and frame rate so you know what to expect in your recording. The same goes for audio
channels, bits per sample, and sample rate. When no source is selected or the source
does not produce a certain type of media, None is displayed where the source media
information would normally appear (next to the corresponding video/audio media
track checkboxes).

Format
• QuickTime: ProRes Video + Uncompressed Audio: ProRes is better suited for NLE
work. Also, color space information is less ambiguous.

• QuickTime: x264 Video + Uncompressed Audio:
– x264 is a compressed video file that results in significantly smaller file sizes.
– x264 recordings are still placed in QuickTime files and still paired with

uncompressed audio. Uncompressed audio offers top quality and minimal CPU
drain for archival purposes.

– You can choose the bitrate and keyframe interval for recordings that use x264

encoding.The default values are 10 Mbps with 15 frames/second. The defaults
were chosen for high quality full HD archival. We use the high-profile encoder
setting and the “fast” x264 algorithm with variable bitrate encoding.
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Quality
Wirecast offers the ability to encode your files using ProRes or x264 on both Mac and
Windows.

Filename
Each new ISO recording you create in a document includes the next number in a
sequence that begins with 1 and is incremented when you create a new ISO
configuration. For example, the first ISO will be named “ISO 1", the second will be
named “ISO 2", third “ISO 3", and so on. Likewise, filenames given will be “iso_01”,
“iso_02”, “iso_03”, and so on. Name-sorted listings of recordings on disk will remain in
order beyond the 9th ISO configuration.
You can always choose another name for the files, but that will not affect the
sequencing. So if you rename “ISO 1" to “Names Don't Matter”, the next ISO will still be
named “ISO 2" by default.
Folder Wirecast will remember the last folder you assigned to an ISO recording
configuration and use that folder as the default for the next configuration that you
create. This setting is app-wide so it will transfer between projects.
Replay Check this to configure your ISO recording to be available for Instant Replay
within your broadcast. This can be applied for Capture Source ISOs as well as Shot ISOs
(See tutorials on Replay for more information on configuring this).

File Options
Single File This is best used if you have shorter broadcasts and have plenty of disk
storage space. When the user chooses the Single File option, what you're really
choosing is the maxed-out 12-hour file duration.
New File Every This ensures you don't have files that are so big you run out of disk
space. If you have a long broadcast or have limited space, you may want to limit your
file sizes with this option. This will break the recordings up and start a new file at the
increment you specify.
See Starting your ISO Recording.

A Note about Resources
Keep in mind that this feature is very resource intensive. Because you are recording
individual cameras or shots alongside your actual production you will need a rather
powerful system.
We recommend that at minimum you have:

• An i7 processor
• A high-end dedicated graphics card
• An SSD for recording
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Recording To Disk
If you want to archive your stream, you can use the Record To Disk destination.
To record to disk, do the following:
1. Click the Record button (or ISO Record button) at the top of the Wirecast default
layout.
2. When the Output window opens, click the Add button at the bottom of the window
to add a recording destination.
3. When the dialog box displays, select Record to Disk and click OK.
4. In the Output Settings window select Record To Disk (MOV, MP4 or Windows Media)
5. Select an encoder.
Note: ProRes encoding is now available for MOV.
6. Click Browse or enter the path to where you want your recording located.
7. Select the recording mode: Use Filename Only, Auto Increment Filenames, or
Timestamp Filenames. If you select Auto Increment Filenames, your filename will
have an incremental number appended to the end of it. This causes a new file to be
created every time you start recording to disk, otherwise your previous file is
overwritten (if you have selected Use Filename Only).
8. Click OK.
Note: When recording to disk on FAT32 formatted drives, single files cannot be larger
than 4GB in size. So, recording to disk on a FAT32 formatted drive may result in files
that do not close properly if they exceed 4GB in size. It is recommended that you
record to disk on a Windows NTFS formatted partition whenever possible.
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Live Broadcast Production
Once you’ve created a document and have configured the inputs and outputs for your
broadcast, you’re ready to broadcast with Wirecast.

Topics
■Launching Wirecast 98
■Switching with Preview 98
■Single-Click Switching with AutoLive 99
■Playing Playlists 99
■Broadcasting 99
■The Final Mix Audio Panels 100
■Viewing a Layer in a Layer Window 101
■Moderating Social Media Comments 101
■Moderating Facebook or YouTube Comments for a Streaming Computer or RTMP
Server 102

■Controlling a PTZ Camera 103
■Starting your ISO Recording 103

Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop
during installation.

Switching with Preview
Do the following to switch shots when AutoLive is disabled:
1. Click a shot in a layer.
Wirecast displays the shot in the Preview Area.
2. Click the transition button for the type of transition Wirecast generates to change
from the current live shot to the shot selected. Alternatively, press the keyboard
shortcut Ctrl+1 to select the first transition button or Ctrl+2 to select the second
transition button.
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3. Click the Go button.
Wirecast places the shot in the Live Broadcast Area.
See AutoLive, The Default Layout, Final Mix Audio Panel, and Go Button.

Single-Click Switching with AutoLive
To switch shots when AutoLive is enabled, click a shot in a layer.
Wirecast places the shot in the Live Broadcast Area.
Note: When you select multiple shots on multiple layers, Wirecast displays all of them
in the Live Broadcast Area, with layer 1 on top and layer 5 at the bottom.
See AutoLive, The Default Layout, and Go Button.

Playing Playlists
Playing back a playlist is the same as playing any other shot. To play a playlist, do the
following:
1. Select the playlist shot
Wirecast displays the shot in the Preview Area.
2. Click the Go button.
Wirecast displays the shot i n the Live Broadcast Area, and broadcasts the shot.
See AutoLive, The Default Layout, and Go Button.

Viewing the Playlist Countdown Timers
See Playlist Countdown Timer Display.
To select a view of the countdown timer, do one of the following:

• Click the gear icon to open the counter display mode menu. Select the top item
(the name of the currently playing shot) to display its countdown time only.

• Select the bottom item (New Playlist - Completion) to display the countdown time of
the current shot and of the Playlist.

Broadcasting
Before you can broadcast with Wirecast, you must configure your output settings. See
Selecting a Destination.
To start broadcasting, select Output > Start/Stop Broadcasting > Start All.
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Note: If you try to broadcast without first configuring an output, Wirecast opens the
Output Settings window for you. See The Output Settings Window.

The Final Mix Audio Panels
You can set the volume level, or you can mute, the final mix audio level for the Preview
Area or the Live Broadcast Area, with the Final Mix Audio panels. There are separate Final
Mix Audio panels for the Preview Area and for the Live Broadcast Area. The controls for
both Final Mix Audio panels work the same way.
See Final Mix Audio Panel.

Displaying the Audio Mixer
To display the Wirecast audio mixer, select Window > Audio Mixer.
See Window Menu.

Displaying or Hiding the Final Mix Audio Panel
To display Final Mix Audio for preview and live displays, select Layout > Final Mix.
To hide Final Mix Audio select Layout > Final Mix again.
See Final Mix Audio Panel.

Controlling or Muting the Final Audio Mix Level
To control the volume for either the Preview Area or for the Live Broadcast Area, select
the respective Final Mix Audio panel, and do one of the following:

• To set the volume, click and drag the slider control up or down.

The decibel scale next to the slider indicates the audio level. When you take a preview shot live, the live audio levels match the levels set in preview.

• To mute the audio output, click the Mute button.
See Final Mix Audio Panel.

Adding a Filter to an Audio Channel
To add a filter to an audio channel, do the following:
1. Open the audio mixer.
See Displaying the Audio Mixer.
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2. In the Live Sources pane, click the Add New FX button.
Wirecast opens a drop-down menu of available effects.
3. Select an effect.
Wirecast adds the name of the selected effect to the Live Sources pane of the audio
mixer.
See also Adding VST Plugins to the Available Audio Plugins.

Adding a Filter to the Final Audio Mix
To add a filter to the final audio mix, do the following:
1. Open the audio mixer.
See Displaying the Audio Mixer.
2. In the Final Mix pane, click the Add New FX button.
Wirecast opens a drop-down menu of available effects.
3. Select an effect.
Wirecast adds the name of the selected effect to the Final Mix pane of the audio
mixer.
See also Adding VST Plugins to the Available Audio Plugins.

Viewing a Layer in a Layer Window
To open any layer in its own window, do the following:
1. Select Window > New Layer Window.
Wirecast displays a list of the layer windows you can open (Main Layer 1 through
Main Layer 5).
2. Select the layer you want to open.
Wirecast displays the layer in a separate layer window.
This separate layer window works exactly like the layers in the default display, but you
can move layer windows independently of one another.
See also Layers.

Moderating Social Media Comments
Once you have a social media title in your document, and comments coming into the
Comment Moderation window, select a comment in the Comment Moderation window,
and select your social media title in the main shot display.
To moderate comments, do the following.
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1. Do one of the following:
– Select Create Title Shot from the lower-left corner of the Comment Moderation
window View comments pane.
– Go directly to the main shot display and select (+). Choose Overlays > Social Media
Title.
Wirecast opens the Social Media Title window.
2. Select a social media title, and go to the Social Media Title Properties window to
adjust any settings.
3. Select Social > Comments.
Wirecast opens the View comments pane on the Comment Moderation dialog box.
4. Once you have comments coming in, and a social media title in your document,
click the Live radio button for one or more comments in the Comment Moderation
window.
The selected comment appears in the Social Media Title in the Preview window.
5. Click Go Live to send the social media title to your live broadcast.

• Once your social media title is live, you can select any other comment in the View

comments pane on the Comment Moderation window. Wirecast transitions the first
comment out and the next comment in.

• If you have Rotate Selected.. checked, simply leave your social media title live. Wirecast automatically rotates the selected comments into your broadcast.

See Social Media Shots and The Comment Moderation Window.

Moderating Facebook or YouTube Comments for a
Streaming Computer or RTMP Server
You can moderate Facebook or YouTube comments from a computer that is
broadcasting your program from Wirecast, while you stream the broadcast to Facebook
or YouTube via a second computer, streaming server, or RTMP server.
These are two typical scenarios for this method:

• You are producing a show using Wirecast on one computer, and transmitting the

feed to another computer or streaming service. The second computer or service
streams the broadcast to Facebook or YouTube. Some producers use this method to
balance resources between two computers.

• You are producing a show using Wirecast, and streaming to Facebook or YouTube
from the same computer. In this scenario, you use a generic RTMP server, not the
built-in Facebook or YouTube destinations in Wirecast.

Do the following:
1. Make sure you have authenticated Wirecast with the desired social media platform.
See Social Media Shots.
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2. To open the Comment Moderation panel select Social > Comments > View active
accounts.
Wirecast opens the Comment Moderation dialog box to the Active Accounts pane.
3. Click the Add Facebook or YouTube Feed (+) button.
See View Active Accounts.
Wirecast opens the Select Destination dialog box.
4. Log in using credentials that have privileges for the page, group or channel you
want to access.
Do one of the following:
– Click the name of the social media platform to which you are streaming and from
which you want to grab comments. Log in with your user account credentials.
– Check the box for Login as new user, create a user account, and log in.
In the Comment Moderation window, Wirecast displays the posts in your feed for
the platform selected.
Wirecast displays a drop-down menu of events.
5. Choose the name of the event or live stream desired.
Once your stream has started, you should see the comments come through to your
moderation panel, as you would if you were streaming directly from that computer.
6. Select comments for display as you would when moderating comments on a
Wirecast computer which is broadcasting.
See Moderating Social Media Comments.
See Social Media Shots and The Comment Moderation Window.

Controlling a PTZ Camera
To control a remotely-controlled pan-tilt-zoom (PTZ) camera, do the following:
1. Configure Wirecast for the PTZ camera. See Setting Up PTZOptics Camera with a
Dynamic IP Address and Setting Up PTZOptics Camera with a Static IP Address.
2. Select a PTZ camera shot in a layer.
3. In the Shot Layer Properties tab of the Shot Editor, click the triangle next to PTZ, and
click the PTZ Controller button.
Wirecast opens the PTZ controller panel.
4. Control the camera with the controls in the PTZ Controller.
See The PTZ Controller Panel and PTZ Control in the Shot Layer Properties Tab.

Starting your ISO Recording
When you finish configuring your ISO recordings, you're ready to start recording. There
are a couple of ways to start your ISO recordings.
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1. Go to Replay+ISO in the main navigation bar. There you have the choice to Start All
or choose to start only a specific ISO that you have set up.
2. Alternatively, you can click the ISO-REC button at the top of the User Interface,
which will start all your configured ISO recordings.
See Configuring ISO Recording.

Error Reporting
When starting ISO recordings, Wirecast will send any number of specific error messages
to the user-log and present you with a generic modal dialog that reads: “Av recording
failed to start. View the user log for details and edit the Replay+ISO configuration to
resolve issues.” The dialog contains an Edit button which opens the ISO configuration
dialog.
Also, many ISO recording errors occur after you start recording and some occur soon
after. These asynchronous errors are reported only in the Notifications window where
no modal dialog is shown.

Configuration Errors and Warnings
Wirecast tries to catch a number of configuration errors and potential problems while
you are interacting with the ISO configuration dialog.
Warnings are shown in the dialog as warning icons next to the configuration fields. If
you hover the cursor over each warning icon, a tool tip appears detailing the problem.
Also, the topmost warning message will appear in red text at the bottom of the dialog
until all warnings are cleared for the selected configuration.
Each ISO configuration listed on the right-hand side of the ISO configuration dialog has
a warning icon if it has a problem. A list of the configuration problems Wirecast detects
follows.

•
•
•
•
•
•
•
•
•
•

No source/shot is selected for recording.
The recording uses a source or shot that no longer exists.
The recording uses the same source or shot as another recording.
No media tracks are enabled for recording.
The source does not produce media that matches the enabled tracks.
The recording uses the same output file as another recording.
The file name contains restricted characters.
The selected output folder does not exist.
The space available on the selected drive is insufficient for recording.
The file duration must be between 10 seconds and 12 hours.

See Configuring Replay + ISO.
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Windows, Controls, and
Menus
You create broadcasts through the various windows, controls, and menus of Wirecast.

Topics
■The Default Layout 107
■Preview Area 112
■Live Broadcast Area 112
■Final Mix Audio Panel 112
■Layers 115
■Add Shot Window 116
■The Shot Editor Window 137
■The Shot Menu 151
■The Preferences Dialog Box 152
■The Audio Mixer Window 163
■The Output Settings Window 166
■The Encoder Presets Window 168
■The Comment Moderation Window 169
■The PTZ Controller Panel 171
■Menus and Application Keyboard Shortcuts 174
■File Menu 175
■Edit Menu 176
■Switch Menu 177
■Media Menu 179
■Output Menu 180
■Layout Menu 184
■Replay + ISO Menu 185
■Social Menu 186
■Window Menu 187
■Help Menu 189
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The Default Layout
When you create a new document, Wirecast displays the document in the default
layout. The main elements of the Wirecast layout are labeled in the following screen
shot, and are described below.
Figure 7. The Default Wirecast Layout

Mode Selection Buttons

Preview Area

Menu Bar

Control/Status Bar

Final Mix Audio Panel

Live Broadcast Area

Open
Shot
Editor

Layers

Transition Controls

Go Button

Control/Status Bar
Control buttons and status information are displayed at the top of the default layout.
Wirecast displays the following controls and statistics:
Stream button
When clicked, Wirecast begins streaming.
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Figure 8. The Control/Status Bar
Recording Time

ISO Record Time

Record Button
Streaming time

Multiviewer/Secondary Live
Output Button

Stream button

ISO Record

Streaming time
Total cumulative time the document has been streamed. This value does not reset
when you start/stop the broadcast. If you save portions of the broadcast to disk,
Wirecast still displays the total cumulative time.
Record Button
Click to begin recording.
Recording Time
This displays how long you have been recording. This value does not reset when you
start/stop the broadcast. It is cumulative.
ISO Record
Click to begin ISO recording.
ISO Record Time
Displays the ISO recording time.
Multiviewer/Secondary Live Output Button
Opens the configuration window if you haven’t already configured your displays. Once
you've configured your displays, this button places the windows on your displays as
configured.
Display Buttons
These three buttons enable you to choose to display the Preview Area, the Live
Broadcast Area, or both in a divided display.
Note: To avoid decrease in video quality, Wirecast should not be used at CPU usage
above 80%. See the Telestream Website for suggested configurations. You can also
view streaming statistics by selecting Output > Show Statistics.
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Transition Controls
There are three Transition buttons. You can configure each to present one of many
possible transition types. Typically, the two configured transitions are: Cut and Smooth.
When Smooth is selected (button darkened), any transition executed by clicking Go is a
smooth transition.
Note: Preferences > General enables you to configure how many buttons you want
displayed (between 0 and 3).

Changing Transitions
Click the Cut button to make it the current transition type.
You can also select one of the two buttons by pressing Ctrl+1 or 2 keys for the two
transition types displayed.
If you click the down-arrow on the right side of any of the transition buttons, you can
select a new transition to assign to that button.

Go Button
When clicked, Wirecast executes the transition selected, broadcasts the shot selected,
and displays it in the Live Broadcast Area.
If AutoLive is enabled, the Go button appears with a red dot. When AutoLive is enabled,
simply selecting a shot--without clicking the Go button, broadcasts the shot.
With AutoLive enabled, clicking the Go button updates the live shot with any changes
you have made to it with the Shot Editor. If you have made no changes to the live shot,
clicking the Go button does nothing when Wirecast is in AutoLive mode.
With AutoLive disabled, you can make several changes to your broadcast without your
viewers seeing the change. This is most useful when an engineer runs your broadcast.
See Single-Click Switching with AutoLive and AutoLive.
See Selecting and Customizing Encoder Presets and Specifying the Transitions for the
Transition Buttons.

Mode Selection Buttons
Button containing green and red dots
When clicked, Wirecast displays both the Preview Area and the Live Broadcast Area.
Button containing green dot
When clicked, Wirecast displays the Preview Area.
Button containing red dot
When clicked, Wirecast displays the Live Broadcast Area.
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Note: These three buttons work the same as three of the options in the Layout Menu.
See Layout Menu.

Playlist Controls
Wirecast provides basic playback controls for playlists. The controls are located at the
bottom of the Playlist tab window and in the Source Properties tab for a selected playlist.
You can transition to the previous or next shot in the list, set playlist behavior, shuffle
the playlist order, and more.
See Source Properties Tab.
Figure 9. Playlist Controls

Total shots

Shuffle
Duration

Transition
Previous

Resume

Next

When Finished

Total Shots
Displays the total number of shots in the playlist.
Duration
Displays the duration of the playlist.
Resume
When checked, if you exit the playlist, when you return the playlist will resume playing
at the location (same shot) as when you exited.
Shuffle
Click to shuffle the order of the playlist shots.
Previous
Transitions to the previous shot in the playlist if the playlist is currently live.
Next
Transitions to the next shot in the playlist if the playlist is currently live.
When Finished
Sets the behavior of the playlist when the last shot in the list has been played. A check
mark indicates what menu item (behavior) is selected.
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• Loop transitions back to the first shot, endlessly.
• Hold stays on the last shot. If the last shot is a clip, the last frame in the clip is dis-

played. If the last shot is a live shot, the live source stays active. If the last shot in a
Playlist is a video clip Shot, it will obey the rules set for the video clip in the Media
Properties Inspector tab under Source Properties. However, it will hold the Playlist
on that last Shot if Set Playlist Behavior is set to “Hold”. Therefore, if you want to see
the last video in the Playlist pause on the last frame, you must set When Finished to
“Hold” under Source Properties, in addition to setting the playlist behavior to
“Hold”. If you set When Finished to “Loop”, under Source Properties, the last video in
the Playlist will continue to loop.

• Available Shots transitions to another shot on the same layer. All available shots are

listed as menu selections. (In the example shown, the only available shot is “Logo”.)

• Previous Live Shot transitions back to the shot that was live before the playlist began
playing.

• Current Preview transitions the contents of Preview to the Live Broadcast Area.
Transition
Sets the transition to use when switching between shots.

Replay Controls
When you select Replay + ISO > Start All, Wirecast displays the Replay controls, as
shown here:
Figure 10. Replay Controls

Create/Update
Replay shot

Elapsed time
Frame advance

Template selection

See Creating a Replay Shot from a Layer.

Playlist Countdown Timer Display
Wirecast displays a countdown timer below the Preview Area or Live Broadcast Area
whenever you play a video shot or playlist. If you play multiple video shots, click the
gear menu icon and select the shot to associate with the countdown timer.

Wirecast User Guide

Windows, Controls, and Menus
Preview Area

See Customizing the Playlist Countdown Timer.
Figure 11. The Playlist Countdown Timer

Countdown timer
Gear icon
Gear menu

Preview Area
Displays the selected shot as it would appear when broadcast, without broadcasting
the shot. When the shot in the Preview Area is selected, Wirecast outlines the preview
with a control frame for resizing and rotating the shot.
See Viewing the Preview Area, Viewing a Shot in the Preview Area, and Resizing or Rotating
a Shot.

Live Broadcast Area
The Live Broadcast Area shows the un-encoded shot currently being encoded and
broadcast. Also, you can play, pause, or scrub clips displayed in the Live Broadcast Area
while they are broadcast.
See Switching with Preview and Single-Click Switching with AutoLive.

Final Mix Audio Panel
The Final Mix Audio panel enables you to control the output volume level, mute audio
output, and mute the line-out feed for Preview and Live windows. The Preview and Live
Volume controls enable you to adjust the audio volume for Preview and Live separately.
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Figure 12. Final Mix Audio Panel

Preview Decibel scale
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The Preview Monitor
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The Final Mix Mute Button

The Preview Monitor Audio Button
When clicked, Wirecast mutes or un-mutes Preview playback on your computer
speakers or headphones.
The Monitor Preview Audio button and the Monitor Final Mix Audio buttons control
whether you hear the output audio through your headphones or computer speakers.
These do not affect what your viewers can hear. You can monitor Preview or Final, but
not both at the same time. You can mute both.
If you do not want to broadcast audio, modify the encoder presets to not process audio
through the encoder.
See Encoder Presets.
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The Final Mix Monitor Audio button
When clicked, Wirecast mutes or un-mutes Final Mix playback on your computer
speakers or headphones.
The Monitor Preview Audio button and the Monitor Final Mix Audio buttons control
whether you hear the output audio through your headphones or computer speakers.
These do not affect what your viewers can hear. You can monitor Preview or Final, but
not both at the same time. You can mute both.
If you do not want to broadcast audio, modify the encoder presets to not process audio
through the encoder.
See Encoder Presets.
Note: All Wirecast audio meters use a consistent dBFS scale. Whether you're viewing
Multiviewer audio bars or the Advanced audio Meter, the readings use the same scale.
Level indicators turn yellow when they hit -6dB and red when they move above -1dB.
All indicators show when audio is clipping by turning yellow or red.
See Controlling or Muting the Final Audio Mix Level and Displaying or Hiding the Final Mix
Audio Panel.

The Final Mix Mute Button
When clicked, Wirecast mutes or un-mutes the Final Mix output.
The Final Mix Mute button controls what your viewers hear. You can quickly mute all
your audio output with this button. This is great for quickly muting audio on your
regular broadcast. When you mute the final mix audio, the encoder still generates
audio, but the output gets muted for all program audio (except ISO-recorded sources).
If, alternatively, you do not want to broadcast audio at all, it's better to modify the
encoder presets to not process audio through the encoder, which will save system
resources.
See Encoder Presets.

Wirecast User Guide

114

115

Windows, Controls, and Menus
Layers

Layers
Figure 13. Layers
Duration

Shots

Tabs
Layer

File name
Document Hotkey

The horizontal bars towards the bottom of the screen are the layers. You can make
more layers visible. Also, you can add, modify, and play shots from the layers.
By default, Wirecast displays five layers. Each layer can contain multiple shots. A red LED
indicates that a shot is Live.
Wirecast allows you to put shots on any of the layers. Layering shots enables Wirecast to
superimpose them, from the lowest layer to the highest, to form a single visual image
during broadcast.
By default, Wirecast displays five layers. Each layer contains shots that can be selected
by clicking a shot. A red LED indicates that a shot is selected. When a shot is selected it
is displayed in the Live Broadcast Area. If you select multiple shots (by selecting a shot
on more than one layer) Wirecast displays all of them in the Live Broadcast Area.
Wirecast displays Layer 1at the top, Layer 5 at the bottom, and the other layers, in order,
between them. The order of layers determines the order of superimposition in the Live
Broadcast Area. If you place a video shot on Layer 5 and a title on Layer 1, Wirecast
superimposes the title over the video.
See also Viewing a Layer in a Layer Window.
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Add Shot Window
The Add Shot window provides a way to add sources, such as live sources, file sources,
the Remote Desktop Presenter program, shot graphics, shot audio, and shot templates.
Click the Plus Button (+) to open the Add Shot menu.
When Wirecast displays the Add Shot menu, select a shot category, select the type of
shot to add. Modify the shot if desired and allowed. To add a shot to a layer, click the
Add “+” button in a layer.
To add a source to the Favorites menu, select the source and click the star icon.
Wirecast changes the color of the star to white and adds the source to the Favorites
menu.

Video Capture
System Device
Select a system device.
See NDI Devices in the Shot Layer Properties Tab.
Wirecast Gear Inputs
If you using Wirecast Gear (and have an active license) all available video inputs will be
listed. If you are using Wirecast Gear 300/400 series hardware, the Wirecast Gear Video
Inputs appear in the Shot Selection menu.
After a WC Gear shot is created, you can set up the shot using Wirecast Gear controls.
Audio Input
Select the audio input (if any) from the pull-down menu.

Audio Capture
System Device
Select a system device.
See NDI Devices in the Shot Layer Properties Tab.
System Audio Capture
Select an audio capture device.
Source Name Displays the name of the source. To change the source name, enter a
new one.
Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay the audio
signal to sync it up with a video source.
Monitor Click the Monitor icon to cause audio to play through your monitor output.
The icon is gold when selected (turned on). If unselected, audio will not play through
the monitor output for this source. Selected is the default.
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ASIO and WASAPI Sources
Select an ASIO audio capture device and click the Add button.
Any ASIO or WASAPI source on your local network will be discovered by Wirecast and
listed under Capture Devices in the Source Input Menu. These devices are generally
used with multi-track audio outputs. ASIO Audio Capture is a very low latency
professional audio capture API. It is used to connect to professional audio interfaces.
WASAPI Audio Capture is also a low latency audio capture API. It replaces the old
DirectShow-based audio capturing.

Media Files
Browse Disk
Select to navigate to a media file.
Stock Media Library
Select to display the Stock Media Library window.
A Media File is a video clip or a picture. To open a Media File source, select Media Files
from the source menu in the shot window, and then navigate to your file. You can also
click the Add Media File button at the bottom of the Add Shot window.
Media Files have the following settings:
Source Name
Displays the name of the source. To change the source name, enter a new one.
In Point
Click Jump to move the play head to the In Point in the media file. Set the In Point either
by dragging the In Point icon to the desired beginning position on the play bar, or by
entering a value into the In Point field.
Out Point
Click Jump to move the play head to the Out Point in the media file. Set the Out Point
either by dragging the Out Point icon to the desired end position on the play bar, or by
entering a value into the Out Point field. The green triangle shows the current location
of the Play Head.
Figure 14. In Point and Out Point Icons
In Point icon

Out Point icon

Playhead

When Finished
Select what happens when the media finishes playing. Loop causes the media to begin
playing again. Hold causes the media to stop and hold the last frame in the Live
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Broadcast Area. Remove causes the media to be removed from the Live Broadcast Area
when it finishes playing.
Begin playing when media becomes Live
When checked, the media begins playing as soon as it is made Live.
Remember position even when not Live
When checked, the media will always start playing where ever it was playing when it
was stopped, even if it was removed from the Live Broadcast Area and made Live again.
When unchecked, the media will start from the beginning every time it is taken Live.
Set Default
Click to set the media display to default settings.
Live Playback
Changes are live. When you select this option and your shot is live, Wirecast displays
any action you take in the Preview Area--such as playing, pausing or scrubbing--in the
Live Broadcast Area, and broadcasts the action live.
Note: If you use this feature to pause or scrub media in the live broadcast, it's usually
best to uncheck Begin playing when media becomes live.

Stock Media Library
When clicked, Stock Media Library opens the Stock Media Library window.
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Figure 15. Stock Media Library Window

Left/Right arrows

Search

Source Type

Source Type
You can toggle on/off any type of media to include in the display: Video, Images, and
Audio.
Search
Enter key words to display just the media files including these words. The display is
updated as your enter words.
Left/Right arrows
Click the arrows to move to the next or previous set of Stock Media files.
Play button
Click to begin playing the selected media file.
File marker
Move the marker to view the media file quickly.
Download button
Click to download the selected media file into a shot.
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See Adding Media Files from the Stock Media Library to a Shot.

Network
iOS Cam
Select an IOS Camera device, or an iOS camera through the Wirecast Go iOS app.
Rendezvous
Select to create a new Rendezvous session, or select to reconnect to a previously
created session.
Web Page
Creates a new web page shot.
See Web Page Properties.
Web Stream
Creates a new Web Stream shot.
See Web Stream Properties.
NDI(R) Source
Select any NDI-capable devices on your network.

Web Page Properties
Web Page shows a web source defined by a web address (URL). To open a Web Page
source, select Web Page from the source menu in the shot window. Web Page
Properties have the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
URL
Displays the web address (URL) of the source. To change the address, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Go Back/Go Forward
If you have enabled Interaction on your web page, these buttons allow you to go back
or go forward just as you would in a browser.
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Transparent Background
Check to make the background transparent in your shot.
Shutdown when inactive
Check to turn off the audio and disable it from the shot when playing videos.
Override CSS
Enter Cascading Style Sheet code to override the default code for this web display.
Interaction
Allows you to choose how you want to interact with your web page in the Preview
window. Choices are Never, Always, or On Double-click.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Web Stream Properties
The Web Stream option allows RTMP, RTSP, MMS, or HTTP streams to be taken directly
into Wirecast. This is useful for incorporating remote IP Cameras or other network
streams into a broadcast. Sources are automatically detected and are also identified by
IP Camera Profile. To open a Web Stream source, select Web Stream from the source
menu in the shot window.
Web Stream Properties has the following settings.
Name
Displays the name of the source. To change the Name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
URI
Enter the address of your input stream. (For example: rtsp://127.0.0.1:8080/
my_stream.sdp, or http://10.0.0.1/my_stream, or rtmp://hades.telestream.net:1935/live/
myStream).
Username
Enter your username for your URI stream.
Password
Enter your password for your URI stream.
Buffer
Enter a buffer time in seconds.
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Reconnect
Click to reconnect the Web Stream source.
Apply
Click the Apply button to update any changes.
Timestamps
Select Provided by source, or Provided by Wirecast.This setting allows you to use
timestamps embedded in the source, or use timestamps generated by Wirecast.
Timestamps are used to synchronize devices. Many sources don't provide completely
accurate timestamps, resulting in sources out of sync with each other (i.e. audio and
video not syncing).
Select Provided by Wirecast to ignore the timestamps coming from the source, and
instead generate new timestamps. However, the risk is that if the system is under a
heavy load, the generated timestamps could be impacted, and end up arriving late. The
default setting is Provided by source.
Deinterlacing
Select None, or Blend Fields.
Dynamic Range
Select Default, Full or Limited.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Screen Capture
Remote Desktop Presenter
Creates a new Remote Desktop Presenter shot.
See Remote Desktop Presenter Properties.
Screen Capture
Creates a new Screen Capture shot of any monitor or window on your computer.
See Screen Capture Properties.
Note: When in screen-capture mode, some apps take control of your mouse and
make the cursor invisible. To reduce the capture window size and regain use of your
mouse, press Alt + Tab.

Remote Desktop Presenter Properties
The Remote Desktop Presenter (RDTP) is a utility application that enables Wirecast to
broadcast the desktop of any computer running the Telestream Desktop Presenter
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program. To open a Remote Desktop Presenter source, select Remote Desktop Presenter
from the source menu in the shot window.
Remote Desktop Presenter is normally auto-detected by Wirecast and is automatically
added to the list of sources. However, if a RDTP is not detected, or if you want to add
one in a remote location you can manually add it by selecting New Remote Desktop
Presenter from the Source menu in the default layout.
Remote Desktop Presenter Properties have the following settings.
Source Name
Displays the name of the source. To change the Source Name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
IP Address
Enter an IP address of the target computer.
Enable Audio When checked, the audio from the remote desktop is enabled.
Apply
Click the Apply button to update any changes.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Screen Capture Properties
A Screen Capture displays any monitor or window on your computer. To open a Screen
Capture source, select Screen Capture from the source menu in the shot window. Screen
Captures have the following settings.
Name Displays the name of the source. To change the source name, enter a new one.
Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Capture Video Check to enable Capture Type, Show Cursor, and fps settings (described
below).
Capture Type Select Monitor (captures your entire monitor), Window (captures the
currently selected window), or Game (captures the game currently played on your PC).
If you select Game, you can also configure how your game is captured by selecting
options offered under Select Window/Monitor (described below).
Anti Cheat Support Enables anti-cheating support for game capture.
Show Cursor Check to show the cursor in your streaming. Uncheck to hide it.
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fps Select the FPS, from 10 to 60 frames per second as the capture rate. An FPS of 60 is
the best frame rate, but it requires greater streaming bandwidth.
Capture System Audio Check to capture system audio when streaming. Uncheck to
mute the audio.
Select Window/Monitor Click the Configure button to display the Select Window
dialog. If you selected Game for your Capture Type, Wirecast displays a configuration
window with the following options:
– Capture Any Full Screen Game Check this box to automatically capture a game
running in a full monitor screen, or running in a full screen of a window.
– Support Multiple Video Cards/SLI Check this box if you have a Windows system
with multiple discrete GPUs and are experiencing problems capturing a game.
(Performance of the capture may be slower than when running on a single GPU.)
– Capture Third Party Overlays Check this box to capture overlays rendered on
top of a game that are generated by applications external to the game. (For
example, the Steam in-game overlay.
Choose Audio Device Click the Configure button to display the Select Audio Device
dialog, then select an audio device from the drop-down menu.
Note: Some apps, when screen captured, take control of your mouse and the cursor is
not displayed. You can, at any time, press Alt + Tab keys to reduce the capture window
size and enable you to use your mouse.
Dynamic Range Select dynamic range setting: Default, Full or Limited.
Monitor Click the Monitor icon to cause audio to play through your monitor output.
The icon is gold when selected (turned on). If unselected, audio will not play through
the monitor output for this source. Selected is the default.
See Screen Capture.

Overlays
Clock
Creates a shot that displays time.
See Clock Properties.
Image Carousel
Creates a new Image Carousel shot that shows a sequence of images.
See Image Carousel Properties.
QR Code Generator
Creates a QR code display to present to your viewers in a live broadcast.
See QR Code Generator Properties.
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Scoreboard
Creates a new Scoreboard shot.
See Scoreboard Properties.
Social Media Title
Opens a selector for Social Media Titles.
See The Comment Moderation Window, and Social Media Shots.
Text
Creates a new Text shot.
See Text Shot Properties.
Title
Opens a dialog for adding titles and lower thirds. In the dialog, you can see the
available title designs in a continually growing library of title designs. You can search for
a title and filter your search using various criteria. You can preview the intro and outro
animation, and you see how the title fits on the screen.
You can revise titles in your project in the Title Properties tab.
If your project contains titles made with earlier versions of Wirecast, those legacy titles
continue to appear in your project. To access the legacy titles, click the three dots in the
upper-right corner of the Add Source dialog, and choose Display Deprecated Sources.
Wirecast displays the names of animated titles with Title... at the beginning. Wirecast
displays the names of legacy titles with Title (legacy) at the beginning.
See Titles (Animated) Properties.

Text Shot Properties
Text displays a text phrase. To open a Text source, select Text from the source menu in
the shot window. Text Properties have the following settings.
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
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check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
File
Click the (...) icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
Update frequency
Enter the number of seconds between updates.
Keep reading text file
Check to keep reading the text file for changes.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
Face
Select the font style from the list of combination of bold and italic.
Size
Enter the font size. Click the gear icon to select the type of font size: small, medium,
large, etc.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
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Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.

Titles (Animated) Properties
A title is text displayed in a banner window. Wirecast offers a wide variety of animated
lower thirds and titles. To open a title source, select Title... from the Add Source menu.
Animated titles have the following settings:
Left/Right arrows
Click to view the previous page, or next page, of titles.
Search
Enter name of title desired.
Filters
Click to open options for filtering your view of the titles.
Scale to Fit/Show Preview
Click to view either the title scaled to the whole screen or placed in its live position.
Tags
Displays identifying tags for the title.
Lines of Text
Displays the number of lines of text in the title.
Custom Colors
Displays the number of custom colors in the title.
Intro Duration
Displays the length of the intro animation.
Animate Intro
Click to preview either the intro animation.
Outro Duration
Displays the length of the outro animation.
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Animate Outro
Click to preview the outro animation.
Note: Some title styles have customization sections for Subhead 1 and Subhead 2.

Title (legacy) Properties
Note: To access legacy titles, in the Add Shot dialog, click the three vertical dots at the
top right corner of the box. Then select Show Deprecated Sources.
Legacy titles have the following settings:
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
File
Click the “...” icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
Update frequency
Enter the number of seconds between updates.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
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Face
Select the font style from the list of combination of bold and italic.
Size
Enter the font size. Click the gear icon to select the size of font.
Style
Select any combination of Bold, Italic, All Caps, by toggling each button.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
On Change
Select transition type: Fade, Drop In, Drop Out, and Slide. Enter the length (in seconds)
of the transition time.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Direction
Select the direction of the scrolling: Top to Bottom, Bottom to Top, Left to Right, or
Right to Left.
Speed
Enter the speed (in pixels per second) that you want your message to scroll through the
display.
Auto Reverse
When checked, the display reverses the scrolling direction when it reaches the top or
bottom of the list.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
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Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text

Twitter Feed (legacy) Properties
Twitter Feed displays a list of Twitter messages.
Note: To access legacy Twitter feed posts, in the Add Shot dialog, click the three
vertical dots at the top right corner of the box. Then select Show Deprecated Sources.
Twitter Feed Properties have the following settings:
Name
Displays the name of the source. To change the source name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
File
Click the “...” icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
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Update frequency
Enter the number of seconds between updates.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
Face
Select the font style from the list of combination of bold and italic.
Size
Enter the font size. Click the gear icon to select the size of font.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.
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Scoreboard Properties
PRO

Scoreboards allow you to add a scoreboard graphic to your broadcast that can be
dynamically updated. Multiple scoreboards can be added. Unlike most other elements
in Wirecast, changes to the Scoreboard go live instantly without requiring a transition.
Once the scoreboard is live, the preview image is exactly as it is seen in your broadcast.
To open a Scoreboard source, select Scoreboard from the source menu in the shot
window.
Scoreboards Properties have the following settings.
Source Name
Displays the name of the source. To change the Source Name, enter a new one.
Scoreboard
Select how the scoreboard will look using two drop-down menus. The upper menu
selects the scoreboard style: Pipe, Shade, Corner, etc. The lower menu selects how the
display fields are laid out: Basic, Right Stats, or Bottom.
Home/Visitor/Score
The Home, Visitor, and Score fields contain the home and visitor team names and their
current score. The three icons to the right of these fields control the text alignment, font
size, and font color. Click on each icon to open its control window.
BG Color
Sets the background color for the Home or Visitor field display. Click the color icon to
open the control window.
+1, +2, +3
Click these score increment buttons to increase the Home or Visitor score display.
Field 1-4
Displays information inside the scoreboard depending on the layout chosen using the
Scoreboard menus. The three icons to the right of these fields control the text
alignment, font size, and font color. Click on each icon to open its control window.
Use a Custom Image
Check to enable the Choose button.
Choose
Click to navigate to the location of your custom image.
Reset
Click to remove a custom image.
Note: Because Wirecast updates the scoreboards dynamically, It is recommended
that you fill in the additional information fields while using a layout that hides them.
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Then, change to a layout that reveals those fields when ready, otherwise your viewers
see you typing in those fields live.
There are four keyboard shortcuts associated with the Scoreboard.
Table 2. Scoreboard
= Increments Home
score
- Decrements Home
score
] Increments Visitor
score
[ Decrements Visitor
score
In order for these keyboard shortcuts to be active, the scoreboard must be displayed in
the Live Broadcast Area and the Wirecast default layout must be in focus (selected as the
active window).
See Application Shortcuts and Document Hotkeys.

Clock Properties
A Clock shot displays time. Clock Properties have the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Clock Modes
Select Clock, Countdown, or Stopwatch.
Figure 16. Clock Modes

Stopwatch mode
Countdown mode
Clock mode

Clock Mode:
Date Select a date display format.
Time Select a time display format.
Countdown Mode:
Mode Select Countdown from or Countdown to.
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Start Time
Enter the time value from which to start counting.
Start/Stop/Resume and Reset
Click Start to start the counter. When counting, click Stop to stop the counter. When
stopped, click Resume to start counting again, or click Reset to rest the counter.
Automatically Start
When checked, the counter will start when the shot is taken live.
Format
Select one of the time-display formats from the drop-down menu.
Start, Stop, Reset
Click Start to begin counting down. Click Stop to end counting down. Click Reset to
reset clock to Timer value.
At Zero
Select either Stop at 00:00 or Start count up clock.
Stopwatch Mode:
Start, Stop, Reset
Click Start to begin counting. Click Stop to end counting. Click Reset to reset stopwatch
to zero.
Display Format
Select time elements to display: Hours, Minutes, Seconds, and Fractional Seconds.
Font
Select font from drop-down menu.
Face
Select face from drop-down menu.
Size
Click the gear icon to select the font size from the menu.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
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Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.

Image Carousel Properties
An Image Carousel shot shows a sequence of images. Image Carousel Properties have
the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Change Every
Sets how often the images are changed, in seconds.
Fade-In Time
Sets how long it takes for each image to fade in, in seconds. Enter zero for
instantaneous display of images.
Shuffle Images
Check to shuffle the display order of the images. When unchecked, images are
displayed as they are ordered in the image list.
Add/Delete/Move Images
Click the plus (+) button to find and add images. Select an image on the list and click
the minus (-) button to delete it. You can move images up and down the list by
selecting an image and clicking the up or down arrow.

QR Code Generator Properties
QR Code Generation has the following settings.
Source Name
Displays the name of the source. To change the source name, enter a new one.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Content
Enter the message you want to be embedded in the QR code displayed in your
broadcast.
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Deinterlacing
Select None, or Blend Fields.

Backgrounds
Web Page
Creates a new Web Page shot.
See Web Page Properties.
Solid Color
Creates a new Solid Color shot.
See Solid Color Properties.

Solid Color Properties
Solid Color displays a solid color background. To open a Solid Color source, select Solid
Color from the source menu in the shot window. Solid Color Properties has the
following settings.
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.

Templates
Shot Template
Select Templates from the Add Shot menu.
When Wirecast displays the Templates window, select a template.
Wirecast displays the new template shot in the Shot Editor.

• Placeholder Shot
See Assigning Media to Placeholders.

• Virtual Set Properties
PRO
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A Virtual Set is a pre-built source set, complete with graphics, that simulates a newsanchor set. For example, you can select a virtual set that displays three layers of decor
with two live sources. You can use virtual sets as they are, or you can customize them to
meet your needs.
Virtual Sets has the following setting.
– Source Name Displays the name of the source. To change the source name,
enter a new one.

The Shot Editor Window
The shot editor has six tabs: Shot Layers, Shot Layer Properties, Audio, Chroma Key
Properties, Smooth Transition Properties, and Source Properties.
Figure 17. The Shot Editor Window
Shot Layers tab
Shot Layer Properties tab
Audio Properties tab
Chroma Key Properties tab
Smooth Transition Properties tab
Source Properties tab

Shot Layers
Enables you to add and delete sources and to change the display order (layering within
the shot).
Shot Layer Properties
Enables you to change the size, position, and other properties of a shot.
Audio
Enables you to set and monitor the audio level.
Chroma Key Properties
Enables you to configure the source chroma key settings. Each source in a shot can
have its own chroma key settings.

Wirecast User Guide

Windows, Controls, and Menus
The Shot Editor Window

Smooth Transition Properties Tab
Enables you to set transition properties.
Source Properties (...) Tab
Enables you to set properties for a source in your shot.
Note: The title of the Source Properties tab changes with the type of shot selected. For
example, when you select a playlist shot, the title of the Source Properties tab becomes
Playlist Properties.

Shot Layers Tab
The Shot Layers tab lists all of the layers in the shot.
Note: Source icons appear only when you hover over them.
Figure 18. The Shot Layers Tab
Add or remove
source

Select source

Move up or
down
Manage layers

Click the eye or
speaker icon

See Adding, Deleting, or Rearranging Layers in a Shot.

Replay Layer
PRO

The Replay Layer is a placeholder layer that can be added to any shot for the purpose of
creating a Replay Template Shot. Once the shot is selected in the Replay Settings it can
be used as a template for any created Replay Shot.
See Creating a Replay Shot from a Layer.
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Shot Layers Properties Tab
The Shot Layer Properties tab enables you to make adjustments to the sources in your
shot.
Figure 19. The Shot Layer Properties Tab

Gear icon
Scale jog wheel
Scale to Fit & Reset Position

Rotation sliders
Opacity slider
Reflection slider
Matte selector
Crop arrow
Crop adjustments
Crop reset button
Color arrow
Color adjustments

Color reset button
Drop Shadow arrow
Check to enable
Drop Shadow
adjustments
Defaults and Reset buttons

Click PTZ arrow
Recall a PTZ preset
Click to open PTZ control panel
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Position
Displays the position of the selected source in your shot. Position “0 0” represents the
middle of the shot area. To move a source, enter new location values.
Size
Displays the size of the selected source in your shot. To resize a source, enter new size
values.
Gear icon
Click and select how to size you bounding box: by pixels or percentage.
Scale Jog Wheel
Click and move the jog wheel to change the scale of your bounding box.
Scale to Fit Button
Click to expand the source to its maximum size on the canvas. This may distort the
display of the source depending on what you have selected in Fill (below).
Reset Position Button
Click to force the source to return to its original size (scale) and rotation positions.
Fill
Select the way the scaling fills the bounding box:

• Lock Aspect Ratio: Fills the bounding box until one side hits the edge. Will respect
the aspect ratio, and will not crop your media.

• Lock and Fill Width: Fills the bounding box to its width. Will respect the aspect

ratio, so media may end up being obscured top to bottom if your bounding box
height is less than the media height (or will have letterboxing if bounding box is
larger).

• Lock and Fill Height: Fills the bounding box to its height. Will respect the aspect
ratio, so media may end up being obscured on the sides if your bounding box
width is less than the media width (or it will have pillar bars on either side if the
bounding box is larger)

• Stretch to Fill: Fills your bounding box, does not respect aspect ratio of media, so
may end up distorting your media.

Note: The Fill feature is not active in Clock, Text, Solid, QR Code or Web Page shots. In
these shots the image automatically stretches to fill the bounding box.
X Y Z Rotation
Slide the X (Horizontal), Y (Vertical), or Z (Straight-through) axis sliders to rotate the
source. (See also Reset Position below).
Opacity
Slide the Opacity slider to adjust the degree of transparency of your image.
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Reflection
Slide the Reflection slider to adjust the degree of reflection below your image.
Matte
A Matte is a mask over a shot. Select a matte by clicking the down-arrow on the Matte
menu. Default is No Matte. You can also use any media file as a custom matte. To do this,
create a new shot of the media file you want to use as a matte. This file now appears in
the Matte drop-down menu where you can select it.
Crop
Click the Crop triangle to open the cropping adjustment pane. Slide the Left, Right, Top,
and Bottom sliders to crop your source image.
Reset
Click the Reset button to reset the crop controls to their default settings.
Color
Click the Color triangle to open the color adjustment pane. Slide the color controls to
adjust the color.
Reset
Click the Reset button to reset the color controls to their default settings.
Drop Shadow
Click the Drop Shadow triangle to open the Drop Shadow adjustment pane. Check the
checkbox to enable the controls.

– Color Click in the color field to open the color palette. Select a shadow color and
luminance by sliding the vertical and horizontal sliders. Click outside the color
edit box to close the palette.

– Angle Move the Angle slider to adjust the direction (0 to 360 degrees) the
shadow text is offset from the actual text.

– Offset Move the slider to adjust the distance the shadow text is offset away from
the actual text.

– Opacity Slide the Opacity slider to adjust the degree of transparency of your
source.

– Blur Size Move the slider to adjust the amount of blur in the drop shadow.
Use As Defaults
Click to set the current drop shadow configuration as the default setting. All future
enabled drop shadows will be set this by default. Clicking this button does not
retroactively update previously created shots. Drop shadow settings on individual
shots can still be changed.
Reset
Click to restore the drop shadow settings back to the default values. You can also
restore the drop shadow settings to Wirecast application defaults by holding the Shift
key down and clicking Reset.
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PTZ
Click the PTZ triangle to open the PTZ control panel.
Preset
Click the up and down arrows to find a PTZ preset to recall, then click the Right Pointing
Arrow button to recall the preset.
Show PTZ Controller
Click to display the PTZ Controller panel.
See The PTZ Controller Panel.

PTZ Control in the Shot Layer Properties Tab
You can select PTZ Controller presets associated with a shot layer video source from the
Shot Layer Properties tab of the Preview Inspector. You configure PTZ Control Presets in
the PTZ Controller Panel.
To expand the PTZ control panel, click the PTZ triangle. To enable preset recall, check
the Enable box. To select a preset, enter a preset number or click the up/down arrow
buttons. Click the Go button (right pointing arrow) to cause the associated PTZ camera
to recall that preset.
Once you have configured a shot layer with a PTZ Preset, sending that shot to preview
recalls the preset for the camera. If multiple shots share the same video source with
different PTZ Presets configured, the shot which is currently live takes precedence over
subsequent PTZ Preset recall actions, until you drop the shot from the live feed.
When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel.
See Shot Layers Properties Tab.

NDI Devices in the Shot Layer Properties Tab
If you have selected an NDI source, the NDI Source Properties tab will display. In
addition to the controls above, an NDI source has the following controls.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Bandwidth
Select the bandwidth to use: Highest (max quality), Lowest (max efficiency), or Audio
Only (video bandwidth not applicable).
GPU Decoding
When checked, incoming sources will use your GPU to process the incoming source.
Timestamps
Select Provided by source, or Provided by Wirecast.This setting allows you to use
timestamps embedded in the source, or use timestamps generated by Wirecast.
Timestamps are used to synchronize devices. Many sources don't provide completely
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accurate timestamps, resulting in sources out of sync with each other (i.e. audio and
video not syncing).
Select Provided by Wirecast to ignore the timestamps coming from the source, and
instead generate new timestamps. However, the risk is that if the system is under a
heavy load, the generated timestamps could be impacted, and end up arriving late. The
default setting is Provided by source.
Deinterlacing
Select None, or Blend Fields.
Dynamic Range
Select Default, Full or Limited.
Monitor
Check the Monitor check box to cause audio to play through your monitor output. If the
check box is unchecked, audio will not play through the monitor output for this source.
Checked is the default.
Note: NDI networking requires that your network has port 5353 open for mDNS
device discovery, as well as one port per video channel (starting from port 5960 and
onward) transmitted by an NDI source, plus one additional port for messaging.
See Adding NDI™ Sources.

Audio Properties Tab
The Audio Properties tab enables you to control and monitor audio. You can set the
audio level, mute and monitor the audio, and map channel outputs.
Figure 20. The Audio Properties Tab
Volume slider
Pan control
Meter display
Speaker icon
Map button

Volume
Adjust the slider to set the audio volume level.
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Pan
Adjust the slider to pan between left and right audio.
Meter
Monitors the audio level. You can also mute the audio by clicking the audio icon.
Speaker Icon
Click to mute the audio output. Icon turns gray when muted. Click the icon again to unmute the audio.
Channels
Select left (L) or right (R) for each channel. Adjust volume slider for each.
Apply to All
Click to apply the current settings to every instance of the selected source. If you have
any shot specific configurations in other shots, they will be changed to match what was
configured when you click this button. This action cannot be undone!
Set as Default
Click to take the current settings and set them as the default configuration. Any time
this source is added to a shot in the future, it will be created with this configuration.
Reset
Click to reset the default settings. This is useful if you have made changes to the default
custom settings, but want the defaults set back to the factory default settings. Factory
defaults are: Chan 1 = Left; Chan 2 = Right; additional channels are unassigned.
Map
Click to open the audio mapping window. Check a square to map an audio channel to
an audio track. Any audio can be tracked to any or all tracks. However, you will typically
assign a group of channels to one track and other groups to other tracks.
If you have created a shot using a 16 input device, the mapping window will display all
16 channels.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.
The audio track that is actually used is selected from the Audio Track menu in the
Output Settings window. You can select only one track. However, if you are recording,
you can select multiple audio tracks.

Chroma Key Properties Tab
Chrome Key (also called “green screen”) enables you to replace all green areas of your
display (or any other color you choose) with a background image. For example, if you
are in front of the traditional green screen, by “keying out” the green and leaving the
background transparent, you will appear to be in front of your background.
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The Chroma Key Properties tab enables you to turn on/off chroma keying and make
chroma key adjustments. Check the Use box and+ select the type of use: Chroma,
Luma, or Color Key.
Use
Check to turn on chroma keying. Uncheck to turn it off. Select the type of use: Chroma,
Luma, or Color Key.
Color
Click the color square to open the Color Pallet. Select a color to use as the chroma key
color and click OK. Click the dropper icon to use your mouse to select a chroma key
color from your screen. Hover over the a desired color in the selected source, and click
the left mouse button to select that color. All adjustments will be made using the
selected color as the key.
Key Threshold
Move the slider to adjust how far away from your chosen chroma color you want to
enable keying. The farther right you move the slider the more variation to the color it
accepts.
Black Clip
The Black Clip slider allows you to define what is considered “black”. When slider is fully
left, you have a very thin definition of what black is. The farther to the right you go, you
start adding more cases of what we consider “black'”. In chroma key, rarely do you want
to bump the far left side to the right.
White Clip
The White Clip slider allows you to define what is considered “white”. Slide both all the
way to the right, for a very thin definition of white. The more you increase the range,
the more you add to what you consider to be full intensity brightness. In chroma key,
rarely do you want to bump the far right side to the left.
Spill Suppression:
This slider says: anything that is near green, bump it away from green. Move this slider
to help take away the green reflection it locates on an edge. This will take everything
that's green, and take away its greenness.
Solidify:
This slider says: if all the pixels around me seem to be part of the key, then bump up my
probability of being part of the key. This tends to “solidify” your key. Move the slider to
the right to bump up the alpha values for pixels surrounded by high alpha values. One
disadvantage is that the hair on a subject may appear more “blocked” in nature.
Edge Coloring
Move the slider to adjust the level of edge coloring which pull colors from inside of
keyed object to get rid of halo on an image.
Display
Select display: result of keying, white-alpha channel, or black-alpha channel. This can
be helpful to get key parameters set correctly.
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Luma Key
This lets you key based on its brightness (or Luma value). You have an icon with a white
background - and you want to get rid of the white background.
Color Key
This lets you set the image alpha based on the distance from a given color in the RGB
space. This is useful for images (logos) that have non-black and non-white
backgrounds. If the BG is black or white use Luma Key. If it's a plate from a greenscreen/
bluescreen then use Chroma Key. Otherwise, try Color Key.
Alpha Clip
This lets you choose what distance from the key color should be considered
“foreground.” Anything over a given distance from the key color is “foreground”
otherwise it's “background”. A range is used so there is a smooth transition from
foreground to background.

Smooth Transition Properties Tab
The Smooth Transition Properties tab provides control over how objects (image, movie,
title, etc.) are added or removed in the Live Broadcast Area. Wirecast performs motion
only during a Smooth transition. If you are using any other transition, the motion
settings are ignored.
There are two types of motion. When an object is added to your broadcast it is called
Build In; When it is removed it is called Build Out. Motion only occurs when an object
enters or leaves the Live Broadcast Area. For example, if you have two shots, each with a
foreground and the media in the foreground is the same, then a Smooth transition is
performed between the foregrounds. However, no motion is performed. Or, if a logo is
positioned in the top left corner in an existing shot, and it is in the bottom right corner
in a new shot, when you make the new shot Live the logo smoothly transitions from the
top left corner to the bottom right corner. But the Build In and Build Out settings are
ignored.
However, if you have two shots with a Foreground, but the media in each is different,
the Build Out is performed for the existing shot, and the Build In is performed for the
new shot.
Direction Menus
These provide selections of where the Build In comes from (top, bottom, right, etc.)
when it is added, and where the Build Out goes when it is removed.
Fade In / Fade Out
Checking these checkboxes causes an object to be added or removed gradually. If
unchecked, the object is instantly added or removed, much like a cut transition.
Spin In / Spin Out
Checking these checkboxes causes an object to be added or removed in a spinning
fashion.
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Scale In / Scale Out
Checking these checkboxes causes an object to be added or removed in a scaled
fashion.
Apply To All
Click this button to make the Transition Settings the same for all sources in a shot. This
is useful if you want to make all of your motion the same for all of the elements in the
shot.
Set As Default
Click this button to make these Transition Settings the default settings for all new shots.
These default settings will be applied in all future WC documents.

Source Properties Tab
The Source Properties tab provides control over clip properties and behaviors. When a
playlist is selected, the Source Properties tab also provides playlist controls.
See also Playlist Controls and Playlist Properties Tab.
Name
Clip filename, editable.
In Point/Jump
Enter the timecode for the in-point desired. Click Jump to bring the playhead to the inpoint.
Out Point/Jump
Enter the timecode for the out-point desired. Click Jump to bring the playhead to the
out-point.
When Finished:
Options in the drop-down menu determine Wirecast behavior when the live clip is
done playing, as follows:
Table 3. When Finished
Loop

Hold

Remove

With no options checked

With no options checked

With no options checked

Wirecast replays the clip from its Wirecast holds on the last frame. Wirecast drops the clip from the
beginning.
If it’s an audio-only clip, Wirecast live playback window.
holds on silence.
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Table 3. When Finished
Loop

Hold

Remove

With Begin playing when
media becomes Live checked

With Begin playing when
media becomes Live checked

With Begin playing when
media becomes Live checked

When the clip goes live, Wirecast When the clip goes live, Wirecast
plays the clip from the clip
plays the clip from the clip
beginning.
beginning, and holds on the last
frame.

When the clip goes live, Wirecast
plays the clip from the clip
beginning to the end, then
drops the clip from the live
playback window.

With Begin playing when
media becomes Live and
Remember position even when
not Live checked

With Begin playing when
media becomes Live and
Remember position even when
not Live checked

With Begin playing when
media becomes Live and
Remember position even when
not Live checked

When the clip goes live, Wirecast When the clip goes live, Wirecast
plays the clip, starting after the plays the clip, starting after the
last frame previously played.
last frame previously played,
and holds on the last frame.
Wirecast doesn’t restart the clip
until you uncheck this option.

When the clip goes live, Wirecast
plays the clip, starting after the
last frame previously played, to
the end. Then Wirecast drops
the clip from the live playback
window.

With Begin playing when
media becomes Live,
Remember position even when
not Live, and Live Playback:
Changes are live checked

With Begin playing when
media becomes Live,
Remember position even when
not Live, and Live Playback:
Changes are live checked

With Begin playing when
media becomes Live,
Remember position even when
not Live, and Live Playback:
Changes are live checked

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

With Begin playing when
media becomes Live, and Live
Playback: Changes are live
checked

With Begin playing when
media becomes Live, and Live
Playback: Changes are live
checked

With Begin playing when
media becomes Live, and Live
Playback: Changes are live
checked

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.
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Table 3. When Finished
Loop

Hold

Remove

With Remember position even
when not Live checked

With Remember position even
when not Live checked

With Remember position even
when not Live checked

When the clip goes live, click
Play. Wirecast plays the clip,
starting after the last frame
previously played.

When the clip goes live, click
Play. Wirecast plays the clip,
starting after the last frame
previously played, holds on the
last frame, and doesn’t restart
until you uncheck this option.

When the clip goes live, click
Play. Wirecast plays the clip,
starting after the last frame
previously played, to the end.
Then Wirecast drops the clip
from the live playback window.

With Remember position even
when not Live, and Live
Playback: Changes are live
checked

With Remember position even
when not Live, and Live
Playback: Changes are live
checked

With Remember position even
when not Live, and Live
Playback: Changes are live
checked

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

With Live Playback: Changes
are live checked

With Live Playback: Changes
are live checked

With Live Playback: Changes
are live checked

When checked, Wirecast lets you When checked, Wirecast lets you When checked, Wirecast lets you
control the playback with the
control the playback with the
control the playback with the
tools in the Preview window.
tools in the Preview window.
tools in the Preview window.
Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Note: When you check Live
Playback: Changes are live, it is
usually best to uncheck Begin
playing when media becomes
Live and Remember position
even when not Live.

Set as Default
Click to make the current source properties the default source properties.

Playlist Properties Tab
The Playlist Properties tab contains the following settings for playlist shots:
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Name
An editable field for the name of the playlist.
When Finished
Sets the behavior of the playlist when the last shot in the list has been played. A check
mark indicates what menu item (behavior) is selected.

• Loop transitions back to the first shot, endlessly.
• Hold stays on the last shot. If the last shot is a clip, the last frame in the clip is dis-

played. If the last shot is a live shot, the live source stays active. If the last shot in a
Playlist is a video clip Shot, it will obey the rules set for the video clip in the Media
Properties Inspector tab under Source Properties. However, it will hold the Playlist
on that last Shot if Set Playlist Behavior is set to “Hold”. Therefore, if you want to see
the last video in the Playlist pause on the last frame, you must set When Finished to
“Hold” under Source Properties, in addition to setting the playlist behavior to
“Hold”. If you set When Finished to “Loop”, under Source Properties, the last video in
the Playlist will continue to loop.

• Available Shots transitions to another shot on the same layer. All available shots are

listed as menu selections. (In the example shown, the only available shot is “Logo”.)

• Previous Live Shot transitions back to the shot that was live before the playlist began
playing.

• Current Preview transitions the contents of Preview to the Live Broadcast Area.
Transition
Sets the transition to use when switching between shots.
Remember position when not live
When selected, Wirecast remembers the start frame for the playlist when the playlist
isn’t live.
Previous
Transitions to the previous shot in the playlist if the playlist is currently live.
Next
Transitions to the next shot in the playlist if the playlist is currently live.
Shuffle
Click to shuffle the order of the playlist shots.
Total Shots
Displays the total number of shots in the playlist.
Duration
Displays the duration of the playlist.
See also Source Properties Tab.
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The Shot Menu
You can change almost all the attributes of a shot through the shot menu. To open the
shot menu for a shot, right-click on the desired shot in a layer.
Wirecast displays the shot menu.
Change Source Select Change Source to change the video source of your shot. Upon
selection, a menu of sources will display enabling you to make a selection.
Change Audio Select Change Audio to change the audio source of your shot. Upon
selection, a menu of audio sources will display enabling you to make a selection.
Keyboard Shortcut You can create a keyboard shortcut for opening the shot. To do
this, select Keyboard Shortcut from the shot menu. Then, select a menu number to
associate with that shot.
Wirecast checks that menu item and adds the keyboard shortcut number in the shot
icon.
To take a shot using the assigned hotkey, press the number key assigned to that shot.
You can assign multiple shots to the same menu number as long as they are on
different layers. When you use the assigned hotkey all the shots assigned to it will be
taken. Selecting a checked menu item will uncheck it and unassign the shot.
Select Unmap All Keys to remove all hotkey assignments.
Note: See also Creating a Document Hotkey.
Edit Shot You can edit a shot by clicking the double arrows (located on the left side of
the Preview Area) to the right, revealing the shot editing panel. You can also edit a shot
by double-clicking on it, by right-clicking it and selecting Edit Shot, by selecting Edit
Shot from the Edit menu, or by selecting it and pressing the Ctrl+E keys.
Rename Shot You can rename a shot by right-clicking it and selecting Rename Shot, or
by selecting Rename Shot from the Edit menu. You can also rename a shot by selecting
it and pressing the Ctrl+R keys.
Duplicate Shot You can duplicate a shot by right-clicking it and selecting Duplicate
Shot, or by selecting Duplicate Shot from the Edit menu. You can also duplicate a shot
by selecting it and pressing the Ctrl+D keys.
Duplicate Shot Options Check a source to create a new instance of it when
duplicating the shot containing it. Multiple selection is allowed.
Delete Shot You can delete a shot by right-clicking it and selecting Delete Shot, or by
selecting Delete Shot from the Edit menu. You can also delete a shot by selecting it and
pressing the Ctrl+Backspace keys.
Save Shot as Template You can configure any shot with a Placeholder and save it as a
Template Shot. When the dialog box displays, enter a template name and click OK.
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Lock Shot Icon Click to take a snapshot of your live shot icon thumbnail and save it as a
static image for your shot. This can help users identify each shot with a snapshot image
that's meaningful for them. For example, if you have a PTZ camera with multiple shots
configured for different camera positions, you can display a customized snapshot of
each camera angle as the icon for each shot. This provides quick identification during
production. Once a shot icon is locked, the Gear menu item will turn into Unlock Shot
Icon.
Refresh Shot Icon Click to refresh the shot icon after any changes made.

The Preferences Dialog Box
You can customize Wirecast functionality with the settings in the Preferences dialog
box.
See Customizing Wirecast with Preferences.
Key Combination
When checked, Wirecast displays the key combination on the shot.
Hotkey Name
When checked, Wirecast displays the hotkey name on the shot.

General Preferences
You can customize whether Wirecast shows the landing page and last document on
startup, the number of transition buttons shown, and other defaults, through the
General preferences.
Open last document on startup
When checked, the last document you used is opened when Wirecast starts up.
Show landing page on startup
When checked, the Welcome screen is displayed when Wirecast starts up.
Show Number of Viewers
When checked, enables the viewership indicator while streaming.
Send diagnostic and usage information
When checked, causes diagnostic and usage information to be sent to Telestream
anonymously.
Hide Unlicensed Features
When checked, Wirecast hides unlicensed Pro features from display in the menus.
Transition Buttons
The value selected from the drop-down menu determines the number of transition
buttons Wirecast displays in the default layout.
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Maximum Reconnect Attempts
The number entered into this field determines the number of times Wirecast tries to
reconnect to a host provider. The default is three.
Audio Playback
The device selected from the drop-down menu determines the device Wirecast uses for
monitoring audio playback.
Stock Media Download Folder
This field displays the full path of the folder where Wirecast stores stock media
downloads. Clicking the Browse button lets you select a different folder for stock media
downloads.

Canvas Preferences
Canvas preferences let you set options for your document canvas, including the default
size and the display rate used for video rendering.
Canvas Size for New Documents
The preference selected from the drop-down menu determines the default canvas size
for new documents.
Note: To optimize the quality of the video that Wirecast broadcasts, set the canvas
size to match, as closely as possible, the resolution of the desired output.
Lock Aspect Ratio When Resizing Layers
When checked, maintains aspect ratio when resizing layers.
Enable Snapping to other layers
When checked, turns on snapping to selected layers.
Enable Snapping to canvas
When checked, turns on snapping to the canvas.
Show Z Rotation controls
When checked, Wirecast displays the Z Rotation controls.
Video Display Rate
The preference selected from the drop-down menu determines the frame rate
displayed on the canvas.
Note: To optimize resources, set this as closely as possible to the framerate of the
desired output. The framerate you set is the framerate that Shot ISO and Multiviewer
use automatically.
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Shot Display Preferences
Shot Display preferences enable you to change settings related to your shots and the
Main Shot Display.
Theme
The preference selected from the drop-down menu determines how Wirecast displays
the shot window.

•
•
•
•

Default: Displays shot icons normally.
Lighter: Displays the Main Shot Display area with a lighter background.
XKeys: Displays shot icons with shot titles highlighted.
XKeys - Layer Backgrounds: Displays shot icons with colored backgrounds.

Live GPU Accelerated Icons
The preference selected determines the framerate at which Wirecast displays the active
icons.
Note: Higher framerates place greater demands on your CPU. This could diminish
Wirecast performance.
Live Audio Meters
When checked Wirecast enables live audio meters.
When Dragging Multiple Files From Explorer Folder
The preference selected determines what Wirecast does when you drag multiple files
from a folder into Wirecast. Depending on your selection, Wirecast either creates a
playlist containing the multiple files, or Wirecast creates multiple shots that are not part
of a playlist.

Shot Selection Icons
Each layer contains one or more shot-selection icons.
The shot icons can be made to display any live activity in the source it represents
(cameras, streaming, etc.).
See Creating a Shot and Shot Display Preferences.

Licenses Preferences
Licenses preferences enable you to register and license Wirecast.
License Key
This field displays the serial number that you have received for Wirecast.
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Note: The serial number is composed of numbers and upper case letters (excluding
upper case letter O), but it never contains quotation marks. When you receive a serial
number, it may be enclosed in quotation marks (e.g., “123-456-789”).
Purchase
When clicked, the Purchase button launches the purchasing dialog.
Deactivate
When clicked, the Deactivate button deactivates the serial number.

Update Preferences
Software update preferences enable you to obtain Wirecast updates.
Automatically check for updates
When checked, Wirecast checks for updates on the Telestream Website each time
Wirecast is launched. No personal information is transferred to Telestream during this
action.
Check Now
When clicked, Wirecast immediately checks for updates on the Telestream Website
(www.telestream.net). Wirecast does not transmit personal information to Telestream
during this action.
See Checking for Wirecast Updates.

Shortcuts Preferences
Shortcut preferences enable you to view and create application shortcuts and
document hotkeys. An application shortcut is a combination of keys that executes a
menu or mouse command. A document hotkey is a combination of keys that executes
a document-specific command. See Finding an Application Shortcut and Creating a
Document Hotkey.
The Shortcuts tab of the Preferences dialog contains the following elements:
Keyboard Shortcut Set Drop-down Menu
When the down-arrow is clicked, Wirecast opens a drop-down menu listing available
keyboard shortcut sets. Each set contains both application shortcuts and document
hotkeys.
Configure Button
When clicked, Wirecast opens a menu of options for duplicating, deleting, renaming,
importing, or exporting keyboard shortcut sets.
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Application Shortcuts Tab
When clicked, Wirecast displays a menu of shortcuts. Subtabs allow you to filter the list
to show either All, Customized, or Conflicted shortcuts.
Document Hotkeys Tab
When clicked, Wirecast displays a menu of document hotkeys.
List of Hotkeys
The hotkeys window displays a list of existing hotkeys.
Name
Wirecast displays the names of document hotkeys in this column.
Key Binding
Wirecast displays the key to press to execute the hotkey command.
Global
When checked, Wirecast applies the document hotkey globally across documents.
Conflict
When you try to assign a hotkey already in use, Wirecast displays an alert icon in the
Conflict column.
Click to record shortcut
Wirecast opens this field when you select a hotkey command, enabling you to create or
change the hotkey.
See also Creating a Document Hotkey.

Controllers Preferences
Controllers preferences enable you to adjust MIDI and X-keys controller settings for
Wirecast.
Controller
The controller selected from the drop-down menu controls Wirecast.
See Installing a Hardware Controller.

MIDI Control Assignments
Each MIDI controller has up to six controls assigned to it. The locations of each of these
controls are shown below for the three midi controllers supported.
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The locations of APC MINI controls are shown below:
Figure 21. APC Mini Controls

The locations of APC40mk2 controls are shown below:
Figure 22. APC40mk2 controls
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The locations of Launchpad MK2 controls are shown below:
Figure 23. Launchpad MK2

Each MIDI controller has up to six controls assigned to it. The locations of each of these
controls are shown below for the three midi controllers supported.

MIDI Control Descriptions
Shot Layers
The matrix of buttons on the MIDI controller (five rows of eight buttons) automatically
correspond to the five layers in the Wirecast shot list window. Up to eight shots in each
layer are controlled by the MIDI controller buttons. Shots are automatically assigned to
MIDI controller buttons as they are created. If fewer than eight shots exist on a layer, the
corresponding buttons (to the right) are inactive.
Go Live
Pressing this MIDI controller button is the same as clicking the Go Live button in the
Wirecast default layout.
Transition 1
Pressing this MIDI controller button is the same as clicking the Left Transition button in
the default layout.
Transition 2
Pressing this MIDI controller button is the same as clicking the Left Transition button in
the default layout.
Audio Mixer Volumes
Sliding these MIDI controls adjusts up to eight volume controls in the Wirecast Audio
Panel. Each MIDI slider corresponds (left to right) to a volume control in the Audio
Panel. Volume controls are automatically assigned to MIDI controller sliders as they are
created. If less than eight volume controls exist in the Audio Panel, the corresponding
MIDI sliders (to the right) are inactive.
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Channel Pan
Each Channel Pan control on a MIDI device corresponds with a Channel Pan control for
a track in the Audio Mixer Panel, for as many as eight channels.
Wirecast automatically assigns Channel Pan controls to MIDI controls as they are
created. If fewer than eight Channel Pan controls exist in the Audio Panel, the
corresponding MIDI controls remain inactive.
Figure 24. Audio Mixer Channel Pan Controls

Audio Mixer Channel Pan Controls

X-keys Control Assignments
The X-keys controller has multiple controls assigned to it. All of the assigned controls
are shown below.
Figure 25. X-keys Control Assignments
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General Key Operations
• Key lamps turn red when a function is on, and turn blue when off (except for keys
that do not have dual states, like the ).

– Function lamps turn red when a function is on, and turn blue when off (except
for keys that do not have dual states, like the keyboard shortcuts).
– Shot switching key lamps turn Blue when shot is in Preview and Red when in
Live. Otherwise they are off.

• The Wirecast software and the X-keys panel stay in sync when keys are pressed or
changes are made in Wirecast.

• Some keys are interactive. In such a case, pressing one key affects the status of
another (like the PREV and LIVE keys).

Key Descriptions
Five Layers keys
Controls the first twelve shots (plus the Clear Layer shot) on each of the five layers.
Keyboard Shortcuts
The twelve keys represent the twelve keyboard shortcuts that have been assigned in
Wirecast. Pressing a key executes the matching numbered keyboard shortcut (1
through 13). The key lamps momentarily turn red, then turn back to blue.
Live/Preview Swap Mode
Toggles the Live/Preview Swap mode. When in this mode, the Live and Preview shots
are swapped.
Auto Live Mode
Toggles the Live Auto mode. When in this mode, selected shots are displayed in the
Live Output window immediately.
Rendezvous
Toggles (show/hide) the display of the Rendezvous window.
Audio Mixer
Toggles (show/hide) the display of the Audio Mixer window.
Preview Monitor Audio
Toggles the Preview monitor audio (what you hear locally) on and off. (It is mutually
exclusive with Live Monitor audio).
Mute Live Streaming audio
Toggles the Live Streaming audio (what your viewers hear) on and off.
Live Monitor Audio
Toggles the Live monitor audio (what you hear locally) on and off. (It is mutually
exclusive with Preview Monitor audio).
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Streaming
Toggles streaming on and off.
Recording
Toggles recording on and off.
ISO Recording
Toggles ISO recording on and off.
Multi Viewer
Enables all displays. Pressing this key is the same as selecting
Output > Multi-Viewer Output > Enable All Displays.
NDI
Enables/Disables NDI output.
Fade to Black
Pressing this key acts as a “master transition-to-black”. The transition used is the one
currently selected. It is very helpful when needed to make the Live Output black in an
emergency. If Wirecast is in Live/Preview Swap mode, the live shot is moved to Preview
and the pre-fade condition can be restored by pressing the Go key.
Live Media Play and Pause
Press the Play button to play a selected media file, and press the Pause key to pause it.
These keys are interactive. Pressing one changes the lamp status of the other.
Replay Create and Update
These keys execute Replay+ISO > Create All Replay Shots, and Replay+ISO > Update All
Replay Shots.
Mark In
Pressing this key executes Replay+ISO > Program Replay > Replay Mark In.
Transitions 1 and 2
These keys select Transition 1 or Transition 2 so that when the Go key is pressed, the
selected transition will occur.
Go
Press this button to send the shot from the Preview Area to the Live Broadcast Area, by
way of the transition selected. If Wirecast is in the Live/Preview mode, the Live output
shot will be moved to the Preview Area when you click the Go button.

Advanced Preferences
Advanced preferences enable you to adjust advanced settings for Wirecast.
Disable Vertical Sync
Check the box when running Wirecast minimized, when the Wirecast user interface is
covered by another application, or when Wirecast is covered by a full-screen game.
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Video Adapter
Select the desired video adapter from the drop-down menu.
Render Engine
Select the desired render engine from the drop-down menu. The options are as follows:

• Automatic This is the default setting. When this option is selected, Wirecast selects
the best render engine based on the available hardware.

Note: Wirecast automatically sets the render engine to Direct3D 11 when it detects
AMD hardware. Also, Wirecast automatically sets the render engine to Direct3D 11
when Direct3D 12 is not available.

• Direct3D 12 Select this option to make Direct3D 12 the default render engine.
• Direct3D 11 Select this option to make Direct3D 11 the default render engine
Disable Vertical Sync
When checked, Wirecast receives frames as fast as possible, for example, during video
game play. This is especially useful when the application window is minimized or
covered by another application.
Video Adapter
The preference selected from the drop-down menu determines the video adapter
Wirecast uses for rendering and compositing. If you are using a discrete GPU, select the
same GPU on which your application is running.
Note: Video Adapter defaults to the first discrete card that is discovered by Wirecast. If
you have multiple GPUs, it is best to configure Wirecast to use the same card as used
for your application (for optimal performance), otherwise Wirecast uses a slower
capture path. Also, best performance is achieved by setting the Video Adapter to use
the NVidia card.
Web Stream
Check to enable automatic discovery of ONVIF cameras.
Microphone
Check to automatically detect feedback and force the display of a warning message.
Missing Media
Check to automatically reconnect live shots when Wirecast loses communications with
a source.
Application Source Latency
The value entered into this field determines Wirecast latency period, in microseconds.
When you update this value, Wirecast applies it as soon as the preference is committed.
You don’t need to restart Wirecast to see the change.
The minimum value for this preference is 50ms (2 frames @ 30fps). The maximum value
is 330ms (10 frames @30fps). The default is 100ms (3 frames @ 30fps).
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Note: Wirecast applies application source latency to all sources, while the audio delay
and video delay values in Source Properties determine the delay for individual
sources.
Missing Media Image
The preference selected determines how Wirecast indicates a missing graphic.

• When Default is selected, Wirecast presents a red question mark in place of the
missing graphic.

• When Transparent is selected, Wirecast makes no replacement of the missing
graphic.

• When Custom is selected, Wirecast lets you browse to a graphic to replace the missing graphic.

• Browse button: click to browse to a media image.

The Audio Mixer Window
The Audio Mixer enables you to monitor and control all of the audio sources from a
single control panel. This section describes in detail how to use the Audio Mixer.
The Audio Mixer separates your audio by hardware and shot. The Live Sources pane
shows all hardware audio sources that are live in your streaming event. This includes
microphones, audio input feeds, cameras, capture cards, and Web streams. The
remaining audio controls are associated with specific shots.
See Displaying or Hiding the Final Mix Audio Panel.
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Figure 26. The Audio Mixer Window

Add new FX

Peaks

Channel
Selection

Level display

Pan Slider
Final Mix Mute

Headphone Mute

The Headphone Mute buttons toggle the source audio when monitoring Preview or
Live output. Muting headphones doesn’t remove the audio from the output stream or
recording. Channel Selection enables you to select left source only, right source only, or
stereo (left and right).
Delay
Enter the amount of audio delay needed (in seconds and milliseconds).
Channel
Select the channel to use: Left, Right, or Stereo (both).
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FX
Click the down-arrow to display the audio effects panel.
Add New FX (+)
Click the plus (+) icon to select an audio effect from the drop-down menu. You can
select more than one effect or plugin.
Delay
L and R Delay adjusts how much delay on each channel. Feedback is how much delay is
used. Fb Tone is a frequency setting of highs and lows to be delayed. FX Mix is how
much delay will be added to audio output. Output sets the delay output level.
Dynamics
Thresh sets the threshold of engaging compression. Ratio sets the compression ratio.
Output sets the compression level. Attack sets the manner in which compression is
applied. Release sets how compression in released. Limiter sets a max output level on
the audio. Gate controls (Thresh, Attack, and Release) sets the noise gate that cuts off
noise at the set level. Mix adjusts how much compression is applied to the audio.
De-ess
Thresh sets the threshold of de-essing. Freq selects the frequency at which de-essing
will be applied to the audio. HF Drive adjusts the high frequency aspect of de-essing.
EQ
Low, medium, and high adjusts low, mid, and high frequency components in the audio.
Loudness
Loudness adjusts the amount of loudness (raising high and low frequencies) in the
audio. Output adjusts how much loudness is applied to the audio.
Limiter
Thresh sets the minimum threshold of limiting in the audio. Output sets the amount of
limiting used in the audio. Release sets the manner in which limiting is released as the
audio decreases. Attack sets the manner in which limiting is applied. Knee adjusts the
frequency and shape of point where limiting begins.
Multiband
Listen selects which part of the frequency spectrum to hear: low, mid, high, or all
(output). L<>M adjusts the cutoff frequency in the low to mid range (87 to 1020 Hz).
M<>H adjusts the cutoff frequency in the mid to high range (111 to 19606 Hz). L, M,
and H Comp adjusts the compression for low, mid, and high frequencies. L, M, and H
Out adjusts the output for low, mid, and high frequencies. Attack sets the manner in
which compression is applied. Release sets the manner in which compression is
released. Stereo adjusts how the left and right channels are separated (width) from 0 to
200%. Process selects stereo or mono mode.
Noise Reduction
Amount sets the amount that noise reduction is applied.
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Level Control
Adjusts the audio level of the live audio output.
Level Display
Displays the levels (left and right) of the live audio outputs.
Mute
Mutes the live audio output.
Monitor
Toggles the monitor audio output in the headphones without effecting the live audio
output.
Final Mix Audio Level
Adjusts the audio level of the Final Mix audio output.
Final Mix Display
Displays the levels (left and right) of the Final Mix audio outputs.
Final Mix Mute
Mutes the Final Mix audio output.
Headphone Mute
Toggles the monitor audio output in the headphones without effecting the Final Mix
audio output.
Source Selection
Click the down arrow to select an audio source from the drop-down menu.
Track Selection
Click the down arrow to select an audio track from the drop-down menu.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.

The Output Settings Window
The Output Settings window enables you to customize the settings for a destination.
Destination List
Wirecast lists the last-used destinations in the left-side pane of the Output Settings
window. Each destination has its own broadcast technology preset, for example RTMP,
or Windows Media.
Add Button
When clicked, the Add button opens the Select an Output Destination dialog, enabling
you to add destinations to the destination list.
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Remove Button
When clicked, the Remove button opens the Select an Output Destination dialog,
enabling you to remove destinations from the destination list.
Name
This is an editable field for the name of the output setting. By default, Wirecast names
the setting for the destination selected.
Destination
This drop-down menu lists all the visible existing destinations.
More Button
This button opens a menu listing all existing destinations, with check boxes for making
each destinations visible in the Destinations drop-down menu.
First Gear Icon
This drop-down menu lists actions available for the destination selected.
Encoding
This drop-down menu lists the available encoding presets. Each destination preset has
its own encoding presets. The encoding presets define the codec, aspect ratio, and
frame rate for each destination. Wirecast provides many encoding presets.
Second Gear Icon
This drop-down menu enables you to view the details for the preset selected, create a
new preset, or filter the presets listed for the destination selected.
Audio Track Selection
This drop-down menu lists the audio tracks available for the destination selected.
Map Button
This button opens the Multi-Track Input Mapper for the destination and track selected.
See The Multi-Track Input Mapper.
Address
This editable field contains the network address for the destination selected.
Port
This editable field contains the port address for the destination selected.
Passphrase
This editable field contains the passphrase for the destination selected.
Location
This field displays the host location for the destination selected.
See Destinations and The Encoder Presets Window.
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The Multi-Track Input Mapper
The Multi-Track Input Mapper window enables you to determine the output audio
channel destination for each of the audio tracks in a Wirecast document.
Source
Wirecast displays the filename of the audio source in the Source field.
Channel
Wirecast displays the output audio channels available in the Channel fields.
Track (1-8)
Wirecast displays checkboxes for each of the available audio tracks in the Track
columns.
See Map and Mapping Audio Tracks to Output Audio Channels.

The Encoder Presets Window
The Encoder Presets window enables you to select a default encoder preset for your
output, and to create your own custom presets.
Encoder Preset
This drop-down menu lists all default and custom encoder presets available.
Video Encoding
When checked, Wirecast enables you to customize the video encoding settings shown
in the Video Encoding pane.
Note: You should match the output to the canvas size as closely as possible to
preserve video resolution and quality. For example, a 800x600 source results in
significant loss of quality if an aspect ratio of 640x480 is selected for the output.
Choosing an output of 720x576, which is much closer in size, helps preserve video
quality.
Profile
Many encoder presets enable you to select one of three profiles: Baseline, Main, or
High.
Baseline Profile (BP) Baseline profile is primarily for low-cost applications that require
additional data loss robustness. This profile is used in some video conferencing and
mobile applications. It includes all features supported in the Constrained Baseline
Profile, plus three additional features used for loss robustness (or for other purposes
such as low-delay multi-point video stream compositing). The importance of this
profile has faded somewhat since the definition of the Constrained Baseline Profile in
2009. All Constrained Baseline Profile bitstreams are also considered to be Baseline
Profile bitstreams, since these two profiles share the same profile identifier code value.
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Main Profile (MP) The Main profile is used for standard-definition digital TV broadcasts
that use the MPEG-4 format as defined in the DVB standard. It is not, however, used for
high-definition television broadcasts, since the importance of this profile faded when
the High Profile was developed in 2004 for that application.
High Profile (HiP) The High profile is the primary profile used for broadcast and disc
storage applications, particularly for high-definition television applications. For
example, this profile is used by the Blu-ray Disc storage format and the DVB HDTV
broadcast service.
Audio Encoding (AAC)
When checked, Wirecast enables you to customize the AAC audio encoding settings
shown in the Audio Encoding pane.
See Encoder Presets and Encoder Presets.

The Comment Moderation Window
Figure 27. The Comment Moderation Window, View comments pane

Descriptions of the controls in the Comment Moderation window follow.
Facebook, Twitter and YouTube logos
The colored ring around a logo indicates the status of the Wirecast connection to that
platform, as follows:
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Red
Not reading comments
Note: Until you start live streaming, Facebook and YouTube icons remain red.
Green
Connected and reading comments
Green with a yellow exclamation warning
Connected, but with a potential issue.
Turn off/on comments
Click the checkbox under any of the three platforms to turn off reading comments for
that entire platform.
Note: If you have more than one stream going to a platform (e.g. Facebook profile
and Facebook group), this control turns off comments to all of the streams on that
platform. There is not currently a way to turn off comments from individual streams to
the same platform.
View Active Accounts
Click this to see which accounts you have authenticated, and what their status is. This
opens the Active Accounts pane on the Comment Moderation dialog.
Figure 28. The Active Accounts Pane

Add Facebook or YouTube Feed
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• For Twitter:
– If the Account is authenticated and reading comments, the message will say
Reading Comments
– If the Account is Authenticated, but you have unchecked it from the main
Moderation window, it will say Offline

• For Facebook or YouTube:
– If the Account is Authenticated but you have not yet started streaming, or you
have unchecked it from the main Moderation window it will say Offline
– If the account is authenticated and you are streaming, the message will say
Reading Comments

• View Comments When clicked, Wirecast opens the View comments pane.
• Add Facebook or YouTube Feed When clicked, Wirecast opens the Select destination
pane.

Search
Lets you search the text within comments
Rotate Selected Every XX Seconds
Check this option and all comments selected will rotate into the selected title and
displayed. Click Unselect All to deselect any comments you have selected.
Comment panel
Comments appear as they come in from each selected platform. An asterisk “*”
indicates the column can be sorted.

• Live The comments that are selected to rotate, if Rotate Every is selected, or the
comment that is currently selected for live display

•
•
•
•
•
•

Source The platform the comment came from
Photo The photo of the commenter
User Name The name of the commenter
Comment The comment
Time The time the comment was made on the platform
Favorite Choose favorite comments by clicking on the star icon. This can be helpful
to sort comments for display later.

• See Social Media Shots, Moderating Social Media Comments, and Moderating Facebook or YouTube Comments for a Streaming Computer or RTMP Server.

The PTZ Controller Panel
In this panel you can create a preset group of settings for each camera listed in the
Camera drop-down menu. You can associate multiple presets for each camera. Also,
you can switch between devices in the Camera drop-down menu.
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Camera
This drop-down list shows cameras available to Wirecast. Selecting a camera updates
the PTZ Controller window to display the preset VISCA and PTZ configuration for that
camera. Once you establish a connection to a valid VISCA device, the PTZ Controller
panel shows the camera's current Pan/Tilt orientation. Changing the Camera source
changes all the settings in the panel accordingly.
Note: A PTZ camera's VISCA configuration is discrete from the video feed. You can
associate any available video source with any manually-entered VISCA device
information. This accommodates a workflow where the camera's video feed is being
captured via a Capture Card.
Protocol
Select a PTZ protocol from the drop-down menu,
IP Address
Enter the IP address of a valid VISCA-over-IP source on the network. This IP address is
configured in your camera's network settings.
Port
Enter the IP port for the VISCA connection of the camera. This IP port is configured in
your camera's network settings.
VISCA Address
Select the correct VISCA Address of the camera. This VISCA Address is configured in
your camera's VISCA settings.
Status / Reconnect Button
Displays the current VISCA connection status (“connected” or “invalid source”) of your
camera. Click the Reconnect button to force a reconnection.
Home Button
Click the House icon to reorient the PTZ camera to its default position (default centered,
no zoom).
Pan/Tilt
Select the desired pan/tilt control method (Map, D Pad, or Analog Pad) from this dropdown menu.
Figure 29. The Pan/Tilt Control
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• Map – displays an X/Y plane with a yellow cross-hair representing the current Pan/
Tilt orientation of the camera

Figure 30. The Pan/Tilt Control Map

• D-Pad – Pan the camera by clicking the left and right arrows, and tilt the camera by
clicking the up and down arrows.

Figure 31. The D-Pad

• Analog Pad – Click in the analog circle to reposition the camera pan and tilt.
Figure 32. The Analog Pad

Zoom
Move the slider to adjust the zoom factor of your camera.
Note: When the PTZ Controller panel is the selected window, you can press the arrow
keys on the keyboard to adjust the Pan (left and right arrow keys) and Tilt (up and
down arrow keys) of the camera. Alternatively the W, A, S, and D keys can also be used
(W = Up, A = Left, S = Down, D = Right)
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Focus
Click the Plus and Minus buttons to adjust the focus of the camera. The yellow button in
the center toggles auto-focus on and off. Any manual adjustments made to the focus
will automatically disable the auto-focus.
Exposure
Select the exposure mode from the Exposure drop-down menu.

• Shutter Move the slider to adjust the shutter of the camera. You can only adjust the
Shutter when Exposure mode is not in auto-focus.

• Iris Move the slider to adjust the iris of the camera. You can only adjust the Iris
when Exposure mode is not in auto-focus.

Note: Refer to PTZOptics documentation for more details about each mode.
White Balance
Select the white balance mode from the White Balance drop-down menu.
Note: Refer to PTZOptics documentation for more details about each White Balance
mode.
One Shot
When the White Balance mode is set to One Shot, click this button to adjust the White
Balance one time only.
Red Gain/Blue Gain
When not in auto-focus mode, you can use these sliders to adjust the red and blue gain
of the video signal to compensate for white balance issues.
Presets
Enter a preset number and click Save to save current Pan, Tilt, and Zoom configurations
of camera. To recall a preset, select a preset number by clicking the arrow buttons, then
click the Recall button.
Note: If you have Wirecast in the AutoLive mode, you must click the Live button to
switch between presets on the same PTZ camera. This is a built-in safeguard against
unintentionally moving the camera while in Live mode.
See Configuring The PTZ Controller, Opening the PTZ Controller Panel, and Controlling a
PTZ Camera.

Menus and Application Keyboard Shortcuts
You can launch most Wirecast features from the items in the Wirecast menu bar. When a
menu item is clicked, Wirecast opens a drop-down menu of features related to that
menu item.
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Also, you can launch most Wirecast features with application keyboard shortcuts.
Application keyboard shortcuts are key combinations assigned to the Wirecast menu
commands.
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.

File Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
New
Creates a new, empty Wirecast document.
Open
Displays the Open dialog window for opening a Wirecast document.
Open Recent
Displays up to fifteen of the most recently accessed documents. Every time a document
is opened or saved it is entered into this list.
Import Media
Enables you to import media into Wirecast. A new shot is automatically created using
the new media.
Save
Saves the document. If the document has not already been saved, the Save As... dialog
window is displayed.
Save As
Displays the Save As... dialog window so that the document can be saved using a new
file name.
Close Window
Closes the currently active Wirecast window. If the window is a document, all of its Shot
Editor windows are closed as well. If Wirecast is still broadcasting, you are asked to stop
the broadcast. If the document has not been saved, you are asked to save the
document before closing.
Preferences
Opens the Preferences dialog. If the Preferences dialog already is open, it becomes the
active window.
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See The Preferences Dialog Box, Customizing Wirecast with Preferences, and Resetting
Preferences.
Exit
Closes all documents and then exits. If the broadcast is playing, you are asked to stop
the broadcast. If a document has not been saved, you are asked to save the document
before exiting.
Always On Top
When checked, the Wirecast window remains active as the topmost open window on
your system.

Edit Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Undo
Reverses your last change in Wirecast. Undo is only available in some windows (such as
the Preview Area). Wirecast offers an unlimited number of undo actions (within
computer memory limitations). Undo information is stored on a per-window basis.
Also, if you close a window then reopen it, your undo information is lost.
Redo
Reverses your last undo action. Redo is only available in some windows (such as the
Preview Area). Wirecast offers an unlimited number of redo actions (within your
computer’s memory limitations). Redo information is stored on a per-window basis.
Also, if you close a window then reopen it, your redo information is lost.
Cut
Cuts selected text.
Copy
Copies selected text to clipboard.
Paste
Pastes selected text from clipboard to location of cursor.
Paste as new Consolidated Shot
Pastes selected shots into one consolidated shot. A consolidated shot is a shot created
from multiple sources.
Select All
Selects all text in the active window.
Edit Shot
Opens the Shot Editor. You can also double-click a shot, or right-click and select Edit
Shot, to open the Shot Editor.

Wirecast User Guide

176

177

Windows, Controls, and Menus
Switch Menu

See The Shot Editor Window.
Rename Shot
Enables you to rename a shot. You can also right-click a shot and select Rename Shot.
Duplicate Shot
Duplicates the currently selected shot. You can also right-click a shot and select
Duplicate Shot.
Duplicate Shot Options
Check a source to create a new instance of it when duplicating the shot containing it.
Multiple selection is allowed.
Delete Shot
Deletes the currently selected shot. You can also right-click a shot and select Delete
Shot.
Move To Layer
Moves a shot to the selected layer. When shots are created, they are assigned to a
specific layer. They exist on that layer until they are moved or deleted. You can also click
and drag a shot to another layer.

Switch Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Go
Performs a transition (same action as clicking the Go button).
Transitions
Wirecast has up to three transition buttons that can be assigned any transitions (cut,
smooth, etc.) that Wirecast supports. The Switch menu lists the currently assigned
transitions by name. You can also select the Left, the Middle, and the Right transitions
by pressing the control key and either the 1 or 2 key. Right-click on either transition to
open the operation menu. Select how the transition will operate: Ease In, Ease In/Out
Ease Out, Linear, or I.
To select which transitions appear in this menu, see Final Mix Audio Panel.
Transition Speed
Enables you to select one of five transition speeds ranging from Slowest to Fastest.
Manage Stinger Transitions
When clicked, Manage Stinger Transitions opens the Manage Stinger Transitions dialog.
This enables you to import and use custom transitions that employ transparent
backgrounds. These transitions are typically created using applications such as Adobe
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After Effects, Apple Motion or ScreenFlow.
See Importing Stinger Transitions.
Figure 33. Add Transition and Remove Transition Controls

Click Play to
Preview
Scrubber

Remove Transition
Add Transition

AutoLive
Toggles (turns on and off ) the AutoLive feature.
You may want to single-click a shot to make it become live. Alternatively, you may want
to make several changes to a shot before making it live. You can use either method in
Wirecast.
When enabled, the AutoLive feature lets you broadcast any shot with a single click.
When AutoLive is enabled, Wirecast disables the Go button. Clicking a shot in a layer
automatically places the shot in the Live Broadcast Area.
See Single-Click Switching with AutoLive and Go Button.
Live/Preview Swap
Toggles (turns on and off ) the Live/Preview Swap feature. When on, the Live Broadcast
and Preview windows trade panes (swap) when the Go button is clicked.
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Layer Visibility
Click to open the menu and select a layer to hide or show in your shot. A check mark
displays when the layer is visible. The shot icon becomes gray when not visible. You can
toggle on and off the viability of each layer by pressing the Alt+1 through Alt+5 keys.
Disable PTZ Preset Recall
Enables/Disables PTZ preset recall.
See The PTZ Controller Panel.
Note: When you transition to a shot containing an animated title, Wirecast first
executes the transition, and then performs the opening animation for the title. When
you clear the title from the shot, Wirecast first performs the closing animation for the
title, and then executes the transition for the end of the shot.

Media Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Start Playing All Movies
Starts playing any movies that are not currently playing.
Pause All Movies
Pauses all movies that are currently playing.
Shuffle Playlist
Randomly rearranges the order of media in the playlist.
Assign Placeholder
Opens the Assign Placeholder menu.
Reset Placeholder
Opens the Reset Placeholder menu.
Show Asset Manager
Displays devices that can be configured. Some devices (cameras, etc.) may be
configurable. For example, you can configure a USB camera to manually change its
focus, contrast, brightness, etc. Other devices have multiple inputs you can choose
(AlchemyTV Card, etc.).
See Reassigning Media.
Note: The Configure Devices menu selection is present only if a device is connected
to Wirecast. The configuration user interface is provided by the device maker. It is
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beyond the scope of this document to describe all of the features available for all
devices. See the documentation provided with your device on how to configure it.

Output Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Output Settings
Opens the Output Settings window.
Start/Stop Broadcasting
Starts (or stops) broadcasting to the network.
Start/Stop Recording
Starts (or stops) recording to disk. If you have not yet configured the Output Settings
for this document, you are prompted to do so.
Show Recordings
Opens all the folders of all the file directories in the Output Settings.
Multi-Viewer Output
Enables you to setup and use a Multi-Viewer display on and or all monitors. You can
configure your displays, enable all displays, select a display to be active, or show (or
hide) all displays when the application is in the background.
See External Display Outputs and Multiviewer/Secondary Live Output Button.
Configure Displays
Select Configure Displays to open the configuration window.
Setup your Multi-Viewer by choosing a Monitor which determines where the MultiViewer will display. Also select the Mode: Multi-viewer, Live Output, or Disabled
(neither).
Select a Layout which determines how the Multi-Viewer will be displayed. The layout
choices are: one, two, or four slots. In the Pro version ten or seventeen slots can also be
selected. Each panel slot can then be mapped to any source: Preview, Live or any
existing Shot in your document. Click inside a panel to select a source. Each Monitor is
configured separately using the Configuration window. So, when you select a different
monitor, the configuration panel (slots) also change. Additionally, all the monitors are
automatically numbered. Clicking the Identify Displays button causes each of the
monitors to display it number on it.
You can also control how each panel is labeled by making a selection from the Labels
menu:
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Draw Labels Below each Slot
Displays the label below each shot in each panel.
Superimpose Labels Over Each Shot
Displays the label over each shot in each panel.
Do Not Draw Labels
No labels are displayed.
Click on any slot panel to open the source menus, then select a source from the list to
display it in the slot. Click Identify Display to cause the display number on each display
to be shown.
Enable/Disable All Displays
Select to hide or display all of your configured Multi-Viewed monitors.
Select a Display
Select one of your configured Multi-Viewed monitors to hide or display. Shown below is
a typically configured monitor with four slots. Audio meters are provided in each view.
Hide All Displays When App is in the Background
When selected, all Multi-Viewer Displays are hidden if Wirecast itself is put into the
background or minimized. Turning this option off allows the Multi-Viewer outputs to
stay on if Wirecast is put in the background or minimized
Note: Multi-Viewer displays can also be disabled by clicking on the Multi-Viewer
display itself (on its target monitor), and then pressing the Escape (Esc) key.
Secondary Display Live Output
PRO

Sends the live program to a secondary device. For example, you can send a live
program feed to another screen or to a capture card in an external device. If the
external device has an UVC HDMI capture card, you can capture the live output from
Wirecast for use in the applications--such as Zoom or Teams--on the other device.
You can use Secondary Display Live Output as an alternative to Virtual Camera/Mic.
You can map audio tracks, as well as video, to the secondary display.
See External Display Outputs and Multiviewer/Secondary Live Output Button.
Virtual Camera Out
Enables you to present the output of Wirecast as if it were a camera (a virtual camera),
allowing it to be automatically detected by other applications when they are launched.
Outputs only the Live Program feed.
Active Broadcast
Once you have logged into your YouTube or Twitch account and you start streaming,
you can select Active Broadcast to display the YouTube broadcast window in a browser.
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Control Room (YouTube only)
Once you have logged into your YouTube account, you can select Control Room to
display the YouTube control room window in a browser.
Dashboard (Twitch Only) Once you have logged into your Twitch account, you can
select Dashboard to display the Twitch dashboard window in a browser.
VOD of Last Broadcast Enables you to view the most recent completed broadcast.
Note: Active Broadcast is enabled only for Twitter-Live Broadcast and YouTube.,
Control Room and VOD of Last Broadcast are enabled only when you are logged into
YouTube.
Facebook (Facebook Live Only)
Select Active Broadcast to display your Facebook Live event.
Twitter
Opens menu to monitor your Twitter broadcast.

• Active Broadcast Once you have logged into your Twitter account and you start

streaming, you can select Active Broadcast to display the your broadcast window in
a browser.

• Producer Dashboard Once you have logged into your Twitter account, you can

select Producer Dashboard to display the Twitter dashboard window in a browser. In
the dashboard you can start your broadcast by clicking the Go Live button.

To stop your broadcast click the Stop Stream button.

• Toggle Broadcast Click to toggle between Go Live and Stop Broadcast on the
Producer Dashboard.

Canvas Size
Sets the canvas size resolution used when broadcasting a Wirecast document.
Note: You should match the output to the canvas size as close as possible to preserve
video resolution and quality. For example, a 800x600 source results in significant loss
of quality if a resolution of 640x480 is selected. Using 720x576, which is much closer in
size, helps preserve video quality.
Show Statistics
Displays the statistics window for your broadcast. You can select (for display): Bitrate,
RTMP Queue Size, Framerate, System CPU Usage, and System Memory Usage.
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PRO

NDI Output
Sends the output of the Live Program feed. Select the output resolution for your NDI
output. You can also select a link that will take you to NDI.NewTek.com for additional
information.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.
Blackmagic Cards
Note: If you are updating to Wirecast 14 (or a previous version) and have multiple
capture cards that are different models, when you open a saved document that
contains sources from the capture cards, one of the inputs may fail to upgrade (and
will show their saved source.) To remedy this re-add the missing source back into the
document, then open the Asset Manager and assign that newly added source to back
into its saved shot.
You can use Blackmagic cards to send live feeds directly into editing, effects and
broadcast design systems. In order to use this feature, install a Blackmagic card with
associated drivers, then restart Wirecast. The Blackmagic card with then be listed in the
Output menu.
Under the Output menu, select a Blackmagic card, and then select an HD setting for its
output. If your card has multiple outputs, you can select more than one and all will
output simultaneously at independent resolutions and Frame rates.
To begin outputting, select Start Output and chose a setting.
You can stop the Blackmagic card output by selecting Stop Output. If you have multiple
outputs selected, they will all stop outputting.
Note: Some Blackmagic cards do allow input and output simultaneously, but need to
be configured in the Blackmagic software.
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Layout Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
To optimize the user interface for each document, you can configure the Wirecast
layout.
Wirecast enables you to select which functions are displayed in the default layout.
These functions are added or removed from the default layout using the Layout menu.
Final Mix
When checked, displays the Final Mix Audio controls. Final Mix Audio controls are
located on the left and right sides of the default layout.
Show Live and Preview
When checked, displays the Live and Preview windows, and allows you to select
between displaying the Preview Area only, the Live Broadcast Area only, or both.
Show Preview Only
Displays the Preview Area only.
Show Live Only
Displays the Live Broadcast Area only.
Note: The three controls above work the same as the Mode Control buttons at the
top-right of the default layout. See Layers.
Zoom Layers In
Increases the size of all the layer icons.
Zoom Layers Out
Decreases the size of all the layer icons.
Zoom Layers To
Sets the size of all the layer icons to: 50%,100%, or 200%.
Note: You can also change each layer size by clicking and dragging the divider line
between layers. Additionally, you can change the size of all layers by holding the Ctrl
key while clicking and dragging the divider line between layers.
Go to Layer
Displays the selected layer. You can also press Ctrl + Shift keys with the T, F, N, B, or A
keys to select a layer. Each of these letter keys represents a layer name: Title,
Foreground, Normal, Background, and Audio.
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Replay + ISO Menu
PRO

Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Start All
Activates the Create Replay Shot system. When activated, the menu item becomes
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.
Activate
Activates the Create Replay Shot system. When activated, the menu item becomes
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.
Configure ISO Outputs
Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an
ISO output, click Configure, then click the Add ISO button.
Note: You can create ISO recordings of any source or shot in your document.
Replay Mark All
Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the
beginning point of your Replay Shot capture.
Create All Replay Shots
Select Create to create additional Replay shots.
Update All Replay Shots
If no replay shot exists, selecting Update creates a new Replay shot. There after,
selecting Update updates the first Replay shot created.
Configure
Displays the Replay Shot settings window.
For more information about Replay Shots see Replay + ISO Menu.
ISO enables you can set up ISO recording and do Replays from the same menu. To use
Replay and ISO functionality, select the Replay + ISO menu.
Start All
Activates all configured ISO shots and/or the Program Replay. When activated, the
menu item becomes Stop All. Click Stop All to deactivate the Create Replay Shot system.
Program Replay
Allows you to Stop, Mark In, Create, or Update a relay shot.
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Replay Mark All
Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the
beginning point of your Replay Shot capture.
PRO

Create All Replay Shots
Select Create to create additional Replay shots.
PRO

Update All Replay Shots
If no replay shot exists, selecting Update creates a new Replay shot. There after,
selecting Update updates the first Replay shot created.
PRO

Configure
Displays the Replay Shot settings window.
Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an
ISO output, click Configure, then click the Add ISO button.
See Configuring Replay + ISO.

Social Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Two social media options are provided: Facebook and Twitter. Facebook enables you to
receive polling data from viewers. Twitter enables you to add Twitter messages to your
broadcast along with filtering the messages displayed.

Facebook
The Social > Facebook menu contains the Create New Poll option as well as a list of any
previously-created polls.
See Creating a Facebook Poll and Selecting a Facebook Poll.

Twitter
Message Feed
Brings up your Twitter feed.
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Create Shot
Creates a shot with a social media title in Main Layer 1.
Settings
Brings up the Social Media Settings dialog.
Authenticate
Click to authenticate your account with Twitter. Enter your pin when the PIN field
displays.
Feed Type
Select a Feed Type: Home Timeline, User Timeline, Favorites, Search. If you select
Search, the Search String field becomes active.
Search String
Enter a search string. (Active only when Search is selected in Feed Type above.)

Comments
Opens a dialog listing comments about the broadcast that are posted to Facebook,
Twitter, or YouTube.

Window Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Welcome to Wirecast
Displays the Welcome screen.
Encoder Presets
Opens the Encoder Presets window.
See Encoder Presets and The Encoder Presets Window.
Audio Mixer
Opens the Audio Mixer window.
See The Audio Mixer Window.
Audio Plugin Explorer
Opens the Audio Plugin Explorer dialog box.
See The Audio Mixer Window.
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PTZ Controller
PRO

Opens the PTZ Controller Panel.
Wirecast Pro allows you to remotely control cameras with built-in pan, tilt and zoom
(PTZ) features using the built-in PTZ Controller window. This feature currently works
with PTZOptics and Lumens cameras that support VISCA over IP control, as well as NDI
PTZ protocol controls.
See The PTZ Controller Panel.
USB Devices
Opens a list of all USB devices.
Rendezvous Dashboard
Opens the Rendezvous Dashboard. Click Start Session to use.
See Rendezvous.
PRO

Rendezvous Audio Mixer
Displays the Rendezvous Audio Mixer window.

– Output from document Select document source via the pull-down menu.
– Channel Output level indicators for each channel.
– Include In Mix When checked, this audio source is included in your Rendezvous
session.

– Audio Level (Sliders) Move the sliders Library to adjust the audio level.
Download Manager
Opens the Stock Media download monitor window. Whenever you add a Stock Media
Library file, the downloading progress is displayed. You can cancel a download by
clicking on the X icon. To navigate to the location of a downloaded file, click the
spyglass icon.
Notifications
Opens the notifications window. This window displays last “important” log messages
and other application health messages.
New Layer Window
Opens a new Main Layer window for the layer selected.
Document Windows
All open document windows are listed at the bottom of this menu.
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Help Menu
Note: To view a complete list of the default application keyboard shortcuts, see
Finding an Application Shortcut.
Wirecast Help
Opens the online version of the User Guide.
Open Wirecast PDF User Guide
Opens the PDF version of the User Guide.
Open Tutorial HTML
Opens the Wirecast Tutorial in your browser. To follow the tutorial, you'll need to Create
a Document for the Tutorial as well.
Create Document for Tutorial
Creates a new Wirecast Document which contains the media necessary for following
the Tutorial.
Buy/Upgrade
Opens Licenses in the Preferences dialog. This window allows you to purchase licenses
and to activate or deactivate them.
Provide Feedback
Opens the Telestream Website feedback page where you can enter any feedback you
may have about our product or company.
Send Support Information
Opens a Support Assistant dialog window. To create a new support ticket, select Create
a support ticket. The information is sent to the Telestream support team for evaluation.
If you have been previously issued a case number, select Link with existing support case
# and enter your case number. You can also select Do not receive follow-up from
Telestream. This enables you to send support information to Telestream without
receiving a response. Click Save Report to save the information to a file on your
computer. Click Send Report to send the information to Telestream.
For troubleshooting purposes, you can reset your preferences to the defaults by
clicking the Reset Preferences button. This will reset your preferences and create a
backup of your current preferences, in case TS Support needs it.
For troubleshooting without resetting preferences, you can also open Wirecast in “Safe”
mode using Shift + Control + Open.
Note: You must click Send Report to create a ticket. If you click Save Report, a ticket will
not be created.
Open Scripting Documentation Opens the Wirecast Scripting Help document.
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Show Scripting Examples Opens the directory where the Wirecast Scripting examples
are located.
Visit Telestream LLC Website
Opens the Telestream Website home page.
Visit Wirecast / Desktop Presenter download page
Opens the Telestream Website download page for Desktop Presenter.
Acknowledgments
Opens an on-line help to Acknowledgments.
About Wirecast
Opens a dialog box that gives the Wirecast version number and copyright information.
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Tutorials
The best way to learn Wirecast is to work quickly through all its main features. This tour
of features presents a series of three tutorials, each designed to help you understand
how to create and broadcast presentations using Wirecast.
As you work through these tutorials, you will become familiar with important Wirecast
concepts. The more you know about Wirecast, the better it will serve your broadcasting
objectives.
Because each tutorial builds on the skills and knowledge you learn in the previous
tutorials, we recommend that you take the tutorials in order. Working through all the
tutorials takes about thirty minutes.
Note: If you run the tutorials before activating a Wirecast license, or with Wirecast in
demonstration mode, Wirecast periodically superimposes a logo watermark over the
video, and a voice-over watermark over the audio.
Note: For licensing information, select File> Preferences > License. Click Purchase, or,
contact Telestream at: desktopsales@telestream.net.

Topics
■Tutorial 1: Basic Concepts 192
■Tutorial 2: Editing Shots 196
■Tutorial 3: Broadcasting 197

Tutorial 1: Basic Concepts
The goal of this tutorial is to provide you with a quick experience creating and
streaming a presentation using Wirecast.

Tutorial Prep
To prepare for this tutorial, do the following:
1. Select Help > Create Document for Tutorial.
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2. Select Switch > Smooth.
3. Select Switch > AutoLive.
4. De-select Switch > Live/Preview Swap.
5. Select Layout > Show Live Only.
Wirecast displays the Live Broadcast Area, and the Go button with the red AutoLive
LED turned on. You will change all of these options in the tutorial.

The Wirecast Default Layout
To familiarize yourself with the main windows, controls, and menus of Wirecast, see The
Default Layout.

What Is a Shot?
Wirecast uses the concept of a “shot” to construct presentations. A shot contains one or
more media sources or files, along with settings for the sources and files. A shot
contains at least one media file, such as a photo or a video clip. However, a shot can
contain a number of sources and files, such as a live camera, a title, and background
music. A shot can even include a whole playlist of clips.
You can assemble most of the files and sources for your broadcast, in shots, before you
start broadcasting. Also, you can edit a shot and change its settings (See Tutorial 2:
Editing Shots).

Switching Between Shots
Individual shots are displayed in the Layers. The Transition Controls are located just
below the Live Broadcast Area where the two default transitions are shown: Cut and
Smooth.
Replacing a shot in the Live Broadcast Area with a shot in the Preview Area is called
“taking a shot live.”
See Layers and Final Mix Audio Panel.
1. Click the Ripples shot in the third layer.
The Ripples image fades in on the Live Broadcast Area. A “fade action” occurred
when you clicked on Ripples. This is because the Smooth fade is the default transition.
2. Click the shot labeled Clear Layer.
The Ripples image fades to black. The Clear Layer shot enables you to display black
video.
Note: Wirecast does not support a true dissolve transition. The Smooth fade transition
is the transition closest to a dissolve.
If you switch from shot “A” to a shot that contains shot “A,” the Smooth fade
interpolates the difference between the two shots and animates the changes. This
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makes a shot element larger or smaller, and changes its position as needed.
However, if you switch from shot “A” to an entirely different shot “B,” then the Smooth
transition simply fades between the two shots.
3. To make the cut your default transition, select the Cut control.
4. Click the Ripples shot in the third layer.
The Ripples image cuts in on the Live Broadcast Area.
When you select Cut as the default transition, switching from shot “A” to shot “B” simply
cuts from the first shot to the second. When Smooth is selected, transitions fade in and
out, as you just saw.

Transitions
You can assign a maximum of three transitions to the Transition Controls, but more than
three transitions are available to you. To select a different transition, click the small
arrow on the right side of any of the transition buttons. When the list of transitions
appears, select a transition to assign to that button. You can also click the transition
button itself and drag the mouse downward to display the menu of transitions.
1. To change the left transition button from Cut to Bands, click the Cut button and
drag downward until the menu appears. Select Bands from the menu. Bands should
now be displayed as the left button.
2. Now click back and forth between the River and Ripples shots using Bands.
You can use these keyboard shortcuts for the two default transition buttons: Ctrl+1
and Ctrl+2.
Note: The Preferences > General tab enables you to set the number of transition
buttons that Wirecast displays.
See The Default Layout and Final Mix Audio Panel.

Transition Speed
To determine how fast a transition occurs, do the following:
1. Select Switch >Transition Speed.
2. Choose a transition speed, from Slowest to Fastest.

Layers
Note: Before you start this section, select Smooth as your default transition.
You can display several shots in the Preview Area and Live Broadcast Area at the same
time by placing them in layers, one above another.
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To broadcast a layered shot, do the following:
1. Select the Logo shot in layer 2.
2. Select the River shot in layer 3.
The Live Broadcast Area displays a layered shot containing both images.
See Layers.

Auto Live
So far in this Tutorial, Wirecast has been running in AutoLive mode. Wirecast sends any
shot you select in a layer automatically to the Live Broadcast Area. This mode is very
useful for those users who want to set up all of their shots at once and then single-click
them as they run their presentation.
The disadvantage of this single-click method is that you can’t preview the shot before
taking it live.

Turn AutoLive Off
A red LED, next to the Go button is lit when you are in AutoLive mode.
See Final Mix Audio Panel.
1. For this tutorial, turn off AutoLive. Select Switch > AutoLive.
Wirecast de-selects AutoLive. A dialog box informs you that AutoLive is off.
2. Click OK in the dialog box to continue.
3. Click the Ripples shot.
Notice that Wirecast doesn’t send Ripples to the Live Broadcast Area. That is because
AutoLive is turned off.
4. Now, click the Ripples shot, and then click the Go button.
Wirecast sends the Ripples shot to the Live Broadcast Area.
Note: When AutoLive is off, you must click the Go button (or press Ctrl+G) to display
the selected shot in the Live Broadcast Area.

Multiple Changes
A benefit of having AutoLive off is that you can make several changes to your shot first,
and then have all changes sent to the Live Broadcast Area at the same time.
Do the following:
1. Verify that AutoLive is off.
2. Click Sample Title in Layer 1.
3. Click Clear Layer Shot in Layer 2, and then click the Ripples Shot in Layer 3.
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4. Click the Go button (or Ctrl+G)
Wirecast takes the Ripples and Sample Title shots live at the same time.

Preview
One problem you may have noticed while running this tutorial is that you can’t see the
changes you are making before broadcasting them. To solve this problem, Wirecast
enables you to see a preview of what you broadcast.
1. Select Layout > Show Live and Preview.
Wirecast displays the Preview Area to the left of the Live Broadcast Area. The Preview
Area uses a green LED to identify it. The Live Broadcast Area uses a red LED to identify it. These two colors (green and red) are also used to identify which shots are
associated with the Preview or Live areas.
2. Click the River shot on Layer 3.
Wirecast displays the River shot in the Preview Area. When shots are selected they
display a green or red LED to indicate selection for Preview Area or Live Broadcast
Area.
3. To send the River shot to the Live Broadcast Area, click the Go button.
4. To remove the title from the River shot in the Preview Area, click the Clear Layer shot
in Layer 1.
5. Turn on the Live/Preview Swap option by selecting Switch > Live/Preview Swap
(check mark displayed). Notice that the Go button displays a double-arrow,
indicating that the Live/Preview Swap option is on.
See the Go button on the screenshot in The Default Layout.
6. Select the Ripples shot and click the Go button to send the Ripples shot to the Live
Broadcast Area.
Notice that the Ripples and River shots have swapped areas. Also, the shot LEDs
have changed color. The green shot LEDs indicate all shots included in the Preview
Area and the red LEDs indicate the shots included in the Live Broadcast Area. You
can view the shot that is live as you prepare your next shot in the Preview Area.

Tutorial 2: Editing Shots
The first tutorial explained various ways in which you can use existing shots. However,
you can also create and edit shots during a broadcast. This tutorial demonstrates how
to edit your shots.
1. To edit a shot, double-click its icon in a layer.
Wirecast opens the Shot Editor panel. The Shot Editor has six tabs: Shot Layers, Shot
Layer Properties, Audio, Chroma Key Properties, Smooth Transition Properties, and
Additional Source Properties.
See The Shot Editor Window.
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2. Practice editing a shot using the various options in the Shot Editor Window tabs.

Tutorial 3: Broadcasting
This tutorial demonstrates how to setup and broadcast your Wirecast presentations.
You can broadcast to a specific computer (Unicast), multiple viewers (Multicast), or
even record your broadcast to disk.
There are two main components for broadcasting your presentation (or saving it to
disk): encoding and selecting a destination.
You need to decide how you are going to encode your broadcast. Encoding is the type
of compression used (JPEG, MPEG4, etc.). Wirecast comes configured with many
common encoding options. (See The Encoder Presets Window for details.).
A destination for the broadcast must be selected. You can send it to a server for
broadcast or save it to disk.

Streaming
1. To start streaming, click the Stream button.
Note: In the Control/Status bar, the Stream icon blinks until a connection is made.
Once you are connected the Stream icon turns green. If you can’t connect, Wirecast
displays an error message. See Control/Status Bar.
Note: While streaming, the streaming status is displayed at the top of the default
layout. Connection strength is indicated by how many bars are displayed in the Stream
icon. Fewer bars indicates a weaker (slower) connection. If you are streaming to
Facebook, additional statuses are displayed on the right side of the status bar.
See Streaming Status Colors.
2. Click Stream again to stop streaming.
3. (Optional) You can also record your broadcast by clicking Record.
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Making Great Broadcasts
There are many ways to make a good live event even better. This appendix focuses on
two main things to remember about video streaming:

• High Quality Audio Input Great-looking video with poor audio is poor video.
• Good Lighting Video without light is radio. Poor lighting can ruin an otherwise

excellent live event. If you use chroma key or luma key, excellent lighting, both of
talent and background, is essential.

When video is saved to disk or sent over the network, it needs to be compressed. The
compression process is done by encoders (codecs) which are optimized to work with
clean input data. This means that if the audio or video is muddy to start with, it remains
muddy after compression. Some codecs may even exaggerate poor input because the
algorithm is built to look for differences.
Your goal is to send the best quality video and audio to the codecs. This means making
sure what you see and hear in the Live Broadcast Area is high-quality video and audio.

Topics
■ High Quality Audio
■ Good Lighting
■ Broadcast Settings

High Quality Audio
You can make a great live event even better by paying attention to audio details. Here
are some suggestions:

• Use an External Microphone Most video cameras have an audio input for an

external microphone. Use this, whenever possible, instead of the built-in microphone. Built-in microphones usually are not high quality, and they tend to pick up
hum from the electronics inside the camera. Even an average external microphone
can deliver better sound than most built-in camera mics.

• Use a Microphone Splitter or Mixer If the broadcast has more than one sound

source, use a separate mic for each sound source. Give each speaking subject a
dedicated mic. Wire the mics to a mic splitter or audio mixer. Wire the output of the
splitter or mixer to the camera audio input. Dedicated mics produce better sound
quality than one omni-directional microphone at a distance.
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• Position the Microphone Properly Place any microphone as close to the sound

source as possible, even when using omni-directional microphones, because sound
volume decreases greatly the farther away the microphone is placed. High-volume
sound hitting the microphone results in a stronger signal from the mic.

• Use Lapel Microphones Even inexpensive lapel microphones can make a huge difference because you can place them close to the source of the sound: the speaker’s
mouth.

• Control Environmental Noise If a chair squeaks, use a different chair. If you have a
wood floor and you can hear people shuffling their feet as they talk, put down a
rug. Turn off air conditioners, machines, and buzzing fluorescent lights. Do whatever it takes to keep noise at a minimum. Microphones pick up everything. Before
you start broadcasting, yell, “Quiet on the set!”

Good Lighting
Do not underestimate the power of lighting. Whether shooting outdoors or indoors,
you must control the lighting that hits the lens. For a good picture and a high-quality
video signal, you must provide your lens two things: enough light and light with the
right qualities. Here are a few suggestions to help you obtain reasonably good lighting:

• If you are using only one lighting source, do not shine it directly on your subject.
You should diffuse the light by bouncing it off of a wall or by shining it through
opaque material.

• Avoid deep shadows. Make sure you fill all areas of your subject with light. Some-

times this requires adjusting the light to bounce off a different wall or use two
lights. Placing a light low and another one high is often a good way to light evenly.

• Do not light too evenly. If you evenly light a set, you may actually be worse off than
not lighting the set at all. Take a sample shot and see if it looks natural. Good lighting usually has a little more light coming from above than any other direction. You
should very rarely light just from below a subject.

• Beware of having too much light on your subject. If your subjects are people and

you must use a lot of light, use make-up to compensate for the overly bright lighting. This is not necessarily a bad thing, but you must choose how much effort you
want to go through to make a good live event. If your lighting balance is excellent,
you can avoid using make-up on your subjects. The key in adjusting the lighting is
to look at your subject and make sure they do not look washed out.

• Watch professional events and learn from them. As you watch, notice the lighting
instead of watching the program. Notice how they employ the suggestions listed
above.

Good lighting can make an amateur video look professional and a professional video
look fabulous. The important thing to remember is that one or two properly placed
lights makes a huge difference in the quality of your live event.
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Triangular Lighting
One advanced and very effective approach to good lighting is known as triangular
lighting (or three-point lighting, or the three-light setup). This involves setting up three
lights (sometimes using natural light as one of the light sources), in a configuration that
achieves a good balance. Here are the main elements of triangular lighting:

• Key Light (Main Light) This is the strongest of your lights and does most of the

work. You can use the Sun or a strong lamp as your key light. Place the key light
higher than talent eye-level, higher than the lens, and to the left or right of the lens.
at least 20 degrees off the line between lens and talent. This creates shadows on
the subject that enhance the sense of three-dimensionality.

• Fill Light This is a soft light. Place the fill light higher than talent eye-level, higher

than the lens, and on the side of the lens opposite the key light. If your key light
comes from the left of your camera, your fill light should come from the right, or
vice versa. The fill light brightens the shadows, making them softer and less severe.

• Back Light (Rim Light) This light is directed from behind and above the subject.

Aim the back light at the top of the subject’s head. The back light is also called a rim
light because it makes a slight rim around the edge of the head of your subject. The
back light separates your subject from the back ground. This enhances the sense of
three-dimensionality and helps create a sharp separation between the subject and
a chroma-key background. Since the back light faces the lens, make sure light from
the back light does not spill into the lens, causing lens flares.

Broadcast Settings
Once you have good video and audio coming into Wirecast, make sure the broadcast
settings are configured correctly for your presentation. Though there are many
broadcast parameters to modify, there are three that are the most important:
bandwidth, motion, and encoder settings.

Bandwidth
Bandwidth is the speed of data you can broadcast from your computer to your viewers.
Transmit data no faster than your network upload speed and your viewers’ download
speed.
Estimate your viewers’ download speed by the type of Internet connection they likely
have. Are your viewers all on your corporate high-speed LAN, are they viewing from
home via DSL or cable Internet, or are they on cell phones in remote areas downloading
video over slow cell phone networks? Set your broadcasting bandwidth accordingly.
If you broadcast to a LAN, discuss your plans with your network administrator. Verify
that you will not disrupt the network with your broadcasts. Ask the administrator what
your bandwidth upper limit should be.
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Motion
Once you determine your bandwidth, determine whether your video contains a lot of
motion. An interview typically has little motion. A sports event, however, typically has
lots of motion. Wirecast comes configured with defaults to help ease your
configuration task. Choose a default configuration that meets your motion constraints.

Encoder Settings
It is beyond the scope of this document to describe the delicate balance required in
defining encoder settings. Various streaming networks publish their optimal encoder
settings. The Wirecast settings for the various streaming platforms generally are
optimized for those platforms. (See The Encoder Presets Window for information on
changing the encoder settings.)
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