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Overview
The Vantage Panel for Adobe Premiere Pro® is a free add-on panel that you can add to the 
Adobe Premiere Pro UI to send a sequence directly to Vantage. 

Using the Vantage Panel simplifies interaction between Adobe Premiere Pro and Vantage. With 
the Vantage Panel you can submit an Adobe Premiere Pro project together with variables and 
metadata to Vantage for processing, including automatic interaction with Adobe Media 
Encoder to flatten and export the sequence to a file. 

Specifically, the Vantage Panel allows you to:

• Submit an Adobe Premiere Pro sequence directly to your Vantage system without leaving
the editing environment.

• Select the Vantage workflow to which you want to submit the job

• Input values into Vantage metadata variables associated with the job submission.

Adobe Premiere Pro Process Workflow 
1. From Adobe Premiere Pro use the Vantage Panel to send an edit sequence and associated

metadata directly to a Vantage workflow.

2. The Vantage Adobe Panel first flattens the sequence using a predefined Adobe Media
Encoder preset, writing the flattened file to a network location accessible to the Vantage
domain (see the Configuration section for details about defining the preset and folder
location).

3. When the flattened sequence file is complete, the Vantage Panel sends a submit message
containing the selected Vantage workflow, the location of the flattened file and any
required metadata variable values directly to Vantage for processing.
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Requirements
In order to use this panel you will need:

Adobe System:

• Adobe Premiere Pro CC 2015 (or later) installed and operating

• Vantage Panel for Adobe Premiere Pro® CC 2015 (or later)

• System requirements for Adobe Premiere Pro can be found at
https://helpx.adobe.com/premiere-pro/system-requirements.html

Vantage System:

• Vantage 6.3 Update Pack 3 (or later) running on a separate server

– Vantage SDK Service (installed by default)

Licensing and Support
• Adobe Premiere Pro CC 2015 is purchased from and licensed by Adobe.

• Vantage is purchased from and licensed by Telestream.

• Support for the Vantage Panel for Adobe Premiere Pro® CC is provided by Telestream. If
Telestream determines that an issue requires Adobe support, Telestream will refer the cus-
tomer to Adobe.

Limitations
• Each instance of the Vantage Panel for Adobe Premiere Pro® CC works with one Vantage

domain at a time.

• This app note describes functionality of Vantage 6.3 Update Pack 3 with the Vantage Panel
for Adobe Premiere Pro® version 1.0. Features may differ if you have different versions.

• The Metadata Label entry feature is currently not supported in version 1.0.

Installing the Vantage Panel* 
Follow the steps below to install the Vantage Panel on your Adobe Premiere Pro CC system. 
Before installing make sure that:

• Your INTERNET connection is working.

• The Creative Cloud desktop app is installed with File Syncing turned on.

1. Open the Adobe Premeire Pro CC application.

2. From the Window menu, select Browse Add-Ons from the drop-down menu. Adobe’s
Creative Cloud Add-ons web page will open in your default browser.

3. From Adobe’s Creative Cloud Add-ons web page, search for Vantage.

4. Select the Vantage add-on for Premiere Pro CC, and click on the
Free button just below the panel name. The Vantage panel
downloads and installs automatically.

5. Proceed to the Configuration section of this guide.
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*Note: Adobe Extension Manager installations are not supported.
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Configuration
After the Panel is installed you will need to set up the configuration parameters that apply to 
your specific system setup. The Vantage administrator can do this by updating the Panel's 
configuration file (vantage_config.json shown below) with the appropriate values for the 
required parameters shown below: 

"vantageDomain"—The Vantage domain IP Address or fully qualified DNS name

"exportPathLocal"—This is a 'local' folder path, from the perspective of Adobe Media Encoder, 
where Media Encoder will write the flattened sequence to be processed by Vantage. It can be a 
mapped drive letter on a Windows system or a network connected volume on a Mac OS X 
system.

"exportPathAlias"—This is a network path alias, from the perspective of Vantage, to the 
flattened sequence file exported by the Adobe Media Encoder. This reference will be used by 
Vantage to read and process the exported file. Vantage will require full read permissions.

"exportPreset"—This is a local path, from the perspective of Adobe Media Encoder, to the 
Media Encoder preset used to flatten the sequence.

Sample vantage_config.json file for Adobe Premiere Pro CC installed on Windows System

{
"vantageDomain": "http://vantage-node1:8676",
"exportPathLocal": "S:\\\\Share\\\\Panel",
"exportPathAlias": "\\\\\\\\vantage-node1\\\\Share\\\\Panel",
"exportPreset": " C:\\\\Users\\\\adminuser\\\\Documents\\\\Adobe\\\\Adobe Media 
Encoder\\\\9.0\\\\Presets\\\\.epr"
}

Sample vantage_config.json file for Adobe Premiere Pro CC installed on Mac OS X System

{
"vantageDomain": "http://vantage-node1:8676",
"exportPathLocal": "/Volumes/Share/Panel",
"exportPathAlias": "\\\\\\\\vantage-node1\\\\Share\\\\Panel",
"exportPreset": "/Users/localadmin/Documents/Adobe/Adobe Media Encoder/9.0/Presets/
AdobeTest.epr"
}

Follow these steps to update the Vantage Panel configuration file:

1. The first time the Vantage Panel is launched from Adobe Premiere Pro CC, it self-generates 
the configuration file to be edited. From within Premiere Pro CC, select Window 
>Extensions > Vantage to launch the Vantage Panel. After the panel launches, close it 
immediately. This generates the vantage_config.json configuration file that will need to be 
edited.
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2. Locate and open the vantage_config.json configuration file in a simple text editor that does
not add hidden control characters to the file:

On a Windows system the configuration file is located here:

C:\Users\[your user account]\Documents\Adobe\Premiere Pro
\[Premiere Pro version]\Pro-file-[your user account]

On a Mac OS X system the configuration file is located here:

/Users/[your user account]/Documents/Adobe/Premiere Pro/[Premiere 
Pro version]/Profile-[your user account]\vantage_config.json

3. Enter your Vantage IP Address or DNS host name. Change the value associated with
"vantageDomain" to specify the server that hosts the Vantage SDK Service. Replace
"vantage-node1" with your Vantage IP Address or DNS host name. In most Vantage
installations the port number should not change:

Windows/Mac OS X— "vantageDomain": "http://[YOUR VANTAGE SERVER
HERE]:8676",

4. Enter a local path, from the perspective of the Media Encoder system, to the location where
Adobe Media Encoder will write the flattened sequence. Change the value associated with
"exportPathLocal" with a drive letter or mapped drive letter on a Windows system, or a
connected volume on a Mac OS X system.

Windows— "exportPathLocal": "S:\\\\Share\\\\Panel",

Mac OS X—  "exportPathLocal": "/Volumes/Share/Panel",

This location must be shared so that it can be accessed by Vantage.

5. Enter a network path alias, from the perspective of Vantage, to the flattened sequence file
exported by the Adobe Media Encoder. This reference will be used by Vantage to read and
process the exported file created by Media Encoder. Vantage will require full read
permissions. This is the same location as in the previous step expressed as a UNC path:

Windows/Mac OS X— "exportPathUNC":
"\\\\\\\\myserver\\\\Users\\\\myusername\\\\myfoldername",

6. Finally, enter the path to the Adobe Media Encoder preset (EPR) file you plan to use to flatten the 
sequence. This can be a custom preset located in Adobe Media Encoder's preset folder or a 
system preset located in the systempreset folder:

Mac OS X System Preset— "exportPreset": "/Applications/Adobe
Premiere Pro CC 2015/Adobe Premiere Pro CC 2015.app/Contents/MediaIO/
systempresets/3F3F3F3F4D6F6F56/HD 1080i 29.97, H.264, AAC 48kHz.epr"

Mac OS X Custom Preset— "exportPreset": "/Users/localadmin/Documents/
Adobe/Adobe Media Encoder/9.0/Presets/AdobeTest.epr"

Windows System Preset— "C:\\\\Program Files\\\\Adobe\\\\Adobe Media
Encoder CC 2015\\\\MediaIO\\\\systempresets\\\\3F3F3F3F4D6F6F56\\\\HD
1080i 29.97, H.264, AAC 48kHz.epr"

Windows Custom Preset— "exportPreset": " C:\\\\Users\\\\admin-
user\\\\Documents\\\\Adobe\\\\Adobe Media Encoder\\\\9.0\\\\
Presets\\\\.epr"

Note: Create and use custom Media Encoder presets that best support your desired 
workflow. Flatten sequences to uncompressed or a specific codec type that best meets 
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your requirements. Consult Adobe Media Encoder help for details on creating custom 
presets.

7. Save the vantage_config.json configuration file in its original location, and reopen the 
Vantage Panel from within Adobe Premiere Pro CC. (If the configuration is changed at any 
time, close and reopen the panel to import the changes.)

Once the configuration file is updated, the Vantage Panel will be correctly populated. 

Configuration Troubleshooting
The following tips are provided to help you troubleshoot your Vantage Panel configuration.

Correct Use of Slashes
For forward slashes (which are used on Mac OS X), a single slash should be used.

Example: /Volumes/HDD/Users/John/Desktop/Project

However for backward slashes, which are used on Windows and for UNC paths, four slashes are 
needed to represent a single slash. 

Example 1: C:\\\\Share\\\\Subfolder

Example 2: \\\\\\\\hostname\\\\Share\\\\Subfolder

Correct Use of Quotations Marks
If the configuration file contains any curly quotation marks or other unexpected characters, the 
Vantage panel does not work and displays the following error message when it is started from 
within Adobe Premiere Pro.

Panel Error Display

To correct the problem, replace all curly quotation marks with straight quotation marks. See the 
file excerpts below for incorrect (red) and correct (blue) examples.

Incorrect: "exportPathAlias": “\\\\\\\\qa-computer\\\\Share”,

Correct: "exportPathAlias": "\\\\\\\\qa-computer\\\\Share",
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Using the Vantage Panel

Connecting to Vantage
When the Vantage Panel is launched from within Premiere Pro CC, it automatically connects to 
the Vantage domain specified in the Panel’s configuration file and populates the Workflows 
menu with all available Vantage workflows. To refresh the list of Vantage workflows contained 
in the Workflows menu, select the Refresh button.

Vantage Panel

Workflows menu
The Workflows drop-down menu displays all Active workflows (those in an Active ready state) 
in black text. Workflows that are in an Inactive state (unable to accept jobs) are displayed in 
gray text.

Workflows Menu

Vantage workflows 
listed in a drop-down 
and search menu.

Variables and Labels 
Click a field to edit.

Vantage  domain name 
or IP address

Refresh 
workflows 
button
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Variables and Metadata Labels
When a workflow is selected, the Panel displays any associated metadata variables (with their 
default values) in the Panel’s Variables and Metadata Labels section. You can change values by 
single-clicking a field and entering a new value within the Edit box.

Edit Box

Submitting a Job
Follow these steps to submit a sequence to Vantage:

1. Open the Vantage Panel in Adobe Premiere Pro by selecting Windows > Extensions >
Vantage.

2. The Workflows tab is open by default when you open the panel. If not, select it.

3. Use the Workflows drop-down menu to view and select from the Active workflows, or type
in the name of the workflow to display a filtered list.

4. In the Variables section, enter variable values that you want to pass to the selected Vantage
workflow.

5. When all parameters have been entered, click the Submit Job button.

Adobe Media Encoder will flatten the sequence using the predefined Media Encoder pre-
set, writing the flattened file to a network location accessible to Vantage. The file is then
submitted to Vantage for processing by the selected workflow using the variable and meta- 
data label values you specified.

Note: If a sequence is deleted while the AME task is running, the job will not be submitted 
to Vantage. To avoid this issue, do not delete a sequence until the AME task is complete.

6. You can view the status of your job using any installed Vantage web or client application.
See the Vantage User’s Guide for details about job status views (http://www.telestream.net/
pdfs/user-guides/Vantage-UserGuides/Vantage-User-Guide.pdf).

Note: If the required codec is not installed on the Adobe computer for Adobe Media 
Encoder to either consume or output a particular format, then Adobe Media Encoder will 
fall back to using the "Match Source" preset.

For example on a Windows system, if the input or output for Adobe Media Encoder is MOV, 
QuickTime must be installed (otherwise Media Encoder will revert to using "Match Source").

The machine may need to be rebooted after installing codecs, such as QuickTime.
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Example Vantage Workflow
Before you can use Adobe Premiere Pro and Vantage together, you need to create Vantage 
workflows that accomplish what you want done with the source files prior to submitting them 
to Adobe Media Encoder. The following simple workflow example includes a Populate action 
that allows specifying variables and labels for adding to the source file. These are the key 
features of a workflow used with Adobe Premiere Pro and Vantage Panel:

1. Start with an origin action, such as Receive, that receives the source file from Adobe 
Premiere Pro and applies the Original nickname to the file.

2. Include additional actions, such as the Populate and Flip actions shown. These actions are 
optional according to your requirements. 

3. The variables and metadata labels you added via the Vantage Panel can be bound as 
needed to parameters in the actions for inclusion in the output file. 

For more information on Vantage workflow creation, see the Vantage Workflow Designer Tours 
section in the Vantage User Guide (http://www.telestream.net/pdfs/user-guides/Vantage-
UserGuides/Vantage-User-Guide.pdf ). 

Example Vantage Workflow
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Removing the Vantage Panel
If you want to remove the Vantage Panel add-on, follow these steps:

1. Open the Adobe Premiere Pro CC application.

2. From the Window menu, select Browse Add-Ons from the drop-down menu. Adobe’s
Creative Cloud Add-ons web page opens in your default browser.

3. From Adobe’s Creative Cloud Add-ons web page, locate My
Add-Ons, and select All your purchases and shared items 
(shown at right).

All add-ons currently installed or acquired will appear.

4. Select Remove from the Vantage listing.

The Vantage Panel is removed from Adobe Premiere Pro CC.
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Copyright and Trademark Notice
© 2017 Telestream®, LLC. All rights reserved. No part of this publication may be reproduced, 
transmitted, transcribed, altered, or translated into any languages without written permission 
of Telestream, Inc. Information and specifications in this document are subject to change 
without notice and do not represent a commitment on the part of Telestream.

Telestream, CaptionMaker, Episode, Flip4Mac, FlipFactory, Flip Player, Lightspeed, ScreenFlow, 
Switch, Vantage, Wirecast, GraphicsFactory, MetaFlip, and Split-and-Stitch are registered 
trademarks and Gameshow, MacCaption, e-Captioning, Pipeline, Post Producer, Tempo, 
TrafficManager, Vidchecker, and VOD Producer are trademarks of Telestream, LLC. All other 
trademarks are the property of their respective owners.
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