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Overview

The Vantage Database Deployment Utility allows you to upgrade or install a Vantage database into
an existing SQL 2008, 2012, or 2014 database instance. The utility auto-discovers SQL database
instances on your network and allows you to select the one you wish to install the Vantage database
into.

Because this utility installs a Vantage domain database into an existing SQL instance, it allows you to
use the existing database name and password. This allows you to create Vantage systems using
custom instance names other than VANTAGE.

Software Requirements
» The Vantage Database Deployment Utility works with Vantage version 6.3.

Licensing

» The Vantage Database Deployment Utility is available for use with any Vantage license level.

Features

« Installs a Vantage database into an existing Microsoft SQL instance. This allows custom
database instance names and passwords. Customers who need to distinguish among mul-
tiple domain databases by different instance names and passwords can do so.

o Upgrades existing Vantage database instances, making upgrades of standard, mirrored,
and clustered databases much faster and easier.

» Re-installs a clean version of a Vantage database into an existing database.

Limitations

« If you plan to use Windows authentication when deploying a database using the Database
Deployment Utility, you must also set the SQL Server service Log On to the same Windows
account that you will use for database authentication. To change the SQL Server service log on,
select Start > Administrative Tools > Services > SQL Server > Properties > Log On > This account.

» These instructions do not cover the installation of SQL or the creation of the instance.
Please refer to SQL documentation and contact Telestream for assistance if your Vantage
installation includes a mirrored or clustered database configuration.
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Prerequisites for Instance Installation

It is assumed you have already created a SQL database instance into which a Vantage database
instance can be deployed. The database instance must meet certain prerequisites before you
can use the Vantage utility to deploy a Vantage database instance:

» The SQL instance must be deployed as a named instance.

e The SQL instance must include a SQL or active directory user account. The user can be sa or
another account, and any password may be used.

» The user account installing the Vantage database must have the sysadmin role assigned.
The steps below explain how to assign a role.

» The user account running the Vantage database after it is installed can have the db_owner
and dbcreator roles assigned instead of sysadmin, if you prefer the user to have lower privi-
leges.

Configuring the Administrator Role

1. In the SQL Server Management Studio > Object Explorer panel, expand Security, and
expand Logins.

2. Right-click the sa user or another user that you want to use as the administrator login, and
select Properties.

3. Go to Server Roles and enable sysadmin. Click OK. This gives the user system administrator
privileges for the database instance.

[ Login Properties - TELESTREAM\chuckp =Ny X

Selecta page ‘ . 1=
2 S - Hell
2 General ; =3 (B el

il Server Roles
1# User Mapping Server role is used to grant server-wide security privileges to a user.

# Securables

%7 Status

B Server roles:

[T bulkadmin
[] dbereator

[] diskadmin
[ processadmin
[¥] public

[T securityadmin
[] serveradmin
[] setupadmin
[¥] sysadmin
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Configuring the Vantage User Role
1. Right-click the current Windows user and select Properties.

2. Click User Mapping. Check master or Vantage (if present) in the database column, and
check db_owner. Click OK.

5 Login Properties - TELESTREAM\chuckp [E=NEER™
Selecta page I . 7
. S - Hell
4 General ; s Lj P
| #4 Server Roles
_’@_ User Mapping Users mapped to this login:
_::_ Securables May Database User Default Schema
L Status ' TELESTREAM\chuckp =
[ model
[ msdb
[ tempdb
Vartage
. Database role membership for: master
Connection
[] db_accessadmin
Server: ["] db_backupoperator
W-CHUCKPA\DBUTILTEST [F] db_datareader
Connection: [C] db_datawriter
TELESTREAM\chuckp [C] db_ddladmin

. . ["] db_denydatareader
3 View connection properties 7] db_denydatawriter
o
Progress [] db_securityadmin
[¥] public
Ready

[ ok ][ Ccancel

3. Right-click the Windows user and select Properties again.

4, Click Server Roles and check dbcreator to enable it. Click OK. This gives the current Windows
user sufficient privileges to run the Vantage database instance after installation.

-
5 Login Properties - NT AUTHORITY\SYSTEM [E=NEER
Selecta page I - I
4 General ; — Lj =
A4 Server Roles
_»%N UUser Mapping Server role is used to grant server-wide security privileges to a user.

# Securables

1 Status
Server roles:
[7] bulkadmin
Eldbereater |
[] diskadmin
[ processadmin
[¥] public
[T securityadmin
[] serveradmin
[] setupadmin
[ sysadmin

5. From the Select a page panel, go to Memory and set Maximum server memory (in MB) to 75%
of the host system’s memory. For example, if the system's memory is 8 GB (8192 MB), then
the maximum server memory for SQL should be set to 6 GB (6144 MB) (8192 x 0.75 = 6144).

6. Click OK to close the Microsoft SQL Server Management Studio window.
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Using the Database Deployment Utility

Follow these steps to use the Database Deployment Utility to install Vantage into an existing
database instance, to upgrade an existing Vantage database to the current version, or to replace an
existing Vantage database with a clean, new Vantage database:

1. Launch the DatabaseDeploymentUtility.exe file.
2. Check the I accept the license agreement checkbox, and click Next.
3. Select a Host and Instance in the left panel.

Vantage Database Deployment Utility

Choose the SQL instance where the database will be deployed
s [ Instance & o W-TECHPUBSTEST
W-BILLH VANTAGE
W-DOM) VANTAGE Instance: VANTAGE
W-MICHELLEIZ VANTAGE Authentication: Windows Authentication
W-TECHPUBSTEST  VANTAGE
3RDPARTY SQLEXPRESS
HE-04 SQLEXPRESS
JUNO SPECTOR360 Password: ssssssssss
W-BILLH SQLEXPRESS
W-NiikAl SO FYPRESS

] Sql Server Authentication

User: sa

-

Refresh Cancel Previous | Connect |

4. In the right panel, choose an Authentication method, either Windows or SQL Server.

No matter which authentication method you choose, the user must have the sysadmin role
assigned to install a Vantage database instance.

IMPORTANT: If you use Windows authentication, you must also set the SQL Server service
Log On to the same Windows account that you will use for database authentication. Other-
wise, you will receive a logon error message.

To change the SQL Server service Log On, select Start > Administrative Tools > Services >
SQL Server > Properties > Log On > This account.

5. Enter the authentication User name and Password, if required.

6. Click Connect to connect to the database instance. A dialog opens listing the DB instance
and asking what you would like to do.

Non-Vantage Database Instance Vantage Database Instance
Vantage Database Deployment Utility ‘ Vantage Database Deployment Utility

A new Vantage Domain Database v6.3.0 will be deployed to W-CHUCKP/DBUTILTEST This 5QL instance contains an existing Vantage Database

Host name: 'W-TECHPUBSTEST
Instance name: VANTAGE

Database version: 63.0

What would you like to do?
® Upgrade

Replace existing database

Cancel Previous Cancel Previous \ Install \
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7. Select the type of deployment you want to do:

a. If you are installing the Vantage domain database into an existing non-Vantage database
instance, there is nothing to select. Just verify that the instance you connected to is listed
in the window. Then go on to the next step.

Warning: The existing contents of the database instance will be erased and replaced
with the new Vantage instance.

b. If you are upgrading or replacing an existing Vantage database, verify that the instance
you connected to is listed in the window, and then select what you want to do:

Upgrade—Select this if you want to retain the domain database contents but upgrade it
to the current Vantage database version.

Note: You cannot downgrade a database; upgrading will only move a database from pre-
vious versions to the current version.

Replace existing database—Select this if you want to completely erase the database con-
tents and install a new, clean Vantage database.

Warning: If you select Replace, all database contents WILL BE ERASED and replaced. Back
up your database first using the Vantage Management Console if you want to keep the
contents. Backing up before upgrading is also advisable as a precaution but not required.

8. Click Install.

9. If you selected Replace existing database, a warning message pops up to advise you that
your database will be completely erased and replaced if you continue.

Are you really really sure?

You are about to replace the existing Vantage
ﬂ Domain Database with a new blank database. This

process cannot be undone. Are you sure you want to
do this?

[ ok || cancel |

10. Click OK to install the upgraded or new database.
11. A window opens to show progress and advises you when the installation is complete.

Vantage Database Deployment Utility

Installation complete

Hest name: W-CHUCKP

Instance name: DBUTILTEST

| [ Finish |

12. Click Finish when the progress window indicates Installation/Upgrade Complete.

The database has now been converted/upgraded to a current Vantage database. If you
chose Upgrade, the Vantage domain database contents remain intact, but the database
structure is upgraded. If you chose Replace, a clean Vantage domain database is installed.

.
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13. You are now ready to install or upgrade Vantage:

14.

15.

a. New Vantage Installations: If you are installing a new Vantage instance, run the
Vantage_Setup.exe installer, select Array {Multi-Node} Installation, select Custom, select
the components you want, but do NOT select Database. This ensures Vantage installs,
but the database is not touched.

b. Upgrading Vantage: If you are upgrading an existing Vantage instance, use the Control
Panel Programs and Features to remove only Vantage but leave MS SQL and the domain
database in place. Then run the Vantage_Setup.exe installer, select Array {Multi-Node}
Installation, select Custom, select the components you want, but do NOT select Database.
This ensures Vantage installs, but the upgraded database is not touched.

If necessary, use the Vantage Management Console > File > Change Vantage Domain
(shown below) to connect your new or upgraded Vantage installation to the deployed
database.

If you installed a Vantage database with a custom name and password, you may need to
select My Vantage Domain isn't listed. Then enter the server name, the custom database
name, expand the Connection settings, and enter the custom Login and Password. When
you click OK, the Vantage Management Console should connect to the database and begin
normal operation.

Select Vantage Domain

Select Vantage Domain

Select a Vantage Domain: Select a Vantage Domain:

3RDPARTY 3RDPARTY

PROD-MATTK
W-DOMI
W-MICHELLEI3
W-TECHPUBSTEST

W-MICHELLEI3
W-TECHPUBSTEST

¥ Connection Settings Enter name or IP address of your Vantage Domain server:

W-CHUCKP
My Vantage Domain isn't listed
Enter the Vantage instance name:

DBUTILTEST

~ Connection Settings

Specify the connection settings for accessing the Vantage SQL Server
database. Normally you will use the default values, unless your Vantage
administrator has specified otherwise.

Login: sa

Password: sessssssss

| oK | Cancel

REMINDER: If you use Windows authentication, you must also set the SQL Server service
Log On to the same Windows account that you will use for database authentication. To
change the SQL Server service Log On, select Start > Administrative Tools > Services > SQL
Server > Properties > Log On > This account.

If necessary (for a new installation), install Vantage licenses using the Vantage Management
Console > Licenses panel and configure Vantage as described in the Vantage Domain
Management Guide.
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Copyright and Trademark Notice

Copyright © 2015 Telestream, LLC. All rights reserved. No part of this publication may be
reproduced, transmitted, transcribed, altered, or translated into any languages without written
permission of Telestream. Information and specifications in this document are subject to
change without notice and do not represent a commitment on the part of Telestream.

Telestream, CaptionMaker, Episode, Flip4Mac, FlipFactory, Flip Player, Lightspeed, ScreenFlow,
Vantage, Wirecast, GraphicsFactory, MetaFlip, and Split-and-Stitch are registered trademarks
and Pipeline, MacCaption, e-Captioning, and Switch are trademarks of Telestream, LLC. All
other trademarks are the property of their respective owners.
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