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Contacting Telestream
To obtain product information, technical support, or provide comments on this guide, contact us using 
our web site, email, or phone number as listed below.

Copyrights and Trademark Notices
Copyright © 2022 Telestream, LLC and its Affiliates. All rights reserved. No part of this publication may 
be reproduced, transmitted, transcribed, altered, or translated into any languages without written 
permission of Telestream, LLC. Information and specifications in this document are subject to change 
without notice and do not represent a commitment on the part of Telestream. Specifications subject to 
change without notice.

Telestream, CaptionMaker, Cerify, DIVA, Episode, Flip4Mac, FlipFactory, Flip Player, GraphicsFactory, 
Kumulate, Lightspeed, MetaFlip, Post Producer, ScreenFlow, Switch, Tempo, TrafficManager, Vantage, 
VOD Producer, and Wirecast are registered trademarks and Aurora, ContentAgent, Cricket, e-
Captioning, Inspector, iQ, iVMS, iVMS ASM, MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port, 

Resource Contact Information

Telestream Technical 
Support

Support Website: https://www.telestream.net/telestream-
support/captioning/support.htm
Support Email: www.telestream.net/telestream-support/
captioning/contact-support.htm
Enterprise Telephone Support: 
U. S. Toll Free: (877) 257-6245
U. S. from outside U.S.: (530) 470-2036
Europe | Middle East | Africa | Asia | Pacific:
 +49 228 280 9141
Terms and times of support services vary, per the terms of 
your current service contract with Telestream.

Telestream, LLC Web Site: www.telestream.net
Marketing Email: info@telestream.net
Telestream, LLC
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International 
Distributor Support

Website: www.telestream.net
See the Telestream Website for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net
Share comments about this or other Telestream documents.

Video Tutorials www.telestream.net/telestream-support/captioning/
tutorials.htm


https://www.telestream.net/telestream-support/captioning/support.htm

https://www.telestream.net/telestream-support/captioning/support.htm

www.telestream.net/telestream-support/captioning/contact-support.htm

www.telestream.net/telestream-support/captioning/contact-support.htm
http://www.telestream.net
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
http://www.telestream.net/telestream-support/overview.htm

https://www.telestream.net/telestream-support
mailto:support@telestream.net
http://www.telestream.net/telestream-support/captioning/tutorials.htm
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CaptureVU, FlexVU, PRISM, Sentry, Stay Genlock, Aurora, and Vidchecker are trademarks of Telestream, 
LLC and its Affiliates. All other trademarks are the property of their respective owners. 

Adobe. Adobe® HTTP Dynamic Streaming Copyright © 2014 Adobe Systems. All rights reserved.

Apple. QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour logo, and the 
Bonjour symbol are trademarks of Apple, Inc.

Avid. Portions of this product Copyright 2012 Avid Technology, Inc.

CoreOS. Developers of ETCD.

Dolby. Dolby and the double-D symbol are registered trademarks of Dolby Laboratories Licensing 
Corporation.

Fraunhofer IIS and Thomson Multimedia. MPEG Layer-3 audio coding technology licensed from 
Fraunhofer IIS and Thomson Multimedia.

Google. VP6 and VP8 Copyright Google Inc. 2014 All rights reserved.

MainConcept. MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. 
Copyright 2004 MainConcept Multimedia Technologies.

Manzanita. Manzanita is a registered trademark of Manzanita Systems, Inc.

MCW. HEVC Decoding software licensed from MCW.

MediaInfo. Copyright © 2002-2013 MediaArea.net SARL. All rights reserved. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 
THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Microsoft. Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008 |Server 
2012|Server 2016|Server 2019, Windows 7, Windows 8, Windows 10, Media Player, Media Encoder, .Net, 
Internet Explorer, SQL Server 2005|2008|2012|2016|2019, and Windows Media Technologies are 
trademarks of Microsoft Corporation.

NLOG, MIT, Apache, Google. NLog open source code used in this product under MIT License and 
Apache License is copyright © 2014-2016 by Google, Inc., © 2016 by Stabzs, © 2015 by Hiro, Sjoerd 
Tieleman, © 2016 by Denis Pushkarev, © 2015 by Dash Industry Forum. All rights reserved.

SharpSSH2. SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. Redistribution and use in 
source and binary forms, with or without modification, are permitted provided that the following 
conditions are met:

Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer:
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Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors may be used to 
endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY 
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL 
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Swagger. Licensed from SmartBear.

Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.

VoiceAge. This product is manufactured by Telestream under license from VoiceAge Corporation.

x264 LLC. The product is manufactured by Telestream under license from x264 LLC.

Xceed. The Software is Copyright ©1994-2012 Xceed Software Inc., all rights reserved.

ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.

 

Other brands, product names, and company names are trademarks of their respective holders, and are 
used for identification purpose only.

MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT COMPLIES WITH THE 
MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR PACKAGED MEDIA IS EXPRESSLY 
PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE PATENTS IN THE MPEG-2 PATENT PORTFOLIO, 
WHICH LICENSE IS AVAILABLE FROM MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 
80237 U.S.A.



5

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING VIDEO IN COMPLIANCE 
WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/OR (ii) DECODING MPEG-4 VIDEO THAT 
WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR 
WAS OBTAINED FROM A VIDEO PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER 
USE. ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL AND 
COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE HTTP://
WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL USE OF 
A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE REMUNERATION TO (i) ENCODE VIDEO 
IN COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS 
ENCODED BY A CONSUMER ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A 
VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED 
FOR ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://
WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE FOR 
ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT AN ADDITIONAL 
LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR ENCODING IN CONNECTION WITH (i) DATA 
STORED OR REPLICATED IN PHYSICAL MEDIA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) 
DATA WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR 
PERMANENT STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the product will 
perform as stated below for a period of one (1) year from the date of shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment supplied but 
not manufactured by the Company but NOT including any third party equipment that has been 
substituted by the Distributor for such equipment (the “Hardware”), will be free from defects in 
materials and workmanship under normal operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any defective Hardware 
component or part, or Software Media, with new or like new Hardware components or Software Media. 
Components may not be necessarily the same, but will be of equivalent operation and quality. 
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Software Updates
Except as may be provided in a separate agreement between Telestream and You, if any, Telestream is 
under no obligation to maintain or support the Software and Telestream has no obligation to furnish 
you with any further assistance, technical support, documentation, software, update, upgrades, or 
information of any nature or kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or Software Media, 
or any part thereof, is damaged due to abuse, misuse, alteration, neglect, or shipping, or as a result of 
service or modification by a party other than the Company, or (ii) Software is modified without the 
written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER WARRANTIES, 
EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE. No oral or written information or advice given by the Company, 
its distributors, dealers or agents, shall increase the scope of this Limited Warranty or create any new 
warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the country in which 
the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF TELESTREAM, 
LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS LIMITED WARRANTY. Your sole and 
exclusive remedy for any and all breaches of any Limited Warranty by the Company shall be the 
recovery of reasonable damages which, in the aggregate, shall not exceed the total amount of the 
combined license fee and purchase price paid by you for the Product. 

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, 
LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR 
INABILITY TO USE THE PRODUCT, OR THE BREACH OF ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF 
THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY 
PROVIDED FAILS OF ITS ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA

You can call Telestream during U. S. business hours via telephone at (530) 470-1300.
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Regulatory Compliance
Electromagnetic Emissions: FCC Class A, EN 55022 Class A, EN 61000-3-2/-3-3, CISPR 22 Class A

Electromagnetic Immunity: EN 55024/CISPR 24, (EN 61000-4-2, EN 61000-4-3, EN 61000-4-4, EN 61000-
4-5, EN 61000-4-6, EN 61000-4-8, EN 61000-4-11)

Safety: CSA/EN/IEC/UL 60950-1 Compliant, UL or CSA Listed (USA and Canada), CE Marking (Europe)

California Best Management Practices Regulations for Perchlorate Materials:
This Perchlorate warning applies only to products containing CR (Manganese Dioxide) Lithium coin 
cells. Perchlorate Material-special handling may apply. See www.dtsc.ca.gov/hazardouswaste/
perchlorate.
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Introduction

With CaptionMaker, you can generate captions for television, web, and mobile delivery. 
CaptionMaker enables you to author, edit, encode and re-purpose video captions. 
Using exclusive e-Captioning™ technology, CaptionMaker generates captions that 
comply with broadcast standards and regulations.

Topics
■The CaptionMakerMacCaption Workflow 14

■Comparing CaptionMaker & MacCaption Versions 14

■Identifying Pro and Enterprise Features in This Document 16

■Captioning at a Glance 17

■Live Captioning 19

■CaptionMaker Workspace 20

■Vantage and Switch Captioning Support 23
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The CaptionMakerMacCaption Workflow
You can use CaptionMaker in workflows like the following:

Figure 1. The CaptionMaker Workflow

Comparing CaptionMaker & MacCaption Versions
The CaptionMaker and MacCaption applications are available in three levels: Desktop, 
Pro, and Enterprise.

The following table compares the features between levels. To add capabilities, you can 
purchase an upgrade to another level.
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Target uses Caption and subtitling 
authoring and editing

Authoring, editing, QC, 
asset management, 
TV broadcast exports

Target customers Corporate, independent, 
academic, government, 

houses of worship

Caption service providers,
TV networks, Post facilities

Authoring/Exports

Caption Authoring, Timing and Formatting1

Timed Text Speech cloud based auto-
transcription1

Auto Time Stamp (sync text and audio)

√

√

√

√

√

√

√

√

√

√

√

√

√

Auto-transcription with a Telestream Cloud 
account in over 100 languages1

√ √ √

√ √ √

√

√

√

√

√ √ √

√ √ √

√

√

√ √

√

√

√ √

Caption Asset Management (Imports/Conversions)

Automation

Assemble Captions3 (conform to EDL)
Batch processing (GUI)2

1Auto Transcription and Timed Text Speech usage requires a Telestream Cloud account and is an additional cost, based on consumption billing 
2Currently available for CaptionMaker only
3Currently available for MacCaption only

√ √

Desktop Pro Enterprise

Export SCC (CEA-608) & MCC (CEA-708) 
files 

Streaming/Mobile Video (SMPTE 2052 timed 
text--TTML and DFXP, Vimeo, Safari, 
Android, IMSC 1.0, IMSC 1.12, WebVTT, 
SRT, iOS, YouTube, WMV, SAMI, etc.)

Burn-in Subtitles and Basic DVD Subtitles

iTunes iTT subtitle creation, edit, and export3

Drop shadow option for subtitling workflows3 

Japanese Ruby Annotation formatting 
support3  
Subtitle overlay (movie w/alpha channel
subtitle graphics)
      
Advanced DVD/Blu-ray subtitles

TV broadcast and VOD media
(ProRes, MPEG-2, H.264, MXF, Avid AAF2, 
tape, etc.)

OP-47/OP-42 Teletext for MXF Workflows2

Export caption interchange files 
(Cheetah CAP, TDS2, ULT, EBU-STL, etc.)

V-chip/XDS/AFD Encoding
Live captioning2 (via hardware encoder or
web stream e.g. YouTube)

Reformat Pop-on <-> Roll-up

Import Nexidia QC .XML Report2

Extract CC from video files (MOV, MXF, 
MPEG-2, etc.)

Import caption interchange files (Cheetah 
CAP, TDS2, ULT, PAC, EBU-STL, etc.)

Import plain text, SCC & MCC, web formats

Scripting & External Control (CLI)

√

√

√

√

√

√

√

√

√

√

√

√

√

√

√

√ √

√

√

√ √

Automation & high 
volume caption and 

subtitle asset delivery

Major networks, content 
providers, asset management 

& distribution services
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Identifying Pro and Enterprise Features in This 
Document

Some features described in this document are available only in the Pro or Enterprise 
versions of CaptionMaker. Features that are included in the Pro version are identified by 
the following PRO icon:

The Enterprise version includes all available features. Features that are included only in 
the Enterprise version, and not in Desktop or Pro, are identified by the following ENT 
icon.

Note: Features that have no icon are included in three versions.
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Captioning at a Glance
Captioning is basically a three-step process.

1. Transcribing—Creating a text transcript of the video dialogue.

2. Designing—Setting the timing, placement, and appearance of the captions.

3. Encoding—Encoding the caption data into the video, or exporting the data into a 
separate caption file.

Transcribing a Video
The transcription features in CaptionMaker can create a text transcript of a video, and 
can add the transcription into the captioning project with the correct timing. The 
Transcription Edit Mode can be used to facilitate easy editing of that timed text, or of 
any text that you have loaded into the project.

For details, see the Transcription chapter.
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Importing a Text File
CaptionMaker can import scripts from a text file and most word processors, such as 
Word Rich Text Files (.rtf ). Rich Text Files provide the option of importing colors and 
italics. However, because of special formatting and characters used in some kinds of 
document files, it is often best to start with a plain text (.txt) file.

Using a Video File
The other ingredient you need for producing captions is a video file. Make sure you are 
using a digital video file, not videotape, as your video source. CaptionMaker can play 
back most types of QuickTime files, and also Windows Media files (Windows only). See 
Opening a Movie for a list of all file types that play in CaptionMaker.

If you have a file format that won’t play, please see Using a Proxy Movie to learn about 
making a proxy movie for use with CaptionMaker.

Automatic Time Stamp (ATS)
In most other captioning software, even after you import the transcript and video, you 
must go through a time consuming process to manually synchronize each piece of text 
so that it appears at the correct time in the video.

In CaptionMaker Auto Time Stamp (ATS) automatically synchronizes the text transcript 
with your audio or video file, dramatically reducing the time it takes to caption a video. 
See  for instructions on ATS operation.
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Live Captioning
You can use CaptionMaker to accept live caption data from a stenography machine, 
regular keyboard, or other method. You can then send the captions to an encoding 
device or, through the Internet, to services that accept live caption data.

For both live broadcast captioning and Internet (web) text streaming, you need a way 
to enter the text in real time. There are two common methods for importing captions: 
steno typing and speech recognition software.

Stenographic typing can be more accurate than speech recognition, but stenographic 
typists can be expensife.

To increase speech recognition accuracy, you can train the software to recognize one 
person’s voice. This can be the presenter, or a shadow speaker. A shadow speaker is also 
necessary when there is more than one person speaking.

See How to Transcribe a Movie for more about speech recognition software, and 
Shadow Speaker in the Glossary.

See Live Captioning.

Live Captioning Operation
For examples of live caption configuration and operation, see Live Caption Data Input 
into CaptionMaker in the Example Workflows chapter. 

Send Live Captions to Lightspeed Live Stream
CaptionMaker can be used as the source of live caption input into a Telestream 
Lightspeed Live Stream server. For details on how to do this, see Sending Live Captions 
to a Telestream Lightspeed Live Stream Server.

CC Encoder Hardware
For live broadcast TV encoding, CaptionMaker requires a hardware encoder. Hardware 
encoders range in price from $1,200 to $10,000 depending on whether the video is 
analog, digital SD, or digital HD.


https://support.telestream.net/s/article/Live-Captioning
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CaptionMaker Workspace
The CaptionMaker workspace contains the following main sections.

• Menus and Toolbars To control toolbar display, choose View > Toolbars and Dock-
ing Windows. See the Menus chapter for details on menus and Main Toolbar for 
details about the toolbars

• Video Playback and Caption Preview Panel Play the video and preview the cap-
tion/subtitle timing, location, and formatting. The Preview Panel shows how it will 
typically look in the final display destination. 

• Editing Operation Controls Buttons provide controls for most of the common 
editing operations.

• Text Panel Provides timing and display parameters, text editing, and caption/subti-
tle selection. To select the columns you want to display, choose View > Visible Col-
umns.

• Status Bar Provides information about some current settings and operations. 
• Programs CaptionMaker effectively runs six copies of itself simultaneously, 

enabling you to manage up to six caption languages (Programs) in one Caption-
Maker project file. Select which copy of CaptionMaker (Program) you want to man-
age by clicking the Program tabs at the top of the editing grid, or by selecting View 
Menu > Select Program. All functions (editing, importing, exporting, etc.) operate on 
the currently selected program.

Note: To display the video preview, deselect View > Semi-full Screen Spreadsheet. 
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Preview Panel Subtitle Display Limitations
The CaptionMaker preview panel does not support transparency/translucency when a 
movie is open in the preview panel, so it does not display transparent/translucent 
background subtitles correctly.

For example, if you set the Background Translucency to transparent, the exported 
subtitles will correctly have transparent backgrounds, but the preview panel can only 
display the subtitles with opaque backgrounds (when a movie file is open in the 
preview panel).

Note: In CaptionMaker 8.2.1 and later, users may view transparent subtitle 
backgrounds in the preview player window by opening the movie file using Microsoft 
Media Foundation (MMF).

Main Toolbar Video Playback and Caption Preview Panel

Text Panel Status Bar

Program tabs

Ancillary Toolbar

Operation 
Controls
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Full Screen Text Panel
To have a large view of the text panel, select View > Full Screen Spreadsheet. Or, you 
can click the  Full Screen Spreadsheet button on the Main toolbar.

Semi-Full Screen Text Panel
To have a larger view of the text panel, while still keeping most controls available and 
hiding the video preview, select View > Semi-full Screen Spreadsheet.

Pop-Up Video Preview Window
To view the video preview panel in a separate window, select View > Pop-Up Preview 
Window. You can place this window wherever you like.

Margin Indicator Frame
An optional white frame indicates where the margins are set for captions and subtitles. 
To turn the display of this frame on or off, or to adjust the margins, see Set Caption 
Margins and Set Subtitle Margins in the Menus chapter. CaptionMaker displays the 
frame only when captions or subtitles are present.
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Vantage and Switch Captioning Support
The Telestream software tools, Vantage and Switch, are great companions to 
CaptionMaker. Vantage and Switch provide tools for creating, editing, encoding, and 
verifying caption data. Vantage and Switch support professional file formats used for 
TV and the Internet.

Telestream Vantage version 7.0 and later, with the Timed Text Flip service, provides 
many caption encoding and transcoding features, including:

• MCC caption file support, including CEA-608 and CEA-708 caption data insertion.

• MXF caption data insertion for SMPTE 436M.

• MPEG-2 user data 608/708 insertion (A/53).

• Direct-convert caption data pass-through, such as MPEG-2 to MXF captions.

• Burn-in subtitle overlays.

• DVB Subtitling.

For a complete list of caption and subtitling features of Vantage Timed Text Flip, please 
visit   http://www.telestream.net/vantage/TimedText.htm

Note: CaptionMaker does not convert, or transcode, media files. However, 
CaptionMaker can convert caption files of one type to caption files of many other 
types.
Vantage has options for converting media files of one type to media files of other 
types.

Switch can decode and play many caption and subtitle files, with features such as:

• Playing captions embedded in video and side-car caption files.

• Decoding embedded CEA-608 and CEA-708 caption data.

• Playing Internet caption files, such as WebVTT, iTT, TTML, and so on.

• MXF ancillary caption track decoding and playback.

• MPEG-2 user data caption decoding and playback.

• Decoding and playback of various caption and subtitle files, such as SCC, MOV, DV, 
DVB, LXF, GXF, SMPTE-TT, SRT, EBU-STL and so on.

• Viewing Vertical Ancillary (VANC) caption data on an external monitor. 

Note: Common video players such as VLC, Windows Media Player, QuickTime Player, 
Sony XDCAM Viewer, and so on, do NOT display most types of closed captions. So 
even if your video will play in one of these players, it may not show the captions.

For more information and additional features of Vantage Timed Text Flip and Switch, go 
to telestream.net. 

http://www.telestream.net/vantage/TimedText.htm
http://www.telestream.net/vantage/TimedText.htm
http://www.telestream.net
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Installation

The topics in this chapter provide system requirements, explain how to install or 
upgrade your captioning software, and describe how to use the HASP Network Dongle. 

Note: The Demo version of CaptionMaker can only run in trial mode. When you 
purchase a license, you must download and install a licensed version in order at 
activate CaptionMaker.
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System Requirements
The following describes the minimum operating system and computer requirements to 
run CaptionMaker.

Supported operating systems:

• Windows 7 (32/64-bit)

• Windows 8 and 8.1 (32/64-bit)

• Windows 10 (64-bit)

• Windows Server 2008, 2012 R2, and 2016 
Note: “Desktop Experience” feature must be installed

Computer requirements:

• 2GB RAM

• 5GB free Hard Disk space

• Minimum screen resolution: 1024x768 or 1280x720 (720p)

• One free USB port (only if using a dongle-based license)

• Internet access required for Timed Text Speech transcription and some online fea-
tures

• PDF reader required to view documentation

• Auto Time Stamp requires 2GB RAM and Java Runtime Environment (JRE) version 6 
or later

• QuickTime Player 7.6 or later is recommended

Available Subtitling and Captioning Characters
For subtitling, you can generate any character or symbol that you can generate on the 
computer's screen, though you may have to download a font into the memory of your 
external device depending on which one you are using.

However, captioning is a different case. The closed caption encoder does not actually 
draw the characters, but tells the closed caption decoder which characters to display. 
The languages supported by typical closed caption decoders include the following:

• Dutch, English, French, German, Portuguese, and Spanish.

Installing and Activating CaptionMaker
When you purchase CaptionMaker you will receive a software license key. You can 
easily download and install the software by clicking on the downloads page at 
telestream.net and following the instructions.

Note: As of version 6.3 of CaptionMaker and MacCaption, only Desktop, Pro, and 
Enterprise licenses issued by Telestream are supported. If you purchased 

http://www.telestream.net
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CaptionMaker or MacCaption prior to October 2013, you need to upgrade to a 
Telestream Desktop, Pro, or Enterprise license before upgrading to the current 
software version. Please contact Telestream for more information.

For detailed CaptionMaker installation, upgrading, and setup instructions, see the 
chapter, Installation.

Follow these steps to install CaptionMaker:

1. Download the CaptionMaker installer and run the setup program.

2. Click Setup to start the CaptionMaker InstallShield Wizard. Follow the on-screen 
instructions in the installation dialogs.

3.  When asked if you want to install the HASP USB dongle drivers:

a.  Select Yes if you are using a USB dongle-based license.
b. Select No if you will enter your serial number directly in the application.

4. Click Finish to close the installer.

Buying CaptionMaker
Follow these steps to buy a license and activate the software:

1. After purchasing CaptionMaker, you will receive instructions to download the 
licensed (non-Demo) version of the software. You must install the licensed version of 
CaptionMaker in order to activate your license. See the previous section for 
instructions on installing CaptionMaker.

2. Start the program for the first time by clicking on the CaptionMaker icon on your 
desktop. The first time the software runs, you will see the following message 
indicating CaptionMaker is running in DEMO mode.
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Note: To start the program, you can also go to the Start Menu, Telestream folder, and 
click CaptionMaker.

3. Click OK to continue.

4. Open the Help menu, and select Manage CaptionMaker License.

5. In the Manage CaptionMaker License dialog, click Activate/Purchase.

6. Enter your serial number and click OK. 

7. Click Activate License. If you have Internet access, activation will complete 
automatically. The Manage CaptionMaker License says, “CaptionMaker is 
registered.”
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8. Quit and restart CaptionMaker. Then go to Help > About CaptionMaker. Verify that 
the window reads CaptionMaker-Desktop, -Pro, or -Enterprise, matching the license 
you purchased (as shown below). You are now ready to use CaptionMaker.

 

Activating CaptionMaker Offline
Please follow the procedure outlined below to activate CaptionMaker on a computer 
that has no Internet connection.

1. To begin manual activation, please open the Manage CaptionMaker License dialog 
from the Help menu.

2. Once in the CaptionMaker License dialog, click on the Activate/Purchase License 
button. Enter your serial number and then click OK.
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3. The Offline Activation Dialog opens.

Note: The code in this screenshot is for demonstration purposes only. You must use 
the code generated on your computer.

4. Copy the code provided in the “Offline Activation” window into TextEdit or 
Notepad and move the saved file onto a USB thumb drive.

Note: The code is linked to this computer. If you move the license to a new computer, 
you will need to generate a new Offline Activation code on that computer.
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5. Using another computer with Internet access; Copy the code from the USB or 
thumb drive and enter the Offline activation code at URL: http://
cws.telestream.net/offlineactivation.aspx.

6. Click the “Submit” button after entering in the code to receive the license file.

7. Once the license file downloads, place on a thumb drive, or a location that is 
accessible by the Offline computer.

8. Go back to the machine without Internet access and place the License file onto the 
desktop.

9. From the Offline activation window click “Choose License File...” button and select 
the License file on your desktop. Click the Open button and CaptionMaker will 
become activated.

Upgrading CaptionMaker
If you need to use features that are in a higher level of the software, you can buy an 
upgrade.

Note: If you are upgrading from a previous version and you work with external 
hardware, such as a caption encoder, VTR deck, or external time code interface, 
Telestream recommends that you write down your device configuration settings such 
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as port, address, and so on, prior to upgrading, in case these settings need to be 
entered again.

To upgrade, you can select Help > Purchase/Upgrade to go to the Telestream Online 
Store web page, or follow these steps to upgrade your license using Help > Manage 
CaptionMaker License:

1. Open the Help menu, and select Manage CaptionMaker License.

2. In the Manage CaptionMaker License dialog, click Upgrade.

3. In the online store, select the license level you want to buy.

4. Follow the on-screen prompts to purchase the upgrade. The procedure that follows 
explains how to activate the upgraded license.

Activating a CaptionMaker Upgrade
Usually the upgrade process will complete automatically, but in some cases you may 
receive the upgrade key via email. In that case you must deactivate your old key in 
order to enter the new key. To activate your upgraded license, follow these steps:

1. Open the Help menu, and select Manage CaptionMaker License.

2. Click Deactivate License. This requires an Internet connection.

3. Confirm that the screen shows The serial number is valid, but it is not activated.

4. Click Edit Serial Number. A dialog box opens to allow serial number entry.
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5. Enter the new serial number, and click OK.

6. Click Activate License.

7. Confirm that the screen shows CaptionMaker is registered and shows the upgraded 
license level.

 

Deactivating a CaptionMaker License
If you want to move the CaptionMaker license to another computer, you must first 
deactivate it on the current computer. This action requires Internet access. Follow these 
steps:

1. Open the Help menu, and select Manage CaptionMaker License. A dialog opens 
indicating that the product is registered and allowing you to deactivate the license.

2. Click Deactivate License.

3. Confirm that the screen shows The serial number is valid, but it is not activated.

 

4. Once deactivated, you may now activate this serial number on another computer 
where you have installed CaptionMaker. 

Deactivating an Offline Activated License
At times it may be necessary to deactivate an offline activated license on a system that 
has no Internet connection (for example, to update the license support renewal date). 
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In order to do this, you must use the CaptionMakerForceDeactivate utility included in 
the CaptionMaker install directory.

1. Close any open instances of CaptionMaker.

2. Navigate to the CaptionMaker install directory (Default Path: C:\Program Files 
(x86)\CPC\CaptionMaker)

3. Double click on the 'CaptionMakerForceDeactivate.exe' utility.

4. When prompted, supply your system Administrator credentials.

5. Relaunch CaptionMaker and follow the procedure for Activating CaptionMaker 
Offline. 

HASP Network Dongle
Note: Dongles are no longer available for purchase. However, legacy dongles are still 
supported for those who have them.

The network dongle option avoids the need to physically keep or move standalone 
(single user) dongles around to individual machines. For example, if you need 
Telestream software for 4 concurrent users at your organization. Instead of receiving 4 
single user dongles, you would receive one physical network dongle. It would be 
connected to any Windows or Mac physical machine on the LAN, and provides a 
floating license available to any physical or virtual machine on the LAN. Any computer 
on the LAN or VPN can make use of one of these licenses.

Another advantage is that the network licenses can be shared over the LAN or VPN 
(including over the Internet) without having to physically move the USB keys. This 
allows remote users to run the software on their computers while traveling or working 
remotely. Only the license itself is shared over the network, the actual software is 
running directly on the computer, so there are no speed issues as with remote-desktop 
or screen-sharing solutions.

The number of concurrent users of the software is limited to the number of licenses 
purchased. For example, if you have 4 licenses on your network dongle, any 4 machines 
can open the software at the same time; if a 5th machine tries to run the software, it will 
give an error until one of the other 4 open copies is closed. 

If you are interested in upgrading your existing single user keys to a network key or 
have any questions about the network key option, please feel free to contact 
Telestream.

The network dongle uses TCP/UDP port 1947 for local (LAN only) communication. This 
port must not be blocked in order for a station to access the network license.

Troubleshooting HASP
On any machine with Telestream captioning software (or just the HASP drivers) 
installed, you can check the status of HASP drivers and keys by going to:
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http://localhost:1947

If the web page doesn't open as Sentinel Admin Control Center, then the HASP driver is 
not installed or not running. You can find troubleshooting tips in the Telestream 
Knowledge-Base article HASP dongle troubleshooting.

If the page opens, click "HASP Keys" or "Sentinel Keys" (depending on the version) on 
the left.

On the Server Machine
The network key will show up under Location: Local. If not, then the server is not 
recognizing the dongle.

Click Configuration on the left, then go to the tab Access from Remote Clients. Make sure 
Allow Access from Remote Clients is checked. If not, check it, then click Submit.

Click Show Recent Client Access to see IP addresses and client names that have 
communicated with the key. Under Access it should always say allowed. On this list you 
should be seeing the names/addresses of clients that are trying to access the key.
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On the Client Machines
The server's network key should show up under Location, and contain the name or IP 
address of the server. For example, VELA in the following screenshot.

Click Configuration on the left, then go to the tab Access to Remote License Managers. 
The following checkboxes must be checked: Allow Access to Remote Licenses and 
Broadcast Search for Remote Licenses. You can also try checking Aggressive Search for 
Remote Licenses.

Pointing a Client to a Specific License Server
The following steps can be used if the client is not seeing the subnet broadcast packets 
from the license server, or if you have multiple license servers and want to restrict a 
specific client to only use a specific license server. Also, in general this may help if you 
are having trouble getting the server's key to show up on the client.

1. On each client, open http://localhost:1947.

2. Click Configuration on the left, then select the tab Access to Remote License 
Managers. 

3. Uncheck the checkbox Broadcast Search for Remote Licenses, and check the 
checkbox Aggressive Search for Remote Licenses.

4. Under Specify Search Parameters, enter the IP address of the license server.

5. Click Submit. (You may need to wait a few minutes.)

To Disable Remote Network HASP Keys on a Particular Client
If you have a client that you don't want to access a remote network key, you can disable 
access to remote keys. For example, a client has a single user HASP key and you don't 
want it to preferentially grab the network key instead. 

To disable access to remote keys:

1. Click Configuration on the left, then go to the tab Access to Remote License 
Managers.
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2. Uncheck the option Allow Access to Remote Licenses.

If You're Still Having Trouble
If the network key still does not show up on the client, and/or if the client does not 
show up on the server under Show Recent Client Access, then TCP/UDP port 1947 
communication between the server and the client is getting blocked somehow. 
Unfortunately this opens up a wide range of possible issues specific to the network 
setup, and may require a networking guru to get involved.

QuickTime Removal Issues
On April 14, 2016 the US Department of Homeland Security stated that Apple will no 
longer be providing security updates of QuickTime for Windows, “leaving this software 
vulnerable to exploitation.” They recommend uninstalling QuickTime for Windows. 
Some functionality in CaptionMaker is reliant on certain elements of the QuickTime for 
Windows software, so a complete uninstall will compromise some features. 

The security flaws are only in the actual player component. We therefore recommend 
only removing the QuickTime player component. This should circumvent the security 
flaws while leaving CaptionMaker fully functional.

Instructions to Remove Only the QuickTime Player
To remove only the QuickTime player component:

1. Go to C:\Program Files (x86)\QuickTime.

2. Delete the file “QuickTimePlayer.exe”.

3. Select Yes at the confirm delete dialog box.

Please contact Telestream technical support if you require assistance.

If You need to Remove All QuickTime Components
If your IT policies require you to completely uninstall QuickTime for Windows from 
machines running CaptionMaker, then the following functionality will no longer be 
available: 

• Playback of movies using the Use QuickTime option. (DirectShow and Microsoft 
MMF alternatives are available, but playback compatibility or performance may be 
reduced. For MP4 playback please use the Microsoft MMF option.)

• Export: (Encode CC) Black QuickTime 720x486 for NLE (line 21 movie).

• Export: (Burn Subtitles) into QuickTime mov/mp4.

• Export: (Encode Subtitles) Black QuickTime 720x486 for NLE (subtitle overlay 
movie).

• Export: (Encode Subtitles) HD Black QuickTime for NLE (subtitle overlay movie).

• Tools > Find Shot Changes (when the movie is a QuickTime mov/mp4).
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CaptionMaker Features that Will Continue to Work
The following CaptionMaker features, despite having QuickTime in the name, don't use 
the Apple QuickTime APIs and will continue to work even if QuickTime is uninstalled:

• Export: (Encode CC) QuickTime Podcast/Web Closed Captions (QT 608 CC track).

• Export: (Encode CC) DV QuickTime 720x480.

• Export: Webcast - Quick Time Script (*.txt).

Device Selection and Configuration
CaptionMaker uses the concept of device selection because it was originally designed 
to directly control caption hardware devices, such as the Evertz and EEG caption 
encoders, and subtitle hardware devices such as the Chyron Codi or MagniCoder 
subtitle encoders.

The default caption device is Virtual Encoder, and the default subtitle device is Generic 
Subtitles. The default devices are good for a typical file-based workflow. If you are using 
a specific hardware device, or different file type, you can select an appropriate device. 

The name of the currently selected device is displayed in the Status Bar at the bottom 
right of the CaptionMaker workspace.

To select a new device or adjust device settings, go to the Caption > Device, or Subtitle 
> Device menu options. When you select a new caption or subtitle device in the Device 
dialog you are automatically switched into the caption or subtitle mode of the new 
device.

For more information on caption device selection and settings, see Device in the 
Caption section of the Menu chapter. For more information on subtitle device selection 
and settings, see Device in the Subtitle section of the Menu chapter.

The Video Preview Panel Changes to Show Device Format
The Video Preview Panel changes to show what the captions or subtitles will most likely 
look like in the final displayed destination, depending on the device selected. For 
example, when you select caption mode the preview window displays what your 
captions will typically look like when decoded by a TV.

If you have selected a DVD authoring system subtitle device, such as Spruce 
DVDMaestro, the Video Preview Panel shows what your subtitles will typically look like 
when displayed by a DVD player.

Current Device
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Certain Device Settings are Remembered per Device
CaptionMaker remembers certain settings separately for each device. When you 
change a setting that is remembered for a device, you are changing that setting only for 
the device that is currently selected.

For each Caption Device, CaptionMaker remembers the communications connection 
parameters such as the COM port number or the IP address.

For each Subtitle Device, CaptionMaker remembers the following settings (the setting 
locations are also included below):

• Background Translucency (Attribute menu > Background Translucency).

• Default caption/subtitle colors (Attribute menu > Background Translucency).

• Left, Right, Top, and Bottom Margin settings (Subtitle menu > Set Subtitle Margins).

• Enable/disable character borders, and the character border width (Subtitle menu > 
Set Subtitle Image Font).

Global Device Settings Not Remembered
The following settings are not remembered differently for each device, but affect the 
global settings on the program level. They will apply to any device selected.

• The subtitle image font settings (font name, font size, kerning, spacing, padding, 
and so on) are not remembered for each Subtitle Device. These settings are global 
for all subtitle devices.

• The Background Type setting (Normal, Black Box, Fill Row, or Transparent) is not 
remembered for each device because there is a Background Type column in the text 
grid that allows you to assign a background type to each caption or subtitle.
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Virtual Encoder and Generic Subtitles Default Devices 
The default caption device Virtual Encoder and the default subtitle device Generic 
Subtitles work well for a typical file-based workflow (which means, when hardware 
devices are not used). Both of these devices are designed to emulate hardware 
encoders. The Virtual Encoder and Generic Subtitles devices work for SD, HD, and 
UHD resolutions. Generic Subtitles also provides more positioning options and user 
selectable fonts.

When you need certain options you can also use devices for a file-based workflow that 
have hardware names, and you do not need to have the actual hardware device 
connected. Some of the available devices are only for SD resolution video, such as 
Generic DVD. HD resolution, including 720p and 1080i/p, require devices such as 
Blu-ray, or the default devices. 

The following features are available with the Virtual Encoder caption device:

• UHD (Ultra High Definition), HD (High Definition), and SD (Standard Definition).

• 2160i, 2160p, 1080i, 1080p, 720p, 480i (SD NTSC), 576i (SD PAL).

• CEA-608 and CEA-708 captioning protocols.

• Multiple frame rate support for 23.976 fps, 24 fps, 29.97 fps, 59.94 fps, 25 fps, 50 fps, 
including drop frame and non-drop frame. 

The following features are available with the Generic Subtitles device:

• UHD (Ultra High Definition), HD (High Definition), and SD (Standard Definition).

• 2160i, 2160p, 1080i, 1080p, and 720p, 480i (SD NTSC), 576i (SD PAL).

• Multiple frame rate support for 23.976 fps, 24 fps, 29.97 fps, 59.94 fps, 25 fps, 50 fps, 
including drop frame and non-drop frame.

• Provides the background opacity option. 

• Select from any font installed in your system. 

• Use multiple colors for font and background.

Supported Video Formats
CaptionMaker supports three technologies for playing video files: DirectX-DirectShow, 
QuickTime (if installed), and Microsoft Media Foundation (MMF). DirectX-DirectShow is 
generally good at playing WMV and AVI files. QuickTime is generally good at playing 
MOV, MP4, and audio files. Use Microsoft Media Foundation (MMF) when QuickTime is 
not installed.

You can drag and drop a video file onto the video preview player window, in addition to 
using the Open Movie selection from the File menu.

Note: Opening a movie only loads the video and its audio for playback. If the video 
contains closed captions, a separate import step is needed to bring in the captions. 
See Importing Captions from a Video.
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The following types of video and audio files can be played in CaptionMaker:

Opening or Replacing a Movie
You can open a new movie, or replace the currently loaded movie. 
To open or replace a movie follow these steps:

WMV (.wmv)

AVI (.avi) with generic codec

AVI (.avi) with 3rd party codec (if 
installed)

AVI (.avi) with DV codec (DV25/50) (if 
QuickTime is installed)

MP4 (.mp4) 

MOV (.mov) ProRes (if QuickTime is 
installed)

MOV (.mov) H.264

MOV (.mov) DV25 and DV50

MOV (.mov) with Animation 

MOV (.mov) Avid Codec (if installed)

MPEG-2, with 3rd party codec (if 
installed). Use the DirectX playback 
option

MP3 (.mp3) (audio only)

AIFF (.aif ) (audio only)

WAV (.wav) (audio only)
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1. From the File menu choose Open Movie, or drag and drop a video file into the 
CaptionMaker Video Preview panel. The Video Properties dialog opens.

 

2. The playback file type is automatically selected based on the file extension of the 
video or audio you're opening, however you can choose a different option if you 
prefer. You can select one of the following playback options for the type of video 
file you are opening:

a. DirectX DirectShow. The default for playing Windows Media (WMV and AVI) 
files.

b. QuickTime. The default for playing QuickTime files such as MOV and also works 
well for MP4 and audio files. QuickTime must be installed to use this option.

c. Microsoft Media Foundation (MMF). For playing MP4 files if QuickTime is not 
installed. This feature is not supported on Server editions of Windows. 

3. Click Browse and locate the video file that you want to import. (The file is already 
selected if you used the drag-drop method).

4. Make any other desired adjustments, then click OK.

The video appears in the CaptionMaker Video Preview panel.
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Video Playback Options when Opening a Movie
When you choose File > Open Movie, or drag and drop a video or audio file into the 
CaptionMaker Video Preview panel, the Video Properties dialog opens. The Video 
Properties dialog provides the following options:

Caption/Subtitle Display
Display rendered captions/subtitle. Selected by default when captions are present. 
De-select to turn off caption/subtitle display. 

External video from tape
CaptionMaker can interface with a webcam or a video capture card that can let users 
see live video or a video feed coming from a server or a tape. 

Enable Video Capture Check to use CaptionMaker in conjunction with a video capture 
device. When checked, CaptionMaker initiates a scan for capture devices upon 
application launch.

Current video device. Choose the input video device to use, such as a video capture 
card or webcam.

Settings. Opens a dialog to set the capture card frame rate and display resolution for 
preview purposes.

Enable external video from tape. Enables access to a video device or an external 
capture card.

Pause. CaptionMaker can control a VTR via an RS-232 com port.

Video playback from disk
Enable video file playback from disk. Selected by default to enable video file 
playback. De-select to enable video playback from a capture card or other video device. 

Play video file during AutoSync/AutoPreview. The same function as the Preview Play 
button on the main workspace. Triggers captions when time code comes from video 
file. This is not the same function as Automatic Time Stamp (ATS).



Installation
Device Selection and Configuration

44

CaptionMaker User Guide                November 14, 2022

Use DirectX DirectShow. This is the default for playing Windows Media (WMV and AVI) 
files.

Use QuickTime. This is the default for playing QuickTime files such as MOV and is the 
recommended option for MP4. QuickTime must be installed to use this option. 
(QuickTime is available as a free download from apple.com.)

Use Microsoft Media Foundation (MMF). This is for playing MP4 files if QuickTime is 
not installed.

Note: Other types of video may be supported if you have installed the appropriate 
3rd-party codec. For example, if you've installed a codec for decoding MPEG-2 videos 
in DirectX based programs, then using the DirectX option will enable you to play 
MPEG-2 videos in CaptionMaker.

Playback file. The path and name of the file currently loaded in the preview panel, or 
that you have selected from the Browse window.

Browse. Open a window and browse to select the file.

Scan playback file for Time Code Info. When files are DV25/DV50 codec and have 
embedded time code, click this button to read the time code and populate the time 
code offset.

Temporarily set TC reader to “video playback”. When selected, time code will chase 
the video file and not look for a time code reader hardware card.

Read and use the actual TC values in the file. You can use this option when files are 
DV25/DV50 codec and have embedded time code.

Time code offset (time code of first frame in the video file): Enable offset. When the 
video time starts at a time other than zero, such as one hour, enable this option and set 
this time to match the video start time. For example, enter 01:00:00:00 to make the 
timecode clock start at one hour, as shown in the following image:

Playback file time code mode. Select the time code mode of the project. 30 fps Non-
Drop, 29.97 fps Drop, 25 fps PAL, or 24 fps FILM. This can also be set after import.
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Using a Proxy Movie
A proxy movie is a lower quality video file that is used as a stand-in for the high quality 
master file when authoring captions or subtitles. Here are some reasons you may want 
to use a proxy movie for part or all of the captioning process:

• Large original video file. Downloading a large movie file takes a long time and 
uses a lot of space. Unless you need to embed the captions into the master video 
file, you can do the captioning using a much smaller and easier to download proxy 
movie.

• Playback issues. The original video may be very demanding to playback without 
dropping frames. Especially if encoded with high quality settings, or if you have an 
older or lower end computer, or if the video is sitting on an external drive like a 
flash drive or a network drive. Using a proxy movie will help the movie play 
smoother and make the captioning software feel more responsive.

• Incompatible format. The movie might be in a format that can't be played back 
well or at all in the captioning software. Some types of video files, such as MXF or 
MPEG-2 transport streams, require additional software to play them back. In this 
case you can use a proxy movie for the captioning process, and then you can still 
embed the caption data into the original master file if you need to.

Use Telestream Cloud or Vantage to Make a Proxy Movie
Telestream Cloud and Vantage can be used to create proxy movies. These platforms 
support a wide range of formats, including all the major input output formats for web, 
streaming, VOD, production, broadcast and more.

For more information go to:   http://www.telestream.net/ 

Proxy Movie Settings
The resolution and bit rate of the proxy movie does not matter too much. You can keep 
these low for easy playback. What is important, however, is that you maintain the same 
frame rate of the master file. For example, if the master file is 59.94 frames per second, 
make sure the proxy movie is also 59.94 frames per second. This is because the video 
frame rate has a large impact on the captioning process, and using a different frame 
rate could cause the captions to not sync up with the original video. Additionally, if the 
original master video has a time code track, ideally the proxy movie should start at the 
same time code as well.

Here are some general guidelines for your export settings:

• MP4 or QuickTime MOV format.

• H.264 video at 640x360 (if HD) resolution using baseline profile.

• A bit rate of around 500 kbps to 1000 kbps (higher will make a larger file, but will 
make the video more clear).

• Uncompressed (PCM) audio at 44100 or 48000 Hz, stereo or mono.

http://www.telestream.net/
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Note on H.264 (MP4) Compression Settings

Some encoders, such as x264, have different profile settings such as High profile, Main 
profile, or Baseline profile. The higher profile makes a higher quality file at the same 
bitrate by using more advanced compression algorithms. The problem is that these 
advanced settings require more CPU power to decode, and some settings such as a 
higher keyframe interval can cause seeking within the video to take a long time.

When authoring captions, you tend to do a lot of seeking within the video, so this can 
slow down the process and make the software feel less responsive.   Since quality is 
generally not a problem when using a proxy video, we recommend encoding using the 
baseline profile. This will help with smoother playback and better responsiveness while 
captioning. Of course, you can still use a high profile or higher quality file as your final 
output.
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Preparing and Importing 
Files

The topics in this chapter provide information on transcription, describe how to import 
various types of files into CaptionMaker, and explain how to use a proxy movie.

Topics
■Transcript Preparation 49

■Caption and Subtitle Import 50

Transcript Creation
You can create transcripts of soundtracks by typing them manually, or by letting 
CaptionMaker generate them automatically.

Manual Transcription
For manual transcription, a typist can transcribe the video using any standard word 
processor.

Copy-Paste Transcription
Copy and paste is an easy way to import transcript text directly into the text the panel 
of CaptionMaker. This way you can get text from various sources, such as e-mail, Word 
docs, PDFs, or websites.

CaptionMaker can automatically split up the text to be title safe and meet CEA-608 
caption standards, when you enable the feature in the Paste Option dialog. To enable, 
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choose Edit > Paste Options, and select Always break up the pasted text into multiple 
cells.

When you copy and paste text, CaptionMaker breaks up the text based on the settings 
in the Paste Options dialog.

V-Pedal
The V-Pedal is a device that controls the playback of video and audio files on a 
computer, using a foot pedal. This device is a time saver because it allows the 
transcriber to easily pause and rewind the video without having to take their hands off 
the keyboard. V-Pedal devices can connect via a USB port to either Mac or Windows.

The V-Pedal can also control video playback in CaptionMaker. CaptionMaker includes 
the V-Pedal drivers.

For information about V-Pedal, go to: http://www.vpedal.com/

Automated Transcription
The transcription features in CaptionMaker can create a text transcript of a video and 
populate it directly into the captioning project with the correct timing.

http://www.vpedal.com/
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Enabling or Disabling Transcription Mode
If you are manually transcribing a movie, the transcribing process is usually done faster 
in a word processor, but can be performed in CaptionMaker by using the transcribing 
mode. 

To enable/disable transcribing mode, go to File > Old Transcription Mode. When 
enabled, the cursor moves to the next caption cell when you press Enter. When this 
mode is disabled, pressing Enter produces a carriage return within the same caption 
cell.

Transcript Preparation
You can improve the quality and accuracy of imported transcripts by making sure the 
transcripts first conform to certain technical and stylistic guidelines.

The transcription editing mode can be used to facilitate easy editing of that timed text, 
or of any text that you have loaded into the project. 

For details, see the Timed Text Speech chapter.

Avoid Italics and Bold Text
When creating a transcript it is best to avoid using italics and bold. Italics in closed 
captioning generally mean that the speaker is off-screen. Do not use bold as it could 
result in text blinking on and off. TV sets and cable boxes do not have the ability to bold 
text, so we recommend avoiding bold.

Indicate Change in Person Speaking
When importing a transcript into captioning software, the captioner looks for a change 
in the person speaking to start a new caption block. A good captioning project should 
have an indicator for the viewer to show a change in speaker. The transcript can help 
this effort by including a symbol before the speaker change. The characters “>>” 
typically shows this change.

Use Tab Delimitation
If line breaks or timecode are critical for the captioning project, a simple tab character 
can be placed in the text. In the same way spreadsheet software can separate cells, 
captioning software can do so when it detects a tab character. For example, if a 
sentence is long, a tab character will create a line break in the text. See TAB Delimited 
for more information. 

Use Plain Text if Possible
Although CaptionMaker can accept a variety of text files such as .doc, .rtf, and .txt, the 
recommended file format is a plain text document (.txt). Many word processors include 
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extraneous data in native file formats such as margins, footnotes, and other non-text 
related code. Most word processors can save the document as a plain text file, for 
import into CaptionMaker.

If italics or color information needs to be preserved when importing transcripts, the .rtf 
format works the best to bring this information into CaptionMaker.

Caption Style Guidelines
Adhering to good caption style is very important. The following is an excerpt from the 
Described and Captioned Media Program (DCMP), web site, http://www.dcmp.org/:

Captioning is the key to opening up a world of information for persons with hear-
ing loss or literacy needs. There are more than 30 million Americans with some type 
of hearing loss. Millions of others are illiterate, learning to read, or use English as a 
second language.

The first captioning of any kind was performed in the late 1950's by Captioned 
Films for the Deaf, the ancestor of DCMP, two decades before the advent of closed 
captioning on broadcast television. The first edition of the Captioning Key was pub-
lished in 1994, and these guidelines were based on decades of experience by DCMP 
(then called Captioned Films and Videos Program), review of captioning research, 
and examination of standards developed by various captioning vendors. The Cap-
tioning Key has been applied to both entertainment and educational media, has 
been used for consumers at all levels (children through adults), has received inter-
national distribution, and has been translated into other languages.

These guidelines are a key for vendors performing captioning for the DCMP. The vendor 
list can be found at this URL: https://dcmp.org/vendor-info. The DCMP provides 
information on how to become an approved vendor on the DCMP Web site. 

The information is applicable to vendors and other businesses that provide closed 
captioning (CC) and subtitles for the deaf and hard of hearing (SDH) of all types of 
media at various levels. Thus, these guidelines are also useful to media producers/
distributors and others considering captioning their products or learning about 
captioning.

Caption and Subtitle Import
You can import transcription files or script files in subtitle formats, caption formats, or 
text formats.

CaptionMaker can import many kinds of closed captioning and subtitle files, but when 
dealing with subtitle imports, there is one extra consideration. CaptionMaker can only 
import subtitle formats which are text-based. This refers to how the subtitles are stored 
in the file. If they are stored in a text format along with formatting information and time 
codes, they can be imported to edit or convert them. Some examples of text-based 
subtitle files are SubRip SRT, WebVTT, iTunes iTT, PAC, DLP Cinema XML, and EBU-STL.

http://www.dcmp.org
http://www.dcmp.org
https://dcmp.org/vendor-info
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However, if the subtitles are image-based, also known as bitmap subtitles, then 
CaptionMaker cannot import them. When the text is converted into an image, it is very 
difficult to turn that image back into an editable text format. Some examples of image-
based subtitle files are Blu-ray BDN, UYC/USF, and any other subtitle format that deals 
with image files like PNG, TIFF, BMP, and so on. 

There are also some subtitle file formats that support both text-based and image-based 
subtitles. For these formats, CaptionMaker can only import the subtitle file if it is the 
text-based variant. Some examples of these formats are: DVD Studio Pro STL, Scenarist 
SST, and SMPTE Timed Text.

Types of Caption/Subtitle Files
In addition to text documents, CaptionMaker can import a wide variety of file types, 
such as TV Caption files, WebVTT files, Subtitle files, PAC files, and Web Caption files. For 
a complete list of file types see Import Format Settings.

Importing Files
To import caption or subtitle files:

1. Select File > Import, or drag and drop the caption/subtitle file into the 
CaptionMaker text panel. The Import File dialog opens. 

2. Choose the type of caption/subtitle file you want to import: WebVTT, Text, TV, 
Subtitle, Web, or Extract From Video. 

3. From the drop-down menu choose the specific type of file.
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4. Under File Name click Browse and navigate to find the file. 

5. Under Options, leave this unchecked to create a new document, or select it to 
import starting at the current selected row.

6. For some file types click Finish to import the file. For others, click Next for more 
settings. Depending on the file type, either the Import Format dialog, or the Import 
Options dialog opens.

Import Format Settings
When importing text caption or subtitle files, options in the Import Format dialog are 
used to match the formatting in the file.
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Note: Before importing, you can open the file to determine the formatting used in 
the document.

 

• Choose the import format you need for the type of formatting in the file. Free Form, 
TAB Delimited, or LINE Delimited. 

• When TAB Delimited or LINE Delimited is selected, click Finish to import the file. 

• When Free Form is selected, click Next and the Import Options dialog opens for 
Free Form. See Import Options for Free Form for information on using the Import 
Options dialog with the Free Form selections.

Free Form
Use Free Form when the caption/subtitle rows are created by breaking the text into 
sections based on punctuation markers (periods, commas) or paragraph breaks, and 
there is no timecode or line breaks in the document.

TAB Delimited
Tab Delimited has several options, depending on information in the file.
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Text Only. Tab characters in text-only files are used to indicate the point at which the 
line will break. Here is an example:

NOW MY NAME APPEARS            AT THE BOTTOM OF THE SCREEN,

WE PUT CAPTIONS             OF WHAT I SAY AT THE TOP,

SO THAT MY NAME IS NOT            COVERED BY CAPTIONS.

After opening the file in CaptionMaker, it looks like the following:

Time Code In and Text. This type of file includes time code in, with tabs separating the 
time code and line breaks. Here is an example:

01:03:31:08         NOW I'M AT THE            RIGHT OF THE SCREEN,

01:03:33:07          SO MY CAPTIONS            APPEAR AT THE RIGHT.

01:03:35:13

01:03:36:13          NOW I AM GOING OFF-SCREEN.

After opening the file in CaptionMaker, it looks like the following:

Time Code In, Out, and Text. This type of file includes time code in and out, with tabs 
separating the time code and line breaks. Here is an example:

01:03:31:08         01:03:33:05        NOW I'M AT THE            RIGHT OF THE SCREEN,

01:03:33:07         01:03:35:15         SO MY CAPTIONS            APPEAR AT THE RIGHT.

01:03:35:17         01:03:36:11

01:03:36:13        01:03:38:06         NOW I AM GOING            OFF-SCREEN.

Time Code In and Web-TV Link. 

This option is a way to transmit web links (URLs) via the caption data. The actual WebTV 
devices and service are no longer in production, but some companies, such as Echostar, 

NOW MY NAME APPEARS
AT THE BOTTOM OF THE SCREEN,

WE PUT CAPTIONS
OF WHAT I SAY AT THE TOP,
SO THAT MY NAME IS NOT
COVERED BY CAPTIONS.

01:03:31:08 NOW I'M AT THE
RIGHT OF THE SCREEN,

01:03:33:07 SO MY CAPTIONS
APPEAR AT THE RIGHT.

01:03:35:13
01:03:36:13 NOW I AM GOING OFF-SCREEN.

01:03:31:08 NOW I'M AT THE
RIGHT OF THE SCREEN,

01:03:33:07 SO MY CAPTIONS
APPEAR AT THE RIGHT.

01:03:35:17
01:03:36:13 NOW I AM GOING

OFF-SCREEN.
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are using the same specification to display web content during a commercial. For 
example, the set top box could display a “Buy Now” button during an infomercial that 
contains the WebTV links.

Insert Tabs by Using a Spreadsheet
Sometimes a captioner will receive a script that has already been timed by a 
stenographer or other third party. Simply importing the script would make the time 
code showing up as additional captions. Tabs should be inserted, as described in the 
previous section. A simple way to add tabs is to import the timed script into a 
spreadsheet program such as Excel. The Time In and Time Out as well as each caption 
box should get its own row in one of three columns for In/Out/Caption. Once 
formatted, you can export as a Tab Delimited Text file and tabs are inserted. 

LINE Delimited
Import a Line Delimited file, where each line in the file represents one item of the 
record in the database. The lines must be in the following order: In Time, Out Time, and 
Text. The following is an example of formatting in a Line Delimited file:

00:00:00:13

§MUSIC§

00:00:04:15

I AM AT THE

LEFT OF THE SCREEN.

00:00:06:10

SO CAPTIONS OF WHAT I SAY

APPEAR AT THE LEFT OF THE

00:00:09:02

SCREEN, TOO.

00:00:11:02

00:00:13:05
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Import Options for Free Form
When you select Free Form in the Import Format dialog, the Import Options dialog 
opens when you click Next. The default settings are recommended for most captioning 
projects.

The Import Options dialog provides the following options:

Each row made of [2] line(s) of text. (2 is the default value) Specify the number of 
lines of text for each row in the CaptionMaker Text Panel. The limit is 4 lines of text, 
according to the CEA-608 standard.

End a row with end of sentence punctuation (.?!). When selected, a caption row ends 
and a new one is started when a period, question mark, or exclamation point is 
encountered during text import.

End a row with a comma (,) or semi-colon (;) if applicable. When selected, a caption 
row ends and a new one is started when a comma or semi-colon is encountered during 
text import.

End a row with: [   ] . Enter custom character to end a row. When this character is 
encountered during import, CaptionMaker ends the current row and starts a new one. 

Start a row with: [   ] . Enter custom character to start a row. When this character is 
encountered during import, CaptionMaker starts a new row.
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Note: Only one new row is started even if multiple consecutive instances of a 
character are in the text file. For example, if you enter the ">" character to start or end 
a row, CaptionMaker will start a new row when it sees ">", ">>", or ">>>" and so on. 

Maximum number of characters for each line of text. (26 is the default value) The 
maximum number of characters for each line is from 26 to 32 characters when in 
captioning mode. 32 characters is the limit for CEA-608. The maximum number of 
characters per line can also be changed later by going to Format > Reformat Rows, to 
open the Reformat Lines dialog. 

Switch to subtitle mode, before importing, to use more than 32 characters per line. 

Format multi-line blocks as bottom-heavy. When selected, more words are included 
in the bottom rows than the upper rows. 

Square up text if more than one line of text in a row. When selected, words are 
distributed more evenly in multiple rows of text.

Display mode: 
– Pop-On. Pop-on mode is recommended for most post-production captioning 

projects. 

– Paint-On. The characters are painted on the screen one after another, from left 
to right. 

– Roll-Up 2 Lines. Sets a maximum of 2 lines to appear on screen at a given time.

– Roll-Up 3 Lines. Sets a maximum of 3 lines to appear on screen at a given time.

– Roll-Up 4 Lines. Sets a maximum of 4 lines to appear on screen at a given time.

– Block Roll-Up. This is a combination of the Paint-On and Roll-Up modes.

Note: Roll-up captions are typically used for live captioning, such as TV news. One 
line at a time rolls up from the bottom, up to the maximum number of lines that are 
set appear at a given time.

See Display Modes for more information on display mode operation.

Moving Files Between CaptionMaker and MacCaption
CaptionMaker can import MacCaption (.mcc) project files, but MacCaption cannot 
import CaptionMaker (.cap) project files. To move from one platform to another you'll 
need to export and then import in a format that is used by both. 

Moving Caption Files
For captioning projects, the MCC (.mcc) file format is a good option for moving caption 
files between CaptionMaker and MacCaption. 

The SCC (.scc) file format is another option, but these are limited to using only a 29.97 
frame rate.
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Playback file video frame rate. Affects the rate at which the video file plays back. You 
must know the frame rate of the file you are importing before settings this. This must be 
set here during import. 

Frame rates available: 30 fps, 29.97 fps, 25 fps, 24 fps, 23.98 fps, 50 fps, 59.94 fps, 60 fps.

Moving Subtitle Files
For subtitle projects, the IMSC TTML file type works well to move subtitle files between 
CaptionMaker and MacCaption.

The WebVTT or Cheetah ASC (.asc) formats are also good options for moving subtitle 
files between MacCaption and CaptionMaker. These allow for more than 32 characters 
per line.

Importing Closed Captions from a Video
Opening a video only opens the video and audio for playback. If the video contains 
closed captions, a separate step is needed to import the captions.

To import captions from a video:

1. From the File menu choose Import, or drag and drop a file into the Text Panel area. 
The Import File dialog opens. 

2. Choose Extract From Video.

3. From the drop-down menu choose the type of video file you want to import. (The 
QCC Multi-format Input will work for most files.)

4. Under File Name click Browse and navigate to find the file. (If you used the drag and 
drop method the file and location are already selected.)
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5. Under Options, leave this unchecked to create a new document, or select it to 
import starting at the current selected row. 
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6. Click Next. The Import Options dialog opens.

7. Select the caption service you want to import. The default of CC1 is the most 
common service channel to use. When a video file has multiple languages or 
services these options allow you to choose which language to extract.

8. If words are cut off or going off of the screen after import, you can re-import and 
select 608 Import Options to try and correct this. Import is faster when this is not 
selected, so it’s better to use this only when you need to. 

9. Click Finish to import the caption file.

QCC Multi-Format Import

The QCC™ Multi-Format Import feature allows you to extract closed captions in 608/708 
from a large variety of SD and HD video file types. This feature was introduced in 
CaptionMaker 5.17, and new formats and options are added regularly. 

This is very useful when using Command Line Interface scripting. An entire archive of 
video files can be read with the QCC Multi-Format Import. Even obscure file types such 
as DV25/50, IMX30 with VBI, and ProRes .mov captions (both legacy Codec and Caption 
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Track). In addition, users can extract multiple languages from the files such as CC1 and 
CC3.

This import function facilitates importing (retrieving/extracting) closed captions from 
the following file types:

• .mpg .mpeg .m2v .mpv .ts .m2t .m2ts (MPEG-2 user data 608/708, line 21)

• .mov .mp4 .m4v .3gp (QuickTime CC tracks, line 21, H.264 NAL SEI 608/708, DV 
VAUX, ProRes VANC)

• .mxf (SMPTE 436m, MPEG-2 user data, line 21)

• OP-47 and OP-42 that use page 801 and 888 

• .gxf (VANC, MPEG-2 user data, line 21)

• .avi .wmv (Line 21, DV VAUX)

• WebVTT

Note: When importing WebVTT files, you can choose whether to ignore color tags by 
selecting or de-selecting Ignore color tags.

Note: New formats and features are added regularly to the QCC Multi-Format Import. 

The following diagram depicts the extraction of data from various types of media by 
the QCC Multi-Format Import and the conversion and delivery to multiple destinations. 
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IMSC TTML Subtitle Import
One feature of IMSC TTML subtitle files is that they facilitate transferring subtitles 
between MacCaption and CaptionMaker. IMSC TTML subtitle files work well for this 
because they can contain extra information, such as:

• The subtitle font information of name, point size, color, border enable, border color, 
and border width. 

• The subtitle background box color and translucency.

• The video mode, such as NTSC, 720P, 1080i, and so on. 

When you import an IMSC TTML subtitle file, you are given the choice of importing all, 
some, or none of this extra information.

Checkboxes are provided in the Import Options dialog that allow you to select the 
extra information you want to import. This import dialog is also used to import SMPTE-
TT, MAGIC-TT, and IMSC TTML caption files. The default settings of these checkboxes is 
to ignore all of the extra information when importing TT / TTML files. To access the 
Import Options dialog, and perform this import, the path is File > Import > Web 
Caption Files > Webcast - TT / TTML.
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When importing IMSC TTML files you can uncheck each checkbox for any item of extra 
information that you want CaptionMaker to import from the TT / TTML file. The 
following describes the operation of each “Ignore TTML...” checkbox:

• Ignore TTML Font Family—When this is checked CaptionMaker will not change 
your currently selected subtitle font name (see Subtitle menu > Set Subtitle Image 
Font for the current selection). When it is unchecked CaptionMaker will change the 
subtitle font name according to the information in the file being imported.

Note: When a font family is imported that is not in your Windows system, Windows 
will choose a substitute font. The name of the imported font will initially appear in the 
Image Font dialog, but the substitute font will actually be the one used during export.

• Ignore TTML Font Size—When this is checked CaptionMaker will not change your 
currently selected subtitle font size (see Subtitle menu > Set Subtitle Image Font for 
the current selection). When it is unchecked CaptionMaker will change the subtitle 
font size according to the information in the file being imported.

• Ignore TTML Font Color—When this is checked CaptionMaker will not change 
your currently selected subtitle font color (see Attribute menu > Background Trans-
lucency > Default Caption/Subtitle Colors > Foreground for the current selection). 
When it is unchecked CaptionMaker will change the subtitle font color according to 
the information in the file being imported.

• Ignore TTML Font Outline—When this is checked CaptionMaker will not change 
your currently selected subtitle character border settings (for the current selection 
see Attribute menu > Background Translucency > Default Caption/Subtitle Colors > 
Border). When it is unchecked CaptionMaker will change the subtitle character bor-
der settings according to the information in the file being imported).

• Ignore TTML Background—When this is checked CaptionMaker will not change 
your currently selected subtitle background box color and translucency settings 
(for the current selection see Attribute menu > Background Translucency > Default 
Caption/Subtitle Colors > Background). When it is unchecked CaptionMaker will 
change the subtitle background box color and translucency settings according to 
the information in the file being imported.

• Ignore TTML Video Mode—When this is checked CaptionMaker will not change 
your currently selected video mode (see Video Mode menu for the current selec-
tion). When it is unchecked CaptionMaker will change the video mode according to 
the information in the file being imported.

• Ignore WebVTT Color Tags—When this is checked CaptionMaker will not import 
WebVTT color tags.

Imported Info is Either Global or Goes Into the Generic 
Subtitles Device 
When an “Ignore TTML...” box is unchecked, the information goes into either the global 
program settings, which affects any subtitle device you select, or goes into the Generic 
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Subtitle device. This depends on the type of information it is, as described in the 
following:

• When font color, font outline, or background information are imported, these set-
tings go into the Generic Subtitles device. These new settings are saved only into 
the Generic Subtitles device, so when that device is used the new settings will be in 
effect.

Note: If a different device is currently selected you will not see the imported Generic 
Subtitles settings. You must select the Generic Subtitles device to see the settings that 
are saved for it.

• When font family (font name), font size, or video mode information is imported, 
these settings apply globally to the program settings and thus apply to any device 
selected.
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Timed Text Speech

The topics in this chapter describe the Timed Text Speech features in CaptionMaker.
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■Transcription Edit Mode 71

■How to Transcribe a Movie 75
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Timed Text Speech Overview
The Timed Text Speech features in CaptionMaker will create a text transcript of speech 
in a video and populate it directly into the captioning project with the correct timing.

The Transcription Edit Mode can be used to facilitate easy editing of that timed text, or 
of any timed text that you have loaded into the project.

 

Transcribing a Movie
CaptionMaker uses the Timed Text Speech service to analyze the audio track of a video 
file and automatically populate the text and timing information directly into the text 
edit cells as it becomes available. Timed Text Speech currently works with English, 
French, Brazilian Portuguese, and Spanish language video content.

Timed Text Speech processing operates from servers in Telestream Cloud. You need to 
set up a Telestream Cloud account to use Timed Text Speech, and when using Timed 
Text Speech, CaptionMaker must be connected to the Internet in order to create the 
transcript. Only the audio portion is transmitted to Telestream Cloud, so your Internet 
speed only needs to accommodate that scope of file size.

See How to Transcribe a Movie below for a description of the movie transcription 
procedure.

Creating a Telestream Cloud Account and Project
Timed Text Speech operates by connecting via the Internet to your account that you 
have set up in Telestream Cloud, and using the Timed Text Speech projects and settings 
that you have created there. 

1. Go to https://cloud.telestream.net/ and click Sign Up to create a Telestream Cloud 
account or Login to your existing account. 

2. Select Timed Text Speech to open the Projects window for transcription projects.

  

https://cloud.telestream.net/
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3. Click the Add Project button to create a new project. 

4. Create the settings for your project by giving it a Project Name, a Description, 
choosing the language of the video(s) you will be submitting, and enabling other 
options. Then click the Create and Customize button.

Note: Arabic, Japanese, and Chinese languages are not currently supported by 
CaptionMaker.

5. You can optionally choose to add vocabulary that is specific to your video content 
either as a file or by entering it in the provided field.

6. Click the Finish button to create your new project.
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Note: At this point you move to CaptionMaker to initiate the next steps. You do not 
submit the transcription job directly in the Telestream Cloud web browser interface. 

7. Open CaptionMaker to initiate the transcription operation. See How to Transcribe a 
Movie. 

Caution: Support for importing the Transcription Files that are available for 
download from the Telestream Cloud web site (.csv, .json, or .srt) will be added in 
a future version of CaptionMaker. These downloaded files are not currently 
supported in CaptionMaker. 

Logging into Your Telestream Cloud Account from 
CaptionMaker

When you click the Login button in the Timed Text Speech panel in CaptionMaker, or 
select Telestream Cloud Account from the Transcription menu, The Telestream Cloud 
Login dialog opens. 

• User Name. Enter the user name for the transcription account. The user name is 
saved for future transcribing operations. 

• Password. Enter the password for the transcription account. The password is saved 
for additional transcribing operations during the current session. For enhanced 
security, the password must be re-entered after you close and re-open Caption-
Maker. 

• Don’t have an account? Click this link to go to the Telestream Cloud web site so 
you can create an account. 

• Forgot username / password? Click this link to go to a web page where you can 
enter your email address and initiate a process to reset your password. 
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Closing CaptionMaker Does Not Log You Out of Telestream 
Cloud

If you are logged into your Telestream Cloud account when you close CaptionMaker, 
you will continue to be logged into your cloud account. When you reopen 
CaptionMaker the Auto-Transcribe button will be active and jobs can be initiated. 

If you prefer to require a user to log into the Telestream Cloud account when 
CaptionMaker is reopened, you must explicitly log out of Telestream Cloud before 
closing CaptionMaker. 

To log out of Telestream Cloud, select Telestream Cloud Account from the Transcription 
menu, then click the Logout button in the Telestream Cloud Login dialog. The Auto-
Transcribe button will change to “Login”, which indicates that you are now logged out 
of Telestream Cloud.

Job Settings for Timed Text Speech
You must first be logged into Telestream Cloud to enable access to the Auto-Transcribe 
button, or to enable the Auto-Transcribe Movie option from the Transcription menu. 
See Logging into Your Telestream Cloud Account from CaptionMaker above. 

 

When you click the Auto-Transcribe button (or select Transcription > Auto-Transcribe 
Movie) the Timed Text Speech Job Settings dialog opens so you can choose the movie 
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to transcribe, select the Telestream Cloud project to use, and set other parameters to 
apply during the transcribing operation. 

• Use currently open movie. Select to use the movie loaded into CaptionMaker for 
the transcribing operation. De-select the checkbox when you want to browse to 
find a movie file. This option is not available when no movie is loaded. 

• Video File. Click the Browse button, then navigate to select the video file you want 
to transcribe. The video file will not be loaded into the Preview Panel. This method 
allows you to choose video file types that may not be playable in CaptionMaker, 
such as MXF. 

• Select Telestream Cloud Project. Select the project you have created in 
Telestream Cloud that you want to use for this video.

• Manage Projects. Click this link to open your Telestream Cloud Projects page in 
your browser. 

• Dialog Track. Select the audio track in your source video file that you want to sub-
mit to Telestream Cloud for transcription. Selecting Default selects Track 1. Use 
Default when there is only one dialogue track. Examples of other tracks that can be 
present in a video file are different languages, or the dialogue track (usually center 
channel) of surround-sound. 

• Job Name. Enter the job name to use. When a movie is loaded in CaptionMaker this 
defaults to the movie file name.
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• Text Wrapping Options. Sets parameters that determine when new text cells are 
created. 

– Maximum Number of Characters Per Line. Sets the maximum number of 
characters for each text cell. The default is 32 characters. The range is 1 to 100 
characters. 

– Wrap on End-of-Sentence Punctuation ( . ! ? ). When enabled, a new text cell is 
created when these characters are included in the transcribed text. The default is 
enabled. 

– Wrap When the Time Gap Between Words in Greater Than ____ mS. When 
enabled, a new text cell is created when there is a gap in the detected speech 
greater than the specified milliseconds. The default is 800 milliseconds and 
enabled. The range is 1 to 5000 milliseconds. 

• Submit. Clicking Submit will send your job to Telestream Cloud for processing. 
Transcribed timed text will start populating the text cells in CaptionMaker as it is 
being processed and received back. Per minute charges will apply.

Transcription Edit Mode
When Transcription Edit Mode is active, video playback will loop from the start to end 
time of the currently selected text cell. A special editing mode is also activated, which 
provides the ability to quickly adjust caption position, and easily navigate through cells 
and words to perform transcript edits by using unique keyboard shortcuts. 

Using Transcription Edit Mode
To switch into Transcription Edit Mode, simply press the  button, or select 
Transcription Edit Mode from the Transcription menu. When enabled, the button color 
is darker  and the Transcription Edit Mode option in the Transcription menu is 
checked. The control toggles Transcription Edit Mode on and off. 

Click in the text cell or row you want to start editing, then press F3, or press the 

 button to start or pause playback. 

When Transcription Edit Mode is active, playback will start automatically when you 
select a text row if the Auto Play/Pause option is selected in the Transcription Edit Mode 
Settings dialog. 

Use the keyboard shortcuts for easy navigation. See Keyboard Shortcuts for 
Transcription Edit Mode and Punctuation Behaviors for Transcription Edit Mode below. 
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Transcription Edit Mode Settings
The Transcription Edit Mode Settings provides options to add playback time before and 
after the start and end times of the currently selected cell, and set the auto-play option.

• Video Looping Start Time Offset. Adds playback time, in milliseconds, before the 
start of the current cell so words in the previous cell are included. The default is 250 
milliseconds. 

• Video Looping End Time Offset. Adds playback time, in milliseconds, to the end 
of the current cell so words in the next cell are included. The default is 250 millisec-
onds. 

• Auto Play/Pause Video. When enabled, and Transcription Edit Mode is active, 
starts looping video playback when you click in a cell. 

Keyboard Shortcuts for Transcription Edit Mode
The following keyboard shortcuts are available when Transcription Edit Mode is active.

Action
Keyboard 
Shortcut Description

Play/Pause 
Video

F3 Toggles the video between play and pause. 

Next Cell Down Arrow Moves the cursor to the start of the next text cell.

Previous Cell Up Arrow Moves the cursor to the start of the previous text cell.

Next Word Right Arrow Advances the cursor to the start of the next word. If the cursor is on 
the last word of a cell, this advances the cursor to the start of the next 
cell (and triggers the video to loop in the next row).

Previous 
Word

Left Arrow Moves the cursor back to the start of the current word, if the cursor is 
in the middle/end of the current word. Or to the start of the previous 
word, if the cursor is at the start of a word. If the cursor is on the first 
word of a cell, this moves the cursor to the start of the last word of the 
previous cell (and triggers the video to loop in that row).
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Note: Push Word is not active in the last (bottom) row of the text edit grid, or in the 
second-to-last row when Timed Text Speech has completed populating the text cells.

Split Cell at Cursor is not active in the last (bottom) row of the text edit grid. 

Punctuation Behaviors for Transcription Edit Mode
Special behaviors are initiated for certain end-of-sentence, end-of-word, and 
surrounding punctuation entry when Transcription Edit Mode is active. Any other 
punctuation, not listed below, is simply treated as regular typing input and does not 
trigger any special behavior.

Select Next 
Word

Shift+Right 
Arrow

If nothing is currently selected/highlighted, this selects the word that 
the cursor is currently on. If something is already selected, this 
expands the selection to include the next word past the end of the 
current selection. This is limited to the contents of the current cell — 
a selection cannot span across multiple cells. 

Select 
Previous 
Word

Shift+Left 
Arrow

If nothing is currently selected, this selects/highlights the word prior 
to the word the cursor is currently on. If something is currently 
selected, this expands the selection to include the previous word 
prior to the start of the selection. This is limited to the contents of the 
current cell — a selection cannot span across multiple cells.

Toggle 
Capitalization

Shift+Up 
Arrow

Toggles capitalization to upper or lower case for the first letter of the 
word currently under the cursor.

Push Word Ctrl+Down 
Arrow

Moves the last word of the current cell to be the first word of the next 
cell. The timecode of the current and next cell is adjusted. 

Pull Word Ctrl+Up 
Arrow

Moves the first word of the next cell to be the last word of the current 
cell. The timecode of the current and next cell is adjusted.

Next 
Character

Ctrl+Right 
Arrow

Moves the cursor right one character.

Previous 
Character

Ctrl+Left 
Arrow

Moves the cursor left one character.

Split Cell at 
Cursor

Ctrl+Enter Splits the cell into two cells at the cursor location.

Music Note Ctrl+M Inserts a music note at the cursor location. 

Action
Keyboard 
Shortcut Description
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End of Sentence Punctuation Behaviors 
When these end-of-sentence punctuations are typed: period, question mark, or 
exclamation point ( . ? ! ) the following behaviors occur. 

• The cursor moves to the end of the current word. 

• The punctuation mark is inserted at the end of the current word. 

• The next word automatically has its first letter capitalized. (Note that the next word 
might be in the next cell.)

• Any words in the current cell that are to the right of the punctuation mark are 
pushed down to the next cell, as if Split Cell were clicked. 

Note: End-of-sentence punctuation behaviors are not active in the last (bottom) row 
of the text edit grid. 

End of Word Punctuation Behavior
End-of-word punctuation marks of colon, semicolon, or comma ( : ; , ) will automatically 
jump the cursor to the end of the word that is under the cursor, and put the mark at the 
end of the word. But unlike end-of-sentence punctuation, this does not capitalize the 
next word or split the current cell.

Surrounding Punctuation Behavior
When a range of text is selected, typing any of the surrounding punctuation marks will 
add the opening mark at the start and the closing mark at end of the highlighted range. 
If a range is not selected, then this simply types a single one of that mark at the current 
cursor location.

The surrounding punctuation marks are: parenthesis ( ), square bracket [ ], curly bracket 
{ }, single quotation mark ( ‘ ), double quotation mark ( “ ), and music note (Ctrl-M). 

Position Adjustment Using the Numeric Keypad
When Transcription Edit Mode is active, the numeric keypad (on a full-size keyboard) 
can be used to set the caption position of the selected text cell, on a range of selected 
cells, or the cell the cursor is in. The position designations in the H, V, and J columns (if 
set to visible) will change to the new position set by the numeric keypad entries. 

Disable this feature by turning Num Lock on. When Num Lock is on the keys will type 
numbers into the cell. 
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The following shows the position that is set for each numeric keypad number: 

How to Transcribe a Movie 
You can create a timed transcript of the movie that is open in CaptionMaker, or you can 
transcribe a movie file that is not opened in CaptionMaker. If you are planning to edit 
the transcript now, it may be more convenient to load the movie before transcribing it. 

Telestream Cloud Account
Before you can initiate the transcribing operation you will need to have an account and 
create at least one project in Telestream Cloud. See Creating a Telestream Cloud 
Account and Project. 

Transcribing an Open Movie
The following describes the procedure to open a movie and transcribe it.
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1. From the File menu choose Open Movie, or drag and drop a movie/video file into 
CaptionMaker’s Video Preview panel. The Video Properties dialog opens. 

 

2. The playback file type is automatically selected based on the file extension of the 
video or audio you're opening, however you can choose a different option if you 
prefer. You can select one of the following playback options for the type of video 
file you are opening:

a. DirectX DirectShow. The default for playing Windows Media (WMV and AVI) 
files.

b. QuickTime. The default for playing QuickTime files such as MOV and also works 
well for MP4 and audio files. QuickTime must be installed to use this option.

c. Microsoft Media Foundation (MMF). For playing MP4 files if QuickTime is not 
installed. This feature is not supported on Server editions of Windows. 

3. Click Browse and locate the video file that you want to import. (The file is already 
selected if you used the drag-drop method). For information on the other options, 
see Video Playback Options when Opening a Movie. 

4. Make any other desired adjustments, then click OK. The video is loaded and 
appears in the CaptionMaker Video Preview panel.

5. Make sure your computer is connected to the Internet. 
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6. Click the Login button in the Timed Text Speech panel. 

7. Enter your Telestream Cloud User Name and Password in the Telestream Cloud 
Login dialog, then click OK.

8. Click the Auto-Transcribe button in the Timed Text Speech panel (or select 
Transcription > Auto-Transcribe Movie). 

 

9. The Timed Text Speech Job Settings dialog opens.

10. Select the checkbox for Use Currently Open Movie. 

Note: For more details about the options in the Timed Text Speech Job Settings 
dialog, see Job Settings for Timed Text Speech.

11. Select the Telestream Cloud project you want to use for this video. 

12. Select the Dialog Track (audio track) in your source video file that you want to 
submit to Telestream Cloud for transcription. 

13. Enter an optional Job Name. This defaults to the open movie file name.

14. Make any adjustments to the Text Wrapping Options.

15. Click Submit to send the job to Telestream Cloud for processing. 
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16. The transcription process begins and text starts populating the text cells while it is 
being transcribed. The percent of processing that has completed is indicated in the 
Timed Text Speech panel.

17. You can start editing the text as soon as the first results start appearing in the text 
cells. See Using Transcription Edit Mode. 

18. Finished is displayed in the Timed Text Speech panel when the transcribing process 
has concluded

Transcribing a Movie File that is Not Open
The following describes the procedure to transcribe a movie file that is not open in 
CaptionMaker. This option allows you to select a movie file during the transcription 
process without needing to open that movie in CaptionMaker. This method allows you 
to choose video file types that may not be playable in CaptionMaker, such as MXF. 

Note: If you have a movie open in CaptionMaker, but you select a different movie to 
submit for transcription, the text that loads into CaptionMaker during the 
transcription process will not match the open movie dialog. 

1. Make sure your computer is connected to the Internet. 

2. Click the Login button in the Timed Text Speech panel. 

3. Enter your User Name and Password in the Telestream Cloud Login dialog, then 
click OK.

4. Click the Auto-Transcribe button in the Timed Text Speech panel (or select 
Transcription > Auto-Transcribe Movie).
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5. The Timed Text Speech Job Settings dialog opens.

6. De-select the checkbox for Use Currently Open Movie, then click the Browse button 
to navigate to and select the video file you want to transcribe. (The video will not 
be loaded into the Preview Panel, and only the audio portion is transmitted to 
Telestream Cloud for processing.)

Note: For more details about the options in the Timed Text Speech Job Settings 
dialog, see Job Settings for Timed Text Speech.

7. Select the Telestream Cloud project you want to use for this video. 

8. Select the Dialog Track (audio track) in your source video file that you want to 
submit to Telestream Cloud for transcription.

9. Enter an optional Job Name. This defaults to the open movie file name.

10. Make any adjustments to the Text Wrapping Options.

11. Click Submit to send the job to Telestream Cloud for processing. 

12. The transcription process begins and text starts populating the text cells while it is 
being transcribed. The percent of processing that has completed is indicated in the 
Timed Text Speech panel.
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13. You can start editing the text as soon as the first results start appearing in the text 
cells. See Using Transcription Edit Mode.   

14. Finished is displayed in the Timed Text Speech panel when the transcribing process 
has concluded.



Synchronization 81

CaptionMaker User Guide                                                                                          

Synchronization

The topics in this chapter describe how to perform automatic and manual time 
stamping, how to use the time code controls, adjust timing, and check for errors.

Topics
■Time Code Overview 82

■Caption and Video Playback Controls 86

■Time Code Controls 87

■Manual Time Stamping 89

■Adjusting the Timing 89

■Setting the Time Code Mode 95

■Making Two Captions Appear Simultaneously 95

■Error Checking 96
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Time Code Overview
CaptionMaker converts text to closed caption data and simulates sending control 
codes to captioning hardware for file-based delivery, or sends actual control codes to 
hardware devices. Start and stop time codes tell the captions when to turn on and turn 
off. Start and stop time codes are also required for a blank space between captions, 
when there is a pause in speaking. 

The following topics describe how to apply the time codes to each portion of text, so 
they line up properly with actions in the video. This is also called “time stamping”. 
CaptionMaker provides options for automatic time stamping, manual time stamping, 
and many ways to make manual and automatic adjustments.

Using Automatic Time Stamp (ATS)
After you have all of the text loaded into the CaptionMaker Text Panel, and have it 
broken into the sections you want, you are ready to time stamp it for synchronization 
with the video. The easiest way is to use the Automatic Time Stamp (ATS) feature. 

The ATS feature works very well for videos with high quality audio and containing 
mostly dialogue. It does not work as well if the dialogue is mixed with music or sound 
effects, so it is preferable to use a dialogue-only audio mix to synchronize the captions.

Requirements for ATS
The following are the basic requirements to perform an Auto Time Stamp operation:

• A video with a clear high quality audio dialogue track, in the English language, with 
very little background noise or other interfering sounds.

• An accurate transcript of all the dialogue in the video.

• Java Runtime Environment (JRE), version 6 or later, must be installed.

• See System Requirements for the minimum computer specs. 

ATS Results
When you run an Automatic Time Stamp operation, the following occurs:

• Automatically synchronizes each caption; no need to manually time-stamp cap-
tions.

• The process is much faster than real-time (15 times to 30 times faster, depending on 
the speed of your computer).

• When error checking is enabled, CaptionMaker automatically detects captions with 
poor synchronization and highlights them in a color (red is the default), so you can 
spot check and manually correct these captions.

See Error Color Settings for information on changing error detection options and 
colors.
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Best Practices for ATS
The following are important points to consider for getting the best results from an 
Automatic Time Stamp operation:

• An accurate transcript is vital. To get good results, the transcript cannot deviate sig-
nificantly from the audio.

• High quality audio is also the key. Compression, sound effects, or music can distort 
the dialogue.

• Speaker IDs that are indicated with “>> Name:” are treated as unspoken text.

• Non-verbal information in the transcript, such as music or sound effect indications, 
should be enclosed by brackets such as this: [MUSIC], or [Applause].

• If the software highlights some caption lines as low confidence, you might want to 
do a quick Preview Play to spot check these sections. In many cases the low confi-
dence sections may be fine or close enough for your needs. If not, you can do a 
manual time stamp just on these few sections to improve the alignment. 

Automatic Time Stamp Operation
After the text is imported and broken into the sections you want, you are ready for 
Automatic Time Stamp. 

To perform the Automatic Time Stamp operation:

1. In the Time Code menu select ATS Automatic Time Stamp. The Auto Time Stamp 
dialog opens and indicates the progress, confidence percentage, and time 
remaining. 

2. The ATS dialog closes automatically when the operation is complete. 

Selecting a Range for Auto Time Stamp
You can also run ATS on a range of captions if there is a small portion that could use 
additional adjusting. See Selecting Multiple Rows for techniques to select a range of 
captions.

ATS Error When File Name Contains Special Characters
If you use a video file that has a # (hash, pound) or some other special characters in the 
file name, you may get an error message when trying to use Auto Time Stamp (ATS).

If this error occurs, copy the video file to a local hard drive (not a network drive) and 
rename the video file so there are no special characters. That should allow ATS to read 
the video file.
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Checking the Timing
After running ATS, or after manual time stamping, you are ready to check the timing of 
the captions by using Preview Play. At the same time you can check the location of the 
captions to see if position adjustments are needed. Each caption should start when the 
first word of the caption is spoken. 

Preview Play
To preview the caption and video synchronization: 

1. Rewind the video all of the way to the beginning by dragging the slider, that’s just 
below the video, all of the way to the left.

2. Press the Preview Play button  . This engages the Auto Row button  which 
makes the captions change with the video, following the Start and Stop times that 
are set.

3. To stop the video, press the Play/Pause button  .

4. You can now use the Play/Pause button  to start and stop the video and the 
captions will stay synchronized since the Auto Row button is engaged. 

Audio Waveform Window
The Audio Waveform Window enables you to easily see where your captions are in 
relation to the audio in a source file. Select View > Audio Waveform Window to open the 
Audio Waveform Window.

   

Reading the Audio Waveform (Top to Bottom)
WPM Error Coloring. The color block at the top of the Audio Waveform Window 
indicates that these caption cells have a WPM (word per minute) value of greater than 
150. Error coloring and WPM criteria is configured in the Error Color Settings dialog.

Caption Text. A preview of the caption text for the currently selected cell is displayed 
at the top of the waveform timeline.
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Red Highlighted Waveform. Indicates the waveform of the currently selected caption 
cell.

Black Background (rather than gray). Indicates that this section of the timeline has 
no caption data.

Dotted Vertical Lines. Represent the beginning (green) and end (red) of caption cells 
in the grid.

Time Code. Displayed at the bottom of the waveform timeline.

Scene (Shot) Detection Markers. Triangles at the bottom of the Audio Waveform 
Window indicate a scene change at this point in the video timeline. These indicators 
become visible when the user initiates scene change detection by going to Tools > Find 
Shot Changes.

Note: If you assign keyboard shortcuts for inserting or removing shot changes, then 
those shortcuts are also automatically assigned as Audio Waveform Window shortcut 
keys. See Shot Change Marker Insert/Remove for more information. 

Waveform Navigation
The following commands operate when the Audio Waveform Window has focus.

Play/Pause. Use the Spacebar on your keyboard to toggle video playback.

Previous Caption Cell. Use the Up Arrow key to move the play head to the beginning 
of the previous caption cell.

Next Caption Cell. Use the Down Arrow key to move the play head to the beginning of 
the next caption cell. 

Zoom Setting. Change the scale of the waveform by either using the Left/Right Arrow 
keys on your keyboard, the '+/-' buttons on the Audio Waveform Window, or by 
selecting a zoom value from the drop-down list. This is particularly useful when 
working with long source files.

Audio Waveform Play Head. Drag the play head to navigate through the audio 
timeline, or click on a section of the waveform or play head bar and jump to that spot in 
the timeline.

Caption Cell Time Code Editing
Use keyboard shortcuts to step the caption In/Out points while keeping the Audio 
Waveform Window in focus. You need to have an expanded keyboard with a number 
keypad and select the main CaptionMaker window to perform these edits. 

Ctrl + Keypad +/- . Increment/decrement the 'In' time code of the currently selected 
caption cell by 1 frame.

Shift + Keypad +/- . Increment/decrement the 'Out' time code of the currently selected 
caption cell by 1 frame. 
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Caption and Video Playback Controls 

 

Playback Speed Indicator. Indicates the current playback speed. Displays 0 when 
video is not playing. For example, +1 is normal speed forward, -1 is normal speed in 
reverse, and +2 is forward speed twice as fast as normal speed. When using the J-K-L 
keyboard controls, multiple pressing of the J or L key will increase the speed in reverse 
(J key) or forward (L key). See Advanced Playback Control below for more information 
on J-K-L control speeds. 

Transcription Edit Mode.   Toggles Transcription Edit Mode on and off. See 
Transcription Edit Mode for more information. 

Rewind.   Press to put the video into rewind mode.

Step Back.   Press to go back one frame. Hold Shift and press to go back about 1/3 
of a second. Hold Control and press to go back about 1 second.

Play/Pause.   Press to play and pause the video. 

Step Forward.   Press to go forward one frame. Hold Shift and press to go forward 
about 1/3 of a second. Hold Control and press to go forward about 1 second.

Fast Forward.   Press to put the video into fast forward mode.

Preview Play.    Press to start playback and engage the Auto Row button  . This 
makes the captions change along with the video, following the Start and Stop times 
that are set. 

Time Stamp.   This button starts video playback, but the captions do not play 
along. Use this mode when you want to edit the In points (start times) of the captions 
and you don’t want the captions to advance. 

Auto Row (Captions Follow Video).   When this is pressed (toggled on), the 
captions change along with the video, following the Start and Stop times that are set. 

Auto Shuttle (Video Follows Captions).   When this is pressed (toggled on), and 
you select a caption row, the video automatically jumps to the time of that caption.   
You can also quickly move through the caption rows using the up and down arrow 
keys, and the video follows along.

 Pointer and handle to time location
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Advanced Playback Control
Users can control the video playback speed using the VTR controls toolbar to speed up 
or slow down the video. See VTR Toolbar for more information. 

You can also use the J-K-L keyboard controls to shuttle the video, the same way that 
popular video editing applications operate. To enable the J-K-L option, from the VTR 
Control menu choose Enable “JKL” Control.

To use the J-K-L keyboard control, press J to rewind, K to stop, and L to play forward. 
Multiple presses of the J or L keys increases the speed of rewind or forward. 

When your cursor is in a text edit field the J-K-L keys will enter letters. Click in the Video 
Preview Panel to switch back to the J-K-L keys controlling video playback. 

You can configure the speed increments that are used for multiple presses of the J or L 
keys. To do so, go to VTR Control > Configure “JKL” Control. The “JKL” Play & Shuttle 
Control Settings dialog opens.

 

Time Code Controls

Time Display.   Displays the current time of the video in HH:MM:SS:FF 
format. (H = hours; M = minutes; S = seconds; F = frames.)
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Start Time Code Reader.   When selected, timing information is displayed from 
the time code reader, video playback, or the PC System Timer.

Send Caption/Subtitle (Keypad Plus (+)).    Click to set the In Point or Start Time 
of the first word of the currently selected caption. If multiple rows are selected, start 
time is set for the first, or top row. For hardware devices, this sends the selected 
caption/subtitle to the device. The Plus key (+) on an extended keyboard or keypad is 
the shortcut. 

Send Caption/Subtitle Erase (Keypad Minus (-)).    Click to set the Out Point or 
End Time of the last word of the currently selected caption. This only needs to be set 
when a space is needed between captions, such as when there is a pause in the speech, 
or when the captions have ended. For hardware devices, this sends a command to 
erase the selected caption/subtitle from the device at that time code point. The Minus 
key (-) on an extended keyboard or keypad is the shortcut.

Note: When you set an Out Point or End Time, you must set an In Point or Start Time 
at the point you want the next caption to appear in the video. When a space is not 
needed between captions, you only need to set the In Point or Start Time for each 
caption. 

Mark Time Code on Send Lines.   This associates the clock time to the In Point and 
Out Point (Send) buttons. This must be selected for time codes to be written to captions 
when time stamping with the In Point or Out Point buttons, or other time stamp 
method. De-select this when you do not want to preserve time codes, such as when 
sending to certain hardware devices. 

Time Code Properties.   Opens the Time Code Reader Properties dialog. See Time 
Code Reader Properties for information on the dialog options. 

Seek Previous and Next Shot Change.   These buttons become active after 
the shot change information has been detected for a file. To run the shot change 
detection operation, select Tools > Find Shot Changes. A status bar in the bottom of the 
CaptionMaker window indicates the progress:

The Previous and Next Shot Change buttons are now active. The display text is red 
when less than 10 seconds from the next shot change, as shown in the following: 

 

See Find Shot Changes for more information on using the shot change finding options.
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Manual Time Stamping
Manual time stamping allows you to associate a time code to each block of text so it 
will be in sync with the dialogue. Manual time stamping is needed for various 
situations, such as videos that are not in English or that have loud music. To perform 
manual time stamping:

1. Rewind the video all of the way to the beginning by dragging the slider, that’s just 
below the video, all of the way to the left.

2. Click the Time Stamp button  . Playback starts, but the captions do not play 
along.

3. Click the Send Caption, or In Point button  each time you hear the first word of 
a caption. Or you can press the + key on your extended keyboard number pad. 

4. Every time you press the + key, or the In Point button, time code appears in Start for 
that row and the next row is automatically selected. Continue until you have set the 
start time for each row of captions. 

5. To stop video playback, press the Play/Pause button  .

Note: If you don’t have an extended keyboard, such as on a typical laptop, you can 
change the default + key shortcut for Send Caption Line(s). See Customize Keystrokes 
for information on changing the default keyboard shortcuts.

Creating a Pause in Caption Display
Typically, closed captions are back-to-back to allow the reader enough time to read the 
text on the screen. But if there is a significant pause in the dialogue, or credits and other 
information is displayed, there should be a pause in caption display. 

To create a pause, you can press the Out Point/End Time button  during a manual 
time stamping process. 

After setting an Out Point/End Time, you must press the In Point/Start Time button  
when you want the next caption to appear in the video.

Check Your Timing
After you have performed a manual time stamping you should check the timing by 
using the Preview Play button  . For more information see Preview Play. 

Adjusting the Timing
Several timing adjustment options are available when you need to synchronize 
captions to a video, correct for changes over time, or create different versions for 
various delivery requirements. 
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Adjusting Specific Caption Timing
During playback you may have discovered some captions that need to have their 
timing adjusted. The following describes some methods for adjusting specific captions:

• New In Points. Click on the row where you want to make the change, then move 

back a couple of captions before that. Click the Time Stamp button  , and press 

the In Point button  when at the point you want to synchronize the caption to 
the dialogue. Continue for any captions you want to fix. 

• New Out Point. When you want to create a space before the next caption displays, 

press the Out Point button  . Then you will need to set a new In Point when you 
want the next caption to display. 

• Manual Time Entry. You may also enter new times manually by typing into the 
Start or Stop columns. The time just before or after it is automatically adjusted. 

• Right-Click Menu. Right-click in the Start or Stop column to open a menu. You can 
select Mark “In” Time Code or select Mark “Out” Time Code. 

Clock Time vs. Time Code
The numbers for the clock time and the time code of a caption can sometimes be 
different. The following provides a brief explanation of how these time measurements 
relate to each other. 

Clock Time
Clock Time is also referred to as Media Time or Real-World Time. This is the time that an 
event occurs relative to the start of the video. Imagine you start a stopwatch at the 
same time the video starts. At the time a caption is supposed to appear, the time shown 
on the stopwatch is the clock time (or media time) of the caption. The clock time of a 
caption is independent of the video frame rate. For example, if a section of dialogue 
occurs exactly 60 seconds after the start of the show, it will always occur at 60 seconds 
regardless of whether the video frames update at 10 frames per second, 25 fps, 100 fps, 
or any other frame rate. 

The only case where a clock time of a caption might change is if the video speed is 
changed. This sometimes happens when converting film sourced material to TV 
formats—the video is slightly slowed down or sped up, and now the video version has 
a different duration than the original film (without any other edits to the content). This 
results in the dialogue and its associated caption clock time occurring slightly earlier or 
later than before.

Time Code
Also called SMPTE time code. Time Code is a system used to uniquely label each video 
frame with a time-based identifier in HH:MM:SS:FF format. Time code is the value 
displayed in the Time Code section on the CaptionMaker interface. Due to some 
peculiarities of different video systems, you cannot always take a time code at its face 
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value—the numbers shown in the time code are not always equivalent to the number 
of hours, minutes, and seconds that it actually represents. Thus it is important to keep 
in mind that the time code of a caption will sometimes appear to be a different number 
than the clock time of a caption, even though both they both reference the exact same 
moment in time. 

Further complicating things is that time codes come in different modes, and so a given 
clock time can be represented by different time codes depending on which time code 
mode you are using. The Convert Time Code dialog allows you to switch modes 
depending on your needs. 

For more information on time codes, see the Telestream knowledge-base article: Time 
code for 23.976 / (23.98) frames per second video. 

Applying Ripple Time Code Offsets
Ripple Time Code changes the time code within a currently selected range, or from a 
selected row to the end of the file. Use this when you want to change the time stamp of 
all the selected rows by a few frames, or if you want to set a new start time for the 
selected range. The Current Movie Offset shown in the top section is populated based 
on an offset specified on import of the currently loaded video file. 

• New starting time code for selected range. Enter a new starting time code. 

– Set starting time code to current movie time. When checked, this option will 
ripple time code for the selected range based on the current movie position.

• Number of frames to add to all time codes. Enter a positive or negative number 
of frames to add to or subtract from all time codes. 

http://telestream.force.com/kb/articles/Knowledge_Article/Time-code-for-23-976-frames-per-second-video 
http://telestream.force.com/kb/articles/Knowledge_Article/Time-code-for-23-976-frames-per-second-video 
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• Time code value to add to all time codes. Enter a positive or negative time code 
value to add to or subtract from all time codes. 

– Add the Movie Offset time to all time codes. When checked, this option will 
ripple time code for the selected range based on the Current Movie Offset, which 
is specified on video import.

Note: Only one of the check boxes can be selected at a time. To manually enter time 
codes, both check boxes must be unchecked. 

To make a Ripple Time Code adjustment:

1. Use one of these selection methods—

a. Select a range of rows that you want to adjust. 
b. To adjust all the way to the end, select the row where you want to start 

performing the Ripple Time Code offset. 
c. If you want to create offsets for the entire file, select the Start column header to 

highlight all the Start time cues.

2. Right-click on the time code cell of the very first selected row and choose Ripple... 
from the pop-up menu. Or, select Ripple Time Code from the Time Code menu. 

3. The Ripple Time Code dialog opens, and displays the starting and ending row that 
the operation will be performed on.

4. Enter the adjustments you want to make into the fields provided. 

5. Click OK to save your changes. 

Stretch/Shrink Time Code
If your caption timing is right on time at the start but is off a few seconds from the video 
at the end, you have “captioning drift”. This can be corrected by using the Stretch/
Shrink Time Code option. Choose Time Code > Stretch/Shrink Time Code.

The time code value is in the HH:MM:SS:FF format.

Use the “Increase time code by 1.001/1.000” option when you want to convert 23.976 
fps to 24 fps, 29.97 fps to 30 fps, or 59.94 fps to 60 fps. This difference is 3.6 seconds per 
hour of video.

Use the “Decrease time code by 1.000/1.001” option when you want to convert 24 fps 
to 23.976 fps, 30 fps to 29.97 fps, or 60 fps to 59.94 fps. This difference is 3.6 seconds per 
hour of video.
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Stretch/Shrink Time Code is also useful when you use a “proxy movie” to do all the 
captioning and then need to match the time coded file with the master copy of the 
video, which may have a slightly different code by the end of the video. One reason this 
could happen is due to a drop frame/non-drop frame issue. To match the time code of 
the caption file with the video, make sure the first time code of the caption file matches 
with the master copy. Then enter the last time code from the master copy into the “New 
value for the last time code in file” field. This will stretch or shrink all the time codes in 
the caption file to match the master copy.

You can also use the Convert Time Code dialog to match the time code of the master 
copy of the video. 

Convert Time Code
The Convert Time Code dialog provides several options so you can adjust the time code 
to match other versions or delivery destinations of the movie, or you can change the 
timing when captions do not sync up with the video. To open the dialog, go to Time 
Code > Convert Time Code.

Maintain Clock Times
Use Maintain Clock Times if the captions are currently in sync with your movie (the 
clock times are correct), and you want them to stay in sync, but at a different frame rate 
or time code mode. For example, this option is used when your captions sync up with a 
29.97 fps movie and now you want to apply them to a 23.976 fps version of the same 
movie, which has the same duration as the original, so that you can deliver a 23.976 fps 
caption file. When the time code or frame rate changes, the clock times that they 
represent will be unchanged.
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Modify Clock Times
Use Modify Clock Times if the captions currently do not sync with the movie (the clock 
times are not correct) and you want to bring them into sync. Or, if the captions sync 
with this movie but you need to make them sync with another version of the movie 
which plays faster or slower. For example, this mode is used if you imported a Non-Drop 
Frame (NDF) caption file which does not sync with your movie which is in Drop Frame 
(DF) mode. Or, when your captions sync with a 24 fps film and you want to apply them 
to a 25 fps PAL conversion which has been sped up by 4% from the original film. The 
time code modes are:

• 23.976 FILM

• 24.0 FILM (SMPTE 24)

• 25 PAL, 50 PAL (SECAM, SMPTE 25, 50)

• 29.97 DF, 59.94 DF: Drop Frame (SMPTE DF)

• 29.97 NDF, 59.94 NDF: Non-Drop Frame (SMPTE 30, 60)

Note: In some cases, when changing from one time code mode to another, Modify 
Clock Times might appear to leave the time codes unchanged. This is due to the fact 
that the same time code (in a different mode) can represent a different clock time. 
Thus the clock time actually did change, even though the time code appears 
unchanged.

Start Time Offset
Enable Start Time Offset if your captions have a starting time code offset such as 
01:00:00:00 and you wish to preserve this offset even after the conversion. 

For example, if your project and captions are in 29.97 DF mode, the captions start at 
01:00:00;00 and are in sync with the video. You want to convert the project to 23.976 
mode and have the start time remain at 01:00:00:00. In this case, select Maintain Clock 
Times, choose Convert From 29.97 DF, and Convert To 23.976. Then, enable the Start 
Time Offset option and set it to 01:00:00:00. The first caption will remain at 01:00:00:00 
but the timing from that point forward will be adjusted. If you tried to do this 
conversion without setting the Start Time Offset option, the first caption time would 
change to 00:59:56:10 and not be in sync.

Preview of Changes
In the Preview of Changes section, each time is provided as both a video time code (in 
the given mode) in format HH:MM:SS:FF, and also as a clock time in the format 
NNNN.N s (seconds), so that you can see what adjustments will be made.
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Setting the Time Code Mode
It is important to know the time code mode when working with video time codes, 
because if you don't know the mode then the actual time they represent can be 
uncertain. This is the leading cause of synchronization issues, such as caption text that 
doesn't quite line up with the audio.

First, let's distinguish between video frame rate and time code mode:

• Video frame rate—the rate at which the image is updated.

• Time code mode—the numbering or labeling system used to uniquely identify 
each video frame.

Sometimes, these two items have a simple relationship. For example, PAL video uses 
25.0 frames per second frame rate, and 25 fps time code. In other cases the relationship 
can be more complicated, which is the case for film-like digital videos that run at 23.976 
frames per second but count time code as if they were 24.0 frames per second. 

Here is how video systems, such as closed captioning software, correlate these two 
different measurements:

• Both 23.976 and 24.0 fps videos use the same type of time code (SMPTE 24). When 
using 24.0 fps video and SMPTE 24 time code, it syncs with a real time clock (similar 
to drop frame time code). 

• When using 23.976 fps video with SMPTE 24 time code, it does not sync with a real 
time clock (similar to non-drop frame time code).

In CaptionMaker, you set the time code counter mode (SMPTE 30 non-drop frame, 
SMPTE 29.97 drop frame, SMPTE 24 Film, and SMPTE 25 PAL) via the Time Code > Time 
Code Mode menu.  If your video is 24.0 fps or 23.976 fps and you're using SMPTE 24 
time code, you'd select Time Code Mode > Film (24 fps) for both cases because they 
both use the same time code counting system. 

The video frame rate is set separately in the Video Properties dialog (the dialog that 
opens after you go to File > Open Movie, or drag-and-drop the video into the 
CaptionMaker window). 

Making Two Captions Appear Simultaneously
You may wish to have two or more captions appear on the screen at once, but in 
different positions (the top and bottom of the screen, for example). The need for this 
may arise in a program where two people say different things at the same time, such as 
a translation. This feature is also known as “Split Captions”. 

To do this, make two captions have the same Start Times, and both will appear on the 
screen simultaneously. The easiest way to do this is to skip over one of the rows while 
assigning time code, and later cut and paste the Start Time from the row where you did 
assign time code to the row that you did not assign a time code to. Of course, you 
should assign different positions to these captions so they will both be visible.
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Note: You can use the function Same Start Time to assign the same time code to 
multiple rows. Highlight multiple rows with time code, right-click on any highlighted 
row and choose Same Start Time from the menu.

The following image shows an example of two captions appearing at the same time:

Error Checking
CaptionMaker provides various options for checking errors, such as missing time codes, 
non-sequential time codes, incorrect words per minute, and so on. A Nexidia XML QC 
report file can also be imported, to help locate errors with associated SCC files.

AutoSync Error Checking
This option performs automatic time code error checking. When Caption > AutoSync 
Error Checking is selected, CaptionMaker checks the whole file to make sure there are 
no missing time codes or the time codes are not in ascending order before running 
AutoSync. With this option checked as you work, errors are caught quickly and when 
running AutoSync it finds errors faster and stops at the point of the error.
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Error Color Settings
When you enable the Error Coloring Settings, a variety of error checking issues can be 
highlighted in the colors you select. When an error occurs, the time code value changes 
color in the affected row.

   

When you caption/subtitle a video, it is very important that you conform to 
recommended maximum words per minute for captions, depending on your audience. 
Similarly, it is customary not to have a pop-on caption covering a shot change. And 
finally, if you do not allow enough time for a pop-on caption to build up, the caption 
does not appear at the time you assigned. 

For example, pop-on captions take about one second for every 50 characters of text. If 
the difference of time codes of the previous caption and the current caption is less than 
one second for a caption of 50 characters, the caption appears later than the assigned 
time code.

To check all of these errors on the fly, you can enable specific settings by selecting 
Caption > Timing Error Settings or Subtitle > Timing Error Settings to open the Error 
Coloring Settings dialog. You can check any one of the items, adjust values, and assign 
different colors for each error in the dialog box. The Enable Error Coloring option, at the 
top of the dialog, must be checked for coloring settings to be active.

For example, this dialog can be set so that any WPM (word per minute) values above 
200 show up as Orange and any WPM values greater than 300 show up as Red. You can 
do so by checking the box next to the 'Highlight WPM values greater than' field, 
entering a value for the lower limit of that color range, and then designating a color for 
that specified range by clicking on the square color picker box.

Note: The CaptionMaker default WPM calculation finds each individual word by 
finding the spaces between the words. To change to using a five-character-per-word 
calculation to determine the WPM, see Words Per Minute Using 5 Chars/Word. 
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Load and Save Color Setting Files
The Load File and Save File buttons enable you to move more quickly between projects 
that may have different color setting criteria.

Load File. Load a previously saved Error Coloring Settings configuration.

Save File. Save the current configuration of the Error Coloring Settings dialog.

Using a Nexidia XML QC Report to Locate Errors
CaptionMaker can import a .XML report file generated by Nexidia's QC automation 
software, then use this file to locate errors in an associated .SCC file. This report can be 
obtained through the Vantage connector to Nexidia's QC tool. The report can include 
timecode specific synchronization issues, as well as notes regarding missing words 
from the caption project.   Nexidia's software engine can use a .SCC file and 
automatically compare timing and words to the audio of a video file.

Before importing the Nexidia XML report, a caption project must be open and the 
corresponding .SCC file should be imported into the CaptionMaker project. The notes 
column in the CaptionMaker text edit grid must be visible in order to see the report 
from the XML file. In addition, the "Nexidia: Highlight START time of captions/subtitles 
with Nexidia Errors" check box must be selected in the Error Coloring settings dialog of 
CaptionMaker. Once the XML file is imported, a captioner can quickly locate the errors 
found by the automated Nexidia analysis.   

To import a Nexidia QC report .XML file:

1. Import the associated .SCC file into CaptionMaker, or open the appropriate caption 
project. 

2. Enable viewing the Notes column by opening the Visible Columns dialog from the 
View menu. Highlight “Notes/Descriptions” and click OK. 

3. Enable Nexidia error coloring in the Error Coloring Settings dialog. Open this from 
either the Captions or Subtitle menu by selecting Timing Error Settings. You can 
change the color, if desired. See the previous Error Color Settings topic for more 
information.

4. Go to File > Import to open the Import File dialog.

5. Select Text Documents under File Type.

6. From the drop-down list select Nexidia XML Report File (*.xml).

7. Click the Browse button under File Name and locate the Nexidia report file.

8. Click Finish to import the file.

Once imported, CaptionMaker can use the XML report to highlight the problem 
timecodes with a color and populate the notes section with the details.
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Final Checking
Final Checking is a very important function to check all timing and formatting errors 
before you do the final encoding. 

To perform Final Checking:

1. In the Caption menu choose Final Checking. Or click the  button in the Main 
toolbar. The Verify Database dialog opens.

 

2. Make your selections and adjust any default values, if needed. 

3. Click OK and the Select Rows to Final Check opens.

4. Select the range of rows you want to check.

5. Click OK to start running the Final Check. 

6. Error message dialogs will open that provide information about any errors found.
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Caption and Subtitle 
Editing

The topics in this chapter describe how to format and position captions/subtitles, 
perform row operations, adjust display modes, and includes some tips for creating 
captions.

Topics
■Formatting and Positioning 102

■Row Operations 104

■Caption Formats 107

■Teletext in OP-47 and OP-42 109

■Captioning Tips 110
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Formatting and Positioning
CaptionMaker provides a wide variety of tools to format and position your captions. 
The tools apply to the currently selected row, or to all text in any range you select. 

Additional options are available for the Left, Center, and Right formatting buttons. Click 
the down-arrow on a button to open a menu to select from three options, as shown in 
the following:

Left Position.  Sets the caption to the left position, with Left Justify, Center 
Justify, and Right Justify options. 

Center Position.  Sets the caption to the center position, with Left Justify, Center 
Justify, and Right Justify options. 

Right Position.  Sets the caption to the right position, with Left Justify, Center 
Justify, and Right Justify options. 

Bold/Flash.  Applies bold formatting to the row(s) selected, or only to specific 
selected text. 

Note: It is not recommended to use bold formatting since in most TV display 
situations the text will flash. 

Italic (Control+I).  Applies italic formatting to the row(s) selected, or only to 
specific selected text. 

Underline (Control+U).  Applies underline formatting to the row(s) selected, or 
only to specific selected text. 

Color.  Changes the color of the text in the row(s) selected, or only to specific 
selected text. 

Top.  Moves the caption(s) to the top in the row(s) selected. 

Bottom.  Moves the caption(s) to the bottom in the row(s) selected.
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Pull First Word.  Pulls the first word of the next caption into the currently selected 
caption.

Push Last Word.  Pushes the last word of the currently selected caption to the 
next caption.

Compress Text Block.  Compresses the text block in the selected row(s). 

Expand Text Block.  Expands the text block in the selected row(s).

Compress and Expand perform a word wrap to increase or decrease the number of 
caption lines, ranging from 1-4 lines. It is recommend to have 1-2 lines for most 
captions.

Alternate Break Formatting.  Adjusts the way words are distributed in the text 
block. Multiple clicking provides different arrangements. It is better to make the text 
bottom heavy (shorter lines towards the top, longer lines towards the bottom).

Additional Position Adjustments
Ancillary toolbar. When you have the Ancillary toolbar open, it provides additional 
options to move up or down one line at a time, or move one character to the right or 
left: 

Snap Vertical Positions. You can use the Format menu > Snap Vertical Positions 
option to move all captions or subtitles in the current project to the absolute bottom or 
top row positions. See Snap Vertical Positions in the Menus chapter for more 
information. 

Transcription Edit Mode
When Transcription Edit Mode is active, video playback will loop from the start to end 
time of the currently selected text cell. A special editing mode is also activated, which 
provides the ability to quickly navigate through cells and words to easily perform 
transcript edits by using unique keyboard shortcuts. 

See Transcription Edit Mode in the Timed Text Speech chapter for detailed information. 



Caption and Subtitle Editing
Row Operations

104

CaptionMaker User Guide                November 14, 2022

Upper, Lower, or Sentence Case
Use the Upper/Lower Case dialog options to send selected captions as all upper case, 
or to change the current selection to all upper, all lower, or sentence case. To open the 
dialog go to Format > Upper/Lower case. 

Insert Music Symbol 
To insert a music symbol, open the Attribute menu > Insert Music Symbol(s) > Single 
Music Symbol, or Surrounding Music Symbols. Press Control+M for the single music 
symbol.

The Single Music Symbol is inserted where the cursor is located, or at the beginning of 
the text when a row is highlighted. The Surrounding Music Symbols are placed at the 
start and end of the text in the selected row, or the row the cursor is in. 

Row Operations
The Row Operations tools provide a quick way to insert, delete, merge, split, and select 
rows.

Insert Row(s).  Create a new blank row before the currently selected row. When 
you have multiple rows selected it inserts that number of rows. 

Delete Row(s).  Delete the currently selected row(s).
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Merge Rows.  Combine two selected rows into one row.

Split Row.  Splits the current row at the position of the text cursor.

Select Row.  Click to open the Select Caption/Subtitle Record dialog. Type the 
row you want to go to and click OK. 

 

Selecting Multiple Rows 
The following describes some methods to select multiple rows:

• Click and drag. Select one row, hold down the left mouse button and drag to 
select more rows. 

• [ # ]. Click the hash/pound symbol in the upper-left corner of the Text Panel to 
select all rows and columns. 

Note: Turn off the Auto Shuttle button  first, before using any of the following 
Shift or Control row selection methods. 

• Shift+click. Select one row, hold Shift and select the row you want for the end of 
the range. 

• Shift+arrow keys. Hold the Shift key, then use the Up, Down, Right, or Left arrow 
keys to select additional rows or cells. 

• Control+click. Hold Control and click to select individual rows. 

Display Modes
Display Modes control the way captions appear or move onto the screen. 
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Pop-On
Pops 1 to 4 lines of captions or subtitles onto the screen simultaneously. It is the most 
commonly used mode for subtitling, and is typically the preferred option for closed 
captioning. It is virtually impossible to use the Pop-On mode without using time code 
or the PC System Timer. The technical reason for this is that it takes time (roughly 1/60th 
of a second) to process each character of a caption line. Only when this processing has 
been completed is the caption line loaded onto the screen. Since this delay is variable 
(because the number of characters in each cell varies) it is almost impossible for a 
person to compensate for this delay. CaptionMaker precisely compensates for this 
delay when used with time code or the PC System Timer.

Paint-On
Paints characters on the screen one after another, from left to right, so that the screen 
looks like the output of a human typist. When the first word of the next caption 
appears, the entire previous caption is erased.

Roll-Up
Scrolls up captions from the bottom of the screen one line at a time. Two to four lines 
normally appear on the screen at any given time. Television news is a frequent user of 
Roll-Up captioning (often in conjunction with a teleprompter that generates captions).

Block Roll-Up
Combines the Paint-On and Roll-Up modes. Two to four lines of captions scroll onto the 
screen from the bottom. When the next caption appears, one line of caption disappears 
from the top. 

Pass Through Captioning
Enables Pass Through mode for a segment of the video which as been previously 
captioned. This mode lets the captions previously existing on the video pass through. 

Right-click on the cell in the Display column and choose Pass Through for the time 
codes for which you want to let the existing captions pass through the encoder. Then 
resume captioning at the time code you want to stop Pass Through. In the following 
example, existing captions from the video pass through the encoder at time code 
01:03:35:13 and CaptionMaker starts captioning again at time code 01:04:15:18. 

01:03:31:08  Pop-On  NOW I'M AT THE RIGHT OF THE SCREEN

01:03:33:07  Pop-On  SO MY CAPTIONS APPEAR AT THE RIGHT 

01:03:35:13  Pass Through 

01:04:15:18  Pop-On  NOW I AM GOING OFF-SCREEN
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Changing the Display Mode
To change the Display Mode for one row, or multiple rows:

1. Select one row, or multiple rows. 

2. Right-click in the Display column in one of the highlighted rows and choose a 
display mode from the menu.

3. The new display mode is now active in that row or rows.

To change the Display Mode for all captions:

1. Click Display in the text panel header to highlight all cells in the Display column. 

2. In the Attribute menu go to Display Mode and choose the display mode you want 
from the menu that opens. Or right-click a row in the Display column and choose a 
display mode from the menu.

3. The new display mode is now active for all captions.

Caption Formats
608

CEA-608 (formerly known as EIA-608) was the original closed captioning standard used 
for analog TV broadcasts since 1980. This is also called "line 21" captions because they 
are embedded in line 21 of analog TV signals. 
608 captions are typically limited to a single block character font with gray mono-
spaced text on a black square background. Only the standard alphanumeric and certain 
accented characters are supported. Due to bandwidth restrictions, it is uncommon to 
see more than two languages encoded simultaneously.
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CEA-608 captions also support different background colors. See images below for 
examples of background color when viewed in a CEA-608 decoder.

                         

Up-Converted from 608 to 708
608 captions that are up-converted to 708 do not take advantage of any of the new 708 
caption features, such as multiple fonts and styles, multiple windows, Unicode 
character support, or proper support for more than four languages.

708
CEA-708 (formerly known as EIA-708) is the new closed captioning standard used for all 
DTV broadcasts, including HD and SD. 708 supports a number of features, including:

1. 708 captions can appear in multiple fonts, sizes, colors, and styles:

                     

 

2. 708 captions are drawn into "windows" which allows more creative and flexible 
positioning of the captions, including use of the full 16x9 width of HD video.

3. 708 captions can contain up to 63 different captions tracks (although typically up to 
6 are used simultaneously), without the bandwidth limitations of 608.

4. 708 captions also include a digital form of the 608 caption data for backwards 
compatibility with older analog gear.

708 captions are required for all captioned DTV broadcasts, which includes both HD 
and SD material. The DTV transition occurred on June 11, 2009. DTV broadcasts (with 
very few exemptions) must now include both 708 and 608 captions.
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When submitting a captioned SD tape to a broadcaster, the 708 captions are 
automatically generated from the 608 data when the video is encoded for DTV. 
However, when sending a pre-encoded file for broadcast (such as a MPEG-2 transport 
stream), the file must contain both 708 and 608 data even if it is only SD, because it will 
be transmitted as-is (not re-encoded by the broadcaster). HD tapes must always 
contain both 708 and 608 captions as well.

Note: U.S. broadcast equipment does not support the full CEA-708 specification, 
therefore,  only encodes simple CEA-708 that does not include any of the advanced 
features. Unicode characters do not display properly.

Industry-Standard Caption Format Data
All existing industry-standard caption data formats, such as SCC files or CAP files, only 
store CEA-608 caption data. However, CaptionMaker can import any industry standard 
caption file format, and then up-convert the captions into CEA-708 caption data for 
embedding into a video file or exporting into new formats that support CEA-708.

MacCaption developers have created a new file specification called MCC (MacCaption 
Closed Caption file) which contains native CEA-708 encoded caption data. 
CaptionMaker also supports the MCC file format. The MCC format is an open 
specification and free for any hardware or software manufacturer to use. Please contact 
Telestream for more information.

Teletext in OP-47 and OP-42
The following is an overview of Teletext OP-47 and OP-42.

Teletext OP-47
OP-47 (Operational Practice number 47) is a solution for inserting a Teletext ancillary 
data channel into HD media. OP-47 was originally developed by Australian 
broadcasters and is now widely used. The data can be stored in the SMPTE 436M track 
of an MXF wrapper.

OP-47 Teletext stores data in selectable pages within magazines (1-8). These can be 
selected by viewers using menu controls on their TV monitor. Typically, the subtitle 
data can be stored in magazine 8 page 01, or Teletext 801. Other samples may have 
Teletext 888, which is magazine 8 page 88. This is according to the SMPTE-RDD8 
specification.

CaptionMaker can read and write OP-47 with a user selectable parameter that specifies 
the magazine and page.   Teletext information can have up to 40 characters per line of 
text, including spaces. 

Teletext supports Latin, Hebrew, Arabic, Greek, and Cyrillic alphabet. However, it does 
not support Asian unicode characters such as Chinese and Japanese. CaptionMaker can 
only insert Latin alphabet Characters into OP-47.
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CaptionMaker also supports background color attributes when reading and writing 
OP-47 Teletext. See Attribute Menu for more detail on the settings and types of colors 
supported in CaptionMaker.

See OP-47 and OP-42 Teletext Workflows for more information on working with OP-47 
Teletext data in CaptionMaker. 

Teletext OP-42
The OP-42 export creates a QuickTime animation black movie with alpha channel VBI 
file, which is used with Vantage or other transcode and editing systems to render the 
VBI into an MPEG IMX SD .MXF file. OP-42 is used by SD analog systems that have PAL 25 
FPS settings.

See Exporting the OP-42 Alpha Channel VBI File for more details. 

You can switch to the CaptionMaker classic look of black text on white background for 
the text panel. To change this, choose View > Black Text on White Background. 

Captioning Tips
The following tips provide suggestions for the best ways to break lines of text, how to 
represent on-screen and off-screen speakers, centering text, and various general 
captioning guidelines. 

Suggestions for Breaking Lines
Professional captioning methods include creating the best text break points, 
positioning the captions properly, and the use of time sequencing. Captions should be 
adjusted to provide uniform readability. 

The following are common places to break lines into separate captions:
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• End a caption at the end of a sentence. The Import File option can make these 
breaks automatically using the end-of-sentence punctuation marks " . ", "?", and "!".

• End captions at commas and semicolons if they come at a natural pause in the dia-
log and conclude a phrase. The Import File option can make these breaks automat-
ically as well, but there are many commas in English that are not good places to 
break text.

When you break text into individual captions, they should make grammatical sense. 
Here is an example:

Unformatted, Raw Text: 

A poor way to caption it: 

A good way to caption it: 

On-Screen and Off-Screen Speakers
One basic convention concerns the difference between how you represent on-screen 
and off-screen speakers. The words spoken by off-screen speakers (commonly 
narrators) appear in italics, but italics can be skipped if the speaker comes in and out of 
view. The words of on-screen speakers appear in the normal font. 

Centering or Not
Another convention concerns centering and not-centering. Captions can indicate the 
location of the speaker, and should appear under the speaker. However, if the speaker is 
in the center but centering the caption interferes with a graphic and/or important on-
screen visual information, then the caption should be moved to another location.

On the way to the airport, I got caught in 
traffic and ended up being late for my 
flight. I had to wait around for five hours 
to catch the next available flight.

On the way to the airport,
I got caught in 

traffic and ended up being late
for my flight. I had to wait
around for five hours to catch
the next available flight.

On the way to the airport,
I got caught in traffic

and ended up being late
for my flight.

I had to wait around
for five hours

to catch
the next available flight.
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General Captioning Guidelines
The main objective is to have each caption represent a single thought. There is no 
single right way to caption a video, but a few additional guidelines may help:

• Your captioning style should be consistent throughout the video.

• Whenever possible, you should break captions into logical phrases. Captions ran-
domly broken up may convey a different meaning than intended.

• Captions can indicate the location of the speaker. For instance, a caption on the left 
side of the screen indicates the speaker is on the left, while a centered caption 
shows that only one person is speaking throughout a scene.

• Words can be emphasized with underlining.

• Use Attribute > Insert Music Symbol(s) to place a musical note at the beginning and 
end of musical lyrics. 

• Never paraphrase lyrics. Also include the title of the song when possible.

• Indicate sound effects in parentheses and in lower case, for example (boom) and 
(applause).
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Caption Mode and Subtitle 
Mode

The topics in this chapter describe subtitle operation and how to change the look of 
subtitles.

Topics
■Subtitling Overview 114

■Switching Between Caption and Subtitle Modes 116

■Converting Between Captions and Subtitles 116

■Adjusting Colors and Styles 117
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Subtitling Overview
Subtitles are text that appears on a video or in a movie and typically contains only a 
translation of the dialogue, usually because the dialogue is in a foreign language, or 
because the dialogue was difficult to hear clearly. Unlike captions, subtitles usually do 
not convey non-dialogue sounds such as background noise, sound effects, or music 
cues, because it is presumed that the viewer is able to hear them. Subtitles have fewer 
rules and limitations than closed captions, and generally have more fonts, styles, and 
colors available to choose from. 

Subtitles can be burned into the video so they can't be turned off. This is called "open 
subtitles", "burn-in subtitles" or "hard subtitles," and is used when the subtitles must 
always be available, such as when translating foreign language dialogue for a general 
audience. This is also useful when working with a video format or player that doesn't 
support soft subtitles or closed captions.

Some formats, such as DVD, Blu-ray, many web-based players, and a few other video 
formats, can contain one or more tracks of subtitles which can be selected and turned 
on or off by the player. This is called "soft subtitles" or "separate subtitles".  

Subtitle tracks which contain non-verbal audio cues and mimic the look and feel of 
closed captions are called "SDH" (Subtitles for the Deaf and Hard of Hearing) tracks. 
SDH tracks are often used to emulate closed captions on formats that don't support 
closed captioning due to technical limitations, such as Blu-ray.

Subtitle Mechanisms
Just as closed captions can exist embedded in a video file or in a separate sidecar file, 
there are several ways you can export subtitles:

• Burn-in. This permanently combines the subtitles and the video. They can't be 
turned off, but you never have to worry about whether they will work or not.

• Overlay for Later Burn-in. If you're working with a video editor that wants to burn-
in the subtitles, you can send them an overlay file. They put the overlay into their 
NLE system and render the burn-in video from there. This way, the captioner 
doesn't need the full resolution master video from the editor. 

• DVD/Blu-ray. Several prosumer and professional software packages for authoring 
DVD and Blu-ray discs can accept subtitle files. In this case the viewer can turn the 
subtitle tracks on or off. The type of file to export depends on which authoring soft-
ware is being used to author the DVD or Blu-ray.

Subtitle Export
For information about subtitle export see Exporting Subtitles in the Exporting / 
Encoding chapter.
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Captions vs. Subtitles
Captions are text that appear on a video and contain the dialogue and cues to indicate 
sounds are occurring, such as music or sound effects. Subtitles are text that appear on a 
video or in a movie and typically contain only a translation of the dialogue. 

Captions
The purpose of captioning is to make a video accessible to those who cannot access the 
audio content, such as for people who are deaf or hard of hearing, and for other 
situations in which the audio cannot be heard due to environmental noise or a need for 
silence.

Captions can be either open captions (always turned on, aka "burned in") or closed 
captions (can be turned on/off by the viewer). For TV broadcast, closed captions are 
much more common because they allow each viewer to decide whether they want the 
captions to be turned on or off. Closed captions are transmitted as a special coded 
signal sent along with the video picture, and require a decoder in your television or set 
top box to display the text on the screen. This special coded signal is what broadcasters 
check for to ensure that your video is in accordance with the law.

Caption Font and Style are Determined by the Decoder
For technical reasons, closed captions have many more rules and constraints that affect 
the timing and the appearance of the text. This means that in practical use, the caption 
author has limited or no ability to specify the font, size, text styling, and so on. These 
settings are determined by the decoder which renders the text to the screen when the 
captions are turned on.

Subtitles
Subtitles are text that appears on a video or in a movie and typically contains only a 
translation of the dialogue, typically because the dialogue is in a foreign language, or 
because the dialogue was difficult to hear clearly. Unlike captions, subtitles usually do 
not convey non-dialogue sounds such as background noise, sound effects, or music 
cues, because it is presumed that the viewer is able to hear them. Subtitles have fewer 
rules and limitations than closed captions, and generally have more fonts, styles, and 
colors available to choose from.

For more information on using subtitles, see .
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Switching Between Caption and Subtitle Modes
To switch CaptionMaker between caption and subtitle modes, simply click the button 
on the workspace.

When switching modes, the caption or subtitle device used is typically the last one you 
selected. If the Video Mode is changing between HD or SD when switching from 
caption to subtitle mode, CaptionMaker uses the Generic Subtitles device. 

Note: The Caption/Subtitle switch is disabled when CaptionMaker is in Live Caption 
mode, and when running AutoSync or AutoPreviewSync.

Converting Between Captions and Subtitles
CaptionMaker has the ability to convert closed captions into subtitles and vice versa. 
When converting closed captions to subtitles, there isn't too much you need to worry 
about, because subtitles are generally much more capable than closed captions. 

Where you need to be careful is when converting subtitles into closed captions. The 
subtitles might break some of the rules of closed captioning, for example, by having 
more than 32 characters per line. In this case, some manual reformatting needs to be 
done when conforming the subtitles into closed captions.

When switching from subtitle mode to caption mode, the following dialog appears to 
let you know that the database will be checked to make sure each caption is not over 
32 characters per line. 
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Making sure you are in the right mode when you start your project helps you avoid 
some extra work.

Adjusting Colors and Styles
Subtitles have many options available to choose font styles and colors.

Setting the Font Image Properties
To change the font style, size, and properties for the whole project:

1. Choose Subtitle > Set Subtitle Image Font. The Image Font dialog opens.

2. To change or adjust the font, click the Select button. The Font dialog opens.

3. Choose a font and settings, then click OK.
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4. Make any additional adjustments or selections in the Image Font dialog and click 
OK. A dialog opens asking if you want to update the fonts used on the edit grid.

5. Select Yes to change the font style in both the Text Edit Panel and the Video 
Preview Panel. Select No to change the font only in the Video Preview Panel.

Adjusting Font Color or Format 
To change the font color, or select bold, italic, or underline:

1. Select the text you want to change. Either specific words, certain rows, or click the 
Caption/Subtitle header to select all rows.

2. Click the text color button  from the Formatting tools, and select a color. Or 
select Text Color from the Attribute menu.

3. Click the Bold, Italic, or Underline button if you want to change those formats. The 
keyboard shortcuts are Control+B, Control+I, and Control+U. 

Changing the Background Colors for Individual Text
To set different background colors for individual letters, words, or rows:

1. Select the text you want to change. Either specific letters, words, certain rows, or 
click the Caption/Subtitle header to select all rows.

2. In the Attribute menu select Background Color.

3. Select the color you want from the menu.

Note: For more information on changing background colors, styles, and settings see 
Attribute Menu.
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Changing Backgrounds and Outlines for the Project
When in subtitle mode, you can change the subtitle background, foreground, outlines, 
translucency and related properties for the entire project.

Note: The preview panel can not display transparent subtitle backgrounds or levels of 
transparency when a movie file is opened with Quicktime or DirectX DirectShow. 
These are always shown as solid colors. However, the subtitles are exported correctly 
according to the transparent and translucency settings. 

To change image colors for all captions:

1. Choose Attribute > Background Translucency. The Image Colors dialog opens.

 

2. Click a colored button for any of the properties you want to change. The Color 
dialog opens.

3. Choose or set the color you want and click OK.

4. Make any additional changes in the Image Colors dialog and click OK to close the 
dialog and make the changes.
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Exporting / Encoding

This chapter describes CaptionMaker exporting and encoding options. 

CaptionMaker has a variety of export options, including formats for web and mobile 
video, DVD/Blu-ray, Web, broadcast video formats for SD and HD, and so on. Depending 
on which version of the software you purchase, different features are available. See 
Comparing CaptionMaker & MacCaption Versions for a summary of the exporting and 
encoding features in each version.
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Embedding Captions into Video
Captions embedded in video are typically used for broadcast video files such as ProRes, 
MPEG-2, and MXF. The captions are embedded directly into the video file instead of 
being saved to a separate file. CaptionMaker does not convert one type of video to 
another. This conversion is called transcoding and can be done in other Telestream 
applications such as Telestream Cloud or Vantage. 

If you want to output, for example, an MPEG-2 file with embedded captions, you must 
provide an MPEG-2 video file in the desired format, and then CaptionMaker can embed 
captions into it.

To embed captions into a video file:

1. Have the video file loaded into CaptionMaker, and the associated captions edited, 
formatted, and finished.

2. Choose File > Export. The Export File dialog opens.

3. Select Embed Into Video.

4. Choose the type of file you want to export.

5. The Input File Name is already populated when you are exporting a video that is 
loaded into CaptionMaker.

6. Click Browse to choose a destination and create a name for the file.
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7. Click Finish. The Select Starting Time Code dialog opens. 

8. Accept the default selection, or enter a desired start time, and click OK.

9. The status bar on the bottom of the CaptionMaker window indicates the progress, 
and the export is complete.

Exporting Standalone Caption Files
Many types of caption files are standalone, meaning the captions are in a separate file 
and not embedded into the video file. There are many different types of standalone 
caption files:

• For use on the web, such as Timed Text, WebVTT, and SRT (.srt) files. The type 
depends on the player being using on the web.

Note: When exporting WebVTT files, you can choose whether to ignore color tags by 
selecting or de-selecting Export Color Tags.

• Some are used in broadcast workflows, such as SCC (.scc) and MCC (.mcc).  (SCC is 
also used for DVD closed captioning.)

• Some are used for working with an NLE system, such as Final Cut Pro, Avid, and 
Adobe Premiere Pro. 

• Some are used for interchange with other captioners or captioning software, such 
as Cheetah, CAP, TDS, Ultech ULT, and so on.

To export captions as a standalone file:

1. Have the captions loaded into CaptionMaker, edited, formatted, and finished.



Exporting / Encoding
Exporting Standalone Caption Files

124

CaptionMaker User Guide                November 14, 2022

2. Choose File > Export. The Export File dialog opens.

3. Select the File Type. Typically TV Caption or Web Caption Files.

4. From the drop-down menu choose the type of file you want to export.

5. Click Browse under Output File Name to choose a destination and create a name for 
the file.
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6. Click Next. The dialog opens for the file type you selected. 
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7. The options vary, depending on file type. For example, TTML exporting displays an 
Export Options dialog box.

8. Make adjustments, such as changing the Frame Rate if needed. There is also a 
Language field that enables you to specify a language for the output. This 
information will be in the header of the exported .xml files.

9. Click Finish to export the file.

Options for Exporting WebVTT files
When exporting WebVTT files, you can choose any of the following options:

• Choose whether to ignore color tags

• Choose whether to export line numbers instead of vertical offset percents

• Choose whether to export optional "line alignment" parameters ("start","cen-
ter","end")
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File-Based Delivery for Broadcast TV
There are many file formats that can be used for file-based video delivery, such as 
QuickTime, MPEG-2, and MXF. Most formats support closed captions, but their 
workflows vary. The caption workflows vary, also, depending on how the broadcaster 
plays the files.

For example, many video servers installed at TV stations play QuickTime video files, but 
not necessarily the closed captions in QuickTime video files. Some servers support all 
kinds of QuickTime captions, other servers support only a few, or none. If the server has 
limited support for QuickTime captions, you might have to provide video and captions 
to the broadcaster in a different format, such as MPEG-2 or MXF.

Get the TV Station Spec Sheet
It is best to ask your TV station for a "spec sheet" and confirm with its engineers that the 
format you're using works for them. Make sure the spec sheet mentions specific types 
of captions that they support. Saying "QuickTime file" or "MPEG-2 file" isn't always 
sufficient, because there are many different types of captions that can be inserted into 
QuickTime files and MPEG-2 files.

Get a Sample Captioned Video File
If the TV station can't provide you a spec sheet, ask them for a sample file that contains 
closed captions which work for them. You can then examine the file to determine what 
types of captions are known to work.

Use Switch to Perform a Test
It is always a good idea to send the station a short captioned sample video and ensure 
that they can read the captions from your sample before proceeding with the full 
delivery.

We recommend using Telestream Switch to check that your video has captions, before 
sending to the station. Get it at http://www.telestream.net/switch/overview.htm

Note: Common video players such as VLC, Windows Media Player, QuickTime Player, 
Sony XDCAM Viewer, and so on, do NOT display most types of closed captions. So 
even if your video will play in one of these players, it may not show the captions. 

Overview of TV Formats
Here is an overview of the types of captions that can be used for broadcast TV files:

• Captions embedded into the video file:

– Closed Captioning track. An extra track of closed captions is added to the file. 
This is most often used with QuickTime files (QuickTime CC track) and MXF files 

http://www.telestream.net/switch/overview.htm
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(SMPTE 436m VANC track). However, not every server that can play QuickTime or 
MXF files is able to read this closed captioning track.

– User data captions. Captions are added as metadata into the contents of the 
file.  This is often used with MPEG-2 (ATSC DTV 608/708 captions), and 
occasionally with H.264 video (NAL SEI 608/708 captions), or DV video for 
standard definition (DV VAUX captions).

– Line 21 VBI. This is used for standard definition video only. The VBI line 21 
"Morse Code" dots-and-dashes are embedded into the top line of the video. The 
video resolution must be 720x486 for most QuickTime and AVI formats (rather 
than 720x480, which excludes the extra 6 lines of VBI where the captions go), or 
sometimes 720x512 for certain MPEG-2 formats.

• Sidecar caption file - a standalone file containing just the captions:

– SCC files are commonly used, but they contain 608 (analog) captions only. Make 
sure the station has a system that can upconvert this data into CEA-708 digital 
captions, such as using Telestream Vantage.

– MCC files are a next-generation improvement on SCC files, and contain native 
CEA-708 digital captions. They are supported by Adobe Premiere Pro CS5.5 and 
later, Blackmagic Hyperdeck, Manzanita muxers, Harris Nexio, and some other 
systems.

– If the station uses Avid systems, they may want an Avid AAF caption track file.

– Rarely, a station might ask you for a different type of caption interchange file, 
such as Cheetah .CAP, TDS, and so on.

– If the video will be shown on the internet, you may be asked to provide a web 
format caption file, such as SMPTE Timed Text (TTML), DFXP, WebVTT, and so on.  

Next Steps for Delivery to the TV Station
Once you have confirmed with a TV station what kinds of video files they can accept 
with captions, you need to export that type. Keep in mind that CaptionMaker is not 
transcoding software - that is, it does not convert one type of video file into another. 

If you're editing your video in NLE software, you may be able to export directly to the 
format you need (without captions), but not every NLE can export to every format. If 
you're starting with a QuickTime file and need to deliver a MPEG-2 file, you need to do 
some steps outside of the captioning software to create the MPEG-2 file first. Only then 
can CaptionMaker insert the captions into the MPEG-2 file. 

For transcoding, we recommend Telestream Cloud or Vantage. Make sure you select the 
correct bit rate and other specifications as required by the TV station.

Tape Delivery for Broadcast TV
Some TV stations still rely on tape formats for their receivables. CaptionMaker can be 
used together with your NLE system, such as Adobe Premiere, Avid, or Final Cut Pro, 
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and a tape deck such as DV, BetaSP, or HDCAM to deliver a closed captioned video tape 
to the TV station.

Note that the following descriptions only apply when outputting to a tape deck via 
your capture card. These instructions do not apply when exporting a video file from 
your NLE system. For more information on file-based workflows for TV please refer to 
the previous section.

Adobe Premiere
Premiere versions CS 5.5 or later can use an MCC file to output HD digital captions via 
your capture card (such as AJA, Blackmagic, Matrox, and so on) to a tape deck, or a SCC 
file to output SD analog captions via your capture card or DV digital video via Firewire.

Sony Vegas
Sony Vegas accepts an MCC file for HD digital caption output via your capture card 
(such as AJA or Blackmagic) to a tape deck, and can author DVDs with closed captions 
using an SCC file. 

Avid Media Composer
Media Composer version 5 or later can use an Avid AAF file to output HD digital 
captions via your Mojo DX or Nitris DX hardware.  For SD analog output, you can use the 
CaptionMaker 720x486 line 21 overlay workflow.

Final Cut Pro
Final Cut Pro version 7 can use a QuickTime CC track to output HD digital or SD analog 
captions via your capture card such as AJA, Blackmagic, Matrox, or DV via Firewire.

Note: Final Cut Pro X does not support closed captioning output. 

Other NLEs and More Information
Most other NLEs that output SD analog video can use the 720x486 line 21 overlay 
workflow.

For more information on tape based workflows and how to check your captions after 
outputting to tape, please refer to the Telestream Knowledge Base. See the Support 
page in this guide for the web links.

Exporting Subtitles
There are several ways you can export subtitles:
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• Burn-in. This permanently combines the subtitles and the video. They can't be 
turned off, but you never have to worry about whether they will work or not.

• Overlay for Later Burn-in. If you're working with a video editor that wants to burn-
in the subtitles, you can send them an overlay file. They put the overlay into their 
NLE system and render the burn-in video from there. That way, the captioner 
doesn't need the full resolution master video from the editor.

• DVD/Blu-ray. Several prosumer and professional software packages for authoring 
DVD and Blu-ray discs can accept subtitle files. In this case the viewer can turn the 
subtitle tracks on or off. The type of file to export depends on which authoring soft-
ware is being used to author the DVD or Blu-ray.

Some Subtitle Exports Use Settings of a Specific Assigned 
Device

Some subtitle export functions require settings that are remembered for each Subtitle 
Device, so these subtitle export functions are assigned a particular Subtitle Device. 
When the subtitle export function executes, it uses the settings for its assigned Subtitle 
Device, no matter what device you currently have selected in the user interface.

For example, you can configure the Generic Subtitles device so that the export "(Burn 
Subtitles) into QuickTime mov/mp4" will burn simulated open captions into a movie. 
Then you can keep the Virtual Encoder device selected while you are authoring 
captions, and you don't have to switch to the Generic Subtitles device to burn your 
captions into a movie. The export function "(Burn Subtitles) into QuickTime mov/mp4" 
always uses the settings of the Generic Subtitles device, no matter what device you 
currently have selected in the user interface.

The following table lists of all of the subtitle export functions that are assigned to a 
particular Subtitle Device. These export functions always use the settings of their 
assigned Subtitle Device, no matter what device you currently have selected in the user 
interface. Export functions that are not listed below will use settings of the Subtitle 
Device that you currently have selected in the user interface. 

Subtitle Export Function Assigned Subtitle Device

(Burn Subtitles) into QuickTime mov/mp4 Generic Subtitles**

(Encode Subtitles) HD Black QuickTime for 
NLE

Generic Subtitles**

(Encode Subtitles) HD Black AVI for NLE Generic Subtitles**

IMSC SMPTE-TT XML/PNG Generic Subtitles

(Burn Subtitles) into QuickTime mov/mp4 
using Telestream Media Framework

Generic Subtitles

IMSC 1.0 Text Subtitles Generic Subtitles
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Note: ** In CaptionMaker versions V6.5.0.6784 and older, these three exports used 
the settings of the "Link HDE3000 USF/UYC" device.

Webcast - EBU-TT Generic Subtitles

DLP Cinema text based Subtitle File Generic Subtitles

Spruce DVDMaestro TIF Graphics Spruce DVDMaestro

Spruce TL Script (extended positioning) Spruce DVDMaestro

Apple DVD Studio Pro 3&4 STL (extended 
positioning)

Spruce DVDMaestro

Daikin Scenarist TIF Graphics Daikin Scenarist

Sonic Solutions TIF Graphics Sonic Solutions

HD-DVD Sonic Solutions

CVC DVD DVD CVC

Pinnacle Impression DVD Pro Pinnacle Impression DVD Pro

Generic DVD Subtitles Generic DVD

(Encode Subtitles) Link HDE3000 USF/UYC Link HDE3000 USF/UYC

Blu-ray XML/PNG Blu-ray

Blu-Print XML/PNG Blu-ray

DVDit Pro HD Subtitle Script Blu-ray

(Encode Subtitles) Black QuickTime 720x486 
for NLE

ULTECH DV2000/ITVinjector USF/UYC

(Encode Subtitles) Black AVI 720x486 for NLE ULTECH DV2000/ITVinjector USF/UYC

(Burn Subtitles) into AVI (*.avi) ULTECH DV2000/ITVinjector USF/UYC

ULTECH DV2000/ITVinjector USF/UYC ULTECH DV2000/ITVinjector USF/UYC

Subtitle Export Function Assigned Subtitle Device
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Alpha-Channel Subtitle Overlay

When in Subtitle mode, CaptionMaker can export a MOV QuickTime file with just the 
subtitle graphics. This can be exported using the Animation codec, with Millions of 
Colors+, to provide the Alpha channel overlay capability. 

Subtitling vs. Teletext

EBU Subtitling Data Exchange Format STL (EBU-STL) is a widely-used subtitle file type in 
Europe. It is designed to be used either to burn in subtitles or to insert Teletext data into 
broadcast signals. Therefore, there are two varieties of this file and two separate 
exports in CaptionMaker. 

EBU-STL imports and exports have support for Teletext Level 1 encoding, including 
Double Height characters and text foreground color.

Note: You can manually set the Maximum Number of Rows (MNR) for EBU-STL 
subtitle export, anywhere from 0 through 99. The standard MNR values are 14, 23, and 
99. In the Export EBU-STL Subtitle File dialog box, enter a value into the field, Max 
Number of Rows (MNR).

Creating the Open-Captions Look for Burn-In Subtitles

Subtitles can be created that look very similar to standard open captions. CaptionMaker 
can convert SCC or STL, and a variety of caption and subtitle formats, to burn-in 
subtitle-only graphics using QuickTime Animations with Alpha channel. After the 
subtitle graphics are created as part of a MOV or MP4 video file, they can be used with a 
non-linear editing system such as Adobe Premier Pro, or a transcoding platform such as 
Vantage, to render them on top of corresponding video files.

Differences in Captions and Subtitles that Look Like Captions
Subtitles can be rendered to look as much like a captions as possible, but there are 
several important differences between captions and subtitles:

• Multiple-line subtitles are always rendered as one rectangular block containing all 
of the lines of text. Captions can display multiple-lines one line at a time, and the 
outline of the background behind the caption is not always rectangular.

• Captions display in a fixed grid of 15 rows of 32 characters each. Subtitles can be 
rendered using a font and font size similar to captions, but sometimes the subtitle 
text does not wrap at exactly 32 characters.
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• Roll-Up and Paint-On caption modes are not supported for subtitles, so all subtitles 
are always displayed as Pop-On.

Automatic Configuration Method to Create the Open-
Captions Look for Burn-In Subtitles
The automatic configuration method to make subtitles look similar to open captions 
will automatically adapt font size, margin, and related export settings to the current 
movie that is being subtitled, then after export, return all of the settings to their 
previous state. When using this export, it does not matter what Video Mode you have 
selected or if you are in Caption or Subtitle mode. 

Follow these steps to use the automatic “Burn Simulated Open Captions” method and 
create subtitles that have the open-captions look:

1. Have the video file loaded into CaptionMaker, and the associated caption text 
loaded, edited, formatted, and finished.

2. Choose File > Export. The Export File dialog opens.

3. Select Subtitles for File Type. 

4. From the drop-down menu choose "(Burn Simulated Open Captions) into 
QuickTime mov/mp4". 
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5. The Input File Name is already populated when you are exporting from a video that 
is loaded into CaptionMaker.

6. Click Browse under Output File Name to choose a destination and create a name for 
the file.

7. Click Finish. The “Select Starting Time Code” dialog opens.

8.  Leave the Start Time at the default setting of 00:00:00:00 to start from the first 
frame of the video, or adjust the Start Time if desired. 

9. Click OK. The Compression Settings dialog opens.

10. In the Compression Settings dialog set Compression type (or codec) to MPEG-4 
Video.

11. Select the Frames Per Second and Quality that you want, such as 29.97 and Best. It 
is good to match the frame rate to the video the subtitle file will be used with.

12. Click OK to export the video. The status bar in the bottom of the window indicates 
the progress.

13. Play the exported file to verify the placement and look of the subtitles.

Note: If you are in Caption mode when you execute the “Burn Simulated Open 
Captions” export function, the Caption-Subtitle switch will temporarily switch to 
Subtitle Mode during the export and then switch back when the export finishes. 

Manual Configuration Method to Create the Open-Captions 
Look for Burn-In Subtitles
The following steps provide specific recommended choices and settings to make 
subtitles look similar to open captions, for a 1920 x 1080 video. If you have a different 
size, or format that you want to use, see Values to Use for Different Formats of the 
Manual “Open-Captions Look for Burn-In Subtitles” Procedure, and you can substitute 
those font size and margin values in the following steps:

1. Set the resolution by going to the Video Mode menu and selecting HD1080. This 
insures that the subtitle graphics are rendered in the corresponding resolution to 
the video file it will be used with.

2. Switch to Subtitle Mode by choosing Subtitle > Device. 

3. In the Subtitle Device dialog choose a device that can support 1920 x 1080 subtitle 
graphics, such as the Generic Subtitles device and click OK. Generic Subtitles is the 
default, so this may already be selected. (Once selected, the font size and color 
becomes editable.)
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4. Set the font by selecting Subtitle > Set Subtitle Image Font. The Image Font dialog 
opens.

a. Click the Select button and choose Courier New font, Bold, type in size 42, or 
similar. Then click OK.

b. Back in the Image font dialog, set “Character pixel kerning” to 0.
c. Set “Line pixel spacing” to 0.
d. Set “SPACE character width” to 0.
e. Uncheck “Apply character border of __ pixels”.
f. Click OK to close the Image font dialog. 
g. When the dialog appears asking if “...you want to update the font in the edit grid” 

click No (unless you really do want to change the edit grid).

5. Create a black box around the text to give the look and feel of standard closed 
captions on TV: 

a. Select the Image Colors button in the Ancillary toolbar. The Image Colors dialog 
opens.

b. In Default Background Type select Black Box and set the Translucency to 255.
c. Click OK to close the dialog.

6. Adjust the subtitle margins:

a. Select Subtitle > Set Subtitle Margins and the Margin Settings dialog opens.
b. For HD1080 Video Mode enter these values—Left 327, Right 327, Top 108, 

Bottom 108, Left/Right subtitle padding 52, Top/Bottom subtitle padding 0. 
c. Click OK to close the dialog. 

7. Export the subtitle graphic as .mov black QuickTime movie:

a. Go to File > Export and select Subtitles. 
b. From the drop-down menu choose "(Burn Subtitles) into QuickTime mov/mp4”.
c. Set the Output file Name and destination.
d. Click Finish. The “Select Starting Time Code” dialog opens.
e. Set the start time to match your project or incoming STL or SCC files. If your files 

start at 1 hour then you should set Start Time Code to 01:00:00:00. If this is not set 
properly you could have 1 hour of blank video without titles.

f. Click OK. The Compression Settings dialog opens.

8. In the Compression Settings dialog set Compression type (or codec) to MPEG-4 
Video.

9. Select the Frames Per Second and Quality that you want, such as 29.97 and Best. It 
is good to match the frame rate to the video the subtitle file will be used with.

10. Click OK to export the video. The status bar in the bottom of the window indicates 
the progress. 

11. Play the exported file to verify the placement and look of the subtitles.
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Values to Use for Different Formats of the Manual “Open-
Captions Look for Burn-In Subtitles” Procedure
The following are the values to use when you have different formats than the ones 
listed in the above manual configuration procedure.

Font Sizes

Enter these font sizes when using Courier New for these Video Modes:

• For NTSC or PAL enter 20

• For HD720 enter 32

• For HD1080 enter 48

• For UHD-1 enter 94

Subtitle Margins

The following lists the six values to be entered in the Subtitle Margins dialog for the 
various Video Modes, in this order—Left, Right, Top, Bottom, Left/Right subtitle 
padding, and Top/Bottom subtitle padding:

• For NTSC enter 72, 72, 48, 48, 26, 0

• For PAL enter 72, 72, 58, 58, 26, 0

• For HD720 enter 218, 218, 72, 72, 35, 0

• For HD1080 enter 327, 327, 108, 108, 52, 0

• For UHD-1 enter 654, 654, 216, 216, 105, 0

Multi-Language Export
CaptionMaker supports encoding multiple caption languages into one output file 
using the Multi-Language Merge export functions.  But this requires a separate 
encoding pass for each caption language. CaptionMaker also supports encoding 
multiple caption languages simultaneously into one output file in a single pass. The 
current list of exports that support this are:

• Ultech ULT Caption

• MacCaption MCC 608/708

• (Encode CC) QuickTime Podcast/Web/Web Closed Captions

• (Encode CC) H.264 SEI 608/708 Closed Captions

• (Encode CC) MPEG-2 Userdata 608/708 Captions

Separate caption properties settings are maintained for each program in CaptionMaker. 
When you select Caption Menu (see Properties (Device Name) Dialog), only the caption 
properties of the currently selected program are accessed.  You must set the caption 
properties for each Program individually by selecting that program, and then selecting 
Caption Menu > Properties.
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When exporting multiple programs simultaneously using one of the above listed 
exports, the following dialog is displayed to allow you to configure/verify the caption 
properties settings for all six programs at once.

Export mode  Radio buttons that select one of these two options:

• Exporting only the currently selected program (effectively the same as previous 
versions of CaptionMaker)

• Exporting one or more programs simultaneously.

Program Settings  Check Export to export this Program.  Select a valid caption channel 
from the Channel menu.

Transcoder Configuration  Select the corresponding 708 service, and a language, for 
each caption track.

MXF Export Workflow

This export is specific to XDCAM HD MXF files. When exporting this file type you need 
an input file that has the correct codec and HD resolution based on XDCAM HD.   
CaptionMaker supports both 720P 59.94 and 1080i 29.97 XDCAM HD MXF OP1a clips. 
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The export clones the MXF and inserts a SMPTE-436M caption track in the MXF wrapper 
of the exported file. There is no transcode happening in this operation. The MXF files 
can then be played via Sony XDCAM VTR, Telestream Switch 1.5 or above, Adobe 
Premiere Pro CC, and many video playback servers such as Harris and Omneon.

In addition, V-chip, AFD, and XDS data can be added to the SMPTE-436M track during 
export.

If you need to transcode (convert) some other type of video file to XDCAM HD MXF, 
consider using Telestream Cloud or Vantage.

To embed your caption into an MXF file:

1. Prepare and finish your captions project.

2. Go to File > Export. The Export File dialog opens.

3. Select Embed Into Video and choose MXF (*.mxf) from the drop-down menu. 

4. Under Input File Name, select your source MXF file.

5. Under Output File Name, select a new name for the new captioned MXF file.

6. Click Finish. 

7. You will be prompted to select the starting time for the MXF. If your captions begin 
relative to zero (for example, the first caption appears 1 minute after the start of the 
video, and the time code for that caption is 00:01:00:00), then select 00:00:00:00. On 
the other hand, if your captions are relative to the MXF's time code track (for 
example, the MXF starts at 01:00:00:00 and the first caption is at 01:01:00:00), then 
select the MXF's starting time of 01:00:00:00.

Using OP-47 and OP-42 Teletext with MXF Files
For information on using OP-47 Teletext data with MXF files see OP-47 and OP-42 
Teletext Workflows in the Example Workflows chapter.

Checking the Captions in an MXF File
To play the video and captions together and verify for timing/sync, you can use the 
Telestream Switch application. Switch (version 1.5 and above) is one of the few 
applications that can play a wide range of captioned files.

Note that common video players such as VLC, Windows Media Player, QuickTime Player 
(any version), Sony XDCAM Viewer, and so on, do NOT display MXF closed captions of 
any type. So even if your MXF video will play in one of these players, it will not show the 
captions. 

Playing XDCAM HD MXF files in the Preview Panel
CaptionMaker supports DirectShow and QuickTime 7. To play MXF files, certain 
conditions must be met:

You must have a "MXF decoder" plug-in installed for QuickTime or DirectShow. Some 
examples are Sony Cinémon, Calibrated MXF Import, and MXF4Mac. These plug-ins 
allow QuickTime or DirectShow-based applications to play MXF files.
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Note: Even if the MXF file cannot be viewed in the CaptionMaker Preview Panel, you 
can still use the MXF file for caption embedding and extraction. In other words, you 
can still put captions into it or read captions from it even if you can't play it. 

Playing MXF Video in CaptionMaker with Captions in Sync
If you want to confirm that all of the captions were inserted correctly, you can re-import 
the captions back into CaptionMaker. Start by saving and closing any open project so 
you have a fresh blank project.

If the MXF can be played in the CaptionMaker Preview Panel, then you can use the 
following process to view the captions in sync with the movie: 

1. Drag and drop the movie into the CaptionMaker Preview Panel. 

2. Import the captions by going to File > Import. The Import File dialog opens.

3. Select Extract From Video and choose QCC Multi-format Input from the drop-down 
menu. 

4. Browse to select the file. 

5. Click Next, then make other selections if needed, or accept the defaults and click 
Finish. The captions are extracted and imported. 

6. Click the Preview Play button to play the movie in sync with the captions.

If the MXF file cannot be played in the Preview Panel, then you can use a proxy movie to 
check the timing and sync. See Using a Proxy Movie for information on creating a proxy 
movie.

Avid AAF Export

The Avid AAF workflow is designed to export a captions-only MXF file wrapped in the 
AAF container. This can then be imported into Avid Media Composer 5 or above. In 
Avid, the captions-only data file can be imported into the DATA-track on the Avid 
timeline. The Avid AAF file contains an MXF with SMPTE 436M data and includes CEA-
608/CEA-708, V-chip, XDS, and AFD data.

To export to AAF:
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1. Once captions are ready for export, go to File > Export. The Export File dialog 
opens. 

2. Select the TV Caption Files group, and then select “Avid Captions Only AAF (*.aaf )” 
from the drop-down menu.

3. Under Output File Name, enter or browse to a location and enter the name to save 
the new file. 
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4. Click Next. The Export MCC/AAF/MXF File dialog opens. 

  

5. In the MCC/AAF Export Options section, confirm the following:

a. If your captions start at 00:00:00:00, you probably want the MCC/AAF Export 
Options Start Time Code field to contain 00:00:00:00 as well. If your captions start 
with a sequence time code such as 01:00:00:00, you want the Start Time Code 
field to have the same start time as your Avid sequence. This might be 
01:00:00:00, or if you have bars/tone/slate on your sequence, it might be 
00:58:30:00 or similar.

b. The Frame Rate selector should match your Avid sequence (typically 29.97fps for 
1080i video, or 59.94fps for 720p).

6. Under AAF Export options, select Interlaced or Progressive Segmented Frame if you 
are working with an "i" format (such as 1080i) or a PsF format (such as 1080PsF 
23.98). Or select Progressive if you're working with a true "p" format (such as 720p).

7. Click Finish to complete the AAF export.
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H.264 and MPEG-2 Exports

The following H.264 and MPEG-2 exports are only available in the Pro and Enterprise 
versions of CaptionMaker. 

SEI H.264 608/708
This export is sometimes referred to as "NAL SEI 608/708 captions" or "ATSC A/72 DTV 
608/708 H.264 captions". For this export, caption data is inserted into the H.264 codec. 
This is especially useful for customers delivering MP4 with embedded captions to 
Akamai's Sola platform. This is used for streaming H.264 files. The wrapper can be MOV, 
TS, or MP4. These extensions need to be specified when saving the output file. TS is 
Transport Stream, MOV is the QuickTime container, and the MP4 wrapper is good for 
multiple player compatibility. The extension tells CaptionMaker how to multiplex the 
media and is not just an extension naming convention on export.

This export can create MP4 (ISO Base Media Format) files if the output file is named 
.mp4; M4V format if the output file is named .m4v; and QuickTime MOV files if the 
output file is named .mov. These formats are all closely related but have some minor 
differences. In these cases, the source video prior to captioning can be any of the above 
formats, but it can not be a Transport Stream.

This export creates an MPEG-2 Transport Stream (with H.264 codec) if the output file is 
named with a .ts or .m2t extension. In this case the source video must also be a 
Transport Stream (not a MP4, MOV, and so on). This export creates a generic profile 
Transport Stream that is sufficient for many uses such as web streaming, however it 
does not meet the strict specifications required by some broadcasters, such as the 
CableLabs spec. Users who need strict control over the Transport Stream parameters 
should use another multiplexing solution such as Manzanita MP2TSME.

MPEG-2 User Data
This export is similar to the "ATSC DTV 608/708 MPEG-2" export, in that it exports the 
same type of caption data into MPEG-2 Elementary, Program, and Transport streams. 
The resulting Closed Caption data is the same, but each export has some pros and cons, 
discussed below, which is why they are both available. The export extensions should be 
either .mov, .ts, or .mpg.

This is a faster mechanism than MPEG-2 ATSC export. There is only one pass required to 
insert the captions into the MPEG-2 user data or A/53 style. The extension affects the 
multiplexing mechanism on export.

This export creates a generic profile MPEG-2 Transport Stream without the use of 
Manzanita multiplexer software. These Transport Streams do not meet the strict 
specifications required by some broadcasters, such as those that require the CableLabs 
spec. However, for users who just need a generic Transport Stream, it may be sufficient.

Users who need strict control over the Transport Stream parameters (including PIDs, 
muxrate, descriptors, and so on) should use the Manzanita-based workflow, that is, 
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export "ATSC DTV 608/708 Captions to MPEG-2" export together with a Manzanita 
multiplexer such as MP2TSMS. 

MPEG-2 ATSC Export and Manzanita
This export adds userdata in A/53 into MPEG-2 Program streams or Transport Streams. 
Both 608/708 data are included in the export. If Manzanita Multiplexer is installed in the 
same computer (MP2TSMS, MP2TSME) then CaptionMaker can hand off the 
multiplexing part of the export operation to Manzanita. This is specially useful to 
deliver CableLabs compliant streams.

When creating Transport Streams there are three critical pieces of information to know: 
The video and audio PID numbers from the source file, and a Manzanita configuration 
file that matches your delivery spec. (Configuration files for CableLabs-compatible HD 
and SD files are included with CaptionMaker.)

The Video ID and Audio ID are determined by the source Transport Stream file. The 
configuration file depends on your delivery requirements. In many cases the default 
"CableLabs HD" configuration file works unless your target system requires a different 
setting.

• If you know your source file is already encoded for CableLabs, set and enable "Use 
Video ID" to 481 and set and enable "Use Audio ID" to 482. The source MPEG video 
must have already been encoded using these values, otherwise Manzanita will fail 
to demux the file. If your file was encoded with different IDs and/or you do not 
know the Video ID or Audio ID of your transport stream, please download MPEG 
Streamclip from www.squared5.com or use Manzanita MPEG ID to find the correct 
parameters. When you open the Transport Stream in MPEG Streamclip, you see the 
Video ID and Audio ID reported in the lower left corner of the window. These are 
the values you must set inside CaptionMaker.

• If you have a Manzanita configuration file it can be applied by selecting "Encode 
using user specified Manzanita config file" and clicking "Choose". This feature is 
optional, and if left disabled Manzanita multiplexer will use the default CableLabs 
HD configuration for the multiplexing.

• Make sure your caption time codes match your MPEG-2 file. If you made the MPEG-
2 file from an NLE system then it might start at 01:00:00:00 or 00:00:00:00. If it was 
captured from tape or video server it could have an odd starting time code such as 
02:03:04:05. In any case your caption time codes need to match the MPEG-2 time 
codes within the file, otherwise the captions won't line up.

Setting the Manzanita Path Variable
CaptionMaker can use Manzanita's software (such as MP2TSMS) for remuxing MPEG-2 
Transport stream files. On Windows computers it is necessary to set your Path 
environment variable so that CaptionMaker can find the Manzanita software.

To configure the Windows Path for Manzanita:

1. Open Control Panel and double click the System icon.
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2.  Select Advanced System Settings, then select the Advanced tab.

3. Click Environment Variables.

4. The folders containing the Manzanita executables must be included in the “User 
Variables” PATH (to enable transport stream encoding for the current user) or in the 
“System Variables” Path (to enable transport stream encoding for all users).

For example (add the following to the end of the PATH variable):

;C:\Program Files\Manzanita Systems\MP2TSMS 6;C:\Program Files\Manzanita Sys-
tems\MPEGId 3

Note: You need to use the actual folder names where the Manzanita software is 
installed on your system. The item for "MPEG ID" is optional and only needed if you 
have Manzanita's MPEG ID software installed and intend to use it within 
CaptionMaker.

MPEG-2 720x512 422P@ML Extreme Reach SD Delivery
This export is for a special 720x512 4:2:2 MPEG-2 format used by some distributors such 
as DG (DG Fast Channel), Pathfire, and Extreme Reach, and possibly others who use 
hardware made by Vela.

This export is for SD video only and incorporates the Main Concept engine to add VBI 
(Vertical Blanking Intervals) to the video. This is a render intensive process for these SD 
videos which are already in the MPEG-2 codec. There is a generation loss, but this can 
be minimized by using a higher bitrate option during export. This export is used by ad 
agencies to deliver to Extreme Reach.

For detailed instructions on implementing this export, see the Telestream Knowledge 
Base. The web link is on the Support page in this guide. 

QuickTime Podcast Captions
The QuickTime Podcast option embeds 608 caption tracks into MP4, MOV, 3GP, and 
M4V video containers. These containers are typically used for playing captions in 
QuickTime Player, ITunes, and iOS devices. It is recommended to apply the Podcast 
option to files that have the H.264 codec, but can be added to other codecs in the MOV 
container wrapper.

Export a Subtitle Overlay for Vantage®
Rendering burned-in subtitles (also known as open subtitles or open captions) into a 
video requires recompressing or transcoding the video, because the images are being 
changed. If you need to transcode the video anyway, it is ideal to insert the subtitles 
during the transcode step, instead of transcoding the video once to add the subtitles 
and then transcoding it again to the final format. Vantage has a Movie Overlay filter 
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(listed under Video Filters) within the Flip action which can overlay subtitles on top of 
the source video during a transcode.

First, you need to create a subtitle overlay video. This is a QuickTime MOV that contains 
the subtitles only (no video) with an alpha channel transparent background so that it 
can be overlaid on top of the video image. This can be exported from CaptionMaker 
using the “(Encode Subtitles) HD Black QuickTime for NLE" export. Make sure the 
resolution and frame rate of your subtitles video matches that of your source video. 
Also, you must pick a QuickTime codec which supports alpha channel (Millions of 
Colors Plus). Typically we recommend using the Animation codec.

The movie can then be used in the Movie Overlay filter in Vantage. Set the Overlay Left 
and Top values to 0, with Width and Height values that match the source video. The 
path to the video can be hard-coded, or it can come from a variable. 

If you use the “Work Order” feature to submit a spreadsheet to Vantage, the variable 
that points to the subtitle overlay file can be one of the columns in the work order. This 
feature is handy if you want to transcode different versions of the same source video 
with and without subtitles, or multiple versions with different subtitle languages.
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Automated Workflows

All of the features described in this Automated Workflow chapter are only available in 
the Enterprise version of CaptionMaker.

Topics
■Overview 148

■Command Line Interface (CLI) 148

■Batch Processing 154

■Vantage Plus CaptionMaker Workflow Example 155
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Overview
Automation is a great time saver and can handle much of the manual video file analysis, 
conversion, and repetitive tasks when you need to make sure content is properly 
transcoded and aired with accurate closed captioning. 

You can automate many high volume caption processing tasks, such as:

• Caption insertion and extraction.

• Format conversion.

• Time and frame-rate adjustment.

• Sub-clipping and clip assembly.

• Processing archives of video files. 

• Analyzing for quality assurance.

• Captioning data reporting.

• Combining with Vantage for powerful automated captioning workflows.

Batch Processing vs Command Line Interface
The following describes some differences between Batch Processing and using the 
Command Line Interface (CLI) option of CaptionMaker:

• Batch Processing runs only within the CaptionMaker user interface, whereas the 
Command Line Interface can operate standalone and interface with and be initi-
ated from other applications, such as Telestream’s Vantage platform.

• Batch Processing only performs some basic and simple linear functions, but the 
Command Line Interface can perform complex multiple operations.

• The Command Line Interface can be operated with no interaction needed with the 
CaptionMaker user interface. This means that operators can perform a wide range 
of captioning operations and never need to learn how to use the CaptionMaker 
interface.

Command Line Interface (CLI)
The Enterprise version of CaptionMaker provides the option to operate in command 
line mode. A typical use for this is to execute CaptionMaker from another program and 
instruct it to import caption data from one file and export the data into another file. 
Another use is operating the command line interface in QC Mode (Quality Control), so 
that an operator can inspect the captioning in a file from another program. 

Once a Command Line Interface .bat file is created, the functions it is set to perform can 
be easily initiated by any operator or from other applications. This means that operators 
do not need to learn to use the CaptionMaker interface, but can take advantage of its 
powerful features by simply clicking on a .bat file. Some features, such as Time Tailor 
report file support, are only available via the Command Line.

You can use the CaptionMaker Command Line Interface features to combine with 
Telestream Vantage for powerful automated captioning workflows.
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For details on using the Command Line Interface (CLI) feature, see the CaptionMaker 
CommandLine Options document. Open this document from Help > CommandLine 
Documentation (Local).

Run a CLI .bat File on a Folder’s Contents
A very powerful and simple method of using a Command Line Interface .bat file is to 
have it set to run on a certain folder, then whatever files are placed in that folder are 
processed when you double-click the .bat file to run it. A CLI .bat file will process all of 
the file types that it is set to work on that are in the target folder, which can be one or 
thousands of files. Other types of files can also be in the same folder, and they will just 
be ignored by the CLI operation. 

You can also place the CLI .bat file in the folder that it is set to run on. The following 
image shows a .bat file set to run on the folder it is in, and set to process .scc files:

Embedding Closed Captions into Media using the CLI
Using the Command Line Interface (CLI) can simplify the process of inserting caption 
data into media files, such as MP4, MXF, and WMV. A script can be created to take a 
caption data file, such as .MCC or .SCC, and insert the data into a media file. 

This script must define the input caption file location, input media file location, and the 
type of caption data that needs to be inserted. Finally, the script must define the export 
file location of the media with the inserted captions. 

Note: Embedding caption data does not convert the media file to a different format. 
It is imperative that the format of the input file matches the output file.
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Commands for Embedding Closed Captions into Media
The following commands are available to embed closed captions into input media files. 
The input media files must be in the same format as the export type.

Sample Script to Embed Captions into MP4 Media
The following sample script can be saved as a stand-alone .bat file for embedding 
QuickTime Podcast (type 86) caption data into MP4 media.
@echo off
for %%f in (*.scc) do (
"C:\Program Files (x86)\CPC\CaptionMaker\CapMaker.exe" /

ImportType=04 /ImportFile="%%f" /
ExportInFile="C:\Users\Administrator\Desktop\SCCtoPodcast\DemoVide
o1080i60.mp4" /ExportType=86 /ExportOutFile="output.mp4"
if errorlevel 1 (
echo Fail! Error = %ERRORLEVEL%

) else (
echo Success!

)
)

Extract Caption Data for Re-Purposing and Internet Media
A Command Line Interface (CLI) script can be configured to find and extract various 
types of caption data and convert it for multiple uses. There are two basic ways to set 
up a CLI script to extract caption data from a media file:

a. Specific format. The script can specify the type of data it needs to find. For 
example, if a media file is MXF HD with a SMPTE 436M caption track as the known 
input file type, then the script can look for that specific data.   

b. Multiple formats. If the media files are in multiple formats and resolutions then 
the QCC Multi-Format Import option can find caption data from a variety of 
video formats including, but not limited to, SD VBI, MPEG-2, and DV VAUX. 

Type Identifier Description

42  DV AVI (*.avi) 

72 MXF (*.mxf) 

51 SD ATSC MPEG2 (*.mpg, *.mpeg) 

52 HD ATSC MPEG2 (*.mpg, *.mpeg)

86 QuickTime Podcast/Web

87 H.264 SEI 608/708

56 Windows Media Player [embedded captions] (*.wmv)
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Note: If the incoming video format can be identified and is consistent, then 
specifying the caption data type in the CLI script will speed up the time it takes 
CaptionMaker to read the caption data.

Commands for Extracting Caption Data from Media Files
The following commands are available to extract caption data from media files. 

Sample Script to Extract Captions from Media Files
The following sample script can be saved as a stand-alone .bat file to use the QCC Multi-
format Import to capture all of the caption data from a variety of media.
@echo off
for %%f in (*.*) do (
"C:\Program Files (x86)\CPC\CaptionMaker\CapMaker.exe" /

ImportType=85 /ImportFile="%%f" /ExportType=04 /
ExportOutFile="%%~nf.scc"
if errorlevel 1 (
echo Fail! Error = %ERRORLEVEL%

) else (
echo Success!

)
)

Bulk Frame Rate Conversion of Caption and Subtitle Data
Automation and caption data frame rate adjustments can be applied to an entire 
archive of caption/subtitle files using the Command Line Interface (CLI), such as .SCC 
and .CAP.   This can be very useful when the input media files do not match the timing 
of the caption data. 

For example, caption files are generally timed for TV broadcast at 29.97 DF. When the 
media needs to be delivered in 23.98 fps the caption files will not be in sync with the 
deliverable, unless there is a timecode adjustment to change the frame rate of the 
caption file to match the 23.98 fps time base. 

Using the CLI for this process is extremely fast and hundreds of files can be processed in 
under a minute.   In certain cases, caption data can be extracted from media files which 
contain sync issues and fixed using this automation.

Type Identifier Description

72 MXF (*.mxf) 

51 SD ATSC MPEG2 (*.mpg, *.mpeg) 

52 HD ATSC MPEG2 (*.mpg, *.mpeg)

85 QCC Multi-format Import 
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Flip Caption Documents between Various Broadcast or Internet 
Types

TV caption data files, such as .SCC, can be converted to typical Internet caption files, 
such as SMPTE 2052 TTML and WebVTT, using the Command Line Interface or Batch 
Processing.

Furthermore, caption data can also be extracted from media files and converted to 
Internet caption files. The main use of this automation is to do the conversion to 
Internet captions during a transcode, in a format that is acceptable to the content 
provider, such as iTunes, Netflix, and so on. 

The key point is that automated conversions can retain the positioning and formatting 
of TV captions, which is required by many video distribution services and United States 
legislation under the Communications and Video Accessibility Act (CVAA).
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Converting Caption and Subtitle Files to Burn-In Subtitles
Caption and subtitle files contain timecode, positioning, and text that can be converted 
by a Command Line Interface script to graphics for subtitle overlay, or burn-in. See 
Exporting Subtitles for a description of overlay and burn-in files. 

The resulting black QuickTime movie with subtitle graphics can be used in your NLE to 
combine with the video, or use Vantage to perform this operation in an automated 
workflow. 

Command for Exporting a Black Movie with Subtitles
The following export function creates a black QuickTime movie with subtitle graphics 
that can be used for overlay onto a video for burn-in.

Note: The Type 89 export provides a wide variety of options for colors, fonts, formats, 
and more. For details, see the topic “Exporting type 89 (HD Black QuickTime movie with 
subtitles)” in the Command Line Interface document. To open this document, select 
CommandLine Documentation (Local) from the Help menu. 

Sample Script to Convert Captions or Subtitles to Graphics
The following is a sample .bat file script to convert caption or subtitle files to subtitle 
graphics for overlay.

Vantage can add this command script into an automated workflow and then use an 
overlay filter to do the burn-in of subtitles into media.
SETLOCAL ENABLEDELAYEDEXPANSION
for %%f in (*.stl) do (
"C:\Program Files (x86)\CPC\CaptionMaker\CapMaker.exe" /

ImportType=76 /ImportFile="%%f" /ExportType=89 /VideoMode=3 /
FontName="Arial" /VideoBlankColor=000000 /SubFgColor=FFFF00 /
SubCharOutlineWidth=10 /FontSize=42 /SubBgOpacity=255 /
ExportOutFile="%%~nf.mov"
if errorlevel 1 (
echo Fail Error !ERRORLEVEL!

) else (
echo Success

)
)
pause

Type Identifier Description

89 HD Black QuickTime movie with subtitles for NLE 
(*.mov) 
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Batch Processing 
Batch processing is a feature that allows users to convert and embed multiple caption 
files with a single operation.   A collection of standard caption documents can be 
selected and converted to a different format, and placed into a user specified folder. 
One example is described in a previous topic: Flip Caption Documents between Various 
Broadcast or Internet Types. 

To access the Batch dialog, go to File > Batch.

File Types Supported on Import
When clicking the Select Import File Type button the same Import File dialog opens as 
when selecting File > Import. However, some of the import file types are grayed-out 
and not available for batch processing.

File Types Supported on Export
When clicking the Select Export File Type button, the Export File dialog opens. Some of 
the export file types are grayed-out and not available for batch processing. 

Naming of Exported Files
The Name Comes From selection under Output File Naming provides two options:

• Video Source. Uses the name of the input media or video source file.

• Import File. Maintains the name of the input file and applies that to the export file. 
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Vantage Plus CaptionMaker Workflow Example
Vantage users can easily set up CaptionMaker functionality in an automated workflow 
with a “Construct” and “Notify” module in Vantage. This operation is extremely helpful 
for broadcasters who need to repurpose TV captioning archived to an Internet caption 
file such as SMPTE 2052 Timed Text .xml. In addition, CaptionMaker offers a variety of 
other commands that can be automated such as framerate conversion, support for 
caption files not supported in Vantage, timecode offset of SCC files, and quicker closed 
caption extraction for input video files to SCC.

The following example screen capture shows two actions branching from the same 
.SCC file: Convert to SMPTE-TT, and Convert to WebVTT.  You can have any number of 
actions apply to each source file.
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Using Vantage to Convert .SCC Files to WebVTT
The following steps describe how to create this example workflow to make a Watch 
action in Vantage that will automatically convert .SCC files to WebVTT. 

1. Create a Watch action in Vantage. Set it to look for *.SCC files, and create two 
variables:  .SCC File Path (complete path to file), and .SCC File Name (this is used to 
create the output file names).

2. Connect this Watch action to a Construct action, using the “Construct a Path” 
operation. This action takes the .SCC file name and uses it to create an output file 
path/name for the new WebVTT file.  The result is stored in the new variable called 
“WebVTT File Path”.
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3. Connect this Construct action to a Notify action.  This is where CaptionMaker 
comes into play.  First select the “External Shell Notifier” action type.

4. Point the external shell command to a .BAT batch file which has been prepared with 
the right arguments for CaptionMaker. (See the Sample .bat CommandLine Batch 
File below.) Then add two new argument items.  The first argument is the variable 
“.SCC File Path” from Step 1 (path to source .SCC file).  The second argument is set to 
the variable “WebVTT File Path” from Step 2 (path to the output WebVTT file).
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5. Enable the “Set state to failure on non-zero result code or timeout” option.

6. The “Timeout after:” setting is optional and, if desired, should be set to three 
minutes or so, which should allow enough time for CaptionMaker to finish even a 
long conversion job, unless you are reading/writing from the video media, which 
can take longer.

7. When the workflow is complete, Release and Activate the workflow. Now when you 
put a .SCC file in the watch folder, the workflow should activate and convert it to 
WebVTT.

You can create an additional Vantage workflow to encode and deliver a web media file, 
accompanied by the WebVTT file created in this procedure.

Sample .bat CommandLine Batch File
The following is a sample CommandLine batch file’s contents for converting .SCC to 
WebVTT via CaptionMaker. This file must reside locally on the Vantage node:
“c:\Program Files (x86)\cpc\CaptionMaker\CapMaker.exe” /
ImportType=04 /ImportFile=%1 /ExportType=91 /ExportOutFile=%2
EXIT /B %ERRORLEVEL%

Notes about the above CommandLine .bat file content:
• ImportType and ExportType numbers are listed in the CaptionMaker Help > 

CommandLine Documentation document.  In the above example, ImportType=04 
is for .SCC files, and ExportType=91 is for WebVTT output.

• %1 and %2 are the two arguments supplied in the Vantage Notify action.  These are 
the source file input path and output file path variables, respectively.

• The last line (“EXIT /B %ERRORLEVEL%”) ensures that the CaptionMaker status 
result code is passed back up to Vantage.
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Troubleshooting the Vantage Notify Action
If the CaptionMaker operation fails (CaptionMaker times-out or returns a non-zero error 
code), then the Vantage Notify action will be notified of the failure. You can right-click 
on the Notify action to find the status code.

In the above screenshot, the result code is 500. Referencing the CaptionMaker 
Command Line Documentation document, we see that this error indicates: 

500 CLI_BAD_HASP = no valid protection key was found

This error means that the dongle or software license is not valid. In other words, an 
expired or deactivated key.
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Manual Workflows

This chapter describes various workflows, such as those used for the web, mobile 
devices, video servers, DVD, and Teletext.

Topics
■Live Caption Data Input into CaptionMaker 162

■Sending Live Captions to a Telestream Lightspeed Live Stream Server 164

■Captioning for the Web and Mobile Devices 167

■File-Based Workflows 171

■Creating a DVD or Blu-ray with Captions 172

■OP-47 and OP-42 Teletext Workflows 173

■DirecTV GLA Subtitle File Export and Import 177

■Assemble Captions 180
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Live Caption Data Input into CaptionMaker

To create live caption data you need to configure CaptionMaker for the type of source 
being provided. The live caption data source can be anything supported by 
CaptionMaker. Typically, the source comes from one of the following methods:

• Retrieve Caption mode

• Live Caption mode

Retrieve Caption Mode
If you are already captioning live for broadcast (baseband feed such as SDI), you can use 
the Retrieve Caption mode to retrieve the captions from the baseband feed. To 
accomplish this, CaptionMaker must interface with a hardware encoder (such as an 
Evertz 9084HD), or a caption decoder/retrieval device (such as a Link LEI-599).

To use the Retrieve Caption mode, follow these steps:

1. Configure the connection to the caption publishing destination or device. For 
Internet destinations, such as YouTube, see Captioning for the Web and Mobile 
Devices.

2. To configure the retrieval device and connection settings in CaptionMaker, go to 
Caption > Retrieve Caption. 

3. Choose the device you want to use, then click the Configure button.

4. Configure the device settings, such as the COM port or IP address/port used to 
connect to the hardware device, and other options. Then click OK.

5. Enable your connection to the destination, and click the Start button in the 
Retrieve Caption dialog when you are ready to begin caption retrieval.



Manual Workflows
Live Caption Data Input into CaptionMaker

163

CaptionMaker User Guide                                                                                          

6. As caption data is read from the baseband feed, CaptionMaker will forward it to the 
publishing destination in real time.

Live Caption Mode
You can input text directly into CaptionMaker using the Live Caption mode. To use the 
Live Caption mode, follow these steps:

1. Go to Caption > Live Caption Options to make any adjustments to the settings, if 
needed. See Live Caption Options for more information. 

2. Enable the connection to the caption publishing destination or device:

a. To select a device, go to Caption > Device. Select the Device, then click Configure 
to create to proper settings. For information on using the Telestream Lightspeed 
Live Stream server, see Sending Live Captions to a Telestream Lightspeed Live 
Stream Server. 

b. For Internet destinations, such as YouTube, see Captioning for the Web and 
Mobile Devices.

3. To change the text panel to live entry mode, select Live Caption from the Caption 
menu. The caption grid changes to a blank white text entry field. 
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4. You can use a keyboard or any keyboard-like device to enter text into CaptionMaker 
in real time, or use a speech recognition system. A stenographic device may need 
software configuration changes. Test your text input device to see that text is 
appearing in CaptionMaker.

5. Enable your connection to the destination and begin text entry. The live text entry 
is sent to the destination if all settings are correct.

When a line of text exceeds the total characters per line set for a caption, the text 
wraps on the screen and the completed line is sent to the destination. You can also 
press the Enter key to force a line wrap and send a line at any time. 

Sending Live Captions to a Telestream Lightspeed 
Live Stream Server

CaptionMaker can be used as the source of live caption input into a Telestream 
Lightspeed Live Stream server. The IP address of the Lightspeed Live server is needed, 
and settings must be configured in the Lightspeed Live Stream web application. 

To send live captions to a Lightspeed Live Stream server, follow these steps:

1. Obtain the IPv4 address of the Lightspeed Live Stream server. Here is one method:

a. Log into the Lightspeed Live Stream server. 
b. Click the Windows Start icon in the Lightspeed Live Stream server and type 

Command Prompt. Results of your search appears.
c. Right-click Command Prompt and select “Run as Administrator”. The Command 

Prompt window opens.
d. Type ipconfig and press the Enter key. Results appears. 
e. Write down the IPv4 Address. This will be used later in CaptionMaker.

2. Launch the Lightspeed Live Stream web application in a browser.

3. Configure Lightspeed Live Stream with the settings you want to use for the source, 
encoding, and channel output destination.

a. For live captioning input setting details see the “Using Live Captioning Input via 
IP” topic in the Lightspeed Live Guide. 

b. Complete the configurations and have the output Channel ready to start.
c. Make sure you have enabled the Captioning settings in the bottom of the 

Configure Channel dialog.
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4. Launch CaptionMaker, then go to Caption > Device and select Telestream 
Lightspeed Live.

5. Click Configure to open the Device Settings dialog.

6. In LAN Settings enter the IPv4 address of the Lightspeed Live Stream server into the 
Connection IP Address field.

7. Enter the Connection IP Port that is set in the Lightspeed Live Stream web app 
“Configure Channel” dialog. The default Port is 16161.

8. Click OK to close the Device Settings dialog.

9. Click Caption Properties in the Caption Device dialog to open the Properties 
options for the Telestream Lightspeed Live device. 

10. Make any desired changes on the Control, General, and Colors tabs, and click OK to 
confirm the changes, then click OK to close the Caption Device dialog.

11. To change the text panel to live entry mode, select Live Caption from the Caption 
menu. The caption grid changes to a blank white text entry field. 
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12. You can use a keyboard or any keyboard-like device to enter text into CaptionMaker 
in real time, or use a speech recognition system. A stenographic device may need 
software configuration changes. Test your text input device to see that text is 
appearing in CaptionMaker. 

13. In the Lightspeed Live Stream web app, click the Start button to start the Channel 
you have configured for captioning input. 

14. Click the Closed Captioning icon  in the upper right of the Live Stream web 
app to access a URL to view a preview of the stream for that Channel. In the dialog 
that opens, click the clipboard icon to copy the URL or click the arrow icon to open 
the link in a new browser window. 

15. Begin the live text entry into CaptionMaker. The captioning text data is sent to 
Lightspeed Live Stream and out to the publishing destination if all configuration 
settings are correct. 

When a line of text exceeds the total characters per line set for a caption, the text 
wraps on the screen and the completed line is sent to Lightspeed Live Stream. You 
can also press the ‘+’ key to send a line at any time. 

16. When your live broadcast is finished, click the Stop button in the Lightspeed Live 
Stream web app for the Channel. 

■ Assemble Captions

– Assemble Captions Options

– Performing the Assemble Captions Operation
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Captioning for the Web and Mobile Devices
For web video, there are a number of different standards and types of video playback 
mechanisms: Flash, Silverlight, HTML5, QuickTime, HLS, HDS, MS Smooth Streaming, 
MPEG DASH, UltraViolet, and so on. To support a broad variety of different playback 
devices a provider may need to stream the video in multiple formats, because there is 
no single video format that is supported by every device. You may need to export the 
related captions into more than one of these formats.

Many mobile devices already support closed captions, although they require the 
captions in different formats depending on the device. With Telestream software it is 
easy to create captioned videos that work on multiple devices.

The iPhone and iPad are very common players for portable video and music media. The 
Apple devices support TV-style closed captioning in H.264 video files. Most Android-
based phones which support Flash can display Flash closed captions.

For additional information on captioning for the web and mobile devices, see the 
Telestream Knowledge Base on the Captioning Support page of the Telestream web 
site.

Post-Production (VOD) Web Captioning
CaptionMaker supports a large number of formats for captioning video files for video 
on demand (VOD) on the web, including:

• SMPTE Timed Text (SMPTE 2052): A new standard for captioning for both broadcast 
and the web, also for UltraViolet (DECE CFF format).

• WebVTT: Another new standard for captioning and subtitling web videos, fre-
quently used with HTML5 and Apple HLS streaming.

• H.264 SEI Embedded CEA-608/708 Captions: Used for Akamai and Wowza VOD 
streaming, and other systems that support embedded 608/708 captions inside the 
video stream.

• DFXP (TTML): Used by many Flash players and providers such as Brightcove, Lime-
light, Flowplayer, JW Player, and so on.

• iTunes Timed Text (iTT): Used for delivery to iTunes.

• SRT: Supported by many Flash players and also YouTube, however this format does 
not carry any positioning or formatting information, just plain text and timing.

• SCC: Supported by YouTube and some other web video players.

• QuickTime Closed Captions Track: Apple devices and browsers can play closed cap-
tion tracks embedded into QuickTime MOV and MP4 files, which mimics the look 
and feel of TV broadcast captions

With the exception of QuickTime Closed Captions Track and H.264 SEI Embedded CEA-
608/708 Captions, all of the other above formats are sidecar files, meaning the 
captions/subtitles are delivered as a separate file rather than being embedded into the 
video file.

www.telestream.net/telestream-support/captioning/support.htm
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Live Web Captioning

The difficulty with live web captioning is how to get the caption data from the source 
(broadcast feed, and so on) to the end user. Most web streaming encoders and web 
technologies are designed to convey only video and audio, not captions. The following 
services provide captioning options.

YouTube Live Captioning
Live captioning for a YouTube event must be configured in YouTube, using the control 
panel for the live event. When captioning is enabled, a "Captioning URL" is provided to 
you by YouTube.

Note: You must use a video streaming application, such as Telestream’s Wirecast, to 
send the live video to YouTube. CaptionMaker sends only the text stream of the 
captions to YouTube. See YouTube help for instructions on merging the video and 
caption text streams, and other required settings. 

Steps to configure CaptionMaker for live YouTube captioning:

1. Start CaptionMaker (requires Pro or Enterprise version).

2. Go to the Web menu and select YouTube Live Connection Options. 

3. Copy and paste the "Captioning URL" provided by YouTube into the connection 
URL field.

4. The remaining options can be left at default. Click OK.

5. When ready to engage the connection to YouTube, go to Web > YouTube Live 
Connection. This is a toggle that, when enabled, will establish the connection to 
the YouTube servers.

6. Now, any live caption data input into CaptionMaker is forwarded to the YouTube 
servers. To create the data, see Live Caption Data Input into CaptionMaker above. 

7. When the event has finished, go to Web > YouTube Live Connection to toggle the 
connection off.

Roll-Up Live Captions Not Supported by YouTube Live
As of January 2016, YouTube Live does not support roll-up captions for live input and 
instead automatically converts text streams to pop-on, 2-line captions. This means that 
CaptionMaker must format the captions in a way that does not cause two words to be 
put together during line breaks. The line breaks in normal roll-up captions and 2-line 
captions are different and therefore do not have an extra space between each line 
during conversion. CaptionMaker adds that space by default in order for the roll-up text 
stream to be converted without causing text errors. 

Note: Regular YouTube uploaded videos do support roll-up captions. 
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Uvault Live Captioning
Uvault, a live streaming provider and content delivery network, has added closed 
captioning support to their network. CaptionMaker can send the captions to Uvault's 
servers, which then delivers them to the end users along with the video. To send live 
captions to Uvault, follow the steps provided in YouTube Live Captioning, except using 
the Web > Uvault menu options. 
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Web Formats with Closed Captions
There are many formats for the web that have the ability to display closed captions. 
CaptionMaker can easily extract and convert closed captions to any required format, 
frame rate, or time code adjustment. This can also involve editing the video to remove 
commercial breaks or shorten the duration. CaptionMaker can make use of an edit 
decision list (EDL) from your editing system to automatically conform the original 
captions to the new web version.

Flash Closed Captioning
Adobe CC, Flex, Flow Player, JW Player, Hulu, and the Captionate plug-in support closed 
captioning files for the web. Flash video has a wide range of different custom video 
players. There are a variety of caption file formats that Flash video can support. They 
include .SRT, DFXP Timed Text .xml, SAMI .smi, Captionate .xml, and embedded .FLV 
with captions. Telestream software can export any of these file formats to support a 
variety of custom video delivery websites. 

QuickTime Closed Captioning
Telestream software provides the best workflow for inserting closed captioning or 
subtitle tracks into QuickTime files. These work not only in QuickTime Player on your 
desktop, but also in a web browser or on Apple mobile devices.

YouTube Closed Captioning
It is easier than ever to caption web videos through YouTube. Not only does YouTube 
have a speech recognition engine to help transcribe your video, but also an automatic 
time stamping tool to synchronize an already existing script. If you need the 
transcription to be perfect it is best to type it out manually in a word processor and 
upload a .txt file alongside your video to YouTube. This will result in accurate captioning 
text. However, there are times when you may have a closed captioning file or tape that 
already has captions but needs to be converted to a video that can be uploaded to 
YouTube.

Telestream software can quickly convert your TV closed captioning file or tape to the 
.SRT format that is native to YouTube. YouTube accepts other captioning file formats, 
such as SCC, WebVTT, DFXP, SAMI, and EBU-STL.

iTunes Closed Captioning
iTunes software for Mac and Windows has the ability to display closed captioning for 
iTunes videos, including video podcasts and iTunes U. All you have to do is add closed 
captions to a QuickTime .mov or .m4v file. The closed captioning in these iTunes files is 
called closed caption tracks for QuickTime. Create this closed caption track quickly and 
easily by embedding them from any caption document or already captioned video into 
the QuickTime .mov, without re-compression or generation loss.
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Windows Media Closed Captioning
If you are delivering captioning content to an all-Windows audience then Windows 
Media closed captioning could be the most compatible option. Windows Media can 
read the captioning either from a separate SAMI (.smi) file or from an embedded .wmv 
file with captioning. Telestream software can generate either one of these options for 
Windows Media servers needing to deliver accessible video content.

Akamai Sola Sphere Captioning
Telestream software can automatically convert TV closed caption data to web closed 
caption data, which can then be streamed in HD quality by Akamai. Any organization 
with a large number of archived captioned video files can reduce captioning 
operational time and errors by using batch processing mode to convert all the files in a 
folder to desired web captioning formats.

File-Based Workflows
CaptionMaker can embed closed captioning directly into files, including MPEG-2 
Program and Transport Streams, MXF, QuickTime, MCC, and many more. It supports 
broadcast video servers, such as Harris Nexio, Omneon, SeaChange, Avid Airstream, as 
well as Manzanita's multiplexers for VOD CableLabs spec.

Delivering a closed caption file in the correct format depends on the kind of system or 
software that will be used to play or process the file on the receiving side. When 
confirming the delivery specs with your facility or client, here are some good questions 
to ask:

• What kind of server or software process will they be using to ingest (import) the file 
that you send them. Example answers could be: “We will be ingesting the file into 
our Omneon playback server”, or “We are going to put the file in our Final Cut Pro 
system and output to tape”, or “We use Telestream Vantage to transcode the file to 
XYZ format”, and so on.

• What are the detailed specs of file type(s) they can accept with closed captions, 
such as wrapper/stream type, codec, resolution, frame rate, and bit rate.

Video Servers
The following provides some information about typical video servers.

Omneon
Omneon servers support different kinds of media files, depending on the options 
installed on the server:

• XDCAM HD-type MXF files with SMPTE 436M Closed Captions (CaptionMaker only).

• XDCAM HD codec MOV files with internal MPEG-2 Closed Captions (MacCaption 
only).
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• DV/DVCPRO (DV25/50) codec MOV files with internal VAUX Closed Captions.

Harris Nexio
'Harris Nexio servers with software version 5.71 and later, can use the MCC file format 
generated by Telestream captioning software for HD closed captioning.

SeaChange
SeaChange servers can use XDCAM HD-type MXF files with SMPTE 436M Closed 
Captions, or DV25 (standard def ) video with DV VAUX closed captions.

DG Fast
Depending on your specific drop box for DG Fast, they may require either MPEG-2 
Program or Transport streams with embedded closed captions for HD. For SD, they use 
the 720x512 MPEG-2 format, also supported by Telestream captioning software using 
the MainConcept plug-in.

Transcoding Software
Many facilities use a variety of transcoding solutions, such as Telestream Cloud or 
Vantage, in order to accept a wide variety of file formats and convert them to the 
preferred format. You should check to see if the transcoder being used preserves the 
closed captions embedded into the video file. In many cases, it can accept an SCC or 
MCC file with closed captions as a separate file. Or, you may need to identify the "final 
destination" format used by the facility, and provide that file type with embedded 
closed captions.

Creating a DVD or Blu-ray with Captions
When your video and caption files are exported and ready for the final DVD Master with 
closed captioning, you create the DVD using DVD authoring software. Many consumer 
DVD burning software products do not have the ability to make a captioned DVD, so 
special "prosumer" or professional authoring software must be used. For prosumer 
options we recommend Sony DVD Architect Pro (Windows) or Apple Compressor 4.2 
(Mac). You can use Adobe Encore or Apple DVD Studio Pro (Mac), if you have them, but 
they are not currently released. All of these software packages can accept a SCC caption 
data file to merge with the DVD video.

The standard format for a caption data file is the SCC (Scenarist Closed Caption) file. 
This caption data file is created with CaptionMaker and can be imported into DVD 
authoring systems. The captioning text cannot be checked until the DVD is compiled 
and/or burned. For best results, it’s important to use a set top DVD-Player connected via 
analog connections to a TV, such as S-Video or Composite (RCA), since HDMI and 
Component connections don't support closed captions.
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Note: The Blu-ray specification does not support closed captioning. However, you 
can create an SDH subtitle track to mimic the look and feel of closed captioning.

Multiple Languages on DVD
After you have subtitled or captioned a video in one language and obtained the time 
codes, the same time codes can be used for subsequent languages. A translation 
prepared in a captioning file format can then be used to subtitle or caption in 
additional languages.

A DVD can contain closed captions in up to six languages: English, Spanish, French, 
Portuguese, German, and Dutch. CaptionMakercan produce closed caption (.cc or .scc) 
files for all of these six languages.

For subtitles, a DVD disk can contain up to 32 different languages. Telestream software 
can produce subtitles in almost every language, from Arabic to Zulu, using any Unicode 
font. This gives you a large number of languages from which to choose.

Closed Caption File Format for DVD
A DVD closed caption file is a binary file consisting of a number of lines - one line for 
each closed caption. Each line starts with a time code which is separated from the 
closed caption data (in binary format) by a tab character.

 Subtitle Format for DVD
CaptionMaker creates as many files as the number of subtitles, and also a navigation 
file. The navigation file lists details (time code, size, and position) of each subtitle.

The first item on a line is the name of the graphic file, which is a picture file of a subtitle 
using a TrueType Windows font. The next two items are the in and out time codes of a 
subtitle. The following two items after that are width and height of a subtitle. The last 
two items are the position of a subtitle on a 720 x 480 screen.

OP-47 and OP-42 Teletext Workflows 

The following describes how to extract, encode, or export OP-47 and OP-42 Teletext 
data, and provides information on using MCC files that contain this data.

Extracting OP-47 and OP-42 Teletext from Source Video Files
To extract OP-47 and OP-42 Teletext, you can use the QCC Multi-format import option. 
CaptionMaker can extract OP-47 Teletext from XDCAM HD and AVCINTRA100 .MXF 
OP1a file types. OP-42 is SD only. 

To extract OP-47 and OP-42 Teletext:
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1. Go to File > Import. The Import File dialog opens.

2. In File Type select Extract From Video. 

3. Choose “(Retrieve CC/Teletext) QCC Multi-format Input” from the drop-down list. 

4. Under File Name, click Browse to select the input file. Click Next.

5. In the next screen select "Teletext Service: Teletext Subtitles" in the Select Caption 
Service to Import parameters. 

 

6. In the Teletext Page field, you can enter the magazine and page number to extract 
from the MXF source file. The default is 801, and another common option is 888. 

 

7. Click Finish to start the extraction process. 

Note: As an alternative, users can also extract OP-47 HD Teletext from MXF files using 
the dedicated MXF import option "(Retrieve CC/Teletext OP47) MXF (*.mxf)”. 
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Encoding OP-47 Subtitles into MXF Source Video Files 
CaptionMaker can insert OP-47 Teletext subtitle data into the SMPTE 436M track of MXF 
OP1a files. The supported MXF files must be either 720P or 1080i/p with XDCAM HD 
specifications (MPEG-2 essence video). In addition, they must have a video frame rate of 
25 fps or 50 fps, because Teletext only supports these frame rates. There is an export 
option to select in order to embed OP-47 Teletext data into MXF. 

To embed your Teletext data into MXF files, follow these instructions:

1. Prepare and finish your subtitle project.

2. Go to File > Export. The Export File dialog opens.

3. Select File Type > Embed Into Video. 

4. Choose “(Encode Teletext OP47) MXF (*.mxf)” from the drop-down list. 

5. Under Input File Name, click Browse to select your source MXF file.

6. Under Output File Name, select a path and set the name for the new captioned 
MXF file.

7. Click Next.

8. In the next screen you can select the Teletext Subtitle Page, VANC Line F1, VANC 
Line F2, VBI Line F1 and F2, the Filler Type, and the option to have "Double Height" 
characters. See Understanding the Teletext OP-47 Export Options below for 
information on these settings. 

  

9. Click Finish to save your selections. 
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10. You are then prompted by the "Select Starting Time Code" dialog to select the 
starting timecode for the first frame in the video file. Choose the start time that 
corresponds to your CaptionMaker project, by selecting the starting time that will 
sync to your first caption/subtitle in the CaptionMaker text grid.

11. The last option is to add Active Format Description (AFD) to your SMPTE 436M track 
in your MXF. This is optional and should only be used if required by a broadcast 
facility. 

Understanding the Teletext OP-47 Export Options
The Teletext Subtitle Page value should be set to the standard magazine “8”. This is 
the first digit in the parameter, so a setting of 801 will indicate magazine 8 and page 01.   
Samples of MXF files from broadcasters have included single language Teletext 
subtitles in either 801 or 888. Please refer to your TV station's delivery requirements to 
select the appropriate magazine and page number before embedding and delivery of 
OP-47 MXF files.

VANC Line F1 (field 1) is set to line 12 by default. This means that SDI hardware 
baseband playout of the Teletext OP-47 data will be mapped to line 12 (Line 9 is used 
for 608/708 captions). A different line for VANC data can be specified into the SMPTE 
436M track of the MXF file, but is not standard and should only be used when it is 
required.

VANC Line F2 (field 2) should only be used with interlaced video that has field 2 data. 
Progressive video source files should set this parameter to "0", which is disabled. Setting 
VANC Line F2 is optional and should be done if required.

VBI Line F1 (field 1) is one of the Teletext OP-47 standard definition Vertical Blanking 
Intervals for specific downstream applications. The value used for VBI Line F1 is 
typically 21 or 22. The available range is 7 to 22. 0 = disabled. The default value is 0. 

VBI Line F2 (field 2) is one of the Teletext OP-47 standard definition Vertical Blanking 
Intervals for specific downstream applications. VBI Line F2 is often set to 0, or disabled. 
The available range is 320 to 335. 0 = disabled. The default value is 335. 
Note that 335 is line 22 for Field 2.

The Filler Type controls what gets encoded into the spaces between the subtitle 
“bursts”. The default is Packet 31 Test Data, and the other options are Null Page Headers, 
and None (No Filler).

Note: Inserting a constant stream of Packet 31 ‘ExtTest’ data between subtitles keeps 
TVs at a constant gain rate, ensuring accurate reception and display of subtitles

National Option Sub-Set provides the option to choose National Option English or 
National Option Portuguese/Spanish for the export.

Double Height refers to the size of the characters. Selecting this option will result in a 
bigger font size for the text when viewed with a Teletext decoder on a broadcast TV 
monitor.
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Importing and Exporting MCC Files with OP-47 Teletext Data
To import an MCC file containing OP-47 Teletext data: in the Import File dialog choose 
TV caption Files and select “MacCaption MCC 608/708 (*.mcc)” from the File Type drop-
down menu. Then select “Teletext Service: Teletext Subtitles” in the next screen.

When exporting an MCC file containing OP-47 Teletext data: in the Export File dialog 
choose the “TV Caption Files” file type and select "MacCaption MCC Teletext OP47 
(*.mcc)” from the drop-down File Type menu. 

Under Export Options in the next screen, select the appropriate magazine and page 
number for the OP-47 data that will be added to the MCC file. See Understanding the 
Teletext OP-47 Export Options above for more information on the settings. 

Inserting MCC Files with OP-47 Teletext into an MXF Source 
Video

CaptionMaker can also directly insert OP-47 Teletext data from an MCC file that 
contains OP-47 data into an MXF OP1a source video. This means that it's a direct 
conversion and does not import the MCC OP-47 into the CaptionMaker project.

To insert the MCC OP-47 data into an MXF file: in the Export File dialog choose the 
"Embed Into Video" File Type and select "(Encode CC/Teletext) MCC to MXF (*.mxf)” 
from the drop-down File Type menu.

Exporting the OP-42 Alpha Channel VBI File
The OP-42 export creates a QuickTime animation black movie with alpha channel VBI 
file. This file is used with Vantage or other transcode and editing systems to render the 
VBI into an MPEG IMX SD .MXF file.

Note: OP-42 is SD only and the project should be set to PAL 25 FPS.

To create the OP-42 export, go to File > Export and select “Embed into Video” in the 
Export file dialog, then choose "(Encode Teletext OP42) Black QuickTime 720x608 for 
NLE (*.mov)" from the drop-down menu. Set your output file name and click Next.

Change settings as needed in the next dialog, using the same page numbers as Teletext 
OP-47, then click Finish to continue. In the next Compression Settings dialog, you must 
only choose Animation, then click OK to export.

DirecTV GLA Subtitle File Export and Import 

The Direct TV GLA file type is based on the .SCC (Scenarist Closed Captioning) file 
format. The main difference is that the CEA-608 data is modified to meet special 
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subtitle style formatting that is supported by Direct TV cable systems and set-top 
boxes. The exported file will have a .GLA file extension and is designed to be used with 
a Vantage transcode service in order to insert the GLA caption data into a video media 
file. 

Exporting a GLA File
Before exporting the GLA file, CaptionMaker must be set to encode the specific 
modified caption data for this export type. 

Follow these steps to enable the GLA encoding:

1. From the Caption menu select Device. The Caption Device dialog opens.

2. Select DirecTV GLA from the Device drop-down list. Press OK to use the selected 
device. 

3. Once the device is set to DirecTV GLA, go to the File menu and choose Export. The 
Export File dialog opens.

4.  Select the Subtitle file type, then choose “DirecTV GLA Subtitle File (*.gla)” from the 
drop-down list.

5. In Output File Name click the Browse button to choose the location and set the file 
name. Use the .GLA file name extension and press Next.
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6. Choose the Select Time Code String Format: 

a. For drop frame projects select Semicolon. 
b. For non-drop frame projects select Colon.

7. Press Finish to start the export. 

Note: For this type of caption file, it is essential that every caption has enough time to 
process. If a caption has a large amount of characters, it needs more time to process 
the data. 
If two large captions are timed too closely to each other, there will be a time overlap 
and the file could contain errors. For this reason, It is essential that you do a Final 
Check, to verify that enough time is specified to send each caption, using a time code 
tolerance of 0 frames. 
If your caption timing is very tight, it is recommended that you uncheck "Duplicate 
control codes when sending captions" in the Caption > Properties dialog.

Importing a GLA File
To import GLA files, the DirecTV GLA device does not need to be selected. However, 
CaptionMaker must be set to import CC1 EIA-608 services from the GLA file.

Follow these steps to import a GLA file:

1. From the file menu select Import. The Import File dialog opens.



Manual Workflows
Assemble Captions

180

CaptionMaker User Guide                November 14, 2022

2. Select the Subtitle Files type, then choose “DirecTV GLA Subtitle File (*.gla)” from 
the drop-down list. 

3. Click the Browse button to locate the file you want to import. 

4. Press Next to proceed to the Import Options dialog. 

5. Make sure that CC1 is selected for Field 1 EIA-608 Services (CC1 is the default).

6. Press Finish to import the file.

  

Assemble Captions

 

The Assemble Captions feature can save you a lot of time when you have a show that is 
already captioned, and now you need to edit the video. When editing video that 
contains closed caption data, any cuts or inserts will cause the original caption track to 
no longer match the edited sequence. Also, any rendering such as transitions, color 
correction, or compositing of graphics can cause deletion of closed caption data. In the 
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past, this would require the project to be re-captioned from scratch. The Assemble 
Captions feature can find the original captioning data, conform it to match the edited 
sequence, and re-insert it into the final video (including other video formats) after all 
the editing is complete.

Assemble Captions is a feature that is very similar to an assemble edit feature in a non-
linear editing system. It is designed to import an edit decision list (EDL) from Final Cut 
Pro via an Apple Interchange Formatted XML file. MacCaption can conform the closed 
captions to the video edits that were made in Final Cut Pro, provided that the original 
video clip had closed caption data.

Assemble Captions will work with both closed caption data and subtitle files in EBU-STL 
(.stl) and PoliScript PE2 (.txt) formats.

The following is a list of practical applications for the Assemble Captions feature:

• Editing previously captioned SD and HD video clips.

• Combining two or more previously captioned clips on one timeline.

• Adding graphics or overlays to a captioned video clip.

• Editing a vendor master for web or disc delivery without losing caption data.

• Color enhancing or correcting a video master after it has been closed captioned.

• Fixing flash frames in the final video master without losing caption data.

• Cutting foul language or adult content from a video master without losing caption 
data.

• Cutting a video master to clock, making space for more commercial time, without 
losing caption data.

Assemble Captions Options

The following options are available in the Assemble Captions dialog:

• Conform .scc time codes to current time code mode. Adjust .scc time code val-
ues to the current time code mode.

• Conform final result to sequence starting time. Adjusts the starting timecode of 
the captions to the starting timecode of the video sequence. For example, if the 
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video sequence starts at 01:00:00:00 then the decoded captions will also start at 
this time. When deselected, the starting timecode of the captions is set to 
00:00:00:00 by default.

• Offset final result by [00:00:00:00]. Enter a time value to offset the final result. 

• Erase current program data before adding new captions. Erases all captions cur-
rently open in MacCaption prior to importing the new assemble caption. This fea-
ture saves the extra step of starting a new project in order to clear the caption 
project of caption data before performing the Assemble Caption operation.

• Force caption erase at clip boundary. Inserts a caption erase when a caption 
extends over a clip boundary. Depending on the caption data, there may be times 
when a cut in the video breaks the caption timecode that extends beyond the 
length of the cut. In addition, there may be captions that come in before the dia-
logue starts if dialogue was removed during editing. This option automatically 
deletes these captions in order to accurately represent the edits that were made.

• Preserve MacCaption decoded caption data as .scc files. Saves the captions 
extracted from source movies into .scc files in the movie’s folder. MacCaption 
decodes captions from QuickTime videos into .SCC files in order to accomplish the 
Assemble Caption operation. This option permanently saves these .SCC files along-
side the QuickTime videos in their corresponding folder, or in a user specified loca-
tion. 

• Remove clip boundary captions that display less than 1 second. Removes a 
caption that has a display time of less than 1second and extends to the next clip 
boundary. This function is similar to "Force caption erase at clip boundary" except 
that it only affects captions that display less than 1 second.

• Use alternate data file location—Set Location. Sets a new specific location for 
.scc files generated in the Assemble Captions operation. When not selected, Mac-
Caption will save and/or look for SCC files in the same folder as the video file.

Performing the Assemble Captions Operation
Follow these steps to perform an Assemble Captions operation:

1. After editing the captioned clips, export an XML (Apple Interchange Format Version 
4) from Final Cut Pro or other nonlinear editor (NLE).

2. In MacCaption, go to Caption > Decode Preferences and choose the channel for the 
type of captions you are decoding from the Decode Channel drop-down menu.

a. Use “CC1” for Line 21 or DV captions.
b. Use “CC1 in DTV” for AJA KONA or BlackMagic captured files.

3. In MacCaption go to File > Import > Assemble Captions and choose the file type to 
import (.edl, .xml, or .fcpxml).

4. Browse for and open the .edl, .xml, or .fcpxml file that was exported from Final Cut 
Pro or other nonlinear editor.
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5. The Assemble Captions dialog opens and has the following options. The 
recommended options to select for typical operations are in bold:

a. Conform .scc time codes to current time code mode
b. Conform final result to sequence starting time
c. Offset final result by 00:00:00:00
d. Erase current program data before adding new captions
e. Force caption erase at clip boundary
f. Preserve MacCaption decoded caption data as .scc files
g. Remove clip boundary captions that display less than 1 second
h. Use alternate data file location

6. Once you have set your desired Assemble Caption settings press OK, and the 
captions for the edited clip will now sync up to the final edited video and load into 
MacCaption.

7. Check the captions and make any final adjustments.

8. Export the finished project in the desired format.
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Menus

This chapter provides details about the CaptionMaker menus.

Topics
■File Menu 186

■Edit Menu 189

■View Menu 192

■Attribute Menu 194

■Format Menu 197

■Caption Menu 202

■Subtitle Menu 215

■Time Code Menu 224

■Video Mode Menu 232

■VTR Control Menu 233

■Web Menu 234

■Transcription Menu 236

■DV Menu 238

■Tools Menu 239

■Help Menu 243



Menus
File Menu

186

CaptionMaker User Guide                November 14, 2022

File Menu

New Project
(Control+N) Creates a new project file. If a project is open, CaptionMaker asks you to 
save the current project before creating a new one.

Open Project
(Control+O) Opens a CaptionMaker project file. To open other file types, use the Import 
or Merge options.

Save Project
(Control+S) Saves CaptionMaker project files. To save other file types, use the Export or 
Merge options.

Save Project As
Save a new version of the current project.

Open Movie
Opens the Video Properties dialog. See Opening a Movie for a description of the dialog 
and options.

Note: You can also drag and drop a video file into the preview panel. This opens the 
Video Properties dialog.

Insert File
Opens the Import File dialog. You can import a new text file into the existing project at 
the currently selected row. Or, create a new project by selecting that option in the 
Import File dialog. See Import Format Settings for a description of the dialog options.

Import
Opens the Import File dialog. See Import Format Settings for a description of the dialog 
options.

Export
Opens the Export File dialog. See Exporting / Encoding for a description of the dialog 
options.
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Merge Import
Opens the Merge Import Options dialog. Replaces the number markers at the start of 
designated lines with time code values from the base file. The base file is the original 
file with time code assigned to key points in the text. You can import a merge 
formatted file which can have multiple languages in it.

Merge Export
Opens the Merge Export Options dialog. Replaces the number markers at the start of 
designated lines with time code values from the base file. The base file is the original 
file with time code assigned to key points in the text. You can export a merge formatted 
file which can have multiple languages in it.

Batch
Opens the CaptionMaker Batch dialog. Batch processing allows users to convert and 
embed multiple caption files with a single click.   See Batch Processing for a description 
of the dialog options.

Auto Save
Opens the Auto Save Properties dialog.

Offers the option of saving the file automatically, including the time interval (in 
minutes) desired. You can choose one option or both.

• Automatically save the document every [xx] minutes

• Automatically save a backup file (.bak) every [xx] minutes

If you choose the first option you can’t revert to a much earlier version.

Note: If you do not specify a file name/location for saving, CaptionMaker generates a 
file name of: UntitledMMDDYYYYhhmmss.cap, and automatically saves the file in your 
user Documents folder.

The second option saves automatically to a separate backup file with an extension BAK. 
This option can be advantageous because it ensures that the file is saved periodically, 
and also makes it possible to revert to a much earlier version if needed.

When you open a BAK file, you must re-save the file under a different name with the 
CAP extension before you start working with the file.



Menus
File Menu

188

CaptionMaker User Guide                November 14, 2022

Default File Folders
Opens the Default File Folders dialog. Allows you to choose default folders for when you 
open files, and you can choose a location for the Temp directory.

Old Transcription Mode
Enable/disable Old Transcription Mode. When enabled, the cursor moves to the next 
caption cell when you press Enter. This is useful if you compose or transcribe captions 
within CaptionMaker. When this mode is disabled, pressing Enter produces a carriage 
return within the same caption cell.

When Old Transcription Mode is enabled the new Transcription Edit Mode feature is 
not available. When the new Transcription Edit Mode is enabled, Old Transcription 
Mode is not available.

Print
(Control+P) Sends the Text Panel (any selected visible columns) to the printer.

Print Preview
Lets you see how the Work Area will print.

Print Setup
Opens the Print Setup dialog for your local printer.

Page Setup
The Page Setup dialog lets you choose printing margins and options. Click the Print 
Columns button to choose which columns you want to print.
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Note: Printing the vertical and horizontal lines can take a long time. Avoid printing 
the vertical and horizontal lines if possible.

Open Recent Documents
A list of recently open documents, that you can choose from to re-open.

Exit
Closes CaptionMaker.

Edit Menu

Undo
(Control+Z) Steps back through your last actions to undo them.

Redo
(Control+Y) Restores the states you used Undo to roll back.

Cut
(Control-X) Removes the highlighted text or selected object and stores it in memory.

Copy
(Control+C) Copies the highlighted text or selected object to memory.

Paste
(Control+V) Places the previously copied or cut text, or selected object, from memory 
into the target component.

Paste Options
Opens the Paste Options dialog.
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Chars Per Line Settings
Opens the Characters Per Line Settings dialog. This dialog allows you to define a safety 
limit for the number of characters in a given line for subtitle imports, exports and 
editing operations.

Note: The Chars Per Line limit must be defined for all new projects. If not, the default 
safety limit of 50 will be applied.

Find
(Control+F) Opens the Find dialog.

Replace
(Control+R) Opens the Replace dialog.

Word Substitution
When selected, opens the Edit Word Substitution window. Enter text to find, and 
replacement text. Check flags (optionally).

Live Word Substitution
When enabled, words are found and are automatically replaced whenever you type the 
trigger keystrokes. Trigger keystrokes are space (space bar), end of word punctuation ( , 
; : ), or end of line punctuation ( . ! ? ). 
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Configure Word Substitution
Opens the Configure Word Substitution dialog. You can enter words that you want to 
substitute during a Word Substitution operation. After words are entered in this dialog, 
initiate word substitution by selecting Edit > Word Substitution.

• Add. When you click Add to enter new words for substitution, the Edit Word Substi-
tution dialog opens.

• Edit. Select an item in the list and click the Edit button to open the Edit Word Substi-
tution dialog so you can make changes.

• Remove. Select an item in the list and click the Remove button to delete that item.

• Load File. Opens a browse dialog so you can choose a saved word substitution list 
text file to load.

• Save File. Opens a browse dialog so you can choose a location to save the current 
word substitution list as a text file.
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• Match Whole Word. Select this option in the Edit Word Substitution dialog when 
you want the find and replace operation to match the complete word, and not a 
portion of it.

View Menu

Select Programs
Shows the currently selected Program in the grid, and allows you to select a different 
Program (A through F).

Visible Columns
Visible Columns dialog. Select the columns to display in the text panel, such as Start, 
Duration, Justification, or WPM/CPS.

Full Screen Spreadsheet
Toggle between displaying the text panel in the entire CaptionMaker window, or the 
normal view.

Semi-full Screen Spreadsheet
Select to hide the video preview player and create more room for the spreadsheet. De-
select to include the video preview player in the main window.

Pop-Up Preview Window
Opens the video preview panel in a separate window. You can place this window 
wherever you like.

Reset Pop-Up Preview Window Position
Resets the position of the Pop-Up Preview Window to the top left hand corner of the 
primary display.

Audio Waveform Window
Opens the Audio Waveform display in a separate window. You can resize this window, 
and move it around the screen.

See Audio Waveform Window for detailed information.

Reset Audio Waveform Window Position
Resets the position of the Audio Waveform window to the top left hand corner of the 
primary display.
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Anchor Current Row
Enables anchoring the current row to the third row. The rows move so you can see a 
few rows of text below the current cursor location. If you don’t anchor, the rows do not 
move. You may set the anchoring for four different situations:

• Anchor in Edit mode. Turns on anchoring in the Edit mode.

• Anchor on Send Caption/Subtitle. Turns on anchoring when you send captions or 
subtitles using the [+] key.

• Anchor in AutoSync. Turns on anchoring in the AutoSync and Auto Preview Sync 
modes. This option is selected as a default.

• Anchor in Live Caption. Turns on anchoring in the Live Caption mode.

Toolbars and Docking Windows
Open/close the toolbars and customize menu and toolbar settings.

• Main

• Ancillary 

• VTR 

• Customize. Opens the Customize dialog. You can change settings for the menus 
and toolbars. You can also reset menus or toolbars to the default settings when 
updates or changes in new versions are not appearing.

Status Bar
The status bar is at the very bottom of the CaptionMaker window. De-select to hide it. It 
contains information about settings of caption/subtitle hardware, video and time code 
type (NTSC/PAL), status of CapsLock and NumLock keys, and a progress bar during 
export and some other operations. It also shows whether the time code is Non-Drop (N) 
or Drop (D) frame just before NTSC/PAL.
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Black Text on White Background
Select to switch the text panel to the CaptionMaker classic look of black text on white 
background.

Words Per Minute Using 5 Chars/Word
Toggle this setting on when you want to use a five-character-per-word calculation to 
determine Words Per Minute (WPM) rather than the CaptionMaker default WPM 
calculation.

When this setting is toggled off, the CaptionMaker default WPM calculation determines 
each individual word by finding the spaces between the words.

View CPS in the grid instead of WPM
When selected, CaptionMaker replaces the WPM (Words Per Minute) column in the grid 
with the CPS (Characters Per Second) column.

Attribute Menu

Display Mode
For detailed descriptions of all of the modes, see Display Modes. 

• Pop-On. Pop-on mode is recommended for most post-production captioning proj-
ects. 

• Paint-On. The characters are painted on the screen one after another, from left to 
right. 

• Roll-Up 2 Lines. Sets a maximum of two lines to appear on screen at a given time.

• Roll-Up 3 Lines. Sets a maximum of three lines to appear on screen at a given time.

• Roll-Up 4 Lines. Sets a maximum of four lines to appear on screen at a given time.

• Block Roll-Up. This is a combination of the Paint-On and Roll-Up modes.

• Pass Through. Enables Pass Through mode for a segment of the video which as 
been previously captioned. This mode lets the captions previously existing on the 
video pass through.

Text Color
Opens a menu to choose the color of the text from one of eight colors: default (white), 
blue, cyan, green, magenta, red, yellow, white, and black.

Background Color
Opens a menu to choose the color of the background for the text from one of eight 
colors: black, blue, cyan, magenta, red, yellow, white, and green.
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Note: Text Color and Background Color selections apply to the currently selected text 
or rows (cells). A single word, phrase, or entire cells can have a user selectable text and 
background color applied. Select individual words or cells to apply different color 
formatting to only the selected items.

Background Type
Select the background for the generated captions or subtitles. The default is Normal for 
captioning, and Black Box for subtitling. The Background Type options are different for 
captions and subtitles.

Caption Background Type options:
• Normal. The background is only behind each character. This is the default.

• Black Box. The background is a rectangle that is as wide as the caption text.

• Fill Row. The background is a rectangle that spreads to the full width of the avail-
able character space (32 characters).

Subtitle Background Type options:
• Black Box. Sets a background box behind the subtitle. This can be different colors 

and different levels of transparency. Use the Background Translucency option (see 
below) to adjust the color and transparency. Black Box, with Translucency set to 
zero, is the default setting, which effectively makes the background box transpar-
ent.

• Fill Row. Stretches the background box to the full width of the screen that the sub-
titles can span.

• Transparent. Sets the background to transparent. When this is set to transparent, 
the Translucency setting (see below) has no effect.

Note: The preview panel can not display transparent subtitle backgrounds or levels of 
transparency when a movie file is opened with Quicktime or DirectX DirectShow. 
These are always shown as solid colors. However, the subtitles are exported correctly 
according to the transparent and translucency settings.

Background Translucency
Opens the Image Colors dialog, where you can set the background and foreground 
colors, style, translucency and other options. This is only available in subtitle mode.

Bold/Flash
(Control+B) Makes the selected text bold for subtitling, and flashing for captioning.
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Italic
(Control+I) Makes the selected text italic. Italic is often used to indicate off-screen 
speakers in captioning or untranslatable words in subtitling.

Underline
(Control+U) Underlines the selected text.

Horizontal Justification
• Left Justify (Control+L)

• Center Justify

• Right Justify

Horizontal Position
• Left Position

• Center Position

• Right Position

• Other... Opens a dialog to choose a specific position.

• Move Left 1 Character

• Move Right 1 Character

Vertical Position
• Top

• Center 

• Bottom

• Other... Opens a dialog to choose a specific position.

• Repeat Last Other

• Move Up 1 Line

• Move Down 1 Line

Insert Music Symbol(s)
• Single Musical Symbol. (Control-M) Inserts a music symbol (the quarter note) into 

the caption text at the cursor location. The music symbol appears in the Preview 
Panel but not in the Text Panel. The section mark (§) represents the music symbol in 
the Text Panel. When the character is sent to the caption device it produces the 
music symbol.

• Surrounding Musical Symbols. Inserts a music symbol at the beginning and end 
of selected text. If you choose multiple cells and choose this option, it adds a pair of 
music symbols for all the captions being highlighted.
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Insert Transparent Space
Adds one transparent character space in the caption text at the location of the cursor.

Insert Black Box Space
Adds one blank transparent box space in the caption text at the location of the cursor.

Insert Ellipsis
Insert an ellipsis (three period dots) in the text at the location of the cursor.

Note: The ellipsis will appear as a period (.) in 608 output files in CaptionMaker 8.0 
and greater. (This is due to transitioning to Unicode.)

Insert Ruby/Bouten
A ruby is an annotation added to (above or below) a word in a subtitle. The original 
word in the subtitle is called the "base text" and the annotation is called the "ruby text".

Boutens is a form of text emphasis like underlining, and it is handled exactly the same 
as ruby except the "ruby text" always consists of only "filled circle" characters (U+25CF), 
a.k.a. "bouten dots".

To insert a ruby, place the cursor in the cell where you want to insert and select Attribute 
Menu > Insert Ruby/Boutens. Enter "ruby text", click the right-arrow, then enter "base 
text".

Note: Ruby and Boutens are only supported by exports that render subtitle images 
and the IMSC 1.1 Text Subtitles export. For all captioning functions and captioning 
exports and subtitle text exports other than IMSC 1.1 all "ruby text" is ignored.

Format Menu
Note: To access some of the functions from the Format menu, you can right-click in 
the Caption/Subtitle column to open a popup menu.
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Select Row
Opens the Select Caption/Subtitle Record dialog. Move to a specific row by typing the 
row number.

Insert Row(s)
Adds a new row to the Text Panel in the row above the one currently selected. You can 
also use the Insert Row(s) button in the Row Operations tools. Hint: If you need to 
insert a row at the very bottom, click at the end of the text in the last cell and use the 
Split Row command or button to do so.

Delete Row(s)
Removes the currently selected row from the Text Panel. You can also use the Delete 
Row(s) button in the Row Operations tools.

Split Row
Splits the selected row into two rows at the cursor’s current position. You can also use 
the Split Row button in the Row Operations tools.

Merge Rows
Merges all selected rows into a single row. You can also use the Merge Row(s) button in 
the Row Operations tools.

Erase Blank Rows
Removes all blank rows in the Text Panel that do not contain timecode or text.

Auto Split Row(s)
Splits text from the selected row(s) and inserts it into multiple new rows in the grid 
based on the settings specified in the Auto Split Rows Settings dialog. If the original 
row contains a valid start and stop time code, then the time code is calculated for each 
inserted row.
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This function works both in normal mode and in Transcription Mode. You can assign a 
keystroke to this function in Customize Keystrokes.

Configure Auto Split Row(s)
Use the Auto Split Rows Settings dialog to configure Auto Split Row(s) options.

Reformat Rows
Opens the Reformat Lines dialog, offering options for line break settings.

Note: Using Reformat Rows resets the positioning of all affected cells to user defined 
values (default is bottom centered).
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Reformat Caption(s) to Roll-up
Reformats the selected rows to apply the roll-up style, based on settings you choose in 
the dialog.

Reformat Caption(s) to Pop-on
Reformats the selected rows to apply the pop-on style, based on settings you choose in 
the dialog. This can also be used to adjust existing pop-on captions to provide a 
consistent look. For example, if your project is already in pop-on mode and you want a 
different number of lines per block, or if many blocks were edited and now have too 
many lines.

Square Up Text Block
Squares up the text in the currently selected rows, making the lines closer to the same 
length.

Compress Text Block
Compresses the line length of the currently selected captions, reducing the margins for 
the current cell. You can click multiple times to add incremental compression. You can 
also use the Compress Text Block button in the Formatting tools section, or the 
Compress button in column C of the Text Panel.



Menus
Format Menu

201

CaptionMaker User Guide                                                                                          

Expand Text Block
Expands the line length of the currently selected captions. Increases the margins within 
a cell and decreases the number of lines. If you begin with a narrow or compressed 
caption, the Expand Text command adjusts the text into fewer rows that are wider. You 
can click multiple times to add incremental expansion. You can also use the Expand 
Text Block button in the Formatting tools section, or the Expand button in column E of 
the Text Panel.

Alternate Break
Selects alternate line break words in the currently selected captions. Clicking multiple 
times toggles between possible line breaks. It is better to make the text bottom heavy 
(shorter lines towards the top, longer lines towards the bottom). You can also use the 
Alternate Break formatting button in the Formatting tools section, or the Alternate 
Break button in column A of the Text Panel.

Upper/Lower Case
Opens the Upper/Lower Case dialog. See Upper, Lower, or Sentence Case for more 
information.

Pull First Word
Pulls the first word of the next caption into the currently selected caption. You can also 
use the Pull First Word formatting button in the Formatting tools section, or the Pull 
First Word button in column U of the Text Panel.

Push Last Word
Pushes the last word of the currently selected caption to the next caption. You can also 
use the Push Last Word formatting button in the Formatting tools section, or the Push 
Last Word button in column D of the Text Panel.

Snap Vertical Positions
The Snap Vertical Positions option moves all captions or subtitles in the current project 
to the absolute bottom or top row positions.

• Snap All To Bottom. Moves all captions/subtitles in the project to the absolute 
bottom row.

• Snap All To Top. Moves all captions/subtitles in the project to the absolute top row.

• Snap To Top and Bottom. Moves all captions/subtitles in the project based on 
their current position. Captions/subtitles on the upper half of the screen are moved 
the absolute top and those in the lower half of the screen are moved to the abso-
lute bottom.

Note: Snap Vertical Positions is also available when using the CaptionMaker 
Command Line Interface feature. 
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Caption Menu
The Caption menu provides adjustment options and settings when in the Captioning 
Mode. If most of the selections are grayed-out, it means you are in Subtitle Mode.

Send Caption(s)
• Send Caption Line(s) (+ key). Sends the currently selected line to the caption/sub-

title device.  Reads the time cue (from the time code reader or the PC System Timer) 
and puts the time stamp in the Start column.

• Send Caption Erase (- key). Sends an erase-line command to the caption/subtitle 
device to remove the currently selected caption line. 

• Beep When Sending Captions. When selected, a beep occurs when captions are 
sent to a device.

Clear Caption
Sends one blank caption to the video resulting in clearing any existing captions on the 
video.

AutoSync
Performs automatic output to a caption device. After you have associated a time stamp 
with each row, AutoSync automatically outputs the text to the caption device. This 
process is driven by the timecode or the PC System Timer. The cursor does not need to 
be in a specific place in the text in order to start AutoSync.

If you do not have a caption device attached to the computer, choose Virtual Encoder 
as your device. CaptionMaker does not send any data to the Virtual Encoder via serial 
port and you do not get any communication errors.

AutoPreviewSync
Allows you to preview the output that is produced when you use AutoSync. After you 
have associated a time stamp with each row, AutoPreviewSync automatically outputs 
the text. If you are preparing a caption/subtitle file and do not have a captioning device 
attached to your system, you may check the positioning and timing of your file by 
invoking this option instead of using AutoSync.
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AutoRepeat
Opens the AutoRepeat Using System Timer dialog. This is used to loop playback to test 
connectivity to a device, or with the Internet. The text is sent out repeatedly. Use this on 
completed caption projects that have finished time codes.

AutoSync Error Checking
Performs automatic time code error checking as you work. When AutoSync Error 
Checking is selected, CaptionMaker goes through the whole file to make sure there are 
no missing time codes or the time codes are not in ascending order before starting 
AutoSync. With this option checked as you work, errors are caught quickly and 
AutoSync stops at the point of the error.

Final Checking
Opens the Verify Database dialog, where you can check for many common errors with 
the file. It is typically invoked before AutoSync. You can choose options related to time 
code tolerance, reading speed of captions, maximum characters per line, unacceptable 
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characters for captioning, and so on. You can choose any single item or combination of 
items.

  

Timing Error Settings
Opens the Error Coloring Settings dialog. See Error Checking for details on error 
settings and operation.

Jump to Next Timing Error
Takes the cursor to the next error from where it is currently positioned. Used for 
navigating from error to error, which was discovered by Timing Errors Settings, so you 
can make corrections.

Jump to Previous Timing Error
Takes the cursor to the previous error from where it is currently positioned. Used for 
navigating from error to error, which was discovered by Timing Errors Settings, so you 
can make corrections.

Preview Options
• Display Preview Image. When selected, the caption/subtitle is displayed in the 

Preview Panel.

• Highlight Rows During AutoSync. When selected, highlights the current row in 
the Text Panel that is being sent to the captioning/subtitling device (during both 
manual and AutoSync operations).

• Blinking AutoSync Status. When selected, an AutoSync indicator flashes green 
and gray in the bottom status bar when AutoSync is in operation.
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• Preview Image Matches Line(s) Sent. When selected, the Preview Panel and an 
external video monitor show the same text when you press the [+] key. Otherwise 
the text on the video monitor will always lag one row behind the selected row on 
the computer screen.

Note: When Preview Image Matches Line(s) Sent is selected, you can’t drag and drop 
the text in the Preview Panel. After you press the [+] key, the text is sent to the video 
monitor via a caption/subtitle device. It cannot be repositioned.

Live Caption
Select to switch to live caption mode. The caption grid changes to a blank white text 
entry field. Allows you to caption a non-scripted, live presentation by entering dialog as 
it is spoken. When you check this option, and set the captions to Roll-Up mode, you are 
ready to caption a live show in real time.

Live Caption Options
• Roll-Up Lines. Choose 2, 3, or 4 lines of Roll-Up text.

• Caption Length. Sets the maximum length of caption lines. Maximum number of 
characters allowed per line is 32. You may choose any caption length from 12 to 32.

• Left Indent. Opens the Left Indentation dialog to set the left margin for the first 
character.

• Fast Indent. Allows you to set the left margin to preset values from 0 to 20.

• All Attributes. Opens the Live Caption - All Attributes dialog to set various 
options.

• Send to Top. Moves the caption(s) to the top in the row(s) selected.

• Send to Bottom. Moves the caption(s) to the bottom in the row(s) selected.

• Roll Up 1 Blank Line. Sends one blank caption line to the video, resulting in rolling 
up the existing caption on the video by one line. If you are using Roll-Up captions, 
this option can also be used to clear captions on the video by invoking it several 
times to roll up existing captions of more than one line.

• Font Height. Sets the font height in points. Enter the point size you prefer, from 9 
to 24 points.
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• Send Options. Opens the Live Caption Send Options dialog. You can choose to 
send the words to the encoder as soon as they are entered, or after a delay. You can 
also choose time-out options to flush the last word and close the encoder device. 

– To send immediately, uncheck all options and set all entries to 0. (Default)

– To send at the end of a line, select Send after each line.

– To send after a word or several words, check Send after each word and enter the 
number of words to delay.

– To see what has been sent so far, you can turn on Highlight sent live caption 
words/lines.

– To time-out sending, set either Flush Last Word after or Close Caption Device after 
to 0–10 seconds.

• Debugging Options. Opens the Live Mode Debugging Options dialog. Allows 
you to enable Log all Live Mode Keystrokes to a file and lets you browse to select the 
path where you want the log files stored.

Live Bridge Mode
Allows a live captioner using CaptionMaker connected to a hardware encoder device 
on one serial port to temporarily allow other caption data received on a second serial 
port in the same computer to be "bridged" to the hardware encoder.

Live Bridge Mode Options
Opens the Bridge Mode Options dialog. Shows the current device settings and allows 
you to choose the additional COM Port for Live Bridge Mode.

Web-TV
• Edit Web-TV Link. Opens the WebTV - Interactive Link dialog. Settings allow a 

viewer using a WebTV box to click on an icon and link to a Web site associated with 
the content of the program they are watching.

• Delete Web-TV Link. Select to delete the WebTV - Interactive Link settings.

Wink Trigger
Wink is a free, easy-to-use service that allows users to interact with television shows and 
advertisements.

• Edit Short Trigger. Opens the Wink Short Trigger dialog to enter settings and 
information.

• Delete Short Trigger. Select to delete the Wink Trigger settings.

• Wink Trigger Defaults. Set default options for Wink Trigger.
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V-Chip
Use these settings to insert V-Chip Ratings onto line 21 of a video. The V-Chips in TVs 
read the broadcast V-Chip rating information, and either display or block the program 
depending on the V-Chip setting chosen by the viewer.

Device
Opens the Caption Device dialog which allows you to choose a device and configure its 
settings.  Device Selection and Configuration for more information.

The caption devices are all hardware, except for Virtual Encoder, with the specifications 
based on the device. See the device manufacturer for settings recommendations. The 
hardware devices are typically connected via modem, LAN, or serial COM port.  

The following caption devices are available from the Device drop-down menu:
 

Cavena STU

DirecTV GLA 

DSP-1000

EEG DE 241CG

EEG DE 132/352

EEG EN270 Smart Encoder II

EEG EN370 Desk Top Encoder

EEG EN470 Smart Encoder III

Evertz Encoder 

Evertz Encoder (XON)

Generic Decoders



Menus
Caption Menu

208

CaptionMaker User Guide                November 14, 2022

Generic Encoder 

Link Decoders

Link PCE-845D/PDR-885/PDP-886

Link PDE-890/ENC-896

Link PDR-885 V1.1L

Microvideo Encoder

Norpak Encoders

SkyMicro

Soft Touch Hubcap

Soft Touch Hubcap (Mag)

Special Encoder

Telestream Lightspeed Live

Text Output

Ultech DisplayaCap

Ultech EDS400

Ultech InsertaCap

ULTECH SG401 (cap decoder mode)

Ultech UDE 400

vBrick

* Virtual Encoder

Wohler
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Device Settings Dialog

To adjust configuration settings, select a device and click the Configure button. The 
Device Settings dialog opens.

 

• RS232 Settings.  If you are captioning a video on-site, choose Connect Via RS232 
serial port and select the settings.

• Modem Settings. To caption a video at a remote location via modem. The encoder 
must have a built-in modem or a modem attached to it. Choose Connect via modem 
using then select the modem from the list.

• LAN Settings. If your encoder device supports serial over ethernet LAN connec-
tions, you may choose Connect Via Local Area network (LAN).

• Delay. This option delays the timing of each control code that is sent to a hardware 
encoder, by the number of milliseconds set. This may be valuable when a hardware 
encoder is having trouble keeping up with control codes for live encoding.

• Advanced Options. When a hardware encoder is connected to CaptionMaker it 
can have the ability to check its connection by using a response checking mecha-
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nism. This mechanism can interrupt certain operations. Select Disable Encoder 
response checking to disable a hardware encoder’s response checking feature.

When the Evertz Encoder is selected, the option to Retrieve From the Output Video 
instead of the Input Video is available.

Properties (Device Name) Dialog

To adjust properties for the currently selected Program, select a device and click the 
Caption Properties button. The Properties (device name) dialog opens.

 

Control Tab 
• Channel. Select the channel to use: C1, C2, C3, C4, T1, T2, T3, or T4.

C1 through C4 mean the same thing as CC1 through CC4 which are in the 
Transcoder Configuration section of this dialog, and in other CaptionMaker loca-
tions.

C1 through C4 (or CC1-CC4) is a service that can be selected for the project that is 
loaded in the CaptionMaker interface. If the user needs to create an alternate lan-
guage caption channel, or service, then the channel option can be set to C3 or 
something other than the primary C1. If the user selects C3, then CaptionMaker will 
export caption data for that channel only. This is also true when using Caption-
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Maker connected to a hardware encoder. By selecting C3, the hardware encoder 
knows to only add a new language and not delete what is encoding in CC1.

T1-T4 is typically used to display text-only information, such as weather reports or 
stock quotes. Some broadcasters require data to be encoded as a text service using 
hardware. Users can encode to channel T1 through T4 for these specific workflows.

• Compatibility. The Compatibility drop-down menu provides the choices EIA 608, 
TeleCap I, TeleCap II, and EIA 608 (No TeleCap).

To help understand the Compatibility choices, here’s some history. Over the years, 
decoders have evolved through three different sets of standards:

1.TeleCap I decoders were produced by the National Captioning Institute (NCI) 
during the period 1980 to 1983. These decoders cannot recognize:

a.(a) Paint-on mode,
b.(b) Centering, and
c.(c) Captions without blinking between them.

2.TeleCap II decoders were manufactured by NCI during the period 1984 to 1994. 
These decoders cannot handle:

a.(a) Captioning near the center of the screen,
b.(b) Color captioning, and
c.(c) Field 2 and EDS captioning.

3.EIA 608. This is the current standard (as of 1999), which was formulated by the 
Electronics Industries Association (EIA) in 1994 and does not have any of the 
above limitations. New television sets with built-in decoders follow this standard. 

When you select a particular value for compatibility, the program does not send 
any characters or attributes that are not allowed by that compatibility, as incom-
patible characters can cause a TeleCap I or TeleCap II to display garbage charac-
ters. But this does not remove the characters from the CaptionMaker Text Panel.

• With older, external TeleCap I and II decoders, there are only 2 caption and 2 text 
channels available, but technical reasons precluded the use of the second channel 
in practice. With the new EIA 608 standard, it is possible to put two sets of captions 
on one video.

• Initialization. The Initialization Field 2 shows the control codes that are being sent 
to a hardware encoder when that device is initialized. The Special read-out is an 
indicator of the data that CaptionMaker is sending via hardware.

• Upstream Transparency. Theses options are designed to add an additional lan-
guage or caption service to a video signal using a hardware encoder. If you are add-
ing CC3 data in field 2 then you would select Allow existing field 1 data to pass 
through untouched. Then the hardware encoder will know to keep the existing CC1 
data in field 1 during encoding.



Menus
Caption Menu

212

CaptionMaker User Guide                November 14, 2022

• Options. Select the options you want to use. Typically, the default options should 
remain selected: “Send caption data...”, “Send Web TV...”, “Send Wink...”, and “Send V-
Chip...”.

Normally, leave Duplicate control codes... unchecked. If broadcasting to areas with 
poor reception, check the box to send control codes twice.

CaptionMaker sends a reset command when initializing a caption encoder device. 
This can cause problems in cases where multiple systems are connected to a single 
caption encoder device (as the second system to connect will send a reset com-
mand). Checking this box prevents CaptionMaker from sending a reset command. 
This might help with some workflows.

• Transcoder Configuration. Up-converts the service selected above in Channel C1-
T4 into708 (HD). The menu choices map which 708 service channel is connected to 
each language.

• Enable encoding 608 flash attribute. Check this option to enable flashing text in 
outputs. When this box is not checked, CaptionMaker exports all text as not-flash-
ing, even if it is bold. By default, exporting bold and flash as one attribute is dis-
abled. 

Note: Currently, if you want to caption a video in Spanish and in English, you must be 
using encoder equipment that is capable of changing Lines and Channels. You need 
only create one file, but you must run the AutoSync process twice, once for each 
language, due to speed limitations of the encoder.

• Pad for 16x9 mode. When checked, captions are padded 5 columns in from the 
left to center the captions within the 16x9 format screen.

Note: The Pad for 16:9 mode option is intended only for testing consumer TV sets and 
set-top box hardware. This option should not be selected when delivering to 
professional broadcast mechanisms and facilities.

General Tab 
• Pop-On. When checked, blank frames are inserted between pop-on captions. The 

default value is 2 blank frames.

• Live Caption Options: For live captions, sets the number of lines for a roll-up cap-
tion, the left indentation in characters, and the number of characters per line.

• Options. Select Convert to uppercase to send all characters to the caption device as 
uppercase. Select Mark time code... to enable sending captions by pressing the plus 
(+) key on the numeric keypad.

Colors Tab 
Lets you choose the default foreground and background colors for captioning.
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Note: You have the flexibility to change these defaults on each word or row, using the 
options in the Attribute Menu. Please note that not all caption decoders have color 
viewing capability.

• Foreground. Use the drop-down menu to set the default foreground color.

• Background. Use the drop-down menu to set the default background color. 
Opaque makes the color solid. Translucent lets you see some video through the 
color.

Properties
Opens the Properties (device name) dialog for the captioning device currently active in 
CaptionMaker. Details of the Properties dialog are described above.

Initialize Device
Initializes the currently active device. In case you power-off or change the caption/
subtitle device in the middle of a session, you can use this option to ensure it initializes 
properly.

Start in Pass-Through Mode
Select Start in Pass-Through Mode when you want the hardware encoder to not delete 
existing caption data. When selected and you are connecting to a hardware encoder for 
the first time, CaptionMaker tells the encoder not to delete any existing captions. This is 
important when commercials or other content already has captions.

Go to Pass-Through Mode
When using a hardware encoder, use this option to enable pass-through mode at 
anytime, if there is existing caption data in the live video feed. This will tell the hardware 
encoder to let it pass-through untouched.

Close Device
Closes the caption/subtitle device. If your device is a CC encoder, it will free up the 
encoder. If a video with pre-recorded captions passes through the encoder, when the 
device is closed, the captions will pass through. This might be very helpful when you 
are captioning a live broadcast and the TV station airs some commercials with existing 
captions. If the device is not closed, the existing captions from the video will be 
stripped off.



Menus
Caption Menu

214

CaptionMaker User Guide                November 14, 2022

Set Caption Margins
Opens the caption Margin Settings dialog. Default caption margins are all zero. With this 
setting, you have a maximum of 32 characters in a row and 15 possible rows. Unless you 
are quite advanced in captioning, it is better to leave all the margins as zero. If you make 
margins other than zero, you will limit the number of rows and maximum allowable 
characters per row.

• Display Margins. Select to display a white frame that indicates where the margins 
are set. The frame only displays when captions are present. See example below.

• Set as the default... Select this option so that all new projects use these settings 
instead of the defaults.

The following image shows the display of the caption margin settings indicator frame.
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Retrieve Caption
Opens the Retrieve Caption dialog. Allows you to retrieve captions, along with time 
code and positioning information, from a previously captioned video, and store them 
in a file.

The Retrieve Caption command is implemented for a limited number of encoders. After 
retrieving the captions, you may use the file for the following purposes:

• To generate a DVD caption file.

• To generate a DVD subtitle file.

• To reinsert captions onto time-compressed video.

• To reinsert captions to a new, edited version of a previously captioned video.

You will need to edit the caption file to match the newly edited video.

Before retrieving captions, make sure to turn the AutoSave option off. Or, first save the 
blank screen to a file name before retrieving captions. Otherwise you will be asked to 
save the file every few minutes during the retrieval process.

If you chose to also retrieve time codes, connect the time code to the time code device. 
After retrieving caption data, run a final test to check the integrity of the data before 
you use the file for any other purpose.

Send Retrieved Captions to Certain Live Servers

When you are retrieving captions, CaptionMaker has the ability to simultaneously write 
the retrieved captions into the grid and send them to a YouTube Live, Uvault, or Live 
Text Stream server. See Live Caption Data Input into CaptionMaker.

Dial Modem
Permits dialing out over a phone line using a modem connection. If you are captioning 
from a remote location, you may need to connect your modem to the encoder via a 
telephone line. Connect a telephone line to the modem and click on this option. You 
will see a dial-up screen. Type the telephone number including area code. Click on Dial 
to connect your modem to the remote Encoder.

Hang up Modem
Disconnects from the phone line, terminating the modem connection

Subtitle Menu
The Subtitle menu provides adjustment options and settings when in the Subtitle 
Mode. If most of the selections are grayed-out, it means you are in Caption Mode.
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Send Subtitle(s)
• Send Subtitle Line(s) (+ key). Sends the currently selected line to the caption/sub-

title device. Reads the time cue (from the time code reader or the PC System Timer) 
and puts the time stamp in the Start column.

• Send Subtitle Erase (- key). Sends an erase-line command to the caption/subtitle 
device to remove the currently selected caption line.

• Beep When Sending Subtitles. When selected, CaptionMaker sounds a beep 
when subtitles are sent to a device.

Clear Subtitle
Sends one blank subtitle to the video resulting in clearing any current subtitles on the 
video.

AutoSync
Performs automatic output to a subtitle device. After you have associated a time stamp 
with each row, AutoSync automatically outputs the text to the subtitle device. This 
process is driven by the timecode or the PC System Timer. The cursor does not need to 
be in a specific place in the text in order to start AutoSync.

If you do not have a subtitle device attached to the computer, choose Generic Subtitles 
as your device. CaptionMaker does not send any data to the virtual device via serial 
port and you do not get any communication errors.

AutoPreviewSync
Allows you to preview the output that is produced when you use AutoSync. After you 
have associated a time stamp with each row, AutoPreviewSync automatically outputs 
the text. If you are preparing a caption/subtitle file and do not have a subtitle device 
attached to your system, you may check the positioning and timing of your file by 
invoking this option instead of using AutoSync.
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AutoRepeat
Opens the AutoRepeat Using System Timer dialog. This is used to loop playback to test 
connectivity to a device, or with the Internet. The text is sent out repeatedly. Use this on 
completed subtitle projects that have finished time codes.

AutoSync Error Checking
Performs automatic time code error checking as you work. When AutoSync Error 
Checking is selected, CaptionMaker goes through the whole file to make sure there are 
no missing time codes or the time codes are not in ascending order before starting 
AutoSync. With this option checked as you work, errors are caught quickly and 
AutoSync stops at the point of the error.

Final Checking
Opens the Verify Database dialog, where you can check for many common errors with 
the file. It is typically invoked before AutoSync. You can choose options related to time 
code tolerance, reading speed of subtitles, maximum characters per line, unacceptable 
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characters for subtitling, and so on. You can choose any single item or combination of 
items.

  

Timing Error Settings
Opens the Error Coloring Settings dialog. See Error Checking for details on error settings 
and operation.

Jump to Next Timing Error
Takes the cursor to the next error from where it is currently positioned. Used for 
navigating from error to error, which was discovered by Timing Errors Settings, so you 
can make corrections.

Jump to Previous Timing Error
Takes the cursor to the previous error from where it is currently positioned. Used for 
navigating from error to error, which was discovered by Timing Errors Settings, so you 
can make corrections.

Preview Options
• Display Preview Image. When selected, the caption/subtitle is displayed in the 

Preview Panel.

• Highlight Rows During AutoPreview. When selected, highlights the current row 
in the Text Panel that is being sent to the captioning/subtitling device (during both 
manual and AutoPreview operations).

• Blinking AutoPreview Status. When selected, an AutoPreview indicator flashes 
green and gray in the bottom status bar when AutoPreview is in operation.
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• Preview Image Matches Line(s) Sent. When selected, the Preview Panel and an 
external video monitor show the same text when you press the [+] key. Otherwise 
the text on the video monitor will always lag one row behind the selected row on 
the computer screen.

Note: When Preview Image Matches Line(s) Sent is selected, you can’t drag and drop 
the text in the Preview Panel. After you press the [+] key, the text is sent to the video 
monitor via a caption/subtitle device. It cannot be repositioned.

Set Codi Font
If you are using a Chyron Codi as your subtitling device, you can set the default fonts 
using this option.

Set Subtitle Image Font
Opens the Image Font dialog. See Setting the Font Image Properties for more details on 
setting choices.
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Set Subtitle Margins
Opens the subtitle Margin Settings dialog. Sets margins at the edges of the screen to 
ensure subtitles remain within the title safe area. The defaults are 192 for left and right, 
108 for top and bottom, and 5 for the padding.

• Display Margins. Select to display a white frame that indicates where the margins 
are set. The frame only displays when subtitles are present.

• Set as the default... Select this option so that all new projects use these settings 
instead of the defaults.

The following image shows the display of the subtitle margin settings indicator frame.
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Set Vertical Alignment
Opens the Align TextBlock(s) dialog. Sets the vertical alignment options for subtitles.

Device
Opens the Subtitle Device dialog which allows you to choose a device to configure its 
settings. Device Selection and Configuration for more information.

Some of the subtitle devices have target-specific graphic generation parameters for 
specific media, such as the DVD and Blu-ray options. Other devices are hardware, 
except for Generic Subtitles, with the specifications based on the device. See the device 
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manufacturer for settings recommendations. The hardware devices are typically 
connected via modem, LAN, or serial COM port.

The following subtitle devices are available from the Device drop-down menu:

Apple DVD Studio Pro

Blu-ray

Chyron Codi

Chyron Digital PC-Codi

Chyron PC-Codi

Daikin Scenarist

DVD CVC

Generic DVD

* Generic Subtitles

Link HDE 3000 USF/UYC

MagniCoder Premier

MagniCoder Pro

Pinnacle Impression DVD Pro

Sonic Solutions

Spruce DVDMaestro

ULTECH DV2000/ITVinjector USF/UYC
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• To adjust configuration settings, select a device and click the Configure button, if 
the selected device has configuration options. The Device Settings dialog opens. 
The options vary, depending on the device selected.

 

– RS232 Settings.  If you are subtitling a video on-site, choose Connect Via RS232 
serial port and select the settings.

– Modem Settings. To subtitle a video at a remote location via modem. The 
encoder must have a built-in modem or a modem attached to it. Choose Connect 
via modem using then select the modem from the list.

– LAN Settings. If your encoder device supports serial over ethernet LAN 
connections, you may choose Connect Via Local Area network (LAN).

– Delay. This option delays the timing of each control code that is sent to a 
hardware encoder, by the number of milliseconds set. This may be valuable 
when a hardware encoder is having trouble keeping up with control codes for 
live encoding.

– Advanced Options. When a hardware encoder is connected to CaptionMaker it 
can have the ability to check its connection by using a response checking 
mechanism. This mechanism can interrupt certain operations. Selecting the 
option Disable Encoder response checking sends a command to a hardware 
encoder to disable its response-checking feature.
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• To adjust properties, select a device and click the Subtitle Properties button. The 
Properties (device name) dialog opens. The options vary, depending on the device.

• Pop-On. When checked, blank frames are inserted between pop-on subtitles. The 
default value is 2 blank frames.

• Options. Select Convert to uppercase to send all characters to the subtitle device as 
uppercase. Select Mark time code... to enable sending subtitles by pressing the plus 
(+) key on the numeric keypad.

Properties
Opens the Properties (device name) dialog for the subtitle device currently active in 
CaptionMaker. Details of the Properties dialog are described above.

Initialize Device
Initializes the currently active device. In case you power off or change the caption/
subtitle device in the middle of a session, you can select this option to ensure it 
initializes properly.

Time Code Menu
Note: To access some of the functions from the Time Code menu, you can right-click 
in the Start or Stop column to open a popup menu. Some of the options, such as 
Ripple, require you to highlight a number of cells before you invoke the option.

Start Time Code Reader
When selected, timing information displays from the timecode reader, video playback, 
or the PC System Timer.
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Pause Time Code Reader
Pauses the displayed timing information from the timecode reader, video playback, or 
the PC System Timer.

Time Code Mode
Set the timecode mode to one of the frame rates listed. It is extremely important to 
make the right choice to match the video and caption/subtitle hardware you use.

ATS Auto Time Stamp
Initiates the Auto Time Stamp operation. See Using Automatic Time Stamp (ATS) for 
details on operation and usage.

Auto Time Stamp Options
Opens the Error Coloring Settings dialog. See Error Color Settings for details.

Mark “In” Time Code
Choose this to set the In Point or Start Time of the first word of the currently selected 
caption to the current Movie Time. If multiple rows are selected, the start time is set for 
the first, or top row. This option is also available from a menu when you right-click in a 
Start or Stop time code field.

Mark “Out” Time Code
Choose this to set the Out Point or End Time of the last word of the currently selected 
caption to the current Movie Time. This only needs to be set when a space is needed 
between captions, such as when there is a pause in the speech, or when the captions 
have ended. This option is also available from a menu when you right-click in a Start or 
Stop time code field.

AutoAdvance after Mark Time Code
This function should normally be checked. The only reason to uncheck this is if you 
want to assign a timecode to an individual row without the software automatically 
moving the cursor to the next row, so that you may get the timecode a number of times 
in order to make sure it is precise.

Mark Time Code on Send Line(s)
When selected (highlighted yellow), a time code is marked (from the time code reader 
or the PC System Timer) when you press the keyboard [+] key, as well as sending a 
caption or subtitle. If you are sending captions or subtitles manually (not using time 
code) you should not have this button selected.
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Enable Video File Auto Shuttling
When this is selected (toggled on), and you select a caption row, the video 
automatically jumps to the time of that caption. You can also quickly move through the 
caption rows using the up and down arrow keys, and the video follows along. This is the 
same as selecting the Auto Shuttle (Video Follows Captions) button  in the control 
bar below the video preview panel.

Enable Auto Row Select
When this is selected (toggled on), the captions change along with the video, following 
the Start and Stop times that are set. This is the same as selecting the Auto Row 
(Captions Follow Video) button  in the control bar below the video preview panel.

Same Start Time
When multiple rows are selected, the start time of the first row is applied to all of the 
remaining selected rows. This option is also available from a menu when you right-click 
in a Start or Stop time code field.

System Timer Start Time
If you are using the PC System Timer, this option lets you choose the start time (the 
default is 00:00:00:00). This option is useful when time code is not available, then you 
can simulate time code using the PC System Timer.

Set System Timer to Current Start Time
This option resets the PC System Timer to the same time as the time stamp on the 
current row. This option is extremely important to time-stamp a video with the PC 
System Timer. After resetting the PC System Timer, the action of pressing the [+] key to 
read time code or invoking AutoSync, makes the PC System Timer start running at that 
instant.

Set Blank Frames
Opens the Blank Frames dialog, where you can set the number of blank frames between 
pop-on lines. When a new caption/subtitle replaces the previous one in Pop-On 
subtitling, a blink-like action takes places. There is a short interval where no caption or 
subtitle is on the screen. The standard interval that is commonly used is 2 to 6 frames. 
The default value is 2.
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Ripple Time Code
Opens the Ripple Time Code dialog. You can change the time code within the currently 
selected block, or from a selected row to the end of a file. See Applying Ripple Time 
Code Offsets for more information.

 

Convert Time Code
Opens the Convert Time Code dialog. This feature allows you to maintain or modify the 
clock time, change the frame rate, convert from/to PAL and FILM, switch between drop 
frame (DF) and non-drop frame (NDF), and set a time offset. See Convert Time Code for 
more information.
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Stretch/Shrink Time Code
Opens the Stretch/Shrink Time Code dialog. If your caption timing is right on time at 
the start but is off a few seconds from the video at the end, you have captioning drift. 
This can be corrected by using the Stretch/Shrink Time Code option. See Stretch/Shrink 
Time Code for more information.

Non-Linear Shrink Timecode
Opens a Windows dialog so you can choose a text file that contains the information to 
shrink the timecode.
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Reading Speed
Opens the Set Reading Speed dialog. This option is useful for generating captions for use 
by young children, since they may not read as fast as older children or adults, and for 
persons reading captions or subtitles in a non-native language. This option has two 
functions:

a. You can check the average reading speed for selected rows, if they have time 
codes assigned. This does not change the actual time codes.

b. You can also assign a desired words per minute reading speed to a block of 
selected rows. You need to assign time code only for the first row of the selected 
block. In this case, the reading speed of each row is going to be exactly the 
reading speed you assign. This option does change the actual time codes. 

Fill-In Time Code
Opens the Fill-In Time Code dialog. This feature has the following options:

• You can assign a time code to selected rows if a time code is set for the first and last 
line of the selected rows. This can be used when a person is speaking for a long 
period of time (a lecture or speech) at a fairly steady rate. This feature can save time 
when subtitling a video, since it does not require you to enter a time code for each 
row.

• Choose the second radio button when you have no start times in the selected 
range.

• Select Force a minimum cell duration of ___ frames so captions with a single or a few 
words do not end up with a duration of less than the number of frames entered. For 
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pop-on captions 30 frames is recommended, and for roll-up captions 20 frames is 
recommended.

Limit Caption/Subtitle Durations
Opens the Limit Durations dialog, which allows you to enter a duration limit, in seconds, 
for the selected range.

Sort Captions/Subtitles by Time Code
Sorts the selected caption/subtitle rows into time code order from lowest to highest.
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Time Code Reader Properties
Opens the Time Code Reader Properties dialog.

• Reader Tab. Allows you to select one of the several time code readers, or the PC 
System Timer. You can also change the display rate of the time code reader. When 
using a reasonably fast computer, the Display Update rate should probably remain 
at the default value of Fast.

• Colors Tab. Allows you to change the color of the time code display in Caption-
Maker, but has no effect on any aspect of the appearance of the final captioned or 
subtitled video.

Increment Selected Row Start Time Code Value
Increments the selected time code value start time by 1 frame (for example, 00:00:00:00 
to 00:00:00:01.

Decrement Selected Row Start Time Code Value
Decrements the selected time code value start time by 1 frame (for example, 
00:00:00:01 to 00:00:00:00.

Increment Selected Row Stop Time Code Value
Increments the selected time code value stop time by 1 frame (for example, 00:00:30:00 
to 00:00:30:01.

Decrement Selected Row Stop Time Code Value
Decrements the selected time code value stop time by 1 frame (for example, 
00:00:30:01 to 00:00:30:00.
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Preview Play
This is an alternative to clicking the Preview Play button in the CaptionMaker user 
interface. This menu item can have a keyboard shortcut assigned via Customize 
Keystrokes.

Time Stamp
This is an alternative to clicking the Time Stamp button in the CaptionMaker user 
interface. This menu item can have a keyboard shortcut assigned via Customize 
Keystrokes.

Video Mode Menu
Use the Video Mode menu options to set CaptionMaker to the same mode as the video 
you are working with. The choices are:

NTSC
NTSC (National Television Systems Committee) is the analog, standard definition (SD), 
television standard for North America, Japan, and some other parts of the world. NTSC 
supports closed captioning (608 only) on Line 21 of the video signal.

PAL
PAL (Phase Alternating Line) is a system for analog television used in Europe, Asia, 
Australia, and most of South America and Africa. Broadcasting at 625-line / 50 field (25 
frame) per second (576i).

HD720
HD720 is a high-definition (HD) progressive HDTV signal format with 720 horizontal 
lines and a widescreen aspect ratio (AR) of 16:9 (1.78:1), with a resolution of 1280x720 
pixels. Closed captioning for HD is sometimes called Line 9 or VANC, and is codified 
under the 708 standard.

HD1080
HD1080 (also known as Full HD or FHD and BT.709) is a set of HDTV high-definition 
video modes characterized by 1080 horizontal lines of vertical resolution and 
progressive scan, as opposed to interlaced, as is the case with the 1080i display 
standard. The term usually assumes a widescreen aspect ratio of 16:9, and a resolution 
of 1920x1080 pixels. Closed captioning for HD is sometimes called Line 9 or VANC, and 
is codified under the 708 standard.

UHD-1
UHD-1, also known as Ultra HD, has a resolution of 3840x2160 pixels.
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VTR Control Menu

Typical VTR Controls
Allows you to control a VTR using Sony BVU-800 protocol machines and Panasonic 
AG5700 series devices. The control button options are self-explanatory, being in 
common use on video recording and playback devices. Shortcut keys are available for 
many controls.

Enable “JKL” Control
Enables use of the J, K, and L keys to play the video in the Preview Panel or VTR. Press J 
to rewind, K to stop, and L to play forward. Multiple presses of the J or L keys increases 
the speed.

Configure “JKL” Control
Allows you to set the speed increments for the J and L keys. See Advanced Playback 
Control for more information on configuring the speed settings.

Shot Change Marker Insert/Remove

Note: These options are disabled until a Tools > Find Shot Changes operation is 
executed on the currently loaded video file.

Use these options to insert or remove markers for a shot change:

• Insert shot change at current time code. Select to manually insert a shot change 
marker at the currently selected point on the video timeline.

• Remove shot change at current time code. Select to manually remove an auto-
matically or manually generated shot change marker at the currently selected point 
on the video timeline. This option is only enabled when the currently selected time 
code is associated with a shot change marker.

You can assign keyboard shortcuts to these functions in Tools > Customize Keystrokes. 
If you assign shortcuts to these functions then the shortcuts are also automatically 
assigned as Audio Waveform Window shortcut keys.

For additional information on shot changes see Tools > Find Shot Changes.

Properties
Opens the VTR Properties dialog. You can select the device type and configure COM 
port options. You can also set the delay speed at which the controls function.
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Vpedal
Opens the Vpedal Properties dialog. You can set the V-pedal foot controller release back 
function. Release back time is the amount of automatic rewind that occurs when you 
resume playing after a pause. The default rewind is 2 seconds and then playing 
resumes. See V-Pedal for more information.

Web Menu

Retrieve Captions
Opens the Import File dialog. Allows you to choose the file type and browse to open it. 
Check the Options submenu to import the captions into the existing document at the 
current selected row, or uncheck to create a new document upon import. See Import 
Caption or Subtitle Files for more information on importing.

Encode Captions
Opens the Export File dialog. Allows you to select the file type, the output file name and 
location. See the Exporting / Encoding chapter for more information on encoding.

Live Text Stream
Enables output of a live caption text stream to the URL specified in the Live Text Stream 
Options dialog.

Live Text Stream Options
Opens the Live Text Stream Options dialog, where you can enter the URL and other 
parameters of your live text streaming provider, a meeting number, and a password. 
The Live Text Stream feature (see above) must be disabled to edit the dialog fields.

UVault Connection
Enables output of a live caption text stream to the UVault URL you specify. Use the 
option below it to specify the URL and other parameters. See Uvault Live Captioning for 
more information.
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UVault Connection Options
Opens the UVault Communication Configuration dialog, where you can enter the URL 
and other parameters of the UVault live connection. The UVault Connection feature 
(see above) must be disabled to edit the dialog fields.

YouTube Live Connection
Enables output of a live caption text stream to the YouTube URL you specify. Use the 
option below it to specify the URL and other parameters. See YouTube Live Captioning 
for more information.

YouTube Live Connection Options
Opens the YouTube Live Communication Configuration dialog, where you can enter the 
URL and other parameters of the YouTube live connection. The YouTube Live 
Connection feature (see above) must be disabled to edit the dialog fields.
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Transcription Menu

Transcription Edit Mode
Switches CaptionMaker into or out of Transcription Edit Mode. This activates the 
associated interface operation and actions to enable easy editing, such as video 
looping, menu items, and shortcut keys. See Transcription Edit Mode for more details.

Transcription Edit Mode Settings
Opens the Transcription Edit Mode Settings dialog.

• Video Looping Start Time Offset. Adds playback time, in milliseconds, before the 
start of the current cell so words in the previous cell are included.

• Video Looping End Time Offset. Adds playback time, in milliseconds, to the end 
of the current cell so words in the next cell are included.

• Auto Play/Pause Video. When enabled, starts looping video playback when you 
select a cell.

Telestream Cloud Account
Opens the Telestream Cloud Login dialog for login to your Telestream Cloud account.

• User Name. Enter the user name for the transcription account. The user name is 
saved for future transcribing operations.

• Password. Enter the password for the transcription account. The password is saved 
for additional transcribing operations during the current session. For enhanced 
security, the password must be re-entered after you close and re-open Caption-
Maker.

• Don’t have an account? Click the link to go to the Telestream Cloud web site so 
you can create an account.

• Forgot username / password? Click the link to go to a web page where you can 
enter your email address and initiate a process to reset your password.

Auto-Transcribe Movie
Opens the Timed Text Speech Job Settings dialog so you can choose the movie to 
transcribe, select the Telestream Cloud project to use, and set other parameters to 
apply during the transcribing operation. Clicking the Auto-Transcribe button also opens 
this dialog. You must be logged into your Telestream Cloud account for this feature to 
be active. See Job Settings for Timed Text Speech for details on the options.

Next Cell
(Down Arrow) Moves the cursor to the start of the next text cell.
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Previous Cell
(Up Arrow) Moves the cursor to the start of the previous text cell.

Next Word
(Right Arrow) Advances the cursor to the start of the next word. If the cursor is already 
on the last word of a cell, this advances the cursor to the start of the next cell (and 
triggers the video to loop around that next row's in and out times).

Previous Word
(Left Arrow) Moves the cursor back to the start of the current word, if the cursor is in the 
middle/end of the current word. Or to the start of the previous word, if the cursor is at 
the start of a word. If the cursor is already on the first word of a cell, this moves the 
cursor to the start of the last word of the previous cell (and triggers the video to loop 
around that row's in and out times).

Select Next Word
(Shift+Right Arrow) If nothing is currently selected/highlighted, this selects/highlights 
the word that the cursor is currently on. If something is already selected/highlighted, 
this expands the selection to include the next word past the end of the current 
selection. This is limited to the contents of the current cell — a selection cannot span 
across multiple cells.

Select Previous Word
(Shift+Left Arrow) If nothing is currently highlighted, this selects/highlights the word 
prior to the word the cursor is currently on. If something is currently highlighted, this 
expands the selection to include the previous word prior to the start of the selection. 
This is limited to the contents of the current cell — a selection cannot span across 
multiple cells.

Toggle Capitalization
(Shift+Up Arrow) Toggles capitalization to upper or lower case for the first letter of the 
word currently under the cursor.

Push Word
(Ctrl+Down Arrow) Moves the last word of the current cell to be the first word of the 
next cell. The timecode of the current and next cell is adjusted.

Pull Word
(Ctrl+Up Arrow) Moves the first word of the next cell to be the last word of the current 
cell. The timecode of the current and next cell is adjusted.
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Next Character
(Ctrl+Right Arrow) Moves the cursor right one character.

Previous Character
(Ctrl+Left Arrow) Moves the cursor left one character.

Split Cell at Cursor
(Ctrl+Enter) Splits the cell into two cells at the cursor location.

Music Note
(Ctrl+M) Inserts a music note at the cursor location.

DV Menu 

Retrieve Captions
Opens the Import File dialog. Allows you to choose the file type and browse to open it. 
Check the Options submenu to import the captions into the existing document at the 
current selected row, or uncheck to create a new document upon import. See Import 
Caption or Subtitle Files for more information on importing.

Encode Captions/Subtitles
Opens the Export File dialog. Allows you to select the file type, the output file name and 
location. See the Exporting / Encoding chapter for more information on encoding.

Print DV Video to Tape
Opens the Print DV Video to Tape dialog. Transfers a captioned DV video via Firewire to a 
MiniDV, DVCAM, or DVCPRO tape. You can also dump a captioned DV video to an 
analog tape such as VHS or BetaSP using a digital to analog converter such as Sony 
DVMC-DA1 and DA2, or a captioned compatible DV deck which retains captions.

Capture DV Video
Opens the Capture DV Video dialog. Captures a DV video (720x480) via Firewire (IEEE 
1394) and creates a DV AVI file. Video may be captured from devices such as the Sony 
DVMC-DA1/DA2, a camcorder, or a DV deck.
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You can export a blank video (720x486) file with encoded closed captions or subtitles 
to be merged with the original video using an NLE system.

Tools Menu

Spelling
Opens the Select Rows to Spell Check dialog.

To check spelling:

1. If you want to spell check a certain row or range, or start from a certain row, select 
the row or range of rows. When you want to check the entire file, you don’t need to 
select any particular row.

2. Select Tools > Spelling. The Select Rows to Spell Check dialog opens.

3. Select the Range Mode option you want to use.

4. Select the language you want to use. The available languages are: American 
English, Spanish, French, German, Portuguese, British English, and Canadian 
English.

5. Click OK to initiate the spell check operation.
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When spell check finds words it does not recognize, CaptionMaker displays the Check 
Spelling dialog.

 

The Check Spelling dialog shows the word that it doesn’t recognize in the Not in 
dictionary field. The Change to field shows the dictionary’s suggestion for correcting the 
error. Click Change to accept the suggestion and correct the word, or select another 
choice from the Suggestion list and click Change.

You can also click Ignore to skip the word, or click Ignore All if you want to skip all 
instances of the word when multiple instances are present.

If the word is valid but not in the dictionary, click Add to enter it in the dictionary, or 
click Edit Dictionary to modify the dictionary file by selecting from various options for 
handling the word. When finished with a word, click Resume to continue spell checking.

Note: When you upgrade to CaptionMaker 8.0.3 or greater from an older version, a 
dialog opens to repair the existing dictionary files. Click Repair File and then OK when 
the Repair Successful message appears. This will happen once per dictionary file and 
then never again.

Find Shot Changes 
CaptionMaker has two different methods to detect scene changes within media files.

• Old Detection Method. Scene change detection implementation used in Caption-
Maker 8.2.0 and prior releases.

• New Detection Method. Scene change detection based on Telestream Dib tech-
nology which gives users more control over the threshold at which a scene change 
is detected.

– Detection Threshold. Values range from 1 to 250, where lower values will detect 
more scene changes, and higher values will detect fewer scene changes.

Initiates the Find Shot Changes operation. The status bar in the bottom of the window 
indicates progress. You can find the shot changes in any video (MP4, WMV, AVI, MOV, 
MPEG, M2V, and so on). It is a good idea not to have a shot change inside the duration 
of any caption in Pop-on mode, so this Find Shot Changes operation helps to locate the 
changes.
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When you save the CaptionMaker project, the shot change information is saved in the 
CAP file. When you reopen the CAP file, you do not need to find shot changes again.

After finding the shot changes, when you play the video, the Next Shot Change 
indicator appears right below the Time code display in HH:MM:SS:FF format. The Next 
Shot Change display color becomes RED when it is less than 10 seconds from the next 
shot change.

You can also click the two buttons next to the time code display area to move to the 
previous and next shot change locations. See Time Code Controls for button and 
display locations.

After performing the Find Shot Changes operation, the Start time code of the identified 
shot change caption/subtitle row will change color, based on the color set in the Error 
Coloring Settings dialog, if this option is active. See Error Color Settings for information 
on activating/deactivating the shot change indicator, or changing the displayed color.

To insert or remove a Shot Change Marker, see Shot Change Marker Insert/Remove.

Snap Time Codes to Shot Changes
After the Find Shot Changes operation has taken place, you can initiate the Snap Time 
Codes to Shot Changes function. This automatically adjusts time codes so that 
captions/subtitles do not display during detected shot changes.

Export Shot Changes to Text File
After the Find Shot Changes operation, select this option to export a text file which will 
list the time code of each shot change that was found.
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Customize Keystrokes 
Opens the Customize Keystrokes dialog. Most menu items and commands can also be 
accessed via keyboard.

 

You can customize the keyboard shortcuts to your preference. Double-click the 
function you want to change, or click it once and click Set. In the New Keystroke dialog, 
simply type the keys you want to replace the existing assigned keys, and click OK.

Note: Some function keys reserved by Windows (such as F10 to open the top menu) 
should not be assigned for caption key shortcuts as they may trigger the default 
Windows behavior instead of the intended CaptionMaker behavior.

Common typing characters, such as single letters, are reserved for text typing. 
Keystroke combinations will need to include the Alt, Control, Shift plus function keys, or 
extended keypad characters.

To clear any assigned keys without assigning new ones, select a function and click Clear.

Note: To assign a key on the number keypad, you must have NumLock on.
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Copy Custom Keystrokes to Another Computer

If you are running CaptionMaker on more than one computer you can copy the 
Customize Keystrokes settings from one computer to another. Do this by using the Save 
File button in the Customize Keystrokes dialog to save the custom keystrokes to a file in 
any location you prefer. Name the file CapKeyMap.dat. Copy the file to the other 
computer and use the Load File button in the Customize Keystrokes dialog to import the 
saved file.

Select Playback Audio Tracks
This dialog allows you to specify the audio track(s) that you want to hear when viewing 
media in the Preview window. Selected tracks will also display in the Audio Waveform 
window.

Note: The ability to Select Playback Audio Tracks is currently only supported when 
using QuickTime for Media playback.

Comm Monitor
Select Comm Monitor to open the Communications Error Messages dialog and start the 
error message function. Hardware encoders and decoders are connected to 
CaptionMaker via serial COM ports. This monitor can tell if there are any 
communication errors during the connection to the hardware encoders.

Comm Monitor Log File
Select this option to choose a location and file name for the Communication Monitor 
log file. Any errors detected with a connection to the hardware encoders via a serial 
COM port is saved to a TXT file when this option is enabled.

Help Menu

Grid Tooltips
Turns the tooltips off and on for the Text Panel.

Quick Start Guide (Local)
Opens the Quick Start Guide that is installed with CaptionMaker. Adobe PDF reader is 
required to view the document.

User Guide (Local)
Opens the CaptionMaker User Guide. Adobe PDF reader is required to view the 
document.
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Command Line Documentation (Local)
Opens the CaptionMaker CommandLine Options guide, installed with the product, that 
describes controlling the software via the command line. Adobe PDF reader is required 
to view the document.

Online Technical Support
Takes you to the Telestream web site Closed Captioning Support page, where you can 
find a range of support information or enter a technical support ticket.

Purchase/Upgrade
Takes you to the Telestream Online Store for the captioning products, where you can 
choose a version for purchase or to upgrade.

About CaptionMaker
Displays the version number, copyright notice, and contact information for Telestream. 

Downloads
Opens the Downloads dialog. You can select if you want automatic update checks, and 
can check for updates and download the latest version.

Manage CaptionMaker License
Opens the Manage CaptionMaker License dialog. Provides options to upgrade or 
deactivate the license and a field for reading or entering your license number.

Upgrade HASP4 License
Opens a dialog so you can upgrade a HASP4 License.

Upgrade HASP SRM License
Opens a dialog so you can upgrade a HASP SRM License.

Open the HSRP SRM Admin Control Center
Opens http://localhost:1947 in your browser. You should see the Sentinel Admin 
Control Center page appear. If you do not see this page, then either the HASP driver is 
not installed, or the driver is experiencing a problem. This could be caused by a firewall 
or anti-virus software which is blocking the HASP driver or blocking TCP/UDP port 
1947. Please make sure TCP and UDP port 1947 are not blocked for internal 
communication (Internet access is not required, just local network). If you can't access 
this page in your browser, the problem MUST be resolved before the dongle can be 
used. For more information see HASP Network Dongle.
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Toolbars

This chapter describes the Master Template toolbars.

Topics
■Accessing and Customizing the Toolbars 246

■Main Toolbar 247

■VTR Toolbar 248
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Accessing and Customizing the Toolbars
Toolbars in CaptionMaker provide a quick and convenient way to change settings and 
access options.

Show or Hide Toolbars
To show or hide the toolbars, go to View > Toolbars and Docking Windows and select a 
toolbar to toggle on or off.

Add or Remove Buttons
To change the buttons that are shown on a toolbar, click the down-arrow on the right 
side of a toolbar to open the Add or Remove Buttons menu. Button selections may then 
be toggled on or off based on which buttons you want to show or hide.
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Move a Toolbar
To move a toolbar to a new location, hover your mouse cursor over the left end of a 
toolbar and the cursor changes to double crossed arrows. Click to grab the toolbar and 
move it.

Detailed Button Descriptions
Additional information for many toolbar buttons appears in the Status Bar in the 
bottom left of the CaptionMaker workspace. Hover your mouse cursor over a button to 
see the information.

Main Toolbar
The Main toolbar provides buttons for common operations.

Ancillary Toolbar
The Ancillary toolbar provides buttons for some formatting video operations.

New Document

Open a Document

Save

Print

Spell Check

Full Screen Spreadsheet 

Undo

Redo

Cut

Copy

Paste

AutoSync

AutoPreviewSync

Left Position & Justify

Center Position & Justify

Right Position & Justify

Move to Top

Move to Bottom

Bold

Italic

Underline

Text Color

Check for Errors

Customize Keystrokes

Auto Time Stamp

About CaptionMaker

Opens Help
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VTR Toolbar
The VTR toolbar controls the video in the Video Preview Panel or an external VTR 
hardware device.

Mark Timecode when Sending Lines

Set Font in Subtitle Mode

Image Colors

Set Margins

Pop-Up Preview Window

Open Video Properties

Insert Row(s)

Delete Row(s)

Merge Rows

Split Row

Clear Captions

Live Caption Mode

Roll Up 1 Blank Line

Left Indent

Move to Top

Move to Bottom

Move Up 1 Line

Move Down 1 Line

Move Left 1 Character

Move Right 1 Character

Play

Pause

Stop

Rewind

Fast Forward

Seek Time Code

Shuttle Reverse

Shuttle Forward

Current Shuttle Speed

Decrement Shuttle Speed

Increment Shuttle Speed

Advance Frame Reverse

Advance Frame Forward

Set Advance Frame Step Size

Eject VTR Tape
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