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Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.
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OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.

Other brands, product names, and company names are trademarks of their respective 
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4

MacCaption User Guide

MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT 
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR 
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE 
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM 
MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 80237 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE 
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING 
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL 
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE 
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD 
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER 
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER 
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR 
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. 
SEE HTTP://WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE 
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT 
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR 
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA 
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON 
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT 
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.
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Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), will be free from defects in materials and workmanship under normal 
operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality. 

Software Updates
Except as may be provided in a separate agreement between Telestream and You, if 
any, Telestream is under no obligation to maintain or support the Software and 
Telestream has no obligation to furnish you with any further assistance, technical 
support, documentation, software, update, upgrades, or information of any nature or 
kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.
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Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product. 

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA

You can call Telestream, LLC via telephone at (530) 470-1300.
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Support

To obtain product information, watch tutorial videos, get technical support, or provide 
comments on this guide, contact us using our web site, email, or phone number as 
listed below.

Resource Contact Information

Video Tutorials www.telestream.net/telestream-support/captioning/
tutorials.htm

Technical Support, 
Information, FAQs, 
Upgrades

Web Site: www.telestream.net/telestream-support/
captioning/support.htm

Support Web Mail: www.telestream.net/telestream-
support/captioning/contact-support.htm

Telestream Web Site: www.telestream.net

Sales and Marketing Email: info@telestream.net

Telestream
848 Gold Flat Road
Nevada City, CA. USA 95959
530-470-1300

International 
Distributor Support

Web Site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net

If you have comments or suggestions about improving 
this document, or other Telestream documents—or if 
you've discovered an error or omission, please email us.

http://www.telestream.net/telestream-support/captioning/support.htm
http://www.telestream.net/telestream-support/captioning/support.htm
http://www.telestream.net/telestream-support/captioning/tutorials.htm
http://www.telestream.net/telestream-support/captioning/contact-support.htm
http://www.telestream.net/telestream-support/captioning/contact-support.htm
http://www.telestream.net
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
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Overview

Introduction
CaptionMaker allows you to easily author, edit, encode and repurpose video captions 
for television, web, and mobile delivery. Utilizing exclusive e-Captioning™ technology, 
CaptionMaker simplifies the process of complying with FCC regulatory requirements, 
enabling greater access to broadcast content for television, online, and mobile viewers.

In this chapter:

■ Captioning Process at a Glance

■ Installation

■ Video Tutorials

■ QuickTime Removal Issues

■ Vantage and Switch Support Captioning

■ Moving Files Between CaptionMaker and MacCaption

■ Comparing CaptionMaker & MacCaption Versions

■ Identifying Pro and Enterprise Features in This Document

■ Prerequisites for Captioning

■ Automatic Time Stamp (ATS)

■ Caption Style Guidelines

■ Captions vs. Subtitles

■ Switching Between Caption and Subtitle Modes

■ Device Selection and Configuration

■ What is 608 and 708 Closed Captioning?

■ Teletext in OP-47 and OP-42

■ Live Captioning

■ CaptionMaker Workspace
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Captioning Process at a Glance
Captioning is basically a three-step process.

1. Transcribing—Create a text file of the video dialogue. 

2. Caption File Creation—Implement the timing, placement, and appearance of the 
captions. 

3. Encoding—Encode the caption data into the video, or export the captions as a 
separate file. 

Installation
When you purchase CaptionMaker you will receive a software license key. You can 
easily download and install the software by clicking on the downloads page at 
telestream.net and following the instructions.

Note: As of version 6.3 of CaptionMaker and MacCaption, only Desktop, Pro, and 
Enterprise licenses issued by Telestream are supported. If you purchased 
CaptionMaker or MacCaption prior to October 2013, you need to upgrade to a 
Telestream Desktop, Pro, or Enterprise license before upgrading to the current 
software version. Please contact Telestream for more information.

For detailed CaptionMaker installation, upgrading, and setup instructions, see the 
chapter, Installing CaptionMaker, near the end of this guide. 

Video Tutorials
Video tutorials for CaptionMaker on the Telestream website provide a great way to get 
started, learn more about features, and get valuable tips and techniques. 

Find the tutorials at:
http://www.telestream.net/captioning/resources.htm 

http://www.telestream.net/captioning/resources.htm
http://www.telestream.net


Overview
QuickTime Removal Issues

21

CaptionMaker User Guide

QuickTime Removal Issues
On April 14, 2016 the US Department of Homeland Security stated that Apple will no 
longer be providing security updates of QuickTime for Windows, “leaving this software 
vulnerable to exploitation". They recommend uninstalling Quicktime for Windows. 
Some functionality in CaptionMaker is reliant on certain elements of the QuickTime for 
Windows software, so a complete uninstall will compromise some features. 

The security flaws are only in the actual player component. We therefore recommend 
only removing the QuickTime player component. This should circumvent the security 
flaws while leaving CaptionMaker fully functional.

Instructions to Remove Only the QuickTime Player
To remove only the QuickTime player component:

1. Go to C:\Program Files (x86)\QuickTime.

2. Delete the file “QuickTimePlayer.exe”.

3. Select Yes at the confirm delete dialog box.

Please contact Telestream technical support if you require assistance.

If You need to Remove All QuickTime Components
If your IT policies require you to completely uninstall QuickTime for Windows from 
machines running CaptionMaker, then the following functionality will no longer be 
available: 

• Playback of movies using the "Use QuickTime" option. (DirectShow and Microsoft 
MMF alternatives are available, but playback compatibility or performance may be 
reduced. For MP4 playback please use the Microsoft MMF option.)

• Export: (Encode CC) Black QuickTime 720x486 for NLE (line 21 movie).

• Export: (Burn Subtitles) into QuickTime mov/mp4.

• Export: (Encode Subtitles) Black QuickTime 720x486 for NLE (subtitle overlay 
movie).

• Export: (Encode Subtitles) HD Black QuickTime for NLE (subtitle overlay movie).

• Tools > Find Shot Changes (when the movie is a QuickTime mov/mp4).

CaptionMaker Features that Will Continue to Work
The following CaptionMaker features, despite having QuickTime in the name, don't use 
the Apple QuickTime APIs and will continue to work even if QuickTime is uninstalled:

• Export: (Encode CC) QuickTime Podcast/Web Closed Captions (QT 608 CC track).

• Export: (Encode CC) DV QuickTime 720x480.

• Export: Webcast - Quick Time Script (*.txt).
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Vantage and Switch Support Captioning
The Telestream software tools, Vantage and Switch, are great companions to 
CaptionMaker to provide the complete workflow of tools to create, edit, encode, and 
verify caption data in professional file formats for TV and the Internet. 

Telestream Vantage version 7.0 and newer, with the Timed Text Flip service, provides 
many caption encoding and transcoding features, including:

• MCC caption file support, including CEA-608 and CEA-708 caption data insertion.

• MXF caption data insertion for SMPTE 436M.

• MPEG-2 user data 608/708 insertion (A/53).

• Direct-convert caption data pass-through, such as MPEG-2 to MXF captions.

• Burn-in subtitle overlays.

• DVB Subtitling.

For a complete list of caption and subtitling features of Vantage Timed Text Flip, please 
visit   http://www.telestream.net/vantage/TimedText.htm

Note: CaptionMaker does not convert, or transcode, one type of input media file to a 
different type of output media file. However, it can convert caption/subtitle files to 
many different types. Vantage has great options to convert one media file type to one 
or more other media file types. 

Switch can decode and play many caption and subtitle files, with features such as:

• Playing captions embedded in video and side-car caption files.

• Decoding embedded CEA-608 and CEA-708 caption data.

• Playing Internet caption files, such as WebVTT, iTT, TTML, and so on.

• MXF ancillary caption track decoding and playback.

• MPEG-2 user data caption decoding and playback. 

• Decoding and playback of various caption and subtitle files, such as SCC, MOV, DV, 
DVB, LXF, GXF, SMPTE-TT, SRT, EBU-STL and so on. 

• Viewing Vertical Ancillary (VANC) caption data on an external monitor. 

Note: Common video players such as VLC, Windows Media Player, QuickTime Player, 
Sony XDCAM Viewer, and so on, do NOT display most types of closed captions. So 
even if your video will play in one of these players, it may not show the captions. 

For more information and additional features of Vantage Timed Text Flip and Switch, go 
to telestream.net. 

http://www.telestream.net
http://www.telestream.net/vantage/TimedText.htm
http://www.telestream.net/vantage/TimedText.htm
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Moving Files Between CaptionMaker and 
MacCaption

CaptionMaker can import MacCaption (.mcc) project files, but MacCaption cannot 
import CaptionMaker (.cap) project files. To move from one platform to another you'll 
need to export and then import in a format that is used by both. 

Moving Caption Files
For captioning projects, the MCC (.mcc) file format is a good option for moving caption 
files between CaptionMaker and MacCaption. 

The SCC (.scc) file format is another option, but these are limited to using only a 29.97 
frame rate. 

Moving Subtitle Files
For subtitle projects, the IMSC TTML file type works well to move subtitle files between 
CaptionMaker and MacCaption.  

The WebVTT or Cheetah ASC (.asc) formats are also good options for moving subtitle 
files between MacCaption and CaptionMaker. These allow for more than 32 characters 
per line.
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Comparing CaptionMaker & MacCaption Versions
The CaptionMaker and MacCaption applications are available in 3 levels: Desktop, Pro, 
or Enterprise.

Please refer to the following chart for the features of each level. You can purchase a 
software upgrade from one level to another to add capabilities. 

Target uses Caption and subtitling 
authoring and editing

Authoring, editing, QC, 
asset management, 
TV broadcast exports

Target customers Corporate, independent, 
academic, government, 

houses of worship

Caption service providers,
TV networks, Post facilities

Authoring/Exports

Caption Authoring, Timing and Formatting

Timed Text Speech
Cloud Based Auto-Transcription

Auto Time Stamp (sync text and audio)

√

√

√

√

√

√

√

√

√

√

√

√

√

Auto-transcription with Telestream Cloud 
Account Subscription in over 100 languages.

√ √ √

√ √ √

√

√

√

√

√ √ √

√ √ √

√

√

√ √

√

√

√ √

Caption Asset Management (Imports/Conversions)

Automation

Assemble Captions2 (conform to EDL)
Batch processing (GUI)1

1Currently available for CaptionMaker only
2Currently available for MacCaption only

√ √

Desktop Pro Enterprise

Export SCC (CEA-608) & MCC (CEA-708) 
files 

Streaming/Mobile Video (SMPTE 2052 timed 
text--TTML and DFXP, Vimeo, Safari, 
Android, IMSC 1.0, IMSC 1.11, WebVTT, 
SRT, iOS, YouTube, WMV, SAMI, etc.)

Burn-in Subtitles and Basic DVD Subtitles

iTunes iTT subtitle creation, edit, and export2

Drop shadow option for subtitling workflows2 

Japanese Ruby Annotation formatting 
support2  
Subtitle overlay (movie w/alpha channel
subtitle graphics)
      
Advanced DVD/Blu-ray subtitles

TV broadcast and VOD media
(ProRes, MPEG-2, H.264, MXF, Avid AAF1, 
tape, etc.)

OP-47/OP-42 Teletext for MXF Workflows1

Export caption interchange files (CAP1, TDS1,
ULT, EBU-STL, etc.)

V-chip/XDS/AFD Encoding

Live captioning1 (via hardware encoder or
web stream e.g. YouTube)

Reformat Pop-on <-> Roll-up

Import Nexidia QC .XML Report1

Extract CC from video files (MOV, MXF, 
MPEG-2, etc.)

Import interchange files (Cheetah CAP, TDS1,
ULT, PAC, EBU-STL, etc.)

Import plain text, SCC & MCC, web formats

Scripting & External Control (CLI)

√

√

√

√

√

√

√

√

√

√

√

√

√

√

√

√ √

√

√

√ √

Automation & high 
volume caption and 

subtitle asset delivery

Major networks, content 
providers, asset management 

& distribution services



Overview
Identifying Pro and Enterprise Features in This Document

25

CaptionMaker User Guide

Identifying Pro and Enterprise Features in This 
Document

Some features described in this document are only available in the Pro or Enterprise 
versions of CaptionMaker. Features that are included in the Pro version are identified by 
the following PRO icon: 

The Enterprise version includes all available features. Features that are included only in 
the Enterprise version, and not in Desktop or Pro, are identified by the following ENT 
icon: 

Note: Features that have no icon are included in the Desktop version, and in the Pro 
and Enterprise versions. 
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Prerequisites for Captioning
The two ingredients you need to start captioning a video are: (1) a video file, and (2) a 
transcript of the dialogue in the video.

Transcribing a Video
The transcription features in CaptionMaker can create a text transcript of a video and 
populate it directly into the captioning project with the correct timing. The 
Transcription Edit Mode can be used to facilitate easy editing of that timed text, or of 
any text that you have loaded into the project. 

For details, see the Timed Text Speech chapter. 

Importing a Text File
CaptionMaker can import scripts from a text file and most word processors, such as 
Word Rich Text Files (.rtf ). Rich Text Files provide the option of importing colors and 
italics. However, because of special formatting and characters used in some kinds of 
document files, it is often best to start with a plain text (.txt) file. 

Using a Video File
The other ingredient you need for producing captions is a video file. Make sure you are 
using a digital video file, not videotape, as your video source. CaptionMaker can play 
back most types of QuickTime files, and also Windows Media files (Windows only). See 
Opening a Movie for a list of all file types that play in CaptionMaker. 

If you have a file format that won’t play, please see Using a Proxy Movie to learn about 
making a proxy movie for use with CaptionMaker.
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Automatic Time Stamp (ATS)
In most other captioning software, even after you import the transcript and video, you 
must go through a time consuming process to manually synchronize each piece of text 
so that it appears at the correct time in the video.

In CaptionMaker, Auto Time Stamp (ATS) automatically synchronizes the text transcript 
with your audio or video file, dramatically reducing the time it takes to caption a video. 
See Using Automatic Time Stamp (ATS) for instructions on ATS operation. 

Caption Style Guidelines
Adhering to good caption style is very important. The following is an excerpt from the 
Described and Captioned Media Program (DCMP), web site -  http://www.dcmp.org/:

Captioning is the key to opening up a world of information for persons with hear-
ing loss or literacy needs. There are more than 30 million Americans with some type 
of hearing loss. Millions of others are illiterate, learning to read, or use English as a 
second language.

The first captioning of any kind was performed in the late 1950's by Captioned 
Films for the Deaf, the ancestor of DCMP, two decades before the advent of closed 
captioning on broadcast television. The first edition of the Captioning Key was pub-
lished in 1994, and these guidelines were based on decades of experience by DCMP 
(then called Captioned Films and Videos Program), review of captioning research, 
and examination of standards developed by various captioning vendors. The Cap-
tioning Key has been applied to both entertainment and educational media, has 
been used for consumers at all levels (children through adults), has received inter-
national distribution, and has been translated into other languages.

These guidelines are a key for vendors performing captioning for the DCMP. The vendor 
list can be found at this URL: https://dcmp.org/vendor-info. The DCMP provides 
information on how to become an approved vendor on the DCMP Web site. 

The information is applicable to vendors and other businesses that provide closed 
captioning (CC) and subtitles for the deaf and hard of hearing (SDH) of all types of 
media at various levels. Thus, these guidelines are also useful to media producers/
distributors and others considering captioning their products or learning about 
captioning. 

http://www.dcmp.org
https://dcmp.org/vendor-info
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Captions vs. Subtitles
Captions are text that appear on a video and contain the dialogue and cues to indicate 
sounds are occurring, such as music or sound effects. Subtitles are text that appear on a 
video or in a movie and typically contain only a translation of the dialogue. 

Captions
The purpose of captioning is to make a video accessible to those who cannot access the 
audio content, such as for people who are deaf or hard of hearing, and for other 
situations in which the audio cannot be heard due to environmental noise or a need for 
silence.

Captions can be either open captions (always turned on, aka "burned in") or closed 
captions (can be turned on/off by the viewer). For TV broadcast, closed captions are 
much more common because they allow each viewer to decide whether they want the 
captions to be turned on or off. Closed captions are transmitted as a special coded 
signal sent along with the video picture, and require a decoder in your television or set 
top box to display the text on the screen. This special coded signal is what broadcasters 
check for to ensure that your video is in accordance with the law.

Caption Font and Style are Determined by the Decoder
For technical reasons, closed captions have many more rules and constraints that affect 
the timing and the appearance of the text. This means that in practical use, the caption 
author has limited or no ability to specify the font, size, text styling, and so on. These 
settings are determined by the decoder which renders the text to the screen when the 
captions are turned on.

Subtitles
Subtitles are text that appears on a video or in a movie and typically contains only a 
translation of the dialogue, typically because the dialogue is in a foreign language, or 
because the dialogue was difficult to hear clearly. Unlike captions, subtitles usually do 
not convey non-dialogue sounds such as background noise, sound effects, or music 
cues, because it is presumed that the viewer is able to hear them. Subtitles have fewer 
rules and limitations than closed captions, and generally have more fonts, styles, and 
colors available to choose from. 

For more information on using subtitles, see the Subtitle Mode chapter. 
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Switching Between Caption and Subtitle Modes
To switch CaptionMaker between caption and subtitle modes, simply click the button 
on the workspace.

When switching modes, the caption or subtitle device used is typically the last one you 
selected. If the Video Mode is changing between HD or SD when switching from 
caption to subtitle mode, CaptionMaker uses the Generic Subtitles device. 

Note: The Caption/Subtitle switch is disabled when CaptionMaker is in Live Caption 
mode, and when running AutoSync or AutoPreviewSync.

Device Selection and Configuration
CaptionMaker uses the concept of device selection because it was originally designed 
to directly control caption hardware devices, such as the Evertz and EEG caption 
encoders, and subtitle hardware devices such as the Chyron Codi or MagniCoder 
subtitle encoders. 

The default caption device is Virtual Encoder, and the default subtitle device is Generic 
Subtitles. The default devices are good for a typical file-based workflow. If you are using 
a specific hardware device, or different file type, you can select an appropriate device. 

The name of the currently selected device is displayed in the Status Bar at the bottom 
right of the CaptionMaker workspace.

To select a new device or adjust device settings, go to the Caption > Device, or Subtitle 
> Device menu options. When you select a new caption or subtitle device in the Device 
dialog you are automatically switched into the caption or subtitle mode of the new 
device.

For more information on caption device selection and settings, see Device in the 
Caption section of the Menu chapter. For more information on subtitle device selection 
and settings, see Device in the Subtitle section of the Menu chapter.

Current Device
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The Video Preview Panel Changes to Show Device Format
The Video Preview Panel changes to show what the captions or subtitles will most likely 
look like in the final displayed destination, depending on the device selected. For 
example, when you select caption mode the preview window displays what your 
captions will typically look like when decoded by a TV. 

If you have selected a DVD authoring system subtitle device, such as "Spruce 
DVDMaestro", the Video Preview Panel shows what your subtitles will typically look like 
when displayed by a DVD player.

Certain Device Settings are Remembered per Device
CaptionMaker remembers certain settings separately for each device. When you 
change a setting that is remembered for a device, you are changing that setting only for 
the device that is currently selected.

For each Caption Device, CaptionMaker remembers the communications connection 
parameters such as the COM port number or the IP address.

For each Subtitle Device, CaptionMaker remembers the following settings (the setting 
locations are also included below):

• Background Translucency (Attribute menu > Background Translucency).

• Default caption/subtitle colors (Attribute menu > Background Translucency).

• Left, Right, Top, and Bottom Margin settings (Subtitle menu > Set Subtitle Margins).

• Enable/disable character borders, and the character border width (Subtitle menu > 
Set Subtitle Image Font).

These Device Settings are Not Remembered, and are Global
The following settings are not remembered differently for each device, but affect the 
global settings on the program level. They will apply to any device selected.

• The subtitle image font settings (font name, font size, kerning, spacing, padding, 
and so on) are not remembered for each Subtitle Device. These settings are global 
for all subtitle devices.

• The "Background Type" setting (Normal, Black Box, Fill Row, or Transparent) is not 
remembered for each device because there is a "Background Type" column in the 
text grid that allows you to assign a background type to each caption or subtitle.
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Virtual Encoder and Generic Subtitles Default Devices 
The default caption device Virtual Encoder and the default subtitle device Generic 
Subtitles work well for a typical file-based workflow (which means, when hardware 
devices are not used). Both of these devices are designed to emulate hardware 
encoders. The Virtual Encoder and Generic Subtitles devices work for SD, HD, and 
UHD resolutions. Generic Subtitles also provides more positioning options and user 
selectable fonts. 

When you need certain options you can also use devices for a file-based workflow that 
have hardware names, and you do not need to have the actual hardware device 
connected. Some of the available devices are only for SD resolution video, such as 
Generic DVD. HD resolution, including 720p and 1080i/p, require devices such as 
Blu-ray, or the default devices. 

The following features are available with the Virtual Encoder caption device:

• UHD (Ultra High Definition), HD (High Definition), and SD (Standard Definition).

• 2160i, 2160p, 1080i, 1080p, 720p, 480i (SD NTSC), 576i (SD PAL).

• CEA-608 and CEA-708 captioning protocols.

• Multiple frame rate support for 23.976 fps, 24 fps, 29.97 fps, 59.94 fps, 25 fps, 50 fps, 
including drop frame and non-drop frame. 

The following features are available with the Generic Subtitles device:

• UHD (Ultra High Definition), HD (High Definition), and SD (Standard Definition).

• 2160i, 2160p, 1080i, 1080p, and 720p, 480i (SD NTSC), 576i (SD PAL).

• Multiple frame rate support for 23.976 fps, 24 fps, 29.97 fps, 59.94 fps, 25 fps, 50 fps, 
including drop frame and non-drop frame.

• Provides the background opacity option. 

• Select from any font installed in your system. 

• Use multiple colors for font and background. 
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What is 608 and 708 Closed Captioning?
608

CEA-608 (formerly known as EIA-608) was the original closed captioning standard used 
for analog TV broadcasts since 1980. This is also called "line 21" captions because they 
are embedded in line 21 of analog TV signals. 
608 captions are typically limited to a single block character font with gray mono-
spaced text on a black square background. Only the standard alphanumeric and certain 
accented characters are supported. Due to bandwidth restrictions, it is uncommon to 
see more than two languages encoded simultaneously.
CEA-608 captions also support different background colors. See Attribute Menu for 
more detail on the settings and types of colors supported in CaptionMaker. See images 
below for examples of background color when viewed in a CEA-608 decoder.

                         

Up-Converted from 608 to 708
608 captions that are up-converted to 708 do not take advantage of any of the new 708 
caption features, such as multiple fonts and styles, multiple windows, Unicode 
character support, or proper support for more than four languages.

708
CEA-708 (formerly known as EIA-708) is the new closed captioning standard used for all 
DTV broadcasts, including HD and SD. 708 supports a number of features, including:

1. 708 captions can appear in multiple fonts, sizes, colors, and styles:
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2. 708 captions are drawn into "windows" which allows more creative and flexible 
positioning of the captions, including use of the full 16x9 width of HD video.

3. 708 captions can contain up to 63 different captions tracks (although typically up to 
6 are used simultaneously), without the bandwidth limitations of 608.

4. 708 captions also include a digital form of the 608 caption data for backwards 
compatibility with older analog gear.

708 captions are required for all captioned DTV broadcasts, which includes both HD 
and SD material. The DTV transition occurred on June 11, 2009. DTV broadcasts (with 
very few exemptions) must now include both 708 and 608 captions.

When submitting a captioned SD tape to a broadcaster, the 708 captions are 
automatically generated from the 608 data when the video is encoded for DTV. 
However, when sending a pre-encoded file for broadcast (such as a MPEG-2 transport 
stream), the file must contain both 708 and 608 data even if it is only SD, because it will 
be transmitted as-is (not re-encoded by the broadcaster). HD tapes must always 
contain both 708 and 608 captions as well.

Note: U.S. broadcast equipment does not support the full CEA-708 specification, 
therefore, CaptionMaker only encodes simple CEA-708 that does not include any of 
the advanced features. Unicode characters do not display properly.

Industry-Standard Caption Format Data
All existing industry-standard caption data formats, such as SCC files or CAP files, only 
store CEA-608 caption data. However, CaptionMaker can import any industry standard 
caption file format, and then up-convert the captions into CEA-708 caption data for 
embedding into a video file or exporting into new formats that support CEA-708.

MacCaption developers have created a new file specification called MCC (MacCaption 
Closed Caption file) which contains native CEA-708 encoded caption data. 
CaptionMaker also supports the MCC file format. The MCC format is an open 
specification and free for any hardware or software manufacturer to use. Please contact 
Telestream for more information.
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Teletext in OP-47 and OP-42
The following is an overview of Teletext OP-47 and OP-42.

Teletext OP-47
OP-47 (Operational Practice number 47) is a solution for inserting a Teletext ancillary 
data channel into HD media. OP-47 was originally developed by Australian 
broadcasters and is now widely used. The data can be stored in the SMPTE 436M track 
of an MXF wrapper.

OP-47 Teletext stores data in selectable pages within magazines (1-8). These can be 
selected by viewers using menu controls on their TV monitor. Typically, the subtitle 
data can be stored in magazine 8 page 01, or Teletext 801. Other samples may have 
Teletext 888, which is magazine 8 page 88. This is according to the SMPTE-RDD8 
specification.

CaptionMaker can read and write OP-47 with a user selectable parameter that specifies 
the magazine and page.   Teletext information can have up to 40 characters per line of 
text, including spaces. 

Teletext supports Latin, Hebrew, Arabic, Greek, and Cyrillic alphabet. However, it does 
not support Asian unicode characters such as Chinese and Japanese. CaptionMaker can 
only insert Latin alphabet Characters into OP-47.

CaptionMaker also supports background color attributes when reading and writing 
OP-47 Teletext. See Attribute Menu for more detail on the settings and types of colors 
supported in CaptionMaker.

See OP-47 and OP-42 Teletext Workflows for more information on working with OP-47 
Teletext data in CaptionMaker. 

Teletext OP-42
The OP-42 export creates a QuickTime animation black movie with alpha channel VBI 
file, which is used with Vantage or other transcode and editing systems to render the 
VBI into an MPEG IMX SD .MXF file. OP-42 is used by SD analog systems that have PAL 25 
FPS settings.

See Exporting the OP-42 Alpha Channel VBI File for more details. 
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Live Captioning
CaptionMaker can be used to accept live caption data input from a stenography 
machine, regular keyboard, or other method, then send the captions to an encoding 
device or direct to the Internet for services that accept live caption data. 

For both live broadcast captioning and Internet (web) text streaming, you need a way 
to input the text in real time. It is not possible to type text on the computer keyboard as 
fast as people speak. There are two common practices—steno typing and speech 
recognition software. 

A professional real-time captioner can type more than 200 words per minute with over 
99% accuracy using a steno machine. Due to their great skills, these professionals can 
be expensive for a long term project. Speech recognition software is an alternative 
solution—not as good as real-time captioning with a steno machine, but in some cases 
it is acceptable.

To increase accuracy, speech recognition software can be trained to recognize one 
person’s voice. This can be the presenter, or a shadow speaker. A shadow speaker is also 
necessary when there is more than one person speaking. See Transcribing a Video for 
more about speech recognition software, and Shadow Speaker in the Glossary. 

Live Captioning Operation
For examples of live caption configuration and operation, see Live Caption Data Input 
into CaptionMaker in the Example Workflows chapter. 

Send Live Captions to Lightspeed Live Stream
CaptionMaker can be used as the source of live caption input into a Telestream 
Lightspeed Live Stream server. For details on how to do this, see Sending Live Captions 
to a Telestream Lightspeed Live Stream Server. 

CC Encoder Hardware
For live broadcast TV encoding, you also need closed caption encoder hardware. They 
range in price from $1,200 to $10,000 depending on whether the video is analog, 
digital SD, or digital HD. 
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CaptionMaker Workspace
The CaptionMaker workspace contains the following main sections.

• Menus and Toolbars To control toolbar display, choose View > Toolbars and Dock-
ing Windows. See the Menus chapter for details on menus and Toolbars for details 
about the toolbars. 

• Video Playback and Caption Preview Panel Play the video and preview the cap-
tion/subtitle timing, location, and formatting. The Preview Panel shows how it will 
typically look in the final display destination. 

• Editing Operation Controls Buttons provide controls for most of the common 
editing operations. 

• Text Panel Provides timing and display parameters, text editing, and caption/subti-
tle selection. To select the columns you want to display, choose View > Visible Col-
umns. 

• Status Bar Provides information about some current settings and operations. 

• Programs CaptionMaker effectively runs six "copies" of itself simultaneously, 
enabling you to manage up to six caption languages (Programs) in one Caption-
Maker project file. Select which "copy" of CaptionMaker (Program) you want to 
manage by clicking the Program tabs at the top of the editing grid, or by selecting 
View Menu > Select Program. All functions (editing, importing, exporting, etc.) oper-
ate on the currently selected program.

Note: To display the video preview, de-select View > Semi-full Screen Spreadsheet. 



Overview
CaptionMaker Workspace

37

CaptionMaker User Guide

  

Preview Panel Subtitle Display Limitations
The CaptionMaker preview panel does not support transparency/translucency when a 
movie is open in the preview panel, so it does not display transparent/translucent 
background subtitles correctly.

For example, if you set the Background Translucency to transparent, the exported 
subtitles will correctly have transparent backgrounds, but the preview panel can only 
display the subtitles with opaque backgrounds (when a movie file is open in the 
preview panel).

Note: In CaptionMaker 8.2.1 and later, users may view transparent subtitle 
backgrounds in the preview player window by opening the movie file using Microsoft 
Media Foundation (MMF).

Main Toolbar Video Playback and Caption Preview Panel

Text Panel Status Bar

Program tabs

Ancillary Toolbar

Operation 
Controls
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Full Screen Text Panel
To have a large view of the text panel, select View > Full Screen Spreadsheet. Or, you 
can click the  Full Screen Spreadsheet button on the Main toolbar. 
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Semi-Full Screen Text Panel
To have a larger view of the text panel, while still keeping most controls available and 
hiding the video preview, select View > Semi-full Screen Spreadsheet. 
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Pop-Up Video Preview Window
To view the video preview panel in a separate window, select View > Pop-Up Preview 
Window. You can place this window wherever you like. 

 

Margin Indicator Frame
An optional white frame indicates where the margins are set for captions and subtitles. 
To turn the display of this frame on or off, or to adjust the margins, see Set Caption 
Margins and Set Subtitle Margins in the Menus chapter. The frame only displays when 
captions or subtitles are present. 
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Black Text on White Background
You can switch to the CaptionMaker classic look of black text on white background for 
the text panel. To change this, choose View > Black Text on White Background. 
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Preparing and Importing 
Files

The topics in this chapter provide information on transcription, describe how to import 
various types of files into MacCaption, and explain how to use a proxy movie.

■ Transcript Formatting

– Avoid Italics and Bold Text

– Indicate Change in Person Speaking

– Using Tab Delimited

– Plain Text is the Preferred File Format

■ Import Caption or Subtitle Files

– Types of Caption/Subtitle Files

– Considerations When Importing Subtitles for Editing or Converting

– Importing Captions or Subtitles

■ Using Copy and Paste for Text

■ Opening a Movie

– To Open or Replace a Movie

■ Importing Captions/Subtitles from a Video

■ Using a Proxy Movie

– Use Telestream Cloud or Vantage to Make a Proxy Movie

– Proxy Movie Settings

■ Set Resolution With No Loaded Movie or for Export
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Transcript Formatting 
For non-live, prerecorded material, a transcript must be created of the dialogue in the 
video before the closed captioning process can begin. While listening to a video, a 
typist can transcribe the video using any standard word processor, or an existing script 
can be used. 

The transcription features in MacCaption can create a text transcript of a video and 
populate it directly into the captioning project with the correct timing. The 
transcription editing mode can be used to facilitate easy editing of that timed text, or of 
any text that you have loaded into the project. 

For details, see the Timed Text Speech chapter.

Avoid Italics and Bold Text
When creating a transcript it is best to avoid using italics and bold. Italics in closed 
captioning generally mean that the speaker is off-screen. Do not use bold as it could 
result in text blinking on and off. TV sets and cable boxes do not have the ability to bold 
text, so we recommend avoiding bold.

Indicate Change in Person Speaking
When importing a transcript into captioning software, the captioner looks for a change 
in the person speaking to start a new caption block. A good captioning project should 
have an indicator for the viewer to show a change in speaker. The transcript can help 
this effort by placing a symbol before the speaker change. The characters “>>” typically 
shows this change.

Using Tab Delimited
If line breaks or timecode are critical for the captioning project, a simple tab character 
can be placed in the text. In the same way spreadsheet software can separate cells, 
captioning software can do so when it detects a tab character. For example, if a 
sentence is long, a tab character will create a line break in the text. 

Plain Text is the Preferred File Format
Although MacCaption can accept a variety of text files, the recommended file format 
for transcriptions is a plain text document (.txt). Many word processors include 
extraneous data in native file formats such as page numbers, margins, footnotes, 
column settings, and other non-text related code. Most word processors can save the 
document as a plain text file, for import into MacCaption.
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Import Caption or Subtitle Files 
After you have created the transcription of the dialogue, or if you already have a 
caption/subtitle file, you are ready to import it into MacCaption. 

Types of Caption/Subtitle Files
In addition to text documents, MacCaption can import a wide variety of file types, such 
as TV Caption files, Subtitle files, PAC files, and Web Caption files. For a complete list of 
file types see File Types for Import/Export. 

Considerations When Importing Subtitles for Editing or 
Converting

MacCaption can import many kinds of closed captioning and subtitle files, but when 
dealing with subtitle imports, there is one extra consideration. MacCaption can only 
import subtitle formats which are "text based”. This refers to how the subtitles are 
stored in the file. If they are stored in a textual format along with formatting 
information and time codes, they can be imported to edit or convert them. Some 
examples of text-based subtitle files are SubRip SRT,  WebVTT, iTunes iTT, PAC, DLP 
Cinema XML, and EBU-STL.

However, if the subtitles are "image based," also known as "bitmap subtitles," then 
MacCaption cannot import them. When the text is converted into an image, it is very 
difficult to turn that image back into an editable text format. Some examples of image-
based subtitle files are Blu-ray BDN, UYC/USF, and any other subtitle format that deals 
with image files like PNG, TIFF, BMP, and so on. 

There are also some subtitle file formats that support both text-based and image-based 
subtitles. For these formats, MacCaption can only import the subtitle file if it is the text-
based variant. Some examples of these formats are: DVD Studio Pro STL, Scenarist SST, 
and SMPTE Timed Text. 
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Importing Captions or Subtitles
You can import caption or subtitle files in two basic ways:

• Menu selection. From the File menu choose Import and select the type of file to 
import. 

• Drag and drop. You can drag and drop the caption/subtitle file directly into the 
MacCaption text panel. A white highlight border appears around the text panel 
when it is ready to accept the file.

During the import operation a dialog may appear for some file types, providing options 
for how to configure and place the captions. For text file options see Text Import 
Options. 

When captions are already present in MacCaption and you are importing a new text 
file, the following option will be presented in the File Open/File Save dialogs. 

Replace. The existing captions are deleted and content from the file is imported in its 
place.

Insert. The file content is inserted just above the current row that is selected.

Note: When importing a standalone file, such as SCC, the above dialog does not 
appear. Standalone file imports are appended onto the end of the currently existing 
text in the editing cells. 
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Text Import Options
When importing a Plain Text file the following Text Import Options dialog opens.

The Text Import Options dialog provides the following options:

Treat each line of text as one caption. Each line of text becomes one caption. The text 
can include an optional tab delimited in and out time code, which is used for timing.

Replace caption text by sequence number. Use this option when each line in the text 
document starts with a number, corresponding to each caption row. Start with number 
1, and continue consecutively for each row, for example, 1 through 35. The numbers in 
the text document will place the captions in the corresponding numbered row in the 
MacCaption workspace. 

The sequence number option is useful for translation into other languages. The line 
numbers will place the translation in the proper timing location if you replace the 
existing captions that have been timed to the video. 

Combine text lines to form captions. Select this option to active the following 
choices for combining text lines:

• Maximum number of text rows for each caption: [1-4]. (2 is the default value) 
Specify the maximum number of lines of text for each caption. The limit is 4 lines of 
text, according to the CEA-608 standard. 

• Begin caption with the following sequence of characters: [>>>]. Enter custom 
character(s) to start the next caption. When this character is encountered during 
import, MacCaption starts a new caption.

Note: Only one new row is started even if multiple consecutive instances of a 
character are in the text file. For example, if you enter the ">" character to start or end 
a row, MacCaption will start a new row when it sees ">", ">>", or ">>>" and so on. 
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• End caption with an end of sentence punctuation: (.?!). When selected, a cap-
tion ends and a new one is started when a period, question mark, or exclamation 
point is encountered during text import. 

• End caption with the following character: [__]. Enter custom character(s) to end 
a caption. When this character is encountered during import, MacCaption ends the 
current caption and starts a new one.

• End last row with a comma (,) or semi-colon (;) if applicable. When selected, a 
caption ends and a new one is started when a comma or semi-colon is encountered 
during text import.

• Square up text if more than one line of text in a row. When selected, words are 
distributed more evenly in multiple rows of text.

Default Display Mode: 
– Pop-On. Pop-on mode is recommended for most post-production captioning 

projects. 

– Paint-On. The characters are painted on the screen one after another, from left 
to right. 

– Roll-Up 2 Lines. Sets a maximum of 2 lines to appear on screen at a given time.

– Roll-Up 3 Lines. Sets a maximum of 3 lines to appear on screen at a given time.

– Roll-Up 4 Lines. Sets a maximum of 4 lines to appear on screen at a given time.

Note: Roll-up captions are typically used for live captioning, such as TV news. One 
line at a time rolls up from the bottom, up to the maximum number of lines that are 
set appear at a given time. 

See Display Modes for more information on display mode operation. 

Read text as:
– Western (Mac OS Roman) (Default)

– Unicode (UTF-8)
– Unicode (UTF-16)
– Unicode (UTF-16BE)
– Unicode (UTF-16LE)
– Automatic
– Windows 1252 (Latin 1)

Note: UTF encodings are used for any languages or characters that are not part of the 
ASCII character set, such as Asian, French, German, Russian, Spanish, and so on. 

Gather characters from XML tag “AAAA” [__]. Select this option and type in the XML 
tag you want to extract the text characters from. 
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Maximum number of characters for each line of text: [1-68]. (26 is the default value) 
The maximum number of characters for each line is from 26 to 32 characters when in 
captioning mode. 32 characters is the limit for CEA-608. 26 or 28 characters is the 
recommended setting. 

Note: Switch to subtitle mode, before importing, to use more than 32 characters per 
line.

Convert illegal caption characters such as open quote to straight quote. Select this 
option to attempt to convert any illegal Unicode characters in the caption text into 
their standard ASCII equivalents. Some special Unicode characters cannot be used in 
608 closed captions, such as the em-dash (long hyphen), ellipses (three dots as one 
character), curved quotes, and so on. For this option to be active, a Unicode option or 
Automatic must be selected in the “Read text as” menu.

Using Copy and Paste for Text
Copy and paste is an easy way to import transcript text directly into the text the panel 
of MacCaption. This way you can get text from various sources, such as e-mail, Word 
docs, PDFs, or websites. 

Place your cursor in a text row in the place you want to paste the text. MacCaption will 
automatically split up the text into the maximum number of rows per caption based on 
the setting in the Input Preferences dialog. To adjust the setting, choose Caption > 
Input Preferences.
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Opening a Movie 
MacCaption uses the Mac OS AV Foundation library to play movie files. The types of 
movie files supported depends on your Mac OS version and on any AV Foundation 
plugins or extensions that you might have installed. Note that some other AV 
Foundation-based applications (e.g. QuickTime Player X) include additional format 
support beyond what AV Foundation makes available to other applications like 
MacCaption

If you have a file type that cannot be played in MacCaption, you can create a proxy 
movie. For more information see Using a Proxy Movie.

Note: Opening a movie only loads the video and its audio for playback. If the video 
contains closed captions, a separate import step is needed to bring in the captions. 
See Importing Captions/Subtitles from a Video.

You will have the best playback experience using these types of files:

To Open or Replace a Movie
You can open a new movie (or audio file), or replace the currently loaded movie. To 
open or replace a movie, go to the File menu and choose Open Movie, or simply drag 
and drop a video file into the MacCaption video preview panel. When you drag and 
drop and there is already a video loaded, the new video replaces the previous one. 

QuickTime .mov or MPEG-4 .mp4 
wrapper

ProRes or H.264 (AVC) codec
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Importing Captions/Subtitles from a Video
Opening a video only opens the video and audio for playback. If the video contains 
closed captions, a separate import step is needed to bring in the captions.

When captions or subtitles are embedded in a movie, you can simple drag and drop the 
movie into the MacCaption Text Panel area. This will trigger the MacCaption import 
component that will pull the captions/subtitles out of the movie and load them into 
the Text Panel.

You can also go to File > Import > Extract CC from Media to choose a file type to extract 
the caption/subtitle from. You can select a specific file type, or use the 
QCC Multi-Format Import option, which covers most file types. See QCC Multi-Format 
Import below.
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QCC Multi-Format Import

The QCC™ Multi-Format Import feature allows you to extract closed captions in 608/708 
from a large variety of SD and HD video file types. 

This is very useful when using Command Line Interface scripting. An entire archive of 
video files can be read with the QCC Multi-Format Import. Even obscure file types such 
as DV25/50, IMX30 with VBI, and ProRes .mov captions (both legacy Codec and Caption 
Track). In addition, users can extract multiple languages from the files such as CC1 and 
CC3.

This import function facilitates importing (retrieving/extracting) closed captions from 
the following file types:

• .mpg .mpeg .m2v .mpv .ts .m2t .m2ts (MPEG-2 user data 608/708, line 21)

• .mov .mp4 .m4v .3gp (QuickTime CC tracks, line 21, H.264 NAL SEI 608/708, DV 
VAUX, ProRes VANC)

• .mxf (SMPTE 436m, MPEG-2 user data, line 21)

• .gxf (VANC, MPEG-2 user data, line 21)

• .avi .wmv (Line 21, DV VAUX)

Note: New formats and features are added regularly to the QCC Multi-Format Import. 

The following diagram depicts the extraction of data from various types of media by 
the QCC Multi-Format Import and the conversion and delivery to multiple destinations. 
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Using a Proxy Movie
A proxy movie is a lower quality video file that is used as a stand-in for the high quality 
master file when authoring captions or subtitles. Here are some reasons you may want 
to use a proxy movie for part or all of the captioning process:

• Large original video file. Downloading a large movie file takes a long time and 
uses a lot of space. Unless you need to embed the captions into the master video 
file, you can do the captioning using a much smaller and easier to download proxy 
movie.

• Playback issues. The original video may be very demanding to playback without 
dropping frames. Especially if encoded with high quality settings, or if you have an 
older or lower end computer, or if the video is sitting on an external drive like a 
flash drive or a network drive. Using a proxy movie will help the movie play 
smoother and make the captioning software feel more responsive.

• Incompatible format. The movie might be in a format that can't be played back 
well or at all in the captioning software. Some types of video files, such as MXF or 
MPEG-2 transport streams, require additional software to play them back. In this 
case you can use a proxy movie for the captioning process, and then you can still 
embed the caption data into the original master file if you need to.

Use Telestream Cloud or Vantage to Make a Proxy Movie
Telestream Cloud and Vantage can be used to create proxy movies. These platforms 
support a wide range of formats, including all the major input output formats for web, 
streaming, VOD, production, broadcast and more.

For more information go to:   http://www.telestream.net/ 

Proxy Movie Settings
The resolution and bit rate of the proxy movie does not matter too much. You can keep 
these low for easy playback. What is important, however, is that you maintain the same 
frame rate of the master file. For example, if the master file is 59.94 frames per second, 
make sure the proxy movie is also 59.94 frames per second. This is because the video 
frame rate has a large impact on the captioning process, and using a different frame 
rate could cause the captions to not sync up with the original video. Additionally, if the 
original master video has a time code track, ideally the proxy movie should start at the 
same time code as well.

Here are some general guidelines for your export settings:

• MP4 or QuickTime MOV format.

• H.264 video at 640x360 (if HD) resolution using "baseline" profile.

• A bit rate of around 500 kbps to 1000 kbps (higher will make a larger file, but will 
make the video more clear).

• Uncompressed (PCM) audio at 44100 or 48000 Hz, stereo or mono.

http://www.telestream.net/
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Note on H.264 (MP4) Compression Settings

Some encoders, such as x264, have different profile settings such as "High profile", 
"Main profile", or "Baseline profile". The higher profile makes a higher quality file at the 
same bitrate by using more advanced compression algorithms. The problem is that 
these advanced settings require more CPU power to decode, and some settings such as 
a higher keyframe interval can cause seeking within the video to take a long time. 

When authoring captions, you tend to do a lot of seeking within the video, so this can 
slow down the process and make the software feel less responsive.   Since quality is 
generally not a problem when using a proxy video, we recommend encoding using 
"baseline" profile. This will help with smoother playback and better responsiveness 
while captioning. Of course, you can still use a high profile or higher quality file as your 
final output.
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Set Resolution With No Loaded Movie or for Export
When in Subtitle mode you can use the Subtitle Movie Resolution feature to set the 
resolution of the display panel when no movie is loaded, or set the resolution to the 
final size you plan to export even when a proxy is loaded that is a different size. 

This option allows you to preview and adjust subtitles in their final correct font display 
size. The default resolution is 1920 x 1080 when no movie is loaded. 

Note: In Caption mode, movie preview resolution defaults to 720 x 480 when no 
movie is loaded.

These size options are available from the Subtitle Movie Resolution menu:

• 320 x 240

• 720 x 480

• 1280 x 720

• 1408 x 792 (DLP Cinema 16:9)

• 1920 x 1080

• 2048 x 1080 (DCI 2K)

• 3840 x 2160 (4K UHD)

• 4096 x 2160 (DCI 4K)

• Custom—Opens the Subtitle Preview dialog which allows you to enter a custom 
width and height for the display resolution, up to 4096 x 4096.

 

Current Resolution Select the Resolution
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Timed Text Speech

The topics in this chapter describe the Timed Text Speech features in MacCaption. 

■ Timed Text Speech Overview

– Transcribing a Movie

– Create a Proxy for Certain File Types

■ Creating a Telestream Cloud Account and Project

– Logging into Your Telestream Cloud Account from MacCaption

– Closing MacCaption Does Not Log You Out of Telestream Cloud

■ Job Settings for Timed Text Speech

■ Transcription Mode

– Using Transcription Mode

– Transcription Mode Settings

– Keyboard Shortcuts for Transcription Mode

– Punctuation Behaviors for Transcription Mode

■ How to Transcribe a Movie

– Telestream Cloud Account

– Transcribing a Movie File
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Timed Text Speech Overview
The Timed Text Speech features in MacCaption will create a text transcript of speech in 
a video and populate it directly into the captioning project with the correct timing.

The Transcription Mode can be used to facilitate easy editing of that timed text, or of 
any timed text that you have loaded into the project. 

 

Transcribing a Movie
MacCaption uses Timed Text Speech to analyze the audio track of a video file and 
automatically populate the text and timing information directly into the text edit cells 
as it becomes available. Timed Text Speech currently works with English, French, 
Brazilian Portuguese, and Spanish language video content. 

Timed Text Speech processing operates from servers in Telestream Cloud. You need to 
set up a Telestream Cloud account to use Timed Text Speech, and when using Timed 
Text Speech, MacCaption must be connected to the Internet in order to create the 
transcript. Only the audio portion is transmitted to Telestream Cloud, so your Internet 
speed only needs to accommodate that scope of file size. 

See How to Transcribe a Movie below for a description of the movie transcription 
procedure. 

Create a Proxy for Certain File Types
Certain file types which can be processed by Timed Text Speech to create a transcript, 
such as MXF, may not be playable in MacCaption. In this case, Telestream recommends 
creating a proxy which can be opened in MacCaption, such as MP4 or MOV, using 
Vantage or Telestream Cloud transcoding. 
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Creating a Telestream Cloud Account and Project
Timed Text Speech operates by connecting via the Internet to your account that you 
have set up in Telestream Cloud, and using the Timed Text Speech projects and settings 
that you have created there. 

1. Go to https://cloud.telestream.net/ and click Sign Up to create a Telestream Cloud 
account or Login to your existing account. 

2. Select Timed Text Speech to open the Projects window for transcription projects.

  

3. Click the Add Project button to create a new project. 

4. Create the settings for your project by giving it a Project Name, a Description, 
choosing the language of the video(s) you will be submitting, and enabling other 
options. Then click the Create and Customize button. 

Note: Arabic, Japanese, and Chinese languages are not currently supported by 
MacCaption. 

https://cloud.telestream.net/
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5. You can optionally choose to add vocabulary that is specific to your video content 
either as a file or by entering it in the provided field.

6. Click the Finish button to create your new project.

Note: At this point you move to MacCaption to initiate the next steps. You do not 
submit the transcription job directly in the Telestream Cloud web browser interface. 

7. Open MacCaption to initiate the transcription operation. See How to Transcribe a 
Movie. 

CAUTION: Support for importing the Transcription Files that are available for 
download from the Telestream Cloud web site (.csv, .json, or .srt) will be added in a 
future version of MacCaption. These downloaded files are not currently supported in 
MacCaption. 
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Logging into Your Telestream Cloud Account from 
MacCaption

When you click the Login button in the Timed Text Speech panel in MacCaption, or 
select Telestream Cloud Account from the Transcription menu, The Telestream Cloud 
Login dialog opens. 

• User Name. Enter the user name for the transcription account. The user name is 
saved for future transcribing operations. 

• Password. Enter the password for the transcription account. The password is saved 
for additional transcribing operations during the current session. For enhanced 
security, the password must be re-entered after you close and re-open MacCaption. 

• Don’t have an account? Click this link to go to the Telestream Cloud web site so 
you can create an account. 

• Forgot username/password? Click this link to go to a web page where you can 
enter your email address and initiate a process to reset your password. 

Latest Safari Browser is Required to Log Into Telestream 
Cloud
You must have the latest version of the Safari browser installed in order to log into your 
Telestream Cloud account. Older versions of the OS X operating systems will have older 
versions of Safari installed by default. You must specifically update Safari to the most 
current version. 

Closing MacCaption Does Not Log You Out of Telestream 
Cloud

If you are logged into your Telestream Cloud account when you close MacCaption, you 
will continue to be logged into your cloud account. When you reopen MacCaption the 
Auto-Transcribe button will be active and jobs can be initiated. 
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If you prefer to require a user to log into the Telestream Cloud account when 
MacCaption is reopened, you must explicitly log out of Telestream Cloud before closing 
MacCaption. 

To log out of Telestream Cloud, select Telestream Cloud Account from the Transcription 
menu, then click the Logout button in the Telestream Cloud Login dialog. The Auto-
Transcribe button will change to “Login”, which indicates that you are now logged out 
of Telestream Cloud. 
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Job Settings for Timed Text Speech
You must first be logged into Telestream Cloud to enable access to the Auto-Transcribe 
button, or to enable the Transcribe Movie option from the Transcription menu. See 
Logging into Your Telestream Cloud Account from MacCaption above. 

 

When you click the Auto-Transcribe button (or select Transcription > Transcribe Movie) 
the Timed Text Speech Job Settings dialog opens so you can choose the movie to 
transcribe, select the Telestream Cloud project to use, and set other parameters to 
apply during the transcribing operation. 

• Video File. Displays the path and file name of the currently loaded video file. If no 
video is loaded then “(No video file open)” is displayed. The loaded video file will be 
transcribed, or you can click the Browse button to navigate to and select the video 
file you want to transcribe. When you Browse and select a video file, it is loaded into 
MacCaption. 

• Dialogue Track. Select the audio track in your source video file that you want to 
submit to Telestream Cloud for transcription. Selecting Default selects Track 1. Use 
Default when there is only one dialogue track. Examples of other tracks that can be 
present in a video file are different languages, or the dialogue track (usually center 
channel) of surround-sound. 
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• Select Telestream Cloud Project. Select the project you have created in 
Telestream Cloud that you want to use for this video.

• Manage Projects. Click this link to open your Telestream Cloud Projects page in 
your browser. 

• Job Name. Enter the job name to use. When a movie is loaded in MacCaption this 
defaults to the movie file name.

• Text Wrapping Options. Sets parameters that determine when new text cells are 
created. 

– Maximum Number of Characters Per Line. Sets the maximum number of 
characters for each text cell. The default is 32 characters. The range is 1 to 100 
characters. 

– Wrap on End-of-Sentence Punctuation ( . ! ? ). When enabled, a new text cell is 
created when these characters are included in the transcribed text. The default is 
enabled. 

– Wrap When the Time Gap Between Words in Greater Than ____ mS. When 
enabled, a new text cell is created when there is a gap in the detected speech 
greater than the specified milliseconds. The default is 800 milliseconds and 
enabled. The range is 1 to 5000 milliseconds. 

• Submit. Clicking Submit will send your job to Telestream Cloud for processing. 
Transcribed timed text will start populating the text cells in MacCaption as it is 
being processed and received back. Per minute charges will apply.

Transcription Mode
When Transcription Mode is active, video playback will loop from the start to end time 
of the currently selected text cell. A special editing mode is also activated, which 
provides the ability to quickly navigate through cells and words to easily perform 
transcript edits by using unique keyboard shortcuts. 

Using Transcription Mode
To switch into Transcription Mode, simply press the  button, or select Transcription 
Mode from the Transcription menu. 

Click in the text cell or row you want to start editing, and press the  button to 
start or pause playback. 

When Transcription Mode is active, playback will start automatically when you select a 
text row if the Auto Play/Pause option is selected in the Transcription Mode Settings 
dialog. 

Use the keyboard shortcuts for easy navigation. See Keyboard Shortcuts for 
Transcription Mode and Punctuation Behaviors for Transcription Mode below. 
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Transcription Mode Settings
The Transcription Mode Settings provides options to add playback time before and 
after the start and end times of the currently selected cell, and set the auto-play option.

• Video Looping Start Time Offset. Adds playback time, in milliseconds, before the 
start of the current cell so words in the previous cell are included. 

• Video Looping End Time Offset. Adds playback time, in milliseconds, to the end 
of the current cell so words in the next cell are included.

• Auto Play/Pause Video. When enabled, and Transcription Mode is active, starts 
looping video playback when you click in a cell. 

Keyboard Shortcuts for Transcription Mode
The following keyboard shortcuts are available when Transcription Mode is active.

Action
Keyboard 
Shortcut Description

Next Cell Down Arrow Moves the cursor to the start of the next text cell.

Previous Cell Up Arrow Moves the cursor to the start of the previous text cell.

Next Word Right Arrow Advances the cursor to the start of the next word. If the cursor is on 
the last word of a cell, this advances the cursor to the start of the next 
cell (and triggers the video to loop in the next row).

Previous 
Word

Left Arrow Moves the cursor back to the start of the current word, if the cursor is 
in the middle/end of the current word. Or to the start of the previous 
word, if the cursor is at the start of a word. If the cursor is on the first 
word of a cell, this moves the cursor to the start of the last word of the 
previous cell (and triggers the video to loop in that row).

Next 
Character

Command+
Right Arrow

Moves the cursor right one character.
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Punctuation Behaviors for Transcription Mode
Special behaviors are initiated for certain end-of-sentence, end-of-word, and 
surrounding punctuation entry. Any punctuation other than those listed below are 
simply treated as regular typing input and do not trigger any special behavior.

End of Sentence Punctuation Behaviors
When these end-of-sentence punctuations are typed: period, question mark, or 
exclamation point ( . ? ! ) the following behaviors occur. 

• The cursor moves to the end of the current word. 

• The punctuation mark is inserted at the end of the current word. 

• The next word automatically has its first letter capitalized. (Note that the next word 
might be in the next cell.)

• Any words in the current cell that are to the right of the punctuation mark are 
pushed down to the next cell, as if Split Cell were clicked. 

Previous 
Character

Command+
Left Arrow

Moves the cursor left one character.

Select Next 
Word

Shift+Right 
Arrow

If nothing is currently selected/highlighted, this selects the word that 
the cursor is currently on. If something is already selected, this 
expands the selection to include the next word past the end of the 
current selection. This is limited to the contents of the current cell — 
a selection cannot span across multiple cells. 

Select 
Previous 
Word

Shift+Left 
Arrow

If nothing is currently selected, this selects/highlights the word prior 
to the word the cursor is currently on. If something is currently 
selected, this expands the selection to include the previous word 
prior to the start of the selection. This is limited to the contents of the 
current cell — a selection cannot span across multiple cells.

Pull First 
Word 

Option+ 
Up Arrow

Moves the first word of the next cell to be the last word of the current 
cell. The timecode of the current and next cell is adjusted.

(This is located in the Format menu)

Push Last 
Word 

Option+ 
Down Arrow

Moves the last word of the current cell to be the first word of the next 
cell. The timecode of the current and next cell is adjusted. 

(This is located in the Format menu)

Toggle 
Capitalization

Shift+Up 
Arrow

Toggles capitalization the first letter of the word currently under the 
cursor, or the first word of a selection. 

Split Cell Command+
Enter

Splits the cell into two cells at the cursor location.

Action
Keyboard 
Shortcut Description
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End of Word Punctuation Behavior
End-of-word punctuation marks of colon, semicolon, or comma ( : ; , ) will automatically 
jump the cursor to the end of the word that is under the cursor, and put the mark at the 
end of the word. But unlike end-of-sentence punctuation, this does not capitalize the 
next word or split the current cell.

Surrounding Punctuation Behavior
When a range of text is selected, typing any of the surrounding punctuation marks will 
add the opening mark at the start and the closing mark at end of the highlighted range. 
If a range is not selected, then this simply types a single one of that mark at the current 
cursor location. 

The surrounding punctuation marks are: parenthesis ( ), square bracket [ ], curly bracket 
{ }, single quotation mark ( ‘ ), double quotation mark ( “ ), and music note 
(Command+M). 

Position Adjustment Using the Numeric Keypad + Shift Key
The numeric keypad (on a full-size keyboard) can be used to set the caption position of 
the selected text cell, on a range of selected cells, or the cell the cursor is in. They are 
not active in the timecode entry fields.

These numeric keypad shortcuts are only active when you hold the Shift key. 

The following shows the position that is set for each numeric keypad number: 

7

Top Left

8

Top Center

9

Top Right

4

Row 12, Left

5

Row 12, Center

6

Row 12, Right

1

Bottom Left

2

Bottom Center

3

Bottom Right
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How to Transcribe a Movie 
You can create a timed transcript of the movie that is open in MacCaption, or you can 
select a movie file to open during the transcription process. 

Telestream Cloud Account
Before you can initiate the transcribing operation you will need to have an account and 
create at least one project in Telestream Cloud. See Creating a Telestream Cloud 
Account and Project. 

Transcribing a Movie File 
The following describes the procedure to transcribe a movie file with MacCaption. 

1. Make sure your computer is connected to the Internet. 

2. Click the Login button in the Timed Text Speech panel (or select Transcription > 
Telestream Cloud Account). 

3. Enter your User Name and Password in the Telestream Cloud Login dialog, then 
click OK.

4. Click the Auto-Transcribe button in the Timed Text Speech panel (or select 
Transcription > Transcribe Movie).

 

5. The Timed Text Speech Job Settings dialog opens.



Timed Text Speech
How to Transcribe a Movie

69

MacCaption User Guide

6. Use the Video File currently loaded in MacCaption, or click the Browse button to 
navigate to and select the video file you want to transcribe. When you Browse and 
select a video file, it is loaded into MacCaption. 

Note: For more details about the options in the Timed Text Speech Job Settings 
dialog, see Job Settings for Timed Text Speech.

7. Select the Dialogue Track (audio track) in your source video file that you want to 
submit to Telestream Cloud for transcription.

8. Select the Telestream Cloud project you want to use for this video. 

9. Enter an optional Job Name. This defaults to the open movie file name.

10. Make any adjustments to the Text Wrapping Options.

11. Click Submit to send the job to Telestream Cloud for processing. 

12. The transcription process begins and text starts populating the text cells while it is 
being transcribed. The percent of processing that has completed is indicated in the 
Timed Text Speech panel.
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13. You can start editing the text as soon as the first results start appearing in the text 
cells. See Using Transcription Mode.   

14. Finished is displayed in the Timed Text Speech panel when the transcribing process 
has concluded.
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Synchronizing and 
Adjusting Captions/Subtitles

The topics in this chapter describe how to perform automatic and manual time 
stamping, how to use the time code controls, adjust timing, and check for errors. 

■ Time Code Overview

■ Using Auto Time Stamp

■ Checking the Timing

■ Caption and Video Playback Controls

■ Time Code Display and In/Out Points

■ Manual Time Stamping

■ Adjusting the Timing

■ Setting the Time Code Mode

■ Error Checking
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Time Code Overview
MacCaption converts text to closed caption data and simulates sending control codes 
to captioning hardware for file-based delivery, or sends actual control codes to 
hardware devices. Start and stop time codes tell the captions when to turn and turn off. 
Start and stop time codes are also required for a blank space between captions, for a 
pause in speaking. 

The following topics describe how to apply the time codes to each portion of text, so 
they line up properly with actions in the video. This is also called “time stamping”. 
MacCaption provides options for automatic time stamping, manual time stamping, and 
many ways to make manual and automatic adjustments. 

Using Auto Time Stamp
After you have all of the text loaded into the MacCaption Text Panel, and have it broken 
into the sections you want, you are ready to time stamp it for synchronization with the 
video. The easiest way is to use the Auto Time Stamp feature. 

The Auto Time Stamp feature works very well for videos with high quality audio and 
containing mostly dialogue. It does not work as well if the dialogue is mixed with music 
or sound effects, so it is preferable to use a dialogue-only audio mix to synchronize the 
captions.

Requirements for Auto Time Stamp
The following are the basic requirements to perform an Auto Time Stamp operation:

• A video with a clear high quality audio dialogue track, in the English language, with 
very little background noise or other interfering sounds.

• An accurate transcript of all the dialogue in the video.

• Java Runtime Environment (JRE), version 6 or later, must be installed.

• See System Requirements for the minimum computer specs. 

Auto Time Stamp Results
When you run an Auto Time Stamp operation, the following occurs:

• It automatically synchronizes each caption to the video dialogue; no need to manu-
ally time-stamp captions.

• The process is much faster than real-time (15 times to 30 times faster, depending on 
the speed of your computer).

• When error checking is enabled, MacCaption automatically detects captions with 
poor synchronization or other issues and marks them with a red exclamation point, 
so you can spot check and manually correct these captions. 

See Error Settings for more information.
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Best Practices for Auto Time Stamp
The following are important points to consider for getting the best results from an Auto 
Time Stamp operation:

• An accurate transcript is vital. To get good results, the transcript cannot deviate sig-
nificantly from the audio.

• High quality audio is also the key. Compression, sound effects, or music can distort 
the dialogue.

• Speaker IDs that are indicated with “>> Name:” are treated as unspoken text.

• Non-verbal information in the transcript, such as music or sound effect indications, 
should be enclosed by brackets such as this: [MUSIC], or [Applause]. You can also 
insert the music symbols. See Insert Music Symbol for more information. 

• If MacCaption indicates that some caption lines have errors, you may want to do a 
quick Preview Play to spot check these sections. In many cases the indicated cap-
tions may be fine or close enough for your needs. If not, you can do a manual time 
stamp just on these few sections to improve the alignment. 

Auto Time Stamp Operation
After the text is imported and broken into the sections you want, you are ready for 
Automatic Time Stamp (ATS). 

To perform the Auto Time Stamp operation:

1. In the Time Code menu select Auto Time Stamp. The operation starts and the Auto 
Time Stamp dialog opens indicating the progress, confidence percentage, and time 
remaining. 

2. The Auto Time Stamp dialog closes automatically when the operation is complete. 

Selecting a Range for Auto Time Stamp
You can also run Auto Time Stamp on a range of captions if there is a small portion that 
could use additional adjusting. 

ATS Error When File Name Contains Special Characters
If you use a video file that has a # (hash, pound) or some other special characters in the 
file name, you may get an error message when trying to use Auto Time Stamp (ATS).

If this error occurs, copy the video file to a local hard drive (not a network drive) and 
rename the video file so there are no special characters in the file name. That should 
allow ATS to read the video file.



Synchronizing and Adjusting Captions/Subtitles
Time Code Overview

74

MacCaption User Guide

Checking the Timing
After running Auto Time Stamp, or after manual time stamping, you are ready to check 
the timing of the captions by using Preview Play. At the same time you can check the 
location of the captions to see if position adjustments are needed. For proper timing, 
each caption should start when the first word of the caption is spoken. 

Preview Play
To preview the caption and video synchronization: 

1.  Rewind the video all of the way to the beginning by dragging the slider, that’s just 
below the video, all of the way to the left.

2. Press the Preview Play button  . This engages the Captions Follow Video button 
 which makes the captions change with the video, following the Start and End 

times that are set for each caption.

3. To stop the video, press the Play/Pause button  .

4. You can now use the Play/Pause button  to start and stop the video and the 
captions will stay synchronized since the Captions Follow Video button is engaged. 
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Caption and Video Playback Controls 

Transcription Mode.   Toggles Transcription Mode on and off. See Transcription 
Mode for more information.

Rewind.   Press to put the video into rewind mode. Press multiple times to 
incrementally increase the speed. 

Frame Step Reverse.   Press to go back one frame. Hold Shift and press to go back 
10 frames (about 1/3 of a second at 30 fps), Option for 30 frames (about 1 second at 30 
fps), and Control for 300 frames (about 10 seconds at 30 fps).

For an example of different frame rates, holding the Option key (moving 30 frames) 
would be about 1.25 seconds for 24 fps, about 1 second for 29.97 fps, and about 0.5 
second for a 59.98 fps movie. 

The Left Arrow key  also moves the playhead back one frame. Hold Shift + Left 
Arrow key to move back 30 frames (about 1 second at 30 fps). 

Note: When your cursor is in a text edit field, pressing the Esc (Escape) key removes 
the focus from the text edit field so you can use the arrow keys to move the playhead. 
When focus is in a text edit field the arrow keys move the caption/subtitle position.

Play/Pause.   Press to play and pause the video. You can also press the Space 
bar. 

Frame Step Forward.   Press to go forward one frame. Hold Shift and press to go 
forward 10 frames (about 1/3 of a second at 30 fps), Option for 30 frames (about 1 
second at 30 fps), and Control for 300 frames (about 10 seconds at 30 fps).

For an example of different frame rates, holding the Option key (moving 30 frames) 
would be about 1.25 seconds for 24 fps, about 1 second for 29.97 fps, and about 0.5 
second for a 59.98 fps movie. 

The Right Arrow key  also moves the playhead forward one frame. Hold Shift + 
Right Arrow key to move forward 30 frames (about 1 second at 30 fps). 

Fast Forward.   Press to put the video into fast forward mode. Press multiple times 
to incrementally increase the speed.

Preview Play.    Press to start playback and engage the Captions Follow Video 
button  . This makes the captions change along with the video, following the Start 
and End times that are set. Use this to preview captions after they have been 
synchronized to the video. 

 Pointer and handle to time location
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Time Stamp.   This button starts video playback, but the captions do not play 
along. Use this mode when you want to edit the In points (start times) of the captions 
with new timing by pressing the Mark In button  and you don’t want the captions 
to advance using the existing timing. 

Captions Follow Video.   When this is pressed (toggled on), the captions change 
along with the video, following the Start and End times that are set. 

Video Follows Captions.   When this is pressed (toggled on), and you select a 
caption row, the video automatically jumps to the time of that caption.   You can also 
quickly move through the caption rows using the up and down arrow keys, and the 
video follows along.

J-K-L Playback Control
You can use the J-K-L keyboard controls to shuttle the video, the same way that popular 
video editing applications operate. 

To use the J-K-L keyboard control, press J to rewind, K to stop, and L to play forward. 
Multiple presses of the J or L keys increases the speed of rewind or forward.

When your cursor is in a text edit field, the J, K, or L keys (and the space bar) operate in 
text entry mode. Click on the Video Playback panel to change the focus, then the J, K, 
and L keys will operate in video control mode. 

Use Esc Key to Exit Text Editing and Activate J-K-L Mode
When your cursor is in a text edit field, pressing the Esc (Escape) key removes the focus 
from the text edit field. The J-K-L keys, and space bar, can then be used for playback 
control. 

For additional information on this and other keyboard shortcuts, see the “Guide to 
MacCaption Keyboard Shortcut Extensions”. You can open this from Help menu > 
Keyboard Shortcuts. 
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Time Code Display and In/Out Points
Information on the MacCaption Workspace shows the current time of the movie, the 
start and end time of each caption, and the duration. Buttons allow you to set the In 
and Out points. 

Movie Time.   Displays the current time of the movie in 
HH:MM:SS:FF format. (H = hours; M = minutes; S = seconds; F = frames.)

Mark In.    Click to set the In Point or Start Time of the first word of the currently 
selected caption. If multiple rows are selected, start time is set for the first, or top row. 

Mark Out.    Click to set the Out Point or End Time of the last word of the currently 
selected caption. This only needs to be set when a space is needed between captions, 
such as when there is a pause in the speech, or when the captions have ended. 

Note: When you set an Out Point or End Time, you must set an In Point or Start Time 
at the point you want the next caption to appear in the video. When a space is not 
needed between captions, you only need to set the In Point or Start Time for each 
caption. 

Caption Time Display
The following timing information is displayed for each caption row:

• Starting Time. The start time of the first word of the caption.

• Ending Time. The end time of the last word of the caption. 

• Duration. The time duration of the caption in seconds and frames.

• Words Per Minute (WPM). The approximate word per minute reading speed of the 
caption. 
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Manual Time Stamping
Manual time stamping allows you to associate a timecode to each block of text so it will 
be in sync with the dialogue. Manual time stamping is needed for various situations, 
such as videos that are not in English or that have loud music. To perform manual time 
stamping:

1. Rewind the video all of the way to the beginning by dragging the slider, that’s just 
below the video, all of the way to the left.

2. Click the Time Stamp button  . Playback starts, but the captions do not play 
along.

3. Click the Mark In button  each time you hear the first word of a caption. 

4. Every time you press the Mark In button, time code appears in Starting Time for 
that row and the next row is automatically selected. Continue until you have set the 
start time for each row of captions. 

5. To stop video playback, press the Play/Pause button  .

Creating a Pause in Caption Display
Typically, closed captions are back-to-back to allow the reader enough time to read the 
text on the screen. But if there is a significant pause in the dialogue, or credits and other 
information is displayed, there should be a pause in caption display. 

To create a pause, you can press the Mark Out button  during a manual time 
stamping process. 

After setting an Out Point, you must press the Mark In button  when you want the 
next caption to appear in the video. 

Check Your Timing
After you have performed a manual time stamping you should check the timing by 
using the Preview Play button  . For more information see Preview Play. 
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Adjusting the Timing
Several timing adjustment options are available when you need to synchronize 
captions to a video, correct for changes over time, or create different versions for 
various delivery requirements. 

Adjusting Specific Caption Timing
During playback you may have discovered some captions that need to have their 
timing adjusted. The following describes some methods for adjusting specific captions:

• New In Points. Click on the row where you want to make the change, then move 

back a couple of caption rows before that. Click the Time Stamp button  , and 

press the Mark In button  when at the point you want to synchronize the cap-
tion to the dialogue. Continue for any captions you want to fix. 

• New Out Point. When you want to create a space before the next caption displays, 

press the Out Point button  . Then you will need to set a new In Point when you 
want the next caption to display. 

• Manual Time Entry. You may also enter new times manually by typing into the 
Starting or Ending time fields. The time just before or after it is automatically 
adjusted. 

• Up/Down Arrow Keys. You can place your cursor in a caption Starting time field, 
then press the up or down arrow keys to adjust one frame at a time. 

• Ripple Time code. See Applying Ripple Time Code Offsets. 

• Stretch/Shrink Time Code. See Stretch/Shrink Time Code. 

• Convert Time Code. Convert Time Code. 

Clock Time vs. Time Code
The numbers for the clock time and the time code of a caption can sometimes be 
different. The following provides a brief explanation of how these time measurements 
relate to each other. 

Clock Time
Clock Time is also referred to as Media Time or Real-World Time. This is the time that an 
event occurs relative to the start of the video. Imagine you start a stopwatch at the 
same time the video starts. At the time a caption is supposed to appear, the time shown 
on the stopwatch is the clock time (or media time) of the caption. The clock time of a 
caption is independent of the video frame rate. For example, if a section of dialogue 
occurs exactly 60 seconds after the start of the show, it will always occur at 60 seconds 
regardless of whether the video frames update at 10 frames per second, 25 fps, 100 fps, 
or any other frame rate. 

The only case where a clock time of a caption might change is if the video speed is 
changed. This sometimes happens when converting film sourced material to TV 
formats—the video is slightly slowed down or sped up, and now the video version has 
a different duration than the original film (without any other edits to the content). This 
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results in the dialogue and its associated caption clock time occurring slightly earlier or 
later than before. 

Time Code
Also called SMPTE time code. Time Code is a system used to uniquely label each video 
frame with a time-based identifier in HH:MM:SS:FF format. Time code is the value 
displayed in the Movie Time field on the MacCaption interface. Due to some 
peculiarities of different video systems, you cannot always take a time code at its face 
value—the numbers shown in the time code are not always equivalent to the number 
of hours, minutes, and seconds that it actually represents. Thus it is important to keep 
in mind that the time code of a caption will sometimes appear to be a different number 
than the clock time of a caption, even though both they both reference the exact same 
moment in time. 

Further complicating things is that time codes come in different modes, and so a given 
clock time can be represented by different time codes depending on which time code 
mode you are using. The Convert Time Code dialog allows you to switch modes 
depending on your needs. 

For more information on time codes, see the Telestream knowledge-base article: Time 
code for 23.976 / (23.98) frames per second video. 

Applying Ripple Time Code Offsets
Ripple Time Code changes the time code within a currently selected range, or from a 
selected row to the end of the file. Use this when you want to change the time stamp of 
all the selected rows by a few frames, or if you want set a new start time for the selected 
range. 

To make a Ripple Time Code adjustment:

1. Use one of these selection methods—

a. Select a range of rows that you want to adjust. Either using Shift-Click or by using 
the Edit menu > Select Range dialog. You can also use Edit menu > Select Up or 
Select Down. 

b. To adjust all the way to the end, select the row where you want to start 
performing the Ripple Time Code offset. 

c. If you want to create offsets for the entire file, choose Edit > Select All 
(Command-A). 

2. From the Time Code menu choose Ripple Time Code. This is also available from a 
right-click menu in the text edit panel.

http://telestream.force.com/kb/articles/Knowledge_Article/Time-code-for-23-976-frames-per-second-video
http://telestream.force.com/kb/articles/Knowledge_Article/Time-code-for-23-976-frames-per-second-video
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3. The Ripple Time Code dialog opens.

4.  Enter the adjustments you want to make into the fields provided, then click Apply. 

Stretch/Shrink Time Code
If your caption timing is right on time at the start but is off a few seconds from the video 
at the end, you have “captioning drift”. This can be corrected by using the Stretch/
Shrink Time Code option. Choose Time Code > Stretch/Shrink Time Code. This option is 
also available from a right-click menu in the text edit panel.

The time code value is in the HH:MM:SS:FF format.

Use the “Increase time code by 1.001/1.000” option when you want to convert 23.976 
fps to 24 fps, 29.97 fps to 30 fps, or 59.94 fps to 60 fps. This difference is 3 seconds per 
hour of video.

Use the “Decrease time code by 1.000/1.001” option when you want to convert 24 fps 
to 23.976 fps, 30 fps to 29.97 fps, or 60 fps to 59.94 fps. This difference is 3 seconds per 
hour of video.

This option is also useful when you use a “proxy movie” to do all the captioning and 
then need to match the time coded file with the master copy of the video, which may 
have a slightly different code by the end of the video. One reason this could happen is 
due to a drop frame/non-drop frame issue. To match the time code of the caption file 
with the video, make sure the first time code of the caption file matches with the 
master copy. Then choose this option and enter the last time code from the master 
copy. This will stretch or shrink all the time codes in the caption file to match the master 
copy.

You can also use the Convert Time Code dialog to match the time code of the master 
copy of the video. 
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Convert Time Code
The Convert Time Code dialog provides several options so you can adjust the time code 
to match other versions or delivery destinations of the movie, or you can change the 
timing when captions do not sync up with the video. To open the dialog, go to Time 
Code > Convert Time Code. This option is also available from a right-click menu in the 
text edit panel.

Maintain Clock Times
Use Maintain Clock Times if the captions are currently in sync with your movie (the 
clock times are correct), and you want them to stay in sync, but at a different frame rate 
or time code mode. For example, this option is used when your captions sync up with a 
29.97 fps movie and now you want to apply them to a 23.976 fps version of the same 
movie, which has the same duration as the original, so that you can deliver a 23.976 fps 
caption file. When the time code or frame rate changes, the clock times that they 
represent will be unchanged.

Modify Clock Times
Use Modify Clock Times if the captions currently do not sync with the movie (the clock 
times are not correct) and you want to bring them into sync. Or, if the captions sync 
with this movie but you need to make them sync with another version of the movie 
which plays faster or slower. For example, this mode is used if you imported a Non-Drop 
Frame (NDF) caption file which does not sync with your movie which is in Drop Frame 
(DF) mode. Or, when your captions sync with a 24 fps film and you want to apply them 
to a 25 fps PAL conversion which has been sped up by 4% from the original film. The 
time code modes are:

• 23.976: Film   

• 24.0: Film (SMPTE 24)

• 25.0 or 50: PAL/SECAM (SMPTE 25, 50)
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• 29.97 DF, 59.94 DF: Drop Frame (SMPTE DF)

• 29.97 NDF, 59.94 NDF: Non-Drop Frame (SMPTE 30, 60)

Note: In some cases, when changing from one time code mode to another, Modify 
Clock Times might appear to leave the time codes unchanged. This is due to the fact 
that the same time code (in a different mode) can represent a different clock time. 
Thus the clock time actually did change, even though the time code appears 
unchanged.

Start Time Offset
Enable Start Time Offset if your captions have a starting time code offset such as 
01:00:00:00 and you wish to preserve this offset even after the conversion. 

For example, if your project and captions are in 29.97 DF mode, the captions start at 
01:00:00;00 and are in sync with the video. You want to convert the project to 23.976 
mode and have the start time remain at 01:00:00:00. In this case, select Maintain Clock 
Times, choose Convert From 29.97 DF, and Convert To 23.976. Then, enable the Start 
Time Offset option and set it to 01:00:00:00. The first caption will remain at 01:00:00:00 
but the timing from that point forward will be adjusted. If you tried to do this 
conversion without setting the Start Time Offset option, the first caption time would 
change to 00:59:56:10 and not be in sync.

Preview of Changes
In the Caption—Before—After section, each time is provided as both a video time code 
(in the given mode) in format HH:MM:SS:FF, and also as a clock time in the format 
NNNN.N s (seconds), so that you can see what adjustments will be made.
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Setting the Time Code Mode
It is important to know the time code mode when working with video time codes, 
because if you don't know the mode then the actual time they represent can be 
uncertain. This is the leading cause of synchronization issues, such as caption text that 
doesn't quite line up with the audio.

First, let's distinguish between video frame rate and time code mode:

• Video frame rate—the rate at which the image is updated.

• Time code mode—the numbering or labeling system used to uniquely identify 
each video frame.

Sometimes, these two items have a simple relationship. For example, PAL video uses 
25.0 frames per second frame rate, and 25 fps time code. In other cases the relationship 
can be more complicated, which is the case for film-like digital videos that run at 23.976 
frames per second but count time code as if they were 24.0 frames per second. 

Here is how video systems, such as closed captioning software, correlate these two 
different measurements:

• Both 23.976 and 24.0 fps videos use the same type of time code (SMPTE 24). When 
using 24.0 fps video and SMPTE 24 time code, it syncs with a real time clock (similar 
to drop frame time code). 

• When using 23.976 fps video with SMPTE 24 time code, it does not sync with a real 
time clock (similar to non-drop frame time code).

In MacCaption, you set the time code counter mode (SMPTE 30 non-drop frame, SMPTE 
29.97 drop frame, SMPTE 24 Film, and SMPTE 25 PAL) via the Time Code > Mode menu.  
If your video is 24.0 fps or 23.976 fps and you're using SMPTE 24 time code, you'd select 
Time Code Mode > 24 for both cases because they both use the same time code 
counting system. 
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Error Checking
MacCaption provides various options for checking errors, such as missing timecodes, 
non-sequential timecodes, incorrect words per minute, and so on. 

When you caption/subtitle a video, it is very important that you conform to 
recommended maximum words per minute for captions, depending on your audience. 
Similarly, it is customary not to have a pop-on caption covering a shot change. And 
finally, if you do not allow enough time for a pop-on caption to build up, the caption 
does not appear at the time you assigned. 

For example, pop-on captions take about one second for every 50 characters of text. If 
the difference of time codes of the previous caption and the current caption is less than 
one second for a caption of 50 characters, the caption appears later than the assigned 
time code. 

Error Settings
Options for error detection are available in the Errors tab of the Preferences dialog. To 
open the dialog go to the MacCaption menu and select Preferences > Errors.

When Show Errors is selected, the values and options selected are automatically 
checked for those errors. 
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Viewing Error Messages
When an error is detected for a caption, a red box with an exclamation point “!” appears 
in the caption row. When you hover your cursor over the red box, a message pops up 
indicating the detected error:

You can also double-click the red exclamation box to open a dialog and read the same 
error message. 

When errors are detected, a red box appears in the bottom of the MacCaption 
workspace with arrows to move to the previous or next error:
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Format and Edit Captions/
Subtitles 

The topics in this chapter describe how to format and position captions/subtitles, 
perform row operations, adjust display modes, and includes some tips for creating 
captions.

■ Formatting and Positioning

– Grid Locations and Position Options

– Upper, Lower, or Sentence Case

– Insert Music Symbol

■ Row Operations

– Selecting Multiple Rows

■ Display Modes

– Pop-On

– Paint-On

– Roll-Up

– Changing the Display Mode

■ Captioning Tips

– Suggestions for Breaking Lines

– On-Screen and Off-Screen Speakers

– Centering or Not

– General Captioning Guidelines

■ Special Characters
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Formatting and Positioning
MacCaption provides a wide variety of tools to format and position your captions. The 
tools apply to the currently selected row, or to all text in any range you select. 

Additional options are available for the Left, Center, and Right formatting buttons. Click 
the arrows on a button to open a menu to select from three Justify options, as shown in 
the following:

Horizontal Alignment.  Sets the caption horizontal alignment to Left, Center, 
Right, or to a grid location number. 

Vertical Alignment.  Sets the caption vertical alignment to Top, Bottom, or to a 
grid location number. 

Justification.  Sets the caption to Left, Center, or Right justification. 

Left Position.  Sets the caption to the left position, with Left Justify, Center 
Justify, and Right Justify options. 

Center Position.  Sets the caption to the center position, with Left Justify, Center 
Justify, and Right Justify options. 

Right Position.  Sets the caption to the right position, with Left Justify, Center 
Justify, and Right Justify options. 

Move to Top.  Moves the caption(s) to the top in the row(s) selected. 

Move to Bottom.  Moves the caption(s) to the bottom in the row(s) selected.

Pull Word Up.  Pulls the first word of the next caption into the currently selected 
caption.

Push Word Down.  Pushes the last word of the currently selected caption to the 
next caption.

Compress Line Length. (Option+Left Arrow)  Compresses the text block in the 
selected row(s). Multiple clicking creates incremental changes. 

Expand Line Length. (Option+Right Arrow)  Expands the text block in the 
selected row(s). Multiple clicking creates incremental changes.
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Note: Compress and Expand perform a word wrap to increase or decrease the 
number of caption lines, ranging from 1-4 lines. It is recommend to have 1-2 lines for 
most captions.

Alternate Break.  Adjusts the way words are distributed in the text block. Multiple 
clicking provides different arrangements. It is better to make the text bottom heavy 
(shorter lines towards the top, longer lines towards the bottom).

Bold/Flash.  Applies bold formatting to the row(s) selected, or only to specific 
selected text. It is recommended not to use bold formatting since in most TV display 
situations the text will flash. 

Italic.  Applies italic formatting to the row(s) selected, or only to specific selected 
text. 

Underline.  Applies underline formatting to the row(s) selected, or only to specific 
selected text. 

Transcription Mode
When Transcription Mode is active, video playback will loop from the start to end time 
of the currently selected text cell. A special editing mode is also activated, which 
provides the ability to quickly navigate through cells and words to easily perform 
transcript edits by using unique keyboard shortcuts. 

See Transcription Mode in the Timed Text Speech chapter for detailed information. 
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Grid Locations and Position Options
You can also position captions in increments, using the television caption grid 
locations. You can position the captions up or down, right or left, in half-grid 
increments. The adjustments apply to the currently selected row, or to all selected rows. 
To see the grid, choose Display > Show Caption Grid, as shown in the following:

There are various ways you can move the captions and subtitles into different grid 
locations:

• Drag and Drop. You can simply grab a caption and drag and drop it to a new posi-
tion. The caption will snap to half-grid locations. 

• Arrow Keys. First, click in the Video Preview Panel to highlight it. A white border 
appears. Then use your up, down, right, or left arrow keys to move the caption or 
subtitle one character at a time. Hold Shift when using the arrow keys to move the 
captions all of the way to the left, right, top, or bottom. For subtitles, holding Shift 
moves them 20 pixels in any direction. 

• Tool Bar Selection.  Use the Horizontal and Vertical Alignment 
menus to select grid locations by number. 

• 1-9 Number Keys. The 1-9 number keys are shortcuts to position locations. First, 
click in the Video Preview Panel to highlight it. A white border appears. Then use 
the number keys for the following positions:

– Keys 1-3: Bottom Left, Center, Right.

– Keys 4-6: One line up from bottom Left, Center, Right.

– Keys 7-9: Top Left, Center, Right.

Note: You do not need to see the grid to position captions. They will automatically 
snap to the half-grid locations. 
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Upper, Lower, or Sentence Case
To convert the selected row(s) to upper, lower, or sentence case, go to Format > Upper 
and Lower Case and choose one of the following options:

• Convert to Upper Case. Converts the selected text to upper case. 

• Convert to Lower Case. Converts the selected text to upper case.

• Sentence Wise Upper and Lower Case. Converts text to “sentence style” with the 
first word of a sentence capitalized.

• Upper and Lower Case Preferences. Opens a dialog so you can choose to capital-
ize the first letter of each word following a period. 

Insert Music Symbol 
To insert a music symbol, go to Format > Insert Music Symbol and choose one of the 
following options:

• Single Music Symbol. (Command-M) Inserts a music symbol (the quarter note) 
into the caption text at the cursor location. 

• Surrounding Music Symbols. Inserts a music symbol at the beginning and end of 
selected text. If you select multiple rows and choose this option, it adds a pair of 
music symbols for all of the selected captions.
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Row Operations
The Row operations tools provide a quick way to insert, delete, split, and merge rows. 

Insert Caption Row.  Create a new blank row above the currently selected row. 
When you have multiple rows selected it inserts that number of rows. 

Delete Caption(s).  Delete the currently selected caption row(s).

Split Caption.  Splits the current row at the position of the text cursor and places 
the text after the cursor in a new row. You can also press the Return key to split the row 
at the cursor position. When the cursor is at the end of the text and you press the 
Return key a blank row is inserted after the current row. 

Merge Caption.  Combine the row below and the current selection into one row.

Selecting Multiple Rows 
The following describes various methods to select multiple rows:

• Shift+click. Select one row, hold Shift and select the row you want for the end of 
the range. You must first click in the row number or timing area, not in a text edit 
field. 

• Shift+arrow keys. Hold the Shift key, then use the Up or Down arrow keys to select 
additional rows. You first must click in the row number or timing area, not in a text 
edit field.

• Select All. To select all rows, choose Edit > Select All, or Command+A. 

• Select Up. Choose Edit > Select Up to select all rows up to number 1, from the cur-
rently selected row. Or use Option+Shift+Command+U. 

• Select Down. Choose Edit > Select Down to select all rows down to the end, from 
the currently selected row. Or use Option+Shift+Command+D. 
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Display Modes
Display Modes control the way captions appear or move onto the screen. 

Pop-On
Pops 1 to 4 lines of captions or subtitles onto the screen simultaneously. It is the most 
commonly used mode for subtitling, and is typically the preferred option for closed 
captioning. It is virtually impossible to use the Pop-On mode without using time code. 
The technical reason for this is that it takes time (roughly 1/60th of a second) to process 
each character of a caption line. Only when this processing has been completed is the 
caption line loaded onto the screen. Since this delay is variable (because the number of 
characters in each cell varies) it is almost impossible for a person to compensate for this 
delay. MacCaption precisely compensates for this delay when used with time code.

Paint-On
Paints characters on the screen one after another, from left to right, so that the screen 
looks like the output of a human typist. When the first word of the next caption 
appears, the entire previous caption is erased.

Roll-Up
Scrolls up captions from the bottom of the screen one line at a time. Two to four lines 
normally appear on the screen at any given time. Television news is a frequent user of 
Roll-Up captioning (often in conjunction with a teleprompter that generates captions).

Changing the Display Mode
To change the Display Mode:

1. Select the row(s) in which you want to change the display mode. 

2. Choose a mode from the Display Mode menu:

3. The new display mode is now active in the selected row(s). 
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Program A—F Selection 
Use program selection to choose which program, A—F, to have active in the Text Panel. 
The program that is currently selected is the one in which text is placed during an 
import operation. Unless you are captioning a video with two channels, such as for 
English and Spanish languages, there is no need to use any program other than 
Program A.

You can use the Program menu to select the program to edit:

  

You can also select the program from the Display menu:

Or, use the keyboard shortcut “Option+Command+A through F” to select the program 
to edit.

Display Multiple Programs in the Video
To have more than one program display subtitles in the video at the same time, use the 
Subtitle Preferences dialog to select the programs. See Setting Subtitle Preferences and 
Display Multiple Sizes, Colors, or Locations. 
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Decode Channel Selection
Captioned videos that you are importing from the Import menu are decoded according 
to the Decode Channel selected. You can use the Decode menu to choose the Decode 
Channel:

Or, go to Caption > Decode Preferences and choose the channel for the type of captions 
you are decoding from the Decode Channel drop-down menu.

 

For information on the Decode Channel selections see Set Decode Channel in the 
Menus chapter. 
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Captioning Tips
The following tips provide suggestions for the best ways to break lines of text, how to 
represent on-screen and off-screen speakers, centering text, and various general 
captioning guidelines. 

Suggestions for Breaking Lines
Professional captioning methods include creating the best text break points, 
positioning the captions properly, and the use of time sequencing. Captions should be 
adjusted to provide uniform readability. 

The following are common places to break lines into separate captions:

• End a caption at the end of a sentence. The Text Import Options dialog can make 
these breaks automatically using the end-of-sentence punctuation marks " . ", "?", 
and "!".

• End captions at commas and semicolons if they come at a natural pause in the dia-
log and conclude a phrase. The Text Import Options can make these breaks auto-
matically as well, but there are many commas in English that are not good places to 
break text.

When you break text into individual captions, they should make grammatical sense. 
Here is an example:

Unformatted, Raw Text: 

A poor way to caption it: 

A good way to caption it: 

On the way to the airport, I got caught in 
traffic and ended up being late for my 
flight. I had to wait around for five hours 
to catch the next available flight.

On the way to the airport,
I got caught in 

traffic and ended up being late
for my flight. I had to wait
around for five hours to catch
the next available flight.

On the way to the airport,
I got caught in traffic

and ended up being late
for my flight.

I had to wait around
for five hours

to catch
the next available flight.
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On-Screen and Off-Screen Speakers
One basic convention concerns the difference between how you represent on-screen 
and off-screen speakers. The words spoken by off-screen speakers (commonly 
narrators) appear in italics, but italics can be skipped if the speaker comes in and out of 
view. The words of on-screen speakers appear in the normal font. 

Centering or Not
Another convention concerns centering and not-centering. Captions can indicate the 
location of the speaker, and should appear under the speaker. However, if the speaker is 
in the center but centering the caption interferes with a graphic and/or important on-
screen visual information, then the caption should be moved to another location.

General Captioning Guidelines
The main objective is to have each caption represent a single thought. There is no 
single right way to caption a video, but a few additional guidelines may help:

• Your captioning style should be consistent throughout the video.

• Whenever possible, you should break captions into logical phrases. Captions ran-
domly broken up may convey a different meaning than intended. 

• Captions can indicate the location of the speaker. For instance, a caption on the left 
side of the screen indicates the speaker is on the left, while a centered caption 
shows that only one person is speaking throughout a scene.

• Words can be emphasized with underlining.

• Use Attribute > Insert Music Symbol(s) to place a musical note at the beginning and 
end of musical lyrics. 

• Never paraphrase lyrics. Also include the title of the song when possible.

• Indicate sound effects in parentheses and in lower case, for example (boom) and 
(applause).
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Special Characters
Caption text can display certain special characters. These special characters can be 
generated either with a combination of keyboard characters or with a ‘\’ (backslash) 
character in combnation with a second character, as listed in the following table. 

Character Desired Keyboard Combination Backslash Combination

á Option-e then a \’a

à Option-` then a \`a

â Option-i then a \^a 

é Option-e then e \’e

ê Option-i then e \^e

ç Option-c \c

í Option-e then i \’i

î Option-i then i \^i

Ñ Option-n then N \N

ñ Option-n then n \n

ó Option-e then o \’o

ô Option-i then o  \^o

ú  Option-e then u  \’u

û Option-i then u \^u

÷ Option-=  \=

° Option-shift-8 \o

¢ Option-4 \$ 

£ Option-3  \l

® Option-r \r

™ Option-2 \t

1/2 Option-v \v

¿ Option-shift-? \?

Music note Option-b \b
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Subtitle Mode

The topics in this chapter describe subtitle operation and how to change the 
formatting and behavior of subtitles. 

■ Subtitling Overview

– Subtitle Mechanisms

– Subtitle Export

■ Converting Between Captions and Subtitles

■ Setting Subtitle Preferences

■ Display Multiple Sizes, Colors, or Locations

– Simultaneous Subtitle Example

■ Subtitle Style Configuration

– Text Settings

– Drop Shadows Settings

– Other Settings

– Japanese Ruby Subtitling
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Subtitling Overview
Subtitles are text that appears on a video or in a movie and typically contains only a 
translation of the dialogue, usually because the dialogue is in a foreign language, or 
because the dialogue was difficult to hear clearly. Unlike captions, subtitles usually do 
not convey non-dialogue sounds such as background noise, sound effects, or music 
cues, because it is presumed that the viewer is able to hear them. Subtitles have fewer 
rules and limitations than closed captions, and generally have more fonts, styles, and 
colors available to choose from. 

Subtitles can be burned into the video so they can't be turned off. This is called "open 
subtitles", "burn-in subtitles" or "hard subtitles," and is used when the subtitles must 
always be available, such as when translating foreign language dialogue for a general 
audience. This is also useful when working with a video format or player that doesn't 
support soft subtitles or closed captions.

Some formats, such as DVD, Blu-ray, many web-based players, and a few other video 
formats, can contain one or more tracks of subtitles which can be selected and turned 
on or off by the player. This is called "soft subtitles" or "separate subtitles".  

Subtitle tracks which contain non-verbal audio cues and mimic the look and feel of 
closed captions are called "SDH" (Subtitles for the Deaf and Hard of Hearing) tracks. 
SDH tracks are often used to emulate closed captions on formats that don't support 
closed captioning due to technical limitations, such as Blu-ray.

Subtitle Mechanisms
Just as closed captions can exist embedded in a video file or in a separate sidecar file, 
there are several ways you can export subtitles:

• Burn-in. This permanently combines the subtitles and the video. They can't be 
turned off, but you never have to worry about whether they will work or not.

• Overlay for Later Burn-in. If you're working with a video editor that wants to burn-
in the subtitles, you can send them an overlay file. They put the overlay into their 
NLE system and render the burn-in video from there. This way, the captioner 
doesn't need the full resolution master video from the editor. 

• DVD/Blu-ray. Several prosumer and professional software packages for authoring 
DVD and Blu-ray discs can accept subtitle files. In this case the viewer can turn the 
subtitle tracks on or off. The type of file to export depends on which authoring soft-
ware is being used to author the DVD or Blu-ray.

Subtitle Export
For information about subtitle export see Exporting Subtitles in the Exporting / 
Encoding chapter. 
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Converting Between Captions and Subtitles
MacCaption has the ability to convert closed captions into subtitles and vice versa. 
When converting closed captions to subtitles, there isn't too much you need to worry 
about, because subtitles are generally much more capable than closed captions. 

Where you need to be careful is when converting subtitles into closed captions. The 
subtitles might break some of the rules of closed captioning, for example, by having 
more than 32 characters per line. In this case, some manual reformatting needs to be 
done when conforming the subtitles into closed captions.

Making sure you are in the right mode when you start your project helps you avoid 
some extra work.
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Setting Subtitle Preferences
The Subtitle Preferences dialog provides options to select the program to display, set 
the title safe percentage, and other options. Go to Subtitle > Subtitle Preferences to 
open the dialog. 

 

Select programs to display 
Offers options to select which Program’s subtitles are displayed.

• Currently selected program. Display subtitles only from the currently selected 
program.

• All programs. Display subtitles from all programs that have subtitles.

• Individually selected programs. Display subtitles from the specific programs you 
select—A, B, C, D, E, or F.

Title safe boundary
Sets the amount of margin to leave around subtitles to ensure they are not cut off at the 
edges of the screen. The range is 0–20 percent of the visual image. 10 percent is the 
standard for NTSC. 

Apply subtitle setting changes to all selected programs
Applies changes in subtitle settings to all selected programs even if they are not 
currently displayed.
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Display Multiple Sizes, Colors, or Locations
When in subtitle mode, Programs A through F can be used to display multiple font 
sizes, colors, or additional simultaneous locations. This feature works in a similar way 
that layers do in a graphic editing application. Multiple programs can be set to display 
at the same time, and each one can have a different style or location. 

Simultaneous Subtitle Example
The following provides an example of how to use multiple programs to display 
different subtitles at the same time:

1. Program A contains the first layer of text, and provides the main content. You are 
currently working in Program A, in subtitle mode.

2. You want some text to have a different look and location, but display at the same 
time, so copy those text rows to place them in memory.

3. Select the Program menu and choose Program B:   . 

4. Paste the copied rows into the blank rows of Program B.

5. From the Subtitle menu select Subtitle Preferences.

6. In the Subtitle Preferences dialog choose “Individually selected programs” and 
check both A and B, as show in the following:

7. In Program B, set the Start and End Times for each row so the subtitles display when 
you want them to. You can do this by typing in the Start and End time fields, or by 
using the Mark In and Mark Out buttons. 

8. Go back to Program A and remove any subtitles you don’t want there, and adjust 
timings. 
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9. Now, two different subtitles can display at the same time, as shown in the following 
image taken from the MacCaption Video Preview Panel:

Program A subtitle

Program B subtitle
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Subtitle Style Configuration
From the Subtitle top menu, open the Subtitle Configuration dialog to select the font 
and set style, size, color, spacing, outline, and drop shadow settings for the currently 
selected program.

You can preview the changes in the video playback panel while you are making 
selections and adjustments for text and drop shadow in the Subtitle Configuration 
dialog, before you close it. 

Text Settings
You can make the following selections and adjustments in the Text panel of the Subtitle 
Configuration dialog for the currently selected program.

Text Drawing
In the Text Drawing selection box, select the font to use to draw the subtitles. 

Size
In the Size menu, select the point size of the font to use for the subtitles.
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Color
Click in the Color box to open the Colors dialog and set the default color to use for the 
selected program’s subtitles. The default is white. 

Letter Spacing
Add or subtract the amount of horizontal space between characters, as a percent of the 
font size. The range is -10% to 100%. Normal spacing is 0%. 

Leading
Adjust the leading (line spacing) as a percent of the font size. The range is -20% to 
100%. Normal line spacing (leading) is 0%.

Outline
Size—Set the pixel size of the text outline. The range is 0 to 50 pixels. 0 pixels is no 
outline. 

Color—Click in the Color box to open the Colors dialog and set the color of the text 
outline. 
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Drop Shadows Settings
You can make the following selections and adjustments in the Drop Shadows panel of 
the Subtitle Configuration dialog for the currently selected program.

Enable Drop Shadows
Check to enable drop shadows, or uncheck to disable them.

Color
Click in the Color box to open the Colors dialog and set the drop shadow color. The 
default is black. 

Opacity
Set the opacity of the drop shadows as a percent. The range is 0% (completely 
transparent) to 100% (fully opaque).

Edge Blur
Set the percent of drop shadow blur. The range is 0% to 200%. Zero (0) gives the 
shadow a sharp edge, and higher percentages create softer edges. The default is 1%.

Distance
Set the distance of the drop shadow from the text, as a percent of font size. The range is 
0% to 200%. The default is 5%. 

Angle
Set the direction of the drop shadow from the text. The range is 0 to 359 degrees.  Zero 
(0) degrees is right, 90 degrees is up, 180 degrees is left, 270 degrees is down.  315 
degrees is a common drop shadow setting, which is down and to the right. 
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Other Settings
You can make the following selections and adjustments in the Other panel of the 
Subtitle Configuration dialog for the currently selected program.

Color
Click in the Color box to open the Colors dialog and set the background color. The 
default is black. 

Opacity
Set the opacity of the background as a percent. The range is 0% (completely 
transparent) to 100% (fully opaque).



Subtitle Mode
Subtitle Style Configuration

109

MacCaption User Guide

Japanese Ruby Subtitling
MacCaption uses the Ruby Annotation method to create positioning for Japanese 
characters. To annotate words or phrases with Ruby, highlight the text inside the cell 
you want to change and go to the Subtitle menu and select Ruby Annotation. The Ruby 
Annotation dialog opens.

 

This dialog shows the “Base Text" you have selected and provides the Ruby Text area for 
entry of the annotated Japanese text. If the base text is longer that the annotation, the 
Ruby text kerning will be automatically adjusted to fit within the spacing of the base 
text. This feature is specifically designed for Japanese language subtitles, it is not 
recommended for other languages.

To edit Ruby text that has been entered, select the text in the cell that contains the 
Ruby text. Go to Subtitle > Ruby Annotation. The Ruby Annotation dialog opens to 
allow editing of the text.

When exporting a program to iTunes .itt (which is in Export > Web/Mobile Standalone 
Files) the export dialog’s language value will be automatically be set to “ja” if Ruby text 
is in the program, or “en-US” when there is no Ruby text in the program. To use Ruby 
text in an export, the language value must indicate “ja” or a Japanese variant. 

For more information see Ruby Japanese Subtitle Formatting in the Glossary. 
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Exporting / Encoding

MacCaption has a variety of   exporting and encoding options, including formats for 
web and mobile video, DVD/Blu-ray, broadcast video formats for SD and HD, and so on. 
Depending on which version of the software you purchase, different features are 
available. 

See Comparing CaptionMaker & MacCaption Versions for a summary of the exporting/
encoding features in each version. See Export File Types for a detailed listing of all 
formats available for the different versions of MacCaption.

Topics in this chapter:

■ Embedding Captions into Video

■ Exporting Standalone Caption Files

■ Exporting Text Files

■ File-Based Delivery for Broadcast TV

■ Tape Delivery for Broadcast TV

■ Exporting Subtitles

■ MXF Export Workflow

■ H.264 and MPEG-2 Exports

■ QuickTime Podcast Captions

■ Export a Subtitle Overlay for Vantage®

■ Setting the Caption Data Lowest Limit
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Embedding Captions into Video
Captions embedded in video are typically used for broadcast video files such as ProRes, 
MPEG-2, and MXF. The captions are embedded directly into the video file instead of 
being saved to a separate file. MacCaption does not convert one type of video to 
another. This conversion is called transcoding and can be done in other Telestream 
software such as Telestream Cloud or Vantage. 

If you want to output, for example, an MPEG-2 file with embedded captions, you must 
provide an MPEG-2 video file in the desired format, and then MacCaption can embed 
captions into it.

To embed captions into a video file:

1. Have the video file loaded into MacCaption, and the associated captions edited, 
formatted, and finished.

2. Choose File > Export > Embed CC into Media and choose the desired format that 
works with the video loaded into MacCaption. The Save dialog opens.

3. In the bottom area of the dialog, select the options you want to use. The options 
vary, depending on the format selected. The following shows the options for a 
QuickTime format.

4. Select the location you want and click Save.

5. The Export Options dialog may open for the format you are using, or no dialog will 
open if additional options are not available. The options vary for different formats. 
The following is an example:
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6. Choose the settings you want, then click OK. A progress bar appears. The file is 
processed and completed.

7. If a message indicates that errors occurred, you can view them by going to 
Window > Message. 
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Exporting Standalone Caption Files
Many types of caption files are standalone, meaning the captions are in a separate file 
and not embedded into the video file. There are many different types of standalone 
caption files:

• For use on the web, such as Timed Text, WebVTT, and SRT (.srt) files. The type 
depends on the player being using on the web.

• Some are used in broadcast workflows, such as SCC (.scc) and MCC (.mcc).  (SCC is 
also used for DVD closed captioning.)

• Some are used for working with an NLE system, such as Final Cut Pro, Avid, and 
Adobe Premiere Pro. 

• Some are used for interchange with other captioners or captioning software, such 
as Cheetah, CAP, TDS, Ultech ULT, and so on.

See Export File Types for a full listing of all types of files. 

To export captions as a standalone file:

1. Have the captions loaded into MacCaption, edited, formatted, and finished.

2. Choose File > Export > [choose the appropriate file type] > [choose the desired 
format]. The Save File dialog opens.

3. In the bottom area of the dialog, if any options are available, select the ones you 
want to use. The options vary, depending on the format selected. The following 
shows the options for .scc files.

4. Change the file name, if you want to, or change the location by expanding the 
dialog using the down-arrow button. Then click Save.
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5. An Export Options dialog may open for the format you are using, or no dialog will 
open if additional options are not available for that format; the options vary for 
different formats. The Caption Data Lowest Limit dialog opens for .scc files. 

6. For information on settings, see Setting the Caption Data Lowest Limit. Choose the 
settings you want, then click OK. 

7. The file is processed and exported.

8. If a message indicates that errors occurred, you can view them by going to 
Window > Message. 
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Exporting Text Files
MacCaption has a number of different options available for exporting text files. The 
Export Options become available during a file export process.

To export a text file and select the export options:

1. Have the caption text loaded into MacCaption, edited, formatted, and finished. 

2. Go to File > Export > Plain Text File. The Save File dialog opens.

3. Change the file name, if you want to, or change the location by expanding the 
dialog using the down-arrow button. Then click Save. The Text Export Options 
dialog opens.

4. The Export Options dialog provides the following options:

• Include Caption Type Information. Inserts information such as POPON to indicate 
what type of captions the following lines are formatted in.

• Include Sequence Number. This inserts numbering information, in sequence, such 
as Caption Number 1, 2, 3 and so on.
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• Include Words Per Minute. Inserts words per minute of each caption, such as 450 
WPM.

• Include Starting Time. Inserts Start timecode of each caption, such as 
T 00:00:09:25.

• Include Ending Time. Inserts End timecode of each caption, such as E 00:00:01:24. 

• Put Text on One Line. All the text from each caption is placed on one line, regard-
less of how it is formatted in MacCaption. 

– Put Sequence Number on Text Line. Adds a sequence number to each text line. 

– Put Time Information on Text Line. Inserts the Start and End timecode before 
the text of each caption. It will look like this: 00:00:00:00 00:00:05:01 “caption 
text”.

– Text Line Break Character. Select the type of line break character you want: 
Space, Tab, \ (backslash), or Return.

• Insert Blank Line Between Each Caption. Spaces the caption lines by inserting a 
blank line between each caption.

• Remove Text Style Information. Removes style information from the text.

• Remove Text Color Information. Removes any text color information.

• Include CCaption File Header at Start of File. Inserts CCaption at the top of the 
text file.

• Encode Text as Unicode (UTF-16). Export text as a UTF-16 format file. Select this 
option when you are exporting for foreign languages. 

• Encode Output File in RTF Format. Exports the file in .rtf format. 
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File-Based Delivery for Broadcast TV
TV stations used to receive shows on tape, but most stations now use digital video files 
instead. Just as there were many different tape formats back in the day, such as BetaSP, 
DV, HDCAM, and so on, there are many different file formats that can be used for file-
based delivery, such as QuickTime, MPEG-2, and MXF. Most formats support closed 
captions in one way or another, but each workflow is slightly different. It also depends 
on what the TV station is using to play back the file. 

For example, many video servers installed at TV stations support playing back 
QuickTime video files, but this does not guarantee that they support the closed 
captions in QuickTime video files. Even if the captions seem to work on your end (such 
as playing them in QuickTime Player), this doesn't mean that the TV station can see the 
captions when played back on their server. 

There are actually several different types of captions that can be inserted into 
QuickTime files. Your station might accept all of them (if they use Telestream Vantage, 
for example), or only some of them, or maybe even none of them. You might have to 
use a different type of video file other than QuickTime, such as MPEG-2 or MXF, to 
ensure that they can read the captions.

Get the TV Station Spec Sheet
It is best to ask your TV station for a "spec sheet" and confirm with its engineers that the 
format you're using works for them. Make sure the spec sheet mentions specific types 
of captions that they support. Saying "QuickTime file" or "MPEG-2 file" isn't always 
sufficient, because there are many different types of captions that can be inserted into 
QuickTime files and MPEG-2 files.

Get a Sample Captioned Video File
If the TV station can't provide you a spec sheet, ask them for a sample file that contains 
closed captions which work for them. You can then examine the file to determine what 
types of captions are known to work.

Use Switch to Perform a Test
It is always a good idea to send the station a short captioned sample video and ensure 
that they can read the captions from your sample before proceeding with the full 
delivery.

We recommend using Telestream’s Switch to check that your video has captions, before 
sending to the station. Get it at http://www.telestream.net/switch/overview.htm

http://www.telestream.net/switch/overview.htm
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Overview of TV Formats
Here is an overview of the types of captions that can be used for broadcast TV files:

• Captions embedded into the video file:

– Closed Captioning track. An extra track of closed captions is added to the file. 
This is most often used with QuickTime files (QuickTime CC track) and MXF files 
(SMPTE 436m VANC track). However, not every server that can play QuickTime or 
MXF files is able to read this closed captioning track.

– User data captions. Captions are added as metadata into the contents of the 
file.  This is often used with MPEG-2 (ATSC DTV 608/708 captions), and 
occasionally with H.264 video (NAL SEI 608/708 captions), or DV video for 
standard definition (DV VAUX captions).

– Line 21 VBI. This is used for standard definition video only. The VBI line 21 
"Morse Code" dots-and-dashes are embedded into the top line of the video. The 
video resolution must be 720x486 for most QuickTime and AVI formats (rather 
than 720x480, which excludes the extra 6 lines of VBI where the captions go), or 
sometimes 720x512 for certain MPEG-2 formats.

• Sidecar caption file - a standalone file containing just the captions:

– SCC files are commonly used, but they contain 608 (analog) captions only. Make 
sure the station has a system that can upconvert this data into CEA-708 digital 
captions, such as using Telestream Vantage.

– MCC files are a next-generation improvement on SCC files, and contain native 
CEA-708 digital captions. They are supported by Adobe Premiere Pro CS5.5 and 
later, Blackmagic Hyperdeck, Manzanita muxers, Harris Nexio, and some other 
systems.

– Rarely, a station might ask you for a different type of caption interchange file, 
such as Cheetah .CAP, TDS, and so on.

– If the video will be shown on the internet, you may be asked to provide a web 
format caption file, such as SMPTE Timed Text (TTML), DFXP, WebVTT, and so on.  

Next Steps for Delivery to the TV Station
Once you have confirmed with a TV station what kinds of video files they can accept 
with captions, you need to export that type. Keep in mind that MacCaption is not 
transcoding software - that is, it does not convert one type of video file into another. 

If you're editing your video in NLE software, you may be able to export directly to the 
format you need (without captions), but not every NLE can export to every format. If 
you're starting with a QuickTime file and need to deliver a MPEG-2 file, you need to do 
some steps outside of the captioning software to create the MPEG-2 file first. Only then 
can MacCaption insert the captions into the MPEG-2 file. 

For transcoding, we recommend Telestream Cloud or Vantage software. Make sure you 
select the right bit rate and other specifications as required by the TV station.
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 Tape Delivery for Broadcast TV
Some TV stations still rely on tape formats for their receivables. MacCaption can be 
used together with your NLE system, such as Adobe Premiere, Avid, or Final Cut Pro, 
and a tape deck such as DV, BetaSP, or HDCAM to deliver a closed captioned video tape 
to the TV station.

Note that the following descriptions only apply when outputting to a tape deck via 
your capture card. These instructions do not apply when exporting a video file from 
your NLE system. For more information on file-based workflows for TV please refer to 
the previous section.

Adobe Premiere
Premiere versions CS 5.5 or later can use an MCC file to output HD digital captions via 
your capture card (such as AJA, Blackmagic, Matrox, and so on) to a tape deck, or a SCC 
file to output SD analog captions via your capture card or DV digital video via Firewire.

Avid Media Composer
Media Composer version 5 or later can use an Avid AAF file to output HD digital 
captions via your Mojo DX or Nitris DX hardware.  For SD analog output, you can use the 
MacCaption 720x486 line 21 overlay workflow.

Final Cut Pro
Final Cut Pro version 7 can use a QuickTime CC track to output HD digital or SD analog 
captions via your capture card such as AJA, Blackmagic, Matrox, or DV via Firewire.

Other NLEs and More Information
Most other NLEs that output SD analog video can use the 720x486 line 21 overlay 
workflow.

For more information on tape based workflows and how to check your captions after 
outputting to tape, please refer to the Telestream Knowledge Base. See the Support 
page in this guide for the web links.
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Exporting Subtitles
There are several ways you can export subtitles:

• Burn-in. This permanently combines the subtitles and the video. They can't be 
turned off, but you never have to worry about whether they will work or not.

• Overlay for Later Burn-in. If you're working with a video editor that wants to burn-
in the subtitles, you can send them an overlay file. They put the overlay into their 
NLE system and render the burn-in video from there. That way, the captioner 
doesn't need the full resolution master video from the editor.

• DVD/Blu-ray. Several prosumer and professional software packages for authoring 
DVD and Blu-ray discs can accept subtitle files. In this case the viewer can turn the 
subtitle tracks on or off. The type of file to export depends on which authoring soft-
ware is being used to author the DVD or Blu-ray.

Alpha-Channel Subtitle Overlay

When in Subtitle mode, MacCaption can export a MOV QuickTime file with just the 
subtitle graphics. This will be exported using the codec which provides the Alpha 
channel transparent overlay capability. 

To use this export:

1. Set the resolution size you want to export by using the Subtitle Movie Resolution 
menu. See Set Resolution With No Loaded Movie or for Export for menu options. 

2. Go to File > Export > Subtitles/Open Captions and select Black Movie with Subtitles. 
The File Save dialog opens.

3. Change the file name, if you want to, and select the location. Then click Save.

4. The file is processed and exported. 

5. Play the exported file to verify the placement and look of the subtitles.
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Subtitling vs. Teletext

EBU Subtitling Data Exchange Format STL (EBU-STL) is a widely used subtitle file type in 
Europe. It is designed to be used for both burn-in subtitle or to insert Teletext data into 
broadcast signals. 

EBU-STL imports and exports have support for Teletext Level 1 encoding, including 
Double Height characters and text foreground color.
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Creating the Open-Captions Look for Burn-In Subtitles

Subtitles can be created that look very similar to standard open captions. MacCaption 
can convert SCC or STL, and a variety of caption and subtitle formats, to burn-in 
subtitle-only graphics using ProRes 4:2:2 with Alpha channel. After the subtitle graphics 
are created as part of a MOV video file, they can be used with a non-linear editing 
system, or a transcoding platform such as Vantage, to render them on top of 
corresponding video files.

The following are recommended choices and settings to make subtitles look similar to 
open captions, for a 1920 x 1080 video:

1. Switch into Subtitle Mode by using the Caption/Subtitle switch. 

2. Adjust the font style by selecting Subtitle > Subtitle Configuration to open the 
Subtitle Configuration dialog. Make these selections:

a. Select the Courier New font from the Text Drawing selection box.
b. Set the font Size to the 42 to 54 point range, which is common for typical 

situations. 
c. Click in the Color box to open the Colors dialog, and set the color to White. 
d. Click OK to save settings and close the Subtitle Configuration dialog. 

3. Create a black box around the text to give the look and feel of standard closed 
captions on TV: 

a. Select Subtitle > Background Color. Set to Black, then click OK. 
b. Select Subtitle > Background Opacity and set this to 100 percent.

4. Go to File > Export > Subtitles/Open Captions and select Black Movie with Subtitles. 
The File Save dialog opens.

5. For Export Size click the Choose button. The Export Size Settings dialog opens.

6. Select the export size you want to use, and click OK.

7. Change the file name, if you want to, and select the location. Then click Save.

8. The Compression Settings dialog opens.

9. Make any other adjustments you want, then click OK.

10. The file is processed and exported. 

11. Play the exported file to verify the placement and look of the subtitles.
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MXF Export Workflow

This export is for OP1a MXF files, such as XDCAM HD and XAVC. The source file must be 
an OP1a MXF file containing your desired video codec, settings, and frame rate, as 
MacCaption will not transcode the video during the export, it will only insert a caption 
track.

The export clones the MXF and inserts a SMPTE-436M caption track in the MXF wrapper 
of the exported file. There is no transcode happening in this operation. The MXF files 
can then be played via Sony XDCAM VTR, Telestream Switch 1.5 or above, Adobe 
Premiere Pro CC, and many video playback servers such as Harris and Omneon.

In addition, V-chip, AFD, and XDS data can be added to the SMPTE-436M track during 
export.

If you need to transcode (convert) some other type of video file to XDCAM HD MXF, 
consider using Telestream Cloud or Vantage (or another 3rd party transcoding 
software).

To embed your caption into an MXF file:

1. Prepare and finish your captions project.

2. Go to File > Export > Embed CC into Media and choose MXF OP1a (.mxf). The Save 
File dialog opens.
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3. A dialog opens to choose the MXF input file.

4. Select the file and click Open.

5.  A dialog indicates the progress, and then the embed function is complete.

 

Checking the Captions in a MXF File
To play the video and captions together and verify for timing/sync, you can use the 
Telestream Switch application. Switch (version 1.5 and above) is one of the few 
applications that can play a wide range of captioned files.

Note that common video players such as VLC, Windows Media Player, QuickTime Player 
(any version), Sony XDCAM Viewer, and so on, do NOT display MXF closed captions of 
any type. So even if your MXF video will play in one of these players, it will not show the 
captions. 
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Playing XDCAM HD MXF files in the Preview Panel
MacCaption 8.0 uses AVFoundation which does not support the playback of MXF files 
in the media player window.

In previous versions of MacCaption (7.0.13 and earlier), MXF playback was possible by 
utilizing QuickTime 7 in conjunction with 3rd party decoder plugins. AVFoundation, 
however, does not support 3rd party plugins.

Note: Although the MXF file cannot be viewed in the MacCaption Preview Panel, you 
can still use the MXF file for caption embedding and extraction. In other words, you 
can still put captions into it or read captions from it even if you can't play it. 

Playing MXF Video in MacCaption with Captions in Sync
If you want to confirm that all of the captions were inserted correctly, you can re-import 
the captions back into MacCaption. Start by saving and closing any open project so you 
have a fresh blank project.

Please use the following process to view the captions in sync with the movie: 

1. Drag and drop the movie into the MacCaption Preview Panel. 

2. Import the captions by going to File > Import > Extract CC from Media and choose 
QCC Multi-format Import. 

3. Browse to select the file, then click Open. 

4. The captions are extracted and imported. 

5. Create a Proxy Movie. (See Using a Proxy Movie for information on creating a proxy 
movie.)

6. Import the Proxy Movie

7. Click the Preview Play button to play the movie in sync with the captions.
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H.264 and MPEG-2 Exports

The following H.264 and MPEG-2 exports are only available in the Pro and Enterprise 
versions of MacCaption. 

H.264 SEI 608/708
The H.264 SEI 608/708 Captions export is sometimes referred to in the industry as "NAL 
SEI 608/708 captions" or "ATSC A/72 DTV 608/708 H.264 captions". For this export, 
caption data is inserted into the H.264 codec. This is especially useful for customers 
delivering MP4 with embedded captions to Akamai's Sola platform. This is used for 
streaming H.264 files. The wrapper can be MOV, TS, or MP4. These extensions need to 
be specified when saving the output file. TS is Transport Stream, MOV is the QuickTime 
container, and the MP4 wrapper is good for multiple player compatibility. The 
extension tells MacCaption how to multiplex the media and is not just an extension 
naming convention on export.

This export can create MP4 (ISO Base Media Format) files if the output file is named 
.mp4; M4V format if the output file is named .m4v; and QuickTime MOV files if the 
output file is named .mov. These formats are all closely related but have some minor 
differences. In these cases, the source video prior to captioning can be any of the above 
formats, but it can not be a Transport Stream.

This export creates an MPEG-2 Transport Stream (with H.264 codec) if the output file is 
named with a .ts or .m2t extension. In this case the source video must also be a 
Transport Stream (not a MP4, MOV, and so on). This export creates a generic profile 
Transport Stream that is sufficient for many uses such as web streaming, however it 
does not meet the strict specifications required by some broadcasters, such as the 
CableLabs spec. Users who need strict control over the Transport Stream parameters 
should use another multiplexing solution such as Manzanita MP2TSME.

MPEG-2 User Data
The MPEG-2 Userdata 608/708 Captions export is similar to the "ATSC DTV 608/708 
Closed Captions (to MPEG-2)" export, in that it exports the same type of caption data 
into MPEG-2 Elementary, Program, and Transport streams. The resulting Closed Caption 
data is the same, but each export has some pros and cons, discussed below, which is 
why they are both available. The export extensions should be either .mov, .ts, or .mpg.

This is a faster mechanism than MPEG-2 ATSC export. There is only one pass required to 
insert the captions into the MPEG-2 user data or A/53 style. The extension affects the 
multiplexing mechanism on export.

This export creates a generic profile MPEG-2 Transport Stream without the use of 
Manzanita multiplexer software. These Transport Streams do not meet the strict 
specifications required by some broadcasters, such as those that require the CableLabs 
spec. However, for users who just need a generic Transport Stream, it may be sufficient.
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Users who need strict control over the Transport Stream parameters (including PIDs, 
muxrate, descriptors, and so on) should use the Manzanita-based workflow, that is, 
export "ATSC DTV 608/708 Closed Captions (to MPEG-2)" export together with a 
Manzanita multiplexer such as MP2TSMS. 

MPEG-2 ATSC Export and Manzanita
The ATSC DTV 608/708 Closed Captions (to MPEG-2) export adds userdata in A/53 into 
MPEG-2 Program streams or Transport Streams. Both 608/708 data are included in the 
export. If Manzanita Multiplexer is installed in the same computer (MP2TSMS, 
MP2TSME) then MacCaption can hand off the multiplexing part of the export operation 
to Manzanita. This is specially useful to deliver CableLabs compliant streams.

When creating Transport Streams there are three critical pieces of information to know: 
The video and audio PID numbers from the source file, and a Manzanita configuration 
file that matches your delivery spec. (Configuration files for CableLabs-compatible HD 
and SD files are included with MacCaption.)

The Video ID and Audio ID are determined by the source Transport Stream file. The 
configuration file depends on your delivery requirements. In many cases the default 
"CableLabs HD" configuration file works unless your target system requires a different 
setting.

• If you know your source file is already encoded for CableLabs, set and enable "Use 
Video ID" to 481 and set and enable "Use Audio ID" to 482. The source MPEG video 
must have already been encoded using these values, otherwise Manzanita will fail 
to demux the file. If your file was encoded with different IDs and/or you do not 
know the Video ID or Audio ID of your transport stream, please download MPEG 
Streamclip from www.squared5.com or use Manzanita MPEG ID to find the correct 
parameters. When you open the Transport Stream in MPEG Streamclip, you see the 
Video ID and Audio ID reported in the lower left corner of the window. These are 
the values you must set inside MacCaption.

• If you have a Manzanita configuration file it can be applied by selecting "Generate a 
Transport Stream using Manzanita software" and clicking "Configure". This feature 
is optional, and if left disabled Manzanita multiplexer will use the default CableLabs 
HD configuration for the multiplexing.

• Make sure your caption time codes match your MPEG-2 file. If you made the MPEG-
2 file from an NLE system then it might start at 01:00:00:00 or 00:00:00:00. If it was 
captured from tape or video server it could have an odd starting time code such as 
02:03:04:05. In any case your caption time codes need to match the MPEG-2 time 
codes within the file, otherwise the captions won't line up.
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MPEG-2 720x512 422P@ML Extreme Reach SD Delivery
This export is for a special 720x512 4:2:2 MPEG-2 format used by some distributors such 
as DG (DG Fast Channel), Pathfire, and Extreme Reach, and possibly others who use 
hardware made by Vela.

This export is for SD video only and incorporates the Main Concept engine to add VBI 
(Vertical Blanking Intervals) to the video. This is a render intensive process for these SD 
videos which are already in the MPEG-2 codec. There is a generation loss, but this can 
be minimized by using a higher bitrate option during export. This export is used by ad 
agencies to deliver to Extreme Reach.

To use this option, go to File > Export > Embed CC into Media and choose “CCIR 601/
4:2:2P@ML Movie with Closed Captions”. For detailed instructions on implementing this 
export, see the Telestream Knowledge Base. The web link is on the Support page in this 
guide. 
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QuickTime Podcast Captions
The QuickTime Podcast option embeds 608 caption tracks into MP4, MOV, 3GP, and 
M4V video containers. These containers are typically used for playing captions in 
QuickTime Player, ITunes, and iOS devices. It is recommended to apply the Podcast 
option to files that have the H.264 codec, but can be added to other codecs in the MOV 
container wrapper.

To use this option, go to File > Export > Embed CC into Media and choose QuickTime 
608 Closed Captions (FCP/Podcast/Web). The following File Save dialog opens:

Select the options you want, then click Save to create the export. 
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Export a Subtitle Overlay for Vantage®

Rendering burned-in subtitles (also known as open subtitles or open captions) into a 
video requires recompressing or transcoding the video, because the images are being 
changed. If you need to transcode the video anyway, it is ideal to insert the subtitles 
during the transcode step, instead of transcoding the video once to add the subtitles 
and then transcoding it again to the final format. Vantage has a Movie Overlay filter 
(listed under Video Filters) within the Flip action which can overlay subtitles on top of 
the source video during a transcode.

First, you need to create a subtitle overlay video. This is a QuickTime MOV that contains 
the subtitles only (no video) with an alpha channel transparent background so that it 
can be overlaid on top of the video image. See Alpha-Channel Subtitle Overlay for 
details on creating this subtitle overlay video. 

The movie can then be used in the Movie Overlay filter in Vantage. Set the Overlay Left 
and Top values to 0, with Width and Height values that match the source video. The 
path to the video can be hard-coded, or it can come from a variable. 

If you use the “Work Order” feature to submit a spreadsheet to Vantage, the variable 
that points to the subtitle overlay file can be one of the columns in the work order. This 
feature is handy if you want to transcode different versions of the same source video 
with and without subtitles, or multiple versions with different subtitle languages.
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Setting the Caption Data Lowest Limit
Setting the Caption Data Lowest Limit during export assures that all of the closed 
captioning technical data is placed into the actual video content area of the movie. The 
closed caption data for certain types of captions, such as Pop-on, must precede the 
display of the actual closed caption itself. For Roll-up and Paint-on closed captions 
some caption data is placed a few frames before the start of the caption display.

If you do not set a Caption Data Lowest Limit within the actual video content area, you 
may lose the first caption if the beginning of the video is edited to remove bars and 
tone, the slate, or the countdown.

The following shows an example of the Caption Data Lowest Limit settings dialog. This 
dialog is automatically displayed during the export process, for the appropriate file 
types.

The Caption Data Lowest Limit should be set to start when the actual video content 
starts. For example, If you are using pop-on captions and the movie time code starts at 
0:58:00:00, the actual video content starts at 1:00:00:00 and the first closed caption 
appears at 1:00:01:00, which is one second into the video content, the actual closed 
caption data is placed into the movie before the caption is scheduled to pop on at 
1:00:01:00. In this case you would set the Caption Data Lowest Limit to 1:00:00:00 to 
force MacCaption to begin putting the closed caption data into the movie no earlier 
than time code 1:00:00:00.

As with all closed captioning, be sure to verify the accuracy of your work by viewing a 
playback of the final product.
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All of the features described in this Automated Workflow chapter are only available in 
the Enterprise version of MacCaption. 

■ Overview

– Command Line Interface

■ Command Line Interface

– Embed Closed Captions into Media

– Extract Caption Data for Re-Purposing and Internet Media

– Bulk Frame Rate Conversion of Caption and Subtitle Data

– Flip Caption Documents between Various Broadcast or Internet Types

– Converting Caption and Subtitle Files to Burn-In Subtitles

■ -export=black_movie_subtitles -output=result.mov
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Overview
Automation is a great time saver and can handle much of the manual video file analysis, 
conversion, and repetitive tasks when you need to make sure content is properly 
transcoded and aired with accurate closed captioning. 

You can automate many high volume caption processing tasks, such as:

• Caption insertion and extraction.

• Format conversion.

• Time and frame-rate adjustment.

• Sub-clipping and clip assembly.

• Processing archives of video files. 

• Analyzing for quality assurance.

• Captioning data reporting.
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Command Line Interface 
MacCaption's Command Line Interface provides quick access to all of the parameters 
related to the necessary import, export, and processing options, and can greatly 
simplify custom tasks for technicians and operators. The MacCaption CLI scripts list the 
operating parameters in a logical and human readable way.

The Command Line Interface (CLI) is designed to be used with the Terminal application 
installed in Mac OS X, without needing to operate the MacCaption user interface. 
Software developers can also design mechanisms that will trigger these commands 
using 3rd-party applications and/or developer tools found in OS X.

The MacCaption Command Line Interface is very powerful and includes options not 
found in the Telestream CaptionMaker application for Windows. These powerful 
options that are exclusive to MacCaption include support for ProRes HD, caption 
embedding, and the Assemble Captions feature. 

Once a Command Line Interface script is created, the functions it is set to perform can 
be easily initiated by any operator or from other applications. A complicated operation 
in the MacCaption user interface can be simplified by writing a CLI script. This is very 
useful when the same operation is needed on a regular basis.

For complete details on all commands for the Command Line Interface (CLI) feature, see 
the MacCaption Command Line Interface document. Open this document from Help > 
Command Line Interface.

Embed Closed Captions into Media
Using the Command Line Interface (CLI) can simplify the process of inserting caption 
data into media files, such as MP4, MOV, and MXF. A script can be created to take a 
caption data file, such as .MCC or .SCC, and insert the data into a media file. 

The script must define the input caption file name and location, input media file name 
and location, and the type of caption data that needs to be inserted. Finally, the script 
must define the export file name and location, which will be the media with the 
inserted captions. 

Note: Embedding caption data does not convert the media file to a different format. 
It is imperative that the format of the input file matches the output file.

Sample Script to Embed Closed Captions into Media
The following sample script will import CC1 captions from a .SCC file and create a 
QuickTime Podcast movie:

./MacCaption.app/Contents/MacOS/MacCaption \

-import=scc -tcmode=29.97df -displaymode=caption -ioptions=A1 -
input=my_input.scc \

-movie=my_source_movie.mov \

-export=quicktime_podcast -output=my_podcast.mov
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Extract Caption Data for Re-Purposing and Internet Media
A Command Line Interface (CLI) script can be configured to find and extract various 
types of caption data and convert it for multiple uses. There are two basic ways to set 
up a CLI script to extract caption data from a media file:

a. Specific format. The script can specify the type of data it needs to find. For 
example, if a media file is MXF HD with a SMPTE 436M caption track as the known 
input file type, then the script can look for that specific data.   

b. Multiple formats. If the media files are in multiple formats and resolutions then 
the QCC Multi-Format Import option (QCC) can find caption data from a variety 
of video formats including, but not limited to, MXF, MPEG, MOV, MP4, M4V, TS, 
GXF, and LXF. 

Note: If the incoming video format can be identified and is consistent, then 
specifying the caption data type in the CLI script will speed up the time it takes 
MacCaption to read the caption data.

In addition to reading caption data from a variety of video files. The Command Line 
Interface can specify a language channel such as CC1 or CC3 during extraction. This 
helps users select alternate languages that may be embedded within the video media.

Typical Parameters for Extracting Caption Data
The following are some typical CLI parameters to use when reading embedded 
captions from video media:

-import=QCC 

QCC imports a variety of formats. Use a specific type for an individual format. See the 
Help > Command Line Interface document for a complete list, under the “Import 
Parameters” heading in that document.

-ioptions=options 

Where “options” can be a portion, or all, of the values “123456789hi” which specify the 
type of captions to import:

Use 1, 2, 3, and 4 for CC1, CC2, CC3, and CC4

Use 5, 6, 7, and 8 for CC1, CC2, CC3, and CC4 in DTV

Use 9 for 708 captions in DTV

Use h for KS C 5601 in Field 1

Use i for KS C 5601 in Field 2

The default is '1'

-input=input_file 

The “input_file” parameter is the input caption file name and location.
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Bulk Frame Rate Conversion of Caption and Subtitle Data
Automation and caption data frame rate adjustments can be applied to an entire 
archive of caption files using the Command Line Interface (CLI), such as .SCC and .CAP.   
This can be very useful when the input media files do not match the timing of the 
caption data. 

For example, caption files are generally timed for TV broadcast at 29.97 DF. When the 
media needs to be delivered in 23.98 fps the caption files will not be in sync with the 
deliverable, unless there is a timecode adjustment to change the frame rate of the 
caption file to match the 23.98 fps time base. 

Using the CLI for this process is extremely fast and hundreds of files can be processed in 
under a minute. In certain cases, caption data can be extracted from media files which 
contain sync issues and fixed using this automation.

Flip Caption Documents between Various Broadcast or 
Internet Types

TV caption data files, such as .SCC, can be converted to typical Internet caption files, 
such as SMPTE 2052 TTML and WebVTT, using the Command Line Interface.

Furthermore, caption data can also be extracted from media files and converted to 
Internet caption files. The main use of this automation is to do the conversion to 
Internet captions during a transcode, in a format that is acceptable to the content 
provider, such as iTunes, Netflix, and so on. 

The key point is that automated conversions can retain the positioning and formatting 
of TV captions, which is required by many video distribution services and United States 
legislation under the Communications and Video Accessibility Act (CVAA).
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Converting Caption and Subtitle Files to Burn-In Subtitles
Caption and subtitle files contain timecode, positioning, and text that can be converted 
by a Command Line Interface (CLI) script to MOV graphics for subtitle overlay, or burn-
in. See Exporting Subtitles for a description of overlay and burn-in files. 

The resulting black QuickTime MOV movie with subtitle graphics can be used in your 
NLE to combine with the video, or use Vantage to perform this operation in an 
automated workflow. 

A script can be applied to a an entire archive of .CCA files, or other caption and subtitle 
file formats, to create the desired look of the subtitle overlay.

Sample Script to Create Subtitle Overlay for Burn-In
This example provides a sample script that converts a .CCA (MacCaption Project file) 
into a subtitle overlay graphic. The custom font, font size, background color, opacity, 
and resolution of the subtitle graphics are represented by command line parameters.

The script performs the following actions: 

• When starting MacCaption, all preferences related to subtitle graphics are set to 
default values.

• Import the CCA file "sample.cca" into MacCaption's default text area, or Program A.

• Change the subtitle style settings to:

– 36 point Zapfino font

– Green text

– Red background with 50% opacity

• Change the pixel resolution for exported raster images to 1024x768.

• Using all of these settings, export a Black Movie with Subtitles from the current pro-
gram (A) and create the "result.mov" file.

MacCaption.app/Contents/MacOS/MacCaption -
omit_reading_preferences_file -s -inhibit_gui \

-import=cca -ioptions=Cc -input=sample.cca \

-command=set_current_program=A \

-subtitle_font=Zapfino -subtitle_font_size=36 \

-subtitle_fg_color=#00FF00 \

-subtitle_bg_color=#FF0000 -subtitle_bg_opacity=50 \

-raster_export_extents=1024x768 \

-export=black_movie_subtitles -output=result.mov
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Example Workflows

This chapter describes various workflows, such as those used for the web, mobile 
devices, video servers, DVD, and Teletext.

■ Live Caption Data Input into CaptionMaker

■ Sending Live Captions to a Telestream Lightspeed Live Stream Server

■ Captioning for the Web and Mobile Devices

– Post-Production (VOD) Web Captioning

– Live Web Captioning

– Web Formats with Closed Captions

■ File-Based Workflows

– Video Servers

– Transcoding Software

■ Creating a DVD or Blu-ray with Captions

– Multiple Languages on DVD

– Closed Caption File Format for DVD

– Subtitle Format for DVD

■ OP-47 and OP-42 Teletext Workflows

– Extracting OP-47 and OP-42 Teletext from Source Video Files

– Encoding OP-47 Subtitles into MXF Source Video Files

– Importing and Exporting MCC Files with OP-47 Teletext Data

– Inserting MCC Files with OP-47 Teletext into an MXF Source Video

– Exporting the OP-42 Alpha Channel VBI File

■ DirecTV GLA Subtitle File Export and Import

– Exporting a GLA File

– Importing a GLA File
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Live Caption Data Input into CaptionMaker

To create live caption data you need to configure CaptionMaker for the type of source 
being provided. The live caption data source can be anything supported by 
CaptionMaker. Typically, the source comes from one of the following methods:

• Retrieve Caption mode

• Live Caption mode

Retrieve Caption Mode
If you are already captioning live for broadcast (baseband feed such as SDI), you can use 
the Retrieve Caption mode to retrieve the captions from the baseband feed. To 
accomplish this, CaptionMaker must interface with a hardware encoder (such as an 
Evertz 9084HD), or a caption decoder/retrieval device (such as a Link LEI-599).

To use the Retrieve Caption mode, follow these steps:

1. Configure the connection to the caption publishing destination or device. For 
Internet destinations, such as YouTube, see Captioning for the Web and Mobile 
Devices.

2. To configure the retrieval device and connection settings in CaptionMaker, go to 
Caption > Retrieve Caption. 

3. Choose the device you want to use, then click the Configure button.

4. Configure the device settings, such as the COM port or IP address/port used to 
connect to the hardware device, and other options. Then click OK.

5. Enable your connection to the destination, and click the Start button in the 
Retrieve Caption dialog when you are ready to begin caption retrieval.
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6. As caption data is read from the baseband feed, CaptionMaker will forward it to the 
publishing destination in real time.

Live Caption Mode
You can input text directly into CaptionMaker using the Live Caption mode. To use the 
Live Caption mode, follow these steps:

1. Go to Caption > Live Caption Options to make any adjustments to the settings, if 
needed. See Live Caption Options for more information. 

2. Enable the connection to the caption publishing destination or device:

a. To select a device, go to Caption > Device. Select the Device, then click Configure 
to create to proper settings. For information on using the Telestream Lightspeed 
Live Stream server, see Sending Live Captions to a Telestream Lightspeed Live 
Stream Server. 

b. For Internet destinations, such as YouTube, see Captioning for the Web and 
Mobile Devices.

3. To change the text panel to live entry mode, select Live Caption from the Caption 
menu. The caption grid changes to a blank white text entry field. 
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4. You can use a keyboard or any keyboard-like device to enter text into CaptionMaker 
in real time, or use a speech recognition system. A stenographic device may need 
software configuration changes. Test your text input device to see that text is 
appearing in CaptionMaker. 

5. Enable your connection to the destination and begin text entry. The live text entry 
is sent to the destination if all settings are correct.

When a line of text exceeds the total characters per line set for a caption, the text 
wraps on the screen and the completed line is sent to the destination. You can also 
press the Enter key to force a line wrap and send a line at any time. 
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Sending Live Captions to a Telestream Lightspeed 
Live Stream Server

CaptionMaker can be used as the source of live caption input into a Telestream 
Lightspeed Live Stream server. The IP address of the Lightspeed Live server is needed, 
and settings must be configured in the Lightspeed Live Stream web application. 

To send live captions to a Lightspeed Live Stream server, follow these steps:

1. Obtain the IPv4 address of the Lightspeed Live Stream server. Here is one method:

a. Log into the Lightspeed Live Stream server. 
b. Click the Windows Start icon in the Lightspeed Live Stream server and type 

Command Prompt. Results of your search appears.
c. Right-click Command Prompt and select “Run as Administrator”. The Command 

Prompt window opens.
d. Type ipconfig and press the Enter key. Results appears. 
e. Write down the IPv4 Address. This will be used later in CaptionMaker.

2. Launch the Lightspeed Live Stream web application in a browser.

3. Configure Lightspeed Live Stream with the settings you want to use for the source, 
encoding, and channel output destination.

a. For live captioning input setting details see the “Using Live Captioning Input via 
IP” topic in the Lightspeed Live Guide. 

b. Complete the configurations and have the output Channel ready to start.
c. Make sure you have enabled the Captioning settings in the bottom of the 

Configure Channel dialog.

Note: A Captioning Stenographic Input entitlement must be added to the Lightspeed 
Live Stream license for the live captioning input features to be visible and active.
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4. Launch CaptionMaker, then go to Caption > Device and select Telestream 
Lightspeed Live.

5. Click Configure to open the Device Settings dialog.

6. In LAN Settings enter the IPv4 address of the Lightspeed Live Stream server into the 
Connection IP Address field.

7. Enter the Connection IP Port that is set in the Lightspeed Live Stream web app 
“Configure Channel” dialog. The default Port is 16161.

8. Click OK to close the Device Settings dialog.

9. Click Caption Properties in the Caption Device dialog to open the Properties 
options for the Telestream Lightspeed Live device. 

10. Make any desired changes on the Control, General, and Colors tabs, and click OK to 
confirm the changes, then click OK to close the Caption Device dialog.

11. To change the text panel to live entry mode, select Live Caption from the Caption 
menu. The caption grid changes to a blank white text entry field. 
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12. You can use a keyboard or any keyboard-like device to enter text into CaptionMaker 
in real time, or use a speech recognition system. A stenographic device may need 
software configuration changes. Test your text input device to see that text is 
appearing in CaptionMaker. 

13. In the Lightspeed Live Stream web app, click the Start button to start the Channel 
you have configured for captioning input. 

14. Click the Closed Captioning icon  in the upper right of the Live Stream web 
app to access a URL to view a preview of the stream for that Channel. In the dialog 
that opens, click the clipboard icon to copy the URL or click the arrow icon to open 
the link in a new browser window. 

15. Begin the live text entry into CaptionMaker. The captioning text data is sent to 
Lightspeed Live Stream and out to the publishing destination if all configuration 
settings are correct. 

When a line of text exceeds the total characters per line set for a caption, the text 
wraps on the screen and the completed line is sent to Lightspeed Live Stream. You 
can also press the ‘+’ key to send a line at any time. 

16. When your live broadcast is finished, click the Stop button in the Lightspeed Live 
Stream web app for the Channel. 
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Captioning for the Web and Mobile Devices
For web video, there are a number of different standards and types of video playback 
mechanisms: Flash, Silverlight, HTML5, QuickTime, HLS, HDS, MS Smooth Streaming, 
MPEG DASH, UltraViolet, and so on. To support a broad variety of different playback 
devices a provider may need to stream the video in multiple formats, because there is 
no single video format that is supported by every device. You may need to export the 
related captions into more than one of these formats.

Many mobile devices already support closed captions, although they require the 
captions in different formats depending on the device. With Telestream software it is 
easy to create captioned videos that work on multiple devices.

The iPhone and iPad are very common players for portable video and music media. The 
Apple devices support TV-style closed captioning in H.264 video files. Most Android-
based phones which support Flash can display Flash closed captions.

For additional information on captioning for the web and mobile devices, see the 
Telestream Knowledge Base on the Captioning Support page of the Telestream web 
site. 

Post-Production (VOD) Web Captioning
CaptionMaker supports a large number of formats for captioning video files for video 
on demand (VOD) on the web, including:

• SMPTE Timed Text (SMPTE 2052): A new standard for captioning for both broadcast 
and the web, also for UltraViolet (DECE CFF format).

• WebVTT: Another new standard for captioning and subtitling web videos, fre-
quently used with HTML5 and Apple HLS streaming.

• H.264 SEI Embedded CEA-608/708 Captions: Used for Akamai and Wowza VOD 
streaming, and other systems that support embedded 608/708 captions inside the 
video stream.

• DFXP (TTML): Used by many Flash players and providers such as Brightcove, Lime-
light, Flowplayer, JW Player, and so on. 

• iTunes Timed Text (iTT): Used for delivery to iTunes.

• SRT: Supported by many Flash players and also YouTube, however this format does 
not carry any positioning or formatting information, just plain text and timing.

• SCC: Supported by YouTube and some other web video players.

• QuickTime Closed Captions Track: Apple devices and browsers can play closed cap-
tion tracks embedded into QuickTime MOV and MP4 files, which mimics the look 
and feel of TV broadcast captions

With the exception of QuickTime Closed Captions Track and H.264 SEI Embedded CEA-
608/708 Captions, all of the other above formats are sidecar files, meaning the 
captions/subtitles are delivered as a separate file rather than being embedded into the 
video file.

www.telestream.net/telestream-support/captioning/support.htm
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Live Web Captioning

The difficulty with live web captioning is how to get the caption data from the source 
(broadcast feed, and so on) to the end user. Most web streaming encoders and web 
technologies are designed to convey only video and audio, not captions. The following 
services provide captioning options.

YouTube Live Captioning
Live captioning for a YouTube event must be configured in YouTube, using the control 
panel for the live event. When captioning is enabled, a "Captioning URL" is provided to 
you by YouTube.

Note: You must use a video streaming application, such as Telestream’s Wirecast, to 
send the live video to YouTube. CaptionMaker sends only the text stream of the 
captions to YouTube. See YouTube help for instructions on merging the video and 
caption text streams, and other required settings. 

Steps to configure CaptionMaker for live YouTube captioning:

1. Start CaptionMaker (requires Pro or Enterprise version).

2. Go to the Web menu and select YouTube Live Connection Options. 

3. Copy and paste the "Captioning URL" provided by YouTube into the connection 
URL field.

4. The remaining options can be left at default. Click OK.

5. When ready to engage the connection to YouTube, go to Web > YouTube Live 
Connection. This is a toggle that, when enabled, will establish the connection to 
the YouTube servers.

6. Now, any live caption data input into CaptionMaker is forwarded to the YouTube 
servers. To create the data, see Live Caption Data Input into CaptionMaker above. 

7. When the event has finished, go to Web > YouTube Live Connection to toggle the 
connection off.

Roll-Up Live Captions Not Supported by YouTube Live
As of January 2016, YouTube Live does not support roll-up captions for live input and 
instead automatically converts text streams to pop-on, 2-line captions. This means that 
CaptionMaker must format the captions in a way that does not cause two words to be 
put together during line breaks. The line breaks in normal roll-up captions and 2-line 
captions are different and therefore do not have an extra space between each line 
during conversion. CaptionMaker adds that space by default in order for the roll-up text 
stream to be converted without causing text errors. 

Note: Regular YouTube uploaded videos do support roll-up captions. 
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Uvault Live Captioning
Uvault, a live streaming provider and content delivery network, has added closed 
captioning support to their network. CaptionMaker can send the captions to Uvault's 
servers, which then delivers them to the end users along with the video. To send live 
captions to Uvault, follow the steps provided in YouTube Live Captioning, except using 
the Web > Uvault menu options. 
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Web Formats with Closed Captions
There are many formats for the web that have the ability to display closed captions. 
CaptionMaker can easily extract and convert closed captions to any required format, 
frame rate, or time code adjustment. This can also involve editing the video to remove 
commercial breaks or shorten the duration. CaptionMaker can make use of an edit 
decision list (EDL) from your editing system to automatically conform the original 
captions to the new web version. 

Flash Closed Captioning
Adobe CC, Flex, Flow Player, JW Player, Hulu, and the Captionate plug-in support closed 
captioning files for the web. Flash video has a wide range of different custom video 
players. There are a variety of caption file formats that Flash video can support. They 
include .SRT, DFXP Timed Text .xml, SAMI .smi, Captionate .xml, and embedded .FLV 
with captions. Telestream software can export any of these file formats to support a 
variety of custom video delivery websites. 

QuickTime Closed Captioning
Telestream software provides the best workflow for inserting closed captioning or 
subtitle tracks into QuickTime files. These work not only in QuickTime Player on your 
desktop, but also in a web browser or on Apple mobile devices.

YouTube Closed Captioning
It is easier than ever to caption web videos through YouTube. Not only does YouTube 
have a speech recognition engine to help transcribe your video, but also an automatic 
time stamping tool to synchronize an already existing script. If you need the 
transcription to be perfect it is best to type it out manually in a word processor and 
upload a .txt file alongside your video to YouTube. This will result in accurate captioning 
text. However, there are times when you may have a closed captioning file or tape that 
already has captions but needs to be converted to a video that can be uploaded to 
YouTube. 

Telestream software can quickly convert your TV closed captioning file or tape to the 
.SRT format that is native to YouTube. YouTube accepts other captioning file formats, 
such as SCC, WebVTT, DFXP, SAMI, and EBU-STL.

iTunes Closed Captioning
iTunes software for Mac and Windows has the ability to display closed captioning for 
iTunes videos, including video podcasts and iTunes U. All you have to do is add closed 
captions to a QuickTime .mov or .m4v file. The closed captioning in these iTunes files is 
called closed caption tracks for QuickTime. Create this closed caption track quickly and 
easily by embedding them from any caption document or already captioned video into 
the QuickTime .mov, without re-compression or generation loss. You can also take 
existing video podcast archives that you are hosting and add closed captions to them 
using batch processing



Example Workflows
Captioning for the Web and Mobile Devices

150

CaptionMaker User Guide

Windows Media Closed Captioning
If you are delivering captioning content to an all-Windows audience then Windows 
Media closed captioning could be the most compatible option. Windows Media can 
read the captioning either from a separate SAMI (.smi) file or from an embedded .wmv 
file with captioning. Telestream software can generate either one of these options for 
Windows Media servers needing to deliver accessible video content. 

Akamai Sola Sphere Captioning
Telestream software can automatically convert TV closed caption data to web closed 
caption data, which can then be streamed in HD quality by Akamai. Any organization 
with a large number of archived captioned video files can reduce captioning 
operational time and errors by using batch processing mode to convert all the files in a 
folder to desired web captioning formats.
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File-Based Workflows
CaptionMaker can embed closed captioning directly into files, including MPEG-2 
Program and Transport Streams, MXF, QuickTime, MCC, and many more. It supports 
broadcast video servers, such as Harris Nexio, Omneon, SeaChange, Avid Airstream, as 
well as Manzanita's multiplexers for VOD CableLabs spec.

Delivering a closed caption file in the correct format depends on the kind of system or 
software that will be used to play or process the file on the receiving side. When 
confirming the delivery specs with your facility or client, here are some good questions 
to ask:

• What kind of server or software process will they be using to ingest (import) the file 
that you send them. Example answers could be: “We will be ingesting the file into 
our Omneon playback server”, or “We are going to put the file in our Final Cut Pro 
system and output to tape”, or “We use Telestream Vantage to transcode the file to 
XYZ format”, and so on. 

• What are the detailed specs of file type(s) they can accept with closed captions, 
such as wrapper/stream type, codec, resolution, frame rate, and bit rate.

Video Servers
The following provides some information about typical video servers. 

Omneon
Omneon servers support different kinds of media files, depending on the options 
installed on the server:

• XDCAM HD-type MXF files with SMPTE 436M Closed Captions (CaptionMaker only).

• XDCAM HD codec MOV files with internal MPEG-2 Closed Captions (MacCaption 
only).

• DV/DVCPRO (DV25/50) codec MOV files with internal VAUX Closed Captions.

Harris Nexio
'Harris Nexio servers with software version 5.71 and later, can use the MCC file format 
generated by Telestream captioning software for HD closed captioning.

SeaChange
SeaChange servers can use XDCAM HD-type MXF files with SMPTE 436M Closed 
Captions, or DV25 (standard def ) video with DV VAUX closed captions.

DG Fast
Depending on your specific drop box for DG Fast, they may require either MPEG-2 
Program or Transport streams with embedded closed captions for HD. For SD, they use 
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the 720x512 MPEG-2 format, also supported by Telestream captioning software using 
the MainConcept plug-in.

Transcoding Software
Many facilities use a variety of transcoding solutions, such as Telestream Cloud or 
Vantage, in order to accept a wide variety of file formats and convert them to the 
preferred format. You should check to see if the transcoder being used preserves the 
closed captions embedded into the video file. In many cases, it can accept an SCC or 
MCC file with closed captions as a separate file. Or, you may need to identify the "final 
destination" format used by the facility, and provide that file type with embedded 
closed captions.
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Creating a DVD or Blu-ray with Captions 
When your video and caption files are exported and ready for the final DVD Master with 
closed captioning, you create the DVD using DVD authoring software. Many consumer 
DVD burning software products do not have the ability to make a captioned DVD, so 
special "prosumer" or professional authoring software must be used. For prosumer 
options we recommend Sony DVD Architect Pro (Windows) or Apple Compressor 4.2 
(Mac). You can use Adobe Encore or Apple DVD Studio Pro (Mac), if you have them, but 
they are not currently released. All of these software packages can accept a SCC caption 
data file to merge with the DVD video. 

The standard format for a caption data file is the SCC (Scenarist Closed Caption) file. 
This caption data file is created with CaptionMaker and can be imported into DVD 
authoring systems. The captioning text cannot be checked until the DVD is compiled 
and/or burned. For best results, it’s important to use a set top DVD-Player connected via 
analog connections to a TV, such as S-Video or Composite (RCA), since HDMI and 
Component connections don't support closed captions.

Note: The Blu-ray specification does not support closed captioning. However, you 
can create an SDH subtitle track to mimic the look and feel of closed captioning.

Multiple Languages on DVD
After you have subtitled or captioned a video in one language and obtained the time 
codes, the same time codes can be used for subsequent languages. A translation 
prepared in a captioning file format can then be used to subtitle or caption in 
additional languages.

A DVD can contain closed captions in up to six languages: English, Spanish, French, 
Portuguese, German, and Dutch. CaptionMaker can produce closed caption (.cc or .scc) 
files for all of these six languages.

For subtitles, a DVD disk can contain up to 32 different languages. Telestream software 
can produce subtitles in almost every language, from Arabic to Zulu, using any Unicode 
font. This gives you a large number of languages from which to choose.

Closed Caption File Format for DVD
A DVD closed caption file is a binary file consisting of a number of lines - one line for 
each closed caption. Each line starts with a time code which is separated from the 
closed caption data (in binary format) by a tab character.
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 Subtitle Format for DVD
CaptionMaker creates as many files as the number of subtitles, and also a navigation 
file. The navigation file lists details (time code, size, and position) of each subtitle.

The first item on a line is the name of the graphic file, which is a picture file of a subtitle 
using a TrueType Windows font. The next two items are the in and out time codes of a 
subtitle. The following two items after that are width and height of a subtitle. The last 
two items are the position of a subtitle on a 720 x 480 screen.
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OP-47 and OP-42 Teletext Workflows 

The following describes how to extract, encode, or export OP-47 and OP-42 Teletext 
data, and provides information on using MCC files that contain this data. For additional 
information see Teletext in OP-47 and OP-42 in the Overview chapter. 

Extracting OP-47 and OP-42 Teletext from Source Video 
Files

To extract OP-47 and OP-42 Teletext, you can use the QCC Multi-format import option. 
CaptionMaker can extract OP-47 Teletext from XDCAM HD and AVCINTRA100 .MXF 
OP1a file types. OP-42 is SD only. 

To extract OP-47 and OP-42 Teletext:
1. Go to File > Import. The Import File dialog opens.

2. In File Type select Extract From Video. 

3. Choose “(Retrieve CC/Teletext) QCC Multi-format Input” from the drop-down list. 

4. Under File Name, click Browse to select the input file. Click Next.

5. In the next screen select "Teletext Service: Teletext Subtitles" in the Select Caption 
Service to Import parameters. 
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6. In the Teletext Page field, you can enter the magazine and page number to extract 
from the MXF source file. The default is 801, and another common option is 888. 

 

7. Click Finish to start the extraction process. 

Note: As an alternative, users can also extract OP-47 HD Teletext from MXF files using 
the dedicated MXF import option "(Retrieve CC/Teletext OP47) MXF (*.mxf)”. 
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Encoding OP-47 Subtitles into MXF Source Video Files 
CaptionMaker can insert OP-47 Teletext subtitle data into the SMPTE 436M track of MXF 
OP1a files. The supported MXF files must be either 720P or 1080i/p with XDCAM HD 
specifications (MPEG-2 essence video). In addition, they must have a video frame rate of 
25 fps or 50 fps, because Teletext only supports these frame rates. There is an export 
option to select in order to embed OP-47 Teletext data into MXF. 

To embed your Teletext data into MXF files, follow these instructions:

1. Prepare and finish your subtitle project.

2. Go to File > Export. The Export File dialog opens.

3. Select File Type > Embed Into Video. 

4. Choose “(Encode Teletext OP47) MXF (*.mxf)” from the drop-down list. 

5. Under Input File Name, click Browse to select your source MXF file.

6. Under Output File Name, select a path and set the name for the new captioned 
MXF file.

7. Click Next.

8. In the next screen you can select the Teletext Subtitle Page, VANC Line F1, VANC 
Line F2, VBI Line F1 and F2, the Filler Type, and the option to have "Double Height" 
characters. See Understanding the Teletext OP-47 Export Options below for 
information on these settings. 

  

9. Click Finish to save your selections. 
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10. You are then prompted by the "Select Starting Time Code" dialog to select the 
starting timecode for the first frame in the video file. Choose the start time that 
corresponds to your CaptionMaker project, by selecting the starting time that will 
sync to your first caption/subtitle in the CaptionMaker text grid.

11. The last option is to add Active Format Description (AFD) to your SMPTE 436M track 
in your MXF. This is optional and should only be used if required by a broadcast 
facility. 

Understanding the Teletext OP-47 Export Options
The Teletext Subtitle Page value should be set to the standard magazine “8”. This is 
the first digit in the parameter, so a setting of 801 will indicate magazine 8 and page 01.   
Samples of MXF files from broadcasters have included single language Teletext 
subtitles in either 801 or 888. Please refer to your TV station's delivery requirements to 
select the appropriate magazine and page number before embedding and delivery of 
OP-47 MXF files.

VANC Line F1 (field 1) is set to line 12 by default. This means that SDI hardware 
baseband playout of the Teletext OP-47 data will be mapped to line 12 (Line 9 is used 
for 608/708 captions). A different line for VANC data can be specified into the SMPTE 
436M track of the MXF file, but is not standard and should only be used when it is 
required. 

VANC Line F2 (field 2) should only be used with interlaced video that has field 2 data. 
Progressive video source files should set this parameter to "0", which is disabled. Setting 
VANC Line F2 is optional and should be done if required. 

VBI Line F1 (field 1) is one of the Teletext OP-47 standard definition Vertical Blanking 
Intervals for specific downstream applications. The value used for VBI Line F1 is 
typically 21 or 22. The available range is 7 to 22. 0 = disabled. The default value is 0. 

VBI Line F2 (field 2) is one of the Teletext OP-47 standard definition Vertical Blanking 
Intervals for specific downstream applications. VBI Line F2 is often set to 0, or disabled. 
The available range is 320 to 335. 0 = disabled. The default value is 335. 
Note that 335 is line 22 for Field 2. 

The Filler Type controls what gets encoded into the spaces between the subtitle 
“bursts”. The default is Packet 31 Test Data, and the other options are Null Page Headers, 
and None (No Filler). 

Note: Inserting a constant stream of Packet 31 ‘ExtTest’ data between subtitles keeps 
TVs at a constant gain rate, ensuring accurate reception and display of subtitles

National Option Sub-Set provides the option to choose National Option English or 
National Option Portuguese/Spanish for the export. 

Double Height refers to the size of the characters. Selecting this option will result in a 
bigger font size for the text when viewed with a Teletext decoder on a broadcast TV 
monitor.
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Importing and Exporting MCC Files with OP-47 Teletext 
Data

To import an MCC file containing OP-47 Teletext data: in the Import File dialog choose 
TV caption Files and select “MacCaption MCC 608/708 (*.mcc)” from the File Type drop-
down menu. Then select “Teletext Service: Teletext Subtitles” in the next screen.

When exporting an MCC file containing OP-47 Teletext data: in the Export File dialog 
choose the “TV Caption Files” file type and select "MacCaption MCC Teletext OP47 
(*.mcc)” from the drop-down File Type menu. 

Under Export Options in the next screen, select the appropriate magazine and page 
number for the OP-47 data that will be added to the MCC file. See Understanding the 
Teletext OP-47 Export Options above for more information on the settings. 

Inserting MCC Files with OP-47 Teletext into an MXF Source 
Video

CaptionMaker can also directly insert OP-47 Teletext data from an MCC file that 
contains OP-47 data into an MXF OP1a source video. This means that it's a direct 
conversion and does not import the MCC OP-47 into the CaptionMaker project.

To insert the MCC OP-47 data into an MXF file: in the Export File dialog choose the 
"Embed Into Video" File Type and select "(Encode CC/Teletext) MCC to MXF (*.mxf)” 
from the drop-down File Type menu.

Exporting the OP-42 Alpha Channel VBI File
The OP-42 export creates a QuickTime animation black movie with alpha channel VBI 
file. This file is used with Vantage or other transcode and editing systems to render the 
VBI into an MPEG IMX SD .MXF file.

Note: OP-42 is SD only and the project should be set to PAL 25 FPS.

To create the OP-42 export, go to File > Export and select “Embed into Video” in the 
Export file dialog, then choose "(Encode Teletext OP42) Black QuickTime 720x608 for 
NLE (*.mov)" from the drop-down menu. Set your output file name and click Next.

Change settings as needed in the next dialog, using the same page numbers as Teletext 
OP-47, then click Finish to continue. In the next Compression Settings dialog, you must 
only choose Animation, then click OK to export. 
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DirecTV GLA Subtitle File Export and Import 

The Direct TV GLA file type is based on the .SCC (Scenarist Closed Captioning) file 
format. The main difference is that the CEA-608 data is modified to meet special 
subtitle style formatting that is supported by Direct TV cable systems and set-top 
boxes. The exported file will have a .GLA file extension and is designed to be used with 
a Vantage transcode service in order to insert the GLA caption data into a video media 
file. 

Exporting a GLA File
Before exporting the GLA file, CaptionMaker must be set to encode the specific 
modified caption data for this export type. 

Follow these steps to enable the GLA encoding:

1. From the Caption menu select Device. The Caption Device dialog opens.

2. Select DirecTV GLA from the Device drop-down list. Press OK to use the selected 
device. 

3. Once the device is set to DirecTV GLA, go to the File menu and choose Export. The 
Export File dialog opens.
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4.  Select the Subtitle file type, then choose “DirecTV GLA Subtitle File (*.gla)” from the 
drop-down list. 

5. In Output File Name click the Browse button to choose the location and set the file 
name. Use the .GLA file name extension and press Next. 

6. Choose the Select Time Code String Format: 

a. For drop frame projects select Semicolon. 
b. For non-drop frame projects select Colon.

7. Press Finish to start the export. 

Note: For this type of caption file, it is essential that every caption has enough time to 
process. If a caption has a large amount of characters, it needs more time to process 
the data. 
If two large captions are timed too closely to each other, there will be a time overlap 
and the file could contain errors. For this reason, It is essential that you do a Final 
Check, to verify that enough time is specified to send each caption, using a time code 
tolerance of 0 frames. 
If your caption timing is very tight, it is recommended that you uncheck "Duplicate 
control codes when sending captions" in the Caption > Properties dialog.



Example Workflows
DirecTV GLA Subtitle File Export and Import

162

CaptionMaker User Guide

Importing a GLA File
To import GLA files, the DirecTV GLA device does not need to be selected. However, 
CaptionMaker must be set to import CC1 EIA-608 services from the GLA file.

Follow these steps to import a GLA file:

1. From the file menu select Import. The Import File dialog opens.

2. Select the Subtitle Files type, then choose “DirecTV GLA Subtitle File (*.gla)” from 
the drop-down list. 

3. Click the Browse button to locate the file you want to import. 

4. Press Next to proceed to the Import Options dialog. 

5. Make sure that CC1 is selected for Field 1 EIA-608 Services (CC1 is the default).

6. Press Finish to import the file.
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This chapter describes the MacCaption menus. 

■ MacCaption Menu

■ File Menu

■ Edit Menu

■ Display Menu

■ Caption Menu

■ Subtitle Menu

■ Time Code Menu

■ Format Menu

■ Transcription Menu 

■ Special Menu

■ Window Menu

■ Help Menu
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MacCaption Menu
About MacCaption
Opens the About MacCaption dialog. The dialog displays the version number, your 
edition, Telestream contact details, and other information. 

Preferences 
(Command+,) Opens the Preference dialog, which contains four tabs. 

General Tab

 

• Preserve Movie Timecode. Preserves the current movie's time code when import-
ing closed captions and calculating caption offsets and positioning. If this option is 
not selected, a starting time code of 00:00:00:00 is used. A movie's starting time can 
be changed with the Set Movie Time option in the Special Menu.

• Open Last .cca File on Program Launch. When starting MacCaption, opens the 
last project file that was in use.

• Adjust Video Timing in FCP Captured Movies. Adjust video timing, if necessary, 
when importing files produced from Final Cut Pro.

• Auto Save a Copy Every __ Minutes. Enables periodic saving of your project every 
number of minutes set.

• Message Window 

– Log messages to disk file. Enables the saving of Message Window contents to a 
log file. Click Set File to choose the location and file name to use for the log file. 

• Caption Timecode Sync Function Key. The default function key for time code 
sync is F1. You can assign any function key of your choice.
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• User Time Stamp Frame Adjustment. This feature can compensate for your reac-
tion time when pressing the Time Stamp button—as long as your reaction time is 
consistent. For example, if you consistently press the Time Stamp button 10 frames 
after the time it should ideally be pressed to sync the audio and captions, then set 
the time frame adjustment to –10. The software will automatically subtract 10 
frames from the time code each time you press the Time Stamp button, thereby 
compensating for your 10 frame lag time. 

CAUTION: If there are multiple users of MacCaption and each has a different reaction 
time, you should reset the Time Stamp Frame Adjustment to zero after each session so 
as not to throw off the timing of the next user. 

• Scratch Directory 

– Current Directory. The currently set path and scratch directory is displayed. 

– Set Directory. Click to set the folder on one of your local hard drives which is 
used as the scratch disk. This folder is used for temporary files during some disk 
intensive import and export operations.

Display Tab
The Display Tab sets preferences for the MacCaption user interface operation. 

 

• Play a Sound When a Long Operation Completes. Plays system chime when an 
operation takes longer than 2 minutes to complete. 

• Selected Text Cell Background Color. Sets the background color of the currently 
selected text cell(s). 
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• Text Editing Font. Sets the text editing font and size for each program.

– Program. Choose the program for which you want to change the font or size. 

– Font. Choose the text editing font to use for the selected program.

– Size. Choose the text editing font size to use for the selected program.

Note: An example of the selected font and font size is shown above the Font and Size 
selection fields. 

Errors Tab

Provides options to control the type of errors that are reported for individual captions 
and subtitles in the text panel. All errors are disabled by de-selecting the Show Errors 
check box.

• Show Errors. When checked, the selected errors are displayed. When not checked, 
all error messages are disabled. 

• Line is Too Long. Display an error message when a caption is more than 32 charac-
ters in length, or a subtitle is more than 68 characters in length.

• No Starting Time. Display an error message when the caption does not have a 
starting time.

• Time Out of Sequence. Display an error message when the caption timecode is 
out of sequence.

• Lines in Caption Exceed. The caption has more than the specified number of lines 
(the default is 4).
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• WPM is Higher Than. Display an error message when the caption has more words 
per minute than the maximum number specified in the field. 

• Caption Duration More Than. Indicates an error when the caption duration is 
greater than the maximum specified. 

• Caption Duration Less Than. Indicates an error when the caption duration is less 
than the minimum specified.

• Caption Times Overlap. Indicates an error when the Erase Time of the current cap-
tion extends into the next caption

• Illegal Closed Caption Character. Indicates an error when a character that is not 
allowed in 608 captions is detected in a caption, when in caption mode. 

• Caption Overlaps Scene Transition. Enables scene detection errors to indicate if a 
caption overlaps a scene transition such as a cut or dissolve.

• Non Optimal Character Sequence. Indicates unusual formatting errors, such as a 
non-italics space between two italics words, and so on.

• ATS Confidence is Below. Provides a warning when the estimated Auto Time 
Stamp timing operation confidence is below the specified percent.
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NLE Tab
Video non-linear editing (NLE) systems from different vendors require specific values to 
generate proper closed-caption image data files. The information in the NLE Tab is not 
used when MacCaption adds closed captions to Digital Video.

Note: For information and more details on specific NLE settings, see the Knowledge 
Base for MacCaption on the Telestream website. 

 

• Primary Row (0-484). The primary row number where closed caption (field 1) data 
is placed. Field 2 data is placed on Primary Row + 1. The Primary Row data value 
must be between 0 and 484 inclusive for NTSC (0 and 574 for PAL).

• Starting Column (14-39). The column offset for the center point of the first closed-
caption clock run-in bit. The Starting Column data value must be between 14 and 
39 inclusive.

• Small QuickTime. Select to allow the generation of QuickTime data files that reuse 
a previously compressed image frame. For example, the QuickTime frame corre-
sponding to the closed-caption binary values of “0, 0” occurs fairly often in a 
closed-caption QuickTime movie. With Small QuickTime selected, when a second 
“0, 0” frame is about to be compressed a pointer is built into the QuickTime file that 
references the previously compressed “0, 0” image frame. The use of the previously 
compressed image frame saves both the time needed to compress the image as 
well as the space needed to store it. A QuickTime movie file created in this manner 
is significantly smaller in size than one created without this option, however, not all 
non-linear editing systems are able to display video that is composed with this type 
of previously referenced frames. 
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• Use 0 IRE YCrCb Levels for 4:2:2 Video. Change luma from 16 to 0 for native 4:2:2 
video. Checking this option will make line 21 CC IRE levels incorrect for all but 
native YCrCb output. 

• NLE Values Set To. This menu contains specific presets for various NLE hardware 
systems. For example, select Avid ABVB when using an Avid Media Composer with 
the ABVB hardware board set, select Avid DS for an Avid DS system, select Avid 
Meridien for an Avid NLE with the Meridien hardware board set, select Blackmagic 
DeckLink Extreme or Media 100, and so on. 
AJA KONA can be used for Final Cut Pro. Blackmagic DeckLink or Matrox DigiSuite 
can be used for Adobe Premier Pro. 

• Set Current Values as 'My NLE'. MacCaption can be configured for additional NLE 
systems by directly modifying the Primary Row and Starting Column data fields in 
this NLE Tab. The Set Current Values as 'My NLE' button copies the current Primary 
Row and Starting Column NLE settings into the 'My NLE' setting where they can be 
modified.

Services
Make changes to services, if any apply. 

Hide MacCaption
(Command+H) Select to hide MacCaption.

Hide Others
(Option+Command+H) Select to hide everything on the screen other than MacCaption.

Show All
Select to show all windows that were hidden.

Quit MacCaption
(Command+Q) Select to quit MacCaption. 
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File Menu

New Window
(Command+N) Open a new window when there is not currently a window open. 

Open Project
Opens the Finder so you can choose an existing .cca project to open.

Open Movie
(Command+O) Opens the Finder so you can choose a movie to open. If a movie is 
currently open you need to close it first by selecting Close Movie or Close Project. 

Note: You can also drag and drop a movie file into the video preview panel. 

Open Recent
You can choose a recent project file to open. 

Close Window
(Command+W) Closes the current window.

Close Project
(Option+Command+W) Closes the current project.

Close Movie
(Shift-Command+W) Closes the current movie.

Save
(Command+S) Saves the current project.

Save As
(Shift+Command+S) Save a new version of the current project. 

Properties
Opens a dialog that displays some properties for the current project. 
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Import
Imports captions/subtitles from a vast number of file types. You can import text from 
caption files, subtitle files, document files, or extract captions from a variety of video file 
types. 

Note: You can also drag and drop files directly into the interface. Text and caption 
files go into the Text Panel, and movies into the Video Panel.

• Last Import Operation. (Command+I) Shows the last import operation performed. 
This makes it easy to initiate the same one again. 

• MacCaption Project (.cca). Import a MacCaption project file.

• For Multiple Language. Import a file that is used for adding languages to the 
caption project. The default options are ones typically used for multiple language 
captioning. See Multiple Languages for more information. 

• Plain Text File. Import a plain text file. See Text Import Options for more informa-
tion. 

• Extract CC From Media. Select the file type that you want to extract closed caption 
media from. The QCC Multi-Format Import option allows you to extract closed cap-
tions in 608/708 from a large variety of SD and HD video file types.

• Standalone Caption/Subtitle Files. Select the file type for importing standalone 
caption or subtitle files. 

• Assemble Captions. Select the file type for an assemble captions procedure. See 
Assemble Captions for more information.

Export
Exports captions/subtitles to a wide range of file types. You can export caption, subtitle, 
and text files, or embed captions directly onto digital video without the need for 
encoding hardware.

• Last Export Operation. (Command+E) Shows the last export operation per-
formed. This makes it easy to initiate the same one again. 

• For Multiple Language. Export a file that has multiple languages in it.

• Plain Text File. Export a plain text file. 

• Embed CC Into Media. Select the type of media file to embed closed captions into.

• Broadcast Standalone Files. Select the type of TV broadcast standalone caption 
file you want to create. 

• Web/Mobile Standalone Files. Select the type of web or mobile caption file you 
want to create.

• Subtitles/Open Captions. Select the type of subtitle or open caption file you want 
to create.
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Convert
Converts USF/UYC and SMPTE-TT subtitle files to other file types. The conversion option 
dialogs provide various options, such as image format, setting the start time, timecode 
adjustments, and entering XML content. The options dialog appears after the source 
file is selected

• Last Convert Operation: Shows the last Convert operation performed. 

• USF/UYC to DECE CFF. Converts a USF/UYC file to a DECE CFF file. 

• USF/UYC to Rhozet/PNG. Converts a USF/UYC file to Rhozet/PNG files. You have 
the option to prepend text to the output file name, in addition to format and time 
code options. 

• USF/UYC to Text/PNG. Converts a USF/UYC file to Text/PNG files. 

• USF/UYC to TI DLP Cinema/PNG. Converts a USF/UYC file to a TI DLP Cinema/PNG, 
which includes an XML content file and multiple PNG files in the format you choose 
when the options dialog appears. 
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Edit Menu

Undo
(Command+Z) Step back through your last actions to undo them.

Redo
(Shift+Command+Z) Restore the states you just used Undo to roll back.

Cut
(Command+X) Remove the highlighted text or selected object and store it in memory.

Copy
(Command+C) Copy the highlighted text or selected object to memory.

Paste
(Command+V) Place the previously copied or cut text or selected object from memory 
into the target component.

Delete
Deletes the selected item. 

Clear All
Clears all current selections.

Select All
(Command+A) Select all captions/subtitles. 

Select Up
(Option+Shift+Command+U) Select all caption/subtitle rows up to number 1, from the 
currently selected row. 

Select Down
(Option+Shift+Command+D) Select all caption/subtitle rows down to the end, from 
the currently selected row.

Previous Error
Jump to the next error above the currently selected caption/subtitle row, when errors 
are detected.
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Next Error
Jump to the next error below the currently selected caption/subtitle row, when errors 
are detected.

Find
(Command+F) Opens the Find/Replace dialog. To insert the Music symbol in the Find/
Replace dialog you can use the Command+M keyboard shortcut. 

Find Next
(Command+G) Find the next occurrence of text last entered into the Find/Replace 
dialog.

Find Previous
(Shift+Command+G) Find the previous occurrence of text last entered into the Find/
Replace dialog.

Configure Word Substitution
Opens the Word Substitution List dialog. Enter any words or phrases that you want to 
have changed and enter the words or phrase to substitute. You can also import or 
export word substitution lists.
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Word Substitution
Initiates the word substitution operation, using the “Original and Substitution” words 
entered in the Configure Word Substitution dialog. 

Clear
Includes options to clear the following specific items from selected rows:

• Duration(s)

• Positioning

• Starting and Ending Time(s)

• Subtitle Horizontal Increment(s)

•  Subtitle Vertical Increment(s)

• Text

• Times and Text

Configure Current Program
Select to configure options for the currently selected program. 

Spelling

The spelling and custom dictionary information is stored in each project file, on a per-
program basis. The language you specify to use for each program and each project is 
saved for each program and used for that program when you run a spell check. The 
spell check is performed with the Special > Spell dialog. See Spell. 

• Language. Select the language to use for the current program. All languages that 
have spelling dictionaries installed in your computer are available for selection. 

Note: The default language for MacCaption is set to the first Preferred Language 
specified in your Mac OS X computer operating system. To change your computer 
default language, go to System Preferences > Language & Region > Preferred 
Languages panel. 
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• Custom Dictionary. The file name of the current custom dictionary is displayed. No 
file name is displayed when no dictionary is selected. 

– Open. Open an existing custom dictionary file.

– New. Create a new custom dictionary file. The default file name is MacCaption 
User Dictionary.ccd.

– Close. Close the currently open custom dictionary file.

Duplicate Current Program
Select to copy the current caption/subtitle information into another program. You can 
copy information in up to five other channels that can be available simultaneously on 
the same video (depending on output format). 

This option is often used to copy all the time codes and positional information from 
one language (for example, Program A) to another language (for example, Program B). 
Then you can translate the text (Program B) to another language.

Start Dictation
You can use the Start Dictation feature to speak into your computer microphone and 
MacCaption will convert the speech to caption text. 

This feature works with Mac OS X Mavericks (10.9) and above, which supports built-in 
speech to text technology that allows users to speak into their microphone for text 
dictation into OS X software applications. 

To use the OS X speech to text dictation, select Start Dictation, or press the fn shortcut 
key twice (fn fn) and begin speaking.
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Display Menu

Font
Select the font to use in the text editing rows.

Program A-F
(Option+Command+A through F) Select the independent text editing program to 
display.

Show Grid
Display or hide the grid in the movie panel. This feature shows the required locations 
for captions and can be useful when dragging your captions to desired locations.

Show Safe Titles
Display or hide the title-safe boundaries in the movie panel. 

Play/Stop Movie
Start or stop movie playback.

Preview Play
Start Preview Play mode. 

Time Stamp
Initiate a Time Stamp at the current time code location.

Jump Forward/Back 1 Second
Go forward or back one second in the movie. 

Display as Subtitles/Captions
(Command+D) Switch between caption and subtitle mode. This is the same as clicking 
the Caption/Subtitle switch that is below the video controls on the main workspace. 
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Caption Menu

Encode Preferences
Opens the Encode Preferences dialog. 

608 Encode Targets

Select the data channel to use for programs A through D. The CEA-608 standard for line 
21 captioning provides four independent closed caption data channels. These are 
named CC1, CC2, CC3 and CC4. There is no direct correspondence between a program 
and a specific CC channel, but typically Program A is used for CC1 and Program B for 
CC2 or CC3. Data channels B through D are commonly used for additional languages.

If desired, it is also possible to encode a program to more than one CC channel. 

Note: CC1 and CC2 are both transmitted in the Odd Field of a video frame and CC3 
and CC4 are both transmitted in the Even Field of a video frame. Due to closed caption 
bandwidth limitations it is important to note that two closed caption programs 
containing a lot of text may appear fine when placed in CC1 and CC3, but may appear 
later than their intended display time when placed in CC1 and CC2 or CC3 and CC4. As 
with all closed captioning, a careful review of the final output that contains all closed 
captioned channels is recommended.
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608 Closed Captioning Options

You can choose these options:

• Blank between pop-on. Inserts a blank frame between pop-on captions. 

• Duplicate control codes when sending captions. Generate pairs of identical con-
trol codes when encoding closed caption data.

• Force an erase on a roll up caption base row change. When the base row of a 
roll-up caption changes, the new roll-up position will not contain any previous cap-
tion data.

708 Closed Captioning Options

These are considered advanced CEA-708 options. It is recommended to leave these set 
to Default for broadcast TV delivery, in order to pass quality assurance testing using 
professional broadcast monitors and equipment. The non-default options are only 
intended to be used for directly testing consumer-grade televisions and set-top boxes. 
Many new HDTVs also allow the user to override the caption display settings to their 
own preferences.

In addition to Default, these options are included:

• Caption Size. Small, Standard, Large. 

• Font Style. Monospaced with serif, Proportional with serif, Monospaced no serif, 
Proportional no serif, Casual, Cursive, Small capitals. 

• Foreground Color. White, Black, Red, Green, Blue, Yellow, Magenta, Cyan. 

• Foreground Opacity. Solid, Flash, Translucent, Transparent. 

• Background Color. White, Black, Red, Green, Blue, Yellow, Magenta, Cyan.

• Background Opacity. Solid, Flash, Translucent, Transparent. 

• Character Edge. None, Raised, Depressed, Uniform, Left drop shadow, Right drop 
shadow. 

Note: Not all TVs and decoders will respect all possible 708 setting options. 

708 Encode Service Number Targets

Select the Service Number and Language to use for each Program.

The CEA-708 standard provides 64 independent closed caption data channels called 
“Service Numbers.” These are named Service Number 1 through 63, however typically 
only the first six (1-6) are used. MacCaption can generate closed captions for up to six of 
these closed caption data streams. There is no direct correspondence between a 
Program and a specific Service Number, but typically Program A is used for Service 1, 
Program B for Service 2, and so on.

Additional Encode Preferences Options

The following describes the additional options available in the Encode Preferences 
dialog:
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• Include 608 captions in DTV export operations. Encode 608 closed captions in 
DTV caption exports.

• Include 708 captions in DTV export operations. Encode 708 closed captions in 
DTV caption exports.

• Encode 708 captions for 16:9. Encode captions for a 16:9 screen aspect ratio. 

Note: The 16:9 option is intended only for testing consumer TV sets and set-top box 
hardware. This option should not be selected when delivering to professional 
broadcast mechanisms and facilities.

• Include SCTE-20 in DTV MPEG-2 export operations. Encode SCTE-20 captions in 
DTV MPEG-2 caption packets.

• Precede DTV captions with a Reset command. Include a leading reset command 
when encoding 708 enclosed captions. 

• Use KS C 5601 encoding for Service Number [1-63]. Encode Korean KSC 5601 in 
DTV caption packets. Only use this option for South Korean television, which uses a 
specific type of CEA-708 encoding. Do not enable this when delivering captioned 
video content to other countries, such as the United States, Mexico, and Canada. 

Decode Preferences
Opens the Decode Preferences dialog, which includes the following options:

• Import captions using movie frame rate and convert to current time code 
mode. When decoding captions, use the frame rate of the source movie. 

• Enable Direct Icon when importing captions if possible. Enables the use of an 
exact image of imported captions when exporting. 

• Remove erase if caption blanking is less than [__] frames. (default is 5) Removes 
existing caption erase commands when the time from the erase to the next caption 
is less than the indicated number of frames. 

• Import characters beyond column 32. Check to import up to 68 characters per 
line. Uncheck to follows the 608 specification: When a text line contains 33 or more 
characters, MacCaption imports the first 31 characters, and the last character in the 
line, and discards all characters in between.

Set Decode Channel
Captioned videos that you are importing from the Import menu are decoded according 
to the Decode Channel selected. Choose from the following options to set the decode 
channel:

• Select CC1, CC2, CC3, or CC4 for decoding line 21 captions. 

• Select CC1 in DTV through CC4 in DTV to decode 608 captions from DTV encoded 
files. 
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• Select 708 in DTV and then select a service number in the Set Decode Channel Ser-
vice Number menu to decode 708 captions. 

• Select KS C 5601 in Field 1 or Field 2 for South Korean captioning.

• Select 708 KS C 5601 in DTV for South Korean captioning.

Set Decode Channel Service number
Select Caption > Set Decode Channel Service Number to choose the desired channel 
service number when Set Decode Channel is set to 708 in DTV. Numbers range from 1to 
63, but typically only 1–6 are used.

Input Preferences
Opens the Input Preferences dialog. 

• Pop-On and Paint-On. When checked, enables text input auto-advance to the 
next text edit row for pop-on and paint-on captions. The value sets the maximum 
number of rows for pop-on or paint-on captions, then it auto-advances to the next 
text row. The default is 2 rows, and this is the recommended maximum. 
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• Limit Caption Line Length. When checked, enables text input auto-advance to 
the next text edit row for all caption types, when the designated maximum number 
of text columns, or characters, have been entered. The default maximum is 32 col-
umns, or characters. 

Attributes
Choose options for display mode, formatting, and position. 

• Display Mode. Set for Pop-On, Paint-On, Roll-Up 2, 3, or 4 lines.

• Text Color. Choose the color for the caption text.

• Bold/Flash. Makes the selected text bold for subtitling, and flashing for captioning.

• Italic. Makes the selected text italic. Italics is often used to indicate off-screen 
speakers in captioning or untranslatable words in subtitling.

• Underline. Underlines the selected text.

• Horizontal Justification. Choose one of three possible horizontal justifications: 
Left, Center, or Right.

• Horizontal Position. Choose one of three possible horizontal positions: Left, Cen-
ter, or Right.

• Vertical Position. Choose a vertical position of Top, Bottom, Move Up 1 Line, or 
Move Down 1 Line. 

Convert Illegal Caption Characters
Select this option to attempt to convert any illegal Unicode characters in the caption 
text into their standard ASCII equivalents. Some special Unicode characters cannot be 
used in 608 closed captions, such as the em-dash (long hyphen), ellipses (three dots as 
one character), curved quotes, and so on. 

Caption Data Lowest Limit
Opens the Caption Data Lowest Limit dialog. This allows you to set the lowest limit, or 
starting time, for caption data to begin in your exported file. Certain exports, such as 
Black Movie or Matrox 4VANC, use this time as the starting time code of the exported 
file. 

See Setting the Caption Data Lowest Limit for more information and examples. 
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Set Caption Data Lower Limit
Sets the lower limit for caption encoding at the currently selected row. Captions before 
the lower limit will not be encoded. The lower limit mark “LL” is placed in the formatting 
information of the affected row. 

Clear Caption Data Lower Limit
Clears the lower limit, when set, of the selected row. The “LL” mark is removed. 
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Subtitle Menu

Subtitle Preferences
Opens the Subtitle Preferences dialog. See Setting Subtitle Preferences in the Subtitle 
Mode chapter for information about the available options. 

 

Ruby Annotation
Opens the Ruby Annotation dialog that allows entry of Japanese characters. See 
Japanese Ruby Subtitling in the Subtitle chapter and Ruby Japanese Subtitle 
Formatting in the Glossary for more information. 
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Subtitle Configuration
Opens the Subtitle Configuration dialog for the currently selected program. 

Note: You can preview the changes in the video playback panel while you are making 
selections and adjustments for text and drop shadow in the Subtitle Configuration 
dialog, before you close it. 

See Subtitle Style Configuration in the Subtitle Mode chapter for information about the 
available options. 
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Time Code Menu

Mode
Set the time code mode to use for captions/subtitles to one of the frame rates listed. It 
is important to make the right choice to match the movie being used, or the caption/
subtitle hardware (if any). See Setting the Time Code Mode for more information. 

Set Blank Frames
Opens the Blank Frames dialog. Choose the minimum number of blank frames to insert 
between the out-point of each caption/subtitle, and the in-point of the next one. The 
commonly used interval is from 2 to 6 frames.

Convert Time Code
Opens the Convert Time Code dialog. This feature allows you to maintain or modify the 
clock time, change the frame rate, switch between drop frame (DF) and non-drop frame 
(NDF), and set a time offset. 

Click the “?” icon to view the Convert Time Code Help. 

See Convert Time Code for more information about the options and settings. 
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Fill-In All Caption Times
Opens the Fill-In Caption Times dialog. Assigns a time code to selected rows if a time 
code is set for the first and last line of the selected rows. This can be used, for example, 
when a person is speaking for a long period of time (a lecture or speech) at a fairly 
steady rate, or for a language translation. This feature can save time when subtitling a 
video, since it does not require you to enter a time code for each row. 

• First Radio Button: Fill-in time code values... Fills in the time code values for the 
selected range using the first row’s Start Time, the last row’s Start Time, and a calcu-
lated words per minute.

• Second Radio Button: Only fill-in time code values... Select this option to only fill 
in time code values that have cleared start times. 

• Minimum frame duration. Select this option to maintain a minimum time or 
frame duration so captions/subtitles with a single or few words continue to display 
for the minimum duration that is set. The default is 20 frames and 20 to 30 frames is 
a typical value range. 

Movie Time
Opens the Movie Time dialog. You can set the movie Starting Time or Current Time to a 
specified value, or switch to use the Movie Time Code or use the currently selected 
Caption Starting Time code.
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Reading Speed
Opens the Reading Speed dialog. This option is useful for young children, since they 
may not read as fast as older children or adults, and for persons reading captions or 
subtitles in a non-native language. This option has three functions: 

a. You can check the average reading speed for selected rows, if they have time 
codes assigned. This does not change the actual time codes. 

b. You can also assign a desired words per minute reading speed to a block of 
selected rows. You need to assign time code only for the first row of the selected 
block. In this case, the reading speed of each row is going to be exactly the 
reading speed you assign. This option does change the actual time codes. 

c. You can set a Minimum Frame Duration. Select this option to maintain a 
minimum time or frame duration so captions/subtitles continue to display for 
the minimum duration that is set. The default is 2 seconds. 

Ripple Time Code
Opens the Ripple Time Code dialog. You can change the time code within the currently 
selected block, or from a selected row to the end of a file. See Applying Ripple Time 
Code Offsets for more information. 
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Stretch/Shrink Time Code
Opens the Stretch/Shrink Time Code dialog. If your caption timing is right on time at 
the start but is off a few seconds from the video at the end, you have “captioning drift”. 
This can be corrected by using the Stretch/Shrink Time Code option. See Stretch/Shrink 
Time Code for more information. 

Auto Time Stamp
Initiates the Auto Time Stamp operation. See Using Auto Time Stamp for details on 
operation and usage. 

Auto Time Stamp Preferences
Opens the Auto Time Stamp Options dialog. Select the audio track to be analyzed when 
performing the Auto Time Stamp operation.

Non-Linear Time Shrink
Opens a Finder window so you can choose a text file that contains the information to 
shrink the timecode.
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Limit Caption Durations
Opens the Limit Caption Durations dialog. Sets a maximum duration for the selected 
range of captions/subtitles, with values in seconds and frames (SS:FF).

Mark In
Choose this to set the In Point or Start Time of the first word of the currently selected 
caption to the current Movie Time. If multiple rows are selected, the start time is set for 
the first, or top row. You can also use the Mark In button in the main workspace. See 
Time Code Display and In/Out Points for more information. 

Mark Out
Choose this to set the Out Point or End Time of the last word of the currently selected 
caption to the current Movie Time. This only needs to be set when a space is needed 
between captions, such as when there is a pause in the speech, or when the captions 
have ended. You can also use the Mark Out button in the main workspace.
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Format Menu
Insert Row
(Shift+Command+I) Adds a new text row above the one currently selected. You can 
also use the Insert Caption button in the main workspace. Hint: If you need to insert a 
row at the very bottom, click at the end of the text in the last cell and use the Split Row 
option to do so.

Delete Row
(Shift+Command+D) Removes the currently selected row from the Text Panel. You can 
also use the Delete Caption button in the main workspace. 

Split Row
Splits the selected row into two rows at the cursor’s current position. You can also use 
the Split Caption button in the main workspace.

Merge Rows
(Shift+Command+M) Merges all selected rows into a single row. You can also use the 
Merge Caption button in the main workspace.

Consolidate Blank Rows
Removes all blank rows in the Text Panel that do not contain text. (This option is only 
active when the condition exists.)

Remove Blank Rows without Time Code
Removes all blank rows in the Text Panel that do not contain a Start Time. (This option is 
only active when the condition exists.)

Remove Leading and Trailing Spaces
Removes any leading or trailing text spaces from the currently selected row(s). (This 
option is only active when the condition exists.)

Reformat Captions to Roll-up
Opens the Reformat Captions to Roll Up dialog. Reformats the selected rows to apply 
the roll-up style, based on settings you choose in the dialog.
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Reformat Captions to Pop-on
Opens the Reformat Captions to Pop On and Paint On dialog. Reformats the selected 
rows to apply the pop-on style, based on settings you choose in the dialog. 

Reformat Pop-on Captions
Opens the Reformat Pop On and Paint On Captions dialog. Use this option to adjust the 
number of lines in the selected pop-on or paint-on captions. For example, if your 
project is already in pop-on mode and you want a different number of lines per row, or 
if many rows were edited and now have too many lines.

Compress Text Block(s)
Compresses the line length of the currently selected captions, reducing the margins for 
the current cell and increasing the number of lines. You can click multiple times to add 
incremental compression. You can also use the Compress Line Length button in the 
main workspace. 

Expand Text Block
Expands the line length of the currently selected captions. Increases the margins within 
a cell and decreases the number of lines, adjusting the text into fewer rows that are 
wider. You can click multiple times to add incremental expansion. You can also use the 
Expand Line Length button in the main workspace. 

Alternate Break
Selects alternate line break words in the currently selected captions. Clicking multiple 
times toggles between possible line breaks. It is better to make the text bottom heavy 
(shorter lines towards the top, longer lines towards the bottom). You can also use the 
Alternate Break button in the main workspace.
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Compress Text Blocks for Captions
This option will reduce any caption in the project, or selected caption cells, to not have 
more than 32 characters per line, including spaces. When a caption is found with more 
than 32 characters, an additional caption line is created for the extra characters. 

Captions can only have a maximum of 32 characters per line, as per the CEA-608 
specification. If a project was created for subtitles, or created using a non-compliant 
application, it could have more than 32 characters per line.

Insert Music Symbol
• Single Music Symbol. (Command+M) Inserts a music symbol (the quarter note) 

into the caption text at the cursor location. 

• Surrounding Music Symbols. Inserts a music symbol at the beginning and end of 
selected text. If you select multiple rows and choose this option, it adds a pair of 
music symbols for all of the selected captions.

Upper and Lower Case
The following options are available to change the text case:

• Convert to Upper Case. Converts the selected text to upper case. 

• Convert to Lower Case. Converts the selected text to upper case.

• Sentence Wise Upper and Lower Case. Converts text to “sentence style” with the 
first word of a sentence capitalized.

• Upper and Lower Case Preferences. Opens a dialog so you can choose to capital-
ize the first letter of each word following a period. 

Pull First Word
(Option+Up Arrow) Pulls the first word of the next caption into the currently selected 
caption. You can also use the Pull Word Up button in the main workspace.

Push Last Word
(Option+Down Arrow) Pushes the last word of the currently selected caption to the 
next caption. You can also use the Push Word Down button in the main workspace.

Move to Top
Moves the selected caption to the top of the screen. You can also use the Move to Top 
button in the main workspace.

Move to Bottom
Moves the selected caption to the bottom of the screen. You can also use the Move to 
Bottom button in the main workspace.



Menus
Format Menu

194

MacCaption User Guide

Move Caption/Subtitle Up
Moves the selected caption or subtitle one line up.

Move Caption/Subtitle Down
Moves the selected caption or subtitle one line down.

Move Caption/Subtitle Left
Moves the selected caption or subtitle one character to the left.

Move Caption/Subtitle Right
Moves the selected caption or subtitle one character to the right.
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Transcription Menu 

Transcribe Movie 
Opens the Timed Text Speech Job Settings dialog so you can choose the movie to 
transcribe, select the Telestream Cloud project to use, and set other parameters to 
apply during the transcribing operation. Clicking the Auto-Transcribe button also 
opens this dialog. You must be logged into your Telestream Cloud account for this 
feature to be active. See Job Settings for Timed Text Speech for details on the options.

Telestream Cloud Account
Opens the Telestream Cloud Login dialog for login to your Telestream Cloud account. 

• User Name. Enter the user name for the transcription account. The user name is 
saved for future transcribing operations. 

• Password. Enter the password for the transcription account. The password is saved 
for additional transcribing operations during the current session. For enhanced 
security, the password must be re-entered after you close and re-open Caption-
Maker. 

• Don’t have an account? Click the link to go to the Telestream Cloud web site so 
you can create an account. 

• Forgot username / password? Click the link to go to a web page where you can 
enter your email address and initiate a process to reset your password. 

Transcription Mode
Switches MacCaption into or out of Transcription Mode. This activates the associated 
interface operation and actions to enable easy editing, such as video looping, menu 
items, and shortcut keys. See Transcription Edit Mode for more details. 

Transcription Mode Settings 
Opens the Transcription Mode Settings dialog.

• Video Looping Offsets

– Start Time. Adds playback time, in milliseconds, before the start of the current 
cell so words in the previous cell are included. 

– End Time. Adds playback time, in milliseconds, to the end of the current cell so 
words in the next cell are included

• Auto Play/Pause Video. When enabled, starts looping video playback when you 
select a cell. 

Next Cell
(Down Arrow) Moves the cursor to the start of the next text cell. 
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Previous Cell
(Up Arrow) Moves the cursor to the start of the previous text cell. 

Next Word
(Right Arrow) Advances the cursor to the start of the next word. If the cursor is already 
on the last word of a cell, this advances the cursor to the start of the next cell (and 
triggers the video to loop around that next row's in and out times).

Previous Word
(Left Arrow) Moves the cursor back to the start of the current word, if the cursor is in the 
middle/end of the current word. Or to the start of the previous word, if the cursor is at 
the start of a word. If the cursor is already on the first word of a cell, this moves the 
cursor to the start of the last word of the previous cell (and triggers the video to loop 
around that row's in and out times).

Next Character
(Command+Right Arrow) Moves the cursor right one character. 

Previous Character
(Command+Left Arrow) Moves the cursor left one character. 

Select Next Word
(Shift+Right Arrow) If nothing is currently selected/highlighted, this selects/highlights 
the word that the cursor is currently on. If something is already selected/highlighted, 
this expands the selection to include the next word past the end of the current 
selection. This is limited to the contents of the current cell — a selection cannot span 
across multiple cells. 

Select Previous Word
(Shift+Left Arrow) If nothing is currently highlighted, this selects/highlights the word 
prior to the word the cursor is currently on. If something is currently highlighted, this 
expands the selection to include the previous word prior to the start of the selection. 
This is limited to the contents of the current cell — a selection cannot span across 
multiple cells.

Toggle Capitalization
(Shift+Up Arrow) Toggles capitalization the first letter of the word currently under the 
cursor, or the first word of a selection. 
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Split Cell
(Command+Enter) Splits the cell into two cells at the cursor location. 
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Special Menu

Captions Follow Video
When selected, the captions change along with the video, following the Start and Stop 
times that are set. This is the same as selecting the Captions Follow Video button in the 
movie control section. 

Video Follows Captions
When selected, and you select a caption row, the video automatically jumps to the time 
of that caption. You can also quickly move through the caption rows using the up and 
down arrow keys, and the video follows along. This is the same as selecting the Video 
Follows Captions button in the movie control section. 

Position Video When Selecting Caption
When selected, the video moves to the time code of a selected caption row.

Position Video When Selecting Caption Text
When selected, the video moves to the time code of a caption row in which you place 
the text editing cursor.

Show Actual Captions During Time Stamp
This option is used when time-stamping a new project. When enabled, the Video 
Playback/Preview Panel will behave like a closed caption decoder and show the 
captions as they are being encoded into a video. When this setting is not enabled the 
Video Playback/Preview Panel will show the captions that are cued to be sent but not 
yet time-stamped.

Select Playback Audio Tracks
When there is more than one audio track, use this option to select the audio track(s) 
you want to hear. 

Customize Keystrokes
Opens a message dialog that describes how to set a keyboard shortcut. To set a 
keyboard shortcut: 

1. Find the command that you want to assign or change a keystroke to at its place in 
the menu. 

2. Hold down Control and click on the command. The Customize Keycode dialog 
opens. 

3. Select the key you want to assign this command to, and whether you want to hold 
down the Shift, Option, or Command button when using it.
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4. Click OK & Continue. If the keyboard shortcut is already in use, a dialog appears that 
asks if you want to assign the shortcut to the new command. If the keyboard 
shortcut is not being used, it is now set and active. 

Spell
Checks the spelling of the caption text for the currently selected program. The 
Language and Custom Dictionary used are set in the Edit > Configure Current Program 
dialog. See Configure Current Program. To change the current Language or Custom 
Dictionary that is used in the Special > Spell dialog, close the Spell dialog and open the 
Edit > Configure Current Program dialog, then make the change there. 

When Special > Spell is selected, the following dialog opens: 

Not in Dictionary

The first unrecognized word that is found appears in the Not in Dictionary field. 

• Add to Dictionary. Add the current unrecognized word to the current Custom Dic-
tionary. This button is only enabled when a Custom Dictionary is specified for the 
current program in the Edit > Configure Current Program dialog. 

• Ignore Once. Ignore the current unrecognized word one time, and find the next 
unrecognized word. 

• Ignore All. Ignore all instances of the current unrecognized word, and find the next 
unrecognized word.
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Change To

If a suggestion from the dictionary is available, it appears in the Change To field. If no 
suggestion is presented or you wish to enter your own corrected word, type the correct 
word in the Change To field and click Change Once or Change All.

• Change Once. Change the current unrecognized word to the suggested replace-
ment word in the Change To field, one time, and find the next unrecognized word.

• Change All. Change all instances of the current unrecognized word to the sug-
gested replacement word in the Change To field, and find the next unrecognized 
word.

• Suggestions. Additional suggestions from the current dictionary are provided, if 
available. Select one of the suggestions when you want to use it, and it appears in 
the Change To field. 

• Undo Last. Undo the last spell check change. 

• Close. Close the dialog to conclude the spelling check. Any changes that have been 
made to words or the dictionary are saved. 

Active Format Description
Active Format Description (AFD) is metadata contained in the digital video signal 
describing the aspect ratio of the picture. This allows monitors capable of receiving 
AFD metadata to switch the displayed aspect ratio as the received picture changes.

To enable AFD to be included in the video, check the box labeled Include Active Format 
Description Information, and then select the aspect ratio—either 4:3 or 16:9 as shown 
in the display graphics. Below the graphics, drop-down menus let you choose the 
specific ratio and configuration.
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Content Advisory Information
Allows you to include Content Advisory Information and V-Chip Program Rating Data 
for embedding in the video signal.

Content Advisory Information is specific information about the program material. The 
Content Advisory Information is sent along with video and close caption information to 
the end user. You can enter any, all, or none of the information in the Content Advisory 
Information dialog box.

Select Include Content Advisory Information to generate Content Advisory 
Information. The dialog allows you to enter information about your program, including: 
Program Name, Length (hours and minutes), Keyword Group, and Details.

In the United States, the Television Parental Guidelines rating system should be used for 
all productions that are not motion pictures. Use the V-Chip option to set this rating. 
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V-Chip
The V-Chip program rating information can be sent along with the video and closed 
caption information to the end user. To enable this function, select Include V-Chip 
Information to generate V-Chip Program Rating Data. Use the Type menu to choose 
which V-Chip information to send, and check a rating box. Only one rating system can 
be specified for a program.

MacCaption generates rating information for the Television Parental Guideline Rating 
system, the Motion Picture Association of America (MPAA) Rating system, the Canadian 
English Language Rating System and the Canadian French Language Rating System.

The rating abbreviations are explained on each menu except the Television Parental 
Guidelines, which are as follows:

TV-MA – Mature Audiences Only
TV-14 – Parents Strongly Cautioned
TV-PG – Parental Guidance Suggested
TV-G – General Audience
TV-Y7 – Directed To Older Children
TV-Y – All Children
------------------------------------------------
FV – Fantasy Violence
V – Graphic Violence
S – Explicit Sexual Activity
L – Crude and/or Indecent Language
D - Intensely Suggestive Dialogue

Additional information on the V-Chip, Television Parental Guidelines, Motion Picture 
Guidelines and Canadian Guidelines can be found at TV Parental Guidelines (http://
www.tvguidelines.org/), Motion Picture Association of America (http://www.mpaa.org/), 
and V-Chip Canada (http://www.vchipcanada.ca/) web sites.

http://www.tvguidelines.org/
http://www.tvguidelines.org/
http://www.mpaa.org/
http://www.vchipcanada.ca/
http://www.vchipcanada.ca/
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Window Menu

Clear Message Window
Select to clear the current contents of the message window.

Main Workspace
The main workspace window is shown with its file name. The shortcut is Command+0 
(zero).

Message Window
Select Message Window to open or view the window that displays messages about 
various operations that have occurred. The shortcut is Command+1. 
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Help Menu

Quick Start Guide (Local)
Opens the Quick Start Guide, in PDF format, that is installed with MacCaption. 

User Guide (Local)
Opens the User Guide, in PDF format, that is installed with MacCaption.

Command Line Interface
Opens the MacCaption Command Line Interface guide in your default browser. 

Feature Comparisons
Opens the Feature Comparison page on the Telestream web site. 

Online Technical Support
Takes you to the Telestream web site Closed Captioning Support page, where you can 
find a range of support information or enter a technical support ticket.

Keyboard Shortcuts
Opens the Keyboard Shortcut Extensions guide in your default browser. This describes 
the standard keyboard shortcuts for MacCaption.

Download
Opens the Download Options dialog. Click the Download button to open the 
Telestream Closed Captioning downloads page. Click Read Me to open the current 
version of the MacCaption Release Notes. 

Manage MacCaption License
Opens the MacCaption License dialog. Provides options to upgrade or deactivate the 
license and a field for reading or entering your license number. Click the lock icon to 
allow changes. First a dialog appears to enter your computer password, then options 
for making license changes become available.

Purchase/Upgrade
Takes you to the Telestream Online Store for the captioning products, where you can 
choose a version for purchase or to upgrade. 

Clear Preferences
Opens a confirmation dialog. Click OK if you want to delete the preferences and restart 
MacCaption.
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File Types for Import/
Export

This chapter provides lists of all file types that CaptionMaker and MacCaption can 
import or export, categorized by purpose, and by what is available in the different 
versions of Desktop, Pro, and Enterprise.

■ Command Line Interface File Types

■ Identifying MacCaption and CaptionMaker File Types

■ Import File Types

– Text Files

– Extract Closed Captions from Media

– Standalone Caption/Subtitle Import Files

– Web and Mobile Standalone Import Files

– Assemble Captions

■ Export File Types

– Text Files

– Embed Closed Captions into Media

– Broadcast Standalone Files

– Web and Mobile Standalone Export Files

– Subtitle and Open Caption Export Files
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Command Line Interface File Types
Not all of the file types listed in this chapter are supported when using the 
CaptionMaker or MacCaption Command Line Interface (CLI). 

• To see the files that are available when using the CLI in CaptionMaker, open the CLI 
document from Help > CommandLine Documentation (Local). 

• To see the files that are available when using the CLI in MacCaption, open the CLI 
document from Help > Command Line Interface. 

Identifying MacCaption and CaptionMaker File 
Types

File type descriptions, in the tables in this chapter, for MacCaption and CaptionMaker 
are color coded and marked with asterisks to indicate which platform they work with. 
The following designations are used:

• Blue and one asterisk (*): Indicate file types that only work with MacCaption 

• Green and two asterisks (**): Indicate file types that only work with CaptionMaker. 

• Black: Works for both MacCaption and CaptionMaker. 
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Import File Types
The following tables provide the import file types, along with relevant notes.

Text Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Extract Closed Captions from Media
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Desktop Pro/Enterprise Notes
MacCaption Project (.cca) MacCaption Project (.cca) 

For Multiple Language*
Plain Text File Plain Text File
ASCII Text (.txt)** ASCII Text (.txt)**
Rich Text Format (.rtf )** Rich Text Format (.rtf )**
Word Document (.doc)** Word Document (.doc)**
WordPerfect Document (.wpd, 
.doc)**

WordPerfect Document (.wpd, 
.doc)**
Translation (.rtf )**

Desktop Pro/Enterprise Notes
ATSC DTV 608/708 CC SD (to 
MPEG2, .ts .m2v)**

MPEG2 data. Manzanita can add 
to Transport Stream. Cable 
station broadcast. XDCAM MOV.

ATSC DTV 608/708 CC HD (to 
MPEG2, .ts .m2v)**

Same as above note, but only 
looking at line 708.

AVI 720x486 for NLE (.avi) - NLE 
720x486 video/gray-scale**

VBI importer, line 21 data, 
QuickTime, AVI.

QCC Multi-Format Import (.mpg 
.mpeg .m2v .mpv .ts)

This is a catch-all import that 
includes many formats. See QCC 
Multi-Format Import for more 
information.

Ccube/LSI DVx 608 Linear Closed 
Captions**
Ccube/LSI DVx 608 Temporal 
Closed Captions**
DV AVI 720x480 (.avi)**
DV/DVCPro 720x480 (DV25/
50)**

Not enough to do Closed 
Captions (CC) because it doesn’t 
have enough resolution. 
Ancillary field.

DVD Closed Cap (from MPEG2) DVD Closed Cap (from MPEG2)** MPEG2, not the same as SCC.
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DV QuickTime 720x480 (MOV)**
MPEG2 720x480 New Tek 
TriCaster (.mpg, .mpeg)**
MPEG2 720x512 422P@ML 
(.mpg, .mpeg)**

Matrox MXO2 hardware, MOV, 16 
channel audio, CC data in 16th 
channel, cross convert, currently 
uses SCC or MCC.

Media eXchange Format .mxf** XDCAM MXF only, OP1A, HD. 
Support for 608/708 caption 
data or OP-47 Teletext from 
SMPTE-436M track. 

Nexidia QC report files .XML** These files contain notes that 
help CaptionMaker find errors. 
See Using a Nexidia XML QC 
Report to Locate Errors. 

QuickTime DTV 608/708** CC 608 track only, for iDevice 
and desktop- viewable in 
QuickTime player.

QuickTime Podcast CC 608 QuickTime Podcast CC 608 ** CC 608 track only, for iDevice - 
viewable in QuickTime player.
Older insertion style for 
broadcast.
Older SeaChange hardware, 
MOV specific area for caption.
User data from Final Cut Pro 
XDCAM media.

QuickTime Subtitles (MOV, 
.m4v)*

Alternate for subtitle tech, 
multiple tracks, QuickTime 
player, iDevice.

QuickTime Text Track (MOV, 
.m4v)*

Text played below video, low 
quality, mobile.

Desktop Pro/Enterprise Notes
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Standalone Caption/Subtitle Import Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Desktop Pro/Enterprise Notes
XML, not SMPTE.

Avid DS .txt** Subtitle file for Avid. Time code 
and text only. Render using Avid 
tools.

Caption Center .tds** Use WGTS software. Slightly 
encoded text file.

Captions Inc. .cin** Caption file for captioning 
company - Captions Inc.
Old version of CPC software 
encoding, for embedding 
caption data.

Cheetah INT .asc** Uses less control coding 
interspersed with text.

Cheetah INT .cap Caption file used with hardware 
encoding, very popular.

CPC/LeapFrog CCaption (.onl)/
CPC-715 File .onl**

Online file for use with old CPC 
software, tape to tape.

DirecTV GLA (.gla)** Based on .SCC (Scenarist Closed 
Captioning) file format, with 
special formatting for DirecTV. 

DLP Cinema DCI Iterop .xml Digital light projection package. 
Used more for subtitles.

DOS CPC-600/CPC-700 (.)** DOS CPC-600/CPC-700 (.)**
DVD Caption File .cc DVD Caption File .cc Generic for Scenarist files. Very 

limited, only 29.97. Used by most 
products.

DVD Caption File  .scc DVD Caption File  .scc Generic for Scenarist files. Very 
limited, only 29.97. Used by most 
products.

DVD Studio Pro .stl* Subtitle for DVD Studio Pro.
EBU Subtitling Data Exchange 
.stl

EU broadcasters standard 
format. Open subtitling - text file 
burn-in. Includes Teletext Level 1 
encoding, Double Height 
characters, foreground color.

Evertz ProCAP .txt** Software file that interacts only 
with Evertz hardware.

EZTITLE Format (.txt)**
Transcription software file. 
Import only.
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iTunes .itt iTunes .itt Subtitling for iTunes. XML file.
MacCaption VANC .mcc* MacCaption VANC .mcc* 
MacCaption MCC 608/708 .mcc MacCaption MCC 608/708 .mcc Allows for additional Active 

Format Description metadata. 
Support for OP-47 Teletext. 

National Captioning Institute 
.cap**

NCI company proprietary format.

Additional format for NCI.
PAC Subtitles .pac Popular EU subtitle format.
PoliScript PE2 (.txt)*
PowerPixel Format (.txt)**
ProCap Author.doc (.doc)**
ProCap Transfer (.txt)**

Windows CaptionMaker (.cap)** Windows CaptionMaker (.cap)**
Windows CaptionMaker V 1.xx 
(cap)**

Windows CaptionMaker V 1.xx 
(cap)**

Mobile text format from Apple. 
Text vs. embedded text, rare.

Rhozet .xml* Competitor file for Carbon 
Coder, 608 only.

SAMI Sync Accessible Media 
Interchange .smi

SAMI Sync Accessible Media 
Interchange .smi

Original web streaming file 
format, used for Windows Media 
Player, stand-alone file format.

Same as Windows Media SAMI 
file .smi

Original web streaming file 
format, used for Windows Media 
Player, stand-alone file format.

Sofni .sub ** EU subtitler. Often used for 
DirecTV.

Softitler (.txt) Softitler (.txt)** EU subtitler, text file format.
Sonic Text .txt** Sonic solutions, for Sonic DVD.
Sony Blu-ray Subtitles .txt* Just for Sony Blu-ray platform. 

Blu-print file.
Subrip .srt Subrip .srt Format to optically pull subtitles 

from DVDs, simple time-in time-
out. Different than YouTube. 
Works with Vimeo.

Timed Text DFXP .xml Timed Text DFXP .xml Multipurpose. Use for TTML, 
Netflix Timed Text, SMPTE 2052, 
Crackle Timed Text, and more. 

Desktop Pro/Enterprise Notes
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Web and Mobile Standalone Import Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Assemble Captions

The Assemble Captions import formats are only available in the Pro and Enterprise 
versions of MacCaption. 

* Indicates MacCaption only.

Ultech Caption .ult From Ultech. Originally 
hardware, multi frame rate, multi 
platform.

WebVTT .vtt WebVTT .vtt Next generation of Subrip .srt. 
Contains positioning and style. 
Popular with media players, web 
format.

YouTube .sbv, .srt YouTube .sbv, .srt** .sbv is used solely for YouTube. 
.srt is slightly different from 
Subrip.

Desktop Pro/Enterprise Notes
Google/YouTube Video Subtitle 
Script (.srt)

Google/YouTube Video Subtitle 
Script (.srt)

iTunes Timed Text (.itt) iTunes Timed Text (.itt)
Netflix TT .xml Netflix TT  .xml Netflix Timed Text
SMPTE Timed Text / Magic Time 
Text .xml

SMPTE Timed Text / Magic Time 
Text .xml

Constraint of DFXP, follows 
SMPTE rule, strict formating.

SubRip (.srt) SubRip (.srt) Simple text. Used for web.
TT / TTML .xml  .ttml TT / TTML .xml  .ttml Timed Text. IMSC 1.0 and 1.1 

TTML subtitle files
WebVTT .vtt WebVTT .vtt Next generation of Subrip .srt. 

Contains positioning and style. 
Popular with media players. 

Windows Media SAMI file .smi Windows Media SAMI file .smi Slight derivation of SAMI. 
Different than plain SAMI.

Windows Media Player 
[Embedded Captions] (.wmv)**

Windows Media Player 
[Embedded Captions] (.wmv)**

Desktop Pro/Enterprise Notes

Pro/Enterprise Notes
CMX 3600 (.edl)*
Final Cut Pro 7 (.xml)*
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Export File Types
The following tables provide the export file types, along with relevant notes. 

Text Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Embed Closed Captions into Media 
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Desktop Pro/Enterprise Notes
For Multiple Language** For Multiple Language**
Plain Text File Plain Text File
ASCII Text (.txt)** ASCII Text (.txt)**
Rich Text Format (.rtf )** Rich Text Format (.rtf )**
Word Document (.doc)** Word Document (.doc)**
WordPerfect Document (.wpd, 
.doc)**

WordPerfect Document (.wpd, 
.doc)**

Desktop Pro/Enterprise Notes
ATSC DTV 608/708 CC SD (to 
MPEG2, .ts .m2v)**

Adds user data to XDCAM or 
MOV.

ATSC DTV 608/708 CC HD (to 
MPEG2, .ts .m2v)**

Adds user data to XDCAM or 
MOV.

AVI 720x486 for NLE (.avi)**
Black AVI 720x486 for NLE (.avi)**
CCIR 601/4:2:2P@ML Movie w/
CC**

SD export to add line 21 to 
720x512. Extreme Reach.

CCube/LSI DVx 608 Linear CC** MPEG1 608 export, older.
CCube/LSI DVx 608 Temporal 
CC**

MPEG1 608 export, older.

DV AVI 720x480 (.avi)**
DV/DVCPro 720x480 DV25/50 
CC**

Puts in the VAUX (vertical aux) to 
send to tape.

DVCPro HD DV100 .mov CC** Add to the VANC of DVCPro file.
DVD CC (to MPEG2)...** Not broadcast spec, but can be 

converted into spec.
DVD Style CC (to MPEG2)** Not broadcast spec, but can be 

converted into spec.
H.264 SEI 608/708 captions User data for H.264, for V-Brick, 

SOLA streaming platform for 
Akamia.
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Broadcast Standalone Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

MPEG-2 Userdata 608/708 
captions

Different method than ATSC. Put 
data in Transport Stream 
without Manzanita. Not Cable 
Lab spec.

QuickTime DTV 608/708 CC 
Track…

Track for broadcast. In wrapper 
of file MOV (ProRes or H.264).

QuickTime 608 CC (Final Cut Pro/
Podcast/Web)

QuickTime 608 CC (Final Cut Pro/
Podcast/Web)

Track for web content, iOS, and 
related.

QuickTime 708 Closed Captions Track for web content, iOS, and 
related.

MXF OP1a using Telestream 
Media Framework
Sony Material eXchange Format 
.mxf/MXF**

XDCAM MXF. Used for XDCAM 
decks, Omneon servers. 

Support for 608/708 caption 
data or OP-47 Teletext into 
SMPTE-436M track. 

Windows Media Player 
[Embedded Captions] (.wmv)**

Windows Media Player 
[Embedded Captions] (.wmv)**
YUY2 AVI 720x12 (.avi)**
SeaChange CC** Specifically for SeaChange 

hardware, MOV proprietary.

Desktop Pro/Enterprise Notes
Avid Advanced Authoring 
Format .aaf**

Avid MC export either HD MXF 
or HD tape. Used with Nitris DX 
and MOJO DX. 

Support for OP-47 Teletext.
Avid DS .txt** Subtitle file for Avid. Time code 

and text only. Render using Avid 
tools.

Black 720x486 movie w/ CC** To create line 21 black movie to 
add line 21 caption data in any 
NLE. SD only.

Black 720x512 NTSC Movie for 
Matrox DigiServer**

For Matrox server. Adds caption 
data. SD only.

Caption Center .tds** Use WGTS software, slightly 
encoded text file.

Desktop Pro/Enterprise Notes
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Captions Inc .cin Caption file for captioning 
company - Captions Inc.

Cheetah International .asc Uses less control coding 
interspersed with text.

Cheetah International .cap Caption file used with hardware 
encoding. This is a most widely 
used format.

Convert MCC to Avid Captions 
Only AAF (.aaf )**
Convert SCC to Avid Captions 
Only AAF (.aaf )**
CPC/LeapFrog CCaption (.onl)/
CPC-715 File .onl**

Online file for use with old CPC 
software. Tape to tape.

DOS CPC-600/CPC-700 (.)** DOS CPC-600/CPC-700 (.)** Works for various file extension 
types.

DVD Caption File (.cc)** DVD Caption File (.cc)**
DVD Caption File (Scenarist .scc) DVD Caption File (Scenarist .scc) Generic for Scenarist files. Very 

limited, only 29.97. Used by most 
products.

DVD T2 Links File (.scc)** DVD T2 Links File (.scc)**
Evertz ProCAP .txt** Software file that interacts only 

with Evertz hardware.
EZTITLE Format (.txt)**

MacCaption VANC Data File .mcc MacCaption VANC Data File .mcc Text file that contains 608/708 
data. Support for OP-47 Teletext.

MacCaption MCC V2 .mcc* MacCaption MCC V2 .mcc* Allows for additional Active 
Format Description metadata.

Matrox 4VANC Closed 
Captions**

Matrox MXO2 hardware, MOV, 16 
channel audio, CC data in 16th 
channel, cross convert, currently 
uses SCC or MCC.

Multiplexed File for Manzanita** Multi language data, SCC.
PowerPixel Format (.txt)**
ProCap Transfer (.txt)
Ultech .ult From Ultech, originally 

hardware. Multi frame rate, multi 
platform.

Ultech ULT Caption (multi-
language merge) (.ult)**

Windows CaptionMaker (.cap)** Windows CaptionMaker (.cap)**

Desktop Pro/Enterprise Notes



File Types for Import/Export
Export File Types

217

CaptionMaker User Guide

Windows CaptionMaker Ver 1.xx 
(.cap)**

Windows CaptionMaker Ver 1.xx 
(.cap)**

Desktop Pro/Enterprise Notes
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Web and Mobile Standalone Export Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

Desktop Pro/Enterprise Notes
Crackle Timed Text .xml Crackle Timed Text .xml 1 of 2 Sony XML TTL timed text. 

Used to output to Crackle only.
Echo360 .xml XML captioning format

EBU-TT EBU-TT Subtitle XML file
Flash Text .txt** Old method of adding captions 

to Flash.
Flash XML for Captionate .xml Flash XML for Captionate .xml** Used just for Captionate. Simple 

XML.
Flash XML for CS4 [Timed Text 
DFXP] .xml

Flash XML for CS4 [Timed Text 
DFXP] .xml**

Designed for flash CS4. Still used 
frequently (DFXP).

Flash XML in Timed Text 
Authoring Format without 
header (.dfxp)**

Flash XML in Timed Text 
Authoring Format without 
header (.dfxp)**

IMSC 1.0 Text Captions (.ttml) IMSC 1.0 Text Captions (.ttml) Also can process SMPTE-TT files.
IMSC 1.0 Text Subtitles (.ttml) IMSC 1.0 Text Subtitles (.ttml)
IMSC 1.1 Text Subtitles (.xml) IMSC 1.1 Text Subtitles (.xml)
MAGIC TT (timed Text) (.xml)** MAGIC TT (timed Text) (.xml)**
Mijo XML in seconds format 
(.xml)**

Mijo XML in seconds format 
(.xml)**

PBS COVE (.sami)** PBS COVE (.sami)**
iTunes .itt* iTunes .itt* Subtitling for iTunes. XML file.
Netflix TT Captions .xml* Netflix TT Captions .xml* Netflix Timed Text. For closed 

captions and subtitles.
QuickTime .txt, .smi** QuickTime .txt, .smi** Text played below video. Low 

quality, mobile.
RealText .rt, .smi** RealText .rt, .smi** For RealPlayer. SAMI for 

RealPlayer.
SAMI Sync Accessible Media 
Interchange .smi

Original web streaming file 
format. Used for Windows Media 
Player. Standalone file format.

SMPTE 2052 Timed Text 
Captions (.xml)*

SMPTE 2052 Timed Text 
Captions (.xml)*

SMPTE TT (Timed Text) (.xml)** SMPTE TT (Timed Text) (.xml)** Constraint of DFXP. Follows 
SMPTE rule, strict formatting.

SubRip (.srt) SubRip (.srt) Simple text. Used for web.
Sony Pic Timed Text .xml Sony Pic Timed Text .xml Constraint of DFXP.
Timed Text DFXP .xml Timed Text DFXP .xml Multipurpose. Least constrained 

of DFXP exports.



File Types for Import/Export
Export File Types

219

CaptionMaker User Guide

Subtitle and Open Caption Export Files
* Indicates MacCaption only.   ** Indicates CaptionMaker (Windows) only.   Black: MacCaption and CaptionMaker.

WebVTT .vtt WebVTT .vtt Next generation of Subrip .srt. 
Contains position and style. 
Popular for media players. Web 
format.

Windows Media SAMI file .smi** Windows Media SAMI file .smi** Slight derivation of SAMI. 
Different than plain SAMI.

YouTube .srt** YouTube .srt** .srt is slightly different from 
Subrip. Only for YouTube.

Desktop Pro/Enterprise Notes
(Burn Subtitles) Any Video File (.) 
to (.avi)**

(Burn Subtitles) Any Video File (.) 
to (.avi)**

(Burn Subtitles) into QuickTime 
mov/mp4 using Telestream 
Media Framework (.mov; .mp4)**

(Burn Subtitles) into QuickTime 
mov/mp4 using Telestream 
Media Framework (.mov; .mp4)**

Currently supports H.264 up to 
15000 kbps. 

(Encode Subtitles) Black AVI 
720x486 for NLE (.avi)**
OP-42 SD Teletext Black movie with VBI for NLE.
Black Movie with Open Captions Open captions burned in. Uses 

alpha channel. SD only.
DirecTV GLA (.gla)** Based on .SCC (Scenarist Closed 

Captioning) file format, with 
special formatting for DirecTV. 

Movie with Open Captions** Movie with Open Captions** Burns in straight. No alpha 
channel. SD only.

Black Movie with Subtitles Black Movie with Subtitles Alpha channel, any resolution 
subtitle. Can be made to look 
like captions.

Movie with Combined Subtitles Movie with Combined Subtitles Burned in, open subtitles. 
Flattens movie. Any resolution.

Movie with Separate Subtitles** Movie with Separate Subtitles** Burned in, open subtitles. Any 
resolution.

HD Black AVI for NLE (.avi)** Alpha channel, any resolution 
subtitle. Can be made to look 
like captions.

(Encode Subtitles) HD Black 
QuickTime for NLE (*.mov)

(Encode Subtitles) HD Black 
QuickTime for NLE (*.mov)

Exports .mov animation with 
alpha channel. 

Adobe Encore V2 .txt Adobe Encore V2 .txt Subtitle for Encore. Simple - no 
formatting.

Desktop Pro/Enterprise Notes
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Apple XML Interchange Format 
.xml**

Subtitle format for working in 
Final Cut Pro.

Avid DS .txt Subtitle file for Avid. Time code 
and text only. Render using Avid 
tools.

Blu-ray BDN .xml Generates XML + PNG. Can 
choose colors. Indexed files.

CFF-TT Image Subtitles .xml Subtitles for UltraViolet platform. 
Text file + image file.

CFF-TT Text Subtitles .xml Subtitles for UltraViolet platform. 
Text file.

Digital Cinema Distribution 
Master .xml**

XML for package to distribute to 
theaters. Subtitle.

DVD Studio Pro 3 .txt DVD Studio Pro 3 .txt Text file for DVD Studio Pro.
DVD Studio Pro / 
Sonic Creator .son

Text file for DVD Studio Pro. For 
Sonic Creator. File + TIFF.

DVD Studio Pro .stl** DVD Studio Pro .stl** Text file for DVD Studio Pro. 
Native. Option for images.

EBU Subtitling Data Exchange 
Format .stl

EU market. Used for open 
subtitles. Includes Teletext Level 
1 encoding, Double Height 
characters, foreground color.

IMSC/SMPTE-TT XML with PNG 
(.XML and .PNG) **

IMSC/SMPTE-TT XML with PNG 
(.XML and .PNG) **
NetBlender Blu-ray .DoST Similar to Blu-ray, contains 

image files (PNG).
Netflix TT Subtitles .xml Netflix TT Subtitles .xml SMPTE XML for Netflix Timed 

Text.
QuickTime Subtitles Track** QuickTime Subtitles Track** Embedding into QuickTime. 

Subtitles. Multiple track capable.
QuickTime Text Track** QuickTime Text Track** 3GP file for mobile devices.

Rhozet .xml Used for Rhozet Carbon Coder. 
Generates XML + PNG. Can 
choose colors. Indexed files.

CVC DVD (.scr + .bmp)**
Daikin Scenarist TIF Graphics 
(.sst + .tif )**

DVD Architect Pro (.sub)** DVD Architect Pro (.sub)**
DVD Caption File (.cc) DVD Caption File (.cc)
DVD Caption File (.scc) DVD Caption File (.scc)
DVD T2 Links File (.scc)** DVD T2 Links File (.scc)**

Desktop Pro/Enterprise Notes
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DVDit Pro HD Subtitle Script 
(.txt)**
Generic DVD Subtitles (.txt + 
.bmp)**
HD-DVD (.hdt + .tif )**
Pinnacle Impression DVD Pro 
(.txt + .bmp)**
Sonic Producer Text (.txt)**
Sonic Solutions Text (.txt)**
Sonic Solutions TIF Graphics 
(.nav + .tif )**
Spruce DVDMaestro TIF Graphics 
(.son + .tif )
Spruce STL Script (extended 
positioning) (.stl)
Spruce STL Script (standard 
positioning) (.stl)

DVD Caption File (Scenarist 
.scc)**

DVD Caption File (Scenarist 
.scc)**

Generic for Scenarist files. Very 
limited, only 29.97. Used by most 
products.

Scenarist .sst Used for subtitling. Text and 
image.

SubRip .srt SubRip .srt Simple text. Used for web.
Texas Instruments DLP Cinema 
(DCI Interop) XML (.xml)
DLP Cinema text based Subtitle 
File (*.xml)**

Must use "Generic Subtitle" 
device. Font size in the DLP file = 
Font size in Windows * (1056 / H) 
where H is the video screen 
height in pixels. (e.g. Font size of 
43 for HD1080 video).

Ultech DV2000/3000 .usf, .uyc Subtitle added to DV2000/3000 
box. Real time subtitling (NBC).

                                  Korean Closed Captions
NTSC DV 720x480 Video with 
Korean CC**

708 Korean for special 
characters. SD only.

Black 720x482 movie with 
Korean CC**

708 Korean for special 
characters. SD only. Line 21 
overlay.

Desktop Pro/Enterprise Notes
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                                 Remote Caption Encode
Remote MPEG2 DTV 608/708 
Closed Captions**

 

                                 Convert
USF/UYC to DECE CFF*
USF/UYC to Rhozet/PNG*
USF/UYC to Text/PNG*
USF/UYC to TI DLP Cinema/PNG*

Desktop Pro/Enterprise Notes
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Installing MacCaption

The topics in this chapter provide system requirements, explain how to install or 
upgrade MacCaption, and describe how to use the HASP Network Dongle. 

Note: The Demo version of MacCaption can only run in trial mode. When you 
purchase a license, you must download and install a licensed version in order at 
activate MacCaption. 

The following topics are included:

■ System Requirements

■ Available Subtitling and Captioning Characters

■ Installing and Activating MacCaption

– Buying and Activating MacCaption

– Activating MacCaption Offline

– Upgrading MacCaption

– Deactivating Your MacCaption License

■ HASP Network Dongle

– Troubleshooting HASP
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System Requirements
The following provides the minimum operating system and computer requirements to 
run MacCaption. 

Supported operating systems: 

• macOS 10.14 (Mojave)

• macOS 10.15 (Catalina)

• macOS 11.2 (BigSur)

Computer requirements:

• Intel Processor

• QuickTime Player 7.6 or later

• 2GB RAM

• 5GB free Hard Disk space

• Minimum screen resolution: 1280x720 (720p)

• One free USB port (only if using a dongle-based license)

• Internet access required for Timed Text Speech transcription and some online fea-
tures

– The latest Safari or Chrome browser is required for some features 

• PDF reader required to view documentation

• Auto Time Stamp requires 2GB RAM and Java Runtime Environment (JRE) version 6 
or later. On OS X 10.10 and higher, use Java JDK version 8. 

Available Subtitling and Captioning Characters
For subtitling, you can generate any character or symbol that you can generate on the 
computer's screen, though you may have to download a font into the memory of your 
external device depending on which one you are using. 

However, captioning is a different case. The closed caption encoder does not actually 
draw the characters, but tells the closed caption decoder which characters to display. 
The languages supported by typical closed caption decoders include the following:

• Dutch, English, French, German, Portuguese, and Spanish.
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Installing and Activating MacCaption
Follow these steps to install MacCaption:

1. Download the Desktop, Pro, or Enterprise licensed version (depending on what you 
purchased) of the MacCaption installer and open the disk image. 

2. Double-click the installer package to open it. The installer displays a Welcome 
screen and important information. Click Continue. Follow the on-screen 
instructions in the installation dialogs.

 The installation continues, and at completion, a window opens to indicate success. 
Click Close to complete the installation. 
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Buying and Activating MacCaption
Buy and activate a MacCaption license as follows:

1. After purchasing MacCaption, you will receive instructions to download the 
licensed (non-Demo) version of the software. You must install the licensed version 
of MacCaption in order to activate your license. See the previous section for 
instructions on installing MacCaption.

2. To run MacCaption, find the MacCaption icon in your Applications folder, and 
double click it. 

The first time the software runs, if you have not already activated it on this com-
puter, you will be running in demo mode and restrictions will apply.

3. Open the Help menu, and select Manage MacCaption License. 

The MacCaption License dialog opens, indicating the software is not yet activated.

3. If you already have a serial number, click Activate Serial Number. If not, click on 
Purchase License and follow the on-screen instructions to purchase a license 
online. 

4.  Input your serial number and then click Activate. 

(Note: If you don’t have Internet access, you can activate using a different com-
puter that has Web access. See Activating MacCaption Offline.) 

5. After clicking Activate, MacCaption pops up a dialog asking you to enter your 
credentials. 
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6. Enter your Mac user name and password to authenticate your user account, then 
click Install Helper. 

7. Click OK, and then quit and restart the MacCaption software. 

8. Go to MacCaption > About MacCaption, and verify that you are running the proper 
license type (for example, Desktop, Pro, or Enterprise). 

  

9. Click OK. MacCaption is now installed and ready to use.
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Activating MacCaption Offline
Please follow the procedure outlined below to activate MacCaption on a computer that 
has no Internet connection:

1. To begin the manual activation, please open the 'Manage MacCaption License' 
dialog from the Help menu.

2. Click on the 'Activate Serial Number' button, enter your serial number, and then 
click the Activate button.

3. The Offline Activation dialog opens.
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Note: The code in this screenshot is for demonstration purposes only. You must use 
the code generated on your computer.

4. Copy the code provided in the “Offline Activation” window into TextEdit or 
Notepad and move the saved file onto a USB thumb drive.

Note: The code is linked to this computer. If you move the license to a new computer, 
you will need to generate a new Offline Activation code on that computer.

5. Using another computer with internet access; Copy the code from the USB or 
thumb drive and enter the offline activation code at URL: http://cws.telestream.net/
offlineactivation.aspx. 

6. Click the “Submit” button after entering in the code to receive the license file. 

7. Once the license file downloads, place on a thumb drive, or a location that is 
accessible by the Offline computer.

8. Go back to the machine without internet access and place the License file onto the 
desktop.

9. From the Offline activation window click “Choose License File...” button and select 
the License file. You will be prompted for your admin user name and computer 
password to proceed with the activation. Enter your computer password and you 
will see "Activation Succeeded".
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10. Quit and restart MacCaption. Then go to MacCaption > About MacCaption, and 
verify that you are running the proper license type (for example, Desktop, Pro, or 
Enterprise). 
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Upgrading MacCaption
If you need to use features that are in a higher level of the software, you can purchase 
an upgrade.

Note: If you are upgrading from a previous version and you work with external 
hardware, such as a caption encoder, VTR deck, or external time code interface, 
Telestream recommends that you write down your device configuration settings such 
as port, address, and so on, prior to upgrading, in case these settings need to be 
entered again.

1. Open the Help menu and select Manage MacCaption License. The MacCaption 
License window opens.

2. Click Upgrade License. 

3. The MacCaption online store window will open. Follow the on-screen prompts to 
select and purchase your upgrade.
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Activating a MacCaption Upgrade
Usually the upgrade process will complete automatically, but in some cases you may 
receive the upgrade key via email. In that case you must deactivate your old key in 
order to enter the new key. To activate your upgraded license, follow these steps:

1. Open the MacCaption Help menu, and select Manage MacCaption Activation. The 
MacCaption License window opens. 

2. Ensure that you have Internet access and then click on Deactivate Serial Number. 
You will be prompted to enter your Mac username and password.. 

3. After deactivation, MacCaption will automatically exit. Start the software again. It 
will start in Demo mode.

4. Open the Help menu, and select Manage MacCaption Activation. 

5. Click Activate Serial Number. The Serial Number entry form opens.

6. Enter the new upgrade serial number that was emailed to you, and click Activate. 
You will be prompted to enter your Mac username and password. Click Install 
Helper to conclude activation.
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7. Confirm that the screen now shows "MacCaption (Version): Activated" and displays 
the upgraded license level. 

8. Click OK. Then quit and restart MacCaption.

Deactivating Your MacCaption License
If you want to move the MacCaption license to another computer, you must first 
deactivate it on the current computer. This action requires Internet access. Follow these 
steps: 

1. Go to the MacCaption Help menu and select Manage MacCaption Activation. The 
MacCaption License window opens.

2. Click on Deactivate Serial Number. You must enter your Mac username and 
password in order to complete the deactivation process. 

3. Confirm that the screen shows "MacCaption (Version): Not Activated".

   

4. Once deactivated, you may now activate this serial number on another computer 
where you have installed CaptionMaker or MacCaption. 
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HASP Network Dongle
The network dongle option avoids the need to physically keep or move standalone 
(single user) dongles around to individual machines. For example, if you need 
Telestream software for 4 concurrent users at your organization. Instead of receiving 4 
single user dongles, you would receive one physical network dongle. It would be 
connected to any Windows or Mac physical machine on the LAN, and provides a 
floating license available to any physical or virtual machine on the LAN. Any computer 
on the LAN or VPN can make use of one of these licenses.

Another advantage is that the network licenses can be shared over the LAN or VPN 
(including over the Internet) without having to physically move the USB keys. This 
allows remote users to run the software on their computers while traveling or working 
remotely. Only the license itself is shared over the network, the actual software is 
running directly on the computer, so there are no speed issues like with "remote 
desktop" or screen sharing solutions.

The number of concurrent users of the software is limited to the number of licenses 
purchased. For example, if you have 4 licenses on your network dongle, any 4 machines 
can open the software at the same time; if a 5th machine tries to run the software, it will 
give an error until one of the other 4 open copies is closed. 

If you are interested in upgrading your existing single user keys to a network key or 
have any questions about the network key option, please feel free to contact 
Telestream.

The network dongle uses TCP/UDP port 1947 for local (LAN only) communication. This 
port must not be blocked in order for a station to access the network license.

Troubleshooting HASP
On any machine with Telestream captioning software (or just the HASP drivers) 
installed, you can check the status of HASP drivers and keys by going to:

http://localhost:1947

If the web page doesn't open as "Sentinel Admin Control Center", then the HASP driver 
is not installed or not running. You can get some troubleshooting tips in the Telestream 
web Knowledge-Base under “HASP dongle troubleshooting”.

If the page opens, click "HASP Keys" or "Sentinel Keys" (depending on the version) on 
the left.

On the Server Machine
The network key will show up under Location: Local. If not, then the server is not 
recognizing the dongle.
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Click Configuration on the left, then go to the tab "Access from Remote Clients".  Make 
sure "Allow Access from Remote Clients" is checked. If not, check it, then click Submit.

Click “Show Recent Client Access” to see IP addresses and client names that have 
communicated with the key. Under Access it should always say "allowed".  On this list 
you should be seeing the names/addresses of clients that are trying to access the key. 

On the Client Machines
The server's network key should show up under Location, and contain the name or IP 
address of the server. For example, VELA in the following screenshot.

Click Configuration on the left, then go to the tab "Access to Remote License Managers".  
The following checkboxes must be checked: "Allow Access to Remote Licenses" and 
"Broadcast Search for Remote Licenses".  You can also try checking "Aggressive Search 
for Remote Licenses".
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Pointing a Client to a Specific License Server
The following steps can be used if the client is not seeing the subnet broadcast packets 
from the license server, or if you have multiple license servers and want to restrict a 
specific client to only use a specific license server. Also, in general this may help if you 
are having trouble getting the server's key to show up on the client.

1. On each client, open http://localhost:1947.

2. Click Configuration on the left, then select the tab "Access to Remote License 
Managers".  

3. Uncheck the checkbox "Broadcast Search for Remote Licenses", and check the 
checkbox "Aggressive Search for Remote Licenses".

4. Under "Specify Search Parameters", enter the IP address of the license server.

5. Click Submit. (You may need to wait a few minutes.)

To Disable Remote Network HASP Keys on a Particular Client
If you have a client that you don't want to access a remote network key, you can disable 
access to remote keys. For example, a client has a single user HASP key and you don't 
want it to preferentially grab the network key instead. 

To disable access to remote keys:

1. Click Configuration on the left, then go to the tab "Access to Remote License 
Managers".  

2. Uncheck the option "Allow Access to Remote Licenses".

If You're Still Having Trouble
If the network key still does not show up on the client, and/or if the client does not 
show up on the server under "Show Recent Client Access", then TCP/UDP port 1947 
communication between the server and the client is getting blocked somehow. 
Unfortunately this opens up a wide range of possible issues specific to the network 
setup, and may require a networking guru to get involved.
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This glossary provides information about terms used in captioning and subtitling.

#

Section 508
Section 508 refers to accessibility law, which requires video broadcasts and many 
webcasts to be made accessible to the deaf and hard of hearing. Please see the official 
Section 508 web site for more details. This is not directly related to CEA-608 and CEA-
708, which are technical standards.

CEA-608
CEA-608 refers to the technical standard for captioning standard-definition NTSC video. 
It is also commonly referred to as "Line 21 closed captioning". See What is 608 and 708 
Closed Captioning? for an in-depth look at the difference between 608 and 708.

CEA-708
CEA-708 refers to the technical standards for captioning high-definition video. It is also 
commonly referred to as the VANC data or "Line 9 closed captioning". 

A

Active Format Description
Active Format Description (AFD): A standard for telling a receiving device how to best 
frame video. For example, without AFD, a 16:9 signal which contains a pillarboxed 4:3 
video would then be letterboxed for display on a 4:3 TV, making a tiny image 
surrounded by black bars on all sides. With AFD, the TV knows that it can crop the video 
so that the actual picture fills the whole screen. 
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ATSC
ATSC (Advanced Television Systems Committee) is the digital television (DTV) standard 
used by broadcasters for HDTV and the digital broadcast of SD in the United States and 
Canada. ATSC supports closed captioning (608 and 708) in the metadata of the video 
signal.

B

Burn-in
Burn-in refers to a graphic, text, or image that is superimposed on video, and thus 
becomes part of the video itself. Closed captions are not burned in, since they can be 
turned on and off, unlike open captions and many subtitles which cannot.

C

.CAP
A .cap file can refer to many different types of files, so you need to be careful when 
using them. Several formats of caption files have the .cap extension, including the 
popular Cheetah .cap format. A .cap file can also be a project file for CaptionMaker, 
which must be opened in CaptionMaker before exporting to another caption format.

Capture Card
A capture card is a piece of hardware for your computer that allows you to bring video 
into your computer for editing and output back to a physical format like tape. Many 
capture cards support closed captioning for HD and SD, including ones from Matrox, 
AJA, and Blackmagic.

Caption Decoder
A caption decoder is a device that enables closed captions to be turned on if they are 
present in the video signal, essentially turning closed captions into open captions. 
Typically a decoder is inside your TV or cable box and you can turn captions on using 
your remote or a setting in the menus. There are also hardware and software decoders 
available that allow you to preview captions on your computer or a master tape to 
ensure that they are present.

CaptionMaker
CaptionMaker is closed captioning software by Telestream for the Windows platform. 
CaptionMaker reads and writes all major captioning formats and supports many 
traditional workflows involving hardware encoders. In addition to broadcast SD video, 
CaptionMaker encodes captions for web formats like Quicktime, Flash, YouTube, and 
Windows Media, and also tapeless workflows like MPEG-2 Program Streams.
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Closed Captioning
Closed Captioning is text that appears over video, and can be turned on and off using a 
decoder which is built into most consumer television sets and cable boxes. Closed 
Captions differ from subtitles in that they contain information about all audio, not just 
dialogue. 

Codec
Codec stands for "coder-decoder". It is a hardware or software technology which allows 
for the compression and decompression of video and audio in order to strike a balance 
between file size and quality. Different codecs have different data rates, aspect ratios, 
and methods of closed captioning in order to achieve this balance. Some examples of 
codecs are DV, MPEG-2, WMV, H.264, Uncompressed, and ProRes. To watch a video, your 
computer needs the specific codec that video uses, otherwise it will not play. Not all 
codecs are available for all operating systems, and they may not be free to use.

Container Format
A container format is a way to encapsulate video so that it can be viewed in a video 
player, edited in an non-linear editor, or processed in some other way. Examples of 
container formats are QuickTime, AVI, and MXF.

D

Drift
"Drift" is a term used to describe a specific behavior of closed captions. It can either 
mean they are appearing progressively later than they should, or progressively earlier. 
Most often, this occurs slowly over the duration of a program, resulting in a discrepancy 
of over three seconds by the end of an hour. Drift is most often caused by a drop-frame 
/ non-drop discrepancy, or frame rate differences.

Drop-Frame
Drop-frame timecode refers to a method of counting timecode in 29.97 fps video. It 
does not refer to actual frames of video being dropped that would affect video quality. 
Since 29.97 fps is not exactly 30 fps, when counting in drop-frame certain numbers in 
the timecode counter are skipped in order to ensure that the timecode will reflect the 
real-time length of the program. The counterpart of drop-frame is non-drop which 
does not skip numbers when counting timecode. To prevent drift, it is important to 
timestamp in the correct mode (or convert your captions' timecode using Telestream 
software) when closed captioning a 29.97 fps program. Also see Non-Drop Frame. 
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DTV
DTV stands for "digital television" and is a general term encompassing digital television 
around the world to distinguish it from analog television (such as NTSC). In the US the 
standard for DTV is ATSC.

E

Elementary Stream
A data stream that contains either video or audio data, but not both. Usually associated 
with MPEG video files and given the extension .m2v for video, or .m2a or .ac3 for audio. 
Elementary MPEG-2 video streams can contain closed caption data. A Program or 
Transport stream can be demultiplexed, or separated, into its component Elementary 
streams.

Encoder
The term "encoder" typically refers to a hardware encoder, but can refer to software 
encoders as well. A hardware encoder is usually a rack-mounted device that accepts a 
video signal, marries it to closed captions, and then outputs a new closed captioned 
video signal, usually resulting in generation loss. A software encoder, such as 
CaptionMaker or MacCaption, can add captions to video without a hardware encoder. 
You can simply encode captions to video files already present on your computer, or to 
file formats that will add captions as you output from your NLE with no generation loss.

H

High Definition (HD)
High Definition is a television standard with either 720 or 1080 lines in the video signal. 
Closed captioning for HD is sometimes called Line 9 or VANC, and is codified under the 
708 standard.

L

Line 9
Line 9 refers to the location of the VANC closed captioning data in an HD video signal. 
In the full raster, it appears as the 9th line from the top of the frame.

Line 21
Line 21 refers to the location of the VBI closed captioning data in an NTSC720x486 
signal. It actually appears on lines 21 and 22 since line 22 is the second field of the 
closed captioning data.
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Live Captioning
Live captioning is a captioning process used for live webcasts or broadcasts to add 
captions to video on the fly. It requires several important tools. The first is a source of 
transcription such as a stenographer or speech recognition software. Please note, 
getting speech recognition software to usable levels of accuracy still requires an 
individual to operate it. The second item required for live captioning is a hardware 
encoder which will accept the video signal and the closed caption data and combine 
them for output. Also, you may need captioning software to tie these two things 
together (especially if you're using speech recognition software).

M

MacCaption
MacCaption is closed captioning software developed by Telestream for the Mac 
platform. MacCaption reads and writes all major captioning formats and supports the 
latest closed captioning workflows for Final Cut Pro. In addition to broadcast HD and SD 
video, MacCaption encodes captions for web formats such as QuickTime, Flash, 
YouTube, and Windows Media, and also tapeless workflows such as MPEG-2 Transport 
Streams, DVCPRO HD and XDCAM.

.MCC
MCC is a MacCaption closed captioning file, and the only file format that supports both 
608 and 708 (SD and HD) closed captioning, unlike SCC, which only can encode 608 
(SD) closed captions. CaptionMaker can also use this format. This comprehensive 
format is being used by several companies for integration into their closed captioning 
workflows.

MPEG-2
MPEG-2 can refer to not only a video codec, but also a container format. MPEG-2 can 
come in three different file types, Elementary Streams, Program Streams and Transport 
Streams. MPEG-2 files are becoming a more common form of video delivery because it 
allows a broadcaster to put it directly on their server instead of ingesting from tape. 
MacCaption can add captions to all three forms of MPEG-2 files.

N

Non-Drop Frame
Non-Drop Frame timecode refers to a method of counting timecode in 29.97 fps video. 
It does not refer to actual frames of video being dropped that would affect video 
quality. Since 29.97 fps is not exactly 30 fps, when counting in non-drop, the timecode 
will get progressively further and further behind "real time." For instance, after 2000 
frames a drop-frame counter will display 00:01:06:22, while a non-drop counter will 
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display 00:01:06:20, but the content and real-time length of the video will be the same. 
The drop-frame counter is slightly ahead because it's goes straight from 00:00:59:29 to 
00:01:00:02. To prevent drift, it is important to timestamp in the correct timecode mode 
(or convert your captions' timecode using Telestream software) when closed 
captioning a 29.97 fps program. Also see Drop-Frame. 

Non-linear Editor
A non-linear editor (NLE) is software that allows you to edit video by moving pieces of it 
around in a timeline with multiple layers of video. This is in contrast to linear editing, 
which forces you to add one piece of video after another to tape in a linear fashion. 
Many NLEs support closed captioning for HD, SD, or both. Examples of non-linear 
editors are AVID, Final Cut Pro, Premiere Pro, and Sony Vegas. 

NTSC
NTSC (National Television Systems Committee) is the analog, standard definition (SD), 
television standard for North America, Japan, and some other parts of the world. NTSC 
supports closed captioning (608 only) on Line 21 of the video signal.

O

Open Captions
Open captions are captions that do not need to be turned on, they are always visible. 
This is opposed to closed captions which must be turned on with a decoder. Open 
captions are actually part of the image itself. Open captions are also called burned-in 
captions.

P

Paint-on
Paint-on captions appear on the screen from left to right, one character at a time. This 
mode of displaying captions is uncommon, except as the first caption of many 
commercial spots to reduce lag.

PAL
PAL (Phase Alternating Line) is a system for analog television used in Europe, Asia, 
Australia, and most of South America and Africa. Broadcasting at 625-line / 50 field (25 
frame) per second (576i).

Pop-on
Pop-on captions appear on the screen one at a time, usually two or three lines at a 
once. This mode of displaying captions is typically used for pre-recorded television.
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Program Stream
A data stream that multiplexes, or combines, a single video and a single audio stream 
together. Usually given the extension .mpg, and used for files to be played on a 
computer, some DVD authoring systems, and some tapeless distribution.

R

Roll-up
Roll-up captions appear from the bottom of the screen one line at a time, usually with 
only three lines visible at a time. This mode of displaying captions is typically used by 
live television, such as news broadcasts.

Ruby Japanese Subtitle Formatting
(Ruby is currently only available in MacCaption)

Ruby subtitle formatting is a popular style of formatting that allows viewers to see an 
annotated description of a word on screen. Typically, the annotation is located above 
the text and is shown in smaller text size. This formatting is compatible with subtitle 
burn-in exports such as "Combined Subtitles" and with TTML OTT formated files such 
as iTunes .iTT.

S

.SCC file
SCC stands for "Scenarist Closed Caption", a file type developed by Sonic. SCC files have 
become a popular standard for many different applications of closed captions. Some 
programs that use .scc files are Sonic Scenarist, DVD Studio Pro, Final Cut Pro, and 
Compressor.

Shadow Speaker
When using speech recognition software, a shadow speaker is a person who repeats 
everything said in a program into a microphone so that the speech recognition 
software only has to interpret that shadow speaker's voice and not the multiple voices 
in the program. After training the software to the shadow speaker’s voice (about 15 
minutes), it can achieve accuracy rates up to 90-95% in a clean audio environment.

Speech Recognition
Speech recognition software takes spoken word and translates it into text. 
CaptionMaker and MacCaption include Timed Text Speech technology that creates a 
text transcript of a video and populates it directly into the captioning project with the 
correct timing. 
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Standard Definition (SD)
Standard Definition is a television standard with (typically) 480 lines in the video signal 
(486 when NTSC). Closed captioning for SD is sometimes called Line 21 and is codified 
under the 608 standard.

Stenographer
A stenographer is a person who can transcribe audio into written form on the fly (like a 
court reporter). Stenographers can also dial-in to a hardware encoder remotely over a 
phone line so that closed captions can be added to a video signal for live broadcast. See 
also: Live Captioning.

Subtitling
Subtitling is text that appears on screen that normally only gives information about 
dialogue that is spoken. With the exception of DVD and Blu-ray, subtitles cannot be 
turned off, but are burned into the image. 

T

Transport Stream
A data stream that multiplexes, or combines multiple video and audio streams together 
with other metadata. Usually given the extension .ts, .m2t, or .m2ts, and used for DTV 
broadcast, VOD, tapeless delivery, and other systems where multiple channels are 
mixed together.

V

VANC
VANC stands for "Vertical ANCillary data space" and refers to the data stored on Line 9 in 
HD video (outside the display area) that holds the 708 closed captioning data while it is 
going over an HD-SDI signal or on an HD tape format. VANC data appears on only the 
part of Line 9 towards the left, but VANC data can also carry different information, such 
as V-chip data.

VBI
VBI stands for "Vertical Blanking Interval" and is the time between the last line or field 
drawn in a video frame and the first line or field of the next frame. This is usually 
measured with lines, in NTSC there are 40 lines for VBI. Closed Captioning data for NTSC 
video is stored on Line 21 of the VBI.
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