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Preface

Copyrights and Trademark Notices
Copyright © 2020 Telestream, LLC and its Affiliates. All rights reserved. Telestream 
products are covered by U.S. and foreign patents, issued and pending. Information in 
this publication supersedes that in all previously published material. Specification and 
price change privileges reserved. TELESTREAM is a registered trademark of Telestream, 
LLC. All other trade names referenced are the service marks, trademarks, or registered 
trademarks of their respective companies.

Specifications subject to change without notice. Copyright © 2020 Telestream, LLC and 
its Affiliates. Telestream, CaptionMaker, Cerify, Episode, Flip4Mac, FlipFactory, Flip 
Player, Gameshow, GraphicsFactory, Lightspeed, MetaFlip, Post Producer, Prism, 
ScreenFlow, Split-and-Stitch, Switch, Tempo, TrafficManager, Vantage, VOD Producer, 
and Wirecast are registered trademarks and Aurora, Cricket, e-Captioning, Inspector, iQ, 
iVMS, iVMS ASM, MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port, 
CaptureVU, Cerify, FlexVU, Prism, Sentry, Stay Genlock, Aurora, and Vidchecker are 
trademarks of Telestream, LLC and its Affiliates. All other trademarks are the property of 
their respective owners.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour 
logo, and the Bonjour symbol are trademarks of Apple, Inc.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.



Preface
Copyrights and Trademark Notices

10

Sparkle, copyright (c) 2006 Andy Matuschak.

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the "Software"), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, merge, 
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons 
to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or 
substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL 
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR 
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 
OTHER DEALINGS IN THE SOFTWARE.

RSS reader class, copyright (c) 2002, Brent Simmons. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of ranchero.com or Brent Simmons nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS 
IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This project uses software developed by the OpenSSL Project for use in the OpenSSL 
Toolkit (http://www.openssl.org). This toolkit is licensed as follows:

Copyright (c) 1998-2005 The OpenSSL Project. All rights reserved.
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Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the 
following acknowledgment: "This product includes software developed by the 
OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or 
promote products derived from this software without prior written permission. For 
written permission, please contact: openssl-core@openssl.org.

5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" 
appear in their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment: 
"This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN 
NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, 
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This project uses Speex, an Open Source/Free Software patent-free audio compression 
format designed for speech and developed by the GNU Project 
(http://www.speex.org/). This codec is licensed as follows:

Copyright © 2002-2003, Jean-Marc Valin/Xiph.Org Foundation. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

 Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.
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 Neither the name of the Xiph.org Foundation nor the names of its contributors may be 
used to endorse or promote products derived from this software without specific prior 
written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS 
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN 
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) 
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young 
(eay@cryptsoft.com). This product includes software written by Tim Hudson 
(tjh@cryptsoft.com).

ShortcutRecorder, copyright 2006-2007 Contributors. All rights reserved.

License: BSD

Jesper, waffle software, <wootest+shortcutrecorder@gmail.com>

David Dauer, <david@daviddauer.de>

Jamie Kirkpatrick, Kirk Consulting Ltd, <jkp@kirkconsulting.co.uk> 

CTGradient, v 1.5, copyright (c) 2006 Cotingent.

Created by Chad Weider on 12/3/05.

Some rights reserved: http://creativecommons.org/licenses/by/2.5/

MIT License

Copyright (c) 2018 Telestream, LLC

Permission is hereby granted, free of charge, to any person obtaining a copy of this 
software and associated documentation files (the "Software"), to deal in the Software 
without restriction, including without limitation the rights to use, copy, modify, merge, 
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons 
to whom the Software is furnished to do so, subject to the following conditions:  The 
above copyright notice and this permission notice shall be included in all copies or 
substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL 
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR 
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
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ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 
OTHER DEALINGS IN THE SOFTWARE.

Limited Warranty and Disclaimers
Telestream, LLC. (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), is free from defects in materials and workmanship under normal 
operating conditions and use.

Software—If software is supplied as part of the product, the software will operate in 
substantial conformance with specifications set forth in its product user's guide. The 
Company does not warrant that the software will operate uninterrupted or error-free, 
will meet your requirements, or that software errors will be corrected.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality.

Software—If software is supplied as part of the product and it fails to substantially 
conform to its specifications as stated in the product user's guide, the Company shall, at 
its own expense, use its best efforts to correct (with due allowance made for the nature 
and complexity of the problem) such defect, error or nonconformity.

Software Updates—If software is supplied as part of the product, the Company will 
supply the registered purchaser/licensee with maintenance releases of the Company’s 
proprietary Software Version Release in manufacture at the time of license for a period 
of one year from the date of license or until such time as the Company issues a new 
Version Release of the Software, whichever first occurs. To clarify the difference 
between a Software Version Release and a maintenance release, a maintenance release 
generally corrects minor operational deficiencies (previously non-implemented 
features and software errors) contained in the Software, whereas a Software Version 
Release adds new features and functionality. The Company shall have no obligation to 
supply you with any new Software Version Release of Telestream software or third party 
software during the warranty period, other than maintenance releases.
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Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, LLC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product.

Damages
TELESTREAM, LLC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC.
848 Gold Flat Road
Nevada City, CA 95959

You can call Telestream, LLC. via telephone at (530) 470-1300.
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Telestream Contact Information
To obtain product information, technical support, or to provide comments on this 
guide, contact us using our Web site, email, or phone number as listed in Table 1.

Table 1. Telestream Contact Information

Resource Contact Information

Telestream Technical 
Support

Web Site: http://www.telestream.net/telestream-support

Support Web Mail. www.telestream.net/telestream-support/
screen-flow/contact-support.htm

ScreenFlow Technical 
Support, FAQs, 
Forums, & Upgrades

Web Site: http://www.telestream.net/telestream-support/
screen-flow/support.htm

Telestream, LLC. Web Site: http://www.telestream.net/purchase/store.htm

Online Web Store: info@telestream.net

Sales and Marketing Email: info@telestream.net

Phone:  530-470-1300

Telestream, LLC. 
848 Gold Flat Road
Nevada City, CA. USA 95959

International 
Distributor Support

Web Site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net

If you have comments or suggestions about improving this 
document, or other Telestream documents—or if you've 
discovered an error or omission, please email us.

mailto:info@telestream.net
http://www.telestream.net/telestream-support/overview.htm
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
http://www.telestream.net/purchase/store.htm
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
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About ScreenFlow

This guide is designed to help you understand how to use ScreenFlow to record, edit, 
and create high-quality screencasts and encode them as MPEG-4 files, or publish them 
directly to video sites such as YouTube, for your audience to enjoy.

This guide also provides hints, tricks, and other information to help you make the best 
screencasts possible.

 Record, Edit, Share

 ScreenFlow Trial Mode

 Making Movies in ScreenFlow

 Making Slide Shows in ScreenFlow

 Opening ScreenFlow

Note: If you haven’t installed ScreenFlow yet and would like to now, proceed to 
Installing ScreenFlow.
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Record, Edit, Share
Telestream’s ScreenFlow is a powerful, easy-to-use screen recording and video editing 
software for the Mac. 

With ScreenFlow, you can easily create screencasts—recording your entire display 
while simultaneously capturing your video camera, microphone, and your computer 
audio. ScreenFlow is ideal for creating screencasts for software demos, tutorials, 
application previews, training, and business presentations.

The easy-to-use editing interface lets you creatively edit your video, and add additional 
images, voice-overs, text, and music beds, with callouts and transitions for a truly 
professional-looking video. The finished result is an MP4 movie, ready for publishing to 
your Web site, blog or directly to Vimeo or YouTube.

Or, use ScreenFlow simply as an intuitive video editor to edit and create your own best 
picture nominee.

ScreenFlow Trial Mode 
Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Until you unlock ScreenFlow by purchasing a license and activating it, ScreenFlow 
operates in trial mode. In trial mode, all of ScreenFlow’s features are available, but your 
movies are watermarked when you export or publish them.

To unlock ScreenFlow, go to Unlocking ScreenFlow via Telestream Web Store. 
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Making Movies in ScreenFlow
With full support for 64-bit architecture, ColorSync, Retina displays and built on Cocoa, 
not only is ScreenFlow a powerful, intuitive and responsive application for creating 
screencasts, it doubles down as a snappy movie maker. 

With its essential nonlinear editor features like the canvas and timeline, making movies 
using your own clips is a snap. Import your own movie clips into the media library, and 
drop them right into the timeline. With its magnetic properties, you can join and sync 
clips without overlaps or clicks in a single drop, then add transition effects, and voice 
overs and music beds.

Using ScreenFlow’s essential features, making your own movies is easy. You don’t have 
to wade through a cluttered jumble of things you’ll never use, just to get your movie 
built. ScreenFlow helps you do what you want—make great movies for friends and 
customers. It doesn’t force you to become a professional editor just to get the job done.

Everything you need is at your fingertips: clip nesting and grouping, video and sound 
effects, tracks and canvas, video clipping, transitions, and support for external camera 
and mic recording.

Use ScreenFlow’s integrated rendering in MEPG-4, and you’ll be premiering your movie 
in no time.

Making Slide Shows in ScreenFlow
Slide shows have never been easier to make. You can use images in leading formats 
including PNG, TIFF, and JPEG and many others. You can adjust each image to display 
just the right length of time. And, you can make great transitions, create text overlays 
and graphics, and add your own voice-overs and add music beds, trimmed just right. 
Just like movies, you can use integrated publishing directly in ScreenFlow to render 
your movie for publication or distribution. 

Opening ScreenFlow
To open ScreenFlow, follow these steps:

1. Open your Applications folder.

2. Drag ScreenFlow onto your dock bar.

3. Click the ScreenFlow icon to launch the application.

When you launch ScreenFlow, it displays a Welcome window.



About ScreenFlow
Opening ScreenFlow

20

Figure 1. ScreenFlow Welcome Window

When you’re ready to start recording, select New Recording to display the Configure 
Recording window.

See Recording Media in ScreenFlow for detailed information about recording.
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New Document enables you to set screen dimensions and create a new document. Set 
screen dimensions and the Timeline Framerate, then click the open icon. 

The Preset drop-down menu contains a list of popular document dimensions. Screen 
dimensions include: 4k, 1080pHD, 720p,Web, iOS Capture (various types), and 
instagram.

Recent Document displays a list of recently opened documents for selection. Select a 
recent document and click the open icon.

Set screen 
dimensions

Select Timeline 
Framerate

Click the 
open icon

Select recent 
document

Click the 
open icon
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When a ScreenFlow project is opened and ScreenFlow detects a missing file, the 
Missing Media Wizard displays, enabling you to remove the missing file or replace it. 
Click Remove to remove the file from your workflow, or click Choose to navigate to a 
replacement file. After you have removed or replaced the missing file, click Continue to 
close the Wizard and access your document.

New From Templates displays a list of previously created templates. (See Templates for 
detailed information about creating and using templates.)
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Stock Media Library displays a screen that enables you to buy stock media. Click Buy to 
get started. (See Stock Media Library for detailed information about using stock media.)

Click Buy
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Installing ScreenFlow

This chapter specifies the platform requirements for ScreenFlow, and describes how to 
install, upgrade, and uninstall ScreenFlow and related subsystems.

Note: These topics apply only to purchases of ScreenFlow from the Telestream Web 
Store. If you purchased ScreenFlow from the Mac App Store, refer to their installation 
and upgrade instructions.

These topics are covered:

 System Requirements

 Installing ScreenFlow via Telestream Web Store

 Unlocking ScreenFlow via Telestream Web Store

 Activating Your Telestream Web Store License

 Installing Telestream Audio

 Deactivating Your ScreenFlow License

 Removing ScreenFlow from Your Computer

Be sure to review the platform requirements before installing ScreenFlow.
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System Requirements
• Intel-based1 Mac2 with 64-bit processor - Core i3+ recommended

Note: Intel GMA chips are unable to support Motion Blur and some Callout features. 
ScreenFlow does not support "Hackintosh" systems

• Operating Systems

– macOS Catalina 10.15

– macOS Mojave 10.14 

– macOS High Sierra 10.13 

• Minimum 2 GB RAM

• 20 GB hard drive

• Apple macOS approved graphics card required

Note: ScreenFlow requires a GPU officially supported by Apple.  ScreenFlow does not 
support NVIDIA "Web Drivers".  eGPU (external thunderbolt GPU) workflows are not 
yet supported by ScreenFlow 

• Cameras using the DV and/or HDV codec are not supported. Click here to learn 
more.

• Online Help browser requirements: Safari

Note: Cameras using an HDV codec are not supported.
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Installing ScreenFlow via Telestream Web Store
Note: You must be logged in as an administrator in order to continue.

ScreenFlow is available from Telestream as a disk image (dmg) file, as well as from the 
Mac Apps Store. This topic is for users who have downloaded ScreenFlow from the 
Telestream Web site.

When you download or open the .dmg file in Safari, Mac OS X automatically mounts the 
disk image and runs the installer. When you download a .dmg file using another Web 
browser, double-click on the .dmg file to run the ScreenFlow installer.

Note: The installer attempts to close applications including QuickTime, Final Cut Pro, 
Episode Desktop, and Pipeline Control before installation. If the installer can’t close 
these applications, installation will fail after about a minute.

When the installer runs, it displays the window depicted below, in Figure 2.

Figure 2. Installing ScreenFlow

http://www.telestream.net/controls/screenflow/download-screenflow.htm
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Drag the ScreenFlow icon onto the Applications folder to install ScreenFlow.

Enter an administrative user’s name and password to continue. When installation is 
complete, Close the installer—ScreenFlow is installed and ready for you to use.

Unlocking ScreenFlow via Telestream Web Store
You must purchase a ScreenFlow license in order to export movies without 
watermarking them. 

Note: This topic does not apply to users who purchased from the Mac App Store. The 
App Store has its own installation and licensing procedure.

Note: You must be logged in as an administrator in order to continue.

To purchase a ScreenFlow license, follow these steps: 

1. Start ScreenFlow.

2. Select ScreenFlow > Preferences and click the Licenses tab, as shown in Figure 3.

Figure 3. Preferences Licenses Pane

3. Click Purchase. This redirects you to the Telestream online store where you can 
purchase or upgrade your license.

When the purchase is complete, the ScreenFlow license installs automatically.

Note: If ScreenFlow doesn’t display a Purchase button, then you have already 
registered ScreenFlow and it’s been activated and unlocked.

Click License tab

Click Purchase
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Activating Your Telestream Web Store License
If you have already purchased a license through the Telestream Web Store, Telestream 
sent you an email receipt containing your license key.

Note: If your Macintosh is not connected to the Internet, follow the instructions in the 
Manual Activation Guide to activate your license and unlock ScreenFlow.

The easiest way to register the license key and activate ScreenFlow is to click on the link 
provided in your email receipt. If the link doesn’t work, register ScreenFlow as follows:

1. Launch ScreenFlow.

2. Select ScreenFlow > Preferences and click the Licenses tab.

Note: If ScreenFlow doesn’t display a Purchase menu, then you have already 
registered and unlocked ScreenFlow.

3. Enter your serial number and click Activate, as shown here in Figure 4.

Figure 4. Enter Your Serial Number To Unlock ScreenFlow

Note: If the Activate button is dimmed, it means that the license is invalid. Double-
check your license from the e-mail. Make sure that all letters are capitalized, dashes are 
included, and all 0’s are zeros, not the capital letter O. It may also help to copy and 
paste your serial number from your e-mail, but be careful not to copy any additional 
text such as a space. If you are still having problems, please contact technical support.

Now your serial number is activated and ScreenFlow is unlocked. Close the Preferences 
window to continue.

Click License tab

Click Activate

Enter serial 
number

http://dev2.telestream.net/telestream-support/screen-flow/help.htm 
http://dev2.telestream.net/telestream-support/screen-flow/help.htm 
http://www.telestream.net/telestream-support/screen-flow/contact-support.htm
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Installing Telestream Audio
To capture computer audio, ScreenFlow must install the Telestream Audio driver.

Note: You must be logged in as an administrator in order to continue.

The installation process begins automatically if you attempt to record computer audio 
without the driver installed.

Note: If you purchased ScreenFlow from the Mac App Store, you will be directed to 
the Telestream Web site to download and install the driver.

To install the Telestream Audio driver manually, follow these steps:

1. In ScreenFlow, select ScreenFlow > Preferences, then click the Advanced tab.

2. Click the Install Driver button to display the Install Telestream Audio dialog using 
the Installer application.

3. Click Continue to proceed. The installer displays a space requirement message. 

4. Click Install to continue.

5. Enter your password to install the driver and click OK to continue.

6. The installer installs the Telestream Audio driver. Upon completion, click Close to 
close the Installation Complete dialog.

Upgrading Telestream Audio

Note: If you are prompted at any time by ScreenFlow to upgrade the audio driver, exit 
out of the upgrade message by selecting Cancel. First, uninstall the current Audio 
Driver, then install the latest version of the Audio Driver either manually or using the 
Record Computer Audio checkbox.

To upgrade the Telestream Audio driver manually, follow these steps:

1. In ScreenFlow, select ScreenFlow > Preferences, then click the Advanced tab.

2. Click the Install Driver button to display the Install window, then click Continue. 

3. When the space requirement message is displayed, click Install.

4. Enter your password and click Install Software.

5. After the Telestream Audio driver is installed, click Close.

To upgrade the Telestream Audio driver through the New Recording tab, follow these 
steps:

1. Launch ScreenFlow to display the Welcome window.

2. Select New Recording.

3. Check Record Computer Audio.
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4. When the upgrade message displays, select Upgrade, and click Continue.

5. When the space requirement message is displayed, click Continue.

6. Enter your password and click Install Software.

7. After the Telestream Audio driver is installed, click Close.

Uninstalling Telestream Audio
To uninstall the Telestream Audio driver, select ScreenFlow > Preferences, then click the 
Advanced tab. Click the Uninstall Driver button and enter the password to uninstall the 
driver.

Deactivating Your ScreenFlow License
If you want to use your ScreenFlow license on another computer, you must deactivate it 
first. Then, you can activate the license in ScreenFlow running on another computer

Note: This topic does not apply to users who purchased from the Mac App Store. The 
App Store has its own installation and licensing procedure.

Your user must be an administrator. If your user is not an administrative account, you’ll 
need to create one (or log on with one) in order to continue.

To deactivate your ScreenFlow license, follow these steps: 

1. Start ScreenFlow.

2. Select ScreenFlow > Preferences and click the Licenses tab, as shown in Figure 5.

Figure 5. Preferences Licenses Pane
Click License tab

Click Deactivate
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3.  Click Deactivate to deactivate the license on this computer. Now, you can use the 
same license in ScreenFlow running on another computer. Please allow 15 minutes 
before trying to reactivate your license. 
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Removing ScreenFlow from Your Computer
To uninstall ScreenFlow, open the Applications folder and drag the ScreenFlow 
application to the trash. (The ScreenFlow license is stored separately, so you do not 
need to re-activate your license if you reinstall ScreenFlow.)

The files that you remove depend on the versions of ScreenFlow you have had on your 
computer. 

 Removing ScreenFlow Files Upgraded from Version 2.0

 Removing ScreenFlow Files Upgraded from Version 3.0

 Removing ScreenFlow Files from Version 4.0

Removing ScreenFlow Files Upgraded from Version 2.0
To completely remove ScreenFlow that has been upgraded from version 2.0, move 
these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow.plist

• ~/Library/Preferences/com.vara.screenflow.LSSharedFileList.plist

• ~/Library/Preferences/com.vara.screenflow.plist

• ~/Library/Preferences/com.vara.screenflowhelper.plist

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files Upgraded from Version 3.0
To completely remove ScreenFlow that has been upgraded from version 3.0, move 
these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/net.telestream.screenflowhelper.plist
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Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files from Version 4.0
To completely remove ScreenFlow that was installed (not upgraded from a previous 
version), move these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow.plist

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp.plist

• ~/Library/Preferences/WSG985FR47.net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files from Version 5.0
To completely remove ScreenFlow that was installed (not upgraded from a previous 
version), move these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow.plist

• ~/Library/Preferences/net.telestream.screenflowapp.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp5.plist

• ~/Library/Preferences/WSG985FR47.net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files from Version 6.0
To completely remove ScreenFlow that was installed (not upgraded from a previous 
version), move these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Preferences/net.telestream.screenflow6.plist
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• ~/Library/Preferences/net.telestream.screenflow.LSSharedFileList.plist

• ~/Library/Preferences/net.telestream.screenflowapp6.plist

• ~/Library/Preferences/WSG985FR47.net.telestream.screenflowhelper.plist

Note: Some of these files may not be present, because the associated feature was not 
used.

Removing ScreenFlow Files from Version 7.0
To completely remove ScreenFlow that was installed (not upgraded from a previous 
version), move these files to your trash:

• /Applications/ScreenFlow

• /System/Library/Extensions/TelestreamAudio.kext

• /Library/Audio/Plug-Ins/HAL/TelestreamAudioCapture.driver

• /Library/Preferences/net.telestream.screenflow7.plist

• ~/Library/Preferences/net.telestream.screenflow7.plist

• ~/Library/Preferences/net.telestream.screenflow.LSSharedFileList.plist

• ~/Library/Preferences/WSG985FR47.net.telestream.screenflowhelper.plist

• ~/Library/Saved\ Application\ State/net.telestream.screenflow7.savedState

• ~/Library/Application Support/ScreenFlow/Global Library

•

Note: Some of these files may not be present, because the associated feature was not 
used.
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Getting Started

These tours are designed to introduce you to the capabilities and significant features of 
ScreenFlow.

We encourage you to take these tours before beginning a screencast or other 
ScreenFlow project. They help you to gain a basic understanding of how ScreenFlow 
works and help to familiarize yourself with the program.

The creation of a ScreenFlow screencast is a three step process: first you record your 
video, next you edit your screencast project, and finally you export your screencast to a 
video file or publish it directly to an Internet video service such as YouTube and others.

For video tutorials, please visit our ScreenFlow demos page.

 Tour 1: Recording With ScreenFlow

 Tour 2: Editing Your Screencast

 Tour 3: Publishing Your Screencast

http://www.telestream.net/telestream-support/screen-flow/training.htm
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Tour 1: Recording With ScreenFlow
This first tour focuses on creating a high quality recording for editing and publishing. 
When creating a screencast, it is important to prepare your recording properly while 
considering how you intend to use this screencast.

We recommend that you record a few sample screencasts to familiarize yourself with 
ScreenFlow and its options, before creating a screencast for publication.

To record a screencast with ScreenFlow, follow these basic steps:

1. Open your Applications folder.

2. Drag ScreenFlow onto your dock bar.

3. Double-click the ScreenFlow icon to launch the application.

When you launch ScreenFlow, it displays a Welcome window.

Figure 6. ScreenFlow Welcome Window
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When you’re ready to start recording, select New Recording to display the Configure 
Recording window.

Figure 7. Configure Recording Window

Configuring Your Recording
Use the Configure Recording window to specify your recording sources. This opens 
when you launch the application and select New Recording. It can also be accessed from 
ScreenFlow Helper > Configure Recording.

Record Desktop from Check this option to record your computer monitor. This source 
records by default. If you have multiple displays connected, you can record on any or all 
of them.

Desktop video and computer audio are combined into a single clip, and added to your 
project as a .scc file.

Record IOS Device Check this option to record your screen from any IOS device and 
then select an IOS device from the drop-down menu. (IOS devices must be connected 
to appear in the menu.)

Record Video from Check this option to record video from any camera connected to 
your computer. Use the drop-down menu to choose from multiple cameras. Upon 
selecting a source, a preview image is displayed below.

Select New 
Recording
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Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

Record Audio from Check this option to record audio from any microphone 
connected to your computer. Use the drop-down menu to choose from multiple 
microphones. Upon selecting the source, the volume level is displayed below.

Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

ScreenFlow records microphone audio at a sample rate of 48KHz.

Record Computer Audio Choose this option to record all sounds played through your 
computer. The ScreenFlow audio driver must be installed to use this setting. If the 
driver is not installed, you are prompted to install it.

Desktop video and computer audio are combined into a single clip, and added to your 
project as a .scc file.

Click the Advanced Settings radio button to display more recording settings.

Note: When you check Record Computer Audio, the following message may display:

If it does, please consult ScreenFlow 7.3.1 and higher: New Audio Driver located on the 
Telestream Knowledge Base at:  
https://support.telestream.net/s/article/ScreenFlow-7-3-1-and-higher-New-Audio-Driver

Beginning Your Recording
When you are ready, click the Record button. ScreenFlow enters a countdown mode 
before recording. You can change the length of this countdown (see Using the 
Countdown Window). 

Create a short presentation then stop your recording: press Shift-Command-2 or select 
Stop Record from the ScreenFlow Helper menu in the upper-right corner of your 
display. 

When you stop recording, ScreenFlow opens your recording in the ScreenFlow editing 
window with all of your recorded sources placed on the timeline.

https://support.telestream.net/s/article/ScreenFlow-7-3-1-and-higher-New-Audio-Driver
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Display video and computer audio are combined into one clip; camera video and 
microphone audio are combined in another clip, to maintain video/audio sync. Video 
and audio can be separated by selecting the clip and choosing Edit > Detach Audio.

Partial Screen Capture
Partial screen capture enables you to record just a portion of the screen. 

The partial screen record button (the dashed rectangle icon) is located to the left of the 
main record button. When clicked, the screen will darken and a rectangular selection 
will appear. This capture area can be resized using the mouse. While the rectangular 
selection is present, the user cannot interact with any windows on their desktop, and 
the mouse is now controlling the sizing of the region. 

There is a control strip at the bottom of the focused screen where you can cancel out of 
this mode, start the recording, or use presets to constrain the region you are capturing. 
(See Partial Screen Capture for more detail).

Advanced Settings
The Advanced Settings button above the Record button in the Configure Recording 
window switches to the Timed Recording pane. In addition to setting the Desktop 

Cancel
Record

Presets

Partial screen 
record button
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Framerate, you can record in a loop or record for a set duration. (See Advanced Settings 
in Recording for more detail).

Advanced 
settings 
button
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Tour 2: Editing Your Screencast
The purpose of this tour is to familiarize you with the basic editing features of 
ScreenFlow. This tour describes some of the most common and basic editing 
techniques.

For a comprehensive description of editing features, see Editing ScreenFlow Projects.

When you finish your recording, ScreenFlow creates a new document and recorded 
media is placed at the beginning of the timeline. The media elements on the timeline 
reference your project’s stored media. Changes made on the timeline or on the canvas 
do not alter your original recording.

The Editing Window
The space used for editing is the editing window, which consists of three main parts: 
Canvas Control, Playback Controls, and Timeline area.

Figure 8. Editing Window

Canvas Controls

The large, central area of the editing window is called the canvas. This offers a preview 
of all visual elements in your project. The gray space around the preview is for elements 
that will not be present in your exported video. This is used to display off-screen 

Canvas

Timeline areaCanvas control Playback controls

Properties
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elements present in scaling and panning effects. The elements displayed on the canvas 
reflect the position of the scrubber on the timeline.

You can set the canvas size and background color using the canvas controls (see 
Configuring the Canvas).

Timeline Area

The wide area at the bottom of the screen is the timeline. This is a visual representation 
of the temporal length of your screencast. The scale at the top of the timeline 
represents measurements of time.

The red vertical line on the timeline is called the scrubber. This represents the current 
temporal position of the preview currently displayed on the canvas.

The timeline is divided into tracks to manage different clips overlapping at the same 
time. If the clip is visual (i.e. video, image, or text), the upper most track is displayed over 
the lower tracks.

Between the canvas and the timeline are playback controls which enable you to play 
your screencast and jump to the beginning or end of your video.

Properties

On the upper-right side of the editing window are the Properties tabs. These are the 
main editing controls of ScreenFlow and allow you to configure each clip in your 
screencast. It also includes the media library which stores all recorded and imported 
media in an unaltered state.

For more information, see the Properties topics in Editing ScreenFlow Projects.

Canvas Cropping
Canvas cropping is used to change the resolution or aspect ratio of the workspace you 
have to edit in. This can be useful if you want to constrain your screencast to only a 
portion of the total recording (i.e. a foreground window).

Canvas cropping is accessible through the canvas cropping button located on the left 
side of the tool bar. 

This is set by numerically entering the width and height values or dragging the edge of 
the canvas with your mouse cursor.

Note: The canvas can be set to a size larger than the original recording by using the 
File > Document Settings. Remember, the canvas size represents your total usable 
display space, which converts to the frame size of your video when you export or 
publish it.

Canvas cropping button
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Figure 9. Canvas Controls

Image Cropping
To crop an image, select the video or still image on the canvas. Hold the Control key 
and drag the edge or handles of the image to constrain and crop it. Hold the Control 
and Shift keys and drag to just crop the image.

Actions
Actions are property changes used to transition the media from one state to another.

Actions are added to a clip by selecting the clip, opening the property that you want to 
alter, then clicking the Add Action button (+Action) at the top of the properties pane. 
The action is placed in relation to the position of the scrubber, but can be moved on the 
clip. The duration of the action is changed by dragging the edge of the action to 
lengthen or shorten the action.

Figure 10. Video Properties Action
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Place the scrubber before or after the action to make changes to the property relative 
to the action. When the scrubber is placed before the action, this sets the properties of 
the clip before the action. When the scrubber is placed after the action, this sets the 
properties of the clip after the action.

Video Properties
Video properties can be used to make changes to any recorded or imported video, 
video action, or image file. This includes both screen and camera recordings.

This tour focuses on the most common features. For more details, see Configuring Video 
Properties.

Figure 11. Video Properties

Scale Use this option to change the size of a video or image relative to the size of the 
canvas. This can be used for highlighting a particular portion of the screen or with a 
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video action to create a zoom effect. Use the slider or enter a percentage value to 
change the image scale.

Scale to Fit button Enlarges clip to fill the window, while maintaining its scale.

Stretch to Fit button Enlarges clip to fill the window, without maintaining its scale (fills 
the entire window).

Reset button Restores the clip to its original scale and size.

Position Position represents the location of your video or image on the canvas. The 
position is based on the exact placement of the center of your image. Values in the 
position field are represented in pixels. You cannot reposition the clip on the canvas 
with arrow keys all of the time. The clip must be selected using the mouse. If the clip is 
selected on the timeline, the arrow keys do not adjust the location of the clip on the 
canvas.

You can reposition the image by dragging the image on the canvas, nudging the image 
with the arrow keys, or entering a numerical value in the position fields.

XYZ Rotation You can rotate the image on its X, Y, or Z axis by entering a value in 
degrees, or by clicking and dragging (in circular motion) the rotation icon to the right of 
the value field.

Opacity This is the degree to which the image is translucent. The greater the value, the 
more opaque the image. If the value is set to zero, the image is invisible. This is used 
with a video action to fade an image in or out. It is particularly useful if you would like 
to periodically display your camera recording.

Cropping Click the disclosure triangle down to display cropping options. Set the crop 
margins (by pixel) for left, right, top and bottom. 

Reflection Check to implement reflection. Use the slider to set the value or enter it 
manually (0 to 100%). Reflection creates a mirror image of the selected clip below the 
clip itself. The greater the value, the more opaque the reflection. When set to zero, the 
reflection is invisible.

Corner Round Move the slider to round the corners on your media display. 

Drop Shadow Check to create a shadow effect behind a still image. If the image uses a 
transparency, the shadow only reflects the non-transparent part of your image. Use the 
thumb wheel (or enter the value manually) to set the Angle of the shadow relative to 
the image in degrees (-180 to 80 degrees). The default is -45 degrees. You can also 
select a shadow color by clicking in the Color box to open the color pallet. Slide the 
Offset slider to set how far the shadow is displayed from its object. Slide the Opacity 
slider to adjust the transparency of the shadow. Slide the Blur Size slider to adjust the 
amount of blur (fuzziness) in the shadow. 

Color Controls Click the disclosure triangle down to display color options, and adjust 
saturation, brightness, and contrast using the sliders.

Video Filters Click the plus icon to add filters to the selected clip.
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Screen Recording Properties
Screen recording properties are effects specific to demonstrations using the mouse and 
keyboard. They can only be applied to screen recording clips.

This tour focuses on the most common features. For more details, see Configuring 
Screen Recording Properties.

Figure 12. Screen Recording Properties

Show Mouse Pointer. When checked, any mouse pointer icon activity in the screen 
recording is displayed. When unchecked, the mouse pointer is hidden.

Pointer Zoom. Often it can be difficult to see the mouse in a screencast, particularly if 
the video has been significantly resized. Increasing the pointer zoom value makes the 
mouse cursor larger and easier for the viewer to follow.

Click Effect. This feature can be used to make a visual effect when you click your 
mouse. Select Radar to screencast a red circle with each click or Invert to change the 
cursor from black to white with each click.

Pointer. Select the icon image used as the mouse pointer.

Opacity. This is the degree to which the mouse pointer is translucent. The greater the 
value, the more opaque the image. If the value is set to zero, the image is invisible.

Sound on Click. Select this option to generate a click sound when the mouse button is 
pressed. You can set the volume by moving the Volume slider (or by entering a value 
manually). You can also select the source of your click sound by clicking Choose and 
navigating to a file containing the sound you want.
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Show Keystrokes. Check to displays keys being typed during a recording. Select 
between Show All Keys and Show Modifier Keys (F1 through F12 and arrow keys). Enter 
values for Height and Position of the Keystrokes display. Set the Width by moving the 
slider.

Attached To Clip. When checked, the keystroke bar will be attached to the screen 
recording clip, and will be affected by any changes made to the recording. This includes 
scaling, cropping, and any changes made to the canvas crop. When unchecked, the 
keystroke bar will only be affected by changes to canvas crop, and will remain centered 
to the canvas if any changes are made.

Callout Properties
Callout Properties are used to highlight a specific portion of the screen. They can be 
applied to screen recordings, images, or video clips. Unlike the other properties, Callout 
Properties must be used with an action.

This tour focuses on the most common features. For more details, see Configuring 
Callout Properties.

Figure 13. Callout Properties

Highlight. Callouts are capable of highlighting an area in three different ways. Mouse 
cursor highlights a circular space around the mouse cursor. Foreground Window 
highlights any window which is currently active. Freehand allows you to draw the area 
you want to highlight.

Opacity. The opacity slider controls the opacity of the space outside the callout. A low 
value makes the surrounding area more visible, while a high value makes the 
surrounding area less visible.
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Blur. Move the slider to increase/decrease the amount of blur in the callout.

Blur Background. Check to blur the background of the callout and not just the edges.

Zoom Up. This option magnifies the area inside the callout to make it more prominent.

Border. This option increases the range of the callout area to draw attention to a larger 
space. This feature is not available with freehand callouts.

Outline Enter the value (in pixels) to create an outline around the callout area (range: 0 
to 59.) Click the color box to change the color of the outline

Shadow. Check to add a drop-shadow around the callout. Move the slider to adjust the 
amount of shadow. 

Feather. Specify the blend value (in pixels) to apply to the callout border to create a 
smooth transition between the callout area and the surrounding space (range: 0-20).

Round. Applies to foreground window callouts only. Specify the round-off value (in 
pixels) of the callout edge to create a more gentle appearance (range: 0-59).

Build. Specify the transition time of the callout, in seconds, up to 2 decimal places, and 
from 0 to 4 seconds. Duration In determines the amount of build-in time to reach the 
full effect of the callout. Duration Out determines the amount of build-out time to 
return to normal.

Touch Callout Properties
Touch callouts work in a similar fashion to freehand callouts. When the action is 
selected in the timeline, the video view enters a modal editing state, which is 
represented by the timeline. Only the currently selected clip and some editing controls 
in the top right corner of the video view are highlighted. This modal editing state can 
be exited by clicking away from the touch callout, or by clicking the close button on the 
editing tools.



Getting Started
Tour 2: Editing Your Screencast

51

The touch callouts are configured through a tab in the ScreenFlow inspector where the 
touch callouts can also be added. 

Count Select the number of Touch Callouts.

Fill Check to choose Solid Color Gradient from the popup menu. For solid color, select a 
color from the color wheel. 

Outline Enter the value (in pixels) to create an outline around the callout area (range: 0 
to 59.) Click the color box to change the color of the outline.

Size Move the slider to set the size of the Touch Callout area (in pixels). You can also 
enter size value and press the Enter key.

Spacing Move the slider to set the distance between multiple Touch Callouts. This 
setting is grayed-out if you have only one Touch Callout.

Opacity Enter a value, or click the up or down arrows, to set the amount of opacity 
(transparency) of a selected Touch Callout.

Rotation Enter a value, or click the up or down arrows, to set the amount of rotation of 
a selected Touch Callout.

(See Configuring Touch Callouts for more information.)

Media Library
The media library stores all recorded and imported media in an unaltered state. This 
media may be dragged from the media library to your timeline or canvas for inclusion 

Touch Callout tab
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in the project. You can drag this media into your project multiple times to replicate the 
same file. 

For more information, see Using the Media Library.
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Tour 3: Publishing Your Screencast
The purpose of this tour is to familiarize you with publishing your screencast. 
ScreenFlow screencasts are not video files—they are saved as ScreenFlow documents 
(with a .screenflow extension), which can only be opened and used by ScreenFlow.

There are two ways to publish your screencasts—by exporting them to a standard 
video file format or publishing them directly to an Internet video service, like Vimeo or 
YouTube.

Determining the correct export settings for your screencast depends on the complexity 
of your screencast and the intended use of the video after it has been produced.

This tour explores the basics of ScreenFlow’s export options. For a comprehensive 
description, see Publishing Your ScreenFlow Project.

Select File > Export or press Command-E to export your presentation:

Figure 14. Export Settings Window

Save As Choose a name for your exported video (default: ScreenFlow.mp4).

Where Choose a location to export your video.

Type you can export automatically or manually. (See Exporting Your Video for details.)

Encoding Quality Select: Fastest, Normal, or Slowest.

Note: Fastest is only available if your PC has an Intel QuickSync CPU.
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Resolution Select a resolution, or select Custom which opens Width and Height fields 
to enter custom resolution values.

Letterbox Content Check to display letterbox content (text display of audio content)/

Options Use these controls to specify motion blur, add chapter tracks, add captions, 
and burn-in captions depending on your encoding options. 

Publishing
In addition to encoding a video file, ScreenFlow can also publish screencasts directly to 
Vimeo, YouTube, Google Drive, Facebook, and Wistia. These options are accessible from 
the File menu. For more information, see Publishing Your ScreenFlow Project.
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Recording Media in
ScreenFlow

Creating a screencast or other project that involves video is typically a three-step 
process: recording your media, editing the project, and exporting (or publishing) your 
screencast as a video file. This chapter focuses on the first step—recording video and 
audio directly in ScreenFlow.

Note: ScreenFlow automatically stops recording when you have less than 100 
megabytes free on your system disk volume.

 How ScreenFlow Records and Saves Media

 Setting Recording Preferences

 Configuring Recording Options

 Recording Media in ScreenFlow

 Recording Tips

 Templates
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How ScreenFlow Records and Saves Media
ScreenFlow is comprised of two separate applications which work together seamlessly 
to provide you a wide variety of options and flexibility as you record media, edit, and 
export your screencasts. 

In addition to ScreenFlow—the desktop application that starts up when you double-
click the ScreenFlow icon—there is also a utility, called ScreenFlow Helper. It is 
ScreenFlow Helper that actually performs the task of audio and video recording. The 
ScreenFlow application enables you to compose and edit your screencast projects and 
export them, but it uses ScreenFlow Helper to perform audio and video recording.

ScreenFlow Helper can be configured to start when you log in to your computer or only 
when you start ScreenFlow (in the ScreenFlow Preferences General Pane). When this 
option is disabled, ScreenFlow Helper always starts when you log in and stays running 
whether ScreenFlow is running or not.

ScreenFlow Helper always runs in the background so that you can start and stop 
recording without changing the state of your system. When ScreenFlow Helper is 
running, it displays a menu identified by a camera icon , in the Finder menu bar.

Note: ScreenFlow can record the computer screen as video, as well as record camera-
based video (iSight, for example). Throughout this guide, the computer screen is 
referred to as the display—as in display video—in keeping with Apple’s terminology.

When you finish recording a clip in ScreenFlow, display video is combined with 
computer audio, and added to your screencast project and saved as a ScreenFlow file. 
Camera-based video (iSight, for example) and microphone-based audio is also 
combined, and added to a screencast file. Screencast files are stored in a ScreenFlow-
controlled location, and clips are added to the project’s media library.

ScreenFlow clips (sometimes called screen recordings or screencast files)—unlike clips 
recorded outside ScreenFlow in QuickTime or other video formats—contain spatial and 
temporal information about mouse tracking and key presses that enables powerful 
special effects to enhance your screencast.

Note: Clips recorded by ScreenFlow are saved in a proprietary ScreenFlow format, 
with a .scc extension, and referred to as screencast files. Screencast files can only be 
utilized by ScreenFlow. Because screencast files are automatically and transparently 
managed by ScreenFlow, you rarely ever encounter them or have to deal with them.
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Setting Recording Preferences
ScreenFlow provides several options for recording. To view and change these 
preferences, select ScreenFlow > Preferences. The recording options are displayed on the 
General tab and the Advanced tab.   For details, see Setting Preferences.

Configuring Recording Options
In ScreenFlow, you don't need to define a capture region in order to record a clip of 
your display for your screencast. ScreenFlow records your entire computer display with 
an advanced algorithm that produces the highest quality recording and small file 
size—giving you the flexibility to make changes to your frame size in post-production.

You can set up ScreenFlow to record video and audio from various cameras and 
microphones, depending on your project, and you can change these settings any time 
you need to.

To configure your recording options, click on the ScreenFlow Helper menu (    ) and 
select Configure Recording to display the New Recording window. You can also select 
File > Add Additional Recording or select File > New. If the New Recording option is 
grayed-out, you must first open an existing recording or create a new one. Keep in 
mind that Additional Recording allows you to not record the screen, whereas Configure 
Recording always records the screen.

Note: You can also add recording from the Media Library (see Using the Media Library).

The recording options are identical in both windows. However, the Add Additional 
Recording window also allows you to close ScreenFlow automatically before recording. 

 Configuring Recording in the ScreenFlow Recording Window

Configuring Recording in the ScreenFlow Recording 
Window

You use the ScreenFlow window to select recording options and record media. You can 
record multiple audio and video sources simultaneously: For example, you can record 
your display (with optional computer audio), and at the same time, record yourself 
using the iSight camera, and providing voice-over commentary. If you have multiple 
displays connected, you can record on any or all of them.
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You can display the ScreenFlow recording window (depicted in Figure 15) by opening 
the ScreenFlow Helper  menu and selecting Configure Recording.

Figure 15. Configure Recording Window

Record Desktop from Check this option to record your computer monitor. This source 
records by default. If you have multiple displays connected, you can record on any or all 
of them.  Desktop video and computer audio are combined into a single clip, and 
added to your project as a .scc file.

If you have additional displays to record, click the Plus (+) button and a new Record 
Desktop from drop-down menu will be added. The newly added menu provides a Minus 
(-) button enabling you to remove this menu.

If the number of displays being recorded matches the number of displays connected to 
the user's system, the Plus (+) button on the first row will be disabled, letting you know 
you cannot add any more displays for recording.

Note:  The choice of displays in the menus are updated as more displays are added. 

Click to 
display 
advanced 
settings

Click the Plus (+) button to add a menu
Click the Minus (-) button to remove a menu



Recording Media in ScreenFlow
Configuring Recording Options

59

Record IOS Device Check this option to record your screen from any IOS device and 
then select an IOS device from the drop-down menu. (IOS devices must be connected 
to appear in the menu.)

Record Video from Check this option to record video from any camera connected to 
your computer. Use the drop-down menu to choose from multiple cameras. Upon 
selecting a source, a preview image is displayed below.

Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

Record Audio from Check this option to record audio from any microphone 
connected to your computer. Use the drop-down menu to choose from multiple 
microphones. Upon selecting the source, the volume level is displayed below.

Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

ScreenFlow records microphone audio at a sample rate of 48KHz.

Click the gear icon to open controls that enable you to pan and adjust the volume.

Record Computer Audio Choose this option to record all sounds played through your 
computer. The ScreenFlow audio driver must be installed to use this setting. If the 
driver is not installed, you are prompted to install it.

Desktop video and computer audio are combined into a single clip, and added to your 
project as a .scc file.

Gear icon

Volume

Pan 
controls
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Click the Advanced Settings radio button to display more recording settings.

Figure 16. Advanced Settings Window

You can also configure ScreenFlow to record your display unattended. For example, you 
might want to record a half-hour Webinar, and you don’t want to sit through it to stop 
the recording. Use the Stop Recording option on the second panel to specify the 
elapsed time to stop the recording, and click Set Timer, then start recording. Elapsed 
time recording is a one-off event—you need to set it every time you want to use it.

Table 2. ScreenFlow Record Dialog Controls

Control Description

Record Desktop 
Framerate

The default is always Automatic, which maintains the exact 
same behavior as previous versions of ScreenFlow. This 
means the application will record frames as quickly as 
possible. The user can modify the settings to reduce the 
frame rate recorded to disk.

These options are available to the user: Automatic, 30, 25, 15, 
5 and 1 fps. They are immediately applied.

Timeline Framerate Select the timeline framerate: 24, 25, 30, 50 or 60 fps.

Record in loop for Check to record a loop of the most recent amount of hours 
and minutes selected.

Stop Recording After Specify when ScreenFlow should automatically stop this 
recording session. Click Set Timer to activate one time.

Set Timer Sets or removes timer for the next recording.

Record Click the red button—the Record icon—to display the 
countdown window (if enabled—see the Countdown option 
in the General Pane) and begin recording.

Advanced 
Settings radio 
button
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Recording Media in ScreenFlow
Depending on how you plan to use your clip, choose these recording options:

 Stopping, Pausing & Resuming Your Recording

 Using the Countdown Window

 Recording When you Start ScreenFlow

 Creating a Document Without Recording

 Adding Recordings to a ScreenFlow Project

 Recording Clips

 Setting the Recording Timer

Stopping, Pausing & Resuming Your Recording
Before you start recording, it’s nice to know how to stop. To stop recording in 
ScreenFlow, click the ScreenFlow Helper  menu and select Stop Record or press 
Shift-Command-2, the default shortcut to stop recording.

To pause your recording, click the ScreenFlow Helper  menu and select Pause. When 
you pause recording, the solid black recording dot changes to a pause symbol . To 
start recording again, select Resume from the ScreenFlow Helper menu.

Using the Countdown Window
By default, each time you start recording (unless you’ve disabled it in Preferences), 
ScreenFlow displays the countdown window as shown below in Figure 17, providing a 
delay to allow you to prepare for recording.

Figure 17. Using the Countdown Window

By default, the countdown is set to 5 seconds. To change the countdown option (or to 
enable or disable the countdown window), select > Preferences > General. For details, 
see General Pane. You can set the countdown delay for up to ten seconds.

To skip a countdown in progress, simply click on the countdown window and 
ScreenFlow begins recording immediately.
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Recording When you Start ScreenFlow
To record a clip for a new screencast project, just start ScreenFlow. The ScreenFlow 
recording window displays and you can click the red Record button to start recording 
your first clip. (If you don’t want to record right now, just close the window.) During 
recording, the camera icon of the ScreenFlow Helper menu displays a black dot.

When you stop recording, ScreenFlow displays a window that lets you add your 
recording to a new document, add to an existing document, or discard the document.

Creating a Document Without Recording
To create a ScreenFlow document without recording, start ScreenFlow. When the 
ScreenFlow recording window displays (Figure 17), click the Close button on the upper 
left corner. Now, select File > New or press Command-N.

ScreenFlow displays a dialog which allows you to set your canvas size to any dimension, 
regardless of your display size. 

Figure 18. Using the New Document Window

Select a preset canvas size from the Preset popup menu or enter a custom canvas size 
in the Width and Height fields. Then click the new document icon at the bottom.

Now, you can record video or work on your project using other media, as you want.

Adding Recordings to a ScreenFlow Project
To record a clip and add it to an open project, make sure the project window is open 
and selected. Then, select File > Add Additional Recording (Shift-Command-R) or press 
the Add Recording button in the media library. Verify your settings and click Record.

Depending on your preferences, the countdown window displays, and then 
ScreenFlow begins recording. During recording, the camera icon of the ScreenFlow 

New document 
button
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Helper menu displays a black dot. When you stop recording, ScreenFlow adds the clip 
you just recorded to the project.

Recording Clips
To record a clip without deciding which project to add it to first, click on the ScreenFlow 
Helper  menu and select Record, or select File > New > New Recording and click the 
red Record button. Depending on your preferences, the countdown window displays, 
and then ScreenFlow begins recording. During recording, the camera icon of the 
ScreenFlow Helper menu displays a black dot.

When you stop recording, ScreenFlow displays a Recording Complete window 
(Figure 19) so that you can create a new document with our recording, or add your 
recording to any open document.

Figure 19. Using the Recording Complete Dialog

To verify your settings first, click on the ScreenFlow Helper  menu and select 
Configure Recording. When you’re ready, click the Record button. Depending on your 
preferences, the countdown window displays, and then ScreenFlow begins recording. 

When you stop recording, ScreenFlow displays the Recording Complete window, as 
shown above, so that you can add your recording to an open project, start a new one, 
or discard your recording.

Adding Markers
ScreenFlow enables you to attach markers directly to your clips. During a recording, if 
something important or notable occurs, it may be desirable to create a marker during 
the recording process to provide quick access, later, when organizing a project.

The Add Marker menu item is only enabled during recording. It is disabled when the 
recording is paused or stopped. 
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Recording Monitor
Recording Monitor provides a preview of your microphone and camera during a 
recording, to check audio levels and keep the camera shot correct. Additional 
functionality such as the duration of the recording is also available.

To open the Recording Monitor, click the ScreenFlow Helper icon, then select Show 
Recording Monitor.

Note: When the recording monitor is displayed, it is included in the screen recording. 
It is recommended that you move the Recording Monitor window to an area of the 
screen that will be cropped out, or move it to another monitor. 

The Recording Monitor tracks the selected inputs from the ScreenFlow recording 
configuration. If you have disabled both the camera and microphone, the recording 
monitor will shrink to just a timer. The green striped header at the top of the recording 
monitor will change to red when a recording is actually in progress. This gives you quick 
visual cue that your recording is in progress. Both the timer and the Add Marker 
buttons are grayed-out when nothing is recording. The timer text displays in white 
once the recording has started. You can set markers by clicking the Add Marker button.

Select Show Recording Monitor

Click ScreenFlow Helper icon

Click to add 
a marker 

Recording 
indicator

Microphone 
audio monitors

Timer text

Camera 
monitor
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Note: Only the microphone audio is monitored, not the entire audio of your 
recording. 

Once you have completed your recording, any markers you have added will 
immediately be shown in the timeline. The markers are attached to the primary clip.

Setting the Recording Timer
You can also configure ScreenFlow to record your display unattended. For example, you 
might want to record a half-hour Webinar and you don’t want to sit through it to stop 
the recording. 

To set up ScreenFlow to stop recording after a certain time, click on the ScreenFlow 
Helper  menu and select Configure Recording. 

Use the Stop Recording option on the second panel to specify the elapsed time to stop 
the recording, and click Set Timer, then start recording. Elapsed time recording is a one-
off event—you need to set it every time you want to use it.

Each time you start ScreenFlow, ScreenFlow also launches ScreenFlow Helper and the 
Configure Recording window to help you begin recording your screencast. You can also 
display the Configure Recording window from File > New > New Recording or ScreenFlow 
Helper > Configure Recording.

When you stop recording, you can add this new recording to a new document, or add 
the recording to a ScreenFlow document that is already open. If you have no other 
projects open, ScreenFlow will automatically create a project file for the new recording.

Marker on 
timeline
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Using the Configure Recording Window
Use the Configure Recording window to select recording options and start recording 
media.

Record Desktop from Check this option to record your computer monitor. This source 
records by default.  If you have multiple displays connected, you can record on any or 
all of them.

Desktop video and computer audio are combined into a single clip, and added to your 
project as a .scc file.

Record IOS Device Check this option to record your screen from any IOS device and 
then select an IOS device from the drop-down menu. (IOS devices must be connected 
to appear in the menu.)

Record Video from Check this option to record video from any camera connected to 
your computer. Use the drop-down menu to choose from multiple cameras. Upon 
selecting a source, a preview image is displayed below.

Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

Record Audio from Check this option to record audio from any microphone 
connected to your computer. Use the drop-down menu to choose from multiple 
microphones. Upon selecting the source, the volume level is displayed below.

Live video (i.e. camera) and live audio (i.e. microphone) are combined into a single clip, 
and added to your project as a .scc file.

ScreenFlow records microphone audio at a sample rate of 48KHz.

Record Computer Audio Choose this option to record all sounds played through your 
computer. The ScreenFlow audio driver must be installed to use this setting. If the 
driver is not installed, you are prompted to install it.
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Desktop video and computer audio are combined into a single clip, and added to your 
project as a .scc file.

Record 
Click the red record button to display the countdown window and begin recording.

When you have finished recording, video and audio sources are combined to maintain 
video/audio sync. Desktop video is combined with computer audio and camera video 
is combined with microphone audio. You can separate these clips using the Edit > 
Detach Audio command.

The only limitation on the length of your recording is the amount of space available on 
your hard drive. ScreenFlow automatically stops recording when you have less than 100 
MB free on your system disk volume.

Advanced Settings 
The Advanced Settings button above the Record button in the Configure Recording 
window switches to the Timed Recording pane. 

Loop Recording

The loop recording is activated by checking the Record in a loop box. The recording 
loop duration is set by entering hours and minutes. Click the Record button to activate. 
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Once the recording starts, you can see the loop duration in the status menu of the 
ScreenFlow Helper.

Timed Recording

You can also set your timer to stop the recording after a set number of minutes and 
seconds. Click the Set Timer button to apply this setting. Once the timer has been set, 
this button will change to Reset Timer. Click again to disable timed recording. 

Countdown Window 

Each time you start recording, ScreenFlow displays the countdown panel, providing a 
delay to allow you to prepare recording:

To skip the countdown, simply click on the countdown window and ScreenFlow begins 
recording immediately. By default, the countdown is set to 5 seconds. To change the 
countdown option, go to Preferences > General. You can set the countdown delay for 
up to 20 seconds.

Adding A Recording

When you have finished your recording, the clips that you have recorded are 
automatically opened in a new document. If you already have a document open, you 

Loop duration
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are given the option of creating a new document or adding your recording to an 
existing document.

If you have accidentally created a new document when you intended to add the 
recording to an existing document, just drag or copy/paste your recording into the 
previous document’s canvas, timeline, or Media Library. This duplicates the recording in 
the other document’s project folder.

Add Additional Recording

To add a recording to your document, you may simply create a new recording, in which 
case you receive notification (as shown above) or you may choose Add Additional 
Recording. This may be selected from the File menu or the Media Library.

The Add Additional Recording selection reopens the New Recording window so you 
can add another recording. 
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Partial Screen Capture
Partial screen capture enables you to record just a portion of the screen. 

The partial screen record button (the dashed rectangle icon) is located to the left of the 
main record button. When clicked, the screen will darken and a rectangular selection 
will appear. This capture area can be resized using the mouse. While the rectangular 
selection is present, the user cannot interact with any windows on their desktop, and 
the mouse is now controlling the sizing of the region. 

There is a control strip at the bottom of the focused screen where you can cancel out of 
this mode, start the recording, or use presets to constrain the region you are capturing.

 If there are multiple monitors connected, the secondary displays will have a text 
message overlaid to let you know you can click on that screen to begin selection on 
that display. Once you have clicked on a new display, the control strip will disappear 
from its current display and move to the new one. The preset button displays a popup 
giving you some constraint presets (1280x720, etc). You can also enter a fixed width 
and height directly.

There are some keyboard shortcuts enabled in selection mode. You can use the cursors 
keys to "nudge" the rectangle around the screen. If you hold the Shift key while 
nudging, the movement will be increased. If you move the mouse over a window and 
press the space bar, the selection rectangle will resize to fit just that window. You can 
use the escape key at any time to exit out of selection mode. 

The selection rectangle is always cropped to a single display, and so it cannot span 
multiple displays. If you click the red record button, the selection user interface will 
disappear and the standard recording countdown will begin. The recording will inherit 
any other recording settings from the main user interface (such as cameras and 

Cancel

Record

Presets

Partial screen 
record button
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microphones). The selection rectangle will be remembered the next time you enter 
region selection mode, but it will not automatically be used if you pick Record from the 
ScreenFlow Helper menu (this will continue to record only in full screen mode). Region 
recording can only be activated through the front-end window. Once the recording has 
ended, you interact with the new document as usual. The canvas size is set to the size of 
the region you selected. 

Recording Tips
Before you begin your recording, it’s useful to consider how you (and your users) intend 
to use your screencast, how you want to organize your media, and how best to present 
your screencast on screen.

 Setting Your Display Resolution

 Using Text in a Screencast

 Considerations for Narrative Screencasts

Setting Your Display Resolution
Two important factors to consider before you begin recording is the resolution of your 
display and the intended export resolution of your screencast. Since you usually do not 
intend to export your screencast at the same resolution that you recorded at, it is 
important to consider that your final video will be at a lower resolution than it is on 
your screen—especially if you are recording a large resolution display or a Retina 
display (maximum 2880 x 1800). This is especially important when you have text which 
must be legible. Digital video was not designed to capture text, so it can often be 
difficult to capture clearly.

Telestream recommends that you check your display resolution before recording 
(select System Preferences > Displays). Lower your display resolution as much as 
possible without impairing your ability to view your screencast clearly. Do not lower the 
resolution below your intended export resolution or you will lose quality.

Using Text in a Screencast
Digital video was designed primarily for capturing real world images, so it is often 
difficult to capture the thin lines of text legibly. Here are a few tips to consider when 
you are using text in your video:

• Use larger point sizes (e.g., at least 25 points or more). Larger characters always ren-
der better than small ones.

• Do not use serif fonts (e.g. Times Roman). Always use sans-serif fonts (e.g., Arial or 
Helvetica).

• Use boldface fonts, since they render better, especially at smaller sizes.
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• Do not use odd values for the output movie's frame height or width. Always use 
even numbers. Also, input sources having odd height or width values can result in 
illegible titles.

• Always generate non-interlaced video (the Lossless preset is the only format that 
you can specify as interlaced). Interlaced video is much more prone to poor quality 
text rendering because it may introduce flickering.

Considerations for Narrative Screencasts
When creating narrative screencasts, you might consider two different approaches. For 
simple demonstrations, you may be able to narrate the demo as you perform it. For 
more complex demos, you may have a problem narrating in real time, as you perform 
the task using the keyboard and mouse.

 Record Everything at Once

 Record Your Display—Then Add Narration

Record Everything at Once
Using this method, you record each recording source in a single session—
simultaneously recording the display, camera video, microphone audio, and computer 
audio. When you are done recording, you can use the editing tools to finalize your 
screencast project.

For example, you might start a screencast project by recording your display, then cut to 
a Picture-in-Picture of a camera recording, as you demonstrate the application. Later, 
you fade out your video, leaving only the audio to narrate the remaining moments of 
the screencast.

This method is considered a single-pass production. It works well when your subject 
matter is simple, straightforward, or short. For longer or more complex screencast 
projects, you may find the second approach more comfortable.

Record Your Display—Then Add Narration
Using this method, you first record the display (optionally, without computer audio), 
demonstrating your application or subject matter without any video or voice-over.

When you have finished your demonstration, you can record your camera and 
microphone sources while playing the video preview of your demonstration in 
ScreenFlow. This can be done in a single long recording or several short recordings.

You can then edit your recordings to align your narration with your demonstration or 
fade your camera recording in and out when appropriate.

This workflow is effective when the screencast involves a series of complex mouse or 
keyboard operations, or you have several comprehensive steps or tasks to achieve, 
each of which take some effort to produce.
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Templates

Introduction 
Templates enable you to generate a document that can be used as a “template” for 
creating other documents. This allows you to specify consistent starting and ending of 
your content. When you creating (and then edit) a document made from a template, 
there are three groups of clips in the timeline that are important:  starting content, 
ending content and variable content.   A newly created template always places the 
starting content at the beginning of the timeline, the variable content (screen 
recording content) in the middle, then the ending content placed at the end.  When a 
template is created, ScreenFlow determines the starting and ending content based on 
the Template Placeholder Clip information. 

Creating a Template 
A template can be created from any regular ScreenFlow by selecting File > Save As 
Template. This new template document is managed by ScreenFlow and is saved in a  
special folder in the Users Library folder located at:
         ~/Library/Application Support/ScreenFlow/Templates/ 

This folder contains all the content needed by the template.  However, the new 
template file is given the a file extension of:  .screenflowtemplate (instead of .screenflow 
used for ScreenFlow documents).  Screenflow manages this template folder by  
deleting and updating files as needed, so you should not make any changes directly.

Templates can be shared between different computers. ScreenFlow will automatically 
read any templates present in this shared template folder. 

To control the variable portion of the template, the user has access to a new Template 
Placeholder Clip. This is added to the timeline by selecting Insert > Template Placeholder 
Clip.   When the dialog window displays, select the type of template placeholder clip: 
Screen Recording, Camera, or IOS Device.

When a ScreenFlow document is saved as a template (File > Save Template), a dialog 
window displays allowing you to name your template. Enter a template name and click 

Select type

Click Save
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Save. Once a document has been converted to a template, the Save as Template menu 
item is disabled. 

Note: If a template placeholder clip has not been previously inserted (Insert > 
Template Placeholder Clip), a “No Template Placeholder Clips” message will display.  
You must insert a template placeholder clip before you save a document as a 
template.

The placeholder clip can be visually positioned, scaled, rotated, etc., just like normal 
clips. However, ScreenFlow labels the placeholder clip so it can be matched with the 
correct content when creating a document from the template.  The placeholder also 
determine the options that are presented to the user when a new document is made 
from an existing template.  When adding a ‘Screen Recording’ or ‘Camera’ placeholder, 
an audio placeholder clip can optionally be added at the same time, enabling the 
configuration of audio specific properties. 

Using a Template 
After a template has been created and saved, it is ready for immediate usage. To create 
a new document from a template, select File > New, then select the New From Template 

Enter name

Click Save
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tab when the Welcome window displays. Select a template, then click the Open icon. 
You can also edit a selected template by clicking the Edit Template button. 

When the recording settings window displays, set up your recording as needed. Click 
the radio button to open the other settings window.

Select a 
template

Click the 
Open icon

Select New From Template tab

Click to edit selected template.

Set up 
recording

Click the 
radio button
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When the other recording settings window displays, finish setting up your recording. 
Click the record button to begin recording using your new template.

Set up the 
recording

Click the 
record button
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Editing ScreenFlow
Projects

You use the editor window to create your screencast or other ScreenFlow project, add 
media, and add text, actions, and other effects for clarity, emphasis, and visual appeal.

You also use the editor window to arrange elements spatially and temporally in your 
project, and configure elements to behave or display just the way you want, and to 
preview your project and then go back and adjust your results.

 Editor Window Overview

 Adding Media to Your Project

 Using the Editor Windows Toolbar

 Editing Your Project on the Canvas

 Using the Clip Editor

 Editing Your Project on the Timeline

 Using Nested Clips

 Creating Closed Captions

 Configuring Video Properties

 Configuring Audio Properties

 Adding Narration

 Configuring Screen Recording Properties

 Configuring Callout Properties

 Recording IOS devices

 Configuring Touch Callouts

 Add Snapback Action

 Rolling Edit

 Configuring Annotations Properties

 Configuring Text Properties

 Using Style Presets

 Using Audio and Video Filters

 Using the Chroma Key Filter
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 Using the Media Library

 Stock Media Library

Editor Window Overview
You use the editor window (Figure 20) to create screencasts or other ScreenFlow 
projects, and then edit your projects. This includes adding media, text, actions, and 
other visual and audio effects for clarity, emphasis, and visual appeal.

The editor window also allows you to arrange your project’s elements both spatially 
and temporally, and configure each element’s properties to behave or display just the 
way you want, and to preview your project and then go back and adjust your results.

Figure 20. Editor Window Overview

The editor window is a document window for ScreenFlow documents. Each editor 
window displays a single ScreenFlow project. Each ScreenFlow project is stored in a 
ScreenFlow document, including the media library. You can open several ScreenFlow 
documents and work on these projects simultaneously.

Canvas pane

Timeline
pane

Canvas button

Playback
controls

Properties 
panes

Audio meters

Timeline 
magnification 
slider

Resize canvas and timeline panes 
by dragging the borders.

Timecode Toolbar

Scrubber

Tools Menu
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Note: To create a new, untitled ScreenFlow document for a new project, see Creating 
a Document Without Recording.

The editor window consists of three panes: Canvas, Properties, and Timeline.

You can resize the canvas and timeline panes by clicking and dragging the toolbar up 
or down. Click anywhere in the region of the toolbar directly below the toolbar icons 
(and above the timeline) and drag the toolbar up or down to resize the panes.

The upper-left pane of the editor window is the canvas. The canvas is a spatial 
representation of the visual clips of your project (and their properties, actions, etc.), 
based on the position of the scrubber on the timeline. At any given point in time, 
elements in a project may be entirely or partially visible in the frame, or off-screen 
entirely. You use the canvas to arrange, resize and configure these elements. For details, 
see Editing Your Project on the Canvas.

The bottom pane (directly below the playback controls) is the timeline—a temporal 
representation of your project, with a time scale at the top. The timeline enables you to 
arrange the clips in your project in play order, and add fades and other effects. The 
elements on the timeline reference media in your project’s media library. Changes 
made on the timeline or on the canvas do not alter your original media clips in the 
media library. For details, see Editing Your Project on the Timeline.

The upper-right pane displays the properties panes and media library. There are seven 
properties panes: Video, Audio, Screen Recording, Callout, Touch Callout, Annotations, 
and text. For details, see Configuring Video Properties. The media library (Using the Media 
Library) stores all recorded and imported media in its original format and state. 

All three panes work together to help you create, edit, and preview your project.

Adding Media to Your Project
Media files are added as clips in ScreenFlow. And clips are the building blocks of every 
ScreenFlow project. Before you can accomplish any editing or composition, you need 
to add clips to your project. A clip in ScreenFlow is not the media itself—the media is 
the file that the clip represents (or points to). A clip not only points to a media file, it also 
contains all of the other information need to play and render the clip the way you’ve 
configured it. This may include start and stop times, fades and other actions, and other 
properties that you assign.

As mentioned before in Recording Media in ScreenFlow, you can record your display 
directly in ScreenFlow, and you can also record directly in ScreenFlow using a camera 
and microphone. When you do, these recordings are automatically managed by 
ScreenFlow, and clips are added to your project under your control.

You can also add media that has been recorded outside of ScreenFlow, and you can use 
still images as clips also. ScreenFlow supports video and audio file formats that 
QuickTime Player can play in Mac OS X10.6.x and higher. ScreenFlow also supports 
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many image formats, including PNG, JPEG, GIF, and TIFF images—if Preview can display 
a file, you can use it in ScreenFlow.

The media library is an integral part of ScreenFlow—it’s a central repository for media 
you’re using in a project, and knowing how it works will help you take advantage of it.

Adding media to a project involves, first, adding a clip to the media library—even if it 
happens automatically. You either drag media from the file system onto the timeline 
and ScreenFlow adds its clip to the media library automatically—or you add media 
directly to the media library (creating a clip), and then you drag the clip onto to the 
canvas or timeline whenever you want to—creating a copy of the original clip. (See 
Managing Media in your Media Library for more detail on how to add media to your 
library).

You might think that dragging a clip onto the timeline merely places it there, but in fact 
it’s a copy. You can edit it without changing the properties of the original clip. And, you 
can drag the original clip onto the timeline over and over, as many times as you like.

The following topics focus on the practical issues of getting clips into your project, 
ignoring the finer details of media library management for the moment. For those 
details, as well as best practices, see Managing Media in your Media Library.

 Adding Clips

 Deleting Clips

Adding Clips
To add clips to your project use these methods:

• Drag a clip from the media library directly onto the canvas. This allows you to place 
the media’s frame spatially on the canvas. The clip is automatically placed in a new, 
top track on the timeline at the point of the scrubber. If this clip is a display record-
ing and the canvas is the same size, you can just drag it onto the timeline—the clip 
is automatically positioned to fill the canvas correctly. Clips are imported sequen-
tially (by time) on one single track, when dragged to the Timeline.

• Drag a clip from the media library directly onto the timeline. This allows you to 
place the clip on the track(s) you want, and at the location on the timeline you 
want. You can select one or more clips using lasso selection—click and drag across 
some portion of each clip to select it.

• Double-click a clip in the media library to add it to the timeline at the point of the 
scrubber.

• Drag a clip from the file system (Desktop or Finder window) directly onto the time-
line. This allows you to place the clip on the track you want, at the point on the 
timeline you want. The clip is automatically added to the media library.

Note: You can also copy and paste clips in the same project, and you can copy and 
paste clips between open ScreenFlow document windows.
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You can also click and drag multiple clips. When you do they are placed in sequence on 
the timeline. If you hold the shift key down while clicking dragging multiple clips, the 
clips are placed as stacked layers on the timeline.

The default name of a clip is obtained from the media file it references. To change the 
name of a clip, double-click on the text or click the gear icon  on the clip, and select 
Rename Clip. The new name does not change the name of the source file.

Deleting Clips
To delete clips from your project use these methods:

• Select a clip on the canvas or timeline and press Delete or select Edit > Delete. This 
removes the clip from the canvas/timeline, but the original clip remains in the 
media library.

• Select a clip in the media library and press Delete or select Edit > Delete. This 
removes the clip from the timeline and deletes the clip from the media library. If the 
media is on the timeline, ScreenFlow displays a Delete dialog—click Delete to con-
tinue. (This action does not delete the referenced media file—just the clip.)

Deleting All Unused Media
It is possible for media sources to exist in a ScreenFlow document without having an 
associated clip for them in the timeline. ScreenFlow provides an easy way to delete 
such orphaned media sources from the Media Library.

To do this, click the Media Library tab, click the gear icon to open its menu, then select 
Remove All Unused Media. 

Click the Media Library tab

Click the 
gear icon

Click Remove All 
Unused Media
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When the list of unused media displays, click Delete to delete all the unused sources 
from the Media Library.

Using the Editor Windows Toolbar
Below the ScreenFlow canvas is a toolbar with various controls. 

Click delete

Media Library button

Canvas Cropping button
Playback Controls Audio Meters

Headphone icon
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It displays several tools you’ll use to configure your canvas, preview your video, and 
monitor your audio, as described below, in Table 3.

If you load a long media file onto the time line (or move a long file to another location 
in the time line), the progress is displayed in percent in the right side of the timecode 
display.

Editing Your Project on the Canvas
The canvas (Figure 21) is a real-time video preview pane—a spatial representation of 
the visual elements of your project—which allows you to size and position the visual 
elements of your project. How (and where) the elements display at any point in time is 
controlled by the position of the scrubber on the timeline.

Table 3. Using the Editor Window Toolbar

Control Description

Media Library button Click to display the Media Library panel.

Canvas Button Click the canvas button (far left) to display the canvas 
controls—click it again to hide them. You can use these 
controls to view and adjust canvas properties: the canvas size 
(and resulting frame size of your exported video) and 
background color.
For details, see Configuring the Canvas.

Playback Controls Use the playback controls (center) to play your project as well 
as jump to the beginning or end of your project. 

You can also use the traditional video editor’s JKL keystrokes 
for Rewind, Stop, and Playback. Press J or L repeatedly to 
speed up rewind/playback respectively.

The timecode of the project is displayed directly to the right 
of the playback controls. (You can set timecode to SMPTE or 
ScreenFlow—see Timeline Pane.)

Audio Meter The audio meter (far right) displays audio volume. The top 
meter represents the left channel; the bottom, the right 
channel.

<headphone icon> Click the headphone icon to toggle (on and off ) muting of the 
preview audio (headphones).

Progress 
display
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To move the Canvas, click and drag it using your mouse. When you do this, the position 
values change accordingly in the Video tab. If you press the Space Bar while moving the 
Canvas, the position value are not changed.

If you are using a trackpad, pinch fingers closer of farther apart on the trackpad to 
zoom in or out. You can also scroll in any direction using two fingers on the trackpad. 
Additionally, you can use two fingers to rotate the canvas.

Figure 21. Using the Canvas Pane

The center rectangle (which may be obscured by a clip, as shown above) represents the 
video frame of your project. Its dimension (which is set by clicking the Canvas button 
and using the canvas controls) determines the frame size of your video when you 
export or publish it. 

The gray space around the video frame rectangle is workspace; space that isn’t 
included in exported video. You can use this space for off- or partially off-screen visual 
elements for scaling or pan effects.

 Zooming and Panning the Canvas

 Configuring the Canvas

 Arranging and Adjusting Clips on the Canvas

Zooming and Panning the Canvas
You can zoom in and out on the canvas to view details or see the big picture. 

To zoom in or out on the canvas, hold down the Option Key and move the scroll wheel.

You can also use these commands:

• Zoom in—select View > Zoom In (Command-=)

Canvas work
area

Canvas button

Playback controls

Output frame 
rectangle

Timecode

Canvas 
properties
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• Zoom out—select View > Zoom Out (Command--)

• Zoom to full pixel size—select View > Zoom to 100% (Option-Command-0 (zero))

When the canvas is larger than the panel, scroll bars appear so that you can pan in any 
direction to view hidden portions of the canvas. Hold down the spacebar and drag to 
pan the canvas with a mouse.You can also use normal trackpad actions.

Configuring the Canvas
Before you start working on a project, it’s a good idea to configure your canvas—
determine the frame size of your published project, pick a background color, etc.

Click the Canvas button  to view and configure your canvas properties (Figure 22).

Figure 22. Empty Canvas Pane Without Any Elements

Canvas 
properties

Canvas button
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When canvas controls are displayed, you can’t use the canvas. Click the button again to 
hide the controls. Click the green check mark to save your settings and close the canvas 
control bar. 

Arranging and Adjusting Clips on the Canvas
After you add clips to your project, you can quickly and easily arrange them spatially on 
the canvas, and you can crop, resize, rotate, add filters, etc.

Table 4. Canvas Properties

Control Description

Canvas (Width and 
Height)

Enter the width and height values on the Canvas X and Y 
fields to change the video frame size. (When canvas controls 
are hidden, you can also click and drag any corner of the 
rectangle to change its size.) The size cannot be set to a value 
larger than the original recording.

Background Color Click the Background Color button  (to the right of the 
Canvas height and width fields) to choose the background 
color of the canvas (default: black.) If your visual elements 
don’t obscure the background, it displays as part of the video.

Snap to Front 
Window

Check to highlight a foreground window in your recording 
when you want to crop the area outside of that window. This 
helps you to crop the canvas around the foreground window. 

When you start your recording, no window is selected. So 
during your recording you need to click on the window you 
want to highlight. After the recording, you need to move the 
scrubber to where you clicked to highlight. Now you can click 
on the canvas button, move the sides and they will snap to 
your highlighted (focused) window.

Preset select one of four canvas sizes, or select Custom which allows 
you to enter size values manually.

Reset | Cancel | Apply Use these buttons to:  reset the settings to the default values 
(arrow icon), cancel changes you’ve made (x icon), or apply 
the changes you’ve made, before hiding these controls (check 
icon).
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Figure 23. Arranging and Adjusting Clips on the Canvas Pane

To operate on a clip, click to select it. ScreenFlow highlights the clip (both on the canvas 
and the timeline). When you select a clip on the canvas, it also selects it on the timeline.

Note: You can select a clip on the canvas or timeline when you want to view or 
change its properties, which is done using the properties panes to the right of the 
canvas.

 Placing a Clip Spatially

 Resizing/Scaling a Clip

 Cropping a Clip

 Rotating a Clip

Placing a Clip Spatially
To place a clip anywhere on the canvas, click and drag it to the location you want, and 
then release the mouse. When dragging a clip on the canvas, as you near the center 
vertically or horizontally, yellow guidelines appear to help you locate the clip along 
those lines, if you want.

The location of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click its Video Properties tab. The location is identified in the Position field, 
as X and Y values (in pixels). 

Resizing/Scaling a Clip
To resize (or scale) a clip up or down, select the clip and then select any resize handle 
and drag your mouse. You can also use the scroll wheel plus the Command key to resize 
the selected clip.

Click a media clip to highlight it.

Grab a resize handle to resize 
the rectangle.

Grab the center handle to 
rotate the clip at any angle.

Notice the highlighted clip on 
the timeline, and the scrubber 
bar’s position.
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The scale of a clip is also specified as part of its properties. To adjust it in the video 
properties panel, select the clip and click the Video Properties tab. Use the Scale slider 
or manually enter a percent to resize the clip.

Cropping a Clip
To crop a clip, press and hold the Control key and drag any resize handle inward. Hold 
the Shift key while scaling to preserve the aspect ratio.

The cropping of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click the Video Properties tab. Click the Details icon and use the left, right, 
top and bottom sliders or manually enter a pixel value to crop the clip.

Rotating a Clip
Click and drag the center handle of the clip and rotate it.

The rotation of a clip is also specified as part of its properties. To adjust it there, select 
the clip and click the Video Properties tab. Use the X, Y, and Z thumbwheels or manually 
enter a degree value to rotate the clip in any direction.
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Using the Clip Editor
The Clip Editor enables you to select an individual clip, view it in a clip editor on the left-
hand side of the main document user interface. You can preview the clip and perform 
quick edits, adding the resulting clip directly to the timeline. 

Close Window  Click X to close the Clip Editor. You can also select  View>Hide Clip Editor 
and View>Show Clip Editor.

Adjust Size Click and grab the edge of the Clip Editor window to adjust its size.

Scrubber Click and move the scrubber to change the display location in the media.

Add Media Click the Plus (+) button to add the media (in its current state) to the 
Timeline.

Add In-Point Click to add an in-point at the scrubber location. A blue bar will display to 
indicate the selected section of the clip.

Add Out-Point Click to add an out-point at the scrubber location. A blue bar will 
display to indicate the selected section of the clip.

I/O Section After setting an In-Point and Out-Point, you can move these points by 
clicking on the either end of the blue bar and moving them. Selecting the three dots in 
the center move the entire I/O selection.

Jump to Beginning Click to jump the scrubber to the beginning of the media.

Close Window

Add In-Point

Add Media

Jump To Beginning
Play/Pause

Jump To End
Timecode Display

Audio Meters

Mute Audio

 I/O Section

Adjust Size

Add Out-Point

 Scrubber
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Jump to End Click to jump the scrubber to the end of the media.

Play/Pause Click to start playback of the media. Click again to pause it..

Timecode Display Displays the time location of the scrubber in the media.

Audio Meters Displays audio levels (left and right channels) during playback.

Mute Audio Click the headphone icon to mute playback audio. Selecting the icon 
again turns the audio back on.

Editing Your Project on the Timeline
The timeline (Figure 24) is a temporal representation of your project. The timeline 
displays all of the clips in your project and represents the start and end time for each of 
the clips. You can use the timeline to arrange clips in the order you want them played. 
You can also layer them, and crop them. You can also use the timeline to add actions 
(such as fade) to your clips.

Figure 24. The Timeline Displays Media Clips

The timeline is divided vertically into tracks to allow you to arrange clips that overlap at 
certain points on the timeline. 

 Using the Scrubber

 Using the Scale

 Zooming In and Out on the Timeline

 Using Tracks

 Trimming Clips

 Creating and Closing Gaps in a Single Track

 Creating and Closing Gaps Across All Tracks

 Using In and Out Points

 Changing a Clip’s Play Speed

 Grouping Clips

 Locking Clips

 Creating a Freeze Frame

 Using Markers to Identify Points on the Timeline

 Creating Transitions
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Using the Scrubber
The red vertical bar with a handle (red flag) at the bottom is the scrubber. The scrubber 
identifies the current temporal position of the view displayed on the canvas, and its 
timecode displays in the toolbar. 

You can scrub (move) through your project by using the mouse to grab the top handle 
(in the time scale) and moving it right or left. Notice that as you use the scrubber to 
scrub your project, the canvas updates in real time. 

You press the Home key (or select Mark > Go to > Project Start) to jump the scrubber to 
the beginning of the timeline, and the End key (or select Mark > Go to > Project End) to 
jump to the end. You can also use the left and right arrow keys to move the scrubber a 
frame at a time—or select Mark > Go to > Previous Frame or Next Frame.

Use the red handle (red flag) at the bottom to insert time across all layers on the 
timeline, splitting clips if they fall under the scrubber.

Using the Scale
At the top of the timeline is the scale. The scale is a precise measure of the total length 
of time in the project, and you can determine the start and stop time of each clip (or 
action in the clip) in the project by moving the scrubber to the start or stop of the clip.

Zooming In and Out on the Timeline
If you need to zoom in on an area of the timeline to make minor adjustments—or zoom 
out to see the big picture—use the timeline magnification slider (Figure 25). 

Note: Apple Magic Trackpad and MacBook Pro users can use pinch gestures to zoom 
in/out on the timeline.

Figure 25. Timeline Magnification Slider

To change the scale magnification, use the slider in the lower left corner of the window. 
At maximum magnification, each line on the scale represents a single frame of video.

Note: You can also click repeatedly on the small and large magnifier icons to 
incrementally zoom in or out.

You can also use the View > Zoom Timeline to Fit (Control-T) | Zoom Timeline In (=) | 
Zoom Timeline Out (-) menu items to adjust magnification.

Magnification slider
Plus icon
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To add media to the timeline at the current scrubber position, click the plus (+) icon and 
select a media from the drop-down list displayed.

Timeline Buttons
There are four timeline buttons.

Click the Mouse Tool button to select how the mouse is used on the timeline.

Select The mouse selects items on the timeline..

Zoom Enables you to click and drag a region to zoom. If the mouse is clicked once 
(without dragging), it zooms in on the timeline one step per click. If the Option key is 
held down while clicking, it zooms out one step per click.

Hand Mouse moves the timeline by clicking and dragging with the mouse.

Blade When rolling over the timeline, a red line will follow the cursor.  If the mouse is 
clicked, the timeline will have all clips split at that mouse position.

Track Select Cursor changes to a right facing arrow.  Clicking on the timeline in this 
mode selects clips that are forward in time the current selection (from left to right). 

Note: If you hold down the shortcut key for a mouse tool, you can access it 
immediately.  If you release the key after 1/4 second, the previous tool will be restored.  
This allows the mouse tools to be used quickly with the keyboard

Thumbnail button
Snapping button

Framerate button

Mouse Tool  button

Click the Mouse
Tool  button

Shortcut keys
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The Thumbnail button opens the thumbnail menu. Check (optionally) Thumbnails and 
then select either Single, or Track.  You can also check (optionally) Waveform and the 
select either Single or Stereo.

Click the Snapping button to turn snapping on or off. When snapping is on, the button 
is displayed in blue. When off, it changes to white.

Click the Framerate button to display the Framerate menu. Select framerate settings 
and click Update when finished.

Using Tracks
You can place multiple clips sequentially in a single track or you can place clips 
separately on individual tracks, and use as many tracks as you need. 

Tracks allow you to organize your clips by layer. For visual elements at the same point 
on the timeline, vertical arrangement of tracks determines how they display in relation 
to other tracks. The further down the stack they are on the timeline, the further back 
they display in the video. Thus, if a track is below another track, its elements will be 
obscured by the track or tracks on top. Visual elements in the top track always display 
front-most can’t be obscured; those in the bottom track always displays farthest back 
and will be obscured by the elements in all other tracks above (in front) of it.

For example, a text box placed on a track above a video overlays the text on top of the 
video. If the text box were placed on the track below the screen recording, it would be 
behind the recording and not visible.
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Adding and Deleting Tracks
You never need to add a track explicitly; ScreenFlow adds a track every time you drag a 
clip down into the timeline below the existing tracks.

To delete a track, select the track and press the Delete key. Delete

Using the Track Controller
Use the controls (Figure 26) in the track controller at the far left of the timeline on each 
track to adjust the track height and re-arrange their order.

Figure 26. Using Track Controls to Adjust Track Height and Position

To adjust the height of a track, use the arrow buttons on the track. Click the down arrow 
to decrease the track height; click the up arrow to increase track height. This can make 
it easier to manage clips and other elements in your timeline. 

To re-arrange a track’s position, select the track position handle and drag the track up 
or down in relation to the other tracks on the timeline and drop it in the new position. 
This allows you to move all of the clips, rather than moving one clip at a time.

You can click and drag a clip left or right in a timeline to adjust its start time relative to 
the other clips. You can also click and drag clips to other tracks, or down to a new track.

You can also hide the video and/or mute the audio of any track. To hide/unhide the 
video, click the eye icon on the left end of the track. To mute/unmute the audio, click 
the speaker icon on the left end of the track. 

Trimming Clips
ScreenFlow provides a few simple commands for quick editing of clips in your timeline.

 Splitting a Clip

 Trimming a Clip

Splitting a Clip
To split your clip into two smaller clips, position the scrubber over the moment where 
you want the split to occur, then press the T key or select Edit > Split. This splits the 

Track height

Track position

Eye icon

Speaker
icon
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selected clip at the scrubber into two separate clips. By default, the newly-created clip 
to the left is selected after the split. 

Note: Press Shift-T to split the clip and have the clip on the right selected.

Trimming a Clip
Reducing the Clip Length—To trim the front of the selected clip, position the scrubber 
at the time you want the clip to begin, then press the W key or select Edit > Trim Front 
to Scrubber. This trims the clip up to the scrubber, thus changing the start time—but it 
does not alter the referenced media.

To trim the end of the clip, position the scrubber at the time where you want the clip to 
end, then press the E key or select Edit > Trim End to Scrubber. This trims the clip (not 
the media) after the scrubber.

You can also grab either end of the clip and drag it inward to trim it. 

Lengthening a Previously Trimmed Clip—On a previously-trimmed clip, you can pull 
either edge out from the clip to restore trimmed media.

Note: Trimming changes the amount of time the clip plays; it does not modify the 
referenced media file.

Creating and Closing Gaps in a Single Track
To create a gap in a track between existing clips, drag to shift the clips to the left or right 
as necessary. 

To close a gap in a track, click in the gap—ScreenFlow highlights the gap in purple with 
diagonal gray stripes. Press the Delete key, or control-click and select Close Gap.

Creating and Closing Gaps Across All Tracks
To create a gap in the entire timeline (across all tracks) to place a new clip, position the 
scrubber where you want the gap to occur. Then, grab the handle (red flag) at the 
bottom of the scrubber and move it to the right. 
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Figure 27. Using the Scrubber to Create a Gap on the Timeline

As the gap is created and widened, all clips to the right of the scrubber (in every track) 
move to the right to create the timeline gap. If the scrubber is positioned over any clip, 
it splits it in two.

To close a gap, position the scrubber at the beginning of the gap you want to close. 
Then, drag the bottom scrubber handle (red flag) to the left. This doesn’t join clips 
which have been split; it just butts them together. If clips overlap, this forms a 
transition.

Using In and Out Points
You can create in and out points on your timeline, and use them in the following ways:

• To delete the selected (marked) section of the timeline and close the gap, select 
Edit > Ripple Delete (Command-Backspace). All clips between the in and out points 
on all tracks are trimmed, and each clip completely encompassing the in and out 
points is split into two clips. All clips on the right are shifted left. After performing in 
and out point operations, in and out points are automatically removed.

• To delete the selected (marked) section of the timeline, without closing the gap, 
select Edit > Delete. All clips between the in and out points on all tracks are 
trimmed, and each clip completely encompassing the in and out points is split into 
two clips, leaving a gap on the timeline. After performing in and out point opera-
tions, the in and out points are automatically removed.

• To publish the range bounded by the points (instead of exporting the entire proj-
ect), select File > Publish to Selected Range  < Vimeo |YouTube |  Google Drive | Dropbox 
| Facebook | Wistia >. ScreenFlow displays the selected Publish dialog. Proceed as 
appropriate for the publisher. See Publishing Your ScreenFlow Project for details.

• To export the range bounded by the points (instead of exporting the entire proj-
ect), select File > Export Selected Range. (See Exporting Your Video).

The time between mark in and out points is highlighted in purple (Figure 28). 

Position the scrubber, then 
drag the handle (red flag) to 
create a gap on the timeline.
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Figure 28. Marking In and Out Points on Timeline

To set in and out points, position the scrubber and select Mark > Mark In Point (or press 
I). ScreenFlow highlights the timeline in blue to the end of the timeline. Then move the 
scrubber to the out point and select Mark > Mark Out Point (O) to set the out point.

You can reverse this process as well: Position the scrubber and set the out point. 
ScreenFlow highlights the timeline in blue to the beginning of the timeline. Then move 
the scrubber and set the in point.

To set in and out points relative to the position of the scrubber, shift-click on the 
timeline scale. If you shift-click to the left of the scrubber, you create the in point, using 
the scrubber location as the out point; if you shift-click to the right of the scrubber, you 
create the out point using the scrubber as the in point.

When you create an in point without an out point, ScreenFlow automatically sets the 
out point to the end of the last clip. When you create an out point without an in point, 
ScreenFlow sets the in point to the beginning of the timeline.

Changing a Clip’s Play Speed
You can change the play speed of individual clips on the timeline (). This option is useful 
for quickly moving past a process that doesn’t need to be shown in detail or slowing 
down a quick process which should be viewed in greater detail.

To change a clip’s play speed, use one of these two methods:

• Press and hold the Option key and move your cursor to the edge of the clip. The 
cursor displays a clock icon indicating that you are changing the clip speed. Move 
the edge of the clip inward to speed the clip up and outward to slow the clip down. 

• Click on the gear icon and select Show Clip Inspector.

Click on gear icon.
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To adjust the speed, use the slider or manually enter a percentage value. You can also 
change the duration to change the speed. Short is faster, longer is slower. Optionally, 
check Play Clip in Reverse. Check Locked to lock a clip to prevent editing.

Figure 29. Using the Clip Inspector

The clip is marked with a speed badge—a turtle or rabbit icon—to indicate that the clip 
speed was decreased or increased.

Grouping Clips
You can group a set of clips together to link them to one another temporally, which 
enables you to move them as a group in a single operation. This is useful when you 
have a sequence of clips arranged, and you want to preserve their relationship to one 
another.

It’s also useful when you have a screencast clip and a corresponding iSight clip with 
video and/or voice-over. Because the iSight clip is on the same timecode, grouping the 
two makes it easy to keep them in synch with one another.

To group a set of clips together, select the clips you want to group, and select Edit > 
Group or press Command-G.

To ungroup them again, select the group, then select Edit > Ungroup or press 
Command-U. 

Note: ScreenFlow also supports nesting of clips—hiding nested clips in one master 
nest clip, to reduce timeline complexity and increase the ease of editing. For details, 
see Using Nested Clips.

Locking Clips
You can lock a clip so that it can’t be altered in any way on the timeline. This is useful 
when you have a clip placed or configured exactly the way you want and do not want 
to alter them. Figure 30 depicts a clip which is locked—it displays dimmed and cannot 
be modified or moved.

To lock a clip, select it and use one of these methods:

• Select Arrange > Lock Clip.
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• Click the gear icon  on the clip and select Show Clip Inspector, then check Locked 
or select Lock Clip (Option-Command-L).

Figure 30. Locking and Unlocking Clips

To unlock the clip, select it and select Arrange > Unlock Clip or display the gear menu 
and select Show Clip Inspector or select Unlock Clip (Option-Command-L).

Creating a Freeze Frame
If you want to pause on a single frame of video while editing, select the clip and move 
the scrubber to the frame where you want to freeze. Select Edit > Add Freeze Frame to 
create a still image of the current frame of video, as shown below in Figure 31. 

Figure 31. Creating a Freeze Frame

This command splits the video into two clips, and adds a two second freeze frame clip 
(essentially an image) in between the two split clips. The duration of the freeze frame 
can be modified by expanding or contracting the clip (see Trimming Clips).

Using Markers to Identify Points on the Timeline
You can place markers on your timeline to identify a particular milestone on your 
project that you want to refer to often. Markers are particularly useful in a long or 
complex project during editing.

 Adding Markers

 Jumping to a Marker

 Deleting Markers

Note: You can also export marker locations as chapters in supported formats. For 
more information, see the Add Chapter Track from Markers control, described in 
Exporting Your Video.

Locked clips display as dimmed.
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Adding Markers
To add a marker, select from these choices:

• Move the scrubber to the desired location and select Mark > Markers > Add

• Control (right)-click in the time scale (scrubber jumps) and select Add Marker

• Select Window > Markers, then move the scrubber to the desired location and in the 
Markers window, click the plus (+) icon at the bottom left.

ScreenFlow displays a dialog so you can name the marker.

Figure 32. Creating a Marker

After entering the name of the marker, click OK. 

Note: Markers display as orange ticks on the time scale if they are named, but display 
in blue if blank or unnamed. You can select them to rename them, or drag them to re-
arrange them.

Jumping to a Marker
To jump to a given marker, select:

• Select Window > Markers

ScreenFlow displays the marker list window, as shown here in Figure 33.

Figure 33. Selecting a Marker From the Marker List
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Click the arrow to the left of a marker to quickly move to that time in the project. 

• Control (right)-click in the time scale—select the marker that you want to jump to.

Deleting Markers
To delete markers, choose from the following:

• Control (right)-click the orange or blue marker in the time scale and select Delete

• In the Markers window, select the marker and press Delete or click the minus (-) 
icon at the bottom left.

Creating Transitions
Transitions are applied to a clip to create a smooth progression into, out of, and 
between clips. Transitions can only be added to clips in the same track.

The default duration of a transition is one second. You can expand or contract the 
duration by moving the thin vertical line separating the transition from the main part of 
the clip. You may need to zoom in on the timeline to make it easier. As you adjust its 
duration, the time value displays in real time.

Note: You can also change the default duration of transitions in the ScreenFlow > 
Preferences >Timeline pane (Timeline Pane).

• Adding Transitions

• Configuring Video Transitions

• Configuring Audio Transitions

Adding Transitions
To add a transition, select a clip and choose from the following:

• Select Edit > Add Starting Transition to add a transition to the front of the clip

• Select Edit > Add Ending Transition to add a transition to the end of the clip

• Select Edit > Add Starting & Ending Transition to add a transition to both ends

You can also create transitions between two clips by dragging one clip over an adjacent 
clip. The section where the two clips overlap is the transition.

Configuring Video Transitions
To configure a transition, double-click the Transition icon in the clip (Figure 34).
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Figure 34. Transition Icon in Timeline Window

ScreenFlow displays the Transitions Inspector (Figure 35). 

Figure 35. Transitions Inspector Window

Click a transition icon to choose one of the transition types. (A notice will display for 
transitions that are not configurable). Click on a transition icon to see a demonstration 
of the transition action. (The transition keeps performing until your move the mouse 
off the icon.) Configure the transition properties (width, height, color, angle, opacity, 
etc.) using the controls displayed on the right side of the Transition Inspector window. 

Click the Preview button to preview the transition in your clip on the canvas. You can 
also set the transition duration value in seconds in the duration field at the bottom of 
the Transition Inspector window.

Show the Transition Groups area by clicking the arrow in the bottom left corner of the 
window.(click it again to hide them). Click All to display all available transitions.

When you hover over a transition a star appears. Click that star to add the transition to 
the list of favorites. To remove a transition from your list of favorites, click the star again. 
Click Favorites to display a list of your most used transitions. 

Click Built-in OS X to display transitions that are built into the operating system.

Transition icon.

Favorites 

Transition groups button

Preview button

Transition ControlsTransition icons

Duration field
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Transition Pack
The following transitions are included in ScreenFlow:

• Bands Radial Wipe

• Boxes Wipe

• Circle Wipe 

• Clock Wipe 

• Color Drop Wipe

• Cross Blur Wipe

• Cross Hair Wipe

• Doors Wipe

• Flip Over Wipe

• Grid Wipe

• Grid Zoom Wipe

• Jaws Wipe 

• Lava Wipe

• RGB Split

• Radial Wipe

• Slat Wipe 

• Square Reveal Wipe

• Vacuum Wipe

• Wave Wipe 

• Windshield Wipe 

Configuring Audio Transitions
Audio transitions are applied to audio clips in the same manner as video transitions. 
However, since there is no visual media in an audio clip, there is one transition—a 
volume transition, which is automatically applied. 

Audio transitions have no user-settable properties. Starting and ending audio 
transitions fade in and fade out. Overlapping transitions fade from one clip to the 
succeeding clip simultaneously.
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Labels
ScreenFlow enables you to color code clips in the timeline for quick navigation and 
labelling. You can create labels from the Edit menu or by right-clicking the clip. One or 
more clips need to be selected in the timeline for the Label menu item to be enabled.

 

When the Label menu item displays, click the desired color to identify the selected clips. 
Click X to remove the color label from the clip(s). There are four colors available for 
labeling.

Detaching Timelines
You can detach timelines and display them separately, even in an external monitor. To 
detach a timeline, select Window > Detach Timeline, and the timeline becomes a 
separate window.

Detached timeline
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Note: Detach Timeline is an application wide setting that will place any currently open 
documents into detached-timeline mode. Any documents that are subsequently 
opened are done so in the detached-timeline state. This settings is retained in the user 
preferences and will be maintained when the application is reopened. 

After activating the detached timeline feature, the timeline is removed from the 
preview window and placed in it’s own separate window. The initial position of this 
timeline window will be close to where the timeline is located in its attached form. This 
helps you to orientate the new detached window easily. However, the detached 
timeline window maintains its own title bar, close, maximize and minimize controls. The 
title bar reflects the document’s name, and is synchronized to the preview window’s 
title. The detached timeline window tile is appended with “-Timeline” to ensure proper 
identification. Closing a detached timeline window closes the entire document 
associated with it.

Using Nested Clips
At some point in the editing process, you may find that your project—after adding 
more and more clips—is becoming unmanageable. The solution: create nested clips.

Figure 36. Screencast with Nested Clips

You can select multiple, related clips and merge them into a single, nested clip—this 
reduces the visual complexity of the high-level timeline by displaying a single nested 
clip—which may represent dozens of clips gathered inside it. 

Each nested clip can be expanded and displayed on its own tab (Figure 36), so that you 
can edit it on its own independent view of the timeline. Nested clips also make it easy 
to re-use complex sequences in other places or other projects. But more importantly, 

Timeline 
tab
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you can edit a whole group of clips by placing edits on the nest, which affect all of the 
clips inside the nest. 

 Creating Nested Clips

 Viewing and Editing Nested Clips

Creating Nested Clips
To nest a set of clips, select the clips you want in the set and choose:

• Select Edit > Nest Clips. 

• Click the gear icon  on one of the clips and select Nest Clips (Option-Control-N).

• Control (right)-click one of the clips and select Nest Clips (Option-Command-N).

ScreenFlow replaces the set of nested clips with a single clip the length of the now-
nested clips on the timeline.

To un-nest a clip, select it and select Edit > Unnest Clips.

You can also nest clips recursively. That is, you can create a nest of clips, then open that 
nested clip and select some clips inside it and nest them, and so on. You can also go the 
other direction and nest two nests together, or create a nest from a nest and a clip. 
Although the depth of nesting is limited to ten, two or three levels is usually sufficient.

Viewing and Editing Nested Clips
To display the clips inside of a nested clip, double-click the nested clip in the high-level 
timeline (or in the Timeline tab when tabs are displayed). 

To display the tab bar, select View > Show Tab Bar. (Uncheck it to hide it again). The tab 
bar displays the Timeline tab at the far left. The Timeline tab displays the entire view of 
the timeline, including nested clips in relation to all other clips.

Additional tabs display the name of each nested clip in the Timeline tab. To change it, 
double-click on the name in the clip and rename it. The name on the tab automatically 
updates when you change the master clip’s name.

To display the clips inside a given nested clip, select the tab for that clip. ScreenFlow 
hides the Timeline tab contents, and uses the entire window to display all of the clips 
that comprise the nested clip. ScreenFlow opens the nested clip and displays all of its 
contents on the timeline.

To view the big picture of your timeline, you can click the Timeline tab at any time.

Nesting also provides another benefit: You can apply video filters and actions such as 
color correction or effect filtering to a nested clip. These changes apply to all clips 
inside the nested clip.

You can organize tabs to suit the needs of your project. To move a tab around, click and 
drag it to its new location. For example, you might want clip tabs to be displayed 
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ordinarily, just as the clips are arranged on the timeline. Or, you may want them 
displayed alphabetically.

When you delete a nested clip, all clips inside are deleted, and its tab is automatically 
removed from the timeline as well.

Keep in mind that after you have trimmed a video, the untrimmed portion displays with 
diagonal lines.

Creating Closed Captions
You can use ScreenFlow's caption editor to add, edit, and publish ADA-compliant soft 
subtitles as caption tracks to a project (Figure 37). Closed captions are not included by 
default when you create a new project—you need to enable them if you need them.

You can include captions in the screencast when you export the project as an MPEG-4 
movie (suitable for playback in iPhone & iPad, for example) and when you publish 
YouTube videos. Caption tracks can be created in multiple languages. You can also 
export captions as an SRT subtitle file.

Note: To view closed captions in a movie player, you must enable closed caption 
viewing. Enabling closed caption viewing in players is beyond the scope of this guide.

untrimmed 
video
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Figure 37. Screencast with Closed Captions

Closed caption text is rendered on-screen in white, sans-serif type, centered at the 
bottom of the screen.

 Displaying and Previewing Closed Captions

 Adjusting Video to Accommodate Caption Text

 Adding and Configuring Closed Captions

 Generating Closed Captions

 Importing and Exporting Closed Captions as SRT Subtitles

Displaying and Previewing Closed Captions
To display closed captions on the canvas, select View > Show Captions. As you scrub or 
preview the project, closed captions display on the canvas along with all other visual 
elements in the project.

Adjusting Video to Accommodate Caption Text
To provide a suitable background on which to display caption text clearly, use black or 
another dark background color, and consider using one of these techniques:

• Shorten the computer video frame upward (Figure 38) to create an empty rectan-
gle at the bottom. (This creates a minor distortion in the image.) 

Captions are rendered on the 
frame from the text you enter 
in caption clips.
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Figure 38. Shortening Video Frame Up for Captions

• Crop the computer video frame upward (Figure 39)—preserving the application 
window, but hiding the dock bar at the bottom. (This doesn’t distort the image.)

Figure 39. Cropping Video Frame for Captions

• Reduce the frame proportionally (Figure 40), positioning it at the top center of the 
canvas to achieve the same goal. Leave the canvas as-is—with pillars on each side 
of the frame—or shorten the canvas horizontally to eliminate the pillars (remem-
bering that this adjusts the frame size of your video).

Shorten video frame 
upward to create space for 
closed caption text.

Crop bottom of video 
frame to create space for 
closed caption text.
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Figure 40. Shrinking Video Frame for Captions

Adding and Configuring Closed Captions
To add and configure closed captions, first select View > Show Captions Track 
(Figure 41). ScreenFlow displays the caption track at the top of the timeline. Each clip 
on the timeline with an audio track displays a corresponding caption clip. Only one 
caption track can be shown at a time. 

Figure 41. Using the Caption Editor on the Canvas Pane

If there is more than one audio clip in the project at the same time (for example, a 
voice-over and a music bed), the audio clip on top (highest layer on the timeline) has its 
caption track displayed.

Reduce video frame to 
create space for closed 
caption text.

Leave pillars or reduce 
canvas size horizontally to 
remove them.

Closed caption editor pane

Caption playback controls:
     Previous Box | Play Clip | Next Box

Caption text field

Caption track

Caption boxes in a caption clip

Audio clip that corresponds to the caption clips above.
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Caption clips are permanently joined to their parent clip, and are always the same time 
length. They can not be moved independently. When you move (or duplicate or delete) 
the clip that ScreenFlow created the caption clip for, the caption clip moves along the 
timeline with it.

Caption clips are comprised of one or more caption boxes—which contain the text to 
display—in 3 second increments, which you can adjust. The number of boxes depends 
on the total length of the clip. You click each caption box independently to add text.

To add text to a clip’s caption box (or to edit it), click the target box. ScreenFlow displays 
the caption editor, where you can enter text and test it for appropriate time length, 
adjusting the length as necessary. You can add carriage returns to closed captions to 
display closed caption text on multiple lines.

To change the caption’s language, control-click on the caption box and select Set 
Language, or Edit>Captions>Set Language. Select the language you want to display 
captions in.

To move between caption boxes, use the left and right arrows in the caption playback 
controls. Or, press the tab key to advance to the next box and use Shift-tab to go to the 
previous box. The scrubber automatically jumps to the beginning of the next (or 
previous) box, and displays that box’s text, so you can add or edit it.

Note: When transitioning to the next caption, captions with a duration of 0.9 seconds 
or shorter get skipped over. Transitioning only jumps to captions that are one second 
in duration or longer.

To lengthen the display time of a caption box, press Command-up arrow. To reduce the 
display time, press Command-down arrow. You an also change the time in the caption 
editor.

To delete all of the text in all captions, control-click and select Clear All Captions, or Edit 
> Captions > Clear All Captions.

Generating Closed Captions
You can generate closed captions when exporting or publishing in these formats:

• Export the project as an MP4 (H.264 video) file. Select the Web-High or Web-Low 
preset or any Apple device preset, or a customized derivative. You’ll need to check 
Add Captions Track on the export window. For details, see Exporting Your Video.

• Publish the project to YouTube. You’ll need to check Add Captions Track on the 
export window. For details, see Publishing to YouTube.
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• Export with burned-in captions. To do this, check the Burn In Captions checkbox, 
under Options in the Export window.

Importing and Exporting Closed Captions as SRT Subtitles
To export your closed captions and save them in an SRT subtitle file, control-click on the 
timeline and select Export to SRT or Edit > Captions > Export to SRT. 

ScreenFlow displays a Save As dialog, where you can name the file, select a location, 
and save the file.

To Import an SRT file, select Edit > Captions > Import from SRT, then pick the SRT file you 
wish to import. In the file dialog window you can select the language of the caption file.

The imported SRT file is parsed and captions are generated for each entry. If there are 
any existing captions for the imported language, they will be cleared before the import. 
The import always overwrites any existing captions and does not merge them. 

Select Language 
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If there are any gaps in time between captions in the imported SRT file, spacer captions 
will be inserted to keep the captions in sync. ScreenFlow imports the captions into the 
first audio clip on the timeline, if the captions are longer than the clip, they are not split 
onto other audio clips. 

Configuring Video Properties
You can configure video properties to make visual changes to screen recordings, 
camera-based video, and other imported video clips, as well as image clips in a project.

You can also add video actions (transitional properties—those which change over 
time) to a clip and apply video properties only to the action. Actions display as yellow 
rectangles inside the clip—they are time-limited sections of a clip which enable you to 
apply properties to that time-bound section of the clip. Video actions can be added to 
both the start and end of a clip to create a transition. 

Select a video, screen recording, or image clip, or place the scrubber at the start or end 
of a video action in a clip before applying properties. To display the Screen Recording 
Properties pane, click the Screen Recording Properties icon, as shown in Figure 42.
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Figure 42. Video Properties
Click to display the Video Properties tab.

Add Video Action button

Add Video Filter button
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Video properties are described in Table 5.
Table 5. Video Properties Pane

Control Description

Scale Use the slider or enter a value (0-400%) to change the scale of 
your image. This is useful for highlighting a particular portion 
of the screen, or in a video action to create a zoom effect. 

Position Enter X and Y coordinates to specify the location (in pixels) of 
your video or image on the canvas, based on the center of the 
image. You can also reposition the image by dragging the 
image on the canvas, or nudging the selected image with the 
arrow keys.

X/Y/Z Rotation Use the rotation options to rotate (in degrees: -180 to180) the 
image in a virtual, three-dimensional space. X rotates the 
image along a horizontal axis. Y rotates the image along a 
vertical axis. Z spins the image along a depth axis. Or, use the 
thumb wheels to rotate the image in real time.

Opacity Use the slider to set the opacity value or enter it manually (0 
to 100%). The greater the value, the more opaque the image. 
When set to zero, the image is transparent—invisible. This can 
be used with a video action to fade an image in or out, or if 
you have a video voice-over, and would like to periodically 
display your entire camera recording frame.

Cropping Click the disclosure triangle down to display cropping 
options. Set the crop margins (by pixel) for left, right, bottom, 
and top. 

Reflection Check to implement reflection. Use the slider to set the value 
or enter it manually (0 to 100%).

Reflection creates a mirror image of the selected clip below 
the clip itself. The greater the value, the more opaque the 
reflection. When set to zero, the reflection is invisible. 

Corner Round Drag slider to adjust the roundness of the corners.

Drop Shadow Check to create a shadow effect behind a still image. If the 
image uses a transparency, the shadow only reflects the non-
transparent part of your image.

Use the thumb wheel (or enter the value manually) to set the 
angle of the shadow relative to the image in degrees (-180 to 
80 degrees). The default is -45 degrees.

Angle Use the thumb wheel (or enter the value manually) to set the 
Angle of the shadow relative to the image in degrees (-180 to 
80 degrees).
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Configuring Audio Properties
Display the Audio properties tab to modify the selected audio clips in your timeline. 
You can apply audio properties to any clip which contains audio, including clips with 
both video and audio.

You can also add audio actions (transitional properties—those which change over 
time) to a clip and apply properties to them. Audio actions can be added to both the 
start and end of a clip to create a transition. 

Color Click the color field to select the shadow color from the color 
picker. Default: black.

Offset Use the slider to set the value (in pixels) or enter it manually (0 
to 150 pixels) to specify the distance between the shadow 
and the clip. Default: 40.

Opacity Use the arrows to set the value or enter it manually (0 to 
100%). The greater the value, the more opaque the shadow. If 
the value is set to zero, the shadow is invisible. Default: 75%. 

Blur Size Use the arrows to set the value or enter it manually. Blur is a 
gradual loss in opacity as the shadow spreads from the center. 
Default: 4. Range: 0 to 100 pixels.

Color Controls Click the disclosure triangle down to display color options. 

Saturation Use the slider to set the value or enter it manually (0 to 400%). 
Saturation is the intensity of a color relative to its brightness, 
represented as a percentage. Default: 100%. 

Brightness Use the slider to set the value or enter it manually (0 to 400%). 
Brightness is the degree of luminosity present in the image, 
represented as a percentage. Default: 100%. 

Contrast Use the slider to set the value or enter it manually (0 to 400%). 
Contrast is the relative intensity of the black and white values 
in an image. A high contrast has a greater intensity of black 
and white values. This value is represented as a percentage. 
Default: 100%. 

Video Filters Click the plus icon to add filters to the selected clip. For details 
see Using Audio and Video Filters.

Add Video Action Click to add a video action at the moment indicated by the 
scrubber in the selected clip. You can also click the +Action 
icon at the top of the panel.

Table 5. Video Properties Pane

Control Description
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Select a video clip with audio, audio clip, screen recording clip with audio, or place the 
scrubber at the start or end of an audio action in the clip before applying properties. To 
display the Audio Properties pane, click the Audio Properties icon.

Figure 43. Audio Properties

To reset all audio properties in the selected clip to default values, click the gear icon  
at the top-right corner of the pan and select Reset to Defaults.

Each clip with audio displays with a waveform. This waveform provides a visual 
representation which reflects volume changes. Figure 44 depicts an audio clip with an 
audio action set to increase volume. Notice how the waveform display is enlarged to 
the right, due to the added action (shown in purple).

Figure 44. Audio Clip in Timeline

Volume The slider, and accompanying text field, provide the volume adjustment for 
the Audio Mixer. The volume is 100% by default, but can be boosted beyond or below 
this value. 

Mute Audio Check to mute all audio output from the mixer.

Ducking Check to activate ducking. When active, you can set the percent of ducking by 
moving the slider or by entering a value and pressing the Enter key. The slider is 
updated accordingly.  The purpose is to minimize the audio levels for background 
music/sounds, where ever there is narration/voiceover playing.

1. Highlight "narration" clip(s), which produces a yellow border.

2. Select the Audio Inspector tab in the properties inspector.

3. Select Ducking.

4. Adjust the percentage slider to desired level of ducking.

Processing Check Smooth Volume Levels to activate a smoothing process imposed on 
the audio output.

Click to display the Audio Properties tab.
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Audio Mixer
You can mix, pan, and solo all of your audio channels using the controls in the audio 
mixer. The Audio Mix panel is closed by default, but you can open it by clicking on the 
triangle icon. Each individual input channel is displayed. 

a

Gear icon Click to open the options menu where you can select Rest to defaults or Set 
Mix to Mono.

Channel Number Each individual audio channel has a number of controls. On the far 
left is the channel number string; this is simply the index of the channel. 

Audio Meter Next to the number is an audio meter showing the RMS power, peak and 
peak hold of audio in that channel. The meter is dB based and has a scale from -72 to 
+6. If the peak goes above 0dB, the meter will be tinted red to let the user know 
clipping is occurring. Once the peak hold decays below 0dB, the meter resumes its 
normal look. The lighter green value is the RMS power, which provides a general 
indication of the current loudness of the channel. The darker green color is the current 
peak dB value and the white line is the current peak hold value. 

Solo Buttons To the right of the audio meter is the 'S' or Solo button. This is a preview 
feature which mutes all other channels in the mix. (The solo state is not saved to the 
document). This is a standard feature from audio software, letting the user focus purely 
on monitoring a single channel. The solo button is a mutual exclusion: if a channel is 
already soloed and the user clicks it for a different channel, it will cease to be soloed 
and the new channel will become soloed. Holding down the command key while 
clicking on solo buttons will allow the user to solo multiple channels at once, which is 
especially useful for layering tracks in music production. If the user clicks the solo 
button again on the same channel (without holding down the command key), it will 
deactivate solo and normal playback will resume. When a channel is soloed, all other 
channel's meter's in the mix will have a visually disabled state where the meter goes to 
a gray shade. 

Pan Controls The control next to the solo is the pan button. The pan function in the 
audio mixer determines how much of the channel is mixed to the left & right channels 
of the final mix. When the pan control is in the middle (0%), the input channel is mixed 

Click triangle
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equally to both left & right output channels. When the pan is at -100% (all the way to 
the left), the input channel is being mixed only to the left output channel. If it is 100% 
(all the way to the right), the input channel is being mixed only to the right output 
channel. If the pan is set to -50%, 100% of input channel will be sent to the left channel, 
which 50% will be sent to the right. This is particularly useful when the ScreenFlow is 
using two microphones: one can slightly favor each channel. When a stereo media is 
imported into ScreenFlow, its audio mix will be setup by default to have the left input 
channel at -100% pan, and the right input channel at 100% pan. 

Note: This setup emulates how earlier versions of ScreenFlow behave: the left input 
channel is sent to the left output channel, and the right input channel is sent to the 
right output channel. Please be aware that the 'Mix to Mono' feature has been 
removed: this functionality can now be achieved with audio mixer's pan feature. 

Slider The slider and accompanying text field provide the volume adjustment for the 
input channel. The volume is 100% by default, but can be boosted beyond or below 
this value. 

Mix Output Displays the audio output of the mixer using a stereo meter bar.

Effect

aud

Effect Check to activate effects. Select an effect from the pull-down menu.

Amount Move the slider to adjust the amount of effect you want in your audio output. 
You can also enter a value directly. Press the Enter key when finished. The slider is 
updated accordingly.

Filter Check Remove Background Noise to remove or lower the background noise in 
your audio output.

Amount Move the slider to adjust the amount of background noise to remove. You can 
also enter a value directly. Press the Enter key when finished. The slider is updated 
accordingly.
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Audio Filters
Click the triangle to open the Audio Filters control window. Click the plus (+) icon to 
add a filter. Select a filter from the list of filters when displayed. You can add multiple 
filters. To remove a filter, click the “X” in the upper right corner of the filter window.

Configuring Video Motion Properties
The Video Motion tab enables you to control the motion of your media. To display the 
Video Motion Properties pane, click the Video Motion Properties icon, as shown in 
Figure 46.

Click triangle

Click plus to add

Click minus to remove
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Figure 45. Video Motion Properties

Video Motion properties are described in Table 6.

Adding Narration
Narration enables you to add a voiceover on top of an existing recording. To add a 
narration, select Insert > Narration. When the settings window displays, select an Audio 
Device, optionally check the End After checkbox (and enter a time in seconds), and 

Table 6. Video Motion Properties Controls

Control Description

Duration Enter the duration of the Video Motion.

Effect Check to enable effects, then select the type of effect: Gravity, 
Spring, or Pulse.

Lock to Check to lock the Video Motion to the Duration entered in the 
Duration field. When you check this box, the Duration field is 
disabled, preventing you from making changes until you 
unlock it.

Preview Click the triangle to see a preview of your Video Motion.

    Apply to Check (individually) to adjust the position, scale, or rotation of 
the clip after the action to see the effect.

Click to display the Video 
Motion Properties tab.

Click to add a Video 
Motion action.
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optionally uncheck the Mute Audio resident in your document. Click the Record button 
to start adding your narrative.

 

Note: The Mute audio playing during narration checkbox is checked by default to 
prevent feedback while adding narrations.

After clicking the record button, a count-down window will display to let you know 
when to begin your narrative. Progress while you are recording will display on the 
timeline. Click the Stop button when you finish your narrative.

 

After you have stopped recording your narrative, you can keep it or discard it.

 

Select and Audio Device

Check box and enter time value

Uncheck mute audio (optionally)

Click Record button

Click Stop button

Narrative progress bar

Select Keep or Discard
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If the you selected a time limited duration, as the finish time approaches, an ending 
countdown will appear on the screen. When the narration is either manually ended, or 
has stopped due to a limited duration, and the narration will have been added to the 
user’s document.

Configuring Screen Recording Properties
A screen recording (sometimes called a screencast, ScreenFlow clip or screen capture)—
as compared to a video clip or video file—is a proprietary format video clip that has 
been recorded directly in ScreenFlow, and is saved with a .scc extension. Screencast 
files can not be opened by other applications. Because screencast files are 
automatically and transparently managed by ScreenFlow, you rarely ever encounter 
them or have to deal with them.

Screen recording properties can only be applied to screen recording clips. If you try to 
apply properties to recording actions, they will be applied to the whole clip. Screen 
recording properties cannot be applied to clips recorded by other applications.

Select a screen recording or select the start or end of a screen recording action in the 
clip before applying properties. 

When you add a screen recording action, it displays in yellow.

To display the Screen Recording Properties pane, click the Screen Recording Properties 
icon, as shown in Figure 46.

Figure 46. Screen Recording Properties
Click to display the Screen Recording 

Click to add a screen 
recording action.
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Screen Recording properties are described in Table 7.
Table 7. Screen Recording Properties Controls

Control Description

Show Mouse Pointer When checked, any mouse pointer icon activity in the screen 
recording is displayed. When unchecked, the mouse pointer 
is hidden.

Pointer Zoom When Show Mouse Pointer is checked, use the slider to 
specify the size of the mouse icon in the screen recording.

Use the slider or manually enter the value to specify the 
percent of increase to apply.

Often it can be difficult to distinguish or track the mouse in a 
screencast, particularly if the video has been significantly 
resized. Increasing the pointer zoom value increases the size 
of the mouse icon, making it easier to follow.

Click Effect Select None | Radar | Invert from the popup menu to create a 
visual effect when you click the mouse. Radar displays an 
animated red circle with each click. Invert changes the cursor 
from black to white and back with each click.

Attention Effect Select Circle to pick an effect to display over the mouse 
pointer during their screen recording. Set the Size, Fill Color, 
Border Width, Edge Color and Edge Blur for the effect. (See 
Figure 47 below). The effect can be turned on & off using a 
Screen Recording action.

Pointer Select Default | Circle - Light | Circle - Dark | Square | Choose 
Image from the popup menu to change the pointer image.

The Circle - Dark option is particularly good for iOS 
screencasts.

When you select Choose Image, ScreenFlow displays an Open 
dialog, so you can navigate and select an image file. When 
selecting a custom image, you also specify the cursor hotspot 
position.

Opacity Specifies the degree of pointer translucency.

Use the slider to set the value or enter it manually (0 to 100%).

The greater the value, the more opaque the pointer. If the 
value is set to zero, the pointer is invisible. Default: 100%.

This can be used in a screen recording action to fade the 
pointer in or out.

Sound on Click Check to generate a sound when the mouse button is 
pressed.

Click the disclosure triangle to display Sound on Click details. 
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Figure 47. Attention Effect Properties

Volume Specify the volume level of the mouse click sound (from 0 to 
5,000%). Use the arrows to set the value or enter it manually.

Click Sound Click Choose to display an Open dialog, and navigate to and 
select any custom sound file, to play a unique sound file every 
time the mouse is clicked.

Show Keystrokes Check to display the characters (one at a time) of keyboard 
characters typed during the recording.

Show All Keys Check to display all keystrokes typed during the recording, 
including the modifier keys.

Show Only Modifier 
Keys

Check to display modifiers used in hotkey commands, 
function keys, and the arrow keys that were pressed during 
the recording.

Height and Position Specify the height and position of the font.

Font Button Click to display the font settings and specify all font 
information for the characters shown in the keyboard 
characters display.

Width Slide the slider right or left to adjust the keystroke bar 
horizontally. You can also enter a value into the numeric box.

Attached To Clip When checked, the keystroke bar will be attached to the 
screen recording clip, and will be affected by any changes 
made to the recording. This includes scaling, cropping, and 
any changes made to the canvas crop. 

When unchecked, the keystroke bar will only be affected by 
changes to canvas crop, and will remain centered to the 
canvas if any changes are made.

Table 7. Screen Recording Properties Controls

Control Description

Select Circle.

Set values
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Configuring Callout Properties
Callouts are transitional properties—those which change over time—and are used to 
highlight a specific portion of the screen. Mouse cursor and foreground windows 
callouts can only be added to screen recording clips. Freehand callouts can be added to 
video clips, image clips, and screen recording clips.

Callout properties cannot be applied at a clip level, only to a specific callout within a 
clip.

Note: You must add and/or select a callout before configuring its settings.

To display the Callout Properties pane, click the Callout Properties icon in the Properties 
pane, as shown in Figure 48 below.

Figure 48. Callout Properties

Click the +Action button to add a new Callout.

Click to display the Callout Properties tab.

Click to add a callout.
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Callout properties are described in Table 8. 
Table 8. Callout Properties

Control Description

Highlight Select how to highlight an area of the recording: Mouse 
Cursor highlights a circular space around the mouse cursor. 
Foreground Window highlights the window which is in the 
screen recording. Mouse and foreground highlights can only 
be added to screen recording clips.

Freehand callouts can be added to video clips, image clips, 
and screen recording clips.

See Adding Freehand Callouts to Images.

Opacity Use the slider to control the percent of opacity of the space 
outside the callout. A value of 0 makes the surrounding area 
entirely visible; a 100% value makes the surrounding area 
invisible.

Blur Use the slider or manually enter the pixel value to blur the 
callout area (range: 0-16).

Blur Background Check to blur the area outside of the callout.

Zoom Up Use the slider or manually enter the percentage value to 
magnify the area inside the callout (range: 0 to 500%).

Border Use the slider or manually enter the value to create a gradual 
loss in opacity as the shadow spreads from the center (range: 
0-300). This feature does not apply to freehand callouts. This 
is not a zoom control, but instead it adds more area to the 
callout.

Outline Enter the value (in pixels) to create an outline around the 
callout area (range: 0 to 59.) Click the color box to change the 
color of the outline.

Shadow Check to add a shadow behind the callout. Use the slider or 
manually enter the value to create a gradual change in size as 
the shadow spreads from the center (range: 0-80).
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Adding Freehand Callouts to Images
You can highlight freehand areas directly on images, using either a circular paint brush 
or a rectangle tool. You can use freehand callouts to blur out sensitive data or create a 
highlighted box around the content you are discussing, for example.

To create a freehand callout, follow these steps:

1. Set the location of the scrubber.

2. Select an image on your canvas.

3. Click the Callout Properties tab, click the + Action button, and click Freehand. 
(Because you’re working on an image, Freehand is the only callout option.)

Feather Specify the blend value (in pixels) to apply to the callout 
border to create a smooth transition between the callout area 
and the surrounding space (range: 0-20).

Round Applies to foreground window callouts only. Specify the 
round-off value (in pixels) of the callout edge to create a more 
gentle appearance (range: 0-59).

Build Specify the transition time of the callout, in seconds, up to 2 
decimal places, and from 0 to 4 seconds. Duration In 
determines the amount of build-in time to reach the full 
effect of the callout. Duration Out determines the amount of 
build-out time to return to normal.

Table 8. Callout Properties

Control Description

Click  + Action

Click Callout Properties tab

Click Freehand.
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4. When ScreenFlow displays the tool palette in the upper right corner of the canvas, 
select either the brush or the rectangle tool. If you select the brush, you can set the 
size of the brush.

Figure 49. Freehand Callout Tool Palette

5. Draw the highlighted region on your selected image using your mouse. To 
brush-on a highlighted area, select the brush tool, set the brush size, then click and 
drag the mouse to define an area. To create a rectangle highlighted area, select the 
rectangle tool, then click and drag the mouse to define an area

  

Brush tool

Rectangular tool

Brush size adjust

Rectangle area

Brushed area

Brush tool

Rectangle tool

Brush size adjust
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6. Use the callout properties to adjust the look of your callout.

7. To remove a brushed-on freehand callout, select the brush tool, then hold down 
the Option key and the left mouse button while moving the mouse over the 
highlighted area to erase it. To remove a rectangle freehand callout, select the 
rectangle tool, then hold down the Option key and the left mouse button while 
moving the mouse over the highlighted area to select it. When you release the 
mouse button, the callout is removed. 

Recording IOS devices
ScreenFlow enables you to record the screen of your iOS device. You must be running 
Yosemite and iOS 8, and have your device connected to your computer with an Apple 
Lightening to USB cable. 

1. Connect your device to the computer and make sure it is detected. You can check 
iTunes to verify it has been detected. 

Note: If it is the first time the iOS device is connected to your computer, you will be 
asked if you trust the device. Select Trust to continue.

Callout controls
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2. Open ScreenFlow and select New Recording.

3. Select your iOS device from the Record Desktop from drop-down list.

4. Click the Record button. After the countdown, you can begin demonstrating your 
iOS device. 

Note: There will not be a preview of your screen, but the screen will record. It will not 
record touches; you can add touch callouts to simulate your finger touches/swipes. 
(See Configuring Touch Callouts.)

5. When you stop the recording you will see your iOS device on the canvas. 
ScreenFlow will automatically orient the screen for apps that display as landscape. 
You may need to adjust the canvas size.

Select New 
Recording

Check Record  
IOS Device

Select IOS 
device

Click Record 
button
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You can display a recording monitor by selecting Show Recording Monitor from the 
Record configuration menu. The monitor displays stereo volume meters, a Preview 
Volume slider, and an Add Marker button. Preview Volume allows you to hear the 
system audio playing on your iOS device through your computer audio output as it is 
being recorded. 

Note: If you do not hear iOS audio while recording, toggle the ringer/vibrate switch 
on your iOS device. Also, be aware that this audio will be heard twice in the 
ScreenFlow project if you are recording computer audio while monitoring iOS audio.

When you play or scrub through the video, you will see all of the actions you performed 
on the device. 

Configuring Touch Callouts
When running on OS X 10.10 (Yosemite), ScreenFlow can capture directly from the 
screen of an iOS device over a USB connection. This opens up new workflow 
opportunities for ScreenFlow. Unfortunately there is no way to automatically receive 
touch events from the iOS device, so the application cannot know where the user 
touched on the iOS device. The solution is to allow the user to manually specify touch 
overlays. These are Touch Callouts, and they are added through the Actions menu. 

Select Add Touch Callout.

Select Add Touch Callout
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The touch callouts are configured through a new tab in the ScreenFlow inspector 
where the touch callouts can also be added. 

Count Select the number of Touch Callouts.

Fill Check to choose Solid Color Gradient from the popup menu. For solid color, select a 
color from the color wheel. 

Outline Enter the value (in pixels) to create an outline around the callout area (range: 0 
to 59.) Click the color box to change the color of the outline.

Size Move the slider to set the size of the Touch Callout area (in pixels). You can also 
enter size value and press the Enter key.

Spacing Move the slider to set the distance between multiple Touch Callouts. This 
setting is grayed-out if you have only one Touch Callout.

Opacity Enter a value, or click the up or down arrows, to set the amount of opacity 
(transparency) of a selected Touch Callout.

Rotation Enter a value, or click the up or down arrows, to set the amount of rotation of 
a selected Touch Callout.

Touch callouts work in a similar fashion to freehand callouts. When the action is 
selected in the timeline, the video view enters a modal editing state, which is 

Touch Callout tab
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represented by the timeline. Only the currently selected clip and some editing controls 
in the top right corner of the video view are highlighted. This modal editing state can 
be exited by clicking away from the touch callout, or by clicking the close button on the 
editing tools.

When in editing mode, you can click the touch callout and move it around the screen as 
needed. You can increase the number of callouts (representing finger presses). You can 
also specify a fill or outline on the callout independently.

By default, the touch callout only has a start state. If you wish to have a movable callout, 
click the ‘Callout has end state’ checkbox. This will display the end state callout. As you 
move the timeline over the action, you will see the touch callout move from the starting 
to the ending point. 

End State If you have specified an end state, you can also tell the touch callout to wait 
for a number of seconds before starting the movement / animation to the end state. 
This is enabled using the Wait - seconds before starting option. The timing curve can be 
specified for the interpolation to the end state. These are the same options as the Video 
action - Linear, Ease In, Ease Out, and Ease In & Out.

Animate If you want the callout to animate its size, spacing, opacity, or rotation 
parameters, you can select the Animates values to end state checkbox. The first time this 
is checked, it fills the end state values from the current starting state values. 

When you are editing the touch callouts in the main canvas, the start state touch 
callout has a cross-hair in the middle, and the end state has a little circle. This helps you 
to determine which state you are in. 

Note: Touch Callouts are not restricted to iOS recordings - they can be added to any 
clip that a regular callout can be.
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Add Snapback Action
Snapback actions are available for each of the three types of override actions: Video, 
Audio, and Screen Recording. They behave like any other type of action. For example, 
you cannot have two video (or video Snapback) actions occupying the same time 
period. A snapback action will restore the state from before the previous action was 
executed. 

To add a Snapback Action, select Actions > Add Snapback Action, and select Video, 
Audio, or Screen Recording. 

In the example below, the values are restored from the clip itself, since there is no 
action behind the Video action.

In this example, the Video Snapback goes into the first video action state.

You cannot add a Snapback Action if there is no action to snapback to. If you try to add 
a snapback action, a warning is displayed.
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Rolling Edit
ScreenFlow provides support to the timeline for performing rolling edits, giving you 
productivity improvement for editing you presentations.

The rolling edit feature is enabled when two clips are connected to each other with no 
gap between them. 

When you move the mouse over the seam of the two clips, the rolling edit icon appears 
at the top of the clips.

If you click on this icon, the rolling edit mode is activated and moving the mouse left 
and right alters the duration of the clip on the left, and it alters the in-point and 
duration of the clip on the right.

When the clips have a potentially infinite duration (text or still image clips), the only 
limit on the operation is that no clip can shrink smaller than a single frame. When the 
clips have a finite duration (recorded clips), the clips cannot be resized past the amount 
of content available, just as they would if you had grabbed the right or left edge.

Configuring Annotations Properties
Annotations are used for displaying simple shapes in your project. Annotations are clips 
you can add to your timeline, and behave like image clips. You can apply several video 
properties (scaling, position, x/y/z rotation, and opacity) and video actions to 
annotations clips.

To display the Annotations Properties pane, click the Annotations Properties icon in the 
Properties pane, as shown in Figure 50 below.

Rolling edit icon
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Figure 50. Annotations Properties

Adding an Annotation Clip
To add an annotation clip, set the scrubber in the location where you want the clip to 
start, and click the Add icon (+). ScreenFlow adds a 5 second annotation clip in a new, 
top track (which you can move anywhere on the timeline you want).

When you create an annotation clip, you must immediately add at least one object to 
the clip, or ScreenFlow will automatically delete it. As a matter of fact, if you later 
remove all annotations, ScreenFlow deletes the annotation clip automatically.

Figure 51 depicts a sample callout on the canvas (left), and its corresponding clip on 
the timeline (in orange on the right).

Figure 51. Sample Annotations Clip on Canvas (left) and Timeline (right)

Adding and Configuring Annotation Items
To add annotation items to an annotation clip, follow these steps.

1. Select the clip to which you wish to add an Annotation.

2. Choose the Annotations Property Tab.

3. Choose an Annotation Object from Tool Palette (see Figure 50).

4. Adjust object on canvas to desired effect.

While selected, you can adjust the item’s properties as described below in Table 9. 

Click to display the 
Annotations Properties tab

Tool palette

Click to add an annotations clip.
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Note: Notice that as you are drawing, the timeline loses focus and darkens. Drawing is 
a modal operation: When you’re done drawing and configuring objects, you must click 
on the timeline to continue working on the canvas or timeline. 

To save these settings for new annotations clips you may add in the future, click the 
gear icon  and select Make Settings Default. 

Freehand Annotations
You can also create Freehand Annotations (freehand drawings accessible through the 
existing Annotation’s Inspector panel). This feature enables you to draw smooth and 
accurate freehand lines and shapes, move and resize them, and change properties such 
as: color, opacity, shadow, and outline. 

Table 9. Annotations Properties Controls

Control Description

Shapes Choose from the types of annotations in the tool bar: 

• Line (arrow)

• Line

• Square (filled)

• Square

• Circle

Color Click to select the color of the annotation.

Opacity Use the slider (or enter the percentage value manually) to set 
the opacity of the selected object.

Thickness Use the slider or manually enter the value to specify the 
thickness (in pixels) of annotation lines (range: 2 to 350). 
Default: 55.

Shadow Check to create a shadow on objects in the annotation. Use 
the slider or manually enter the value (in pixels) to specify the 
opacity of the shadow (range: 1 to 60). Default: 25. The value 
creates a gradual loss in opacity as the shadow spreads from 
the center.

Outline Check to create an outline around objects in the annotation. 
Use the slider to specify the thickness of the outline.

Color Click to select the color of the outline.

Endpoints Select a shape to affix to the end of a line segment. The first 
and second field represent the starting and finishing point of 
the line segment, respectively.
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To add a new Freehand Annotation, click the Freehand button on the Annotations tab, 
then click the Add button (+) to place a freehand Annotation in the timeline.

Freehand Annotations are stored as Bezier Curves, which are generated from a list of 
mouse points. Freehand annotations are drawn like any other annotation type. Lines 
are created by dragging the mouse along the canvas to draw lines.  

One difference between Freehand Annotations and other annotation types is that 
Freehand Annotations are not automatically selected when the mouse is released from 
drawing. This prevents you from having to de-select a drawing each time you want to 
create a new one. Another difference is that in order to select a Freehand Annotation, 
you are required to hold down the Command Key. This is to prevent users from 
selecting other freehand annotations while drawing.

Configuring Text Properties
Text boxes are clips which display blocks of text in your project. Text clips behave like 
image clips—they are static images which display for the length of time you specify. 
You can also apply video properties and transitions to text clips, along with Test 
Animations.

 Adding and Configuring a Text Clip

 Text Animations

Adding and Configuring a Text Clip
To add a text clip, set the scrubber in the location where you want the clip to start, and 
click Add Text Box or click the gear icon  on the Text Properties pane and select Add 
Text Box or Insert > Add Text Box. ScreenFlow adds a 5 second text clip in a new, top track 
(which you can move anywhere on the timeline you want).

Click Freehand button

Click Add button
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Note: Go to ScreenFlow > Preferences > Timeline to change the default duration of 
your Text clip.

When you create a text clip, it has the default word Text in it. Select the text to edit it. 
You must have at least one character in the clip, or ScreenFlow automatically deletes it. 
As a matter of fact, if you later remove all text, ScreenFlow deletes the clip 
automatically.

Figure 52 depicts a sample text clip on the canvas (left), and its corresponding clip on 
the timeline (on the right).

Figure 52. Sample Text Clip on Canvas (left) and Timeline (right)

While the text is selected, you can adjust the text properties as described below in 
Table 10.

Click the gear icon  and select Reset to Defaults to reset all properties in this pane to 
default values. When you select Reset to Defaults, the settings applied by this 
command are the settings in place when Make Settings Default for New Text Clips was 
executed.

To display the Text Properties pane, click the Text Properties icon in the Properties pane, 
as shown in Figure 53 below.
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Figure 53. Text Properties

 
Table 10. Text Properties Controls

Menu Item Description

Font Select this menu to choose a font face from the list of fonts 
provided by your system. The font is applied to the entire text 
box (if none or all text is selected) or a range of selected 
characters.

Size Select this menu to choose the size of your text in pixels 
(range: 9 to 288). The size is applied to the entire text box (if 
none or all text is selected) or a range of selected characters. 
Select Font > Show Fonts to enter a custom size.

Alignment Select paragraph alignment: Align Left | Align Right | Center. 
This property affects single or multiple selected paragraphs

Click to display the 
Text Properties tab.

Click to add text.
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Text Animations
Text clips can have the interesting property of per character animations for building in 
and out the clip to the screen. These effects are commonly seen in other popular 
applications. Once enabled, a default effect is selected, with a default duration of 0.75 
seconds. You can switch between different effects. 

Fill Check to choose Solid Color | Image | Gradient from the 
popup menu. For solid color, select a color from the color 
wheel. The color is applied to the entire text box (if none or all 
text is selected) or a range of selected characters. For Image, 
ScreenFlow displays an Open dialog, so you can navigate to 
and select any custom image file. Deselect the checkbox to 
remove the file. This can be used with Outline to create 
characters which are transparent. Applying an image uses the 
color patterns represented in the image to fill the text. These 
properties are applied to the entire text box (if none or all text 
is selected) or a range of selected characters.

Color The Fill color field allows you to choose the color used in your 
text. For gradient, click in the top half and select a color, then 
click in the bottom half and select the second color.

Outline Check to outline the text.The outline is applied to the entire 
text box (if none or all text is selected) or a range of selected 
characters. Use the slider to set the width of the outline (in 
pixels) range: 0 to 15.

Kerning Select Text Kerning mode: Tighten (closer) or Loosen (further).

Color Click to select the color of the outline. Select the color, 
brightness, and opacity. Brightness is only available on the 
Color Sliders pane of the Show Colors tool.

Backdrop Check to add a background and choose Solid Color | Image 
Fill.

Color For Solid Color only, click to select the color of the backdrop. 
Specify the color, brightness, and opacity. Brightness is only 
available on the Color Sliders pane of the Show Colors tool.

Round Use the arrows or manually specify the value in pixels to 
smooth the edge of the text box (range: 0 to 100). Default: 20.

Margin Use the slider or manually enter the size (in pixels) of the 
backdrop (range: 0 to 300). Default: 25.

Table 10. Text Properties Controls

Menu Item Description
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To display the Text Animations pane, click the Text Properties icon in the Properties 
pane and scroll down to the bottom of the pane as shown in Figure 54 below. Click the 
triangle icons on the Build In/Out Animation sections to open the controls.

Figure 54. Text Animations

Build In/Out Animation Check to enable Build In or Build Out Animations.

Type Select the type of text animation: Break Apart, Center, Character Flip, Gravity, 
Move, Scale, or Typewriter.   Experiment with each of these using the Test Button to see 
the performance of each animation type.

Test Button Click the Play icon (large triangle to the right of the Type menu) to watch 
your Text Animation play out based on your current settings.

Duration Move the slider to increase or decrease the duration (in seconds) of the text 
animation. You can also set the duration by typing a value into the numeric display to 
the right of the slider. Press the Enter key when finished entering a new value.

Build Select All At Once, By Line, or By Character to choose how your text animation 
builds (transitions) in or out.

Direction Controls Select an arrow to determine which direction your animation will 
build in from, or build out to. You can choose left, right, top, bottom, or any corner.

Distance Move the slider to increase or decrease the distance from which (or to which) 
your text animation will travel. You can also set the distance by typing a value into the 

Click the triangle icon

Test Button

Direction controlsBuild In Controls

Build Out Controls
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numeric display to the right of the slider. Press the Enter key when finished entering a 
new value.

Overlap Move the slider to increase or decrease the manner in which multiple lines of 
text are built in or out. Greater overlap (higher percentage) causes the lines of text to 
enter in an overlapping (sequential) manner. Lower overlap brings in or out all lines at 
once. You can also set the overlap by typing a value into the numeric display to the 
right of the slider. Press the Enter key when finished entering a new value.

Easing Select the kind of easing for your transition. Easing is the rate at which your 
transition occurs. This can be slow at the beginning and fast at the end, or some other 
kind of rate of change. Experiment with each of these using the Test Button to see the 
performance of each animation type. 

Fade Characters Check to cause the text to fade in or out during transition.

Using Style Presets
On all of the configuration panels, there is a Style Presets button in the top right corner. 
Select a video, then click the Style Presets button to open the Style Presets window. 

Click Style Presets buttonSelect a video
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When the Styles Presets window displays, click the plus (+) button to create a new style 
based on the current properties of your video.

When the next setup window displays, select parameters to be included in the new 
style preset, then click the plus (+) button.

Click the plus 
(+) button

Click the plus 
(+) button

Select parameters
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When the next setup window displays, rename the Style Preset from its default name. 
You can also update the preset or delete it by clicking on the great icon to open a drop-
down menu.

Once you have created a list of style presets, you ally them to any video by selecting a 
video and choosing a style preset from the list.

Using Audio and Video Filters
ScreenFlow provides a vast array of audio and video filters to add effects to videos, 
audio tracks, and images. Audio effects include EQ, multi-band compression, peak 
limiting, delay and many more. Video effects include advanced color adjustments, 

Click the 
gear icon

Rename the Style Preset

Choose a style presetSelect a video
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distortion effects, blurring, color effects, alpha mask, and many more as well. Multiple 
filters can be applied to a single clip. Filters can also be applied to nested clips.

Note: You can also purchase 3rd party Core Audio or Video filters and install them for 
use in ScreenFlow.

Each filter has parameters that can be configured and adjusted for optional features 
and fine-tuning its effects.

 Adding a Filter

 Removing a Filter

 Re-ordering Filters

 Configuring a Filter

Adding a Filter
To add a filter to a clip (or clips), follow these steps:

1. Select the clip that you want to add the filter to.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video or Audio Filters plus (+) icon to display the filter list (Figure 55).

Figure 55. Adding a Filter to a Clip

4. Scroll through the list of filters, opening and closing filter groups as appropriate. Or, 
you may search for a filter by entering a filter name into the Search box and 
pressing the Enter key.

5. Click Add to add it to the filter list for the selected clip.

Click the plus icon to 
display the list of filters. 

Scroll through the filter list, 
opening categories as 
appropriate. Select the 
filter you want to add and 
click Add. 

Enter filter name to search 
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Note: If a manufacturer's Audio Unit plug-in does not work in a “sandbox” 
environment, it will not work in the Mac App Store version of ScreenFlow.

Removing a Filter
To remove a filter that has been added to a clip, follow these steps:

1. Select the clip that you want to remove the filter from.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters Figure 56.

Figure 56. Deleting a Filter from a Clip

4. Scroll through the filters until you find the one you want to delete. 

5. Click the X icon to delete it from the clip.

Note: You can disable a filter temporarily, by unchecking its name.

Re-ordering Filters
The application of a filter has different effects, depending on where it is stacked with 
the other filters, if present. Filters are applied based on their order in the list, from top to 
bottom. 

To layer (or order) filters in the order you want them applied, follow these steps:

1. Select the clip that has the filters you want to re-order.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters Figure 57.

Click the X icon to 
delete the filter. 



Editing ScreenFlow Projects
Using Audio and Video Filters

149

Figure 57. Re-ordering the Filter List

4. Scroll through the filters to identify the one you want to re-arrange.

5. Click on the grab icon just to the left of the checkbox by its name.

6. Drag the filter up or down the list to re-order its application in relation to other 
filters in the list.

Configuring a Filter
Video filters that have a visual position coordinate display a cross-hairs button, which 
allows you to adjust the position on the canvas. The label of the parameter you are 
editing also appears on the canvas when adjusting the position.

When multiple clips are selected, ScreenFlow attempts to display the list of filters in the 
Video Properties pane where the filters have similar settings. For example, if two clips 
have two identical filters in the same order, ScreenFlow will display the two filters 
regardless of whether any of the individual parameters are the same. However, if the 
two clips have the same filters but in different order, ScreenFlow displays a Multiple 
Filters message.

Filter processing is CPU-intensive. Depending on the number of filters enabled, expect 
export and publishing times to increase.

After you configure a filter, you can test it out by playing the video.

To configure a filter, follow these steps:

1. Select the clip that has the filter you want to configure.

2. Select the Video or Audio properties pane, as appropriate.

3. Click on the Video | Audio Filters disclosure triangle to display the filters (Figure 58).

Click the grab icon to drag the 
filter up or down the list.
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Figure 58. Sample Filter

4. Scroll through the filters to locate the one you want to configure.

5. Adjust the controls as necessary.

Using the Chroma Key Filter
The Chroma Key filter creates transparency in the selected clip, using a unique color. In 
effect, this creates a keyhole in the clip, by converting all pixels in each frame that are 
similar to the chroma color, so that they are transparent. This permits the pixels in the 
same location in the clip (in layers below) or background behind to display through. 
This is the effect used to depict the classic weatherman standing in front of a weather 
map. The weatherman actually stands in front of a green (or blue) screen, and his image 
is then chroma-keyed onto the weather map to complete the illusion.

In the progressive sequence portrayed in images (below, in Figure 59), an announcer is 
filmed in front of a green screen. The clip (the first image on the left) is added to the 
project, and the Chroma Key filter is added and adjusted to make the background 
pixels transparent, permitting the black background to show through (second image). 
In the final step, a still image clip (third image) is added to the track below the 
announcer clip, which depicts the announcer—in the far right image—as standing in 
the meadow in front of the mountain. Figure 60 shows the chroma key filter application 
on the ScreenFlow timeline.

Figure 59. Typical Chroma Key Filter Application

Original clip Green color keyed out Background - 2nd track Final composite clip
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Figure 60. Chroma Key Filter Application on Timeline

A chromatic background is a background with color in it. Black and white are not colors 
in this sense. Green and blue are the best colors to use, but the Chroma Key filter also 
works with orange or red or purple, just not as well. 

Effective use of a chroma key requires video where the background is a bright, evenly-
lit uniform (or nearly so) color. The persons or objects you place in front of the backdrop 
shouldn’t match the color in the backdrop (unless they have regions that you also want 
to make transparent).

An important aspect of implementing an effective chroma key is to ensure you have a 
uniform chroma key source (green screen). And the best way to do this is to provide an 
even, well-lit chroma background. The better the input, the better the output.

 Implementing a Chroma Keyed Clip

 Applying the Chroma Key Filter

 Refining the Chroma Key Filter Settings

Implementing a Chroma Keyed Clip
To chroma key a clip, do the following:
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1. Shoot your target clip (of persons or objects) against a green screen—a well lit, 
even blue or green surface, for example. This color should not be in the foreground 
object (a person’s tie, for example, shouldn’t be green when using a green screen).

2. Shoot your background image or clip.

3. Add the target clip to your project.

4. Select a background color on the canvas for chroma key testing.

5. Add the Chroma Key filter and set it up. See Applying the Chroma Key Filter.

6. Test your clip by previewing it, and adjust chroma key settings as necessary. See 
Refining the Chroma Key Filter Settings

7. If necessary, split your clips, add the chroma key filter and adjust it.

8. When you’re satisfied with the chroma key, add your background image or clip to 
the project in the track immediately below the target clip.

Applying the Chroma Key Filter
You can apply the Chroma Key filter (Figure 61) to any clip shot against a green screen—
for the purpose of replacing the transparent regions with another image or 
background. 

Figure 61. Chroma Key Filter Settings Editor

You can also apply the filter to clips shot against other uniform-colored backgrounds 
such as a sky, or a wall, although your results may vary, based on the uniformity and 
contrast with the foreground objects. (For details on adding filters, see Using Audio and 
Video Filters).
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Adjust the Chroma Key settings as needed. For details, see Selecting a Chroma Key Color.

Selecting a Chroma Key Color
It is important to choose the correct color for the chroma key. The color should match 
or closely match the background. The color displayed in the box is selected 
automatically by analyzing the current frame. Sometimes this is not the best color.

An effective method for chroma key color selection is to select the correct color by 
clicking in the original image where a cross-hair appears (to select a specific color/
pixel), then use the Refine Key image to further refine the key as required. It's often best 
to click next to the edge of an object that is not going to be removed. Usually, the color 
near the object is the most effective chroma key color.

To select a more effective color, click the Color button to open the Refine Key window in 
the upper right corner of the canvas pane, as shown here in Figure 62.

Figure 62. Refining the Chroma Key Color

Table 11. Chroma Key Filter Settings

Menu Item Description

Color Click to refine the key (to specify the color to be converted to 
transparency.

White Clip Use the slider to adjust the whiteness tolerance to reduce 
white pixel transparency. Adjust the gray scale value (0 to 
255) to the right, until the entire background is transparent.

In a source with lots of very bright white, the background may 
bleed through the white part of the image. To avoid this, 
adjust the White Clip value.

Tolerance Use the slider to specify how far from the chroma key color is 
considered background. Adjust to remove more or less of the 
background color without affecting the foreground image. 

Angle Use the slider to specify the angle around the chosen color. 

The amount of color varies, depending on how far from the 
center of the colorspace the selected color is. 
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When the Refine Key window is open you can click anywhere in the clip image on the 
canvas to select a new color to use. 

You can also click directly in the Refine Key window to adjust the selected color. The 
Refine Key color range displays the colors that are near (in value) to the currently 
selected color. (The Refine Key window does not display all colors in the image.)

Refining the Chroma Key Filter Settings
The most effective chroma key settings are found by an iterative process of adjusting all 
three parameters, viewing results over time, and adjusting them again, until you are 
satisfied with the overall performance. Here’s a suggested pattern of refinement.

Temporarily move your background or image clip out of the way, so that the canvas 
color can be used as a backdrop against your foreground image.

Next, adjust the White Key value by dragging the slider from left to right. As the opaque 
area reduces, pay close attention to the edges of the foreground image. If background 
starts showing through, creating a shadow effect from the black (or other) background, 
adjust the Tolerance level to the left to eliminate the shadows around the edge.

Then, return to the White Key parameter and completely eliminate the opaque areas so 
that the entire background is fully transparent.

Work back and forth between the White Key and Tolerance sliders (with a little fudge 
factor in each) to strike a perfect balance as you scrub your clip.

Finally, reduce the Angle slider value to zero, then move it to the right again until the 
background is completely transparent, then increase it a bit more for fudge factor.

Scrub the clip often, to make sure the chroma key works well across the entire clip.

Note: Sometimes a video will slightly vary color over time. Thus, you might need 
different keys. To add different chroma keys to a clip, you can split the source clip into 
several clips and then apply a slightly different key color to each one.

Using the Media Library
The media library is a directory of sorts, but it is not a file system folder. You use the 
media library to collect all your clips for a given project into a single collection, and to 
provide easy access directly in your project. Screen recording files are stored in a 
ScreenFlow-controlled location (the Media folder in the package contents of each 
ScreenFlow document). Other files you add (video and audio files and images) remain 
in the directory where you placed them, but are also auto-saved in the same location.

When you add (import) a file into ScreenFlow, it creates a media object for it, and 
displays its thumbnail image in the media library, which points to the original media 
file. When you adjust properties of a clip or image or add actions, these properties are 
stored with the media object—the original file is never altered. You can drag these 
media objects onto your canvas or timeline to add them to the project.
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Note: In the Telestream Web Store version of ScreenFlow, you can edit media files and 
images outside of ScreenFlow and save them—ScreenFlow advises you and allows 
you to reload the updated file. ScreenFlow also adds a refresh icon to the media file in 
the Media Library, which you can select. This feature is not present in the Mac App 
Store version.

 Managing Media in your Media Library

 Adding Media to the Timeline

 Using the Media Library Context Menu

 Using the Media Library Controls

Managing Media in your Media Library
Add To add media to your media library, use one of these methods:

• Record media in ScreenFlow. When the recording is added to the canvas and time-
line of an open project window, it is also added to the project’s media library.

• Drag the media file from the Finder into the media library

• Drag the media file from the Finder onto the timeline. ScreenFlow automatically 
adds it to the media library.

• In the media library pane, click Add Media. ScreenFlow displays a File System dia-
log, where you can navigate and select the media to add to the media library.

Note: Videos, images, and audio files imported into the media library remain linked 
to their original source. If a source file is modified, ScreenFlow will advise you, and 
offer to reload the modified file. When ScreenFlow reloads a file, it automatically 
updates the library, timeline, and canvas. This makes it easy to edit your video, audio, 
and images—and automatically update them in your ScreenFlow projects.

After you have added media to your media library, you can hover over the media file 
icon and cause a scrubber to display. This scrubber enables you to preview the media 
file content before placing it on the timeline.

media file 
scrubber
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Duplicate To duplicate media to the file system, drag the media file out to your 
desktop, target folder or server. Mac OS X duplicates the source media file in the new 
location.

Delete To delete media from your media library, select the media object, right-click and 
select Delete Media. If this media is referenced by a clip on the timeline, ScreenFlow 
displays a dialog alerting you that the clip or clips will be deleted as well. 

Rename To rename media files in the library, highlight the media, then click on the 
name to edit it. This renames all clips on the timeline that reference this media, unless 
they have already been given a custom name (double-click the clip on the timeline to 
provide a custom name—this does not rename the referenced clip in the media 
library).

Using the Media Library Controls
To display the media library (Figure 63), click the media library tab in the Properties 
pane.

Figure 63.  Media Library pane.

Search field.

Add Media button

Source buttons

Zoom Slider

Click to display media library.

Gear button

Display Type buttons.
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Use the buttons and other controls on the media library panel to perform the following 
tasks, as described in Table 12.

You can also view the Media library on the left side of the ScreenFlow main window by 
clicking the button on the Media Library button next to the Canvas Cropping button.

Table 12. Media Library Controls

Control Description

Add Media button Click to browse local drives or network servers for media to 
import into your project. This may include video files, audio 
files, and still images.

Display Type Buttons Click these buttons to select between thumbnail and list view.

Source Buttons Click these buttons to select between Media Files, iTunes, and 
Global Library. Media added to the Global Library can be used 
by any ScreenFlow document.

Search To search for a file, enter a search text and press the Enter key.

Gear Button Click the Gear button to select either Remove All Unused 
Media or Show Duration Overlays. Show Duration Overlays 
displays the duration value on the media icon image.

Zoom Slider Use the slider to change the display size of the media 
thumbnails.

Media 
Library 
Pane

Canvas Cropping button

Show Media Library button
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Adding Media to the Timeline
To add media to your timeline once it’s in the media library, either drag it to the canvas 
or the timeline which will place it wherever the scrubber is on the timeline. You can also 
double click on the media object to add to the timeline at the scrubber location. You 
can select one or more clips using lasso selection—click and drag across some portion 
of each clip to select it.

For complete details on these and other ways to add media to your project, see Adding 
Media to Your Project.

Using the Media Library Context Menu
Control-click (right-click) on a media file in the media library to display the context 
menu 

You can perform the following tasks, as described in Table 13.

Global Library
Many ScreenFlow users create documents on a regular basis, using the same assets in 
those documents repeatedly. Global Library enables you to store media multiple times 
in a projects.

Table 13. Media Library’s Media Menu

Menu Item Description

Add to Timeline at 
Scrubber

Select to add your media to the timeline at the current 
scrubber position.

Select Clips in 
Timeline

Select to select the clip or clips to show where this clip is 
being used on the timeline.

Delete Media Select to remove the media from your project. If the media 
has been placed on the timeline, it is removed following a 
confirmation prompt. Media files that are recorded outside of 
ScreenFlow (files that are not .scc files) are not deleted.
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The global library is selected by clicking globe icon button. To add content, you can 
drag & drop media files into the global library panel, or click the plus (+) button and 
navigate to a file and select it.

Media in the global library can then be dragged into ScreenFlow documents and used 
like regular content. Once content has been dragged into a global library in one 
inspector panel, it will appear in the global library of all open documents, and any 
documents that are subsequently opened.

Content within the global library is stored in the ~/Library/Application Support/
ScreenFlow/GlobalLibrary folder. When importing to the library, ScreenFlow will attempt 
to create a ‘hard-link’ from the original content to the Global Library folder. This is 
because a hard-link will not consume additional space on the hard drive. 

To delete an item from the global library, right-click on the file icon to delete and select 
Delete Media. You can also select the file icon and press the delete key.

When you attempt to delete a media file, a warning you that other ScreenFlow 
documents that may be referencing the content of the file you want to delete. You are 
also given the option to continue or cancel the delete action.

 

Click the globe 
icon button

Click the plus 
button

Right-click and 
select Delete

Click Continue or Cancel
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When deleting the item, the file in the Global Library folder will also be removed.

Stock Media Library
The Stock Media Library is directly integrated into ScreenFlow’s existing Media Catalog. 
It enables you access a large collection of stock audio, video, and graphics files that can 
be downloaded and used in your ScreenFlow projects. The directory that stores the 
downloaded Stock Media files is located at:  ~/Movies/ScreenFlow Data.

To access the Stock Media Library, you must first purchase it. To do this, select File > New 
to open the Welcome window, then click the Stock Media Library tab.   Click Buy to 
purchase the Stock Media Library. 

 

To access the Stock Media Library, click the Media Library tab on the inspection panel, 
click the Stock Media button, then select the Stock Media you want to use. You can also 

Click Buy

Click Stock Media Library
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perform queries by using the existing Search field at the bottom of the Media Catalog 
window. The Stock Media Library will populate with content as you enter your query. 

 

Right-click on any Stock Media icon to access its menu.  You can add the media to the 
timeline at the scrubber position, add the media to the Global Library, or download 
different format versions of the media.  For video: HDMP4, 4KMOV, HDMOV, and 
4KMP4.  For audio: WAV and MP3.  For images: PNG and JPG.

 

Click Media 
Library tab

Click Stock 
Media button

Select a Stock 
Media item

Search box
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You can also preview any clip by scrubbing or playing the clip. To preview by scrubbing, 
select a clip then move the scrubbing slider to view the video. To play the video clip, 
select it then click the play icon.

 

Click the Filter button to display the Filter window.

 

When the filter window displays, click a filter to open its menu and select a type.  The 
list will respond by displaying all clips matching the selected type.  You can also search 

Click video clip to select it

Move scrubber slider to preview video

Click Play icon to preview video in main window

Click Filter button
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for any text in the clip names by entering a text string in the search window.  The 
display of clips changes as you type.

 

To view the metadata of a video clip, click the Metadata tab and select a clip.

 

Click a filter to open it

Select a filter type

Enter a search string

Click the 
Metadata tab Select a clip
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When you add an item from the Stock Media Library to your ScreenFlow project, a 
temporary clip will be added to the timeline until the actual item has been 
downloaded. If the item is an image or a video, the temporary clip will be populated 
with the thumbnail of that item. In the case of dragging from the Media Catalog, the 
download will not start until the user releases the item onto either the timeline or the 
canvas. A spinner will be added to the clip to show the download progress. Once the 
download is complete, the clip’s temporary source will be replaced by the newly 
downloaded source. If the clip is deleted before the download has been finished, the 
download will be canceled. Items in the Stock Media Library can be added to the Global 
Library by right clicking on the item and selecting Add to Global Library. 

Even if you have not paid for a subscription to the Stock Media Library, you will still be 
able to query, filter, and preview all of the available content, but you will not be able to 
add any of it to your ScreenFlow project.
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Publishing Your
ScreenFlow Project

When you’re done editing your screencast or other project, the final task is to convert it 
to a standard video format (encode it) for publication and distribution. Before 
generating your project for playback in a specific program, check the program 
specifications to see which formats it supports.

ScreenFlow provides two methods of converting projects to video. You can export a 
standard video file, then distribute or publish it yourself. You can also publish your 
video directly to an online video service such as Vimeo, YouTube, Google Drive, 
Dropbox, Facebook, Wistia, Box, or Imgur  — converting the project to the appropriate 
video format as part of the publication process.

 Exporting Your Video

 Publishing to Vimeo

 Publishing to YouTube

 Publishing to Google Drive

 Publishing to Dropbox

 Publishing to Facebook

 Publishing to Wistia

 Publishing to Box

 Publishing to Imgur

 Upload Manager Interface

 Batch Export
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Exporting Your Video
Select File > Export to produce a video file, using a preset codec you select.

Note: If you have in and out points set in your project, the menu item displays Export 
Selected Range and the exported media is the media between the in and out points.

 Using the Export Window

 Customizing Codec Settings

 Managing your Export Presets

 Configuring Other Options

 Video File Size Considerations

Using the Export Window

Note: ScreenFlow's export options have changed. QuickTime has been deprecated by 
Apple in favor of AVFoundation. This means any export options utilizing the 
QuickTime APIs have been removed. We will continue to expand our export options to 
best serve the needs of the ScreenFlow user community.

To export your video, select File>Export to open the Export Settings window. Configure 
your export options (defined below) and click Export to begin encoding the project into 
a video file. ScreenFlow displays a progress dialog so you can monitor its progress.

When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

Note: An alert will be displayed if you try to select a drive formatted with MS-DOS FAT 
16 or FAT 32.
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Figure 64. Export Settings Windows (Automatic and Manual)

The export settings are described in Table 14.
Table 14. Video Export Options

Control Description

Save As Enter the name of your screencast. The default name is the 
name of your project file. The file extension is applied 
automatically based on your choice of preset.

Where Navigate and select the location of your exported video file.

NOTE: If you purchased ScreenFlow from the Mac App Store, the 
Where popup menu does not display. Instead, ScreenFlow 
displays the File Save dialog after you click Export, so you can 
navigate and select your folder for the exported file.

Type (Automatic)

Encoding Quality Select: Fastest, Normal, or Slowest

Type (Manual)

Preset Export presets are designed for both general and specific use, 
based on the most common applications. 

Select a preset from the popup menu:

Web-High Default export option, which encodes video in H.264 format 
using the x264 codec, with AAC audio, balancing the 
demands of image quality and file size, producing an MP4 file.

Manual Settings
Automatic Settings
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Web-Low Encodes video in H.264 using the x264 codec, with AAC 
audio, for low bandwidth, producing an MP4 file. It plays 
more smoothly on slow Internet connections but with 
reduced image quality when compared to Web-High.

HEVC Encodes video in H.265 using HEVC codec with AAC audio.

NOTE:  Before using the HEVC export option, please be 
advised that this is not a widely supported codec. There are 
still many programs and services that will not accept files 
encoded with the HEVC / H.265 codec. If you are using this 
export option, you may want to check with whatever service 
or program you wish to upload to before doing so, as 
Telestream does not govern 3rd party policies and 
specifications.

Lossless - ProRes 
with Alpha

Encodes a lossless file in ProRes 4444, including a clear alpha 
channel and stereo audio. Suitable for usage in applications 
such as Motion and After Effects.

To view transparent portions of the canvas, select View > 
Show Checkerboard.

ProRes 422 Encodes ProRes 422. Click Customize to select profile: 4444, 
422HQ, 422, or 422LT.

Lossless - Audio 
Only

Encodes an uncompressed audio-only AIFF format ideal for 
additional editing.

iOS App Preview Exports according to Apple’s guidelines for App Store 
previews (30 fps ProRes 422 with stereo AAC 48khz).

iPad / iPhone / 
Apple TV / iPod

These export options are configured based on the 
recommended video specifications for these devices. They 
cannot be altered.

Animated GIF Exports as an animated GIF or PNG. 
     (See  Animated GIF & PNG Preset)

Gear icon

Make Current 
Settings Default

Select to make the current settings become the “default” 
settings that are used when a new document is created.

Reset to Factory 
Defaults

Select to return the default settings to the original factory 
settings.  Any current default settings (set by Make Current 
Setting Default above) are cleared.

Table 14. Video Export Options

Control Description
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Note: If you are using an unlicensed version of ScreenFlow and you attempt to export 
your video, a window displays informing you that your exported video will be 
watermarked.

Animated GIF & PNG Preset
When you select Animated GIF or Animated PNG as your Preset, you can further 
customize the settings by clicking the Customize button under the Preset drop-down 
menu.

Customize Click to make changes to your video and audio encoding 
settings. Some presets cannot be customized. See 
Customizing Codec Settings. 
If iOS App Preview is the selected Preset, clicking Customize 
lets you set the Framerate and the ProRes profile to 4444, 
422LT, or 422 HQ. It also lets you select a Stereo or Mono 
channel

Manage Click to modify the preset encoding settings. See Managing 
your Export Presets.

Resolution Select a resolution, or select Custom which opens Width and 
Height fields to enter custom resolution values.

Letterbox Content Check to display letterbox content (text display of audio 
content).

Options Use these controls to specify motion blur, add chapter tracks, 
add captions, and burn in captions, depending on your 
encoding options. See Configuring Other Options.

Table 14. Video Export Options

Control Description

Select Animated GIF or PNG

Click Customize
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When the Settings window displays, select Framerate, Colors, Loop, Dither, and 
Strength, then click OK.

Framerate Higher frame rates produce larger files. For most GIF files, 15 fps is standard.

Colors 256 is the optimum setting for GIF files. If your animation contains less than 256 
colors, use lower settings.

Loop Check to cause the output file to continuously play in a loop.

Dither Check to turn on dithering in GIF images. This helps reduce banding in 
gradients of color, but it also increases the file size. The Error Diffusion setting produces 
smaller files while maintaining the quality to the Ordered option.

Strength Select the amount of dithering: Light, Medium, or Heavy.

Customizing Codec Settings
After selecting the Web-High, Web-Low, Lossless - ProRes with Alpha, or iOS App 
Preview preset, click the Customize button to modify these codec settings.

H.264/AAC (MPEG-4) Customization
When you customize Web-High and Web-Low presets, ScreenFlow displays the H.264/
AAC compression settings dialog (Figure 65).
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Figure 65. H.264/AAC Settings Window

Set these options, as described below in Table 15. When you’re done, click OK.
Table 15. H.264/AAC (MPEG-4) Settings

Option Description

H.264 Video Uncheck when you do not want your exported file to contain 
video tracks.

Frame rate Enter the frame rate in frames per second, or select preset 
values from the popup menu.

Data rate Enter the data rate in kbits per second.

NOTE: The data rate you enter is a target value. Therefore, the 
actual data rate may be higher or lower than entered.

Profile Select the codec profile (which establishes parameter ranges 
for a given application) from the popup menu:

Automatic The codec determines which profile to use, based on the size 
of the input video.

Main This profile results in longer encoding; it was designed 
primarily for SD digital TV broadcasts. It is well-suited for 
playback on desktop computers.

Baseline This profile is used for faster, simpler encoding, and improved 
data loss robustness, particularly for playback in mobile 
applications.



Publishing Your ScreenFlow Project
Exporting Your Video

172

High The High Profile is used as the preferred choice for HD 
broadcast and disc storage applications.

Codec Select:  Single-pass, Multi-pass, or Hardware Accelerated

Keyframe Rate Select automatic or fixed keyframe rate

Automatic ScreenFlow selects the optimum rate

Fixed every Manually enter the frame rate

AAC Audio Uncheck when you do not want your exported file to contain 
audio tracks.

Sample Rate Select to signify the number of samples taken from the source 
per second (in kHz) and added to the audio track being 
generated.
Select the sample rate from the popup menu. Web-High and 
Web-Low, defaults to CD quality (44.1 kHz). 

Data rate Enter the data rate in kbits per second. Web-High, defaults to 
256kbits/sec. Web-Low, defaults to 96kbits/sec.

Channels Select Mono or Stereo

Table 15. H.264/AAC (MPEG-4) Settings

Option Description
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Managing your Export Presets
Click the Manage button on the Export window to display the Manage Presets windows 
where you create and configure custom export presets. 

ScreenFlow displays the window shown in Figure 66.

Figure 66. Manage Presets Window (Custom Presets Vary)

Check the check box to the left of the preset to show it in the Preset list. Uncheck it to 
hide it.

Click the Copy button to the right of the preset to generate a copy of the preset so that 
you can modify it.

Custom presets are displayed in the list at the bottom of the window. To change the 
custom preset name, double-click the name. Click the Edit button to customize your 
preset. See Customizing Codec Settings for details.
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To create a new Custom Preset, select an existing preset in the list, then click the Plus (+) 
button.

Once the new Preset has been created, it can be edited by clicking the Edit button, or 
deleted by selecting it and clicking the Minus (-) button.

Select a preset

Click Plus button and 
select Copy Preset

Click Minus button

Click Edit button
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Configuring Other Options
Use these options (Figure 67) to specify motion blur, add a chapter track, add captions, 
and caption burn in, depending on the video format you are creating.

Figure 67. Export Settings Export Options

These settings are described in Table 16. 

Note: *QuickTime X and VLC require a chapter marker on the first frame of your 
project or it will move the chapter markers from their intended locations. Be sure to 
set a chapter marker at the very beginning of your project to prevent this.

Table 16. Dimensions Settings

Control Description

Use Motion Blur Check to apply a blurring algorithm to blend movement 
smoothly into the video. This is useful if you are using video 
properties effects to move clips on the canvas. This option 
increases encoding time so it should only be used if objects 
are not moving smoothly in your exported video.

Add Chapter Track 
from Markers*

When encoding with some codecs, check to add chapter 
markers to your movie based on the location and names of 
the markers in your project. These markers provide quick 
navigation and require named markers to be present in the 
project.

Add Captions Track Check to include your caption track.

Burn In Captions When checked, imported captions are burned into the clip.
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Video File Size Considerations
Video files often become very large, making them difficult to send to others, download, 
or post to servers via the Internet.

The frame size of video clips in your project is typically much larger than the screen size 
of the video file you are exporting. For example, if your original screen size is 1280 x 800 
pixels, you probably do not want to create a video of the same frame size. This is 
essentially HD video, and is about four times larger than a 640 x 400 video.

Reducing Video File Size
To preserve the aspect ratio of your project, use the Scale by Dimensions option as 
opposed to Scale to a custom size. For general purposes, you may want to scale by 50%.

Reducing the Frame Rate
The NTSC video standard frame rate is 30 FPS. This is the standard for videos produced 
in North America. However, this standard is based on creating a smooth representation 
of video motion captured in the real world and may not be necessary for your project.

For example, if you specify 30 frames per second, the output will be smooth, but the file 
will be about twice as large as a 15 fps video file. You may find that a 10 fps or 15 fps 
encoding is very acceptable for your audience. Reducing the frame rate can drastically 
reduce the size of the video file.

You should experiment with codec settings to get a sense for what size and frame rate 
works best for you. 
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Publishing to Vimeo
If you have a Vimeo account, ScreenFlow enables you to encode and publish your 
projects directly to Vimeo. Select File > Publish to > Vimeo then select Video Encoding, 
Framerate, and Options.

If you check Save Copy to Disk the Location button is enabled, enabling you to select the 
location for the file to be written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, .mp4 will be used.

Click Sign In when finished.

When the Log In window displays, enter your email and password then click Log In. 

Select Video Encoding

Select Framerate

Click Sign In

Select Options

Check Save Copy to Disk
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When the Publish To Vimeo window displays, enter a Title and Description. The Tags are 
not required to activate the Publish button. The Privacy settings can be adjusted to 
restrict who can view the content. The Account Default Privacy setting uses the defaults 
set up through the Vimeo Web interface. Click Publish when finished. The URL for 
uploads will be returned when the upload has completed. 

When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

.
Table 17. Vimeo Settings

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When Vimeo users 
search for these words, your video is included in the search 
results.

Privacy Select the level of privacy required. Account Default uses the 
defaults set up through the Vimeo Web interface.

Enter Title, 
Description 
and Tags

Click Publish

Set Privacy level
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After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Vimeo account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Table 17. Vimeo Settings

Control Description
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Publishing to YouTube
Note: For Recommended Upload Encoding Settings on YouTube, visit YouTube 
website at: http://www.telestream.net/screenflow/youtube-settings.htm

If you have a YouTube account, ScreenFlow enables you to encode and publish your 
projects directly to YouTube. Select File > Publish to > YouTube, select Video Encoding 
and Options. 

If you check Save Copy to Disk the Location button is enabled, enabling you to select the 
location for the file to be written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, .mp4 will be used.

Click Next when finished.

Figure 68. YouTube Account Login Window

Select Video Encoding

Select Options

Click Sign In

Select Framerate

Check Save Copy to Disk

https://support.google.com/youtube/answer/1722171?hl=en
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In the Google Sign In window, enter your email and password, then click Sign In.

Figure 69. YouTube Account Login Window

When you sign in, Google displays the ScreenFlow Verification dialog. Click Accept to 
complete log in.

Figure 70. ScreenFlow Verification Dialog

Enter email and password

Click Sign In

Click 
Accept
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When the Publish To YouTube window displays, select a Category, and enter a Title and 
Description. The Title is a required field and will manifest itself as the primary filename. 
Enter your tags. The Tags are required to activate the Publish button.  Optionally, check 
the Thumbnail checkbox and click the “Select...” button to display the clip with a 
scrubber.  Move the scrubber to find the image you want for a thumbnail, then click 
“Select...” again.  Enter a Publish Time, select a Privacy level (to restrict who can view the 
content), then click Publish when finished. The URL for uploads will be returned when 
the upload has completed. 

When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

Enter Title, 
Description 
and Tags

Set Publish Time

Check Thumbnail

Select a Category

Set Privacy level
Click Publish

Click Select

Move scrubber
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After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

Table 18. YouTube Publishing Details

Control Description

Category Select the category of your project from the options in the 
popup menu.

Title Enter the title for your project, up to 60 characters. By default, 
this field uses the base name of your project file.

Description Enter a description for your project.

Tags Enter keywords to describe your project. When YouTube users 
search for these words, your video is included in the search 
results.

Privacy Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only YouTube users that you authorize can view this 
video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your YouTube account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.
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Publishing to Google Drive
Google Drive is a generic file storage system that allows you to place uploaded files into 
a specific folder. Additional folders can be created under the Folder pop up menu.

If you have a Google account, ScreenFlow enables you to encode and publish your 
projects directly to Google Drive. Select File > Publish to > Google Drive then select a 
Preset. Optionally, you can customize or manage your preset by clicking Customize or 
Manage. Set Dimensions and select Options as needed. 

If you check Save Copy to Disk the Location button is enabled so you can select the 
location where the file is written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, the extension used 
will be set based on the selected export preset.

Click Next when finished.

Click Sign In

Select Preset

Optionally click Customize 
or Manage

Select Options

Set Dimensions

Check Save Copy to Disk
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When the Google Sign In window displays, enter your email and password, then click 
Sign In.

Figure 71. Google Account Login Window

Enter email and password

Click Sigh In
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When you sign in, Google displays the ScreenFlow Verification dialog. Click Accept to 
complete log in.

Figure 72. ScreenFlow Verification Dialog

When the Publish To Google Drive window displays, select a folder in the list or click 
Create New Folder to create a new folder in your Google Drive account. (My Drive is the 
root folder, consistent with how Google Drive behaves through their Web interface.) 
Enter a Title and Description. The Title is a required field and will manifest itself as the 
primary filename. The star icon (to the right of Title) allows you to mark the upload as a 
favorite. This follows the way Google Drive Web interface behaves. Select also a Sharing 
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level to restrict who can view the content. The URL for uploads will be returned when 
the upload has completed. Click Publish when finished.

When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

.
Table 19. Google Drive Publishing Details

Control Description

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Sharing Check Public | Unlisted | Private:

Public: Anyone can view this video

Unlisted: Only people with a link can view this video

Private: Only Google Drive users that you authorize can view 
this video

Enter Title and 
Description

Click Publish

Set Privacy level

Select a Folder

Click star to mark as 
favorite (optional)
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After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Google account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.

Table 19. Google Drive Publishing Details

Control Description
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Publishing to Dropbox
Dropbox is similar to a virtually hosted file system and therefore has a simple set of 
publishing options. 

If you have a Dropbox account, ScreenFlow enables you to encode and publish your 
projects directly to Dropbox. Select File > Publish to > Dropbox then select a Preset. 
Optionally, you can customize or manage your preset by clicking Customize or Manage. 
Set Dimensions and select Options as needed. 

If you check Save Copy to Disk the Location button is enabled so you can select the 
location where the file is written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, the extension used 
will be set based on the selected export preset.

Click Sign In when finished.

After the Dropbox Authorization window displays, click Continue.

Figure 73. Dropbox Authorization Dialog

Click Sign In

Select Preset

Optionally click Customize 
or Manage

Select Options

Set Dimensions

Check Save Copy to Disk
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When the Sign In window displays, enter your email and password, then click Sign In.

Figure 74. ScreenFlow Sign In Dialog

Note: Once you are finished working with your Dropbox account, it is recommended 
that you log out of the service through your Web browser.

When you have successfully signed in, the window will display a message asking you to 
allow ScreenFlow access to Dropbox. If you have not selected or created a folder for 
ScreenFlow in your Dropbox account, you will be asked to do so.

Figure 75. ScreenFlow Allow Dialog

Enter email and password

Click Sign In
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After allowing ScreenFlow access to Dropbox, a code will display on the web browser 
used to sign in. 

Figure 76. ScreenFlow Allow Dialog

Copy and paste this code into the text field shown in the ScreenFlow authorize 
message. After pasting the code into the ScreenFlow text field, click Continue to finish 
the sign in process.

Figure 77. ScreenFlow Allow Dialog

When the Publish To Dropbox window displays, select a filename (required) and set 
privacy level. Click Publish when finished. The URL for uploads will be returned when 
the upload has completed. 
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When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

Figure 78. Dropbox Account Login Window

The Dropbox upload places all the files into a ScreenFlow folder inside the Apps folder at 
the root of the user’s Dropbox. This cannot be changed because it is the only way for 
third-party applications to upload to Dropbox directly.

.

After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

Table 20. Dropbox Publishing Details

Control Description

Filename Enter a filename to use for your publication. 
NOTE: The Apps folder at the root of the user’s Dropbox 
cannot be changed because it is the only way for third-party 
applications to upload to Dropbox directly.

Privacy Public: Anyone can view this video

Private: Only users that you authorize can view this video

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Dropbox account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.
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Publishing to Facebook
The Facebook upload will post your exported video (with an optional title and 
description) directly to your Facebook home page or any Page or Group you have 
access to. The publishing service will cause Facebook to populate the Post To field with 
all of your accessible information. If there is no title or description added, the video will 
be posted without accompanying text. There are privacy options available, but only 
when posting directly to your Facebook home page. These options are not relevant 
when posting to a Page or Group (since these are public). The URL for the upload will be 
returned once the publish/upload process has completed. 

Note: Facebook limits uploads to a max of 1 GB or 20 minutes. Trying to upload files 
bigger or longer than this will most likely fail.

If you have a Facebook account, ScreenFlow enables you to encode and publish your 
projects directly to Facebook. Select File > Publish to > Facebook to display the Facebook 
Sign In window. Select Video Encoding, Framerate, and Options.

If you check Save Copy to Disk the Location button is enabled so you can select the 
location where the file is written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, .mp4 will be used.

Click Sign In when finished.

Select Video Encoding

Select Options

Click Sign In

Select Framerate

Check Save Copy to Disk



Publishing Your ScreenFlow Project
Publishing to Facebook

194

When the Facebook window displays, enter your email (or phone number) and 
password, then click Log In.

When the Publish To Facebook window displays, enter a Title and Description, then set 
the Privacy level. Click Publish when finished. The URL for uploads will be returned 
when the upload has completed.

Figure 79. Facebook Account Login Window

Enter Title and 
Description

Click Publish

Set Privacy level

Select Post To
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When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

  

After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

Table 21. Facebook Publishing Details

Control Description

Post To Select the category of your project from the options in the 
popup menu.

Title Enter the title for your project. By default, this field uses the 
base name of your project file.

Description Enter a description for your project.

Privacy Public: Anyone can view this video

Friends Only: Only people with a link can view this video

Me Only: Only you can view this video 

“?” button Click to get publishing help

Sign Out Click Sign Out to sign out of your Facebook account.

Publish Click Publish to export and upload your project. ScreenFlow 
displays a progress bar to indicate encoding progress. Click 
Cancel at any time to abort the encode/upload process.



Publishing Your ScreenFlow Project
Publishing to Wistia

196

Publishing to Wistia
If you have a Wistia account, ScreenFlow enables you to encode and publish your 
projects directly to Wistia. Select File > Publish to > Wistia to display the Wistia Sign In 
window. Select Video Encoding, Framerate, and Options.

If you check Save Copy to Disk the Location button is enabled so you can select the 
location where the file is written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, .mp4 will be used.

Click Sign In when finished.

When signing in, you are prompted to enter your Wistia credentials through the built-in 
Web browser. Please be aware that this Web page is controlled by Wistia and 
ScreenFlow has limited control over the functionality.

After signing in, you are prompted to enter meta-data about your publication. Select a 
project and enter a name (required) and description (optional), then click Publish.

Select Video Encoding

Select Options

Click Sign In

Select Framerate

Check Save Copy to Disk

Select a Project

Enter a name and 
description

Click Publish
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When exporting a ScreenFlow project, the application icon will display an export 
progress overlay. This will allow you to minimize the application while exporting and 
still have an idea of the amount of time before the export completes.

Note: All uploads through Wistia must be associated with a project. There is an 
option to create a New Untitled Project during the upload. 

After you have clicked publish, the video will begin exporting and uploading to Wistia. 
This can be viewed using the upload manager in the main document user interface. 
(See Upload Manager Interface.) Once the upload has completed, you will be returned a 
link where you can view the uploaded video on Wistia.
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Publishing to Box
If you have a Box account, ScreenFlow enables you to encode and publish your projects 
directly to Box. Select File > Publish to > Box then select Video Encoding, Framerate, and 
Options.

If you check Save Copy to Disk the Location button is enabled, enabling you to select the 
location for the file to be written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, .mp4 will be used.

Click Sign In when finished.

When the Log In window displays, enter your email and password then click Authorize. 

Select Video Encoding

Select Options

Click Sign In

Select Framerate

Check Save Copy to Disk

Enter email and 
password

Click Sign In



Publishing Your ScreenFlow Project
Publishing to Box

199

When the next window displays, click Grant access to Box.

When the Box settings window displays, select a folder, enter a title (required) and a 
description (optional), select scope of sharing and a password (optional), then click 
Publish.

After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

Click to grant access

Select a folder

Enter a description 
(optional)

Click Publish

Enter a title

Select sharing and 
create a password
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Publishing to Imgur
If you have a Imgur account, ScreenFlow enables you to encode and publish your 
projects directly to Imgur. Select File > Publish to > Imgur then select a Preset. 
Optionally, you can customize your preset by clicking Customize and configure settings 
as needed when the control settings window displays. 

If you check Save Copy to Disk the Location button is enabled so you can select the 
location where the file is written to disk. If you do not choose a location, the file will be 
saved to your Movies folder. If you do not specify a file extension, the extension used 
will be set based on the selected export preset.

Click Sign In when finished.

Click Sign In

Select Preset

Optionally click Customize 
or Manage

Select Options

Set Dimensions

Check Save Copy to Disk
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When the Log In window displays, enter your email and password then click Allow. 

When the Imgur settings window displays, enter a title and description, then click 
Publish.

After you click Publish, go to Upload Manager Interface to continue the publishing 
process.

Enter email and 
password

Click Allow

Enter a description 
(optional)

Click Publish

Enter a title
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Upload Manager Interface
Once the publishing settings have been selected and the Publish button is clicked, the 
exporting begins. 

When the export has completed, the upload will occur in the background through the 
Upload Manager. The Upload Manager button displays in the main document window 
and displays progress via its blue progress bar.

Click the Upload Manager button to display details of the upload. (ScreenFlow supports 
multiple concurrent uploads.)

When the upload finishes, you can click the arrow icon to open the URL in a browser. 
Click Clear to close the Upload Manager and clear out completed uploads from the list. 
If there are no remaining uploads in progress, the Upload Manager button is hidden 
until a new upload occurs. (This is similar to how the Safari download manager works.)

Upload Manager button

Click the Upload 
Manager button

Click ClearClick Arrow to view upload
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If an error occurs when uploading, it is displayed in the Upload Manager window. Click 
the yellow warning triangle to display more information about the error.

Batch Export
ScreenFlow Batch Export exports a large number of ScreenFlow documents, re-
encoding each document into a different formats as needed. This eliminates the 
manual process of opening one document after the other and exporting each one. 

To use the Batch Export feature select File > Batch Export. This opens the batch export 
window.

Documents can be added to the batch either by clicking the plus (+) button located in 
the bottom left corner of the window, or by dragging and dropping documents into 
the Documents pane. The documents list displays an icon, the document name, and 
the duration of the document. 

Once all the documents have been loaded in, choose an output folder as the export 
destination. Select a preset from the Preset menu, then customize the preset 
(optionally) by clicking Customize. Click Manage to manage the arrangement of the list 
of presets. Select also any desired options by checking their boxes.

Error message

Click Yellow triangle

Click to add a document

Documents 
pane
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Once you have created a batch list of documents and have made all the necessary 
settings, click Begin. The documents are re-encoded according to the settings chosen 
and send a single folder in the Output Folder location. The default folder is the user’s 
Movies directory. 

The export settings are the same options you’ll find in the non-batched Export dialog 
window. However, It is not possible to set export settings on an individual document 
level. The settings will be applied across the entire batch. Once the batch has been 
started, the options will dim and progress bars display next to the documents as they 
start exporting. There is also a progress bar at the bottom right of window showing the 
progress of all the documents in the batch. 

When the batch is running, you can click the Cancel button to stop the batch. The user 
will be warned that they are about to stop the batch.

Note: When Close windows when quitting an application (in the Mac System General 
Preferences) is checked, if ScreenFlow quits with the Batch Export window open, when 
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the application reopens, the documents will be reloaded. If the batch export window 
is closed, the batch will not be recalled.

Close Windows check 
box in the Mac General 
System Preferences



Publishing Your ScreenFlow Project
Batch Export

206



Setting Preferences 207

Setting Preferences

You use ScreenFlow Preferences to set your options and customize ScreenFlow to suit 
your specific needs. To display Preferences, select ScreenFlow > Preferences or press 
Command-comma.

Note: If you purchased ScreenFlow through the Mac App Store, the License tab does 
not display. The Mac App Store has its own licensing and updating processes.

 General Pane

 Timeline Pane

 Shortcuts Pane

 Proxy Pane

 Licenses (Telestream Web Store Only)
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General Pane
The General pane provides startup, display, recording, and auto-update options.

Figure 80. Preferences General Pane

These controls are described in Table 22.
Table 22. Preferences General Pane Options

Control Description

Interface Theme Select Light or Dark. This affects how menus are displayed. 
See Light/Dark Theme Comparison below.

Settings Check the features to be enabled when using ScreenFlow:

   Show ScreenFlow Check to toggle the ScreenFlow Helper menu on and off in 
the status menu.

   Countdown Check to use the Countdown window, and set the countdown 
time (in seconds). Range: 0 - 10. Default: 5.

   Send Diagnostic Sends anonymous usage data to Telestream.

Default Background 
Color

Click to set the default color for the canvas background. This 
specifies the color for newly created documents.  It does not 
affect existing documents.

Canvas Locks Aspect Ratio when scaling with a mouse.

Startup Check to launch ScreenFlow Helper when you log in so that 
you can record without first launching ScreenFlow.

These features 
do not display 
if ScreenFlow 
was  purchased 
from the Mac 
App Store
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Figure 81. Light/Dark Theme Comparison

Auto Update Check to automatically check for updates each time you start 
ScreenFlow, so you can update ScreenFlow immediately. 

Note: This option is not available if you purchased 
ScreenFlow from the Mac App Store. The App Store has its 
own update procedure.

Recording Hotkey Click the button to change the recording hotkey command 
(default: Shift-Command-2); then press the key combination 
you want to use.

Note: Be sure to choose a hotkey which is not used by the 
application you are recording.

Pause Hotkey Click the button to set or change the pause hotkey command; 
then press the key combination you want to use.

Note: Be sure to choose a hotkey which is not used by the 
application you are recording.

Add Marker Hotkey Click the button to change the add marker hotkey command; 
then press the key combination you want to use. 

Note: Be sure to choose a hotkey which is not used by the 
application you are recording.

Table 22. Preferences General Pane Options

Control Description

Light Theme Dark Theme
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Note: When ScreenFlow is used in High Sierra OS, the Interface Theme menu in 
Preferences will offer Dark and Light Modes. When ScreenFlow is in Mojave OS (and in 
newer OS's beyond Mojave), ScreenFlow will follow the Mac OS settings for Light or 
Dark Mode.

Timeline Pane
Use the Timeline pane to set timeline preferences.

Figure 82. Preferences Timeline Pane
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These controls are described in Table 23.
Table 23. Preferences Timeline Pane Options

Control Description

Editing When checked, the scrubber will be repositioned after a paste 
action.

Display

   Use SMPTE timecode Check to display the scale as SMPTE timecode 
(HH:MM:SS:FF—Hours:Minutes:Seconds:Frames). 
If unchecked, the scale displays the scale informally. For 
example: 1h2m30s.

   Hide Action Menu Check to hide the action gear menu in clips.

Double-click in Media 
Catalog

Choose between sending a clip to the clip editor (when 
double clicking), or sending it directly to the timeline.

Thumbnail Cache Enter size of the thumbnail cache (in megabytes).  A value of 
zero means unlimited cache sizing.  Once you have updated 
the maximum cache size, the cache is checked for cleanup.  

While thumbnails are being generated, the cache is 
automatically cleaned up every three minutes, to ensure it 
does not run out of control.  When thumbnail icons are 
removed due to the size of the cache, the oldest are deleted 
first. 

The thumbnails are stored at::

   ~/Library/Caches/net.telestream.screenflow9/Thumbnails

Default Transition Select the default effect to use when generating a transition. 
Default: Bars Swipe.

Default Track Height Select the default track height of timeline tracks: small, 
Regular, or Large. If your project has many tracks, you can set 
this to Small to view more tracks in your window without 
scrolling. Default: Regular.

Default Action Curve Select the default Action Curve: Linear, Ease In or Out, 
Exponential Ease In or Out, or None.

Default Durations Select the duration field of the item you want to change. 
These are default time values for actions, transitions, still 
images, callouts, and annotations. Enter the value (in 
seconds) of the default length of the item when added to the 
timeline. Range: one-tenth of a second (typically 3 frames) up 
to (but not including) 30 seconds.
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Shortcuts Pane
Use the Shortcuts pane to create custom keyboard shortcuts.

Figure 83. Preferences Shortcut Pane

These controls are described in Table 24.
Table 24. Preferences Shortcuts Pane Options

Control Description

Keyboard Shortcut 
Set

Select Configure, Import, or Export. Configure opens a 
configuration window.

   Default Select this option to activate the default keyboard shortcuts.

   <Custom Shortcut> Select from a list of user created custom shortcuts.

   Configure Select to open the configuration window (see Figure 84). 
Click the plus icon (+) to add a new custom shortcut set. Click 
the minus icon (-) to delete any selected set. 

   Import Select to import a saved (exported) shortcut set.

   Export Select to export (save) a shortcut set.

Show Select All or Customized. All displays all shortcuts sets, 
whereas Customized display only the set created by the user.

Search Enter a word to use for searching in the list of shortcuts. The 
list is reduced, as matches are found, while your type.
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Figure 84. Configuration window

To change a hotkey assignment, select a hotkey in the list and click “click to change”, 
then enter a new keystroke assignments for that hotkey. Modified shortcuts are 
updated immediately, in either the main menu, helper menu, or with the keyboard only 
functionality.

Note: When you modify a shortcut, if you enter a key combination that already has a 
shortcut associated with it, it results in a conflict and a warning triangle will appear 
next to each shortcut in conflict. The filter bar changes to include a Conflict Filter, 
allowing you to display only the conflicted shortcuts. You must resolve each conflict 
because the shortcut actually used is unpredictable.

Click the minus icon (-) to delete

Click the plus icon (+) to add

Select a hotkey, then 
click to change its value
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Proxy Pane
The Proxy pane (Figure 86) provides ScreenFlow settings for proxy media. Proxies are 
lower quality movie files that take the place of the originals during editing. When the 
final export is done, the originals will be used for the best quality. 

The proxy creation progress is shown within the Media Library (on the Timeline and on 
the Timecode UI). The proxy creation progress is represented by a pink progress bar 
that shows as a solid pink circle when the proxy is created.

Figure 85. Preferences Proxy Pane

These preferences are described in Table 26.
Table 25. Preferences Proxy Options

Preference Description

Proxy Creation Mode In Automatic mode, ScreenFlow will decide if the imported 
content would benefit from having a proxy created. 

In Always mode, when a media file that can have a proxy 
made is added to the Media Library or the Timeline, the proxy 
creation progress starts.

Options Check Limit size of proxy cache to, then enter the size in GBs.

Check Automatically delete proxy files after, then enter the 
number of days.

Check Create proxies at half original resolution (Optionally).

Proxy Cache Location Click Change to select a proxy cache location.
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Advanced Pane
The Advanced pane (Figure 86) provides ScreenFlow settings for video magnification, 
compression, and managing your audio driver and scratch disk.

Figure 86. Preferences Advanced Pane

These preferences are described in Table 26.
Table 26. Preferences Advanced Options

Preference Description

Default File Format Select the file format in which you want to save your 
ScreenFlow workflows. This default format will display in the 
File Format menu in the Save As dialog box. (See Figure 87)

Video Magnification Select Smooth | Sharp to set the compression algorithm used 
when computing a scale effect or zoomed callout. Smooth 
blurs color values to create a smoother transition. Sharp does 
not blur color values. Default: Smooth.
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Figure 87. Save As...  Dialog Window

Note: The Single File Document format saves your ScreenFlow workflow as a single file 
containing references to the media ScreenFlow uses.  This file format has a file 
extension of .screenflowf.

Licenses (Telestream Web Store Only)
The Licenses pane displays your serial number and allows you to manage your licenses. 

Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Screen Recording 
Compression

Select Adaptive | Lossless to specify the method of 
compression used. Adaptive is compressed, which minimizes 
file size, but the loss in video quality is not noticeable to most 
users. Lossless is uncompressed which captures all pixels, 
thereby resulting in a larger file size. Default: Adaptive.

Computer Audio Click to install or uninstall ScreenFlow’s computer audio 
driver, which is required for recording computer audio. 
Note: If you purchased ScreenFlow through the App Store, 
the computer audio driver is installed automatically.

Capture Scratch Disk Click Change to specify a directory where ScreenFlow can 
temporarily save media as it is being recorded. By default, this 
is set to a private system location: ~/Movies/ScreenFlow Data. 
Specifying a custom scratch disk allows you to locate your 
recording in the event that it was interrupted before 
completion.

Table 26. Preferences Advanced Options

Preference Description
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ScreenFlow must be licensed to fully enable the export capabilities. If ScreenFlow is not 
licensed, all exported files are watermarked.

License functions are locked, and require administrator access to prevent guests from 
removing your license. Click the lock at the bottom of the window to make changes, 
then click the lock again, when you’re done.

Licensing ScreenFlow
If ScreenFlow is not currently licensed, the Licenses pane displays the buttons as 
depicted in the figure below (Figure 88).

Figure 88. Preferences Licenses Pane (Unlicensed)

These preferences are described in Table 27.

Deactivating a Serial Number
When ScreenFlow is licensed, the Licenses pane enables you to deactivate serial 
numbers, as depicted in Figure 89.

Table 27. Preferences License Options

Button Description

Purchase License Click to purchase a ScreenFlow license from the Telestream 
Web site. The license is automatically installed upon 
completion of your purchase.

Activate Serial 
Number

Enter serial number and click Activate.
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Figure 89. Preferences Licenses Pane (Licensed)

Updating ScreenFlow
You can check for updates to ScreenFlow by selecting ScreenFlow > Check for Updates. 
When the Software Update screen displays, click Install Update.

Table 28. Preferences License Options

Button Description

Deactivate Serial 
Number

Click to deactivate your ScreenFlow license. This allows you to 
use your license on a different computer. Please allow up to 
15 minutes to process the deactivation before re-activating 
this serial number.

Click Install 
Update
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Using ScreenFlow
Menus

This chapter describes each of ScreenFlow’s menu commands.

 ScreenFlow Helper Menu

 ScreenFlow Menu

 File Menu

 Edit Menu

 Mark Menu

 Insert Menu

 Font Menu

 Actions Menu

 Arrange Menu

 View Menu

 Window Menu

 Purchase Menu (Telestream Web Store Only)

 Help Menu

ScreenFlow Helper Menu
The ScreenFlow Helper menu is identified by the camera icon  in the status menu.

Click camera icon
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.
Table 29. ScreenFlow Helper Menu Items

Menu Item Description

Record/Stop Record
(Shift-Command-2)

Begins recording using the selected sources (display, 
camera, microphone, and/or computer audio). The menu 
icon changes from  to , advising you that 
ScreenFlow is recording.

Select Stop Record or press Shift-Command-2 to stop 
recording. 

Pause/Resume Pauses recording. The menu icon changes to a blinking 
dot, advising you that ScreenFlow has been paused. 
Select Resume to continue recording.

To modify the hotkey for these commands, see General 
Pane. 

Add Marker Allows you to mark a key moment location while you are 
recording. 

Configure Recording Displays the Configuring Recording in the ScreenFlow 
Recording Window for setting recording parameters.

Show Recording Monitor Displays the ScreenFlow recording monitor

Hide Desktop Icons/Show 
Desktop Icons

Hides all icons on your desktop if you prefer a less 
cluttered background. Select Show Desktop to show them 
again. 

Quit ScreenFlow Closes the ScreenFlow and ScreenFlow Helper 
applications. 
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ScreenFlow Menu
This topic describes each item in the ScreenFlow menu, as described in Table 30.
Table 30. ScreenFlow Menu Items

Menu Item Description

About ScreenFlow Displays a dialog indicating the version of ScreenFlow you are 
running.

Check For Updates Note: This option is not available to users who purchased 
from the Mac App Store. The App Store has its own update 
procedure.

Checks Telestream’s Online Store to determine if there is a 
more recent version of ScreenFlow available. If so, you can 
download it. To check for ScreenFlow updates automatically, 
check the Check for Updates option in the General Pane.

Preferences
(Command-,)

Displays the Setting Preferences window so that you can view 
and change ScreenFlow preferences. If the Preferences 
window is already open, it is brought to the front.

Buy ScreenFlow Takes you to the on-line purchasing page at the Telestream 
website where you can purchase ScreenFlow or the Stock 
Media Library.

Services Displays Macintosh Services—none are implemented in 
ScreenFlow.

Hide ScreenFlow
(Command-H)

Hides all ScreenFlow windows.

Hide others
(Option-Command-H)

Hides all other application windows (every window which is 
not a ScreenFlow window).

Show All Shows all previously hidden windows.

Quit ScreenFlow
(Command-Q)

Closes all open documents and then quits.

If a document has not been saved, ScreenFlow displays a Save 
dialog, so you can save the document before quitting.

If Launch ScreenFlow Helper at user login is checked in the 
Preferences General Pane, ScreenFlow Helper stays running 
when you quit ScreenFlow.
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File Menu
This topic describes each menu item in the File menu, as described in Table 31.
Table 31. File Menu Items

Menu Item Description

New
(Command-N)

Displays the Configure Recording window (see Configuring 
Recording in the ScreenFlow Recording Window), which allows 
you to select recording options and record a new clip.

When complete, the clip can be added to a new (untitled) 
ScreenFlow document, or can be added to any existing 
document, or can be discarded entirely.

Open
(Command-O)

Displays the Open dialog, so you can navigate and open a 
ScreenFlow document that was saved earlier. 

Open Recent Click to select from up to 15 recently accessed documents. 

Every time you open or save a document, it is added to the 
list. Select Open Recent > Clear Menu to reset the list.

Add Additional 
Recording
(Shift-Command-R)

Displays the Add Additional Recording dialog. After recording 
is complete, displays the Recording Complete dialog so you 
can add the recording to a new document or to a currently-
open document.

Close
(Command-W)

Closes the active ScreenFlow document.

If the document has not been previously saved, ScreenFlow 
displays a Save As dialog, so that you can name the document 
and save it before closing it.

Close Tab
(Command-W)

Closes the active tab on the timeline.

Save Saves changes to your ScreenFlow document.

Save As Saves your ScreenFlow document with a new name and /or 
new location.  Optionally, select a File Format from the drop-
down menu.  You can set the default file format in the 
Advanced tab in Preferences.

Save As Template Saves your current document as a template. (See Templates).

Document Settings Opens the screen dimensions setting window.

Save Frame Select to save the video frame of the canvas (as rendered by 
the location of the scrubber) as a PNG or JPEG file.
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Document Settings
Typically the canvas size is fixed to the initial screen size when you begin capturing. 
Document Settings enables you to change the canvas size the document you have 
created.

To do this select File > Document Settings. 

When the canvas settings window displays, select a Preset, enter the Width and Height 
needed, and select a Timeline Framerate. Click Update to immediately resize the canvas 
to the new dimensions.

.

Publish to Displays the Publish dialog, enabling you to log in, encode 
your project (or the selected range, when in and out points 
are present) and publish your video.

Export Displays the Export dialog (see Exporting Your Video), so you 
can select your encoding options, encode your project (or the 
selected range, when in and out points are present) and 
export the file.

Batch Export Exports a large number of ScreenFlow documents, re-
encoding each document into a different formats as needed.

Table 31. File Menu Items

Menu Item Description

Select a preset

Click update

Enter width and height

Select Timeline Framerate
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These settings are very similar to the options offered when creating a new document.

Edit Menu
This topic describes each item in the Edit menu, as described in Table 32 through 
Table 37.

Note: Most of these commands are also on the gear  menu, directly on the clip. 

Table 32. Edit Menu Items

Menu Item Description

Undo
(Command-Z)

Reverses your last change.

ScreenFlow permits an unlimited number of undo/redo 
actions (limited only by memory constraints). However, undo 
information is stored on a per-window basis. If you close a 
window and then reopen it, its undo list is lost.

Redo
(Shift-Command-Z)

Reverses your last Undo action.

Cut
(Command-X)

Removes the selected object or objects, and place them on 
the clipboard.

Copy
(Command-C)

Copies the selected object or objects onto the clipboard.

Note: Clips in the media library cannot be copied, but they 
can be added to the timeline multiple times.

Paste
(Command-V)

Adds objects on the clipboard to your document.

Copied text is added to the text box at the cursor position. 
Inserted text adopts the text formatting of the character 
immediately preceding the insertion point.

If the scrubber is at the start of the timeline or anywhere on a 
clip, the clip is added one layer up, at the scrubber position.

If the scrubber is at the end of a clip, the pasted clip is added 
on the same layer.

Paste Properties Updates the properties of the selected clip on the timeline 
with the properties of the clip on the clipboard.
Paste Properties has these sub menu items:

Video
(Option-Command-I)

Pastes video properties into a video clip.

Audio
(Option-Command-A)

Pastes audio properties into an audio clip.
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Note: You can paste properties to multiple clips simultaneously; however, If you copy 
multiple clips with different properties and paste adjustments to another clip, which 
properties will be pasted is not predictable.

Figure 90. Mark In and out points on your timeline

Select Delete to remove all assets from the timeline between the in and out points:

Figure 91. Delete the assets between the in and out points

Screen Recording
(Option-Command-S)

Pastes the screen recording properties into a clip.

Callout
(Option-Command-C)

Pastes callout properties into a callout action.

Video Filters
(Option-Command-V)

Pastes video filter properties into a clip.

Callout
(Option-Command-U)

Pastes audio filter properties into a clip.

Table 33. Edit Menu Items (continued)

Menu Item Description

Paste and Match Style
(Option-Shift-
Command-V)

Adds text on the clipboard to your text box. Inserted text 
adopts the text formatting of the character immediately 
preceding the insertion point. 

Delete Permanently removes the selected items. If you have marked 
in and out points, the segment between the in and out point 
is deleted for all clips, as shown in Figure 90 and Figure 91.

Table 32. Edit Menu Items

Menu Item Description
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Note: To shift clips left to fill the hole created by the deletion, use Ripple Delete 
(Command-backspace), the scrubber handle, or right-click (Control-click) in the empty 
space and select Close Gap.

Figure 92. Timeline before splitting a clip

Figure 93. Timeline after splitting a clip

When splitting a clip, the previous clip name is retained on both clips. By default, each 
segment of a clip uses the name of the original media located in the Media Library.

These segments can be renamed for convenience and clarity.

Table 34. Edit Menu Items (continued)

Menu Item Description

Ripple Delete
(Command-
Backspace or Delete)

Delete the elements (or portions of elements) between the in 
and out points on all tracks of the timeline and shift all clips 
left to close the gap on the timeline.

Select All
(Command-A)

Highlights all clips on the timeline.

Deselect All
(Shift-Command-A)

Deselects all clips on the timeline. This can also be done by 
clicking in an empty area of the canvas or timeline.

Split Clip
(Command-T | 
Command-Shift-T | T)

Converts each selected clip into two separate clips, splitting 
them at the current scrubber point, so that you can adjust the 
parts of the clip independently, as shown in Figure 92 and 
Figure 93.

Table 35. Edit Menu Items (continued)

Menu Item Description

Replace Media Navigate to and select new media. All settings from old media 
are maintained.

Detach Audio Removes the audio stream from the selected clip (visible as a 
green waveform through the center of the clip unless View > 
Show Audio Waveforms is unchecked), and creates a new 
audio clip at the same point on the timeline, as shown in 
Figure 94 and Figure 95. 
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Figure 94. Timeline Prior to Performing the Detach Audio Command

ScreenFlow adds the audio to a new audio clip on the timeline:

Figure 95. Timeline After Detaching Audio from a Clip

After detaching audio from a clip, the new audio clip—containing the audio from the 
selected video clip—is added to the timeline. The original clip is now video only.

Figure 96. Timeline Prior to Performing the Add Freeze Frame Command

Table 36. Edit Menu Items (continued)

Menu Item Description

Extract Audio Select individual audio channel to extract. The extracted 
audio channel is placed into a new track.

Add Freeze Frame
(Shift-Command-F)

Inserts a freeze frame in the middle of a selected clip.

First, the clip is split at the scrubber, then a two second freeze 
frame is inserted between the clips. The duration of the freeze 
frame can be set by dragging the edge of the clip, much like 
any other still image clip. The second half of the clip is moved 
to the right to adjust for the added clip, as shown in Figure 96 
and Figure 97.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of freeze frames.
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ScreenFlow adds two new clips to the timeline:

Figure 97. Timeline After Detaching Audio From a Clip

This is useful for pausing your video while demonstrating or narrating.
Table 37. Edit Menu Items (continued)

Menu Item Description

Trim Front to Scrubber
(W)

Trims the front of the selected clips from the start of the clip 
up to the scrubber position.

Alternatively, you can adjust the left side of the clip by 
clicking the mouse just near the left edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the right to trim the amount you want off of the front 
of the clip. This method is functionally equivalent to using the 
Trim Front to Scrubber command.

Trim End to Scrubber
(E)

Trims the back of the selected clips from the end of the clip 
up to the scrubber mark.

Alternatively, you can adjust the right side of the clip by 
clicking the mouse just near the right edge of the clip (the 
mouse pointer changes to the drag cursor [left] to indicate 
that you can resize the clip). Click and drag the edge of the 
clip to the left to trim the amount you want off of the back of 
the clip. This method is functionally equivalent to using the 
Trim End to Scrubber command.

Lock Clip | Unlock Clip
(Option-Command-L)

Locks selected clips to their positions on the timeline and 
cannot be moved. When clips are locked, you cannot move 
other clips onto them to make transitions. Select again to 
unlock selected clips you have previously locked.

Reverse Clip Select to check and uncheck. When checked, media is played 
in reverse.

Edit Speech Clip Displays the Speech Clip window. (see Insert Menu.)

Close Gaps Removes all selected gaps between clips in the timeline.

Nest Clips
(Option-Command-N)

Nests selected clips into a group for treating the group as a 
whole when operating on them. See Using Nested Clips for 
details.

Unnest Clips Un-nests a previously nested clip.
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Group
(Command-G)

Ties selected clips together on the timeline, so that moving 
one clip moves all grouped clips. Ideal for synchronizing 
voice-overs, music beds, etc., to a camera clip so that their 
timing remains synchronized as you move them around in 
your project.

Ungroup
(Command-U)

Returns selected clips to be independent of other clips.

Add Starting 
Transition | Remove 
Starting Transition
(Option-Command-,)

Adds a transition to the beginning of the selected clip(s). 
Apply again to remove the transition.

Add Ending Transition 
| Remove Ending 
Transition
(Option-Command-.)

Adds a transition to the ending of the selected clip(s). Apply 
again to remove the transition.

Add Starting & Ending 
Transitions | Remove 
Starting & Ending 
Transitions
(Option-Command-.)

Adds transitions to the beginning and ending of the selected 
clip(s). Apply again to remove the transitions.

Label Enables you to add and remove colored labels.

Captions

Set Current 
Language

Specifies the language you want to display captions in.

Import from SRT Imports the closed caption text from a file

Export to SRT Exports the closed caption text in this project to a file.

Clear All Captions Removes caption text from all caption clips in this project.

Start Dictation Displays the Mac OS dictation system, so that you can add 
text to a text box clip using your voice (Using Audio and Video 
Filters).

Emoji & Symbols Displays the Characters window so that you can enter special 
characters in text fields.

Table 37. Edit Menu Items (continued)

Menu Item Description
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Mark Menu
This topic describes each item in the Mark menu, as described in Table 38.
Table 38. Mark Menu Items

Menu Item Description

Mark In Point
(I)

Sets the in point of a range on the timeline at the current 
point of the scrubber.

When you create an in point without an out point, 
ScreenFlow automatically sets the out point to the end of the 
last clip on the timeline, and highlights the range in blue. In 
and out points can be used to delete entire sections of your 
timeline using the Ripple Delete command.

Select the in point (click on the line directly over the timeline 
scale) and drag it right or left to adjust its point on the 
timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Mark Out Point
(O)

Sets the out point of a range on the timeline at the current 
point of the scrubber.

When you create an out point without an in point, 
ScreenFlow automatically sets the in point to the beginning 
of the timeline, and highlights the range in blue. In and out 
points can be used to delete entire sections of your timeline 
using the Ripple Delete command.

Select the out point (click on the line directly over the 
timeline scale) and drag it right or left to adjust its point on 
the timeline.

Shift-click on the timeline scale to set in and out points 
relative to the position of the scrubber.

Clear In & Out Points
(Option-Z)

Removes the in and out points you created previously.

Markers

Add

(back single 
quote mark, left 
of the “1” key)

Adds a marker to the timeline at the scrubber location.

If you export a ScreenFlow document as a QuickTime movie, 
chapter markers are placed at each named marker position in 
the movie when Add Chapter Track from Markers is checked.

Add To Clip Adds a marker to a clip and prompts you for a name.

Delete
(Shift-~)

Deletes the selected marker.
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Add to Clip
ScreenFlow supports timeline markers, but one significant limitation is that they do not 
adjust to content changes. This means you must manually adjust your markers when 
you rearrange your timeline. But Clip-based Markers attached to clips solve this 
problem because they flow with the content and self-adjust. 

To add a clip marker, first select a clip and make sure the scrubber is within the bounds 
of the clip, then select Mark >Markers > Add to Clip. 

Delete All Deletes all markers on the timeline.

Go to Next
(Shift-Up Arrow)

Moves the scrubber to the next marker to the right on the 
timeline.

Go to Previous
(Shift-Down 
Arrow)

Moves the scrubber to the previous marker to the left on the 
timeline. You can also use the mouse to drag markers and 
adjust their position.

Go to

   Project Start Moves the scrubber to the start of the project timeline.

   Project End Moves the scrubber to the end of the project timeline.

   Previous Frame Moves the scrubber to the previous frame on the timeline.

   Next Frame Moves the scrubber to the next frame on the timeline.

Table 38. Mark Menu Items

Menu Item Description
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When the popup dialog box displays, enter a name for your marker and click Create.

 

The marker can be created without a name. Clicking away from the popup cancels the 
Add To Clip operation.

Once the clip marker has been created, it is positioned along the bottom of its parent 
clip. It can be moved with the mouse to reposition it, and if double-clicked, the marker 
popup is displayed enabling you to change the name.

The clip marker works in the exactly as a timeline marker. If it has been given a name, it 
can provide a chapter marker to YouTube or for QuickTime exports. It will appear in the 
Markers window (opened by selecting Window > Markers), enabling you to get a quick 
overview of all markers in the system. 

 

You can also quickly jump around all markers in the system using keyboard shortcuts. 
To delete the marker, move the scrubber over it and select Marker > Delete Marker. 

Enter marker name 
Click Create
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Insert Menu
This topic describes each item in the Insert menu, as described in Table 39.
Table 39. Insert Menu Items

Menu Item Description

Text Box Inserts a text clip into the project at the current scrubber 
position. Text box duration is 5 seconds, but can be adjusted 
by dragging the edge of the clip on the timeline.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of text boxes.

Annotations Clip
(Option-Command-T)

Inserts simple graphic effects to visual clips including 
recordings, videos, and image files. Annotation shapes 
include circle, square, line, and arrow.

Note: Go to ScreenFlow > Preferences > Timeline to change 
the default duration of annotation clips.

Speech Clip... Displays a sheet where you enter text, select a voice, then 
click Insert to create an audio clip in your project by 
converting text to speech using one of six automated voice 
programs. Text can be typed directly into the field or pasted 
from another document.
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Template Placeholder 
Clip

Inserts a placeholder where a clip from a Screen Recording 
and Computer Audio, Camera and Microphone, or IOS device 
will be inserted in a new document created using a template.

Narration Inserts a narration from an audio device.

Choose...
(Shift-Command-V)

Imports media files into your project at the current scrubber 
position. ScreenFlow displays the Open dialog, so that you 
can browse your file system or network server and select the 
media file to add to the project’s media library and timeline.

Table 39. Insert Menu Items

Menu Item Description



Using ScreenFlow Menus
Font Menu

235

Font Menu
This topic describes each menu item in the Font menu, as described in Table 40. Font 
options apply only to text in text clips.
Table 40. Font Menu Items

Menu Item Description

Show Fonts
(Command-T)

Displays the System Font pane. Select a font to apply to 
highlighted text, or all text if none is selected.

Bold
(Command-B)

Makes the selected text bold.

Italic
(Command-I)

Makes the selected text italic.

Underline
(Shift-Command-U)

Underlines the selected text.

Bigger Increases the font size by one point.

Smaller Decreases the font size by one point.

Copy Style Copies the style of the selected text, except background.

Kern Select Text Kerning mode: Default, None, Tighten, Loosen.

Paste Style Applies the previously copied text style to the selected text.

Make Text Properties 
Default

Saves the current text properties for the selected text box clip 
and makes them the default. When you create a new text box, 
the default text properties are used.
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Actions Menu
Actions are time-based changes to clips used to create gradual temporal or temporary 
effects. Actions are applied mid-point, where the change takes place.

This topic describes each menu item in the Actions menu, as described in Table 41.
Table 41. Actions Menu Items

Menu Item Description

Add Video Action
(Command-K)

Adds a Video Action to the selected clip at the location of the 
scrubber. A Video Action allows you to apply effects like 
Zoom, Pan, and Rotate to your video clip.

Add Audio Action Adds an Audio Action to the selected clip. An Audio Action 
allows you to apply various effects on the audio of the 
selected clip, such as ducking, or adjusting the volume.

Add Screen 
Recording Action
(Command-R)

Adds a Screen Recording Action to the selected screen 
recording clip. Screen Recording actions enable you to 
modify the size of the Mouse Pointer, add click effects, or 
show keys pressed, for example.

Add Callout
(Command-L)

Adds a Callout to the selected screen recording clip. A callout 
lets you focus attention on a section of your project. For 
example, you can highlight the mouse pointer by dimming 
everything but the area just around the mouse pointer or 
highlight and magnify the foreground window.

Add Touch Callout Provides a way to automatically receive “touch” events from 
the iOS device.

Add Snapback Action Let you add a Video, Audio, or Screen Recording action.

Go to Next Action Within a clip, selects the next action.

Go to Previous Action Within a clip, selects the previous action.

Play Selected Action Plays the currently selected action.

Curve Type By default, actions are applied to the clip in a linear manner. 
For example, when applying a scaling action, the image size 
changes by equal amounts from start to finish. This may be 
perceived as too abrupt, so you can modify the rate with 
which an action is applied.

The Curve Type menu item has these submenu items:

Linear Linear transition.

Ease-In Starting slow, speeding up towards the end.

Ease-Out Starting fast, slowing down towards the end.
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Arrange Menu
This topic describes each menu item in the Arrange menu, as described in Table 42. 
Font options apply only to text in text clips.

View Menu
This topic describes each menu item in the View menu, as described in Table 43. View 
options determine how the media is presented both on the canvas and on the timeline.

Ease-In & Out Starting and ending slowly, faster in the middle.

Exponential 
        Ease-In

Starting slow, speeding up exponentially towards the end.

Exponential
        Ease-Out

Starting fast, slowing down exponentially towards the end.

Exponential
        Ease-In & Out

Starting and ending slowly, exponentially faster in the 
middle.

None Applies action immediately.

The duration of the action is ignored if this option is applied.

Table 41. Actions Menu Items

Menu Item Description

Table 42. Arrange Menu Items

Menu Item Description

Align Enables you to align selected clips in six different ways: 
Left, Horizontally Center, Vertically Center, Right, Top, Bottom.
NOTE:  If you select a single item (not multiple items), alignment 
is made along the edge of the canvas. Selecting multiple items  
aligns those items to the furthest edge of the grouping, instead 
of aligning to the canvas.

Scale Enables you to scale selected clips: Scale to Fit, Stretch, or 
Reset.  These are the same controls located at the top of the 
Video tab of the Inspector window.

Distribute Evenly distributes display of selected clips.

Group Groups selected items into a single grouped item

Ungroup Un-groups a selected grouped item into single items.

Lock Clip Locks/unlocks a selected clip so that it can’t be altered.
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These options only change how your project is displayed on the canvas—they do not 
alter the media.
Table 43. View Menu Items

Menu Item Description

Enter Full Screen
(Command-F)

Displays the editor window in full screen mode to reduce on-
screen clutter.

Zoom In
(Command-=)

Magnifies the display of the canvas. 

Zoom Out
(Command--)

Reduces the display of the canvas. 

Zoom to 100%
(Option-Command-0)

Displays the canvas area at its direct pixel size.

Zoom to Fit
(Control-Command-0)

When the canvas is obscured, adjusts the display size so that 
it is completely visible in the window.

Show Checkerboard Displays transparent portions of the background as 
checkerboard to distinguish them from opaque portions that 
are the same color as the background. To export video with 
an alpha channel, use the Lossless - ProRes with Alpha preset 
or a custom derivative (see Exporting Your Video).

Show Captions Displays closed caption text on the canvas.

Hide/Show Inspector Hides or shows the inspector panels.

Hide/Show Timeline Hides or shows the timeline.

Show/Hide Quick 
Media Library

Shows or hides the Quick Media Library.

Zoom Timeline to Fit
(Control-T)

Scales the timeline downward to display it entirely in the 
window. 

Zoom Timeline In
(=)

Expands the timeline.

Zoom Timeline Out
(-)

Contracts the timeline.

Switch to Inspector
(Command 0 - 9)

Displays the selected Property pane: Video, Audio, Screen 
Recording, Callout, Annotations, Text, and Media (library).

Select Focus Timeline to return keyboard events back to the 
timeline. For example, when you are editing a text box on the 
timeline, you can select Focus Timeline, then use shortcuts.
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Window Menu
This topic describes each menu item in the Window menu, as described in Table 44.

Snapping
(Control-N)

Toggles snapping for both the canvas and timeline.

When snapping is on, the mouse snaps to various guide-lines. 
For example, on the canvas, the mouse snaps your objects to 
the center and edges of your canvas. It also snaps to other 
objects, if you have any. On the timeline, the mouse snaps to 
the beginnings and endings of actions and clips. Checked/On 
by default.

You can temporarily toggle snapping by holding down the 
Command key. 

Scrub Live Audio
(Shift-S)

When activated, you can hear the audio track while dragging 
the scrubber. Checked/On by default.

Show Audio 
Waveforms

When activated, clips that contain audio have the audio 
waveform shown along the center of the clip. Checked/On by 
default. 

Show Thumbnail 
Icons

When activated, each clip displays a thumbnail icon 
displaying either the first frame (for video or image files) or a 
format icon for audio or text clips. Checked/On by default.

Show Tab Bar Displays the tab bar on the timeline, pushing the timeline and 
all tracks down in the window, to accommodate it. When you 
create nested clips, each clip nest is identified by a tab.

Show Caption Track Displays the caption track on the timeline—the caption track 
is the highest track on the timeline. 

Table 43. View Menu Items

Menu Item Description

Table 44. Window Menu Items

Menu Item Description

Minimize
(Command-M)

Minimizes the foreground window.

Zoom Scales the foreground window to the full size of the screen.
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Figure 98. Markers window

Purchase Menu (Telestream Web Store Only)
Note: This topic does not apply if you purchased ScreenFlow from the Mac App Store. 
The App Store has its own installation and licensing procedure.

Use these menu commands for purchasing from the Telestream Web Store and 
activating your ScreenFlow license, as described in table Table 46.

Select Previous Tab
(Shift-Command-[)

When the tab bar is visible in the timeline (as when editing 
nested clips), this navigates to the previous timeline tab.

Select Next Tab
(Shift-Command-])

Navigates to the next timeline tab.

Markers Opens a window listing the markers in the current document.

You can add, delete, and rename markers, and jump to 
markers in this window, as shown below in Figure 98. 

Table 45. Window Menu Items (continued)

Menu Item Description

Bring All to Front Puts all ScreenFlow windows in front of any other 
application's windows on the desktop.

<documents> List of all open document windows, listed sequentially in the 
order they were opened.

Table 44. Window Menu Items

Menu Item Description
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Note: If your ScreenFlow license is already activated, this menu does not display.

Help Menu
This topic describes each menu item in the Help menu, as described in Table 47.

Table 46. Purchase Menu Items

Menu Item Description

Purchase ScreenFlow 
Online

Displays the Telestream online Web store.

Unlock ScreenFlow Displays the Licenses pane of ScreenFlow Preferences to 
enter a license. Requires admin authentication first. See 
Unlocking ScreenFlow via Telestream Web Store.

Table 47. Help Menu Items

Menu Item Description

Search Searches the User’s Guide (this document).

ScreenFlow Help Displays the ScreenFlow Help Landing Page, where you can 
access the ScreenFlow User Guide, watch tutorials of 
ScreenFlow topics, visit the Community Forum, and access 
other helpful resources. 

Visit ScreenFlow Web 
site

Displays the Web page for general ScreenFlow information.

Visit Support Page Displays the Web page for ScreenFlow support information.

Provide ScreenFlow 
Feedback

Goes to the ScreenFlow support Web page.

http://www.telestream.net/screen-flow/overview.htm
http://www.telestream.net/telestream-support/screen-flow/support.htm
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Figure 99. ScreenFlow Landing Page
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Troubleshooting

This section describes common questions with ScreenFlow. If your issue is not listed or 
the recommended procedure does not work, please contact technical support.

How do I provide Customer Service with diagnostic information about a 
problem I’m having with ScreenFlow?

You select Help > Gather Support Diagnostics. To display this menu item, press Shift 
then click the Help menu. Select Gather Support Diagnostics to collect debugging logs, 
crash reports, a system profile, and a snapshot of the current state of ScreenFlow 
including open documents. 

Click Gather to generate an archive of these files, and save it on your desktop.

Send it to Telestream Customer Service as requested.

I exported my video, but it looks fuzzy or blurry. What can I do to make it look 
better?

When using ScreenFlow, it can be difficult to record your entire display at full resolution 
then compress that data into a low-resolution video while still retaining your necessary 
level of image clarity. Here are a few things you can do:

• Export using the Lossless - Apple ProRes with Alpha uncompressed video format. 
As long as you do not lower the resolution, it is identical to the original recording, 
but results in a large file size. This is ideal if you require additional editing or refor-
matting outside of ScreenFlow before publishing it.

• Reduce your display resolution before recording (System Preferences/Displays). By 
reducing your display resolution before recording, you require less compression 
later. We recommend that you decide what size you want your video to be in 
advance. Then, lower your display resolution as close to that as possible, but no 
smaller. If you record at a smaller resolution than your intended output, you will 
lose image clarity. 

• Use the scale and zoom functions in ScreenFlow. If you do not want to reduce your 
display resolution or export to a large, uncompressed format, your best option is to 
use Video Properties > Scale or Callout Action > Zoom. These functions allow you 
to increase the visibility on a specific portion of the recording which can be valu-
able for maintaining clarity in a heavily compressed video. 

http://www.telestream.net/telestream-support/screen-flow/support.htm
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• Text is the hardest item to reproduce clearly in digital video. Digital video was not 
designed to recreate detailed figures like text. It was designed to map color spaces, 
so the thin lines of text can be particularly difficult to recreate. If you have text in 
your screencast, it is best to use the Scale feature or to increase the text size.

How do you designate a display recording area?

Although many screen capture programs function by designating a specific recording 
area, ScreenFlow does not. ScreenFlow captures the entire display. This enables you to 
make use of the entire display during editing in post-production. 

When using a program which designates a recording space, you may unexpectedly 
move outside of this space due to a menu option or pop-up. If your recording space is 
preset, there is no way to recover this lost information. With ScreenFlow's reliance on 
post-production editing, you can move outside your area of focus when necessary.

Does ScreenFlow work with Parallels or VMware?

Since ScreenFlow captures everything on your display, both Parallels and VMware are 
supported (including Computer Audio output). However, ScreenFlow cannot use the 
Callout features, as these are dependent upon information provided by Mac OS X. 

Telestream has tested ScreenFlow with Parallels in all modes (Coherence, Window, and 
Full Screen) without issue. In fact, when using Parallels/VMware, some users have 
reported that ScreenFlow produces smoother, higher-quality output while using less 
CPU resources than native Windows screen capture programs.

What kind of graphics card should I use?

ScreenFlow requires a Quartz Extreme-capable graphics card. If you are unsure if your 
graphics card is supported, please download an evaluation version; ScreenFlow will 
notify you if it is not supported. You can expect most Mac hardware made in the last 
five years to fully support Quartz Extreme graphics cards. 

ScreenFlow uses video RAM (or VRAM) during the recording process, so it is important 
to have a graphics card with at least 64 MB of VRAM, but we recommend 128 MB. The 
amount of VRAM necessary to record smooth video depends on your display resolution 
and whether or not other applications are simultaneously using VRAM. If you have 
insufficient VRAM, the recording will drop frames and the video skips during playback.

Does ScreenFlow support closed captioning?

ScreenFlow does support closed captioning. For details, see Creating Closed Captions. 

How do I use ScreenFlow to record my iPod/iPhone/iPad?

When running on OS X 10.10 (Yosemite), ScreenFlow can capture directly from the 
screen of an iOS device over a USB connection. For details, see Configuring Touch 
Callouts.

My USB microphone and iSight camera are out of sync. What should I do?

If the audio and video are out of sync, try using the audio input on the computer (not 
the USB input) as there can be a latency problem between USB input and the iSight 



Troubleshooting 245

camera. This is particularly evident when recording a talking head. Use a microphone 
that utilizes the audio input into the computer. 

I can’t find my media files. Where is the media library?

Each project in ScreenFlow has a media library once the first media file has been 
recorded or the first file has been added. The media library is actually a folder inside the 
project itself. The media folder’s contents include .scc files and copies of externally-
added media files, and are controlled by the media library as you record clips in 
ScreenFlow, and add and delete files. 

To view the media folder, control-click (right-click) the project file in Finder and select 
Show Package Contents. Open the Media folder to view the files in the media library for 
this project.

CAUTION: Unless directed by customer service, you should not delete or rename files 
in this directory or it may corrupt your project.

Every file you add to the library is saved (or duplicated) in that folder. ScreenFlow 
recordings are media files with a .scc extension and can’t be opened by other video 
applications. 
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