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Contacting Telestream
To obtain product information, technical support, or provide comments on this guide, 
contact us using our web site, email, or phone number as listed below.

Copyrights and Trademark Notices

Copyright © 2024 Telestream, LLC and its Affiliates. All rights reserved. No part of this 
publication may be reproduced, transmitted, transcribed, altered, or translated into any 
languages without written permission of Telestream, LLC. Information and 
specifications in this document are subject to change without notice and do not 
represent a commitment on the part of Telestream. Specifications subject to change 
without notice.

Telestream, Aurora, CaptionMaker, CaptureVU, Cerify, Content Manager, 
ContentCentral, Cricket, DIVA, DIVAdirector, DIVADocs, DIVAGrid, DIVANet, DIVAProtect, 
DIVASolutions, Episode, Encoding Intelligence, Episode, FLEXVU, Flip4Mac, FlipFactory, 
Flip Player, Geminus, Glim, GraphicsFactory, Inspector, IQ & Design, Kumulate, 
Lightspeed, MassStore, MassTech, MetaFlip, Post Producer, Prism, ScreenFlow, Sentry, 
Singulus, Split-and-Stitch, Stay Genlock, Surveyor, Tempo, TrafficManager, Vantage, 
Vantage Cloud Port, VOD Producer, and Wirecast are registered trademarks of 
Telestream, LLC and its Affiliates and its Affiliates. 

Resource Contact Information

Telestream Technical Support Email: support@telestream.net
URL: http://www.telestream.net/
telestream-support

Support Portal: https://
support.telestream.net/

Telestream, LLC Website: telestream.net
Sales Email: sales@telestream.net
Purchase Website: https://telestream.net/
purchase/store.htm
Marketing Email: info@telestream.net

Telestream, LLC
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International Distributor Support Web Site: telestream.net

See the Telestream Web site for your 
regional authorized Telestream 
distributor.

Telestream Technical Writers Email: techwriter@telestream.net

Share comments about this or other 
Telestream documents.

http://www.telestream.net
http://www.telestream.net/purchase/store.htm
http://www.telestream.net/purchase/store.htm
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
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Argus, ContentAgent, Cricket, e-Captioning, Inspector, iQ, iVMS, iVMS ASM, 
MacCaption, Pipeline, Switch, and Vidchecker are trademarks of Telestream, LLC and its 
Affiliates. All other trademarks are the property of their respective owners. 

Adobe. Adobe® HTTP Dynamic Streaming Copyright © 2014 Adobe Systems. All rights 
reserved.

Apple. QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the 
Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

Avid. Portions of this product Copyright 2012 Avid Technology, Inc.

CoreOS. Developers of ETCD.

Dolby. Dolby and the double-D symbol are registered trademarks of Dolby 
Laboratories Licensing Corporation.

Fraunhofer IIS and Thomson Multimedia. MPEG Layer-3 audio coding technology 
licensed from Fraunhofer IIS and Thomson Multimedia.

Google. VP6 and VP8 Copyright Google Inc. 2014 All rights reserved.

MainConcept. MainConcept is a registered trademark of MainConcept LLC and 
MainConcept AG. Copyright 2004 MainConcept Multimedia Technologies.

Manzanita. Manzanita is a registered trademark of Manzanita Systems, Inc.

MCW. HEVC Decoding software licensed from MCW.

MediaInfo. Copyright © 2002-2013 MediaArea.net SARL. All rights reserved. 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Microsoft. Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008 
|Server 2012|Server 2016|Server 2019|Server 2022, Windows 7, Windows 8, Windows 
10, Windows 11, Media Player, Media Encoder, .Net, Internet Explorer, SQL Server 
2005|2008|2012|2016|2019, and Windows Media Technologies are trademarks of 
Microsoft Corporation.

NLOG, MIT, Apache, Google. NLog open source code used in this product under MIT 
License and Apache License is copyright © 2014-2016 by Google, Inc., © 2016 by Stabzs, 
© 2015 by Hiro, Sjoerd Tieleman, © 2016 by Denis Pushkarev, © 2015 by Dash Industry 
Forum. All rights reserved.

SharpSSH2. SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are 
permitted provided that the following conditions are met:
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Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer:

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Swagger. Licensed from SmartBear.

Telerik. RadControls for ASP.NET AJAX copyright Telerik All rights reserved.

VoiceAge. This product is manufactured by Telestream under license from VoiceAge Corporation.

x264 LLC. The product is manufactured by Telestream under license from x264 LLC.

Xceed. The Software is Copyright ©1994-2012 Xceed Software Inc., all rights reserved.

ZLIB. Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler.

 

Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.
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MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT 
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR 
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE 
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM 
MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 80237 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE 
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING 
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL 
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE 
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD 
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER 
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER 
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR 
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. 
SEE HTTP://WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE 
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT 
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR 
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA 
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON 
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT 
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.
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Limited Warranty and Disclaimers
Telestream, LLC (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), will be free from defects in materials and workmanship under normal 
operating conditions and use.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality. 

Software Updates
Except as may be provided in a separate agreement between Telestream and You, if 
any, Telestream is under no obligation to maintain or support the Software and 
Telestream has no obligation to furnish you with any further assistance, technical 
support, documentation, software, update, upgrades, or information of any nature or 
kind.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, LLC WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
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in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product. 

Damages
TELESTREAM, LLC SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC
848 Gold Flat Road
Nevada City, CA 95959 USA

You can call Telestream during U. S. business hours via telephone at (530) 470-1300.

Regulatory Compliance
Electromagnetic Emissions: FCC Class A, EN 55022 Class A, EN 61000-3-2/-3-3, CISPR 22 
Class A

Electromagnetic Immunity: EN 55024/CISPR 24, (EN 61000-4-2, EN 61000-4-3, EN 
61000-4-4, EN 61000-4-5, EN 61000-4-6, EN 61000-4-8, EN 61000-4-11)

Safety: CSA/EN/IEC/UL 60950-1 Compliant, UL or CSA Listed (USA and Canada), CE 
Marking (Europe)

California Best Management Practices Regulations for Perchlorate Materials:
This Perchlorate warning applies only to products containing CR (Manganese Dioxide) 
Lithium coin cells. Perchlorate Material-special handling may apply. See 
www.dtsc.ca.gov/hazardouswaste/perchlorate.
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Introducing Switch

Telestream® Switch™ is a professional cross-platform media player, inspector, and 
correction tool. Switch comes in three licensed versions: Switch Player, Switch Plus, and 
Switch Pro.

Switch plays virtually any media file, displays detailed information about that file, and 
enables you to make changes to the file.

In Inspect mode, Switch displays information about a media file, such as its speaker 
labels, aspect ratio, clean aperture, bitrate, metadata, encoding formats, and types of 
audio channels. In Edit mode, Switch lets you trim, resize, crop, change aspect ratio; 
rearrange audio tracks, and edit speaker assignments. You can also attach secondary 
audio to your video when exporting.

Note: When in unlicensed free-trial mode, Switch adds video and audio watermarks 
to your media, and may limit premium features. When unlicensed, Switch watermarks 
media display when in transcode mode and truncates media when in pass-through 
mode.
To remove the watermarks and limitations, purchase a Switch license, enter the serial 
number, and activate the license.

For a list of features included for Switch Player, Switch Plus, and Switch Pro, see the 
Switch Product Comparison Chart.

See also Switch Product Page.

Topics
■ Switch Demo Restrictions 15

■ Switch Versions 15

■ Switch Resources 15

Switch supports a wide variety of media standards, file formats, codecs, and containers. 
For a current list of supported playback types, see Playback Format Support.

https://www.telestream.net/switch/tech-specs.htm#playback

https://www.telestream.net/switch/tech-specs.htm#playback
https://www.telestream.net/switch/overview.htm

https://www.telestream.net/switch/tech-specs.htm#playback
https://www.telestream.net/switch/compare.htm#chart
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Note: Telestream updates Switch support of various formats through Telestream 
Media Framework (TMF).

Switch can play many codecs and formats, including uncompressed 4:2:2 10-bit (v210) 
and Apple ProRes 4444 XQ.

Switch Demo Restrictions
The Switch Free Trial (unlicensed version) includes all features of Switch Pro. However, 
the Free Trial version adds video and audio watermarks to your media during playback 
and may limit other premium features.

Switch Versions
Switch is available in three licensing levels: Switch Player, Switch Plus, and Switch Pro.

For a list of features included for Switch Player, Switch Plus, and Switch Pro, see the 
Switch Product Comparison Chart.

See Activating a License Serial Number.

Switch Resources
For up-to-date information about Switch, visit the following Telestream resources:

Tutorials and Demos
Telestream provides tutorials and product demos on the Switch Training Resources 
page:

https://telestream.net/switch/resources.htm#docs

Telestream provides a video introduction to Switch via the Watch Video Introduction 
button on the Welcome screen.

Switch Literature, Documentation, and Knowledge Base
Find current versions of Switch literature, user guides, and customer case studies on the 
Switch Literature and Documentation page. Find Switch technical articles on the Switch 
Knowledge Base.

Switch Literature and Documentation

https://telestream.net/switch/resources.htm#docs

Switch Knowledge Base

Switch Knowledge Base

http://www.telestream.net/switch/resources.htm#docs
https://support.telestream.net/s/global-search/Switch
http://www.telestream.net/switch/resources.htm#docs
https://www.telestream.net/switch/compare.htm#chart
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Switch User Guide

Telestream provides the Switch User Guide via the View User Guide button on the 
Welcome screen.

Switch User Website

Telestream provides the Switch website via the Visit Website button on the Welcome 
screen.

Getting Help
To get help using Switch, select the Help menu. This menu enables you to search for 
help by topic, open the user guide, purchase Switch, or get customer-support help.

Searching Help
To search the help system for any topic or key word, do the following:

1. Click Help.

2. In the Search field, enter a term and press Return.

Switch displays a window that enables you to select related menu items or help 
topics. Switch indicates, with a pointer, menu item that match the search.

Note: As long as there are characters in the Search field, Switch doesn’t display the 
other Help menu items, even if you reopen the Help Menu. To redisplay the full Help 
menu, select a search item or delete all characters from the Search field.

Customer Support
Telestream offers technical support through our website and email.

Reporting Files That Switch Can’t Open or Display

Note: This procedure is for sending details to Telestream for problem files, not for 
requesting help. This procedure does not receive a response from Telestream. 

To report that Switch can’t open or display a file, do the following:

1. Select the window displaying the media file you want to report.

2. Select Help > Report A Problem File.

Switch opens a reporting dialog box.

3. Click the Report button to send a technical report of your file to the Telestream 
support team; or click Cancel to abort this reporting action.

When Switch sends your report, it opens a confirmation message in a browser.

4. Click Submit Feedback to open a new support case.
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Sending Information to Support
To collect and send diagnostic information to the Telestream support team, do the 
following:

1. Select Help > Gather Support Information.

Switch collects information about Switch.

2. When Switch finishes collecting information, enter your support case number and 
click Reveal.

Switch saves diagnostic information in a file on your desktop, and generates an unique 
filename. Sending this file to Telestream enables the support team to diagnose any 
problems you have reported.

Contacting Support
To contact the Telestream support team, do any of the following:

• Select Help > Contact Support.

Switch opens the Switch Support page on the Telestream Website.

• Select View Switch Website.

Switch opens the Switch Product page on the Telestream Website.
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Installation

You can install Switch on any Mac computer that meets the minimum system 
requirements.

Note: Switch installers are available at: telestream.net

Topics
■ System Requirements 18

■ Installing Switch 19

■ Purchasing Switch 19

■ Activating a License Serial Number 20

■ Uninstalling Switch 21

■ Updating/Activating/Deactivating Switch 21

System Requirements
Note: Minimum specifications support playback of standard-definition content. 
Playback of demanding content such as 4K/UHD, HEVC, and high-frame-rate video 
might require more powerful hardware. To play demanding content on minimal 
systems, select Use faster (lower-quality) scaling for video playback in the Setting Display 
Preferences menu.

Note: The following list of system requirements is current at the time of publication, 
but subject to change. Verify that the system on which you plan to install Switch meets 
the platform requirements specified in Switch Technical Specifications. 

• OS Version: macOS Big Sur 11, macOS Monterey 12, macOS Ventura 13

• CPU: 2.4 GHz Core 2 Duo or faster, Any Core 3, i5, or i7

http://www.telestream.net
http://www.telestream.net/switch/tech-specs.htm#requirements.htm
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• RAM: 4 GB minimum

• Display: 1280 x 768 or larger, 50 Hz or faster

• Graphics:

– 256 MB or more graphics memory

Installing Switch
To install Switch, do the following:

1. Log on with administrator rights and provide your administrator name and 
password during installation.

2. Download the DMG file here:

https://telestream.net/switch/overview.htm

3. Run the installer.

If you have an older version of Switch already installed on your computer, the 
installer upgrades to the newer version.

4. Agree to the license terms and follow the instructions displayed by the installer.

5. Double-click the Switch DMG file in your Downloads folder.

6. Click and drag the Switch icon into the Applications folder.

The installer adds the Switch application to your Mac Applications folder. You can run 
Switch at any time by clicking the application icon. You can also drag the icon to your 
dock for easy access in the future.

         

Purchasing Switch
You can find the pricing for Switch on the Switch product page, here:

Switch Product Page
1. Select Help > Buy.

Switch opens the Telestream product-purchasing page in a web browser.

Click application icon

https://www.telestream.net/switch/overview.htm
https://www.telestream.net/switch/overview.htm
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2. Enter the quantity desired, and click Add To Cart.

After you purchase Switch, Telestream sends you a serial number in a confirmation 
email, and opens the Preferences dialog.

3. Once you have obtained your product serial number, enter it into the Serial 
Number field in the Preferences dialog.

4. Click Activate.

Once licensed, Switch does not place video or audio watermarks on outputs.

Switch Watermarks
During unlicensed playback, Switch superimposes a logo watermark on DNxHD and 
HEVC/H.265 assets. Switch places an audio watermark in 15 second intervals on all 
media using Dolby AC-3 audio.

Switch watermarks all unlicensed video exports in transcode mode. Switch truncates 
exports when either audio, video, or both are in pass-through mode. Licensed exports 
have no watermark or truncation. Switch sets the truncation at 30 seconds, or at half 
the duration of the file if it is less than 30 seconds long.

Activating or deactivating a license while a video is open immediately changes the 
video display accordingly.

Activating a License Serial Number
If your computer is connected to the Internet and you purchased an upgrade via the 
Telestream Store online, manually activate your Switch license. Use the serial number in 
the receipt email from Telestream. Also, you can manually activate Switch on another 
Mac not connected to the Internet. To purchase a license for Switch, click the Buy 
button.

To enable upgraded features, or to activate additional copies of Switch, you must have 
access to the Internet. Enter your serial number to manually activate the features 
purchased.

Note: If your computer doesn’t have Internet access, don’t use this process. Instead, 
use a separate computer with Internet access to open the Manual Activation Guide on 
the Telestream Web site.

1. Select Switch > Preferences.

2. Click License. Enter the serial number from your email receipt.

It’s best to copy and paste the serial number to avoid typing mistakes. When typing 
it in, be sure to enter only zeros (no letter Os), capitalize all letters, and include all 
hyphens.

Switch enables the Activate button.

www.telestream.net/pdfs/user-guides/Manual_Activation_Guide.pdf
www.telestream.net/pdfs/user-guides/Manual_Activation_Guide.pdf
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3. Click Activate.

Switch contacts the Telestream Store. Telestream activates your Switch serial num-
ber.

Note: If you experience problems activating, contact Telestream Customer Support 
at: desktopsupport@telestream.net or 877-681-2088.

See Production & Streaming: Renewal & Licensing Questions.

Deactivating a License Serial Number
You can activate a Switch serial number on only one computer at a time, but you don’t 
need to purchase a separate license for each computer you run it on. You can install 
Switch, unactivated, on multiple computers (see Activating a License Serial Number). To 
activate Switch on a different computer, first deactivate the serial number on any 
computer that already has it activated.

To deactivate a Switch serial number, select Switch > Preferences > License. Then click 
Deactivate.

Note: When you deactivate your serial number on your computer, it must have 
Internet access. You can also change licensing by clicking Change and entering a 
different serial number.

Uninstalling Switch
To uninstall Switch, first close Switch, Then, do the following:

1. > > Click and drag Switch from the Applications folder to the trash icon.

Updating/Activating/Deactivating Switch
To check for software updates, see Updating Switch Automatically in the Preferences and 
Updates section.

To activate a license serial number for Switch, see Activating a License Serial Number.

To deactivate a license serial number for Switch, see Deactivating a License Serial 
Number.


https://support.telestream.net/s/article/Licensing-Questions
desktopsupport@telestream.net
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Configuration

To set preferences in Switch, select Switch > Preferences. The Preferences dialog enables 
you to change the update interval, activate licenses, and deactivate licenses.

Topics
■ Updating Switch Automatically 22

■ Setting Display Preferences 23

■ Setting Audio Preferences 23

■ Troubleshooting Video Scopes 24

■ Enabling ARM Systems for SStP and Cineform Playback 24

Customizing General Settings
To change Switch general settings, do the following:

1. Select Switch > Preferences > General.

2. In the Default Export Directory field, select Same as Source or Last Used.

3. If you select Last Used, Switch exports to the last directory used in an export. If that 
directory no longer exists, Switch exports to the source directory.

4. (Optional) Check Watch for growing files to cause Switch to watch for files that are 
still being created.

Note: If the durations shown are not accurate, and you are not using growing files, 
make sure the Watch for growing files preference is not checked. Relaunch Switch if you 
change this setting.

Updating Switch Automatically
To enable Switch to check for software updates, do the following:

1. Select Switch > Preferences > Update.
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2. To set the interval at which Switch checks for updates, choose Daily, Weekly, 
Monthly or Never from the Check For Updates menu.

3. To check for updates manually, click Check Now.

Setting Display Preferences
To set display preferences, do the following:

1. Select Switch > Preferences.

2. Click Display to open the Display Settings window.

3. Check the boxes for any of the following preferences desired:

•  Improve playback performance by giving up search for captions after the first few sam-
ples Abandons searching for captions if they are not found in the first few samples. 
This improves performance.

• Use faster (lower-quality) scaling for video playback To play demanding content on 
minimal systems, select this setting.

• Disable desktop display when external preview is enabled Disables rendering of video 
for desktop playback which can improve quality and reliability of external device 
playback.

• When possible, decode at reduced scale This option works for J2K, ProRes RAW, Pro-
Res on Windows, Sony RAW, and Sony Simple Studio Profile (SStP) files. When possi-
ble, Switch decodes at the scale you select from the drop-down menu. This 
improves performance.

Setting Audio Preferences
To set audio preferences, do the following:

1. Select Switch > Preferences, then click Audio.

Switch opens the Audio Settings window.

See Audio under The Preferences Dialog.

2. Select one of these modes from the Mode drop-down menu:

•  Custom analog dialog normalization

•  Custom Digital dialog normalization

•  Line out

•  RF

3. Adjust the Cut and Boost levels for Dynamic Range Compression by moving the 
sliders.

For more information about dynamic range compression settings, see Switch 
Audio Preferences.


https://support.telestream.net/s/article/Audio-Preferences
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4. To set the audio destination, select Audio > Destination.

See Destination under Audio. Also see To configure audio for SDI output in Switch, 
toggle Audio to Edit In the Inspector and Audio Transcode.

Troubleshooting Video Scopes
Using the video scopes can affect Switch performance. Switch first converts each 
decompressed video frame to an uncompressed format that the scope accepts. Switch 
runs the scope on that frame, and converts that result to an uncompressed format for 
display. Performance degrades most in playback of large video files, and those with 
higher frame rates. Closing the Video Scopes window prevents this additional 
processing.

Video codecs with hardware acceleration, such as H.264 on Mac, perform better than 
those without hardware acceleration.

If Switch drops frames when the Video Scopes window is open, any of the following 
might mitigate the problem:

• Avoid playing multiple videos at once.

• Quit any unused applications to free up resources for Switch.

• Disable display of captions using the View > Subtitles / Closed Captions menu item.

• Disable the search for captions in the Display tab of the Preferences dialog.

• Consider using reduced-scale decoding (accessible in the Display tab of the Prefer-
ences dialog) if your video uses a codec that supports it, such as ProRes, ProRes Raw, 
J2K, Sony Raw, or Sony SStP MPEG-4.

• Try playing in slow motion using the Control > Slow Motion Forward menu item, or 
via the JKL keys.Try frame-stepping with the arrows keys instead of playback.

Enabling ARM Systems for SStP and Cineform 
Playback

Sony is discontinuing support for the SDK for the Sony Simple Studio Profile (SStP) 
codec on ARM. To play back SStP or Cineform files in Switch installed on a system with 
an ARM CPU, launch Switch on Rosetta.

To launch Switch on Rosetta, do the following:

1. Quit Switch.

2. Select the Switch application in the Finder Applications folder.

3. Select File >Get Info.

Finder opens a dialog.

4. Check the box labeled Open using Rosetta.

5. Launch Switch.


https://support.telestream.net/s/article/Switch-Audio-mapping-for-SDI-output
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• Open the file desired for playback.

To have Switch launch natively after you’re done playing back SStP or Cineform files, 
uncheck Open using Rosetta. The next time it launches, Switch runs natively again.



26

Opening Files

In Switch, you can open video files as primary files; and you can open audio or subtitle 
files as secondary files. Also, you can associate and close media files.

Topics
■ Launching Switch 26

■ Opening Video Files 27

■ Opening a Recent Media File 27

■ Opening Audio or Subtitle Files 27

■ Opening Flags 28

■ Opening Recent Files 28

■ Closing Files 28

Launching Switch
To launch Switch, do the following:

1. Install Switch.

See Installing Switch.

2. Double-click Launchpad button located  the tool bar at the bottom of the desktop.

3. To launch Switch, in Launchpad, click the Switch button.

Switch opens and displays a Welcome screen. From the Welcome screen, you can 
watch an introduction video, browse the user guide, visit the Telestream Website, 
or open a media file.

4. (Optional) To force the display of the Welcome screen when all media files have 
been closed, on the Welcome screen, check Show Welcome Screen when all media is 
closed.

See Welcome Screen.
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Opening Video Files
To open a video file in Switch, do the following:

1. On the Welcome screen, select File > Open File, or click Open Other....

Switch displays the Open dialog.

2. Navigate to the file you want to open. Click Open; or click Cancel if you decide to not 
open any video files.

Note: Every time it opens an un-indexed file, Switch indexes the file. Certain file types, 
such as MOV and MP4, always contain indexes. Certain other file types, such as MPEG-
2PS and TS, never contain indexes.

Note: Many media containers, such as MPEG-2 Transport Streams, do not provide 
information about the duration of the media inside. When Switch first opens the file, it 
estimates the video, audio, subtitle, and container durations in the Media Inspector and 
Media Player. Once Switch is done indexing it calculates these durations accurately. Do 
not rely on the durations shown until Switch is done indexing.
If durations shown are not correct, and you are not using growing files, make sure the 
Watch for growing files preference is unchecked. Relaunch Switch after changing this 
setting.

Opening a Recent Media File
To open a media file that was recently open, do one of the following:

• On the Welcome screen, select a file in the Recent Media list. Click Open.

• Select File > Open Recent, and click the name of a recently opened file from the list.

Opening Audio or Subtitle Files
To open an audio or subtitle file in Switch, do the following:

1. Select File > Open Secondary Audio File, or File > Open Secondary Subtitle File.

2. Switch displays the Open dialog.

3. Navigate to the file you want to open. Click Open; or click Cancel if you decide to not 
open an audio file or a subtitle file.

Note: Secondary audio and subtitle files play along with the primary media file you 
have open. These are useful for supplying background audio for a video that has no 
embedded audio, or for supplying subtitles for a video that has no embedded 
subtitles. Secondary audio or subtitle files also can be used as alternatives to the 
primary audio or subtitle files.
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Opening Flags
In Switch, you can flag video frames, add comments to the flags, and share the flags 
with others. You can flag frames individually or in sequence, and can color-code the 
flags. Also, you can export the flags to share with others in XML text files. Switch XML 
flag files are both human-readable and easily parsed.

To open flags, do the following:

1. Select File > Open Flags File.

2. Switch displays the Open dialog.

3. Navigate to the file you want to open. Click Open; or click Cancel if you decide to not 
open a flag file.

See Opening the Flags Tab.

Opening Recent Files
To re-open previously-opened video files, select File > Open Recent.

Switch displays a list of your most recently opened video files. Every time a file is 
opened or exported, Switch adds it to the list.

Closing Files
To close a file, do the following:

1. Select the media window in which Switch displays the file.

2. Select File > Close.
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Playback

You can play media files using Switch. Switch provides a complete set of controls 
through the Control menu.

Topics
■ Viewing Frame Type, Data Rate, and Flags in the Timeline 33

■ Controlling Audio Volume 35

Viewing Media in the Preview Area
The Switch Play Bar in the Preview area provides the easiest way to control the playback 
of your media files. The controls in the Play Bar are described below.

 

Play/Pause Click the Play/Pause button to play the video; click again to pause it.

Scrubber/PlayheadPlay/Pause Time RemainingElapsed Time Volume Control

Play 
Bar
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Note: In addition to clicking Play/Pause on the Play Bar, you can also play and pause 
by pressing the Spacebar. It acts as a toggle between play and pause modes.

Elapsed Time Displays how long the video has been playing. Click the time display to 
change display mode to Time, Frame Counter, or Timecode. You can also enter a time 
value and click Go to go to that time in the video.

Note: When the Time Display mode is set to Frame Count, Switch appends a plus sign 
(+) to the end of the current frame number whenever playback has exceeded the 
length of the video. This usually happens when the audio is longer than the video. 
Switch displays black frames from the end of the video to the end of the clip.

Scrubber/Playhead Click and slide to change the location in the video you are 
viewing. You can also click on any position in the scrubber timeline to cause the 
playhead to jump to that location.

To jump the playhead to an un-indexed part of a clip, hold down the Option key while 
clicking on the desired position in the scrubber timeline. Switch skips indexing the 
previous portions and continues indexing from the location selected. Switch might 
display a spinning progress indicator for up to 10 seconds during this operation. If 
Switch can’t provide the requested video frame within ten seconds, the video display 
remains black. You might still be able to step through nearby frames.

For frame-accurate scrubbing, hold down the Shift key while scrubbing. If you move 
the scrubber less than a half second from the previous seek event, Switch seeks any 
type of frame; I-frame, B-frame, or P-frame.

For quick scrubbing, move the scrubber more than a half second from the previous 
seek event, Switch seeks only I-frames, making scrubbing more responsive.

Note: The skip index feature works for MPEG-2 TS & PS files exclusively. For all 
navigation commands, such as flag navigation, chapter navigation, jump to mark in/
out, and 10 second skip, you can skip indexing over portions of the video you don’t 
want to use.  To skip indexing, use normal navigation controls while holding down the 

Click time 
display

Enter a 
time value

 Click Go

Select time 
display mode
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Option key.
Subtitle and Caption display is disabled when using the skip index feature. If a portion 
of the video is skipped using the skip index feature, you will not be able to see that 
portion unless you close and reopen the file.

Note: Switch can begin playback before it has completed indexing and decoding the 
whole file. Also, you can jump ahead in a clip before indexing is complete.
Once you’ve skipped indexing a section of the video, Switch can’t display the video, 
and can lose accuracy when jumping to subsequent portions. Close the video, reopen 
it, and restart indexing from the beginning.

Time Remaining Displays time remaining for the video to play. Display is shown in 
either seconds or frames depending on the Elapsed Time display mode (Time, Frame 
Counter, or Time Code).

Volume Control Click the speaker button to mute or un-mute the audio. Click and slide 
the bars icon to increase or decrease the volume.
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Viewing Frame Type, Data Rate, and Flags in the 
Timeline

The timeline enables you to view the frame types or the data rate of your video. It also 
allows you to view any flags you have set. To open the timeline, select 
View > Show Timeline. After the timeline opens, the menu changes to Hide Timeline. 
Alternatively, you can press command+T to show or hide the timeline.

GOP Mode
Select GOP (Group of Pictures) mode to display the video frame types. Each bar 
represents a frame, which you can select by clicking it. Purple bars represent P-frames, 
or predictive frames. P-frames contain only the pixels changed since the previous I-
frame. Blue bars represent B-frames. B-frames are bidirectional predictive frames. B-
frames contain only the data that have changed from the preceding frame or are 
different from the data in the very next frame. White bars represent I-frames. I-frames 
are intra-coded frames. I-frames contain all the pixels for the frame being displayed. You 
can also zoom the timeline display by sliding the Zoom slider.
 

Frame 
bars

Zoom 
slider

Select 
GOP
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Datarate Mode
Select Datarate mode to display the datarate for each video frame, showing the overall 
data of the video charted across the timeline in the form of peaks and valleys. You can 
also zoom the timeline display by sliding the Zoom slider.

 

Flags Mode
Select Flags mode to display all flags on the timeline. Click the left flag icon to add a 
new start flag. Click the right flag icon to add a new end flag. Select a flag and click the 
minus (-) button to remove a flag.
 

Datarate 
display

Zoom 
slider

Select 
Datarate

Flags 
display

Click to add 
a start flag

Click to add 
a start flag

Click to 
remove 
a flag
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The flag settings for this timeline are set in the Inspector using the Flags tab. Click the 
plus (+) button to add a new flag. Select a flag and click the minus (-) button to remove 
a flag. Click on the flag icon to change its color to any of five: Green, Blue, Yellow, 
Orange, or Red. (See Flags Tab)

 

Controlling Audio Volume
You can control audio playback volume, or mute audio, through the Audio menu.

Select Increase Volume or Decrease Volume to change the audio volume level, or select 
Mute to silence it entirely. You can also mute all non-active media windows by selecting 
Mute Inactive Windows. Additionally, you can mute all audio, or just the audio of 
selected files, tracks or channels by selecting Mute Files, Mute Tracks, or Mute Channels. 
Select Solo Files, Solo Tracks or Solo Channels to mute all but the selected file, track or 
channel. You can configure advanced audio controls as well, including Loudness Type, 
Peak Hold, and Destination.

See the Audio Menu for details.

Click to add or 
remove a flag

Flags 
icon
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Inspection

Switch allows you to either inspect or edit your media files through a Media Inspector 
window.

See Windows in Switch on how to edit media files.

Topics
■ Opening the Media Player 36

■ Opening the Media Inspector 37

■ Opening the Container Tab 37

■ Opening the Video Tab 38

■ Opening the Audio Tab 39

■ Opening the Subtitle Tab 40

■ Opening a Subtitle File 40

■ Opening the Time Tab 40

■ Opening the Flags Tab 41

Opening the Media Player
To open the Media Player, do the following:

1. From the Welcome screen, select File > Open File.

2. Browse to a file, select it, and click Open.

See Playback.

Comparing Alternate Media
To compare alternate media files associated with your primary media file, do the 
following:

1. Open a primary media file.
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2. Select View > Show Alternate Media.

See View Menu. 

3. Select File > Compare Alternate Media. Open as many as 16 alternate media files.

Switch displays all open alternate media files in the Alternate Media File menu.

See File Menu.

4. Select View > Alternate Media File.

Switch displays the names of all open alternate media files.

See View Menu.

Opening a Flags File
To open a flags file, do the following:

1. Select File > Open Flags File.

2. Browse to a flags file and double-click it to open it.

See File Menu.

Opening the Media Inspector
The Media Inspector enables you to inspect or edit your media files. To open the Media 
Inspector, open a media file in Switch. Then, do the following:

• Select Window > Show Inspector.

Note: If Hide Inspector is displayed as a menu item, it means that the Media Inspector 
already is open.

See Welcome Screen.

Opening the Container Tab
To open the Container tab, do one of the following:

• Open the Media Inspector. Then click the Container tab.

See Opening the Media Player.

• Select Inspect > Container.

See Container Tab.

Viewing Metadata and Secondary Audio/Subtitles
To view embedded DPP file content, do the following:

1. Select the file from the list at the bottom of the Metadata pane.
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2. Click the Metadata gear icon and select Show XML Metadata Content from the drop-
down menu.

Switch displays the metadata content in a window.

Adding Metadata and Secondary Audio/Subtitles
To add metadata, click the associated plus (+) button and add available metadata such 
as Album, Artist, Director, or Year.

To add secondary audio and subtitle files, click the associated plus (+) button and 
navigate to the file you want to add.

To remove an added file, select it and click the minus (-) button.

Click the gear button to make additional settings.

To open the metadata URL, click the Metadata gear button.

To copy the URL of the audio or subtitle file, or to show its location, click the Secondary 
Audio or Secondary Subtitle gear button.

See Metadata and Secondary Audio/Subtitles Pane.

Opening the Video Tab
The Video tab displays data for the video portion of the media file, such as video format, 
size, or rate. To open the Video tab, do one of the following:

• Open the Media Inspector. Then click the Video tab.

See Opening the Media Player. 

• Select Inspect > Video.

Select DPP file name

Click Gear icon

Select Show XML 
Metadata Content
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• Select Edit > Video.

See Video Tab.

Viewing Contradictory-Data Details

When Switch displays a contradictory-data alert icon  in the Video tab of the 
Inspector, you can view the details of the data contradiction.

1. To view the details, do one of the following:

– Hover the cursor over the alert icon

Switch displays an explanatory message.

– Click the alert icon

Switch lists all the conflicting data values for the flagged field.

See Contradictory-Data Alerts in the Video Pane.

Opening the Audio Tab
The Audio tab enables you to inspect the audio portion of your media. This includes 
channel, format, bitrate, and duration. To open the Audio tab, do one of the following:

• Open the Media Inspector. Then click the Audio tab.

See Opening the Media Player.

• Select Inspect > Audio.

• Select Edit > Audio.

See Audio Tab.

Setting Audio Track Options
To determine how Switch displays and plays audio tracks, do the following:

1. Open the Audio tab on the Media Inspector.

See Opening the Audio Tab.

2. To display channel settings, click the down-arrow to the right of the Program field.

3. Do any of the following:

• To change the speaker name, when allowed, click the current speaker name and 
select a new name from the list displayed.

• To mute a channel, check Mute for that channel. 

• To play only one channel, check Solo for that channel. Solo turns off the sound for 
all other channels.

See Audio Track Display.
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Opening the Subtitle Tab
The Subtitle tab enables you to inspect the subtitling in your media. To open the Subtitle 
tab, do one of the following:

• Open the Media Inspector. Then click the Subtitle tab.

See Opening the Media Player.

• Select Inspect > Subtitle.

• Select Edit > Subtitle.

See Subtitle Tab.

Opening a Subtitle File
To open a subtitle file, do the following:

1. Select File > Open Secondary Subtitle File menu. Browse to the desired subtitle file, 
and double-click the file name.

Switch associates the selected subtitle file with the currently-open primary video 
file, and displays the subtitle file in the subtitle tab list.

2. To display the subtitle controls, select the subtitle file.

See Subtitle Tab.

Opening the Time Tab
The Time tab enables you to inspect the timing of your subtitles. To open the Time tab, 
do one of the following:

• Open the Media Inspector. Then click the Time tab.

See Opening the Media Player.

• Select Inspect > Time.

• Select Edit > Time.

See Time Tab.

The Time tab displays entry points (chapters) in your media that you have created in 
Switch. To change the chapters, consult the Windows in Switch section.

Note: You can view only the chapter markers you created in the current session. 
Chapter markers resident in the file when opened in Switch will not be visible -- even if 
they were previously created using Switch.
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Opening the Flags Tab
The Flags tab enables you to inspect the timing of your subtitles. To open the Flags tab, 
do one of the following:

• Open the Media Inspector. Then click the Flags tab.

See Opening the Media Player. 

• Select Inspect > Flags.

• Select Edit > Flags.

See Flags Tab.
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Export

You can export movies, still frames, iTunes packages, flags, or Media Inspector data 
from Switch. Also, you can re-encode and export clips for playback in various 
applications and devices.

Note: You can re-encode from most QuickTime-supported formats, but you can’t 
export to all QuickTime-supported formats.

Topics
■ Exporting Movies 42

■ Exporting iTunes Packages 43

■ Completing the Asset-Only ITMSP Package on iTunes Connect 44

■ Exporting Video Frames 45

■ Exporting Flags 45

■ Exporting Inspector Data 51

Exporting Movies
You can export your video at any time by selecting one of the menu items: Movie, iTunes 
Store Package, or Current Video Frame. You can also export your flags or the Media 
Inspector info. To export your media as a movie, do the following:

1. Select Export > Movie.

Switch opens a dialog box displaying the Container, Video, and Audio setup infor-
mation.

2. To change any of these, click its Edit button.

3. Click Export.

Switch displays the Save dialog.

4. Enter a filename for your movie and navigate to the location where you want to 
save your movie.
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5. Click Save when finished.

See Export Menu and Opening the Media Player.

Exporting iTunes Packages
You can export the following iTunes packages:

• Music Video (NTSC)

• Music Video (PAL)

• Music Video (HD)

• Television (NTSC)

• Television (PAL)

• Television (HD)

• Film (NTSC)

• Film (PAL)

• Film (HD)

Note: If the selected iTunes Store profile doesn’t allow your export settings, Switch 
displays an error message to help you choose correct export settings.

To export an iTunes package, do the following:

1. Select Export > iTunes Store Package. 

Switch opens a dialog box displaying the Container, Video, and Audio setup infor-
mation.

2. To change any of these, click its Edit button.

3. Click Export.

Switch displays the Save dialog.

4. Enter a filename for your movie and navigate to the location where you want to 
save your iTunes package.

5. Click Save when finished.

Switch displays a dialog box.

6. For Asset Type, select Feature or Preview.

If you select Preview, select also a Preview Territory. 

Preview Territory remains grayed-out until you select Preview.

Note: The Feature asset type embeds the secondary audio into the package, whereas 
Preview does not.

7. Enter your provider name.

The Continue button remains grayed-out until you enter a provider name.
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8. Select a language and locale for Metadata, Spoken Language, and Primary Assets.

9. Click Continue to continue.

If Switch is not licensed, Switch displays a warning that the export will be water-
marked.

Switch displays the Save dialog box.

10. Enter a filename for your movie and navigate to the location where you want to 
save your movie.

11. Click Save.

See Export Menu and Opening the Media Player.

Completing the Asset-Only ITMSP Package on 
iTunes Connect

Switch creates an asset-only ITMSP(.itmsp) package, but you still need to enter 
additional information via iTunes Connect to complete the package.

If you do not have an iTunes Connect account, you have two options:

1. Take the iTunes package created by Switch to an iTunes authorized aggregator for 
delivery.

2. Apply for an iTunes Account.

Assets must meet these iTunes Video specifications:

• iTunes requires film to be delivered as ProRes 422 (HQ) at their native frame-rate: 
the frame-rate originally captured by the camera’s image sensor.

• Movies are usually either 23.976, 24 or 25 fps. This is often different form the frame-
rate that is found on tape, archived storage, NLE (Non-Linear Editor) projects or 
masters for broadcast which are 29.97i (NTSC or 25i (PAL). Consult with iTunes if the 
native frame rate is neither 23.976, 24 or 25 fps.

Subtitles must be provided as an iTunes Timed Text (.itt) formatted file.

The following settings are required for iTunes delivery:

• ProRes 422 (HQ)

• 4:2:2: color space

• 1920 x 1080 1:1 (square) pixel aspect ratio for HD

Other requirements:

• Must begin and end with at least one black frame

• 5.1 audio when available in addition to the stereo track

• Audio source in Linear PCM 16 or 24 bit at 48Khz

• Closed Caption or English iTT Subtitle required for distribution in U.S. iTunes Store

• SD Assets:   User must select the correct aspect ratio when SD assets are selected.
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• Chapters: The first chapter stop must be at 00:00:00. If using a frame-accurate time-
code format, the first chapter stop must be at 00:00:00:00.

• Accessibility XML: User must review the XML and make necessary edits to following 
asset and accessibility tags. Please refer to the Vendor Tool Guide for additional 
information.

Asset:

<attribute name="image.textless_master"></attribute>

<attribute name="image.burned_subtitles.locale"></attributes>

<attribute name="image.burned_forced_narrative.locale"></attribute

Accessibility:

<accessibility_info>

<accessibility_role="captions" available=" "/>

<accessibility role=<"captions" available=false" reason_code" "/>

</accessibility info>

Exporting Video Frames
To export a single frame of your media, pause your media and do the following:

1. Select Export > Current Video Frame.

See Export Menu.

Switch displays the Save dialog box.

2. Enter a filename for your video frame. Then navigate to the location where you 
want to save your video frame as a still picture.

3. Click Save.

Exporting Flags
You can save and open all of your flags in a file. This enables you to transfer your flags 
between different Switch users. To save your flags, do the following:

1. Select Export > Flags.

See Export Menu.

Switch displays the Save dialog box.

2. Enter a filename for your flags file. Then navigate to the location where you want to 
save your flags.

3. Click Save.

Switch exports flag files with a single root element <Switch> which maximizes 
compatibility with other applications, particularly Vantage.

Note: Please keep in mind that flags files save a media path relative to the system 
they were created on. If you want to open a flags file on another machine, open the 
media first, and then the flags file. This associates the two and enables you to export 
the updated flags file.
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Here is a sample flags file:
<?xml version="1.0" encoding="UTF-8"?>

<Switch>

       <Media>/Users/telestream/Desktop/DVwithCaptions.mov</Media>

       <Flags>

             <Flag Title="Bad frame" UUID="838C2FF0-F84C-4B56-A35A-C7B6B43C53AA"

Start="1001001" End="1001001" Level="Error"/>

             <Flag Title="Make it look like this." UUID="F15599F6-1A65-4527-

A862-29B1E1C58642" Start="61061061" End="61061061" Level="Good"/>

             <Flag Title="Slate" UUID="899C0852-9EC1-4E69-A14D-3D799782927D"

Start="140140140" End="141808475" Level="Neutral"/>

             <Flag Title="Start of captions" UUID="C0B1066D-FFB8-4D27-

AFE0-3FC7530DDB6D" Start="153153153" End="153153153" Level="Info"/>

             <Flag Title="Check audio here." UUID="E5107F72-1C60-4197-

AF5B-0C426DBD8F3C" Start="508508509" End="508508509" Level="Warning"/>

       </Flags>

</Switch>

See also Opening Flags.

Flags XML Elements
Flags files are written in standard XML using elements defined by Telestream. You can 
create your own scripts and applications for reading and writing flags files using the 
following XML elements.

Flags XML Element Description

 <Media> Contains the absolute path to the media file that 
the flags refer to. The path is formatted for the 
operating system (Mac or Windows) on which the 
file was created. When Switch opens a flags file 
before any media has been opened, Switch 
extracts this path, opens the file, and loads the 
flags associated with it. 
This is primarily for users that are creating a flags 
file, and need to save their work and resume it later. 
You can’t move this path to other accounts or to 
other computers. For those cases, first open a 
media file, and then open a flags file to be 
associated with it.

<Flags> Contains a list of flags. Each <Flag> element may 
have one or more attributes. If any attributes are 
omitted, Switch uses their default values. All 
attributes have been supported since the 
introduction of the flags feature in Switch 4.0.
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Attribute Description

Title Contains the user’s comment about the flagged 
video frame.

Details Holds more information than the Title field, 
allowing more detailed descriptions of the flagged 
frame.

UUID A Universally Unique Identifier; used to distinguish 
each flag from the others.

Start
StartTime
StartTimeCode
StartFrameIndex

For each flag, use only one of these attributes. If 
you include more than one, Switch will pick one 
and ignore the others. These four attributes are 
described in this table, below.

Start Contains a numeric value that describes the start 
of the first frame that has been flagged.
This is the preferred format for specifying the start 
of the flag. It is the most accurate; avoids 
ambiguity--such as when dealing with files that 
have multiple timecode sources, noncontiguous 
timecode, or repeated timecodes--and it works for 
audio-only files, video-only files, and files with 
both audio and video. When exporting flags files 
this is the attribute Switch uses to specify the start 
of the flag.
The value is the time, in one hundred nanosecond 
ticks, between the start of the video (zero) and the 
start of the display time of the frame. For example, 
the first frame in a video always has a display time 
of zero. The value for the Start attribute of the first 
frame would be 0. In a 29.97 fps video. The second 
frame, which has an initial display time of 
approximately 0.033366700033367 seconds, 
would have a value of 333667.
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StartTime Contains a string value that describes the first 
frame that has been flagged. The value is a display 
time, in HH:MM:SS.SS (hours, minutes, seconds, 
and fractional seconds) format, which must be 
during the display time of the desired frame. Since 
this format allows for accuracy only to a one-
hundredth of a second, you may need to round up. 
For example, the value for the StartTime attribute 
of the first frame would be “00:00:00.00”. For a 
29.97 fps video, the second frame, which has an 
initial display time of approximately 
0.033366700033367 seconds, you should specify a 
value of “00:00:00.04”. The value for the StartTime 
attribute should be “00:00:00.07”. Defaults to 
“00:00:00.00”.
Requires Switch 4.5 or later.

StartTimeCode Contains a string value that describes the first 
frame that has been flagged. The value is a 
timecode, in HH:MM:SS;FF (hours, minutes, 
seconds, and frames) format. The last delimiter is a 
colon to signal non-drop-frame timecode format, 
or a semi-colon to signal drop-frame timecode 
format. 
Switch supports multiple timecode sources, but 
flags use only the Made-by-Switch timecode, 
which always starts at zero. For example, the value 
for the StartTimeCode attribute of the first frame 
would be “00:00:00;00” (drop-frame). For a 29.97 
fps video. The second frame would have a value of 
“00:00:00;01” (drop-frame). The StartTimeCode 
attribute should not be used in conjunction with 
audio-only files. Defaults to “00:00:00;00” (drop-
frame) or “00:00:00:00” (non-drop-frame) 
depending on the format of the timecode of the 
video track. Requires Switch 4.5 or later

StartFrameIndex Contains a numeric value that describes the first 
frame that has been flagged. The value is a zero-
based index. For example, the first frame would 
have a value for the StartFrameIndex attribute of 0. 
The value for the second frame would be 1, and 
the value for the third frame would be 2. The 
StartFrameIndex attribute should not be used in 
conjunction with audio-only files. Defaults to 0.

Attribute Description
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End Contains a numeric value that describes the last 
frame flagged.
This is the preferred attribute for specifying the 
end of the flag, as it is the most accurate and 
avoids ambiguity, Also, it works for audio-only files, 
video-only files, and files with both audio and 
video.
Switch sets this attribute when exporting flags to 
specify the end of the flag. However, when you are 
creating flags files for opening in Switch, you can 
use any one of the following attributes: End, 
EndTime, EndTimeCode, or EndFrameIndex. Use 
only one of these attributes for each flag. If you 
include more than one, Switch will pick one and 
ignore the others.

The End attribute has the same value as the Start 
attribute. When describing a sequence of frames, 
this value is inclusive. The frame that starts at this 
value is included in the sequence. The first frame in 
a video always has a display time of zero. The value 
for the End attribute of the first frame would be 0. 
In a 29.97 fps video, the second frame, which has 
an initial display time of approximately 
0.033366700033367 seconds, would have a value 
of 333667. The value for the End attribute would 
be 667334. Defaults to 0. 

Attribute Description
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EndTime Contains a string value that describes the display 
time for the last frame that has been flagged. The 
value is a display time, in HH:MM:SS.SS (hours, 
minutes, seconds, and fractional seconds) format, 
which must be during the display time of the 
desired frame. Since this format allows for 
accuracy only to a one-hundredth of a second, you 
may need to round up. 
For example, the value for the EndTime attribute of 
the first frame would be “00:00:00.00”. For a 29.97 
fps video, the second frame, which has an initial 
display time of approximately 0.033366700033367 
seconds, you should specify a value of 
“00:00:00.04”. The third frame has an initial display 
time of approximately 0.066733400066733 
seconds, so the value for the EndTime attribute 
should be “00:00:00.07”. Defaults to “00:00:00.00”. 
Requires Switch 4.5 or later.

Attribute Description
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Exporting Inspector Data
You can save your Media Inspector information in a text file. To save your inspector 
information, do the following:

EndTimeCode Contains a string value that describes the last 
frame that has been flagged. The value is a 
timecode, in HH:MM:SS;FF (hours, minutes, 
seconds, and frames) format. The last delimiter is a 
colon to signal non-drop-frame timecode format, 
or a semi-colon to signal drop-frame timecode 
format. Switch supports multiple timecode 
sources, but flags can only use the Made-by-
Switch timecode, which always starts at zero. 
For example, the value for the EndTimeCode 
attribute of the first frame would be “00:00:00;00” 
(drop-frame). For a 29.97 fps video, the second 
frame would have a value of “00:00:00;01” (drop-
frame). The third frame would have the value 
“00:00:00;02”. Do not use the EndTimeCode 
attribute in conjunction with audio-only files. 
Defaults to “00:00:00;00” (drop-frame) or 
“00:00:00:00” (non-drop-frame) depending on the 
format of the chosen timecode of the video track. 
Requires Switch 4.5 or later.

EndFrameIndex Contains a numeric value that describes the last 
frame flagged. The value is a zero-based index. For 
example, the first frame would have a value for the 
EndFrameIndex attribute of 0. The value for the 
second frame would be 1, and the value for the 
third frame would be 2. Do not use the 
EndFrameIndex attribute in conjunction with 
audio-only files. Defaults to 0.

Level Used to categorize each flag. Each level has the 
following color when displayed in Switch:

• Red Error

• Orange Warning

• Yellow Info

• Blue Neutral

• Green Good

Attribute Description
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1. Select Export > Inspector Info.

See Export Menu.

Switch displays the Save dialog box.

2. Enter a filename for your video frame.

The two formats that may be exported are: TXT or JSON.

3. Navigate to the location where you want to save your Inspector data.

4. Click Save.

Switch saves the Media Inspector data into a file that is readable in a text editor. The 
data file looks something like this:

Generated by Switch Version x.x on Mon May 23 12:33:19 20xx

https://telestream.net/switch

CONTAINER

Path: C:\Users\Firstname.Lastname\Downloads\Videoname.mov

Directory: C:\Users\Firstname.Lastname\Downloads

File Name: Videoname.mov

Size: 46.9 MB

Type: QuickTime Movie

Creation Date: Mon Oct 25 15:33:38 20xx

Modification Date: Mon Oct 25 15:33:50 20xx

Estimated Duration: 00:02.72

Video Track Count: 1

Audio Track Count: 0

Subtitle Track Count: 0

Subtitle Segmentation: TRUE

Complex Composition Playlist: TRUE

MOV Time Code: Enabled

Time Code: 00:00:00:00

MPEG-2 File Type/Brand: QuickTime File Format

VIDEO

Encoded Width: 1280

Encoded Height: 720
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Duration in Scale: 68

Duration: 00:02.72

Frame Count: 68

Time Scale: 25

Format: Apple ProRes 4444

Bitrate: 138.0 Mbit/s

Subsampling: 4:4:4

Colorspace: ITU-R BT.709

Color Primaries: ITU-R BT.709-5

Color Matrix Coefficients: ITU-R BT.709-5

Color Transfer Characteristics: ITU-R BT.709-5

Language: English

Frame Rate and Field Order: 25.00 fps, Progressive

Clean Aperture: 0 x 0

Pixel Aspect Ratio: Square Pixels

Display Width: 1280

Display Height: 720

ProRes Encoder: apl0

MPEG-4 Compressor Name: Apple ProRes 4444

dimension: [ {  "type": "clef",  "width": 1280,  "height": 
720,  "$annotation": {    "type": "Clean Aperture"  }}, {  
"type": "prof",  "width": 1280,  "height": 720,  
"$annotation": {    "type": "Production Aperture"  }}, {  
"type": "enof",  "width": 1280,  "height": 720,  
"$annotation": {    "type": "Encoded Pixels"  }} ]
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Switch has menus that provide access to all its controls and features.

Topics
■ Switch Menu 54

■ File Menu 55

■ Edit Menu 56

■ Inspect Menu 57

■ Control Menu 58

■ Audio Menu 60

■ View Menu 61

■ Export Menu 68

■ Window Menu 68

■ Help Menu 70

Switch Menu
About Switch

Displays the version of Switch you are running.

Preferences

Opens the Preferences dialog. If the Preferences dialog is already open, it becomes the 
active window.

Services

Presents the Mac Services available.

Hide Switch

Hides the Switch application window (leaves other window displayed).
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Hide Others

Hides all application windows (leaves the Switch window displayed).

Show All

Shows all application windows.

Quit Switch

Closes all files and exits.

The Preferences Dialog
The left-side navigation pane contains the following tabs:

• General

• Update

• License

• Display

• Audio

The sliders for Dynamic Range Compression let you control the following:

– Mode

– Cut

– Boost

Note: Switch allows Dolby E passthrough regardless of these settings. Switch doesn’t 
decode Dolby E tracks, but treats them as PCM tracks.

File Menu
Open

Displays the Open dialog for opening a media file.

Open Secondary Audio File

Opens a secondary audio file that plays along with the currently-open primary media 
file.

Open Secondary Subtitle File

Opens a secondary subtitle file that plays along with the currently-open primary media 
file.

Open Flags

Opens a flags file.

See Opening a Flags File.
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Compare Alternate Media

Opens media files to be compared with your primary media file. You can open up to 
sixteen alternate media files.

When the files are open, Switch lists them on the Alternate Media File menu where 
they can be selected or cycled through sequentially.

See Comparing Alternate Media and View Menu.

Open Recent

Displays the most recently accessed media files. Every time a file is opened or saved it is 
entered into this list.

Close Window

Closes the currently active media file window.

Edit Menu
Undo

Reverses your last change in Switch. Switch offers an unlimited number of undo actions 
(within computer memory limitations). Undo information is stored on a per-window 
basis. If you close a window and then reopen it, your undo information is lost. Undo 
does not undo edit actions.

Redo

Reverses your last undo action. Switch offers an unlimited number of redo actions 
(within computer memory limitations). Redo information is stored on a per-window 
basis. Also, if you close window then reopen it, your redo information is lost. Redo does 
not re-do edit actions.

Cut

Copies (and removes) the selection and stores it on the clipboard allowing you to paste 
it into a selected target.

Copy

Copies (but does not remove) the selection and stores it on the clipboard allowing you 
to paste it into a selected target.

Paste

Duplicates the content in the clipboard into the currently selected location. 

Select All

Selects all items in the currently active window. 



Menus
Inspect Menu

57

Switch User Guide

Copy Link to Current Frame

Allows you to copy a Switch link to the current frame of video. You can add this link to a 
web page or application. When a user clicks this link, the browser or application opens 
the video frame in Switch.

For details, see the SwitchEngine API Customer Integration Guide available on the 
Telestream website. 

Set Mark In

Sets the Mark In location in your media file.

Set Mark Out

Sets the Mark Out location in your media file.

Add Flag

Adds a new flag with the start time at the current location in the video.

Set Flag Out

Sets the end time of a selected flag to the current location in the video.

Inspect Menu
Container

Opens the Media Inspector window and selects the Container tab.

Keyboard shortcut: Control + 1 keys.

Video

Opens the Media Inspector window and selects the Video tab. 

Keyboard shortcut: Control + 2 keys.

Audio

Opens the Media Inspector window and selects the Audio tab.

Keyboard shortcut: Control + 3 keys.

Subtitles

Opens the Media Inspector window and selects the Subtitles tab.

Keyboard shortcut: Control + 4 keys. 

Time

Opens the Media Inspector window and selects the Time tab.

Keyboard shortcut: Control + 5 keys.

Flags

Opens the Media Inspector window and selects the Flags tab.

Keyboard shortcut: Control + 6 keys.

http://www.telestream.net/pdfs/user-guides/SwitchEngine-API-Customer-Integration-Guide.pdf
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Allow Editing

Toggles between edit and inspect mode each time selected.

Keyboard shortcut: Control + 7 keys.

Control Menu
Switch also provides a complete set of playback controls through the Control menu. 
The Control menu includes play, rewind, fast and slow motion, jump, skip, and loop 
controls. 

Play/Pause

Starts playing your selected media. When a media is playing the Play menu item 
changes to Pause. To pause a media, select Pause. When paused, the word Play is 
displayed. Select Play again to restart it.

Play All

Starts playing all open media files. 

Play Forward

Plays your selected media forward at normal or increased speed.

Keyboard shortcut: L. Pressing “L” repeatedly increases the play speed up to 16x.

Stop

Stops forward or backward playing of your media. If you stop a file that is playing at 
reduced or increased speed, the file will play at normal speed when you play it again. 
Switch does not retain the speed playback setting.

Keyboard shortcut: K.

Play Backward

Plays your selected media backward at normal or increased speed.

Keyboard shortcut: J. Pressing “J” repeatedly increases the play-backward speed up 
to 16x.

When a media is playing at increased speed, the speed is displayed in the upper left 
corner of the window.

Note: Play Backward, Stop, and Play Forward are controlled by keyboard shortcuts J, K, 
and L (key presses), respectively.

Slow Motion Forward

Enables you to play video forward at one-half of normal speed.

Keyboard shortcut: command + L.

Slow Motion Backward

Enables you to backward play video at one-half of normal speed. 

Keyboard shortcut: command + J. 
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Step Forward

Steps forward in the video, one frame at a time.

Keyboard shortcut: right-arrow.

Step Backward

Steps Backward in the video, one frame at a time.

Keyboard shortcut: left-arrow.

Skip Forward (1 sec)

Moves the video one second ahead.

Control + shift + Right Arrow.

Skip Backward (1 sec)

Moves the video one second backward.

Keyboard shortcut: Control + shift + Left Arrow.

Skip Forward (10 sec)

Moves the video ten seconds ahead.

Control + right-arrow.

Skip Backward (10 sec)

Moves the video ten seconds backward.

Control + left-arrow.

Next Chapter

Enables you to jump to the next chapter location.

Previous Chapter

Enables you to jump to the previous chapter location.

Chapters

Enables you to jump to a location by selecting a chapter title from the list.

Note: The Chapter menu items (Next Chapter, Previous Chapter, and Chapter) are only 
enabled if the video has chapter markers embedded in it. If no chapter markers are 
present, the menu items are grayed out. Chapter markers are sometimes embedded in 
longer movie clips to divide sections of the media topically or by edit points.

Jump to Mark In

Allows you to jump to a specified mark-in location in your media file. 

Jump to Mark Out

Allows you to jump to a specified mark-out location in your media file.

Jump To End

Moves to the last frame. If the media is playing, it continues playing. If it is paused, it 
remains paused.



Menus
Audio Menu

60

Switch User Guide

Jump To Start

Moves to the first frame. If the media is playing, it will continue playing. If it is paused, it 
will continue to be paused.

Jump To

Opens the Jump To dialog box. Enter a time value and click Go. The playhead moves to 
the location set in the dialog box. If the media is playing, it continues playing. If it is 
paused, it remains paused.

Next Flag

Move media to the next flag start location.

Previous Flag

Moves media to the previous flag end location. 

Flags

Displays a list of flags. Select a flag in the list to go to its start location.

Loop

When selected, your video plays repeatedly and the movie will play again from the 
beginning whenever it reaches the end. You can select from two loop modes: Entire 
Duration or Trimmed Segment.

When checked (selected), media loops back to start when end is reached. You can 
choose to loop on the entire duration of the media or just a trimmed section as set by 
Edit > Set Mark In and Edit > Set Mark Out (or using the I and O keys).

Audio Menu
Increase Volume

Turns the media volume up.

Decrease Volume

Turns the media volume down.

Mute

Mutes the media audio.

Mute Inactive Windows

Mutes all inactive windows (active window remains unmuted).

Mute Files

Mutes all audio tracks in the selected file.

Mute Tracks

Displays a list of tracks. Select a track to mute.

Mute Channels

Displays a list of channels. Select a channel to mute.
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Solo Files

Solos all audio tracks in the selected file.

Solo Tracks

Displays a list of tracks. Select a track to solo (all others are muted).

Solo Channels

Displays a list of channels. Select a channel to solo (all others are muted).

Loudness Type

Selects the loudness type: Gated or Ungated.

Peak Hold

Select Infinite Hold or 4s Hold. Infinite Hold holds the audio peaks for an unlimited 
amount of time. This allows you to view the highest audio peak reached. 4s Hold holds 
the audio peaks for only 4 seconds, and then resets the meter.

Destination

Selects the target for audio playback. The submenu contains the following options:

• Internal Speakers When an audio stream has Dolby E tracks in it and you select Inter-
nal Speakers, Switch mutes the Dolby tracks to prevent noise from the internal 
speakers.

• External Device When an audio stream has Dolby E tracks in it and you select Exter-
nal Device, you can unmute the Dolby E tracks. Switch lets the Dolby E tracks pass 
through via SDI.

• Client Application

To select an external device for audio playback you must also select an external device 
for video playback. Select Prefer External Device to set the target to External Device by 
default for all videos opened subsequently.

See Audio under Preferences.

Note: Switch displays the Client Application option only if a Switch Engine API client is 
connected and receiving audio.

See Controlling Audio Volume.

View Menu
Enter Full Screen

Cause the active media window to display full screen. To return to original window size, 
press the Escape key.

Half Size

Changes the size of the selected media to half of its actual size. 
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Actual Size

Changes the size of the selected media to its actual size.

Double Size

Changes the size of the selected media to twice its actual size.

Fit to Screen

Changes the size of the selected media to the max size of the screen.

Increase Size

Increases the size of the selected media.

Decrease Size

Decreases the size of the selected media.

Show Playback Statistics

Displays playback statistics such as playback frame rate, queue fill percentages, number 
of dropped frames, and AFD (Active Format Description) codes.

Show Frame Metadata

Displays a list of metadata attached to the currently displayed frame, including various 
types of timecode or captions.

Note: Some attached metadata may not be supported by Switch, and therefore will 
not be displayed.

Show Timeline

Displays and hides the Switch timeline. 

Requires a Switch Pro license.

Time Display

Changes the time display on the selected media: Time, Frame Count, or Timecode. You 
can also use Cycle Next to toggle through time display modes and Timecode Source to 
select which timecode to view when your media file contains multiple timecodes.

You may also click on the timecode display to show the settings window. Enter new 
time data and click Go.

If you select Frame Count, enter a new frame count value and click Go.

If you select Timecode, enter a new timecode value and click Go. You can also select a 
timecode source from the drop-down menu (Switch, QuickTime, etc.). 

Safe Areas

Enables you to show/Hide the boundaries of any of three safe areas: Action, Title, 
Caption, All or None. The Caption boundary is defined by a dotted line. The Title 
boundary is defined by a dashed line. The Action boundary is defined by a solid line.

You can also select an alternate aspect ratio (16:9 or 4:3) to define safe areas.

For example, if Pillarbox 4:3, Horizontally Centered is selected Switch displays a green 
rectangle defining the safe area.
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The color of the safe area boundary can also be selected: Light or Dark. If you select 
Light, the Action, Title, and Caption boundaries will be displayed in white (else in black 
is Dark is selected). For the Alternate safe area boundary lines, Light displays them in 
green and Dark displays them in purple.

See Switch: Safe Area Overlays.

Subtitles / Closed Captions
Displays or hides Subtitles / Closed Captioning.

Requires a Switch Plus license.

Subtitle / Closed Captions Source

Choose the source of the Subtitles or Closed Captions. These may be embedded in the 
video or a secondary subtitle file.

Subtitle / Closed Captions Channel

Choose from multiple channels within a source if present. For example, a video or 
secondary subtitle file may contain both 608 and 708 Captions. Channels include CEA-
608 CC1 through CC4, CEA-708 Service 1 through Service 6, or Teletext Pages.

V-Chip & Extended Data Services

When selected, if V-Chip and/or other XDS data is present on the selected caption 
source and channel, it will be rendered in the top right corner of the video.

Enable/Disable External Preview

Enables or disables the selected External Preview device. When enabled, the menu item 
changes to Disable.

External Preview Device

Selects an External Preview device. Switch supports a variety of Blackmagic and AJA 
devices.

Note: Make sure AJA software driver version 16.0 or later is installed. Install a version 
that is compatible with your device. You can download drivers from the AJA website: 
https://aja.com/products/aja-control-room#support

The source video must match a format that is supported by the external preview device 
that you have selected or external preview will not occur. Users can refer to the device 
manufacturer's specifications for a list of supported formats for each device. External 
preview currently only works in Preview mode, not in Edit mode.

Note: External Preview requires a Switch Pro license.

Output VANC Data

Enables and disables the output of VANC data to the selected External Preview device. 
Enabled when checked. When you output via SDI, you have the option to output 
ancillary data along with the audio and video signal. This is metadata that pertains to 
the video being output. For example, Captions are one form of metadata that a you 


https://support.telestream.net/s/article/Switch-Safe-Area-OverlaysShow
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may want to output in conjunction with your video. Like SDI out, this feature will 
remain on when enabled, and will output continuously whenever audio or video is 
being played back.

Show Alternate Media

Shows or hides Alternate Media comparison.

See Comparing Alternate Media.

Alternate Media File

Opens a list of alternate media files. Cycle Previous and Next enables you to 
sequentially cycle through the Alternate media files listed.

See Comparing Alternate Media.

Alternate Media Display

Enables you to choose how the selected alternate media file is compared. 

• Full View displays the media file fully in the media window, enabling you to com-
pare by sequencing through all the media files by selecting View > Alternate Media 
Display > Cycle Next, or by pressing the Control + Shift + S keys.

• Split View displays the selected alternate media file in a split, overlapping window. 
You can slide the middle divider left or right by clicking and dragging the move 
(<>) icon.

• Difference View displays the pixel difference between your primary media and the 
selected alternate media file. The videos are composited into a single black and 
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white signal. Differences between the two videos will appear as highlights on a 
black backdrop.

Video Scope

Select from available video scopes for use in quality control (QC) checks of your video 
media files. Show/Hide the video scope window from the Window Menu. 

• Luma Used for plotting histograms of brightness. Analyzes single-pixel horizontal 
slices of a video frame (ex. 1,920 pixels per slice for HD) and plots each vertical pixel 
according to its gray level (or luminance value). This allows you to quickly and visu-
ally locate bright and dark areas in your video. This scope makes it easier to spot 
things that might be hard for your eyes to notice, especially when using a monitor 
that may be inaccurate or poorly calibrated.

• Vector Used for plotting U-V brightness distribution. Analyzes and displays hue 
and saturation of colors in your video. The colors displayed are red, magenta, blue, 
cyan green, and yellow. The further away from the center each color is, the more 
saturated it is. The location of each color on the graph indicates its specific hue and 
which hues are the most saturated in the image.

• Component Parade (default) Used for plotting three component brightness distri-
butions. Analyzes and displays saturation levels of red, green, and blue in your 
video.

• Cycle Next Cycle through available scopes.

• Actual Size Sets scope to size of scope image.
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Note: To ensure the accuracy of the scopes, verify that your files are tagged with the 
correct colorspace and video range. This can be done in the video tab of the Inspector 
window (see Window Menu). For example, the vectorscope graticules are colored 
squares which represent the locations of the color primaries at 100% for the larger 
rectangles and at 75% for the smaller rectangles. These locations are dependent on 
the colorspace of the video file. Another example would be the Luma scope, where 
the graticules and scope image will vary based on whether the video is full range or 
narrow (studio) range.

Note: Creating the video scope output images requires significant CPU processing. If 
your system has difficulty with scope display, as would be evident by dropped frames, 
it is best to leave the video scopes window closed, so that none of this additional 
processing is performed. The amount of required processing also increases based on 
the dimensions of the video and the frame rate. Higher resolution videos, such as 4K, 
and/or higher frame rates, such as 60fps, will take more processing power than smaller 
SD videos with lower frame rates such as 30fps. If video scopes are required, try 
stepping/jumping through frames rather than using continuous playback.

Interlacing

Determines how to display interlaced video frames on your progressive computer 
monitor. Select which method to use: Weave Fields (default), Blend Fields, Split Fields, 
Field 1, or Field 2. The Cycle Next menu item chooses the next method in the list.

Note: Switch disables the Split Fields option when you enable the Show Gutters 
option.

Show/Hide Gutters

Displays or hides (toggle action) the gutters on the active media window.
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Pixel Aspect Ratio

When checked, uses the Aspect Ratio selected on the video tab in the Media Inspector 
window. Otherwise the aspect ratio is 1:1.

Alpha Channel

Shows/Hides checked transparency background.

With Alpha Channel on, a transparent image may be very hard to see due to the 
checkered background:

Aspect Ratio 
selection

Video tab
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With Alpha Channel off, the same image is easily viewed:

Occasionally, when scaling down a video that has white text on a black background 
and an alpha-mask that removes the background, unwanted artifacts can appear. There 
are several possible workarounds:

• Turn off high quality scaling while working with videos like this.

• View the video at its actual size to avoid scaling altogether. Currently, Switch does 
not allow you to exceed the boundaries of the monitor. If you're video is too big to 
fit on your monitor, you would have to get a bigger monitor.

• Don't use a black background. If you use white text on a white background and 
mask out the background, the Lanczos scaling will look much better.

Export Menu
Movie

Exports media file as a movie.

iTunes Store Package

Exports media file as an iTunes package.

Current Video Frame

Exports currently selected frame as a picture.

Flags

Exports your flags to a file that can saved and reopened as needed.

See Exporting Flags.

Inspector Info

Exports your inspector info in TXT or JSON formats.

Window Menu
Minimize

Minimizes the front-most window.
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Zoom

Maximizes the front-most window.

Show/Hide Inspector

Shows and hides the Media Inspector window.

Show/Hide Video Scopes

Shows and hides the Video Scopes window. Video Scopes are selected in the View Menu.

Show/Hide Audio Meters

Shows and hides the Audio Meters with a scale and levels. If you have a Pro license, 
when you click the arrow, Switch also displays Loudness. There are four loudness level 
displays: Momentary, Short-term, Integrated, and Loudness Range.

• To mute headphones or audio, click the mute headphones (monitor) button, or the 
mute audio button, at the bottom of any track.

• To turn on or turn off one or more level bars in a track, click the Solo or Mute but-
tons at the bottom of the relevant level bar.

When a level bar solo button is first selected, all other levels are muted. You can 
then add any or all other level bars by clicking the solo button of each. This works 
the same way for the Mute buttons, except the action is muting rather than soloing 
(turning off rather than on). When a level bar is muted, its peak meter display is 
dimmed but it continues to update with the value it would have were it audible.

Show/Hide Progress Window

Displays the Export Progress window. .

Show/Hide Welcome Screen

Displays or hides the Switch Welcome screen. 

Click arrow

Mute 
headphones

Mute audio
Solo buttons
Mute buttons
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Available Windows

All open windows are listed at the bottom of this menu. Selecting a listed window 
makes it the active window.

Help Menu
Search

Enables you to search the help system for any topic or key word.

Switch Help

Opens the online help version of the Switch User Guide.

Switch User Guide

Opens the PDF version of the Switch User Guide.

Buy

Enables you to purchase Switch online.

Report A Problem File

Opens a reporting dialog window. Click Report to send a report of your file to the 
Telestream support team. Click Cancel to abort.

Gather Support Information

Gathers support information and enables you to save a file with this information to 
your Mac desktop. A unique filename is generated. Sending this file to Telestream 
enables the support team to diagnose any problems you have reported. Click Reveal 
when finished.

Contact Support

Opens the Switch Support page on the Telestream website.

View Switch Website

Opens the Switch Product page on the Telestream website.

Acknowledgments

Opens the Acknowledgments page on the Telestream website.
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Windows in Switch

You can control most of the Switch features through the windows in the Switch user 
interface.

Topics
■ Welcome Screen 72

■ Media Inspector 73

■ Container Tab 74

■ Video Tab 75

■ Audio Tab 77

■ Subtitle Tab 80

■ Time Tab 81

■ Flags Tab 82

Welcome Screen
By default, when you launch Switch, Switch opens the Welcome screen. Descriptions of 
the buttons and fields in the Welcome screen follow:

Watch Video Introduction

When clicked, Switch opens a video introduction to Switch.

View User Guide

When clicked, Switch opens the Switch User Guide.

Visit Website

When clicked, Switch opens the Switch product page on the Telestream website.

Show welcome screen when all media is closed

When checked, Switch opens the Welcome screen at launch, when media files are 
closed.
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Recent Media field

Displays a list of media files opened in Switch most recently.

Clear

When clicked, Switch clears the list of recently-opened media files.

Open Other...

When clicked, Switch opens a browser for finding media files to open.

Cancel

When clicked, Switch cancels the clearing of the Recent Media field.

Open

When clicked, Switch opens the selected media file.

See Launching Switch.

Media Inspector
The Media Inspector window enables you to inspect or edit your media files.

See  Opening the Media Player

The Media Inspector window has six tabs: Container, Video, Audio, Subtitles, Time, and 
Flags. There is also a switch that enables you to select either Inspect or Edit mode.

Common to all six tabs is an Export menu at the bottom of the Media Inspector. This 
Export menu has the same menu items as the Switch main export menu.

See Export Menu.

Inspect/Edit Mode Switch
The Inspect/Edit mode switch enables you to select either Inspect or Edit mode. When 
the switch is in the Inspect position, you can view the settings. Also, you can add or edit 
information such as speaker labels, chapters, and flags; but you can’t edit the settings. 
When the switch is in Edit mode, you can edit the settings. You can export your media in 
either mode.

Container Tab
Video Tab

Audio Tab
Subtitle Tab

Time Tab

Inspect/Edit Mode 
Switch

Flags Tab
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Container Tab
The Container tab provides a way to inspect and edit the container for your media 
including information such as: name, location, size, type.

See Opening the Container Tab.

File Pane
Name

Displays the filename in the source file of your media, and is not editable. (You can 
change the name of the file when exporting.)

Directory

Displays the location of your media file, and is not editable.

Size

Displays the size of the media file, and is not editable.

Type

Select the container type by clicking on the double arrow and selecting a type from the 
menu: MXF, MOV, MP4, TS, MPEG, TIFO, and WMV.

Duration

Displays the duration of the media file (when known).

Created

Displays the date when your media file was created.

Modified

Displays the date when your media file was last modified.

Metadata and Secondary Audio/Subtitles Pane
Plus (+) icon

Adds available metadata (Album, Artist, Director, Year, etc).

Minus (-) icon

Removes available metadata (Album, Artist, Director, Year, etc).
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Gear icon

Opens the metadata URL to display the metadata in HTML or XML format.

See Adding Metadata and Secondary Audio/Subtitles.

Video Tab
The Video tab provides controls for the video portion of your media. This includes video 
format, size, and rate.

Video Pane
Format

Displays the current video format used. When in transcode mode you can change the 
format by making a selection from the drop-down menu: H.264, H.262, WMV and 
ProRes.

Bit Rate

Displays the video bit rate (when available).

Bit Depth

Displays the video bit depth (when available).

Chroma Subsampling

Displays the chrominance sub-sampling ratio.

Color Space

Select a color space from the Color Space drop-down menu. Then click the arrow to 
open the color space controls. Your choice of color space automatically populates Color 
Primaries, Matrix Coefficients, and Transfer Characteristics. However, you can set these 
manually using pull-down menus.

Add metadata

Remove metadata

Gear icon
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Note: If you change any of the control settings so that they do not match a known 
color space, Switch changes the Color Space display type to Unknown. 

Range

Displays the range value.

Alpha Channel

Displays Yes if the media file contains an alpha channel, and No if it doesn’t. 

Language

Select a language to use in metadata from the drop-down menu.

Duration

Displays the time duration of the video.

Rate

Displays the video rate in FPS (frames per second).

Note:  Frame rate changes (beyond those supported as part of deinterlacing) should 
be made outside of Switch.

Encoded Size

Displays the encoded media file and the pixel dimensions of the video in the file.

Clean Aperture

To set Clean Aperture, click the down arrow on the Clean Aperture menu. Enter the 
desired size in the Size fields, or enter Left, Right, Top, and Bottom aperture settings.

Aspect Ratio

Click the down arrow to open the Aspect Ratio control panel. Select the aspect ratio 
type (PAR or DAR) from the Type menu. Select also an aspect ratio from the Aspect Ratio 
menu list.

Display Size

Displays the size (resolution) of the video after crop, resize, etc. are applied.

Contradictory-Data Alerts in the Video Pane
Sometimes video files store the same data in multiple places, and sometimes the data 
in one place doesn’t agree with the data in the other. For example, the Alpha Channel 
data in the container might say that the video has no alpha channel, while the data in 
the video essence says the video does have an alpha channel. In such cases, Switch 

flags the relevant data field in the Inspector Video tab with an alert icon .

See Viewing Contradictory-Data Details.
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Video Properties Pane
ProRes Encoder

Displays the name of the ProRes encoder.

Alpha Channel

Displays true if the asset has an alpha channel, and false if it doesn’t

MPEG-4 Compressor Name

Displays the name of the MPEG-4 compressor.

dimension

Displays the width and height of the asset, in pixels.

See Opening the Video Tab.

Export Drop-Down Menu
When clicked Switch opens a menu of possible assets to export, including Movie, 
iTunes Store Package, Current Video Frame, Flags, and Inspector Info.

Audio Tab
The Audio tab enables you to inspect and edit the audio portion of your media. This 
includes channel, format, bitrate, and duration. To access the Audio tab, open the Media 
Inspector by selecting Window > Show Inspector, then click the Audio tab. Alternatively, 
you can select Inspect > Audio.

Audio Transcode/Audio Pass-Through

You can select Audio Transcode (use transcoder) or Audio Pass-Through (do not use 
transcoder) by selecting one of these from the pull-down menu.

Note: When exporting to an iTunes Store Package, if you have selected Feature for the 
Asset Type, secondary audio files are included in the exported iTunes package. If 
Preview is selected as the Asset Type, the audio files are not included in the exported 
iTunes package.

Click the plus icon to add a track. (Click minus icon to delete a selected track.) 

Click plus icon

Click gear icon
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Click the gear icon to display the settings menu.

Revert

Reverts audio settings to their original values. This action cannot be undone.

Move Up/Down

After selecting an audio track, you can move it up or down in the list. 

Note: The order of audio tracks in the list reflect the order of the tracks in the source 
file when in inspect mode, and the order of the tracks in any export files when in Edit 
mode.

Split/Join

Selecting Split divides a multi-channel track into multiple audio tracks, each containing 
a single channel of audio. Highlighting multiple tracks, then selecting Join, merges 
them into a single track containing all of the selected channels.

Note: When creating a Feature iTunes package using Audio Pass-Through, the 
secondary audio files will be added separately from the primary asset. When creating a 
Preview iTunes package, secondary audio files will be ignored when using Audio Pass-
Through mode.

Click a track to edit its settings.

Program

Select a type of audio configuration from the Program pull-down menu. Click also the 
down arrow on the right to display channel settings. For some channel selections, you 
can also change the speaker name. To do this, click on the current speaker name and 
then select a new name from the displayed list.

Format

Select an audio codec from the pull-down menu: Linear PCM (LPCM), AAC-LC, MPEG 
Layer 2, or Windows Media Audio (WMA).

Click the down arrow on the right of the drop-down menu, and select the format type. 
Also select Big or Small Endian.

Bit Rate

Displays the audio bit rate.

Click gear icon

Select a setting
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Sample Rate

Select a sample audio rate from the Sample Rate menu: 44.1Khz or 48Khz.

Language

Select the language to use in metadata.

Duration

Displays the time duration of the audio.

Audio Track Display
The Switch audio track display shows as many as 64 audio tracks. Switch displays the 
channels in the order in which they appear in the file or bitstream. This may differ from 
the channel order displayed by other applications or Windows.

Program

Displays the type of audio program, for example, stereo. When clicked, the down arrow 
to the right of the Program field opens a pane of the fields described as follows:

Format

Displays audio codec used.

Bit Rate

Displays the audio bit rate.

Sample Rate

Displays the sample audio rate.

Language

Displays the language used in on-screen test, such as text in graphics, lower-thirds, 
credits, and burned-in subtitles.

Duration

Displays the time duration of the audio.

Note: The order of audio tracks in the list reflect the order of the tracks in the source 
file when in inspect mode, and the order of the tracks in any export files when in Edit 
mode.

See Setting Audio Track Options.
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Subtitle Tab
The Subtitle tab enables you to inspect and edit the subtitling in your media.

Add Subtitle files by opening them from the File > Open Secondary Subtitle File menu. 
Once opened it is associated with the currently open primary video file. When the 
subtitle file displays in the subtitle tab list, select it to display its controls.

To access the Subtitle tab, open the Media Inspector by selecting Window > Show 
Inspector, then click the Subtitle tab. Alternatively, you can select Inspect > Subtitles.

Format

Displays the type of subtitling used in your media.

Language

Select which language the subtitles are written in from the Language drop-down 
menu.

Timecode Format

To interpret the display time of the subtitles, select a timecode format from the menu. 
You can change the timecode format only for SCC, SRT, LambdaCAP, or VTT files.

Start

Displays the start time of SCC subtitles. This field allows you to re-synchronize some 
subtitles with the video by adjusting the start timecode. You can re-synchronize the 
following file types: PAC, MCC, STL, TTML, and DFXP.

Duration

Displays the time duration of the subtitles.

Other

Displays metadata.

See Opening the Subtitle Tab and Opening a Subtitle File.
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Time Tab
The Time tab provides controls for setting the trimming and chapter markers. This 
includes timing controls (In, Out, and Length) and chapter controls.

Trim Lets you choose where a video clip begins and ends by setting trim points. The 
time format is: hours, minutes, seconds, fractional seconds (hh:mm:ss:fs).

 

Note: Cut, Copy, Paste, Delete, and Select All can be used to edit fields in Edit boxes. 

Time tab

Click to add Trim

Click to add Chapters

In marker

Edit bar

Out markerPlay Head
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Chapters Enables you to create entry points (chapters) in your media.

Flags Tab
The Flags tab enables you to edit the flags stored in FLAGS files.

Flags

Lets you flag start and end points in your video for the placement of captions. Switch 
displays the flag time in any of these formats: frame count, timecode, or HH:MM:SS:FS 
(fractional seconds).

• To set the start or end point of the flagged section of your video, enter the time and 
click the Go button. Alternatively, you can title a flag by entering a title into the Title 
field.

Details

This field is for a description of the flag longer than can fit in the Title field.

See Opening the Flags Tab.

Click plus icon to add a chapter marker

Click minus icon to remove a chapter marker

Click Go to go to chapter marker

Flags tab

Click on flag to change color

Add a title (optionally)

Set switch to edit

Click plus (+) to add a flag
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MIT License

Copyright (c) 2023 Telestream, LLC

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the Software), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED AS IS, WITHOUT WARRANTY OF ANY KIND, 
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES 
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT 
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, 
WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING 
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR 
OTHER DEALINGS IN THE SOFTWARE.
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