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Preface
Copyrights and Trademark Notices
Copyright © 2015 Telestream, LLC. All rights reserved. No part of this publication may 
be reproduced, transmitted, transcribed, altered, or translated into any languages 
without the written permission of Telestream. Information and specifications in this 
document are subject to change without notice and do not represent a commitment 
on the part of Telestream.

Telestream, CaptionMaker, Episode, Flip4Mac, FlipFactory, Flip Player, Lightspeed, 
ScreenFlow, Switch, Vantage, Wirecast, GraphicsFactory, MetaFlip, and Split-and-Stitch 
are registered trademarks and Pipeline, MacCaption, and e-Captioning are trademarks 
of Telestream, LLC. All other trademarks are the property of their respective owners.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour 
logo, and the Bonjour symbol are trademarks of Apple, Inc.

MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. 
Copyright 2004 MainConcept Multimedia Technologies.

Microsoft, Windows NT|2000|XP|XP Professional|Server 2003, Vista, Media Player, Media 
Encoder, .Net, Internet Explorer, SQL Server 2005 Express Edition, and Windows Media 
Technologies are trademarks of Microsoft Corporation.

Dolby and the double-D symbol are registered trademarks of Dolby Laboratories.

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
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EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.

MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT 
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR 
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE 
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM 
MPEG LA, LLC, 6312 S. Fiddlers Green circle, Suite 400E, Greenwood Village, Colorado 
80111 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE 
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING 
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL 
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE 
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER TO (i) ENCODE VIDEO IN 
COMPLIANCE WITH THE AVC STANDARD (“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO 
THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-
COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER LICENSED 
TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY 
OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE 
HTTP://WWW.MPEGLA.COM.
Switch User Guide |165870
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MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE 
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT 
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR 
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA 
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON 
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT 
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers
Telestream, LLC. (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), is free from defects in materials and workmanship under normal 
operating conditions and use.

Software—If software is supplied as part of the product, the software will operate in 
substantial conformance with specifications set forth in its product user's guide. The 
Company does not warrant that the software will operate uninterrupted or error-free, 
will meet your requirements, or that software errors will be corrected.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality.

Software—If software is supplied as part of the product and it fails to substantially 
confirm to its specifications as stated in the product user's guide, the Company shall, at 
its own expense, use its best efforts to correct (with due allowance made for the nature 
and complexity of the problem) such defect, error or nonconformity.

Software Updates—If software is supplied as part of the product, the Company will 
supply the registered purchaser/licensee with maintenance releases of the Company’s 
proprietary Software Version Release in manufacture at the time of license for a period 
of one year from the date of license or until such time as the Company issues a new 
Version Release of the Software, whichever first occurs. 

To clarify the difference between a Software Version Release and a maintenance 
release, a maintenance release generally corrects minor operational deficiencies 
Switch User Guide |165870
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(previously non-implemented features and software errors) contained in the Software, 
whereas a Software Version Release adds new features and functionality. The Company 
shall have no obligation to supply you with any new Software Version Release of 
Telestream software or third party software during the warranty period, other than 
maintenance releases.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, LLC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product.

Damages
TELESTREAM, LLC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.
Switch User Guide |165870
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Further information regarding this limited warranty may be obtained by writing:

Telestream, LLC.
848 Gold Flat Road
Nevada City, CA 95959

You can call Telestream via telephone at (530) 470-1300.

Telestream Contact Information
To obtain product information, technical support, or provide comments on this guide, 
contact us using our web site, email, or phone number.

Table 1. Telestream Contact Information

Resource Contact Information

Telestream Technical 
Support

Web site:  www.telestream.net/telestream-support

Support Email: desktopsupport@telestream.net

Telestream, LLC. Web site:  www.telestream.net

Sales and Marketing Email: info@telestream.net

Telestream, LLC. 
848 Gold Flat Road
Nevada City, CA. USA 95959

International 
Distributor Support

Web site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriters@telestream.net

If you have comments or suggestions about improving 
this document, or other Telestream documents—or if 
you've discovered an error or omission, please email us.
Switch User Guide |165870
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Overview
Introduction
Switch is a professional media player that plays files and allows you to inspect and edit 
them. Switch opens and plays virtually any media file, displays detailed information 
about that file, and lets users make changes to the file - saving time and ensuring 
higher accuracy in media inspection. 

The built-in inspector displays information about your media such as audio channels, 
speaker labels, aspect ratio, clean aperture, bitrate, metadata, encoding formats and 
more. Edit mode enables modifications including trim, resize, and crop; changing 
aspect ratio; rearranging audio tracks; editing speaker assignments. You can also attach 
secondary audio to your video when exporting.

When Switch is unlicensed (the free Player version), it watermarks the video by placing 
the Switch logo in the upper right portion of the display. The audio is also watermarked 
with a occasional message. To remove the watermarks during playback, you must 
purchase and enter a valid Switch license serial number and activate it. There are two 
licensing levels: Plus and Pro. The Plus license removes all watermarking except for 
iTunes exporting, and of files created using J2K, DNxHR, and DNxHD video codecs.

Note: Switch will watermark your media when in transcode mode and will truncate it 
when in pass-through mode.

Topics
 Play License Restrictions

 Switch Pro Features

 Switch Pro Features

 System Requirements

 Summary of License Features
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Play License Restrictions
Playback Restrictions:

• Video watermark overlay for DNxHD, HEVC on both Mac and Windows

• Video watermark overlay for MPEG-2 on Windows only

• Audio watermark heard for AC-3 audio

Application Restrictions: 

• Can't add secondary subtitle files

• Can't enable caption decoding

• Can't display advanced metadata

Export Restrictions:

• If audio and video are in transcode mode, a watermark is added to the export.

• If either audio or video (or both) are in pass-through mode, export will be truncated 
to thirty seconds, or half the duration (if the source is less than thirty seconds).

• If audio and video are in transcode mode, and the source has AC-3 audio, export will 
have the audio watermark added.

When Switch is unlicensed. the watermark/truncation behavior is the same for iTunes 
and non-iTunes exports.

Switch Plus Features
The Switch Plus license removes watermarking on all features except iTunes exporting, 
and of files created using J2K, DNxHR, and DNxHD video codecs.  The Plus license also 
enables Captions and the playback of STL, and enables Audio Levels.
Switch User Guide |
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Switch Pro Features
The Switch Pro license enables all the features of the Plus license along with iTunes 
exporting and creation of files created using J2K, DNxHR, and DNxHD video codecs. 
The Pro license also enables playback through external preview devices such as SDI 
monitors, the addition of loudness meters, and deep data inspection.

The table below lists the features of Switch for Playback, Inspection, and Export.
Table 2. Switch Pro Features

Features Details

Playback

Containers AAC

AC31

AIFF

AVI (open DML)

AVC (AVC Elementary Stream)

DV

Flash

GXF

HEVC2 (HEVC Elementary Stream)

LXF

MOV3

M1V (MPEG-1 Video Elementary Stream)

M2V (MPEG-2 Video Elementary Stream)

MP3 (MPEG Layer 1,2,3 Audio Elementary Stream)

MP4 (ISO Base Media Format)

MPG (MPEG-1 System Stream)

MPS (MPEG-2 Program Stream)

MTS (MPEG-2 Transport Stream)

MXF (OP-1a; AS02, AS03, AS11)

MXF (OP-Atom)

MXF (OP-1a proxy)

MXF (OP-1b)

SCC4

TIFO

WAV
Switch User Guide |
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Video Codecs Apple ProRes

DV 25

DVCPro 25

DVCPro 50

DVCPro 100

DVCPro HD

DNxHDX

DNxHR 

H.263

H.264

H.2651

JPEG

MPEG-1

MPEG-2

MPEG-4

Uncompressed YUV

Audio Codecs AAC

AC31

MPEG Audio Layer 1,2,3

Microsoft ADPCM

G.711 aLaw

G.711 uLaw

G.726

PCM3

Captions/Subtitles

Navigation Step, skip or jump forward/reverse navigation, JKL 
playback, command/period stepping, slow motion 
playback.

Loop, instant replay navigation

Position display Frame number / timecode

Inspection

Table 2. Switch Pro Features

Features Details
Switch User Guide |
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System Requirements
OS Version:  and later.

CPU:  2.4 Ghz Core 2 Duo or faster.  Any Core i3, i5, or i7 

RAM:  4 GB (minimum) 

Display: 1280 x 768 or larger, 50 Hz or faster

Video & audio property 
inspection

Video and audio formats, bitrates, subsampling, Color 
Space, language, duration, frame rate, encoded size, 
Clean Aperture, aspect ratio, display size, metadata, 
audio tracks and channels, audio sample rates, 
secondary audio files, secondary subtitle files

Property pass-through Yes

Export

Editable properties Crop, resize, change clean aperture, change pixel aspect 
ratio, change colorimetry, down-mix (audio)

Video Encoding Format 
support

Apple ProRes

iTunes Asset Preparation Built-in packaging presets for iTunes store package

Table 2. Switch Pro Features

Features Details
Switch User Guide |
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Summary of License Features
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Installing Switch
Introduction
This section will demonstrate how to install, remove, update, and customize Switch.

Note: Switch installers are available at:  www.telestream.net

Topics
 Installing Switch
 Uninstalling Switch
 Updating/Activating/Deactivating Switch
 Opening Switch

Installing Switch
When installing Switch you must log on with administrator rights and provide your 
administrator name and password during installation. To install Switch, follow these 
steps:

1. Download the DMG file from the Website at:
http://www.telestream.net/switch/overview.htm

2. If you have an older version of Switch already installed on your computer, the 
installer upgrades to the newer version. Agree to the license terms and follow the 
instructions displayed by the installer program.

3. Locate and double-click the Switch DMG file in your Downloads folder.

    

Double-click

http://www.telestream.net
http://www.telestream.net/switch/overview.htm
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4. Click and drag the Switch icon into the Applications folder.

       

There will be a Switch application in your Mac Applications folder. You can run Switch at 
any time by clicking the application icon. You can also drag the icon to your dock for 
easy access in the future.

         

Uninstalling Switch
To uninstall Switch:

1. Close Switch by selecting Switch > Quit Switch.

2. Click and drag Switch from the Applications folder to the trash icon.

Click and drag icon

Click application icon

Drag Switch 
to trash
Switch User Guide | 165870
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Updating/Activating/Deactivating Switch
To check for software updates, see Update in the Preferences and Updates section.

To activate a serial number for Switch, see Activating a Serial Number in the Preferences 
and Updates section.

To deactivate a serial number for Switch, see Deactivating a Serial Number in the 
Preferences and Updates section.

Opening Switch
After you have installed Switch (See Installing Switch), you can open Switch by clicking 
the Launchpad icon in the tool bar at the bottom of the desktop.

     

In Launchpad, find the Switch icon and click it to open Switch.

     

When Switch opens it displays a welcome screen. You can watch an introductory video, 
browse the user guide, visit the Telestream Website, or open a media file. To open a 

Click Launchpad

Click Switch
Switch User Guide | 165870
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media file, select a recently opened file and click Open. If you do not have any recent 
files, or if you want to open another file, click Open Other to navigate to a media file.

If you click Open Other, a navigation window displays. Navigate to the location of your 
file and click Open.

   

Select a recent file

Select help

Click Open

Click Open Other
Click to exit

Navigate to 
file location

Click Open
Switch User Guide | 165870
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Opening Files
Introduction
This section presents how to open media files as primary or secondary files (audio and 
subtitle files), or open recently accessed files. It also describes how to associate and 
close media files. 

Topics
 Opening Files
 Opening Secondary Files
 Opening Recent Files
 Closing Files

Opening Files
Select File > Open File, (or press the command + O keys), to open a media file in Switch. 
When the Open dialog box displays, navigate to the file you want to open, and click 
Open. Click Cancel if you decide to not open any media files. 

The file navigation window provides a variety of display and sorting options. These are 
accessed by clicking the icons at the top of the window.

Opening Secondary Files
You can open a Secondary audio file by selecting File > Open Secondary Audio File, or a 
Secondary Subtitle file by selecting File > Open Secondary Subtitle File. When the Open 
dialog box displays, navigate to the secondary file you want to open, and click Open. 
Click Cancel if you decide to not open a secondary file. 

Secondary audio and subtitle files play along with the primary media file you have 
open. These are useful for supplying background audio for a video that has no 
embedded audio, or for supplying subtitles for a video that has no embedded subtitles. 
You can open up to 28 secondary files.
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Opening Recent Files
You can re-open previously opened media files by selecting File > Open Recent. This 
displays a list of your most recently accessed media files. Every time a file is opened or 
exported it is entered into the list. You may also (optionally) clear the menu list by 
selecting Clear Menu.

Closing Files
To close a file, first select (make active) the media window displaying it, then select 
File > Close.
Switch User Guide | 165870
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Media Playback
Introduction
This section presents how to playback media files using Switch. Playback is controlled 
using a Play Bar. A complete set of controls are provided through the Control menu.

Topics
 Play Bar
 Audio Control

Play Bar
The easiest way to control the playback of your media is through the Switch Play Bar. 
The features of the Play Bar are described below.

 

Play/Pause Click the play/pause button to play the video; click again to pause it.

Scrubber/PlayheadPlay/Pause Time RemainingElapsed Time Volume Control

Play 
Bar
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Note: In addition to clicking Play/Pause on the Play Bar, you can also play and pause 
by pressing the spacebar. It acts as a toggle between play and pause modes.

Elapsed Time Displays how long the video has been playing. Click the time display to 
change display mode: Time, Frame Counter, or Time Code. 

Scrubber/Playhead  Click and slide to change the location in the video you are 
viewing. You can also click on any position in the scrubber timeline to jump the 
playhead to that location.

Time Remaining Displays time remaining for the video to play. Display is shown in 
either seconds or frames depending on the Elapsed Time display mode (Time, Frame 
Counter, or Time Code).

Volume Control Click the speaker icon to mute or un-mute the audio. Click and slide 
the bars icon to increase or decrease the volume.

Control Menu
Switch also provides a complete set of playback controls through the Control menu. 
The Control menu includes play, rewind, fast and slow motion, jump, skip, and loop 
controls. 

Play  Starts playing your selected media. When a media is playing the Play menu item 
changes to Pause. To pause a media, select Pause. Select Play again to restart it.

Play All  Starts playing all open media files. 

Play Forward  Plays your selected media forward at normal or increased speed. 
Pressing the “L” key also plays your media forward. Repeated “L” key presses increases 
the play speed up to 16x.

Stop Stops forward or backward playing of your media. Pressing the “K” key also stops 
media playing. If your media is playing at increased speed when Stop is selected (or the 
“K” key is pressed), any new playing of media will be at normal speed (the increased 
speed is not remembered).

Play Backward  Plays your selected media backward at normal or increased speed. 
Pressing the “J” key also plays your media backward. Repeated “J” key presses increases 
the play speed up to 16x.
Switch User Guide | 165870
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When a media is playing at increased speed, the speed is displayed in the upper left 
corner of the window.

Slow Motion Forward enables you to forward play video at one-half of normal speed. 
You can also press the Ctrl+ L keys. If your media is playing in slow motion when Stop is 
selected (or the “K” key is pressed), any new playing of media will be at normal speed 
(the slow motion is not remembered).

Slow Motion Backward enables you to backward play video at one-half of normal 
speed. You can also press the Ctrl+ J keys. If your media is playing in slow motion when 
Stop is selected (or the “K” key is pressed), any new playing of media will be at normal 
speed (the slow motion is not remembered).

Step Forward Steps forward in the video, one frame at a time. You can also press the 
right arrow key to step forward. The L, K, and J keys (Backward, Stop, and Forward) 
remain active.

Step Backward Steps Backward in the video, one frame at a time. You can also press 
the left arrow key to step backward. The L, K, and J keys (Backward, Stop, and Forward) 
remain active.

Skip Forward (1 sec) Moves the video one second ahead. You can also press the 
Ctrl+Right Arrow keys.

Skip Forward (10 sec) Moves the video ten seconds ahead. You can also press the 
Ctrl+Alt+Right Arrow keys.

Skip Backward (1 sec) Moves the video one second backward. You can also press the 
Ctrl+Left Arrow keys.

Skip Backward (10 sec) Moves the video ten seconds backward. You can also press the 
Ctrl+Alt+Left Arrow keys.

Next Chapter Enables you to jump to the next chapter location.

Previous Chapter Enables you to jump to the previous chapter location.

Chapters Enables you to jump to a location by selecting a chapter title from a list.

Note: The Chapter menu items (Next Chapter, Previous Chapter, and Chapter) are 
only enabled if the video has chapter markers embedded in it. If no chapter markers 
Switch User Guide | 165870



Media Playback
Audio Control

28
are present, the menu items are grayed out. Chapter markers are sometimes 
embedded in longer movie clips to divide sections of the media topically or by edit 
points. 

Loop When selected, your video plays repeatedly and the movie will play again from 
the beginning whenever it reaches the end.

Audio Control
The Audio menu enables you to control playback volume. 

Select Increase Volume or Decrease Volume to change the audio volume level, or select 
Mute to silence it entirely. You can also mute all non-active media windows by selecting 
Mute Inactive Windows. Additionally, you can mute all audio, or just the audio of 
selected files, tracks or channels by selecting Mute Files, Mute Tracks, or Mute Channels. 
Select Solo Files, Solo Tracks or Solo Channels to mute all but the selected file, track or 
channel.
Switch User Guide | 165870
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Inspecting Media
Introduction
Switch allows you to either inspect or edit your media files through a Media Inspector 
window. This section presents how to use Switch to inspect media files. (See Editing 
Media on how to edit media files).

Topics
 Media Inspector
 Container Tab
 Video Tab
 Audio Tab
 Subtitle Tab
 Time Tab

Media Inspector
The Media Inspector window enables you to inspect or edit your media files. To open 
the Media Inspector window, select Window > Show Inspector.

Note: If Hide Inspector  is displayed as a menu item, it means that the Media Inspector 
is already open.

The Media Inspector window can also be opened by selecting one of its five tabs from 
the Edit menu.

       

Container tab

Video tab

Audio tab

Time tab

Subtitles tab
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The media Inspector window has five Media Inspector tabs: Container, Video, Audio, 
Subtitles and Time. There is also a switch that enables you to select either Inspect or 
Edit mode.

Common to all five tabs is an Export menu at the bottom of the inspector window. You 
can export your video at any time by selecting one of the menu items: Movie, iTunes 
Store Package, or Current Video Frame. This is the same as the Export menu at the top 
of the Switch media window.

Inspect/Edit Mode Switch
The Inspect/Edit mode switch enables you to select either Inspect or Edit mode. When 
the switch is in Inspect mode, settings cannot be edited -- they can only be inspected 
(viewed). When the switch is in Edit mode, settings can be edited. You can export your 
media in either mode.  See Exporting Media for details on how to export media files.

Container tab
Video tab

Audio tab
Subtitles tab

Time tab
Mode switch

Export menu
Switch User Guide | 165870
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Container Tab
The Container tab provides a way to inspect the container for your media (name, 
location, size, type, etc.). To access the Container tab, open the Media Inspector by 
selecting Window > Show Inspector, then click the Container tab.

You can also display the Container tab by selecting  Edit > Container.

File Controls
Name Displays the filename of your media. To change the file name, consult the Editing 
Media section.

Directory Select a location (directory) for your media file from the list displayed in the 
drop-down menu.

Size Displays the size of the media file (when known).

Type Displays the container type. To change the container type, consult the Editing 
Media section.

Duration Displays the duration of the media file (when known).

Created Displays the date when your media file was created.

Modified Displays the date when your media file was last modified.

Container tab
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Metadata and Secondary Audio/Subtitles
Metadata and Secondary Audio/Subtitles are displayed along with information about 
them. To add metadata, secondary audio, or secondary subtitles, see Metadata and 
Secondary Audio/Subtitles in the Editing Media section.

To view an embedded DPP file content, select the file name from the list at the bottom 
of the Metadata window, then click the gear icon and select Show XML Metadata 
Content from the drop-down menu.

The metadata content displays in a window: 

Select DPP file name

Click Gear icon

Select Show XML 
Metadata Content
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Video Tab
The Video tab provides inspection of the video portion of your media (video format, 
size, rate, etc.). To access the Video tab, open the Media Inspector by selecting Window 
> Show Inspector, then click the Video tab.

You can also access the Video tab by selecting Edit > Video.

Format Displays the video format of your media file. To change the format, consult the 
Editing Media section.

Bit Rate Displays the video bit rate (when available).

Subsampling Displays the subsampling ratio.

Color Space Displays the Color Space. To change the Color Space, consult the Editing 
Media section.

Language Displays the language used in metadata. To change the language, consult 
the Editing Media section.

Duration Displays the time duration of the video.

Rate Displays the video rate in FPS (frames per second). To change the rate, consult the 
Editing Media section.

Encoded Size Displays the encoded media file and whether it is HD, UHD, SD, etc.

Clean Aperture Displays the Clean Aperture setting. To change Clean Aperture, 
consult the Editing Media section.

Video tab
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Aspect Ratio Displays the aspect ratio. Click the eye icon on the right side to see a 
preview the aspect ratio setting. To change the Aspect Ratio, consult the Editing Media 
section.

Display Size Displays the size (resolution) of the video after crop, resize, etc. are 
applied. Also displays whether the video is HD,UHD, SD, etc.

Video Properties Displays video metadata.

Audio Tab
The Audio tab enables you to inspect the audio portion of your media. This includes 
channel, format, bitrate, duration, etc. To access the Audio tab, open the Media 
Inspector by selecting Window > Show Inspect, then click the Audio tab. You can also 
select Edit > Audio.

Program Displays the type of audio channel (Stereo, 5.1 Audio, etc.). Click the down 
arrow on the right to display channel settings. For some channel selections, you can 

Audio tab

Audio settings
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also change the speaker name. To do this, click on the current speaker name and then 
select a new name from the displayed list.

Format Displays audio codec used.

Bit Rate Displays the audio bit rate.

Sample Rate Displays the sample audio rate (44.1Khz or 48Khz).

Language Displays the language to use in metadata.

Duration Displays the time duration of the audio.

Subtitle Tab
The Subtitle tab enables you to inspect the subtitling in your media. 

Subtitle files are added by opening them from the File > Open Secondary Subtitle File 
menu. You can add up to 28 files, but only the subtitles from the first subtitle file are 
displayed. Once opened it is associated with the currently open primary video file. 
When the subtitle file displays in the subtitle tab list, select it to display its controls. SCC 
is the only supported format.

Note: You must have a subtitle at time 00:00:00 in your subtitle file (even if it is just a 
blank subtitle) or else your subtitles will be out of sync with your audio.

Click arrow

Select a name
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To access the Subtitle tab, open the Media Inspector by selecting Window > Show 
Inspector, then click the Subtitle tab. You can also select Edit >Subtitles.

Format Displays the type of subtitling used in your media. 

Language Displays which language the subtitles are written in. 

Duration Displays the time duration of the subtitles.

Other Displays metadata.

Time Tab
The Time tab enables you to inspect the timing portion of your media (In, Out, Length, 
and chapter controls). To access the Time tab, open the Media Inspector by selecting 
Window > Show Inspector, then click the Time tab. You can also select Edit > Time.

Subtitle tab

Time tab
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Chapters Displays entry points (chapters) in your media that you have created in 
Switch. To change the chapters, consult the Editing Media section.

Note: You can only view the chapter markers you have created in Switch. Chapter 
markers resident in the file when opened in Switch will not be visible -- even if they 
were previously created using Switch.
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Editing Media
Introduction
Switch allows you to either inspect or edit your media files through a Media Inspector 
window. This section presents how to use Switch to edit media files. (See Inspecting 
Media on how to inspect media files).

Topics
 Media Inspector
 Container Tab
 Video Tab
 Audio Tab
 Subtitle Tab
 Time Tab

Media Inspector
The Media Inspector window enables you to inspect or edit your media files. To open 
the Media Inspector window, select Window > Show Inspector.

Note: If Hide Inspector  is displayed as a menu item, it means that the Media Inspector 
is already open.

The Media Inspector window can also be opened by selecting one of its five tabs from 
the Edit menu.

       

Container tab

Video tab

Audio tab

Time tab

Subtitles tab
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The media Inspector window has five Media Inspector tabs: Container, Video, Audio, 
Subtitles and Time. There is also a switch that enables you to select either Inspect or 
Edit mode.

Common to all five tabs is an Export menu at the bottom of the inspector window. You 
can export your video at any time by selecting one of the menu items: Movie, iTunes 
Store Package, or Current Video Frame. This is the same as the Export menu at the top 
of the Switch media window.

Inspect/Edit Mode Switch
The Inspect/Edit mode switch enables you to select either Inspect or Edit mode. When 
the switch is in Inspect mode, settings cannot be edited -- they can only be inspected 
(viewed). When the switch is in Edit mode, settings can be edited. You can export your 
media in either mode. See Exporting Media for details on how to export media files.

Container tab
Video tab

Audio tab
Subtitles tab

Time tab
Mode switch

Export menu
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Container Tab
The Container tab provides a way to inspect and edit the container for your media 
including information such as: name, location, size, type. To access the Container tab, 
open the Media Inspector by selecting Window > Show Inspector, then click the 
Container tab.

You can also display the Container tab by selecting Edit > Container.

File Controls
Name Displays the filename of your media. (You can change the name of the file when 
exporting.)

Directory Select a location (directory) for your media file from the list displayed.

Size Displays the size of the media file (when known).

Type Select the container type by clicking on the double arrow and selecting a type 
from the menu:  MOV, MP4, TS, and MPEG

Duration Displays the duration of the media file (when known).

Created Displays the date when your media file was created.

Modified Displays the date when your media file was last modified.

Container tab
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Metadata and Secondary Audio/Subtitles
To add metadata, click the associated plus (+) icon and add available metadata (Album, 
Artist, Director, Year, etc). To add secondary audio and subtitle files, click the associated 
plus (+) icon and navigate to the file you want to add. To remove an added file, select it 
and click the minus (-) icon. Click the gear icon to make additional settings.

Click the Metadata gear icon to open the metadata URL or to display the metadata in 
HTML or XML format.  Click the Secondary (Audio or Subtitle) gear icon, to copy the URL 
of the audio or subtitle file, or to show its location.

Click plus icon to add a file

Click minus icon to remove a file

gear icons
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Video Tab
The Video tab provides controls for the video portion of your media. This includes video 
format, size, rate, etc. To access the Video tab, open the Media Inspector by selecting 
Window > Show Inspector, then click the Video tab.

You can also access the Video tab by selecting Edit > Video.

Video Transcode/Video Pass-Through You can select Video Transcode (use 
transcoder) or Video Pass-Through (do not use transcoder) by selecting one of these 
from the pull-down menu.

Format Displays the current video format used. When in transcode mode you can 
change the format by making a selection from the drop-down menu: H.264, H.262, and  
ProRes.

Click the down arrow to the right of the Format menu, then select the quality and enter 
any needed command line settings.

Bit Rate Displays the video bit rate (when available).

Video tab

Video controls

Pull-down menu

Enter command line settings

Click down arrow

Select Quality
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Subsampling Displays the subsampling ratio.

Color Space Select the Color space from the drop-down menu.

Language Select a language to use in metadata from the drop-down menu.

Duration Displays the time duration of the video.

Rate Displays the video rate in FPS (frames per second).

Note:  Frame rate changes (beyond those supported as part of deinterlacing) should 
be made outside of Switch.

Original Size Displays the original size (resolution) of the video and whether it is HD, 
UHD, SD, etc.

Crop The crop tool enables you to use just a selected portion of the visible picture. This 
is useful in making the picture frame smaller to fit in a Web window application.  It is 
also useful for fitting in a 4:3 or 16:9 aspect ratio that is sized smaller than the existing 
frame geometry. 

To open the cropping controls, click the down arrow. You can crop the visible area of 
your media by entering the pixel size you want, or by entering the number of pixels to 
crop in each direction of the image (left, right, top, bottom).

Resize You can resize the picture (and optionally change the aspect ratio) for devices or 
applications. Resize the video by clicking the down arrow to display the control panel 
and entering size (resolution) values. 

You can set constraints on resizing. Select Maintain Aspect Ratio or Fit To Screen from the 
Constraints menu to determine how aspect ratio changes as you resize your video. 
Select None to remove all constraints on cropping. 

Enter pixel size

Enter cropping values

Click down arrow

Enter size values

Click down arrow

Select constraints

Select mode
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If you have selected Maintain Aspect Ratio, select (from the aspect ratio menu) the 
aspect ratio to be used.

Select a display mode from the Mode menu. Your choices are: Center, Letterbox, Fill, 
and Stretch.

:

Center:  When increasing the dimensions, the video remains the same size and black is 
added on all sides as needed to fill in. When decreasing the dimensions, the video is 
cropped.

Letterbox:  The video is resized both vertically and horizontally so that each axis is less 
than or equal to the target dimensions. If one dimension is less than the target 
dimension, black is added to fill in.

Fill:  Fills the dimensions with video by scaling the video up or down, by cropping the 
video, or by adding black as needed to fill.

Stretch:  The video is resized to fit the target dimensions, ignoring the aspect ratio.  This 
may distort the video.

Clean Aperture To set Clean Aperture, click the down arrow on the Clean Aperture 
menu. Enter the desired size, left, right, top, and bottom aperture settings.

Aspect Ratio Click the down arrow to open the Aspect Ratio control panel. Select the 
aspect ratio type (PAR or DAR) from the Type menu. Select also an aspect ratio from the 
Aspect Ratio menu list.

Display Size Displays the size (resolution) of the video after crop, resize, etc. are 
applied. Also displays whether the video is HD,UHD, SD, etc.

Select an aspect 
ratio to be used

Aspect ratio menu

Select a 
display mode
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Audio Tab
The Audio tab enables you to inspect and edit the audio portion of your media. This 
includes channel, format, bitrate, duration, etc. To access the Audio tab, open the Media 
Inspector by selecting Window > Show Inspect, then click the Audio tab. You can also 
select Edit > Audio.

Audio Transcode/Audio Pass-Through You can select Audio Transcode (use 
transcoder) or Audio Pass-Through (do not use transcoder) by selecting one of these 
from the pull-down menu.

Note: When exporting to an iTunes Store Package, If you have selected Feature for the 
Asset Type, secondary audio files are included in the exported iTunes package. But if 
Preview is selected as the Asset Type, the audio files are not included in the exported 
iTunes package.

Click the plus icon to add a track. (Click minus icon to delete a selected track.) 

Audio tab

Audio controls

Click plus icon

Click gear icon
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Note: When creating a Feature iTunes package using Audio Pass-Through, the 
secondary audio files will be added separately from the primary asset. When creating a 
Preview iTunes package, secondary audio files will be ignored when using Audio Pass-
Through mode.

Click a track to edit its settings.

Program Select a type of audio channel from the Program pull-down menu (Stereo, 5.1 
Audio, etc.). Click also the down arrow on the right to display channel settings. For 
some channel selections, you can also change the speaker name. To do this, click on the 
current speaker name and then select a new name from the displayed list.

Edit settings

Click a track

Click speaker name

Select a name
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Format Select an audio codec from the pull-down menu:  LPCM, AAC-LC, 
or MPEG Layer 2.

Click the down arrow on the right of the drop-down menu, and select the format type. 
Also select Big or Small Endian.

Bit Rate Displays the audio bit rate.

Sample Rate Select a sample audio rate from the Sample Rate menu: 44.1Khz or 48Khz.

Language Select the language to use in metadata.

Duration Displays the time duration of the audio.

Subtitle Tab
The Subtitle tab enables you to inspect and edit the subtitling in your media. 

Subtitle files are added by opening them from the File > Open Secondary Subtitle File 
menu. You can add up to 28 files, but only the subtitles from the first subtitle file are 
displayed. Once opened it is associated with the currently open primary video file. 
When the subtitle file displays in the subtitle tab list, select it to display its controls. SCC 
is the only supported format.

Note: You must have a subtitle at time 00:00:00 in your subtitle file (even if it is just a 
blank subtitle) or else your subtitles will be out of sync with your audio.

Click arrow

Select Format

Click down arrow

Select Format type
Select Endian type
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To access the Subtitle tab, open the Media Inspector by selecting Window > Show 
Inspector or select Edit >Subtitles, then click the Subtitle tab.

Format Displays the type of subtitling used in your media. 

Language Select which language the subtitles are written in from the Language drop-
down menu. 

Duration Displays the time duration of the subtitles.

Other Displays metadata.

Subtitle tab

Select a Subtitle file

Select a language
Switch User Guide | 165870



Editing Media
Time Tab

50
Time Tab
The Time tab provides controls for setting the triming and chapter markers. This 
includes timing controls (In, Out, and Length) and chapter controls. To access the Time 
tab, open the Media Inspector by selecting Window > Show Inspector, or select Edit > 
Time, then click the Time tab. Click a plus (+) icon to add a trim or chapters to your 
video.

Trim Lets you choose where a video clip begins and ends by setting trim points. 

The time format is: days, hours, minutes, seconds, fractional seconds (or scale) 
(hh:mm:ss:fs/scale). You can also enter partial values and have the rest filled in 
automatically, such as entering 30 for thirty seconds. 

Time tab

Click to add Trim

Click to add Chapters
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You can set in and out markers by sliding them in the edit bar below the video. You can 
also select a video clip by moving the Play Head to a location in the video and pressing 
the “I” key to set the Mark In point, or “O” key to set the Mark Out point. The dark area 
between the two markers indicates the selected portion. 

 

Note: Cut, Copy, Paste, Delete, and Select All can be used to edit fields in Edit Boxes. 

Click the plus icon to create a trim. (Remove a trim by selecting it and clicking the minus 
icon.) Click a Go button to move the Play Head to the In or Out point.

Chapters Enables you to create entry points (chapters) in your media. Click the plus 
icon to add a chapter. The chapter entry point is created with a picture of the starting 
video frame and the timecode location. Click Go to go to that location in your video. To 
remove a chapter point, select the chapter point and click the minus icon.

In marker

Edit bar

Out markerPlay Head

Click plus icon to add a trim

Click minus icon to remove a trim

Click Go to move Play Head 

Click plus icon to add a chapter marker

Click minus icon to remove a chapter marker

Click Go to go to chapter marker
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To create a chapter thumbnail which is not the first frame of the chapter, move the 
playhead to the frame you want to use, click the plus (+) button to create the chapter, 
then adjust the time value to the intended start of the chapter.

Note: Chapters can only be created in files exported as iTunes packages, not in movie 
(.mov) files.
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Exporting Media
Introduction
This section shows you how to export media from Switch. Media can be exported as a 
movie or as an iTunes package. You can also export selected video frames as single 
pictures. 

Topics
 Exporting Media
 Exporting Movies
 Exporting iTunes Packages
 Exporting Video Frames

Exporting Media 
A powerful feature of Switch is the ability to re-encode video and export a new movie 
clip for use by other applications and many popular devices (iPhone, iPod etc.). Switch 
is also a file transcoding tool. While not having the powerful features of Telestream 
Episode or Vantage, Switch is handy for doing quick conversions of all container 
formats, audio codecs, and video codecs that are available in QuickTime.

To export media from Switch, select Export, then select the type of export you want: 
Movie, iTunes Store Package, or Current Video Frame. 

Note: You can re-encode from all QuickTime supported formats, but you cannot 
export to all QuickTime supported formats.
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Exporting Movies
To export your media as a movie, select Export > Movie. When the dialog box opens. it 
displays the Container, Video, and Audio setup information. You can change any of 
these by clicking one of the Edit buttons. Once the settings are correct, click Export.

When the Save dialog box displays, enter a filename for your movie and navigate to the 
location where you want to save your movie. Click Save when finished.

Exporting iTunes Packages
To export your media as an iTunes Store Package, select Export > iTunes Store Package. 

Note: If the video codec used is not Apple ProRes 422 (HQ), or if you are in Video Pass-
Through mode, an error message will display. You will also get an error message if the 
audio codec is not Linear PCM, or if the audio track is not 16 or 24 bit.

When the dialog box opens. it displays the Container, Video, and Audio setup 
information. You can change any of these by clicking one of the Edit buttons. Once the 
settings are correct, click Export.

When the dialog box displays, select Asset Type: Feature or Preview. The Feature asset 
type embeds the secondary audio into the package, whereas Preview does not. If you 
select Preview, select also a Preview Territory. (Preview Territory will remain grayed-out 
until Preview is selected.)

Click Edit to change settings

Click Export

Click Edit to change settings

Click Export
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Enter your provider name. (The Continue button will remain grayed-out until a provider 
name is entered.) Select also a language and locale for Metadata, Spoken language, 
and Primary Assets. Click Continue to continue.

If Switch is not licensed, a warning that the export will be watermarked is displayed. 
Click Continue to continue.

When the Save dialog box displays, enter a filename for your movie and navigate to the 
location where you want to save your movie. Click Save when finished.

Exporting an iTunes Asset Only .itmsp Package
Switch creates an asset-only .itmsp package, but you still need to enter additional 
information via iTunes Connect to complete the .itmsp package.

If you do not have an iTunes Connect Account, you have two options:  

1. Take iTunes package created by Switch to an iTunes authorized aggregator for 
delivery (https://itunesconnect.apple.com/WebObjects/iTunesConnect.woa/wa/displayAggregators?ccTypeId=7)

2. Apply for an iTunes Account (http://www.apple.com/itunes/working-itunes/sell-content/movie-faq.html)

Assets must meet iTunes Video Specification:  

• iTunes requires film to be delivered as ProRes 422 (HQ) at their native frame-rate: 
the frame-rate originally captured by the camera’s image sensor.  

• Movies are usually either 23.976, 24 or 25 fps.  This is often different form the frame-
rate that is found on tape, archived storage, NLE (Non-Linear Editor) projects or 
masters for broadcast  which are 29.97i (NTSC or 25i (PAL).  Consult with iTunes if 
the native frame rate is neither 23.976, 24 or 25 fps.  

Subtitles must be provided as an iTunes Timed Text (.itt) formatted file.  

Enter Provider Name

Select Asset Type

Select Preview Territory 
(if Preview is selected above)

Select Language and Locale

Click Continue

Click Continue
Switch User Guide | 165870



Exporting Media
Exporting Video Frames

56
The following settings are required for iTunes delivery

• ProRes 422 (HQ)

• 4:2:2: color space

• 1920 x 1080 1:1 (square) pixel aspect ratio for HD

Must begin and end with at least one black frame

5.1 audio when available in-addition to the stereo track

Audio source in Linear PCM 16 or 24 bit at 48Khz

Closed Caption or English iTT Subtitle required for distribution in U.S. iTunes Store

SD Assets:   User must select the correct Aspect Ratio when SD assets are selected.

Chapters:  The first chapter stop must be at 00:00:00. If using a frame-accurate 
timecode format, the first chapter stop must be at 00:00:00:00.

Accessibility XML:  User must review the XML and make necessary edits to following 
asset and accessibility tags.  Please refer to the "Vendor Tool Guide” for additional 
information. 

Asset:

<attribute name="image.textless_master"></attribute>

<attribute name="image.burned_subtitles.locale"></attributes>

<attribute name="image.burned_forced_narrative.locale"></attribute

Accessibility:

<accessibility_info>

<accessibility_role="captions" available=" "/>

<accessibility role=<"captions" available=false" reason_code" "/>

</accessibility info>

Exporting Video Frames
To export a single frame of your media, pause your media and select Export >Current 
Video Frame. When the Save dialog box displays, enter a filename for your video frame 
then navigate to the location where you want to save your video frame as a picture. 
Click Save when finished.
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Getting Help
Introduction
This section presents how to get help using Switch. This includes online help, PDF help 
documents, and obtaining customer service support. 

Topics
 Getting Help
 Searching for Help
 User Guides
 Purchasing Switch
 Customer Support
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Getting Help
To get help using Switch, select the Help menu. This menu enables you to search for 
help by topic, open the user guide, purchase Switch, or get customer support help.

Searching for Help
You can search the help system for any topic or key word. Enter your request and press 
the Enter key. This displays a window that enables you to select related menu items or 
help topics. Possible menu item selections are displayed with a pointer, 

    

Note: As long as there are characters in the Search field, the other Help menu items 
will not display even if you reopen the Help Menu.  To redisplay the Help Menu, select 
a search item or delete all characters from the Search field.

User Guides
Select Switch Help to open the online help version of the Switch User Guide, or select 
Switch User Guide to open the PDF version of the User Guide.

Enter help top

Make selectio

Menu item 
pointer
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Purchasing Switch
Click Buy to open a browser window of the Telestream product purchasing Web page. 
When the Telestream store Web page displays, enter quantity and click Add To Cart to 
make your purchase. You will receive a serial number in a confirmation email.

The Switch Preferences window is also opened so that you can activate your new 
purchase. Once you have obtained your product serial number, enter it into the Serial 
Number field in the Preferences window, then click Activate.

Customer Support
To report a problem with Switch, first select the window displaying the media file you 
want to report, then select Report Problem File in the Help menu. 

Enter quantity Click Add To Cart

Enter serial 
number

Click Activate
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When the reporting dialog window opens, click the Report button to send a technical 
report of your file to the Telestream support team. Click Cancel to abort this reporting 
action.

If your report is successfully sent, a confirming browser window will display. Click 
Submit Feedback to open a new support case.

Select Gather Support Information from the Help menu to collect and send information 
about Switch when you encounter problems. When the process finishes collecting 
information, enter your support case number and click Reveal.

Click Submit Feedback

Enter support case number

Click Reveal
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Support information is gathered and saved in a file to your Mac desktop. A unique 
filename is generated. Sending this file to Telestream enables the support team to 
diagnose any problems you have reported. 

Select Contact Support to open the Switch Support page on the Telestream Website. 
Select Visit Switch Website to open the Switch Product page on the Telestream Website. 
Select Acknowledgments to open the Acknowledgments page on the Telestream 
Website.
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Preferences and
Updates

Introduction
This section describes how to set preferences in Switch, how to check for updates, and 
how to set services preferences.

Topics
 Setting Preferences

– Update

– License

 Check for Updates
 Services Preferences

Setting Preferences
To set preferences in Switch, select Switch > Preferences. The preferences window 
enables you to change the update interval and activate/deactivate licenses.

Update
To use Switch Preferences to check for software updates (manually or at scheduled 
intervals) follow these steps:

1. Select Switch > Preferences, then click the Update icon.

2. To change the interval at which Switch checks for updates, choose Daily, Weekly, 
Monthly or Never from the Check For Updates menu.
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3. To check for updates manually, click Check Now.

You can also check for updates by selecting Switch > Check for Updates. 

License
During unlicensed playback, DNxHD and HEVC/H.265 are watermarked placing a 
transparent Switch logo in the upper right portion of the display. No other video 
codecs are watermarked during playback. Additionally, an audio watermark in 15 
second intervals will be added to all media using Dolby AC-3 audio.

To remove the watermark during playback, you must purchase and enter a valid serial 
number and activate it. 

All unlicensed video exports are watermarked in transcode mode. Exports are truncated 
when either audio and/or video are in pass-through mode. Licensed exports have no 
watermark or truncation. Truncation is set at 30 seconds, or half the duration of the 
media if less than 30 seconds long.

Activating or deactivating a license while a video is open will cause the video display to 
change accordingly and immediately.

Activating a Serial Number
If your computer is connected to the Internet and you purchased an upgrade via the 
Telestream Store online, use the email receipt (which contains your serial number) to 
manually activate Switch. Manual activation is also used for activating a serial number 
in Switch on another Mac.

To enable the upgraded features, or activate additional copies of Switch, you must have 
access to the Internet. Your serial number must be manually entered to activate the 
features purchased.

Note: If your computer does not have Internet access, do not use this process. 
Instead, use a separate computer with Internet access to open the Manual Activation 

Click Check 
Now

Click Update

Select interval
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Guide on the Telestream Web site (www.telestream.net/pdfs/user-guides/
Manual_Activation_Guide.pdf). This is a step-by-step guide to manually activate Switch.

1. Select Switch > Preferences, click the License icon, enter your serial number, then 
click Activate. (When the serial number is entered correctly, the Activate button is 
enabled.) 

 

Enter the serial number exactly as it exists in your email receipt. It is best to copy and 
paste the serial number to avoid typing mistakes. When typing it in, be sure to enter 
only zeros (no letter O's), capitalize all letters, and include all hyphens. The Telestream 
Store is contacted and the serial number for your computer is activated.

Note: If you experience problems activating, contact Telestream Customer Support 
at: desktopsupport@telestream.net or 877-681-2088.

Deactivating a Serial Number
A Switch serial number can only be active on one computer at a time. But, you can 
enter it on multiple computers (see Activating a Serial Number), making it available on 
all of them. Before activating Switch on a different computer, you must deactivate 
where ever it is currently activated. In other words, you can deactivate it and then 
activate it elsewhere as needed. This makes the use of the serial number more flexible, 
and avoids unnecessarily purchasing extra licenses.

To deactivate a Switch serial number, Select Switch > Preferences, click the License icon, 
then click Deactivate.

        

Click Activate

Click License.

Enter serial 
number

Click Deactivate

Click License
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When you deactivate your serial number on your computer, it must have Internet 
access. Deactivation enables you to activate this same serial number on another 
computer. You can also change licensing by clicking Change and entering a different 
serial number.

Check for Updates
To check for the latest Switch updates, select Switch > Check for Updates. This selection 
directs you to the Update tab in Switch preferences. (See Update in the Setting 
Preferences section for details.)

Services Preferences
Switch Services Preferences are available through the Switch menu. To access these 
preferences, select Switch > Services > Services Preferences. 

When the dialog window displays, click either the Keyboard or Keyboard Shortcuts tab.
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Keyboard Tab
Click the Keyboard tab to display keyboard controls. Set the key repetition speed by 
sliding the Key Repeat slider to Fast, Slow, or Off. Set the amount of delay until a pressed 
key repeats by sliding the Delay Until Repeat slider to Short or Long.

        

Optionally, check Use all function keys to use the special features printed on the keys. 
Check Show Keyboard to display the Keyboard and Character Viewers in the menu bar. 
Click Input Sources to select input source characteristics (language, text, and region).

Click Modifier Keys to display a control panel that allows you to map the action of each 
modifier key (Caps Lock, Control, Option, Command). Click Restore to restore all 
modifier keys to their original settings. Click OK when finished.

        

Check 
checkboxes 
(optionally)

Click Keyboard

Slide sliders

Click OK 

Map key actions
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Shortcuts Tab
Click the Shortcuts tab to set and restore keyboard shortcuts. 

     

Click Keyboard 
Shortcuts
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Introduction
Switch has nine menus that provide access to all its controls and features. This section 
describes the functionality of each menu item in Switch.

Topics
 Switch Menu

 File Menu

 Edit Menu

 Control Menu

 Audio Menu

 View Menu

 Export Menu

 Window Menu

 Help Menu

Switch Menu
About Switch Displays the version of Switch you are running.

Preferences Opens the Preferences window. If the Preferences window is already open, 
it becomes the active window.

Services Presents the Macintosh Services available.

Hide Switch Hides the Switch application window (leaves other window displayed).

Hide Others Hides all application windows (leaves the Switch window displayed).

Show All Shows all application windows.

Switch menus
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Quit Switch Closes all files and exits.

File Menu
Open  Displays the Open dialog window for opening a media file.

Open Secondary Audio File Opens a Secondary Audio files that plays along with the 
currently open primary media file.

Open Secondary Subtitle File Opens a Secondary Subtitle files that plays along with 
the currently open primary media file.

Open Recent Displays the most recently accessed media files. Every time a file is 
opened or saved it is entered into this list.

Close Window Closes the currently active media file window.

Edit Menu
Undo Reverses your last change in Switch. Switch offers an unlimited number of undo 
actions (within computer memory limitations). Undo information is stored on a per-
window basis. Also, if you close window then reopen it, your undo information is lost. 
Undo does not undo edit actions.

Redo Reverses your last undo action. Switch offers an unlimited number of redo 
actions (within computer memory limitations). Redo information is stored on a per-
window basis. Also, if you close window then reopen it, your redo information is lost. 
Redo does not re-do edit actions.

Cut Copies (and removes) the selection and stores it on the clipboard allowing you to 
paste it into a selected target.

Copy Copies (but does not remove) the selection and stores it on the clipboard 
allowing you to paste it into a selected target.

Paste Duplicates the content in the clipboard into the currently selected location. 
Media is placed in the clipboard using Cut and Copy. 

Select All Selects all items in the currently active window. 

Container Opens the Container tab in the Media Inspector window. 

Video Opens the Video tab in the Media Inspector window. 

Audio Opens the Audio tab in the Media Inspector window. 

Subtitles Opens the Subtitles tab in the Media Inspector window. 

Time Opens the Time tab in the Media Inspector window. 

Set Mark In Sets the Mark In location in your media file. 

Set Mark Out Sets the Mark Out location in your media file..
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Control Menu
Play/Pause Plays the selected media file. When playing, the word Pause is displayed 
and when selected causes the media to stop playing. When paused, the word Play is 
displayed.

Play All Plays all open media files.

Play Forward Causes the selected media to progressively (each time selection is made) 
play faster in forward direction. 

Stop Causes the selected media to stop playing. 

Play Backward Causes the selected media to progressively (each time selection is 
made) play faster in backward direction. 

Note: Play Backward, Stop, and Play Forward are controlled by keyboard shortcuts J, K, 
and L (key presses), respectively.

Slow Motion Forward Places the currently playing media into forward slow motion 
mode. Slow motion can also be started while paused. 

Slow Motion Backward Places the currently playing media into backward slow motion 
mode. Slow motion can also be started while paused. 

Step Forward Moves selected media forward one frame.

Step Backward Moves selected media backward one frame.

Skip Forward (1 or 10 sec) Moves selected media forward one or ten seconds. 

Skip Backward (1 or 10 sec) Moves selected media backward one or ten seconds.

Next Chapter Moves media to the next chapter.

Previous Chapter Moves media to the previous chapter. 

Chapters Displays list of chapters. Moves media to selected chapter.

Jump To End Moves current location in media to last frame. If the media is playing, it 
will continue playing. If it is paused, it will continue to be paused.

Jump To Start Moves current location in media to first frame. If the media is playing, it 
will continue playing. If it is paused, it will continue to be paused.

Loop When checked (selected), media loops back to start when end is reached.

Audio Menu
Increase Volume Turns the media volume up.

Decrease Volume Turns the media volume down.

Mute Mutes the media audio.
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Mute Inactive Windows Mutes all inactive windows (active window remains 
unmuted).

Mute Files Mutes all audio tracks in the selected file.

Mute Tracks Displays a list of tracks. Select a track to mute.

Mute Channels Displays a list of channels. Select a channel to mute.

Solo Files Solos all audio tracks in the selected file.

Solo Tracks Displays a list of tracks. Select a track to solo (all others are muted).

Solo Channels Displays a list of channels. Select a channel to solo (all others are 
muted).

Loudness Type Selects the loudness type:  Gated or Ungated.

Play Through External Preview Device  Select to play audio through the selected 
External Preview device. Audio will only be played through the external preview device 
when external preview is enabled.  Also, the video must match a standard broadcast 
format, otherwise audio will be played though the default system audio device

View Menu
Enter Full Screen Cause the active media window to display full screen. To return to 
original window size, press the Escape key. 

Half Size Changes the size of the selected media to half of its actual size. 

Actual Size Changes the size of the selected media to its actual size.

Double Size Changes the size of the selected media to twice its actual size.

Fit to Screen Changes the size of the selected media to the max size of the screen.

Increase Size Increases the size of the selected media. 

Decrease Size Decreases the size of the selected media.

Time Display Changes the time display on the selected media.

Enable/Disable Closed Captions Enables decoding of embedded captioning. (Select 
again to disable them.)

Note: Enable/Disable Closed Captions requires a Switch Plus license

Subtitle Source Enables you to select a subtitle source.

Enable/Disable External Preview Enable or disable the selected External Preview 
device.

External Preview Device Selects an External Preview device. Switch currently supports 
the following external preview devices: AJA T-TAP, AJA ioXT, AJA io4K, AJA Kona 3G, AJA 
Kona 4.  Other AJA devices may work as well. The source video must match a format 
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that is supported by the external preview device that you have selected or external 
preview will not occur.  Users can refer to the device manufacturer's specifications for a 
list of supported formats for each device. External preview currently only works in 
Preview mode, not in Edit mode.

Note: External Preview requires a Switch Pro license

Show/Hide Gutters Displays or hides (toggle action) the gutters on the active media 
window.

Pixel Aspect Ratio When checked, uses the Aspect Ratio selected on the video tab in 
the Media Inspector window. Otherwise the aspect ratio is 1:1.

Export Menu
Movie Exports media file as a movie.

iTunes Store Package Exports media file as an iTunes package.

Current Video Frame Exports currently selected frame as a picture.

Window Menu
Minimize Minimizes the front-most window.

Zoom Maximizes the front-most window.

Show/Hide Inspector Shows and hides the Media Inspector window.

Aspect Ratio 
selection

Video tab
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Show/Hide Audio Meters Displays the Audio Meters with a scale and levels.  If you 
have a Pro license, Loudness is also displayed by clicking the down arrow.  .

Show/Hide Progress Window Displays the Export Progress window. .

Show/Hide Welcome Screen Displays 

Available Windows All open windows are listed at the bottom of this menu. Selecting 
a listed window makes it the active window.

Help Menu
Search Enables you to search the help system for any topic or key word.

Switch Help Opens the online help version of the Switch User Guide.

Switch User Guide Opens the PDF version of the Switch User Guide.

Buy  Enables you to purchase Switch online.

Report Problem File Opens a reporting dialog window.  Click Report to send a report 
of your file to the Telestream support team. Click Cancel to abort.

Click down arrow
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Gather Support Information Gathers support information and enables you to save a 
file with this information to your Mac desktop. A unique filename is generated. Sending 
this file to Telestream enables the support team to diagnose any problems you have 
reported. Click Reveal when finished.

Contact Support Opens the Switch Support page on the Telestream Website.

Visit Switch Website Opens the Switch Product page on the Telestream Website.

Acknowledgments Opens the Acknowledgments page on the Telestream Website.

Enter support case number

Click Reveal
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View and Window
Controls
Introduction
This section presents how to control how Switch is displayed (viewed) and how to 
manage Switch windows.

Topics
 View Control
 Window Controls

View Control
The Switch View menu provides a number of viewing controls that adjust the size and 
manner of the selected window.

Selecting Enter Full Screen causes the selected window to expand to the full display of 
your monitor. To return to the window view, press the Escape key

Select Half Size to make the size of the selected media half of its actual size, or select 
Actual Size to restore it.

Note: Actual Size is a combination of the dimensions of the video essence in the file, 
the aperture mode, any scale edits, any crop edits, and any rotation edits.

Select Double Size to change the size of the selected media to twice its actual size. Fit to 
Screen changes it to the max size of the screen. Use Increase and Decrease Size to make 
the selected media incrementally larger or smaller.

Time Display changes the format of the time displayed in the Play Bar (see Play Bar). 
Select Time to display the elapsed time of the media in hours and minutes (03:47). 
Select Frame Counter to display it in frames (870 F). The trailing F indicates Frame 
Counter mode. Select Time Code to display the elapsed time using a format of 
hh:mm:ss:ff (03:34:17:05).



View and Window Controls
View Control

78
You can also change the time display format by clicking on the time display in the Play 
Bar.

Enable Closed Captions enables the decoding of embedded closed captions in the 
primary source file. If there is no secondary subtitle files added to the inspector, the 
Subtitle Source menu will be disabled as long as this option is disabled. From a user 
interface perspective, this will enable both the Subtitle Source menu and the Closed 
Caption submenu so that the caption track can be selected.

The Subtitle Source menu is disabled unless the user has enabled closed caption 
decoding, or a secondary subtitle file is added. If a secondary subtitle file is added to 
the inspector, this menu is enabled and the subtitle track from the secondary subtitle 
file is added to this menu. You can still select None to prevent any subtitles from 
displaying, even though this menu is enabled and secondary subtitles have been 
added to the inspector.

Show/Hide Gutters shows (or hides) the non-displayed portion of a cropped display.

Click time display

Play 
Bar

Gutters
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Select (check) Pixel Aspect Ratio to use the aspect ratio that has been selected on the 
Video tab in the Media Inspector window. Otherwise (unchecked) the aspect ratio is 
1:1.

Window Controls
To access various window controls, select the Switch Window menu.

Minimizes and Zoom enables you to minimize or zoom in on the active (front-most) 
window. 

Use Show/Hide Inspector to display (or hide) the Media Inspector window. Show/Hide 
Audio Meters displays the audio meters. Select Show/Hide Export Progress to display the 
Export Progress window. .

All currently open windows are listed at the bottom of the menu. Selecting a listed 
window makes it the active window.

Aspect Ratio 
selection

Video tab
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Reference
Introduction
This section provides important reference information including supported codecs and 
formats, and network protocols.

Topics
 Supported Codecs, Formats, & Protocols

Supported Codecs, Formats, & Protocols
The following audio and video codecs and general file formats can be processed in 
Switch.

Note: Switch can play all codecs, formats, and protocols provided by QuickTime 
including uncompressed 4:2:2 10-bit (v210) and Apple ProRes 4444 XQ. Switch for 
Windows exports Apple ProRes 422 (HQ) within iTunes Store Package only. 

 

Table 3. Switch Pro Supported Formats

Format Playback Video Playback Audio Export Video Export Audio

QuickTime (MOV) AVC, AVC-Intra, 
DNxHD, JPEG2, 
MPEG-21, 
MPEG-4, Apple 
ProRes, XDCAM

AAC, AC3, 
MPEG, PCM3

Apple ProRes PCM3

ISO Base Media Format 
(MP4)

AVC, HEVC AAC, AC3, PCM3

MPEG-2 Program Stream 
(MPS)

AVC, MPEG-21 AC3, MPEG, 
PCM3
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1 Generic MPEG-2 ('mp2v') is supported for playback and pass through only. Constrained MPEG-2 types 
(IMX, HDV, XDCAM) are supported for encoding.

2 Photo JPEG is supported, Motion JPEG (A and B) will be supported in a future release.

3 PCM 16-, 20- and 24-bit signed integer (little and big endian) support only.

4 Export of .scc files is currently only supported through iTunes Package export

MPEG-2 Transport Stream 
(MTS)

AVC, MPEG-21 AAC, AC3, 
MPEG, PCM

Windows Audio (WAV) PCM3

SMPTE 379 OP-1a (MXF) AVC, AVC-Intra, 
DNxHD, DV, 
HDV, IMX, 
MPEG-2, 
XDCAM

AAC, PCM3, 
331M

SMPTE 360 Generic 
Exchange (GXF)

AVC-Intra, DV, 
MPEG-21

PCM3

Scenarist Closed Caption 
(SCC)

SCC4

Table 3. Switch Pro Supported Formats

Format Playback Video Playback Audio Export Video Export Audio
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Portions of this software may utilize the following copyrighted material, the use of 
which is hereby acknowledged:

x264 The product is manufactured by Telestream, LLC under license from x.264 LLC 

Main Concept © 2013 Rovi Corporation. All rights reserved. MainConcept is a 
subsidiary of Rovi Corporation. 

Apple QuickTime, MacOS X, and Safari are trademarks of Apple, Inc. Bonjour, the 
Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

Matt Gemmell Includes MAAttachedWindow code by Matt Gemmell.
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Play/Pause 25
Preferences

General 63
License 64
Update 63

R
Resize 44

S
Scrubber 26
Secondary Audio/Subtitles 32, 42
Serial Number

Activating 21
Deactivating 21

Services 66
Slow Motion 27
Starting Switch 21
Step Forward/Backward 27
Subtitle Tab 35, 48
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