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Preface

Copyright and Trademark Notice
Copyright © 2021 Telestream, LLC and its Affiliates. All rights reserved. Telestream
products are covered by U.S. and foreign patents, issued and pending. Information in
this publication supersedes that in all previously published material. Specification and
price change privileges reserved. TELESTREAM is a registered trademark of Telestream,
LLC. All other trade names referenced are the service marks, trademarks, or registered
trademarks of their respective companies.
Specifications subject to change without notice. Copyright © 2021 Telestream, LLC and
its Affiliates. Telestream, CaptionMaker, Cerify, Episode, Flip4Mac, FlipFactory, Flip
Player, Gameshow, GraphicsFactory, Lightspeed, MetaFlip, Post Producer, Prism,
ScreenFlow, Split-and-Stitch, Switch, Tempo, TrafficManager, Vantage, VOD Producer,
and Wirecast are registered trademarks and Aurora, Cricket, e-Captioning, Inspector, iQ,
iVMS, iVMS ASM, MacCaption, Pipeline, Sentry, Surveyor, Vantage Cloud Port,
CaptureVU, Cerify, FlexVU, Prism, Sentry, Stay Genlock, Aurora, and Vidchecker are
trademarks of Telestream, LLC and its Affiliates.
QuickTime, Mac OS X, Final Cut Pro, and Safari are trademarks of Apple, Inc. Bonjour, the
Bonjour logo, and the Bonjour symbol are trademarks of Apple, Inc.

x

Wirecast supports the use of NewTek NDI™ technology; "NDI™" is a trademark of
NewTek, Inc. For information about NDI™ visit http://NDI.NewTek.com/
Note: All other brand, product, and company names are property of their respective
owners, and are used only for identification purposes.
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MPEG-2 License Requirements
Telestream has obtained a license from MPEG LA, to produce MPEG-2 video, to meet the
following requirement on behalf of its FlipFactory and Pipeline licensees: The use of this
product in any manner that complies with the MPEG-2 standard is expressly prohibited
without a license under applicable patents in the MPEG-2 patent portfolio, which license is
available from MPEG LA, L.L.C., 250 Steele Street, Suite 300, Denver, Colorado 80206

MPEG Disclaimers
MPEGLA MPEG-2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM
MPEG LA, LLC, 4600 S. Ulster Street, Suite 400, Denver, Colorado 80237 U.S.A.

MPEGLA MPEG-4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE.
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE
HTTP://WWW.MPEGLA.COM.

MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C.
SEE HTTP://WWW.MPEGLA.COM.

MPEG-4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON
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A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA,
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers
Telestream, LLC. (the Company) warrants to the original registered end user that the
product will perform as stated below for a period of one (1) year from the date of shipment
from factory:
Hardware and Media. The Product hardware components, including equipment supplied
but not manufactured by the Company but NOT including any third party equipment that
has been substituted by the Distributor for such equipment (the “Hardware”), will be free
from defects in materials and workmanship under normal operating conditions and use.
Software. If software is supplied as part of the product, the software will operate in
substantial conformance with specifications set forth in its product user's guide. The
Company does not warrant that the software will operate uninterrupted or error-free, will
meet your requirements, or that software errors will be corrected.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:
Hardware and Media. The Company will either repair or replace (at its option) any
defective Hardware component or part, or Software Media, with new or like new Hardware
components or Software Media. Components may not be necessarily the same, but will be
of equivalent operation and quality.
Software. If software is supplied as part of the product and it fails to substantially conform
to its specifications as stated in the product user's guide, the Company shall, at its own
expense, use its best efforts to correct (with due allowance made for the nature and
complexity of the problem) such defect, error or nonconformity.

Software Updates
If software is supplied as part of the product, the Company will supply the registered
purchaser/licensee with maintenance releases of the Company’s proprietary Software
Version Release in manufacture at the time of license for a period of one year from the
date of license or until such time as the Company issues a new Version Release of the
Software, whichever first occurs. To clarify the difference between a Software Version
Release and a maintenance release, a maintenance release generally corrects minor
operational deficiencies (previously non-implemented features and software errors)
contained in the Software, whereas a Software Version Release adds new features and
functionality. The Company shall have no obligation to supply you with any new Software
Version Release of Telestream software or third party software during the warranty period,
other than maintenance releases.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, neglect,
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or shipping, or as a result of service or modification by a party other than the Company, or
(ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF
ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT
LIMITATION, ANY WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. No oral or written information or advice given by the Company,
its distributors, dealers or agents, shall increase the scope of this Limited Warranty or
create any new warranties.
Geographical Limitation of Warranty. This limited warranty is valid only within the
country in which the Product is purchased/licensed.
Limitations on Remedies. YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE
LIABILITY OF TELESTREAM, LLC. WITH RESPECT TO THE PRODUCT, SHALL BE AS
STATED IN THIS LIMITED WARRANTY. Your sole and exclusive remedy for any and all
breaches of any Limited Warranty by the Company shall be the recovery of reasonable
damages which, in the aggregate, shall not exceed the total amount of the combined
license fee and purchase price paid by you for the Product.
Damages. TELESTREAM, LLC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES,
INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF YOUR USE OR INABILITY TO USE
THE PRODUCT, OR THE BREACH OF ANY EXPRESS OR IMPLIED WARRANTY,
EVEN IF THE COMPANY HAS BEEN ADVISED OF THE POSSIBILITY OF THOSE
DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS ESSENTIAL PURPOSE.
Further information regarding this limited warranty may be obtained by writing:
Telestream, LLC.
848 Gold Flat Road
Nevada City, CA 95959
You can call Telestream, LLC. via telephone at (530) 470-1300.

7

Contents

Preface 3
Copyright and Trademark Notice 3
MPEG-2 License Requirements 4
MPEG Disclaimers 4
MPEGLA MPEG-2 Patent 4
MPEGLA MPEG-4 VISUAL 4
MPEGLA AVC 4
MPEG-4 SYSTEMS 4
Limited Warranty and Disclaimers 5
Warranty Remedies 5
Software Updates 5
Restrictions and Conditions of Limited Warranty
Limitations of Warranties 6

5

Introducing Wirecast 15
Wirecast Workflow 16
Wirecast Resources 17
Tutorials, Webinars, and Demos 17
Telestream User Forum 18
Wirecast Literature, Documentation, and Knowledge Base
Customer Support 18
Email contacts 18
Website Links 18
Navigate the User Interface. 18
We'd Like to Hear from You. 18
Two Ways to Use this Application 19
Presenter Is Operator 19
Presenter Plus Operator 19

Installation 21
Topics 21
General System Requirements 21

18

8

Contents

Operating System 21
Processor 21
Memory 22
Hard Drive 22
Graphics Card 22
Internet Connectivity 22
Rendezvous Requirements 22
Internet Connectivity 23
ISO Recording Requirements 23
Recommended Hardware 23
Hardware Accelerated Encoding Requirements 24
Installing Wirecast 24
Purchasing and Activating Wirecast 24
Activating Wirecast on One Computer from Another Computer 24
Upgrades Included 25
Checking for Wirecast Updates 25
Deactivating Wirecast 25
Running Wirecast Without an Activated License 26
Uninstalling Wirecast 26
Installing a Hardware Controller 26
Preventing Dropped Frames from Vertical Sync 27
Preventing Dropped Frames from Short Latency 27
Choosing a Video Adapter 27

Customization 29
Topics 29
Setting the Primary Device for Audio Monitoring 29
Disabling Sleep Mode 30
Assigning CPU Usage 30
Launching Wirecast 30
Learning the Layout 30
Customizing Wirecast with Preferences 30
Resetting Preferences 31
Customizing the Playlist Countdown Timer 31
Setting the Number of Transition Buttons 31
Selecting and Customizing Encoder Presets 31
General Preferences 32
Canvas Preferences 33
Shot Display Preferences 33
Licenses Preferences 34
Software Update Preferences 34
Keyboard Shortcuts Preferences 35
Controllers Preferences 35
MIDI Control Assignments 35
MIDI Control Descriptions 37
X-keys Control Assignments 38
General Key Operations 38

Wirecast User Guide

Contents

Key Descriptions 39
Advanced Preferences 40

Document Creation and Input Configuration 43
Configuring the Wirecast Layout 44
Shots 44
Adding Media Files to a Shot 45
Adding Video Sources to a Shot 45
Adding Audio Sources to a Shot 45
Creating a Consolidated Shot 45
Adding a Title to a Shot 45
Adding a Virtual Set to a Shot 46
Editing a Shot 46
Adding, Deleting, or Rearranging Layers in a Shot 46
Resizing or Rotating a Shot 47
Changing Shot Sources 47
Positioning an Image Within a Shot 49
Moving a Shot to Another Layer 49
Playlist Shots 50
Adding Clips to a Playlist Shot 51
Adding Clips to a Playlist from the Shots Menu 51
Editing Playlist Shots 52
Changing the Duration of a Playlist Shot 52
Adding a Live Source to a Playlist Shot 52
Replay Shots 53
Creating a Replay Shot from a Selected Clip 53
Creating a Replay Shot from a Layer 54
Trimming a Replay Shot 54
PTZ Cameras and Controls 55
Setting Up PTZOptics Camera with a Static IP Address 55
Configuring The PTZ Controller 56
Setting Up a PTZ Camera Shot 56
Opening the PTZ Controller Panel 57
Enabling Preset Recall for a PTZ Camera 57
Twitter 57
Creating a Twitter Shot 58
Selecting Messages for a Twitter Shot 58
Facebook 58
Selecting a Facebook Poll 59
Editing or Deleting a Facebook Poll 59
Showing or Hiding a Poll or Results when Streaming to Facebook
Rendezvous 60
Adding NDI™ Sources to Rendezvous 61
Joining a Rendezvous Session 62
Participant Options 62
Adding a Participant Shot to Rendezvous 63
Enabling Rendezvous Chat 65

Wirecast User Guide

60

9

10

Contents

Ending a Rendezvous Session 66
Resizing the Shot Icons 66
Setting Transition Speed 67
Determining the Transitions for the Transition Buttons
Images/Opacity 67
GIF and Transparency 67
The Preview Area 68
Viewing the Preview Area 68
Viewing a Shot in the Preview Area 68
Magnifying the Preview Area 68
Setting the Speed of Preview 69
Adding and Modifying Template Placeholders 69
Assigning Media to Placeholders 69
Shots 71
Reassigning Media 71
Supported Codecs 72

67

Output Configuration 75
Topics 75
Destination Settings 75
Multicast and Unicast Destination Settings 76
Adding a Destination 77
Removing a Destination 77
Modifying Windows Media Server Destination Settings 77
Push To Server 77
Pull From Server 78
Modifying RTMP Server Destination Settings 79
Modifying SRT (Secure Reliable Transport) Destination Settings 79
Modifying CDN Partners Destination Settings 79
Most Common CDN Configurations 80
Modifying Azure Media Services and Sermon.net Destination Settings
Modifying Brightcove and Limelight Destination Settings 81
Modifying Akamai Destination Settings 81
Modifying LinkedIn Live Destination Settings 82
Modifying LiveArena Destination Settings 83
Modifying Twitter/Live Broadcast Destination Settings 83
Modifying Twitch Destination Settings 84
Modifying Vimeo Destination Settings 85
Modifying Wowza Streaming Engine Destination Settings 85
Modifying Zixi Destination Settings 86
Modifying Facebook Live Destination Settings 86
Modifying Microsoft Stream Destination Settings 87
Modifying YouTube Destination Settings 88
Encoder Presets 89
Selecting an Encoder Preset 89
Creating an Encoder Preset 89
Modifying the MainConcept H.264 Preset 90

80

Wirecast User Guide

Contents

Modifying the x264 Preset 92
Streaming 94
Red and Yellow Stream Icon Circumstances
Limiting Reconnection Attempts 97
Configuring Replay + ISO 97
Activating Replay 98
Configuring ISO Recording 98
Capture Source ISO 99
Shot ISO 100
Format 100
Quality 101
Filename 101
File Options 101
A Note about Resources 102
Recording To Disk 102

95

Live Broadcast Production 103
Topics 103
Switching with Preview 103
Single-Click Switching with AutoLive 104
Playing Playlists 104
Viewing the Playlist Countdown Timer 104
Broadcasting 105
Controlling or Muting the Final Audio Mix Level 105
Displaying or Hiding the Final Mix Audio Panel 106
Viewing a Layer in a Layer Window 106
Controlling a PTZ Camera 106
Starting your ISO Recording 106
Error Reporting 107
Configuration Errors and Warnings 107

Windows, Controls, and Menus 109
Topics 109
Control/Status Bar 110
Preview Area 111
Live Broadcast Area 111
Transition Controls 112
Final Mix Audio Panel 112
Mode Selection Buttons 113
Layers 113
Window Controls 113
Transition Controls 113
Changing Transitions 114
Go Button 114
Playlist Controls 114
Playlist Countdown Timer Display

Wirecast User Guide

116

11

12

Contents

Add Shot Window 116
Video Capture 116
Audio Capture 117
Media Files 117
WC Gear Inputs 118
Audio Input Select the audio input (if any) from the pull-down menu.
ASIO and WASAPI Sources 118
Stock Media Library 119
Network 120
Web Page Properties 120
Web Stream Properties 121
Screen Capture 122
Remote Desktop Presenter Properties 122
Screen Capture Properties 123
Overlays 124
Text Shot Properties 125
Properties for Titles (Animated) 127
Properties for Legacy Titles 128
Twitter Feed Properties 130
Scoreboard Properties 131
Clock Properties 133
Image Carousel Properties 134
QR Code Generator Properties 135
Backgrounds 135
Solid Color Properties 135
Virtual Set Properties 136
Templates 136
Shot Selection Icons 136
The Shot Editor Window 137
Shot Layers Tab 137
Replay Layer 138
Shot Layers Properties Tab 139
PTZ Control in the Shot Layer Properties Tab 142
NDI Devices in the Shot Layer Properties Tab 142
Audio Properties Tab 143
Chroma Key Properties Tab 144
Smooth Transition Properties Tab 146
The Audio Mixer Window 147
The Output Settings Window 149
The Encoder Presets Window 151
The PTZ Controller Panel 152
File Menu 155
Edit Menu 155
Switch Menu 157
Media Menu 158
Output Menu 159
Layout Menu 163
Replay + ISO Menu 164

118

Wirecast User Guide

Contents

Social Menu 165
Facebook 165
Twitter 165
Comments 166
Window Menu 166
Help Menu 167

Keyboard Shortcuts 169
Topics 169
Creating a Keyboard Shortcut 169
Creating a Keyboard Shortcut for a Shot 170
Creating a Keyboard Shortcut for Multiple Shots
Deleting a Keyboard Shortcut 170
General Shortcuts 171
File Menu 171
Edit Menu 172
Switch Menu 172
Media Menu 172
Output Menu 172
Layout Menu 173
Replay Menu 173
Social Menu 173
Window Menu 173
Help Menu 173

Tutorials 175
Topics 175
Tutorial 1: Basic Concepts 176
Tutorial Prep 176
The Wirecast Default Layout 176
What Is a Shot? 176
Switching Between Shots 176
Transitions 177
Transition Speed 177
Layers 178
Auto Live 178
Turn AutoLive Off 178
Multiple Changes 179
Preview 179
Tutorial 2: Editing Shots 180
Tutorial 3: Broadcasting 181
Streaming 181

Making Great Broadcasts 183
Topics 183

Wirecast User Guide

170

13

14

Contents

High Quality Audio 183
Good Lighting 184
Triangular Lighting 185
Broadcast Settings 185
Bandwidth 185
Motion 186
Encoder Settings 186

Acknowledgments 187
Topics 187
Steinberg VST Plug-In SDK Licensing Agreement
(Version 3.6.6- 17.06.2016) 187
MIT 190
TurboJPEG 190

Wirecast User Guide

15

Introducing Wirecast

Wirecast is professional-grade software for live streaming video production. Wirecast
provides the tools you need for every step of a broadcast, from audio-video capture to
live production to streaming.
Note: We use the word, “broadcast” throughout this guide to mean a one-to-many
transmission of an audio-video stream, and related data, over the Internet.
Wirecast is available in two versions: Studio and Pro.
Wirecast Studio supports the following:
– Up to two guests on Rendezvous
– Unlimited capture
– Live production
– High-definition and standard-definition encoding for live streams
– Broadcasting to multiple servers and platforms simultaneously
– Streaming to Facebook, YouTube, Twitter, CDNs, LAN multicasts and unicasts,
virtual camera, or secondary displays.
Wirecast Studio includes the following tools:
– A Stock Media Library
– An advanced audio mixer
– A remote desktop presenter
– Multi-viewer outputs
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Wirecast Pro includes all the features of Wirecast Studio and also supports the following:
– Up to seven guests on Rendezvous
– 8-track audio output
– Live replay
– Program feed output
– Pro audio FX
– Custom transitions
– 3D virtual sets
– ISO recording
– Built-in PTZ controller
– NDI outputs
Features that pertain specifically to Wirecast Pro are indicated by this Pro icon:
PRO

Note: Both Studio and Pro licenses include one year of Insider Access Support
providing free software updates, access to built-in Stock Media library, on-demand
video training, access to Knowledgebase and Community Forum, and email support
with an eight-business-hour response time target.
This guide explains how Wirecast works, and provides tips for producing the best
broadcasts possible.

Topics
■ Wirecast Workflow
■ Wirecast Resources
■ Two Ways to Use this Application
■ Navigate the User Interface.

Wirecast Workflow
Because of its versatility in handling a variety of inputs and outputs, Wirecast typically
fits in the middle of your broadcasting workflow. Wirecast can take the place of
traditional T-bar hardware switchers, graphics generators, and title generators.
However, you can also use Wirecast simply as the back-end encoder for large switching
systems.
Wirecast productions generally follow a four-step workflow:
1. Plug in your live input devices such as video cameras, iOS cameras, computer
desktop, and web feeds.

Wirecast User Guide
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2. Capture your content.
3. Produce your program using the full range of Wirecast production features.
4. Stream your program live to the web or to a LAN, or record it to a local drive.

Wirecast Resources
For up-to-date information about Wirecast, visit the following Telestream resources.

Tutorials, Webinars, and Demos
A quick way to learn Wirecast basics is to work through the tutorials in the Tutorials
section of the Wirecast User Guide. The tutorial environment built into Wirecast
corresponds with these tutorials. The three tutorials take about thirty minutes.
Also, read Making Great Broadcasts. This topic provides practical tips for improving the
quality of your presentations.
Telestream provides additional tutorials, webinars, and product demos on the Wirecast
Training Resources page:
http://www.telestream.net/telestream-support/wire-cast/training.htm

Wirecast User Guide
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Telestream User Forum
Join the active community of Wirecast users in posting Wirecast questions, answers,
and feature requests. Also, one click takes you from the forum to the knowledge base of
Wirecast technical articles.
Telestream User Forums:
https://telestreamforum.forumbee.com/

Wirecast Literature, Documentation, and Knowledge Base
Find current versions of Wirecast literature, user guides, and customer case studies on
the Wirecast Literature and Documentation page. Find Wirecast technical articles on
the Wirecast Knowledge Base.
Wirecast Literature and Documentation:
http://www.telestream.net/wirecast/resources.htm#docs
Wirecast Knowledge Base:
https://support.telestream.net/s/global-search/Wirecast

Customer Support
Telestream offers technical support through our website and email.

Email contacts
• Sales: sales@telestream.net
• Support: desktopsupport@telestream.net

Website Links
• How to Buy:

http://www.telestream.net/purchase/store.htm

• Support:

http://www.telestream.net/telestream-support/wire-cast/support.htm

Navigate the User Interface.
For descriptions of the various Wirecast menu items, tools and windows, see Windows,
Controls, and Menus.

We'd Like to Hear from You.
Telestream welcomes comments, feedback, and suggestions about your experience with
Telestream products. You can reach us at desktopsupport@telestream.net

Wirecast User Guide
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If you have suggestions about improving the Telestream documentation or website, email
us at techwriter@telestream.net.

Two Ways to Use this Application
There are two different ways you can use Wirecast:

• Presenter Is Operator The person conducting the presentation also operates Wirecast.

• Presenter Plus Operator The presenter concentrates on the content and someone
else operates Wirecast. In this mode, the presenter never needs to know in detail
how Wirecast works.

Presenter Is Operator
In this mode of operation, the person conducting the presentation simultaneously
operates Wirecast.
Here are some suggestions for using Wirecast when you are both the presenter and
operator:

• Keep it simple Set up Wirecast to make it easy for you to be the operator and the
presenter. Set up your logo and titles so that you need to make very few changes
during your presentation. Use a minimum number of shots so it’s easy for you to
see which shot to choose.

• Keep the AutoLive feature on This enables you to present your shots with just one
click. Though this limits your ability to perform complex presentations, it is the best
way when the presenter is also the operator. To turn AutoLive on or off, select it
under the Switch menu.

• Pre-configure your shots Make sure that all the shots are created prior to your
presentation. Do not try to create or modify shots while broadcasting them.

• Use hot-keys for switching shots Wirecast provides a hotkey editor that enables
you to easily assign hotkeys to your shots.

Presenter Plus Operator
In this mode of operation, an engineer (or operator) is responsible for using Wirecast,
and the presenter concentrates on the content of the presentation.
Here are some suggestions for using Wirecast when you have both an operator and a
presenter:

• Keep the AutoLive feature off This enables you to make several changes at one

time before taking the changes live. However, to quickly make a shot live, press the
Shift+Ctrl keys and click the shot. The AutoLive control is located under the Switch
menu

Wirecast User Guide
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• Open the Preview Area The operator should use Preview mode to examine everything before it becomes live. The Preview display control is located under the Layout menu.

• Use the Layer Windows to make more shots available To open layer windows so
you can quickly flip between shots on several layers, select Window > New Layer
Window.

Wirecast User Guide
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You can install Wirecast on any Mac or Windows computer that meets the minimum
system requirements.

Topics
■ General System Requirements
■ Installing Wirecast
■ Purchasing and Activating Wirecast
■ Activating Wirecast on One Computer from Another Computer
■ Upgrades Included
■ Checking for Wirecast Updates
■ Deactivating Wirecast
■ Uninstalling Wirecast
■ Installing a Hardware Controller
■ Preventing Dropped Frames from Vertical Sync
■ Preventing Dropped Frames from Short Latency
■ Choosing a Video Adapter

General System Requirements
Operating System
• Minimum: Windows 10 version 1803 or higher
• Recommended: Windows 10 version 1903

Processor
• Minimum: i5 dual-core @ 2.3GHz, 6th generation or higher
NOTE: May be insufficient for 1080p+ or 60 fps workflows
How to check the generation of your Intel processor
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• Recommended: i7 quad-core @ 2.8GHz+

Memory
• Minimum: 4GB RAM
• Recommended: 16GB+ RAM

Hard Drive
• Minimum: 2GB, 7200 RPM for record to disk

NOTE: Additional hard disk space required for record to disk

• Recommended: 500GB+, Solid State OS Drive

Graphics Card
• Minimum: Intel HD, DirectX 11 capable

NOTE: Insufficient for advanced Multi-Viewer workflows

• Recommended: Nvidia GeForce or AMD Radeon, 1GB+ video memory

Internet Connectivity
• Minimum: Open HTTP/HTTPS port 80, RTMP port 1935,
port 7272 for Remote Desktop Presenter

• Recommended: If behind a firewall, check with your CDN for any sites to whitelist.
Note: We recommend running Wirecast on the Windows Aero theme, which includes
a hardware accelerated window manager. Running Wirecast on the Windows Classic
theme can cause performance issues.

Rendezvous Requirements
Wirecast Rendezvous uses WebRTC technology that can be very resource intensive. For
the best Rendezvous experience, we recommend the following hardware:
Studio (2 guests + 1 host)

Pro (7 guests + 1 host)

Bandwidth4

Add 4 Mbps

Add 5+ Mbps5

Processor4

i5 quad-core6

i7 quad-core6

4 BBased on a single simultaneous stream of 720p30 x264 @ 4.0Mbps.
5

Bandwidth per guest will scale downwards as more are added to maintain reliability.

6

Minimum recommended processor with example stream4. More demanding workflows
may require a more capable CPU.
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Internet Connectivity
• Requires Internet connectivity with HTTP/HTTPS port 80, and RTMP port 1935 open
for streaming, Remote Desktop Presenter requires opening port 7272.

• An Internet connection is recommended for Wirecast license activation.
• It is recommended that an upload rate of at least double the desired rate be available.

– For lowest quality (240p) streaming an upload rate of at least 650Kbps is
required.
– 720p streaming requires an upload rate of at least 2500 Kbps.
– 1080p streaming requires an upload rate of at least 4500 Kbps.

ISO Recording Requirements
Note: You cannot record the following using ISO: Rendezvous callers, Web Stream
plugin, IP Cameras, Web Page plugin and Wirecast Go.

• Solid State Drive or fast RAID array recommended for ISO Recording and Replay
functionality.

• Actual data rates will vary depending on quality level selected for ProRes (Mac) or
MJPEG recording (Windows), as well as the resolution and frame rate selected.

• For Mac ProRes recording please refer to Apple’s ProRes data rate specifications.
• Total expected data rate should be compared to available disk write speed to
ensure adequate disk throughput.

Note: Failure to ensure the available disk write speed is greater than the highest
expected total data rate may result in frames being dropped from recordings (ISO,
Replay, and Record-to-Disk).

Recommended Hardware
• Intel Core i3 CPU @ 1.7 Ghz or higher recommended for 540p streaming with x264
@ 30 fps.

• Intel Core i5 CPU @ 2.5 Ghz or higher recommended for 720p streaming with x264
@ 30 fps.

• Intel Core i7 CPU @ 3.0Ghz or higher recommended for 1080p streaming with x264
@ 30fps.

Note: 60 FPS streaming will result in increased CPU usage and a high bit rate (4Mbps
or higher) for good quality.

• Minimum 4GB RAM, 2GB free hard disk space. Additional hard disk space required
for recording to disk.

Wirecast User Guide
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Hardware Accelerated Encoding Requirements
• Intel Quick Sync Video encoding requires an Intel CPU with an Intel® QuickSync
Video core.

• NVIDIA NVENC encoding requires an NVidia GPU with Kepler architecture or newer.

Installing Wirecast
To install Wirecast, follow these steps:
1. Download the installer from the Telestream website:
https://dynamic.telestream.net/downloads/download-wirecast.asp?prodid=wirecast.
2. Run the installer (.exe) program and follow the instructions provided.
Note: The Wirecast installer asks whether you want to install the Virtual Microphone
feature. If you do (recommended), check the box for this feature and continue the
installation. You must have administrative rights to install Virtual Microphone.
3. If you have an older version of Wirecast already installed on your computer, the
installer upgrades to the newer version.

Purchasing and Activating Wirecast
To purchase and activate Wirecast, do the following:
1. Launch Wirecast.
2. Select File > Preferences > Licenses, and click Purchase. Purchase Wirecast. Enter your
license key into the License Key field. If you previously purchased a copy of Wirecast
and want to use that serial number, enter that serial number.
3. Click Activate.
Wirecast validates the serial number and unlocks Wirecast.
4. Close the Preferences window.
Telestream activates your Wirecast program.
Note: You can also purchase a serial number at www.telestream.net.
See License Key.

Activating Wirecast on One Computer from
Another Computer
If the computer where Wirecast is installed is not on the Internet, you can use another
computer to activate your license and unlock Wirecast. To activate your license from
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another computer, follow the steps in the Manual Activation Guide at:
http://www.telestream.net/telestream-support/wire-cast/training.htm.

Upgrades Included
With each purchase of Wirecast – whether it is an upgrade purchase or full license – you
receive an Access Support subscription for one year from the date of purchase. You can
renew this subscription annually.
You can choose to upgrade from an Access Support subscription to a Premium Support
subscription at any time, for an additional fee. You can also renew Premium Support
subscriptions annually.
Your support subscription is tied to your Wirecast license. As long as your license is
entered into the software and your Premium or Access support subscription is active,
you will be allowed to upgrade to the latest unlocked version of Wirecast for free. To do
this, download and install the latest version of Wirecast. You will automatically have
access to all the new features (depending on your license level).
If your support subscription is expired, or you have not entered your license into the
software, you will not be able to upgrade to an unlocked version and the software will
revert to demonstration mode. However, you may continue to use the last valid version
of the software released during your support subscription coverage.
If your support subscription is about to expire (12 months from the date of purchase),
Wirecast will prompt you to renew it. If you do not renew it before it expires, you may
re-subscribe at any time for an additional fee.
See also Software Update Preferences.

Checking for Wirecast Updates
To check for Wirecast software updates, do the following:
1. Select File > Preferences > Software Update,
2. Click Check Now.
Wirecast checks for updates, but does not transmit personal information to
Telestream during this action.
See also Software Update Preferences.

Deactivating Wirecast
Deactivating a serial number on one computer allows you to re-activate it on another
computer. Without an activated license, Wirecast adds water-marking to the video and
audio whenever licensed features are used.
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Note: You can always reactivate a serial number by re-entering it into the License Key
field and clicking Activate.
To deactivate Wirecast, do the following:
1. Select FileWirecast > Preferences > Licenses.
2. Click Deactivate.
Wirecast deactivates the serial number and removes it from the License Key field.
Note: You can access the License Reset Tool at:
https://www.telestream.net/telestream-support/deactivate-software.htm
See License Key.

Running Wirecast Without an Activated License
With no active serial number, Wirecast enters demonstration mode. In demonstration
mode, Wirecast watermarks all outputs (both to disk and network). The video watermark is a periodic overlay of the Wirecast logo. The audio watermark is a periodic voiceover. If you have a Wirecast serial number and are using a Wirecast Pro feature without a
Pro license, Wirecast also watermarks that output.

Uninstalling Wirecast
To uninstall Wirecast, follow these steps:
1. Run the Wirecast installer (.exe) program.
The installer asks if you want to repair or remove the existing version.
2. Select Remove to uninstall the existing version of Wirecast.
3. Choose the Wirecast program icon in Finder > Applications, or on your desktop.
4.

Installing a Hardware Controller
You can control many Wirecast functionalities with some external hardware controllers,
or Human Interface Devices. Wirecast provides control of three MIDI controllers: APC
MINI, APC40mk2, Launchpad MK2, and one X-keys controller: XKeys 128.
To install a hardware controller for Wirecast, do the following:
1. Select FileWirecast > Preferences > Controllers.
2. Select a controller from the drop-down menu.
3. To close the Preferences dialog box, click the “x.”
See Controllers Preferences.
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Preventing Dropped Frames from Vertical Sync
You can prevent Wirecast from dropping frames, and optimize Wirecast performance
by disabling vertical sync.
Wirecast usually synchronizes its video display with the refresh rate of your display.
However, this degrades performance when the Wirecast program window is not visible
(due to the screen being locked, Wirecast minimized, or the Wirecast covered by
another application).
Note: Disabling vertical sync can interfere with the smooth display of video in the
Wirecast user interface. This does not, however, decrease the broadcast video
quality.
In order to avoid dropping frames, do the following:
1. Select File > Preferences > Advanced.
2. Check Disable Vertical Sync.
3. To close the Preferences dialog box, click the “x.”

Preventing Dropped Frames from Short Latency
You can prevent Wirecast from dropping frames, and optimize Wirecast performance
by lengthening latency.
Wirecast adds latency to all incoming sources. Latency is the brief period between
receiving live video and displaying it or processing it. Adding latency gives Wirecast
time to store the incoming data properly. This preference lets you specify the length of
the latency. The lower this value, the less time Wirecast takes between receiving data
and using it. If the connection is not fast enough, or the latency is too brief, this may
result in dropped video frames (less noticeable) and audio blips (very noticeable). The
higher this value, the more time Wirecast has to store data before displaying or
processing it.
In order to avoid dropping frames from short latency, do the following:
1. Select File > Preferences > Advanced.
2. Enter a value into the Application Source Latency field.
3. To close the Preferences dialog box, click the “x.”
See Application Source Latency.

Choosing a Video Adapter
If your computer has multiple video adapters, such as NVIDIA, AMD, or Intel graphics
cards, you can determine which video adapter Wirecast uses. To select a video adapter,
do the following:
1. Select File> Preferences > Advanced.
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2. From the Video Adapter drop-down menu, select the video adapter desired. Choose
a video adapter.
3. To close the Preferences dialog box, click the “x.”
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You can customize Wirecast to your needs by selecting Wirecast preferences. You can
select most preferences directly from a Wirecast document or from the Shot Editor. You
can also manage your licenses, update your software, and select advanced video
preferences through the Preferences window.

Topics
■ Launching Wirecast
■ Learning the Layout
■ Customizing Wirecast with Preferences
■ Resetting Preferences
■ Customizing the Playlist Countdown Timer
■ Selecting and Customizing Encoder Presets
■ General Preferences
■ Canvas Preferences
■ Shot Display Preferences
■ Software Update Preferences
■ Keyboard Shortcuts Preferences
■ Controllers Preferences
■ Advanced Preferences

Setting the Primary Device for Audio Monitoring
To select the device Wirecast uses for audio monitoring, do the following:
1. In Windows, right-click the speaker icon in the task bar. Then, select Open Sound
settings > Sound.
2. Select the desired default audio-monitoring device from the drop-down menu
under Choose your output device.
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Wirecast uses the device chosen as the default device for audio-monitoring. You can
change the device from this default through the Audio Playback preference. See Audio
Playback.

Disabling Sleep Mode
Wirecast does not prevent your computer from entering sleep mode. To ensure
uninterrupted streaming, disable sleep mode on your computer while using Wirecast.

Assigning CPU Usage
To avoid a decrease in video quality, don’t set Wirecast CPU usage above 80%. See the
Telestream Website for suggested configurations.

Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop
during installation.
Note: You can determine whether Wirecast displays the landing page, and whether
Wirecast opens the last document you worked on, at startup. See Show landing page
on startup and Open last document on startup.

Learning the Layout
Before customizing the Wirecast layout, familiarize yourself with the default layout, and
with the main Wirecast windows, controls, and menus. See Windows, Controls, and
Menus.

Customizing Wirecast with Preferences
You can customize Wirecast to meet your particular production needs, and types of
equipment, by choosing preferences. To customize Wirecast, do the following:
1. Select Preferences from the File menu (or press the Ctrl+ Comma (“,”) keys).
2. In the Preferences dialog, click one of these headings to view and change its
associated preferences:

•
•
•
•
•

General
Canvas
Shot Display
Licenses
Software Update
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• Keyboard Shortcuts
• Controllers
• Advanced
Wirecast applies your preferences immediately, and saves them automatically, every
time you change a preference.

Resetting Preferences
To reset your preferences, use Support Assistant (see Send Support Information under
Help Menu).

Customizing the Playlist Countdown Timer
The countdown timer in the Live Broadcast Area displays either the times for the current
shot, or the times for both the current shot and for the playlist containing the current
shot. To choose the mode of the playlist countdown timer, do the following:
1. With a playlist displayed in the Live Broadcast Area, click the gear icon in the Live
Broadcast Area.
Wirecast displays a drop-down menu
2. Choose one of the following:

• To display the times for only the current shot, choose the first item in the dropdown menu. The first item is the name of the current shot.

• To display the times for both the current shot and for the whole playlist, choose the
second item in the drop-down menu, New Playlist - Completion.

Setting the Number of Transition Buttons
To set the number of transition buttons, from 0 - 3, that Wirecast displays, do the
following:
1. Select File > Preferences > General.
2. Select the desired number of transition buttons from the Transition Buttons dropdown menu, and close the Preferences dialog box.
See Transition Buttons and Determining the Transitions for the Transition Buttons

Selecting and Customizing Encoder Presets
To select one of the default encoder presets, or to customize encoder presets for your
outputs, do the following:
1. Select Window > Encoder Presets.
2. Select an encoder preset from the Encoder Preset drop-down menu, and click
Close.

Wirecast User Guide

31

32

Customization
General Preferences

3. (Optional) Alternatively, check Video Encoding, Audio Encoding, or both. Choose the
video and audio settings desired. Click Save As, give the custom preset a name, and
click OK.
See The Encoder Presets Window.

General Preferences
You can customize whether Wirecast shows the landing page and last document on
startup, the number of transition buttons shown, and other defaults, through the
General preferences.
Open last document on startup
When checked, the last document you used is opened when Wirecast starts up.
Show landing page on startup
When checked, the Welcome screen is displayed when Wirecast starts up.
Show Number of Viewers
When checked, enables the viewership indicator while streaming.
Send diagnostic and usage information
When checked, causes diagnostic and usage information to be sent to Telestream
anonymously.
Hide Unlicensed Features
When checked, unlicensed features (Studio and Pro) are hidden from display in the
menus.
Transition Buttons
The value selected from the drop-down menu determines the number of transition
buttons Wirecast displays in the default layout.
Maximum Reconnect Attempts
The number entered into this field determines the number of times Wirecast tries to
reconnect to a host provider. The default is three.
Audio Playback
The device selected from the drop-down menu determines the device Wirecast uses for
monitoring audio playback.
Stock Media Download Folder
This field displays the full path of the folder where Wirecast stores stock media
downloads. Clicking the Browse button lets you select a different folder for stock media
downloads.
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Canvas Preferences
Canvas preferences let you set options for your document canvas, including the default
size and the display rate used for video rendering.
Canvas Size for New Documents
The preference selected from the drop-down menu determines the default canvas size
for new documents.
Note: To optimize the quality of the video that Wirecast broadcasts, set the canvas
size to match, as closely as possible, the resolution of the desired output.
Lock Aspect Ratio When Resizing Layers
When checked, maintains aspect ratio when resizing layers.
Enable Snapping to other layers
When checked, turns on snapping to selected layers.
Enable Snapping to canvas
When checked, turns on snapping to the canvas.
Show Z Rotation controls
When checked, Wirecast displays the Z Rotation controls.
Video Display Rate
The preference selected from the drop-down menu determines the display rate.

Shot Display Preferences
Shot Display preferences enable you to change settings related to your shots and the
Main Shot Display.
Theme
The preference selected from the drop-down menu determines how Wirecast displays
the shot window.

•
•
•
•

Default: Displays shot icons normally.
Darker: Displays shot icons with a darked background.
XKeys: Displays shot icons with shot titles highlighted.
XKeys - Layer Backgrounds: Displays shot icons with colored backgrounds.

Live GPU Accelerated Icons
The preference selected determines the framerate at which Wirecast displays the active
icons.
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Note: Higher framerates place greater demands on your CPU. This could diminish
Wirecast performance.
Live Audio Meters
When checked Wirecast enables live audio meters.
When Dragging Multiple Files From Explorer
The preference selected determines what Wirecast does when you drag multiple files
from a folder into Wirecast. Depending on your selection, Wirecast either creates a
playlist containing the multiple files, or Wirecast creates multiple shots that are not part
of a playlist.

Licenses Preferences
Licenses preferences enable you to register and license Wirecast.
License Key
This field displays the serial number that you have received for Wirecast.
Note: The serial number is composed of numbers and upper case letters (excluding
upper case letter O), but it never contains quotation marks. When you receive a serial
number, it may be enclosed in quotation marks (e.g., “123-456-789”).
Purchase
When clicked, the Purchase button launches the purchasing dialog.
Deactivate
When clicked, the Deactivate button deactivates the serial number.

Software Update Preferences
Software update preferences enable you to obtain Wirecast updates.
Automatically check for updates
When checked, Wirecast checks for updates on the Telestream Website each time
Wirecast is launched. No personal information is transferred to Telestream during this
action.
Check Now
When clicked, Wirecast immediately checks for updates on the Telestream Website
(www.telestream.net). Wirecast does not transmit personal information to Telestream
during this action.
See Checking for Wirecast Updates.
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Keyboard Shortcuts Preferences
Keyboard Shortcut preferences enable you to view and create custom key assignments.
List of Keyboard Shortcuts
The Keyboard Shortcuts window displays a list of existing keyboard shortcuts.
“+” Button
When clicked, this button creates a new line item, in the list of shortcuts, that you can
edit to create a keyboard shortcut.
“-” Button
When clicked, this button deletes the line item and keyboard shortcut selected in the
list of keyboard shortcuts.
Name
Text entered into this field names the keyboard shortcut selected in the list of keyboard
shortcuts.
Key Binding field (unlabeled)
Wirecast makes the key combinations entered into this field keyboard shortcuts.
See also Creating a Keyboard Shortcut.

Controllers Preferences
Controllers preferences enable you to adjust MIDI and X-keys controller settings for
Wirecast.
Controller
The controller selected from the drop-down menu controls Wirecast.
See Installing a Hardware Controller.

MIDI Control Assignments
Each MIDI controller has up to six controls assigned to it. The locations of each of these
controls are shown below for the three midi controllers supported.
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The locations of APC MINI controls are shown below:

The locations of APC40mk2 controls are shown below:

The locations of Launchpad MK2 controls are shown below:

Each MIDI controller has up to six controls assigned to it. The locations of each of these
controls are shown below for the three midi controllers supported.
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MIDI Control Descriptions
Shot Layers
The matrix of buttons on the MIDI controller (five rows of eight buttons) automatically
correspond to the five layers in the Wirecast shot list window. Up to eight shots in each
layer are controlled by the MIDI controller buttons. Shots are automatically assigned to
MIDI controller buttons as they are created. If less than eight shots exist on a layer, the
corresponding buttons (to the right) are inactive.

Go Live
Pressing this MIDI controller button is the same as clicking the Go Live button in the
Wirecast default layout.
Transition 1
Pressing this MIDI controller button is the same as clicking the Left Transition button in
the default layout.
Transition 2
Pressing this MIDI controller button is the same as clicking the Left Transition button in
the default layout.
Audio Mixer Volumes
Sliding these MIDI controls adjusts up to eight volume controls in the Wirecast Audio
Panel. Each MIDI slider corresponds (left to right) to a volume control in the Audio
Panel. Volume controls are automatically assigned to MIDI controller sliders as they are
created. If less than eight volume controls exist in the Audio Panel, the corresponding
MIDI sliders (to the right) are inactive.
Channel Pan
Adjusting these MIDI controls sets up to eight Channel Pan controls in the Wirecast
Audio Panel (located just below the volume controls). Each MIDI control corresponds
(left to right) to a Channel Pan control in the Audio Panel. Channel Pan controls are
automatically assigned to MIDI controls as they are created. If less than eight Channel
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Pan controls exist in the Audio Panel, the corresponding MIDI controls (to the right) are
inactive.

Channel Pan Controls

X-keys Control Assignments
The X-keys controller has multiple controls assigned to it. All of the assigned controls
are shown below.
3

4

5

6

7

8

9

10

11 12

13

14

15

2

16
17
18
19

1

20

General Key Operations
• Key lamps turn red when a function is on, and turn blue when off (except for keys
that do not have dual states, like the Keyboard Shortcuts).

– Function lamps turn red when a function is on, and turn blue when off (except
for keys that do not have dual states, like the Keyboard Shortcuts).
– Shot switching key lamps turn Blue when shot is in Preview and Red when in
Live. Otherwise they are off.

• The Wirecast software and the X-keys panel stay in sync when keys are pressed or
changes are made in Wirecast.

• Some keys are interactive. In such a case, pressing one key affects the status of
another (like the PREV and LIVE keys).
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Key Descriptions
Five Layers keys
Controls the first twelve shots (plus the Clear Layer shot) on each of the five layers.
Keyboard Shortcuts
The twelve keys represent the twelve Keyboard Shortcuts that have been assigned in
Wirecast. Pressing a key executes the matching numbered Keyboard Shortcut (1
through 13). The key lamps momentarily turn red, then turn back to blue.
Live/Preview Swap Mode
Toggles the Live/Preview Swap mode. When in this mode, the Live and Preview shots
are swapped.
Auto Live Mode
Toggles the Live Auto mode. When in this mode, selected shots are displayed in the
Live Output window immediately.
Rendezvous
Toggles (show/hide) the display of the Rendezvous window.
Audio Mixer
Toggles (show/hide) the display of the Audio Mixer window.
Preview Monitor Audio
Toggles the Preview monitor audio (what you hear locally) on and off. (It is mutually
exclusive with Live Monitor audio).
Mute Live Streaming audio
Toggles the Live Streaming audio (what your viewers hear) on and off.
Live Monitor Audio
Toggles the Live monitor audio (what you hear locally) on and off. (It is mutually
exclusive with Preview Monitor audio).
Streaming
Toggles streaming on and off.
Recording
Toggles recording on and off.
ISO Recording
Toggles ISO recording on and off.
Multi Viewer
Enables all displays. Pressing this key is the same as selecting
Output > Multi-Viewer Output > Enable All Displays.
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NDI
Enables/Disables NDI output.
Fade to Black
Pressing this key acts as a “master transition-to-black”. The transition used is the one
currently selected. It is very helpful when needed to make the Live Output black in an
emergency. If Wirecast is in Live/Preview Swap mode, the live shot is moved to Preview
and the pre-fade condition can be restored by pressing the Go key.
Live Media Play and Pause
Press the Play button to play a selected media file, and press the Pause key to pause it.
These keys are interactive. Pressing one changes the lamp status of the other.
Replay Create and Update
These keys execute Replay+ISO > Create All Replay Shots, and Replay+ISO > Update All
Replay Shots.
Mark In
Pressing this key executes Replay+ISO > Program Replay > Replay Mark In.
Transitions 1 and 2
These keys select Transition 1 or Transition 2 so that when the Go key is pressed, the
selected transition will occur.
Go
Press this button to send the shot from the Preview Area to the Live Broadcast Area,by
wa he transition selected. If Wirecast is in the Live/Preview mode, the Live output shot
will be moved to the Preview Area when you click the Go button.

Advanced Preferences
Advanced preferences enable you to adjust advanced settings for Wirecast.
Disable Vertical Sync
When checked, Wirecast receives frames as fast as possible, for example, during video
game play. This is especially useful when the application window is minimized or
covered by another application.
Video Adapter
The preference selected from the drop-down menu determines the video adapter
Wirecast uses for rendering and compositing. If you are using a discrete GPU, select the
same GPU on which your application is running.
Note: Video Adapter defaults to the first discrete card that is discovered by Wirecast. If
you have multiple GPUs, it is best to configure Wirecast to use the same card as used
for your application (for optimal performance), otherwise Wirecast uses a slower
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capture path. Also, best performance is achieved by setting the Video Adapter to use
the NVidia card.
Web Stream
Check to enable automatic discovery of ONVIF cameras.
Microphone
Check to automatically detect feedback and force the display of a warning message.
Missing Media
Check to automatically reconnect live shots when Wirecast loses communications with
a source.
Application Source Latency
The value entered into this field determines Wirecast latency period, in microseconds.
When you update this value, Wirecast applies it as soon as the preference is committed.
You don’t need to restart Wirecast to see the change.
The minimum value for this preference is 50ms (2 frames @ 30fps). The maximum value
is 330ms (10 frames @30fps). The default is 100ms (3 frames @ 30fps).
Note: Wirecast applies application source latency to all sources, while the audio delay
and video delay values in Source Properties determine the delay for individual
sources.
Missing Media Image
The preference selected determines how Wirecast indicates a missing graphic.

• When Default is selected, Wirecast presents a red question mark in place of the
missing graphic.

• When Transparent is selected, Wirecast makes no replacement of the missing
graphic.

• When Custom is selected, Wirecast lets you browse to a graphic to replace the missing graphic.
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Document Creation and
Input Configuration
Wirecast enables you to work with media created outside of Wirecast, as well as with
live camera and live microphone sources. Wirecast supports media in a variety of
platforms such as AVFoundation, a variety of file types such as MOV and AVI, and a
variety of codecs such as AVC or H.264. This section introduces some common media
types you can use with Wirecast. You can add media by selecting Import Media from the
File menu.

Topics
■ Creating a Document
■ Configuring the Wirecast Layout
■ Shots
■ Playlist Shots
■ PTZ Cameras and Controls
■ Twitter
■ Facebook
■ Creating a Replay Shot from a Layer
■ RendezvousResizing the Shot Icons
■ Setting Transition Speed
■ Determining the Transitions for the Transition Buttons
■ Images/Opacity
■ The Preview Area
■ Adding and Modifying Template Placeholders
■ Reassigning Media
■ Supported Codecs
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Creating a Document
In Wirecast, you keep all the resources for a particular broadcast in a Wirecast
document. You can save the audio, video, file, and controller sources, as well as the
output settings, for a broadcast in a document file. Wirecast Document files have the
file extension, “wcst.”
Once you’ve created a document, you add shots to the document. Then, you add
sources to the shots. The document then contains the shots and sources for a particular
broadcast.
To create a new document, do the following:
1. Select File > New.
Wirecast opens a new document.
2. To save the document, select File > Save.
3. Enter a file name for the document, and click Save.
Note: Consider establishing a file-naming method for naming documents. For
example, you could name documents for specific broadcasts, or for specific types of
broadcasts.

Configuring the Wirecast Layout
To optimize the user interface for each document, you can configure the Wirecast
layout. Wirecast saves the layout settings in the document file.
To configure the Wirecast layout, do the following:
1. Select Layout.
2. Choose a desired option from the menu.
Wirecast configures the layout accordingly, and closes the Layout menu.
3. To select whether Wirecast displays the Preview Area, the Live Program Area, or both,
choose the appropriate Mode Selection Button. See Mode Selection Buttons.

Shots
You can create and edit shots for your broadcasts before you begin broadcasting.

Creating a Shot
1. To create a shot, click the “+” in any of the layers.
Wirecast opens the Add Shot dialog box.
2. Select options for the shot as desired.
See Add Shot Window.
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Adding Media Files to a Shot
1. To add media files to a shot, click the “+” in any of the layers.
Wirecast opens the Add Shot dialog box.
2. Click Media Files. Select media files for the shot as desired.
3. Click Add.
See Add Shot Window.

Adding Video Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.
Wirecast opens the Add Shot dialog box.
2. Click Video Capture. Select video sources for the shot as desired.
3. Click Add.
See Add Shot Window.

Adding Audio Sources to a Shot
1. To add media files to a shot, click the “+” in any of the layers.
Wirecast opens the Add Shot dialog box.
2. Click Audio Capture. Select audio sources for the shot as desired.
3. Click Add.
See Add Shot Window.

Creating a Consolidated Shot
1. Select multiple sources in the Shot Layers tab of the Shot Editor.
2. Select Edit > Copy.
3. Select Edit > Paste as new Consolidated Shot to create a new shot in the selected
layer.
See Edit Menu.

Adding a Title to a Shot
To add a title to a shot, do the following:
1. In a layer, click the Add Shot “+” button.
2. Select Overlays > New Title.
3. To add the title to your document, click the Add button.
See Title.

Wirecast User Guide

45

46

Document Creation and Input Configuration
Shots

Adding a Virtual Set to a Shot
To add a virtual set to a shot, do the following:
1. In a layer, click the Add Shot “+” button.
2. Select Backgrounds > Virtual Set. Click Add.
3. Click the desired virtual set, and click OK.
4. Customize the set as desired.
See Virtual Set Properties.

Editing a Shot
To edit a shot, double-click the shot in a layer to open the shot editor. You can also
single-click the shot to select it, then click the double-arrow on the left of the default
layout to open the shot editor panel. See The Shot Editor Window.
Select a shot

Click doublearrow

Double-click
a shot

Adding, Deleting, or Rearranging Layers in a Shot
You can add, delete, or rearrange layers in a shot with the controls on the Shot Layers
tab of the Shot Editor.
To add, delete, or rearrange layers in a shot, do the following:
1. Select a shot in a layer. Then select Edit > Edit Shot.
2. Edit the shot in one or more of the following ways, as desired:

• Add a layer by clicking the plus (+) button
• Delete a layer by select selecting it and clicking the minus (-) button.
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• Reorder the layers by selecting a source and clicking the up arrow or down arrow to
move it.

• To move a layer forward or back, replace a source in a layer with another source,

add a layer to a shot, remove a layer from a shot, or display the original location of a
media file, click the gear icon.

• Toggle, on or off, the visibility of a video source by clicking the eye icon.
• Toggle, on or off, the visibility of an audio source by clicking the speaker icon.
See Shot Layers Tab.

Resizing or Rotating a Shot
To resize or rotate a shot, do the following:
1. Click a shot in a layer. Then, click the shot in the Preview Area.
Wirecast places a control frame around the shot in the Preview Area. The control
frame includes handles for resizing and rotation.
2. Click and drag any of these handles to resize or rotate your image.
See Preview Area.

Changing Shot Sources
To change the audio or video source of a shot, right-click on any shot.
Wirecast displays the shot menu.
Change Source Select Change Source to change the video source of your shot. Upon
selection, a menu of sources will display enabling you to make a selection.
Change Audio Select Change Audio to change the audio source of your shot. Upon
selection, a menu of audio sources will display enabling you to make a selection.
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Keyboard Shortcut You can create a keyboard shortcut to any shot. To do this, select
Keyboard Shortcut, then select a menu number to associate with that shot. After you
have selected a menu number, that menu item is checked and the number is displayed
in the shot icon.

Select Keyboard Shortcut

Select a menu number

Menu item checked
Menu number displayed

To take a shot using the assigned hotkey, press the number key assigned to that shot.
You can assign multiple shots to the same menu number as long as they are on
different layers. When you use the assigned hotkey all the shots assigned to it will be
taken. Selecting a checked menu item will uncheck it and unassign the shot.
Select Unmap All Keys to remove all hotkey assignments.
Note: See also the section on Keyboard Shortcuts Preferences for Keyboard Shortcut
management.
Edit Shot You can edit a shot by clicking the double arrows (located on the left side of
the Preview Area) to the right, revealing the shot editing panel. You can also edit a shot
by double-clicking on it, by right-clicking it and selecting Edit Shot, by selecting Edit
Shot from the Edit menu, or by selecting it and pressing the Ctrl+E keys.
Rename Shot You can rename a shot by right-clicking it and selecting Rename Shot, or
by selecting Rename Shot from the Edit menu. You can also rename a shot by selecting
it and pressing the Ctrl+R keys.
Duplicate Shot You can duplicate a shot by right-clicking it and selecting Duplicate
Shot, or by selecting Duplicate Shot from the Edit menu. You can also duplicate a shot
by selecting it and pressing the Ctrl+D keys.
Duplicate Shot Options Check a source to create a new instance of it when
duplicating the shot containing it. Multiple selection is allowed.
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Delete Shot You can delete a shot by right-clicking it and selecting Delete Shot, or by
selecting Delete Shot from the Edit menu. You can also delete a shot by selecting it and
pressing the Ctrl+Backspace keys.
Save Shot as Template You can configure any shot with a Placeholder and save it as a
Template Shot. When the dialog box displays, enter a template name and click OK.
Lock Shot Icon Click to take a snapshot of your live shot icon thumbnail and save it as a
static image for your shot. This can help users identify each shot with a snapshot image
that's meaningful for them. For example, if you have a PTZ camera with multiple shots
configured for different camera positions, you can display a customized snapshot of
each camera angle as the icon for each shot. This provides quick identification during
production. Once a shot icon is locked, the Gear menu item will turn into Unlock Shot
Icon.
Refresh Shot Icon Click to refresh the shot icon after any changes made.

Positioning an Image Within a Shot
You can also snap an image in the Preview Area to various alignments: Snap to Center,
Snap to Edge, Snap to Corner, or Snap to an Image. The yellow guide lines appear when
the image is ready to snap into place.
See Preview Area.

Moving a Shot to Another Layer
You can move a selected shot to another layer by selecting Move to Layer from the Edit
menu, then selecting the target layer from the drop-down menu. You can also click and
drag the shot icon to a different layer.
When shots are created, they are assigned to a specific layer. They exist on that layer
until they are moved or deleted. (See Layers.)

Wirecast User Guide

49

50

Document Creation and Input Configuration
Playlist Shots

To temporarily disable the snap action, hold down the Alt key while moving an image
into place (the yellow snap lines will not appear). Additionally, after selecting an image,
the arrows keys can be used to nudge it into placement.

Snap to Center

Snap to Edge

Snap to Corner

Snap to an Image

Playlist Shots
You can create and broadcast shots containing multiple preselected clips. First, create
and edit the playlist shots.

Creating a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source
from the list.
1. To create a new Playlist, click the “+” in one of the layers, and select Shots.
2. Select New Playlist Shot. Then click Add.
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The playlist shot icon displays a playlist badge, the playlist duration, and the playlist
completion action.
Playlist badge
Playlist duration
Playlist completion action

Adding Clips to a Playlist Shot
To add clips to an existing playlist, do the following:
1. Click and drag the desired clips onto the layer where the playlist shot is located.

Added clips
New Playlist

2. Click and drag each shot onto the playlist shot (you must click the bottom part of
the shot icon to drag it). Wait for the playlist shot to obtain a yellow border before
releasing the mouse button.
Click and drag clip

Release when yellow boarder appears

Adding Clips to a Playlist from the Shots Menu
To add clips to an existing playlist shot from the Shots menu, do the following:
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1. Double-click the playlist icon to open the Playlist tab.
Shot List tab
Playlist tab

2. Select Shots > New Shot, and select the clips desired.
Wirecast adds the selected clips to the playlist.

Editing Playlist Shots
To edit a shot in a playlist, do one of the following:

• Double-click the shot in the playlist.
• Right-click the shot and select an item from the Change Shot Menu.
Note: Do not delete shots from a playlist while the playlist is running.

Changing the Duration of a Playlist Shot
The Change Shot menu for playlist shots has a Modify Duration option. By default, live
sources have an infinite duration (since they are not clips). For clips, you must assign a
duration time.
1. To set or change the duration of a playlist shot, right-click the shot and select
Modify Duration from the Change Shot Menu.
Wirecast displays the Shot Duration window.
2. Enter a new duration time value.
3. (Optional) Check Apply to All if you want this duration applied to all items in the
playlist.
4. (Optional) Reset the duration to its original value by clicking Reset.
5. Click OK when finished.

Adding a Live Source to a Playlist Shot
To add a live source to a playlist, click the “+” in one of the layers, and select a live source
from the list.
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Note: Wirecast does not support nested playlists: playlists within playlists).

Replay Shots
You can create replay shots that you can broadcast at any time.
See Configuring Replay + ISO.

Creating a Replay Shot from a Selected Clip
To create a Replay shot, do the following:
1. Make sure you have activated Replay.
See Activating Replay.
2. To play a clip, select the clip and click the Go button.
3. Click the Create Replay Shot button.
Since the default Replay duration is set at 30 seconds, Wirecast creates a Replay
shot that starts 30 seconds before you clicked Create Replay Shot. Wirecast places
the new Replay Shot in Layer 1 and displays the Replay controls at the bottom of
the Preview Area.
Selected clip
Go button
Create Replay Shot

Replay Shot created
Replay controls displayed
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Creating a Replay Shot from a Layer
To create a replay shot, do the following:
1. In a layer, click the plus icon (+). In the Add Shot dialog box, select Shots > Replay
Shot. Click Add.
2. In the Shot Layers tab of the Shot Editor, add additional graphics, titles or other
sources to the shot as needed.
3. Select Replay+ISO > Configure, then select Replay Settings. Select the new template
from the Replay Shot Template drop-down menu, check Program Replay, and click
OK.
4. Enable the Replay system by selecting Replay+ ISO > Start All.
5. Click the Update Replay Shot button to create a replay shot using the new template.

Newly created Replay
shot

Update Replay Shot
button

See Add Shot Window, The Shot Editor Window, Shot Layers Tab, and Replay Layer.

Trimming a Replay Shot
To trim a Replay shot from its start, do the following:
1. Select a Replay shot in a layer.
The Replay shot appears in the Preview Area.
2. Scrub the play head to the frame in the Replay shot you want to set as the start of
the shot.
3. Click the Mark In button.

Wirecast User Guide

Document Creation and Input Configuration
PTZ Cameras and Controls

4. Play the Replay shot to the frame you want to end the shot.
5. Click the Create Replay Shot button.
Your Replay Shot now contains only the content you wanted.

PTZ Cameras and Controls
You can control cameras that allow remote control of pan, tilt, and zoom (PTZ)
functions. First, configure Wirecast to support your PTZ cameras.

Setting Up PTZOptics Camera with a Dynamic IP Address
PTZOptics cameras ship with a Static IP address set to 192.168.100.88. To communicate
with your cameras on your network, you will need to change this to be in range of your
existing network.
To set up your PTZOptics camera IP address, follow these steps:
1. To obtain a usable IP address for your camera, ensure you can access the video feed
of your camera over HDMI or SDI (not IP). Since the IP address will be changing, you
need to use HDMI or SDI to access the video feed. Connect the HDMI port of the
camera to a TV, or if you are already using a capture card with Wirecast simply add
the source to your document and queue it up in Preview.
2. To set your Camera to DHCP (Automatic) and make it addressable by your PC, enter
“# * 4” (sequentially) using the camera remote control. (Do not press the buttons
simultaneously.) The camera will display a message in the video feed that says
“DHCP OPEN”, and then the camera will automatically reboot.
Note: If your camera did not display DHCP OPEN and restart automatically, you may
need to contact PTZOptics for assistance unless you are proficient in manual IP
assignment procedures not covered below.
3. When the video feed displays, enter “# * 4” (sequentially) using the remote control
to view the new DHCP address. The camera will now always request a new IP
address, whenever it is plugged into a new network.
Note: This means the IP address can change, which is generally not desirable in a live
environment.

Setting Up PTZOptics Camera with a Static IP Address
If you prefer to set a static IP address for a permanent installation, follow these steps:
1. Open a web browser, and enter the IP address obtained in the previous steps. You
can view that IP address by entering “# * 4” (sequentially) using the remote control
2. Enter admin for both the username and password.
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3. Select Network in the navigation options, located at the top-left part of the web
page.
4. Find the DHCP/STATIC setting.
5. Set IP Configuration Type to Fixed IP Address.
6. When the confirmation dialog window displays, click Apply, then click OK.
7. Recycle to power on the camera to reboot it.
Note: If you are have trouble setting the IP address on your camera, contact
PTZOptics for assistance.

Configuring The PTZ Controller
1. Get the IP address of your camera.
See Setting Up PTZOptics Camera with a Dynamic IP Address and Setting Up PTZOptics
Camera with a Static IP Address
2. To display the PTZ Controller panel, select Window > PTZ Controller.
3. Select the video ingestion method from the Camera menu. This will be an HDMI or
SDI capture device, or NDI if your device supports it.
4. Enter the IP address for your camera.
5. Port and VISCA Address are set automatically to the default values for PTZOptics
camera. You do not need to change these.
6. Click the Connection button to the far right of Status. Wirecast displays connected
when a connection is made.

Setting Up a PTZ Camera Shot
To setup a Wirecast shot using a camera setup, follow these steps:
1. To display the PTZ Controller panel, select Window > PTZ Controller.
1. Select D-Pad from the Pan/Tilt menu and move the camera to a desire position.
(Pan the camera by clicking the left and right arrows, and tilt the camera by clicking
the up and down arrows.)
2. Enter a preset number (0 to 255) and click the Save button to save this camera
position.
3. To create a camera shot, click a “+” in one of the Wirecast layers.
Wirecast opens the Add Shot dialog box.
4. Select Video Capture, select your camera from the device pane, and click the Add
button.
Wirecast places your PTZ camera shot in the layer.
5. To open the Shot Editor, double-click your camera shot from its layer. Click the Shot
Layer Properties tab.
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6. Click the PTZ triangle to display the PTZ controls. Check the Preset check box, enter
a preset number and click the Go arrow.
You are now able to move your camera by changing shots.

Opening the PTZ Controller Panel
To open the PTZ Controller panel, select Window > PTZ Controller.
See The PTZ Controller Panel.

Enabling Preset Recall for a PTZ Camera
Once you have configured a shot layer with a PTZ Preset, sending that shot to preview
recalls the preset for the camera. If multiple shots share the same video source with
different PTZ Presets configured, the shot which is currently live takes precedence over
subsequent PTZ Preset recall actions, until you drop the shot from the live feed.
To enable preset recall, do the following:
1. In the Shot Editor, select the Shot Layer Properties tab. Click the PTZ triangle towards
the bottom of Shot Layer Properties.
2. Check the Enable box. To select a preset, enter a preset number or click the up/
down arrow buttons. Click the Go button (right pointing arrow) to cause the
associated PTZ camera to go live with the recalled preset.
When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel.
See Shot Layer Properties Tab and The PTZ Controller Panel.

Twitter
You can display posts from a Twitter feed in your broadcast. First, configure Wirecast for
Twitter.

Configuring a Twitter Feed
To display contents from a Twitter feed during your broadcast, configure a Twitter feed
for Wirecast. To configure your account with Twitter, do the following:
1. Select Social > Twitter > Settings. Then click the Authenticate button.
2. When Wirecast displays the PIN field. enter your Twitter PIN
3. Select a Feed Type.
If you select Search, the Search String field becomes active., and Wirecast displays
Twitter feeds that contain a search string.
4. Click OK.
5. When Wirecast displays the Twitter window, click Authorize app.
6. When Wirecast displays the PIN window, copy the PIN, and close the window.
7. In the Twitter Settings window, enter, or paste, the PIN.
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8. Select a Feed Type. If you select Search, enter a search string containing a word or
phrase used in the Twitter feeds, and click OK.
See Creating a Twitter Shot.

Creating a Twitter Shot
To create a new Twitter shot, do the following:
1. Make sure you have configured a Twitter feed. See Configuring a Twitter Feed.
2. Select Social > Twitter > Create Shot.
3. When Wirecast displays the new shot icon in the Shot List, click it to place it in the
Preview Area.
4. Click and drag the Twitter message box to any location in the shot.
Note: When a message feed is selected, Wirecast automatically fills in the message.

Selecting Messages for a Twitter Shot
To add Twitter messages to your broadcast, do the following:
1. Click Twitter > Message Feed.
Wirecast displays the Twitter message window.
2. (Optional) Enter a term into the Search field to search for the messages you want to
broadcast, and press Enter.
3. To select messages to be rotated in your broadcast, first check Rotate Selected Every,
and enter the number of seconds of the rotation interval.
4. Select the messages you want rotated by checking the Select box at the left of each
message.
5. Choose a starting message by clicking the Live circle to the left of the message
desired.
6. (Optional) Check Auto Refresh Every and enter number of seconds for each refresh.
7. (Optional) To select all messages, click the Gear icon in the Twitter message
window, and select All from the drop-down menu.
8. Close the Twitter message window.

Facebook
You can create and display Facebook polls in your broadcast. First, configure Wirecast
for Facebook.
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Creating a Facebook Poll
Note: Wirecast displays Facebook polls in the Facebook user interface only when a
Facebook video is playing, and is fully open.
Note: Wirecast can use only Facebook Polls created within the Wirecast application
itself. You can’t import Facebook polls created within the Facebook Live user interface.
To create a Facebook poll, do the following:
1. Select Social > Facebook > Create New Poll.
Wirecast opens a dialog box for specifying the poll options.
2. Enter a question.
3. Select whether there are two, three, or four answers, and enter each answer. Be sure
to enter an answer for every option selected.
4. Check the boxes for any of the implementation options desired.
5. Click OK.
Once you’ve created the poll, Wirecast lists the poll in the Social > Facebook menu.
See Facebook.

Selecting a Facebook Poll
To select an existing Facebook poll, do the following:
1. Select Social > Facebook.
2. Select a previously-created poll from the drop-down menu.
Note: Wirecast saves Facebook polls, like Wirecast preferences, with the Wirecast
application, not with a specific document.
See Facebook.

Editing or Deleting a Facebook Poll
To edit or delete an existing Facebook poll, do the following:
1. Select Social > Facebook.
2. Select a previously-created poll from the drop-down menu.
3. Do one of the following:

• To edit the poll, select Edit.
• To delete the poll, select Delete.
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Note: Facebook does not allow you to edit a poll that is being shown, so this option is
not enabled while streaming to Facebook and using a poll.
See Facebook.

Showing or Hiding a Poll or Results when Streaming to
Facebook
The options to Show Poll, Show Results, and Hide are available when streaming to
Facebook. Once the poll has been activated, you may show a poll or show its results at
any time while streaming to Facebook. When you start streaming, the Show Poll option
is enabled, but by default, it is not selected.
There is a lag of 5 to 15 seconds between selecting a poll and having it shown in your
stream. When a poll is actually shown in your stream, a check mark is added to its menu
item and Wirecast enables the Show Results and Hide options.
To show or hide a Facebook poll or Facebook poll results, do one of the following:

• To show a Facebook poll, select Social > Facebook > Show Poll.
• To show the results for the Facebook poll, select Social > Facebook > Show Results.
Note: Showing a Facebook poll closes the poll to further responses.
Note: On Facebook, polls are not automatically shown. The viewer must click on the
video to see or vote on a poll.
To hide the Facebook poll and results, select Social > Facebook > Hide.
Note: You may hide a poll only if it is the active poll. Showing a different poll, or
showing the results for a different poll, hides any other polls being shown. This allows
you to show a poll, or show the results of the poll, and then hide it.
See Facebook.

Rendezvous
Creating a Rendezvous Session
Rendezvous provides an easy way to organize a video conference with up to two
guests in Wirecast Studio, and up to seven guests in Wirecast Pro. You can bring in live
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video feeds from a computer or smart device running a supported web browser, or
from iOS devices running the Wirecast Go app.
To create a Rendezvous session, do the following:
1. select Rendezvous Session from the Shot Menu, then select Create Rendezvous
Session.
2. In the Creating Session window, optionally select Enable chat for session and/or
Share chat history, then click Create Session.
3. In the Created Session window click the Click to Copy button to copy the
Rendezvous URL to the clipboard. Send this URL to the participants that you want
to invite to the broadcast.
4. Click OK when finished.
See also Rendezvous Essentials.

Adding NDI™ Sources to Rendezvous
Wirecast lists any NewTek NDI source on your local network under the Network option
in the Add Source Menu. To add an NDI source to a shot, do the following:
1. In a layer, click the “+” icon.
Wirecast opens the Add Shot dialog box.
2. Select Network.
3. Select the NDI source from the list of sources in the right-side pane, and click Add.
Wirecast create a shot for the NDI source selected.
Note: You can also check GPU Decoding for NDI sources. When checked, incoming
sources will use your GPU to process the incoming source (potentially saving you
some CPU processing power).
When the Rendezvous Dashboard displays, select video source, audio source and audio
output. You can also make a copy of the URL to send to participants by clicking Copy.
Send the session URL (copied above) to your participants and instruct them to use this
URL in a browser to join the Rendezvous session you just created.
Note: The only browsers supported by Wirecast for joining a Rendezvous session are
Chrome and Firefox.
See NDI Devices in the Shot Layer Properties Tab.
See also How to setup a NDI Discovery Server to resolve NDI connectivity issues in
Wirecast.
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Joining a Rendezvous Session
To join a Rendezvous session on a remote computer (or smart device), paste the
obtained URL into a browser and press the Enter key to initiate a connection with
Wirecast.
Note: The only browsers supported by Wirecast for joining a Rendezvous session are
Chrome and Firefox.
When the Wirecast Rendezvous window appears, select a camera and microphone
from the drop-down menus by clicking the gear icon. You can, optionally, mute the
camera or mic by clicking on either icon. Enter an identification in the Your Name field
and click Join.
Note: Wirecast Go, running on iOS devices, can join a Rendezvous Session by
opening the URL. Android devices can join a session by opening a Session URL (sent to
them) using a Chrome browser.
After you click Join, the Rendezvous window will display a Waiting to join message until
the Wirecast host has added you as a participant.

Participant Options
Once you have successfully joined the Rendezvous session, the window will display the
camera shot from Wirecast and from your local computer. In this window you can mute
the audio or hide video of your resources or those coming from Wirecast. You can also
adjust your settings by clicking on the gear icon.
Mute local audio
or hide video
Local
camera

Wirecast
host camera

Mute WC host
audio or video
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You can also share your screen (instead of your camera) by clicking on the gear icon and
selecting Share Screen.
When the Share Screen window displays, select the screen you want to share and click
Share.

Adding a Participant Shot to Rendezvous
Whenever participants are waiting to join the Rendezvous session, a participant icon
displays in both the Wirecast default layout and the Rendezvous Dashboard. Click on
the icon and select a participant to add to the session.

Local camera

Participant
camera

“P” icon (see
note below)
Click on icon

Select participant

Note: If at any time Wirecast displays a “P” icon to the right of a user’s name, it
indicates that the connection is “proxied” through the Wirecast TURN infrastructure,
and traffic is flowing through WC servers. In most cases, Rendezvous traffic does not
flow through Wirecast proxy servers. Data flows only through Wirecast servers if the
user’s server cannot be connected directly (this typically happens in the case of
restrictive firewalls). Otherwise, the traffic flows peer-to-peer and there is no need to
worry about Wirecast server capacity. See also Wirecast Network Ports and Proxy
Servers.
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Create a shot of a participant by clicking the shot menu and selecting a participant. The
participant is automatically added when you create this shot.

Select
participant

Click Shot Menu
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Wirecast displays your new Rendezvous shot on the shot level from which it was
selected. Select the shot to display it in the Preview Area where you can place it and size
it as needed.
You can also select your local camera and mic as an integrated Webcam shot on
another layer and add it to the Preview Area by selecting it.
From the Rendezvous Dashboard in Wirecast, you can mute audio or hide the camera
of your local sources (or of those who have joined). To do this click the camera or mic
icon of the source to mute. You can also disconnect at any time by clicking the
Disconnect button.
You can also select the Live Broadcast Area as your Rendezvous display (instead of your
local camera). To do this, click the camera icon and select Live Output. You can add live
output audio by clicking the mic icon.

Enabling Rendezvous Chat
There are times in a live interview where you need to communicate privately with your
guests. That is the purpose of the Rendezvous Chat feature in Wirecast.
When you initiate a Rendezvous session, you will be asked to choose the chat settings
for that session.
The Enable chat for session option enables a chat dialog between you and your guests.
If you select Share chat history with new session participants, any new guests that arrive
at any time in the session will see the full chat history. If you don't select this option,
new guests will only see chat messages that occur after they have joined the session.
When you select Create session, your Rendezvous Session will be created, and you can
copy/send the link to your guests.
Click OK and your Rendezvous Dashboard will appear. There will be a panel on the right
side of your Dashboard that, when clicked, will slide-out to reveal the Rendezvous Live
Chat panel.
You can open and close that panel at any time by clicking on the “>>” icon to the left of
the Live Chat panel.
You will receive a notification if a guest types a message, even if you have the Live Chat
panel closed or the Rendezvous Dashboard is not in focus.
Host and guests can type into the message window to communicate. This chat panel
will not be seen on the live broadcast, so you can type private messages you might not
want to say over the live stream.
Each guest's name will appear above any messages they send. If you have several
guests, each guest will have a different color assigned to their chat bubble windows, for
easy identification.
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You, as the host, can select Clear Chat in the top right corner of your Live Chat panel, at
any time, and all the messages will be cleared from your, and your guests', Live Chat
panel.
Your guests connecting through a browser, like Chrome, will also see a Live Chat panel
in their browser.
They can close their Live Chat panel by clicking on the X in the top of their panel.
If a message arrives for a guest when they have their Chat panel closed, they will get a
green dot on the chat icon, which they can press to re-open their chat panel.
If a guest disconnects and reconnects to the same session, they will still be able to see
the chat history (as long as you selected to enable chat history).
However, if you disconnect your session and force Guests to disconnect, then your chat
history will be deleted.

Ending a Rendezvous Session
When you are ready to close your session, click Stop Session.
When you disconnect from a Rendezvous session, your camera is removed in the
participant’s browser and the participant’s camera is removed from your local session
window. To reconnect to the previous session click Reconnect to previous session. When
you do this, everything is restored as long as the remote browsers are still open. If a
remote browser has been closed, it can still reconnect by re-joining, using the same
URL that was used previously. You can also start a new session by clicking Start Session,
but you will have to copy and send a new URL to all potential participants.
See Rendezvous.

Resizing the Shot Icons
You can resize the shot icons on any layer by clicking and dragging the edge of the
layer window.

Click and drag
window edge

Resized layer
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Setting Transition Speed
The transition speed is set by selecting Switch > Transition Speed. There are five settings:
Slowest, Slow, Normal, Faster, and Fastest.

Determining the Transitions for the Transition
Buttons
To assign a type of transition to a transition button, do the following:
1. Click the down-arrow on the right side of the transition button
2. From the drop-down menu, select a new transition to assign to that button.
3. See Transition Controls, and Setting the Number of Transition Buttons.

Images/Opacity
Wirecast supports a wide variety of still images types (TIFF, GIF, JPEG, PNG, etc.). Some
of these formats offer some form of opacity (or transparency). This is often called an
Alpha Channel. Wirecast works seamlessly with these formats making them the
preferred methods for using graphics and logos which have transparency.

GIF and Transparency
GIF files are a special case because they only offer transparency and not a true Alpha
Channel. The GIF format enables you to define part of the image as transparent
(completely invisible), but does not enable you to define it as partially transparent.
Some GIF images use transparency for much of the image. However, near the edges of
the visible data, transparency cannot be used. This happens quite often when there is a
shadow near the edges of the visible data. The author of the GIF often assumes a
certain background color (white, for example) and that color becomes embedded in
the actual image.
When Wirecast displays these types of images, the edges of the visible data shows the
background that was saved in the GIF. This is not a defect in Wirecast and, therefore,
Wirecast can only present the data as it exists in the GIF. The solution is to obtain the
original image and re-save the image as either TIFF or PNG. Both of these formats offer
full Opacity.
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The Preview Area
You can preview media files in the Preview Area.
See Preview Area.

Viewing the Preview Area
To display the Preview Area, select Layout > Show Live and Preview, or Layout > Show
Preview Only.
See Preview Area.

Viewing a Shot in the Preview Area
To view a shot in the Preview Area, click a shot in a layer.
Wirecast displays the shot in the Preview Area.
See The Default Layout, Viewing the Preview Area, and Preview Area.

Magnifying the Preview Area
Another control available at the bottom of the Preview Area is the Magnification control.
Click the magnifier icon (spyglass) to display a magnification slider. Slide the slider to
the left for lower magnification of the In and Out controls, and to the right for greater
magnification.
Magnifier icon

In and Out point
controls

Magnifier slider

For example, if you move the slider to the right, the In and Out controls move farther
apart, increasing the magnification, so that you can more easily adjust the location of
the In and Out controls. This is very helpful when you have long-duration shots.
However, the slider will quit sliding when you have reached the maximum size of the
shot.

In and Out point
controls moved

Magnifier slider
moved right
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Setting the Speed of Preview
One more control is available at the bottom of the Preview Area. It is the speed control.
You can set the playback speed of the shot by clicking the speed icon (“1x”) and
selecting a speed from the pull-down menu. Your choices are 1x (normal speed), 2x
(double speed),.5x (half speed), and .25x (one-fourth speed). The audio is muted for any
speed other than normal.
Click the speed icon

Select a speed

Adding and Modifying Template Placeholders
There are nine default placeholders (labeled A through I). If you need more, you can
create your own. All existing Placeholder letters will appear in the list of available
placeholders, and the current assignment of each placeholder will display next to the
letter.
Select New Placeholder and click Add to generate a new placeholder.
Wirecast displays the new placeholder shot in the shot editor, and displays its
Placeholder [#] in the list of placeholders.
The next time you choose Add Source > Placeholders, you will be able to see and choose
that newly generated Placeholder from the list.
Note: Wirecast saves new placeholders in the document. These placeholders don’t
appear in newly created documents. You can’t assign media to a placeholder with New
Placeholder > Add. You can add an existing placeholder to a shot, or add a new
placeholder.

Assigning Media to Placeholders
To assign media to a placeholder, do one of the following:

• Select Media Menu > Assign Placeholder. Any placeholders that have been added to
shots will appear in the drop-down of the Assign Placeholder menu item. Clicking
on one of the available Placeholders will open the Add Source dialog box, where
you can assign a source to that Placeholder. When you assign a Source to a Placeholder, that source will be assigned to the Placeholder in every shot that Placeholder is used.
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• In the Shot Layers tab, click on the Gear Menu of any Placeholder and select Assign
Placeholder. This will bring up a drop-down where you can choose a source to be
assigned to your Placeholder.

• Right-Click on a Placeholder in the Preview Area.
• This will bring up a similar Assign Placeholder drop-down menu where you can
select a source to replace your Placeholder.

Media does not have to already be in the document in order to select/assign it. The
exception to this is Rendezvous Guests. You cannot assign them to a placeholder until
they have joined the broadcast.
Resetting Placeholders
Select Media> Reset Placeholder, then select a Placeholder to remove any media
assignments.
Indicating Media is assigned to a Placeholder
There are two places to see what source/media is assigned to any particular
Placeholder:
1. In the Add Source Dialog box you can see a list of available Placeholders and see
what they're currently assigned to.
2. Select Media > Assign Placeholder. Then select a current placeholders and its
assignment.
Adding placeholders to shots or templates
You can add a Placeholder to any shot in the same way you can currently add a source.
Click the Add Source menu, select Templates and choose a Placeholder.
Creating customized Shot Templates
You can configure any shot with a Placeholder and save it as a Template Shot. Click the
Shot Gear menu then select Save as a Template.
When the dialog box displays, enter a template name and click OK.
Once saved as a Template shot, it will appear in the Add Source > Template Dialog box,
as a Custom Template.
Custom Templates are saved in Global Preferences so that you can access your Custom
Template across different documents.
Note: Any Placeholders that are in your Custom Template will revert to an unassigned
Placeholder, (even if that Placeholder was assigned to a Source when you saved the
Custom Template)
Deleting Custom Templates
To delete a Custom Template select Add Source > Templates > Shot Template to open the
Custom Templates window. Select the template to delete, then click Delete Template.
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This will delete it from your Global Preferences, so that Custom Template will no longer
appear in the Shot Templates window. However, shots in any documents using this
Shot Template will not be deleted, they will simply no longer be a Template shot.

Shots
New Shot
Creates a new shot. Select and click the Add button.
New Playlist Shot
Creates a new Playlist shot. Select and click the Add button.
New Shots From Clipboard
Creates a new shot that has been copied to the clipboard. This is how you duplicate a
shot. Select and click the Add button.
Favorites
Displays a list of shots that have been marked as a Favorite by clicking on the star on
the right side of each shot in the Add Shot Menu.
All
Displays all sources in one list.
Add Media File
Creates a Media File shot (video clip or picture). When selected, a navigation widow
displays. Navigate to a media file location, select a media file, and click Open. (See Media
File Properties).
See Templates.

Reassigning Media
The Asset Manager is used to change the sources of media in your document. It is
accessed by selecting Media > Show Asset Manager.
Wirecast stores a path to your media in the Wirecast document. If you relocate your
media, Wirecast no longer is able to find them. In this case, use the Asset Manager to
reassign the new media locations. However, Wirecast does keep track of the relative
path to your media. If you move both the document and media to a new position,
Wirecast still finds the media.
To reassign media, follow these steps:
1. To open the Asset Manager, select Show Asset Manager from the Wirecast Media
menu.
2. Select the media you want to assign to another source.
3. Some media assets (i.e. cameras) enable you to set the aspect ratio by displaying a
Device Aspect Ratio menu. You can select an aspect ratio from this menu.
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4. Select the desired media file from the Assign To menu; or click Browse and locate the
desired media file, and then select the desired media file.
Note: When Remote Desktop Presenter is selected as the source, you can enter the IP
address for the RDP. This enables you to build a Wirecast presentation with placeholders and then reconfigure at a later date to accommodate a new presenter with a
new Remote Desktop Presenter as a source. Click Apply, then click the corresponding
icon in the Shot Selection.
5. Click Apply to replace the existing media, then close the Reassign Media window.
Note: You can also select an item from the list and click Delete to remove it. Or, you
can click Delete All to clear the list.

Supported Codecs
Shown below is a list of supported video and audio codecs.
Video Codec
AVC
H264
DVC25
DVCPRO50
DVCPRO100
MJPEG
ProRes

MOV
MP3 MPEG-4 WAV AIFF
ASF
(M4V)
ISO (MP4)
(AIFF, AIF) (WMV)
YES
NO YES
NO NO
NO
YES
NO YES
NO NO
NO
YES
NO NO
NO NO
NO
YES
NO NO
NO NO
NO
YES
NO NO
NO NO
NO
YES
NO NO
NO NO
NO
YES
NO NO
NO NO
NO
(mac only)
YES
NO NO
NO NO
NO

QuickTime
Animation
VP8
NO
VP9
NO
Windows Media NO
Video
Audio Codecs
AAC
MP3
Opus
PCM
Vorbis

YES
YES
NO
YES
NO

WEBM

NO
NO
NO
NO
NO
NO

NO NO
NO NO
NO NO

NO NO
NO NO
NO NO

NO
NO
YES
(windows)

YES
YES
NO

NO
YES
NO
NO
NO

NO
NO
NO
YES
NO

NO
NO
NO
NO
NO

NO
NO
YES
NO
YES

YES
NO
NO
NO
NO

NO
NO
NO
YES
NO
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Windows Media NO
Audio
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Before you can broadcast with Wirecast, you must configure your output settings.
Wirecast enables you to specify many output settings for your presentation. You can
configure Wirecast to broadcast multiple data rates simultaneously, broadcast with
different encoders at the same time, or use Windows Media Encoder to record your
broadcast to disk.

Topics

■ Destinations
■ Encoder Presets
■ Streaming
■ Configuring Replay + ISO
■ Recording To Disk

Destinations
To broadcast with Wirecast, you define at least one destination. A destination can be a
broadcast server, content distribution network, or local disk recording.
See The Output Settings Window.

Destination Settings
Wirecast offers several default presets. The first choice you need to make is whether
you'll be using RTMP Server, SRT (Secure Reliable Transport), Windows Media, or some
combination as the broadcast technology. This decision depends on what you expect
your viewers to use. Given enough bandwidth, you can stream to combinations of
RTMP Server, and Windows Media by adding new destinations to the output settings.
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Note: To use Push To Server, you must have a good local Internet connection and
access to a Windows Media Server. Pushing your broadcast to a Windows Media Server
moves the bandwidth strain from your local machine to the external server.

Multicast and Unicast Destination Settings
You can select Multicast or Unicast from the Destination drop-down menu. Multicast
lets you broadcast to multiple computers simultaneously. Unicast lets you broadcast to
a specific computer.
You need to create an SDP File, and you must do so every time you change any option
on this page (including the encoder preset). To create an SDP file click the gear icon to
the right of the Destination field. Select Save SDP File, navigate to the desired location,
and click Save in the Save File dialog window. The SDP file must be given to the user to
place on the computer that receives your broadcast.
During multicast, your broadcasting computer sends data across your local network,
identifying it as a broadcast that it has no specific destination. Since many applications
could be doing the same thing, the broadcasting computer must have a unique way of
defining the data that is being multicast. This enables clients to choose between the
available multicast streams.
The multicast protocol uses unique addresses, one for video and one for audio.
Although these unique addresses look like TCP/IP addresses, they are not. Instead, they
provide a way to define uniqueness among all multicast data flowing over the network.
Once the broadcasting computer is streaming this data through the local network, any
computer on the network can receive it.
The SDP file becomes the glue between your broadcast computer and the viewer
computers. The SDP file contains multicast addresses, encoding format, and other
important information.

Selecting a Destination
To select a destination for a broadcast, do the following:
1. Select Output > Output Settings. Select a destination from the Destination dropdown menu.
Wirecast displays the Output Settings dialog with presets for the destination you
selected. Each Output Settings dialog has a unique set of controls and a way to
authenticate your connection.
2. (Optional) To view more destinations in the Destination drop-down menu, click
More in the Select an Output Destination dialog. Check the box for each destination
you want to include in the destination menu list. Uncheck the box for any
destination you want removed from the list of destinations for the broadcast.
3. , Click OK
See The Output Settings Window.
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Adding a Destination
To add a destination for a broadcast, do the following:
1. Select Output > Output Settings.
2. In the left-side pane, click Add.
Wirecast displays the Select an Output Destination dialog.
3. Choose a destination from the Destination drop-down menu.
4. (Optional) To view more destinations in the Destination drop-down menu, click
More in the Select an Output Destination dialog. Check the box for each destination
you want to include in the destination menu list.
5. Click OK.
Note: You can add as many destinations as you need, but keep in mind that each
additional destination requires additional system resources.
See The Output Settings Window.

Removing a Destination
To remove a destination from a broadcast, do the following:
1. Select Output > Output Settings. Select a destination from the Destination dropdown menu, and click OK.
Wirecast displays the Output Settings dialog with presets for the destination you
selected.
2. In the left-side pane, select the destination you want to remove.
3. Click Remove.
4. Click OK.
See The Output Settings Window.

Modifying Windows Media Server Destination Settings
Windows Media can be used to broadcast WMV8, WMV9 and WMV9 Advanced.

Push To Server
To access the Windows Media Push To Server window, select the Windows Media
Streaming destination. In the Output Settings dialog, check the box for Push to Server.
Address Enter the Internet address of the Windows Media Server you use to broadcast.
Publish Point Enter the name of the file that is put on the server, and that is used as
part of the URL that your users use. Wirecast cannot know the resulting URL that your
users use, as this may vary depending on the installation of the Windows Media Server.
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Contact your Windows Media Server administrator to understand how to build a
proper URL for your viewers, based on the Publish Point.
Auto Remove Check Auto Remove to remove the file used as the publish point when
the broadcast is over.
Username/Password Enter the user name and password for the Windows Media
Server. Contact your Windows Media Server administrator to obtain these. If there is no
user name or password required, leave these fields empty.

Pull From Server
To access the Windows Media Pull From Server window, select any of the WindowsMedia-based presets from the Encoding drop-down menu. Check the box for Pull From
Server.
To use the Pull from Server option, set the port number that your users use to connect
to your computer. Connect by using the Open URL option in Windows Media Player,
and enter a URL. For example, if your computer IP address is 10.0.5.55 and your port is
1755, use mms://10.0.5.55:1755.
Port Number Enter the port on your computer to use as the broadcast port. This can
be, effectively, any port number as long as it doesn't conflict with any existing ports on
your computer. Be aware that if you have any firewall software installed, you need to
enable the port entered here.
See also Wirecast Network Ports and Proxy Servers.
Maximum Connections The maximum number of connections your server accepts is
50 users. Your CPU is affected by the number of users you have connected, therefore
you may need to limit the number of connections.
This option turns your local computer into a mini Windows Media Server, enabling you
to broadcast immediately. There are, however, some limitations:

• User Requirement You cannot have more than 50 users connected at any one
time.

• Bandwidth Requirement You must have enough bandwidth on your Wirecast
computer to supply all of your viewers.

• CPU Requirement Since the Wirecast computer is acting as a server the CPU must
be fast enough to handle all of the user connections.

The greatest issue with this method is bandwidth. If, for example, all of your viewers are
on a local network (a business or school), then you should be able to use this method.
However, if you have a DSL connection to the Internet and you want to broadcast a
200k stream to 20 viewers, you may not have enough upload bandwidth to
accommodate this.
Note: Be aware that when you use Wirecast with an Internet connection what matters
is your upload bandwidth. Most ISP businesses offer packages that have a higher
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download than upload bandwidth (e.g., a 512k DSL package is often only 256k
upload).
See The Output Settings Window.

Modifying RTMP Server Destination Settings
Wirecast can stream to an RTMP/H.264-compatible streaming server such as RTMP
Server Media Server or Wowza Media Server.
To configure RTMP Server Streaming, follow these steps:
1. Select Destination > RTMP Server.
2. Select an encoder.
3. Enter the Address to the RTMP server. The default RTMP port is 1935, but you may
need to configure your firewall to allow connections on this port.
4. Wirecast can import a RTMP Server Encoder configuration file (XML file). Click Open
FMLE XML File, and navigate to the configuration file and select either version 2.5 or
version 3.0. Wirecast reads the Address and Stream information from that file. Many
online streaming services offer FMLE configuration files which Wirecast can use.
Note: Only the Address and Stream information from the XML configuration file is
used. No Encoding information is imported.
5. Click OK to save your settings:

Modifying SRT (Secure Reliable Transport) Destination
Settings
Wirecast can stream to SRT (Secure Reliable Transport), an open-source video transport
protocol that enables the delivery of high-quality and secure, low-latency video across
the public Internet. SRT Supports x264 and Apple H.264 encoding methods.
To configure SRT Streaming, follow these steps:
1. Select Destination > SRT:Secure Reliable Transport.
2. Select an encoder.
3. Enter the Address, Port, and Passphrase to the SRT.
4. Click OK to save your settings:

Modifying CDN Partners Destination Settings
Listed below are the Content Distribution Network (CDN) partner destinations available
in Wirecast. Most destinations share a common user interface and only require a user
name and password. Destinations that do not conform to this paradigm, or require
additional parameters, are presented separately.
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Note: The list of CDN partners in Wirecast is subject to change at any time.

Most Common CDN Configurations
To stream to one of these CDN partners, do the following:
1. Select Output > Output Settings.
Wirecast opens the Output Settings dialog box.
2. Select a CDN partner from the Destination drop-down menu.
3. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
4. Enter your username or email.
5. Click Authenticate to enter your password and generate the RTMP URL. You only
need to do this one time because Wirecast stores the channel information for
future streams. The default RTMP port is 1935. You may need to configure your
firewall to enable connections on this port.
Note: If you do not have a username and password, you can sign up with a CDN
partner by clicking Sign Up.
6. Select your channel.
7. Optionally, you can refresh your connection by clicking Refresh.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 30
seconds
9. Click OK when finished.

Modifying Azure Media Services and Sermon.net
Destination Settings
To stream to one of these CDN partners, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select a CDN partner from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this is provided by the CDN partner).
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Note: If you do not have a stream name and password, you can sign up with the CDN
partner by clicking Learn More.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
8. Click OK when finished.

Modifying Brightcove and Limelight Destination Settings
To stream to one of these CDN partners, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select a CDN partner from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this is provided by the CDN partner).
7. Click Set Credentials to enter your Username and Password.
Note: If you do not have a stream name and password, you can sign up with the CDN
partner by clicking Learn More.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
9. Click OK when finished.

Modifying Akamai Destination Settings
To stream to Akamai, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Akamai from the Destination menu.
3. Select an encoder.

Wirecast User Guide

81

82

Output Configuration

4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your Akamai Stream ID and Event Name.
6. Enter your Akamai Angle and Video Rate.
7. Enter your user name and click Authenticate to enter your log in information.
Note: If you do not have a username and password, you can sign up with Akamai by
clicking the Akamai icon, or by clicking Sign Up.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
9. Click OK.

Modifying LinkedIn Live Destination Settings
To stream to LinkedIn Live, follow these steps:
1. Enter a Name for your destination.
2. Select LinkedIn Live from the Destination menu.
3. Select an Encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Select On Behalf of Organization or Member and click Login.
6. When the login window displays, enter email/phone and password information,
then click Sign In.
Note: If you do not have a username and password, you can sign up with LinkedIn
Live by clicking Join Now.
7. Select an Organization.
8. Select a Ingest Region.
9. Enter your Post information.
10. (Skip ahead to step 11 to create a targeted audience.)
To create an event, check Event, enter a URL, and click Verify URL.
11. (Skip ahead to step 14 if you created an event.)
To create a targeted audience, check Audience Targeting and Click Setup.
12. When the Setup window displays, select multiple regions.
13. Select Languages and click OK.
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Note: Your target audience must include at least 300 members.
14. Check Draft (optionally) if you want your post to be just a draft, and click Create
Broadcast.
15. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
16. Click OK.

Modifying LiveArena Destination Settings
To stream to LiveArena, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select LiveArena from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your LiveArena Account ID, User Name, and Password.
6. Click Apply.
Note: If you do not have a username and password, you can sign up with LiveArena
by clicking the LiveArena icon, or by clicking Sign Up.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
8. Click OK.

Modifying Twitter/Live Broadcast Destination Settings
To stream to Twitter follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Twitter from the Destination menu.
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3. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
4. Click Plus (+) to enter your username and password.
5. Copy the Authorization Code and click on the URL below it.
6. When the Authorization Code window displays, paste in the code and click
Authorize.
Note: If Wirecast does not display the Authorization Code window, or if Wirecast
displays an error window, clear your browser history or try using a different browser.
Then, sign in again.
7. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the length of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
8. Click OK.
See also Wirecast: Streaming to Twitter using RTMP Output Destination.

Modifying Twitch Destination Settings
To stream to Twitch, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Twitch from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter your Twitch username.
6. Click Authenticate to open the Twitch Log In window.
Note: If you do not have a username and password, you can sign up with Twitch by
clicking the Twitch icon or by clicking Sign Up.
7. When the Twitch Login window displays, enter your username and password and
click Log In.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
9. Click OK when finished.
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Modifying Vimeo Destination Settings
To stream to Vimeo, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Vimeo from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Click Authenticate to enter your username and password.
Note: If you do not have a username and password, you can sign up with Vimeo by
clicking Sign Up.
6. When the Authorization window displays, click Allow.
7. Click the plus (+) icon to add a new event.
8. Enter your email and password, then press Enter.
9. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
10. Click OK when finished.

Modifying Wowza Streaming Engine Destination Settings
To stream to Wowza Streaming Engine, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Wowza from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter the domain name or IP address (this is provided by the CDN partner).
6. Enter the stream name of your broadcast (this may be provided by the CDN
partner).
7. Click Import Wowza Config to import a Wowza configuration to use.
8. Select User Agent. Default is Wirecast/FM1.0.
9. Click Set Credentials to enter your Username and Password.
Note: If you do not have a stream name and password, you can sign up Wowza.
10. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
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0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
11. Click OK when finished.

Modifying Zixi Destination Settings
To stream to Zixi, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Zixi from the Destination menu.
3. Select an encoder.
4. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
5. Enter Zixi connection information.
6. Enter your Zixi channel name and password.
7. Click Apply to generate the RTMP URL. You only need to do this one time because
Wirecast stores the channel information for future streams. The default RTMP port
is 1935. You may need to configure your firewall to enable connections on this port.
Note: If you do not have a username and password, you can sign up with Zixi by
clicking the Zixi icon, or by clicking Sign Up.
8. Optionally, enter a Stream Delay value. This provides a time buffer between your
live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. However, greater delays require greater memory use. The amount
of memory used is displayed when you enter the amount of delay.
Note: We recommend keeping stream delay as low as possible, ideally less than 300
seconds.
9. Click OK.
See also Wirecast: Streaming to Destination Zixi.

Modifying Facebook Live Destination Settings
To stream to Facebook, follow these steps:
1. Optionally, enter a Name for your destination.
2. Select Facebook Live from the Destination menu (if not already selected).
3. Select an encoder from the Encoding menu.
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4. Choose the audio track to be used by selecting it from the Audio Track Selection
menu.
5. You can (optionally) click the Map button to open the Multi-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
Note: If you change the encoding settings while streaming to Facebook, an error will
occur. The encoder settings are set by Facebook.
6. To log into Facebook, do one of the following:
– To log into Facebook with a user account, click Authenticate and log into
Facebook. If you already are logged into Facebook, you can click the Change
button to log into a different Facebook account.
Note: If you do not have a username and password, you can sign up with Facebook
by clicking the Facebook icon, or by clicking Sign Up.
– To log into Facebook with a one-time stream key instead of a user account, click
Pair Device. Wirecast opens a dialog. Follow the instructions given in the dialog.
7. Select Go Live Now or Schedule for Later from the Post To menu.
8. If you selected Schedule for Later, select also a start date and a time.
9. Select Pages, Profile, or Groups from the Post To destination menu. Click Refresh to
refresh the page list. If planning to use co-branded content, check the Show verified
pages only checkbox to filter out all non-verified pages. Enter a Title and a
Description. Click Create to refresh after changing any settings.
10. If you selected Go Live Now, select also Pages, Profile, or Groups and enter a Title and
Description (as described in step 9 above). Optionally, click Advanced Options.
If you select Pages, you can also select Crosspost, if desired.
11. If you selected to post to a Profile, select also a level of Privacy: Public, Friends, or
Only Me.
12. Click Create to start an event on Facebook. You can, optionally, optimize your
connection by clicking Optimize Connection. When you do a progress bar is
displayed while optimization is performed. Click Cancel Speed Test at any time to
cancel your optimization request.
13. Click OK when finished.

Modifying Microsoft Stream Destination Settings
In order to broadcast using Microsoft Stream, you must first configure your streaming
using Office 365. For a detailed procedure on how to do this visit the Telestream
Knowledge Base at:
https://support.telestream.net/s/article/Wirecast-10-Publish-to-Microsoft-Stream

Wirecast User Guide

87

88

Output Configuration

1. When Wirecast displays the Output Settings window, select Microsoft Stream as your
Destination, and click OK.
2. When Wirecast displays the Output window, select an Encoder and Audio Track for
the stream. Paste in the address copied from Office 365 where streaming was
initiated.
3. (Optional) Enter a Stream Delay if needed. Click Ok when finished.
4. (Optional) Click the Map button to open the Muti-Track Input Mapper. For each
channel, select (by checking the box) one or more inputs.
Click OK when finished.

Modifying YouTube Destination Settings
Note: Custom encoders cannot be used to stream to YouTube. They may only be used
to encode a recording to disk.
To stream to YouTube, follow these steps:
1. Log into your YouTube account using your browser.
2. Optionally, enter a Name for your destination.
3. Select YouTube from the Destination menu.
4. Select an encoder.
5. You can (optionally) click the Map button to open the Muti-Track Input Mapper. For
each Channel, select (by checking the box) one or more inputs.
6. Check Use Backup Server if you get an error when authenticating, or the application
tries to connect and then crashes.
Note: At times the primary streaming servers at YouTube go down for maintenance or
other reasons. When Wirecast users attempt to connect to these servers, especially when
using YouTube's "Stream Now" feature, they are unable to connect.
7. Click the plus (+) icon to add a new event.
Note: If you do not have a YouTube account, click Sign Up (or go to
www.youtube.com).
8. Enter all of your event information and click Save.
Note: Click the Details button to get more information from Google.
9. Click Authenticate, enter your login information, and wait for your event to appear
in the Event menu box. Click the minus icon (-) to remove a selected event.
Optionally, enter a Stream Delay value. This provides a time buffer between your
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live stream from Wirecast and the actual broadcast itself. You can set the delay from
0 to 999 seconds. Click OK when finished.
Note: If you are not already signed in, a browser with is launched enabling you to
sign into your YouTube account. Enter your account information and click Sign In.

Encoder Presets
Without compression, the bandwidth of audio-video data can be too large to
successfully broadcast across a network. An encoder is a program that compresses
audio, video, or both, for broadcast. Wirecast supports a wide variety of encoders, also
known as codecs.
The settings for encoders range from simple to very complex. Wirecast offers presets of
the most common settings for encoders. This provides a starting point, reduces
complexity, and enables you to experiment and adjust settings as you test your
broadcast.
Note: Encoder Presets can be edited from the Output Settings window. To do this
select Output > Output Settings, click the gear icon, then choose View Details from the
drop-down menu.
See The Encoder Presets Window.

Selecting an Encoder Preset
To use an encoder other than the default, select an encoder from the Encoding dropdown menu in the Output Settings dialog.
Note: Click More next to the Destination field to display a list of all available
destinations. Check the box for each destination you want to include in the
destination menu list.
Note: Click Filter from the Gear menu next to the Encoding field to display a check list
of encoder presets. Check the presets you want to display in the Encoder Presets menu.
Click Save when finished.

Creating an Encoder Preset
The default encoder presets cannot be changed. However, you can make a copy of any
preset, modify it as needed, and save it under a new name. You can refer back to the
default presets at any time since they are never modified.
To edit an encoder preset, do the following:
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1. Select Window > Encoder Presets.
2. Select a preset to edit from the Encoder Preset drop-down menu.
3. Change the settings as desired.
4. Click Save As. Enter a name for the edited preset.
5. Click OK.
Note: Click New Preset from the Gear menu next to the Encoding field to create a new
encoder preset. Enter a name for your new preset and click OK. (See Creating New
Presets).
Note: Click View Details from the Gear menu next to the Encoding field to modify an
encoder preset. (See Creating New Presets). One important option is Strict Constant
Bitrate. When checked, the bitrate is strictly held at the bitrate entered in Average bit
rate.

Modifying the MainConcept H.264 Preset
To modify a MainConcept H.264 preset, follow these steps:
1. Select Window > Encoder Presets.
2. Select the MainConcept H.264 encoder preset from the Encoder drop-down menu.
3. To encode video, check the Video Encoding checkbox.
When checked, the video for your broadcast is encoded. When Video Encoding is
unchecked, the output contains a blank video screen.
Note: To create an audio-only broadcast, uncheck Video Encoding and check Audio
Encoding (AAC). To create a video-only broadcast, check Video Encoding and uncheck
Audio Encoding (AAC).
4. Enter the desired width, in pixels, into the Width field.
5. Enter the desired height, in pixels, into the Height field.
6. Select the desired framerate, into the Frames per second field. This value is a target
value for the encoder. The exact value of the output is not guaranteed.
7. Enter the average bit rate in Kbits (1000 bits) per second into the Average bit rate
field. This is the target bit rate of your video. Higher numbers provide better quality.
The connection speed of your audience is a significant factor in determining your
target bit rate. The encoder compresses the video to approximate this target.
However, at different times during your broadcast the bit rate may be higher or
lower than the target rate.
8. Select an encoder profile from the Profile menu. Three profiles are provided:
Baseline, Main, and High. The Baseline profile is commonly used in mobile
applications. It is also used in other applications which operate with limited
processing power, storage capacity, and/or bandwidth. The Main profile is
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appropriate for general-purpose applications of broadcast media, such as highbandwidth Internet broadcasting. The High profile provides the highest broadcast
quality encoding.
9. (Optional) Key frame every allows you to enter the number of frames. A movie is a
sequence of images and each image is called a frame. To compress video data,
most encoders take a frame and make it a reference (also known as a key). This
keyframe is sent as part of the broadcast, and all of the data after that keyframe is
relative to it. The benefit of this is that the compressor only needs to send what has
changed since the last keyframe. The main drawback of this is that over time it
becomes harder for the encoder to distinguish the frame-difference information,
especially if there is a lot of motion in the video. Another drawback is if your
viewer’s computer misses a keyframe, the video is distorted until the next keyframe
is sent. However, you can control how often the encoder makes a new keyframe by
setting the number of frames. The more keyframes you broadcast, the more
bandwidth required and less compression, but results in better quality video.
10. (Optional) Check the Timecode Every checkbox and enter the number of frames
between timecodes. Wirecast can generate timecodes embedded in the flash
stream. If a frames value of zero is entered, the timecode is never sent. Wirecast
sends metadata along with the frames. This data looks like an ONFi call. Various
timecodes and timestamps are also sent with the stream.
11. (Optional) Check Strict Constant Bitrate. When checked, it forces the Average bit rate
(see item 8 above) to maintain the exact bit rate entered. CBR pads the data (when
necessary) to meet exact bitrate specified. Disabling CBR can result in slightly
improved quality and decrease file size, but at the cost of greater bitrate
fluctuations which could prove troublesome for certain streaming destinations.
Selecting this option for recording is not recommended because it can result in
decreased quality and larger files, with no real benefit.
12. (Optional) Check Keyframe Aligned. When checked, it facilitates adaptive bitrate
streaming by ensuring that keyframes from multiple streams are in sync, along with
the keyframes timestamp, DTS and PTS values. But this is true only if those other
streams also have the option turned on and have the same keyframe interval. To
accomplish this, Wirecast disables scene detection and manually inserts the
keyframe at the exact keyframe interval specified. Therefore, to ensure quality and
smooth switching in the player, the keyframe interval should be in the 1 to 4
second range. When Keyframe Aligned is enabled, absolute timestamp is also
enabled.
13. (Optional) Check the Audio Encoding (AAC) checkbox.
When checked, the audio for your broadcast is encoded. When Audio Encoding
(AAC) is unchecked, the output contains no audio track.
14. Select the type of audio channels: Mono or Stereo. Mono uses less bandwidth than
stereo.
15. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate
menu. This is the target bit rate of your audio. Higher numbers provide better
quality. The connection speed of your audience is a significant factor in
determining your target bit rate. The encoder compresses the audio to
approximate this target. However, at different times during your broadcast the bit
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rate may be higher lower than the target rate. The total broadcast bit rate is a
function of video bit rate plus audio bit rate.
16. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample rate
menu. This value specifies how many thousands of times per second to sample the
audio in the broadcast. Higher values provide better quality sound, but at greater
bandwidth.
17. Click Save to save your settings.
See The Encoder Presets Window.

Modifying the x264 Preset
Note: The x264 implementation of the H.264 standard results in better quality and
lower CPU usage for any given bitrate, but at the cost of higher memory usage. The
default implementation is based on the MainConcept codec and uses less memory.
To modify an x264 preset, follow these steps:
1. Select Window > Encoder Presets.
2. Select an x264 from the Encoder menu.
Note: See The Encoder Presets Window.
3. Check the Video Encoding checkbox. When checked, the video for your broadcast is
encoded. When unchecked, a blank video screen is provided. This is the preferred
method of producing audio-only broadcasts.
4. Enter the Width of your broadcast video.
5. Enter the Height of your broadcast video.
6. Select the desired frames per second (fps) of your broadcast. This value is a target
value for the encoder and the exact value is not guaranteed.
7. Enter the average bit rate in Kbits (1000 bits) per second. This is the target bit rate of
your video. Higher numbers provide better quality. The connection speed of your
audience is a significant factor in determining your target bit rate. The encoder
compresses the video to approximate this target. However, at different times
during your broadcast the bit rate may be higher or lower than the target rate.
8. Select encoding quality (Ultra fast to Very slow encoding). Slower encoding results
in better quality.
9. In the x264 command line options edit box, enter any command line options you
want included.
10. Select an encoder profile from the Profile menu. Three profiles are provided:
Baseline, Main, and High. The Baseline profile is commonly used in mobile
applications. It is also used in other applications which operate with limited
processing power, storage capacity, and/or bandwidth. The Main profile is
appropriate for general-purpose applications of broadcast media, such as high-
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bandwidth Internet broadcasting. The High profile provides the highest broadcast
quality encoding.
See Profile.
11. Key Frame (optionally) allows you to enter the number of frames. A movie is a
sequence of images and each image is called a frame. To compress video data,
most encoders take a frame and make it a reference (also known as a key). This
keyframe is sent as part of the broadcast, and all of the data after that keyframe is
relative to it. The benefit of this is that the compressor only needs to send what has
changed since the last keyframe. The main drawback of this is that over time it
becomes harder for the encoder to distinguish the frame-difference information,
especially if there is a lot of motion in the video. Another drawback is if your
viewer’s computer misses a keyframe, the video is distorted until the next keyframe
is sent. However, you can control how often the encoder makes a new keyframe by
setting the number of frames. The more keyframes you broadcast, the more
bandwidth required. The result is less compression but better quality video.
12. Check (optionally) Strict Constant Bitrate. When checked, it forces the Average bit
rate (see above) to maintain the exact bit rate entered. CBR pads the data (when
necessary) to meet exact bitrate specified. Disabling CBR can result in slightly
improved quality and decrease file size, but at the cost of greater bitrate
fluctuations which could prove troublesome for certain streaming destinations.
Selecting this option for recording is not recommended because it can result in
decreased quality and larger files, with no real benefit.
13. Check (optionally) Keyframe aligned. When checked, it facilitates adaptive bitrate
streaming by ensuring that keyframes from multiple streams are in sync, along with
the keyframes timestamp, DTS and PTS values. But this is true only if those other
streams also have the option turned on and have the same keyframe interval. To
accomplish this, Wirecast disables scene detection and manually inserts the
keyframe at the exact keyframe interval specified. Therefore, to ensure quality and
smooth switching in the player, the keyframe interval should be in the 1 to 4
second range. When Keyframe Aligned is enabled, absolute timestamp is also
enabled.
14. Check (optionally) the Timecode Every checkbox and enter the number of frames
between timecodes. Wirecast can generate timecodes embedded in the flash
stream. If a frames value of zero is entered, the timecode is never sent. Wirecast
sends metadata along with the frames. This data looks like an ONFi call. Various
timecodes and timestamps are also sent with the stream.
15. Check (optionally) the Audio Encoding (AAC) checkbox. When checked, the audio
for your broadcast is included. When unchecked, audio is absent. This is the
preferred method of producing video-only broadcasts because the presence of
silent audio uses bandwidth.
16. Select the number of channels: Mono or Stereo. Mono uses less bandwidth than
stereo, but stereo is more pleasing to the listener.
17. Select the audio bit rate, in Kbits (1000 bits) per second, from the Target Bit Rate
menu. This is the target bit rate of your audio. Higher numbers provide better
quality. The connection speed of your audience is a significant factor in
determining your target bit rate. The encoder compresses the audio to
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approximate this target. However, at different times during your broadcast the bit
rate may be higher or lower than the target rate. The total broadcast bit rate is a
function of video bit rate plus audio bit rate.
18. Select the audio sample rate, in kHz (1000 Hz) per second, from the Sample Rate
menu. This value specifies how many thousands of times per second to sample the
audio in the broadcast. Higher values provide better quality sound, but at greater
bandwidth.
19. To save your settings, click Save.
See The Encoder Presets Window.
20. Select Window > Encoder Presets.
21.
22. Set the quality of your encoding at high, medium, or low. Higher quality results
with greater CPU usage.
23.
See The Encoder Presets Window.

Streaming
To start steaming, do the following:
1. Click the Stream button.

The Stream button

The Stream button blinks until a connection is made. Once you are connected, the
Stream icon turns unblinking green. If you cannot connect, Wirecast displays an error
message.
Wirecast indicates connectivity strength by the number of bars displayed in the Stream
icon. Fewer bars indicate lower speed or connection reliability issues. If packets aren't
reaching the destination server, Wirecast buffers the packets. When this happens, the
green streaming indicator becomes yellow and Wirecast continues sending those
packets in an attempt to reach the destination server.
If packets continue to fail to reach the server, Wirecast drops packets, and the streaming
indicator turns red. When Wirecast stops attempting to send packets, Wirecast displays
the red Failed icon.
Red Failed icon

When the connection is recovered, Wirecast replaces the red Failed icon with green
bars.
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Note: Connection problems may be due to: destination server-side issues, Internet
ISP problems, or Wirecast computer resources. You can test for server-side issues by
running a test stream to another server. If you get a continuous green streaming
indicator to the new destination, contact the CDN host and report the destination
server problem. To test for Internet ISP problems, run a speed test and note upload
speed and packet loss. Your total combined encoder settings to all destinations should
be no more than half the tested upload speed. This allows for headroom because the
sending data rate and ISP upload bandwidth can vary from moment to moment. It's
not uncommon for actual upload speed to vary from that claimed by an ISP. Packet
loss should always be 0% as any other number indicates packet loss. In this case, the
ISP should be contacted so they can run tests to your point-of-origin broadband
connection. While streaming from Wirecast, keep CPU use under 60% for optimal
performance, and be aware that if CPU usage exceeds 80% a variety of problems may
occur, including a red Failed icon indicating a disconnection.
While streaming, Wirecast displays the status. If you are streaming to Facebook,
Wirecast displays additional statuses on the right side of the status bar.

Number of
viewers

Various
reactions

2. (Optional) To record your broadcast click Record.
3. To stop streaming, click Stream again.

Red and Yellow Stream Icon Circumstances
When streaming over RTMP, there is a buffer for the packets called the flash queue.
Buffer Utilization
The buffer is utilized to handle scenarios where the Internet uplink to the RTMP
endpoint (CDN) temporarily is unable to deliver at a fast enough rate.

• This can occur because your local LAN is saturated
• This can occur because your ISP uplink is saturated
• This can occur if the route from your ISP to the end point is compromised or saturated.

• This can happen if the endpoint is saturated.
• Any degradation in speed from Wirecast to CDN endpoint, can cause a temporary
slow down.

Colors

• Green will be shown when the flash queue is able to be emptied just as fast or
faster than it is able to be filled.

Wirecast User Guide

95

96

Output Configuration
Streaming

• Yellow will be shown when the flash queue has grown, but is not yet approaching
overload.

• Red will be shown when the flash queue is just about to be full, in which packets
will be lost.

Example 1

• Encoding is set to 7Mbps
• ISP upload speed is 7Mbps
• Video content was fairly still, but a scene change or shot switch occurs that is fast
motion.

• The encoder bursts to handle the more complex content, and momentarily requires
8Mbps to properly deliver the content.

• The flash queue is only able to output at 7Mbps, so it grows with more frames/
packets backed up.

• The Icon color turns Yellow, to alert this state.
• The encoder catches up, and settles back down to 5Mbps after the scene change.
• The Icon returns to green.
Example 2

•
•
•
•

Encoding is set to 5Mbps
ISP upload speed is 7Mbps
Video content is running fine, with green Icon.
Someone else on the network begins uploading at 4Mbps, perhaps an Aspera
transfer if you remember those taking down Telestream's network...

• The available bandwidth to the stream is 3Mbps during this usage.
• The icon will turn yellow, then turn red.
• If the queue stays red for long enough, the stream disconnects.
Example 3

•
•
•
•

Encoding is set to 5Mbps

•
•
•
•

The available upload speed drops to 5Mbps

ISP upload speed is 7Mbps
Video content is running fine, with green Icon.
The ISP oversold their network, and some neighboring business or residents all
hopped on the Internet at the same time.
The icon drops to yellow, then to red.
The icon stays red, and the stream continues.
Viewers are still seeing the stream despite the icon being red.
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• The flash queue is able to unload the packets during downward bitrate fluctua-

tions, and builds more packets in buffer during upward bitrate fluctuations, just
enough that the queue stays in this almost-full-but-hasn't-burst state.

Limiting Reconnection Attempts
When Wirecast loses an Internet connection, Wirecast attempts to reconnect. Each time
reconnection is attempted, the stream icon will blink. To limit the number of
reconnection tries, do the following:
1. Select File > Preferences > General.
2. Enter a value into the field, Maximum Reconnect Attempts.
3. To close the Preferences dialog box, click the “x.”
When the connection is recovered, the red Failed icon is replaced with the green bars.

Configuring Replay + ISO
PRO

Replay enables you to repeatedly play a clip, or even a portion of a clip, any number of
times or endlessly. You can also replay playlists (see Playlists). This makes the
combination of Playlist and Replay a very powerful production tool.
ISO (or Isolated Output) allows users to create recordings for system devices (cameras,
capture cards, or mics) that are currently not being displayed in the Live canvas window.
This enables you to be outputting one device while broadcasting with another. ISOs
can also be setup as a replay source. This enables you to have all the Replay
functionality (hotkeys, Mark-in, and Mark-out) in your ISO source but without it being
displayed in the Live canvas window.
Replay and ISO share the same menu because ISOs have the ability to be setup to use
replay functionality. This functionality is toggled in the ISO Settings window. If an ISO is
set to use Replay then it will use all the replay settings that have been configured in the
Replay+ISO window.
Note: Multiple Replay clips captured during the same replay session will not render
correctly when played at the same time on different Main Layers or different shot
layers.
To use Replay you need to set it up the way you want it to perform. To do this select
Replay+ISO > Configure. Check the Program Replay box, make your desired settings, and
click OK when finished.
Capture Audio in the Replay Check the Audio box to capture audio in the Replay you
are creating. If unchecked all audio is ignored.
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Video Quality Set the video quality for Standard or High. Depending on what quality
you choose, an estimate of the write rate will be displayed.
Folder Click Browse and navigate to the location where you want to store your Replay
shots.
Create Replay Hotkey Select a hotkey from the drop-down menu that will activate the
Create Replay function.
Update Replay Hotkey Select a hotkey from the drop-down menu that will activate
the Update Replay function.
Mark Replay Hotkey Select a hotkey from the drop-down menu that will activate the
Mark Replay function.
Manage Opens the Preferences > Hotkeys window so you can add, delete or change
your hotkeys. The Global check box must be checked if you want that hotkey to be
available in the drop-down menus above.
See Replay + ISO Menu and Replay Shots.

Activating Replay
Note: When Replay is activated, CPU usage increases.
To activate Replay, select Replay > Start All.
The Start All menu item becomes Stop All and Wirecast adds buttons to the Wirecast
default layout: Set Replay Mark In and Update Replay Shot.
Once Replay has been activated it keeps all shot activity (playing of clips or capturing of
live sources) in the Replay buffer on disk. The amount that is saved when the Create
Replay Shot button is pressed depends on the value entered into the Default Replay
duration setting.
See Replay Shots.

Configuring ISO Recording
ISO (or Isolated Output) is a Wirecast Pro feature that allows you to create clean
recordings of your system devices (cameras, capture cards, or mics) even when they are
not being displayed in the Live canvas window. This is often helpful when you want to
edit together a video-on-demand version of your live show. You can have recordings of
all your cameras even when they weren't live in your broadcast.
There are two ways to ISO record:
1. The Capture Source ISO capability allows you to choose one source (such as your
webcam, or a microphone). This is truly an isolated source recording, so it doesn't
enable you to combine a separate audio and video raw sources into one ISO
recording. However if your source includes audio, you can capture that as part of
your Capture Source ISO.
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2. The Shot ISO capability lets you record any shot that is on your Main Shot Display.
This lets you mix two or more sources into a single shot and record that. It also lets
you ISO record sources that are not available in the Capture Source ISO option such
as WebRTC sources (Rendezvous and Wirecast Go), NDI, Webstream, or Elgato
capture sources.
3. Select Configure from the Replay+ISO main navigation.
4. Click Add ISO.
You have two choices for Recording type: Capture Source ISO or Shot ISO.

Capture Source ISO
Capture Source ISO lets you ISO record an individual camera or audio source, (e.g. your
Facetime Camera, or a camera plugged in via a capture card.
Note: Certain sources, such as Rendezvous guests, Web Stream sources, IP Cameras
sources, Web Page plugin sources, or Wirecast Go sources will not show up as available
Capture Source sources. To record these, you should use Shot ISO.
If your chosen source produces both video and audio, you will have the option to
include which media tracks are included from your single source.
If you want to record audio that is coming from a separate source (like from a separate
micro-phone), you can either set up another Capture Source ISO for that audio
separately, OR you can place your chosen video and audio sources into a single shot on
the Main Shot Display and use Shot ISO to record that shot.
Note: Documents created prior to Wirecast version 14.1 that had ISO configured that
included video and audio from two different sources will be split into two separate
source recordings (one for Audio, one for Video).
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Shot ISO
Shot ISO lets you ISO record any shot on the Main Shot Display. The advantage of this is
that you can combine any audio and video sources into a shot. You can also record
shots that contain sources that aren't available in Capture Source ISO, like Rendezvous
guests and IP camera sources.
If your chosen shot has both video and audio, you will have the option to include which
media tracks are included from the shot.
Shot ISO recordings will produce video at the canvas resolution and frame rate. This can
be adjusted in Preferences > Canvas. Audio will match the Wirecast internal mixer which
is stereo, 32-bit float, 48 kHz.
Note: Any animated graphic or media file contained in your shot will not play as part
of a Shot ISO recording. So, if you don't want a static image where your media is, you
should place that source in a different shot on a different layer.
Audio-Only Recordings You can make audio-only ISO recordings, using either Capture
Source (if your source is audio) or Shot ISO (if your shot includes only audio).
The ISO configuration dialog displays the selected source's current video resolution
and frame rate so you know what to expect in your recording. The same goes for audio
channels, bits per sample, and sample rate. When no source is selected or the source
does not produce a certain type of media, None is displayed where the source media
information would normally appear (next to the corresponding video/audio media
track checkboxes).

Format
• QuickTime: ProRes Video + Uncompressed Audio: ProRes is better suited for NLE
work. Also, color space information is less ambiguous.

• QuickTime: x264 Video + Uncompressed Audio:
– x264 is a compressed video file that results in significantly smaller file sizes.
– x264 recordings are still placed in QuickTime files and still paired with

uncompressed audio. Uncompressed audio offers top quality and minimal CPU
drain for archival purposes.

– You can choose the bitrate and keyframe interval for recordings that use x264

encoding.The default values are 10 Mbps with 15 frames/second. The defaults
were chosen for high quality full HD archival. We use the high-profile encoder
setting and the “fast” x264 algorithm with variable bitrate encoding.
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Quality
Wirecast offers the ability to encode your files using ProRes or x264 on both Mac and
Windows.

Filename
Each new ISO recording you create in a document includes the next number in a
sequence that begins with 1 and is incremented when you create a new ISO
configuration. For example, the first ISO will be named “ISO 1", the second will be
named “ISO 2", third “ISO 3", and so on. Likewise, filenames given will be “iso_01”,
“iso_02”, “iso_03”, and so on. Name-sorted listings of recordings on disk will remain in
order beyond the 9th ISO configuration.
You can always choose another name for the files, but that will not affect the
sequencing. So if you rename “ISO 1" to “Names Don't Matter”, the next ISO will still be
named “ISO 2" by default.

Folder Wirecast will remember the last folder you assigned to an ISO recording
configuration and use that folder as the default for the next configuration that you
create. This setting is app-wide so it will transfer between projects.
Replay Check this to configure your ISO recording to be available for Instant Replay
within your broadcast. This can be applied for Capture Source ISOs as well as Shot ISOs
(See tutorials on Replay for more information on configuring this).

File Options
Single File This is best used if you have shorter broadcasts and have plenty of disk
storage space. When the user chooses the Single File option, what you're really
choosing is the maxed-out 12-hour file duration.
New File Every This ensures you don't have files that are so big you run out of disk
space. If you have a long broadcast or have limited space, you may want to limit your
file sizes with this option. This will break the recordings up and start a new file at the
increment you specify.

See Starting your ISO Recording.
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A Note about Resources
Keep in mind that this feature is very resource intensive. Because you are recording
individual cameras or shots alongside your actual production you will need a rather
powerful system.
We recommend that at minimum you have:

• An i7 processor
• A high-end dedicated graphics card
• An SSD for recording

Recording To Disk
If you want to archive your stream, you can use the Record To Disk destination.
Note: Wirecast auto-saves your stream or recording. All formats (WMV, MOV, MP4) are
recoverable in increments of 20 seconds. Any recording less than 20 seconds is
corrupted. ISO also recovers. In the case of an unexpected shutdown, the recoverable
video is available in increments of one minute.
To record to disk, do the following:
1. Click the Record button (or ISO Record button) at the top of the Wirecast default
layout.
2. When the Output window opens, click the Add button at the bottom of the window
to add a recording destination.
3. When the dialog box displays, select Record to Disk and click OK.
4. In the Output Settings window select Record To Disk (MOV, MP4 or Windows Media)
5. Select an encoder.
Note: ProRes encoding is now available for MOV.
6. Click Browse or enter the path to where you want your recording located.
7. Select the recording mode: Use Filename Only, Auto Increment Filenames, or
Timestamp Filenames. If you select Auto Increment Filenames, your filename will
have an incremental number appended to the end of it. This causes a new file to be
created every time you start recording to disk, otherwise your previous file is
overwritten (if you have selected Use Filename Only).
8. Click OK.
Note: When recording to disk on FAT32 formatted drives, single files cannot be larger
than 4GB in size. So, recording to disk on a FAT32 formatted drive may result in files
that do not close properly if they exceed 4GB in size. It is recommended that you
record to disk on a Windows NTFS formatted partition whenever possible.
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Once you’ve created a document and have configured the inputs and outputs for your
broadcast, you are ready to broadcast with Wirecast.

Topics
■ Launching Wirecast
■ Switching with Preview
■ Single-Click Switching with AutoLive
■ Playing Playlists
■ Broadcasting
■ Controlling or Muting the Final Audio Mix Level
■ Starting your ISO Recording

Launching Wirecast
To start Wirecast, double-click the Wirecast icon that was placed on your desktop
during installation.

Switching with Preview
Do the following to switch shots when AutoLive is disabled:
1. Click a shot in a layer.
Wirecast displays the shot in the Preview Area.
2. Click the transition button for the type of transition Wirecast generates to change
from the current live shot to the shot selected. Alternatively, press the keyboard
shortcut Ctrl+1 to select the first transition button or Ctrl+2 to select the second
transition button.
3. Click the Go button.
Wirecast places the shot in the Live Broadcast Area.
See AutoLive, The Default Layout, Transition Controls, and Go Button.
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Single-Click Switching with AutoLive
To switch shots when AutoLive is enabled, click a shot in a layer.
Wirecast places the shot in the Live Broadcast Area.
When you select multiple shots on multiple layers, Wirecast displays all of them in the
Live Broadcast Area, with layer 1 on top and layer 5 at the bottom.
See AutoLive, The Default Layout, and Go Button.

Playing Playlists
Playing back a playlist is the same as playing any other shot. To play a playlist, do the
following:
1. Select the playlist shot
Wirecast displays the shot in the Preview Area.
2. Click the Go button.
Wirecast displays the shot i n the Live Broadcast Area, and broadcasts the shot.
See AutoLive, The Default Layout, and Go Button.

Viewing the Playlist Countdown Timer

Drop-down menu
Countdown timer
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Click the gear icon to open the counter display mode menu. Select the top item (the
name of the currently playing shot) to display its countdown time only.
Click the gear icon

Select current shot

Current shot countdown time

Select the bottom item (New Playlist - Completion) to display the countdown time of the
current shot and of the Playlist.
Click the gear icon

Select New Playlist - Completion

Playlist countdown time
Current shot countdown time

Broadcasting
Before you can broadcast with Wirecast, you must configure your output settings. See
Selecting a Destination.
To start broadcasting, select Output > Start/Stop Broadcasting > Start All.
Note: If you try to broadcast without first configuring an output, Wirecast opens the
Output Settings window for you. See The Output Settings Window.

Controlling or Muting the Final Audio Mix Level
You can set the volume level, or you can mute, the final mix audio level for the Preview
Area or the Live Broadcast Area, with the Final Mix Audio panels. There are separate Final
Mix Audio panels for the Preview Area and for the Live Broadcast Area. The controls for
both Final Mix Audio panels work the same way.
To control the volume for either the Preview Area or for the Live Broadcast Area, select
the respective Final Mix Audio panel, and do one of the following:

• To set the volume, click and drag the slider control up or down.

The decibel scale next to the slider indicates the audio level. When you take a preview shot live, the live audio levels match the levels set in preview.
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• To mute the audio output, click the Mute button.
See Final Mix Audio Panel.

Displaying or Hiding the Final Mix Audio Panel
To display Final Mix Audio for preview and live displays, select Layout > Final Mix.
To hide Final Mix Audio select Layout > Final Mix again.
See Final Mix Audio Panel.

Viewing a Layer in a Layer Window
To open any layer in its own window, do the following:
1. Select Window > New Layer Window.
Wirecast displays a list of the layer windows you can open (Main Layer 1 through
Main Layer 5).
2. Select the layer you want to open.
Wirecast displays the layer in a separate layer window.
This separate layer window works exactly like the layers in the default display, but you
can move layer windows independently of one another.
See also Layers.

Controlling a PTZ Camera
To control a remotely-controlled pan-tilt-zoom (PTZ) camera, do the following:
1. Configure Wirecast for the PTZ camera. See Setting Up PTZOptics Camera with a
Dynamic IP Address and Setting Up PTZOptics Camera with a Static IP Address.
2. Select a PTZ camera shot in a layer.
3. In the Shot Layer Properties tab of the Shot Editor, click the triangle next to PTZ, and
click the PTZ Controller button.
Wirecast opens the PTZ controller panel.
4. Control the camera with the controls in the PTZ Controller.
See The PTZ Controller Panel and PTZ Control in the Shot Layer Properties Tab.

Starting your ISO Recording
When you finish configuring your ISO recordings, you're ready to start recording. There
are a couple of ways to start your ISO recordings.
1. Go to Replay+ISO in the main navigation bar. There you have the choice to Start All
or choose to start only a specific ISO that you have set up.
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2. Alternatively, you can click the ISO-REC button at the top of the User Interface,
which will start all your configured ISO recordings.
3. See Configuring ISO Recording.

Error Reporting
When starting ISO recordings, Wirecast will send any number of specific error messages
to the user-log and present you with a generic modal dialog that reads: "Av recording
failed to start. View the user log for details and edit the Replay+ISO configuration to
resolve issues.” The dialog contains an Edit button which opens the ISO configuration
dialog.
Also, many ISO recording errors occur after you start recording and some occur soon
after. These asynchronous errors are reported only in the Notifications window where
no modal dialog is shown.

Configuration Errors and Warnings
Wirecast tries to catch a number of configuration errors and potential problems while
you are interacting with the ISO configuration dialog.
Warnings are shown in the dialog as warning icons next to the configuration fields. If
you hover the cursor over each warning icon, a tool tip appears detailing the problem.
Also, the topmost warning message will appear in red text at the bottom of the dialog
until all warnings are cleared for the selected configuration.
Each ISO configuration listed on the right-hand side of the ISO configuration dialog has
a warning icon if it has a problem. A list of the configuration problems Wirecast detects
follows.

•
•
•
•
•
•
•
•
•
•

No source/shot is selected for recording.
The recording uses a source or shot that no longer exists.
The recording uses the same source or shot as another recording.
No media tracks are enabled for recording.
The source does not produce media that matches the enabled tracks.
The recording uses the same output file as another recording.
The file name contains restricted characters.
The selected output folder does not exist.
The space available on the selected drive is insufficient for recording.
The file duration must be between 10 seconds and 12 hours.

See Configuring Replay + ISO.
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Windows, Controls, and
Menus
You create broadcasts through the various windows, controls, and menus of Wirecast.

Topics
■ The Default Layout
■ Control/Status Bar
■ Preview Area
■ Live Broadcast Area
■ Transition Controls
■ Final Mix Audio Panel
■ Mode Selection Buttons
■ Layers
■ Window Controls
■ Add Shot Window
■ The Shot Editor Window
■ The Audio Mixer Window

The Default Layout
When you create a new document, Wirecast displays the document in the default
layout. The main elements of the Wirecast layout are labeled in the following screen
shot, and are described below.
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Figure 1. Wirecast default layout
Menu Bar

Mode Selection
Buttons

Preview Area
Control/Status Bar

Live Broadcast Area

Layers

Final Mix Audio Panel

Go button

Transition Controls

Control/Status Bar
Control buttons and status information are displayed at the top of the default layout.
ISO Record
Recording time
Record button
Streaming time

ISO record time
Multiviewer/Secondary Live
Output button

Stream button

Display Live
Only
Display
Preview Only
Display Preview
and Live

Wirecast displays the following controls and statistics:
Stream button
When clicked, Wirecast begins streaming.
Streaming time
Total cumulative time the document has been streamed. This value does not reset
when you start/stop the broadcast. If you save portions of the broadcast to disk,
Wirecast still displays the total cumulative time.
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Record Button
Click to begin recording.
Recording Time
This displays how long you have been recording. This value does not reset when you
start/stop the broadcast. It is cumulative.
ISO Record
Click to begin ISO recording.
ISO Record Time
Displays the ISO recording time.
Multiviewer/Secondary Live Output Button
Opens the configuration window if you haven’t already configured your displays. Once
you've configured your displays, this button places the windows on your displays as
configured.
Display Buttons
These three buttons enable you to choose to display the Preview Area, the Live
Broadcast Area, or both in a divided display.
Note: To avoid decrease in video quality, Wirecast should not be used at CPU usage
above 80%. See the Telestream Website for suggested configurations. You can also
view streaming statistics by selecting Output > Show Statistics.

Preview Area
Displays the selected shot as it would appear when broadcast, without broadcasting
the shot. When the shot in the Preview Area is selected, Wirecast outlines the preview
with a control frame for resizing and rotating the shot.
See Viewing the Preview Area, Viewing a Shot in the Preview Area, and Resizing or Rotating
a Shot.

Live Broadcast Area
The Live Broadcast Area shows the un-encoded shot currently being encoded and
broadcast. Also, you can play, pause, or scrub clips displayed in the Live Broadcast Area
while they are broadcast.
See Switching with Preview and Single-Click Switching with AutoLive.
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Transition Controls
Wirecast displays up to three transition buttons. You can configure each to present one
of many possible types of transitions. If, for example, Smooth is selected (button
darkened), clicking Go executes a smooth transition to the new shot.
See Setting the Number of Transition Buttons and Determining the Transitions for the
Transition Buttons.

Final Mix Audio Panel
The Final Mix Audio panel enables you to control the output volume level, mute audio
output, and mute the line-out feed for Preview and Live windows.
Preview Decibel scale

Live Decibel scale

Preview Volume
Live Volume

Preview Line-Out
Mute button

Live Line-Out
Mute button
Live Mute button

The Preview and Live Volume control enables you to adjust the audio volume for
Preview and Live separately.
The Live Mute button mutes the Live Broadcast Area audio (what your viewers hear).
Even when you mute the output, the encoder still generates audio but the output
remains silent.
Note: If you do not want to broadcast audio, modify the encoder presets to not
process audio through the encoder. See Encoder Presets.
The Preview Line-Out Mute button and Live Line-Out Mute button control local volume
(what you hear), not broadcast volume. When Line-Out is muted, audio is not sent to
your headphones or speakers, but your viewers still hear the audio. The two controls
are mutually exclusive. You can’t have both on at the same time, but you can mute
both.
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See Controlling or Muting the Final Audio Mix Level and Displaying or Hiding the Final Mix
Audio Panel.

Mode Selection Buttons
Button containing green and red dots
When clicked, Wirecast displays both the Preview Area and the Live Broadcast Area.
Button containing green dot
When clicked, Wirecast displays the Preview Area.
Button containing red dot
When clicked, Wirecast displays the Live Broadcast Area.
Note: These three buttons work the same as three of the options in the Layout Menu.
See Layout Menu..

Layers
The horizontal bars towards the bottom of the screen are the layers. You can make
more layers visible. Also, you can add, modify, and play shots from the layers.
By default, Wirecast displays five layers. Each layer can contain multiple shots. A red LED
indicates that a shot is Live.
Wirecast allows you to put shots on any of the layers. Layering shots enables Wirecast to
superimpose them, from the lowest layer to the highest, to form a single visual image
during broadcast.
By default, Wirecast displays five layers. Each layer contains shots that can be selected
by clicking a shot. A red LED indicates that a shot is selected. When a shot is selected it
is displayed in the Live Broadcast Area. If you select multiple shots (by selecting a shot
on more than one layer) Wirecast displays all of them in the Live Broadcast Area.
Wirecast displays Layer 1at the top, Layer 5 at the bottom, and the other layers, in order,
between them. The order of layers determines the order of superimposition in the Live
Broadcast Area. If you place a video shot on Layer 5 and a title on Layer 1, Wirecast
superimposes the title over the video.
See also Viewing a Layer in a Layer Window.

Window Controls
Transition Controls
There are three Transition buttons. You can configure each to present one of many
possible transition types. Typically, the two configured transitions are: Cut and Smooth.
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When Smooth is selected (button darkened), any transition executed by clicking Go is a
smooth transition.
Note: Preferences > General enables you to configure how many buttons you want
displayed (between 0 and 3).

Changing Transitions
Click the Cut button to make it the current transition type.
You can also select one of the two buttons by pressing Ctrl+1 or 2 keys for the two
transition types displayed.
If you click the down-arrow on the right side of any of the transition buttons, you can
select a new transition to assign to that button.

Go Button
When clicked, Wirecast executes the transition selected, broadcasts the shot selected,
and displays it in the Live Broadcast Area.
If AutoLive is enabled, the Go button appears with a red dot. When AutoLive is enabled,
simply selecting a shot--without clicking the Go button, broadcasts the shot.
With AutoLive enabled, clicking the Go button updates the live shot with any changes
you have made to it with the Shot Editor. If you have made no changes to the live shot,
clicking the Go button does nothing when Wirecast is in AutoLive mode.
With AutoLive disabled, you can make several changes to your broadcast without your
viewers seeing the change. This is most useful when an engineer runs your broadcast.
See Single-Click Switching with AutoLive and AutoLive.

Playlist Controls
Playlists provide some basic playback controls, located at the bottom of the Playlist tab
window. You can transition to the previous or next shot in the list, set playlist behavior,
shuffle the playlist order, and more.

Number of
shots
Duration
Resume

Shuffle
Transition to
previous shot
Transition to
next shot

Transition
between
shots
Set Playlist
behavior
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Number of Shots
Displays the current number of shots in the playlist.
Duration
Displays the duration of the playlist shots.
Resume
When checked, if you exit the playlist, when you return the playlist will resume playing
at the location (same shot) as when you exited.
Shuffle
Click to shuffle the order of the playlist shots.
Transition to previous shot
Transitions to the previous shot in the playlist if the playlist is currently live.
Transition to next shot
Transitions to the next shot in the playlist if the playlist is currently live.
Set Playlist behavior
Sets the behavior of the playlist when the last shot in the list has been played. A check
mark indicates what menu item (behavior) is selected.

• Loop transitions back to the first shot, endlessly.
• Hold stays on the last shot. If the last shot is a clip, the last frame in the clip is dis-

played. If the last shot is a live shot, the live source stays active. If the last shot in a
Playlist is a video clip Shot, it will obey the rules set for the video clip in the Media
Properties Inspector tab under Source Properties. However, it will hold the Playlist
on that last Shot if Set Playlist Behavior is set to “Hold”. Therefore, if you want to see
the last video in the Playlist pause on the last frame, you must set When Finished to
“Hold” under Source Properties, in addition to setting the playlist behavior to
“Hold”. If you set When Finished to “Loop”, under Source Properties, the last video in
the Playlist will continue to loop.

• Available Shots transitions to another shot on the same layer. All available shots are

listed as menu selections. (In the example shown, the only available shot is “Logo”.)

• Previous Live Shot transitions back to the shot that was live before the playlist began
playing.

• Current Preview transitions the contents of Preview to the Live Broadcast Area.
Transition between shots
Sets the transition to use when switching between shots.
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Playlist Countdown Timer Display
Wirecast displays a countdown timer below the Preview Area or Live Broadcast Area
whenever you play a video shot or playlist. If you play multiple video shots, click the
gear menu icon and select the shot to associate with the countdown timer.

Countdown timer
Gear icon
Gear menu

Add Shot Window
The Add Shot window provides a way to add sources, such as live sources, file sources,
the Remote Desktop Presenter program, shot graphics, shot audio, and shot templates.
Click the Plus Button (+) to open the Add Shot menu.
When Wirecast displays the Add Shot menu, select a shot category, select the type of
shot to add. Modify the shot if desired and allowed. To add a shot to a layer, click the
Add “+” button in a layer.
To add a source to the Favorites menu, select the source and click the star icon.
Wirecast changes the color of the star to white and adds the source to the Favorites
menu.

Video Capture
System Device
Select a system device.
See NDI Devices in the Shot Layer Properties Tab.

• Wirecast Gear Video Inputs If you using Wirecast Gear (and have an active
license) all available video inputs will be listed.
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Audio Capture
System Device
Select a system device.
See NDI Devices in the Shot Layer Properties Tab.

• ASIO Audio Capture Select an ASIO audio capture device and click the Add button.
System Audio Capture
Select an audio capture device. WASAPI Audio Capture Select a WASAPI capture
device and click the Add button.
Source Name Displays the name of the source. To change the source name, enter a
new one.
Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay the audio
signal to sync it up with a video source.
Monitor Click the Monitor icon to cause audio to play through your monitor output.
The icon is gold when selected (turned on). If unselected, audio will not play through
the monitor output for this source. Selected is the default.

Media Files
Browse Disk
Select to navigate to a media file.
Stock Media Library
Select to display the Stock Media Library window.
A Media File is a video clip or a picture. To open a Media File source, select Media Files
from the source menu in the shot window, and then navigate to your file. You can also
click the Add Media File button at the bottom of the Add Shot window.
Media Files have the following settings:
Source Name
Displays the name of the source. To change the source name, enter a new one.
In Point
Click Jump to move the play head to the In Point in the media file. Set the In Point either
by dragging the In Point icon to the desired beginning position on the play bar, or by
entering a value into the In Point field.
Out Point
Click Jump to move the play head to the Out Point in the media file. Set the Out Point
either by dragging the Out Point icon to the desired end position on the play bar, or by
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entering a value into the Out Point field. The green triangle shows the current location
of the Play Head.
In Point icon

Out Point icon

Play Head location

When Finished
Select what happens when the media finishes playing. Loop causes the media to begin
playing again. Hold causes the media to stop and hold the last frame in the Live
Broadcast Area. Remove causes the media to be removed from the Live Broadcast Area
when it finishes playing.
Begin playing when media becomes Live
When checked, the media begins playing as soon as it is made Live.
Remember position even when not Live
When checked, the media will always start playing where ever it was playing when it
was stopped, even if it was removed from the Live Broadcast Area and made Live again.
When unchecked, the media will start from the beginning every time it is taken Live.
Set Default
Click to set the media display to default settings.
Live Playback
Changes are live. When you select this option and your shot is live, Wirecast displays
any action you take in the Preview Area--such as playing, pausing or scrubbing--in the
Live Broadcast Area, and broadcasts the action live.
Note: If you use this feature to pause or scrub media in the live broadcast, it's usually
best to uncheck "Begin playing when media becomes live."

WC Gear Inputs
If you are using Wirecast Gear 300/400 series hardware, the Wirecast Gear Video Inputs
appear in the Shot Selection menu.
After a WC Gear shot is created, you can set up the shot using Wirecast Gear controls.
Audio Input Select the audio input (if any) from the pull-down menu.

ASIO and WASAPI Sources
Any ASIO or WASAPI source on your local network will be discovered by Wirecast and
listed under Capture Devices in the Source Input Menu. These devices are generally
used with multi-track audio outputs. ASIO Audio Capture is a very low latency
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professional audio capture API. It is used to connect to professional audio interfaces.
WASAPI Audio Capture is also a low latency audio capture API. It replaces the old
DirectShow-based audio capturing.

Stock Media Library
When you open a Stock Media Library file, Wirecast displays a window presenting
Terms and Conditions. Read the Terms and Conditions, check the I Agree checkbox, and
click the Proceed button. Wirecast displays this agreement window only the first time
you open a Stock Media Library file.
You can also select Stock Media Library to open the Stock Media Library window. Use
Source Type and Left/Right buttons to navigate to a media file, then click Download to
include it as a shot.
Source Type

Search

Left/Right arrows

Play button
File marker

File Type

Download
button

Source Type
You can toggle on/off any type of media to include in the display: Video, Images, and
Audio.
Search
Enter key words to display just the media files including these words. The display is
updated as your enter words.
Left/Right arrows
Click the arrows to move to the next or previous set of Stock Media files.
Play button
Click to begin playing the selected media file.
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File marker
Move the marker to view the media file quickly.
Download button
Click to download the selected media file into a shot.

Network
iOS Cam
Select an IOS Camera device, or an iOS camera through the Wirecast Go iOS app.
Rendezvous
Select to create a new Rendezvous session, or select to reconnect to a previously
created session.
Web Display
Creates a new Web Display shot.
See Web Page Properties.
Web Stream
Creates a new Web Stream shot.
See Web Stream Properties.
NDI(R) Source
Select any NDI-capable devices on your network.

Web Page Properties
Web Page shows a web source defined by a web address (URL). To open a Web Page
source, select Web Page from the source menu in the shot window. Web Page
Properties have the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
URL
Displays the web address (URL) of the source. To change the address, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
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Transparent Background
Check to make the background transparent in your shot.
Shutdown when inactive
Check to turn off the audio and disable it from the shot when playing videos.
Override CSS
Enter Cascading Style Sheet code to override the default code for this web display.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Web Stream Properties
The Web Stream option allows RTMP, RTSP, MMS, or HTTP streams to be taken directly
into Wirecast. This is useful for incorporating remote IP Cameras or other network
streams into a broadcast. Sources are automatically detected and are also identified by
IP Camera Profile. To open a Web Stream source, select Web Stream from the source
menu in the shot window.
Web Stream Properties has the following settings.
Name
Displays the name of the source. To change the Name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
URI
Enter the address of your input stream. (For example: rtsp://127.0.0.1:8080/
my_stream.sdp, or http://10.0.0.1/my_stream, or rtmp://hades.telestream.net:1935/live/
myStream).
Username
Enter your username for your URI stream.
Password
Enter your password for your URI stream.
Buffer
Enter a buffer time in seconds.
Reconnect
Click to reconnect the Web Stream source.

Wirecast User Guide

121

122

Windows, Controls, and Menus
Add Shot Window

Apply
Click the Apply button to update any changes.
Timestamps
Select Provided by source, or Provided by Wirecast.This setting allows you to use
timestamps embedded in the source, or use timestamps generated by Wirecast.
Timestamps are used to synchronize devices. Many sources don't provide completely
accurate timestamps, resulting in sources out of sync with each other (i.e. audio and
video not syncing).
Select Provided by Wirecast to ignore the timestamps coming from the source, and
instead generate new timestamps. However, the risk is that if the system is under a
heavy load, the generated timestamps could be impacted, and end up arriving late. The
default setting is Provided by source.
Deinterlacing
Select None, or Blend Fields.
Dynamic Range
Select Default, Full or Limited.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Screen Capture
Remote Desktop Presenter
Creates a new Remote Desktop Presenter shot.
See Remote Desktop Presenter Properties.
Screen Capture
Creates a new Screen Capture shot of any monitor or window on your computer.
See Screen Capture Properties.
Note: When in screen-capture mode, some apps take control of your mouse and
make the cursor invisible. To reduce the capture window size and regain use of your
mouse, press Alt + Tab.

Remote Desktop Presenter Properties
The Remote Desktop Presenter (RDTP) is a utility application that enables Wirecast to
broadcast the desktop of any computer running the Telestream Desktop Presenter
program. To open a Remote Desktop Presenter source, select Remote Desktop Presenter
from the source menu in the shot window.
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Remote Desktop Presenter is normally auto-detected by Wirecast and is automatically
added to the list of sources. However, if a RDTP is not detected, or if you want to add
one in a remote location you can manually add it by selecting New Remote Desktop
Presenter from the Source menu in the default layout.
Remote Desktop Presenter Properties have the following settings.
Source Name
Displays the name of the source. To change the Source Name, enter a new one.
Audio Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
IP Address
Enter an IP address of the target computer.
Enable Audio When checked, the audio from the remote desktop is enabled.
Apply
Click the Apply button to update any changes.
Monitor
Click the Monitor icon to cause audio to play through your monitor output. The icon is
gold when selected (turned on). If unselected, audio will not play through the monitor
output for this source. Selected is the default.

Screen Capture Properties
A Screen Capture displays any monitor or window on your computer. To open a Screen
Capture source, select Screen Capture from the source menu in the shot window. Screen
Captures have the following settings.
Name Displays the name of the source. To change the source name, enter a new one.
Audio Delay Enter the amount of time (in seconds, as short as 1 ms) to delay audio.
Video Delay Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Capture Video Check to enable Capture Type, Show Cursor, and fps settings (described
below).
Capture Type Select Monitor (captures your entire monitor), Window (captures the
currently selected window), or Game (captures the game currently played on your PC).
If you select Game, you can also configure how your game is captured by selecting
options offered under Select Window/Monitor (described below).
Anti Cheat Support Enables anti-cheating support for game capture.
Show Cursor Check to show the cursor in your streaming. Uncheck to hide it.
fps Select the FPS, from 10 to 60 frames per second as the capture rate. An FPS of 60 is
the best frame rate, but it requires greater streaming bandwidth.
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Capture System Audio Check to capture system audio when streaming. Uncheck to
mute the audio.
Select Window/Monitor Click the Configure button to display the Select
Window dialog. If you selected Game for your Capture Type, Wirecast displays a
configuration window with the following options:

– Capture Any Full Screen Game Check this box to automatically capture a game
running in a full monitor screen, or running in a full screen of a window.

– Support Multiple Video Cards/SLI Check this box if you have a Windows system

with multiple discrete GPUs and are experiencing problems capturing a game.
(Performance of the capture may be slower than when running on a single GPU.)

– Capture Third Party Overlays Check this box to capture overlays rendered on
top of a game that are generated by applications external to the game. (For
example, the Steam in-game overlay.

Choose Audio Device Click the Configure button to display the Select Audio Device
dialog, then select an audio device from the drop-down menu.
Note: Some apps, when screen captured, take control of your mouse and the cursor is
not displayed. You can, at any time, press Alt + Tab keys to reduce the capture window
size and enable you to use your mouse.
Dynamic Range Select dynamic range setting: Default, Full or Limited.
Monitor Click the Monitor icon to cause audio to play through your monitor output.
The icon is gold when selected (turned on). If unselected, audio will not play through
the monitor output for this source. Selected is the default.
See Screen Capture.

Overlays
Clock
Creates a shot that displays time.
See Clock Properties.
Image Carousel
Creates a new Image Carousel shot that shows a sequence of images.
See Image Carousel Properties.
QR Code Generator
Creates a QR code display to present to your viewers in a live broadcast.
See QR Code Generator Properties.
Scoreboard
Creates a new Scoreboard shot.
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See Scoreboard Properties.
Text
Creates a new Text shot.
See Text Shot Properties.
Title
Opens a dialog for adding titles and lower thirds. The title library includes over 25
customizable animated titles. In the dialog, you can see all the available title designs.
You can search for a title and filter your search using various criteria. You can preview
the intro and outro animation, and you see how the title fits on the screen.
You can revise titles in your project in the Title Properties tab.
If your project contains titles made with earlier versions of Wirecast, those legacy titles
continue to appear in your project. To access the legacy titles, click the three dots in the
upper-right corner of the Add Source dialog, and choose "Display Deprecated Sources."
Wirecast displays the names of animated titles with “Title...” at the beginning. Wirecast
displays the names of legacy titles with “Title (legacy)” at the beginning.
See Properties for Titles (Animated).

Text Shot Properties
Text displays a text phrase. To open a Text source, select Text from the source menu in
the shot window. Text Properties have the following settings.
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
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File
Click the (...) icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
Update frequency
Enter the number of seconds between updates.
Keep reading text file
Check to keep reading the text file for changes.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
Face
Select the font style from the list of combination of bold and italic.
Size
Enter the font size. Click the gear icon to select the type of font size: small, medium,
large, etc.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
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Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.

Properties for Titles (Animated)
A title is text displayed in a banner window. Wirecast offers a wide variety of animated
lower thirds and titles. To open a title source, select Title... from the Add Source menu.
Animated titles have the following settings:
Left/Right arrows
Click to view the previous page, or next page, of titles.
Search
Enter name of title desired.
Filters
Click to open options for filtering your view of the titles.
Scale to Fit/Show Preview
Click to view either the title scaled to the whole screen or placed in its live position.
Tags
Displays identifying tags for the title.
Lines of Text
Displays the number of lines of text in the title.
Custom Colors
Displays the number of custom colors in the title.
Intro Duration
Displays the length of the intro animation.
Animate Intro
Click to preview either the intro animation.
Outro Duration
Displays the length of the outro animation.
Animate Outro
Click to preview the outro animation.
Note: Some title styles have customization sections for Subhead 1 and Subhead 2.
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Properties for Legacy Titles
Note: To access legacy titles, in the Add Shot dialog, click the three vertical dots at the
top right corner of the box. Then select Show Deprecated Sources.
Legacy titles have the following settings:
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
File
Click the “...” icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
Update frequency
Enter the number of seconds between updates.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
Face
Select the font style from the list of combination of bold and italic.
Size
Enter the font size. Click the gear icon to select the size of font.
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Style
Select any combination of Bold, Italic, All Caps, by toggling each button.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
On Change
Select transition type: Fade, Drop In, Drop Out, and Slide. Enter the length (in seconds)
of the transition time.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Direction
Select the direction of the scrolling: Top to Bottom, Bottom to Top, Left to Right, or
Right to Left.
Speed
Enter the speed (in pixels per second) that you want your message to scroll through the
display.
Auto Reverse
When checked, the display reverses the scrolling direction when it reaches the top or
bottom of the list.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
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Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text

Twitter Feed Properties
Twitter Feed displays a list of Twitter messages. Twitter Feed Properties have the
following settings.
Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Mode
Select the source of your text: Text (directly entered) or File (navigate to a text file), or
RSS (ticker tape RSS feed).
If you select Text, enter your text in the text box below the source selector.
If you select File, enter a file name in the File Path box displayed, or click the navigation
button (three dots) and find your text file. The text from your file will be automatically
displayed. The file has to contain UTF-8 encoded text in order for it to be rendered
correctly. Only the first 64KB of the text file will be loaded and displayed. You can also
check the Keep reading text file continuously to keep the text display in your broadcast
up to date with file changes.
If you select RSS, enter a URL in the URL box displayed.
Text
Enter text to display.
File
Click the “...” icon to navigate to the file containing text to display.
RSS URL
Enter the RSS URL where the text to be displayed is located.
Update frequency
Enter the number of seconds between updates.
Font
Select the desired font used for your messages. If you select Web Font, a Web Font field
will display below. You can also select any of the fonts installed on your computer.
Face
Select the font style from the list of combination of bold and italic.
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Size
Enter the font size. Click the gear icon to select the size of font.
Justify
Enables you to justify the text along the left, center, or right side of the display.
Align
Enables you to align the text at the top, middle, or bottom of the display.
Color
Click the box to open the color selection panel. Select a new text color from the palette.
Wrap
Select wrap mode from the drop-down menu: Word Wrap or Break Wrap.
Scroll
Enter a scroll mode: Non Stop or If it Does Not Fit.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.

Scoreboard Properties
PRO

Scoreboards allow you to add a scoreboard graphic to your broadcast that can be
dynamically updated. Multiple scoreboards can be added. Unlike most other elements
in Wirecast, changes to the Scoreboard go live instantly without requiring a transition.
Once the scoreboard is live, the preview image is exactly as it is seen in your broadcast.
To open a Scoreboard source, select Scoreboard from the source menu in the shot
window.
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Scoreboards Properties have the following settings.
Source Name
Displays the name of the source. To change the Source Name, enter a new one.
Scoreboard
Select how the scoreboard will look using two drop-down menus. The upper menu
selects the scoreboard style: Pipe, Shade, Corner, etc. The lower menu selects how the
display fields are laid out: Basic, Right Stats, or Bottom.
Home/Visitor/Score
The Home, Visitor, and Score fields contain the home and visitor team names and their
current score. The three icons to the right of these fields control the text alignment, font
size, and font color. Click on each icon to open its control window.
BG Color
Sets the background color for the Home or Visitor field display. Click the color icon to
open the control window.
+1, +2, +3
Click these score increment buttons to increase the Home or Visitor score display.
Field 1-4
Displays information inside the scoreboard depending on the layout chosen using the
Scoreboard menus. The three icons to the right of these fields control the text
alignment, font size, and font color. Click on each icon to open its control window.
Use a Custom Image
Check to enable the Choose button.
Choose
Click to navigate to the location of your custom image.
Reset
Click to remove a custom image.
Note: Because Wirecast updates the scoreboards dynamically, It is recommended
that you fill in the additional information fields while using a layout that hides them.
Then, change to a layout that reveals those fields when ready, otherwise your viewers
see you typing in those fields live.
There are four hotkeys associated with the Scoreboard.

= Increments Home score
- Decrements Home score
] Increments Visitor score
[ Decrements Visitor score
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In order for these hotkeys to be active, the scoreboard must be displayed in the Live
Broadcast Area and the Wirecast default layout must be in focus (selected as the active
Windows window).

Clock Properties
A Clock shot displays time. Clock Properties have the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Clock Modes
Select Clock, Countdown, or Stopwatch.

Stopwatch mode
Countdown mode
Clock mode

Clock Mode:
Date Select a date display format.
Time Select a time display format.
Countdown Mode:
Mode
Select Countdown from or Countdown to.
Start Time
Enter the time value from which to start counting.
Start/Stop/Resume and Reset
Click Start to start the counter. When counting, click Stop to stop the counter. When
stopped, click Resume to start counting again, or click Reset to rest the counter.
Automatically Start
When checked, the counter will start when the shot is taken live.
Format
Select one of the time-display formats from the drop-down menu.
Start, Stop, Reset
Click Start to begin counting down. Click Stop to end counting down. Click Reset to
reset clock to Timer value.
At Zero
Select either Stop at 00:00 or Start count up clock.
Stopwatch Mode:
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Start, Stop, Reset
Click Start to begin counting. Click Stop to end counting. Click Reset to reset stopwatch
to zero.
Display Format
Select time elements to display: Hours, Minutes, Seconds, and Fractional Seconds.
Font
Select font from drop-down menu.
Face
Select face from drop-down menu.
Size
Click the gear icon to select the font size from the menu.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.
Shadow
Check to activate the text shadow slider controls. Click the color box to open the color
palette.
Angle
Move the Angle slider to adjust the direction (0 to 360 degrees) the shadow text is
offset from the actual text.
Offset
Move the slider to adjust the distance the shadow text is offset away from the actual
text.
Blur
Move the Blur slider to adjust the amount of blur in the shadow text.

Image Carousel Properties
An Image Carousel shot shows a sequence of images. Image Carousel Properties have
the following settings.
Name
Displays the name of the source. To change the source name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
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Change Every
Sets how often the images are changed, in seconds.
Fade-In Time
Sets how long it takes for each image to fade in, in seconds. Enter zero for
instantaneous display of images.
Shuffle Images
Check to shuffle the display order of the images. When unchecked, images are
displayed as they are ordered in the image list.
Add/Delete/Move Images
Click the plus (+) button to find and add images. Select an image on the list and click
the minus (-) button to delete it. You can move images up and down the list by
selecting an image and clicking the up or down arrow.

QR Code Generator Properties
QR Code Generation has the following settings.
Source Name
Displays the name of the source. To change the source name, enter a new one.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Content
Enter the message you want to be embedded in the QR code displayed in your
broadcast.
Deinterlacing
Select None, or Blend Fields.

Backgrounds
Web Page
Creates a new Web Display shot.
See Web Page Properties.
Solid Color
Creates a new Solid Color shot.
See Solid Color Properties.

Solid Color Properties
Solid Color displays a solid color background. To open a Solid Color source, select Solid
Color from the source menu in the shot window. Solid Color Properties has the
following settings.
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Name
Displays the name of the source. To change the Source Name, enter a new one.
Width/Height
Displays the width and height of the display source. To change the width or height,
enter a new value.
Background
Select Solid, Linear Gradient (line), or Radial Gradient (circle). Click in the color box to
open the color palette and select a background color. Click the second color box to
select the gradient color. For Linear Gradient, adjust the slider to set the angle of the
gradient display.

Virtual Set Properties
PRO

A Virtual Set is a pre-built source set, complete with graphics, that simulates a newsanchor set. For example, you can select a virtual set that displays three layers of decor
with two live sources. You can use virtual sets as they are, or you can customize them to
meet your needs.
Virtual Sets have the following settings.
Source Name Displays the name of the source. To change the source name, enter a
new one.

Templates
Shot Template
Select Templates from the Add Shot menu.
When Wirecast displays the Templates window, select a template.
Wirecast displays the new template shot in the shot editor.

• Placeholder Shot
See Assigning Media to Placeholders.

Shot Selection Icons
Each layer contains one or more shot-selection icons.
The shot icons can be made to display any live activity in the source it represents
(cameras, streaming, etc.).
See Creating a Shot and Shot Display Preferences.
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The Shot Editor Window
The shot editor has six tabs: Shot Layers, Shot Layer Properties, Audio, Chroma Key
Properties, Smooth Transition Properties, and Source Properties.
Shot Layers tab
Shot Layer Properties tab
Audio tab
Chroma Key Properties tab
Smooth Transition Properties tab
Title Properties tab

Shot Layers
Enables you to add and delete sources and to change the display order (layering within
the shot).
Shot Layer Properties
Enables you to change the size, position, and other properties of a shot.
Audio
Enables you to set and monitor the audio level.
Chroma Key Properties
Enables you to configure the source chroma key settings. Each source in a shot can
have its own chroma key settings.
Title Properties
Enables you to set properties for a title in your shot.

Shot Layers Tab
The Shot Layers tab lists all of the layers in the shot.
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Note: Source icons appear only when you hover over them.

Add or remove
source

Select source

Move up or
down
Manage layers

Click the eye or
speaker icon

See Adding, Deleting, or Rearranging Layers in a Shot.

Replay Layer
PRO

The Replay Layer is a placeholder layer that can be added to any shot for the purpose of
creating a Replay Template Shot. Once the shot is selected in the Replay Settings it can
be used as a template for any created Replay Shot.
See Creating a Replay Shot from a Layer.
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Shot Layers Properties Tab
The Shot Layer Properties tab enables you to make adjustments to the sources in your
shot.
Position
Size
Gear icon
Scale jog wheel
Scale to Fit & Reset Position
Fill
Rotation sliders
Opacity slider
Reflection slider
Matte selector
Click Crop arrow
Crop adjustments
Crop reset button
Click Color arrow
Color adjustments

Color reset button
Click Drop Shadow arrow
Check to enable
Drop Shadow
adjustments
Defaults and Reset buttons

Click PTZ arrow
Recall a PTZ preset
Click to open PTZ control panel

Position
Displays the position of the selected source in your shot. Position “0 0” represents the
middle of the shot area. To move a source, enter new location values.
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Size
Displays the size of the selected source in your shot. To resize a source, enter new size
values.
Gear icon
Click and select how to size you bounding box: by pixels or percentage.
Scale Jog Wheel
Click and move the jog wheel to change the scale of your bounding box.
Scale to Fit Button
Click to expand the source to its maximum size on the canvas. This may distort the
display of the source depending on what you have selected in Fill (below).
Reset Position Button
Click to force the source to return to its original size (scale) and rotation positions.
Fill
Select the way the scaling fills the bounding box:

• Lock Aspect Ratio: Fills the bounding box until one side hits the edge. Will respect
the aspect ratio, and will not crop your media.

• Lock and Fill Width: Fills the bounding box to its width. Will respect the aspect

ratio, so media may end up being obscured top to bottom if your bounding box
height is less than the media height (or will have letterboxing if bounding box is
larger).

• Lock and Fill Height: Fills the bounding box to its height. Will respect the aspect
ratio, so media may end up being obscured on the sides if your bounding box
width is less than the media width (or it will have pillar bars on either side if the
bounding box is larger)

• Stretch to Fill: Fills your bounding box, does not respect aspect ratio of media, so
may end up distorting your media.

Note: The Fill feature is not active in Clock, Text, Solid, QR Code or Web Page shots. In
these shots the image automatically stretches to fill the bounding box.
X Y Z Rotation
Slide the X (Horizontal), Y (Vertical), or Z (Straight-through) axis sliders to rotate the
source. (See also Reset Position below).
Opacity
Slide the Opacity slider to adjust the degree of transparency of your image.
Reflection
Slide the Reflection slider to adjust the degree of reflection below your image.
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Matte
A Matte is a mask over a shot. Select a matte by clicking the down-arrow on the Matte
menu. Default is No Matte. You can also use any media file as a custom matte. To do this,
create a new shot of the media file you want to use as a matte. This file now appears in
the Matte drop-down menu where you can select it.
Crop
Click the Crop triangle to open the cropping adjustment pane. Slide the Left, Right, Top,
and Bottom sliders to crop your source image.
Reset
Click the Reset button to reset the crop controls to their default settings.
Color
Click the Color triangle to open the color adjustment pane. Slide the color controls to
adjust the color.
Reset
Click the Reset button to reset the color controls to their default settings.
Drop Shadow
Click the Drop Shadow triangle to open the Drop Shadow adjustment pane. Check the
checkbox to enable the controls.

– Color Click in the color field to open the color palette. Select a shadow color and
luminance by sliding the vertical and horizontal sliders. Click outside the color
edit box to close the palette.

– Angle Move the Angle slider to adjust the direction (0 to 360 degrees) the
shadow text is offset from the actual text.

– Offset Move the slider to adjust the distance the shadow text is offset away from
the actual text.

– Opacity Slide the Opacity slider to adjust the degree of transparency of your
source.

– Blur Size Move the slider to adjust the amount of blur in the drop shadow.
Use As Defaults
Click to set the current drop shadow configuration as the default setting. All future
enabled drop shadows will be set this by default. Clicking this button does not
retroactively update previously created shots. Drop shadow settings on individual
shots can still be changed.
Reset
Click to restore the drop shadow settings back to the default values. You can also
restore the drop shadow settings to Wirecast application defaults by holding the Shift
key down and clicking Reset.
PTZ
Click the PTZ triangle to open the PTZ control panel.
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Preset
Click the up and down arrows to find a PTZ preset to recall, then click the Right Pointing
Arrow button to recall the preset.
Show PTZ Controller
Click to display the PTZ Controller panel.
See PTZ Controller.

PTZ Control in the Shot Layer Properties Tab
You can select PTZ Controller presets associated with a shot layer video source from the
Shot Layer Properties tab of the Preview Inspector. You configure PTZ Control Presets in
the PTZ Controller Panel.
To expand the PTZ control panel, click the PTZ triangle. To enable preset recall, check
the Enable box. To select a preset, enter a preset number or click the up/down arrow
buttons. Click the Go button (right pointing arrow) to cause the associated PTZ camera
to recall that preset.
Once you have configured a shot layer with a PTZ Preset, sending that shot to preview
recalls the preset for the camera. If multiple shots share the same video source with
different PTZ Presets configured, the shot which is currently live takes precedence over
subsequent PTZ Preset recall actions, until you drop the shot from the live feed.
When you enable Preset, clicking Show PTZ Controller opens the PTZ Controller panel.
See Shot Layers Properties Tab.

NDI Devices in the Shot Layer Properties Tab
If you have selected an NDI source, the NDI Source Properties tab will display. In
addition to the controls above, an NDI source has the following controls.
Video Delay
Enter the amount of time (in seconds, as short as 1 ms) to delay video.
Bandwidth
Select the bandwidth to use: Highest (max quality), Lowest (max efficiency), or Audio
Only (video bandwidth not applicable).
GPU Decoding
When checked, incoming sources will use your GPU to process the incoming source.
Timestamps
Select Provided by source, or Provided by Wirecast.This setting allows you to use
timestamps embedded in the source, or use timestamps generated by Wirecast.
Timestamps are used to synchronize devices. Many sources don't provide completely
accurate timestamps, resulting in sources out of sync with each other (i.e. audio and
video not syncing).
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Select Provided by Wirecast to ignore the timestamps coming from the source, and
instead generate new timestamps. However, the risk is that if the system is under a
heavy load, the generated timestamps could be impacted, and end up arriving late. The
default setting is Provided by source.
Deinterlacing
Select None, or Blend Fields.
Dynamic Range
Select Default, Full or Limited.
Monitor
Check the Monitor check box to cause audio to play through your monitor output. If the
check box is unchecked, audio will not play through the monitor output for this source.
Checked is the default.
Note: NDI networking requires that your network has port 5353 open for mDNS
device discovery, as well as one port per video channel (starting from port 5960 and
onward) transmitted by an NDI source, plus one additional port for messaging.
See Adding NDI™ Sources to Rendezvous.

Audio Properties Tab
The Audio Properties tab enables you to control and monitor audio. You can set the
audio level, mute and monitor the audio, and map channel outputs.
Volume slider
Pan control
Meter display
Speaker icon
Map button
Channel controls

Volume
Adjust the slider to set the audio volume level.
Pan
Adjust the slider to pan between left and right audio.

Wirecast User Guide

143

144

Windows, Controls, and Menus
The Shot Editor Window

Meter
Monitors the audio level. You can also mute the audio by clicking the audio icon.
Speaker Icon
Click to mute the audio output. Icon turns gray when muted. Click the icon again to unmute the audio.
Channels
Select left (L) or right (R) for each channel. Adjust volume slider for each.
Apply to All
Click to apply the current settings to every instance of the selected source. If you have
any shot specific configurations in other shots, they will be changed to match what was
configured when you click this button. This action cannot be undone!
Set as Default
Click to take the current settings and set them as the default configuration. Any time
this source is added to a shot in the future, it will be created with this configuration.
Reset
Click to reset the default settings. This is useful if you have made changes to the default
custom settings, but want the defaults set back to the factory default settings. Factory
defaults are: Chan 1 = Left; Chan 2 = Right; additional channels are unassigned.
Map
Click to open the audio mapping window. Check a square to map an audio channel to
an audio track. Any audio can be tracked to any or all tracks. However, you will typically
assign a group of channels to one track and other groups to other tracks.
If you have created a shot using a 16 input device, the mapping window will display all
16 channels.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.
The audio track that is actually used is selected from the Audio Track menu in the
Output Settings window. You can select only one track. However, if you are recording,
you can select multiple audio tracks.

Chroma Key Properties Tab
Chrome Key (also called “green screen”) enables you to replace all green areas of your
display (or any other color you choose) with a background image. For example, if you
are in front of the traditional green screen, by “keying out” the green and leaving the
background transparent, you will appear to be in front of your background.
The Chroma Key Properties tab enables you to turn on/off chroma keying and make
chroma key adjustments. Check the Use box and+ select the type of use: Chroma,
Luma, or Color Key.
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Use
Check to turn on chroma keying. Uncheck to turn it off. Select the type of use: Chroma,
Luma, or Color Key.
Color
Click the color square to open the Color Pallet. Select a color to use as the chroma key
color and click OK. Click the dropper icon to use your mouse to select a chroma key
color from your screen. Hover over the a desired color in the selected source, and click
the left mouse button to select that color. All adjustments will be made using the
selected color as the key.
Key Threshold
Move the slider to adjust how far away from your chosen chroma color you want to
enable keying. The farther right you move the slider the more variation to the color it
accepts.
Black Clip
The Black Clip slider allows you to define what is considered “black”. When slider is fully
left, you have a very thin definition of what black is. The farther to the right you go, you
start adding more cases of what we consider “black'”. In chroma key, rarely do you want
to bump the far left side to the right.
White Clip
The White Clip slider allows you to define what is considered “white”. Slide both all the
way to the right, for a very thin definition of white. The more you increase the range,
the more you add to what you consider to be full intensity brightness. In chroma key,
rarely do you want to bump the far right side to the left.
Spill Suppression:
This slider says: anything that is near green, bump it away from green. Move this slider
to help take away the green reflection it locates on an edge. This will take everything
that's green, and take away its greenness.
Solidify:
This slider says: if all the pixels around me seem to be part of the key, then bump up my
probability of being part of the key. This tends to “solidify” your key. Move the slider to
the right to bump up the alpha values for pixels surrounded by high alpha values. One
disadvantage is that the hair on a subject may appear more “blocked” in nature.
Edge Coloring
Move the slider to adjust the level of edge coloring which pull colors from inside of
keyed object to get rid of halo on an image.
Display
Select display: result of keying, white-alpha channel, or black-alpha channel. This can
be helpful to get key parameters set correctly.
Luma Key
This lets you key based on its brightness (or Luma value). You have an icon with a white
background - and you want to get rid of the white background.
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Color Key
This lets you set the image alpha based on the distance from a given color in the RGB
space. This is useful for images (logos) that have non-black and non-white
backgrounds. If the BG is black or white use Luma Key. If it's a plate from a greenscreen/
bluescreen then use Chroma Key. Otherwise, try Color Key.
Alpha Clip
This lets you choose what distance from the key color should be considered
“foreground”. So anything over a given distance from the key color is “foreground”
otherwise it's “background”. A range is used so there is a smooth transition from
foreground to background.

Smooth Transition Properties Tab
The Smooth Transition Properties tab provides control over how objects (image, movie,
title, etc.) are added or removed in the Live Broadcast Area. Wirecast performs motion
only during a Smooth transition. If you are using any other transition, the motion
settings are ignored.
There are two types of motion. When an object is added to your broadcast it is called
Build In; When it is removed it is called Build Out. Motion only occurs when an object
enters or leaves the Live Broadcast Area. For example, if you have two shots, each with a
foreground and the media in the foreground is the same, then a Smooth transition is
performed between the foregrounds. However, no motion is performed. Or, if a logo is
positioned in the top left corner in an existing shot, and it is in the bottom right corner
in a new shot, when you make the new shot Live the logo smoothly transitions from the
top left corner to the bottom right corner. But the Build In and Build Out settings are
ignored.
However, if you have two shots with a Foreground, but the media in each is different,
the Build Out is performed for the existing shot, and the Build In is performed for the
new shot.
Direction Menus
These provide selections of where the Build In comes from (top, bottom, right, etc.)
when it is added, and where the Build Out goes when it is removed.
Fade In / Fade Out
Checking these checkboxes causes an object to be added or removed gradually. If
unchecked, the object is instantly added or removed, much like a cut transition.
Spin In / Spin Out
Checking these checkboxes causes an object to be added or removed in a spinning
fashion.
Scale In / Scale Out
Checking these checkboxes causes an object to be added or removed in a scaled
fashion.
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Apply To All
Click this button to make the Transition Settings the same for all sources in a shot. This
is useful if you want to make all of your motion the same for all of the elements in the
shot.
Set As Default
Click this button to make these Transition Settings the default settings for all new shots.
These default settings will be applied in all future WC documents.

The Audio Mixer Window
The Audio Mixer enables you to monitor and control all of the audio sources from a
single control panel. This section describes in detail how to use the Audio Mixer.
To open the Audio Mixer window, select Audio Mixer from the Window menu.
The Audio Mixer separates your audio by hardware and shot. Live Input is always the
first section to the right of the Final Mix control, and it contains all hardware audio
sources that are live in your streaming event. This includes microphones, audio input
feeds, cameras, capture cards, Web streams, etc. The remaining audio controls are
associated with specific shots.
Live Sources
control panel

Final Mix Audio
control panel

Final Mix
Audio Level

Delay
Channel
FX
Add new FX

Final Mix
display

Level control

Final Mix Mute

Level display

Headphone
Mute
Source
selection
Track
selection

Mute button
Monitor button
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The Monitor button toggles the source audio when monitoring Preview or Live output.
This does not remove the audio from the output stream or recording. Delay enables
you to delay the audio as needed, in seconds and milliseconds. Channel enables you to
select left source only, right source only, or stereo (left and right).
Delay
Enter the amount of audio delay needed (in seconds and milliseconds).
Channel
Select the channel to use: Left, Right, or Stereo (both).
FX
Click the down-arrow to display the audio effects panel.
Add New FX (+)
Click the plus (+) icon to select an audio effect from the drop-down menu.
Delay
L and R Delay adjusts how much delay on each channel. Feedback is how much delay is
used. Fb Tone is a frequency setting of highs and lows to be delayed. FX Mix is how
much delay will be added to audio output. Output sets the delay output level.
Dynamics
Thresh sets the threshold of engaging compression. Ratio sets the compression ratio.
Output sets the compression level. Attack sets the manner in which compression is
applied. Release sets how compression in released. Limiter sets a max output level on
the audio. Gate controls (Thresh, Attack, and Release) sets the noise gate that cuts off
noise at the set level. Mix adjusts how much compression is applied to the audio.
De-ess
Thresh sets the threshold of de-essing. Freq selects the frequency at which de-essing
will be applied to the audio. HF Drive adjusts the high frequency aspect of de-essing.
EQ
Low, medium, and high adjusts low, mid, and high frequency components in the audio.
Loudness
Loudness adjusts the amount of loudness (raising high and low frequencies) in the
audio. Output adjusts how much loudness is applied to the audio.
Limiter
Thresh sets the minimum threshold of limiting in the audio. Output sets the amount of
limiting used in the audio. Release sets the manner in which limiting is released as the
audio decreases. Attack sets the manner in which limiting is applied. Knee adjusts the
frequency and shape of point where limiting begins.
Multiband
Listen selects which part of the frequency spectrum to hear: low, mid, high, or all
(output). L<>M adjusts the cutoff frequency in the low to mid range (87 to 1020 Hz).
M<>H adjusts the cutoff frequency in the mid to high range (111 to 19606 Hz). L, M,
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and H Comp adjusts the compression for low, mid, and high frequencies. L, M, and H
Out adjusts the output for low, mid, and high frequencies. Attack sets the manner in
which compression is applied. Release sets the manner in which compression is
released. Stereo adjusts how the left and right channels are separated (width) from 0 to
200%. Process selects stereo or mono mode.
Noise Reduction
Amount sets the amount that noise reduction is applied.
Level Control
Adjusts the audio level of the live audio output.
Level Display
Displays the levels (left and right) of the live audio outputs.
Mute
Mutes the live audio output.
Monitor
Toggles the monitor audio output in the headphones without effecting the live audio
output.
Final Mix Audio Level
Adjusts the audio level of the Final Mix audio output.
Final Mix Display
Displays the levels (left and right) of the Final Mix audio outputs.
Final Mix Mute
Mutes the Final Mix audio output.
Headphone Mute
Toggles the monitor audio output in the headphones without effecting the Final Mix
audio output.
Source Selection
Click the down arrow to select an audio source from the drop-down menu.
Track Selection
Click the down arrow to select an audio track from the drop-down menu.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.

The Output Settings Window
The Output Settings Window enables you to customize the settings for a destination.
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Destination List
Wirecast lists the last-used destinations in the left-side pane of the Output Settings
window. Each destination has its own broadcast technology preset, for example RTMP,
or Windows Media.
Add Button
When clicked, the Add button opens the Select an Output Destination dialog, enabling
you to add destinations to the destination list.
Remove Button
When clicked, the Remove button opens the Select an Output Destination dialog,
enabling you to remove destinations from the destination list.
Name
This is an editable field for the name of the output setting. By default, Wirecast names
the setting for the destination selected.
Destination
This drop-down menu lists all the visible existing destinations.
More Button
This button opens a menu listing all existing destinations, with check boxes for making
each destinations visible in the Destinations drop-down menu.
First Gear Icon
This drop-down menu lists actions available for the destination selected.
Encoding
This drop-down menu lists the available encoding presets. Each destination preset has
its own encoding presets. The encoding presets define the codec, aspect ratio, and
frame rate for each destination. Wirecast provides many encoding presets.
Second Gear Icon
This drop-down menu enables you to view the details for the preset selected, create a
new preset, or filter the presets listed for the destination selected.
Audio Track Selection
This drop-down menu lists the audio tracks available for the destination selected.
Map Button
This button opens the Multi-Track Input Mapper for the destination and track selected.
Address
This editable field contains the network address for the destination selected.
Port
This editable field contains the port address for the destination selected.
Passphrase
This editable field contains the passphrase for the destination selected.
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Location
This field displays the host location for the destination selected.
See Destinations and The Encoder Presets Window.

The Encoder Presets Window
The Encoder Presets window enables you to select a default encoder preset for your
output, and to create your own custom presets.
Encoder Preset
This drop-down menu lists all default and custom encoder presets available.
Video Encoding
When checked, Wirecast enables you to customize the video encoding settings shown
in the Video Encoding pane.
Note: You should match the output to the canvas size as closely as possible to
preserve video resolution and quality. For example, a 800x600 source results in
significant loss of quality if an aspect ratio of 640x480 is selected for the output.
Choosing an output of 720x576, which is much closer in size, helps preserve video
quality.
Profile
Many encoder presets enable you to select one of three profiles: Baseline, Main, or
High.
Baseline Profile (BP) Baseline profile is primarily for low-cost applications that require
additional data loss robustness. This profile is used in some video conferencing and
mobile applications. It includes all features supported in the Constrained Baseline
Profile, plus three additional features used for loss robustness (or for other purposes
such as low-delay multi-point video stream compositing). The importance of this
profile has faded somewhat since the definition of the Constrained Baseline Profile in
2009. All Constrained Baseline Profile bitstreams are also considered to be Baseline
Profile bitstreams, since these two profiles share the same profile identifier code value.
Main Profile (MP) The Main profile is used for standard-definition digital TV broadcasts
that use the MPEG-4 format as defined in the DVB standard. It is not, however, used for
high-definition television broadcasts, since the importance of this profile faded when
the High Profile was developed in 2004 for that application.
High Profile (HiP) The High profile is the primary profile used for broadcast and disc
storage applications, particularly for high-definition television applications. For
example, this profile is used by the Blu-ray Disc storage format and the DVB HDTV
broadcast service.
Audio Encoding (AAC)
When checked, Wirecast enables you to customize the AAC audio encoding settings
shown in the Audio Encoding pane.
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See Encoder Presets and Encoder Presets.

The PTZ Controller Panel
In this panel you can create a preset group of settings for each camera listed in the
Camera drop-down menu. You can associate multiple presets for each camera. Also,
you can switch between devices in the Camera drop-down menu.
Camera
This drop-down list shows cameras available to Wirecast. Selecting a camera updates
the PTZ Controller window to display the preset VISCA and PTZ configuration for that
camera. Once you establish a connection to a valid VISCA device, the PTZ Controller
panel shows the camera's current Pan/Tilt orientation. Changing the Camera source
changes all the settings in the panel accordingly.
Note: A PTZ camera's VISCA configuration is discrete from the video feed. You can
associate any available video source with any manually-entered VISCA device
information. This accommodates a workflow where the camera's video feed is being
captured via a Capture Card.
Protocol
Select a PTZ protocol from the drop-down menu,
IP Address
Enter the IP address of a valid VISCA-over-IP source on the network. This IP address is
configured in your camera's network settings.
Port
Enter the IP port for the VISCA connection of the camera. This IP port is configured in
your camera's network settings.
VISCA Address
Select the correct VISCA Address of the camera. This VISCA Address is configured in
your camera's VISCA settings.
Status / Reconnect Button
Displays the current VISCA connection status (“connected” or “invalid source”) of your
camera. Click the Reconnect button to force a reconnection.
Home Button
Click the House icon to reorient the PTZ camera to its default position (default centered,
no zoom).
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Pan/Tilt
Select the desired pan/tilt control method (Map, D Pad, or Analog Pad) from this dropdown menu.

• Map – displays an X/Y plane with a yellow cross-hair representing the current Pan/
Tilt orientation of the camera

• D-Pad – Pan the camera by clicking the left and right arrows, and tilt the camera by
clicking the up and down arrows.

• Analog Pad – Click in the analog circle to reposition the camera pan and tilt.

Zoom
Move the slider to adjust the zoom factor of your camera.
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Note: When the PTZ Controller panel is the selected window, you can press the arrow
keys on the keyboard to adjust the Pan (left and right arrow keys) and Tilt (up and
down arrow keys) of the camera. Alternatively the W, A, S, and D keys can also be used
(W = Up, A = Left, S = Down, D = Right)
Focus
Click the Plus and Minus buttons to adjust the focus of the camera. The yellow button in
the center toggles auto-focus on and off. Any manual adjustments made to the focus
will automatically disable the auto-focus.
Exposure
Select the exposure mode from the Exposure drop-down menu.

• Shutter Move the slider to adjust the shutter of the camera. You can only adjust the
Shutter when Exposure mode is not in auto-focus.

• Iris Move the slider to adjust the iris of the camera. You can only adjust the Iris
when Exposure mode is not in auto-focus.

Note: Refer to PTZOptics documentation for more details about each mode.
White Balance
Select the white balance mode from the White Balance drop-down menu.
Note: Refer to PTZOptics documentation for more details about each White Balance
mode.
One Shot
When the White Balance mode is set to One Shot, click this button to adjust the White
Balance one time only.
Red Gain/Blue Gain
When not in auto-focus mode, you can use these sliders to adjust the red and blue gain
of the video signal to compensate for white balance issues.
Presets
Enter a preset number and click Save to save current Pan, Tilt, and Zoom configurations
of camera. To recall a preset, select a preset number by clicking the arrow buttons, then
click the Recall button.
Note: If you have Wirecast in the AutoLive mode, you must click the Live button to
switch between presets on the same PTZ camera. This is a built-in safeguard against
unintentionally moving the camera while in Live mode.
See Configuring The PTZ Controller, Opening the PTZ Controller Panel, and Controlling a
PTZ Camera.
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File Menu
New
Creates a new, empty Wirecast document.
Open
Displays the Open dialog window for opening a Wirecast document.
Open Recent
Displays up to fifteen of the most recently accessed documents. Every time a document
is opened or saved it is entered into this list.
Import Media
Enables you to import media into Wirecast. A new shot is automatically created using
the new media.
Save
Saves the document. If the document has not already been saved, the Save As... dialog
window is displayed.
Note: Wirecast auto-saves your Stream/recording. All formats (WMV, MOV, MP4) will
be recoverable in increments of 20 seconds. Any recording less than 20 seconds is
corrupted. ISO also recovers. In the case of an unexpected shutdown, the recoverable
video is available in increments of one minute.
Save As
Displays the Save As... dialog window so that the document can be saved using a new
file name.
Close Window
Closes the currently active Wirecast window. If the window is a document, all of its Shot
Editor windows are closed as well. If Wirecast is still broadcasting, you are asked to stop
the broadcast. If the document has not been saved, you are asked to save the
document before closing.
Preferences Opens the Preferences window. If the Preferences window is already open,
it is made active.
Exit Closes all documents and then exits. If the broadcast is playing, you are asked to
stop the broadcast. If a document has not been saved, you are asked to save the
document before exiting.

Edit Menu
Undo
Reverses your last change in Wirecast. Undo is only available in some windows (such as
the Preview Area). Wirecast offers an unlimited number of undo actions (within
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computer memory limitations). Undo information is stored on a per-window basis.
Also, if you close a window then reopen it, your undo information is lost.
Redo
Reverses your last undo action. Redo is only available in some windows (such as the
Preview Area). Wirecast offers an unlimited number of redo actions (within your
computer’s memory limitations). Redo information is stored on a per-window basis.
Also, if you close a window then reopen it, your redo information is lost.
Cut
Cuts selected text.
Copy
Copies selected text to clipboard.
Paste
Pastes selected text from clipboard to location of cursor.
Paste as new Consolidated Shot
Pastes selected shots into one consolidated shot. A consolidated shot is a shot created
from multiple sources.
Select All
Selects all text in the active window.
Edit Shot
Opens the Shot Editor. You can also double-click a shot, or right-click and select Edit
Shot, to open the Shot Editor.
See The Shot Editor Window.
Rename Shot
Enables you to rename a shot. You can also right-click a shot and select Rename Shot.
Duplicate Shot
Duplicates the currently selected shot. You can also right-click a shot and select
Duplicate Shot.
Duplicate Shot Options
Check a source to create a new instance of it when duplicating the shot containing it.
Multiple selection is allowed.
Delete Shot
Deletes the currently selected shot. You can also right-click a shot and select Delete
Shot.
Move To Layer
Moves a shot to the selected layer. When shots are created, they are assigned to a
specific layer. They exist on that layer until they are moved or deleted. You can also click
and drag a shot to another layer.
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Switch Menu
Go
Performs a transition (same action as clicking the Go button).
Transitions
Wirecast has two transition buttons that can be assigned any transitions (cut, smooth,
etc.) that Wirecast supports. The Switch menu lists the currently assigned transitions by
name. These two transitions can also be selected by pressing the control key and either
the 1 or 2 key. Right-click on either transition to open the operation menu. Select how
the transition will operate: Ease In, Ease In/Out Ease Out, Linear, or I.
To select which transitions appear in this menu, see Transition Controls.
Transition Speed
Enables you to select one of five transition speeds ranging from Slowest to Fastest.
Manage Stinger Transitions
Enables you to import and use custom transitions that employ transparent
backgrounds. These transitions are typically created using applications such as Adobe
After Effects, Apple Motion or ScreenFlow.
Select Switch > Manage Stinger Transitions to display the Stinger Transition Manager. To
import a transition file, click the plus (+) button and navigate to the location of the file.
Once the transition file is imported, you can preview the transition from shot A to shot
B by clicking the play button. To set the location of where the shot will change from A
to B, slide the scrubber to a location in the transition, then click the A/B button.

Click play to
preview

Move scrubber
to a location

Click the A/B
button

Note: Stinger transitions are stored in the preferences (including the path to the
media file). This allows the you to re-use transitions in other WC documents. When
Wirecast cannot find a media file associated with a Stinger transition (file deleted or
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moved), the transition will be removed from the transition bank list and the name will
be highlighted red in the Stinger Transition Manager.
To delete a transition, select it and click the minus (-) button. Click the help (?) button to
display help instructions (this portion of the user guide). Check (optionally) the Keep all
video frames in memory check box. When checked, CPU spiking (which can cause
streaming problems) is prevented, but more memory is used. Click Close to exit the
Stinger Transition Manager.
To execute a Stinger Transition, open a transition menu and select a Stinger transition.
Click the Go button to execute the Stinger transition.
AutoLive
Toggles (turns on and off ) the AutoLive feature.
You may want to single-click a shot to make it become live. Alternatively, you may want
to make several changes to a shot before making it live. You can use either method in
Wirecast.
When enabled, the AutoLive feature lets you broadcast any shot with a single click.
When AutoLive is enabled, Wirecast disables the Go button. Clicking a shot in a layer
automatically places the shot in the Live Broadcast Area.
See Single-Click Switching with AutoLive and Go Button.
Live/Preview Swap
Toggles (turns on and off ) the Live/Preview Swap feature. When on, the Live Broadcast
and Preview windows trade panes (swap) when the Go button is clicked.
Layer Visibility
Click to open the menu and select a layer to hide or show in your shot. A check mark
displays when the layer is visible. The shot icon becomes gray when not visible. You can
toggle on and off the viability of each layer by pressing the Alt+1 through Alt+5 keys.
Disable PTZ Preset Recall
Enables/Disables PTZ preset recall.
See The PTZ Controller Panel.
Note: When you transition to a shot containing an animated title, Wirecast first
executes the transition, and then performs the opening animation for the title. When
you clear the title from the shot, Wirecast first performs the closing animation for the
title, and then executes the transition for the end of the shot.

Media Menu
Start Playing All Movies
Starts playing any movies that are not currently playing.
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Pause All Movies
Pauses all movies that are currently playing.
Shuffle Playlist
Randomly rearranges the order of media in the playlist.
Show Asset Manager
Displays devices that can be configured. Some devices (cameras, etc.) may be
configurable. For example, you can configure a USB camera to manually change its
focus, contrast, brightness, etc. Other devices have multiple inputs you can choose
(AlchemyTV Card, etc.).
See Asset Manager.
Note: The Configure Devices menu selection is present only if a device is connected
to Wirecast. The configuration user interface is provided by the device maker. It is
beyond the scope of this document to describe all of the features available for all
devices. See the documentation provided with your device on how to configure it.

Output Menu
Output Settings
Opens the Output Settings window.
Start/Stop Broadcasting
Starts (or stops) broadcasting to the network.
Start/Stop Recording
Starts (or stops) recording to disk. If you have not yet configured the Output Settings
for this document, you are prompted to do so.
Show Recordings
Opens all the folders of all the file directories in the Output Settings.
Multi-Viewer Output
Enables you to setup and use a Multi-Viewer display on and or all monitors. You can
configure your displays, enable all displays, select a display to be active, or show (or
hide) all displays when the application is in the background.
Configure Displays
Select Configure Displays to open the configuration window.
Setup your Multi-Viewer by choosing a Monitor which determines where the MultiViewer will display. Also select the Mode: Multi-viewer, Live Output, or Disabled
(neither).
Select a Layout which determines how the Multi-Viewer will be displayed. The layout
choices are: one, two, or four slots. In the Pro version ten or seventeen slots can also be
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selected. Each panel slot can then be mapped to any source: Preview, Live or any
existing Shot in your document. Click inside a panel to select a source. Each Monitor is
configured separately using the Configuration window. So, when you select a different
monitor, the configuration panel (slots) also change. Additionally, all the monitors are
automatically numbered. Clicking the Identify Displays button causes each of the
monitors to display it number on it.
You can also control how each panel is labeled by making a selection from the Labels
menu:
Draw Labels Below each Slot
Displays the label below each shot in each panel.
Superimpose Labels Over Each Shot
Displays the label over each shot in each panel.
Do Not Draw Labels
No labels are displayed.
Click on any slot panel to open the source menus, then select a source from the list to
display it in the slot. Click Identify Display to cause the display number on each display
to be shown.
Enable/Disable All Displays
Select to hide or display all of your configured Multi-Viewed monitors.
Select a Display
Select one of your configured Multi-Viewed monitors to hide or display. Shown below is
a typically configured monitor with four slots. Audio meters are provided in each view.
Hide All Displays When App is in the Background
PRO

When selected, all Multi-Viewer Displays are hidden if Wirecast itself is put into the
background or minimized. Turning this option off allows the Multi-Viewer outputs to
stay on if Wirecast is put in the background or minimized.
Note: Multi-Viewer displays can also be disabled by clicking on the Multi-Viewer
display itself (on its target monitor), and then pressing the Escape (Esc) key.
Secondary Display Live Output
Sends the live program to a secondary device. For example, you can send a live
program feed to another screen or to a capture card in an external device. If the
external device has an UVC HDMI capture card, you can capture the live output from
Wirecast for use in the applications--such as Zoom or Teams--on the other device.
You can use Secondary Display Live Output as an alternative to Virtual Camera/Mic.
You can map audio tracks, as well as video, to the secondary display.
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Virtual Camera Out
Enables you to present the output of Wirecast as if it were a camera (a virtual camera),
allowing it to be automatically detected by other applications when they are launched.
Outputs only the Live Program feed.
For more detailed information, see Virtual Camera.
Active Broadcast
Once you have logged into your YouTube or Twitch account and you start streaming,
you can select Active Broadcast to display the YouTube broadcast window in a browser.
Control Room (YouTube only)
Once you have logged into your YouTube account, you can select Control Room to
display the YouTube control room window in a browser.
Dashboard (Twitch Only) Once you have logged into your Twitch account, you can
select Dashboard to display the Twitch dashboard window in a browser.
VOD of Last Broadcast Enables you to view the most recent completed broadcast.
Note: Active Broadcast is enabled only for Twitter-Live Broadcast and YouTube.,
Control Room and VOD of Last Broadcast are enabled only when you are logged into
YouTube.
Facebook (Facebook Live Only)
Select Active Broadcast to display your Facebook Live event.
Twitter
Opens menu to monitor your Twitter broadcast.

• Active Broadcast Once you have logged into your Twitter account and you start

streaming, you can select Active Broadcast to display the your broadcast window in
a browser.

• Producer Dashboard Once you have logged into your Twitter account, you can

select Producer Dashboard to display the Twitter dashboard window in a browser. In
the dashboard you can start your broadcast by clicking the Go Live button.

To stop your broadcast click the Stop Stream button.

• Toggle Broadcast Click to toggle between Go Live and Stop Broadcast on the
Producer Dashboard.

Canvas Size
Sets the canvas size resolution used when broadcasting a Wirecast document.
Note: You should match the output to the canvas size as close as possible to preserve
video resolution and quality. For example, a 800x600 source results in significant loss
of quality if a resolution of 640x480 is selected. Using 720x576, which is much closer in
size, helps preserve video quality.
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Show Statistics
Displays the statistics window for your broadcast. You can select (for display): Bitrate,
RTMP Queue Size, Framerate, System CPU Usage, and System Memory Usage.
PRO

NDI Output
Sends the output of the Live Program feed. Select the output resolution for your NDI
output. You can also select a link that will take you to NDI.NewTek.com for additional
information.
Note: Although SDI supports 16 discrete audio channels, Wirecast Pro video out
currently only supports two channels.
Blackmagic Cards
Note: If you are updating to Wirecast 14 (or a previous version) and have multiple
capture cards that are different models, when you open a saved document that
contains sources from the capture cards, one of the inputs may fail to upgrade (and
will show their saved source.) To remedy this re-add the missing source back into the
document, then open the Asset Manager and assign that newly added source to back
into its saved shot.
You can use Blackmagic cards to send live feeds directly into editing, effects and
broadcast design systems. In order to use this feature, install a Blackmagic card with
associated drivers, then restart Wirecast. The Blackmagic card with then be listed in the
Output menu.
Under the Output menu, select a Blackmagic card, and then select an HD setting for its
output. If your card has multiple outputs, you can select more than one and all will
output simultaneously at independent resolutions and Frame rates.
To begin outputting, select Start Output and chose a setting.
You can stop the Blackmagic card output by selecting Stop Output. If you have multiple
outputs selected, they will all stop outputting.
Note: Some Blackmagic cards do allow input and output simultaneously, but need to
be configured in the Blackmagic software.
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Layout Menu
To optimize the user interface for each document, you can configure the Wirecast
layout.
Wirecast enables you to select which functions are displayed in the default layout.
These functions are added or removed from the default layout using the Layout menu.
Final Mix
When checked, displays the Final Mix Audio controls. Final Mix Audio controls are
located on the left and right sides of the default layout.
Show Live and Preview
When checked, displays the Live and Preview windows, and allows you to select
between displaying the Preview Area only, the Live Broadcast Area only, or both.
Show Preview Only
Displays the Preview Area only.
Show Live Only
Displays the Live Broadcast Area only.
Note: The three controls above work the same as the Mode Control buttons at the
top-right of the default layout. See Mode Selection Buttons.
Zoom Layers In
Increases the size of all the layer icons.
Zoom Layers Out
Decreases the size of all the layer icons.
Zoom Layers To
Sets the size of all the layer icons to: 50%,100%, or 200%.
Note: You can also change each layer size by clicking and dragging the divider line
between layers. Additionally, you can change the size of all layers by holding the Ctrl
key while clicking and dragging the divider line between layers.
Go to Layer
Displays the selected layer. You can also press Ctrl + Shift keys with the T, F, N, B, or A
keys to select a layer. Each of these letter keys represents a layer name: Title,
Foreground, Normal, Background, and Audio.
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Replay + ISO Menu
PRO

Start All
Activates the Create Replay Shot system. When activated, the menu item becomes
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.
Activate
Activates the Create Replay Shot system. When activated, the menu item becomes
Deactivate. Click Deactivate to deactivate the Create Replay Shot system.
Configure ISO Outputs
Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an
ISO output, click Configure, then click the Add ISO button.
Note: You can create ISO recordings of any source or shot in your document.
Replay Mark All
Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the
beginning point of your Replay Shot capture.
Create All Replay Shots
Select Create to create additional Replay shots.
Update All Replay Shots
If no replay shot exists, selecting Update creates a new Replay shot. There after,
selecting Update updates the first Replay shot created.
Configure
Displays the Replay Shot settings window.
For more information about Replay Shots see Replay + ISO Menu.
ISO enables you can set up ISO recording and do Replays from the same menu. To use
Replay and ISO functionality, select the Replay + ISO menu.
Start All
Activates all configured ISO shots and/or the Program Replay. When activated, the
menu item becomes Stop All. Click Stop All to deactivate the Create Replay Shot system.
Program Replay
Allows you to Stop, Mark In, Create, or Update a relay shot.
PRO

Replay Mark All
Allows you to tighten up your Replay Shot capture. Select Replay Mark In to mark the
beginning point of your Replay Shot capture.
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PRO

Create All Replay Shots
Select Create to create additional Replay shots.
PRO

Update All Replay Shots
If no replay shot exists, selecting Update creates a new Replay shot. There after,
selecting Update updates the first Replay shot created.
PRO

Configure
Displays the Replay Shot settings window.
Once ISO outputs are created, all ISO outputs are listed in this menu. To configure an
ISO output, click Configure, then click the Add ISO button.
See Configuring Replay + ISO.

Social Menu
Two social media options are provided: Facebook and Twitter. Facebook enables you to
receive polling data from viewers. Twitter enables you to add Twitter messages to your
broadcast along with filtering the messages displayed.

Facebook
The Social > Facebook menu contains the Create New Poll option as well as a list of any
previously-created polls.
See Creating a Facebook Poll and Selecting a Facebook Poll.

Twitter
Message Feed Brings up your Twitter feed.
Create Shot Creates a shot with a social media title in Main Layer 1.
Settings Brings up the Social Media Settings dialog.
Authenticate
Click to authenticate your account with Twitter. Enter your pin when the PIN field
displays.
Feed Type
Select a Feed Type: Home Timeline, User Timeline, Favorites, Search. If you select
Search, the Search String field becomes active.
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Search String
Enter a search string. (Active only when Search is selected in Feed Type above.)
(See in the Social Media section of this user guide for more detailed information).

Comments
Opens a dialog listing comments about the broadcast that are posted to Facebook,
Twitter, or YouTube.

Window Menu
Welcome to Wirecast
Displays the Welcome screen.
Encoder Presets
Opens the Encoder Presets window.
See Encoder Presets and The Encoder Presets Window.
Audio Mixer
Opens the Audio Mixer window.
See The Audio Mixer Window.
PTZ Controller
PRO

Opens the PTZ Controller Panel.
Wirecast Pro allows you to remotely control cameras with built-in pan, tilt and zoom
(PTZ) features using the built-in PTZ Controller window. This feature currently works
with PTZOptics and Lumens cameras that support VISCA over IP control, as well as NDI
PTZ protocol controls.
See The PTZ Controller Panel.
Show USB Devices
Opens a list of all USB devices.
Open Rendezvous Dashboard
Opens a Rendezvous Dashboard. Click Start Session to use.
See Rendezvous.
PRO

Open Advanced Rendezvous Audio Mixer
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Displays the Rendezvous Audio Mixer window.

– Output from document Select document source via the pull-down menu.
– Channel Output level indicators for each channel.
– Include In Mix When checked, this audio source is included in your Rendezvous
session.

– Audio Level (Sliders) Move the sliders Library to adjust the audio level.
Download Manager
Opens the Stock Media download monitor window. Whenever you add a Stock Media
Library file, the downloading progress is displayed. You can cancel a download by
clicking on the X icon. To navigate to the location of a downloaded file, click the
spyglass icon.
Notifications
Opens the notifications window. This window displays last “important” log messages
and other application health messages.
New Layer Window
Opens a new Main Layer window for the layer selected.
Document Windows
All open document windows are listed at the bottom of this menu.

Help Menu
Wirecast Help
Opens the online version of the User Guide.
Open Wirecast PDF User Guide
Opens the PDF version of the User Guide.
Open Tutorial HTML
Opens the Wirecast Tutorial in your browser. To follow the tutorial, you'll need to Create
a Document for the Tutorial as well.
Create Document for Tutorial
Creates a new Wirecast Document which contains the media necessary for following
the Tutorial.
Buy/Upgrade
Opens Licenses in the Preferences window. This window allows you to purchase licenses
and to activate or deactivate them.
Provide Feedback
Opens the Telestream Website feedback page where you can enter any feedback you
may have about our product or company.
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Send Support Information
Opens a Support Assistant dialog window. To create a new support ticket, select Create
a support ticket. The information is sent to the Telestream support team for evaluation.
If you have been previously issued a case number, select Link with existing support case
# and enter your case number. You can also select Do not receive follow-up from
Telestream. This enables you to send support information to Telestream without
receiving a response. Click Save Report to save the information to a file on your
computer. Click Send Report to send the information to Telestream.
For troubleshooting purposes, you can reset your preferences to the defaults by
clicking the Reset Preferences button. This will reset your preferences and create a
backup of your current preferences, in case TS Support needs it.
For troubleshooting without resetting preferences, you can also open Wirecast in “Safe”
mode using Shift + Control + Open.
Note: You must click Send Report to create a ticket. If you click Save Report, a ticket will
not be created.
Open Scripting Documentation Opens the Wirecast Scripting Help document.
Show Scripting Examples Opens the directory where the Wirecast Scripting examples
are located.
Visit Telestream LLC Website
Opens the Telestream Website home page.
Visit Wirecast / Desktop Presenter download page
Opens the Telestream Website download page for Desktop Presenter.
Acknowledgments
Opens an on-line help to Acknowledgments.
About Wirecast
Displays version and copyright information about Wirecast.

Wirecast User Guide

169

Keyboard Shortcuts

This section provides a list all of keyboard shortcuts used for Wirecast commands. The
shortcuts are listed under the names of the menus in which the commands appear.
Note: See also the section on Keyboard Shortcuts Preferences for Keyboard Shortcut
management.

Topics
■ Creating a Keyboard Shortcut
■ Creating a Keyboard Shortcut for a Shot
■ Creating a Keyboard Shortcut for Multiple Shots
■ Deleting a Keyboard Shortcut
■ General Shortcuts
■ File Menu
■ Edit Menu
■ Switch Menu
■ Media Menu
■ Output Menu
■ Layout Menu
■ Replay Menu
■ Social Menu
■ Window Menu
■ Help Menu

Creating a Keyboard Shortcut
To create a keyboard shortcut, do the following:
1. Select File > Preferences > Keyboard Shortcuts.
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2. Click the add (+) button.
3. In the Name field, enter a name for the keyboard shortcut.
4. (Optional) To make your keyboard shortcut active even when the Wirecast window
is not the active window, check Global.
If Global is not checked, the Wirecast window must be selected in order for the
keyboard shortcut to work.
See also Keyboard Shortcuts Preferences

Creating a Keyboard Shortcut for a Shot
1. In the layers pane, click the gear icon for a shot.
Wirecast opens the Keyboard Shortcuts pane of Preferences.
2. In the Name field, enter a name for the keyboard shortcut.
3. In the Key Binding (unlabeled) field, enter a key combination for the shot.
4. To close the Preferences dialog box, click the “x.”
Once a keyboard shortcut is assigned to a shot, Wirecast displays the keyboard shortcut
in the shot icon.

Keyboard Shortcut name

See also Keyboard Shortcuts Preferences.

Creating a Keyboard Shortcut for Multiple Shots
You can assign the same keyboard shortcut to multiple shots. This is useful when you
want to activate different shots on different layers at the same time, using a single
keyboard shortcut. To create a keyboard shortcut for multiple shots, do the following:
1. Assign a keyboard shortcut to one shot.See Creating a Keyboard Shortcut for a Shot.
2. Assign the same keyboard shortcut to a second shot on another layer.
Wirecast displays the keyboard shortcut in both shot icons.
See also Keyboard Shortcuts Preferences.

Deleting a Keyboard Shortcut
1. Select File > Preferences > Keyboard Shortcuts.
2. Click the Delete (-) button.
See also Keyboard Shortcuts Preferences.
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General Shortcuts
.

Misc Shortcuts
Display Shot
Enter

Space bar

i
o
e
=
]
[

Keyboard Shortcut
<shot number key*>
Selects left-hand
transition button and
clicks Go button
When two transitions
are displayed, the
space bar selects the
transition on the right
and clicks the Go
button.
When three transitions
are displayed, the
space bar selects the
transition in the middle
and clicks the Go
button.
Sets the media IN point
Sets the media OUT
point
Sets the Replay IN point
Increments Home score
Decrements Home
score
Increments Visitor
score
Decrements Visitor
score

* See Keyboard Shortcut in Changing Shots.

File Menu
File Menu
New
Open
Import Media
Save
Save As
Close Window
Preferences
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Ctrl+N
Ctrl+O
Ctrl+Shft+I
Ctrl+S
Ctrl+Shft+S
Ctrl+W
Ctrl+Comma

171

172

Keyboard Shortcuts
Edit Menu

Edit Menu
Edit Menu
Undo
Redo
Edit Shot
Rename Shot
Duplicate Shot
Delete Shot

Keyboard Shortcut
Ctrl+Z
Ctrl+Shft+Z
Ctrl+E
Ctrl+R
Ctrl+D
Ctrl+Backspace+Delete

Switch Menu
Switch Menu
Go
Cut
Smooth
AutoLive
Live/Preview Swap

Keyboard Shortcut
Ctrl+G
Ctrl+1
Ctrl+2
Ctrl+L
Ctrl+Alt+W

Media Menu
Media Menu
Start Playing All
Movies
Pause All Movies
Play to Next Point
Jump to Previous Point

Keyboard Shortcut
Ctrl+P
Ctrl+Shft+P
Ctrl+RightArrow
Ctrl+LeftArrow

Output Menu
Output Menu
Output Settings
Start/Stop
Broadcasting > Start All
Start/Stop Recording >
Start All

Keyboard Shortcut
Ctrl+Y
Ctrl+B
Ctrl+K
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Layout Menu
Layout Menu
Go to Layer > Main
Layer 1
Go to Layer > Main
Layer 2
Go to Layer > Main
Layer 3
Go to Layer > Main
Layer 4
Go to Layer > Main
Layer 5

Keyboard Shortcut
Shift+Ctrl+T
Shift+Ctrl+F
Shift+Ctrl+N
Shift+Ctrl+B
Shift+Ctrl+A

Replay Menu
Replay + ISO Menu
Update All Replay
Shots

Keyboard Shortcut
R

Social Menu
Social Menu

Keyboard Shortcut
NO SHORTCUTS

Window Menu
Window Menu
Inspector
Encoder Presets
Audio Mixer
New Layer Window >
Main Layer 1

Keyboard Shortcut
Ctrl+I
Ctrl+Shift+E
Ctrl+U
Ctrl+T

Help Menu
Help Menu
Wirecast Help
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Ctrl+?
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Tutorials

The best way to get started using Wirecast is to quickly work through all its main
features. This tour presents a series of three tutorials, each designed to help you
understand how to create and broadcast presentations using Wirecast.
As you work through these tutorials, you will become familiar with important Wirecast
concepts. The more you know about Wirecast, the better it will serve your broadcasting
objectives.
Because each tutorial builds on the skills and knowledge you learn in the previous
tutorials, it is recommended that you take the tutorials in order. Working through all the
tutorials takes about thirty minutes.
Note: If you run the tutorial before activating a Wirecast license, or with Wirecast in
demonstration mode, Wirecast periodically superimposes a logo watermark over the
video, and a voice-over watermark over the audio.
Note: For licensing information, select File > Preferences > License. Click Purchase. Or,
contact Telestream at: desktopsales@telestream.net.

Topics
■ Tutorial 1: Basic Concepts
■ Tutorial 2: Editing Shots
■ Tutorial 3: Broadcasting
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Tutorial 1: Basic Concepts
The goal of this tutorial is to provide you with a quick experience creating and
streaming a presentation using Wirecast.

Tutorial Prep
To prepare for this tutorial, do the following:
1. Select Help > Create Document for Tutorial.
2. Select Switch > Smooth.
3. Select Switch > AutoLive.
4. De-select Switch > Live/Preview Swap.
5. Select Layout > Show Live Only.
Wirecast displays the Live Broadcast Area, and the Go button with the red AutoLive
LED turned on. You will change all of these options in the tutorial.

The Wirecast Default Layout
To familiarize yourself with the main windows, controls, and menus of Wirecast, see The
Default Layout.

What Is a Shot?
Wirecast uses the concept of a “shot” to construct presentations. A shot contains one or
more media sources or files, along with settings for the sources and files. A shot
contains at least one media file, such as a photo or a video clip. However, a shot can
contain a number of sources and files, such as a live camera, a title, and background
music. A shot can even include a whole playlist of clips.
You can assemble most of the files and sources for your broadcast, in shots, before you
start broadcasting. Also, you can edit a shot and change its settings (See Tutorial 2:
Editing Shots).

Switching Between Shots
Individual shots are displayed in the Layers. The Transition Controls are located just
below the Live Broadcast Area where the two default transitions are shown: Cut and
Smooth.
Replacing a shot in the Live Broadcast Area with a shot in the Preview Area is called
“taking a shot live.”
See Layers and Transition Controls.
1. Click the Ripples shot in the third layer.
The Ripples image fades in on the Live Broadcast Area. A “fade action” occurred
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when you clicked on Ripples. This is because the Smooth fade is the default
transition.
2. Click the shot labeled Clear Layer.
The Ripples image fades to black. The Clear Layer shot enables you to display black
video.
Note: Wirecast does not support a true dissolve transition. The Smooth fade transition
is the transition closest to a dissolve.
If you switch from shot “A” to a shot that contains shot “A,” the Smooth fade
interpolates the difference between the two shots and animates the changes. This
makes a shot element larger or smaller, and changes its position as needed.
However, if you switch from shot “A” to an entirely different shot “B,” then the Smooth
transition simply fades between the two shots.
3. To make the cut your default transition, select the Cut control.
4. Click the Ripples shot in the third layer.
The Ripples image cuts in on the Live Broadcast Area.
When you select Cut as the default transition, switching from shot “A” to shot “B” simply
cuts from the first shot to the second. When Smooth is selected, transitions fade in and
out, as you just saw.

Transitions
You can assign a maximum of three transitions to the Transition Controls, but more than
three transitions are available to you. To select a different transition, click the small
arrow on the right side of any of the transition buttons. When the list of transitions
appears, select a transition to assign to that button. You can also click the transition
button itself and drag the mouse downward to display the menu of transitions.
1. To change the left transition button from Cut to Bands, click the Cut button and
drag downward until the menu appears. Select Bands from the menu. Bands should
now be displayed as the left button.
2. Now click back and forth between the River and Ripples shots using Bands.
You can use these keyboard shortcuts for the two default transition buttons: Ctrl+1 and
Ctrl+2.
Note: The Preferences > General tab enables you to set the number of transition
buttons that Wirecast displays.
See The Default Layout and Transition Controls.

Transition Speed
To determine how fast a transition occurs, do the following:
3. Select Switch >Transition Speed.
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4. Choose a transition speed, from Slowest to Fastest.

Layers
Note: Before you start this section, select Smooth as your default transition.
You can display several shots in the Preview Area and Live Broadcast Area at the same
time by placing them in layers, one above another.
To broadcast a layered shot, do the following:
1. Select the Logo shot in layer 2.
2. Select the River shot in layer 3.
The Live Broadcast Area displays a layered shot containing both images.
See Layers.

Auto Live
So far in this Tutorial, Wirecast has been running in AutoLive mode. Wirecast sends any
shot you select in a layer automatically to the Live Broadcast Area. This mode is very
useful for those users who want to set up all of their shots at once and then single-click
them as they run their presentation.
The disadvantage of this single-click method is that you can’t preview the shot before
taking it live.

Turn AutoLive Off
A red LED, next to the Go button is lit when you are in AutoLive mode.
See Transition Controls.
1. For this tutorial, turn off AutoLive. Select Switch > AutoLive.
Wirecast de-selects AutoLive. A dialog box informs you that AutoLive is off.
2. Click OK in the dialog box to continue.
3. Click the Ripples shot.
Notice that Wirecast doesn’t send Ripples to the Live Broadcast Area. That is because
AutoLive is turned off.
4. Now, click the Ripples shot, and then click the Go button.
Wirecast sends the Ripples shot to the Live Broadcast Area.
Note: When AutoLive is off, you must click the Go button (or press Ctrl+G) to display
the selected shot in the Live Broadcast Area.
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Multiple Changes
A benefit of having AutoLive off is that you can make several changes to your shot first,
and then have all changes sent to the Live Broadcast Area at the same time.
Do the following:
5. Verify that AutoLive is off.
6. Click Sample Title in Layer 1.
7. Click Clear Layer Shot in Layer 2, and then click the Ripples Shot in Layer 3.
8. Click the Go button (or Ctrl+G)
Wirecast takes the Ripples and Sample Title shots live at the same time.

Preview
One problem you may have noticed while running this tutorial is that you can’t see the
changes you are making before broadcasting them. To solve this problem, Wirecast
enables you to see a preview of what you broadcast.
1. Select Layout > Show Live and Preview.
Wirecast displays the Preview Area to the left of the Live Broadcast Area. The Preview
Area uses a green LED to identify it. The Live Broadcast Area uses a red LED to
identify it. These two colors (green and red) are also used to identify which shots
are associated with the Preview or Live areas.
2. Click the River shot on Layer 3.
Wirecast displays the River shot in the Preview Area. When shots are selected they
display a green or red LED to indicate selection for Preview Area or Live Broadcast
Area.
3. To send the River shot to the Live Broadcast Area, click the Go button.
4. To remove the title from the River shot in the Preview Area, click the Clear Layer shot
in Layer 1.
5. Turn on the Live/Preview Swap option by selecting Switch > Live/Preview Swap
(check mark displayed). Notice that the Go button displays a double-arrow,
indicating that the Live/Preview Swap option is on.
Double-arrow

6. Select the Ripples shot and click the Go button to send the Ripples shot to the Live
Broadcast Area.
Notice that the Ripples and River shots have swapped areas. Also, the shot LEDs
have changed color. The green shot LEDs indicate all shots included in the Preview
Area and the red LEDs indicate the shots included in the Live Broadcast Area. You
can view the shot that is live as you prepare your next shot in the Preview Area.
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Ripples and River shots swapped

Green LEDs show Preview Area shots
Red LEDs show Live Broadcast Area

Tutorial 2: Editing Shots
The first tutorial explained various ways in which you can use existing shots. However,
you can also create and edit shots during a broadcast. This tutorial demonstrates how
to edit your shots.
1. To edit a shot, double-click its icon in a layer.
Wirecast opens the Shot Editor panel. The Shot Editor has six tabs: Shot Layers, Shot
Layer Properties, Audio, Chroma Key Properties, Smooth Transition Properties, and
Additional Source Properties.
See The Shot Editor Window.
2. Practice editing a shot using the various options in the Shot Editor Window tabs.
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Tutorial 3: Broadcasting
This tutorial demonstrates how to setup and broadcast your Wirecast presentations.
You can broadcast to a specific computer (Unicast), multiple viewers (Multicast), or
even record your broadcast to disk.
There are two main components for broadcasting your presentation (or saving it to
disk): encoding and selecting a destination.
You need to decide how you are going to encode your broadcast. Encoding is the type
of compression used (JPEG, MPEG4, etc.). Wirecast comes configured with many
common encoding options. (See The Encoder Presets Window for details.).
A destination for the broadcast must be selected. You can send it to a server for
broadcast or save it to disk.

Streaming
1. To start streaming, click the Stream button.
In the Control/Status bar, the Stream icon blinks until a connection is made. Once you
are connected the Stream icon turns green. If you can’t connect, Wirecast displays an
error message. See Control/Status Bar.
Connection strength is indicated by how many bars are displayed in the Stream icon.
Fewer bars indicates a weaker (slower) connection.
If the connection is ever broken, a no connection icon is displayed in place of the bars.
No connection icon

When the connection recovers, the no connection icon is replaced with green bars.
2. Click Stream again to stop streaming.
3. (Optional) You can also record your broadcast by clicking Record.
While streaming, the streaming status is displayed at the top of the default layout.

Streaming
time

Recording
time

ISO Recording
time

If you are streaming to Facebook, additional statuses are displayed on the right side of
the status bar.

Number of
viewers
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Making Great Broadcasts

There are many ways to make a good live event even better. This appendix focuses on
two main things to remember about video streaming:

• High Quality Audio Input Great-looking video with poor audio is poor video.
• Good Lighting Video without light is radio. Poor lighting can ruin an otherwise

excellent live event. If you use chroma or luma keys, excellent lighting, both of talent and background, is essential.

When video is saved to disk or sent over the network, it needs to be compressed. The
compression process is done by encoders (codecs) which are optimized to work with
clean input data. This means that if the audio or video is muddy to start with, it remains
muddy after compression. Some codecs may even highlight poor input because the
algorithm is built to look for differences.
Your goal is to send the best quality video and audio to the codecs. This means making
sure what you see and hear in the Live Broadcast Area is high quality video and audio.

Topics
■ High Quality Audio
■ Good Lighting
■ Broadcast Settings

High Quality Audio
You can make a great live event even better by paying attention to audio details. Here
are some suggestions:

• Use an External Microphone Most video cameras have an audio input for an

external microphone. Use this, whenever possible, instead of the built-in microphone. Built-in microphones usually are not high quality, and they tend to pick up
hum from the electronics inside the camera. Even an average external microphone
can deliver better sound than most built-in camera mics.

• Use a Microphone Splitter or Mixer If the broadcast has more than one sound
source, use a separate mic for each sound source. Give each speaking subject a
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dedicated mic. Wire the mics to a mic splitter or audio mixer. Wire the output of the
splitter or mixer to the camera audio input. Dedicated mics produce better sound
quality than one omni-directional microphone at a distance.

• Position the Microphone Properly Place any microphone as close to the sound

source as possible, even when using omni-directional microphones, because sound
volume decreases greatly the farther away the microphone is placed. High-volume
sound hitting the microphone results in a stronger signal from the mic.

• Use Lapel Microphones Even inexpensive lapel microphones can make a huge difference because you can place them close to the source of the sound: the speaker’s
mouth.

• Control Environmental Noise If a chair squeaks, use a different chair. If you have a
wood floor and you can hear people shuffling their feet as they talk, put down a
rug. Turn off air conditioners, machines, and buzzing fluorescent lights. Do whatever it takes to keep noise at a minimum. Microphones pick up everything. Before
you start broadcasting, yell, “Quiet on the set!”

Good Lighting
Do not underestimate the power of lighting. Whether shooting outdoors or indoors,
you must control the lighting that hits the lens. For a good picture and a high-quality
video signal, you must provide your lens two things: enough light and light with the
right qualities. Here are a few suggestions to help you obtain reasonably good lighting:

• If you are using only one lighting source, do not shine it directly on your subject.
You should diffuse the light by bouncing it off of a wall or by shining it through
opaque material.

• Avoid deep shadows. Make sure you fill all areas of your subject with light. Some-

times this requires adjusting the light to bounce off a different wall or use two
lights. Placing a light low and another one high is often a good way to light evenly.

• Do not light too evenly. If you evenly light a set, you may actually be worse off than
not lighting the set at all. Take a sample shot and see if it looks natural. Good lighting usually has a little more light coming from above than any other direction. You
should very rarely light just from below a subject.

• Beware of having too much light on your subject. If your subjects are people and

you must use a lot of light, use make-up to compensate for the overly bright lighting. This is not necessarily a bad thing, but you must choose how much effort you
want to go through to make a good live event. If your lighting balance is excellent,
you can avoid using make-up on your subjects. The key in adjusting the lighting is
to look at your subject and make sure they do not look washed out.

• Watch professional events and learn from them. As you watch, notice the lighting
instead of watching the program. Notice how they employ the suggestions listed
above.

Good lighting can make an amateur video look professional and a professional video
look fabulous. The important thing to remember is that one or two properly placed
lights makes a huge difference in the quality of your live event.
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Triangular Lighting
One advanced and very effective approach to good lighting is known as triangular
lighting (or three-point lighting, or the three-light setup). This involves setting up three
lights (sometimes using natural light as one of the light sources), in a configuration that
achieves a good balance. Here are the main elements of triangular lighting:

• Key Light (Main Light) This is the strongest of your lights and does most of the

work. You can use the Sun or a strong lamp as your key light. Place the key light
higher than talent eye-level, higher than the lens, and to the left or right of the lens.
at least 20 degreesoff the line between lens and talent. This creates shadows on the
subject that enhance the sense of three-dimensionality.

• Fill Light This is a soft light. Place the fill light higher than talent eye-level, higher

than the lens, and on the side of the lens opposite the key light. If your key light
comes from the left of your camera, your fill light should come from the right, or
vice versa. The fill light brightens the shadows, making them softer and less severe.

• Back Light (Rim Light) This light is directed from behind and above the subject.

Aim the back light at the top of the subject’s head. The back light is also called a rim
light because it makes a slight rim around the edge of the head of your subject. The
back light separates your subject from the back ground. This enhances the sense of
three-dimensionality and helps create a sharp separation between the subject and
a chromakey background. Since the back light faces the lens, make sure light from
the back light does not spill into the lens, causing lens flares.

Broadcast Settings
Once you have good video and audio coming into Wirecast, make sure the broadcast
settings are configured correctly for your presentation. Though there are many
broadcast parameters to modify, there are three that are the most important:
bandwidth, motion, and encoder settings.

Bandwidth
Bandwidth is the speed of data you can broadcast from your computer to your viewers.
Transmit data no faster than your network upload speed and your viewers’ download
speed.
Estimate your viewers’ download speed by the type of Internet connection they likely
have. Are your viewers all on your corporate high-speed LAN, are they viewing from
home via DSL or cable Internet, or are they on cell phones in remote areas downloading
video over slow cell phone networks? Set your broadcasting bandwidth accordingly.
If you broadcast to a LAN, discuss your plans with your network administrator. Verify
that you will not disrupt the network with your broadcasts. Ask the administrator what
your bandwidth upper limit should be.
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Motion
Once you determine your bandwidth, determine whether your video contains a lot of
motion. An interview typically has little motion. A sports event, however, typically has
lots of motion. Wirecast comes configured with defaults to help ease your
configuration task. Choose a default configuration that meets your motion constraints.

Encoder Settings
It is beyond the scope of this document to describe the delicate balance required in
defining encoder settings. Various streaming networks publish their optimal encoder
settings. The Wirecast settings for the various streaming platforms generally are
optimized for those platforms. (See Encoder Presets for information on changing the
encoder settings.)
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Steinberg VST Plug-In SDK Licensing Agreement
(Version 3.6.6- 17.06.2016)
OBJECT OF THE AGREEMENT
1. 1.The object of this agreement consists of the Steinberg VST PlugIn Software
Development Kit version 3.6.6 respectively any preview version of this Kit,
comprising of documentation, example code, and several PlugIn examples. These
are described hereinafter as the "Licensed Software Developer Kit".
2. 2.In case a preview or beta version of the Licensed Software Developer Kit is
provided, the Licensee is allowed to use the Licensed Software Developer Kit solely
for internal evaluations. Any publishing, distribution or transfer to a third party is
not permitted.
3. 3.Steinberg is the holder of all copyrights, rights of ownership, and other rights
concerning the Licensed Software Developer Kit.
4. 4.The Licensed Software Developer Kit contains information about how to develop
a Product, and how to extend an application so that it can host VST PlugIns, that are
developed under the VST PlugIn Specification, either by Steinberg or any ThirdParties.
Currently the Licensed Software Developer Kit is running on the following computer
platforms: Apple Macintosh Computers under the Mac OS 10.8, 10.9, 10.10, 10.11 (32
and 64bit) Windows 7, Windows 8 and Windows 10 (32 and 64bit)
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GRANTING OF RIGHTS
5. 1.Steinberg hereby grants to the Licensee a non-exclusive, worldwide,
nontransferable license during the term of this agreement to use the Licensed
Software Developer Kit solely:
6. For the development of PlugIns/Application and/or for the development of an
application that can host VST PlugIns (herein VST Product),
7. Publish, sell or otherwise distribute a Product under his own brand name that is
using parts or all of the Licensed Software Developer Kit.
8. 2.In case the Licensee receives a preliminary version of the Licensed Software
Developer Kit, the Licensee is not allowed to publish any Product to the public
using a preliminary Software Developer Kit. The Licensee is only allowed to publish
Products to the public based on a Licensed Software Developer Kit which is not
declared as a preliminary version by Steinberg.
9. 3.The Licensee has no permission to sell, licence, give-away and/or distribute the
Licensed Software Developer Kit or parts of it for the use as software developer kit
in any way, for example, integrated in any framework application, on any medium,
including the Internet, to any other person, including sub-licensors of the Licensee
or companies where the Licensee has any involvement. This includes re-working
this specification, or reverse-engineering any products based upon this
specification.
10. 4.In case the Licensed Software Developer Kit is modified, it shall not be published,
sold or distributed without agreement of Steinberg. Furthermore, the naming of
the Licensed Software Developer Kit shall not include "VST3.6.6 SDK" or any
combination containing the VST brand without permission of Steinberg.
11. 5.In case the Licensed Software Developer Kit is extended by additional code, it
shall not be used in any other description than "(Licensees company name)
extension to the Steinberg VST3.6.6 SDK."
12. 6.The Licensee recognizes the value of the goodwill associated with the mark VST
Plug-In Technology and acknowledges that such goodwill exclusively belongs to
the benefit of Steinberg and belongs to Steinberg. The Licensee warrants that it will
not use the mark VST PlugIn Technology on promotional merchandise, with the
exception of demo versions of any of his product making use of this Licensed
Software Developer Kit. The Licensee warrants that it will not use the mark VST
PlugIn Technology on, or in connection with products obscene, pornographic,
excessively violent or otherwise in poor taste.
13. 7.If the Licensee is developing a Product, that is using parts or all of the Licensed
Software Developer Kit, and this product is not published under his own name but
will be published under the name of a third party, this third party has to agree to be
bound by Sections 2.1 to 2.3 and 3 of this VST PlugIns SDK Licensing Agreement.
The third party has to completely comply with these provisions. If the third party is
not in accordance with these conditions, the third party is not allowed to distribute
this product which is using parts or all of the Licensed Software Developer Kit.
14. 8.If the Licensee is planning to publish a Product under his own name or under the
name of a third party, that is using parts or all of the Licensed Software Developer
Kit, the Licensee is under the obligation to inform Steinberg about it by sending the
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signed 'Steinberg VST Plug-In SDK Licensing Agreement' to Steinberg, either by
mail, or by fax.
COPYRIGHTS NOTICE, USE OF TRADEMARKS
If the Licensee is publishing a Product under his own name that is using parts or all of
the Licensed Software Developer Kit, the Licensee shall be under an obligation to refer
to Steinberg's copyrights and trademarks in the following way:
a) In case that the Licensee is publishing a 'boxed product', the Licensee shall display in
a visible manner the VST Logo and Steinberg's copyright notice on the packages.
Steinberg's copyrights notice: "VST is a trademark and software of Steinberg Media
Technologies GmbH"
b) In case that the Product is published without a physical packages (e.g. download),
The Licensee shall display the VST Logo and Steinberg's copyrights notice on the
Licensee's website in the context of the Product.
c) The Licensee shall include the VST Logo and Steinberg's copyrights notice in all
electronic documentation, regardless of the media used, such as PDF manuals, website
etc. and all printed and all electronic advertising materials. The VST Logo artwork and
usage guidelines are part of the "Licensed Software Developer Kit" and are supplied by
Steinberg in digital format.
d) In the 'about box' or an alternative place (e.g. help menu, startup screen) of the
Product in one of the following formats: VST PlugIn Technology by Steinberg Media
Technologies, VST PlugIn Interface Technology by Steinberg Media Technologies
GmbH.
FEES AND ROYALTIES
This license is non-royalty bearing and the Licensee shall not obligated to pay to
Steinberg any fees or royalties with respect to the VST PlugIn Interface technology.
LIMITATION OF LIABILITY
1. Subject to the provisions in the following sub-sections, Steinberg shall only be
liable, irrespective of the legal grounds, for damages caused by the intentional or
grossly negligent conduct of Steinberg, its legal representatives, managerial
employees or any other vicarious agents. In the case of damage caused by the
grossly negligent conduct of any other vicarious agents, the liability shall be limited
to those damages which must typically be expected within the scope of an
agreement such as the present one. Any further liability other than as permitted
under this agreement shall be excluded.
2. Any liability of Steinberg for damages arising form violation of life, body and health,
from the assumption of a guarantee or from a procurement risk as well as
Steinberg's liability for damages pursuant to the Product Liability Act
(Produkthaftungsgesetz) shall remain unaffected.
3. To the extent the liability of Steinberg is excluded pursuant to the subsections of
these provisions, this shall also apply to the benefit of Steinberg's employees in the
event the Licensee files any claims directly against them.
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MIT
Copyright (c) 2018 Telestream, LLC
Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the "Software"), to deal in the Software
without restriction, including without limitation the rights to use, copy, modify, merge,
publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

TurboJPEG
This software is based in part on the work of the Independent JPEG Group.
Copyright (C)2009-2019 D. R. Commander. All Rights Reserved.
Copyright (C)2015 Viktor Szathmáry. All Rights Reserved.
Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

• Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and/or other
materials provided with the distribution.

• Neither the name of the libjpeg-turbo Project nor the names of its contributors

may be used to endorse or promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
IS", AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
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OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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