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Copyrights and Trademark Notices
Copyright © 2012 Telestream, Inc. All rights reserved. No part of this publication may be 
reproduced, transmitted, transcribed, altered, or translated into any languages without 
the written permission of Telestream. Information and specifications in this document 
are subject to change without notice and do not represent a commitment on the part 
of Telestream.

Telestream, Vantage, Flip4Mac, FlipFactory, Episode, ScreenFlow, Wirecast, 
GraphicsFactory, MetaFlip, MotionResolve, and Split-and-Stitch are registered 
trademarks and Pipeline, Launch, and Videocue are trademarks of Telestream, Inc. All 
other trademarks are the property of their respective owners.

QuickTime, Mac OS X, and Safari are trademarks of Apple, Inc. Bonjour, the Bonjour 
logo, and the Bonjour symbol are trademarks of Apple, Inc.

MainConcept is a registered trademark of MainConcept LLC and MainConcept AG. 
Copyright 2004 MainConcept Multimedia Technologies.

Microsoft, Windows NT|2000|XP|XP Professional|Server 2003|Server 2008, Windows 7, 
Media Player, Media Encoder, .Net, Internet Explorer, SQL Server 2005, and Windows 
Media Technologies are trademarks of Microsoft Corporation.

This product is manufactured by Telestream under license from Avid to pending patent 
applications.

This product is manufactured by Telestream under license from VoiceAge Corporation

Dolby and the double-D symbol are registered trademarks of Dolby Laboratories.

SharpSSH2 Copyright (c) 2008, Ryan Faircloth. All rights reserved. Redistribution and 
use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met:

Redistributions of source code must retain the above copyright notice, this list of 
conditions and the following disclaimer.

Redistributions in binary form must reproduce the above copyright notice, this list of 
conditions and the following disclaimer in the documentation and/or other materials 
provided with the distribution.

Neither the name of Diversified Sales and Service, Inc. nor the names of its contributors 
may be used to endorse or promote products derived from this software without 
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS 
IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; 
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
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WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Other brands, product names, and company names are trademarks of their respective 
holders, and are used for identification purpose only.

MPEG Disclaimers

MPEGLA MPEG2 Patent
ANY USE OF THIS PRODUCT IN ANY MANNER OTHER THAN PERSONAL USE THAT 
COMPLIES WITH THE MPEG-2 STANDARD FOR ENCODING VIDEO INFORMATION FOR 
PACKAGED MEDIA IS EXPRESSLY PROHIBITED WITHOUT A LICENSE UNDER APPLICABLE 
PATENTS IN THE MPEG-2 PATENT PORTFOLIO, WHICH LICENSE IS AVAILABLE FROM 
MPEG LA, LLC, 6312 S. Fiddlers Green circle, Suite 400E, Greenwood Village, Colorado 
80111 U.S.A.

MPEGLA MPEG4 VISUAL
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 VISUAL PATENT PORTFOLIO LICENSE 
FOR THE PERSONAL AND NON-COMMERCIAL USE OF A CONSUMER FOR (i) ENCODING 
VIDEO IN COMPLIANCE WITH THE MPEG-4 VISUAL STANDARD (“MPEG-4 VIDEO”) AND/
OR (ii) DECODING MPEG-4 VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A 
PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO 
PROVIDER LICENSE IS GRANTED OR SHALL BE IMPLIED FOR ANY OTHER USE. 
ADDITIONAL INFORMATION INCLUDING THAT RELATING TO PROMOTIONAL, INTERNAL 
AND COMMERCIAL USES AND LICENSING MAY BE OBTAINED FROM MPEG LA, LLC. SEE 
HTTP://WWW.MPEGLA.COM.
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MPEGLA AVC
THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE 
PERSONAL USE OF A CONSUMER OR OTHER USES IN WHICH IT DOES NOT RECEIVE 
REMUNERATION TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD 
(“AVC VIDEO”) AND/OR (ii) DECODE AVC VIDEO THAT WAS ENCODED BY A CONSUMER 
ENGAGED IN A PERSONAL ACTIVITY AND/OR WAS OBTAINED FROM A VIDEO PROVIDER 
LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR 
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. 
SEE HTTP://WWW.MPEGLA.COM.

MPEG4 SYSTEMS
THIS PRODUCT IS LICENSED UNDER THE MPEG-4 SYSTEMS PATENT PORTFOLIO LICENSE 
FOR ENCODING IN COMPLIANCE WITH THE MPEG-4 SYSTEMS STANDARD, EXCEPT THAT 
AN ADDITIONAL LICENSE AND PAYMENT OF ROYALTIES ARE NECESSARY FOR 
ENCODING IN CONNECTION WITH (i) DATA STORED OR REPLICATED IN PHYSICAL MEDIA 
WHICH IS PAID FOR ON A TITLE BY TITLE BASIS AND/OR (ii) DATA WHICH IS PAID FOR ON 
A TITLE BY TITLE BASIS AND IS TRANSMITTED TO AN END USER FOR PERMANENT 
STORAGE AND/OR USE. SUCH ADDITIONAL LICENSE MAY BE OBTAINED FROM MPEG LA, 
LLC. SEE HTTP://WWW.MPEGLA.COM FOR ADDITIONAL DETAILS.

Limited Warranty and Disclaimers
Telestream, Inc. (the Company) warrants to the original registered end user that the 
product will perform as stated below for a period of one (1) year from the date of 
shipment from factory:

Hardware and Media—The Product hardware components, if any, including equipment 
supplied but not manufactured by the Company but NOT including any third party 
equipment that has been substituted by the Distributor for such equipment (the 
“Hardware”), will be free from defects in materials and workmanship under normal 
operating conditions and use.

Software—If software is supplied as part of the product, the software will operate in 
substantial conformance with specifications set forth in its product user's guide. The 
Company does not warrant that the software will operate uninterrupted or error-free, 
will meet your requirements, or that software errors will be corrected.

Warranty Remedies
Your sole remedies under this limited warranty are as follows:

Hardware and Media—The Company will either repair or replace (at its option) any 
defective Hardware component or part, or Software Media, with new or like new 
Hardware components or Software Media. Components may not be necessarily the 
same, but will be of equivalent operation and quality. 
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Software—If software is supplied as part of the product and it fails to substantially 
confirm to its specifications as stated in the product user's guide, the Company shall, at 
its own expense, use its best efforts to correct (with due allowance made for the nature 
and complexity of the problem) such defect, error or nonconformity. 

Software Updates
If software is supplied as part of the product, the Company will supply the registered 
purchaser/licensee with maintenance releases of the Company’s proprietary Software 
Version Release in manufacture at the time of license for a period of one year from the 
date of license or until such time as the Company issues a new Version Release of the 
Software, whichever first occurs. To clarify the difference between a Software Version 
Release and a maintenance release, a maintenance release generally corrects minor 
operational deficiencies (previously non-implemented features and software errors) 
contained in the Software, whereas a Software Version Release adds new features and 
functionality. The Company shall have no obligation to supply you with any new 
Software Version Release of Telestream software or third party software during the 
warranty period, other than maintenance releases.

Restrictions and Conditions of Limited Warranty
This Limited Warranty will be void and of no force and effect if (i) Product Hardware or 
Software Media, or any part thereof, is damaged due to abuse, misuse, alteration, 
neglect, or shipping, or as a result of service or modification by a party other than the 
Company, or (ii) Software is modified without the written consent of the Company.

Limitations of Warranties
THE EXPRESS WARRANTIES SET FORTH IN THIS AGREEMENT ARE IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, ANY 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. No oral 
or written information or advice given by the Company, its distributors, dealers or 
agents, shall increase the scope of this Limited Warranty or create any new warranties.

Geographical Limitation of Warranty—This limited warranty is valid only within the 
country in which the Product is purchased/licensed.

Limitations on Remedies—YOUR EXCLUSIVE REMEDIES, AND THE ENTIRE LIABILITY OF 
TELESTREAM, INC. WITH RESPECT TO THE PRODUCT, SHALL BE AS STATED IN THIS 
LIMITED WARRANTY. Your sole and exclusive remedy for any and all breaches of any 
Limited Warranty by the Company shall be the recovery of reasonable damages which, 
in the aggregate, shall not exceed the total amount of the combined license fee and 
purchase price paid by you for the Product. 
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Damages
TELESTREAM, INC. SHALL NOT BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY 
LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF YOUR USE OR INABILITY TO USE THE PRODUCT, OR THE BREACH OF 
ANY EXPRESS OR IMPLIED WARRANTY, EVEN IF THE COMPANY HAS BEEN ADVISED OF 
THE POSSIBILITY OF THOSE DAMAGES, OR ANY REMEDY PROVIDED FAILS OF ITS 
ESSENTIAL PURPOSE.

Further information regarding this limited warranty may be obtained by writing:
Telestream, Inc.
848 Gold Flat Road
Nevada City, CA 95959

You can call Telestream, Inc. via telephone at (530) 470-1300.

Part number: 93500
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Preface
To obtain product information, technical support, or provide comments on this guide, 
contact us using our Web site, email, or phone number as listed in Table 1.

Table 1. Telestream Contact Information

Resource Contact Information

Vantage Technical 
Support

Web Site: http://www.telestream.net/telestream-
support/vantage/support.htm

Support Email. support@telestream.net

Terms and times of support services vary, per the terms of 
your current service contract with Telestream.

Vantage Information, 
Assistance, FAQs, 
Forums, & Upgrades

Web Site: http://www.telestream.net/telestream-
support/vantage/support.htm

Support Email. support@telestream.net

Telestream, Inc. Web Site: www.telestream.net

Sales and Marketing Email: info@telestream.net

Telestream, Inc. 
848 Gold Flat Road, Suite 1
Nevada City, CA USA 95959

International 
Distributor Support

Web Site: www.telestream.net

See the Telestream Web site for your regional authorized 
Telestream distributor.

Telestream Technical 
Writers

Email: techwriter@telestream.net

If you have comments or suggestions about improving 
this document, or other Telestream documents—or if 
you've discovered an error or omission, please email us.

http://www.telestream.net/telestream-support/vantage/support.htm
http://www.telestream.net/telestream-support/vantage/support.htm
http://www.telestream.net/telestream-support/vantage/support.htm
http://www.telestream.net/telestream-support/vantage/support.htm
mailto:support@telestream.net
http://www.telestream.net
mailto:info@telestream.net
http://www.telestream.net
mailto:techwriter@telestream.net
mailto:support@telestream.net
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Workflow Designer
Tours
These tours are designed to help you understand how to create, configure, and manage 
workflows in Workflow Designer. You’ll also learn how to submit media to workflows for 
processing.

As you take these tours, you’ll also become familiar with important Vantage concepts 
and how you can use them to design workflows to meet your processing requirements. 
The more you know about Vantage, the better it will serve your automated media 
transcoding requirements.

Because each tour builds on the skills and knowledge you learn in the previous tours, 
we recommend that you take the tours in succession.

As you gain hands-on experience creating workflows and processing media in 
Vantage—which leads to a working knowledge of Vantage and its components and 
architecture—you’ll gain proficiency in using Vantage to solve your organization’s 
media processing problems.

Note: Sample video files are provided for use in these workflows: <Install_Drive>:/
Program Files/Telestream/Vantage/Store. Files: FlipDemo.wmv (48 seconds), 
FlipDemo_short.wmv (15 seconds), and FlipDemo.mss.

Tours
 Tour 1: Creating and Configuring Workflows

 Tour 2: Using Your Workflow to Transcode Media

 Tour 3: Using the Workflow Design Space

 Tour 4: Transcoding Files Using Settings You Want

 Tour 5: Using Binders, Nicknames, & Attachments

 Tour 6: Using Variables in Workflows

 Tour 7: Decision Making in Workflows

 Tour 8: Dynamic Parameters
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Note: You can take tours 1 through 4 without a license. For tours 5 and beyond, you’ll 
need a trial license to execute the workflows. Also, without a license, you can only 
input WMV files and transcode them. For a trial license, contact sales@telestream.net.

Tour 1: Creating and Configuring Workflows
This tour is designed to provide your first hands-on experience with Vantage Workflow 
Designer. This tour takes about fifteen to twenty minutes to complete, and introduces 
you to the concept and process of creating a typical Vantage transcoding workflow. In 
the next tour, you’ll submit media to transcode, monitor your job as it executes, and 
play your new media.

A workflow in Vantage is a series of actions arranged to automate a specific media-
related task: transcoding a file from one format to another, for example. Workflows in 
Vantage are organized by category.

Vantage provides several types of actions (the smallest amount of work you can specify 
in Vantage) which you can use to build a specific workflow. For example, a Watch action 
continually polls a hot folder (such as a media server directory or a local or network 
folder) for incoming media to process—which Vantage performs by automatically 
submitting a job to the workflow you've created. 

The task specified by each type of action (Flip, Copy, etc.) is actually executed by a 
Vantage service—for example, the Watch action is executed by the Vantage Monitor 
service.

In this tour, you’ll log on to your Vantage domain using Workflow Designer, and create 
and configure a workflow to encode QuickTime files.

Start Vantage Workflow Designer and Log In
You can run Workflow Designer directly on the Vantage server or on another Windows 
workstation on the LAN.

Note: If Team Management | Enterprise | Master Control is enabled, Vantage user 
accounts should be established before you log in and use Vantage. Vantage user 
accounts are controlled in the Vantage Management Console, typically by the Vantage 
administrator. If you don’t have a Vantage user account, obtain one from the 
administrator or create one yourself using the Vantage Management Console. For 
assistance, run the console and select Help > Online Help. 
The default Vantage user is Administrator, with no password assigned.

1. Double-click the Vantage Workflow Designer shortcut on your desktop or select 
start > Programs > Telestream > Vantage > Vantage Workflow Designer.

2. First Time—Select a domain. If this is the first time you’ve started Workflow Designer 
on this computer, you have to manually select the domain. (A Vantage domain is 
identified by the computer that hosts the Vantage database—you are connecting 
Vantage User’s Guide
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Workflow Designer to the Vantage domain’s database. For example, if your Vantage 
database is on a server named Vantage_01, then you select that name to connect.) 
After connecting the first time, Workflow Designer remembers the last domain you 
used, and connects automatically.

Figure 1. Using the Select Vantage Domain Panel to Connect to a Vantage Domain.

3. Select the domain you want to use, and click OK.

If you are having problems connecting to the domain, see Connecting to an Unlisted 
Domain or Connecting with Custom SQL Server Login Settings, or contact your IT 
department or Vantage administrator for assistance.

If you are accessing a Vantage domain where Team Management is enabled, you 
need to provide your Vantage username to log in to a Vantage domain. 

4. Enter your Vantage username and password in the login dialog to proceed.

Figure 2. Vantage Domain Login Dialog.

The Vantage Domain Login dialog identifies the name of the domain you’re logging 
in to. If Workflow Designer can’t locate the domain or the domain name is not correct, 
contact your Vantage administrator or your IT organization for assistance.

Once you’re logged in, Workflow Designer displays the main window.

Creating a Workflow Category
When Vantage is installed, there are no categories or workflows stored in the domain 
database. So, the first person that logs in to a new domain via Workflow Designer is 
prompted to create a new category in which to store workflows.

This is the list of domains 
running on your network.
Vantage User’s Guide
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Note: Even if categories are present, you may want to make your own so that your 
workflows don’t interfere with the work of others, or so that your tutorial workflows 
are organized in their own category, separate from production workflows.

If you’re prompted to create a new category, click OK. Otherwise, select File > Create 
New Category.

Workflow Designer displays the Create New Category dialog.

Figure 3. Create New Category Dialog.

Note: Enter <Your Name> Tutorial Workflows and click OK. 
For these tours, the category is referenced generically, as Tutorial Workflows.Vantage 
displays help tips as you use it, to help you become familiar with its features. If you 
don’t want Vantage to display them, check Don’t show me this again.

Creating a Workflow
Now, lets create your first workflow to convert files to a small-frame (proxy) QuickTime 
file for preview purposes. 

1. If you’re prompted to create a new workflow, click OK. Otherwise, select File > 
Create New Workflow.

Workflow Designer displays the Create New Workflow dialog.

Figure 4. Create New Workflow Dialog.
Vantage User’s Guide
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2. Select the category you just created, from the list at the top of the dialog.

3. Enter the name Simple Transcode (in your Tutorial Workflows category), and click 
OK. (There’s no need to change the expiration policy settings now.)

Your new workflow is automatically added to the Vantage database and to the list 
in the workflows panel under the category you created earlier.

When you create a workflow, it is automatically deactivated and placed in edit mode, so 
you can begin adding actions.

You don’t need to explicitly save workflows you create or modify. The changes you 
make as you create (or modify) a workflow are saved in the database automatically. 

Adding Actions to Your Workflow
You add actions and connect them together to form a workflow. Every workflow starts 
from an origin action (such as a Watch action watching a hot folder) and any connected 
downstream actions will execute subsequently.

When building a workflow, you may have multiple Watch actions, or other origin 
actions. For this tour, we will only create one.

Note: In the Workflow Design panel, notice that actions are displayed by groups in 
the actions toolbar at the top of the workspace. To sort them, right-click in the toolbar 
and select Sort by Name or Sort by Behavior.

1. Open the Monitor group in the actions toolbar by clicking the arrow in the upper 
left corner of the group to display its Watch and Associate actions.

Figure 5. The Action Toolbar—Monitor Group Actions.

2. Click and drag a Watch action into the workspace to add your first action to the 
workflow. (Notice that it automatically centers itself—Vantage visually optimizes 
workflow actions automatically.) The Watch action polls a hot folder for new media 
files placed in the folder, and starts a job to execute the workflow (each of its 
actions) using that file.
Vantage User’s Guide
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Figure 6. Adding Actions to Your Workflow.

3. Open the Transcode action group and, rather than dragging an unconfigured Flip 
action onto to the workflow, click the Flip action one time to display a 
comprehensive list of pre-set Flip actions.

Figure 7. Selecting Preset Actions.
Vantage User’s Guide
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4. Select Web > QuickTime > QuickTime H.264 with AAC. The (pre-configured) action 
is added to the workflow and is arranged just to the right of the Watch action.

Note: Actions are automatically re-arranged as you make design changes.To suspend 
auto arrange, click the Auto Arrange button at the bottom of the panel (note the 
button highlights yellow) until you’ve connect all of your actions. Then, click it to re-
enable auto arrange again.

Connecting Your Actions Together
To create a chain of actions, you connect them together. There are two ways to connect 
actions:

– Click and drag a connecting line from one connector pin to another

– Click and drag an action and bump into another action.

1. Click and drag a connector line from the yellow connector pin on the right side of 
the Watch action to the yellow connector pin on the left side of the Flip action. 
(Connector pins display in yellow until they’re connected.)

2. Next, open the Transport action group and drag the Copy action so that your cursor 
is directly over the right side pin of the Flip action (a connector bar highlights pale 
blue, as shown below). 

Figure 8. Bumping Actions into Another to Connect Them.

3. When the pale blue bar displays, release the mouse—the Copy action 
automatically connects to the Flip action.

Figure 9. Releasing the Mouse to Complete the Connection.
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4. Now, delete the Copy action, because it is not required for this workflow. Select it 
(by clicking on it) and press Delete—or click the X icon in the upper right corner 
and confirm the Delete dialog.

Note: Recall that Workflow Designer automatically saves your work in the database as 
you add and re-arrange actions. You don’t have to save workflows explicitly.

Configuring the Watch Action
Each action in a workflow performs a specific function—and must be configured to 
perform the task specifically the way you want for a given workflow.

Each action displays a yellow i (for inspector) icon  in the top left corner, the color 
yellow indicates that it hasn’t yet been configured (it displays blue when configured).

Vantage can process a broad array of media types and formats, and access all major file 
systems. In addition to standard file systems including Windows and FTP, Vantage 
intelligently works with several complex media types such as Avid reference movies, 
and P2 cameras.

You’ll configure this watch action to poll for any type of media file placed in a specified 
folder on a Windows server.

1. Click on the  icon of the Watch action to open the inspector.

Figure 10. Watch Action—First Inspector Panel.

2. Select Any Media to poll for any type of new media file and click Next to continue. 
Vantage displays the next panel in the inspector.

Note: Entries in these lists are disabled features that are not licensed.

File formats supported by 
Vantage—those in gray 
are not licensed.
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Figure 11. Watch Action—Second Inspector Panel.

3. Select Windows, and click Next to display the next panel.

Figure 12. Watch Action—Third Inspector Panel.

Note: If your Vantage domain was installed on a single server (an All-In-One domain), 
you can specify a local folder using drive-letter format (for example, 
C:\VantageTourOneIn). 
If your domain is a multi-server array (a distributed Vantage domain) or you are 
running Workflow Designer on another computer, the path must be a share with 
proper permissions (for example, \\MyDomainServer\VantageTourOneIn) and you must 
use the UNC path form (the C drive on your computer is not the same as the C drive on 
the Vantage server where the workflow executes).
For a detailed discussion, see Understanding Path Specifications for Vantage Storage.

4. Open Windows Explorer and create a folder directly on the Vantage domain server 
for this workflow and name it TourOneIn. If you plan to reference it as a share, 
display Properties and enable sharing.

5. Return to Workflow Designer and click Browse to navigate and select the fully-
qualified path in this field. Or, enter the share path manually. 
This is now the hot folder for this workflow.

6. Click Next to continue. Workflow Designer displays the final panel, the file system 
detector panel.

Click Browse to navigate to 
and select your hot folder or 
manually enter the path.
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Figure 13. Watch Action Inspector—File System Detector Panel.

7. Take a moment to review these watch action settings. (You can place your mouse 
cursor over the controls to display tooltips which describe each setting.)

Note: You must select a nickname for every file in a workflow. When you create, 
operate on, move, copy, or delete a file —you provide a nickname—so that 
downstream actions can operate on the correct file, just by knowing its nickname. A 
file’s nickname is completely separate from a file’s actual (file) name. For example, in 
this Watch action, each incoming file is assigned and tracked with the nickname 
Original —regardless of its file name (for example, SnowBird_007.wmv). Similarly, you 
will configure the subsequent Flip action to use the same file—by using the same 
nickname Original as its source. In this way, regardless of the actual file names, you can 
indicate exactly which file each action in the workflow should be using.

8. Select a nickname to identify the incoming file—in this case, Original is already 
selected, so you don’t need to change it. 

9. Click the  icon at the top right of the panel to open context-sensitive help (a 
man page) with detailed information about configuring this inspector. Wherever 
you see the context-sensitive help icon, you can click it to display details about the 
part of Workflow Designer you’re focused on. (Click the ? to display the User’s 
Guide—the document you’re reading.)

10. Click Next and then click Finish to save this configuration of the Watch action.

Now that you’ve configured the action, notice that the inspector icon is hidden to let 
you know that it has been configured. Move your mouse back over the action—

You must select or enter a 
nickname in every action 
that acts on or creates a file, 
to uniquely identify and 
track this file instance 
throughout the workflow.
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Vantage displays the inspector icon again—in blue. You can always re-open the action 
inspector to review or change its settings.

Configuring the Flip Action
The Inspector icon on the Flip action is yellow as well—so it also must be configured. 
Why does it need to be configured, given that you selected a pre-configured action? 
Because the output file nickname has not been specified.

1. Click the Inspector icon to open the Flip inspector and note the red asterisk by the 
Output media file nickname dropdown field, indicating that a nickname is required.

Figure 14. Flip Action Inspector.

2. Click the dropdown to view the list of Vantage-supplied nicknames for output files. 
Select Vantage Proxy as the nickname for this proxy file the workflow creates. Now, 
any subsequent actions in the workflow can reference the output from this Flip 
action, simply by referring to the nickname Vantage Proxy. (You could also type in 
your own nicknames, instead of using Vantage-supplied nicknames.)

Note: The nickname has no affect on the output filename (which will be the same as 
the input filename). For example, if you submit test.mpg, this Flip action will create 

Media components 
represent the building 
blocks and hierarchy 
of the media: Video 
stream and its 
essence (H.264), 
Audio stream and its 
essence (AAC), plus 
the container 
(QuickTime). 

You must select or 
enter a nickname in 
every action that acts 
on or creates a file, to 
uniquely identify and 
track this file instance 
throughout the 
workflow.
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test.mov. The MPG file is always referenced by the nickname Original and the MOV file 
is always referenced by the nickname Vantage Proxy in this workflow. 

3. Take a moment to select the video stream, audio stream, and H.264 and AAC codec 
components, as well as the QuickTime Movie container component in turn, and 
review the details panel for each component as it displays its details below the 
video stream building blocks.

4. Click Next and then click Finish to save this configuration of the Flip action, and 
note that the yellow inspector icon doesn’t display anymore.

Conclusion
Congratulations! You’ve just learned how to create a workflow, and learned the basics 
of configuring actions using Workflow Designer’s Inspector. You’ve created a complete 
workflow which can detect new media files placed in a hot folder, and convert them to 
QuickTime format.

In the next tutorial, you’ll learn how to activate workflows, submit jobs, and monitor 
them.
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Tour 2: Using Your Workflow to Transcode Media
This tour takes about 15 minutes, and shows you how to activate your workflow, submit 
media to transcode, monitor your job as it executes, and view your new media.

You can start a job in various ways:

• Place a media file in the hot folder to submit a job automatically

• Assign a hot folder to the Watch action which already has one or more media 
files—and check Process Existing Media in the Watch inspector. This causes Van-
tage to process all existing media in the directory, rather than ignore it.

• Click the Submit Job button (at the bottom of the window) and select the file to 
submit a job manually. Just follow the steps in each panel.

• In this tour, we’ll start a job automatically.

Starting a Job Automatically
To start a job automatically, follow these steps:

1. If you closed Workflow Designer, open it again.

2. Select your Simple Transcode workflow in the Workflow Design panel on the left.

3. Click the Activate button at the bottom of the window. 

Figure 15. Activating a Workflow to Process Jobs.

Click Activate to release the workflow from editing, save 
it, and activate it to start the Watch action.
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Workflow Designer releases it from edit mode and the Vantage Monitor service starts 
the Watch action in your workflow, polling the hot folder you specified, searching for 
new media files to process. A job is started for each new file placed in this folder.

Monitoring your Workflow Status
When you activate a workflow, Workflow Designer displays the Monitor Status panel to 
display the status of all Watch actions.

Figure 16. Monitor Status Panel.

Notice that the Watch action state is listed as In Process, which indicates it has started 
executing, and it is polling for new files. When a new file is discovered, a job is created 
that executes the Simple Transcode workflow. Actions may also be Waiting—the state 
that the transaction enters while Vantage is determining which service should process 
it. A transaction remains in Waiting state until it is accepted by a service for processing.

You can double-click the Watch action entry in the table to display more detailed 
information. You can confirm that it is polling the directory that you specified, and that 
no new files are detected.
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Figure 17. Monitor Status/History Dialog.

When jobs are started, each action is executed by a specific Vantage service, and can be 
optimized for execution if multiple services (for example, multiple Vantage Transcode 
services) are in your domain.

Now lets submit a job by following these steps.

1. Drag a file to your hot folder to submit a job. We suggest that you use one of the 
sample WMV media files provided, which are located at <InstallDrive>:\Program 
Files (x86)\Telestream\Vantage\Store\.

2. Click the Job Status tab to display the status of running jobs.

Figure 18. Job Status Panel—Each Action Displays a Color-coded Status.
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3. Click on the new job entry in the table, and observe each action change color as the 
entire job executes each task specified by the actions in the workflow. 

Workflows display specific border colors to identify each action’s state. Blue indi-
cates the action has completed without errors, and yellow indicates the action 
hasn't started executing yet. For a complete list, see (Using the Jobs Table).

4. Move your mouse over actions in the Monitor Status panel to display the i 
(inspector) icon in the top left corner. 

5. Click the inspector icon to display runtime information about the action in the 
Status/History window.

Figure 19. Status/History Window Displays Action Execution Details.

6. Click on each succeeding status line in the Status/History window to display details 
about the action. Close this window when you’re done.

When all actions are outlined in blue, the job has completed successfully.

Playing Your New File
Now that the job has completed, Vantage has created a newly-encoded QuickTime file.

Note: You didn’t configure the Flip action to tell it where to save new files. So, where 
are the new files saved? The short answer: unless otherwise specified, new files are 
written to a local store—a pre-defined Vantage directory created for storing files.

1. In the Job Status tab, make sure your job entry is selected in the Jobs table at the 
bottom.

2. Click on the Binders  icon to display the binder for this job. 
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Figure 20. Binder Window Displays Assets—Media, Metadata, and Attachments.

3. A binder keeps track of the location of media files associated with a job, plus 
metadata labels and other attachments (files).

4.  Right-click the output file which your workflow transcoded into QuickTime to open 
the containing Windows folder, then double-click it to play it!

Deactivating a Workflow
In an upcoming tour, you’ll use a copy of this same workflow. You should deactivate this 
workflow so that you can use the same hot folder in the next workflow, without the 
Simple Transcode workflow ingesting new media you add to the hot folder. 

Select the Simple Transcode workflow in the workflows panel, and click Deactivate at 
the bottom of the window.
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Figure 21. Deactivating a Workflow Stops its Watch Action.

If you want to edit the workflow again, select File > Edit Workflow or click Edit at the 
bottom of the window. When you’re done editing a workflow, you should click Release 
so that it can be edited or executed by others in the organization.

Conclusion
Congratulations! You’ve just learned how to automatically submit media to a workflow, 
monitor its execution, and view the transcoded media file.

In the next tour, you will explore how to use Workflow Designer’s design space 
effectively.

Tour 3: Using the Workflow Design Space
Lets take a moment to learn some techniques for using the workflow design space, 
before we continue to make changes. This tour takes about 5 minutes.

Some workflows—like Simple Transcode—have only a few actions in them; others may 
have dozens of actions. Sometimes you’re working on the big picture of a workflow—
laying out actions and connecting them together. Other times, you’re working on 
action details—configuring the details of a transcode task, for example. 

In each case, you may want to zoom in or out, or scroll around—or center—the work 
area, to help you focus directly on the work you’re performing at the moment.
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Zooming In and Out on a Workflow
1. If you closed Workflow Designer, open it again, and select Simple Transcoding 

workflow from your category in the Workflows panel on the left.

2. With your Simple Transcode workflow selected and displayed in your Workflow 
Design panel, click Edit at the bottom of the window.

3. Use the zoom slider bar at the bottom left corner to zoom in and out to suit your 
viewing and editing needs.

Figure 22. Zooming In and Out to Display Workflow Details.

There are three ways to zoom in and out on a workflow:

• Drag the zoom slider bar at the bottom left of the workflow

• Repeatedly press Control-+/- (the plus and minus keys)

• Use the scroll wheel on your mouse while pressing the control key.

Moving the Workflow Around in the Design Space
A workflow with many actions may be larger than you can view effectively in your 
workspace, when viewed at the zoom level you’re currently using. 

1. Move the workflow around in the workspace—click anywhere on the workflow 
canvas itself (don’t click on an action). The cursor becomes a compass—now, you 
can drag the workflow in the appropriate direction.

Centering the Workflow
1. Center the workflow in your workspace—right-click in the workspace and select 

Recenter Workflow from the context menu. Alternatively, you can press Control-R 
on the keyboard.

Before you continue, take a few moments to practice zooming, moving, and centering 
the workflow—you’ll use these features frequently, especially as you create larger and 
more complex workflows. Becoming familiar with them now will make it easier to focus 
on the design process.

Use the zoom slider bar to zoom 
your workflow in and out.
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Conclusion
Congratulations! You’ve just learned how to navigate the Workflow Design canvas. In 
the next tour, you will learn how to set up transcoding sessions to use the settings that 
you want.
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Tour 4: Transcoding Files Using Settings You Want
This hands-on tour takes about 20 minutes. This tour is designed to add to your 
workflow management and creation skills, and your first in-depth look at how 
effectively Vantage deals with the complexities of media transcoding. 

Duplicating Your Workflow
1. If you quit Workflow Designer after the last tour, start it again. In the Workflows 

panel (left), open (click) the Vantage Tours category. 

2. Select the Simple Transcode workflow by clicking on it.

Figure 23. Selecting a Workflow.

3. Select File > Duplicate Workflow (or right-click and select Duplicate Workflow). 
Vantage displays the Duplicate Workflow dialog.

Figure 24. Duplicating a Workflow.

4. Enter the name of the new workflow: Complex Transcode. Click OK to save the 
workflow with the new name and dismiss the dialog.

Vantage automatically selects the new workflow, places it in edit mode and displays it 
in the Workflow Design panel.

Enter the name of the new 
workflow you want to create.
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Adding a Branch to the Workflow
Now, let’s add a second, pre-configured Flip action to your new workflow. Vantage 
provides many pre-configured actions for most types of actions, to make it easier to 
build custom workflows.

Let’s add the second Flip action in a manner that enables Vantage to encode two 
separate output files simultaneously, from a single workflow—by creating a branch, 
with parallel actions. Each of these actions are executed independently of each other, 
as soon as the resources are available, making this workflow more time-efficient.

Creating branches for multiple, parallel encoding is an important part of Vantage 
scalability and high-volume transcoding.

1. Open the transcode action group on the action toolbar.

Figure 25. Selecting a Pre-configured Action to Add.

2. Click on the Flip action and select Mobile > 3GPP 300KB H.264 with AAC preset 
from the dropdown menu to add it to the workflow.

3. Connect the new Flip action to the Watch action—click and drag a connector line 
from the out connect pin on the right side of the Watch action to the in connect pin 
(left side) to connect the new Flip action—creating a new branch in the workflow.

When a workflow has multiple branches, actions in those branches can execute 
simultaneously. In this case, once a file has been discovered and a job has been cre-
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ated (or a job has been manually submitted), both encodes will execute at approxi-
mately the same time, resulting in faster throughput.

4. Open the inspector and specify an output file nickname to identify the new file 
you’re encoding—this time you need to type a custom name: enter Mobile 3GPP. 

5. Click Save to update the workflow and close the inspector.

Adding and Configuring Move Actions
As this workflow is currently designed, newly-encoded media is saved in a local 
Vantage store, because you haven’t explicitly specified that the workflow should place 
the media in a folder. Lets add a Move action to each branch, so that the workflow saves 
the new media in a specific, user-accessible folder.

Move actions are file system actions. They utilize a special feature called the Vantage 
folder address book, which enables you to create a fully-qualified path (server and 
directory) with a unique name, making it easier to specify destination paths for files.

For a detailed discussion of using UNC paths, see Understanding Path Specifications for 
Vantage Storage.

1. Open the transport action group on the action toolbar. Drag a Move action onto 
the QuickTime branch, and another onto the 3GPP branch, connecting each to the 
Flip action, so that each Move executes after the Flip action.

2. Open the QuickTime branch’s Move action inspector.

Figure 26. Move Action Inspector (Prior to Configuration).

3. First, select the Vantage Proxy file by nickname as the file to move.

4. Click on the Browse button to the right of the Destination field. Vantage displays 
the Vantage Folder Address Book.
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Figure 27. Vantage Folder Address Book.

Vantage folders are similar to addresses, which you create (and name) to identify 
specific paths you use frequently. Vantage folders simplify directory referencing by 
allowing you to specify a fully-qualified path by a simple name. They also allow you 
to update a path or credentials centrally, and automatically update all actions using 
that Vantage folder.

For example, you might have a folder on a given server for HD MPEG2 content: 
\\Voyager\SunupCampaign\Darwin\WaitingApproval\HDMPEG2. You can create a 
Vantage folder in the address book for this path, and name it SunupHDWaitingAp-
proval.   If you need to change the path or any password associated with the 
address later, you can simply change it in the address book and all actions will auto-
matically be updated.

5. Create a new Vantage folder—click the Add Folder toolbar icon (the new folder 
icon at far left):

Figure 28. Vantage Folder Address Book—Add New Folder Dialog.

6. Enter the folder in the Name field: VantageOut.

7. Click Modify to specify the directory that this Vantage folder address points to.

8. Vantage folders can be defined for any supported file system. For this tour, choose 
Windows File System and click Next.
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9. Click Browse to select a directory of your choice (for example, in Windows Explorer 
make a folder named C:\VantageOut) for the output media file to be copied, and 
click OK. (Don’t use letter drive formats on a distributed domain or distributed 
clients—they won’t work.)

10. Click Finish to close the Folder Location Editor dialog. (You may have to click OK on 
the local folder warning dialog.)

11. Click OK to add this new Vantage folder to the domain and close the Add New 
Folder dialog.

12. Now, click Select to specify the folder you just created, as the destination for the 
Move action.

Figure 29. Move Action Inspector—After Configuration.

13. Finally, click Save to save these settings and close the inspector.

14. Repeat these steps for the 3GPP action, selecting Mobile 3GPP nickname of the file 
you’re moving, and select the same destination.

When you’re done, your workflow should look like this:

Figure 30. Completed Complex Transcode Workflow.
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Activating the Workflow and Submitting a Job
1. Now, activate this workflow.

2. Automatically submit a media file to this workflow, using one of the sample media 
files in <InstallDrive>:\Program Files\Telestream\Vantage\Store\. If you don’t 
remember how to submit a job by dropping the file in a hot folder, refer to Tour 2: 
Using Your Workflow to Transcode Media.

As the job executes, notice in the Job Status window the simultaneous execution of 
both Flip actions, resulting in two new media files.

Changing the QuickTime Flip Action
Now, let’s look at the original QuickTime Flip action that you added in Tour 2 in more 
detail, and learn how to change these settings.

1. Click Edit to deactivate the workflow and enter editing mode.

2. Display the inspector of the QuickTime Flip action.

Figure 31. Sample Flip action Inspector.

3. Click the Encoder dropdown menu to display the list of codecs you can use in the 
Flip action.

4. Click on the Video Stream to display the Processor dropdown in the details panel 
below, where you select which video processor to use: Legacy 8-bit RGB, 4:4:4, 
Multi-core 16-bit YCbCr 4:4:4:4, or Lightspeed Accelerated 16-bit YCbCr 4:4:4:4. The 
Lightspeed video processor only operates on a Lightspeed Vantage server.

Encoder menu 
displays all 
encoders in the 
domain.

Video button & 
codec menu.

Audio button & 
codec menu.

Container button 
and menu.

Video and Audio 
stream buttons.

Video Processor 
selector.
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5. To the right of the video stream, click the Video Codec dropdown menu to display 
the video codecs that are available.

6. To the right of the audio stream, click the Audio Codec dropdown menu to display 
the audio codecs that are available.

7. At the far right of the video and audio streams, click the Container dropdown menu 
to display the containers that are available (notice that the QuickTime encoder only 
provides a QuickTime container).

Note: As you click on the video codec, audio codec, and container buttons to select 
them, configuration details display in the configuration panel at the bottom of the 
window. For example, the Video Codec configuration panel enables you to set frame 
width, height, and bitrate for the video in the QuickTime file.

When you select a stream (by clicking the audio or video stream buttons, far left), 
you can also add processing filters.

8. Select the video stream button in the toolbar and then click on the Video Filter 
dropdown menu to display a list of video filters.

Figure 32. Adding a Filter to a Flip Action Using the Inspector.

9. Select the Contrast filter. Workflow Designer enables it in the video stream.
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Figure 33. Adding a Filter to the Video Stream.

These filters are applied during a transcode, and provide you a great deal of control 
over how the transcode functions.

10. Click on the Video Codec at the far right to display the codec settings at the bottom 
of the window:

Figure 34. Selecting the Video Encoder to View and Configure Settings.

11. Open Frame Size/Frame Rate and change the frame size to 640x360.

12. Finally, click the Encoder dropdown menu at the top to display the encoders that 
you can select. When configuring a given encoder, you can select it and configure it 
from scratch, or you can select and use a pre-existing template for this encoder 
(which you did earlier when you added the 3GPP Flip action).

13. Click Cancel to close the inspector without making any changes.

This is the video 
codec in the 
video stream.
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Note: By default, Flip actions name the files they create using the same root name as 
the original media file’s name, with an appropriate extension, based on the encoder. 
For example, a new QuickTime movie from FlipDemo.MSS is named FlipDemo.mov.

Conclusion
In this tour, you’ve learned how to duplicate an existing workflow, how Vantage 
performs multiple simultaneous encodes, and how to create and use Vantage folder 
addresses. You’ve also been introduced to the basics of configuring Flip actions to 
perform encoding tasks the way you want them to.
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Tour 5: Using Binders, Nicknames, & Attachments
This hands-on tour takes about 30 minutes and introduces you to the concept of 
binders, nicknames, and attachments in Vantage and how they enable you to easily 
track and manage multiple files during a workflow, simplifying workflow design, and 
organize all of the assets for a given version of media in a centrally-accessible manner.

A binder is a collection of media files, attachment files, metadata tracks, and metadata 
labels. Binders are not an actual physical location; rather, they are a collection of 
references to files and metadata labels. Binders provide Vantage with the mechanism 
for tracking multiple assets as a workflow executes, allowing you to design complex 
workflows—that can deal with dozens of files simultaneously—and separate your 
workflow design from the underlying files themselves.

Nicknames
A key feature of Vantage is the notion of nicknames. A nickname in Vantage is a 
convenient means of referencing a file, using only a word or phrase—such as Original 
or Vantage Proxy. In the context of a workflow, all files are referenced by a nickname 
which you assign as you configure the workflow. 

Nicknames are used in every action that creates—or operates on—a file. It is simply a 
way to tell the action which file (referenced by the nickname) it should be using for the 
task at hand. Nicknames are far easier to use and remember than fully-qualified paths 
to files—Vantage automatically tracks the physical location of the actual files.

Vantage provides some pre-set, special nicknames, and you can assign your own 
nicknames to be more meaningful in the context of your workflow. Nicknames are 
stored in the database, and they can be re-used over and over again in multiple 
workflows—they’re only attached to files during the execution of the workflow.

Note: For some complex media types—such as Omneon reference files or P2 camera 
files—a media item is actually a collection of files, all of which are necessary to make 
the media work. In this case, the nickname refers to the entire collection of media files; 
Vantage tracks the underlying video and audio files automatically.

Adding a Delete Action
The Delete action allows you to delete a file that is no longer needed, using the 
nickname of the file. Let’s use it to delete the original file at the end of the workflow.

1. Select the Complex Transcode workflow—duplicate it as Complex Transcode Tour 5.

2. In Complex Transcode Tour 5, open the transport action group, and click and drag a 
Delete action into the workflow. Notice that no nicknames display on this action.

3. Now, connect the Delete action to the top Move action so that it executes the Move 
action is complete. 
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Note: Notice that the nicknames now display on this action. The list on the left are 
files available before execution; the list on the right are files available after execution. 
(After configuration, the files used in this action are highlighted.)

Figure 35. Nicknames Display Directly on an Action.

4. Open the Delete action inspector (click the yellow i in the top left corner). 

Figure 36. Delete Action Inspector Lists Files by Nickname.

The Delete action accepts one parameter: The nickname of the file that you want to 
delete. This Delete action displays the nicknames of all files in the workflow—Origi-
nal (from Watch) and Vantage Proxy (from the connected Flip action). 

5. Select Original (which identifies the input file) and click Save to close the inspector.

Now—Vantage highlights the other Flip action’s Original nickname in red, indicating an 
error—this file has been deleted. By using nicknames, Vantage can discover many 
workflow design issues automatically—in this case, you’re attempting to delete a file 
while it is simultaneously being transcoded by a peer Flip action in the other branch!

This issue is easily resolved by connecting the Move action to the Delete action to 
merge the branches, as shown following, with the steps complete:

Nicknames of files 
in this workflow 
before execution of 
this action.

Nicknames of files 
in this workflow 
after execution of 
this action.
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Figure 37. Merged Branches Synchronize Actions.

When the workflow branches are merged, the workflow is now valid and the Flip 
actions are synchronized. In this case, the workflow waits for all upstream workflow 
branches to complete before executing the first step in the merged branch. When the 
branches are merged, the Delete action won’t execute until both Flip actions have 
completed.

Attachment Files and the Associate Action
In addition to creating and working with media files, Vantage workflows can also 
handle and use non-media files, called attachments. An attachment file might be an 
XML file, an SCC caption file, an STL subtitle file, a PDF, or any other type of file which 
does not contain video or audio media.

A binder may contain more than one media file; it may also contain more than one 
attachment file. This capability allows you to copy and move not only the media, but 
any supporting files that are necessary in the workflow.

Vantage also allows you to watch hot folders for attachment files as well as media files. 

Open the Watch action inspector, and on the first panel, note that you can specify 
whether to submit jobs when a media file is identified or an attachment file is 
identified. (Select the Attachments option at the top of the panel).

This feature is useful in several situations. For example, suppose that you have a set of 
media files and you are receiving SCC caption files that need to be matched to those 
files, and applied during a transcode. You can set up a Watch action to wait for 
incoming SCC files; but how will you apply them to media?

The answer lies in the Associate action, which allows you to add files to a binder 
midway through a workflow. It accomplishes this by matching the filename of an 
existing binder file, to discover new files that will be added. For example, in this 
workflow, the filename of the SCC file can be used to match with the appropriate media 
file; now both files are in the binder and they can be used in the workflow.

Conclusion
In this tour, you learned about file nicknames. You also learned how to manage 
multiple assets in a workflow, and how to troubleshoot for errors.
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Tour 6: Using Variables in Workflows
This hands-on tour takes about 30 minutes and introduces you to the use of variables in 
workflows. This tour also provides you a first look at the Vantage Management Console.

This tour focuses on the role that variables play in Vantage workflows: passing 
important job information between actions, controlling execution flow, action priority, 
and controlling job routing.

Introduction to Variables
Variables are temporary job metadata; information that only lasts as long as the job. A 
variable is simply a type, a name, and a value—for example, a number named Lines of 
Black at Top, set to 50.

Variables can be used in several ways in Vantage:

• To allow information to be passed between actions in a workflow

• For job routing to specialized hardware

• For decision-making to determine which branch of actions execute

• To determine the priority of a particular action

In this tour, you’ll learn how to manage and publish variables. In subsequent tours you’ll 
also learn how to use variables for decision-making.

Variables are managed in the Vantage Domain via the Vantage Management Console. 
(You can also create variables directly in Workflow Designer, at the time you are adding 
a variable to an action—the process is the same in both programs.)

Starting the Vantage Management Console
Recall that the Vantage Management Console (usually referred to as just console) is the 
program you use to configure and administer your Vantage domain—including 
Vantage services, licenses, workflow design items, and the workflows themselves.

1. Double-click the Vantage Management Console shortcut to launch it.

2. If you haven’t previously launched the console, you’ll be prompted to select a 
Vantage domain. Select your Vantage domain to continue. (If you’re using Team 
Management, you’ll log in using a Vantage user, also created in the console.)

Creating and Managing Variables
1. Select Workflow Design Items > Variables to display the Variables panel.
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Figure 38. Managing Variables in the Management Console.

The Variables panel displays a list of variables. Many of these are included with Van-
tage for use in the domain. You can use these default variables in workflows as-is, or 
you can create your own.

2. Select the Curtained variable to display its details at the bottom of the panel. Rather 
than using a default variable, let’s create a new one now.

3. Click the Create a New Variable icon in the toolbar (far left icon).

Figure 39. Creating a New Variable.

4. In the details panel, enter the name File Modification Date, set the value type 
to Date, and leave the default value unchanged.

5. Click the Save icon (disk) to save your variable.

Note: There is nothing special about the name File Modification Date—you can create 
variables with any name. In this workflow, we will use this specific variable to store the 
modification date of the file so we’ll name it descriptively.

New icon in the Variable Toolbar
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Using the Priority Variable
There is one special variable that cannot be changed—Priority. This variable has special 
meaning in Vantage, because it sets the priority of any actions that receive it when 
determining job load balancing.

However, aside from this special meaning, Priority acts like any other variable. Its value 
can be set just like other variables, and it can be used for all the same purposes. 

Setting Variable Values in a Workflow
The power of variables is that their value can change dynamically during execution of a 
workflow. There are several ways that a value changes:

• As the result of an action executing. For example, analysis (and many other) actions 
can publish their results as variables—such as determining the number of pixels 
that compose a letterbox. Similarly, Watch and Associate actions can publish infor-
mation about files that they detect, using variables.

• From external metadata. Specifically, the Populate action can set variables based 
upon metadata label values found in external files 

• From a Compute action, which can create variables from other variables. For exam-
ple, Compute can add two number variables to create a new variable.

• As a pre-step to an action executing; any action can set the value of any variable 
prior to execution.

• As a pre-step to a server executing an action; any service on any server can be con-
figured to set a variable before executing an action.

Let’s experiment with two of these. First, lets modify one Flip action in the Complex 
Transcode workflow, so that Vantage processes it with a higher priority than the other.

1. Open Workflow Designer, and duplicate Complex Transcode Tour 5 as Complex 
Transcode Tour 6.

Figure 40. Adding Variables to an Action in a Workflow.

2. Right-click the QuickTime Flip action and select Add Variables from the context 
menu to display the Add Variables dialog.
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Figure 41. Add Variables Panel.

3. Click the Add Variable(s) icon in the toolbar to display the Select Variables dialog.

Figure 42. Selecting a Variable to Add Use in an Action.

4. Scroll through the list (or press the first letter of the variable—in this case P) and 
select the Priority variable—click OK to add it to this action.

Now, the Priority variable is attached to the workflow and its default value is 5. You 
can change the value of the variable at the bottom of the panel—higher numbers 
indicate higher priority, lower numbers indicate lower priority. 
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Figure 43. Setting a Variable’s Default Value.

5. Enter a large number (for example, 100) and click OK to make this variable setting 
permanent.

Next, let’s configure the Watch action to set the value of the File Modification Date 
variable that you created earlier, each time it picks up a file and submits a job.

6. Open the Watch action inspector, and click Next three times, to display the 
Configure Settings panel.

Figure 44. Watch Action Inspector’s Configure Settings Panel—Adding a Variable.

7. Under Generate Variables, check the File Modified Date checkbox.
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8. Use the drop-down to the right to select File Modification Date, the variable that you 
created in the Management Console earlier in the tour.   Note that you could also 
add the new variable right here in the dialog.

9. Click Next, then click Finish.

Now, your Watch action will assign the file modified date value of each file that it 
submits for processing into the variable File Modification Date, for use in this workflow. 
You’ll use this variable in the next tour.

Using Variables in the Workflow
Variables are generally available to any action downstream from where they were set. In 
the case of File Modification Date, that variable’s value is available to all subsequent 
actions. In contrast, setting a variable in an action on one branch of a workflow does 
not affect the value of a variable with the same name on the other—because these are 
actually two different variables with the same name in two different branches.

In cases where workflow branches merge, variables are passed from the branch which 
actually completes last. Because which branch finishes last on a job-by-job basis is 
indeterminate from the perspective of workflow design, Telestream recommends that 
merged branches have actions which explicitly set variables which collide in this 
manner, and must be used downstream. In this case, you could reset the variable on the 
merge action to ensure that no matter which upstream branch completed first, the 
correct value is passed downstream. If you need both variable values past the merge, 
then you should start with 2 different variables; one on each branch.

If a variable is assigned to an action—but its value is not set explicitly—then the 
variable’s default value (which is set in the Management Console) is used. For example, 
in the above workflow, you set Priority to 100 (higher priority) for one of the Flip 
actions; the other uses the default value of 0 (lower priority).

Conclusion
In this tour, you learned about managing and creating variables, as well as how to set 
variable values in a workflow. In the next two tours, you’ll learn about how to use 
variables for decision-making, and how to use them to pass information between 
actions in a workflow.
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Tour 7: Decision Making in Workflows
This hands-on tour takes about 20 to 30 minutes and introduces you to the concept of 
decision-making to control the logical flow of media through a workflow. You’ll use 
variables to make these decisions.

Action States
As most actions are processed in a workflow, they are passed an action state from the 
previous action or actions, and if they execute, they also set another action state. 
Monitor actions represent an exception—as an origin action, they do not inherit an 
action state. Actions then set one of three action states to indicate the union of any 
input actions plus any execution action: Success, Ignore, or Fail. Some actions allow you 
to specify the emitting state: Decide, Examine, Compare, and Identify, for example. 
However, most actions’ emitting state is set by the service that executes the action.

This state is automatically passed to the next action or actions (in the case of a branch) 
in the workflow; these actions in turn may determine whether or not to execute based 
upon the incoming state. This process-passing-and-setting pattern repeats throughout 
the entire workflow during its lifetime.

Action states enable decision-making—causing actions (or entire branches of the 
workflow) to not execute.

To understand how to implement and utilize action states for decision-making and 
logic, its important to understand their precedence, whether an action receives states 
from one or multiple incoming actions (a merge of multiple branches):

• If at least one incoming action state is Fail, regardless of other incoming states, the 
action inherits Fail and must pass it on whether the action executes or not—Fail has 
precedence over all action states. Most actions will not execute if they inherit Fail. If 
one action fails, the entire job fails.

• If there is no Fail state, but at least one Success state, then the action inherits Suc-
cess—which has precedence over Ignore. Usually, actions execute when they 
inherit Success. After execution, the action may emit Success, Fail, or Ignore.

• If all incoming states are Ignore, the action inherits Ignore. Ignore has lowest prece-
dence of the three states. An action may or may not execute when inheriting an 
Ignore, based on its state execution setting. If an action receives an Ignore state and 
does not explicitly fail, then it emits a Success state. Otherwise, it emits a Fail state 
unless it is an action which can emit Ignore, and you have configured it to do so.

Generally speaking, actions only execute if (1) none of their predecessors set the Fail 
state, and (2) at least one of the predecessors set the Success or Ignore state. Most 
actions allow you to set the execution state.

Similarly, if an action sets Ignore, the next action will also likely not execute. Most 
actions, excluding Watch and Receive (since they are origin actions), can be configured 
to perform on certain states—this allows workflows to send an email for example, if 
they detect a failure.
Vantage User’s Guide



Workflow Designer Tours
Tour 7: Decision Making in Workflows

58
Note: Actions can be configured to execute upon Fail or Ignore—for example, to 
send an email when an action failure is detected. To configure an action’s execution 
based on the incoming action state, right-click and select Perform On.
You can also set an action to execute regardless of the state: Right-click and select 
Perform On > Any.

The Decide Action
The Decide action analyzes selected incoming variables and sets the action state based 
upon the results of its analysis. Decide effectively acts as a gatekeeper to a branch in a 
workflow, determining whether to generate a Success, Ignore, or Fail action, which is 
passed on to subsequent actions, which can be set to conditionally execute, based on 
the incoming action state.

Because variable values are usually determined at run-time, Decide allows you to 
perform the analysis, and set its state at run-time as well—and may behave differently 
for every job through a workflow. This action is a powerful action allowing you to build 
complex decision-making into a workflow.

Note that if you want to have multiple branches in a workflow, and only execute 
specific branches for each job, then you’ll need multiple decides—one acting as a 
gatekeeper for each branch in the workflow.

Processing New Files Example
Let’s look at an example (start Workflow Designer if it isn’t already open).

1. Open the Complex Transcode Tour 6 workflow and rename it to Complex Transcode 
Tour 7. We’ll update this workflow to only process new files that are in the hot folder. 

Recall that the Watch action was configured to publish a variable named File Modifi-
cation Date. We’ll use this variable to only process files created or modified after 
January 1st, 2010.

2. In the actions toolbar, open the Common category and drag a Decide action onto 
the workflow.

3. Modify the workflow so that the Decide action follows Watch, and all remaining 
actions follow the Decide action, as shown in the following figure.
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Figure 45. Decide Action Enables Execution Branching Logic.

4. To break action connections, roll over the connector between them and click the 
red X icon. In this case, delete the connectors between the Watch and both Flip 
actions. Then, reconnect the actions the way you want them to execute.

5. Open the Decide action inspector. 

6. The Decide action is designed to perform evaluations upon variables, and set a 
state if they meet all the conditions that you specify. 

7. In the top left, click Select Variables and add the File Modification Date variable.

8. Select the > (Greater) operator and set the test value to January 1, 2010, 12:00:00 
AM. 

9. Verify that the state selection is Success—meaning that if the date is later than 
January 1st, this action will emit a Success—and that the Otherwise state is Ignore. 

10. Click Finish to close the inspector and update the workflow.

Now—because actions by default operate only when the incoming action state is 
Success, your workflow will process files created after January 1st, but will not process 
files created on or before this date. 

Filtering Old Files Example
But what if you wanted to simply delete old files?

Let’s modify the workflow to delete old files. To do that, you’ll create a new branch off of 
Watch, with a Decide and Delete action (shown below, complete).
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Figure 46. Delete Actions in a Workflow—Example.

1. Add the Decide action, connected to the Watch on a separate branch. 

2. Now, open the Decide action inspector, and configure similarly to the previous 
one—add the File Modification Date variable, select the reverse operator <= (Less 
Than or Equal), and set the date to January 1, 2010 AM. If this is true, Success is set; if 
false, Ignore is set. 

3. Click Finish to close the inspector.

4. After the Decide action, add a Delete action and configure it to delete the Original 
file. It executes by default only on Success states.

This workflow now has two branches, each controlled by a Decide action—one will 
process only new files, the other will process only old files. Because of the way we 
configured the Decide actions, each file submitted will only be processed in one branch 
in this workflow.

Conclusion
In this tour, you’ve learned how to assign values to variables, to test those values, set 
action states, and use the Decide action to make run-time decisions—all features 
designed to enable you to add control to your workflows, based on information you’ve 
gleaned from your input file.
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Tour 8: Dynamic Parameters
This hands-on tour takes about 15 minutes and introduces you to the concept of 
dynamic parameters in Vantage, and how they can be used to pass information 
between actions in a workflow.

Note: To execute workflows you create in this tour, you’ll need a license—certain 
features (the Examine action, for example) won’t execute without one. For a trial 
license, contact sales@telestream.net.

Parameter Binding
Thus far, when we have configured our actions in a workflow, parameters have been set 
at a fixed value. For example, the frame size of a transcode output is 320x240. 
Obviously, by using fixed values the action performs the task the same way each 
time—creating an output file that is 320x240—every time this action executes.

How would workflow processing improve, if we could change these settings and 
parameters job-by-job, on the basis of the media being processed?

Vantage supports this capability to dynamically change the value of parameters and 
settings by binding parameters to variables. Recall that variables are metadata that is 
only known at run-time, and this metadata may be different for every single file. In 
Vantage workflows, you can configure almost any parameter, in almost any action, to 
use a variable (and its current value) as its input.

Cropping Curtains
Let's build a real-world example. In this example, we know that some of our content has 
black on the left and right—curtains—that we want to crop. However, the amount of 
black is likely to be slightly different for every file being processed in Vantage. Instead 
of creating many workflows to deal with each situation—and manually measuring the 
black before processing, we'll build a workflow to crop the curtains automatically, as 
appropriate for each incoming media file, by combining an Examine action with a 
transcode with filters implemented.

1. Open the Complex Transcode Tour 4 workflow again, and rename it to Complex 
Transcode Tour 6. 

2. Open the Analysis group and add an Examine action—connect it between the 
Watch action and the QuickTime H.264/AAC Flip action. (You can place the action 
directly on the connector line and it will automatically connect to both, replacing 
the line.)

3. Open the Examine action inspector.

4. Click the Analyzer dropdown menu and select Curtain Detection. Designer displays 
the configuration setting for this analysis tool.
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5. Open Generate Variables and configure this action to publish two variables (by 
checking them): Suggested Crop Left (select the Curtained Left Pixels variable) and 
Suggested Crop Right (select Curtained Right Pixels). 

Note: Vantage provides many predefined variables for use in your actions. While this 
is convenient, you’re certainly free—and often will need to—create your own 
variables—they behave just like the ones Vantage provides.

6. Under Input Media File Nickname, select Original as the file to analyze. 

7. Click Save to update the action and close the inspector.

8. Open the inspector of the Flip action immediately after Examine.

9. Click on the Video Stream button, then click the triangle in the Video Filter button 
(2nd from the right) to display the video filters you can use. Add a Crop video filter 
to the transcode. 

10. Select the Crop filter to display its parameters at the bottom of the window.

11. On the Left value, click the Browse (green with ellipses) button to display a list of 
available variables, and select the Left parameter to bind to the Curtained Left Pixels 
variable.

12. Perform these steps to do the same for the Right parameter and the Curtained Right 
Pixels variable.

13. Click Save when you’re done. 

You've now created a dynamic transcode, which will automatically adjust crop settings 
based upon incoming curtain data from the curtain detection Examine action. Every 
media file that is processed will have its own, custom transcode setting appropriate for 
that file!

Take a moment to explore the rest of the transcode settings in this inspector, and notice 
the bind buttons on many parameters. You’ll find the bind button in other actions as 
well—for example, the Web Service notification action allows you to send variables to 
external Web Services, and the Email Message action allows you to include variables as 
part of an email.

If you have curtained material, submit a job for processing and view the results.

Conclusion
In this tour, you learned how to create dynamic parameters that use variables as their 
inputs. This feature enables you to create powerful, dynamic workflows that adaptively 
change what they do based upon the metrics of the media being processed.
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Vantage Client Programs
& Web App Basics

These topics provide basic reference information to help you get started with Workflow 
Designer and Workflow Portal and Vantage Web apps.

 Starting and Stopping Vantage Client Programs

 Logging onto or Changing Vantage Domains—Client Programs

 Changing Vantage Users—Client Programs

 Changing Passwords—Client Programs

 Adding/Updating a License—Workflow Designer

 Selecting A Configuration—Workflow Portal

 Vantage Web App Browser Requirements

 Starting & Stopping Vantage Web Apps

 Logging into or Changing Domains—Web Apps

 Returning to the Vantage Web Apps Menu

 Logging Out of a Vantage Domain

 Changing Vantage Users—Web Apps

 Changing Passwords—Web Apps

 Displaying Version Information

 Displaying the User Guide—Client Programs

 Accessing Online Help in Workflow Designer

 Accessing Online Help in Web Apps

Note: When using Workflow Designer on Windows Server 2008, you might have 
problems minimizing windows you’ve maximized by dragging them to the top of your 
monitor. To disable the Windows AeroSnap feature, open the Control Panel > Ease of 
Access Center > Change how your mouse works and check Prevent windows from 
being automatically arranged when moved to the edge of the screen.
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Starting and Stopping Vantage Client Programs
Workflow DeChanging Passwords—Web Appssigner and Workflow Portal connect 
directly to the Vantage database, and can only be used on a computer that has access 
to the database.

You start and stop Vantage Windows programs like most other Windows programs. 
After starting Workflow Designer or Workflow Portal, you’ll select and log into a 
Vantage domain so you can begin work.

 Starting Workflow Designer

 Starting Workflow Portal

 Stopping Workflow Designer or Workflow Portal

Starting Workflow Designer
To start Workflow Designer, use one of these methods:

• Select start > Programs > Telestream > Vantage > Vantage Workflow Designer

• Double-click the Vantage Workflow Designer shortcut on your desktop.

Figure 47. Workflow Designer Shortcut.

Note: If you are launching Workflow Designer for the first time, you may be prompted 
to select and log into a Vantage domain. See Logging onto or Changing Vantage 
Domains—Client Programs for details.

Starting Workflow Portal
To start Vantage Workflow Portal, do one of the following:

• Select start > Programs > Telestream > Vantage > Vantage Workflow Portal

• Double-click the Vantage Workflow Portal shortcut on your desktop.

Note: If you encounter an error when launching the Workflow Portal, please see 
Troubleshooting Workflow Portal for assistance.

Figure 48. Vantage Workflow Portal Desktop Shortcut.
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Note: If you are launching Workflow Portal for the first time, you’ll be prompted to 
select and log into a Vantage domain and choose a Workflow Portal configuration. See 
Logging onto or Changing Vantage Domains—Client Programs for details.

Stopping Workflow Designer or Workflow Portal
To stop Vantage Workflow Designer or Workflow Portal, select File > Exit (Control+Q). 
You don’t need to save work you’ve performed, because all information is stored in the 
Vantage database, and updated automatically as you make changes.
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Logging onto or Changing Vantage Domains—
Client Programs

Note: This topic applies to both of Vantage’s Windows client programs—Workflow 
Designer and Workflow Portal.

After starting Workflow Designer or Workflow Portal, you may need to select a Vantage 
domain, and when Team Management is licensed and User Administration is enabled, 
log in before you can begin working.

First Time—The first time you start Workflow Designer | Workflow Portal on a given 
computer, you have to select a Vantage domain. After that, Workflow Designer | 
Workflow Portal remembers the last domain you used, and connect automatically.

In an environment where more than one Vantage domain is operating, you can 
connect to any domain you have access to (and potentially, have a Vantage user name 
for) to work in that domain.

Vantage domains are identified by the name of the computer on which the Vantage 
domain database resides.

Selecting the Domain
When you start Workflow Designer or Workflow Portal and need to select a domain or 
when you select File > Change Vantage Domain (in Workflow Designer, you can also 
right-click in the workflows panel away from any icons), the program display the Select 
Vantage Domain panel.

Figure 49. Select Vantage Domain panel.

Select the domain you want to use, and click OK. When you change domains, the 
program closes its connection to the current domain’s Vantage database and connects 
to the selected domain’s database.

If your domain isn’t listed, or you can’t connect, you may have to select the domain 
using different methods or change your SQL Server login settings.

Click the domain to connect 
to, and click OK.
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• Connecting to an Unlisted Domain

• Connecting with Custom SQL Server Login Settings

Connecting to an Unlisted Domain
If the domain you want to connect to is not in the list, click My Vantage Domain isn’t 
Listed.

Figure 50. Select Vantage Domain panel.

The program display the Vantage domain server field.

Figure 51. Manually Entering the Vantage Domain Server Name.

Enter the domain database server’s computer name (for example, VantageServer203) or 
IP address and click OK to connect.

Connecting with Custom SQL Server Login Settings
If the Vantage domain is using a SQL database where the default settings for the MS 
SQL server account were changed during installation, open Connection Settings to 
display the SQL Server login and password settings.

Click My Domain Isn’t Listed.

Enter the name or IP 
address of the Vantage 
domain server and click 
OK to connect.
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Figure 52. Select Vantage Domain panel.

The program displays the SQL Server login and password settings.

Figure 53. Changing SQL Server Login Settings.

Enter the Vantage database SQL server account username and password (obtained 
from your Vantage administrator), and click OK to connect.

Logging On

If you are accessing a Vantage domain with a Team Management license and User 
Administration is enabled, you need to provide your Vantage user information to log in. 
(The default Vantage username is Administrator, with no password assigned).

Note: Vantage user names and passwords are maintained via the Vantage 
Management Console, and encrypted and stored in the Vantage database. If you don’t 
have a Vantage user name, ask your Vantage administrator to create one for you.

If Vantage log in is required, the Vantage Domain Login dialog displays.

Click Connection Settings.

Enter the login name and 
password for the SQL 
database and click OK to 
connect.
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Figure 54. Vantage Domain Login dialog for Windows Programs.

Enter your Vantage user name, and password if required, and click OK to connect.

Workflow Designer—First Time Task
The first person that logs in to a Vantage domain via Workflow Designer—or, when 
Team Management is licensed and User Administration is enabled, the first time you 
log in to your account—you are prompted to create a new workflow category in which 
to store workflows.

When you log in, the only categories that display are those that your Vantage user 
name is authorized to access. (If your user name has administrative privileges, all 
workflows in the domain are displayed.) Access to workflow categories by user is 
controlled in the Vantage Management Console.

If you’re prompted to create a new category, click OK to display the Create New 
Category dialog.

Figure 55. Create New Category Dialog.

Enter the name for this category, and click OK. 

Workflow Portal—Selecting a Configuration
If a Workflow Portal configuration has been previously selected, it is used automatically. 
Otherwise the Select Configuration window displays, enabling you to select a 
configuration to use during this session. 

Note: The configurations that Workflow Portal displays are public configurations plus 
those that your Vantage user account is authorized to use. User access to Workflow 
Portal configurations is controlled in the Vantage Domain Console.
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Figure 56. Select Configuration Dialog.

Select a configuration from the list and click OK.
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Changing Vantage Users—Client Programs
Note: This topic applies to both Vantage client programs—Workflow Designer and 
Workflow Portal.

When you are logged in to a Vantage domain that has a Team Management (or higher 
level) license and User Administration is enabled, you can change to another Vantage 
user name. 

Select File > Change Vantage User to display the Vantage Domain Login dialog.

Figure 57. Vantage Domain Login Dialog.

Enter the Vantage user name, and password if required, and click OK to log in with the 
new Vantage user name.
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Changing Passwords—Client Programs
Note: This topic applies to both Vantage client programs—Workflow Designer and 
Workflow Portal.

When you are logged in to a Vantage domain that has a Team Management (or higher 
level) license and User Administration is enabled, you can change the password of 
Vantage user name currently logged in.

Select File > Change Password to display the Set Password window.

Figure 58. Changing your Password in Workflow Designer.

Enter your new Vantage password, confirm the password, and click OK to update the 
password for this user.

The next time you log in to the Vantage domain with this user, you’ll need to use your 
new password.
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Adding/Updating a License—Workflow Designer
To add a license to your Vantage domain in Workflow Designer, follow these steps.

1. Select File > Add/Update License. 
Workflow Designer displays a File System dialog. 

2. Navigate to and select the license XML file.

3. Click Add.

You can also manage licenses in the Vantage Management Console. For more 
information, see the Vantage Domain Management Guide.

Selecting A Configuration—Workflow Portal
To select another configuration when you need to perform other tasks in the same 
domain, follow these steps:

1. Select File > Change Application Configuration.

Workflow Portal displays a list of configurations for this domain.

Figure 59. List of Workflow Portal Configurations.

2. Select the configuration you want to use, and click OK.

Workflow Portal opens the configuration, and displays the appropriate user interface 
for this configuration.

Vantage Web App Browser Requirements
Vantage Web apps are implemented for execution in Microsoft IIS. JavaScript and 
cookies must be enabled to use Vantage Web apps.

Telestream recommends the following Web browsers for use with Vantage Web apps: 

• Internet Explorer 9 64-bit (Windows only)

• Internet Explorer 9 32-bit (Windows only)
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• Current version of Chrome (Mac OS X & Windows)

• Current version of Firefox (Mac OS X & Windows)

• Safari 5 (Mac OS X only). You can not use Safari with Silverlight on operating sys-
tems other than Mac OS X.

Note: To use Vantage Dashboard with Internet Explorer 9, you must configure 
Internet Explorer as described below.

To configure Internet Explorer for use with Vantage Web apps, do the following:

• Enable Active Scripting—Open Internet Explorer, select Tools > Internet options, 
select the Security tab, click Custom level, scroll down to Scripting, click Enable 
under Active scripting, click OK, and click OK to close the Internet Options dialog.

• Disable Compatibility View—Open Internet Explorer, select Tools > Compatibility 
View and uncheck Display intranet sites in Compatibility View and Display all Web 
sites in Compatibility View, then click Close.

• If you are using Internet Explorer on a Windows Server operating system that does 
not include the IIS Web host, disable Enhanced Security Configuration (ESC) using 
the Windows Server Manager.

• If you are using Internet Explorer on a Windows Server operating system that does 
include the IIS Web host, disable Enhanced Security Configuration (ESC) using the 
Windows Server Manager, or use localhost instead of the domain name or IP 
address (http://localhost/Vantage/Portal/ConfigSelect.aspx).

Starting & Stopping Vantage Web Apps
Vantage Web apps connect directly to the Vantage database, and can only be used on a 
computer that has access to the database, via LAN or the Internet.

Note: Workflow Portal is an optional, licensed program in Vantage. When you start 
Workflow Portal, if no license is available, it advises you, and operates in demo mode. 
When operating in demo mode, you can not submit jobs or edit metadata labels.
You can run multiple instances of Workflow Portal on a single computer, so that you 
can use more than one configuration at a time (and each running instance requires its 
own Workflow license). For example, you may be reviewing and submitting assets in 
one configuration, and setting trim points in another.

User authentication may be used to control user access to Workflow Portal 
configurations. Administrators can choose which Vantage users can utilize a specific 
configuration. Administrators can also make certain configurations available to 
everyone.
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Starting Web Apps
To start any Vantage Web app, open a Web browser and enter the Vantage home page 
URL: http://<ServerName>/Vantage.

This URL displays the Vantage home page, with links for all Vantage Web applications, 

You can also launch each Vantage Web app directly, by using its own URL:

• Workflow Portal URL—http://<ServerName>/Vantage/Portal

• Dashboard URL—http://<ServerName>/Vantage/Dashboard

• Job Status Viewer URL—http://<ServerName>/Vantage/JobStatusViewer

Use these URLs to directly start the target Web app. 

Replace <ServerName> with the name of the Vantage IIS server (or its IP address)—by 
default, the same as the Vantage server. Or, use localhost when running Web apps 
directly on the Web server:

 If you don’t know the name of the Vantage IIS server (by default, the same server where 
the Vantage database is hosted), contact your Vantage administrator or IT department.

Stopping Web Apps
To stop a Web app, quit the Web browser, or simply go to another Web site.

Logging into or Changing Domains—Web Apps
After starting a Vantage Web app, you may need to select a Vantage domain, and when 
Team Management is licensed and User Administration is enabled, log in before you 
can begin working.

First Time—The first time you start a Web app on a given computer, you have to select a 
Vantage domain. After that, the Web remember the last domain you used (unless you 
delete the browser’s cookies), and connect automatically.

In an environment where more than one Vantage domain is operating, you can 
connect to any domain you have access to (and potentially, have a Vantage user name 
for) to work in that domain.

Vantage domains are identified by the name of the computer on which the Vantage 
domain database resides.

Selecting the Domain
When you start Workflow Designer or Workflow Portal and need to select a domain or 
when you select File > Change Vantage Domain (in Workflow Designer, you can also 
right-click in the workflows panel away from any icons), the program display the Select 
Vantage Domain panel.
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Figure 60. Select Vantage Domain panel.

Select the domain you want to use, and click OK. When you change domains, your Web 
app closes its connection to the current domain’s Vantage database and connects to 
the selected domain’s database.

If your domain isn’t listed, or you can’t connect, you may have to select the domain 
using different methods or change your SQL Server login settings.

• Connecting to an Unlisted Domain

• Connecting with Custom SQL Server Login Settings

Connecting to an Unlisted Domain
To connect to a domain, you use the Select Vantage Domain panel.

Click the domain to connect 
to, and click OK.
Vantage User’s Guide



Vantage Client Programs & Web App Basics
Logging into or Changing Domains—Web Apps

77
Figure 61. Select Vantage Domain panel.

If the domain you want to connect to is not in the list, click My Vantage Domain isn’t 
Listed to display the Vantage domain server field.

Figure 62. Manually Entering the Vantage Domain Server Name.

Enter the domain database server’s computer name (for example, VantageServer203) or 
its IP address and click OK to connect.

Connecting with Custom SQL Server Login Settings
If the Vantage domain is installed on a SQL database where the default settings for the 
MS SQL server account were changed during installation, open Connection Settings to 
display the SQL Server login and password settings.

Click Advanced to select an 
unlisted domain or change 
the SQL Server database 
login settings.

Enter the name or IP address of the 
Vantage domain server and click 
OK to connect.
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Figure 63. Manually Entering the Vantage Domain Server Name.

Enter the Vantage database SQL server account username and password (obtained 
from your Vantage administrator), and click OK to connect.

Logging On

If you are accessing a Vantage domain with a Team Management license and User 
Administration enabled, you need to provide your Vantage user information to log in. 
(The default Vantage username is Administrator, with no password assigned).

Note: Vantage user names and passwords are maintained via the Vantage 
Management Console, and encrypted and stored in the Vantage database. If you don’t 
have a Vantage user name, ask your Vantage administrator to create one for you.

If Vantage login is required, the Vantage Domain Login dialog displays.

Figure 64. Vantage Domain Login dialog for Web Apps.

Enter your Vantage user name, and password if required, and click OK to connect.

Enter the correct login and 
password for the SQL Server 
database and click OK to connect.
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1. If you are prompted to select a domain, select the domain name, and click OK.

The first time you connect to a Vantage domain from this computer (or you deleted 
your browser’s cookies), select a domain from the list, and click OK to continue. 
Refer to Logging into or Changing Domains—Web Apps for more information.

2. Enter the Vantage user name and password assigned by your Vantage 
Administrator, then click Log In.

The default user name and password are:

• User Name: Administrator

• Password: <none> (no characters entered)

Note: All user passwords are encrypted in the Vantage database. All users have the 
option of changing their password (see Changing Passwords—Web Apps).

3. Check Remember me next time to store the authentication token in a persistent 
cookie in the browser. This keeps you authenticated if you close your browser and 
reopen it again.

4. If you entered the Vantage URL, Vantage displays the Vantage Web app home page, 
so you can select any Vantage Web app. Otherwise, your Web app displays.

Figure 65. Vantage Web Apps Home Page

Returning to the Vantage Web Apps Menu
To return to the main Web apps menu so that you can run another Vantage Web app, 
click on the home button in the title panel.

If the title panel is hidden, click the show/hide control.
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Figure 66. Vantage Web Apps Home Page

Logging Out of a Vantage Domain
If you are viewing information that is sensitive, or viewing an operational app (vs. a 
view-only app), you might want to log out when you leave your computer on and 
unattended. You must log out when you want to change domains.

To log out of the Web app, click Logout in the title panel.
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Changing Vantage Users—Web Apps
Note: This topic applies to all Vantage Web apps.

When you are logged in to a Vantage domain that has a Team Management (or higher 
level) license and User Administration is enabled, you can change to another Vantage 
user name. 

Select File > Change Vantage User to display the Vantage Domain Login dialog.

Figure 67. Vantage Domain Login Dialog.

Enter the Vantage user name, and password if required, and click OK to log in with the 
new Vantage user name.
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Changing Passwords—Web Apps
Note: This topic applies to all Vantage Web apps.

When you are logged in to a Vantage domain that has a Team Management (or higher 
level) license and User Administration is enabled, you can change the password of 
Vantage user name currently logged in.

Select File > Change Password to display the Set Password window.

Figure 68. Changing your Password in Workflow Designer.

Enter your new Vantage password, confirm the password, and click OK to update the 
password for this user.

The next time you log in to the Vantage domain with this user, you’ll need to use your 
new password.

Displaying Version Information
To display version information in a Web app, click About in the Help section of the pane 
on the left.

Figure 69. Vantage Web App About Box (Job Status Views shown).

Version 
Information
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Understanding Path Specifications for Vantage 
Storage

Vantage stores and directories can be specified using the following path forms:

• UNC form: \\ComputerName\Sharename

• Drive-letter form: C:\folder\folder

If all your Vantage services, clients, Vantage stores and folders are on the same server, 
you can use either path form. However, Telestream recommends that you always use 
the UNC path form. It is a requirement when you are operating in a distributed Vantage 
domain.

The problem with using the drive-letter path form is that the drive letter is defined on 
the local machine, and the drive letter does not identify the computer that hosts the 
drive. 

For example, if you specify a Vantage store on drive C: using the drive-letter path form 
and a Workflow Portal operator on a different computer tries to view files in that store, 
Workflow Portal will search for those files on drive C: on the operator’s computer, not on 
the Vantage server.

In another example, you create a workflow in Workflow Designer running on Computer 
A. It includes a Watch action, which will be executed by a Monitor service, running on 
Computer B. You specify a hot folder on drive C: (because you have created it on your 
computer). Now, when the service runs the Watch action it tries to locate the hot folder 
on the C: drive of Computer B, which does not exist.

When any Vantage service or client program will use Vantage storage or directory from 
a different computer, you must specify the path using the UNC form. You should also 
use the UNC form if you think you might ever support Vantage services or clients on 
another computer—a distributed domain. You can change the path form later, but it is 
easier to use the UNC path form now, and it can prevent troubleshooting issues in the 
future.

Note: When services or clients will access Vantage storage from another computer, 
the Vantage storage location or directory must be published as a share, and access 
must be granted to the appropriate Windows users. For more information, see 
Windows Authentication Guidelines in the Vantage Domain Management Guide.

When you want to use a SAN system, be aware that some SAN systems expose the 
shared drive as a letter (mapped) drive (for example, X:) that is visible on any client of 
the SAN. You can utilize SAN drives via a letter drive reference, provided that each 
Vantage server is a client of the SAN and that all mount points use the same letter.

Note: If you are creating a store to hold proxy files viewed in the Vantage Workflow 
Portal, Telestream recommends that you reference the store with a UNC path. Some 
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SAN clients do not allow frame-accurate representation of proxies when using shared 
drives.

Displaying the User Guide—Client Programs
Note: This topic applies to both Vantage client programs—Workflow Designer and 
Workflow Portal.

You can access two different editions of this guide from Vantage client programs:

• PDF version—Displays this guide, stored locally on the IIS server platform, in a for-
mat that can be printed. The PDF contains bookmarks, and you can use the PDF 
search option to search for one or all occurrences of a term.

• Web Help version—Displays the Vantage Web library directly from Telestream’s 
Web site in Web page format. Web Help features include Contents, Index, Search, 
and Favorites pages. You can use the Favorites page to save links that you can use 
to quickly return to a location in this guide. This edition is unavailable if your com-
puter is not connected to the Internet.

To open the User’s Guide PDF or the Web library, do the following:

1. Locate the Help Documentation menu in the left pane of the Web app.

2. If no entries display under the Help Documentation menu, click the control to the 
right of the title to display the list.

3. To open the PDF version of this guide, click User Guide.

4. To open the Web library, click Web Help.
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Accessing Online Help in Workflow Designer
The User’s Guide provides both reference and step-oriented help. Information in the 
User’s Guide (the document you are reading) is general in nature—it does not include 
detailed information about the domain of digital media processing or configuring a 
given codec or filter, for example. 

Workflow Designer also provides detailed information about configuring actions in the 
Workflow Designer inspector, via man pages. Man (or manual) pages are a special kind 
of context-sensitive help, typically providing very detailed information about 
configuring actions. This detailed information is provided for system, file, codec, or filter 
configuring and is much more detailed than is appropriate for the general-purpose 
User’s Guide.

 Using the Help Menu to Display the User’s Guide

 Displaying Context-Sensitive User’s Guide Topics

Using the Help Menu to Display the User’s Guide
There are several ways to use the User’s Guide in Workflow Designer:

• Select Help > Getting Started to display the Tours topic in the User’s Guide—these 
are a great resource for you to become acquainted with Workflow Designer and 
begin learning how to create and configure workflows, submit jobs, and monitor 
them as they transcode your media.

• Select Help > Contents | Index | Search, to display the local User’s Guide with the 
tab you selected active, so that you can browse the table of contents and access 
topics of interest, review the index for specific topics, or enter search criteria to find 
relevant topics you want to read.

• Select Help > Online Help to display the Vantage Online Help section of the 
Telestream Web site (if you have access to the Internet) where a wide variety of 
online resources (including the entire Vantage document library) are available.

Displaying Context-Sensitive User’s Guide Topics
In Workflow Designer, you can click the  icon anywhere you see it displayed, to open 
a specific topic if its available in the User’s Guide. 
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Figure 70. Displaying Online Help Topics in the User’s Guide.

If the topic is not available, you can search the entire User’s Guide for information.

Displaying Man Pages
In Workflow Designer, man pages are a special kind of context-sensitive help, typically 
with detailed information in the domain of media processing, and configuring actions. 
This detailed information is provided for system, file, codec, filter, and other action 
configurations and is more detailed than is appropriate for the general-purpose User’s 
Guide.

You can click the  icon anywhere you see it displayed, to open the appropriate man 
page.

Click the ? icon 
to display 
topical help in 
the User’s Guide.
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Figure 71. Displaying Man Pages.

When the man page window is open, as you proceed through a series of inspector 
panels, the man page changes as you display each panel.

Accessing Online Help in Web Apps
To display online help in any Vantage Web app, click the appropriate menu item in the 
menu on the left.

Figure 72. Accessing Online Help in Web Apps.

Displaying the About Box—To display the About box to determine the application’s 
version number, click About.

Displaying the User’s Guide—To display the User’s Guide (this document) in PDF format, 
click User’s Guide.

There are several ways to use the User’s Guide in Workflow Designer:

• Select Help > Getting Started to display the Tours topic in the User’s Guide—these 
are a great resource for you to become acquainted with Workflow Designer and 
begin learning how to create and configure workflows, submit jobs, and monitor 
them as they transcode your media.

• Select Help > Contents | Index | Search, to display the local User’s Guide with the 
tab you selected active, so that you can browse the table of contents and access 
topics of interest, review the index for specific topics, or enter search criteria to find 
relevant topics you want to read.

• Select Help > Online Help to display the Vantage Online Help section of the 
Telestream Web site (if you have access to the Internet) where a wide variety of 
online resources (including the entire Vantage document library) are available.

Click the M icon to display 
the topical help man page 
for this panel.
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Displaying Web Help—To display the Vantage Web Library on our Web site, click Web 
Help.
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Constructing and
Configuring Workflows
Vantage Workflow Designer is the primary client program in Vantage: you use it to 
design and configure workflows to meet your media transcoding requirements. 
Vantage Workflow Designer combines a wide range of workflow design and media 
processing capabilities into a single program, enabling you to create workflows to solve 
a broad set of operational media processing problems.

Workflow Designer allows you to activate and deactivate workflows, and allows you to 
submit media, and monitor the jobs that are created as workflows perform transactions 
on media you've submitted for processing.

Use this chapter to learn how to construct and configure workflows to perform specific 
media tasks in your organization.

Note: For basic information on starting and stopping Workflow Designer, and 
changing domains, user names and passwords, see relevant topics in Vantage Client 
Programs & Web App Basics.

Telestream recommends that you also take the Workflow Designer Tours to help you 
become familiar with creating and configuring a wide variety of workflows.

 Understanding Workflows

 Using the Workflow Design Panel

 Managing Workflow Categories

 Managing Workflows

 Constructing Workflows

 Creating Action Templates

 Configuring Actions

 Managing Vantage Folder Addresses

 Vantage Workflow Actions

Note: Features in editions for which you don’t have a license are disabled, and 
indicate that you need a license to use them.
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Understanding Workflows
These topics provide information about workflows you’ll find helpful before starting 
the construction and configuration process.

 Workflow Basics

 Typical Workflow Construction and Configuration Process

 Specifying Workflow Details

 Controlling Workflow Status

Workflow Basics
A workflow in Vantage is at least one set of connected set of actions (each of which 
performs a specific task). Vantage provides over two dozen actions, which you use as 
the building blocks of workflows. Workflows can be designed and configured to 
perform a controlled, automated media processing application. Workflow Designer 
organizes its actions by category (and incidentally, by the service which executes 
them), for ease of use.

You construct and configure Vantage workflows in Workflow Designer, using the 
workspace in the Workflow Design panel, by adding various types of actions (Watch 
action, Flip action, Copy action, etc.) and connecting them together to form a logical 
chain of successive tasks. Workflows are stored in the Vantage domain database, and 
actions in the workflow are executed by Vantage services.

A valid workflow must start with an origin action (a Watch action or Receive action), and 
consists of at least two actions, which must be connected. Actions that are not 
connected to another action do not execute—a single, disconnected action invalidates 
a workflow, which prevents it from being activated for use.

Workflows may have more than one origin action, but each origin action will function 
independently of the others, and is not a common design model. Each origin action 
must have its own workflow branch with following actions that are unique to that 
origin action. 

Workflows are not required to end with a terminating action—an action without an 
output pin. The only terminating action is the Forward action. The Forward action 
permits you to pass control directly to another workflow, which must have a 
corresponding Receive origin action. This enables you to create simpler, general 
purpose workflows, and chain them together to provide more automation.

Workflows are executed by jobs, which are created and submitted automatically, 
whenever a new file is discovered by the workflow’s Watch action, or when you submit 
a job manually.
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Figure 73. Workflow Design Panel.

Generally, you construct a workflow in stages: first, conceptualize and design the 
workflow and then add the actions, connecting them together to control execution. 
Finally, configure each action in the workflow to perform exactly the way you want. Test 
your workflow, and fine tune it as necessary. 

Once you have constructed and configured a workflow, you click Activate so it can be 
utilized. To edit it again—or just disable it—you just deactivate it. Then, click Edit, and 
when you’re done, you click Release. When you are editing a workflow, others using 
Workflow Designer can view—but not edit—the workflow. These buttons are all 
displayed at the bottom of the main window.

Typical Workflow Construction and Configuration Process
Before constructing a workflow, it is helpful to have a solid understanding of its 
objective or application—what you want to accomplish with it, You’ll have to 
determine what actions (tasks or steps) are necessary to implement the objective; 
where the media (and optionally, metadata and associated files) originate; what 
transcoding and metadata processing is required; where any new copies of media, 
metadata, and associated files should be stored or deployed, etc.

You should also know in advance what external systems these jobs will interact with, 
and whether you want to register and track the output files and related metadata in a 
Vantage catalog for future use. 

Armed with these details, you can construct the workflow, and configure each action to 
correctly perform its assigned task. Of course, if you don't have all this information at 
the start, you can configure the workflow later. 

Once you have tested a workflow, you have to click Activate so it can be utilized. To edit 
it again—or just disable it—you just deactivate it. Then, click Edit, and when you’re 
done, you click Release. These buttons are all displayed at the bottom of the main 
window.
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Using the Workflow Design Panel
This topic provides general information about using the Workflow Design panel.

 Design Panel Overview

 Specifying Workflow Details

 Displaying Nicknames or Variables on Actions

 Displaying Action Summary Information

 Showing and Hiding Grid Lines

 Moving the Workflow Around in the Design Space

 Centering a Workflow

 Zooming In and Out on a Workflow

 Automatically Arranging Workflow Actions

 Action Toolbar Display Options

Design Panel Overview
You use the Workflow Design panel (click the tab or select File > Workflow Design) to 
view, construct, and configure workflows, and activate workflows for job processing. 

The figure below illustrates the layout and main components of this panel (the 
Workflows panel (left) is not part of the panel, but is shown here for clarity).

Figure 74. The Workflow Designer Panel.
Workflows panel—displays all 
workflows in the database.

Use the Workflow Design panel to construct 
and configure workflows.

Nicknames | Variables View

Actions toolbar—
drag actions onto 
design area to add to 
workflow.

Zoom control

Workflow actions
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At the top of the workflow design panel is the actions toolbar, categorized in groups by 
action type. To sort them, right-click in the toolbar and select Sort by Name or Sort by 
Behavior.

Click the arrow to open each action type and display the set of actions in this group.

Specifying Workflow Details
To display and edit the selected workflow’s details panel, select File > Workflow Details 
Panel or click in the Workflow Design title bar. Vantage obscures the tabbed panels and 
displays details about the selected workflow:

Figure 75. Click the Title to Display Workflow Details.

Click in the title bar again (or click Close) to hide the details panel and reveal the tabbed 
panels again.

Name—Name of workflow.

Description—Displays the description of workflow in workflow tooltip.

Expiration—Check to expire jobs from this workflow after the specified elapsed time.

Hours—Select the number of hours before this workflow expires.

Bound Variables—Indicates which variables are being utilized by actions in this 
workflow. If an action parameter in the workflow binds to a variable, it displays here.

Click in the workflow title bar once to display workflow details—
click again to display the tabbed panels.
Vantage User’s Guide



Constructing and Configuring Workflows
Using the Workflow Design Panel

94
Displaying Nicknames or Variables on Actions
Binder file nicknames, metadata labels, and attachments, or variables can be displayed 
directly on action (in detailed action view) for quick reference.

Figure 76. Actions can Display Nicknames Plus Metadata Labels, or Variables.

Nickname View—To display nicknames, select View > Action Details > Binder File 
Nicknames. In binder file nickname view, each action displays a list of file nicknames 
and metadata labels, plus attachments, that are available to the action before it 
executes (on the left), and the nicknames and labels that are available downstream 
when the action completes (on the right).

Items on an action change color based upon the validity of the workflow. Highlighted 
nicknames have been utilized/created in this workflow. Nicknames displayed in red 
represent an error.

Note: Nicknames and labels that are used or affected by the action are highlighted. 
Nicknames and labels also change color indicating whether or not the workflow is 
valid.

For example, if you configure an action to utilize nickname Copy7 provided by an earlier 
action and then delete the action that created Copy7, then Copy7 displays in red on the 
now-invalid action.

Variable View—To display variables, select View > Action Details > Variables. The 
variable view displays variables that are used to bind parameters in this action. 

Displaying Action Summary Information
Each action has a summary—to display it, hover over the inspector icon. 

Input nicknames

Output nicknames
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Figure 77. Action Summary Text.

The summary displays the action type, description (editable), and a high level 
description of how the action is configured.

Showing and Hiding Grid Lines
To toggle the grid lines, do one of the following:

– Select View > Show Grid Lines (Control-G).

– Right-click and select Show Grid Lines to display horizontal and vertical grid 
lines.

Select again to hide grid lines.

Moving the Workflow Around in the Design Space
A workflow with lots of actions may be larger than your workspace when viewed at the 
zoom level you’re using. 

To move the workflow around in the workspace, click anywhere on the design area 
other than directly on an action. The cursor displays as a compass—now, drag the 
workflow in the appropriate direction and release the mouse.

Centering a Workflow
To center a workflow in your workspace, do one of the following:

– Right-click in the workspace and select Recenter Workflow (Control-R)

– Select View > Recenter diagram) to recenter the diagram on the work area.

Hover over the inspector icon to 
display the summary text.

Summary text displays the 
action description and high level 
configuration details.
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Zooming In and Out on a Workflow
The zoom slider bar at the bottom left corner enables you to zoom in and out to suit 
your needs.

Figure 78. Zooming In and Out to View your Workflow Better.

You can use the scroll wheel on your mouse while pressing Control to zoom in and out 
on a workflow.

Zooming In—To zoom in on a workflow so you can better view details, do one of these 
actions:

• Drag the zoom slider bar to the right

• Repeatedly press Control-+ (the Plus key)

Zooming Out—To zoom out on a workflow so you can see more actions, do one of these 
actions:

• Drag the zoom slider bar to the left

• Repeatedly press Control-- (the Minus key)

Automatically Arranging Workflow Actions
Use the Auto Arrange feature to assist you in visually optimizing and organizing the 
layout of actions in your workflow.

Figure 79. Enabling Auto Arrange.

To disable automatic arrangement of actions while you're adjusting actions in a 
workflow, click the Auto Arrange button, located at the bottom of the Workflow Design 

Zoom in or out to get a better view 
of your workflow and actions.

Enable or disable Auto Arrange to 
suit your construction style.
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panel, to toggle it off. While Auto Arrange is off, the Auto Arrange button displays Auto 
Arrange SUSPENDED in yellow. 

Click the button again to toggle auto arrangement back into effect.

Action Toolbar Display Options
To reduce the size of the Action toolbar at the top of the design area, you can right-click 
in the bar and select Icon. To return the action names to the toolbar, right-click and 
select Icon and Text.

Controlling Workflow Status
This topic describes the four workflow status commands and how and when to change 
a workflow’s status. You change the workflow status via menu items or by using the 
buttons at the bottom of the main window.

At the bottom of the Workflow Designer window are status buttons that you use to 
control the status of the workflow.

Figure 80. Changing a Workflow’s Status.

Edit—Select File > Edit Workflow or click the Edit button to modify the selected 
workflow. If the workflow is currently active (the monitor action is running and the 
workflow can process jobs), Vantage will display a warning dialog that it is about to 
deactivate the workflow. Click OK to continue.

The Actions toolbar displays at the top of the panel when in design mode, so that you 
can add new actions to the workflow.

When you are editing a workflow, other Workflow Designer users can view the 
workflow, but cannot edit or activate it.

Release—When you’re done editing a workflow, Select File > Release Workflow or click 
the Release button. Released workflows can be activated, and can also be edited by 
others.

Activate—Select File > Activate Workflow or click the Activate button on a deactivated 
workflow to start any monitor actions so that jobs can be submitted and processed by 
this workflow.
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Deactivate—Select File > Deactivate Workflow or click the Deactivate button to 
deactivate the workflow. New jobs cannot be submitted and media cannot be 
processed by the workflow in this state. Existing jobs using this workflow continue 
executing to completion.

Managing Workflow Categories
Vantage provides Workflow Categories so that you can organize your workflows by 
categories that you design, and so that you can isolate and control workflows by 
Vantage user accounts (which is done in the Management Console).

This topic describes how to add, change the name, and delete workflow categories.

 Using the Workflow Categories Context Menu

 Creating a Workflow Category

 Renaming a Workflow Category

 Deleting a Workflow Category

Using the Workflow Categories Context Menu
Right-click in the workflows panel to display the following context menus:

In the panel title or empty space—Use the context menu to change the Vantage domain, 
or to create a new workflow category or workflow, import a workflow, or open a 
workflow you’ve used recently.

On a category—Use this context menu to create a new workflow or to rename or delete 
the category.

CAUTION: When you delete a workflow category, all workflows in this category are 
permanently removed from the domain database.

On a workflow—Use this context menu to change the status of the target workflow. You 
can also perform a variety of operations on the workflow (Managing Workflows), or 
manually submit a job if the workflow is activated.

Creating a Workflow Category
All workflows are stored in categories, and you must have at least one category created 
before you can create a workflow.

To create a new category, select File > Create New Category, or right-click in the 
Workflows panel (on the left side of the main window) away from any categories or 
workflows, and select Create New Category. Workflow Designer display the Create New 
Category dialog:
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Figure 81. Create New Category Dialog.

Enter the name of the category you want to create, and click OK.

Workflow Designer creates the category in the database, and displays it in the list.

Renaming a Workflow Category
To change the name of a category, right-click on the category name in the Workflows 
Panel and select Rename. Workflow Designer makes the text editable so you can 
change it. Press Enter or just click away from the field when you’re done.

Deleting a Workflow Category
To delete a category, right-click on the category name in the Workflows Panel and 
select Delete. Workflow Designer displays a warning that you are about to delete the 
category and all workflows stored in this category. Click OK to delete the category and 
its workflows.

CAUTION: This action deletes all workflows in the category, and can not be undone.

Managing Workflows
This topic describes how to add, rename, move, and delete workflows, and perform 
batch operations, and other workflow-related operations.

Note: Whenever you are performing a workflow operation, you can either select the 
workflow directly from the Workflow panel, or if its a workflow you’ve used recently, 
select File > Recent Workflows, and select the workflow from the list.

 Creating a Workflow

 Renaming a Workflow

 Deleting a Workflow

 Moving Workflows Between Categories

 Duplicating a Workflow

 Importing a Workflow

 Exporting Workflows

 Printing Workflows
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 Performing Batch Workflow Operations

Creating a Workflow
To create a new workflow, select File > Create New Workflow, or right-click in the 
Workflows panel (on the left side of the main window) away from any category or 
workflow and select Create New Workflow. Workflow Designer display the Create New 
Workflow dialog:

Figure 82. Create New Workflow dialog

Category—Select the category for this workflow from the list at the top.

Name and Description—Enter the name of the workflow you want to create and an 
optional description in the Name and Description fields.

Expiration Policy—If checked, specifies (in hours) the time that elapses before job 
records for jobs submitted by this workflow are deleted from the database. The time for 
expiration is based on the last updated time in the job record—not the job submission 
time.

Once the expiration period has elapsed, the jobs are subject to automatic deletion by 
the system.

OK | Cancel—Click OK to create the new workflow. Workflow Designer creates the 
workflow in the database, adds it to the specified category, and displays it in the 
Workflow Design panel in edit mode—that is, deactivated and editable.

Renaming a Workflow
To change the name of a workflow, right-click on the workflow name in the Workflows 
panel and select Rename. Workflow Designer makes the text editable so you can 
change it. Press Enter or just click away from the field when you’re done.

Select the category where 
you want to save the 
workflow.

Enter the name of the new 
workflow and click OK.
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Note: You can only rename a workflow when it is in edit mode.

Deleting a Workflow
To delete a workflow, select File >Delete Workflow or right-click on the workflow name 
in the Workflows Panel and select Delete. Workflow Designer displays a warning that 
you are about to delete the workflow and all job history for this workflow. Click OK to 
delete the workflow and its history.

CAUTION: This action deletes the workflow and its job history, and can’t be undone.

Moving Workflows Between Categories
To move a workflow from one category to another, select File > Move Workflow or 
right-click on the workflow you want to move and select Move. Workflow Designer 
displays a Category dialog. Select the category you want to move the workflow to, and 
click OK.

Duplicating a Workflow
To duplicate a workflow, select File > Duplicate Workflow or right-click on the workflow 
and select Duplicate. Workflow Designer displays a Category dialog. Select the 
category you want to create the new workflow in, enter a name, and click OK.

Importing a Workflow
To import a workflow, select File > Import Workflow or right-click on the workflow and 
select Import Workflow. Workflow Designer displays a File System dialog. Navigate and 
select the workflow XML file previously exported from Vantage, and click Open. Select 
the category where you want the imported workflow placed, or create a new one. 
Workflow Designer imports the workflow into the selected category. You can now 
rename and edit the workflow as appropriate.

Exporting Workflows
Exporting a Single Workflow—To export the selected workflow, select File > Export 
Workflow or right-click on the workflow and select Export Workflow. Workflow 
Designer displays a File System dialog. Navigate and select the location where you 
want to save the workflow XML file, and click Save. Workflow Designer exports the 
workflow as an XML file.

Exporting All Workflows in the Domain—To export all workflows in the domain, select 
File > Export All Workflows. Workflow Designer displays a File System dialog. Navigate 
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and select the location where you want to save the workflows. Optionally, create a new 
folder, and click OK. 

Workflow Designer creates a folder for each category in the domain, then exports each 
workflow in each category, as an XML file.

Printing Workflows
Select File > Print Workflow to print the selected workflow using the current workflow 
settings. The workflow is scaled to fit on a single page (with landscape or portrait mode 
preset based on workflow shape), unless the workflow is sufficiently large to make it 
difficult to read when scaled to a single page. Then, Designer provides you the option 
of printing across multiple pages.

Performing Batch Workflow Operations

Note: This feature is enabled only when a Vantage user with Administrator privileges 
is logged in.

To change the status of multiple workflows simultaneously, Select File > Batch 
Workflow Operations. Select the workflows and then edit, release, activate, deactivate, 
delete or move them. 

Workflow Designer displays the Workflow Batch Operations dialog, which lists every 
workflow in the domain. Select one or more workflows (using shift and control keys). 
Then, click the button at the bottom of the dialog to perform that task. When you’re 
done, click Close.
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Constructing Workflows
The following topics describe the operations you’ll use to construct workflows, which is 
done by adding actions, arranging them in order of execution, and connecting them 
together.

Note: Before you can edit a workflow (work with actions or change configuration), it 
must be deactivated and editable. When you first create a new workflow, Workflow 
Designer places it in edit mode automatically.

 Adding Actions

 Deleting Actions

 Controlling the Order of Execution

 Removing Line Crossings

 Re-ordering Actions

Adding Actions
To add actions to a workflow, you open the appropriate action category in the Actions 
toolbar and drag the desired action onto the design area. When you drag an action 
onto the design area, it has no configuration set, and must be configured before you 
can use the workflow.

Many actions have action templates—pre-configured actions that make it easier to 
assemble workflows. Vantage provides many built-in action templates, and you can 
also make and use your own. For details, Creating Action Templates.

To select an action template, click on the action and select an action template from the 
list. The configuration of a template may be exactly what you need, or you may need to 
make minor configuration changes.

Figure 83. Open an Action Category to Add an Action to your Workflow.

You can also copy and paste actions in your workflow. Right-click and select Copy to 
put the action on the clipboard. Next, right-click on the design area, and select Paste to 
add the copied action to the workflow. Or, right-click on another action of the same 
type, and select Paste to configure the action identically with the copied action.

Note: An origin action (Watch or Receive action) is required as the first action in a 
workflow, even if you plan to manually submit jobs to this workflow.
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When you drag an action onto the design area, Vantage may automatically align it near 
where you dropped it (unless auto-arrange is off; see Automatically Arranging Workflow 
Actions). Until you connect an action to other actions, you can move it anywhere you 
want on the work area. If you bump the action you’re adding right next to an existing 
action, Workflow Designer will automatically connect the two.

Generally, its easiest to drag and drop actions in a pattern similar to the desired 
workflow, working from left to right (on each branch, if more than one). However, you 
can drag actions anywhere, and connect them as desired later.

Vantage will tidy up actions—moving them and organizing them by column. Once an 
action is connected, you can move it vertically (up or down) but it cannot be moved 
from its column. Alternatively, Vantage can also attempt to optimize the workflow, 
removing as many line crossings as possible. 

Deleting Actions
To delete an action, select it and press Delete or right-click the action and select Delete. 
When you delete an action, Workflow Designer connects the preceding and 
succeeding actions, unless you uncheck Fill connections after delete in the Delete 
confirmation dialog.

Controlling the Order of Execution
You connect actions together in a workflow to control the order of execution relative to 
other actions, and to control the flow of variables and files from one action to another.

Task execution proceeds action by action, from left to right: when a workflow executes, 
actions at the far left execute first, and actions following the lines execute next.

To connect actions, click and drag a line from the output pin of one action to the input 
pin of the action you want to execute next in the workflow, or vice-versa. Or, when 
dropping an action onto a workflow or dragging an unconnected action around, 
position it so that your mouse is directly on the edge of the action you want it 
connected to.

Conversely, to disconnect an action, hover over the center of the connecting line until a 
red X displays; click the red X to delete the line.

Actions can only be connected from an output pin (on the right side of the action) to an 
input pin (on the left side of the action), and control (file or logic) flows from output to 
input—from left to right.

Certain connections are not permitted:

• You can’t form recursive loops, by connecting actions to themselves or to other 
groups of actions.

• You can’t connect one input (left) pin to another input pin, or one output pin (right) 
to another output pin.
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Note: When you connect action, Workflow Designer can show you the two actions 
you’re connecting (Options > Show Connection Helper) or you can disable it.

You can connect an action to multiple succeeding actions, creating logical branches, as 
shown following. When you do, none of the actions you connect can execute before 
the preceding action upon which they depend completes. 

When you have branches in a workflow, you can optionally, use a Synchronize action as 
a visual connector at either end of the branches, to better organize them. Synchronize 
does not perform any special task, it merely aids in design. In this example, three Copy 
actions execute in parallel after the Watch action completes.

Figure 84. Multiple Actions Can Branch From a Common Action.

These three actions execute independently of each other, and their start time and 
completion time relative to each other is non-determinant. They execute in parallel 
from the perspective of the actions which precede and follow these actions.

You can also connect multiple actions (branches) back to a single succeeding action, as 
shown in the following figure. When you do, each of the actions you connect must 
execute before the succeeding common action can execute. 
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Figure 85. Multiple Action Branches Precede a Common Action.

In this example, all three Copy actions must execute before the Message action 
executes.

You can also create multiple, independent action branches–each branch starting with 
an origin action. Each branch operates independently. Each origin action creates its 
own jobs. Although this is not generally recommended, you may have situations where 
it is the best solution.

Figure 86. Multiple Independent Branches in a Workflow.

In this example, two independent sets of actions are in this workflow. As each origin 
action detects new files to process, a separate job is initiated.
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Removing Line Crossings
On occasion, you might connect two actions on rows in the layout that are more than 
one row apart—resulting in an unintended line crossing. To manually optimize the 
workflow layout, select View > Remove Line Crossings or right-click and select Remove 
Line Crossings. Workflow Designer reformats the workflow and optimizes the layout of 
the actions in a grid.

Re-ordering Actions
To re-order actions vertically, drag one of the actions up or down in the design area to 
the location where you want it. Designer adjusts the other actions to accommodate the 
manual placement of the other action.

 Creating Action Templates
Vantage provides many actions with a variety of action templates, which you can use 
(along with your own) to make workflow construction easier. 

To make your own action template, follow these steps.

1. Add an action to a workflow. 

2. Configure it as appropriate.

3. Edit the description (at the bottom of the action), which is used to name the action 
template.

4. Right-click and select Create Template to save the selected action as a template.

Figure 87. Create Template Window.

5. Add or select a category, or select None and click OK.

Grouping allows you to organize your action templates. If you want more than one 
level of grouping, separate each group with a vertical bar (|)—for example, Broadcast 
Servers | Grass Valley. The description of the action displays as the name of the action 
template.

The action template is added to the template list, and can be selected by clicking on 
the action.
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Configuring Actions
This topic describes how to configure actions, which is performed by using the action’s 
inspector. Each inspector is different, based on the type of action.

 Using the Action Inspector

 Changing Action Descriptions

 Setting Conditional Task Execution

 Understanding Variables

 Adding Variables to an Action

 Creating New Variables

 Binding Settings to a Variable

 Specifying Retry Rule Settings

 Specifying Resource Costs

 Using the Filename Pattern Editor

 Action States

 Implementing Logic and Conditional Execution in Workflows

Using the Action Inspector
Each action has an action inspector—a series of one or more configuration panels—
which you use to configure it to perform its task in a particular way. To access the action 
inspector, click the inspect icon (round yellow i icon) in the upper left corner or right-
click the action and select Configure.

Figure 88. The Action Inspector Icon Displays Yellow Until Configured.

Until an action has been configured, the inspector icon displays yellow; a workflow 
cannot be activated until all actions have been configured. If you hover directly over 
the icon, a summary of the action displays. 

The inspector panel or panels vary, depending on the type of action, and the 
configuration choices you make. For example, to configure a Copy action, you choose 
the source and copied file, and a destination—all in one panel:

Unconfigured actions display 
their inspector icon in yellow to 
alert you to a problem.
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Figure 89. Typical Action Inspector.

However, the inspector for a Watch action typically consists of about 7 or more panels, 
depending on the file system you configure it to monitor.

When you’re viewing an inspector of an action in a workflow that is activated or 
someone else is editing it, the term Read Only displays in the inspector’s title bar. Also, if 
you have changed the configuration, an asterisk (*) displays immediately after the 
action name: for example, Watch *.

Detailed help is available on each panel in the inspector: Click the M icon to display its 
man page or click the ? icon to display this topic in the Workflow Designer User’s Guide.

Changing Action Descriptions
You can change an action description by directly clicking on the description text field at 
the bottom of the action, or right-click and select Description. Enter the new text and 
click away.

Setting Conditional Task Execution
You can configure some actions to only execute when the upstream action or actions 
pass a specific action state to the downstream action. Not all actions allow you to set 
condition execution. For example, you can’t test action states in origin actions—Watch 
and Receive. You also can’t set conditional execution for Flip and Agility actions, and 
others.

To set the state under which an action will execute, right-click and select Perform On > 
Success | Failure | Ignore | Any. The Any option is not a state—it is a selection to indicate 
this action should execute regardless of the state passed to it.

By default, actions only execute when the action state (as set by upstream actions) is 
Success. Success means that the upstream actions have completed normally and the 
incoming state is Success. 

The Fail state indicates that at least one action has executed and failed to complete 
normally or completed normally, but was explicitly set to Fail. If you have an action 
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configured to execute on Fail, it only executes if at least one upstream action has 
reported a failure.

You can also configure an action to execute on the Ignore state by selecting Ignore.

Understanding Variables
A variable is temporary job metadata. Variables have a name (such as Number of Audio 
Channels), a type (such as Integer Number) and a default value. They can be set in a 
variety of ways: In any action that by design, implement variables—analysis, metadata 
population, Watch and Associate actions, etc., or as a property of any action, when 
manually submitting a job.

Variables are passed from action to action according to the action connections. When 
an action utilizes a given variable, all downstream actions that use variables can access 
the variable and its value.

Note: Not all actions are designed to use variables—for example, the Register action 
does not utilize variables.

Variables are used by some actions to control their functionality and execution—and 
thus, implement workflow logic. (Variables are also used by services—and set up in the 
Vantage Management Console.)

Many parameters in Vantage can be bound to a variable, allowing the workflow to 
dynamically update parameters on a job-by-job basis. For details on binding 
parameters to variables, see Binding Settings to a Variable.

When a variable is set to a specific value, that variable value is only available to actions 
within the same branch as the one that set the variable and actions in downstream 
branches.

Note: If two branches merge to a common action, and both have specified a value for 
the same variable, then the behavior is indeterminate.

Before you can assign a variable to an action, you must create a variable. You create 
variables directly in Workflow Designer, and also in the Management Console 
(Workflow Design Items > Variables). The name, default value, and type of a variable is 
defined in the variable.

Adding Variables to an Action
Sometimes, you need to provide information to one or more actions (or directly to a 
job, when you’re manually submitting it) that is independent of the functionality of the 
actions. To do so, you can manually add a variable and set a static value. These variables 
can be used by downstream actions or by other Vantage components such as services, 
to execute the workflow appropriately.
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For example, you can add a variable to set the execution priority of one workflow 
branch to high, and another to low.

To manually add a variable to an action, right-click and select Add Variables. Vantage 
Designer displays the Add Variables window.

Figure 90. Add Variables Window.

In the Add Variables window, you can add variables to the action prior to execution. 
Values set in this window are available to this action, and all downstream actions 
(including actions in connected workflows).

Click the Add Variables icon in the toolbar to display a list of variables.

Figure 91. Select Variables Window.

Select the variable to add and click OK.

Note: Click Create New Variable to create a variable if you need a new one. For details, 
see Creating New Variables.

Next, with the variable selected, modify its default static value if necessary, and click OK 
to add it to the variable for use in the workflow.

Add Variable | Delete Variable toolbar icons.
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Note: It is important not to use the same variable in two actions if the branches 
merge, because the behavior is indeterminate.

Creating New Variables
In addition to creating variables in the Management Console (Templates > Variables), 
you can also create new variables in Workflow Designer. On variable selection windows, 
click the Create New Variable button. Workflow Designer displays the Create New 
Variable Window:

Figure 92. Using the Create New Variables Window.

Name—Enter an appropriate name for the variable.

Description—Enter a functional description. 

Value Type—Select the type of variable to create from the dropdown list.

Default Value—Enter the static value for this variable instance.

Click OK to save the variable.

Binding Settings to a Variable
Most settings in an action are configured with a static value—one that does not 
change from job to job. For example, you configure a Watch action to poll a specific 
directory—and job after job, this directory never changes—that is, it is a static value.

However, many actions also have settings whose values change from job to job—and 
thus, must be assigned a value when the job runs—typically, based on the media being 
processed. 

For example, you may have a Message action that generates an email—and the To 
address in the email should be the address of the associate producer of the show, 
which is provided in metadata, and assigned to a variable prior to the Message action. 
Or, a variable may be assigned a value by an analysis action to determine how many 
lines of black are at the top of a video frame; a crop filter later in the workflow can bind 
to that variable, ensuring that every crop in every job is appropriate to the workflow.
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To solve this problem, Vantage enables many settings to be bound to a variable, 
allowing the workflow to dynamically update the value on a job-by-job basis.

Settings that can be bound to a variable display a green Variable Browse button.

Figure 93. Message Action Inspector—Bindable Parameters.

Click the Variable Browse button to display the Select Variable window:

Figure 94. Select Variables window.

The list of variables includes those variables that are present in the domain, and are of 
the correct type for the parameter. For example, the subject line only accepts text 
variables; the email address can only accept email address variables.

Select the variable to bind to this parameter, and click OK.

Note: Click Create New Variable to create a variable if you need a new one. For details, 
see Creating New Variables.

Parameters that can be bound to a 
variable display a green Browse button.
Click it to select a variable, which will 
supply its current value as the value for 
the parameter.
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Figure 95. Message Action Inspector with a Bound Parameter.

Now, the setting displays with a green border, indicating its value is derived directly 
from the current value of the setting, not the manually entered value.

Configuring an Action’s Run On Rules
Most actions (except the Common actions—Compute, Construct, Decide, Forward, 
Receive, and Synchronize) have a set of rules called run on rules, which can be 
configured to determine if a given service has the features which enable it to execute a 
given action. Unlike qualification rules, which are service-centric, run on rules are 
action-centric.

Note: In addition to setting up specific rules on an action, you can also set up service-
based qualification rules using the Management Console.

Run on rules provide you explicit control over which service can execute a particular 
action in a given workflow.

As you design a workflow, you can indicate that you need to have a particular action 
execute on a particular service (or set of services). To implement this, you define a True/
False variable and provide it a value of TRUE to indicate that this instance of the service 
can satisfy the requirement. Next, you assign this variable to the service or services that 
qualify, in the Vantage Management Console > Services > Variables.

For example, you are designing an HD transcoding workflow, and the Flip action must 
be executed by a Transcode service deemed HD-capable—that is, it is running on a 
server with a processor set capable of adequately handling HD media transcoding. For 
this example, its a server named Vantage_HD_Transcoder.

In Workflow Designer, open your HD workflow, right-click on your Transcode action and 
select Run On Rules to display the Run On Rules dialog.

Settings bound to a variable display a 
green border.
Click the Browse button again to 
unbind a variable, or change which 
variable you want to use.
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Figure 96. Creating Run On Rules for an Action.

Click the Add Variable button in the toolbar at the top, and create an HD_Capable 
variable and set its value to TRUE, as shown below. 

Figure 97. Creating a Variable for use with Run On Rules.

Next, click OK to create this variable, and click OK to save the Run On Rule.

In the Vantage Management Console, select Services > Variables and add the 
HD_Capable variable to the Transcoder service running on the Vantage_HD_Transoder 
server.

Note: When a variable is added to a service, that variable is added to the job if the 
service executes it. Be careful about which variables you use for run on rules, and 
which are used for decision-making; generally you will want to use different variables.
Run on rules only analyze variables explicitly set by a service. They do not analyze 
variables already set in a job. This ensures that run on rules only execute actions on a 
service that explicitly sets them.

Now, return to Workflow Designer and open your HD workflow again. Right-click on 
your Transcode action and select Run On Rules to display the Run On Rules dialog.

Click Check Services to verify that the Vantage_HD_Transcoder now responds correctly 
to queries about being HD-capable.
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Figure 98. Creating a Variable for use with Run On Rules.

Specifying Retry Rule Settings
Certain actions (typically, those that deal directly with files or other network-accessible 
computer systems) which fail during the execution of a workflow attempt to retry 
according to user-specified rules called retry rules.

Default retry rules are set for each action type in the Vantage Management Console, but 
they can be modified on each action in Workflow Designer, which overrides the default 
rules.

For example, you might specify a default retry rule (in the Vantage Management 
Console) that all Flip actions retry one time, after five minutes, and then modify the rule 
in a particular Flip action, that it will retry three times.

Or, you might specify that a Copy action should retry three times: once after five 
minutes (in case of a SAN blip), once after four hours (in case of Internet congestion), 
and once after two days (in case of complete Internet failure). Then, on any given Copy 
action in a workflow, you could make minor adjustments to that default rule.

It is important to keep in mind that individual action retry rules specified in Workflow 
Designer override the default retry rules specified in the Vantage Management 
Console. If an action does not have override retry rules, the default retry rule for the 
action type will be used instead. If there are no override rules specified for an action, 
and no default rules for its action type, then a failed action is not retried.

When an action re-executes, it is again processed for execution—it is handled 
according to load balancing rules, and may be assigned to a different service for 
execution.

If you restart a job that is in the Stopped by User or Failed state, the actions execute as a 
first-time execution. For example, you have an action with Retry after 4 hours. 
Restarting this job results in immediate execution, because the action is executing on 
its first try.

Table 2. Actions with Retry Rules

Archive Examine Message

Associate Flip Multiscreen Flip

Compare Gather Notify

Copy Identify Process MMF
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Overriding Retry Rules
To view or modify retry rules on an action, right-click and select Retry Settings. 
Workflow Designer displays the Automated Retry Settings dialog.

Figure 99. Automated Retry Settings Dialog.

No Retry | Default | Custom Limited Retry | Custom Recurring Retry—Select No Retry to 
override any default retry settings, and not retry execution on failure. Select Default to 
utilize the default retry settings specified in the Vantage Console. Select Custom 
Limited Retry and configure up to three retry settings. Specify Custom Recurring Retry 
and configure the time between retries. For each choice, set Priority value if desired. 

Click OK to save.

Specifying Resource Costs

This feature is enabled in Vantage Master Control and Enterprise Control.

Note: For a complete explanation of the theory and application of Resource Costs, 
see the Vantage Enterprise Guide.

To improve load balancing, each action has a resource cost assigned by action type. In 
addition, you can configure a specific action in a workflow, and assign it a custom 
resource cost.

Resource costs are integer values, that have an ordinal relationship to one another. You 
can implement any scale you want in your domain. Greater scales enable finer-grained 
control. 

Using resource cost values, services can be better utilized by assigning them actions to 
execute based on the total resource cost of their current actions, compared to their 
target resource cost capacity.
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To view or set a resource cost on a given action, right-click and select Resource Cost. 
Workflow Designer displays the Resource Cost Setting dialog:

Figure 100. Resource Cost Settings Dialog.

Select Default, or select Custom and enter an integer value. Click OK to save.

Using the Filename Pattern Editor
Some action inspectors utilize a filename pattern editor, so that you can customize the 
pattern for filename generation, based on the task, and the workflow requirements. 
The filename pattern editor is implemented in the Flip, Copy, Move, Agility Job Profile 
(available in Enterprise Master Control), and metadata transform (available in 
Transcode Connect and above) actions.

To display the editor, click the filename pattern editor button in the inspector:

Figure 101. Filename Pattern Editor Dialog.

Use the editor to implement a filename generator pattern for your workflow. You can 
include raw text (for example, .xml), and elements—base name (which includes the full 
file name including the extension, variable (select your variable), date, and time in any 
combination, to produce the name generator pattern you require.

Note: In Metadata and Flip actions, the basename element is the base name of the 
file without the extension (for example, myfile), which you must supply. In Copy, Move, 
and Agility Job Profile (Enterprise Master Control) actions, the basename is the full 
name of the file, including the extension. For example, myfile.mpg.
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Action States
The action state describes the condition of an action execution in process and after 
completion.

During execution, an action s tate may be Queued | Paused | In Process | Waiting. These 
keywords display in the Job Status panel.

After execution, an action’s final state is assigned: Success | Ignore | Fail. These keywords 
may be tested by actions immediately following the target action, to determine 
whether or not the action should execute. Each action’s state is passed to the next 
action or actions in the workflow.

If an action fails, the next action inherits the Fail action state and (in most cases) will not 
execute—unless its Perform On state is set to Fail.

Some, but not all actions can be configured to set the Ignore state. The next action 
inherits the Ignore state and will likely not execute (unless it has been explicitly set to 
execute on Fail). Most actions, such as Message, can be configured to perform on 
certain states—this allows workflows to send an email if they detect a failure.

If an action receives states from two incoming actions (such as a merge of two 
branches), then states are given the following priority:

• If at least one incoming state is Fail, regardless of other incoming states, the action 
will inherit the Fail state—Fail has precedence over all action states.

• If there is no Fail state, but at least one Success state, then the action will inherit the 
Success state—Success has precedence over Ignore states.

• Only if all incoming states are Ignore, will the action will inherit the Ignore state. 

Ignore has lowest precedence of the three states.

Implementing Logic and Conditional Execution in 
Workflows

Many workflows consist of several actions connected in a single line—thus, each action 
is executed, in turn, for the entire workflow.

However, you may want to create workflows that are intelligent and flexible, so that 
they can successfully process media files with complex output requirements 
automatically: Workflows that can collect information about the media or the file itself 
at runtime, and store that information in variables. Then, you can add a Decide action 
to examine the values in the variable or variables, and pass control to one branch or the 
other, based on the value.

Generally, controlling the logical flow of media in a workflow is achieved by three 
things: adding variables and assigning them values, using a Decide action to evaluate 
variables, then setting an action state for each branch that follows the Decide action, so 
that only the appropriate branch executes for each job.
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Branching workflows are scalable: you can add as many decide actions and branches as 
you need, to further refine your execution choices.

Figure 102. Use Decide Actions to Implement Execution Branching Logic.

In this example, some metrics about the input file are being examined by the Watch 
action—file modification date, for example. The Decide action determines if the date is 
prior to or later than a given date, and sets Success or Fail, based on the answer. 

The top branch’s Flip action only executes on Success (processing those files whose 
modification date is prior to the test date), and the lower branch’s Flip action only 
executes on Fail (processing those files whose modification date is later than the test 
date).
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Managing Vantage Folder Addresses
Vantage Folders are similar to addresses, which you create (and name) to identify 
specific paths you use frequently. Vantage Folders simplify directory referencing by 
allowing you to specify a long, complex path by a simple name. They also allow you to 
update a path or credentials once, and automatically update all actions using that 
Vantage Folder.

For example, you might have a folder on a given server for HD MPEG2 content: 
\\voyager\SunupCampaign\Darwin\WaitingApproval\HDMPEG2. You can create a 
Vantage folder in the address book for this path, and name it SunupHDWaitingApproval.   
If you need to change the path or any password associated with the address later, you 
can simply change it in the address book and all actions will automatically be updated.

Telestream recommends using UNC paths instead of drive letter paths, and it is 
required in distributed domains. For a detailed discussion, see Understanding Path 
Specifications for Vantage Storage.

Now when you create a workflow that generates media you want saved in this folder 
path, you simply select SunupHDWaitingApproval in the Flip action’s inspector.

You can create folder addresses in both the Management Console and in Workflow 
Designer.

In Designer, click on the Browse button to the right of any location field that accepts 
folder addresses. Vantage displays the Vantage Folder Address Book.

Figure 103. Vantage Folder Address Book.

1. Click the Add Folder toolbar icon (the new folder icon at far left).
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Figure 104. Add New Folder Dialog.

2. Name—Enter the folder address name.

3. Description—Optionally, enter a descriptive phrase.

4. Location—Click Modify to display the Folder Location Editor.

5. Select a file system and click Next.

6. Click Browse to navigate and select the directory that this Vantage folder address 
should reference. Or, enter the fully-qualified path manually, preferably in UNC 
form (be sure to only use drive letters when the domain is a single machine.). When 
manually entering a fully-qualified path, the text displays in red if it does not 
conform to the proper convention for the supported file system.
For a detailed discussion, see Understanding Path Specifications for Vantage Storage.

7. Click Finish to close the Folder Location Editor dialog. (You may have to click OK on 
the local folder warning dialog.)

8. Click OK to add this new Vantage folder address to the domain and close the Add 
New Folder dialog.

9. Collision Resolution—Select Create Unique Name | Overwrite | Set Failure State to 
specify what Workflow Designer should do when a file of the same name already 
exists in this location.

– Create Unique Name—Workflow Designer adds a suffix to the filename, making it 
unique, then saves the file in the location.

– OverWrite—Workflow Designer deletes the current file and saves the new file in 
the location.

– Set Failure State —Workflow Designer does not save the file; it sets the action 
state to Fail so that downstream actions may detect the error and perform a 
specified task under this condition.

10. Click Select to close the dialog and use the currently-selected folder address, and 
press OK to save changes. Click Close to simply close the Vantage Folder Address 
Book dialog with changes.
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Vantage Workflow Actions
This topic describes each action, by group. Some of these actions are only enabled by 
optional, licensed features.

 3rd Party Actions

 Agility Actions

 Analysis Actions

 Catalog Actions

 Common Actions

 Communicate Actions

 MediaMate Action

 Metadata Actions

 Monitor Actions

 Staging Actions

 Transcode Actions

 Multiscreen Actions

 Transport Actions

3rd Party Actions
Vantage enables 3rd party actions to be installed in Vantage. For details on configuring 
3rd party actions, see the inspector’s man page.

Agility Actions

Use Agility actions in workflows where you have an Agility ECS system and you want to 
submit jobs to it for processing. You can use Agility actions to create workflows, submit 
and monitor jobs, process MMF files, and control jobs during execution in Agility.

Agility actions are executed by the Agility service.

Note: Before you can use Agility actions, the Agility ECS must be identified in the 
Management Console: Settings & Options > Agility ECS.

 Job Profile Action

 Job XML Action

 Process MMF Action
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Job Profile Action
Use the Agility Job Profile action to obtain and display a list of Agility profiles from an 
Agility ECS (which must be configured in the Console, and available at design time), 
from which you can select and configure, to submit jobs.

Job XML Action
Use the Job XML action to submit the job described in the specified XML to the Agility 
system for processing. This is an alternative to Vantage-based configuration using the 
Job Profile action, and is intended for use primarily by Agility users with SDK 
implementations to generate XML-based job profiles for Agility execution.

Process MMF Action
Use the Process MMF action to process an attached MMF file in Agility, and generate 
variables from it.

Analysis Actions
Use these actions (executed by the Telestream Transcode & Analysis Engine on behalf 
of the Analysis service) in workflows when you want to perform measurements on 
media files, compare media files, or identify the characteristics of media files, and 
publish the results as variables or metadata labels, or set the state of the workflow 
based on the results.

You can publish analysis results in a metadata label within the binder, or you can 
publish results as variables so that they can be used for decision-making, or to feed 
parameters in other actions. In some cases, you can also set the action state of the 
action based on the results of the measurement.

 Examine Action

 Compare Action

 Identify Action

Examine Action
Use the Examine action to analyze the video and audio of a media file, by selecting a 
given analyzer (black detection, macroblocking analysis, slate detection, etc.).

Compare Action
Use the Compare action to examine two media files and determine their differences.

Identify Action
Use the Identify action to extract the properties of a media or attachment file (for 
example, file name, extension, size, or path) or to generate an MD5 hash of a media or 
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attachment file, which you can use to compare two files downstream, or in other 
workflows.

You can also extract metadata from media files (for example, (such as Author or Title).

In addition, you can extract a comprehensive set of properties from media files (for 
example, frame size, frame rate, codec, bitrate, number of audio channels, etc.). 

Extracted values are assigned to variables (which you create in the Management 
Console ors directly in Workflow Designer), for use later in a workflow. You can also set 
the workflow state as a result of execution conditions.

Catalog Actions
Catalog actions are executed by the Catalog service. They allow you to register binders 
in a catalog, and query a catalog for existing binders.

 Register Action

 Exist Action

Register Action
The Register action registers the workflow binder in a Vantage catalog. This allows 
Vantage to preserve the binder—and all files referenced by it—even after a job expires. 
This is also how binders become accessible to operators in Vantage Workflow Portal. 
See online help in Vantage Management Console (Application Configurations) for more 
information about configuring the Vantage Workflow Portal.

Exist Action
Use the exist action to determine if a binder of the same name already exists, thus 
indicating that a job has already run on the same media file.

Common Actions
Common actions do not have a dedicated Vantage service to execute them. Instead, 
these actions are implemented in every Vantage service, so that any service available 
can execute them efficiently and instantaneously.

 Compute Action

 Construct Action

 Decide Action

 Forward Action

 Receive Action

 Synchronize Action
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Compute Action
A Compute action uses variables to set other variables. For example, you can use 
Compute to add two numbers and assign the result to the selected variable. Compute 
can perform mathematical operations such as addition, subtraction, division and 
multiplication. It can also convert variables between types (such as converting a time 
code to a string), string manipulation, such as appending strings together into an 
output variable, and comparison functions.

Construct Action
A Construct action is an action which enables you to construct complex strings, paths, 
and math expressions from literals, variables, and tokens, for use in downstream 
actions.

Decide Action
A Decide action is an action which sets the action state based upon variables. It is 
commonly used to determine whether or not a branch in a workflow should execute (it 
sets the Success state) or not (it sets the Ignore state).

Figure 105. Decide Actions Enable You to Branch Media Processing.

For example, if one branch is for HD, it will start with a Decide action that will set the 
state to Success for HD content, ignore otherwise; if another branch is for everything 
else, it will start with a Decide action that performs the opposite behavior.

Forward Action
A Forward action forwards a binder and all current variables to another workflow, 
which starts a new job for the target workflow. A Forward action may be added to the 
end of a workflow, and requires that the target workflow has a Receive action as its first 
action.

The Forward action is the only terminating action in Vantage—it does not have a 
connecting pin on the right side. Thus, once you add a Forward action to a workflow (or 
branch in a workflow), you can not add any more actions, because control has passed 
to another workflow with a Receive action as its origin action.
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Typically, workflows are created with a Receive action when they are intended for 
execution by another workflow that immediately precedes this one. This ability to chain 
workflows enables you to create run-time customizable workflows consisting of smaller 
workflow building blocks.

Receive Action
A Receive action is a special origin action, which provides a starting point for new jobs 
in Vantage workflows that are not started by a Watch or other origin action.

The Receive action is an optional, licensed feature for use with SDK-based applications, 
and Workflow Portal applications.

Typically, workflows are created with a Receive action when they are intended for 
execution by another workflow that immediately precedes this one. This ability to chain 
workflows enables you to create run-time customizable workflows consisting of smaller 
workflow building blocks.

For examples, jobs submitted by operators using Workflow Portal must have a Receive 
action.

Workflows that end with a Forward action are used to start Receive action-based 
workflows. When you chain workflows, you can pass binders and variables between 
them.

Note: An origin action is required as the first action in a workflow, even if you plan to 
manually submit jobs to this workflow.

Synchronize Action
The Synchronize action is used in workflows where multiple actions connect to 
multiple subsequent actions. Synchronize provides a common connection point, where 
all upstream actions need to be connected to all downstream actions.

Communicate Actions
Communicate actions are used to communicate with external systems. These actions 
are executed by the Communicate service.

 Message Action

 Notify Action

Message Action
A Message action is an action which enables you to generate and transmit an electronic 
message—an email, for example. You must configure Vantage to use an SMTP server 
before email can be utilized; this can be done in the Vantage Management Console.
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Notify Action
A Notify action is an action which saves job information to an XML file, invoke a 
command shell and pass data, or interface with an external system via Web Services.

MediaMate Action
The MediaMate action enables you to implement screen subtitling. This is an optional, 
licensed feature.

The MediaMate action is used to provide screen subtitling, by utilizing various 
subtitling systems from Screen.

Metadata Actions
Metadata actions are an optional, licensed feature available in certain Vantage editions. 
Metadata actions are executed by the Metadata service. They are used to convert 
between attachment files, metadata labels, and variables.

 Populate Action

 Transform Action

Populate Action
Populate actions transform data between variables, attachments, and metadata labels. 
Populate can also be used to obtain certain system-level information related to the 
current job and assign it to variables.

Transform Action
A transform action transforms data between XML files (attachments) and labels. XSL 
style sheets are used to perform these transformations.

Note: You can only use style sheets that have been implemented in the Vantage 
domain database—you can’t select an XSL style sheet from a file system. You manage 
your XSL style sheets using the Vantage Management Console (Vantage Domain > 
Workflow Design Items > Style Sheets).

Monitor Actions
Monitor actions are all executed by the Monitor service, and are used to identify new 
files to be processed, and in the case of the Watch action (an origin action), start jobs for 
this workflow. 

 Watch Action

 Associate Action
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Watch Action
A Watch action is a special origin action, which uses the Monitor service to continually 
(and at regular periods) poll a target location (a directory, for example) on a device or 
file system (FTP, network folder, etc.) to discover new files. 

When a new file is discovered, the Watch action submits a job to the workflow which it 
is part of, for processing the file, typically a media file.

Note: An origin action is required as the first action in a workflow, even if you plan to 
manually submit jobs to this workflow.

Associate Action
An Associate action uses the Monitor service to continually (and at regular periods) poll 
a target location (a directory, for example) on a device or file system (FTP, network 
folder, etc.) to discover new files.   

Generally, the Associate action uses the file name of an existing media file or 
attachment as the basis for discovering new files; for example, if media file 
Vantage.mpg is currently in the workflow, then the Associate action may look for 
Vantage.scc. This behavior can be defined in the Associate action's inspector dialog.

Associate actions execute until the new file is discovered; subsequent actions do not 
execute until the file is found. When the new file is discovered, the Associate action 
makes the file available to other actions in the workflow.

Note: An origin action is required as the first action in a workflow, even if you plan to 
manually submit jobs to this workflow.

Staging Actions
The actions in the Staging service are responsible for file operations in preparation for 
moving files to other systems with special packaging requirements.

 Archive Action

 Gather Action

Archive Action
Use the Archive action to convert the selected input file to another format, usually in 
preparation for copying, moving, or deploying a file to a given system that has special 
file format requirements.
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Gather Action
Use the Gather action to collect one or more files from a specified server and directory 
(and optionally, its subfolders), and bring them into the workflow as attachments. Use 
of a file matching pattern allows you to select only certain types of files.

Transcode Actions
The Flip action is executed by the Transcode service (which in turn utilizes the 
Telestream Transcode & Analysis Engine).

Use the Flip action to create media of a new format, and save it as a file, using a 
prescribed codec profile. How you configure the encoder depends on the encoder you 
choose.

Multiscreen Actions
The Multiscreen Flip action is an optional, licensed transcode engine which enables you 
to package media in industry-standard adaptive rate formats. It is executed by the 
Multiscreen service (which in turn utilizes the Telestream Transcode & Analysis Engine, 
running on a Lightspeed server) and requires a Vantage Lightspeed server to execute.

Multiscreen Flip actions enable you to identify (and map) input tracks, perform optional 
transcoding, and package the output in industry-standard adaptive rate formats 
compatible with adaptive rate streaming workflows, such as Adobe HDS, Apple HLS, 
Microsoft HSS and others.

Transport Actions
Transport actions are executed by the Transport services, and perform file operations 
on selected files. 

 Copy Action

 Move Action

 Delete Action

 Deploy Action

Copy Action
Use the Copy action to duplicate a file from one directory to another directory on a 
given file system. The new file can be tracked by the workflow—that is, referenced in 
the Binder. As a result, the new file must be given a nickname.

Move Action
Use the Move action to replicate a file from one directory to another. This action deletes 
the original file. You can optionally change its nickname during the move.
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Delete Action
Use the Delete action to delete a file on the specified file system. This action also 
removes the file reference from the binder.

Deploy Action
The Deploy action copies one or more files to a destination in a single step, and may 
perform additional custom steps depending upon the type of deployment.

Deployed files are not referenced in the binder, and are not tracked after the action 
completes.
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Using Monitors
Use this chapter to learn how to manage monitors.

 Using the Monitor Status Panel

 Using the Toolbar

 Viewing Origin Action Details

Note: Features in editions for which you don’t have a license are disabled, and 
indicate that you need a license to use them.
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Using the Monitor Status Panel
Click the Monitor Status panel (or click File > Monitor Status) to review the status of 
Watch (and other active origin) actions for the workflow you’ve selected in the 
Workflows panel.

Figure 106. Monitor Status Displays Watch & Other Origin Actions.

Click any column to make it the primary column and sort it ascending or descending.

Using the Toolbar
Groups—Click to organize actions by group, based on the primary column—the one 
you have selected. Click again to turn grouping off. For example, if you select State as 
the primary field in the table and display Groups, Designer sorts the entries by state: In 
Process, and Complete.

Delete—Click to delete the selected historical origin action row(s). Or, right-click on the 
row, and select Delete. You can only delete rows whose origin actions are complete—
that is, the session has ended because the workflow was deactivated.

Status—Click to display the selected workflow’s origin action details. Or, right-click and 
select View Status.

Viewing Origin Action Details
The Monitor panel table displays information about the monitor task—the origin 
action—for the workflow you select in the Workflows panel. 

Click any column to make it the primary column and sort it ascending or descending.

When displayed in groups, click the Down arrow on the table entry to display the origin 
action rows in this group (In Process, or Complete, for example).

Double-click the row (or click the Status icon in the toolbar) to display more details 
about the Origin action for the selected workflow.

Each row is an active origin action, indicating status and other details.

Monitor Status toolbar—Group | Delete | Details.
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Completed Origin Actions—For an origin action that has completed (Success | Ignore | 
Failure), this dialog displays the current status details for the action. 

Figure 107. Origin Action Status Details.

Export—Click to export these details for transmission to Telestream Customer Service 
to aid in support.

Session Log—Select a Session item in the tree and click Session log to display the 
Session log window.

Figure 108. Session Log.

The session log displays session activity entries, if any, including which variables have 
been provided to each action. This information can be helpful when debugging the use 
of variable, or when working on an issue with Telestream Customer Service.

In Process Origin Actions—If the action is active (Queued | Paused | In Process | Waiting), 
this dialog displays with a progress bar and the path of the target directory, plus the last 
status.
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Figure 109. Active Monitor Action Status Details.

Click Done to close the window.
Vantage User’s Guide



137
Managing Jobs
Use this topic to learn how to monitor jobs and manage them.

 Using the Job Status & Domain Job Status Panels

 Submitting Jobs Manually

 Creating Job Reports

 Viewing Binders

 Pausing and Resuming Flip Actions

 Setting an Action’s Execution Priority

 Viewing Action Status

Note: Features in editions for which you don’t have a license are disabled, and 
indicate that you need a license to use them.
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Using the Job Status & Domain Job Status Panels
These two panels displays a list of jobs, and provide job details, at different levels in the 
domain. The only difference in the two tabs is the scope of jobs listed in the table.

– Click the Job Status tab (or click File > Job Status) to review all the jobs currently 
executing for the selected workflow, and to set priorities, view binders and 
associated files, and to pause and resume jobs in progress.

– Click the Domain Job Status tab (or click File > Domain Job Status) to review all 
the jobs currently executing and jobs that are complete but failed in the domain, 
and to pause and resume jobs in progress.

Figure 110. Job Status Displays All Jobs for the Selected Workflow.

If your workflow is deactivated, the table displays the jobs that are still executing or 
which completed prior to deactivating the workflow.

When an action is executing (displays a green border), a progress bar displays at the 
bottom of the action, indicating execution progress.

Each row is a job processed by the selected workflow, indicating 
status and other details.

Job Status toolbar—Group | Stop | Restart | Delete | Binder

Real-time view of transaction processing.
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Figure 111. During Execution, each Action Displays a Progress Bar.

 Viewing the Detailed Action View

 Using the Jobs Table Toolbar

 Using the Jobs Table

Viewing the Detailed Action View
To view actions in detailed action view, select View > Detailed Action View. In this view, 
each action displays its state, creation and update dates, and resource costs directly on 
the action.

Using the Jobs Table
Click any column in the Jobs table to make it the primary column and sort it ascending 
or descending.

Jobs display a color to indicate their state:

• Yellow—(Idle | Pending | Interrupted) an action is waiting to execute

• Green—(In Process) an action is currently executing

• Blue—(Complete) an action executed successfully

• Red—(Failed) this action has failed or an upstream action failed

• Black—(Ignored) this action was not executed due to Perform On state mismatch

• Light Gray—(Paused | Suspended) an action is paused or suspended

• Magenta—(Stopped by User) an action was stopped by a user

• Orange—(Waiting to Retry) an action failed, and is waiting to retry.

The progress bar indicates progress for this action.
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Using the Jobs Table Toolbar
The toolbar for the Jobs table displays icons for the following commands:

Groups—Click to organize the jobs by group, based on the primary column—the one 
you have selected. Click again to turn grouping off.

Stop—When processing, click to halt processing on this job. When you stop a job in 
process, each action for that job is notified to stop its own transaction. When all actions 
have been stopped, the job is considered complete, in a user-stopped state.

Restart—If a job was stopped or it failed, it can be re-started and will continue 
processing where it stopped. Actions that fail or are stopped by a user are re-executed. 
When you restart a job, it is started as a first-time job again. This affects the execution of 
retry rules.

Set Job Expiration—Click to modify the default expiration time for this job. Workflow 
Designer displays the Set Job Expiration dialog—specify a new expiration date and 
click OK.

Delete—Click to delete the selected job row(s). Or, right-click and select Delete.

Binder—Click to display the selected job’s binder. Or, right-click an action or the job row 
in the table, and select View Binder. For details, see Viewing Binders.

Job Report—To create a job report, select one or more jobs in the table, and click on the 
Job Report icon in the toolbar. For details, see Creating Job Reports.

Filter—Click to display only jobs that contain specific text in the job name. Enter the 
text to begin filtering displayed jobs. Delete the text (or just close the filter by clicking 
the filter icon) to display all jobs again.

Note: When you stop, restart, or delete a job with Agility actions in the workflow, 
Agility transactions and tasks are also stopped, restarted, or deleted.
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Submitting Jobs Manually
To submit a job directly to any active workflow directly from Workflow Designer, select 
the target workflow and click Submit Job.

Figure 112. Click Submit Job on the Selected Workflow.

Note: You can only submit jobs to active workflows.

Workflow Designer displays the Submit Job window:

Figure 113. Submit Job Window—Selecting the File System.

Select the type of file system where the input file is stored and click Next.
Vantage User’s Guide



Managing Jobs
Submitting Jobs Manually

142
Figure 114. Submit Job Window—Selecting the Media File.

Click Browse to navigate to the directory and select the file you want to submit, and 
click Next.

Figure 115. Using the Submit Job Window to Submit a Job.

Variables—Optionally, click Variables to manually add a variable with a static value to 
this job. For details, see Adding Variables to an Action.

Variables can be used by actions to control their behavior and workflow logic. 
(Variables are also used by services when configured with processing rules, to control 
which actions can be executed by a given service instance.) 

For example, you might be submitted an extremely long movie file for encoding—and 
you have a Transcode service on a dedicated server specifically for processing long 
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jobs. You add the appropriate variable and enter the predetermined value to route this 
action to this service.

Click Submit to submit the job for processing.

When you have submitted the job, you can view its progress in the Job Status panel 
(Using the Job Status & Domain Job Status Panels).
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Creating Job Reports

Workflow Designer creates Job Reports for the selected job or jobs as comma-
separated value (CSV) files. You can open these reports in spreadsheet programs and 
other programs that can display CSV files, or you can use the CSV files in other systems, 
such as databases or media asset management systems. 

Each job report is based on a job report format you select.

Note: If no job report formats exist in the domain, Workflow Designer displays a 
dialog indicating that you need to create one. Click OK to display the Job Report 
Manager, and create a job report format (Managing Job Report Formats).

Creating a Job Report
To create a comma-separated values job report, select one or more jobs in the table, 
then click on the Job Report icon in the toolbar. Workflow Designer displays the Create 
Job Report dialog.

Figure 116. Create Job Report Dialog.

Select a job report format from the list and click OK to continue.

Note: To manage job report formats, click the Browse icon (the ellipses icon to the 
right of the dropdown menu) to display the Job Report Manager dialog. For details, 
see Managing Job Report Formats. You can also manage job reports in the Vantage 
Management Console.

Vantage displays the File System dialog, which you can use to select the server and 
directory where you want the CSV report file for the selected job or jobs stored, as 
shown in the following figure.
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Figure 117. Selecting a Folder and Naming a Job Report Format File.

Optionally, enter a new name for the job report file (or append a date or other 
significant qualifier) and click Save to process the report and save the file with a .csv file 
extension. When the report file has been generated, Vantage displays a dialog to 
indicate where the file was saved. Click OK to close the dialog.

Managing Job Report Formats
Use the Job Report Manager dialog to create a new job report format, or to edit or 
delete an existing job report format. 

The following sections describe these tasks:

 Displaying the Job Report Manager Dialog

 Creating a New Job Report Format

 Including and Excluding the Header Row

 Choosing the Report Columns

 Duplicating a Job Report

 Deleting a Job Report

Displaying the Job Report Manager Dialog
To view the Job Report Manager dialog, follow these steps.

1. Display the Job Status or Domain Job Status panel.

2. Click the Job Report icon in the toolbar to display the Job Reports dialog.

3. Click the Browse icon (the ellipses icon to the right of the dropdown menu).

Workflow Designer displays the Create Job Report Manager dialog, shown below.
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Figure 118. Using the Job Report Manager to Configure Templates.

Creating a New Job Report Format
You can create job report formats in the Management Console and in Workflow 
Designer.

To create a new report format, do the following:

1. Click the Create report icon .

Workflow Designer adds a new report to the report list and selects it.

2. Enter a new name in the Name field.

3. Optionally, enter a report description in the Description field.

4. Click the Save icon .

Including and Excluding the Header Row
To include or exclude a header row in the job report, select the report and do the 
following:

1. Check the Add Header Row check box to include the header row, or clear the 
checkbox to exclude the header row.

2. Click the Save icon .

Toolbar icons:
Create | Delete | Save | Duplicate
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Choosing the Report Columns
You can configure reports to include or exclude the following columns:

• Job ID

• Job Name

• State

• Progress

• Started

• Updated

• Expires

• Workflow Name

• Additional columns for metadata label parameters

When you choose to display a column for a metadata label, the column displays the 
label value.

To define which columns appear in a report, select the report, and do the following:

1. Under Columns, check (display) or clear (hide) the checkboxes for the columns you 
want to display.

2. To add or delete columns for metadata labels, do the following:

a. Click the Add Column icon  to display the Select Label Parameters for Columns 
dialog.

b. In the Labels pane, select a label for which you want to display parameters.
c. In the Parameters pane, check the checkbox for any parameter you want to 

display, and clear the checkbox for any parameter you do not want to display.
To toggle the display of parameter by category, click the Category icon . One 
display state displays parameters with category headings; the other display them 
without category headings.

d. Repeat parameter label selection until all labels are properly selected.
e. Click OK.

3. To change the displayed order of parameter labels, select a label in the list and use 
the green up  and down arrow  icons to move the label in the list.

The top item in the list appears to the right of the columns listed in the Columns 
row, and to the left of all the other label columns. The last item in the list becomes 
the last column on the right.

4. Click the Save icon .

Duplicating a Job Report
When you duplicate a job report, a new report is created with a modified report name. 
All other configuration settings in the duplicate report match those in the original 
report.

To duplicate a job report, do the following:
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1. Select the report to duplicate.

2. Click the Duplicate icon .

3. In the Name text box, enter a name for the duplicate report.

4. In the Description text box, optionally enter a description for the duplicate report.

5. Click the Save icon .

Deleting a Job Report
To delete a job report, select the report and do the following:

1. Click the Delete icon .

2. When the confirmation dialog displays, click OK.
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Viewing Binders
The Binder window displays information about all files in this job, organized by 
nickname, metadata labels and tracks, and attachments, each in its own tab.

To view the binder for the selected job, click the Binder icon in the toolbar or right-click 
any action or the job row in the table, and select View Binder. Or, double-click the job 
row in the table.

Figure 119. Viewing Binder and Assets for the Selected Job.

Media Files Panel—Displays a list of files, including the file’s path, nickname, and 
filename. To the right is a WMV player control, where you can preview the selected 
content provided that it is in WMV format. For other media, press Play to attempt to 
play the file in an external viewer such as QuickTime Player, if one is available for the 
selected file’s format.

Metadata Labels Panel—Displays metadata labels in the binder, their parameters and 
values. You cannot edit values in this viewer.

Metadata Tracks Panel—Displays metadata tracks that exist in the entire binder.

Attachments Panel—Displays a list of attachment files, including each file’s path, 
nickname, and filename.

Click Done to close the Details window.
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Pausing and Resuming Flip Actions
You can pause and resume Flip actions in a job in progress.

To pause an action, right-click on the action and select Pause from the context menu. To 
resume a paused action, right-click on the job and select Resume from the context 
menu.

You can not pause actions in certain states or in certain workflows. For example, you 
can’t pause an action that is already paused, or an action that has failed. Also, you can’t 
resume an action downstream of another failed action, without restarting the first 
failed action, etc.

Pause for Priority in Flip Actions
Pause for Priority feature is an automatic feature of Flip actions.

If a given Transcode service is saturated (that is, it is performing a number of jobs equal 
to the number of configured sessions); then normally, Vantage will queue up the 
incoming job and wait for a slot to become available. For example, a Transcode service 
is configured to run 2 simultaneous jobs; it receives three jobs (A, B and C); jobs A and B 
begin execution (the service was idle prior to this) and job C is queued until either job A 
or B completes (at which point C will execute).

Pause for Priority comes into play if job C has a higher priority than job A or B. When job 
C has a higher priority that job A, then job A is paused and job C begins processing 
immediately. When Job C or Job B completes; then job A (which was previously paused) 
returns to processing.
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Setting an Action’s Execution Priority
You can modify the execution priority of actions in Wait | Pause | Running states.

Right-click and select Priority to display the Action Priority dialog:

Figure 120. Right-click and Select Priority to Set a New Action Priority.

Change the priority value and click OK to modify the priority of this action in this job.
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Viewing Action Status
To view details about the status of any action in a job, select the job in the table, then 
right-click the target action and select Status.

The Status/History window provides details about each aspect of the action’s 
execution, on a node-by-node basis. You can use this information to gather details 
about its execution, and when an action fails, you can use this information to determine 
why and correct the problem.

Workflow Designer displays the Status/History window:

Figure 121. Viewing the Action Status in the Status/History Window.

You can open or close each node in the tree in the top panel. Select a node to display 
details about the node in the bottom panel.

Export—Click Export to display a File System dialog, and save the status/history 
information as an XML file. You can send these files to Telestream for support issues, or 
export them for processing in other systems.

Session Log—To display a session log on a given node, select the session and click 
Session Log.

Click Done to dismiss the Status/History window.
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Using Workflow
Analytics
Use this chapter to learn how to analyze workflows and job history to identify problems 
and improve overall system performance.

 Understanding Workflow Analytics

 Using the Workflow Analytics Panel

 Performing Bottleneck Analysis

 Performing Execution Analysis

Note: Features in editions for which you don’t have a license are disabled, and 
indicate that you need a license to use them.
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Understanding Workflow Analytics

Workflow analytics is enabled in Vantage Enterprise Control and Master Control 
licenses.

Workflow analytics enables you to visually analyze workflows and job history to identify 
problems and improve overall system performance.

In Workflow Designer, workflow analytics enables you to view jobs (based on the job 
history currently in the domain database) on a case-by-case basis to:

• Identify performance bottlenecks by action in a workflow

• Analyze workflow execution as a result of decisions in a workflow

• Visualize the progress of multiple jobs submitted to a single workflow

• Rank workflows and actions, based on processing time consumption.

Note: Because workflows may be modified over time, jobs ran in the selected 
workflow prior to the last change are ignored.

Vantage administrators and personnel responsible for designing and implementing 
workflows can use this information to modify workflow design and improve Vantage 
domain performance and efficiency.

Note: In the Management Console, workflow analytics enables you to analyze 
workflows at the domain level. For details on using workflow analytics in the Vantage 
Management Console, click the Help icon in the toolbar to display the Vantage 
Domain Management Guide.

Workflow analytics automatically includes new jobs that are submitted, as appropriate, 
displaying them in the Jobs table and recalculating metrics.
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Using the Workflow Analytics Panel
Click the Workflow Analytics tab (or click File > Workflow Analytics), and select the 
workflow in the Workflows panel to view job history information, which helps 
administrators identify performance bottlenecks and optimize execution.

Figure 122. Workflow Analytics Panel Displays Workflow Execution History.

Click on any workflow category to select the workflow you want to analyze, and view all 
of the job history records in the Vantage database for the selected workflow.

After making your job selection (see below), click the Run Analysis button to begin near 
real-time display of the analytics data. To stop calculating and updating the data (or to 
change the jobs you want to analyze), click Stop Analysis.

 Using the Jobs Table Toolbar

 Using the Jobs Table

Using the Jobs Table Toolbar
The toolbar for the Jobs table displays icons for the following commands:

Groups—Click to organize the jobs by group, based on the primary column—the one 
you have selected. Click again to turn grouping off.

Filter—Click to display (and thus determine the set) only jobs that contain specific text 
in the job name. Enter the text to begin filtering displayed jobs. Delete the text to 
display all jobs again.

Actions display the average execution time, and stack rank time 
relatively by color—green (fastest) through red (slowest).

Jobs Table with toolbar Analysis Options
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Using the Jobs Table
Click any column in the Jobs table to make it the primary column and sort it ascending 
or descending.

When you first select a workflow, no jobs are selected, so all jobs are considered in 
calculating the metrics. Select any job or jobs (shift-click or control-click) to view the 
selected set’s analytic details.

To deselect all jobs and return the table to its original state, select one record, then 
control-click to deselect it.
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Performing Bottleneck Analysis
Select Bottleneck Analysis from the dropdown menu on the far right. Workflow 
Designer displays elapsed time for the selected records in the job history set.

In bottleneck analysis (which is enabled by default), you can identify the longest 
running actions in a workflow, based on color and time values.

Color values are applied to each action from green to red on a sliding scale, based on a 
comparison of the average of all selected job records. The shortest average execution 
time displays the darkest shade of green; the longest displays red. Those in between 
display color values through yellow-green, yellow (average), and orange.

Numeric values on each action display the average execution time of the actions which 
ran, based on the selected job records.

When performing bottleneck analysis, choose:

Include Waiting Time—Check to add wait time to execution time and display the 
combined total time for each action. Wait time includes time spent in a Waiting state 
and a Paused state. Uncheck to display only execution time.

Count Non-running Actions—Check to include the execution time (0 seconds) of actions 
that did not run, thus providing a weighted bottleneck analysis based on which 
branches in a workflow executed, based on decision actions. This allows you to focus 
upon the actions which are bottlenecks in real-world operations. 

Uncheck to disregard non-running actions when calculating the execution time. This 
allows you to find the most expensive actions, regardless of whether or not they are 
commonly run.
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Performing Execution Analysis
Select Execution Analysis from the dropdown menu on the far right. Workflow Designer 
displays percentile and numeric values for the selected records in the job history set.

In execution analysis, you can determine which percentage and number of actions 
executed, based on the selected job history set, based on color and percentile values.

Color values are applied to each action from black to green on a sliding scale. The 
lowest average execution displays the darkest shade of black; the highest displays 
green.

Darker actions are those that have not executed yet (near zero percent). Dark green 
actions are average (near 50 percent), and the highest percentile executing actions are 
bright green (approaching 100 percent). 

For each action, the percent of executions completed is calculated against the total 
number of jobs, based on your selected job criteria.

When using execution analysis, choose your job criteria:

All Jobs | Only Completed Jobs | Only Successful Jobs—Select to include all selected jobs 
regardless of their status, only completed jobs (thus excluding running or partially 
completed jobs), or only successful jobs in the calculations.
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Using Workflow Portal
This chapter is intended for operators who are using Workflow Portal for browsing 
video media assets, entering metadata, creating EDLs, and processing media via pre-
defined workflows. Workflow Portal is an optional, licensed feature in Vantage.

In addition to the Workflow Portal program for Windows, Vantage offers a Workflow 
Portal Web app, for those who want the functionality of Workflow Portal without 
installing a Windows program, or who want to run Workflow Portal on Mac OSX or 
Windows in a Web browser via LAN or Internet.

Many topics are general, and apply to both versions of Workflow Portal (with 
exceptions noted); some apply to only one version, and are identified as such.

Note: For information on starting and stopping Workflow Portal, Vantage Web app 
requirements, starting and stopping Web apps, plus changing domains, user names 
and passwords, and other basic topics, see Vantage Client Programs & Web App Basics.

 About Vantage Workflow Portal

 Understanding How Workflow Portal Works

 Understanding Workflow Portal Configurations

 Browsing and Submitting Assets in Catalogs

 Stitching Assets in Vantage Catalogs

 Editing Metadata in the Submit Jobs Window

 Browsing Windows File Systems for Files

 Troubleshooting Workflow Portal

Note: When using Workflow Portal on Windows Server 2008, you might have 
problems minimizing windows you’ve maximized by dragging them to the top of your 
monitor. To disable the AeroSnap feature, open Control Panel > Ease of Access Center > 
Change how your mouse works, and check Prevent windows from being automatically 
arranged when moved to the edge of the screen.
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About Vantage Workflow Portal
Video operations frequently require some form of operator interaction as media is 
processed through a series of workflows. Common operator tasks include metadata 
entry, review and approval, content routing, simple tagging or video stitching.

Operators use Workflow Portal in a given configuration, to select media, perform their 
tasks, and submit jobs to appropriate workflows for processing.

Some example operator tasks include:

• Highlight Extraction From Archive Files—The operator marks in & out timecodes on 
the timeline and chooses the timecode for a thumbnail.

• Promo Preparation—The operator marks the voice-over and graphics entry points 
on the timeline. Vantage automatically re-processes the promo for multiple mar-
kets, days, and languages based upon this simple input.

• Review and Approval—The operator reviews a proxy of the clip and either marks the 
clip as accepted or rejected. 

• VOD Distribution—The operator creates a playlist of clips and enters metadata. Vantage 
merges the clips into a single media file and transforms metadata for distribution.

Workflow Portal and the Workflow Portal Web app are user interface-configurable 
client applications, well-suited to the following types of tasks: 

• Browsing and searching media assets that are in process in a Vantage workflow

• Entering or editing metadata attached to those assets

• Update variables for use in workflows

• Selecting assets to forward to another Vantage workflow (or workflows)

• Workflow Portal only—Creating an Edit Decision List of assets to stitch together

• Marking in/out points on an asset’s timeline

• Reviewing and approving media assets

• Reviewing proxies and deleting assets that do not pass inspection

• Workflow Portal only—Browsing a Windows file system to submit to a workflow.

Note: The Workflow Portal Web app is limited to accessing media assets in the 
Vantage catalog, enter or edit metadata and update variables and submit jobs. The 
Workflow Portal Web app supports both Forward and Copy modes, which is described 
later in this chapter.You can not browse and submit jobs from Windows file systems or 
create and process EDLs for stitching.

Which functions you as an operator can perform in Workflow Portal depend upon the 
type of configuration you’re using, and how it has been configured. User interface 
configuration is performed in the Management Console, typically by a Vantage 
administrator. You select the appropriate configuration when you start Workflow 
Portal, for the work you plan to perform.
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Understanding How Workflow Portal Works
Workflow Portal is an optional, licensed Vantage client program. When you start 
Workflow Portal, if no license is available, it advises you, and operates in demo mode. 
When operating in demo mode, you can not submit jobs or edit metadata labels.

You can run multiple instances of Workflow Portal on one computer (and one license), 
so that you can use multiple configurations at the same time. For example, you may be 
reviewing and submitting assets in one, and setting trim points in another. 

User authentication is used to control user access to Workflow Portal configurations. 
Administrators can choose which Vantage users can utilize a specific configuration. 
Administrators can also make certain configurations available to everyone. User 
authentication is available with Team management, Enterprise Control and Master 
Control licenses.

Workflow Portal allows media processing managers to use the Vantage Management 
Console to design and deploy customized user interfaces to support operator 
performing metadata entry, content browsing, stitching, and job submission.

The illustration below depicts the Vantage administrator designing and implementing 
the workflows and configurations to use in Workflow Portal to implement specific 
media processing requirements in her organization. The illustration also depicts the 
operator using Workflow with a given configuration, to perform his daily tasks on 
incoming media.

Figure 123. How Vantage Workflow Portal is implemented.

You use the Vantage Management Console to specify the user interface and options 
(referred to as a configuration) to support the task that the operator will perform, and 
implement the back-end workflows that will process the media with operator input. 

Vantage administrators design operator 
workflows and Workflow Portal user 
interface configurations.

Operators browse and select media, enter metadata, 
and set workflow options to mark trim points, 
graphics insertion points, stitch media, choose 
delivery channels, perform Review & Approval, etc.
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Administrators Create Workflow Portal Configurations

Note: Administrators who are setting up a Workflow Portal configuration should refer 
to the topic Application Configuration in the Vantage Management Console guide.

Within a Vantage Workflow Portal configuration, administrators:

• Choose from the four basic configuration types, then determine which types of video 
stores and video categories the operator can browse

• Enable workflows (which the Vantage administrator has already created using 
Workflow Designer) to process the selected media and operator input

• Design and customize the operator task and save it as a configuration.

Vantage workflows can include decision-making rules which automatically respond to 
incoming metadata. For example, if an operator selects checkboxes indicating the 
choice of media distribution channel, the workflow uses those checkbox states during 
execution, to trigger the appropriate encoding and other actions.

Vantage also allows metadata fields to be fed directly into processing steps. For 
example, an operator might specify a timecode value used as a trim point; alternatively 
he/she might specify the location of a QuickTime file to be used as a bumper.

The administrator designs the operator metadata label in the Management Console, 
and then determines how the label fields map into the Vantage workflow—directly 
into encoding parameters, Web service calls, or other fields that allow data binding. 
This allows the administrator a great deal of flexibility in both workflow and operator 
task design, with the two working hand-in-hand to process media efficiently.

Administrators can also design their own metadata schemes, including how 
parameters are categorized and displayed to the operator. For example, you might 
have three checkboxes (one for each distribution channel), a string, a dropdown list of 
ratings, and two timecodes indicating the start and end of trim points. 

The administrator also builds a workflow around the metadata label, enabling the 
operator to drive downstream processing through simple data entry.

When Team Management is licensed and User Administration is enabled, 
configurations can be configured for access by specific Vantage users, thus limiting the 
configurations that operators can utilize.
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Customizable Operator Experience
Using customized data entry configurations, operators can:

• Mark timecode points on the video timeline—These points can then be used for 
clip trimming, stitching, graphics insertion or overlays, key frame generation, meta-
data file generation, and more.

• Select checkboxes—to indicate which parts of the workflow should run. This allows 
the operator to choose distribution channels, target customers, encoding profiles, 
application of bumpers/trailers, or the execution of any workflow branch.

• Enter text, numbers or selections from drop-downs—Text and numbers can be 
used for decision-making, feed character generation to burn text directly into the 
video, file naming, or as input for virtually any text- or number-based workflow 
parameter.

• Browse for files—to be used as overlays, as bumpers or trailers, as caption files, sub-
title files, as metadata input, and more.
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Understanding Workflow Portal Configurations
There are three types of Workflow Portal configurations you can create. Each 
configuration can be customized in the Management Console and saved with an 
application-specific name, so that they can be chosen for use when an operator starts 
Workflow Portal.

Each type is intended to support a specific application, with appropriate user interface 
options that can be enabled or disabled, so that you can customize Workflow Portal to 
facilitate the organization’s workflow patterns and media processing requirements.

 Browse Catalogs (Copy/Forward Binder) Configurations

 Creating EDLs from Catalogs Configuration

 Browse Windows Network (Create Binder) Configuration

Browse Catalogs (Copy/Forward Binder) Configurations
This topic applies to both Workflow Portal and the Workflow Portal Web app.

Note: The Workflow Portal Web app enables operators to browse media assets from 
the Vantage catalog, enter metadata, and submit jobs to predefined workflows.

In both Browsing Catalogs configurations, a user selects a binder from a Vantage 
catalog as the media to submit to a workflow. In Copy Binder mode, Workflow Portal 
makes a copy of the binder and submits the copy without modifying the original 
binder. In Forward Binder mode, Workflow Portal submits the binder you selected, 
without making a copy, optionally removing it from the catalog.

Workflow Portal allows you to view binders in the catalog in two different ways. 

• Thumbnail view displays an image thumbnail for each binder.

• List view display a list of assets, including columns containing asset metadata.

Note: Thumbnail view is only available in the Workflow Portal for Windows, and is not 
available in the Web app.
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Figure 124. Typical Browse Catalog configuration.

There are several differences in the user interface between Copy Binder and Forward 
Binder modes:

• When forwarding, you can multi-select binders and submit them at the same time

• When forwarding, you can optionally edit metadata attached to the binder, in-
place, without submitting a job

• When creating a copy, any edits are only performed on the new, copied binder and 
will only be used during submission.

For details on using this configuration, see Browsing and Submitting Assets in Catalogs.

Browse Windows Network (Create Binder) Configuration

Note: This configuration is not available in the Workflow Portal Web app.

The Browse Windows Network configuration enables a user to select a media file from 
any location on the Windows network and submit it to either a specific workflow, or 
choose from among several workflows, depending on how the configuration is set up.

Unlike the other configurations, this configuration does not allow you to browse 
catalog binders, preview assets, editing metadata or variables, 
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Figure 125. Typical Browse Windows Network (Create Binder) Configuration.

This configuration is the equivalent of manually submitting a job in the Workflow 
Designer.

For details on using this configuration, see Browsing Windows File Systems for Files

Creating EDLs from Catalogs Configuration

Note: This configuration is not available in the Workflow Portal Web app.

In Stitching Assets configurations, you can browse and select multiple media files, mark 
in- and out-points, and submit them for clipping and merging into a single file.
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Figure 126. Workflow Portal Stitch Assets Configuration.

You create an EDL using the media from the specified catalogs and submit it to 
workflows. You specify Mark In and Mark Out points for each clip so that only the 
specified portion of the clip is used. All clips in an EDL must have the same width, 
height, frame rate, and sample rate. 

For details on using this configuration, see Stitching Assets in Vantage Catalogs.
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Browsing and Submitting Assets in Catalogs
You use a Browse Catalog configuration (either in a Copy Binder or Forward binder 
Workflow Portal configuration) to browse and select assets and submit them for 
processing. You may optionally be allowed to enter or edit metadata, depending upon 
how the administrator has configured your Portal.

You can navigate through all the fields and controls by repeatedly pressing the Tab key. 
Use the Shift + Tab key combination to move through the fields in reverse order.

Figure 127. Browsing Assets in a Catalog.

Selecting a Catalog
Vantage organizes media assets in catalogs. Each catalog may be further organized by 
folders. In the top-left pane, you have access to one or more catalogs, which you can 
browse to find assets. (The catalogs you can browse are those enabled in the 
configuration you’re using.)

For each asset (media file) in a Vantage catalog, Vantage creates a binder. A binder is 
simply a folder of sorts, which is used to contain all of the relevant information about 
the asset in a single place. Relevant information includes the path to the primary media 
file, and optionally, other versions, such as the original file, proxies, and attachment files 
that are important to this version of the media. In addition, there may be metadata, 
keyframes, thumbnails, etc. in the binder as well. 
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Note: You only have the ability to select a catalog if the administrator gives you 
permission. However, you can always select assets.

To view a catalog’s assets, select it. The selected catalog displays its folders as well, so 
you can drill down into catalog folders to narrow your browsing and searching.

Searching and Selecting Assets
Workflow Portal displays thumbnails of its assets in the preview window. Click on an 
asset to select it, and the preview updates automatically.

Note: The Workflow Portal Web app does not automatically update the assets list as 
new assets arrive in catalogs. Depending upon your task, you may need to periodically 
use the refresh button to view new assets as they arrive.

You can also search for assets by name. Click the Filter button to display a text field. 
Enter the text (or text substring) to only display media whose name contains the text 
you entered. Workflow Portal remembers these text strings, and you can select them to 
restrict your searches.

Previewing Proxies
In the bottom of the window, if you’ve created a proxy in this workflow, you can view a 
preview of the asset. 

Creating Proxy Files
Workflow Portal for Windows supports QuickTime H.264 MOV as the default proxy 
format.

When creating proxy files in a Flip action, you can’t assign the nickname Vantage Proxy 
if you don’t use a valid format. You should always assign the reserved nickname 
Vantage Proxy to your proxy files so that Workflow Portal can properly identify the file as 
a proxy.

In order to utilize the Use Clip Start Time feature, the proxy file must be created in 
Vantage using the QuickTime encoder and registered (using the Register action) in a 
catalog in the same workflow (it cannot be copied (using the Copy action) to the 
catalog). The encoder must be configured to generate a Timecode Track (under 
container settings).

Note: Telestream strongly recommends that you use QuickTime H.264 MOV as the 
proxy format in both Workflow Portal for Windows and the Workflow Portal Web app. 
Telestream does not recommend the use of WMV files as proxies; but for those users 
who have an archive of WMV proxy files; the Web app does provide the ability to view/
playback these proxy files.
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Conducting Previews in Workflow Portal
When you preview assets using proxy files in Workflow Portal, you are utilizing the 
QuickTime Player, to preview QuickTime H.264 MOV files.

You can use the preview controls to play, pause, rewind, and jump to points in the video 
timeline (using the slider). If your computer has speakers, you can also hear the audio in 
the media, and you can adjust volume using the volume slider.

The following keyboard hotkey assignments support player control:

• Ctrl+P or Ctrl+Space—toggle the Play/Pause button

• Ctrl+S—Stop

• Ctrl+F—Forward Frame

• Ctrl+R—Reverse Frame

• Ctrl+Home—Go to start

• Ctrl+End—Go to end.

The following mouse wheel assignments support player control:

• Mouse Wheel + Ctrl—one frame per wheel click

• Mouse Wheel (no modifier keys)—one second per wheel click

• Mouse Wheel + Shift—one minute per wheel click

• Mouse Wheel + Ctrl +Shift—one hour per wheel click.

Conducting Previews in the Workflow Portal Web App
When you preview assets using proxy files in the Workflow Portal Web app, you are 
utilizing the Silverlight Player to preview QuickTime H.264 MOV files and (although not 
recommended), WMV files.

You can use the preview controls to play, pause, rewind, and jump to points in the video 
timeline (using the slider). If your computer has speakers, you can also hear the audio in 
the media, and you can adjust volume using the volume slider.

Note: The Silverlight player, which is utilized in the Workflow Portal Web app, has a 
known issue related to playback behavior when attempting to jog/shuttle/seek to the 
end of a media file.
The issue manifests itself as the inability to scrub or mark at the very end of the proxy 
file being manipulated. The effects can be mitigated by scrubbing to a point just 
before the end (not less than 1% or 1 second from the end) and then playing the video 
for the remainder of the sequence. Play to the end functionality works correctly.
For reference, see the Web page https://connect.microsoft.com/VisualStudio/
feedback/details/714100/mediaelement-stops-playing-before-end.

The following keyboard hotkey assignments support Silverlight Player control:

• I—forward frame step. (Arrows work, but skip several frames at a time)
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• O—backward frame step. (Arrows work, but skip several frames at a time)

• Home—jump to start

• End—jump to end

• P—play/pause

• F—toggle full screen

• J and K—volume up/down

• M—mute audio.

Reviewing and Editing Metadata
If your administrator has enabled Metadata Labels in this configuration, Workflow 
Portal displays a Metadata Labels tab, which displays each of the metadata labels in the 
asset, and their values. 

Click on the Metadata Labels tab to review—and depending on your configuration, 
add or edit—the metadata associated with this asset. When you save your changes, the 
metadata is updated in the binder, in the Vantage catalog stored in the Vantage 
domain database.

Forwarding Assets to Workflows
Select Submit to forward the asset for processing. If enabled, you may also select the 
Forward to Workflows tab to choose which workflows you want to send this media to 
for processing. Some choices may be optional. You can check each workflow’s 
checkbox to specify which workflows should process the asset. Click Submit to send 
media to the specified workflows for processing. Vantage creates jobs for each 
workflow.

Depending upon your configuration, after you submit the media, you may be allowed 
to add and edit variables or metadata in the Submit Jobs window. See Editing Metadata 
in the Submit Jobs Window for more information.

Deleting Assets from a Catalog
If enabled in a configuration, you can select an asset and delete its binder.
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Figure 128. Deleting Assets (Binders) from a Catalog.

For example, you might have an operator reviewing low-res proxies in a given catalog. 
If a proxy fails to meet quality for any reason, you can delete the binder registered by 
the job that created the proxy.

To delete an asset’s binder, do the following

1. Open the catalog where the binder is located.

2. Select the asset (binder) from the list.

3. Click the red X icon at the top of the list to permanently remove the binder from the 
catalog. Removing the binder does not delete media files that are referenced in the 
binder.

When enabled in a Workflow Portal configuration, 
you can delete a binder from a catalog.
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Stitching Assets in Vantage Catalogs
Note: This configuration is not available in the Workflow Portal Web app.

When you are using a configuration that enables asset stitching workflows, you can see 
them visually as indicated in the following figure.

Figure 129. Configuring EDLs to Stitch Assets Into a Single File.

Selecting a Catalog
Vantage organizes registered media in catalogs. Each catalog is further organized by 
folders. In the top-left pane, you may have access to one or more of these catalogs, 
which you can browse to find assets. (The catalogs you can browse are those assigned 
to the configuration you’re using.)

To view a catalog’s assets, select it. The selected catalog displays its folders as well, so 
you can drill down into catalog folders to narrow your browsing and searching.

Open Containing 
Folder icon 

Open With Default 
Program icon

Mark buttons

Go to buttons
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Searching and Selecting Assets
When you select a catalog (and optionally a folder), Workflow Portal displays 
thumbnails of its assets in the preview window to the right of the Catalogs list. Click on 
an asset to select it.

You can also search within the selected catalog or folder for assets by name. Click the 
Filter button to display a text field. Enter the text (or text substring) to only display 
media whose name contains the text you entered. Workflow Portal remembers these 
text strings, and you can select them to restrict your searches.

Adding Assets to the EDL
When you select an asset, you can click the Plus (+) button to add it to the EDL. This list 
contains the list of files that are to be clipped and merged together into a single output 
file when you submit them to a Vantage Workflow.

Note: An EDL must be comprised of media file clips that have the same frame size 
and frame rate.

When you select the first asset in the EDL, the frame size and rate of the EDL are 
determined from the metrics of this file. All assets in the catalog are automatically 
filtered to only display those that match the frame size and rate of the first selected file.

Modifying the EDL
Select any asset in the EDL to perform these tasks:

• Specify the mark in/out points for the asset

• Remove the asset from the EDL

• Change the order of the asset in the EDL—moving it up or down the list—by click-
ing the Move Selected Clip... buttons.

Setting Mark In/Out Points
Each entry (asset) in the EDL has a mark-in and mark-out point. You can specify these 
manually, or you can use Preview (bottom left) to select a point on the slider and use 
the Mark button to set the mark in and mark out point.

You can also enter a duration timecode, which adjusts the Mark Out point relative to 
the Mark In point. This field only indicates the duration of the media between the mark 
in/out points of the currently selected asset in the EDL.

If you specify a duration that moves the Mark Out point beyond the end of the asset 
timeline, both the Duration and Mark Out fields display in red to indicate the error.

All Mark and Duration times can be changed by selecting a field (hour, minute, second, 
frame) and clicking the up or down arrow on the right.
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There are keyboard hotkey assignments for the Mark and Go to buttons. Once selected, 
these buttons can be activated by:

• Ctrl + M—activates selected Mark button

• Ctrl + G—activates selected Go to button
Vantage User’s Guide



Using Workflow Portal
Editing Metadata in the Submit Jobs Window

176
Editing Metadata in the Submit Jobs Window
Depending upon the configuration you’re using, you may be entering metadata in the 
Submit Jobs window depicted below, or you may be entering metadata for the 
selected asset directly in the main window during your browse activities.

Figure 130. Editing Metadata in the Submit Jobs Window.

In either case, if a preview is available you can use it to review the media. If your 
metadata includes time code values, you can also use Preview with the metadata as 
follows: 

• The Mark button sets the metadata timecode to the current point on the preview 
timeline

• The Go to button moves the preview slider to the time code indicated by the meta-
data value.

Depending upon the configuration in the Submit Jobs window, you may be able to 
submit the same clip multiple times. For example, if you are extracting multiple 
highlights from a single media asset, you can mark a highlight, select Submit, and then 
mark a new highlight without affecting the first one.
Vantage User’s Guide



Using Workflow Portal
Browsing Windows File Systems for Files

177
Browsing Windows File Systems for Files
Note: This configuration is not available in the Workflow Portal Web app.

The Browse Windows Directories configuration displays a simple select-and-submit 
interface, as shown in the following figure.

Figure 131. Browsing Windows and Selecting Workflows.

The Browse Windows Network configuration allows you to select files from Windows 
directories, review/edit metadata and variables, and submit jobs.

Browsing for Files
To identify the file or files you want to submit, click Browse to display the Windows file 
system explorer dialog.
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Figure 132. Navigating and Selecting Media to Submit.

Navigate to a location and choose which media file or files to submit. To select multiple 
files in a given directory, either shift-click or control-click to select them, then click 
Open to add them to the Files list in Workflow Portal, as illustrated above.

You can repeat the selection process to select files from multiple directories. The 
Browse button is additive—that is, each time you repeat the process of navigating to a 
location and choosing a file or files to submit, they are added to the Files list. 

If the file list is not correct, you can edit the list manually. For example, you can select a 
given file path and delete it. Or, you can edit a path or filename, copy and paste file 
paths, or add new ones. To delete the list entirely, click Clear.

Selecting Workflows
In the Submit to Workflows panel, check which workflows you want to process the 
media files. Some workflows may be optional—you can check each workflow’s 
checkbox to specify which workflows should process the asset. Click Submit to send the 
media to the specified workflows for processing. Vantage creates a job for each 
workflow.

Entering Metadata and Variables
Depending upon your configuration, after you click Submit, you may be allowed to 
review or update metadata and/or variables in the Submit Jobs window. 

Using the Metadata Tab
Click the Metadata tab to review and add or edit the metadata labels in this 
configuration. The metadata is applied to all media files that are being submitted.
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Figure 133. Entering Metadata in the Submit Jobs Window.

Select the label to displays its parameters in the details panel to the right. Add or 
modify the values as appropriate.

Using the Variables Tab
Click the Variables tab to review and add or edit the variables in this configuration. The 
variables are available to the workflow in each job that is submitted.

Figure 134. Entering Variables in the Submit Jobs Window.

Add or modify the values as appropriate.

Submitting the Jobs
Click Submit when you’re done reviewing and editing metadata and/or variables. 

Figure 135. Job Submitted Dialog.

For each media file in the list, a job is submitted. Click OK to dismiss the advisory dialog.
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Troubleshooting Workflow Portal
When opening Workflow Portal for the first time, depending on the design of your 
network and the location of your workstation and Vantage server, the Domain login 
dialog may not display the domain. If this is the case, you can log in by using the name 
or IP address of the server.

When you change domains or configurations, you may also encounter these problems:

• No Configurations Available...

Workflow Portal displays this error when you log onto a domain where no Workflow 
Portal configurations are stored. Workflow Portal can’t display a user interface with-
out use of a configuration, so the domain must have at least one configuration for 
Workflow Portal to use.

Create or import one or more configurations in this domain, using the Vantage 
Management Console. Then, log on and select one.

• No session licenses available for this application...

The domain you logged on to is not licensed for running Workflow Portal or you 
have exceeded the maximum number of licenses. Therefore, you are operating in 
unlicensed/demo mode, and you won’t be able to submit jobs or edit metadata 
labels.

Obtain an adequate number of Workflow Portal licenses from Telestream Customer 
Service, wait until another Workflow Portal has exited, or increase the number of 
licenses for Workflow Portal, and retry.

Note: An administrator can release a license in the Vantage Management Console.

• Problem communicating with database—could not find stored procedure Select-
SessionsByExecution...

This error displays when Workflow Portal is attempting to display a list of configura-
tions from the selected domain, but the version of the domain is not compatible 
with your client. Contact your Vantage Administrator to upgrade your Workflow 
Portal software.

• The requested workflows are either not running or no longer exist...

This error displays when you submit an asset or media file to a workflow that has 
been deleted, or is not activated. Contact your Vantage administrator, who can acti-
vate the Vantage workflow or edit the configuration to correct the problem.
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Using the Job Status
Views Web App
Job Status Views is a Web app implemented on an IIS server, that enables basic Vantage 
job management via a Web browser. You can use Job Status Views to access job 
information and manage jobs in your Vantage domain from anywhere on the LAN, or 
via the Internet when you establish a VPN connection.

Note: For information about Vantage Web app requirements, starting and stopping 
Web apps and other basic topics, see Vantage Client Programs & Web App Basics.

This chapter presents the following topics:

 About the Job Status Web App

 Job Status Views Web App Overview

 Displaying and Hiding the Title Panel and View Panels

 Using Public and Private Views

 Sorting Jobs by Column

 Paging Through Job Tables & Setting Page Size

 Filtering the Job Table

 Highlighting Job States Row by Row

 Managing Jobs

 Troubleshooting

About the Job Status Web App
Vantage operators can use Job Status Views to do the following:

• Display information about jobs they’ve submitted

• Sort and filter job entries

• Highlight and identify jobs in different states

• Stop, restart, and delete jobs

• Troubleshoot job processing issues.
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Job Status Views also allows administrators to create custom views to control the job 
information Vantage users can view, and to enable or disable job control functions such 
as the ability to delete a job. Views may be public or private—for use only by specified 
Vantage users.

Job Status Views allows you to deliver only the required information for various types of 
Vantage users, more responsively and efficiently than when using the Vantage Web 
Dashboard. For complex installations and additional troubleshooting tools, use the 
Vantage Web Dashboard. For basic job management use Job Status Views.

Job Status Views Web App Overview
After logging in, the Job Status Views Web app displays the jobs table, as shown in 
Figure 136.

Figure 136. Job Status Job List.

The Job Status Views display is presented in three panels:

• Title panel—Displays the home button, Vantage domain and user name, and con-
trols to manage the user password, change domains, and to log out of the domain.

• View panel—Displays views, which define which jobs are listed in the job list. This 
panel also includes controls to display program version information and this user 
guide.

Title 
panel

Views 
panel

Job list 
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• Job list panel—Displays the job list in table format, along with the program’s tool-
bar, which contain command buttons and menus.

Note: If you don’t log in with a Vantage username, private views display None 
Available.

The following sections describe how to manage the program display.

 Displaying and Hiding the Title Panel and View Panels

 Using Public and Private Views

 Sorting Jobs by Column

 Paging Through Job Tables & Setting Page Size

 Filtering the Job Table

 Highlighting Job States Row by Row

Displaying and Hiding the Title Panel and View 
Panels

To display or hide the title or view panels, click the show/hide controls, as shown in 
Figure 136.

Using Public and Private Views
All views are defined either as public or private, and are created and configured in the 
Management Console. Click on the view to select it, and display jobs for this workflow. 
Only private views that are enabled for your Vantage user name are listed.

The default view is the All Workflows public view, which displays jobs for all workflows. 
The information that All Workflows displays depends on how it is configured in the 
Management Console, and whether it is enabled or not. If no private views have been 
defined, or if you log in as Public, the Private Views list displays None Available. 

The following topics provide more information on views:

 About Public and Private Views

 About View Definitions

About Public and Private Views
Public views are views that the Vantage Administrator has made available to all 
Vantage users. Anyone who connects to the Vantage domain can display public views 
in the Job Status Views Web app.

Private views are views that are available only to those Vantage users for which the 
Vantage administrator has enabled access. The administrator might configure custom 
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views for different departments, users by role, or customers, and limit access to those 
views to the appropriate users.

About View Definitions
All views that you create are based on a specific workflow. In addition to being public or 
private, views limit the information that is displayed and specify which job control 
features (if any) the user has to use. If no controls are enabled, the view is considered a 
read-only view. You cannot create or configure views directly in Job Status Views; views 
are created by the Vantage administrator, via the Vantage Management Console, and 
specified as public or private; enforced by which user logs in.

There are many options for views, and displaying all options usually provides too much 
information for most applications. For example, it might be more convenient to display 
fewer columns. This view might only display active jobs, and it might disable controls 
that allow jobs to be restarted, stopped, or deleted.

The following topics provide information on what can be customized (and thus, may or 
may not be present) in views

 Displaying Items in Views

 Controls in Views

Note: Administrators should refer to the Vantage Management Console & Systems 
Administration Guide for information on how to set up custom views.

Displaying Items in Views
Two items of information are always displayed as columns in a view:

• Job—The name of the workflow for each job.

• State—The current state of the job, which can be:

– Complete

– Failed

– In Process

– Paused

– Stopped by User

– Waiting

– Waiting to Retry

Four optional items of information can be added as columns in a view:

• Total Progress—The progress of the job (in percent) if still running.

• Started—The date and time the job was started.

• Updated—The date and time the job was last updated.

• Expires—The date and time when the job expires and will be deleted.
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Controls in Views
An administrator can configure the following controls in a view:

• Enable—Enables or disables use of the view.

• Show Only Active Jobs—Displays only active jobs.

• Read Only Access—Disables the use of the stop, restart, and delete controls for 
managing jobs.

Sorting Jobs by Column
To sort the displayed job list according to the entries in any column, click that column 
label. Each time you click the column label, the sort changes in the following sequence: 
ascending order, descending order, and default sort order.

Paging Through Job Tables & Setting Page Size
A job table may span multiple pages. Use the page size control at the bottom center of 
the job list to specify the number of jobs to display on a page.

The page controls on the bottom left allow you to change pages and jump to the first 
or last page of a job list. Figure 137 shows where the page controls appear in the job 
panel.

Figure 137. Job List, Showing Page Controls.

Filtering the Job Table
Job filters allow you dynamically control which jobs display in the job table. The default 
configuration displays all jobs specified in the view for the workflow. However, during 
troubleshooting, you might want to display only those jobs that are in a failure state. 
Other times, you might want to display only those jobs that are in progress.

Page controls Page size
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To display the Job List filters, click Show Filters in the toolbar. The filters are displayed 
directly below the columns in the job list table, as shown in Figure 138.

Figure 138. Job List, Showing Job Filters.

To hide filters, click Show Filters again.

Which jobs display in the job list is determined by all the filters working together to 
filter the list. If multiple filters are configured, the job list includes all jobs that meet the 
criteria of all configured filters.

 Setting the Job Name Filter

 Setting the Job State Filter

 Setting the Total Progress Filter

 Setting the Date and Time Filters

Setting the Job Name Filter
You can use the job name filter to limit the job list display to only those jobs with a 
name that meet criteria you specify. The following sections describe how to set and 
clear the job name filter:

 Specifying a Job Name Filter

 Clearing the Job Name Filter

Specifying a Job Name Filter
To specify a job name filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. In the text box above the job names, enter text that is part of job names that you 
want to include or exclude from the list.
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3. Click the control to the right of the filter text box and select one of the following 
filters:

– Contains. Displays all jobs that have a name that contains the text you specified.

– DoesNotContain. Displays all jobs except those that have a name that contains 
the text you specified.

– EqualTo. Displays only those jobs that have names that exactly match the text 
you specified.

– NotEqualTo. Displays all jobs except those that have a name that exactly matches 
the text you specified.

Clearing the Job Name Filter
To clear a job name filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. Click the control to the right of the filter text box and select No Filter.

Setting the Job State Filter
The job state filter allows you to selectively exclude jobs from the job list based on the 
job state. The default configuration displays jobs for all of the following job states:

• Complete

• Failed

• In Process

• Stopped By User

• Waiting

• Waiting to Retry

When the job state filter is set to display jobs in all states, the filter name for the State 
column is All States. When the job state filters disable the display for jobs in one or more 
states, the filter name for the State column changes to Custom.

To specify a state filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. Click the control below the State column head and check and clear the checkboxes 
to define the states for which you want to display jobs.

Setting the Total Progress Filter
You can use the total progress filter to limit the job list display to only those jobs that 
meet progress criteria that you specify. The following topics describe how to set and 
clear the total progress filter:

 Specifying a Total Progress Filter

 Clearing the Total Progress Filter
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Specifying a Total Progress Filter
To specify a total progress filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. In the text box below the Total Progress column name, enter the progress level you 
want to include or exclude from the list. The range is 0% to 100%. 

3. Click the control to the right of the total progress text box and select one of the 
following filters:

– Contains. Displays all jobs for which the total progress includes the value you 
specified.

– DoesNotContain. Displays all jobs except those for which the total progress 
includes the value you specified.

– EqualTo. Displays only those jobs for which the total progress matches the value 
you specified.

– NotEqualTo. Displays all jobs except those for which the total progress matches 
the value you specified.

Clearing the Total Progress Filter
To clear a job name filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. Click the control to the right of the Total Progress text box and select NoFilter.

Setting the Date and Time Filters
The date and time filters allow you to limit the job display list to jobs that started, 
updated, or will expire within a specified time period. There are three separate date and 
time filters for:

• Started

• Updated

• Expires

The following topics describe how to set and clear the date and time filters:

 Specifying a Date and Time Filter

 Clearing a Date and Time Filter

Specifying a Date and Time Filter
To set any of the date and time filters, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. Click the control to the right of the filter label box in the appropriate column.

If the filter label box is empty, no filter is defined. If a filter is defined, the filter label 
box displays Custom.
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3. In the panel that appears, click on the calendar and clock icons to set the date and 
time for the period start and period end.

If you omit the period From date and time, the program displays all jobs up to the 
To date and time. If you omit the period To date and time, the program displays all 
jobs after the From date and time.

4. When the period is defined, click Apply.

Clearing a Date and Time Filter
To clear a date and time filter, do the following:

1. If the filters are not visible above the job list, click the Show Filters button.

2. Click the control to the right of the filter label box.

3. Click Clear.

Highlighting Job States Row by Row
Job state highlighting allows you to use colors to make the different job states more 
visible. Or, you can use the same color for all job states to draw less attention to the job 
states.

To toggle job state highlighting, click the Highlight State Rows button in the toolbar. 
Each time you click the button, the job state highlighting changes from the current 
state to the opposite state.

Managing Jobs
Job management, when enabled in a view, enables you to stop, restart, and delete jobs.

The following topics describe how to stop, restart, and delete jobs:

 Stopping Jobs

 Restarting Jobs

 Deleting Jobs

Stopping Jobs
You might want to stop a job to make Vantage resources available for another job, or 
you might stop a job in preparation for system maintenance. 

To stop a job, do one of the following:

• Right-click on a job in the job list, and select Stop.

• Select a job in the job list, then click the Options menu in the toolbar, and select 
Stop.
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Restarting Jobs
Jobs can be stopped by service or network interruptions, or an operator might stop a 
job to give another job priority. To restart a job, do one of the following:

• Right-click on a job in the job list, and select Restart.

• Select a job in the job list, then click the Options menu in the toolbar, and select 
Restart.

Deleting Jobs
You might want to delete a job because the job has failed, or because the output file is 
no longer needed, for example.

To delete a job, do the following:

• Right-click on a job in the job list and select Delete.

• Select a job in the job list, then click the Options menu in the toolbar, and select 
Delete.

Troubleshooting
Job Status Views enables troubleshooting and correction at the job level. For more 
comprehensive troubleshooting, use the Vantage Web Dashboard.

The first step in Vantage troubleshooting with Job Status Views is to identify the jobs 
that are having problems. There are several ways to do this:

• Enable Highlight State Rows to indicate job status with colors. Failed jobs are high-
lighted in red, and other states have distinct colors. (See Highlighting Job States Row 
by Row for more information.)

• Click the State column head to sort the jobs by the current state, then locate the 
group of jobs you want to investigate.

• Use filters to display only the jobs in the state you are investigating. (See Filtering 
the Job Table for more information.)

After you locate the jobs with issues, look for common traits among those jobs. The 
following are some possible issues and suggestions for resolution:

• All jobs are failed or waiting. Look for network, database, or service issues. If all jobs 
within a certain time period had problems, there might have been a temporary 
issue that has since been corrected. Restart failed jobs as described in Restarting 
Jobs.

• All jobs for a specific workflow have failed or are waiting. Look for issues with the 
workflow. Has the workflow ever worked? Are all resources used by that workflow 
available?
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• All jobs for a particular watch folder or destination have failed or are waiting. If you 
know that all the troubled jobs use the same watch folder or destination, it could 
be that the location is not available. 

After you resolve a problem, some jobs might restart on their own, and others might 
require further action from you. If your view is so enabled, you can take the following 
actions on jobs in the job list:

• Restart—Restart stopped jobs as described in Restarting Jobs.

• Delete—Delete jobs as described in Deleting Jobs.

• Stop—If a job seems unlikely to complete or stop, you can stop the job as 
described in Stopping Jobs. Once a job is stopped, you can try to restart the job or 
delete it.
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action

An action is the smallest unit of work that can be specified in a Vantage workflow. 
Actions are connected together in a workflow to perform a useful task. Each action 
must be configured to perform its task in the context of the workflow, using an action 
inspector. Action inspectors are specific to each type of action.

Actions are grouped by functional categories: communication, transcoding, file 
operations, metadata processing, etc. Each action is defined by the specific task they 
perform. For example, an email action, or a metadata label/file transformation action.

Actions have limited interdependency, and so, are very flexible. You may impose 
limitations on actions in a workflow. For example, you might require action B to depend 
on action A in a Vantage workflow.

Actions—during execution—operate on binders, variables, and states, and they 
generate an action state when they complete. Actions are executed by Vantage 
services, which perform the requirements of the action.

action state

The action state describes the condition of an action execution in process and after 
completion.

During execution, an action may be Queued | Paused | In Process | Waiting. After 
execution, an action's final state may be Success | Ignore | Fail. Certain actions (Decide/
Examine/Compare/Identify, for example) allow the use to specify the post-execution 
state, including Ignore. For all other actions, the post-execution state is set by the 
service, and is either Success or Fail. These states display in the Workflow Designer Job 
Status panel.

Action states are always passed to subsequent actions. The incoming state is tested by 
the next actions to determine whether or not following actions should execute.

Some actions allow you to specify that an action should execute on a specific state 
(right-click the action, and select Perform On > Success | Fail | Ignore | Any).

If an action fails, then the next action will inherit the Fail state and (in most cases) will 
not execute. If one action fails, the entire job fails.

Similarly, if you specify an action to set the Ignore state, the next action will inherit the 
Ignore state and will also likely not execute. Certain special actions, such as Message, 
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can be configured to perform on any state (Fail, for example)—this allows workflows to 
send an email if they detect a failure.

Action states have precedence when an action receives states from multiple incoming 
actions (a merge of multiple branches):

• If at least one incoming state is Fail, regardless of other incoming states, the action 
will inherit the Fail state—Fail has precedence over all action states.

• If there is no Fail state, but at least one Success state, then the action will inherit the 
Success state- Success has precedence over Ignore states.

• If all incoming states are Ignore, the action will inherit the Ignore state. Ignore has 
lowest precedence of the three states. If an action receives an Ignore state and does 
not explicitly fail, then it emits a Success state. Otherwise, it emits a Fail state unless 
it is an action which can emit Ignore, and you have configured it to do so.

Agility service

The Agility service is the Vantage component (operating as a Windows service) which 
executes the actions relating to Agility job submission and interaction with Agility: Job 
Profile, and Job XML. Agility features are enabled in Vantage Enterprise Master Control.

All-in-one domain

An All-in-One (single-server) Vantage domain is one in which ALL components of 
Vantage—the Microsoft SQL Server Express database, all Vantage services, and client 
programs—are installed and operate on a single computer.

Analysis service

The Analysis service is the Vantage component (operating as a Windows service) which 
executes the actions relating to the analysis of content: Examine, Compare, and 
Identify.

Archive action

An Archive action, which is executed by the Staging service, uses the selected archiver 
(TAR, for example) to convert the selected input file to another format, usually in 
preparation for copying, moving, or deploying a file to a given system that has special 
file format requirements.

Multiscreen Flip action

Multiscreen Flip actions are an optional, license feature. Multiscreen Flip actions are 
executed by the Multiscreen service which only runs on a Lightspeed sever, and 
implement the specified codec, which is used to encode and package decoded digital 
baseband media into adaptive rate streaming formats, including Adobe HDS, Apple 
HLS, Microsoft HSS, and others. Transcoding is performed by the Telestream Media 
Transcode and Analysis engine on behalf of Vantage.

Associate action

An Associate action uses the Monitor service to continually (and at regular periods) poll 
a target location (a directory, for example) on a device or file system (FTP, network 
folder, etc.) to discover new files, based on some permutation of the name of the file 
being processed.
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Associate actions can be executed on any action state.

Generally, the Associate action uses the file name of an existing media file or 
attachment as the basis for discovering new files. For example, if media file 
Vantage.mpg is currently in the workflow, then the Associate action may look for 
Vantage.scc. This behavior can be configured in the Associate action's inspector.

Associate actions begin executing when a job is submitted, and execute until a new file 
is discovered—subsequent actions do not execute until the file is found. When the new 
file is discovered, the Associate action makes the file available to the other actions in 
the workflow.

Configuration is accomplished in the inspector, and is based on the target device/file 
system being monitored and other requirements.

attachment

An attachment is a non-media file that is associated with media during execution of a 
workflow. For example, an attachment may be an XML file that contains metadata, an 
SCC caption file, an STL or PAC subtitle file. Attachments may also be a PDF file, Excel 
spreadsheet, or Word document, for example. Attachments are identified and 
processed using nicknames for simplicity. Processing is optional—attachments may be 
simply passed through a workflow for storage with the processed media and registered 
in a Vantage catalog.

attachment nickname

See nickname.

binder

A binder is a collection of media files, attachment files, and metadata labels. A binder 
allows a workflow to keep track of all working files while the workflow executes.

Files within binders are referenced by nickname—that is, a binder is not a physical 
location, rather a collection of references. The underlying files may be moved around 
without changing the nickname of the file. This allows a binder to be submitted to, or 
passed between, workflows without requiring that the files be in specific locations.

Binders are referenced by jobs, and by the catalog. If a binder is not in the catalog, and 
not associated with a job, then the binder will be deleted. When a binder is deleted, any 
temporary files (such as media files in Vantage Stores) will also be deleted.

catalog

See Vantage catalog.

Catalog service

The Catalog service is the Vantage component (operating as a Windows service) that 
executes actions utilizing the Vantage catalog.

See Register action.



Glossary196
common actions

Common actions are actions that are implemented in—and can be executed by every 
Vantage service; they are not implemented in a single service.

See Receive action, Forward action, Decide action, Compute action, Construct action, 
Synchronize action

Communicate service

The Communicate service is the Vantage component (operating as a Windows service) 
that executes the actions relating to electronic messaging.

See Message action, Notify action.

Compare action

A Compare action uses the Analysis service to compare media files based on certain 
metrics (for example, PSNR). These metrics can generally be published as variables or as 
a label.

Compute action

A Compute action, which is implemented in every service, performs various arithmetic 
and string manipulation functions, permitting you to create and modify values in 
variables, for use in downstream actions.

console

The term console is an informal name for the Vantage Management Console. 

See Vantage Management Console.

Construct action

A Construct action, which is implemented in every service, enables you to construct 
complex strings, paths, and math expressions from literals, variables, and tokens, for 
use in downstream actions.

Copy action

A Copy action is executed by the Transport service, and is used to replicate a file from a 
source target (file system/device and directory) to a destination target (file system/
device and directory). It typically performs this task by copying the file to the 
destination.

Copy actions can be executed on any action state.

database

The term database is the common term used to refer to the Vantage domain database, 
where all specifications for the domain are stored, along with workflows and job 
history.

Decide action

A Decide action, which is implemented in every service, is an action which allows you to 
explicitly set the action state based upon analysis of variable values at runtime. It is 
most commonly used to determine whether or not subsequent actions (or actions in a 
given branch) in a workflow should execute.
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When the Decide action is used, the state set by the analysis is passed to the next 
action; as a result, for decision branches more than one Decide action will usually be 
used. For example, if one branch is for HD media, it will start with a Decide action that 
will set the state to Success for HD content, or set it to Ignore otherwise; if another 
branch is for all other media, it will start with a Decide action that performs the 
opposite behavior.

See variable, action state.

Delete action

A Delete action is executed by the Transport service, and is used to permanently remove 
a file from a source target (file system/device and directory). Delete actions can be 
executed on any action state.

Deploy action

A Deploy action is executed by the Transport service, and is used to save the specified 
files to a destination outside the Vantage domain. Unlike Delete, Move, or Copy actions, 
Deploy actions allow multiple files to be operated on simultaneously, and do not 
maintain a reference to those files in the binder after it completes.

domain 

See Vantage domain.

Flip action

Flip actions are executed by the Transcode service, and implement the specified codec, 
which is used to transcode decoded digital baseband media into another media 
encoding format. Transcoding is performed by the Telestream Media Transcode and 
Analysis engine on behalf of Vantage.

Enterprise Edition

Vantage Enterprise is a special edition of Vantage, which adds system management 
features which enable a high level of visibility and a deep level of control for large-scale 
or mission-critical workflows. Vantage Enterprise is offered in two licenses: Enterprise 
Control, and Master Control.

Examine action

An Examine action uses the Analysis service to evaluate the video and audio of a media 
file to measure certain characteristics, such as audio loudness, or to detect 
characteristics, such as the presence and size of curtains. You can configure it to publish 
metadata or variables containing the results of analysis.

Exist action

An Exist action uses the Catalog service, and allows you to determine if a binder of a 
given name (or name fragment) is present in a specified catalog.

failover database

The term failover database is the term used to refer to the optional mirrored database, 
which the Vantage domain will automatically be transitioned to in the event of a failure 
of the primary database.
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Forward action

A Forward action, which is implemented in every service, forwards a binder and all 
current variables to another workflow, starting a new job with the target workflow. A 
Forward action may be added to the end of a workflow, and requires that the target 
workflow has a Receive action as its first action.

Typically, workflows are created with a Receive action when they are intended for 
execution by another workflow that immediately precedes this one. This ability to chain 
workflows enables you to create comprehensive, intelligent run-time switching 
workflows consisting of smaller workflows used as building blocks.

See Receive action.

Gather action

A Gather action is implemented by the Staging service, and collects one or more files 
from a specified server and directory (and optionally, its subfolders), and bring them 
into the workflow as attachments. Use of a file matching pattern allows you to select 
only certain types of files.

hot folder

A hot folder is a slang term for a directory on a server that has been identified as a 
directory for storing media to be processed by a workflow in Vantage. When the 
workflow monitor identifies new media in this folder, it is submitted for processing.

inspector

An inspector is a series of one or more panels in Vantage Workflow Designer that 
facilitate the setup and configuration of a given action. Inspectors are unique to each 
action—for example, configuring a Watch action is very different than configuring a 
Flip action.

Identify action

An Identify action uses the Analysis service to determine certain properties of a media 
file, such as codec type, video bitrate, or file size. This information can then be 
published as a metadata label, or as variables.

job

A job is an execution of a Vantage workflow. Jobs have a state (separate from action 
states), and jobs are comprised of actions that are executing. Jobs, like actions, may be 
in-process or they may be complete. 

As a job executes, each action may be performed by any service (on any computer) in 
the Vantage domain that is capable of performing it. The capability of a service to 
perform a specific job depends on its current operating state, its workload, and its 
suitability, defined by a qualification rule.

Jobs for a given workflow can be viewed in the Workflow Designer by selecting the 
workflow in the Workflow Designer panel and displaying the Job Status panel. 
Alternatively, all in-process and failed jobs within a Vantage Domain may be viewed in 
the Status section of the Management Console.
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Job Profile action

Use the Job Profile action (which is executed by the Agility service) to submit jobs to 
Agility for processing; definition of the job is provided directly in Vantage by 
configuring the action.

Job XML action

Use the Job XML action (which is executed by the Agility service) to submit jobs to 
Agility for processing; definition of the job is provided in an XML file.

job routing

See qualification rule.

job state

A job state is the current condition of a job. Keyword values are Start | Pause | Success | 
Fail | In Process.

Job Status Web App

The Job Status Web App enables you to view real-time information about jobs in the 
domain from anywhere on your network with a Web browser. The Job Status Web App 
is installed on the IIS server on your Vantage domain database server. This Web app is 
available in all Vantage Enterprise licenses.

label

A label or metadata label defines a set of metadata by use of name/value pairs 
associated with content. For example, a spot label may contain Agency, Author, ISCI, 
and other metadata values; this set of metadata is collectively called a Spot metadata 
label. Metadata labels are stored in binders with the associated media and attachment 
files.

Vantage supplies a set of default metadata labels for use in workflows. In addition, you 
can create and modify labels for your use using the Management Console (Workflow 
Design Items > Metadata Labels).

license

A license is stored in the Vantage database. Generally, licenses are imported as XML files 
into the database through the Management Console.

MediaMate action

A MediaMate action is used to provide screen subtitling, by utilizing various subtitling 
systems from Screen.

media nickname

See nickname.

Message action

A Message action is implemented in the Communicate service, and is an action which 
enables you to generate and transmit an electronic Message—an email, for example. 
You must configure Vantage to use an SMTP server (Management Console: Vantage 
Domain > Settings & Options > Email) before email can be utilized.
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Metadata service

The Metadata service is the Vantage component (operating as a Windows service) that 
executes the actions relating to the transformation of metadata between labels, 
variables, and XML files.

See also Populate action, Transform action.

Monitor service

The Monitor service is the Vantage component (operating as a Windows service) that 
executes the actions relating to the discovery of files and starting jobs.

See also Watch action, Associate action.

Move action

A Move action is executed by the Transport service, and is used to move a file from a 
source target (file system/device and directory) to a destination target (file system/
device and directory). It typically performs this task by copying the file to the 
destination, then deleting the source.

Move actions can be executed on any action state.

nickname

Nicknames are user-defined strings that are used to reference files within a Vantage 
workflow. Nicknames allow users a convenient way to design workflows independent 
of the actual file locations or underlying file names. As a workflow executes, it maintains 
a collection of underlying files called a binder; nicknames allow the workflow to access 
files within the binder.

Nicknames may refer to either media files, or attachment files. Certain actions will only 
allow the use of certain nickname types; for example, a Flip action only allows media 
file nicknames to be used as the inputs and outputs. However, other actions (such as 
Move and Copy actions) operate on any type of file, and allow the use of any nickname.

The use of a nickname does not affect the actual name of the underlying file, nor do 
nicknames have any special meaning. For example, providing a media file the 
nickname Flash does not necessarily mean that the media file is in fact a Flash file.

Nicknames can be managed in the Management Console under Workflow Design 
Items > Media Nicknames. Nicknames can also be entered manually, directly in the 
Workflow Designer.

The word Original is a reserved nickname specific to media files.

Notify action

A Notify action is implemented in the Communicate service, and is an action which 
saves job information to a file, or which interfaces with an external system. You can 
configure a Notify action to produce an XML file, and you can also use it to invoke a 
Web service.

origin action

An origin action is a specific type of action, which must be used to start a workflow. A 
workflow without an origin action as its first action is not properly designed, and can’t 
be activated. The origin actions are Watch and Receive.
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Populate action

A Populate action uses the Metadata service to transform data between variables and 
metadata labels, and publish variable values from the label for use in downstream 
actions.

Process MMF action

A Process MMF action (which is executed by the Agility service) processes an 
attachment as an MMF file and generate variables from it.

qualification rule

A qualification rule influences or controls the routing and execution of actions among 
Vantage services of the same type in a distributed Vantage domain. Qualification rules 
can be used to ensure that jobs are routed to services that are best suited for the task. 
Vantage uses values contained in variables to determine the suitability of a given 
service to execute the action.

Qualification rules are exclusively based on variables; they are not based on any actual 
machine analysis. As a result, it is up to the system administrator to correctly set up 
variables and qualification rules, and apply variables to the appropriate actions to 
ensure that jobs are routed correctly.

Qualification rules are created and managed in the Vantage Management Console: 
Vantage Domain > Services.

See also run on rules.

Receive action

A Receive action is an origin action which is implemented in every service, to provide a 
starting point for new jobs in Vantage workflows that are not started by a Watch or 
other starting action. 

Typically, workflows are created with a Receive action when they are intended for 
execution by another workflow that immediately precedes this one. This ability to chain 
workflows enables you to create comprehensive, intelligent run-time switching 
workflows consisting of smaller workflows used as building blocks.

Only workflows that end with a Forward action are used to start Receive-based 
workflows. When you chain workflows, you can pass binders and variables between 
them.

See Forward action.

Register action

A Register action uses the Catalog service to place a binder into a Vantage catalog. 
Register actions can be executed on any action state.

See also Vantage catalog.

resource unit

A resource unit is an integer value, implemented in the Vantage Management Console 
on each action type to specify a relative computer resource consumption value in 
relation to all other action types. This value enables Vantage to maximize resources and 
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optimize transactions, so that you can tune your Vantage system for the highest 
possible throughput on your particular hardware.

run on rules

Run on rules are rules that you specify on a given action, to qualify which services have 
the characteristics that enable them to execute this action. Rules are set up by 
specifying variables which have been bound to a given Vantage service and values set. 
Now, the action can test each rule by comparing its run time value to the value in the 
service’s copy and determine if there is a match before attempting to execute it. 

See also qualification rule.

Staging service

The Staging service is the Vantage component (operating as a Windows service) which 
executes Archive actions and Gather actions.

service

See Vantage service.

single-server domain 

See All-in-one domain.

Synchronize action

A Synchronize action, which is implemented in every service, is a connector action, for 
the sole purpose of uncluttering workflow connectors. In workflows where there is a 
many-to-many relationship (for example, 6 Flip actions connect to 6 Deploy actions, 
which connect to 6 deletes), instead of drawing all six connects from each action, you 
can simply connect them to a common Synchronize action. There is no inspector for 
the Synchronize action, because no configuration is required.

Team Management

Team Management is a licensed feature in a distributed Vantage domain, which adds 
user access control. By creating specific Vantage users (and optional passwords) in the 
Vantage domain console, Vantage administrators can control access to workflows in 
Workflow Designer and Workflow Portal. You can also control access to the Vantage 
Console, thus limiting who can configure and control the domain itself.

transcode 

Transcode means the process of decoding media in one format (MPEG2, for example) 
down to digital baseband and then encoding it in another media format (MPEG4, for 
example). 

Transcode service

The Transcode service is the Vantage component (operating as a Windows service) that 
executes Flip actions—transforming media from one format to another. 

See Flip action.

Transform action

A Transform action uses the Metadata service to transform metadata between XML files 
(attachments) and labels. XSL style sheets are used to perform these transformations; 



Glossary 203
style sheets can be managed in the Vantage Management Console: Vantage Domain > 
Catalogs.

Transport service

The Transport service is the Vantage component (operating as a Windows service) that 
executes the actions relating to file operations.

See also Move action, Delete action, Copy action, and Deploy action.

Vantage catalog

The Vantage catalog (or simply catalog) allows the management of binders that you 
want to exist past the life of an individual job. Folders can be created in the catalog with 
individual expiration rules.

The catalog and its folders are not a physical location; rather they are a way of 
organizing binders and controlling when the binders—and the underlying files—are 
deleted.

Vantage domain database

A Vantage domain database is a Microsoft SQL Server database which contains all 
workflows, actions, jobs, binders, licenses, and configuration information for a Vantage 
domain.

Vantage domain

A Vantage domain is a collection of computers, Vantage workflows, actions, Vantage 
services, jobs, binders, and configuration settings, all known to and interacting with 
each other, stored in a Vantage database. This collection constitutes a Vantage domain. 
Vantage domains may exist on a single computer or they may be distributed across 
many computers for durability and scalability.

The name of a vantage domain is generally the same as the name of the server that 
hosts the Vantage database.

Multiple Vantage domains may exist on a network, but they are independent entities 
that do not communicate with each other. They are not bound together and do not 
share resources or work. The purpose of storing an entire domain in a database is to 
provide an easy way to create and manage the domain and to provide access to all the 
details about each resource in the domain to any other resource that needs it.

Vantage folder address

A Vantage folder address is a named directory on a supported file system that is stored 
in the Vantage database, which is used in Move and Copy actions. Unlike Vantage 
stores, actions that use Vantage folder addresses write files to external file systems so 
these files are not deleted when a binder is deleted. 

You can create and manage Vantage folder addresses in the Vantage Folder Address 
Book dialog, in Copy and Move actions in Workflow Designer, and in the Vantage 
Management Console. Once created, you can specify the destination directory in a 
Copy or Move action simply by supplying the name of the folder address. Changes to a 
Vantage folder address—such as updating an IP address or a password—immediately 
affect all workflows.
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Vantage Management Console

The Vantage Management Console (usually referred to informally as the console, for 
short) is a Windows MMC program that enables Vantage system administrators to 
effectively configure Vantage domains, and scale domains across multiple servers to 
meet their operating requirements and perform effectively in their environment.

Vantage service

The term Vantage service refers to the collection of software components (operating as 
Windows services) in a Vantage domain that implement and execute the actions in a 
workflow as it executes.

Vantage store

A Vantage store is a directory on a Windows file system that used for storing temporary 
files. Stores are managed by the Vantage domain for the purpose of centralizing large 
directories for reading and writing files. Unlike a Vantage folder, files placed in a 
Vantage store are deleted when the binder is deleted. Vantage stores are generally 
used to hold temporary files for the duration that a job is executing.

Vantage stores are managed in the Vantage Management Console: Vantage Domain > 
Storage. Services that create temporary files, such as the Transcode service, can be 
configured to use specific stores.

Vantage Workflow Designer

Vantage Workflow Designer is a client program that enables you to create and edit 
workflows, activate and deactivate them, and monitor their status and review jobs in 
process and jobs that have completed.

Vantage Workflow Portal

Vantage Workflow Portal is a client program that features a customizable set of 
functionality to support various operator-related tasks: Selecting media and submitting 
jobs, updating variables and metadata and forwarding jobs, creating EDL-base jobs, 
etc.

Customization is implemented in the Vantage Management Console, when Vantage 
administrators construct the user interface and functionality they want for a given task, 
then save it. When operators launch Portal, they select the configuration appropriate to 
the task at hand, and Portal dynamically implements the appropriate user interface 
from the configuration file.

variable

A variable identifies temporary job metadata. Variables have a name (such as Number of 
Audio Channels), a type (such as Integer Number) and a default value. Variables values 
can be set inside a job in a variety of ways: Through analysis, through metadata 
population, in the Watch and Associate actions, as a property of an action, or by a 
service as it executes an action.

Variables are used by Vantage services and actions to control their behavior and 
workflow logic. The majority of parameters in Vantage can be bound (or attached) to 
variables, allowing the workflow to dynamically update on a job-by-job basis. 
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For example, a variable may be assigned a value by an analysis action to determine how 
many lines of black are at the top of a video frame; a crop filter later in the workflow can 
bind to that variable, ensuring that every crop in every job is appropriate to the 
workflow requirements.

Variables in services may be also be used for job routing. For example, an action with a 
FibreRequired=TRUE variable must pass this condition to a service which evaluates the 
condition to determine if it can successfully perform the action.

Variables can be created in the Management Console (Vantage Domain > Workflow 
Design Items > Variables) or in Workflow Designer, and assigned for use in workflows 
and services.

Watch action

A Watch action is an origin action; it uses the Monitor service to continually (and at 
regular periods) poll a target location (a directory, for example) on a device or file 
system (FTP, Windows network folder, etc.) to discover new files.

When a new file is discovered, the Watch action submits a job for the workflow which it 
is part of, for processing the file—typically, a media file.

Web Dashboard

The Web Dashboard enables you to important domain information from anywhere on 
your network with a Web browser. The Web Dashboard is installed on the IIS server on 
your Vantage domain database server. The Web Dashboard is available in Vantage 
Enterprise Master Control.

workflow

A workflow in Vantage is a set of actions designed to perform an automated process. 
Vantage workflows are created using the Vantage Workflow Designer by adding and 
configuring actions and connecting them together. Workflows are stored in the 
Vantage database, and executed by Vantage services.

Workflow Portal

Short for Vantage Workflow Portal. Also sometimes called just Portal, for short.

Workflow Designer

Short for Vantage Workflow Designer. Also sometimes called just Designer, for short.
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Index
Numerics
3rd party actions 125

A
action state, colors to indicate 141
action states 121
action status, viewing 154
action templates, using 105
actions

adding to a workflow 105
binding settings to a variable 114
changing description of 111
configuring, generally 110
connecting together 106
deleting 106
invalid connections 106
re-ordering 109
setting conditional execution 111
specifying resource cost for 119
states of 121
templates for, creating 109
templates for, using 105
uncrossing connection lines 109
using variables with 112

actions, 3rd party 125
Agility actions 125

starting and stopping 142
analysis actions 126
archive action 131
assets, forwarding to a workflow 173
assets, previewing 171
assets, searching and selecting 176
assets, stitching 175

Associate action 131
auto-arrange, disabling temporarily 98

B
batch operations, performing on workflows 104
binder file nickname view 96
binders

viewing 151
binding settings to variables 114
bottleneck analysis, performing 159
browsers, supported by Job Status 75
browsing and submitting assets from a Vantage

catalog 170
Browsing Catalog Assets mode 166
Browsing Windows Assets mode 167
browsing Windows folders/shares 179

C
catalog actions 127
catalog assets, searching and selecting 171
catalog, browsing 170
catalog, selecting 170, 175
category

creating new 100
deleting 101
renaming 101

changing in Workflow Designer 68
color of jobs 141
common actions 127
communicate actions 129
Compare action 126
compute action 128
conditional execution of actions, setting 111



Index208
configuration, see Application Configuration in
Management Console guide 164

connecting manually to a domain 21, 68, 69, 78
connecting to a domain 68, 77
connection lines, uncrossing 109
Copy action 132
copyright notice 3
CSV file job reports 146

D
decide action 128
default

password 81
user name 81

delete action 133
deploy action 133
domain 206

connecting to 68, 77
connection settings 69, 79

Domain Job Status panel, generally 140
domain name, computer name or IP address

used 69, 79
domain, manually connecting 21, 68, 69, 78
domain, selecting, in Workflow Designer 68

E
editing metadata, reviewing metadata 173
EDL, adding assets to 176
EDL, modifying 176
Encode action 132
errors 182
examine action 126
execution analysis, performing 160
exporting job reports 146
exporting workflows 103

F
Flip actions

pause for priority 152
Flip actions, pausing and resuming 152
Folder Address Book 123
Forward action 128

G
gather action 132
grid lines, showing/hiding 97

I
Identify action 126
importing workflows 103
inspectors, using, generally 110

J
job reports

creating 146
exporting 146
generally 146

job state, colors to indicate 141
Job Status panel, generally 140
Job Status, logging in 77
Job Status, starting 76
Job Status, URL for 77
Job Status, version info 84
Job Status, views, using Management Console

for 186
Job Status, Web browsers used for 75
job submitting, manually 143

L
license, changing / updating in Workflow

Designer 75
logging in to a Vantage Domain in Workflow

Designer 68
logging in to Job Status 77

M
Management Console, using to configure Job Sta-

tus views 186
manual job submission 143
manually connecting to a domain 21, 68, 69, 78
mark in/mark out points, setting 176
media, previewing 171
MediaMate actions 130
message action 129
metadata actions 130, 132
metadata, editing in submit jobs window 178
metadata, reviewing/editing 173
MMC 206
modes in Workflow Portal 166
monitor actions 130
monitor status panel, generally 136
Move action 132
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MPEG disclaimers 4
Multiscreen Flip action 132

N
nickname view 96
notices, legal, generally 3
Notify action 130

P
password

default 81
pause for priority, in Flip actions 152
pausing Flip actions 152
Populate action 130
previewing assets 171
public and private views 185

R
Receive action 129
Register action 127
register action 127
resource costs, specifying 119
resuming Flip actions 152

S
settings, binding to variable 114
specifying resource costs 119
staging actions 131
starting and stopping Workflow Designer 66
starting Job Status 76
stitching assets 175
Stitching Assets mode 168
submit jobs window, editing metadata in 178
support, obtaining 18
synchronize action 129

T
tech support, obtaining 18
Telestream

contacting 7, 18
information about 18
International 18
mailing address 18
sales and marketing 18
technical support 18
Web site 18

Telestream, contacting 18
trademark notices 3
transcode actions 132
transform action 130
transport actions 132
troubleshooting 182

U
uncrossing connection lines 109
URL for Job Status Web app 77
user access 68
User access, generally 21
user name, default 81

V
Vantage

Web site for 18
Vantage account 21
Vantage domain

changing 68
connection settings 69, 79

Vantage domain, manually connecting 21, 68,
69, 78

Vantage domain, selecting, in Workflow
Designer 68

Vantage Folder Address Book 123
Vantage license, changing / updating in Workflow

Designer 75
Vantage user 68
Vantage user password, changing in Web apps 84
Vantage user password, changing in Workflow

Designer 74
Vantage Windows programs, starting and

stopping 66
variables

adding to a workflow 112
binding to settings 114
generally 112
using for decision making 121

variables view 96
version information 84
views, public and private 185

W
warranty 5
Warranty and Disclaimers 5
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Watch action 131
Web browsers, supported by Job Status 75
Web site URL 18
Windows folders/shares, browsing 179
workflow

activating 99
adding actions 105
batch operations 104
centering 97
centering in workspace 97
creating new 102
deactivating 99
deleting 103
design techniques, generally 93
details panel, using 95
duplicating 103
editing 99
exporting 103
importing 103
moving in workspace 97
moving to another category 103
printing 104
releasing 99
renaming 102
zooming in and out 97, 98

Workflow Analytics panel, generally 156
workflow analytics, generally 156
workflow analytics, performing bottleneck analy-

sis with 159
workflow analytics, performing execution analy-

sis with 160
workflow category

see category 100
Workflow Designer

changing / updating license via 75
logging in to a domain 68
starting and stopping 66
submitting jobs manually 143

Workflow Portal desktop shortcut 66, 163
Workflow Portal, described, generally 162
Workflow Portal, launching first time 66, 67
Workflow Portal, modes of 166
workflow status buttons 99
workflow, forwarding to 173

Z
zooming a workflow 97
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